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Chapter 1

About this Guide

About this Guide

This user guide describes the features supported by Aruba Central On-Premises and provides detailed
instructions to set up and configure devices such as Campus APs, Remote APs, Instants, Switches, and
Controllers. In Aruba Central On-Premises, the only access points that you can configure are Instant APs.
However, monitoring is supported for Campus APs, Remote APs, and Instant APs.

Intended Audience
This guide is intended for system administrators who configure and monitor their network using Aruba
Central On-Premises.

Related Documents
In addition to this document, the Aruba Central On-Premises product documentation includes the
following documents:

n Aruba Central On-Premises Installation and Setup Guide
n Aruba Central On-Premises Migration Guide
n Aruba Central On-Premises API Reference Guide
n Aruba Central On-Premises Release Notes

Conventions
The following conventions are used throughout this guide to emphasize important concepts:

Type Style Description

Italics This style is used to emphasize important terms and to mark the titles of books.

System

items

This fixed-width font depicts the following:
n Sample screen output
n System prompts

Bold n Keys that are pressed
n Text typed into a GUI element
n GUI elements that are clicked or selected

Table 1: Typographical Conventions

The following informational icons are used throughout this guide:

Indicates helpful suggestions, pertinent information, and important things to remember.
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Indicates a risk of damage to your hardware or loss of data.

Indicates a risk of personal injury or death.

Contacting Support

Main Site arubanetworks.com

Support Site asp.arubanetworks.com

Airheads Social Forums and Knowledge
Base

community.arubanetworks.com

North American Telephone 1-800-943-4526 (Toll Free)
1-408-754-1200

International Telephone arubanetworks.com/support-services/contact-support/

Software Licensing Site lms.arubanetworks.com

End-of-life Information arubanetworks.com/support-services/end-of-life/

Security Incident Response Team Site: arubanetworks.com/support-services/security-bulletins/
Email: aruba-sirt@hpe.com

Table 2: Contact Information

http://www.arubanetworks.com/
https://asp.arubanetworks.com/
http://community.arubanetworks.com/
http://www.arubanetworks.com/support-services/contact-support/
https://lms.arubanetworks.com/
http://www.arubanetworks.com/support-services/end-of-life/
http://www.arubanetworks.com/support-services/security-bulletins/
mailto:aruba-sirt@hpe.com


Chapter 2

About Aruba Central On-Premises

About Aruba Central On-Premises

Aruba Central On-Premises is a variant of Aruba Central, a SaaS platform that offers you a single
intelligent console to monitor, analyze, and configure WLAN and wired networks. Aruba Central On-
Premises makes it easy and efficient to manage your networks by combining industry-leading
functionality with an intuitive user interface, and enables network administrators and help desk staff to
support and control the network for your premises. The features are designed to manage, maintain, and
analyze your network.

Aruba Central On-Premises is for organizations that do not want the data on cloud because of their
business operations and policies regarding confidentiality, security, downtime, loss of data, and so on.
This software solution also gives the same agility and efficiency of cloud services as Aruba Central, and
at the same time, it adheres to stringent regulatory and compliance requirements.

Aruba Central On-Premises is now integrated as one of the apps within the on-premises version of HPE
GreenLake that resides on the user’s premises. The on-premises version of the platform provides
common services such as user management, device inventory, subscription management, etc.
Customers fully own and control the appliance, and access to the appliance. No data is sent off-
premises. For subscription management Aruba Central On-Premises 2.5.5.0 will continue to
communicate with HPE’s global licensing (GLIS) server.

Key Features
Aruba Central On-Premises offers the following key features and benefits:

n Zero Touch Provisioning—Automatic provisioning to simplify device onboarding and deployment.

n GreenLake Account Home—provides services such as user management, device inventory, and
subscription management.

n Network-wide health monitoring—Comprehensive view of the network, device status, health, and
application usage at Global, Site, Label, and client levels.

n Application visibility—Detailed information about the data usage of the clients connected to
devices in the network and analysis of the client traffic flow.

n Reporting wizard—Generate scheduled or on-demand reports for the Clients, Infrastructure,
Security Compliance, and Applications categories. You can also download reports in PDF and CSV
formats.

n Network security—Strict policy and compliance control for the overall security of the network.
n API integration—APIs and webhooks support for extensibility with third-party software.
n AI Insights—Identify and resolve Wi-Fi connectivity issues, along with logical and actionable insights

about the root cause.
n Built-in alerts and troubleshooting tools—Live events and packet capture logs for troubleshooting

or performing diagnostics tests on devices and networks.
n Threat detection and prevention—Block malicious links or payload and quickly respond to rogue

APs or suspicious traffic.
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n Cluster configuration—Aruba Central On-Premises supports up to a 7-node cluster. Cluster
configuration is a highly recommended architecture for its high performance, easy management,
scalability, and flexibility. Aruba Central On-Premises can be installed as a single node also.

The features such as adding devices, managing licenses, and assigning users and roles are now performed
through HPE GreenLake account home.

Supported Web Browsers

To view the Aruba Central On-Premises UI, ensure that JavaScript is enabled on the web browser.

Browser Versions Operating System

Google Chrome 108.0.5359.71 or
later

Windows 10 or later and
macOS

Mozilla Firefox 107.0.1 or later Windows 10 or later and
macOS

Safari 15.4 (17613.1.17.1.13) or
later

macOS

Microsoft Edge (Microsoft Edge
92.0.902.62 and Microsoft
EdgeHTML 18.19041) or later

Windows 10 or later and
macOS

Table 3: Browser Compatibility Matrix

What you see depends on who you are and what you have
The content of any screen you access through HPE GreenLake account home relies on a combination of
the following:

n Who you are—refers to the effective permissions you have, which depend on the roles to which you
are assigned to.

n What you have—refers to the services your organization has purchased or services that you have
been offered to use.



Aruba Central On-Premises 2.5.7 | User Guide 11

Terminology Change
As part of advancing HPE's commitment to racial justice, we are taking a much-needed step in
overhauling HPE engineering terminology to reflect our belief system of diversity and inclusion. Some
legacy products and publications may continue to include terminology that seemingly evokes bias
against specific groups of people. Such content is not representative of our HPE culture and moving
forward, Aruba will replace racially insensitive terms and instead use the following new language:

Usage Old Language New Language

Campus Access Points + Controllers Master-Slave Conductor-Member

Instant Access Points Master-Slave Conductor-Member

Switch Stack Master-Slave Conductor-Member

Wireless LAN Controller Mobility Master Mobility Conductor

Firewall Configuration Blacklist, Whitelist Denylist, Allowlist

Types of Hackers Black Hat, White Hat Unethical, Ethical

Supported Devices
This section provides the following information:

n Supported APs
n Supported AOS-S Platforms
n Supported AOS-CX Platforms
n Supported Aruba Mobility Controllers

Supported APs
Aruba Central On-Premises supports the following types of Aruba access points (APs).

n Instant APs—The Instant Access Point (IAP) based WLAN solution consists of a cluster of access points
in a Layer 2 subnet. The IAPs serve a dual role as both Virtual Controller (VC) and member APs. The
IAP WLAN solution does not require dedicated controller hardware and can be deployed through a
simplified setup process appropriate for smaller organizations, or for multiple geographically
dispersed locations without an on-site administrator. IAPs run on the Aruba Instant. Aruba Central
On-Premises supports both monitoring and management of IAPs. With Aruba Central On-Premises,
network administrators can configure, monitor, and troubleshoot IAP WLANs, upload new software
images, monitor devices, generate reports, and perform other vital management tasks from remote
locations.

n Campus APs—The Campus Access Point (CAP)s are used in private networks where APs connect over
private links (LAN, WLAN, WAN, or MPLS) and terminate directly on controllers. Campus APs are
deployed as part of the indoor campus solution in enterprise office buildings, warehouses, hospitals,
universities, and so on. Aruba Central On-Premises supports only onboarding and monitoring the
Campus APs.



About Aruba Central On-Premises | 12

n Remote APs—The Remote Access Point (RAP)s allow AP users at remote locations to connect to an
Aruba controller over the Internet. Since the Internet is involved, data traffic between the controller
and the remote AP is VPN encapsulated. That is the traffic between the controller and AP is
encrypted. Remote AP operations are supported on all of Aruba APs.

Supported APs
Aruba Central On-Premises supports the following AP platforms and Aruba Instant software versions:

AP
Platform Installation Mode Minimum Supported Aruba

Instant Software Version
Latest Validated Aruba
Instant Software Version

AP-655 Indoor 8.10.0.1 8.11.1.0

AP-635 Indoor 8.9.0.0 8.11.0.0

AP-615 Indoor 8.11.0.0 8.11.0.0

AP-587EX Outdoor 8.10.0.0 8.11.0.0

AP-587 Outdoor 8.10.0.0 8.11.0.0

AP-585EX Outdoor 8.10.0.0 8.11.0.0

AP-585 Outdoor 8.10.0.0 8.11.0.0

AP-584 Outdoor 8.10.0.0 8.11.0.0

AP-577EX Outdoor 8.7.0.0 8.11.0.0

AP-577 Outdoor 8.7.0.0 8.11.0.0

AP-575EX Outdoor 8.7.0.0 8.11.0.0

AP-575 Outdoor 8.7.0.0 8.11.0.0

AP-574 Outdoor 8.7.0.0 8.11.0.0

AP-567EX Outdoor 8.7.1.0 8.11.0.0

AP-567 Outdoor 8.7.1.0 8.11.0.0

AP-565EX Outdoor 8.7.1.0 8.11.0.0

AP-565 Outdoor 8.7.1.0 8.11.0.0

AP-555 Indoor 8.6.0.0 8.11.0.0

AP-535 Indoor 8.6.0.0 8.11.0.0

AP-534 Indoor 8.6.0.0 8.11.0.0

AP-518 Indoor 8.7.0.0 8.11.0.0

AP-515 Indoor 8.6.0.0 8.11.0.0

Table 4: Supported AP Platforms
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AP
Platform Installation Mode Minimum Supported Aruba

Instant Software Version
Latest Validated Aruba
Instant Software Version

AP-514 Indoor 8.6.0.0 8.11.0.0

AP-505H Indoor 8.7.0.0 8.11.0.0

AP-505 Indoor 8.6.0.0 8.11.0.0

AP-504 Indoor 8.6.0.0 8.11.0.0

AP-503H Indoor 8.7.1.0 8.11.0.0

AP-503 Indoor 8.11.1.0 8.11.1.0

AP-387 Outdoor 8.6.0.0 8.10.0.0

AP-377EX Outdoor 8.6.0.0 8.11.0.0

AP-377 Outdoor 8.6.0.0 8.11.0.0

AP-375ATEX Outdoor 8.10.0.0 8.11.0.0

AP-375EX Outdoor 8.6.0.0 8.11.0.0

AP-375 Outdoor 8.6.0.0 8.11.0.0

AP-374 Outdoor 8.6.0.0 8.11.0.0

AP-367 Outdoor 6.5.4.8 8.11.0.0

AP-365 Outdoor 6.5.4.8 8.11.0.0

AP-345 Indoor 8.6.0.0 8.10.0.0

AP-344 Indoor 8.6.0.0 8.10.0.0

AP-318 Indoor 8.6.0.0 8.11.0.0

AP-303P Indoor 8.6.0.0 8.11.0.0

AP-303H Indoor 6.5.4.8 8.11.0.0

AP-303 Indoor 8.6.0.0 8.11.0.0

AP-203RP Indoor 6.5.4.8 8.10.0.0

AP-203R Indoor 6.5.4.8 8.10.0.0

AP-203H Indoor 6.5.4.8 8.10.0.0

IAP-335 Indoor 6.5.4.8 8.10.0.0

IAP-334 Indoor 6.5.4.8 8.10.0.0

IAP-325 Indoor 6.5.4.8 8.10.0.0
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AP
Platform Installation Mode Minimum Supported Aruba

Instant Software Version
Latest Validated Aruba
Instant Software Version

IAP-324 Indoor 6.5.4.8 8.10.0.0

IAP-315 Indoor 6.5.4.8 8.11.0.0

IAP-314 Indoor 6.5.4.8 8.11.0.0

IAP-305 Indoor 6.5.4.8 8.11.0.0

IAP-304 Indoor 6.5.4.8 8.11.0.0

IAP-277 Outdoor 6.5.4.3 8.6.0.0

IAP-275 Outdoor 6.5.4.3 8.6.0.0

IAP-274 Outdoor 6.5.4.3 8.6.0.0

IAP-207 Indoor 6.5.4.8 8.10.0.0

IAP-205H Indoor 6.5.4.8 6.5.4.8

IAP-205 Indoor 6.5.4.8 6.5.4.8

IAP-204 Indoor 6.5.4.8 6.5.4.8

RAP-109 Indoor 4.2.4.21 4.2.4.21

RAP-108 Indoor 4.2.4.21 4.2.4.21

RAP-3WN Indoor 4.2.4.21 4.2.4.21

RAP-3WNP Indoor 4.2.4.21 4.2.4.21

n IAP-203H, IAP-203R, IAP-203RP, IAP-207, IAP-324, IAP-325, IAP-334, IAP-335, IAP-344, IAP-345, IAP-387 IAPs
are no longer supported from Aruba Instant 8.11.0.0 onwards.

n IAP-214, IAP-215, IAP-224, IAP-225, IAP-228, IAP-274, IAP-275, and IAP-277 IAPs are no longer supported
from Aruba Instant 8.7.0.0 onwards.

n IAP-103, IAP-204, IAP-205, and IAP-205H IAPs are no longer supported from Aruba Instant 8.3.0.0
onwards.

n By default, AP-318, AP-374, AP-375, and AP-377 IAPs have Eth1 as the uplink port and Eth0 as the
downlink port. Aruba does not recommend you to upgrade these IAPs to Aruba Instant 8.5.0.0 or 8.5.0.1
firmware versions, as the upgrade process changes the uplink port from Eth1 to Eth0 port thereby making
the devices unreachable.



Aruba Central On-Premises 2.5.7 | User Guide 15

Supported Campus APs and Remote APs
Aruba Central On-Premises supports the following Campus AP and Remote AP platforms and ArubaOS
software versions:

AP
Platform

Minimum Supported ArubaOS
Software Versions

Latest Validated ArubaOS Software
Versions

AP-655 8.10.0.0 8.11.0.0

AP-635 8.9.0.0 8.11.0.0

AP-615 8.11.0.0 8.11.0.0

AP-587EX 8.10.0.0 8.11.0.0

AP-587 8.10.0.0 8.11.0.0

AP-585EX 8.10.0.0 8.11.0.0

AP-585 8.10.0.0 8.11.0.0

AP-584 8.10.0.0 8.11.0.0

AP-577EX 8.7.0.0 8.11.0.0

AP-577 8.7.0.0 8.11.0.0

AP-575EX 8.7.0.0 8.11.0.0

AP-575 8.7.0.0 8.11.0.0

AP-574 8.7.0.0 8.11.0.0

AP-567EX 8.8.0.0 8.11.0.0

AP-567 8.8.0.0 8.11.0.0

AP-565EX 8.8.0.0 8.11.0.0

AP-565 8.8.0.0 8.11.0.0

AP-555 8.6.0.0 8.11.0.0

AP-535 8.6.0.0 8.11.0.0

AP-534 8.6.0.0 8.11.0.0

AP-518 8.7.0.0 8.11.0.0

AP-515 8.6.0.0 8.11.0.0

AP-514 8.6.0.0 8.11.0.0

AP-505HR 8.6.0.0 8.11.0.0

AP-505H 8.6.0.0 8.11.0.0
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AP
Platform

Minimum Supported ArubaOS
Software Versions

Latest Validated ArubaOS Software
Versions

AP-505 8.6.0.0 8.11.0.0

AP-504 8.6.0.0 8.11.0.0

AP-503HR 8.8.0.0 8.11.0.0

AP-503H 8.8.0.0 8.11.0.0

AP-503 8.11.1.0 8.11.1.0

AP-387 8.6.0.0 8.10.0.0

AP-377EX 8.6.0.0 8.11.0.0

AP-377 8.6.0.0 8.11.0.0

AP-375EX 8.6.0.0 8.11.0.0

AP-375 8.6.0.0 8.11.0.0

AP-374 8.6.0.0 8.11.0.0

AP-367 8.6.0.0 8.11.0.0

AP-365 8.6.0.0 8.11.0.0

AP-345 8.6.0.0 8.10.0.0

AP-344 8.6.0.0 8.10.0.0

AP-335 8.6.0.0 8.10.0.0

AP-334 8.6.0.0 8.10.0.0

AP-325 8.6.0.0 8.10.0.0

AP-324 8.6.0.0 8.10.0.0

AP-318 8.6.0.0 8.11.0.0

AP-315 8.6.0.0 8.11.0.0

AP-314 8.6.0.0 8.11.0.0

AP-305 8.6.0.0 8.11.0.0

AP-304 8.6.0.0 8.11.0.0

AP-303P 8.6.0.0 8.11.0.0

AP-303H 8.6.0.0 8.11.0.0

AP-303P 8.6.0.0 8.11.0.0
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AP
Platform

Minimum Supported ArubaOS
Software Versions

Latest Validated ArubaOS Software
Versions

AP-277 8.6.0.0 8.10.0.0

AP-275 8.6.0.0 8.10.0.0

AP-274 8.6.0.0 8.10.0.0

AP-207 8.6.0.0 8.10.0.0

AP-205H 8.6.0.0 8.10.0.0

AP-205 8.6.0.0 8.10.0.0

AP-204 8.6.0.0 8.10.0.0

AP-203RP 8.6.0.0 8.10.0.0

AP-203R 8.6.0.0 8.10.0.0

AP-203H 8.6.0.0 8.10.0.0

RAP-109 8.6.0.0 8.6.0.0

RAP-108 8.6.0.0 8.6.0.0

AP-103H 8.3.0.0 8.3.0.0

RAP-3WN 8.6.0.0 8.6.0.0

RAP-3WNP 8.6.0.0 8.6.0.0

n AP-615, AP-635, and AP-655 IAPs are Wi-Fi 6E capable APs that support 6 GHz radio band, in addition to
2.4 GHz and 5 GHz radio bands.

n The tri-radio feature is available only for AP-555. In the 5 GHz tab, the Radio 5 GHz (Secondary) data is
available only if the tri-radio mode is enabled. For more information, see About Tri-Radio Mode section
in the latest Aruba Central On-Premises user guide.

n For more information about Aruba's End-of-life policy and the timelines for hardware and software
products at the end of their lives, see: https://www.arubanetworks.com/support-services/end-of-life/

n Data sheets and technical specifications for the supported AP platforms are available at:
https://www.arubanetworks.com/products/networking/access-points/

https://www.arubanetworks.com/support-services/end-of-life/
https://www.arubanetworks.com/products/networking/access-points/
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Supported AOS-S Platforms

n To manage your AOS-S switches using Aruba Central On-Premises, ensure that the switch software is
upgraded to 16.09.0010 or a later version. However, if you already have switches running lower software
versions in your account, you can continue to manage these devices from Aruba Central On-Premises.

n Changing AOS-S switches firmware from latest version to earlier major versions is not recommended if
the switches are managed in UI groups. For features that are not supported or not managed in Aruba
Central On-Premises on earlier AOS-S versions, changing firmware to earlier major versions might result
in loss of configuration.

The following tables list the switch platforms, corresponding software versions supported in Aruba
Central On-Premises, and switch stacking details.

Switch
Platform

Supported
Software
Version

Recommended
Software
Version

Switch
Stacking
Support

Supported
Stack Type
(Frontplane
(VSF) /
Backplane
(BPS))

Supported
Configuration
Group Type
for Stacking
(UI /
Template)

Aruba
2540
Switch
Series

n YC.16.08.0019
and later

n YC.16.09.0015
and later

n YC.16.10.0012
and later

n YC.16.11.002

n YC.16.08.0026
n YC.16.09.0021
n YC.16.10.0022
n YC.16.11.0006

N/A N/A N/A

Aruba
2920
Switch
Series

n WB.16.08.001
9 and later

n WB.16.09.001
5 and later

n WB.16.10.001
1 and later

n WB.16.11.002

n WB.16.08.002
6

n WB.16.09.002
1

n WB.16.10.002
2

n WB.16.11.000
6

Yes
Switch Software
Dependency:
n WB.16.08.001

9 and later
n WB.16.09.001

5 and later
n WB.16.10.001

1 and later
n WB.16.11.000

2

BPS UI and Template

Aruba
2930F
Switch
Series

n WC.16.08.001
9 and later

n WC.16.09.001
5 and later

n WC.16.10.001
2 and later

n WC.16.11.002

n WC.16.08.002
6

n WC.16.09.002
1

n WC.16.10.002
2

n WC.16.11.000
6

Yes
Switch Software
Dependency:
n WC.16.08.001

9 and later
n WC.16.09.001

5 and later
n WC.16.10.001

VSF UI and Template

Table 5: Supported AOS-S Switch Series, Software Versions, and Switch Stacking
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Switch
Platform

Supported
Software
Version

Recommended
Software
Version

Switch
Stacking
Support

Supported
Stack Type
(Frontplane
(VSF) /
Backplane
(BPS))

Supported
Configuration
Group Type
for Stacking
(UI /
Template)

2 and later
n WC.16.11.000

2

Aruba
2930M
Switch
Series

n WC.16.08.001
9 and later

n WC.16.09.001
5 and later

n WC.16.10.001
2 and later

n WC.16.11.002

n WC.16.08.002
6

n WC.16.09.002
1

n WC.16.10.002
2

n WC.16.11.000
6

Yes
Switch Software
Dependency:
n WC.16.08.001

9 and later
n WC.16.09.001

5 and later
n WC.16.10.001

2 and later
n WC.16.11.000

2

BPS UI and Template

Aruba
3810
Switch
Series

n KB.16.08.0019
and later

n KB.16.09.0015
and later

n KB.16.10.0012
and later

n KB.16.11.002

n KB.16.08.0026
n KB.16.09.0021
n KB.16.10.0022
n KB.16.11.0006

Yes
Switch Software
Dependency:
n KB.16.08.0019

and later
n KB.16.09.0015

and later
n KB.16.10.0012

and later
n KB.16.11.0002

BPS UI and Template

Aruba
5400R
Switch
Series

n KB.16.08.0019
and later

n KB.16.09.0015
and later

n KB.16.10.0012
and later

n KB.16.11.002

n KB.16.08.0026
n KB.16.09.0021
n KB.16.10.0022
n KB.16.11.0006

Yes
Switch Software
Dependency:
n KB.16.08.0019

and later
n KB.16.09.0015

and later
n KB.16.10.0012

and later
n KB.16.11.0002

VSF Template only

Provisioning and configuring of Aruba 5400R switches and Aruba 5400R switch stacks is supported only using
configuration templates. Aruba Central On-Premises does not support moving Aruba 5400R switches from the
template group to a UI group. If an Aruba 5400R switch is pre-assigned to a UI group, then the device is moved
to an unprovisioned group after it joins.

Data sheets and technical specifications for the supported switch platforms are available at:
https://www.arubanetworks.com/products/switches/.

https://www.arubanetworks.com/products/switches/
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Supported AOS-CX Platforms
The following table lists the AOS-CX platforms and corresponding software versions supported in Aruba
Central On-Premises.

The version listed under the Recommended Version column in the Firmware page in the Aruba Central On-
Premises web UI is the version that HPE Aruba Networking recommends to obtain the best experience from
Aruba devices.

Switch Platform
Supported
Software
Version

Latest
Software
Version

Supported
Configuration
Group Type (UI /
Template)

AOS-CX 4100i Switch Series 10.10.1000 and
later

10.12.xxxx UI and Template

AOS-CX 6000 Switch Series 10.10.1000 and
later

10.12.xxxx UI and Template

AOS-CX 6100 Switch Series 10.06.0200,
10.10.1000 and
later

10.12.xxxx UI and Template

AOS-CX 6200 Switch Series 10.06.0200,
10.10.1000 and
later

10.12.xxxx UI and Template

AOS-CX 6300 Switch Series 10.06.0200,
10.10.1010 and
later

10.12.xxxx UI and Template

AOS-CX 6400 Switch Series 10.06.0200,
10.10.1000 and
later

10.11.xxxx UI and Template

AOS-CX 6400V2 Switch Series 10.10.1000 and
later

10.12.xxxx UI and Template

AOS-CX 8320 Switch Series 10.06.0200,
10.10.1000 and
later

10.12.xxxx UI and Template

AOS-CX 8325 Switch Series 10.06.0200,
10.10.1000 and
later

10.12.xxxx UI and Template

AOS-CX 8360 Switch Series 10.06.0200,
10.10.1000 and
later

10.12.xxxx UI and Template

AOS-CX 8360V2 Switch Series 10.10.1000 and
later

10.12.xxxx UI and Template

Table 6: Supported AOS-CX Switch Series and Software Versions
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Switch Platform
Supported
Software
Version

Latest
Software
Version

Supported
Configuration
Group Type (UI /
Template)

AOS-CX 8400 Switch Series 10.06.0200,
10.10.1000 and
later

10.12.xxxx UI and Template

AOS-CX 9300 Switch Series 10.10.1000 and
later

10.12.xxxx UI and Template

AOS-CX 10000 Switch Series 10.10.1000 and
later

10.12.xxxx UI and Template

Data sheets and technical specifications for the supported Switch platforms are available at:
https://www.arubanetworks.com/products/Switches/.

Supported Aruba Mobility Controllers
Aruba Central On-Premises supports provisioning, management, and monitoring of the following Aruba
Mobility Controllers.

The following table lists the supported Mobility Controllers and latest validated software versions.

Supported Device Latest Validated Software
Versions

Aruba 7000 Series Mobility Controllers n 8.7.1.9

n 8.8.0.0

n 8.9.0.0

n 8.10.0.3

Aruba 7200 Series Mobility Controllers n 8.7.1.9
n 8.8.0.0
n 8.9.0.0
n 8.10.0.3

Aruba 9004 non-LTE Mobility Controllers 8.8.0.0

Aruba 9240 Mobility Controllers n 8.9.0.0
n 8.10.0.3

NOTE:

n Controllers WebSocket connection must be manually set up to Aruba Central.
n The minimum software version required for monitoring controller clusters and Mobility Conductor managed

networks is ArubaOS 8.2.1.0.

Table 7: Supported Devices and Software Versions

https://www.arubanetworks.com/products/switches/
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What's New

Important Notes
n For new Aruba Central On-Premises deployments, it is a prerequisite to use 10 Gigabit Ethernet (GbE)

interface for optimum performance.
n For users who are still on the 1 GbE switch interface, it is mandatory to first upgrade to Aruba Central

On-Premises 2.5.6.7 version before switching to the 10 GbE interface. For information on switching to
10 GbE interface, see Switching to 10 Gigabit Ethernet Interface on page 34.

n The nodes of an Aruba Central On-Premises cluster must be deployed in the same data center and
same VLAN subnet. It is a prerequisite to get 10 Gbps throughput for intra-cluster communication.

n It is recommended to upgrade all the Aruba Central On-Premises nodes to 512 GB for optimum
performance. Starting from this release, 256 GB RAM is not supported.

New Features
The following sections provide an overview of the new features that are added to Aruba Central On-
Premises in this release.

Adding Subscription for Offline-Mode Installations
Aruba Central On-Premises has introduced manually adding the subscription on HPE GreenLake
account home to support offline deployments. The license file is uploaded in the Device Subscriptions
page under Manage Account > Subscriptions. For more information, see Adding Subscription for
Offline-Mode Installation.

Aruba Central NetConductor
Listed below are the features introduced for Aruba Central On-Premises, in this release: 

n Users can configure underlay network in Aruba Central On-Premises.

For more information, see Network Wizard Overview .

n Aruba Central On-Premises now provides a re-sync button to resolve configuration conflicts within
existing overlay fabrics. This button is only available when a configuration conflicts exists.

For more information, see Fabric Wizard Overview .

n Aruba Central On-Premises now supports Layer 2 overlay segments for the default gateways.

For more information, see Fabric Wizard Overview .

Aruba Central On-Premises APIs
Listed below are the APIs introduced in this release.

Aruba Central On-Premises 2.5.7 | User Guide 22
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API Category New APIs

Service RAPIDS > Aruba Rapids n [GET] /rapids-config/v1/node_list/{node_type}/{node_
id}/config/

n [GET] /rapids-config/v1/node_list/{node_type}/{node_
id}/config/classification_rule/

n [GET] /rapids-config/v1/node_list/{node_type}/{node_
id}/config/classification_rule/{rule_name}/

n [GET] /rapids-config/v1/node_list/{node_type}/{node_
id}/config/classification_rule/{rule_name}/match_criteria/

n [GET] /rapids-config/v1/node_list/{node_type}/{node_
id}/config/classification_rules/{rule_name}/match_
criteria/site_excludes/

n [GET] /rapids-config/v1/node_list/{node_type}/{node_
id}/config/classification_rules/{rule_name}/match_
criteria/site_excludes/{name}/

n [GET] /rapids-config/v1/node_list/{node_type}/{node_
id}/config/classification_rules/{rule_name}/match_
criteria/site_includes/

n [GET] /rapids-config/v1/node_list/{node_type}/{node_
id}/config/classification_rules/{rule_name}/match_
criteria/site_includes/{name}/

n [GET] /rapids-config/v1/node_list/{node_type}/{node_
id}/config/classification_rules/{rule_name}/match_
criteria/ssid_excludes/

n [GET] /rapids-config/v1/node_list/{node_type}/{node_
id}/config/classification_rules/{rule_name}/match_
criteria/ssid_excludes/{essid}/

n [GET] /rapids-config/v1/node_list/{node_type}/{node_
id}/config/classification_rules/{rule_name}/match_
criteria/ssid_includes/

n [GET] /rapids-config/v1/node_list/{node_type}/{node_
id}/config/classification_rules/{rule_name}/match_
criteria/ssid_includes/{essid}/

n [POST] /rapids-config/v1/node_list/{node_type}/{node_
id}/config/

n [POST] /rapids-config/v1/node_list/{node_type}/{node_
id}/config/classification_rule/{rule_name}/match_criteria/

n [POST] /rapids-config/v1/node_list/{node_type}/{node_
id}/config/classification_rules/{rule_name}/match_
criteria/site_excludes/{name}/

n [POST] /rapids-config/v1/node_list/{node_type}/{node_
id}/config/classification_rules/{rule_name}/match_
criteria/ssid_excludes/{essid}/

n [POST] /rapids-config/v1/node_list/{node_type}/{node_
id}/config/classification_rules/{rule_name}/match_
criteria/ssid_includes/{essid}/

n [PUT] /rapids-config/v1/node_list/{node_type}/{node_
id}/config//rapids-config/v1/node_list/{node_type}/node_
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API Category New APIs

id}/config/classification_rule/{rule_name}/
n [PUT] /rapids-config/v1/node_list/{node_type}/{node_

id}/config/classification_rule/{rule_name}/match_criteria/
n [PUT] /rapids-config/v1/node_list/{node_type}/{node_

id}/config/classification_rules/{rule_name}/match_
criteria/site_excludes/{name}/

n [PUT] /rapids-config/v1/node_list/{node_type}/{node_
id}/config/classification_rules/{rule_name}/match_
criteria/site_includes/{name}/

n [PUT] /rapids-config/v1/node_list/{node_type}/{node_
id}/config/classification_rules/{rule_name}/match_
criteria/ssid_excludes/{essid}/

n [PUT] /rapids-config/v1/node_list/{node_type}/{node_
id}/config/classification_rules/{rule_name}/match_
criteria/ssid_includes/{essid}/

n [DELETE] /rapids-config/v1/node_list/{node_type}/{node_
id}/config/

n [DELETE] /rapids-config/v1/node_list/{node_type}/{node_
id}/config/classification_rule/{rule_name}/

n [DELETE] /rapids-config/v1/node_list/{node_type}/{node_
id}/config/classification_rule/{rule_name}/match_criteria/

n [DELETE] /rapids-config/v1/node_list/{node_type}/{node_
id}/config/classification_rules/{rule_name}/match_
criteria/site_excludes/{name}/

n [DELETE] /rapids-config/v1/node_list/{node_type}/{node_
id}/config/classification_rules/{rule_name}/match_
criteria/site_includes/{name}/

n [DELETE] /rapids-config/v1/node_list/{node_type}/{node_
id}/config/classification_rules/{rule_name}/match_
criteria/ssid_excludes/{essid}/

n [DELETE] /rapids-config/v1/node_list/{node_type}/{node_
id}/config/classification_rules/{rule_name}/match_
criteria/ssid_includes/{essid}/

VisualRF > GeoFence n [GET] /visualrf_api/v1/geofence

n [POST] /visualrf_api/v1/geofence

n [DELETE] /visualrf_api/v1/geofence

For more information, see Changes to Aruba Central On-Premises APIs.

Aruba Central On-Premises Deployment
Aruba Central On-Premises now supports Bare Metal mode (non-appliance) deployment along with
appliance mode deployment,

In Bare Metal mode, customers deploy Aruba Central On-Premises on HPE servers that meet certain
specification. The recommended platforms for this deployment are HPE DL360/ DL380 /DL560. To
enable Bare Metal mode, you must download the root certificate authority (CA) from Comand Line
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Interface (CLI) to connect to your network devices. This certificate should be uploaded to your
respective devices for authentication.

For more information on Aruba Central On-Premises deployment, see Aruba Central On-Premises
Installation Guide.

For more information on Command Line Interface options, see System Configuration.

Aruba Central On-Premises Network Link Aggregation
Aruba Central On-Premises supports network link aggregation (LAG) in case of any network breakage.
LAG can be enabled or disabled through Command Line Interface (CLI) from the ILO console. Aruba
Central On-Premises LAG configuration is a network related operation and each node in the cluster
must be individually configured for this feature to work. LAG gets disabled when a node in the cluster is
reset. For more information, see Network Link Aggregation.

Automatic Rollback Configuration on AOS-CX Switches
Aruba Central On-Premises now supports an auto-rollback mechanism for AOS-CX switches running
10.06 or later software versions. The rollback mechanism is triggered when the switch loses its
connectivity to Aruba Central On-Premises after a configuration push. For more information, see
Automatic Rollback Configuration .

Cable Test Support for AOS-CX Switches
Aruba Central On-Premises now supports cable test for AOS-CX switches. This enables testing of the
electrical connections in the switch cable. For more information, see Troubleshooting Device Issues.

Configuring Client Events for AOS-CX
Users can configure client events to generate authentication and DHCP events of clients. For more
information, see Configuring Authentication and DHCP Related Client Events on AOS-CX

Configuring Port Profiles on AOS-CX
The Port profiles feature allows you to configure interface-specific commands at the group level
through an editor that supports syntax and semantic checking. For more information, see Configuring
Switch Ports on AOS-S Switches.

Configuring RADIUS Server Settings on AOS-S Switches
Aruba Central On-Premises supports Window Size and Time Window as the RADIUS server
parameters.

Window Size is used to configure replay protection for dynamic authorization messages. The window
size is the time in seconds within which the received dynamic authorization requests are considered to
be current and accepted for processing. A zero value means there is no time limit. A non-zero value
indicates that the Event-Timestamp attribute is expected as part of all Change of Authorization and
Disconnect request messages. If the timestamp attribute is not present the message is dropped. The
default Window Size value is 300 seconds.

The Time Window option allows the user to select Positive or Plus minus window size. Positive
(positive-time-window) sets the current acceptable time-window as + seconds. Plus minus (plus-or-
minus-time-window) sets the current acceptable time-window as +/- seconds. When replay protection is
enabled and positive-time-window is set, messages from the server must contain an Event-Timestamp
attribute that differs from the current time by not more than the specified number of seconds.

#https://www.arubanetworks.com/techdocs/CLI-Bank/Content/cop/4-systemconfig/4-systemconfig.htm
#https://www.arubanetworks.com/techdocs/CLI-Bank/Content/cop/4-systemconfig/4-2-4-LAG.htm
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When replay protection is enabled and plus-or-minus-time-window is set, messages from the server
must contain an Event-Timestamp attribute that differs from the current time by no more than the (+/-)
specified number of seconds. Messages with a timestamp value outside the valid window
are considered stale and are ignored. Setting the time window to zero disables replay protection. The
default window-type is positive-time-window.

For more information on Time Window and Window Size see Configuring RADIUS Server Settings on
AOS-S Switches

Configuring Switch Ports on AOS-S Switches
Aruba Central On-Premises allows the user to enable or disable the unsupported transceivers (third-
party transceivers).

Configuring System Access for AOS-S Switches
Aruba Central On-Premises supports the following new features:

n TELNET toggle switch - Allows the user to enable or disable the login access via the TELNET server.

n Management Authentication - Allows the user to select either RADIUS, TACACS, LOCAL as the
primary management authentication server.

n MOTD Login Banner - Allows the user to enter the message to be displayed before the login prompt.

For more information, see Configuring System Parameters for AOS-S Switches.

Configuring TACACS Server Settings on AOS-S Switches
Aruba Central On-Premises now allows the user to configure TACACS server settings. For more
information, see Configuring TACACS Server Settings on AOS-S Switches.

Datacenter Redundancy
The Datacenter Redundancy tab is introduced under System Management. This feature allows you
to configure and pair two clusters in order to continue network functioning by switching roles, in case of
a failover, within minimum downtime. For more information, see Datacenter Redundancy .

RAPIDS
Aruba Central On-Premises now allows users to enable or disable the RAPIDS feature as a whole on per
customer basis. Users who want to configure rules can enable the Enable RAPIDS toggle button under
Manage > Security > RAPIDS. Upon enabling the RAPIDS feature, users can see the Classification
Rules table with the default configured rules. In addition to the default rules, users can configure a
predefined set of customized classification criteria at the global level to determine the classification of a
neighboring AP. For more information, see Configuring RAPIDS.

Support for AP-503 Access Points
Aruba Central On-Premises now supports configuring and monitoring of AP-503 access points (AP) using
the UI options and templates. For more information, see Supported APs.

Support for Third-Party Devices
Aruba Central On-Premises now supports adding and monitoring third-party devices, such as Cisco 9200
and 9300 series switches. For more information, see Monitoring Third-Party Devices.
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VSF Switchover
In AOS-CX switch stacks, the VSF Switchover option triggers the standby conductor switch to take over
the conductor role. For more information, see VSF Switchover

Enhancements
The following sections provide an overview of the enhancements introduced in Aruba Central On-
Premises in this release.

Access Logs
Users can now see logs for any kind of Aruba Central On-Premises access that is either done through
the web or Command Line Interface (CLI). For more information, see Viewing Audit Trail.

Access Points Monitoring
The following AP monitoring enhancements are introduced in this release.

Controller AP Group
Aruba Central On-Premises now supports Controller AP Group parameter in the Access Points List and
Access Points Overview page that displays the name of the AP group.

For more information, see the following topics:

n Monitoring Access Points in List View

n Viewing the Summary Tab

Support for Access Points Tab in the Controller Dashboard
Aruba Central On-Premises now supports Access Points tab under Manage > Access Points page in
the controller dashboard that displays details of all the APs connected to a specific controller. For more
information, see Controller > Access Points > Access Points.

Alerts and Events
The following Alerts & Events enhancements are introduced in this release:

IP Management System
A new alert type IP Management System is added under Alerts & Events. The following alert is added
under IP Management System alert type:

IPMS Pool Capacity Alert—Generates an alert when IPMS pool allocation crosses 80% of assigned pool
size. The alert is cleared when the pool capacity is below 80% of the assigned capacity in the network.

For more information, see IP Management System Alert.

Access Point Alerts
DPP Attack—Generates an alert when there is a DPP-related DoS attack in the network.

For more information, see Access Point Alerts.

Central System Alerts
COP Disaster Recovery Alert Notifier—Generates an alert when the DR (Disaster Recovery) role is
successfully changed to the Primary cluster.
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Connectivity Alerts
The following new authentication alert types are added in Connectivity alerts to enhance user
experience by adding detailed information regarding the server IP, authentication type, number of users
impacted, and percentage of users effected.

n Wi-Fi Security Key-Exchange Failure Detected—Generates an alert when there are high number of
client authentication failures (Wi-Fi Security Key-Exchange) in the network.

n Wi-Fi Security Key-Exchange Delay Detected—Generates an alert when there is excessive delay in
the client authentication (Wi-Fi Security Key-Exchange) with the AP in the network.

n 802.1x Authentication Delay Detected—Generates an alert when there is excessive delay in the
802.1x authentication process in the network.

n 802.1x Authentication Failure Detected—Generates an alert when there are high number of
802.1x authentication failures in the network.

n MAC Authentication Delay Detected—Generates an alert when there is excessive delay in the MAC
authentication process in the network.

n MAC Authentication Failure Detected—Generates an alert when there are high number of MAC
authentication failures in the network.

n Captive Delay Detected—Generates an alert when there is excessive delay in the captive portal
authentication process in the network.

n Captive Failure Detected—Generates an alert when there are high number of captive portal
failures in the network.

This additional categorization of the authentication alerts enable users to quickly triage the alerts and
take appropriate action.

For more information, see Connectivity Alerts

AOS-CX Switch Alerts
The following alerts are introduced in this release:

n Management module failure—Generates an alert when the state of the management module
changes to down or failed.

n Line-card failure—Generates an alert when the state of the line card changes to down or failed.

n Fan tray failure —Generates an alert when the state of the fan tray in the slot changes to down or
failed.

n Fan failure —Generates an alert when the state of the fan in the slot tray changes to fault.

n Power supply failure—Generates an alert when the state of the power supply in the slot changes to
fault input or warning.

n Switch Uplink Port Status Change—Generates an alert when there is a change in the status of the
uplink port. This alert is generated when the uplink port goes down and it is cleared when the port
status is restored.

For more information, see AOS-CX Switch Alerts.

AOS-CX Switch Events
Support for the following events are available:
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n MSTP events

n RPVST events

n Loop protect events

For more information about the AOS-CX switch events, navigate to the AOS-CX Switch Software
Documentation Portal. In the AOS-CX Switch Software Documentation portal, navigate to a switch model
and click the View software feature and user guides (HTML) link. Click Software Release Version
listed next to the Event Log Message Reference Guide to view the events for the software release version
selected.

Aruba Central On-Premises APIs
Listed below are the APIs enhanced in this release.

API Category Modified APIs

Configuration > Certificates n [POST /configuration/v1/certificates/

n [PUT] /configuration/v1/msp/certificate
n [PUT] /configuration/v1/non_msp/certificate

Configuration > WLAN Configuration n [POST] /configuration/v2/wlan/{group_name_or_guid_or_
serial_number}/{wlan_name}

n [PUT] /configuration/v2/wlan/{group_name_or_guid_or_serial_
number}/{wlan_name}

n [PATCH] /configuration/v2/wlan/{group_name_or_guid_or_
serial_number}/{wlan_name}

Firmware n [GET] /firmware/v1/devices
n [GET] /firmware/v1/devices/{serial}
n [GET] /firmware/v1/versions
n [GET] /firmware/v1/versions/{firmware_version}
n [GET] /firmware/v1/status
n [GET] /firmware/v2/upgrade/compliance_version
n [GET] /firmware/v1/upgrade/compliance_version
n [GET] /firmware/v1/models
n [GET] /firmware/v1/msp/upgrade/compliance_version
n [GET] /firmware/v1/msp/upgrade/customers/{customer_

id}/compliance_version
n [GET] /firmware/v1/msp/tenants/{tenant_id}

n [POST] /firmware/v1/upgrade
n [POST] /firmware/v1/upgrade/cancel
n [POST] /firmware/v1/upgrade/compliance_version
n [POST] /firmware/v1/msp/upgrade
n [POST] /firmware/v1/msp/upgrade/customers/{customer_id}
n [POST] /firmware/v1/msp/upgrade/cancel
n [POST] /firmware/v1/msp/upgrade/customers/{customer_

https://www.arubanetworks.com/techdocs/AOS-CX/help_portal/Content/home.htm
https://www.arubanetworks.com/techdocs/AOS-CX/help_portal/Content/home.htm


Aruba Central On-Premises 2.5.7 | User Guide 30

API Category Modified APIs

id}/cancel
n [POST] /firmware/v2/msp/upgrade/cancel
n [POST] /firmware/v2/msp/upgrade/customers/{customer_

id}/cancel
n [POST] /firmware/v1/msp/upgrade/compliance_version
n [POST] /firmware/v1/msp/upgrade/customers/{customer_

id}/compliance_version

n [DELETE] /firmware/v2/upgrade/compliance_version
n [DELETE] /firmware/v1/msp/upgrade/compliance_version
n [DELETE] /firmware/v1/msp/upgrade/customers/{customer_

id}/compliance_version

Monitoring > AP n [GET] /monitoring/v2/aps/
n [GET] /monitoring/v1/aps/{serial}

New Device Inventory > Devices n [GET] /platform/device_inventory/v1/devices

New Licensing n [GET] /platform/licensing/v1/subscriptions

Configuration > Device Depending on the role and group scope assigned to a user, the
behavior of the APIs are updated .
n [GET] /configuration/v1/devices/{device_serial}/group
n [GET] /configuration/v1/devices/{device_serial}/configuration
n [GET] /configuration/v1/devices/{device_serial}/config_details
n [GET] /configuration/v1/devices/{device_serial}/variablised_

template

Configuration > MM-MD Depending on the role and group scope assigned to a user, the
behavior of the API is updated.
n [POST] /configuration/v1/devices/{device_serial}/recover_

device

Monitoring > Switch Depending on the role and group scope assigned to a user, the
behavior of the APIs listed under Monitoring > Switch category
are updated.

Monitoring > Gateway Depending on the role and group scope assigned to a user, the
behavior of the APIs listed under Monitoring > Gateway category
are updated.

Listed below are the APIs removed in this release.

API Category Removed APIs

Rapids > SSIDs
The following APIs in the RAPIDS category
are removed. You can now configure
RAPIDS from the RAPIDS configuration
page. For more information, see
Configuring RAPIDS.

n [GET] /rapids/v1/ssid_allow
n [GET] /rapids/v1/ssid_block

n [POST] /rapids/v1/ssid_allow
n [POST] /rapids/v1/ssid_block
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API Category Removed APIs

n [DELETE] /rapids/v1/ssid_allow
n [DELETE /rapids/v1/ssid_block

For more information, see Changes to Aruba Central On-Premises APIs.

Aruba Central supports streaming GeoFence events using streaming API. For more information, see
Streaming APIs.

To enhance security, client_id and client_secret are part of the body parameters for customer
facing token generation APIs. For more information, see Obtaining Token Using OAuth Grant
Mechanism.

Aruba Central On-Premises ISO Installation
From now, during any Aruba Central On-Premises installation on the iLO server, if there are any test ilo
user accounts that were created by the customer, those accounts will be deleted. Only ‘administrator’
and ‘copilo’ ILO account can be created and retained as a part of the ISO installation. This behavior is
applicable to any upgrade from Aruba Central On-Premises 2.5.6 to Aruba Central On-Premises 2.5.7,
and also when any customer migrates from Airwave to Aruba Central On-Premises.

For more information, see Aruba Central On-Premises Installation Guide.

Certificates
Certificates are enhanced to support the following:

n Web UI And API Gateway services support Elliptical Curve Cryptography (ECC) certificate.
n Client Certificate are now supported in Aruba Central On-Premises.
n Server certificate can now be applied to verify RadSec protocol.
n Secure AMON service now supports DTLS protocol.

For more information on certificates, see Managing Certificates.

Device Override Visualization
Users can now view the local override configuration details of a switch or its group. For more
information, see Using Configuration Status on AOS-CX.

Handling Aruba Central On-Premises Upgrade for Datacenter
Redundancy
For Aruba Central On-Premises upgrade from one version to another, it is beneficial to have a
secondary cluster for safe management of software and hardware systems. To upgrade the secondary
cluster, you must first upgrade the primary cluster. Primary cluster can be upgraded through user
interface or command line interface (CLI) option whereas, the secondary cluster can only be upgraded
through CLI.

For more information, see the following topics:

n Handling Upgrade for Datacenter Redundancy

n Datacenter Redundancy

n Disaster Recovery

#https://www.arubanetworks.com/techdocs/CLI-Bank/Content/cop/4-systemconfig/4-8-2-configDR.htm
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Host Upgrade Parallelization
The time to perform a host upgrade from Aruba Central On-Premises 2.5.6 to Aruba Central On-
Premises 2.5.7 for a 7 node cluster is now reduced to 1.5 hours - 2 hours.

Incremental Backup
A new option, Incremental Backup, is added to the Backup Later schedule under Maintain > System
Management > Backup and Restore. This option is provided to aid in taking daily backup of
voluminous databases in a segregated manner. For more information, see Scheduling Incremental
Backup.

Managing Local Overrides for AOS-CX Switches
Aruba Central On-Premises now allows users to view the local overrides of a switch or its group. For
more information, see Using Configuration Status on AOS-CX.

NAE Scripts
In this version of Aruba Central On-Premises, new NAE scripts are supported. For more information, see
Express Configuration Using MultiEdit on AOS-CX.

New Infra Inventory Report
A new column Controller AP Group is added to the Total APs table of the New Infra Inventory
report.

For more information, see Report Categories.

OPA Gatekeeper for Public Image Restriction
Aruba Central On-Premises now downloads packages from private allow listed repositories and uses
signed packages for images.

For more information, see the following topics:

n Aruba Central On-Premises Installation Guide

n Configuring Communication Ports

Password Specifications for Aruba Central On-Premises
Configuration
When installing Aruba Central On-Premises or changing the password from the CLI menu, the minimum
password specification is to use at least eight characters that includes a combination of letters,
numbers, and special characters.

For more information, seeAruba Central On-Premises Installation Guide.

Removing Multiple Devices from a Site
Aruba Central On-Premises now allows users to remove multiple devices at a time. For more
information, see Removing multiple devices from a site.

Replacement Details Page
You can now view the device replacement details page for a particular device by clicking on the old
device serial from the Devices Under Replacement and Replacement History pages. For more
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information, see Device Replacement

Support for Resolving FQDNs
Aruba Central On-Premises now requires the FQDNs to be resolved on both the primary and secondary
DNS servers.



Chapter 4

Getting Started with Aruba Central On-
Premises

Getting Started with Aruba Central On-Premises

To install Aruba Central On-Premises 2.5.7 or to upgrade the existing Aruba Central On-Premises setup to 2.5.7,
you must to be connected to the network through 10 Gig interface. For more information on switching to 10
Gigabit Ethernet (GbE) interface, see Switching to 10 Gigabit Ethernet Interface on page 34. For additional
assistance, contact Aruba TAC (Technical Assistance Center) team.

Aruba Central On-Premises supports two types of deployments:

n Appliance—In this mode, customers deploy Aruba Central On-Premises on Aruba Central Appliance
(R1Q05B) or Aruba Central Ready AirWave 8 Appliance (R1Q04B).

n COP on Bare Metal—In this mode, customers deploy Aruba Central On-Premises on HPE servers
meeting specifications as mentioned in Getting Started with Aruba Central On-Premises table. The
recommended platforms are HPE DL360/ DL380 /DL560.

Checks Minimum Requirements

Hard Disk Type SSD should be present

Network Interface A 10 Gig interface

CPU Cores 40 physical cores

CPU Arch x86/amd64

RAM 512 GB

Hard Disk Size 4 TB

Disk I/O 3300 MiB/s

Processor Speed 2000 Mhz

Table 8: HPE Server Specifications

For information on reinstalling the software or setting up the Aruba Central On-Premises server or
cluster, see the Aruba Central On-Premises Installation Guide.

Switching to 10 Gigabit Ethernet Interface
You must use Command Line Interface (CLI) from the ILO console to run the Switch Network Interface
command.
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n For users who are still on the 1 GbE switch interface, it is mandatory to first upgrade to Aruba Central On-
Premises 2.5.6.7 version before switching to the 10 GbE interface.

n Ensure to run the commands for all the nodes in the cluster.

To switch to 10 GbE interface, complete the following steps:

1. From a secure shell (SSH) client, open an SSH connection.
2. Login as copadmin.
3. When prompted, enter the copadmin password.

A list of commands is displayed.

1. System

2. File Operations

3. Show

4. System Configuration

5. Advanced switch

6. Security

7. Support

8. Temporary Root Shell

9. Authentication

10. Certificate configuration

11. Search commands

====================================

0. exit

Enter option [ 0 - 11 ]:

4. Enter command option 4 from the Show commands menu to view the system configuration
settings.

5. Enter command option 2 from the System Configuration commands menu to view the network
setup settings.

6. Enter command option 3 from the Network Setup commands menu to switch to 10 GbE network
interface.

7. Enter the 10 Gigabit Ethernet interface details.

In the following example, a new network interface ("ens1f1") is entered for 10 GbE.

Enter option [ 0 - 3 ]: 3

The network interface currently configured is: eno1

Please capture and note down current network configurations for interface,

IP Address, Subnet mask and Gateway before

proceeding further.

Current Network Settings

--------------------------

Current Interface : eno1

IP Address : 10.22.154.83

Subnet Mask : 255.255.255.0

Gateway : 10.22.154.3

DNS : 10.20.50.10
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Secondary DNS : 10.20.50.15

FQDN : cop-upgrade-node3.arubathena.com

Enter new interface name: ens1f1

Configuring the ens1f0 network interface

Interface is up...moving on

Network Settings Being Applied

-------------------------------

Network Interface : ens1f1

IP Address : 10.22.154.83

Subnet Mask : 255.255.255.0

Gateway : 10.22.154.3

DNS : 10.20.50.10

Secondary DNS : 10.20.50.15

FQDN : cop-upgrade-node3.arubathena.com

Network settings exist: will be reset to a new value

9f83d89df0f5

Kubernetes is up...moving on

deployment.apps/coredns scaled

deployment.apps/coredns scaled

1

OK

pod "platform-config-platform-uwsgi-deployment-86dc68d4d6" deleted

updating cache, please wait

Interface is updated to ens1f1

Press [Enter] key to continue...

n You cannot switch interface from Aruba Central On-Premises CLI to a port slower than 10 Gbps.
n If all nodes are not connected to interfaces with same speed, any addition or replacement of nodes might

fail.

Provisioning Workflow
The provisioning workflow for Aruba Central On-Premises deployments includes the following steps:

Ensure that you have completed all the steps mentioned in the Installation and Setup Guide.

n Creating a Group
n Managing Devices and Subscriptions
n Assigning Devices to Groups
n Assigning Labels
n Assigning Sites
n Connecting Aruba APs to Aruba Central On-Premises
n Connecting Aruba Switches to Aruba Central
n Configuring Communication Ports
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Accessing Aruba Central On-Premises
You can access the Aruba Central On-Premises app and start monitoring your network using the
features available on the application. For more information about the app, see About Aruba Central On-
Premises.

To launch the Aruba Central On-Premises app, complete the following steps:

1. Access the Aruba Central On-Premises website.

The Sign In page is displayed.

2. Enter the username and click Next.
The Sign On page is displayed.

3. Enter the password and click Sign In.

The Aruba Central On-Premises application is launched and the Overview > Network Health
page is displayed.

Logging Out of Aruba Central On-Premises
To log out of Aruba Central On-Premises, complete the following steps:

1. In the Aruba Central On-Premises WebUI, click the user icon ( ) in the header pane.

2. Click Logout.

To know more about home to access HPE GreenLake account from Aruba Central On-Premises Home
page, see Accessing HPE GreenLake Account Home

Accessing HPE GreenLake Account Home
To access the HPE GreenLake account home, complete the following steps:

1. Log in to the Aruba Central On-Premises app.

2. Click the Account Home ( ) icon in the header pane.
The HPE GreenLake Account Home page is displayed. It consists of the Featured Application
and Quick Actions sections. For more information, see HPE GreenLake Account Home.

Features Requiring Internet Access
Following are the only features on Aruba Central On-Premises that require internet connection:

n Upgrading the Software
o Internet is required for upgrading the software. When upgrading from a minor to major version,

internet connection is required until the process is completed.
o Internet is required to check if any upgrade is available (every 55 days).

n Adding a License
o Internet is required for adding licenses (subscriptions).

n Accessing Help Menu
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o All options under the Help ( ) menu on the top menu bar, Documentation Center, Airheads
Community, View/Update Case, and Open New Case require internet on your browser for
accessing them.

n Providing Remote Access
o Internet is required for the Support Connection to provide remote access to Aruba Support for

troubleshooting purposes.

Offline map under Global > Overview > Network Health is not available.

Scaling Devices for Aruba Central On-Premises
Aruba Central supports switches, controllers, Instant APs, and Campus APs. Aruba Central can be
implemented on multiple nodes. Accordingly, the number of supported devices increase.

Supported Number of Devices - Summary Table
The following table provides a summary of the number of devices supported across multiple nodes.

Node
Size

Campus APs and
Controllers only

Instant AP
only

Switches only

(AOS-S and AOS-
CX)

Mixed-Mode

Single
Node

2000 2000 1000 1600 APs (Instant AP or Campus AP)
and 400 Switches (AOS-S or AOS-CX)

Three
Node

8000 8000 3000 6000 APs (Instant AP or Campus AP)
and 2000 Switches (AOS-S or AOS-
CX)

Five Node 16000 12000 4000 12000 APs (Instant AP or Campus
AP) and 4000 Switches (AOS-S or
AOS-CX)

Seven
Node

25000 25000 10000 (AOS-S) /
5000 (AOS-CX)

16000 APs (Instant AP or Campus
AP) and 7000 Switches (AOS-S) [ 
AOS-CX up to 5000 Switches ]

Table 9: Maximum Number of Supported Devices based on the Deployment Types

Supported Number of Devices - Detailed Table
The following table details the number of devices that Aruba Central supports across multiple nodes.

Nodes Maximum Number of
Supported Devices Modes

Single Node 2000 n 2000 APs where APs can be either Instant APs,
Campus APs, or controllers that manage APs; or a
mixed deployment of any of these devices.
n 1000 switches where switches can be AOS-S or AOS-
CX switches or a mix of the two.
n In a mixed-mode of switches and APs, up to 1600

Table 10: Maximum Number of Supported Devices
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Nodes Maximum Number of
Supported Devices Modes

APs and 400 switches are supported.

Three Node 8000 n 8000 APs, where APs can be either Instant APs,
Campus APs, or APs along with the controllers that
manage APs; or a mix of any of these devices.
n 3000 AOS-S or AOS-CX switches or a mix of the two
can be deployed in switch-only deployment.
n In a mixed-mode of switches and APs, up to 6000
APs (Instant APs or Campus APs) and 2000 switches
(AOS-S or AOS-CX) are supported.

Five Node 16000 n 16000 Campus APs along with the controllers that
manage APs can be deployed.
n 12000 Instant APs can be deployed.
n 4000 AOS-S or AOS-CX switches or a mix of the two
can be deployed in switch-only deployment.
n In a mixed-mode of switches and APs, up to 12000
(Instant APs or Campus APs) and 4000 (AOS-S or AOS-
CX) switches are supported.

Seven Node 25000 n 25000 Campus APs along with the controllers that
manage APs can be deployed.
n 25000 Instant APs can be deployed in Instant AP-
only deployment.
n 10000 AOS-S switches can be deployed in AOS-S
switch-only deployment.
n 5000 AOS-CX switches can be deployed in AOS-CX
switch-only deployment.
n In a mixed-mode of switches and APs, up to 16000
APs (Instant AP or Campus APs), 7000 AOS-S switches
and 5000 (AOS-S or AOS-CX) switches are supported.

Limitations
The following features are not supported:

n Live Events on a single-node deployment
n API Streaming on a single-node deployment
n Live Packet Capture on a single-node deployment
n API Gateway on a single-node deployment
n RAPIDS on a single-node deployment
n UCC on a single-node deployment
n High Availability on a single-node deployment
n Adding and replacing node on a single-node deployment
n AI Insights on single-node and 3-node clusters

HPE GreenLake Account Home
The HPE GreenLake Account Home is the dashboard from where you can manage, configure, and
access the available features and functionalities.

The features are displayed based on the following:
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n The services and tools available to your organization.

n The permissions available to your role.

Top Menu Bar
The following icons and tools are available on the top menu bar.

Menu Items Description

Dashboard The Dashboard tab is the home page for HPE GreenLake Account Home. It
consists of the following:
n Featured Application

n Quick Actions

Devices The Devices tab provides viewing and managing all devices in your inventory. The
Quick Actions under this tab includes the following:
n Add devices

n Assign Devices

n Apply Subscriptions to devices

n Add Device Subscription

Manage The Manage tab provides editing of your company account’s general information.

Table 11: HPE GreenLake Account Home Tabs

Cards
The main viewing area of the HPE GreenLake Dashboard contains one or more tiles called cards.

A card enables you to access software tools for services you have access to in HPE GreenLake. A card
often contains summary information about that service or that part of a service. However, the items are
displayed based on permissions as an HPE customer and the services you have purchased.

The following is an example of the card:

Invite Users

n Description—The information on the card displays the information about the service or tool.

n Button—Upon clicking the Send an Invite button on the card, you navigate to the corresponding
page within HPE GreenLake account home and perform the action.

Quick Actions
The cards under Quick Action provide immediate access to the tools and services for managing
devices, applications, and users.

Tasks include:

n Inviting Users

n Assigning User Access

n Onboarding devices

n Managing Subscriptions

#_Toc104964219
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Figure 1 Quick Actions Available on Dashboard

Services
Click the Services icon to access HPE GreenLake administration pages and general HPE resources.
Use this menu to launch the following services:

HPE GreenLake Administration

n Manage Account—Links to the Manage Account page where you can manage your account users
and their access to HPE GreenLake services and resources.

n Manage Devices—Links to the Devices page where you can view and manage all the devices in your
inventory.

HPE Resources
Click any of the links in this section to view the related information:

n HPE Support Center

n HPE Developer Community

n HPE Communities

n HPE Financial Services

User Profile
Click the User Profile icon to access your HPE Account Details page. The HPE Account Details page
allows you to edit your account data, including changing your password. You can adjust the Time,
Language, and Session Timeout settings from the Preferences page.
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Resource Restriction Policies
In HPE GreenLake account home, each application defines its own scope and uses the Authorization
service to control access to the various scope resources. These scope resources must be linked to the
user role assignments in order to enforce the permissions on them. HPE GreenLake account home uses
Resource Restriction Policies (RRPs) to group these scope resources and facilitate the role assignment
process. RRP is a named group of a list of scope resources. RRP provides a central place where all
assignments or a group of assignment can be updated in one place without the need to update multiple
users individually. RRP covers all the scopes defined by the application to be included in the assignment.
From the Resource Restriction Policies page, you can manage RRPs, such as creating, viewing, and
deleting.

Figure 2 Resource Restriction Policies Page

You cannot delete an RRP if it is used in an user role assignment.

This chapter contains the following sections:

n Creating a Resource Restriction Policy

n Editing Resource Restriction Policies

n Editing Resource Restriction Policy Assignments

n Deleting Resource Restriction Policy for Role

Creating a Resource Restriction Policy
To create a resource restriction policy, complete the following steps:
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1. On the HPE GreenLake account home, click Manage.

The Manage Account page is displayed.

2. On the Manage page, click the Identity & Access card.

The Identity & Access page is displayed.

3. Click the Resource Restriction Policy card.

The Resource Restriction Policies page is displayed with a list of available RRPs.

4. Click Create Resource Restriction Policy.

5. Add a Name and Description for the RRP and click Next.
The Choose an Application page is displayed.

6. Select the Aruba Central On-Premises card and click Next.
The Add Resources page is displayed.

7. Click Add Resources and configure the resources for your application.

8. First, click the region name and then the Aruba Central On-Premises application.

The displayed region name indicates the region in which the Aruba Central On-Premises application
instance is pre-provisioned.

9. Click Group Scope.

A list of groups scopes and resources is displayed.

These scopes are defined in the Aruba Central On-Premises application.

10. Select the resources for the permissions you want to grant to the group and click Add.

The Add Resources page is displayed with newly created resources for this group.

11. Click Next.
The Review & Create page is displayed. Verify the settings for your resource restriction policy.

12. Alternatively, click Modify to change the name, description, application, or resources for this
resource restriction policy.

13. Click Finish.

The Resource Restriction Policies page is displayed with the newly created RRP in the list. The new
RRP can be applied to any user or user group.

Editing Resource Restriction Policies
You can edit an existing RRP to change the permissions for all users assigned that RRP.

To edit the scope of a Resource Restriction Policy, complete the following steps:

1. On the HPE GreenLake account home, click Manage.

The Manage Account page is displayed.

2. Click the Identity & Access card.

The Identity & Access page is displayed.
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3. Click the Resource Restriction Policy card.

The Resource Restriction Policies page is displayed with a list of available RRPs.

4. Select the policy that you want to change. Alternatively, you can click the policy name or the
ellipsis icon to view the details.

The Details page is displayed.

5. In the Resources section, click Edit.

6. Click Add Resources.

7. In the Add Aruba Central On-Premises Resources screen, click the region name, and then the
Aruba Central On-Premises application.

8. Click Group Scope.

A list of groups scopes and resources is displayed with the existing resources.

9. Select the checkboxes to modify the resources for the policy and click Add.

10. Click Save Changes.

The Details is displayed with the modified resources allocated to the policy. The updated
permissions apply to all existing and new users assigned to this RRP.

Editing Resource Restriction Policy Assignments
You can edit an existing policy assigned to the user.

To edit the Resource Restriction Policy assigned to a user, complete the following steps:

1. On the HPE GreenLake account home, click Manage.

The Manage Account page is displayed.

2. Click the Identity & Access card.

The Identity & Access page is displayed.

3. Click the Users card.

The Users page is displayed with the list of users assigned to the account.

4. Select the required user. Alternatively, click the user name or the ellipsis and select View Details.

The Details page is displayed.

5. In the Roles section, click the ellipsis corresponding to the selected user and click Edit Resource
Access.

The Edit Resource Access dialog is displayed.

6. Click the Limit Resource Access toggle switch to enable RRP for the user.

7. Select the specific policy for the user from the Resource Restriction Policy drop-down.

8. Click Save Changes.

The Details page displays the updated permissions for the user.

Deleting Resource Restriction Policy for Role
To delete a resource restriction policy, complete the following steps:
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1. On the HPE GreenLake account home, click Manage.

The Manage Account page is displayed.

2. Click the Identity & Access card.

The Identity & Access page is displayed.

3. Click the Users card.

The Users page is displayed with the list of users assigned to the account.

4. Click the required user name to view details.

5. In the Roles section, click the ellipsis corresponding to Aruba Central On-Premises and select
Remove Role.

The remove confirmation dialog is displayed.

6. Verify that you want to remove the role assignment for the selected user and click the Remove
Role.

The RRP is unassigned to the role.

Managing Users and Roles
The functions such as creating roles and assigning it to users, providing users with authenticated access,
establishing access privileges based on permissions, and monitoring user activity are done in user
management. First, roles are created based on the application and view or edit permissions to the
resources. Then, users are created and roles are assigned.

Users are assigned roles by the administrators who govern the level of access to HPE GreenLake
account home and Aruba Central On-Premises application. A role refers to a logical entity used to
determine access to the application.

You can add users to the HPE GreenLake by sending an invitation. For more information see, Inviting
Users .

Inviting an user does not automatically grant the access to resources. Access is granted by assigning the role(s)
to a user or user group for a specific set of resources within a workspace.

You can view the information about users and the corresponding details using the Users card.
Managing users and user groups are done using Identity & Access. Assignment of roles to users or
user groups is also done through Identity & Access. For more information, see Managing User Identity
and Access.

User Roles for Aruba Central On-Premises
A role refers to a logical entity used for determining user access to devices and application services or
resources in Aruba Central On-Premises.

HPE GreenLake supports a set of built-in Aruba Central On-Premises roles with different privileges and
access permissions. It also allows configuring custom roles.

Access control for federated users is determined by the attributes set in the IdP.
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Predefined User Roles
HPE GreenLake account home allows you to assign the following built-in roles to Aruba Central On-
Premises users.

Role Privilege

Administrator This role has access to all the menu options
along with the monitoring and configuration
pages of the Aruba Central On-Premises app.

View Only This role has read-only access to the Aruba
Central On-Premises app.

View Edit Role This role has edit and view access to the Aruba
Central On-Premises app.
It allows users with this role to view the data
using the Aruba Central On-Premises WebUI or
APIs. The users with this role cannot perform
operations on the Aruba Central application
> Organization > Labels and Sites pages.

Operator This role has view and edit access to the guest
module in the Aruba Central On-Premises app.

Table 12: Predefined User Roles

Custom Roles with Resource Permissions
HPE GreenLake allows you to create custom roles and assign edit or view permissions to resources in
Aruba Central On-Premises. Resources can have sub-resources. A subresource is a resource that is
nested within another resource.

You can also block the user access to some resources or sub-resources in Aruba Central On-Premises.
To block access to a specific resource, you must remove both the edit and view permissions for that
resource. If a resource is blocked for a specific role, the corresponding pages are not displayed on the
WebUI.

HPE GreenLake allows setting permissions for the resources listed in the following table.

Resource Permission

AirGroup Can view, edit, or block user access to the AirGroup pages.

Device Profiling Can view, edit, or block user access to the Device Profiling pages and the
corresponding sub-resources:
n Device Profiling Application Settings
n Device Profiling Classified Devices
n Device Profiling Discovery Settings
n Device Profiling Generic Devices
n Device Profiling Reports
n Device Profiling User Classified Devices

Group Management Service Can view, edit, or block user access to the group management and group
scope pages.

Table 13: Resource Permissions
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Resource Permission

Install Manager Can view, edit, or block user access to the install manager pages.

Label Management Service Can view, edit, or block user access to the label management pages.

Net Insight Can view, edit, or block user access to the AI Insight pages.

NMS Service Can view, edit, or block user access to the Network Management services,
including:
n NMS Service Alerts and Events
n NMS Service Apprf
n NMS Service Configuration

o NMS Service Privileged Configuration
o NMS Service Configuration Variables
o NMS Group Level Access

n NMS Service Firmware
n NMS Service Troubleshooting

Other Applications Can view, edit, or block user access to other applications modules such as
notifications.

Reports Can view, edit, or block user access to view and create reports.

Site Management Service Can view, edit, or block user access to the site management pages.

UC Can view, edit, or block user access to the Unified Communications pages.

VisualRF Can view, edit, or block user access to the floor plans and RF heatmaps.

Inviting Users
You can add users to HPE GreenLake by sending an invitation. Use the Invite Users card to send the
invite link. A notification email is sent. The user must click the Accept Invite link received in the
notification email to navigate to the HPE GreenLake portal and create an account.

Inviting an user does not automatically grant the access to resources. Access is granted by assigning the role(s)
to a user or user group for a specific set of resources within a workspace.

You can access the Invite Users feature in the following HPE GreenLake pages:

n Quick Actions under Dashboard

n Quick Actions under Manage > Identity & Access

n Invite Users under Identity & Access > Users

To send the invite link, complete the following steps:

1. On the HPE GreenLake account home dashboard, click Send an invite on the Invite Users card.

Alternatively, you can also use the Invite Users card present under Quick Access on the
Manage > Identity and Access or Users page. The Invite User window is displayed.

2. Enter the email in Email Address.

3. From the HPE GreenLake Role drop-down list, select the role that you want to assign to the user.
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For information about roles, see User Roles for Aruba Central On-Premises. The following options
are available:

n Administrator

n View Only

n View Edit Role

n Operator

4. Click Send Invite.

A notification is sent the specified email address.

Managing User Identity and Access
The Identity & Access feature is used to send an invite link to the user, assign access to resources,
manage user roles, and view logs about the user activity.

The following actions are available on this page:

n Creating a Role

n Viewing User Details

n Deleting a User

n Viewing Audit Logs

Creating a Role
You can create a role in the following methods:

n Create New Role—Use this option to create a new role by identifying the permissions that are
required for the new role. This will involve determining the actions that users with this role need to
be able to perform.

n Duplicate Existing Role—Use this option to create a role by cloning an existing built-in or custom role
and then modifying it based on the requirement.

Creating a New Role
To create a new role, complete the following steps:

1. On the HPE GreenLake account home, click Manage.
2. On the Identity & Access card, click Roles & Permissions.

The Roles & Permissions page is displayed.

3. Click Create Role.

The Create Role dialog is displayed.

4. Select Create new role.
5. From the Application drop-down list, choose the required application that you want to grant

access.

The following options are available:
n HPE GreenLake
n Aruba Central On-Premises
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6. Click Next.
The Create Role page is displayed. Specify the following details to complete the role setup:

a. Add Name and Description—Add a name for the role and corresponding description and
click Next.

b. Add Aruba Central On-Premises Permissions—Add permissions to define specific access
to each resource. To select permissions for this role, specify the following:

i. Click Add Permissions for specifying the resources.

The Aruba Central On-Premises Permissions window is displayed.

ii. Click the right arrow corresponding to the required resource to add and select View or
Edit or both permissions.

iii. Click Add.

The permissions list of the selected resources is displayed with the defined permissions.

iv. Alternatively, to remove a permission, click the down arrow corresponding to the
permission and click the delete icon.

v. Click Next.

c. Review & Create—The role details are displayed with the specified permissions for the role.
Review the configuration details. Alternatively, to change the configuration, click the Modify
link.

7.1. Click Finish.

The Roles & Permission page is displayed with the confirmation message.

Duplicating an Existing Role
To create a role by duplicating the permissions of an existing role, complete the following steps:

1. On the HPE GreenLake account home, click Manage.
2. On the Identity & Access card, click Roles & Permissions.

The Roles & Permissions page is displayed.

3. Click Create Role.

The Create Role dialog is displayed.

4. Select Duplicate Existing role.
5. From the Application drop-down list, choose the required application to grant access.

The following options are available:
n HPE GreenLake
n Aruba Central On-Premises

6. From the Roles drop-down list, choose the required role to create a duplicate.

The roles are displayed based on the selected applications.

7. Click Next.
The Create Role page is displayed. Specify the following details to complete the role setup:

a. Add Name and Description—Change the name and description and click Next.
b. Add Aruba Central On-Premises Permissions—Retain or change the permissions defined

for each resource. To change the set permissions, specify the following:
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i. The permissions list is displayed, to remove a permission, click the down arrow
corresponding to the permission and click the delete icon.

ii. To add new, click Add Permissions.

The Aruba Central On-Premises Permissions window is displayed.

iii. Click the right arrow corresponding to the required resource to add and select View or
Edit or both permissions.

iv. Click Next.

c. Review & Create—The role details are displayed with the specified permissions. Review the
configuration details. Alternatively, to change the configuration, click the Modify link.

8.1. Click Finish.

The Roles & Permission page is displayed with the confirmation message.

Viewing User Details
To view the details of a role, complete the following steps:

1. On the HPE GreenLake top menu bar, click Manage.

The Manage Account page is displayed.

2. Navigate to Identity & Access > Users.

The Users page is displayed with the summary pane and the users list.

3. To filter the users list, click the corresponding card on the summary pane.

The summary pane displays the following cards:

n Total Users—This card is selected by default. The value on the card denotes the number of
users present for the selected workspace.

n Active Users—The value on the card denotes the number of users that are online.

n Inactive Users—The value on the card denotes the number of users that are offline.

n Unverified Users—The value on the card denotes the number of users that are not verified.

4.1. The users list is displayed with the following information:

n Name—Displays the name of the user.

n Email—Displays the email ID of the user.

n Status—Displays the verification status of the user.

n Platform Role—Displays the corresponding role of the user.

n Last Active—Displays the timestamp when the user for online last time.

n Ellipsis—Displays the ellipsis icon to click and perform the following actions :
o View Details—Select to view complete details of the user.
o Assign Role—Select to assign a role to the user.
o Delete—Select to delete the user.

5. To view details of the user, click the required user.

The Details page is displayed with the following information:
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n Username—The name of the user and the verification status.

n Actions—Click and select Delete User to delete this user profile.

n Details
o Email—The email ID of the user.
o Joined Date—The date when this user was added.
o Last Session—The timestamp of when this user was online the last time.

n Roles
o Assign Role—Click to assign a new role to the user.
o Application—The applications to which this user has access to.
o Role—The role assigned to user.
o Resource Access—The permission level for each application.
o Ellipsis—Displays the ellipsis icon to click and perform the following actions :

l Edit Resource Access—Select to view complete details of the user.
l Remove Role—Select to assign a role to the user.

Deleting a User
To delete a user profile, complete the following steps:

1. On the HPE GreenLake top menu bar, click Manage.

2. Navigate to Identity & Access > Users.

The Users page is displayed.

3. Select the user that you want to delete.

4. Click the ellipsis and select Delete User.
Alternatively, you can navigate to the Details page and click Delete User. The confirmation
message is displayed in the Delete User dialog.

Viewing Audit Logs
Logs are generated when a new user is created and an existing user is modified or deleted. It also
records the login and logout details of the users.

To view audit logs for the users, complete the following steps:

1. On the HPE GreenLake top menu bar, click Manage.

2. Click Audit Log.

The Audit Log page is displayed. The following details are available:

By default, only five columns are displayed. Click Edit Columns to select more columns.

n Account Type—Displays the type of account. For example, standalone.

n Category—Displays the resource accessed.

n Description—Displays the username and from where the user logged in.

n IP Address—Displays the IP address of the user.
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n Time—Displays the timestamp of the login and logout time.

n Username—Displays the username.

3. You can filter the audit logs using the following options:

n Application—Click the down arrow and select the required application to filter logs
corresponding to that application.

n Advanced Search—Click to filter the logs based on keyword search, category, description, IP
address, or time.

n Sorting—All columns allow sorting in ascending and descending order. Click the up arrow or
down arrow corresponding to the column name to sort accordingly.

Exporting Audit Logs
You can export the logs into CSV or PDF format.

To export logs, complete the following steps:

1. On the Audit Logs page, click Export Log.

The dialog box is displayed.

2. Select CSV or PDF format as required.

3. Click Continue.

The dialog box is displayed.

4. From the Table Entries section, select either Current Search Results or Entire Audit Log.

5. From the Table Columns section, select the required columns.

6. Click Save.

The log is exported in the selected format.

Assigning User Access (Assignments Page)
Use the Assign User Access card to assign roles to users in your team; these roles can be built-in roles
or custom roles that you define. The Assignments page is where you give access to the HPE GreenLake
applications.

Creating User Role Assignments
To assign roles to users, complete the following steps:

1. On the HPE GreenLake dashboard top menu, click Manage.

The Manage Account page appears.

2. On the Manage page, click the Identity & Access tile.

The Identity & Access page appears.

3. Click the Users tile.

The Users page displays a list of users in the account.

4. Select a user from the list: Click the user's row to display details, select the ellipsis, and click
ViewDetails.

The Details page appears.
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5. In the Roles section, click the ellipsis next to a user to display the available options.

Options include: Edit Resource Access and Remove Role.

6. Select the Edit Resource Access link.

The Edit Resource Access dialog appears.

7. Slide the Limit Resource Access toggle to the right to enable the RRP for this user.

8. Select the specific policy for the user from the Resource Restriction Policy drop-down.

9. Click SaveChanges.

The Details page displays the newly applied permissions for the user.

Creating a Group
Aruba Central supports creating groups and assigning devices to groups for the ease of configuration
and maintenance. For example, you can create a common group for APs that have similar configuration
requirements.

To create a group, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization.

By default, the Network Structure tab is displayed.

3. Click (+) New Group.

The Create New Group pop-up window opens.

4. Click the Groups tile.

The Groups page is displayed.

5. Expand a group from which you want to move devices to the selected group. For example,

expand the Unprovisioned Devices group, select the devices, and then click the Move
devices icon.

The Move Devices page is displayed.

6. Click (+) Add Group on the Groups table.

The Add Group page is displayed.

7. Enter a name for the group.

The group name can be a maximum of 32 single byte ASCII characters if you use the UI to create
the names. However, if you are using an NB API, the character limit increases to 128. A group
name supports alphanumeric characters and only "-", "_", and space as special characters.
System-defined group names such as “default”, “unprovisioned”, and “global” are not allowed in
group names.

By default, Aruba Central On-Premises enables the UI-based configuration. The template-based
configuration is displayed only when you select devices in the Add group page. Use the toggle button
to enable the Configure using templates.

8. Select device types that will be part of this group. A group can contain following devices:
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n Access points
n Controllers
n Switches

For detailed device combinations, refer to the Device Combinations.

9. Click Next.
By default the ArubaOS 8 architecture is applied for access points and controllers.

10. Select the check box for Make these the preferred group settings optionally to save the
architecture and persona settings of the current group for subsequent group creations.

11. Click Add Group.

You can also create a group that uses different provisioning methods for switch, IAP, device categories.
For example, you can create a group with template-based provisioning method for switches and UI-
based provisioning method for Instant APs and controllers.

For more information, see Groups.

Managing Devices and Subscriptions
The HPE GreenLake portal allows you to view, manage, and onboard all the devices in your workspace
using the Devices option on HPE GreenLake home page. The Devices > Inventory page provides a
summary of your device information along with a set of actions to manage all your devices and their
subscriptions.

If the device you purchased is not listed in your workspace, you can manually add the device.

This section includes the following topics:

n Onboarding Devices

n Managing Device Subscriptions

n Managing Device Profiles

n Assigning Devices to Groups

Onboarding Devices
The HPE GreenLake portal allows you to manually add devices to the inventory using the guided setup
wizard. You can view and manage all the devices in your account using the Devices option on HPE
GreenLake account home page. You can also use auto-provisioning to add and manage various SNMP
and HTTPS profiles for your devices.

You can manually add a device to your HPE GreenLake workspace by selecting the device type and
providing one of the following device details:

n MAC address, serial number, and part number

n .CSV file

n Device discovery using SNMP and HTTPS connection profiles

This section includes the following topics:
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n Adding Devices Using MAC Address, Serial Number, and Part Number

n Adding Devices Using .CSV File

n Adding Instant APs and Switches Using PSK

n Adding Mobility Controllers

n Viewing Devices

n Deleting a Device

Aruba Central On-Premises does not support onboarding of devices using Aruba Activate.

Adding Devices Using MAC Address, Serial Number, and Part Number
You can add devices to the inventory by entering the MAC address, serial number, and part number of
the devices on the HPE GreenLake account home page.

To add devices using the aforementioned options, complete the following steps:

1. In the HPE GreenLake account home page, click Devices > Inventory.

The Device Inventory page is displayed.

2. Click Add Devices.

The Add Devices page is displayed.

3. Under Ownership Type, select the Serial Number, MAC, Part Number radio button.
4. Enter the serial number, MAC address, and part number of the device.
5. Click Enter.
6. Click Next.
7. (Optional) In the next window, enter the tag details and click Next.
8. Click Finish.

The device is added to the inventory.

You can add up to 32 devices.

Adding Devices Using .CSV File
You can add multiple devices by creating and importing a .CSV file with mandatory information such as
the MAC address, part number, and serial number.

To bulk upload devices using a .CSV file, complete the following steps:

1. In the HPE GreenLake account home page, click Devices > Inventory.

The Device Inventory page is displayed.

2. Click Add Devices.

The Add Devices page is displayed.

3. Under Ownership Type, select the .CSV File radio button.
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4. Click Browse Files and add the .CSV file from your local directory.

The .CSV file must include column headers for MAC address, part number, and serial number. The .CSV
file can also include optional fields such as firmware version and IP address of the device.

5. Click Finish.

The devices from the .CSV file are added to the inventory.

Adding Instant APs and Switches Using PSK
Aruba Central On-Premises supports adding devices using a pre-shared key (PSK). If you want to add
Instant APs and switches to Aruba Central On-Premises, you must configure a shared secret key on the
DHCP server. When you add the same shared secret key in HPE GreenLake, the devices with the known
PSK string are added to the HPE GreenLake device inventory.

This section includes the following topics:

n Adding Instant APs Using PSK

n Adding Switches Using PSK

Adding Instant APs Using PSK
To add Instant APs using PSK with DHCP server, complete the following steps:

1. Configure the following parameters on the DHCP server to which the Instant APs connect:
n Option 60 with ArubaInstantAP.

For example,

option 60 text "ArubaInstantAP"

n Option 43 in the format <Group>:<Topfolder>:<folder1>,<Aruba-Central IP>,<shared
secret>.

For example,

option 43 text "3810_switch:top:default,100.100.100.10,secret_key"

Ensure that you provide only the IP address and not the host name.

2. In the HPE GreenLake account home page, click Devices > Auto-Provisioning.

The Provisioning Profiles page is displayed by default.

3. Click Add Key in the Pre-Shared Keys column.

The Create Pre-Shared Key pop-up window is displayed.

4. Configure the following parameters:

n Name—Enter a name for the pre-shared key.

n Pre-Shared Key—Enter the pre-shared key in hexadecimal or plain text string.

n Confirm Key—Re-enter the pre-shared key.
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5. Click Create.

The new profile name is created and listed in the Pre-Shared Keys column.

6. Reboot the Instant APs.

The Instant APs receive the IP address from the DHCP server and connect to Aruba Central On-
Premises.

Adding Switches Using PSK
To onboard switches using PSK, complete the following steps:

1. Configure the following parameters on the DHCP server:

Option 43 in the format <Group>:<Topfolder>:<folder1>,<Aruba-Central IP>,<shared secret>

Ensure that the switches are running factory default configuration.

2. In the HPE GreenLake account home page, click Devices > Auto-Provisioning.

The Provisioning Profiles page is displayed by default.

3. Click Add Key in the Pre-Shared Keys column.

The Create Pre-Shared Key pop-up window is displayed.

4. Configure the following parameters:

n Name—Enter a name for the pre-shared key.

n Pre-Shared Key—Enter the pre-shared key in hexadecimal or plain text string.

n Confirm Key—Re-enter the pre-shared key.

5. Click Create.

The new profile name is created and listed in the Pre-Shared Keys column.

6. Reboot the switches.

The switches receive the IP address from the DHCP server and connect to Aruba Central On-
Premises.

Adding Mobility Controllers
The HPE GreenLake account home page allows you to onboard and monitor controller clusters, the
Mobility Conductor setup, and the conductor and local controller setup. You can use auto-provisioning
to add and manage various SNMP and HTTPS profiles for your devices.

When you add a conductor controller or a Mobility Conductor, HPE GreenLake discovers all the
associated controllers and campus APs, and adds them to the device inventory.

Aruba Central On-Premises does not support configuring controllers. To configure and deploy controllers, use
the ArubaOS WebUI and CLI.

Before You Begin
Ensure that you have completed the following procedures:

n Configuring Parameters on the Controller

n Configuring SNMP and HTTPS Connection Profiles
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Configuring Parameters on the Controller

Before adding controllers to Aruba Central On-Premises, you must configure few parameters on the
controller. You must also configure SNMP and HTTPS connection profiles on the :

n Management Server profile—The Aruba Central On-Premises server must be configured as a
management server on the controller.

n Advanced Monitoring Messages—Enable AMON for communication between the Aruba Central On-
Premises server and controller. When AMON is enabled on the controller over UDP 8211, the
controller periodically sends information about user sessions, AP and client association, and other
such information required for managing and monitoring controllers on Aruba Central On-Premises.

n Syslog Messages and SNMP Traps—Although AMON is a preferred option for polling data from
controllers, to obtain data pertaining to AP lists, you may want to enable SNMP, and configure SNMP
traps and syslog server for logging system events.

n Websocket connection—To enable controller firmware upgrade and troubleshooting from Aruba
Central On-Premises, ensure that the Aruba Central On-Premises server URL and IP address are
configured on the controllers running ArubaOS 6.5.3.6 or later versions.

For more information on configuring controllers, see ArubaOS 8.x User Guide.

Controllers running ArubaOS 6.5.4.8 version do not support Websocket connection, due to which Aruba
Central On-Premises cannot onboard these controllers.

Configuring SNMP and HTTPS Connection Profiles

This section describes the procedure for adding controllers using SNMP and HTTPS connection profiles. You
can also onboard controllers using their MAC address, serial number, or part number. For more information,
see Adding Devices Using MAC Address, Serial Number, and Part Number.

To configure connection profiles for adding controllers, complete the following steps:

1. In the HPE GreenLake account home page, click Devices > Auto-Provisioning.

The Provisioning Profiles page is displayed by default.

2. To add an SNMP connection profile, complete the following steps:

a. Click Add SNMP Profile in the SNMP column.

The Create SNMP Profile pop-up window is displayed.
b. Configure the following parameters:

n Name—Enter a name for the SNMP Profile.

n SNMP Version—Select v2 or v3 from the drop-down list.

n Community String—Enter the pre-shared key in hexadecimal or plain text string.
c. Click Create.

The new profile name is created and listed in the SNMP column.

3. To add an HTTPS connection profile, complete the following steps:

a. Click Add HTTPS Profile in the HTTPS column.

The Create HTTPS Profile pop-up window is displayed.
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b. Configure the following parameters:

n Name—Enter a name for the HTTPS Profile.

n User—Enter a username for HTTPS authentication.

n Password—Enter a password for HTTPS authentication.

n Confirm Password—Re-enter the password for HTTPS authentication.
c. Click Create.

The new profile name is created and listed in the HTTPS column.

For more information on configuring the pre-defined device profiles, see Managing Device Profiles .

Adding a Controller Using Device Discovery
Before you add a new controller using the device discovery method, you must configure the SNMP and
HTTPS profiles as described in Configuring SNMP and HTTPS Connection Profiles

To add controllers using device discovery, complete the following steps:

1. In the HPE GreenLake account home page, click Devices > Inventory.

The Device Inventory page is displayed.

2. Click Add Devices.

The Add Devices page is displayed.

3. Under Ownership Type, select the Device Discovery radio button.
4. Configure the following parameters:

n Name—Enter a name for the controller.

n IP Address—Enter the IP address of the controller.

You can find the controller IP address by issuing the show controller-ip command.

n SNMP Profile—From the drop-down list, select the SNMP profile created in Configuring SNMP
and HTTPS Connection Profiles.

n HTTPS Profile—From the drop-down list, select the HTTPS profile created in Configuring
SNMP and HTTPS Connection Profiles.

5. Click Finish.

The controller is listed in the Device Inventory page.

Viewing Devices
The HPE GreenLake account home page allows you to view all your devices (APs, switches, and
controllers) in one place. You can view detailed information about a device, search for a particular
device, or view the subscription status of your devices.

To view the devices provisioned in your HPE GreenLake account, navigate to the Devices > Inventory
option to view the Device Inventory page. The Device Inventory page lists the total number of devices
including APs, switches, and controllers in the inventory.

The tiles above the Device Inventory table display the total number of devices, assigned and
subscribed devices, and devices requiring subscription in the inventory. To see a list of devices in each
category, click the relevant card.

The following table describes the columns displayed in the Device Inventory table.
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Fields Description

Serial Number The device serial number.

Model The hardware model of the device.

MAC Address The MAC address of the device.

Application The application assigned to the device.

Subscription Tier The subscription tier assigned to the device.

Expiration Date The subscription expiration date of the device.

NOTE: The subscription assigned to a device expires individually. If you have multiple
devices with different expiration date, the device(s) are unsubscribed according to the
device's expiration date(s).

Tags The tags assigned to the device.

Deleting a Device
To delete a device from the inventory, you must remove the device subscriptions first and then delete
the device.

Ensure that the Devices > Auto-Subscribe option is disabled before removing device subscriptions. This
prevents the devices from being licensed again automatically.

To delete a device from the inventory, complete the following steps:

1. In the HPE GreenLake account home page, click Devices > Inventory.

The Device Inventory page is displayed.

The Device Inventory page displays the devices that have been assigned, subscribed, as well as
the devices that require subscriptions.

2. Select the check box for the device that you want to delete.

3. From the Actions drop-down list, select Detach Subscription.

The Detach Subscription pop-up window is displayed.

4. Click Detach Subscription and then click Close in the pop-up window.

The Device Inventory page now displays the detached devices in the inventory.

Require Subscriptions card.

5. Select the check box for the detached device from the Device Inventory page.

6. From the Actions drop-down list, select Delete.

The device is removed from the inventory.

Managing Device Subscriptions
The HPE GreenLake portal allows you apply subscriptions to the devices that are onboarded in your
workspace. You can assign devices to applications, remove device assignments, as well as apply and
remove device and service subscriptions.

This section includes the following topics:
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n Applying Subscriptions to Devices

n Adding Device Subscription Keys to your Workspace

n Removing Subscriptions from Devices

n Enabling Automatic Assignment of Subscriptions

Applying Subscriptions to Devices
To activate and use the devices that you onboarded to your workspace, you must assign subscription to
your devices.

To apply subscription to your devices, complete the following steps:

1. In the HPE GreenLake account home page, click Devices > Inventory.

The Device Inventory page is displayed.

The Device Inventory page displays the devices that have been assigned, subscribed, as well as
the devices that require subscriptions.

2. Select the check box for the device to which you want to apply the subscription.

You can also click the Require Subscriptions tile at the top of the inventory list, and select the
required device from the list.

3. From the Actions drop-down list, select Apply Subscription.

The Apply Subscriptions to Device page is displayed.

4. Click the Apply Subscriptions link to apply subscriptions keys to the selected device.

The Apply Subscriptions to Devices pop-up window is displayed.

5. From the Select Subscription Tier drop-down list, select a subscription tier.

6. Select the check box for the Subscription Key section to assign the associated key to the listed
device.

7. Click Apply Subscriptions.

8. Click Finish and then click Close on the confirmation box.

The Devices page displays the updated device details with the subscription details in the Device
Inventory list.

Adding Device Subscription Keys to your Workspace
You must add a device subscription key to your workspace irrespective of adding a specific device.

To apply device subscription keys to your workspace, complete the following steps:

1. In the HPE GreenLake account home page, click Manage.

The Manage Account page is displayed.

2. Click the Subscriptions card.

The Device Subscriptions page is displayed.

The Device Subscriptions section displays all your device subscription details including subscription
key, device type, subscription tier, number of available subscriptions, and subscription dates in a table.
From this page, you can also add device subscription keys to your inventory.
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3. Click Add Device Subscription.

The Add Device Subscription pop-up window is displayed.

4. Enter the subscription key that you received with your device or in the purchase email.

5. Click Submit.

6. (Optional) Continue adding subscription keys per your requirement.

The subscriptions are listed under Device Subscriptions, and are available to assign to devices in
your workspace.

Removing Subscriptions from Devices
You can remove subscriptions from devices by using either the Devices tab or the Manage tab.

Ensure that the Devices > Auto-Subscribe option is disabled before removing device subscriptions. This
prevents the devices from being licensed again automatically.

This section includes the following topics:

n Removing Device Subscriptions Using the Devices Tab

n Removing Device Subscriptions Using the Manage Tab

Removing Device Subscriptions Using the Devices Tab
To remove device subscriptions using the Devices tab, complete the following steps:

1. In the HPE GreenLake account home page, click Devices > Inventory.

The Device Inventory page is displayed.

The Device Inventory page displays the devices that have been assigned, subscribed, as well as
the devices that require subscriptions.

2. Click the Assigned & Subscribed card.

The inventory list displays all the devices that have been assigned and subscribed.

3. Select the check box for the devices that you want to modify.

4. From the Actions drop-down list, select Detach Subscription.

The Detach Subscription pop-up window is displayed.

5. Click Detach Subscription and then click Close in the pop-up window.

The Device Inventory page displays the list of detached devices .

You can also click the Require Subscriptions card to view the list of detached devices requiring
subscriptions.

Removing Device Subscriptions Using the Manage Tab
You can also remove subscriptions from devices in the Subscriptions page. Follow these steps:

1. In the HPE GreenLake account home page, click Manage.

The Manage Account page is displayed.

2. Click the Subscriptions card.

The Device Subscriptions page is displayed.

3. Click on a subscription key to view its details.
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The Subscription Information page is displayed that shows a list of subscribed devices for the
selected subscription key and tier.

4. Under Subscribed Devices table, select the check box for the devices that you want to modify.

5. From the Actions drop-down list, select Detach Devices.

The Detach Devices pop-up window is displayed.

6. Click Detach.

The Device Inventory page displays the list of detached devices.

You can also click the Require Subscriptions card to view the list of detached devices requiring
subscriptions.

Enabling Automatic Assignment of Subscriptions
The Auto-Subscribe option enables automatic assignment of available licenses for all of the devices
(switches, gateways, and APs) available in the inventory. When you enable this option, you must specify
the preferred subscription tier as either Foundation or Advanced.

To enable automatic assignment of subscriptions, complete the following steps:

1.1. In the HPE GreenLake account home page, click Devices > Auto-Subscribe.

The Auto-Subscribe page is displayed.

2. Click Add.

The Set Up Auto-Subscribe pop-up window is displayed.

3. From the Device Type drop-down list, select one of the following options:

n Access Points

n Switches

n Controllers

4. From the Subscription Tier drop-down list, select either Foundation or Advanced for the device
type that you selected in step on page 63.

Updating the subscription tier may affect your auto-subscribe configuration. Make sure you have
enough subscription seats to cover your devices.

5. Click Configure Device.

A confirmation message is displayed and the newly added auto-subscribe option is listed on the
Auto-Subscribe page.

When a subscription assigned to a device expires or is cancelled, HPE GreenLake checks for the available
subscription tokens in your account and assigns the lengthiest available subscription token to the device. If
your account does not have an adequate number of subscriptions, you may have to manually assign
subscriptions to as many devices as possible. To view the subscription utilization details and the number of
subscriptions available in your account, go to Devices> Auto-Subscribe and select Edit to view the available
seats for each device type.

As the device subscription expiration date approaches, users receive expiry notifications. To view expiration
dates, click Subscriptions> Device Subscriptions to view the expiration date for each subscription.
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Adding Subscription for Offline-Mode Installation
Aruba Central On-Premises application supports offline deployments. An offline-mode installation is
required for security reasons. In offline deployments, the subscription is added by uploading it as a file
to Aruba Central On-Premises. First, you must activate the license using the account ID on the Aruba
Support Portal and generate the subscription. Then, the subscription is sent to your email ID, which you
can download and add.

When the Installation Type is set to offline, Aruba Central On-Premises displays the option to upload
the license file.

Aruba Technical Support handles the generation of offline key in order to restrict the usage to only one
installation per offline key.

Copying the Account ID
Copy the account ID on the Manage Account page and use that to activate the subscription on Aruba
Support Portal.

To copy the account ID, complete the following steps:

1. Login to Aruba Central On-Premises app.

2. Click Account Home.

The HPE Greenlake account home page is displayed.

3. Click Manage.

The Manage Account page is displayed.

4. Copy the Account ID displayed on the Aruba Central On-Premises card.

5. Paste the account ID in the Host ID box to activate the license.

After activation, the subscription key is sent to the registered email ID. You can download and use
that file in offline installations.

Aruba recommends to contact Aruba Technical Support for generating the key.

Adding the Subscription
After the key is activated on the Aruba Support Portal, the subscription is sent to registered email ID.
Use that file to upload into Aruba Central On-Premises.

To add the subscription for an offline installation, complete the following steps:

1. Login to Aruba Central On-Premises app.

2. Click Account Home.

The HPE Greenlake account home page is displayed.

3. Click Manage.

The Manage Account page is displayed.

4. Select the Subscriptions card.
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Alternatively, you can click Manage Subscriptions on HPE Greenlake account home page. The
Device Subscriptions page is displayed.

5. On the Device Subscriptions page, click Add Device Subscription.

The Add Device Subscription pop-up is displayed.

6. Click Select File and upload the license.

7. Click Add Subscription.

The subscription is successfully added.

The details or format of the license file must not be changed. If it is modified, an invalid key error is displayed
when it is uploaded to Aruba Central On-Premises.

Figure 3 Format of the License File

Managing Device Profiles
You can use auto-provisioning to add and manage various SNMP and HTTPS profiles as well as pre-
shared keys for your devices. These pre-defined profiles and keys make it easier to manage device
onboarding during the device discovery process.

Setting up a New Profile
To set up a new profile for the device, you must complete the following steps to configure the pre-
defined profiles and keys:
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1. Adding an SNMP Profile

2. Adding an HTTPS Profile

3. Adding a Pre-Shared Key

Adding an SNMP Profile
To add an SNMP profile for your device, complete the following steps:

1. In the HPE GreenLake account home page, click Devices > Auto-Provisioning.

The Provisioning Profiles page is displayed by default.

2. Click Add SNMP Profile in the SNMP column.

The Create SNMP Profile pop-up window is displayed.

3. Configure the following parameters:

n Name—Enter a name for the SNMP Profile.

n SNMP Version—Select v2 or v3 from the drop-down list.
o If you select v3, you must also configure the following authorization credentials:

l SNMPv3 Username—Enter a name of the SNMPv3 user.
l SNMPv3 Auth Protocol—From the drop-down list, select MD5 or SHA as the

authentication mode to provide secure access to the user.
l Auth Password—Enter a password for SNMPv3 authentication.
l Confirm Auth Password—Re-enter the password for SNMPv3 authentication.
l SNMPv3 Privacy Protocol—From the drop-down list, select AES or DES as the privacy

mode to provide secure access to the user.
l Privacy Password—Enter a password for SNMPv3 privacy protocol.
l Confirm Privacy Password—Re-enter the password for SNMPv3 privacy protocol.

4. Click Create.

The new profile name is created and listed in the SNMP column.

Adding an HTTPS Profile
To add an HTTPS profile for your device, complete the following steps:

1. In the HPE GreenLake account home page, click Devices > Auto-Provisioning.

The Provisioning Profiles page is displayed by default.

2. Click Add HTTPS Profile in the HTTPS column.

The Create HTTPS Profile pop-up window is displayed.

3. Configure the following parameters:

n Name—Enter a name for the HTTPS Profile.

n User—Enter a username for HTTPS authentication.

n Password—Enter a password for HTTPS authentication.

n Confirm Password—Re-enter the password for HTTPS authentication.
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4. Click Create.

The new profile name is created and listed in the HTTPS column.

The minimum character length for HTTPS profile is 8 characters.

Adding a Pre-Shared Key
To create a pre-shared key, complete the following steps:

1.1. In the HPE GreenLake account home page, click Devices > Auto-Provisioning.

The Provisioning Profiles page is displayed by default.

2. Click Add Key in the Pre-Shared Keys column.

The Create Pre-Shared Key pop-up window is displayed.

3. Configure the following parameters:

n Name—Enter a name for the pre-shared key.

n Pre-Shared Key—Enter the pre-shared key in hexadecimal or plain text string.

n Confirm Key—Re-enter the pre-shared key.

4. Click Create.

The new profile name is created and listed in the Pre-Shared Keys column.

Assigning Devices to Groups
You can assign devices to groups for configuration, monitoring, and management purposes. A group is
a primary configuration element that acts like a container. In other words, a group is a subset of one or
several devices that share common configuration settings. For example, you can create a common
group for Branch Gateways or Instant APs that have similar configuration requirements.

To assign a device to a group from the Device Preprovisioning page, complete the following steps:

The following procedure is only for assigning groups to the devices that are connected for the first time. The
group management actions like moving devices between groups, or moving devices from unprovisioned group
to other groups is done on the Groups page. For more information, see Managing Groups.

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization.

By default, the Network Structure tab is displayed.

3. Click the Device Preprovisioning tile.

The Device List table is displayed. The Device List table lists the total number of devices in the
inventory.

4. Select the device(s) which you want to move to a selected group. You can select and move up to
50 devices at a time.

If the selected device is already connected to Aruba Central On-Premises, the Move devices option
will not be available for the device.
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5. Click the Move devices icon.

The Assign Group page is displayed.

6. Select the Destination Group from the drop-down list.

You can assign only particular device type for which the group is created. For example, if a group is
created for Access Points only, then only Access Points can be assigned to that group. You cannot
assign other device types to it.

7. Click Move.

The selected device(s) are moved to the destination group. These devices will adopt the
destination group configuration.

For every device pre-provisioning operation, a warning pop-up is displayed to check the audit trail log
for the status. If you are assigning the devices in bulk, ensure to check the audit trail to confirm if the all
devices are successfully assigned and reason for the rejected devices.

To assign a device to a group from the Groups page, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization.

By default, the Network Structure tab is displayed.

3. Click the Groups tile.

The Groups page is displayed.

4. Expand a group from which you want to move devices to the selected group. For example,
expand the Unprovisioned Devices group, select the devices, and then click the Move
devices icon.

The Move Devices page is displayed.

You can assign only particular device type for which the group is created. For example, if a group is
created for Access Points only, then only Access Points can be assigned to that group. You cannot
assign other device types to it.

5. Select the Destination Group from the drop-down list.
6. Click Move.

The selected devices are moved to the destination group. These devices will adopt the destination
group configuration.

Assigning Labels
In Aruba Central, assigning Sites and Labels is an optional step. Labels refer to the tags attached to a
device provisioned in the network. You can use labels for tagging devices to a specific area in a physical
location, to an owner or a specific branch, or a business unit. You can use these labels as filters to
monitor branch and device health, and generating reports.
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To assign a label to a device, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization.

By default, the Network Structure tab is displayed.

3. Click the Labels tile.

The Manage Labels page is displayed.

4. Locate the label to which you want to assign a device. You can also create a new label by clicking
Add Label and providing a label name.

5. In the table that lists the labels, you can perform one of the following actions:
n Click All Devices to view all devices.
n Click Unassigned to view all the devices that are not assigned to any labels.

6. Select Unassigned.

A list of devices that are not assigned to any label is displayed.

7. Select one or several devices from the list of devices.
8. Drag and drop the selected devices to a specific label.

A pop-up window opens and prompts you to confirm the label assignment.

9. To confirm the assignment, click Yes.

For more information, see Labels and How to Manage Them.

Assigning Sites
In Aruba Central, assigning Sites and Labels is an optional step. A site in Aruba Central refers to a
physical location where a set of devices are installed; for example, campus, branch, or a venue. You can
create a branch or campus site; for example Branch A or Campus A, for a specific geographical location
and assign devices to it. You can use these sites as filters for viewing your deployment topology,
monitoring network and device health.

To assign devices to a site complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization.

By default, the Network Structure tab is displayed.

3. Click the Sites tile.

The Manage Sites page is displayed.

4. Under Manage Sites, locate the site to which you want to assign a device. You can also add a new
site by clicking (+)New Site and providing details, such as site name and address.

5. To view devices that are not assigned to any site, click Unassigned.
6. Select one or several devices from the list of devices.
7. Drag and drop the devices to the site on the left.

A pop-up window opens and prompts you to confirm the site assignment.

8. To confirm the assignment, click Yes.

For more information, see Managing Sites.
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Connecting Aruba APs to Aruba Central On-Premises
The Aruba IAPs have the ability to automatically provision themselves and connect to Aruba Central On-
Premises once they are powered on.

To provision IAP, complete the following steps:

1. Connect your IAP to the provisioning network through PSK onboarding.
2. Wait for the device to obtain an IP address through DHCP.
3. Observe the LED indicators. For more information, refer to the AP Installation Guide.

When an IAP identifies Aruba Central On-Premises as its management entity, it connects to Aruba
Central On-Premises and shows up as a connected device in Aruba Central On-Premises.

Adding an Access Point
You can now assign the devices that you want to manage using Aruba Central On-Premises on the HPE
GreenLake account home. To manage devices from Aruba Central On-Premises, trial users must
manually add the devices to the device inventory in HPE GreenLake account home . For more
information about assigning devices, see Managing Devices and Subscriptions.

Connecting Aruba Switches to Aruba Central
The Aruba switches can automatically provision themselves and connect to Aruba Central once they are
powered on. The switches support zero-touch provisioning (ZTP) using which devices obtain the
IP address in option 43 from the DHCP server.

To provision Switches, complete the following steps:

1. Connect your switches to the provisioning network.
2. Wait for the device to obtain an IP address through DHCP.
3. Observe the LED indicators. For more information, refer to the Switch Installation Guide.

n If the device is in the factory default configuration, you must manually add either the serial
number, MAC address, or part number of the switch in Aruba Central On-Premises for the
switch to connect to Aruba Central On-Premises.

n If the device has preconfigured configuration, you must first create a backup of the
configuration, then reset the switch using the erase all zeroize command in the CLI. This
initiates ZTP on the switch, enabling the switch to obtain the IP address from the option 43
sent by the DHCP server and then connect to Aruba Central On-Premises.

n When a Switch identifies Aruba Central as its management entity, it connects to Aruba Central
and shows up as a connected device in Aruba Central.

n If the Switch is running a software version that is not compatible with Aruba Central, upgrade
the Switch to a supported software version and wait for it to connect to Aruba Central.

Adding a Switch
You can now add the devices that you want to manage using Aruba Central On-Premises on the HPE
GreenLake account home. To manage devices from Aruba Central On-Premises, trial users must
manually add the devices to the HPE GreenLake account home. For more information about adding
devices, see Managing Devices and Subscriptions.
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Configuring Communication Ports
Most of the communication between devices on the remote site and Aruba Central server is carried out
through HTTPS (TCP 443). However, verify if the ports listed in the following table that are open to allow
the Aruba Central server and the managed devices to communicate over a network firewall.

Source
IP/Network Destination IP/Network Destination

Port
Protocol Purpose

Inbound Ports Traffic

Administrative
workstation IP
address

Aruba Central On-Premises cluster IP
address

443 TCP, HTTPS To access and
manage Aruba
Central On-
Premises WebUI.

Administrative
workstation IP
address

All Aruba Central On-Premises node IP
address

4343 TCP, HTTPS To access the
Aruba Central On-
Premises setup
wizard for
installation.

Device IP
address

Aruba Central On-Premises cluster IP
address

443 TCP, HTTPS For HTTPS and
WebSocket
communication
between Aruba
Central On-
Premises and
managed devices.

Device IP
address

Aruba Central On-Premises cluster IP
address

8211 UDP,
AMON

To receive AMON
messages and view
data for controllers
in the Aruba
Central On-
Premises
monitoring
dashboard.

Switch IP
address

Aruba Central On-Premises cluster IP
address

8888 TCP, HTTP For HTTP-based
firmware image
download for CX
and PVOS switches.

Outbound Ports Traffic

All Aruba
Central On-
Premises node
IP address

SMTP server 25, 456, or
587

TCP, SMTP Dependent on the
SMTP configuration
for alerts, reports,
and Aruba Central
On-Premises
account
registration.

The following table provides information on the various domain names and ports for Aruba Central On-
Premises.
Table 14: Domain Names and Ports for Aruba Central On-Premises
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Source
IP/Network Destination IP/Network Destination

Port
Protocol Purpose

All Aruba
Central On-
Premises node
IP address

NTP server 123 UDP, NTP To access user-
configurable NTP
server for clock
synchronization.
Default is
ntp.ubuntu.com.

All Aruba
Central On-
Premises node
IP address

Device IP address 161 UDP, SNMP For SNMP and
traps.

All Aruba
Central On-
Premises node
IP address

Device IP address 162 UDP, SNMP For SNMP and
traps.

All Aruba
Central On-
Premises node
IP address

Arubacontroller IP address 4343 TCP, HTTPS For device
bootstrap to
controllers.

All Aruba
Central On-
Premises node
IP address

nexus2.airwave.com 22 TCP, SSH For Aruba Central
On-Premises
support connection
to TAC.

All Aruba
Central On-
Premises node
IP address

coreupdate.central.arubanetworks.co
m

443 TCP, HTTPS To check and
download Aruba
Central On-
Premises software
for automatic
upgrades.

All Aruba
Central On-
Premises node
IP address

*.quay.io 443 TCP, HTTPS To check and
download Aruba
Central On-
Premises software
for automatic
upgrades.

All Aruba
Central On-
Premises node
IP address

maps.googleapis.com 443 TCP, HTTPS To translate
address and map
latitude/longitude.

All Aruba
Central On-
Premises node
IP address

https://enterpriselicense.hpe.com 443 TCP, HTTPS For Aruba Central
On-Premises
license
enforcement.

Administrative
workstation IP
address

api.mapbox.com 443 TCP, HTTPS To view maps in
Aruba Central On-
Premises WebUI.
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Source
IP/Network Destination IP/Network Destination

Port
Protocol Purpose

Administrative
workstation IP
address

d1c50u1zbkqmph.cloudfront.net 443 TCP, HTTPS For Aruba Central
On-Premises
WebUI static
content access
from CDN.

Administrative
workstation IP
address

help.arubanetworks.com 443 TCP, HTTPS To access Aruba
Central On-
Premises User
Guide from Aruba
Central On-
Premises WebUI.

The source port is always dynamic (random) for both inbound and outbound traffic.

The Aruba appliance opens multiple ports. Aruba recommends that you host the Aruba appliance behind a
firewall.

Verifying Device Configuration Status
Aruba Central provides an audit dashboard for reviewing configuration changes for the devices
provisioned in UI and template groups. The Configuration Audit menu option under Manage >
Devices allows you to view the configuration template errors, configuration sync, and device-level
configuration overrides.

Viewing Configuration Audit Page
n To access the Configuration Audit page for APs, complete the following steps:

a. In the Aruba Central On-Premises app, use the filter bar to select a group or device.
b. Under Manage > Devices > Access Points.

c. Click the configuration icon and click Show Advanced.
d. Click Configuration Audit.

n To access the Configuration Audit page for switches, complete the following steps:
a. In the Aruba Central On-Premises app, use the filter bar to select a group or device
b. Under Manage > Devices > Switches.

c. Click the configuration icon and click Show Advanced.
d. Click Configuration Audit.
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Configuration Synchronization Errors
The devices managed by Aruba Central On-Premises receive configuration changes from Aruba Central
On-Premises. Occasionally, an Aruba Central On-Premises-managed device may fail to receive a
configuration change from Aruba Central On-Premises. Such instances are marked as Failed changes in
the Configuration Audit dashboard. If the condition persists, contact Aruba Technical Assistance.

Local Overrides
In Aruba Central On-Premises, devices are assigned to groups that serve as the primary configuration
elements. Occasionally, based on the network provisioning requirements, the administrators may need
to modify the configuration of a specific device in a group. As these modifications override the
configuration settings that the device has inherited from the group, Aruba Central On-Premises marks
these as local overrides.

Viewing Status for a Template Group
On selecting a template group, the Configuration Audit page displays the options listed in the
following table:

Data Pane
Content Description

Template Errors Provides details of the number of devices with template errors for the selected template
group.
Devices deployed in the template group are provisioned using configuration templates. If
there are errors in the templates or variable definitions, the configuration push to the
devices fails. Aruba Central On-Premises records such failed instances as template errors
and displays these errors on the Configuration Audit page.
To view a complete list of errors, click View Template Errors. The Template Errors
window allows you to view and resolve the template errors issues (if any) for the devices
in the group.

Configuration
Status

Provides details of the number of devices with configuration sync errors for the selected
template group.

To view the configuration sync errors, click View Details. The Configuration Sync Issues
window is displayed with the following tabs:

n Not In Sync Configuration—Displays the configuration changes that are not
synched with the switch.
n Device Running Configuration—Displays the running configuration on the switch.

To resolve the configuration sync errors, click Re-Sync Configuration. Aruba Central On-
Premises will attempt to synchronize the configuration with the switch again. Click Yes in
the confirmation window. To check whether the configuration was synchronized and
pushed to the switch, see the Audit Trail page.

Group & Device
Modes

Allows you to view and edit devices that are set to managed or monitored operation
mode.

n Managed Mode Devices—Click the View & Edit link. The Managed Mode
Devices window is displayed with the list of devices operating in the managed mode.
To change the device operation mode to monitored, click Change to Monitor Mode.
n Monitored Mode Devices—Click the View & Edit link. The Monitored Mode
Devices window is displayed. To change the device operation mode to managed, click
Change to Managed Mode.

Table 15: Configuration Audit Status for a Template Group
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Data Pane
Content Description

Configuration
Backup & Restore

Allows you to create a backup of templates and variables applied to the devices in the
template group. .

n New Configuration Backup—Allows you to create a new backup of templates and
variables applied to the devices in the template group.

All Devices The All Devices table provides the following device information for the selected group:
n Name—The name of the device.
n Type—The type of the device.
n Auto Commit—The status of the auto commit state for all the devices within the
group.
n Config Sync—Indicator showing configuration sync errors.
n Template Error—Indicator showing configuration template errors for the devices
deployed in template groups.

Table 15: Configuration Audit Status for a Template Group

Viewing Status for Devices Assigned to a Template Group
On selecting a device that is provisioned in a template group, the Configuration Audit page displays
the options listed in the following table:

Data Pane
Content Description

Template Applied Displays the template that is currently applied to the selected device.

Template Errors Displays the number of template errors for the selected device. To view a complete list of
errors, click View Template Errors.

Configuration
Status

Displays the configuration sync errors for the selected device.

To view the configuration sync errors, click View Details. The Configuration Sync Issues
window is displayed with the following tabs:

n Not In Sync Configuration—Displays the configuration changes that are not
synched with the switch.
n Device Running Configuration—Displays the running configuration on the switch.

To resolve the configuration sync errors, click Re-Sync Configuration. Aruba Central will
attempt to synchronize the configuration with the switch again. Click Yes in the
confirmation window. To check whether the configuration was synchronized and pushed
to the switch, see the Audit Trail page.

Config
Comparison Tool

Allows you to view the difference between the current configuration (Device Running
Configuration) and the configuration that is yet to be pushed to the device (Attempted
Configuration).
To view the running and attempted configuration changes side by side, click View.

Group & Device
Modes

Allows you to view and edit devices that are operating in the managed or monitored
mode.

n Managed Mode Devices—Click the View & Edit link. The Managed Mode
Devices window is displayed with the list of devices operating in the managed mode.
To change the device operation mode to monitored, click Change to Monitor Mode.
n Monitored Mode Devices—Click the View & Edit link. The Monitored Mode
Devices window is displayed. To change the device operation mode to managed, click
Change to Managed Mode.

Table 16: Configuration Audit Status for Devices in Template Groups
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Viewing Configuration Status for a UI Group
On selecting a UI group, the Configuration Audit page displays the options listed in the following table:

Data Pane
Content Description

Configuration
Status

Displays the number of devices with configuration sync errors for the selected UI group.

To view the configuration sync errors, click View Details. The Configuration Sync Issues
window is displayed with the following tabs:

n Not In Sync Configuration—Displays the configuration changes that are not
synched with the switch.
n Device Running Configuration—Displays the running configuration on the switch.

To resolve the configuration sync errors, click Re-Sync Configuration. Aruba Central will
attempt to synchronize the configuration with the switch again. Click Yes in the
confirmation window. To check whether the configuration was synchronized and pushed
to the switch, see the Audit Trail page.

Local Overrides Displays the number of devices with local overrides. To view a complete list of overrides,
click the Manage Local Overrides link. The Local Overrides window is displayed.

n To preserve the overrides, click Close.
n To remove the overrides, select the group name with local override, click Remove,
and click OK.

All Devices The All Devices List table provides the following device information for the selected
group:

n Name—The name of the device.
n Type—The type of the device.
n Auto Commit—The status of the auto commit state for all the devices within the
group.
n Config Sync—Indicator showing configuration sync errors.
n Local Override—Indicator showing configuration overrides for the devices
deployed in UI groups.

Table 17: Configuration Audit Status for a UI Group

Viewing Configuration Status for Devices Assigned to a UI Group
On selecting a device assigned to a UI group, the Configuration Audit page displays the options listed
in the following table:

Data Pane
Content Description

Configuration
Status

Displays the number of devices with configuration sync errors for the selected device.

To view the configuration sync errors, click View Details. The Configuration Sync Issues
window is displayed with the following tabs:

n Not In Sync Configuration—Displays the configuration changes that are not
synched with the switch.
n Device Running Configuration—Displays the running configuration on the switch.

Table 18: Configuration Audit Status for a Device Assigned to a UI Group
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Data Pane
Content Description

To resolve the configuration sync errors, click Re-Sync Configuration. Aruba Central will
attempt to synchronize the configuration with the switch again. Click Yes in the
confirmation window. To check whether the configuration was synchronized and pushed
to the switch, see the Audit Trail page.

Local Overrides Displays the number of local overrides. To view a complete list of overrides, click Manage
Local Overrides.
The Local Overrides window is displayed. The overrides are grouped based on the
features that are configured in the UI and are displayed as drop-down sections. For
example, all overrides for IGMP are listed under a separate drop-down with the heading
IGMP.

n To preserve the overrides, click Close.
n To remove the overrides, click Remove, and click OK.

Table 18: Configuration Audit Status for a Device Assigned to a UI Group

Device Replacement
Aruba Central supports device replacement workflows for the following types of Aruba devices:

n Access Points—For more information about Instant APs replacement workflows, see Replacing an
Access Point and Bulk Replacement of Access Points.

n AOS-S Switches—For more information about AOS-S switches replacement workflows, see Replacing
an AOS-S Switch.

n Controllers—For more information about the guided steps for controller replacement workflow, see
Guided Steps for Replacing a Controller.

The device replacement workflows inherit the existing device attributes and configuration from the
faulty device to the new device.

The device replacement workflows for AOS-S switch and AOS-S stack is not supported.

About the Aruba Central On-Premises App User Interface
The Aruba Central On-Premises app helps to manage, monitor, and analyze your network. You can
manage your respective accounts end-to-end. Here, the customers have complete access to their
accounts. You can also provision and manage the accounts.

The following image displays the navigational elements of the Aruba Central On-Premises app.
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Figure 4 Navigation Elements of the Aruba Central On-Premises App

Callout
Number Description

1 Filter to select an option under Group, Label, Site. For all devices, select Global. A
corresponding dashboard is displayed.

2 Item under the left navigation contextual menu. The menu is dependent on the filter selection.

3 First-level tab on the dashboard.

4 Second-level tab on the dashboard.

5 Dashboard content for the selected view and filter. For example, the current dashboard in the
image displays the UCC tab under Manage > Applications in the List view for the Global filter.

6 Time range filter. This is displayed for selected dashboards only.

7 List view to display tabular data for the selected filter. This is displayed for selected dashboards
only.

8 Summary view to display charts for the selected filter. This is displayed for selected
dashboards only.

9 Config view to enable configuration options for the selected filter. This is displayed for selected
dashboards only.

Types of Dashboards in the Aruba Central On-Premises App
The Aruba Central On-Premises app uses a filter to set the dashboard context for the app. The menu
for the left navigation pane changes according to the selected filter value. Selecting any item on the left
navigation pane displays a corresponding dashboard. Accordingly, for different values of the filter, the
content displayed for the left navigation menu and the dashboard context differs. The following table
lists down all the available dashboards and the link to the detailed description of each type of
dashboard.
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Link to the Dashboard Filter Value and Dashboard Description

The Global Dashboard When the filter is set to Global (for standard enterprise modes) or All Groups
(for managed service modes), the dashboard context displayed is for all
available devices registered to the specific Aruba Central account. This is called
the global dashboard.

The Group Dashboard When the filter is set to a specific group, the dashboard context displayed is
only for the devices that are configured as part of that group. This is called the
group dashboard.

The Site Dashboard When the filter is set to a specific site, the dashboard context displayed is only
for the devices that are configured as part of that site. This is called the site
dashboard.

The Label Dashboard When the filter is set to a specific label, the dashboard context displayed is
only for the devices that are configured as part of that label. This is called the
label dashboard.

The Controller Dashboard When the filter is set to a controller, the dashboard context displayed is only
for that specific controller. This is called the controller dashboard. The
controller dashboard enables you to manage and monitor a specific controller.

The Access Point Dashboard When the filter is set to an access point, the dashboard context displayed is
only for that specific access point. This is called the access point dashboard.
The access point dashboard enables you to manage and monitor a specific
access point.

The Switch Dashboard When the filter is set to a switch, the dashboard context displayed is only for
that specific switch. This is called the switch dashboard. The switch dashboard
enables you to manage and monitor a specific switch.

The Client Dashboard In the Aruba Central On-Premises app, the client dashboard is displayed
under Manage > Clients for any filter value.

Table 19: Types of Dashboards

The dashboard for any item on the left navigation menu can have a combination of the following views:

n Summary view— Click the Summary icon to display the summary dashboard. The summary
dashboard displays a number of charts. For example, in the global dashboard, under Manage, the
Overview > Network Health tab in Summary view displays a map of the available sites and their
corresponding health. If available, use the time range filter to change the time-lines for the charts.

n List view— Click the List icon to display tabular data for a selected dashboard. For example, in the
global dashboard under Manage, the Overview > Network Health tab in List view displays a list of
the available sites managed by Aruba Central. If available, use the time range filter to change the
time-lines for the tabular data.

n Config view— Click the Config icon to enable the configuration options for a specific dashboard.
For example, in the global dashboard under Manage, the Applications > UCC tab in Config view
displays various configuration options for UCC.

Navigating to the Switch, Access Point, or Controller Dashboard
In the Aruba Central On-Premises app, you can navigate to a device dashboard for a switch, access
point, or controller. The device dashboard enables you to monitor, troubleshoot, or configure a single
device. In order to do this, complete the following steps:
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1. In the Aruba Central On-Premises app, set the filter to one of the options under Group, Label,
or Site. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.

2. Under Manage > Devices, select one of the following options:
n To view an access point dashboard, click the Access Points tab.
n To view a switch dashboard, click the Switches tab.
n To view a controller dashboard, click the Controllers tab.

The list of devices is displayed in List view.

3. Click a device listed under Device Name.
The dashboard context for the specific device is displayed.

To exit the device dashboard, click the back arrow on the filter.
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Workflow to Configure, Monitor, or Troubleshoot in the Aruba
Central On-Premises App
The following image displays a flowchart to help you navigate the Aruba Central On-Premises app to
complete any task.

Figure 5 Navigation Workflow for Aruba Central On-Premises App
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The Global Dashboard
In the Aruba Central On-Premises app, the global dashboard is displayed when the filter is set to
Global. The global dashboard displays information related to all devices registered to that account in
Aruba Central On-Premises.

Some tabs may not be seen in your dashboard view if you are not an administrator for the Aruba Central On-
Premises account.

Left
Navigation
Menu

First-Level Tabs Description

Manage >
Overview

Network Health Displays information of the networks sorted by site, including
information on network devices and WAN connectivity of
individual sites.
For more information, see Network Health.

Summary Displays details such as the bandwidth usage, client count, top
APs by usage, top 5 clients, top AP clusters by usage, top AP
clusters by clients, and WLAN network details. By default, the
graphs are plotted for a time range of 3 hours. To view the
graphs for a different time range, click the Time Range Filter.
For more information, see Global—Summary.

Wi-Fi Connectivity The Wi-Fi Connectivity page displays an overall view of the
connection details for all clients that are connected to or tried to
connect to each connection phase. The connection phases
include Association, Authentication, DHCP, and DNS.
For more information, see Wi-Fi Connectivity.

Ai Insights The AI Insights dashboard displays a report of network events
that could possibly affect the quality of the overall network
performance.
For more information, see The AI Insights Dashboard.

Manage >
Devices

Access Points Displays the access points information in the following views:
n Summary view: Monitoring Access Points in Summary
View
n List view: Monitoring Access Points in List View

Switches Displays the switches information in the following views:
n Summary view: Monitoring Switches in Summary View
n List view: Monitoring Switches in List View

Controllers Displays the controller information in the following view:
n Summary view: Controller > Overview > Summary

Manage >
Clients

Clients Displays information about all the clients connected to the
devices configured for the group.
For more information, see All Clients.

Manage >
Applications

Visibility Provides a summary of client traffic and their data usage to and
from applications and websites. Also, analyzes the client traffic
flow using the graphs displayed.

Table 20: Contents of the Global Dashboard
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Left
Navigation
Menu

First-Level Tabs Description

For more information, see Application Visibility.

UCC Monitors voice, video, and application sharing sessions, provides
traffic visibility, and allows you to prioritize the required
sessions. The app also leverages the functions of the service
engine on the cloud platform to provide visual metrics for
analytical purposes.
For more information, see Unified Communications.

Manage >
Security

RAPIDs Helps to identify and act on interfering devices that can be later
considered for investigation, restrictive action, or both.
For more information, see RAPIDS.

Firewall Monitors traffic coming into and going out of the Aruba Central-
managed network and acts as an investigative resource for users
to track blocked sessions within the network.
For more information, see Configuring Firewall Parameters for
Wireless Network Protection.

Analyze > Alerts
and Events

Alerts & Events Displays all types of alerts and events generated for events
pertaining to device provisioning, configuration, and user
management.
For more information, see Alerts and Events.

Analyze > Audit
Trail

Audit Trail Shows the total number logs generated for all device
management, configuration, and user management events
triggered in Aruba Central.
For more information, see Viewing Audit Trail.

Analyze > Tools n Network Check
n Device Check
n Commands

Enables network administrators and users with troubleshooting
permission to perform troubleshooting or diagnostics tests on
devices and networks managed by Aruba Central.
For more information, see Using Troubleshooting Tools.

Analyze >
Reports

Reports Enables you to create various types of reports. You can create
recurrent reports or configure the reports to run on demand.
For more information, see Reports .

Maintain
> Firmware

n Access Points
n Switches
n Controller

Provides an overview of the latest supported version of firmware
for the device, details of the device, and the option to upgrade
the device.
For more information, see Upgrading Device Firmware.

Maintain >
Organization

Network Structure n Groups
A group in Aruba Central On-Premises is the primary
configuration element that functions as a container for
device management, monitoring, and maintenance. Groups
enable administrators to manage devices efficiently by using
either a UI-based configuration workflow or CLI-based
configuration template.
For more information, see Managing Groups.

n Sites and Labels
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Left
Navigation
Menu

First-Level Tabs Description

A site refers to a physical location where a set of devices are
installed; for example, campus, branch, or venue. Labels are
tags attached to a device provisioned in the network. Labels
determine the ownership, departments, and functions of the
devices.
For more information, see Managing Sites and Labels and
How to Manage Them.

n Certificates
Enables administrators to upload a valid certificate signed by
a root CA so that devices are validated and authorized to use
Aruba Central On-Premises.
For more information, see Managing Certificates.

n Device Preprovisioning

Displays the number of devices that are pre-provisioned to a
group. It enables administrators to assign factory default
devices to a group. For more information, see
For more information, see Preprovision Devices.

n Install Manager

Simplifies and automates site deployments, and helps IT
administrators manage site installations with ease.

Platform Integration Shows tiles view for API Gateway, and Webhooks. You can click
on a tile to navigate to the respective page in Aruba Central On-
Premises.
n API Gateway

Supports the REST API for all Aruba Central On-Premises
services. This feature allows Aruba Central On-Premises
users to write custom applications, embed, or integrate the
APIs with their own applications.

n Webhooks

Webhooks allow you to implement event reactions by
providing real-time information or notifications to other
applications.

Maintain >
System
Management

System Management System management tab allows you to perform administrative
tasks such as setting up the system, enabling SMTP settings,
notifications, migration, and even backup and restore.

The Access Point Dashboard
In the Aruba Central On-Premises app, the access point dashboard is displayed when the filter is set
to an access point. To navigate to an access point dashboard, see About the Aruba Central On-Premises
App User Interface.

The following table lists all the available menu items in the Aruba Central On-Premises app for the
access point dashboard.
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Table 21: Contents of the Access Point Dashboard

Left Navigation
Menu First-Level Tabs Description

Manage >
Overview

Summary The Summary tab displays the AP device details, network
information, radio details including the topology of clients
connected to each radio, and the health status of the AP in
the network.
For more information, see Viewing the Summary Tab.

AI Insights The AI Insights tab displays information on AP
performance issues such as excessive channel changes,
excessive reboots, airtime utilization, and memory
utilization.
For more information, see Viewing the AI Insights Tab.

Floor Plan The Floor Plan tab provides information regarding the
current location of the Instant AP.
For more information, see Viewing the Floor Plan Tab.

Performance The Performance tab displays the size of data transmitted
through the AP.
For more information, see Viewing the Performance Tab.

RF The RF tab provides details corresponding to 2.4 GHz, 5
GHz, and 5 GHz Secondary radios of the AP.
See Viewing the RF Tab.

Manage > Device Access Point
Configuration using
UI groups

Enables AP configuration in the Config view. See
Configuring IAPs.
Configuration using UI groups contains the following
second-level tabs:

n WLANs—Configure wireless network profiles on
Instant APs. For more information, see Configuring
Wireless Network Profiles on IAPs.
n Access Points—Configure device parameters on
Instant APs. For more information, see Configuring
Device Parameters .
n Radios—Configure ARM and RF parameters on
Instant APs. For more information, see Configuring ARM
and RF Parameters on IAPs.
n Interfaces—Configuring interfaces parameters on
Instant APs. For more information, see Configuring
Uplink Interfaces on IAPs.
n Security—Configure authentication and security
profiles on Instant APs. For more information, see
Configuring Authentication and Security Profiles on IAPs.
n VPN—Configure VPN host settings on an Instant AP to
enable communication with a controller in a remote
location. For more information, see Configuring IAPs for
VPN Tunnel Creation.
n Services—Configure AirGroup, location services,
Lawful Intercept, OpenDNS, and Firewall services on
Instant APs. For more information, see Configuring
Services.
n System—Configure system parameters on Instant
APs. For more information, see Configuring System
Parameters for an IAP .
n Configuration Audit—View configuration sync errors
and overrides. For more information, see Verifying
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Left Navigation
Menu First-Level Tabs Description

Device Configuration Status.

Access Point
Configuration using
template groups

Configuration using template groups contains the following
second-level tabs:

n Templates—Configure Access Points using template
groups. For more information, see Configuring IAPs
Using Templates.
n Variables—Modify, download, or upload variables
associated with devices that you can use in template
configuration. For more information, see Managing
Variable Files.
n Configuration Audit—View configuration sync errors
and overrides. For more information, see Verifying
Device Configuration Status.

Manage > Clients Clients The Clients tab displays details of all the clients connected
to a specific AP. For more information, see Viewing the
Clients Tab.

Manage > Security VPN The VPN tab provides information on VPN connections
associated with the Virtual Controller along with
information on the tunnels and the data usage through
each of the tunnels.
For more information, see Viewing the VPN Tab.

Analyze > Alerts
and Events

Alerts & Events The Alerts & Events tab displays details of the alerts and
events generated for the AP.
For more information, see Viewing the Alerts & Events Tab.

Analyze > Audit
Trail

Audit Trail The Audit Trail tab displays the logs for all the device
management, configuration, and user management events
triggered in Aruba Central. For more information, see
Viewing Audit Trail.

Analyze > Tools Commands The Commands tab allows network administrators and
users with troubleshooting permission to perform
troubleshooting or diagnostics tests on devices and
networks managed by Aruba Central.
For more information, see Performing Advanced Device
Troubleshooting

Maintain >
Firmware

Access Points The Access Points tab allow the user to view the firmware
details for devices provisioned in Aruba Central. For more
information, see Upgrading Device Firmware

The Switch Dashboard
In the Aruba Central On-Premises app, the switch dashboard is displayed when the filter is set to a
switch.

To navigate to a switch dashboard, For more information, see About the Aruba Central On-Premises
App User Interface.
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Some tabs may not be seen in your dashboard view if you are not an administrator for the Aruba Central On-
Premises account. Also, some tabs or some fields inside tabs are only applicable either for AOS-S or AOS-CX
switch series.

Left
Navigation
Menu

First-Level
Tabs Description

Manage >
Overview

Summary Displays details about a specific switch, including device information,
network summary, and port and hardware status. It also displays uplink
and usage details. Use the time range filter to change the time period for
the displayed information.
For more information, see Switch > Overview > Summary.

Hardware Displays switch hardware details, including status of power supplies and
fans, CPU and memory utilization, and device temperature.
For more information, see Switch > Overview > Hardware.

Routing Displays routing information for the switch, such as, type of route,
number of static and connected routes, and distance of the route.
For more information, see Switch > Overview > Routing.
The Routing tab is displayed only for AOS-S switches.

Manage >
Clients

Clients Displays details about the wired clients that are connected to the switch.
For more information, see Switch > Clients > Clients.

Neighbours Displays details about the devices neighboring the switch.
For more information, see Switch > Clients > Neighbors.

Manage > LAN Ports Displays details about ports and the LAGs configured in the switch. Also
displays information about AOS-CX switch stacks and stack-related
errors.
See Switch > LAN > Ports.
For information about AOS-CX switch stack-related errors, see Monitoring
AOS-CX Switch Stacks.

PoE Displays details about PoE status, PoE ports, and the power consumption
from these ports.
For more information, see Switch > LAN > PoE.

VLAN Displays VLAN information configured on the switch and details about
tagged and untagged ports.
For more information, see Switch > LAN > VLAN.

Manage > VSX VSX Displays VSX configuration details between AOS-CX switches and the
status of the inter-switch link (ISL).
For more information, see Switch > VSX.
The VSX tab is displayed only for AOS-CX switch series.

Manage >
Device (AOS-S)

AOS-S—
Configuration
using UI groups

Enables AOS-S configuration in the AOS-S Config view. For more
information, see Configuring AOS-S Switches in UI Groups.
Configuration using UI groups contains the following second-level tabs:
n Switches—Configure and view general switch properties, such as,

hostname, IP address, and netmask. For more information, see

Table 22: Contents of the Switch Dashboard



Aruba Central On-Premises 2.5.7 | User Guide 88

Left
Navigation
Menu

First-Level
Tabs Description

Configuring or Viewing Switch Properties.
n Stacks—Create stacks, add members, or view stacking details, such

as, stack type, stack id, and topology. For more information, see
Configuring AOS-S Stacks Using UI Groups.

n Interface:
o Ports—Assign or view port properties, such as, PoE, access

policies, and trunk groups. For more information, see Configuring
Switch Ports on AOS-S Switches.

o PoE—Configure or view PoE settings for each port. For more
information, see Configuring PoE Settings on AOS-S Ports.

o Trunk Groups—Configure or view trunk groups and their
associated properties, such as, members of the trunk group, and
type of trunk group. For more information, see Configuring Trunk
Groups on AOS-S Switches in UI Groups.

o VLANs—Configure or view VLAN details and the associated ports
and access policies. For more information, see Configuring VLANs
on AOS-S Switches.

o Spanning Tree—Configure or view spanning tree protocol and its
associated properties. For more information, see Enabling
Spanning Tree Protocol on AOS-S Switches in UI Groups.

o Loop Protection—Configure or view loop protection and its
associated properties. For more information, see Configuring Loop
Protection on AOS-S Switch Ports.

n Security:
o Access Policies—Add or view access policies. For more

information, see Configuring Access Policies on AOS-S Switches.
o DHCP Snooping—Configure or view DHCP snooping, authorized

DHCP servers IP addresses, and their associated properties. For
more information, see Configuring DHCP Snooping on AOS-S
Switches.

o Port Rate Limit—View or specify bandwidth to be used for
inbound or outbound traffic for each port. For more information,
see Configuring Port Rate Limit on AOS-S Switches in UI Groups.

o RADIUS—Configure RADIUS (Remote Authentication Dial-In User
Service) server settings on AOS-S switches. For more information,
see Configuring RADIUS Server Settings on AOS-S Switches.

o Downloadable User Role—Enable DUR and configure ClearPass
settings to download user roles, policy, and class from the
ClearPass Policy Manager server. For more information, see
Configuring Downloadable User Role on AOS-S Switches.

o Tunneled Node Server—Configure user-based tunnel or port-
based tunnel on switches. For more information, see Configuring
Tunnel Node Server on AOS-S Switches.

o Authentication—Configure and enable 802.1X and MAC
authentication on switches. You can also configure authentication
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Left
Navigation
Menu

First-Level
Tabs Description

order and priority for authentication methods. For more
information, see Configuring Authentication for AOS-S Switches.

n System:
o Access/DNS—Configure or view the administrator and operator

logins. For more information, see Configuring System Parameters
for AOS-S Switches.

o Time—Configure time synchronization in switches. For more
information, see Configuring Time Synchronization on AOS-S
Switches.

o SNMP—Add or view SNMP v2c and v3 community and its trap
destination. For more information, see Configuring SNMP on AOS-S
Switches.

o CDP—Configure CDP and its associated properties. For more
information, see Configuring CDP on AOS-S Switches.

o DHCP—Add or view a DHCP pool and its associated properties. For
more information, see Configuring DHCP on AOS-S Switches.

o IP Client Tracker—Enable AOS-S switches to learn the IP address
of all, trusted, or only untrusted clients connected to the switch.
For more information, see Configuring IP Client Tracker on AOS-S
Switches.

n Routing—Configure or view a specific routing path to a controller.
For more information, see Configuring Routing on AOS-S Switches.

n IGMP—Configure IGMP and its associated properties. For more
information, see Configuring IGMP on AOS-S Switches.

n QoS—Configure QoS traffic policies on switches to classify and
prioritize traffic throughout a network. For more information, see
Configuring QoS Settings on AOS-S Switches.

n Device Profile—Configure device profile on switches to dynamically
detect devices based on certain parameters. For more information,
see Configuring Device Profile and Device Identifier on AOS-S
Switches.

n Configuration Audit—View configuration sync errors and overrides.
For more information, see Verifying Device Configuration Status.

AOS-S—
Configuration
using templates

Configuration of AOS-S switches using template groups contains the
following second-level tabs:
n Templates—Configure switch using template groups. For more

information, see Provisioning Devices Using Configuration Templates.
n Variables—Modify, download, or upload variables associated with

devices that you can use in template configuration. For more
information, see Managing Variable Files.

n Configuration Audit—View configuration sync errors and overrides.
For more information, see Verifying Device Configuration Status.

For more information, see Configuring AOS-S Switches using Templates.
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Left
Navigation
Menu

First-Level
Tabs Description

AOS-S Stack—
Configuration
using templates

Configuration of AOS-S stacks using template groups contains the
following second-level tabs:
n Templates—Configure switch stack using template groups. For more

information, see Configuring AOS-S Stacks Using Template Groups.
n Variables—Modify, download, or upload variables associated with

devices that you can use in template configuration. For more
information, see Managing Variable Files.

n Configuration Audit—View configuration sync errors and overrides.
For more information, see Verifying Device Configuration Status.

Manage
Device (AOS-
CX)

AOS-CX—
Configuration
using UI groups

Enables AOS-CX configuration in the AOS-CX Config view. For more
information, see Configuring AOS-CX Switches in UI Groups.
Configuration using UI groups allows you to configure the following
features:
n System:

o Properties—Edit system property settings such as contact,
location, time zone, and administrator password. You can also
select the VRF to be used and add the DNS and NTP servers. For
more information, see Configuring System Properties on AOS-CX.

o HTTP Proxy—Edit the HTTP proxy configuration details for the
switch. For more information, see Configuring HTTP Proxy on AOS-
CX.

o SNMP—Add, edit, or delete SNMP v2 communities, v3 users, and
trap notifications. For more information, see Configuring SNMP on
AOS-CX.

o Logging—Add, edit, or delete logging servers to view event logs
from the AOS-CX switches. Configure FQDN or IP address, log
severity level, and the VRF to be used for each of the logging
servers. Also configure the global level debug log severity. For
more information, see Configuring Logging Servers for AOS-CX.

o Administrator—Add, edit, or delete server groups to be used for
authentication, authorization, and accounting. You must also
configure the protocol required to enable connection to these
server groups. For more information, see Configuring AAA for AOS-
CX.

o Source Interface—Add, modify, or delete source interface
configuration for Central and User-based tunneling interfaces for
AOS-CX switches. For more information, see Configuring Source
Interface for AOS-CX.

o Stacking—Create stack, add stack members, modify VSF link,
change the secondary conductor, delete stack and delete stack
members. For more information, see Configuring AOS-CX VSF
Stacks Using UI Groups.

n Routing:
o Static Routing—Add, edit, or delete static routes manually and

configure destination IP addresses and next hop values, VRF, and
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Left
Navigation
Menu

First-Level
Tabs Description

the administrative distance. You can add different static routes for
different VRFs on the switch. For more information, see
Configuring Static Routing on AOS-CX.

n Interfaces:
o Ports & Link Aggregations—View and edit port settings such as

description, VLAN mode, speed duplex, routing, and the
operational status of the port. Add, edit, or delete LAGs by
combining different ports and configuring the speed duplex,
VLAN mode, aggregation mode, and the operational status of the
LAG. For more information, see Configuring Ports and LAGs on
AOS-CX.

n Security:
o Authentication Servers—Add, edit, or view the RADIUS and

TACACS servers for authentication. Add settings such as FQDN or
IP address of the servers, authentication port number, response
timeout, retry count, and the VRF to be used when communicating
with the servers. For more information, see Configuring
Authentication Servers on AOS-CX.

o Authentication—View or edit details about 802.1X and MAC
authentication methods. Configure the precedence order and
other parameters such as reauthentication timeout, cached
reauthentication timeout, and quiet period. For more information,
see Configuring Authentication on AOS-CX.

o Access Control—View or add access policies and rules to permit
or deny passage of traffic. For more information, see Configuring
Access Control on AOS-CX.

o Dynamic Segmentation—Enable user-based tunneling on the
switch to provide a centralized security policy based on user
authentication. For more information, see Configuring User-Based
Tunneling for AOS-CX.

o Client Roles—Add or delete client roles and associate these roles
to clients. For more information, see Configuring Client Roles for
AOS-CX.

n Bridging:
o VLANs—Add, edit, delete, or view VLANs, and associated

parameters such as type of IP assignment, operational status,
IP address of the DHCP relay. For more information, see
Configuring VLANs on AOS-CX.

o Loop Prevention—Enable or disable loop protection and spanning
tree protocol, and associated parameters such as the mode and
priority. Enable or disable various MSTP mode-related settings
such as BPDU filter, BPDU protection, admin edge, and root guard.
For more information, see Configuring Loop Prevention on AOS-CX.
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Left
Navigation
Menu

First-Level
Tabs Description

AOS-CX—
Configuration
using MultiEdit
mode

Enables AOS-CX configuration using the MultiEdit mode in the AOS-CX
Config view. View and edit configuration on the AOS-CX switches using
the CLI syntax. You can also apply predefined set of configuration
settings such as NAE to the switches. For more information, see Using
MultiEdit View for AOS-CX.
Configuration using the MultiEdit mode contains the following options:
n View Config—View configuration of AOS-CX switches and find

differences in the configuration across switches. For more
information, see Viewing Configuration Using MultiEdit on AOS-CX.

n Edit Config—Edit configuration for one or more AOS-CX switches in
the MultiEdit mode. Edit the entire configuration in a familiar looking
CLI with syntax checking, colorization, and command completion. For
more information, see Editing Configuration Using MultiEdit on AOS-
CX.

n Express Config—Apply predefined set of configuration settings such
as NAE scripts and device profile to a single or multiple switches. For
more information, see Express Configuration Using MultiEdit on AOS-
CX.

AOS-CX—
Configuration
using templates

Enables AOS-CX switch configuration in the AOS-CX view. For more
information, see Configuring AOS-CX Switches using Templates.
Configuration of AOS-CX switches using template groups contains the
following second-level tabs:
n Templates—Configure switch using template groups. For more

information, see Creating a Configuration Template.
n Configuration Audit—View configuration sync errors and overrides.

For more information, see Verifying Device Configuration Status.
n Configuration Status—View configuration status of AOS-CX switches

that are managed through UI groups in Aruba Central On-Premises.
For more information, see Using Configuration Status on AOS-CX.

AOS-CX VSF
Stack—
Configuration

Enables AOS-CX switch stack configuration in the AOS-CX view. For more
information, see Managing an AOS-CX VSF Stack.

Analyze >
Alerts &
Events

Alerts & Events The Alerts & Events tab displays all types of alerts and events generated
for events pertaining to device provisioning, configuration, and user
management. For more information, see Alerts and Events.

You can also configure and enable certain categories of switch alerts.
For more information, see AOS-S Switch Alerts.

Analyze >
Audit Trail

Audit Trail Displays the details of logs generated for all device management,
configuration, and user management events triggered in Aruba Central
On-Premises.
For more information, see Viewing Audit Trail.

Analyze >
Tools

Network Check The Network Check tab allows administrators and users with
troubleshooting permission to diagnose issues related to wired network
connections.
For more information, see Troubleshooting Network Issues.
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Left
Navigation
Menu

First-Level
Tabs Description

Device Check The Device Check tab allows network administrators and users with
troubleshooting permission to identify, diagnose, and debug issues on
AOS-S and AOS-CX switches using predefined tests.
For more information, see Troubleshooting Device Issues.

Commands The Commands tab allows network administrators and user with
troubleshooting permission to identify, diagnose, and debug issues on
AOS-S and AOS-CX switches at an advanced level using commands.
For more information, see Performing Advanced Device Troubleshooting.

Analyze >
Reports

Reports The Reports tab allows you to create, manage, and view various reports.
You can create recurrent reports, generate reports on demand, or
schedule reports to run at a later time.
For more information, see Reports .

Maintain
> Firmware

Switches The Switches tab allows the user to view the firmware details and
upgrade the devices provisioned in Aruba Central On-Premises.
For more information, see Upgrading Device Firmware

The Controller Dashboard
In the Aruba Central On-Premises app, the controller dashboard is displayed when a controller is
selected. To navigate to a controller dashboard, see About the Aruba Central On-Premises App User
Interface.

The following table lists all the available menu items in the Aruba Central On-Premises app for the
controller dashboard.

Table 23: Contents of the Controller Dashboard

Left Navigation
Menu First-Level Tabs Description

Manage >
Overview

Summary The Summary tab displays the Controller Details and Health
Status.
For more information, see Controller > Overview > Summary.

Routing Displays a summary of the IP routes configured on the controller.
For more information, see Controller > Overview > Routing

Manage > LAN Summary Displays information about Port Status, LAN Interfaces Summary,
and VLAN Interfaces Summary. For more information, see
Controller > LAN > Summary.

Manage > Clients Clients Displays a list of clients connected to a controller.
For more information, see All Clients.

Analyze > Alerts
and Events

Alerts & Events The Alerts & Events tab displays details of the alerts and events
generated for the controller.
For more information, see Controller Alerts and Viewing Events
List View
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Left Navigation
Menu First-Level Tabs Description

Analyze > Audit
Trail

Audit Trail Displays the logs generated in Aruba Central On-Premises.
For more information, see Viewing Audit Trail.

Analyze > Tools Network Check Enables network administrators and users to identify, diagnose,
and debug issues detected by performing diagnostics tests on
devices and networks managed by Aruba Central On-Premises.
For more information, see Troubleshooting Controller
Connectivity Issues.

Commands The Commands tab allows network administrators and users with
troubleshooting permission to execute the CLI to validate the
details of the device.
For more information, see Troubleshooting Controllers and
Command Line Interface.

Analyze > Reports Reports Enables network administrators to create various types of reports.
You can create recurrent reports or configure the reports to run
on demand.
For more information, see Reports .

Maintain >
Firmware

List Provides an overview of the latest supported version of firmware
for the device, details of the device, and the option to upgrade.
For more information, see Upgrading Device Firmware.

Config Provides an upgrade status and compliance status for APs that are
connected to the selected controller.
For more information, see Upgrading Device Firmware.

The Group Dashboard
In the Aruba Central On-Premises app, the group dashboard is displayed when the filter is set to a UI
or template group. A template group is marked by a superscript TG tag. The following table lists all the
available menu items in the Aruba Central On-Premises app for the group dashboard.

Some tabs may not be seen in your dashboard view if you are not an administrator for the Aruba Central
account.

Left
Navigation
Menu

First-Level Tabs Description

Manage >
Overview

Summary Displays details such as the bandwidth usage, client count, top
APs by usage, top 5 clients, top AP clusters by usage, top AP
clusters by clients, and WLAN network details. By default, the
graphs are plotted for a time range of 3 hours. To view the
graphs for a different time range, click the Time Range filter.
For more information, see Global—Summary

Manage >
Devices

Access Points Displays the access points information in the following views:
n Summary view: Monitoring Access Points in Summary
View

Table 24: Contents of the Group Dashboard

#https://www.arubanetworks.com/techdocs/CLI-Bank/Content/landing-pages/cop-home.htm


| 95

Left
Navigation
Menu

First-Level Tabs Description

n List view: Monitoring Access Points in List View
n Config view: Getting Started with AP Deployments

Switches Displays the switches information in the following views:
n Summary view: Monitoring Switches in Summary View
n List view: Monitoring Switches in List View
n Config view: Getting Started with AOS-S Deployments

Controllers Displays the controller information in the following view:
n Summary view: Controller > Overview > Summary

Manage >
Clients

Clients Displays information about all the clients connected to the
devices configured for the group.
For more information, see All Clients.

Manage >
Applications

Visibility Provides a summary of client traffic and their data usage to and
from applications and websites. Also, analyzes the client traffic
flow using the graphs displayed.
For more information, see Application Visibility.

Manage >
Security

RAPIDs Helps to identify and act on interfering devices that can be later
considered for investigation, restrictive action, or both.
For more information, see RAPIDS.

Analyze >
Alerts and
Events

Alerts & Events Displays all types of alerts and events generated for events
pertaining to device provisioning, configuration, and user
management.
For more information, see Alerts and Events.

Analyze >
Audit Trail

Audit Trail Shows the total number logs generated for all device
management, configuration, and user management events
triggered in Aruba Central.
For more information, see Viewing Audit Trail.

Analyze >
Tools

n Network Check
n Commands

Enables network administrators and users with troubleshooting
permission to perform troubleshooting or diagnostics tests on
devices and networks managed by Aruba Central.
For more information, see Using Troubleshooting Tools.

Analyze >
Reports

Reports Enables you to create various types of reports. You can create
recurrent reports or configure the reports to run on demand.
For more information, see Reports .

Maintain
> Firmware

n Access Points
n Switches
n Controllers

Provides an overview of the latest supported version of
firmware for the device, details of the device, and the option to
upgrade the device.
For more information, see Upgrading Device Firmware.

The Client Dashboard
In the Aruba Central On-Premises app, the clients dashboard is displayed when the filter is set to one
of the options under Groups, Labels, Sites, or Global.
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The following table lists all the available menu items in the Aruba Central On-Premises app for the
clients dashboard.

Table 25: Contents of the Clients Dashboard

Left Navigation
Menu First-Level Tabs Description

Manage > Overview Summary Displays the client details about the type of data path
that the client uses, the network and connectivity
details, and basic client details such as IP address of
the client, type of encryption etc.
For more information, see Client Details.

Sessions Displays the firewall session details for the client
connected to an AP. The Sessions page displays
information filtered by the IP address of the client.
For more information, see Client Details.

Location Displays the current physical location of the device on
the floor map.

NOTE: Location tab is visible for the client overview
page only if the AP is terminated at the Site level and
floor plan. Location tab will not be visible for the
clients where the AP is not terminated on the floor
plan.

Manage > Applications Displays the client details for passive motoring of the
client connected to a wireless network. The Visibility
dashboard provides a summary of client traffic and
their data usage to and from applications, and
websites.
For more information, see Application Visibility.

Analyze > Events Displays the details of events generated by the AP
and client association.
For more information, see Alerts and Events

The Site Dashboard
In the Aruba Central On-Premises app, the site dashboard is displayed when the filter is set to any of
the options under Sites. The site dashboard displays information related to all devices configured for
that site in Aruba Central.

Left
Navigation
Menu

First-Level Tabs Description

Manage >
Overview

Site Health Displays details of wired and wireless devices deployed on the
site. This page includes information on client connectivity
statistics, change logs, health of devices, and RF health of the
site.
For more information, see Managing Sites.

Table 26: Contents of the Site Dashboard
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Left
Navigation
Menu

First-Level Tabs Description

Summary Displays details such as the bandwidth usage, client count, top
APs by usage, top 5 clients, top AP clusters by usage, top AP
clusters by clients, and WLAN network details. By default, the
graphs are plotted for a time range of 3 hours. To view the
graphs for a different time range, click the Time Range filter.
For more information, see Global—Summary

WAN Health Displays details for the wired, wireless, and controller devices
deployed on the site.
For more information, see WAN Health—Site.

Topology Provides a graphical representation of the site including the
network layout, details of the devices deployed, and the health
of the WAN uplinks and tunnels.
For more information, see Topology Tab.

Floor Plans Provides information regarding the current location of the AP.
For more information, see Viewing the Floor Plan Tab.

Manage >
Devices

Access Points Displays the access points information in the following views:
n Summary view: Monitoring Access Points in Summary
View
n List view: Monitoring Access Points in List View

Switches Displays the switches information in the following views:
n Summary view: Monitoring Switches in Summary View
n List view: Monitoring Switches in List View

Controllers Displays the controller information in the following view:
n Summary view: Controller > Overview > Summary

Manage >
Clients

Clients Displays information about all the clients connected to the
devices configured for the group.
For more information, see All Clients.

Manage >
Applications

Visibility Provides a summary of client traffic and their data usage to
and from applications and websites. Also, analyzes the client
traffic flow using the graphs displayed.
For more information, see Application Visibility.

Manage >
Security

RAPIDS Identify and act on interfering devices that can be later
considered for investigation, restrictive action, or both. Once
the interfering devices are discovered, Aruba Central sends
alerts to the network administrators about the possible threat
and provides essential information needed to locate and
manage the threat.
For more information, see RAPIDS.

Analyze >
Alerts and
Events

Alerts & Events Displays all types of alerts and events generated for events
pertaining to device provisioning, configuration, and user
management.
For more information, see Alerts and Events.
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Left
Navigation
Menu

First-Level Tabs Description

Analyze >
Tools

Network Check
Commands

Enables network administrators and users with
troubleshooting permission to perform troubleshooting or
diagnostics tests on devices and networks managed by Aruba
Central.
For more information, see Using Troubleshooting Tools.

Analyze >
Reports

Reports Enables you to create various types of reports. You can create
recurrent reports or configure the reports to run on demand.
For more information, see Reports .

The Label Dashboard
In the Aruba Central On-Premises app, the label dashboard is displayed when the filter is set to any of
the options under Labels. The label dashboard displays information related to all devices configured for
that label in Aruba Central.

Left
Navigation
Menu

First-Level Tabs Description

Manage >
Devices

All Devices Displays details such as the bandwidth usage, client count, top
APs by usage, top 5 clients, top AP clusters by usage, top AP
clusters by clients, and WLAN network details. By default, the
graphs are plotted for a time range of 3 hours. To view the
graphs for a different time range, click the Time Range filter.
For more information, see Global—Summary

Access Points Displays the access points information in the following views:
n Summary view: Monitoring Access Points in Summary
View
n List view: Monitoring Access Points in List View

Switches Displays the switches information in the following views:
n Summary view: Monitoring Switches in Summary View
n List view: Monitoring Switches in List View

Controllers Displays the controller information in the following view:
n Summary view: Controller > Overview > Summary

Manage >
Clients

Clients Displays information about all the clients connected to the
devices configured for the group.
For more information, see All Clients.

Manage
> Applications

UCC Displays a variety of charts and lists that allow you to assess the
quality of calls in the network.
For more information, see Unified Communications.

Table 27: Contents of the Label Dashboard
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Left
Navigation
Menu

First-Level Tabs Description

Manage
> Security

RAPIDs Identify and act on interfering devices that can be later
considered for investigation, restrictive action, or both. Once the
interfering devices are discovered, Aruba Central sends alerts to
the network administrators about the possible threat and
provides essential information needed to locate and manage
the threat.
For more information, see RAPIDS.

Analyze > Alerts
and Events

Alerts & Events Displays all types of alerts and events generated for events
pertaining to device provisioning, configuration, and user
management.
For more information, see Alerts and Events.

Analyze > Tools n Network Check
n Device Check
n Commands

Enables network administrators and users with troubleshooting
permission to perform troubleshooting or diagnostics tests on
devices and networks managed by Aruba Central.
For more information, see Using Troubleshooting Tools.

Analyze >
Reports

Reports Enables you to create various types of reports. You can create
recurrent reports or configure the reports to run on demand.
For more information, see Reports .

The Health Bar
The Health Bar provides a snapshot of the overall health of the devices configured as part of the specific
dashboard. The applicable dashboards include global, group, site, client, and device dashboards.

The topic discusses the following:

n Health Bar Dashboard for Global
n Health Bar Dashboard for Group
n Health Bar Dashboard for Site
n Health Bar Dashboard for Access Point
n Health Bar Dashboard for Switch
n Health Bar Dashboard for Controller
n Health Bar Dashboard for Wireless Client
n Health Bar Dashboard for Wired Client

Viewing the Health Bar Dashboard
To view the Health Bar, perform the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a group, label, site, or all devices in the filter, set the filter to one of the options under

Groups, Labels, or Sites. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.
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n To select a device in the filter:
a. Set the filter to Global.
b. Under Manage, click Devices, and then click Access Points, Switches, or Controllers.

A list of devices is displayed in the List view.

c. Click a device listed under Device Name.

The dashboard context for the device is displayed.

n To select a client:
a. Set the filter to Global.
b. Under Manage, click Clients.

A list of clients is displayed in the List view.

c. Click a client listed under Client Name.

The dashboard context for the client is displayed.

The Health Bar icon displays the overall health of the network of the selected filter as either
online or offline.

2. In the selected filter, click the Health Bar icon to expand the Health Bar dashboard.

3. Use the pin icon to pin the Health Bar dashboard to the Aruba Central On-Premises app
display.

Health Bar Dashboard for Global
The following image shows the health bar for the global dashboard.

Figure 6 Expanded but Unpinned Health Bar in the Global Dashboard

Health Bar Icons

Icon Type Description

This icon is specific to Site, Device, and Client dashboard. It indicates that there are no issues in
the connection.
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Icon Type Description

This icon is specific to Site, Device, and Client dashboard. It indicates that there is an issue in the
connection.

This icon is specific to the Global and Group dashboards, and the health is not calculated at these
levels.

Device and Clients Status Icons

Icon
Type Description

n For devices, indicates the number of devices that are online.
n For clients, indicates the number of clients that are connected.

n For devices, indicates the number of devices that are offline.
n For clients, indicates the number of failed clients.
n For AI Insights, indicates the number of insights that are of high priority.

For AI Insights, indicates the number of insights that are of medium priority.

For AI Insights, indicates the number of insights that are of low priority.

The following table includes information on the various parameters of the Health Bar displayed for a
global dashboard. The health bar in a global dashboard is in the context of all devices.

Parameter Description

Access Points n Displays the number of access points that are online and the number of access points
that are offline.

n The number in green indicates the number of access points that are online.
n Clicking the number in green redirects you to Manage > Devices > Access Points >

Online in List view.
n The number in red indicates the number of access points that are offline.
n Clicking the number in red redirects you to Manage > Devices > Access Points > Offline

in List view.

Switches n Displays the number of switches that are online and the number of switches that are
offline.

n The number in green indicates the number of switches that are online.
n Clicking the number in green redirects you to Manage > Devices > Switches > Online in

Listview.
n The number in red indicates the number of switches that are offline.
n Clicking the number in red redirects you to Manage > Devices > Switches > Offline in

List view.
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Parameter Description

Controllers n Displays the number of controllers that are online and the number of controllers that are
offline.

n The number in green indicates the number of controllers that are online.
n Clicking the number in green redirects you to Manage > Devices > Controllers > Online

in List view.
n The number in red indicates the number of controllers that are offline.
n Clicking the number in red redirects you to Manage > Devices > Controllers > Offline in

List view.

Clients n Displays the number of clients that are connected and the number of clients that are
failed.

n The number in green indicates the number of clients that are connected.
n The number in red indicates the number of clients that are failed.
n Clicking the numbers redirects you to Manage > Clients > Clients in List view.

Health Bar Dashboard for Group
The following table includes information on the various parameters of the Health Bar displayed for a
group dashboard. The health bar in a group dashboard is in the context of all devices configured as part
of that group.

Parameter Description

Access Points n Displays the number of access points that are online and the number of access points
that are offline.

n The number in green indicates the number of access points that are online.
n Clicking the number in green redirects you to Manage > Devices > Access Points >

Online in List view.
n The number in red indicates the number of access points that are offline.
n Clicking the number in red redirects you to Manage > Devices > Access Points > Offline

in List view.

Switches n Displays the number of switches that are online and the number of switches that are
offline.

n The number in green indicates the number of switches that are online.
n Clicking the number in green redirects you to Manage > Devices > Switches > Online in

List view.
n The number in red indicates the number of switches that are offline.
n Clicking the number in red redirects you to Manage > Devices > Switches > Offline in

List view.

Controllers n Displays the number of controllers that are online and the number of controllers that are
offline.

n The number in green indicates the number of controllers that are online.
n Clicking the number in green redirects you to Manage > Devices > Controllers > Online

in List view.
n The number in red indicates the number of controllers that are offline.
n Clicking the number in red redirects you to Manage > Devices > Controllers > Offline in
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Parameter Description

List view.

Clients n Displays the number of clients that are connected and the number of clients that are
failed.

n The number in green indicates the number of clients that are connected.
n The number in red indicates the number of clients that are failed.
n Clicking the numbers redirects you to Manage > Clients > Clients in List view.

Health Bar Dashboard for Site
The following table includes information on the various parameters of the Health Bar displayed for a
site dashboard. The Health Bar in a site dashboard is in the context of all devices configured as part of
that site. The values are refreshed every minute. When there is any issue in the connection, short
descriptions are displayed for the Potential Issues label. If there are multiple criteria issues, only the
issue criteria with the highest priority is displayed. The <+x> next to the description indicates that there
are more issues. You can hover over the value to view the description of the issue. For more
information, see Site Health Dashboard.

Parameter Description

Access Points n Displays the number of access points that are online and the number of access points
that are offline.

n The number in green indicates the number of access points that are online.
n Clicking the number in green redirects you to Manage > Devices > Access Points >

Online in List view.
n The number in red indicates the number of access points that are offline.
n Clicking the number in red redirects you to Manage > Devices > Access Points > Offline

in List view.

Switches n Displays the number of switches that are online and the number of switches that are
offline.

n The number in green indicates the number of switches that are online.
n Clicking the number in green redirects you to Manage > Devices > Switches > Online in

List view.
n The number in red indicates the number of switches that are offline.
n Clicking the number in red redirects you to Manage > Devices > Switches > Offline in

List view.

Controllers n Displays the number of controllers that are online and the number of controllers that are
offline.

n The number in green indicates the number of controllers that are online.
n Clicking the number in green redirects you to Manage > Devices > Controllers > Online

in List view.
n The number in red indicates the number of controllers that are offline.
n Clicking the number in red redirects you to Manage > Devices > Controllers > Offline in

List view.

Clients n Displays the number of clients that are connected and the number of clients that are
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Parameter Description

failed.
n The number in green indicates the number of clients that are connected.
n The number in red indicates the number of clients that are failed.
n Clicking the numbers redirects you to Manage > Clients > Clients in List view.

AI Insights n Displays the number of insights categorized by status.
n The number in red indicates the insights are of high priority.
n The number in orange indicates the insights are of medium priority.
n The number in yellow indicates the insights are of low priority.
n Clicking the numbers redirects you to Manage > Overview > AI Insights at the site

context.

Health Bar Dashboard for Access Point
The following table includes information on the various parameters of the Health Bar displayed for an
AP. If the AP is not online and running, not all of the following data is available.

Parameter Description

AP Status n Value can be Online Since, Offline, or Operating under Thermal Management.
n If the value is Online Since, it also displays the time period, in the format of days-hours-

minutes, for which the AP has been online and running.
n When an AP operates under thermal management, the device health is displayed as Poor

and the radios are in disabled mode. For more information, see Thermal Shutdown
Support in Instant Access Points.

Device Health n Displays the performance of the AP in terms of the CPU and memory usage.
n For example, the device health is Good when the CPU usage is less than or equal to 70%

and the memory usage is less than or equal to 90%. If the value of the CPU and/or
memory usage falls below the threshold, the device health is displayed as Poor. If the AP
is down, the value is Offline. If the scenario is not applicable, a “-” sign is displayed.

n Hover over the Device Health status to get the exact percentage value of the memory
and CPU usage.

Radio 2.4 GHz n Displays the performance of the AP in terms of the channel utilization and noise floor in
the 2.4 GHz channel.

n For example, the device health is Good when the channel utilization is less than or equal
to 70% and the noise floor is less than or equal to -80 dBm. If the value of the channel
utilization and noise floor falls below the threshold, the device health is displayed as Poor.
If the AP is online, but the radio is down, the value displayed is Disabled. If the scenario is
not applicable, a “-” sign is displayed.

n Hover over the Radio 2.4 GHz status to get the exact value of the channel utilization and
noise floor.

Radio 5 GHz n Displays the performance of the AP in terms of the channel utilization and noise floor in
the 5 GHz channel.

n For example, the device health is Good when the channel utilization is less than or equal
to 70% and the noise floor is less than or equal to -80 dBm. If the value of the channel
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Parameter Description

utilization and noise floor falls below the threshold, the device health is displayed as Poor
If the AP is online, but the radio is down, the value displayed is Disabled. If the scenario is
not applicable, a “-” sign is displayed.

n Hover over the Radio 5 GHz status to get the exact value of the channel utilization and
noise floor.

Radio 5 GHz
(Secondary)

n Displays the performance of the AP in terms of the channel utilization and noise floor in
the 5 GHz (Secondary) channel.

n For example, the device health is Good when the channel utilization is less than or equal
to 70% and the noise floor is less than or equal to -80 dBm. If the value of the channel
utilization and noise floor falls below the threshold, the device health is displayed as Poor.
If the AP is online, but the radio is down, the value displayed is Disabled. If the scenario is
not applicable, a “-” sign is displayed.

n Hover over the Radio 5 GHz (Secondary) status to get the exact value of the channel
utilization and noise floor.

NOTE: In the Health Bar dashboard, the Radio 5 GHz (Secondary) data is available only for
AP-555 access points and only if the tri-radio mode is enabled. For more information, see
About Tri-Radio Mode.

Radio 6 GHz n Displays the performance of the AP in terms of the channel utilization and noise floor in
the 6 GHz channel.

n For example, the device health is Good when the channel utilization is less than or equal
to 70% and the noise floor is less than or equal to -80 dBm. If the value of the channel
utilization and noise floor falls below the threshold, the device health is displayed as Poor.
If the AP is online, but the radio is down, the value displayed is Disabled. If the scenario is
not applicable, a “-” sign is displayed.

n Hover over the Radio 6 GHz status to get the exact value of the channel utilization and
noise floor.

NOTE: The Radio 6 GHz data is only available for devices with 6 GHz capability.

Virtual
Controller

Indicates if the AP is connected to a virtual controller. If the AP is connected, clicking on the
virtual controller name redirects you to the Manage > Overview > Summary page for the
virtual controller.

Health Bar Dashboard for Switch
The following table includes information on the various parameters of the Health Bar displayed for a
switch. If the switch is not online and running, not all of the following data is available.

Parameter Description

Switch Status Displays the time period for which the switch has been online and running or its offline
status.

Device Health n Displays the performance of the switch in terms of the CPU and memory usage.
n For example, the device health is Good when the CPU usage is less than or equal to 70%

and the memory usage is less than or equal to 70%. If the value of the CPU and/or
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Parameter Description

memory usage falls below the threshold, the device health is displayed as Poor.
n Hover over the Device Health status to get the exact percentage value of the memory

and CPU usage.

Port - Status n Displays the number of ports on the switch that are online and the number of ports that
are offline.

n The number in green indicates the number of switch ports that are online.
n The number in red indicates the number of switch ports that are offline.

Port - Alerts n Displays the total number of open alerts.

Health Bar Dashboard for Controller
The following table includes information on the various parameters of the Health Bar displayed for a
controller. If the controller is not online and running, not all of the following data is available.

Parameter Description

Controller
Status

Displays the time period, in the format of days-hours-minutes, for which the controller has
been running or its offline status.

LAN n Displays the number of LAN ports as online or offline.
n The number in green indicates the number of LAN ports that are online.
n The number in red indicates the number of LAN ports that are offline.
n Clicking the numbers redirects you to Manage > LAN > Summary.

Alerts n Displays the total number of open alerts.
n Clicking the number redirects you to Analyze > Alerts & Events in List view.

Health Bar Dashboard for Wireless Client
The following table includes information on the various parameters of the Health Bar displayed for a
wireless client.

Parameter Description

Client Status Displays the connection status of the client.

Device Health Displays the device health of the client.

Signal Quality Displays the signal quality in dB.

Tx | Rx Rate Displays the transmit and receive rate in Mbps.

Connected To n Displays the device to which the wired client is connected.
n Clicking on the device redirects you to the Manage > Overview > Summary page for that

device.

Refresh icon Refreshes the data on the Health Bar for the client.
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Health Bar Dashboard for Wired Client
The following table includes information on the various parameters of the Health Bar displayed for a
wired client.

Parameter Description

Client Status Displays the connection status of the client.

Connected
Port

Displays the port to which the client is connected.

Connected To n Displays the device to which the wired client is connected.
n Clicking on the device redirects you to the Manage > Overview > Summary page for that

device.

Refresh icon Refreshes the data on the Health Bar for the client.

Using the Search Bar
The search bar in the Aruba Central On-Premises app enables users to search for clients, devices, and
infrastructure connected to the network. The search engine uses Natural Language Processing (NLP) to
analyze queries and return relevant search results.

The following figure illustrates the search bar option in Aruba Central.

Figure 7 Search Bar

To start a search in the Aruba Central UI, click the search bar or press / (forward slash) on your
computer keyboard.

The search results display cards relevant to the search terms. The Search Cards display a monitoring
summary of the devices in the Aruba Central On-Premises app.

Client Search Terms
The search bar helps you to search a client's information in the Network Operation app.

Using the search bar you can perform the following tasks:

n Hover over a client search card to view the monitoring summary for the client.
n Click the client name to open the Client Details page.

You can see the search cards when you search with the client name, IP address, or MAC address. You
can see the following details on the search card:

n Client Name
n IP Address
n MAC Address
n Username
n Status

Following is an example for the client name search:
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Figure 8 Search Card for Client Name

Following is an example for the client IP address search:

Figure 9 Search Card for Client IP Address

Following is an example for the client MAC address search:

Figure 10 Search Card for Client MAC Address

Device Search Terms
The search bar helps you to search all devices monitored by Aruba Central. The search enables you to
navigate to the monitoring pages of the devices in the Network Operation app.

Using the search bar you can perform the following tasks:

n Hover over a search card to view the monitoring summary for the device.
n Click the client name to open the Device Details page.

The cards might vary for each device based on the context. You can click on the search card to navigate
to the details page of that device in the app.

You can see the search cards when you search with the device name, IP address, MAC address, site, or
label. Following are the examples for APs, switches, and controllers.
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Figure 11 Search Card for a Device Name

Figure 12 Search Card for a Device Serial

Figure 13 Search Card for a Device MAC Address

Following is an example for the device serial search:

Figure 14 Search Card for a Device IP Address

Site Search Terms
The search bar helps you to search a site's information on the Network Operation app.

Using the search bar, you can perform the following tasks:

n Hover over a client search card to view the monitoring summary for the site.
n Click the client name to open the Site Details page.

The following illustration is an example for the site search.
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Figure 15 Search Card for a Site

Command Line Interface
The command-line interface features allows you to install, setup, manage, and troubleshoot Aruba
Central On-Premises deployments. The CLI is accessed through a console or through a Secure Shell
(SSH) session from a remote management console or workstation.

Accessing the Aruba Central On-Premises CLI
The following procedure describes how to access the SSH and start executing CLI commands:

1. From a secure shell (SSH) client, open an SSH connection.
2. Login as copadmin.
3. When prompted, enter the copadmin password.

A list of commands is displayed.

For example:

login as: copadmin

admin@10.22.150.92 password:

Last login: Wed Aug 7 05:43:22 2019 from 10.20.15.180

Syntax
Enter option [0 - <option number> ] : <enter option>

For example:

1. System

2. File Operations

3. Show

...

0. exit

...

Enter option [ 0 - 9 ]:

Common Command Options
The following common command options are used to:
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n 0 – Exit—Use this command option to exit the SSH connection.
n b – Back—Use this command option to go back to the previous menu.
n m - Main menu—Use this command option to go to the main menu.

Password Recovery
The password recovery system helps to create a new password for the copadmin user. If you forget the
password, login to the console with the user, coprecovery, and the following options are displayed to
generate the recovery key.

n Generate Recovery Key—The recovery key is generated and stored in an encrypted .asc file. You
can either copy it or use the SCP command to copy the file. Once the key is copied to the local server,
contact customer support to decrypt the recovery key to get a new password.

n SCP Recovery Key—The recovery key is generated and an SCP command is used to copy the file to a
local server. Once the key is copied to the local server, contact customer support to decrypt the
recovery key to get a new password.

n Activate Recovery secret —The secret key is provided and verified by the customer support. A
reset option is used to rest the password in all nodes.

Main Menu Options
When you login to the Aruba Central On-Premises SSH, the main set of commands are displayed. Using
the main menu command options, you can perform various other actions as described in the table.

1. System

2. File Operations

3. Show

4. System Configuration

5. Advanced

6. Security

7. Support

8. Temporary Root Shell

9. Authentication

10. Certificate configuration

11. Search commands

====================================

0. exit

Enter option [ 0 - 11 ]:

List of CLI Commands
The following table lists all the commands supported in a Aruba Central On-Premises deployment:

Option
Number Command Description

1 System Reboots or resets the system.

1-1 Reboot Reboots the system.

1-2 Shutdown Shutdowns the system.
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Option
Number Command Description

1-3 Factory Reset Resets the system to factory settings.

2 File Operations Uploads a file to the host.

2-1 Upload via (SCP) Uploads a file to the host over SCP.

2-2 Upload via (SFTP) Uploads a file to the host over SFTP.

2-3 Upload via (HTTP/HTTPS) Uploads a file to the host over HTTP or HTTPS.

2-4 Download File from COP Downloads a file that is saved on the host.

2-5 Delete File Deletes the files that was uploaded by the upload file command.

3 Show Show commands are used to view or display the settings or
parameters configured.

3-1 Version (Detail) Displays the version details of the Aruba Central On-Premises
deployment.

3-2 List Files Displays the total number of files in the pod.

3-3 Backup – Restore Status Display the backup and restore status of the pod.

3-4 Configuration Display the updated network settings, cluster details,
NTP/Timezone information.

3-5 System Display system information like usage of memory, activate
information, and uptime.

3-6 User Sessions Displays the list of user sessions.

3-7 Show clock Displays the date, week, month, time details.

3-8 App status Pod status of any Aruba Central On-Premises application.

3-9 Cluster Status Displays the cluster details for Aruba Central On-Premises.

4 System Configuration System configuration commands are used to configure system
parameters like network setup, cluster setup, timezone setup
and also, upgrade the setup (online/ offline) or perform a
complete factory reset.

4-1 Upgrade Upgrades the setup for either an online user or an offline user.

4-2 Network Setup Sets up a network permanently or temporarily.

4-3 Proxy Setup Setup proxy configuration for Aruba Central On-Premises.

4-4 Setup Timezone Sets up a timezone.

4-5 Setup NTP Sets up an NTP server.

4-6 Node Setup Sets up a node.
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Option
Number Command Description

4-7 Airgap Enables and Disables Airgap mode for upgrade.

4-8 Disaster Recovery Manages Aruba Central On-Premises disaster recovery.

5 Advanced Advanced commands are used to ping or check connectivity.

5-1 Test Connectivity Tests the connectivity to any URL.

5-2 Nslookup Performs a DNS lookups for any host names.

5-3 Toggle CDN Used to enable CDN, disable CDN , or show CDN Status.

5-4 Configure ILO IP Configures the IP address of the ILO.

6 Security Security commands are used to reset or update the password.

6-1 Reset Password GUI Resets the GUI password.

6-2 Reset Password CLI Resets the CLI password.

6-3 Reset debug apps
password

Resets the debug applications password.

7 Support Support commands are used to collect information that are
useful to TAC.

7-1 Support Connection Starts or stops support connection for remote TAC access.

7-2 Collect All Logs Collects Aruba Central On-Premises diagnostic tar for
debugging.

7-3 Log Snapshot Operations Generates and downloads snapshots. It also deletes snapshots
and downloads upgrade reports.

7-4 Download COP Setup
Logs

Downloads the Aruba Central On-Premises setup logs.

7-5 Restart Application Restarts the applications.

7-6 System Operations Lock
Management

Restarts a particular application.

8 Temporary Root Shell Creates a temporary user and allows access to SSH for 2 days at
a time.

9 Authentication Authenticates the SSH public keys required to connect to the
Aruba Central On-Premises server.

9-1 Display public key Displays SSH public key of the administrator of the Aruba
Central On-Premises server. This is used to establish public key
based SSH connection from the Aruba Central On-Premises
server to an external SSH server.

9-2 Add public key to COP Adds the SSH public key to the Aruba Central On-Premises
server.
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Option
Number Command Description

9-3 List all public key added
COP

Lists all the SSH public key added to the Aruba Central On-
Premises server.

10 Certificate configuration Configures the certificates.

10-1 Enable client cert strict
check

Enables strict check for client certificate validation.

10-2 Disable client cert strict
check

Disables strict check for client certificate validation.

10-3 Generate device cert Generates the device certificates.

10-4 Disable client cert strict
check for devices

Disables strict check for device certificate validation.

10-5 Apply default certificates
to Web UI and API
Gateway

Generates and applies default certificates to web UI and API
gateway.

10-6 Show Root CA Cert Downloads root CA certificate in case of COP on Bare Metal
mode deployment.

11 Search Displays a list of available command options.

System Commands
Enter the command option 1 from the main menu to reboot, shutdown, or reset the system to factory
settings.

Enter option [ 0 - 11 ]: 1

1. Reboot

2. Shutdown

3. Factory Reset

====================================

b. back

m. main menu

0. exit

Enter option [ 0 - 3 ]:

Reboot
Enter the command option 1 from the System menu to reboot the system.

Enter option [ 0 - 3 ]: 1

Are you sure you want to reboot the node (Y/N):

Shutdown
Enter the command option 2 from the System menu to shutdown the system.
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Enter option [ 0 - 3 ]: 2

Executing shutdown...

Shutdown scheduled. Node will shutdown after 1 minute.

Press [Enter] key to continue...

Factory Reset
Enter the command option 3 from the System menu to reset the system to its factory settings.
Currently, it is a complete data reset.

Enter option [ 0 - 3 ]: 3

Error: Please run the reset command from physical or remote console (ILO)

Press [Enter] key to continue...

File Operations Commands
Enter the command option 2 from the main menu to upload a file to the host.

Enter option [ 0 - 11 ]: 2

1. Upload via (SCP)

2. Upload via (SFTP)

3. Upload via (HTTP/HTTPS)

4. Download File from COP

5. Delete file

====================================

b. back

m. main menu

0. exit

Enter option [ 0 - 5 ]:

Upload via (SCP)
Enter the command option 1 from the File Operations menu to upload a file to the host over SCP.

Enter option [ 0 - 4 ]: 1

This will scp a file from the remote server to COP server

Enter remote hostname and path (username@hostname:<filepath>):

auto@10.22.158.92:/home/auto/packages.txt

Copying auto@10.22.158.92:/home/auto/packages.txt to COP server

auto@10.22.158.92's password:

packages.txt

100% 3555 4.4MB/s 00:00

Press [Enter] key to continue...

Upload via (SFTP)
Enter the command option 2 from the File Operations menu to upload a file to the host over SFTP.

Enter option [ 0 - 4 ]: 2

This will scp a file from the remote server to COP server

Enter remote hostname and path (username@hostname:<filepath>):

auto@10.22.158.92:/home/auto/inst_packages.txt
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Copying auto@10.22.158.92:/home/auto/inst_packages.txt to COP server

auto@10.22.158.92's password:

Connected to 10.22.158.92.

Fetching /home/auto/inst_packages.txt to /var/airwave/appliance/localdisk/inst_

packages.txt

/home/auto/inst_packages.txt

100% 1583 127.9KB/s 00:00

Press [Enter] key to continue...

Upload via (HTTP/HTTPS)
Enter the command option 3 from the File Operations menu to upload a file to the host over HTTP or
HTTPS.

Enter option [ 0 - 5 ]: 3

This will copy a file from the url to COP server

Enter full url path for file : http://10.22.154.165/a.html

a.html 100%

[=============================================================================>]

391.90M 106MB/s in 3.7s

Upload file successful.

Press [Enter] key to continue...

Download File from COP
Enter the command option 3 from the File Operations menu to download a file that is saved on the
host.

Enter option [ 0 - 4 ]: 3

! Files present under the directory !

cop_setup_logs inst_packages.txt packages.txt sftp.txt

Enter the file name to copy from COP server to the remote server:

packages.txt

This will scp packages.txt from localdisk to the remote server

Enter remote hostname and path (username@hostname:<filepath>):

auto@10.22.158.92:/home/auto

Copying localdisk files to auto@10.22.158.92:/home/auto

The authenticity of host '10.22.158.92 (10.22.158.92)' can't be established.

RSA key fingerprint is SHA256:e9KqvWRV5YQhrPLoJQMiKFKKWVx7ZWz2T34oF31WvpU.

Are you sure you want to continue connecting (yes/no)? yes

Warning: Permanently added '10.22.158.92' (RSA) to the list of known hosts.

auto@10.22.158.92's password:

packages.txt

100% 3555 2.9MB/s 00:00

Press [Enter] key to continue...

Delete File
Enter the command option 4 from the File Operations menu to delete the files that was uploaded by the
upload file command.
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Enter option [ 0 - 4 ]: 4

! Files present under the directory !

cop_setup_logs inst_packages.txt packages.txt sftp.txt

Enter file/directory to delete:

packages.txt

Deleting file /var/airwave/appliance/localdisk/packages.txt

Are you sure you want to delete this file(Y/N):

Y

File /var/airwave/appliance/localdisk/packages.txt deleted

Press [Enter] key to continue...

Show Commands
Show commands are used to view or display various elements of the Aruba Central On-Premises
deployment like configurations currently performed, user sessions, status, and so on.

Enter the command option 3 from the main menu to view all the show commands supported.

Enter option [ 0 - 11 ]: 3

1. Version (Detail)

2. List Files

3. Backup-Restore Status

4. Configuration

5. System

6. User Sessions

7. Clock

8. App Status

9. Cluster Status

====================================

b. back

m. main menu

0. exit

Enter option [ 0 - 9 ]:

The following section describes the set of commands that can be executed under the Show commands
category.

Version (Detail)
Enter command option 1 from the Show commands menu to display the version (Detail).

Enter option [ 0 - 9 ]: 1

COP Version: 2.5.5.0

Build: 10.0.0-GA01.139

ISO Installed: Ok

COP Software Installed: Ok

Setup Cluster: Ok

Pulling ILO details. Please wait.

HPE Smart Array P408i-a SR Gen10: "4.11"

iLO 5: "2.18 Jun 22 2020"

System ROM: "U32 v2.34 (04/08/2020)"

Press [Enter] key to continue...

List Files
Enter command option 2 from the Show commands menu to display the total number of files.
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Enter option [ 0 - 9 ]: 2

total 4

drwxr-xr-x 2 root root 4096 Jan 3 16:29 cop_setup_logs

Press [Enter] key to continue...

Backup–Restore Status
Enter command option 3 from the Show commands menu to display the backup and restore status.

Enter option [ 0 - 9 ]: 3

############################

backup/restore status

############################

{"details": [

{

"message": "Postgres backup success",

"status": "success"

},

{

"message": "Cassandra backup success",

"status": "success"

},

{

"message": "Elasticsearch backup success",

"status": "success"

},

{

"message": "Minio backup success",

"status": "success"

},

{

"message": "Tar creation success",

"status": "success"

},

{

"message": "Transferring the backup to repository success",

"status": "success"

}

],

"endedOn": "Wed, 26 Jun 2019 12:52:29 GMT",

"operation": "Backup",

"startedOn": "Wed, 26 Jun 2019 11:59:43 GMT",

"status": "Completed"

}

Configuration
Enter command option 4 from the Show commands menu to display the updated network settings,
AirWave cluster details, and NTP/Timezone information.

Enter option [ 0 - 9 ]: 4

1. Network-config/Cluster-info

2. NTP/Timezone Info

3. Show ILO IP Configuration

Enter option [ 0 - 2 ]:

n Network-config/Cluster-info—Enter command option 1 from the Configuration menu to view the
network configuration and cluster information.
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Enter option [ 0 - 3 ]: 1

Updated Network Settings

------------------------

Hostname : node182-158.arubathena.com

IP Address : 10.22.158.182

Subnet Mask : 255.255.255.0

Gateway : 10.22.158.2

DNS : 10.20.50.10

Secondary DNS : 10.20.50.25

Timezone : UTC

COP Cluster Details

-----------------------

Cluster IP : 10.22.158.27

Cluster FQDN : node3vip.arubathena.com

Pod CIDR : 172.16.0.0/16

Service CIDR : 10.3.0.0/23

Router ID : 27

Time Zone : UTC

Cluster Node Count : 3

Cluster Node List :

NAME STATUS ROLES AGE VERSION

10.22.158.181 Ready master 8h v1.14.5

10.22.158.182 Ready master 8h v1.14.5

10.22.158.77 Ready master 8h v1.14.5

n NTP/Timezone Info—Enter command option 2 from the Configuration menu to view the
NTP/Timezone info.

Enter option [ 0 - 3 ]: 2

############################

NTP Info

############################

Default NTP server configured is - ntp.ubuntu.com

############################

TimeZone Info

############################

UTC

n Show ILO IP Configuration—Enter command option 3 from the Configuration menu to view the ILO
IP configuration details.

Enter option [ 0 - 3 ]: 3

Ethernet Management Interface '1'

DHCPv4: Disabled

HostName : ILOSGH003WCDS

IPv4 Address : 10.22.155.54

Subnet Mask : 255.255.255.0

Gateway : 10.22.155.2

Primary DNS: 2001::1

Secondary DNS: 10.20.50.25

System
Enter command option 5 from the Show commands menu to display system information like usage of
memory, system information, and so on.
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Enter option [ 0 - 9 ]: 5

1. Memory/Hard disk/CPU Usage

3. Uptime

====================================

b. back

m. main menu

0. exit

Enter option [ 0 - 2 ]:

n Memory/Hard disk/ CPU Usage—Enter the command option 1 from the System menu to view the
usage of memory, hard disk, and CPU information.

Enter option [ 0 - 2 ]: 1

############################

Memory Usage

############################

total used free shared buff/cache available

Mem: 251G 113G 111G 990M 26G 137G

Swap: 0B 0B 0B

############################

Hardisk Usage

############################

Filesystem Size Used Avail Use% Mounted on

udev 126G 0 126G 0% /dev

tmpfs 26G 17M 26G 1% /run

/dev/sdb4 15G 6.0G 8.3G 42% /

tmpfs 126G 0 126G 0% /dev/shm

tmpfs 5.0M 0 5.0M 0% /run/lock

tmpfs 126G 0 126G 0% /sys/fs/cgroup

/dev/sdb3 465M 109M 328M 25% /boot

/dev/sdb2 241M 512 241M 1% /boot/efi

/dev/sdb5 15G 41M 15G 1% /secondary

/dev/sdb6 1.7T 82G 1.6T 5% /data

tmpfs 26G 0 26G 0% /run/user/1003

tmpfs 26G 0 26G 0% /run/user/1001

tmpfs 26G 0 26G 0% /run/user/1004

############################

CPU Usage

############################

%Cpu(s): 7.0 us, 2.2 sy, 0.0 ni, 90.1 id, 0.4 wa, 0.0 hi, 0.3 si, 0.0 st

Architecture: x86_64

CPU op-mode(s): 32-bit, 64-bit

Byte Order: Little Endian

CPU(s): 80

On-line CPU(s) list: 0-79

Thread(s) per core: 2

Core(s) per socket: 20

Socket(s): 2

NUMA node(s): 2

Vendor ID: GenuineIntel

CPU family: 6

Model: 85

Model name: Intel(R) Xeon(R) Gold 6138 CPU @ 2.00GHz

Stepping: 4

CPU MHz: 2866.513

CPU max MHz: 3700.0000

CPU min MHz: 1000.0000

BogoMIPS: 4000.00

Virtualization: VT-x

L1d cache: 32K
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L1i cache: 32K

L2 cache: 1024K

L3 cache: 28160K

NUMA node0 CPU(s): 0-19,40-59

NUMA node1 CPU(s): 20-39,60-79

Flags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr

n Uptime—Enter the command option 2 from the System menu to view the uptime duration of a
Aruba Central On-Premises pod.

Enter option [ 0 - 2 ]: 2

############################

uptime

############################

06:44:21 up 8:49, 7 users, load average: 17.89, 11.79, 10.51

User Sessions
Enter command option 6 from the Show commands menu to display the list of user sessions.

Enter option [ 0 - 9 ]: 6

############################

List of user sessions

############################

copadmin pts/0 2020-07-27 05:26 01:17 51432 (10.240.125.20)

ineedshell pts/1 2020-07-27 05:02 01:42 3261 (10.20.13.62)

cop_shell pts/2 2020-07-27 05:30 01:10 54299 (10.240.125.20)

copadmin pts/3 2020-07-27 05:54 . 76741 (10.240.126.221)

ineedshell pts/4 2020-07-27 06:05 00:39 47373 (10.20.13.113)

ineedshell pts/5 2020-07-27 06:11 00:32 36861 (10.20.44.187)

ineedshell pts/6 2020-07-27 06:42 00:02 68881 (10.240.130.81

)

Clock
Enter command option 7 from the Show commands menu to display the date, week, month, and time
details.

Enter option [ 0 - 9 ]: 7

Thu Aug 8 03:33:50 UTC 2019

App status
Enter command option 8 from the Show commands menu to provide the pod status of any Aruba
Central On-Premises application. Following example shows the status of the Aruba Central On-Premises
application.

Enter option [ 0 - 9 ]: 8

Enter the application name, to list all apps press Enter key:central

Enter the application name, to list all apps press Enter key:central

acp-system central-grafana-dashboard-7c845956dc-92xgj

1/1 Running

7h42m 172.16.2.94 10.22.158.181 <none> <none>
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1

central acp-ae-rapids-api-deployment-b8d794d49-4sxck

1/1 Running 0 7h30m 172.16.0.172 10.22.158.182 <none>

<none>

central acp-ae-rapids-bootstrap-deployment-789f85cbbd-dtjsb

1/1 Running 0 7h38m 172.16.4.131 10.22.158.77 <none>

central acp-ae-rapids-deployment-588b4989b5-kc58v

1/1 Running 0 7h38m 172.16.0.134 10.22.158.182 <none>

<none

central acp-ae-rapids-deployment-588b4989b5-q7mw8

1/1 Running 0 7h38m 172.16.4.130 10.22.158.77 <none>

<non

central acp-ae-rapids-deployment-588b4989b5-q7mw8

1/1 Running 0 7h38m 172.16.4.130 10.22.158.77 <none>

<none

central acp-ae-rapids-deployment-588b4989b5-xx5ks

1/1 Running 0 7h38m 172.16.2.121 10.22.158.181 <none>

central acp-device-visibility-deployment-5f97648f6f-nxq28

1/1 Running 0 7h42m 172.16.4.102 10.22.158.77 <none>

<none>

central acp-device-visibility-deployment-5f97648f6f-nxq28

1/1 Running 0 7h42m 172.16.4.102 10.22.158.77 <none>

<none>

central admin-api-deployment-7d4f4984f7-9wq5h

1/1 Running 0 7h37m 172.16.2.150 10.22.158.181 <none>

<none>

Cluster Status
Enter command option 9 from the Show commands menu to display the cluster details for Aruba
Central On-Premises.

Enter option [ 0 - 9 ]: 9

COP Cluster Details

-----------------------

Cluster IP : 10.22.158.27

Cluster FQDN : node3vip.arubathena.com

Pod CIDR : 172.16.0.0/16

Service CIDR : 10.3.0.0/23

Router ID : 27

Time Zone : UTC

Cluster Node Count : 3

Cluster Node List :

NAME STATUS ROLES AGE VERSION

10.22.158.181 Ready master 8h v1.14.5

10.22.158.182 Ready master 8h v1.14.5

10.22.158.77 Ready master 8h v1.14.5

System Configuration Commands
The System Configuration commands are used to configure system parameters like network setup,
cluster setup, timezone setup and also, upgrade the setup or perform a complete factory reset.

Enter command option 4 from the main menu to view all the system configuration commands
supported.
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Enter option [ 0 - 11 ]: 4

1. Upgrade

2. Network Setup

3. Proxy Setup

4. Setup Timezone

5. Setup NTP

6. Node Setup

7. Airgap

8. Disaster Recovery

====================================

b. back

m. main menu

0. exit

Enter option [ 0 - 7 ]:

The following section describes the set of commands that can be executed under the system
configuration category.

Upgrade
Enter command option 1 from the System Configuration commands menu to upgrade the system for
either an online user or an offline user.

Enter option [ 0 - 6 ]: 1

COP Server Status

---------------------------------------------------------

Current Version : 2.5.2.0

Latest Version : 2.5.2.0

Online Customer : true

Upgrade Status : UP_TO_DATE

Upgrade Available : false

File Transfer Completion Percentage : 0

Upgrade Stage Completion Percentage : 0

---------------------------------------------------------

Last File Transfer Status :

Last File Transfer Message :

Last File Transfer Time :

Last Upgrade Status :

Last Upgrade Message :

Last Upgrade Time :

---------------------------------------------------------

===== COP is in latest version =====

Network Setup
Prerequisite
Ensure the DNS servers, both primary and secondary configured on Aruba Central On-Premises
resolves the following FQDNs:

n central-<FQDN>

n sso-<FQDN>

n apigw-<FQDN>

n ccs-user-api-<FQDN>
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Additionally, the DNS servers must also resolve the public and private DNS namespaces required by the
organization.

Enter command option 2 from the System Configuration commands menu to setup a network
permanently or temporarily.

Enter option [ 0 - 8 ]: 2

1. Permanent (Network settings)

2. Temporary (Network settings)

3. Switch Network Interface

4. Network Link Aggregation Setup

====================================

b. back

m. main menu

0. exit

Enter option [ 0 - 4 ]:

n Permanent (Network settings)—Enter command option 1 from the Network Setup commands
menu to setup the permanent network settings.

Enter option [ 0 - 4 ]: 1

Network Settings

Hostname : ccs-1n-cophost.arubathena.com

IP Address : 10.22.154.57

Interface : eno1

Enter Subnet mask : 255.255.255.0

Enter Gateway : 10.22.154.2

Enter DNS : 10.20.50.10

Secondary DNS is optional. Press ENTER to proceed

Enter Secondary DNS : 10.20.50.25

Network settings exist; will be reset to new value

To list timezones, enter 'list'

Enter timezone : UTC

=========================== Updated Network Settings

===========================

Hostname : ccs-1n-cophost.arubathena.com

IP Address : 10.22.154.57

Subnet Mask : 255.255.255.0

Gateway : 10.22.154.2

DNS : 10.20.50.10

Secondary DNS : 10.20.50.25

Timezone : UTC

===============================================================================

=

Press [Enter] key to continue...
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n Temporary (Network settings)—Enter command option 2 from the Network Setup commands
menu to setup the temporary network settings.

Enter option [ 0 - 4 ]: 2

Network Settings

Hostname : ccs-1n-cophost.arubathena.com

IP Address : 10.22.154.57

Interface : eno1

Enter Subnet mask : 255.255.255.0

Enter Gateway : 10.22.154.2

Enter DNS : 10.20.50.10

Secondary DNS is optional. Press ENTER to proceed

Enter Secondary DNS : 10.20.50.25

Network settings exist; will be reset to new value

To list timezones, enter 'list'

Enter timezone : UTC

=========================== Updated Network Settings

===========================

Hostname : ccs-1n-cophost.arubathena.com

IP Address : 10.22.154.57

Subnet Mask : 255.255.255.0

Gateway : 10.22.154.2

DNS : 10.20.50.10

Secondary DNS : 10.20.50.25

Timezone : UTC

===============================================================================

=

Press [Enter] key to continue...

n Switch Network Interface—Enter command option 3 from the Network Setup commands menu to
switch interfaces.

Enter option [ 0 - 4 ]: 3

The network interface currently configured is: eno1

Please capture and note down current network configurations for interface, IP

Address, Subnet mask and Gateway before

proceeding further.

Current Network Settings

--------------------------

Current Interface : eno1

IP Address : 10.22.156.17

Subnet Mask : 255.255.255.0

Gateway : 10.22.156.2

DNS : 10.20.50.10

Secondary DNS : 10.20.50.15

FQDN : cop154127.arubathena.com
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Enter new interface name:

Enter valid interface name: lisst

Enter valid interface name: ens1f0

Configuring the ens1f0 network interface

Interface is up...moving on

Network Settings Being Applied

-------------------------------

Newtoek Interface : ens1f0

IP Address : 10.22.156.17

Subnet Mask : 255.255.255.0

Gateway : 10.22.156.2

DNS : 10.20.50.10

Secondary DNS : 10.20.50.15

FQDN : cop154127.arubathena.com

Network settings exist: will be reset to a new value

9f83d89df0f5

Kubernets is up...moving up

deployment.apps/coredns scaled

deployment.apps/coredns scaled

1

OK

pod "platform-config-platform-uwsgi-deployment-86dc68d4d6" deleted

updating cache, please wait

Interface is updated to ens1f0

Press [Enter] key to continue...

n You cannot switch interface from Aruba Central On-Premises CLI to a port slower than 10 Gbps.
n If all nodes are not connected to interfaces with same speed, any addition or replacement of nodes might

fail.

n Network Link Aggregation Setup—Enter command option 4 from the Network Setup commands
menu to enable network link aggregation in case of any network breakage.

Prerequisite
Before enabling bonding or LACP from Aruba Central On-Premises side, physically two ports of
switch should be connected to two ports of the server (ILO/COP box) using 10G fiber ethernet cables.

Enter option [ 0 - 4 ]: 4

1. Enable Network Link Aggregation

2. Disable Network Link Aggregation

3. Check status of Network Link Aggregation

===============================================================================

=

b. back

m. main menu

0. exit

Enter option [ 0 - 3 ]:
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o Enable Network Link Aggregation—Enter command option 1 from the Network Link Aggregation
Setup commands menu to enable network link aggregation setup.

While enabling network link aggregation (LAG) configuration, it should be first enabled on the COP side,
and then it should be enabled on the switch where Aruba Central On-Premises interfaces are
connected.

Enter option [ 0 - 3 ]: 1

Network settings exist; will be reset to new value

Network Settings

Hostname : cop-3node-dr1-node3.test.pdt1.arubaathena.com

IP Address : 10.22.155.88

Interface : ens1f0

Subnet : 255.255.255.0

Gateway : 10.22.155.2

DNS : 10.20.50.10

Secondary DNS : 10.20.50.25

To list available interface, enter 'list'

Enter second interface name for bonding: eno2

8c9a1f7dc7d0

Kubernetes is up... moving on

Network Link Aggregation Enabled

Press [Enter] key to continue...._

o Disable Network Link Aggregation—Enter command option 2 from the Network Link Aggregation
Setup commands menu to disable network link aggregation setup.

While disabling LAG, it should be disabled from the switch side first and then from COP side, otherwise
the node will not be reachable.

Enter option [ 0 - 3 ]: 2

This operation will disable Network Link Aggregation on this Node

10.22.155.88

Do you want to proceed? (Y/N) ? Y

Disabling Network Link Aggregation

8c9a1f7dc7d0

Kubernetes is up... moving on

Network Link Aggregation disabled

Press [Enter] key to continue...._

o Check Status of Network Link Aggregation—Enter command option 3 from the Network Link
Aggregation Setup commands menu to check the network link aggregation status.

Enter option [ 0 - 3 ]: 3

Network Link Aggregation is enabled on 10.22.155.88

Interface Details:



Aruba Central On-Premises 2.5.7 | User Guide 128

Interface: ens1f0 :: Status: Running

Interface: ens1f1 :: Status: Down

Network Link Aggregation not enabled on 10.22.155.86

Network Link Aggregation not enabled on 10.22.155.87

Press [Enter] key to continue....

n Network Link Aggregation(LAG) can be enabled and disabled per node basis only from the ILO console.
n In order for LAG to work end to end, LAG should be enabled or disabled from switch as well as COP

side.
n Switching interface is not allowed when LAG is enabled.
n Link Aggregation (LAG) setting will be available only when the cluster setup is completed.

Proxy Setup
Enter command option 3 from the System Configuration menu to add, delete, or get proxy URL.

Enter option [ 0 - 8 ]: 3

1. Add Proxy

2. Delete Proxy

3. Get Proxy

Enter option [ 0 - 3 ]:

n Add Proxy—Enter command option 1 from the Proxy Setup commands menu from the Proxy Setup
menu to add a proxy URL.

Enter option [ 0 - 3 ]: 1

Enter the proxy url:

Enter Port:

Enter username(optional):

Enter password(optional):

Enter option [ 0 - 3 ]: 1

Enter the proxy url: www.techpubs.com

Enter port: 98

Enter username(optional):

Enter password(optional):

n Delete Proxy—Enter command option 2 from the Proxy Setup commands menu menu to delete a
proxy.

Enter option [ 0 - 3 ]: 2

Proxy deleted

Press [Enter] key to continue...

n Get Proxy—Enter command option 3 from the Proxy Setup menu to get the details of a proxy.

Enter option [ 0 - 3 ]: 3

"url": "10.22.154.228",
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"username": "admin",

"password": "",

"port": "3128"

Setup Timezone
Enter command option 4 from the System Configuration menu to setup a timezone.

Enter option [ 0 - 8 ]: 4

To list timezones, enter 'list'

Enter timezone [UTC]: GMT

Setting TimeZone for other nodes in this cluster...

configmap/airwave-config patched (no change)

Press [Enter] key to continue...

Setup NTP
Enter command option 5 from the System Configuration menu to setup NTP.

Enter option [ 0 - 8 ]: 5

Enter primary NTP server : 10.22.158.230

Enter secondary NTP server (Optional) :10.22.154.165

Enter tertiary NTP server (Optional):

Is NTP Authentication required (y/n) :

n

Configuring NTP for node : 10.22.154.57

10.22.158.230 NTP configured on node 10.22.154.57

10.22.154.165 NTP configured on node 10.22.154.57

NTP is configured node : 10.22.154.57

Press [Enter] key to continue...

All the nodes in a multi-cluster must synchronize to the same NTP server. Run the command
NTP/Timezone info to verify if all the nodes are synchronized with the same NTP server. To run the
NTP/Timezone info, enter command option 2 from the show configuration menu.

You also have an option to authenticate the NTP server by using the secure key.

n If you are using iLO when configuring NTP servers and require the secure key to authenticate the NTP
server, you must either use the WebUI or CLI to copy the NTP server key. The copy and paste operation is
not supported on the iLO console. Logon to the CLI with iLO credentials and use the VSP command to get
the secure key.

n If the Setup NTP command is executed after the cluster is configured, then the modified details of NTP
server is updated to the cluster. If cluster is not configured, then the modified NTP server details is
updated only to the node.

Node Setup
Enter command option 6 from the System Configuration menu to setup a node.
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Enter option [ 0 - 7 ]: 6

1. Add node

2. Replace node

3. Status

====================================

b. back

m. main menu

0. exit

Enter option [ 0 - 3 ]: 1

Enter node ip(s) to be added to the cluster separated by space:10.22.154.237

10.22.154.238

10.22.154.237

10.22.154.238

Add job 'platform-config-node-mgmt-job-nwcbs' under progress...

n Add node—Enter command option 1 from the Node Setup menu to add IP addresses to the cluster.

Enter option [ 0 - 3 ]: 1

Enter node ip(s) to be added to the cluster separated by spaces:

n Replace node—Enter command option 2 from the Node Setup menu to replace an existing node ip
with another in the cluster.

When replacing a node in the cluster, ensure that IP address of the new node is not same as the old node.

Enter option [ 0 - 3 ]: 2

Enter existing node ip to be replaced from the cluster:

Enter new node ip:

n Status—Enter command option 3 from the Node Setup menu to view the system operation details.

Enter option [ 0 - 3 ]: 3

Active system operation details

-------------------------------------------

operation type: Replace node

operation state: SUCCESS

start time: Wed Nov 23 15:30:03 UTC 2022

end time: Wed Nov 23 15:45:04 UTC 2022

operation data: Old node - 10.22.154.142, New node - 10.22.154.226, Execute

node - 10.22.154.137, Job name - platform

- config-node-mgmt-job-gm6z9

--------------------------------------------

Airgap
Enter command option 7 from the System Configuration menu to enable or disable Airgap mode for
upgrade. Enabling Airgap allows you to upgrade the Aruba Central On-Premises setup offline without
any internet access.
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Enter option [ 0 - 8 ]: 7

1. Enable Airgap

2. Disable Airgap

3. Status

====================================

b. back

m. main menu

0. exit

n Enable Airgap—Enter command option 1 from the Airgap menu to enable the same.

Enter option [ 0 - 3 ]: 1

Changing of Airgap mode requires restart of services and is recommended ONLY in

maintenance window.Do you want to continue?(Y/N):

n Disable Airgap—Enter command option 2 from the Airgap menu to disable the same.

Enter option [ 0 - 3 ]: 2

Airgap is already disabled.

Press [Enter] key to continue...

n Status—Enter command option 3 from the Airgap menu to see the status.

Enter option [ 0 - 3 ]: 3

Airgap is already disabled.

Press [Enter] key to continue...

Disaster Recovery
Enter command option 8 from the System Configuration menu to handle upgrade for disaster recovery
in Aruba Central On-Premises network. For more information, see Datacenter Redundancy.

Enter option [ 0 - 8 ]: 8

1. Show Disaster Recovery Status

2. Configure Disaster Recovery

3. Automatic Failover

4. Restore Frequency

5. Time to Failover

6. Initiate Switchover

7. Remove Disaster Recovery Configuration

====================================

b. back

m. main menu

0. exit

Enter option [ 0 - 5 ]:

n Show Disaster Recovery Status—Enter command option 1 from the Disaster Recovery commands
to display the disaster recovery status of the primary cluster.
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Enter option [ 0 - 5 ]: 1

----------------------------------

Disaster Recovery configuration

----------------------------------

Peer Cluster FQDN : central-cop-1node-dr-

vip.test.pdt1.arubathena.com

Initial Role : Secondary

Time to Failover (Minutes) : 15

Automatic Failover : True

Restore Frequency(Days) : 3

--------------------

State Data

--------------------

Cluster Role : Secondary

Primary Since : 0

--------------------

Health Info

--------------------

Disaster Recovery Health Status : Good

Failover In-Progress : False

Heartbeat Status : Successful

Failover Status : Successful

HB Failure Count : 0

Last heartbeat from Peer : Jun 19, 2023, 10:31

Last Failover Time : Jun 12, 2023, 05:58

Restore Status : Successful

Last Restore Time : Jun 17, 2023, 11:06

--------------------

Peer Health Info

--------------------

Peer Disaster Recovery Health Status : Error (Pairing Key mismatch)

Peer Heartbeat Status : Pairing Key mismatch

Peer Failover Status : Successful

Press [Enter] key to continue...

n Configure Disaster Recovery—Enter command option 2 from the Disaster Recovery commands to
configure the secondary cluster in the network.

n The version of the secondary cluster must be same as the primary cluster.
n Secondary cluster can download the running Aruba Central On-Premises build, but cannot be

upgraded until primary cluster is upgraded.

1.Show Config

2.Show Disasater Recovery Pairing Key

3.Configure

4.Enable Redundancy

5.Diasble Redundancy

=====================================

b. back

m. main menu

0. exit

Enter option [0 - 5]:
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o Show Config—Enter option 1 from the Configure Disaster Recovery commands to display the
configuration specification of the secondary cluster.

Enter option [0 - 5]: 1

-----------------------------------------

Disaster Recovery configuration

-----------------------------------------

Peer Cluster FQDN : central-cop-lnode-dr-vip-

test.pdtl.arubaathena.com

Initial Role : Secondary

Time to Failover (Minutes) : 15

Automatic Failover : True

Restore Frequency (Days) : 3

Press [Enter] key to continue...

o Show Disaster Recovery Pairing Key—Enter option 2 from the Configure Disaster Recovery
commands to display the disaster recovery pairing key.

Enter option [0 - 5]: 2

eyJbHvyX2FtnjuiTh2YfhvdezxiKloiNhytfVbnhgt34Jirfcvdsa

aHR0HNc1JoiungfcVyhgfr56FTkijolpuU89nhupjjFrtgvczswRT

alpXmxWRThkIn0=

Press [Enter] key to continue...

o Configure—Enter option 3 from the Configure Disaster Recovery commands to configure the
secondary cluster for disaster recovery.

Enter option [0 - 5]: 3

Disaster Recovery is already configured. Do you want to continue(Y/N)?

o Enable Redundancy—Enter option 4 from the Configure Disaster Recovery commands to enable
data center redundancy. You can also enable data center redundancy from the Aruba Central On-
Premises user interface. For more information, see Datacenter Redundancy.

Enter option [0 - 5]: 4

Disaster Recovery is already enabled.

Press [Enter] key to continue...

o Disable Redundancy—Enter option 5 from the Configure Disaster Recovery commands to enable
data center redundancy. You can also enable data center redundancy from the Aruba Central On-
Premises user interface. For more information, see Datacenter Redundancy.



Aruba Central On-Premises 2.5.7 | User Guide 134

Enter option [0 - 5]: 5

Changing of Disaster Recovery mode requires restart of services and is

recommended ONLY in maintenance window. Do you want to continue (Y/N)?

n Automatic Failover—Enter command option 3 from the Disaster Recovery commands to enable or
disable automatic failover for disaster recovery.

1.Disable

2.Enable

=====================================

b. back

m. main menu

0. exit

Enter option [0 - 2]:

o Disable—Enter option 1 from the Automatic Failover commands to disable automatic failover.

Enter option [0 - 2]: 1

Warning: Automatic Failover will be disabled. Do you want to continue (Y/N)?

o Enable—Enter option 1 from the Automatic Failover commands to enable automatic failover.

Enter option [0 - 2]: 2

Automatic Failover is already enabled.

Press [Enter] key to continue...

n Initiate Switchover—Enter command option 4 from the Disaster Recovery commands to initiate
Aruba Central On-Premises cluster switchover.

Enter option [0 - 5]: 4

Current role is Secondary.

Warning: Failover will be initiated. Devices may disconnect and come up on the

new primary. Do you want to continue (Y/N)?

n Remove Disaster Recovery Configuration—Enter command option 5 from the Disaster Recovery
commands to disaster recovery configuration from the Aruba Central On-Premises network.

Enter option [0 - 5]: 5

Disable Redundancy feature and Remove Disaster Recovery Configuration.

Advanced Commands
Enter command option 5 from the main menu to check test connectivity and NsLookup.
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Enter option [ 0 - 11 ]: 5

1. Test Connectivity

2. NsLookup

3. Toggle CDN

4. Configure ILO IP

====================================

b. back

m. main menu

0. exit

Test Connectivity
Enter command option 1 from the Advanced commands menu to test the connectivity to any URLs.

Enter option [ 0 - 4 ]: 1

1. Ping

2. Dependent Servers Reachability

====================================

b. back

m. main menu

0. exit

Enter option [ 0 - 2 ]:

n Ping—Enter command option 1 from the Test Connectivity menu to ping an IP address or hostname.

Enter option [ 0 - 2 ]: 1

Enter the IP address or hostname to ping:10.22.154.56

PING 10.22.154.56 (10.22.154.56) 56(84) bytes of data.

64 bytes from 10.22.154.56: icmp_seq=1 ttl=63 time=0.473 ms

64 bytes from 10.22.154.56: icmp_seq=2 ttl=63 time=1.61 ms

64 bytes from 10.22.154.56: icmp_seq=3 ttl=63 time=2.63 ms

64 bytes from 10.22.154.56: icmp_seq=4 ttl=63 time=1.58 ms

64 bytes from 10.22.154.56: icmp_seq=5 ttl=63 time=2.99 ms

n Dependent Servers Reachability—Enter command option 2 from the Test Connectivity menu to
check the reachability of the dependent servers.

Enter option [ 0 - 2 ]: 2

Connection to coreupdate (coreupdate.central.arubanetworks.com) successful.

Connecting to coreupdate(coreupdate-prod.central.arubanetworks.com) ...

You are going to access FED system .

Required policy

1 LINE 1

2 LINE 2

3 LINE 3

4 LINE 4

5 LINE 5

Connection to coreupdate (coreupdate-prod.central.arubanetworks.com)

successful.

Connecting to quay(quay.io) ...

You are going to access FED system .



Aruba Central On-Premises 2.5.7 | User Guide 136

Required policy

1 LINE 1

2 LINE 2

3 LINE 3

4 LINE 4

5 LINE 5

Connection to quay (quay.io) successful.

Connecting to nexus(nexus2.airwave.com) ...

Connection to nexus(nexus2.airwave.com) successful.

----- All dependent HTTP(S) servers are reachable -----

Press [Enter] key to continue...

NsLookup
Enter option 2 from the Advanced commands menu to get the DNS lookups for any host names.

Enter option [ 0 - 4 ]: 2

Enter the hostname or IP Address for NS Lookup:google.com

../../../lib/dns/hmac_link.c:349:

Server: 10.20.50.10

Address: 10.20.50.10#53

Non-authoritative answer:

Name: google.com

Address: 142.250.76.46

Name: google.com

Address: 2404:6800:4007:814::200e

Press [Enter] key to continue...

Toggle CDN
Enter command option 3 from the Advanced commands menu to enable CDN, disable CDN , or show
CDN Status.

Enter option [ 0 - 4 ]: 3

1. Enable CDN

2. Disable CDN

3. Show CDN status

====================================

b. back

m. main menu

0. exit

Enter option [ 0 - 3 ]:

n Enable CDN—Enter command option 1 from the Toggle CDN commands menu to enable CDN.

Enter option [ 0 - 3 ]: 1

CDN enabled

Press [Enter] key to continue...
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n Disable CDN—Enter command option 2 from the Toggle CDN commands menu to disable CDN.

Enter option [ 0 - 3 ]: 2

CDN enabled

Press [Enter] key to continue...

n Show CDN Status—Enter command option 3 from the Toggle CDN commands menu to show the
status of CDN.

Enter option [ 0 - 3 ]: 3

{

"monitoring": "//d1c50u1zbkqmph.cloudfront.net",

"configuration": "//d1c50u1zbkqmph.cloudfront.net",

"base": "//d1c50u1zbkqmph.cloudfront.net",

"enabled": false,

"guest": "//d1c50u1zbkqmph.cloudfront.net",

"msp": "//d1c50u1zbkqmph.cloudfront.net"

}

Configure ILO IP
Enter command option 4 from the Advanced commands menu to configure the IP address of the ILO.

Enter option [ 0 - 4 ]: 4

Enter IP Address: 10.22.155.100

Enter Subnet mask: 255.255.255.0

Enter Gateway: 10.22.155.2

Enter DNS: 10.20.50.10

Enter Secondary DNS: 10.20.50.25

10.22.155.100

ILO IP configuration successful

Security Commands
Enter the command option 6 from the main menu to either reset the GUI or CLI password or update the
iLO password.

Enter option [ 0 - 11 ]: 6

1. Reset Password GUI

2. Reset Password CLI

3. Reset debug apps password

====================================

b. back

m. main menu

0. exit

Enter option [ 0 - 3 ]:

Reset Password GUI
Enter the command option 1 from the Security Commands menu to reset the GUI password.
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Enter option [ 0 - 3 ]: 1

Do you want to reset GUI admin user password(y/n) :

Reset Password CLI
Enter the command option 2 from the Security commands menu to reset the CLI password.

Enter option [ 0 - 3 ]: 2

Do you want to reset copadmin password(y/n) :

Reset debug apps password
Enter the command option 3 from the Security commands menu to reset the debug apps password.

Enter option [ 0 - 3 ]: 3

Do you want to reset debug apps password(y/n) :

Support Commands
Enter the command option 7 from the main menu to start or stop the support connection, collect logs,
and restart a particular application.\

Enter option [ 0 - 11 ]: 7

1. Support Connection

2. Collect All Logs

3. Log Snapshot Operations

4. Download COP Setup Logs

5. Restart Application

6. System Operations Lock Management

7. Enable disable services (Grafana/Kibana)

====================================

b. back

m. main menu

0. exit

Enter option [ 0 - 7 ]:

Support Connection
Enter the command option 1 from the Support commands menu to start, stop, restart the support
connection from remote TAC access or check the status of the support connection and upload the
support connection file.

Enter option [ 0 - 7 ]: 1

1. Start Support Connection

2. Stop Support Connection

3. Restart Support Connection

4. Support Connection Status

5. Upload Support Connection File

6. Add Support User 'copsupport'

7. Delete Support User 'copsupport'

8. Show contents of copsupport.gpg

====================================
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b. back

m. main menu

0. exit

Enter option [ 0 - 8 ]: 1

n Start Support Connection—Enter command option 1 from the Support Connection commands
menu to start a support connection.

Enter option [ 0 - 8 ]: 1

{

"support_connection_status": "stopped",

"active_from": "_",

"connection": "inactive"

}

Press [Enter] key to continue...

n Stop Support Connection—Enter command option 2 from the Support Connection commands
menu to stop a support connection.

Enter option [ 0 - 8 ]: 2

{

"support_connection_status": "stopped"

}

Press [Enter] key to continue...

n Restart Support Connection—Enter command option 3 from the Support Connection commands
menu to restart a support connection.

Enter option [ 0 - 8 ]: 3

{

"support_connection_status": "stopped"

}

{

"support_connection_status": "stopped",

"active_from": "_",

"connection": "inactive"

}

Press [Enter] key to continue...

n Support Connection Status—Enter command option 4 from the Support Connection commands
menu to check the status of the support connection.

Enter option [ 0 - 8 ]: 4

{

"support_connection_status": "stopped",

"active_from": "_",

"connection": "inactive",

"node": "_"

}

Press [Enter] key to continue...
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n Upload Support Connection File—Enter command option 5 from the Support Connection
commands menu to upload the support connection file.

Enter option [ 0 - 8 ]: 5

This will scp a file from the remote server to cop server

Enter remote hostname and path (username@hostname:<filepath>):

auto@10.22.158.92:/home/auto/support_connection.tar

Copying auto@10.22.158.92:/home/auto/support_connection.tar to COP server

auto@10.22.158.92's password:

Connected to 10.22.158.92.

Fetching /home/auto/isupport_connection.tar to

/var/airwave/appliance/localdisk/support_connection.tar

/home/auto/support_connection.tar

100% 1988 127.9MB/s 00:00

Press [Enter] key to continue...

n Add Support User 'copsupport'—Enter command option 6 from the Support Connection
commands menu to add support connection for user, copsupport.

Enter option [ 0 - 8 ]: 6

copsupport user account expires on: Mar 10, 2022 8 10:48:17

-----BEGIN PGP MESSAGE-----

hQIMA0wNcZIn82zzAQ//bj0kS7h2s2wMJWX0JlYcfX053lFjWUa2XqHJ5xKk1OP7

jzvVRw+yFApKy5R0DP1RbXnifLHFGGxZx+x40H592agTehIqrI3L5put4Ewi/uK2

RZg9znigDmTe8jKTNWIbrN80VBpTz4QXaArD+4yhAJ80JFhFyFij9fWz1dSCwIUj

oej3JpKtDzVNmRZqANje8HeF62Y6WYWXFFn8VrzBPaasIPk1KQU5MZEKXtZyB3zD

nmi3IyM5rF/+uqFniR7vYlQfYXwySB17ToPKvjbO4tvEt5WWwfXeEg+DczdNkdIz

EpxXwgoby958Le0xCgcV8efbRtGCkxrtks37pPMAGJlVc0qtSJ/74DZc/BHD0WrZ

r4euZjWD/F1Eaxq56nMUHal0jzyLVj5w7DP5Rhj9mnCYl+jsy6ZTIbxpfDzembUF

LwTbVdjrbq79Ib+RFSHMUwFCv9CPGMjMmCJokYpdL82wksdJyOaWwF4AclmA19sU

IuyUtwiXb5bZqwCM0N3+mVQhaUqti0Xu4K5K5E8kSje3QOAyUz0ogS9axGkJQUWx

FpthJUF8ZKwH/tHU07K/So5LhahMcIa+qnCxycUC1X9G5R9EhvpGzEEQrUwy59lp

zCz9w4M0ON/QwNh4IVssnZMTW6WLUv0r9fHEjnJAj/toIsRAVbKSAMgzXKNiwc/S

dQEKZuFfFlPufJW4BWIoAn5PeThJQOrNlKxocI+e3H7eUKMZVof38MACsl6DJdy+

RCVrl4Wie3Ek/i2jXawz9QhBQza5c6BhdnjWqhQ+U9swEB0REnUbTqlaVhTXNVnW

qMGdxD77nPuKKJuTluTONXJLdsF0KA==

=gWUQ

-----END PGP MESSAGE-----

Press [Enter] key to continue...

n Delete Support User 'copsupport'—Enter command option 7 from the Support Connection
commands menu to delete support connection for the user, copsupport.

Enter option [ 0 - 8 ]: 7

Are you sure you want to delete support user 'copsupport' (Y/N)y

Removing user `copsupport' ...

Done.

Support user 'copsupport' deleted successfully.

Press [Enter] key to continue...
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n Show contents of copsupport.gpg—Enter command option 8 from the Support Connection
commands menu to show the contents of copsupport.gpg file.

Enter option [ 0 - 8 ]: 8

-----BEGIN PGP MESSAGE-----

hQIMA0wNcZIn82zzARAAmuLy9Jure2AHc9/oSKXc0OEZ9ZW35O6r+mvWFk98zrMz

V1IW4wocFj1KhcpfMnMZ0O/nBY0oZIb1CK6CpLnaxFAM+T6NLv7Kroz6wqKfVSt8

pjsrmSh3eyfmMK9FlIkU3u2LglB9xUxMFGqjgvqTqcieqwzWFG5LmK1ALUWsUMoE

4PsWTTdVO+gRGkx17hsa7c9US0iVFaeOQJBdfCnOgP3rfqJzoVhbnL3JEnJSZrYs

R/sBIB47LNyw+E0i5ei8mbZ6S3rlWOCexxqFIdmyw+S52xrDPcACW/oqcnW31ubh

u6jD4JqSZqavaf+QZKM80/I0r9N0jAXMExCkOT0TQX3mmg5K5pFgo38j5hnifXTN

O+3rAcjRAgWhu1Nq3+1qpdG0esBCYPGdVs5f2mOej+cNBIsfg+RTemejOa71IeVf

R4/NWpMJa0STYk3/qSybEXjLiYxwwwsJILiqjfE5TVKOcAJhoUVyTH/8t9l4zn+/

qASXne52ocPaa4lxI3SxKGKz159cYcQxlXsJh+CS6RudZaAh8m/WKtWi2g2SqGhk

UsnJXttG5ruFnbFQPk1DdUSPnSzy4SZaBnwC0fvwkbQNUhTuYJmgQEQe8M9on5su

swhivSLvWYZTg6EYTlRveMRjh/iMbsDqp/ylsKH21jLQf9QA+tBM8yuPTmgAjPPS

dQH6+RPsiSlhdjkWnH6ZItIwX1WB1DpZaBjjx/PTTG+7Wi5XerA+8v1liJJOo6X/

yIdMnqlrGrQALRO/xPAXJUc4pQxXIDgHpWTQd3VWlCX5oSl2tPIiUAeq5iDds3vS

5KgqEvskPIeY9BJyMWa+LX2sx175HQ==

=t1Xn

-----END PGP MESSAGE-----

Press [Enter] key to continue...

Collect All Logs
Enter the command option 2 from the Support commands menu to collect the log files into a tar.gz file.

Enter option [ 0 - 7 ]: 2

cluster_log_collection...

Collect COP logs along with diagnostic information (Y/N):Y

Collecting all logs from Elasticsearch takes around 1-3 hours.

It can be also collected from "Log Snapshot Operations" by selecting all as cate

gory.

Do you want to collect logs from Elasticsearch(Y/N):Y

Collecting COP diagnostic information may take 2-5 minutes

COP diagnostic information dumped and will be zipped to logs as well

Starting Elasticsearch snapshot for all logs...

Logs are being collected from 10.22.156.209 now @Tue Feb 8 11:15:25 UTC 2022

tar: /var/log/snmp: Cannot open: No such file or directory

tar: Error is not recoverable: exiting now

0

kubectl exec [POD] [COMMAND] is DEPRECATED and will be removed in a future

version. Use kubectl kubectl exec [POD] -- [COMMAND] instead.

mv: cannot stat 'cop-156-209.arubathena.com_log_collection_2022-02-08_11-15-25_

UTC.tar.gz': No such file or directory

log_compression...

The following archive(tar.gz) contains all the log information to help debugging

the problem:

cop-156-209.arubathena.com_log_collection_2022-02-08_11-14-18_UTC.tar.gz

Please share it with COP customer support team.

cp: cannot stat '/home/copadmin/log_collection': No such file or directory

Press [Enter] key to continue...
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Log Snapshot Operations
Enter the command option 3 from the Support commands menu to generate and download snapshots
for a category or node, generate logs for various pods, delete snapshots, and download upgrade
reports.

Enter option [ 0 - 7 ]: 3

1. Generate Snapshots for a Category

2. Generate System Operation Logs

3. Generate Pod Logs

4. Generate Node Snapshot

5. Download Logs/Snapshots

6. Delete Logs/Snapshots

7. Download Upgrade Reports

====================================

b. back

m. main menu

0. exit

Enter option [ 0 - 7 ]:

n Generate Snapshots for a Category—Enter command option 1 from the Log Snapshot Operations
commands menu to collect log snapshots of specific categories (kube. nginx, alert, infra, syslog, and
system).

Enter option [ 0 - 7 ]: 1

Enter a category to create the snapshot [kube nginx alert infra syslog system

all]... alert

Enter the time range for snapshot creation [3h, 1d, 1w, 1M, 3M]... 1w

{ "status": "Accepted", "snapshotId": "alert-snap-7d-1644406412" }

Press [Enter] key to continue...

n Generate System Operation Logs—Enter command option 2 from the Log Snapshot Operations
commands menu to collect system operation logs.

Enter option [ 0 - 7 ]: 2

Enter a category to create the snapshot [upgrade backuprestore migration]...

migration

% Total % Received % Xferd Average Speed Time Time Time Current

Dload Upload Total Spent Left Speed

100 105 100 105 0 0 652 0 --:--:-- --:--:-- --:--:-- 660

{ "status": "Accepted", "snapshotId": "migration-plain-1m-1644910302",

"category": "migration" }

Press [Enter] key to continue...

n Generate Pod Logs—Enter command option 3 from the Log Snapshot Operations commands menu
to collect pod logs.

Enter option [ 0 - 7 ]: 3

Enter a pod name to generate logs... postgres-cluster-0
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{ "status": "Accepted", "snapshotId": "postgres-cluster-0-1m-1644410009",

"category": "pod" }

Press [Enter] key to continue...

n Generate Node Snapshot—Enter command option 4 from the Log Snapshot Operations commands
menu to collect log snapshots for specific nodes.

Enter option [ 0 - 7 ]: 4

Enter node to generate logs [10.22.154.57]... 10.22.154.57

{ "status": "Accepted", "snapshotId": "10.22.154.57-snap-1m-1644410130" }

Press [Enter] key to continue...

n Download Logs/Snapshots—Enter command option 5 from the Log Snapshot Operations
commands menu to download the log snapshot file.

Enter option [ 0 - 7 ]: 5

List of available snapshots and their status

----------------------------------------------------------------

create time snapshot name status

----------------------------------------------------------------

2022-02-08 11:12:35, "all-snap-7d-1644318755": "in_progress"

----------------------------------------------------------------

Select a name to be downloaded (without quotes)...

n Delete Logs/Snapshots—Enter command option 6 from the Log Snapshot Operations commands
menu to delete log snapshots.

Enter option [ 0 - 7 ]: 6

List of available snapshots and their status

----------------------------------------------------------------

create time snapshot name status

----------------------------------------------------------------

2022-02-08 11:12:35, "all-snap-7d-1644318755": "in_progress"

----------------------------------------------------------------

Select a name to be deleted (without quotes)...

n Download Upgrade Reports—Enter command option 7 from the Log Snapshot Operations
commands menu to download upgrade reports.

Enter option [ 0 - 7 ]: 7

Added `minio` successfully.

mc: Configuration written to `/home/copadmin/.mc/config.json`. Please update

your access credentials.

mc: Successfully created `/home/copadmin/.mc/share`.
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mc: Initialized share uploads `/home/copadmin/.mc/share/uploads.json` file.

mc: Initialized share downloads `/home/copadmin/.mc/share/downloads.json` file.

mc: <ERROR> Unable to validate source minio/deployment/

Press [Enter] key to continue...

Download COP Setup Logs
Enter the command option 4 from the Support commands menu to download the Aruba Central On-
Premises setup logs.

Enter option [ 0 - 7 ]: 4

################################################################################

SCP would be used to copy the logs to a remote host

################################################################################

Enter remote hostname and path (username@hostname:<filepath>):

Restart Application
Enter the command option 5 from the Support commands menu to restart applications.

Enter option [ 0 - 7 ]: 5

Enter an application name to restart:

System Operations Lock Management
Enter the command option 6 from the Support commands menu to manage the system operations lock
management.

Enter option [ 0 - 7 ]: 6

1. Lock status

2. Release Lock

3. Update Lock Setting

====================================

b. back

m. main menu

0. exit

Enter option [ 0 - 3 ]:

n Lock status—Enter command option 1 from the System Operations Lock Management commands
menu to lock the status of the system operation.

Enter option [ 0 - 3 ]: 1

No system operation is active currently

Press [Enter] key to continue...

n Release Lock—Enter command option 2 from the System Operations Lock Management commands
menu to release the lock of the system operation.
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Enter option [ 0 - 3 ]: 2

1. Upgrade

2. Backup

3. Restore

4. Migration

5. Add node

6. Replace node

7. Reboot node

====================================

b. back

m. main menu

0. exit

Enter option [ 0 - 7 ]:

n Update Lock Setting—Enter command option 3 from the System Operations Lock Management
commands menu to update the lock settings of the system operation.

1. on

2. off

====================================

b. back

m. main menu

0. exit

Enter option [ 0 - 2 ]: 1

Do you really want to update system operation lock settings?(y/n):

Temporary Root Shell Commands
Enter command option 8 from the main menu to create a temporary user, cop_shell with a random
password and the system encrypts this password. Provide this key to the customer support. The
customer support will then be able to access the Aruba Central On-Premises SSH using the username,
cop_shell for 2 days from the date of creation.

Use this option to get access to the Shell for a limited period of time for checking pods, collecting logs,
or for executing other CLI commands. This is useful if you want to troubleshoot or debug an issue.

Enter option [ 0 - 11 ]: 8

This will reset the previous COP root shell's pwd. proceed? (y/n): Y

No changes made.

Press [Enter] key to continue...

After the expiry, you can repeat the same process to extend the temporary root access by another 2 days.

Authentication Commands
Enter the command option 9 from the main menu to authenticate the SSH public keys required to
connect to the Aruba Central On-Premises server.
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Enter option [ 0 - 11 ]: 9

1. Display public key

2. Add public key to COP

3. List all public key added COP

====================================

b. back

m. main menu

0. exit

Enter option [ 0 - 3 ]:

Display public key
Enter the command option 1 from the Authentication commands menu to display SSH public key of the
administrator of the Aruba Central On-Premises server. This is used to establish public key based SSH
connection from the Aruba Central On-Premises server to an external SSH server.

Enter option [ 0 - 3 ]: 1

Public key for COP

ssh-rsa

AAAAB3NzaC1yc2EAAAADAQABAAABAQCgvtkfzXgG4AbaLsoJrdqbtdegGQ/NojIYZUDNQuYdNDXZm/Ti88

5MLzwuqJbv8GOlOd8vEor+YcQtJcWCjaBz7gZ2ZKUfC8qHyoErA1TnY52b1a+djSLg05xnZSwMYmbsGW+1

46U2BgYsrcILltsWzoq8RZCNqZ2So6CiwjBLx6LGXQaszXePLm1VkpuVKE17SXmyGFEzYuq/p4VmE5u45s

71PsqV/wIcuvHvMjdZg9YBP1MOHNDpFclvjujZ/6tG8X55DAhszcwW30xjIQTEHBN0wHdSkLIaW4S9xq6x

uw47Ez3lLGSpgB+fAclc34jL00lPHINVdUX2SY6lo93r core@cop-156-209.arubathena.com

Press [Enter] key to continue...

Add public key to COP
Enter the command option 2 from the Authentication commands menu to add the SSH public key to the
Aruba Central On-Premises server.

Enter option [ 0 - 3 ]: 2

Enter key in SSH format:

ssh-rsa

AAAAB3NzaC1yc2EAAAADAQABAAABAQDkg8xcD5bhfBX/SztxI4cME1IYs0+i7if28MXSHjmlwThlmKVSJE

kk+YuqeY8fq7seD2OuTP0snanQ4BbMdophZmJhR/Fx6Z9rDyAYRw+Uu7ViC0ot6WbQ3ilDiEihWIYTOYrA

mLMHx8Div4tHWBJ4sjI940Sr5bMpgEMczrl9TOSoHWLc1re1Y6UfTBNKHST0Nyfrnor1QgoUyiD6sN0KZX

vmp+8EGe8thq4wpNcbq/OJmndP5J40j05OSXLJCchvwgM5ZHK3ifd5KwNtj6JkZw9KHOVvIsvnzbe8kA7r

cTITn1C/XYOWpUUSX/TbhkXgSa/z7negg9YzXuqjgfkx core@cop-dev-jenkins1.arubathena.com

ssh-rsa

AAAAB3NzaC1yc2EAAAADAQABAAABAQDkg8xcD5bhfBX/SztxI4cME1IYs0+i7if28MXSHjmlwThlmKVSJE

kk+YuqeY8fq7seD2OuTP0snanQ4BbMdophZmJhR/Fx6Z9rDyAYRw+Uu7ViC0ot6WbQ3ilDiEihWIYTOYrA

mLMHx8Div4tHWBJ4sjI940Sr5bMpgEMczrl9TOSoHWLc1re1Y6UfTBNKHST0Nyfrnor1QgoUyiD6sN0KZX

vmp+8EGe8thq4wpNcbq/OJmndP5J40j05OSXLJCchvwgM5ZHK3ifd5KwNtj6JkZw9KHOVvIsvnzbe8kA7r

cTITn1C/XYOWpUUSX/TbhkXgSa/z7negg9YzXuqjgfkx core@cop-dev-jenkins1.arubathena.com

Adding keys to authorized user

Add keys to node : 10.22.154.57

authorized_keys

100% 1234 2.7MB/s 00:00

ssh-rsa

AAAAB3NzaC1yc2EAAAADAQABAAABAQDkg8xcD5bhfBX/SztxI4cME1IYs0+i7if28MXSHjmlwThlmKVSJE

kk+YuqeY8fq7seD2OuTP0snanQ4BbMdophZmJhR/Fx6Z9rDyAYRw+Uu7ViC0ot6WbQ3ilDiEihWIYTOYrA

mLMHx8Div4tHWBJ4sjI940Sr5bMpgEMczrl9TOSoHWLc1re1Y6UfTBNKHST0Nyfrnor1QgoUyiD6sN0KZX

vmp+8EGe8thq4wpNcbq/OJmndP5J40j05OSXLJCchvwgM5ZHK3ifd5KwNtj6JkZw9KHOVvIsvnzbe8kA7r

cTITn1C/XYOWpUUSX/TbhkXgSa/z7negg9YzXuqjgfkx core@cop-dev-jenkins1.arubathena.com

ssh-rsa
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AAAAB3NzaC1yc2EAAAADAQABAAABAQC02/Bp28axKaL8COmDl1OVxAygmcXd/s97cDxOcej5JT57LvpDLf

BqU4neyIZOTj+bWZxqnYcEpqd7p8tx8dWFgl0ap2GcENoO2YUlLMSUqW7JnCoHfkOV2xLvS3AU9MN3qj+u

XfRGt4u7N02jbIuMWcdy/xU1YkWAKTnc89zGuf50ujn+s0hQR8XVZFPIcxQyql5AJw1w4rKk1q26TkFZYE

1YNOpbWZSwV9nCW79bki7tzBhVqPwQPUSon40R9fjrLV3RlNh5kEXg5xwRfKmIdpdWu+VPSaKDXsusgX1F

VI9J9w07R27Trxiai8+d4FlRf07W7fIhb9AQhtWOGhf5 auto@slave-ui-p3

ssh-rsa

AAAAB3NzaC1yc2EAAAADAQABAAABAQDkg8xcD5bhfBX/SztxI4cME1IYs0+i7if28MXSHjmlwThlmKVSJE

kk+YuqeY8fq7seD2OuTP0snanQ4BbMdophZmJhR/Fx6Z9rDyAYRw+Uu7ViC0ot6WbQ3ilDiEihWIYTOYrA

mLMHx8Div4tHWBJ4sjI940Sr5bMpgEMczrl9TOSoHWLc1re1Y6UfTBNKHST0Nyfrnor1QgoUyiD6sN0KZX

vmp+8EGe8thq4wpNcbq/OJmndP5J40j05OSXLJCchvwgM5ZHK3ifd5KwNtj6JkZw9KHOVvIsvnzbe8kA7r

cTITn1C/XYOWpUUSX/TbhkXgSa/z7negg9YzXuqjgfkx core@cop-dev-jenkins1.arubathena.com

Copying keys to user : copadmin

Copying keys to node : 10.22.154.57

Press [Enter] key to continue...

List all public key added COP
Enter the command option 3 from the Authentication commands menu to list all the SSH public key
added to the Aruba Central On-Premises server.

Enter option [ 0 - 3 ]: 3

Local IP is - 10.22.156.209

Generating device cert for - 10.22.156.209

—

Certificate Configuration Commands
Enter the command option 10 from the main menu to configure device certificates.

Enter option [ 0 - 11 ]: 10

1. Enable client cert strict check

2. Disable client cert strict check

3. Generate device cert

4. Disable client cert strict check for devices

5. Apply default certificates to Web UI and API Gateway

6. Show Root CA Cert

====================================

b. back

m. main menu

0. exit

Enter option [ 0 - 6 ]:

Enable client cert strict check
Enter the command option 1 from the Certificate configuration commands menu to enable strict check
for client certificates.

Enter option [ 0 - 6 ]: 1

Current status is - true

configmap/nginx-app-configuration replaced

Successfully updated nginx-app-configuration for key strict-cert-check

Existing nginx-app-ingress-deployment replicas - 0

deployment.apps/nginx-app-ingress-deployment scaled

deployment.apps/nginx-app-ingress-deployment scaled

nginx-app-ingress-deployment is scaled down to zero and scaled back to 0 , Please
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wait till nginx-app pods are up and running.

Press [Enter] key to continue...

Disable client cert strict check
Enter the command option 2 from the Certificate configuration commands menu to disable strict check
for client certificates.

Enter option [ 0 - 6 ]: 2

Current status is - true

configmap/nginx-app-configuration replaced

Successfully updated nginx-app-configuration for key strict-cert-check

Existing nginx-app-ingress-deployment replicas - 1

deployment.apps/nginx-app-ingress-deployment scaled

deployment.apps/nginx-app-ingress-deployment scaled

nginx-app-ingress-deployment is scaled down to zero and scaledDisabl back to 1 ,

Please wait till nginx-app pods are up and running.

Press [Enter] key to continue...

Generate device cert
Enter the command option 3 from the Certificate configuration commands menu to restore the default
device certificate. If any custom device certificate is uploaded, this command restores the device
certificate back to default device certificate.

Enter option [ 0 - 6 ]: 3

Local IP is - 10.22.156.209

Generating device cert for - 10.22.156.209

—

Disable client cert strict check for devices
Enter option 4 from the Certificate configuration commands menu to disable strict check for device
certificates.

Enter option [ 0 - 6 ]: 4

Disabling client strict check for devices.

Apply default certificates to Web UI and API Gateway
Enter option 5 from the Certificate configuration commands menu to generate and apply the default
certificates to the web user interface (UI) and API gateway.

Enter option [ 0 - 6 ]: 5

Generating and applying default UI and GW certificates...

Are you sure you want to generate and apply default certificates for UI and API

Gateway? (Y/N):

Show Root CA Cert
Enter option 6 from the Certificate configuration command menu to download the root certificate
authority (CA) to connect to your network devices, if the Aruba Central On-Premises is deployed in COP
on Bare Metal mode. This certificate should be uploaded to your respective devices for authentication.
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Search Commands
Enter option 11 from the main menu to view a list of available command options.

Enter option [ 0 - 11 ]: 11

Enter the text to get the list of available command options (case insensitive) :

cluster

1) Show -> Configuration -> Network-config/Cluster-info

2) Show -> Cluster Status

Use number to select a command and execute it, enter (stop) to quit: 1

Updated Network Settings

------------------------

Hostname : cop-156-209.arubathena.com

IP Address : 10.22.156.209

Subnet Mask : 255.255.255.0

Gateway : 10.22.156.2

DNS : 10.20.50.10

Secondary DNS : 10.20.50.25

Timezone : UTC

COP Cluster Details

-----------------------

Cluster IP : 10.22.156.192

Cluster FQDN : copvip-156-192.arubathena.com

Pod CIDR : 172.16.0.0/16

Service CIDR : 10.3.0.0/23

Router ID : 192

Time Zone : UTC

Cluster Node Count : 1

Cluster Node List :

NAME STATUS ROLES AGE VERSION

10.22.156.209 Ready conductor 35d v1.18.6

Press [Enter] key to continue...

CLI Behavioral Changes
User/ Session Management Changes Overview
With 2.5.5 release administrator can now manage password/ session/ banner related parameters from
Local Authentication page. To do so login to HPE GreenLake with your credentials and navigate to
Manage > Authentication > Local Authentication tab.

n There is no CLI mechanism for modifying these properties.
n On the Manage > Authentication > Local Authentication page Inactive Account Lockout and

Password Expiration fields will be supported in the upcoming release.

n On the Manage > Authentication > Session page CLI Total Concurrent Sessions field will be supported
in the upcoming release.

Banner
Once banner is configured, it displays during login attempt by the user or administrator on the CLI.

Password policy
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If password policy is changed or configured, subsequent change of password must match with the set
configuration requirements.

User Forced Reset
User is immediately logged out from the CLI system when Forced Reset option is selected.

Session Inactivity
Once configured, active CLI sessions get terminated if there is no activity by the user or administrator.

Lockout after failed attempts
After configuration, the user or the administrator gets locked out, if there is unsuccessful login attempt
as per configured value. The duration for the user or administrator to be locked out is also configurable.

IPv6 Support
IPv6 address is supported for Campus APs and Clients IP address in Aruba Central On-Premises.

Instant Access Points and AOS-CX switches are not supported for IPv6 address.

IPv6 only network can be managed in the following network topology, Mobility conductor/Standby
controller > Switches > Access points/Campus APs > Clients. The mobility conductor and standby
controller must be in dual mode to support IPv6 address.

Aruba Central On-Premises supports the IPv6 address on the WebUI pages listed in the following table:

WebUI Description

Cluster Details > Summary IPv6 address is available for access points.

Access Points > List IPv6 address is available for access points.

Access Points > Summary IPv6 address is available for access points.

Clients > List IPv6 address is available for all devices and clients.

Client Details > Summary IPv6 address is available for all devices and clients.

Global Search IPv6 address of an access point can be entered to search the device.

Reports > List IPv6 address is available for access points in network summary
report.

Table 28: IPv6 Support in Aruba Central On-Premises
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Managing Licenses

Managing Licenses

As part of the shift to an Edge-to-Cloud Platform-as-a-Service organization, Aruba has introduced the
Aruba Central Foundation and Advanced Licenses (Aruba Central Licenses). This is a uniform software
subscription licensing model that will be extended to all products under the Aruba Central-managed
portfolio. The new 1, 3, 5, 7, and 10-year fixed-term licenses offer you the flexibility to choose services
and device operations that are most meaningful to the type of business that you own.

Managing subscriptions is available on the HPE GreenLake account home. For more information, see the
Managing Subscriptions.

This licensing model provides different licenses for APs, switches, and controllers.

The licenses for APs, switches, and controllers are not interchangeable. For example, you cannot use an AP
Foundation License on a controller. Similarly, if you have an Aruba 25xx Switch but the license available is for an
Aruba 29xx Switch, the Aruba 29xx Switch license cannot be applied to the Aruba 25xx Switch.

Aruba Central On-Premises features are available for all users tied to Foundation Licenses, but all the
features have different monitoring and configuration options depending on the licensing tier.

This licensing model provides the following types of licenses depending on the devices:

n Switches:
o Foundation—This license provides all the features included in the legacy Device Management

tokens.
n Access Points (APs):

o Foundation—This license provides all the features included in the legacy Device Management
tokens and some additional features that were available as value-added services for APs and
switches in the earlier licensing model.

n Controllers:
o Foundation WLAN Gateway—This license provides all features required for Controller

functionality in all deployment types.

Adding a subscription in the offline mode is supported for Aruba Central On-Premises deployments. For
more information, see Adding Subscription for Offline-Mode Installation.

Changes to the Legacy Licensing Model
For existing Aruba Central On-Premises customers, the previous Device Management and Service Token
model is changed to the new licensing model, which provides a uniform licensing structure for all types
of devices such as APs, switches, and controllers.

The following list provides information about important aspects of the legacy licensing model:

n Device Management Token—This is a mandatory token which allows you to manage and monitor
your APs and switches from Aruba Central On-Premises.
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n Service Token—This token allows you to enable value-added services for APs that are managed
from Aruba Central On-Premises.

n Subscription Key—A valid subscription key allows you to manage, profile, and analyze your devices
using Aruba Central On-Premises. A subscription key is a 14-character alphanumeric string provided
for either a device management or service token.

The new licenses simplify the existing subscription-based licensing model. With the introduction of this
licensing model, the existing Device Management tokens for APs and switches are no longer available.
Similarly, the Service tokens for value-added services on the APs are unavailable. Instead, APs and
switches have adopted the current Foundation License model.

Supported Devices
The Aruba Central On-Premises Licenses are supported for APs, switches, and controllers. The pricing
structure for Foundation Licenses for the hardware devices may differ based on the types of models.

For more information on the individual device models supported, refer to the following sections:

n Supported APs

n Supported AOS-S Platforms

n Supported AOS-CX Platforms

n Supported Aruba Mobility Controllers

WLAN Gateway Foundation License
The WLAN Gateway Foundation can be assigned to the following controllers:

n Aruba 70xx Series
n Aruba 72xx Series

This license does not have a capacity limit for client devices.

For an Aruba Central evaluation account, four licenses of each base SKU are assigned to the account.
These evaluation licenses are valid for 90 days.
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Managing Authentication Methods

The Authentication page allows the administrator to manage and configure external authentication for
users to have access to Aruba Central On-Premises. You can choose any one of the external
authentication methods to allow access to the user.

Following are the supported authentication options and methods:

n Local User Database—With this type of authentication, all users are authenticated by their username
and password against the local database. For more information, see Configuring Local Authentication
.

n SAML—Enable user federation across all services and single sign-on for users with claimed-domain
accounts. Users without a claimed-domain account can still sign in using their username and
password against the local user database. For more information, see Configuring HPE GreenLake
SAML SSO.

n RADIUS—Use this section to configure RADIUS servers to authenticate Aruba Central On-Premises
users. For more information, see Configuring RADIUS Authentication and Authorization .

n RadSec—Enabling RadSec increases the level of security for authentication that is carried out across
the cloud network. RadSec uses Transport Layer Security (TLS) to encrypt all communication between
the client and the server. For more information, see Configuring RadSec Authentication and
Authorization .

Configuring Local Authentication
The local database consists of a list of guest and employee users. All users are authenticated by their
username and password against the local user database. You must configure password complexity and
lockout conditions for local user accounts.

To configure local authentication, complete the following steps:

1. In the HPE GreenLake account home page, click Manage.

The Manage Account page is displayed.

2. Click the Authentication card.

The Authentication page is displayed by default.

3. Click the Local Authentication tab.

4. Configure the following parameters:
n Password complexity—Define the minimum length and mandatory characters for the

password.

You can use @, $, #, !, %, ^, &, *, ~, {, }, (, ), \, ', ;, :, <, and > as special characters in the password.

You can select the following mandatory characters to be part of the password:
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o Lowercase
o Uppercase
o Numerals
o Symbols

n Change password upon next login—Enable the toggle switch to force the users to reset their
password when they next log in to the system.

 The connected users are immediately disconnected and required to reset their password with
the new complexity.

n Lockout & Expiration—Configure the following lockout requirements:
o Lockout after failed attempts—Enable the toggle switch to activate lockout and

expiration requirements.
o Failed Attempts Limit—Configure the number of failed attempts after which the account

is locked out, and specify the duration of the lockout in minutes.
 Also, define the limits for inactive account lockouts and password expiration in days.

5. Click Save Changes.

Configuring Sessions
You can configure sessions conditions for local users who log in to the system.

To configure sessions, complete the following steps:

1. In the HPE GreenLake account home page, click Manage.

The Manage Account page is displayed.

2. Click the Authentication card.

The Authentication page is displayed by default.

3. Click the Sessions tab.

4. Configure the following parameters:
n Web Inactivity Timeout—Specify the maximum time limit for web inactivity.

When set, users cannot configure their sessions to be greater than this limit.
n Web Total Concurrent Sessions—Specify the maximum number of concurrent sessions for

all uses in the account.
n Concurrent Sessions per User—Specify the maximum number of concurrent sessions a user

can be logged into at the same time.
n Login Banner—Provide the text for any required notifications or alerts to users which they

can view on the sign-on page when they log in to the account.
n CLI Inactivity Timeout—Specify the maximum time limit for CLI inactivity. When set, users

cannot configure their sessions to be greater than this limit.
n CLI Total Concurrent Sessions—Specify the maximum number of concurrent CLI sessions

for all uses in the account.

5. Click Save Changes.
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Single Sign-On Management
The Single Sign-On (SSO) solution simplifies user management by allowing users to access multiple
applications and services with a single set of login credentials. If different vendors offer applications
services, IT administrators can use the SAML authentication and authorization framework to provide a
seamless login experience for their users.

To provide a seamless login experience for users whose identity is managed by an external
authentication source, HPE GreenLake now offers a federated SSO solution based on the SAML 2.0
authentication and authorization framework. SAML is an XML-based open-standard for exchanging
authentication and authorization data between trusted partners, particularly between an application
service provider and identity management system used by an enterprise. With HPE GreenLake’s SAML
SSO solution, organizations can manage user access using a single authentication and authorization
source.

The NameId attribute specified on the IDP must include the email address of the user. SP metadata NameID
must be of the format, <md:NameIDFormat>urn:oasis:names:tc:SAML:1.1:nameid-
format:emailAddress</md:NameIDFormat> for SSO authentication to work.

This section includes the following topics:

n SAML SSO Overview

nn Configuring HPE GreenLake SAML SSO

n HPE GreenLake SAML Attributes

SAML SSO Overview
The HPE GreenLake SAML SSO solution consists of the following key elements:

n Service Provider (SP)—The provider of a business function or service; for example, HPE GreenLake.
The service provider requests and obtains an identity assertion from the IdP. Based on this assertion,
the service provider allows access to the service.

n Identity Provider (IdP)—The Identity Management system maintains the user's identity information
and authenticates the user.

n SAML Request—The authentication request is generated when a user tries to access the on-premises
HPE GreenLake login page.

n SAML Assertion—The authentication and authorization information issued by the IdP to allow access
to the (HPE GreenLake account homel) service.

n Relying Party—The business service that relies on SAML assertion for authenticating a user, For
example, HPE GreenLake.

n Asserting Party—The Identity management system or the IdP creates SAML assertions for a service
provider.

n Metadata—Data in the XML format is exchanged between the trusted partners (IdP and HPE
GreenLake) to establish interoperability.

n SAML Attributes—The attributes associated with the user; for example, username, customer ID, role,
and group in which the devices belonging to a user account are provisioned.
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n Entity ID—A unique string to identify the service provider that issues a SAML SSO request. According
to the SAML specification, the string should be a URL, although not required as a URL by all
providers.

n User—User with SSO credentials.

Configuring HPE GreenLake SAML SSO
HPE GreenLake supports the following methods for configuring SAML SSO:

n Uploading metadata file

n Uploading metadata URL

n Manually uploading X.509 certificate

Ensure that you have your service provider details available.

SAML SSO Configuration Steps
The SAML SSO configuration for HPE GreenLake includes the following high-level steps:

1. Configuring user accounts and roles in HPE GreenLake. For more information, see the Managing
User Identity and Access topic in HPE GreenLake Help Center.

2. Configuring SAML authorization profile in HPE GreenLake. For more information, see Configuring
SAML SSO Authorization Profile.

3. Configuring Service Provider metadata such as metadata URL, service consumer URL, name, and
other attributes on the IdP server. For more information, see the following topics:

n Uploading Metadata File

n Uploading Metadata URL

n Manually Uploading X.509 Certificate

SAML SSO Configuration Workflow
HPE GreenLake supports the following type of SAML SSO workflow:

n SP–initiated SSO

n IdP-initiated SAML SLO

SP-Initiated SSO
In an SP Initiated SSO workflow, the SSO request originates from the service provider domain, that is,
from HPE GreenLake. When a user tries to access HPE GreenLake, a federation authentication request is
created and sent to the IdP server.

IdP-initiated SAML SLO
HPE GreenLake supports Single Logout (SLO) of SAML SSO users. SLO allows users to terminate server
sessions established using SAML SSO by initiating the logout process once. SAML SLO can be initiated
either from the Service Provider or the IdP.

However, HPE GreenLake supports only IdP-initiated SLO.

The IdP-initiated logout workflow includes the following steps:
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1. User logs out of the IdP.

2. The IdP sends a logout request to HPE GreenLake.

3. HPE GreenLake validates the logout request from the IdP, terminates the user session, and sends
a logout response to the IdP.

4. The user is logged out of HPE GreenLake.

After the IdP receives a logout response from all service providers, the IdP logs out the user.

Configuring SAML SSO Authorization Profile
To configure SAML SSO authorization profile, complete the following steps:

1. In the HPE GreenLake account home page, click Manage.

The Manage Account page is displayed.

2. Click the Authentication card.

The Authentication tab is displayed by default.

3. Click Edit.
The Authentication Method drop-down list is displayed.

4. Select SAML from the drop-down list.

5. Click Set Up SAML Connection at the bottom of the page.

The Claim a Domain pop-up window is displayed.

6. Enter a domain name in the Organization Domain Name text box.

You must enter a domain name to create and manage an SSO connection.

7. Click Continue.

The Add Identity Provider Details page is displayed.

Ensure that the domain has at least one verified user. The user claiming the domain must be the same
user currently logged into HPE GreenLake. For example, to claim an att.com domain, the user must be
logged in to HPE GreenLake with an @att.com email address. 

HPE GreenLake does not support adding hpe.com, arubanetworks.com, and other free public domain
names such as Gmail.com, Yahoo.com, or Facebook.com, for SAML authorization profiles.

8. Under the Select a Configuration Method box, select one of the following options depending on
the configuration method you wish to use:

n Metadata File—For more information on uploading metadata file, see Uploading Metadata
File.

n Metadata URL—For more information on uploading metadata file, see Uploading Metadata
URL.

n Manual (Enter X.509 Certificate Details)—For more information on uploading metadata file,
see Manually Uploading X.509 Certificate.

9. Click Next.
The Configure Settings page is displayed.
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10. Configure the following parameters for SAML attributes:

n Required Attributes:
o Email Address—Select either NameID or Custom from the SAML Attribute Name drop-

down list.
This attribute contains the user's email address.

o HPE GreenLake Attribute—Set the default value to hpe_ccs_attribute.
You can also substitute your own custom value. For more information, see HPE GreenLake
SAML Attributes.

n Optional Attributes:
o SAML Attribute Name—Enter the value in the First Name and Last Name fields.
o Idle Session Time (Minutes)—Enter the idle session time out, in minutes.

For more information on configuring SAML attributes, see Configuring SAML Attributes.

11. Click Next.
The Review  & Create page is displayed.

12. Check the details displayed on the Review  & Create page, and verify that all your configuration
details are correct.

Click the Modify link to edit your configuration details.

13. Click Finish to continue.

The SSO Setup Complete configuration page is displayed.

Your SSO domain is now set up.

14. Click the Download Metadata File link to download the metadata.

15. Click Exit.
The Authentication page is displayed again. Notice that the authentication method is still set to
the previous option for Local User Database.

16. Click Edit.

17. In the Authentication Method drop-down, select SAML to activate the SAML authentication
method that you just configured.

The Notify All Active Users page is displayed.

18. Click one of the following options:

n Send Email—Click Send Email to send an email immediately.

n Skip For Now—Click Skip for Now to send an email at a later date.

The Authentication page is displayed once again.

19. Click Save Changes.

The Change Authentication Method? confirmation box is displayed.

20. Select Confirm Change.

The authentication method for SAML is configured.

Uploading Metadata File
To upload metadata file to the IdP server as part of SAML SSO configuration, complete the following
steps:
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1. In the HPE GreenLake account home page, click Manage.

The Manage Account page is displayed.

2. Click the Authentication card.

The Authentication tab is displayed by default.

3. Click Edit.
The Authentication Method drop-down list is displayed.

4. Select SAML from the drop-down list.

5. Click Set Up SAML Connection at the bottom of the page.

The Claim a Domain pop-up window is displayed.

6. Enter a domain name in the Organization Domain Name text box.

You must enter a domain name to create and manage an SSO connection.

7. Click Continue.

The Add Identity Provider Details page is displayed.

8. Under the Select a Configuration Method box, select the Metadata File radio button.

9. Under IdP Metadata File, click Upload Metadata File to browse and select the IdP metadata
file., and upload the file to the SAML SSO application.

Ensure that the metadata file is in the XML format and it includes valid certificate content and HTTPS
URLs for the Entity ID, Login URL, and Logout URL fields.

10. HPE GreenLake extracts the required information from the metadata file and populates the
following fields:

n Entity ID

n Domain Login URL

n Domain Logout URL

n X.509 Signing Certificate

11. Verify the details, including the pre-populated information.

12. Click Save.

The Configure Settings page is displayed.

To complete the remaining steps to configure SAML SSO authorization profile, proceed to step 10
of Configuring SAML SSO Authorization Profile.

Uploading Metadata URL
To upload metadata URL to the IdP server as part of SAML SSO configuration, complete the following
steps:

1. In the HPE GreenLake account home page, click Manage.

The Manage Account page is displayed.

2. Click the Authentication card.
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The Authentication tab is displayed by default.

3. Click Edit.
The Authentication Method drop-down list is displayed.

4. Select SAML from the drop-down list.

5. Click Set Up SAML Connection at the bottom of the page.

The Claim a Domain pop-up window is displayed.

6. Enter a domain name in the Organization Domain Name text box.

You must enter a domain name to create and manage an SSO connection.

7. Click Continue.

The Add Identity Provider Details page is displayed.

8. Under the Select a Configuration Method box, select the Metadata URL radio button.

9. Enter the metadata URL in the provided field.

10. Click Validate URL.

If you are using a valid configuration, the details will populate in the fields on the screen.

Ensure that the Entity ID, Login URL, and Logout URL fields have valid HTTPS URLs.

11. Click Save.

The Configure Settings page is displayed.

To complete the remaining steps to configure SAML SSO authorization profile, proceed to step 10
of Configuring SAML SSO Authorization Profile.

Manually Uploading X.509 Certificate
To manually upload X.509 certificate file to the IdP server as part of SAML SSO configuration, complete
the following steps:

1. In the HPE GreenLake account home page, click Manage.

The Manage Account page is displayed.

2. Click the Authentication card.

The Authentication tab is displayed by default.

3. Click Edit.
The Authentication Method drop-down list is displayed.

4. Select SAML from the drop-down list.

5. Click Set Up SAML Connection at the bottom of the page.

The Claim a Domain pop-up window is displayed.

6. Enter a domain name in the Organization Domain Name text box.

You must enter a domain name to create and manage an SSO connection.

7. Click Continue.
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The Add Identity Provider Details page is displayed.

8. Under the Select a Configuration Method box, select the Manual (Enter X.509 Certificate
Details) radio button.

9. Configure the following parameters:

n Entity ID—Enter the entity ID.

n Domain Login URL—Enter a URL for domain login.

n Domain Logout URL—Enter a URL for domain logout.

n X.509 Certificate—Enter the X.509 certificate details.

10. Click Save.

The Configure Settings page is displayed.

To complete the remaining steps to configure SAML SSO authorization profile, proceed to step 10
of Configuring SAML SSO Authorization Profile.

Configuring SAML Attributes
You must configure the SAML attributes on the IdP according to specifications associated with a user
account in HPE GreenLake. These attributes are included in the SAML assertion when HPE GreenLake
sends a SAML request to the IdP.

Prerequisites

Obtain the requiredattributes from your service provider.

To configure the SAML Attributes settings, complete the following steps:

1. In the HPE GreenLake account home page, click Manage.

The Manage Account page is displayed.

2. Click the Authentication card.

The Authentication tab is displayed by default.

3. Click Edit.
The Authentication Method drop-down list is displayed.

4. Select SAML from the drop-down list.

5. Click Set Up SAML Connection at the bottom of the page.

The Claim a Domain pop-up window is displayed.

6. Enter a domain name in the Organization Domain Name text box.

You must enter a domain name to create and manage an SSO connection.

7. Click Continue.

The Add Identity Provider Details page is displayed.
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Ensure that the domain has at least one verified user. The user claiming the domain must be the same
user currently logged into HPE GreenLake. For example, to claim an att.com domain, the user must be
logged in to HPE GreenLake with an @att.com email address. 

HPE GreenLake does not support adding hpe.com, arubanetworks.com, and other free public domain
names such as Gmail.com, Yahoo.com, or Facebook.com, for SAML authorization profiles.

8. Under the Select a Configuration Method box, select one of the following options depending
on the configuration method you wish to use:

n Metadata File—For more information on uploading metadata file, see Uploading Metadata
File.

n Metadata URL—For more information on uploading metadata file, see Uploading Metadata
URL.

n Manual (Enter X.509 Certificate Details)—For more information on uploading metadata file,
see Manually Uploading X.509 Certificate.

9. Click Next.
The Configure Settings page is displayed.

10. Configure the following parameters for SAML attributes:

n Required Attributes:
o Email Address—Enter the attribute that contains the user's email address.

Select NameID from the SAML Attribute Name drop-down list if the email address is a
part of the NameID attribute. Select Custom from the SAML Attribute Name drop-down
list if you want to enter a custom attribute containing the user’s email address.

o HPE GreenLake Attribute—Set the default value to hpe_ccs_attribute.
You can also substitute your own custom value. For more information, see HPE GreenLake
SAML Attributes.

n Optional Attributes:
o SAML Attribute Name—Enter the value in the First Name and Last Name fields.

If the optional First Name and Last Name fields are not entered for IdP, a default value of
Undefined FN, Undefined LN is displayed as the user profile in the system

o Idle Session Time (Minutes)—Enter the idle session time out, in minutes.

11. Click Next.
The Review  & Create page is displayed.

To complete the remaining steps to configure SAML SSO authorization profile, proceed to step 12
of Configuring SAML SSO Authorization Profile.

HPE GreenLake SAML Attributes
The following format must be followed when configuring the "hpe_ccs_attribute" on IdP.

Format: {version}#{pcid}:{app cid}:{role_name}:{scope_group_names}:{ALL_SCOPES}

Syntax requirements for HPE GreenLake SAML attributes
Following is an example of syntax for the SAML attribute.
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version_1 #pcid_123:Aruba_123:admin_role:ALL_SCOPES:pcid_123:custom_role1:seattle_

group,Oregon_group_compute_434

Ensure to define attributes with a colon (:) delimiter.

The following table describes the syntax for SAML attributes.
Table 29: SAML Syntax

Syntax Descriptions

version Defines the version of the assertion attribute. Currently, only version_1 is supported.

pcid     The platform customer ID.

app cid The application customer ID. If you have multiple applications, define attributes separately for
each application ID with a colon (:) delimiter.

role_name Defines the access level for a particular NameID returned in the response. NameID is a valid
email address used as the username to log into HPE GreenLake.

scope_
group_
names

The group in HPE GreenLake. When a group is specified in the attribute, the user can only access
the devices in that group. You can also configure custom attributes to add multiple groups if
users require access to multiple groups.
If no scope group names are defined then scope_group_names is set to ALL_SCOPES by default.

ALL_SCOPES ALL_SCOPES allows access to all scopes groups without any restriction on scope groups.

Example
A user accesses the Aruba Central On-Premises application using SSO with the following attributes:

n Access to a Customer Account with PCID# 64342190c66011ec99ffa247bd22c633.

n Access to Aruba Central On-Premises Application as Aruba Central On-Premises Guest Operator for
all scope_group_names.

n Access GLCP as Account Administrator for all scope_group_names.

In this case, the hpe_ccs_attribute on IdP should be formatted as follows.

version_1#64342190c66011ec99ffa247bd22c633:683da368-66cb-4ee7-90a9-

ec1964768092:Aruba Central Guest Operator:ALL_SCOPES:00000000-0000-0000-0000-

000000000000:Account Administrator:ALL_SCOPES

SAML Attribute Values
After configuring SAML attributes, you can use the following SAML attributes to view and construct the
hpe_ccs_attribute with the platform pcid and the app cid.

To view SAML attributes, complete the following steps:

1. In the HPE GreenLake account home page, click Manage.

The Manage Account page is displayed.
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2. Click the Authentication card.

The Authentication page is displayed by default.

3. Select the account you wish to view and click the ellipsis to display the drop-down list.

4. Click the View SAML Attribute link to display SAML attributes values.

The following figure displays the SAML attribute values.

Figure 16 SAML Attributes

The following table describes the SAML attributes.
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Table 30: SAML Attributes

Attributes Description

Entity The entity ID is the company or organization entity ID URL.

Sign-On URL     The sign-on URL is the URL where SAML SSO authentication is enabled. 

Platform
Customer ID

This  is a unique identifier created during SAML configuration.

GreenLake
Platform ID

This is a unique identifier created during SAML configuration

Applications The applications section lists additional application names and IDs where the SAML values
are applied.

Configuring RADIUS Authentication and Authorization
You can configure RADIUS servers to authenticate Aruba Central On-Premises users. For RADIUS
capability, you must configure the IP/hostname of the RADIUS server, the server shared secret, and the
authentication protocol.

To configure RADIUS servers to authenticate users, complete the following steps:

1. In the HPE GreenLake account home page, click Manage.

The Manage Account page is displayed.

2. Click the Authentication card.

The Authentication tab is displayed by default.

3. Click Edit.
The Authentication Method drop-down list is displayed.

4. Select RADIUS from the drop-down list.

5. Click Set up Radius Server at the bottom of the page.

The Add Primary Server pop-up window is displayed.

At this point, you cannot save changes to the authentication method unless you configure a RADIUS
server.

6. Configure the following parameters:

n Server Hostname or IP Address—Enter a specific hostname or IP address that points to the
validating server.

n Port—Enter the port number to be used.

n Server Secret—Enter the shared secret used to access the primary RADIUS server.

n Confirm Server Secret—Re-enter the shared secret for confirmation.

n Authentication Protocol—Select one of the following supported authentication methods to
apply to both primary and secondary servers:
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o PAP
o PEAP-MSCHAPV2

7. Click Add.

The Authentication page is displayed again.

8. (Optional) Click Set Up Radius Server once again to configure the parameters for secondary
server.

n The authentication protocol that you selected for the primary server will be auto-populated and
set as the default for the secondary server.

n If authentication fails with the primary server, the request is made to the secondary server for
authentication. If both fail, the request authenticates against the default Local User Database.

n All the node IP addresses need to be configured as RADIUS clients on the RADIUS server.

9. Configure the secondary server parameters as described in step on page 165.

10. Click Add.

The Authentication page is displayed once again.

11. Click Save Changes.

The Change Authentication Method? confirmation box is displayed.

12. Click Confirm Change.

The authentication method is changed from the local user database to RADIUS server.

Configuring RADIUS Service in Aruba ClearPass Policy
Manager
For RADIUS Authentication, you must configure the RADIUS Enforcement service in Aruba ClearPass
Policy Manager.

Note the following points while configuring enforcement service in ClearPass Manager:

n Ensure that you have access to the ClearPass Policy Manager instance.
n Only the admin user can configure the enforcement service.
n If no role is defined in RADIUS response for the User, Central does not allow access to the user.
n If no group is defined in RADIUS response for the User, Central does not allow access to the user.

To configure the RADIUS enforcement service in ClearPass Policy Manager, follow the steps mentioned
in ClearPass Policy Manager User guide available at Aruba Support portal.

To configure RADIUS enforcement service, complete the following steps:

1. In ClearPass Policy Manager, navigate to Configuration > Services.

2. Click Add at the top right corner of the page.
3. In the Services window, click the Authentication tab.
4. Select the Strip Username Rules check box to pre-process the username (to remove domain

suffix) before authenticating and authorizing against the authentication source.

For more information, see step Figure 17 on page 167.

https://www.arubanetworks.com/techdocs/ClearPass/6.8/PolicyManager/index.htm#CPPM_UserGuide/About ClearPass/About_ClearPass.htm
https://asp.arubanetworks.com/
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5. Under Configuration > Enforcement > Profiles, click Add at the top right corner of the page.
6. In the Enforcement Profiles window, click the Attributes tab.

7. Configure the attributes described in step Table 31 on page 167.

8. For more information, see

The following table describes the attributes for RADIUS enforcement profile.

Type Name Value

Radius:Aruba Aruba-Admin-Role Select the role assigned to the user

Radius:Aruba Aruba-Admin-Device-Group Select the group assigned to the user.
Comma-seperated option can be used when multiple
groups are assigned.
If the user has access to all groups, then the allgroups
value can be provided.

Table 31: Attributes table

The following figure displays the authentication configuration page for RADIUS enforcement service.

Figure 17 Sample Figure for Services

The following figure displays the user attributes configuration page for RADIUS enforcement profile.
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Figure 18 Sample Figure for role and groups assignment

RADIUS Server User Roles
A role refers to a logical entity used for determining user access to devices and application. Aruba
Central On-Premises roles for RADIUS server users must be modified based on the new roles supported
by HPE GreenLake. These roles cannot be assigned with custom role names, if the role names match
with previous predefined roles. The following tables describes the new RADIUS server roles.

Existing Role New Roles

admin Aruba Central On-Premises Administrator

readonly Aruba Central On-Premises View Only

readwrite Aruba Central On-Premises View Edit

guestoperator Aruba Central On-Premises Guest Operator

Table 32: User Roles

Equivalent HPE GreenLake User Roles
Radius Server uses single role for both Aruba Central On-Premises and HPE GreenLake account. The
following table lists the equivalent HPE GreenLake roles for the Aruba Central On-Premises roles:

Aruba Central On-
Premises Roles Equivalent HPE GreenLake Roles

admin Account Administrator

readonly Observer

readwrite Operator

Table 33: Equivalent User Roles
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Aruba Central On-
Premises Roles Equivalent HPE GreenLake Roles

guestoperator Observer

Aruba Central On-
Premises
Administrator

Account Administrator

Aruba Central On-
Premises view only

Account Administrator

Aruba Central On-
Premises view edit

Operator

Aruba Central On-
Premises guest
operator

Oberserver

Custom Observer

Configuring RadSec Authentication and Authorization
You can configure RadSec servers to authenticate Aruba Central On-Premises users. The RadSec
protocol is used for safely transmitting the authentication and accounting data between the device and
the RadSec server. For RadSec capability, you must configure the IP/hostname of the RadSec server, the
server shared secret, and the authentication protocol.

To configure RadSec servers to authenticate users, complete the following steps:

1. In the HPE GreenLake account home page, click Manage.

The Manage Account page is displayed.

2. Click the Authentication card.

The Authentication tab is displayed by default.

3. Click Edit.
The Authentication Method drop-down list is displayed.

4. Select RadSec from the drop-down list.

5. Click Add RadSec Server at the bottom of the page.

The Add Primary Server pop-up window is displayed.

6. Configure the following parameters:

n Server Hostname or IP Address—Enter a specific hostname or IP address that points to the
validating server.

n Port—Enter the port number to be used.

n Server Secret—Enter the shared secret used to access the primary RadSec server.

n Confirm Server Secret—Re-enter the shared secret for confirmation.

n Authentication Protocol—Select one of the following supported authentication methods to
apply to both primary and secondary servers:
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o PAP
o PEAP-MSCHAPV2

7. Click Add.

The Authentication page is displayed again.

8. (Optional) Click Add RadSec Server once again to configure the parameters for secondary server.

n The authentication protocol that you selected for the primary server will be auto-populated and
set as the default for the secondary server.

n If authentication fails with the primary server, the request is made to the secondary server for
authentication. If both fail, the request authenticates against the default Local User Database.

9. Configure the secondary server parameters as described in step on page 169.

10. Click Add.

The Authentication page is displayed once again.

11. Click Save Changes.

The Change Authentication Method? confirmation box is displayed.

12. Click Confirm Change.

The authentication method is changed from the local user database to RadSec server.



Chapter 8

Upgrading Device Firmware

Upgrading Device Firmware

The Firmware page provides an overview of the latest firmware version supported on the device, details
of the device, and the option to upgrade the device.

Viewing Firmware Details
To view the firmware details for devices provisioned in Aruba Central On-Premises:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a group in the filter, set the filter to one of the options under Group. For all devices,

set the filter to Global. The dashboard context for the selected filter is displayed.
n To select a device in the filter:

a. Set the filter to Global.
b. Under Manage, click Devices, and then click Access Points, Switches, or Controllers. A

list of devices is displayed.
c. Click a device listed under Device Name. The dashboard context for the device is

displayed.

2. Under Maintain, click Firmware.

Firmware Maintenance Window
The following are the data pane items and description:

1. Access Points—Displays the following information:
n Name—Name of the AP. The and icons allow you to sort the names in ascending or

descending order. Clicking on the device name opens a window with connected APs and allows
you to select and view the device Summary page. For more information, see Wireless Client
Details. 

n Group—Displays the group information only on global context. The and icons allow you
to sort the groups in ascending or descending order.

n Site—Displays the site information only on global context. The and icons allow you to
sort the sites in ascending or descending order.

n Current Version—The current firmware version running on the device. The and icons
allow you to sort the firmware versions in ascending or descending order.

n Recommended Version—The version to which the device is recommended for the upgrade.
n Upgrade Status—Filters the device list based on any of the following firmware upgrade status:

o New firmware available
o Scheduled
o In progress
o Failed
o Firmware up to date
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n Compliance Status—Status of the firmware compliance setting. Based on the setting, the
column displays one of the following values:
o Set
o Not Set
o Compliance scheduled on
Hover over any device to view the version number and compliance configured level for set
compliance and displays the date, time (UTC), firmware version number, and compliance
configured level for a scheduled compliance.

Clicking on the device name from the Name columns, opens a window with connected APs and
allows you to select and view the device Summary page. For more information, see Wireless Client
Details. Click any site name from the Site column to view the site associated APs with their firmware
details page.

2. Switches—Displays the following details about Aruba Central On-Premises switches managed
through Aruba Central On-Premises:
n Name—Host name of the switch. The and icons allow you to sort the names in

ascending or descending order.
n Family—Displays the following types of switches:

o AOS-S
o CX

This information is only available for Aruba Central On-Premises switch and Aruba Central On-
Premises CX switches.

n Site—Displays the site information only on global context. The and icons allow you to
sort the sites in ascending or descending order.

n Group—Displays the group information only on global context. The and icons allow you
to sort the groups in ascending or descending order.

n MAC Address—MAC address of the switch. The and icons allow you to sort the address
in ascending or descending order.

n Model—Hardware model of the switch. The and icons allow you to sort the models in
ascending or descending order.

n Firmware Version—The current firmware version running on the switch. The and icons
allow you to sort the firmware versions in ascending or descending order.

n Recommended Version—The version to which the device is recommended for the upgrade.
n Upgrade Status—Filters the device list based on any of the following firmware upgrade

status:
o New firmware available
o Scheduled
o In progress
o Failed
o Firmware up to date

n Compliance Status—Status of the firmware compliance setting. Based on the setting, the
column displays one of the following values:
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o Set
o Not Set
o Compliance scheduled on
Hover over any device to view the version number and compliance configured level for set
compliance and displays the date, time (UTC), firmware version number, and compliance
configured level for a scheduled compliance.

n The Switches tab displays details of both AOS-S and AOS-CX switches.

3. Controllers—Displays the following details about the controllers managed through Aruba
Central On-Premises in Standalone mode and in Cluster mode:

a. Standalone mode:
n Name—Host name of the controllers. The and icons allow you to sort the names in

ascending or descending order.
n Site—Displays the site information only on global context. The and icons allow you

to sort the sites in ascending or descending order.
n Group—Displays the group information only on global context. The and icons allow

you to sort the groups in ascending or descending order.
n MAC Address—MAC address of the controllers. The and icons allow you to sort the

address in ascending or descending order.
n Model—Hardware model of the controllers. The and icons allow you to sort the

models in ascending or descending order.
n Firmware Version—The current firmware version running on the controllers. The and

icons allow you to sort the firmware versions in ascending or descending order.
n Recommended Version—The version to which the device is recommended for the

upgrade.
n Upgrade Status—Filters the device list based on any of the following firmware upgrade

status:
o New firmware available
o Scheduled
o In progress
o Failed
o Firmware up to date

n Compliance Status—Status of the firmware compliance setting. Based on the setting, the
column displays one of the following values:
o Set
o Not Set
o Compliance scheduled on
Hover over any device to view the version number and compliance configured level for set
compliance and displays the date, time (UTC), firmware version number, and compliance
configured level for a scheduled compliance.

b. Cluster mode:
n Name—Host name of the controllers. The and icons allow you to sort the names in

ascending or descending order.
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n Group—Displays the group information only on global context. The and icons allow
you to sort the groups in ascending or descending order.

n Firmware Version—The current firmware version running on the controllers. The and
icons allow you to sort the firmware versions in ascending or descending order.

n Upgrade Status—Filters the device list based on any of the following firmware upgrade
status:
o New firmware available
o Scheduled
o In progress
o Failed
o Firmware up to date

n Compliance Status—Status of the firmware compliance setting. Based on the setting, the
column displays one of the following values:
o Set
o Not Set
o Compliance scheduled on
Hover over any device to view the version number and compliance configured level for set
compliance and displays the date, time (UTC), firmware version number, and compliance
configured level for a scheduled compliance.

4. Set Compliance—Allows you to set firmware compliance for devices within a group. Click Set
Compliance and turn on the toggle switch to enable and view the list of supported firmware
versions for each device in a group in the Manage Firmware Compliance page.

a. Set Compliance for Access Points—To ensure firmware version compliance, complete the
following parameters in the Manage Firmware Compliance page:
n Groups—Select a specific group or multiple groups for which the compliance must be set.

Select All Groups if you want to set compliance for all the groups.
n Firmware Version—Select the firmware version number from the drop-down list to

which the compliance is required to be set.
n When—Select one of the following radio buttons to specify if the compliance must be

carried out immediately or at a later date and time.
o Now—Select this if you want the compliance to be carried out immediately.
o Later Date—Select this if you want the compliance to be carried out in a specific time

zone at the later date and time.
n Click Save button to save the firmware compliance with the above settings. To clear the

compliance, turn off the toggle switch.

b. Set Compliance for Switches—To ensure firmware version compliance, complete the
following parameters in the Manage Firmware Compliance page:
n Groups—Select the group for which the compliance must be set. Select the specific group

to set compliance at group level.
n AOS-S Firmware Version—Select the AOS-S firmware version number from the drop-

down list to which the compliance is required to be set.
n CX Firmware Version—Select the Aruba CX switch version number from the drop-down

list to which the compliance is required to be set.
n When—Select one of the following radio buttons to specify if the compliance must be

carried out immediately or at a later date and time:
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o Now—Select this if you want the compliance to be carried out immediately.
o Later Date—Select this if you want the compliance to be carried out in a specific time

zone at the later date and time.
n Install on—Use the drop-down to select a primary partition or a secondary partition to

install on.
n Automatically reboot to complete the upgrade—Select this check box to reboot Aruba

Central On-Premises automatically after the build is downloaded on the device. On reboot,
the new build is installed on the device.

n Click Save button to save the firmware compliance with the above settings. To clear the
compliance, turn off the toggle switch.

Aruba Central On-Premises lists all available Aruba CX switches software versions. Select the
software version that is applicable to the Aruba CX switch to which compliance is required to be
set. For example, version 10.04.0020 is not applicable to Aruba CX 6200 and 6400 switch series.

c. Set Compliance for Controllers in Standalone Mode—To ensure firmware version
compliance, complete the following parameters in the Manage Firmware Compliance page:
n Groups—Select a specific group or multiple groups for which the compliance must be set.

Select All Groups if you want to set compliance for all the groups.
n Firmware Version—Select the firmware version number from the drop-down list to which

the compliance is required to be set.
n When—Select one of the following radio buttons to specify if the compliance must be

carried out immediately or at a later date and time:
o Now—Select this if you want the compliance to be carried out immediately.
o Later Date—Select this if you want the compliance to be carried out in a specific time

zone at the later date and time.
n Install on—Use the drop-down to select a primary partition or a secondary partition to

install on.
n Automatically reboot to complete the upgrade—Select this check box to reboot Aruba

Central On-Premises automatically after the build is downloaded on the device. On reboot,
the new build is installed on the device.

n Click Save button to save the firmware compliance with the above settings. To clear the
compliance, turn off the toggle switch.

d. Set Compliance for Controllers in Cluster Mode—To ensure firmware version compliance,
complete the following parameters in the Manage Firmware Compliance page:
n Groups—Select a specific group or multiple groups for which the compliance must be set.

Select All Groups if you want to set compliance for all the groups.
n Firmware Version—Select the firmware version number from the drop-down list to which

the compliance is required to be set.
n Auto Reboot—Select this check box to reboot Aruba Central On-Premises automatically

after the build is downloaded on the device. On reboot, the new build is installed on the
device.

n When—Select one of the following radio buttons to specify if the compliance must be
carried out immediately or at a later date and time:
o Now—Select this if you want the compliance to be carried out immediately.
o Later Date—Select this if you want the compliance to be carried out in a specific time

zone at the later date and time.
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n Install on—Use the drop-down to select a primary partition or a secondary partition to
install on.

n Automatically reboot to complete the upgrade—Select this check box to reboot Aruba
Central On-Premises automatically after the build is downloaded on the device. On
reboot, the new build is installed on the device.

n Click Save button to save the firmware compliance with the above settings. To clear the
compliance, turn off the toggle switch.

5. Upgrade All—Allows you to simultaneously upgrade firmware for all devices. Click Upgrade All
to view a list of supported firmware versions for each device.
a. To Upgrade all Access Points—Click Upgrade All and complete the following parameters in

the Upgrade Access Points Firmware page:
n Sites—Select a specific site or multiple sites for which the upgrade must be set. You can

also search for the site in the search filter.
n Firmware Version—Select the firmware version number from the drop-down list to

which the compliance is required to be set. Select None for none of the firmware versions.
n When—Select one of the following radio buttons to specify if the upgrade must be carried

out immediately or at a later date and time:
o Now—Select this if you want the compliance to be carried out immediately.
o Later Date—Select this if you want the compliance to be carried out in a specific time

zone at the later date and time.
n Upgrade—Click this button to start the upgrade with the above settings.
n Schedule—Click this button to schedule the upgrade with the above settings.
n Cancel—Click this button to cancel the upgrade.

While upgrading a large number of APs, cancel operation may not work as intended, and
continues to upgrade.

b. To Upgrade all Switches—Click Upgrade All and complete the following parameters in the
Upgrade Switch Firmware page:
n Sites—Select a specific site or multiple sites for which the upgrade must be set. You can

also search for the site in the search filter.
n AOS-S Firmware Version—Select the AOS-S firmware version number from the drop-

down list to which the compliance is required to be set.
n CX Firmware Version—Select the CX switch firmware version number from the drop-

down list to which the compliance is required to be set.
n Auto Reboot—Select this check box to reboot Aruba Central On-Premises automatically

after the build is downloaded on the device. On reboot, the new build is installed on the
device.

n When—Select one of the following radio buttons to specify if the upgrade must be carried
out immediately or at a later date and time:
o Now—Select this if you want the compliance to be carried out immediately.
o Later Date—Select this if you want the compliance to be carried out in a specific time

zone at the later date and time.
n Upgrade—Click this button to start the upgrade with the above settings.
n Schedule—Click this button to schedule the upgrade with the above settings.
n Cancel—Click this button to cancel the upgrade.
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c. To Upgrade all Controllers in Standalone Mode—click Upgrade All and complete the
following parameters in the Upgrade Controller Firmware page:
n Sites—Select a specific site or multiple sites for which the upgrade must be set. You can

also search for the site in the search filter.
n Firmware Version—Select the firmware version number from the drop-down list to which

the compliance is required to be set.
n Auto Reboot—Select this check box to reboot Aruba Central On-Premises automatically

after the build is downloaded on the device. On reboot, the new build is installed on the
device.

n When—Select one of the following radio buttons to specify if the upgrade must be carried
out immediately or at a later date and time.
o Now—Select this if you want the compliance to be carried out immediately.
o Later Date—Select this if you want the compliance to be carried out in a specific time

zone at the later date and time.
n Upgrade—Click this button to start the upgrade with the above settings.
n Schedule—Click this button to schedule the upgrade with the above settings.
n Cancel—Click this button to cancel the upgrade.

d. To Upgrade all Controllers in Cluster Mode—click Upgrade All and complete the following
parameters in the Upgrade Controller Firmware page:
n Firmware Version—Select the firmware version number from the drop-down list to which

the compliance is required to be set.
n Auto Reboot—Select this check box to reboot Aruba Central On-Premises automatically

after the build is downloaded on the device. On reboot, the new build is installed on the
device.

n When—Select one of the following radio buttons to specify if the upgrade must be carried
out immediately or at a later date and time.
o Now—Select this if you want the compliance to be carried out immediately.
o Later Date—Select this if you want the compliance to be carried out in a specific time

zone at the later date and time.
n Upgrade—Click this button to start the upgrade with the above settings.
n Schedule—Click this button to schedule the upgrade with the above settings.
n Cancel—Click this button to cancel the upgrade.

6. Upload—Allows you to upload the software image for multiple devices.
7. Search Filter—Allows you to define a filter criterion for searching devices based on the following

properties:
n Common to all devices—Name, Firmware Version, Recommended Version and Upgrade Status

of the device.
n Specific to switches and controllers—MAC address and Model.

8. Column Filter—Clicking the filter icon enables you to customize the table columns or set it to the
default view.

9. Continue—Allows you to continue with firmware upgrade.
10. Cancel Upgrade—Cancels a scheduled upgrade.
11. Cancel All—Cancels a scheduled upgrade for all devices.
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Uploading a Software Image
To upload a software image for the device:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Firmware > Upload.
3. Select the device from the Device list drop-down for which you want to upload the software

image.
4. Click Choose File option to browse to your local directory and select the software image.
5. Click Upload. The updated file details is displayed in the Uploaded Files table.

This section also includes the following topics:

n Upgrading a Single Device or Multiple Devices
n Upgrading Devices using Upgrade All Option
n Setting Firmware Compliance For Access Points
n Setting Firmware Compliance For Switches
n Setting Firmware Compliance For Controllers

Upgrading a Single Device or Multiple Devices
Aruba Central On-Premises allows you to upgrade a single device or multiple devices in the following
ways:

1. In the Aruba Central On-Premises app, select one of the following options:
a. To select a group, site or global in the filter:

n Set the filter to one of the options under Group or Sites. For all devices, set the filter to
Global. The dashboard context for the selected filter is displayed.

n Under Maintain, click Firmware.
n Select one or more devices from the device list and click the Upgrade icon at the bottom

of the page or hover over one of the selected device and click the Upgrade icon. The
Upgrade <Device> Firmware pop-up window opens.

b. To select a device in the filter:
n Set the filter to Global.
n Under Manage, click Devices, and then click Access Points, Switches, or Controllers. A

list of devices is displayed.
n Click a device listed under Device Name. The dashboard context for the device is

displayed.
n Under Maintain, click Firmware and click Upgrade in the Firmware Details window. The

Upgrade <Device> Firmware pop-up window opens.

2. In the Upgrade <Device> Firmware pop-up window, select the appropriate firmware version.
You can either select a recommended version or manually choose a specific firmware version.

n To obtain custom build details, contact Aruba Central On-Premises Technical Support.
n The recommended firmware versions can be different for different devices and depends on the

device model and software architecture.
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3. Select one of the following radio buttons to specify if the compliance must be carried out
immediately or at a later date and time:
n Now—Allows you to set the compliance to be carried out immediately.
n Later Date—Allows you to set the compliance to be carried out at the later date and time.

Select a specific time zone from the Select Zone drop-down options to schedule the upgrade
at a specif zone time.

4. From the Install On drop-down, select any one of the following partition options:
n Primary partition—Select this if you want to install the firmware version in the primary

partition.
n Secondary partition— Select this if you want to install the firmware version in the secondary

partition.

5. Select the check box if you want Aruba Central On-Premises to automatically reboot after device
upgrade.

The Auto Reboot option is available for AOS-S and AOS-CX switches, and Controllers.

6. Click Upgrade. The device downloads the image from the server, saves it to flash, and reboots.
Depending on the progress and success of the upgrade, one of the following messages is
displayed:
n Upgrading—While image upgrade is in progress.
n Upgrade failed—When the upgrade fails.

7. If the upgrade fails, retry upgrading your device.

After upgrading a switch, click Reboot.

Upgrading Devices using Upgrade All Option
To upgrade multiple devices using the Upgrade All option, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Group or Sites.
For all devices, set the filter to Global. The dashboard context for the selected filter is displayed.

2. Under Maintain, click Firmware. 
The firmware dashboard for Access Points is displayed by default.

3. Click Upgrade All. The Upgrade <Device> Firmware pop-up window opens.
4. In the Upgrade <Device> Firmware pop-up window, select the specific site or multiple sites from

the Sites drop-down list. This option is available only at the global context.
5. Select the appropriate firmware version (for Access points and Controllers) and AOS-S firmware

version and CX firmware version (for AOS-S and AOS-CX switches) from their respective drop-
down list. You can either select a recommended version or manually choose a specific firmware
version.

n To obtain custom build details, contact Aruba Central Technical Support.
n The recommended firmware versions can be different for different devices and depends on the

device model and software architecture.
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6. Select one of the following radio buttons to specify if the compliance must be carried out
immediately or at a later date and time:
n Now—Allows you to set the compliance to be carried out immediately.
n Later Date—Allows you to set the compliance to be carried out at the later date and time.

Select a specific time zone from the Select Zone drop-down options to schedule the upgrade
at a specif zone time.

7. From the Install On drop-down, select any one of the following partition options:
n Primary partition—Select this if you want to install the firmware version in the primary

partition.
n Secondary partition— Select this if you want to install the firmware version in the secondary

partition.

8. Select the check box if you want Aruba Central On-Premises to automatically reboot after device
upgrade.

The Auto Reboot option is available for AOS-S and AOS-CX switches, and Controllers.

9. Specify if the upgrade must be carried out immediately or at a later date and time.
10. Click Upgrade. The device downloads the image from the server, saves it to flash, and reboots.

Depending on the progress and success of the upgrade, one of the following messages is
displayed:
n Upgrading—While image upgrade is in progress.
n Upgrade failed—When the upgrade fails.

11. If the upgrade fails, retry upgrading your device.

After upgrading a switch, click Reboot.

Setting Firmware Compliance For Access Points
Aruba Central On-Premises allows you to run a firmware compliance check and force firmware upgrade
for all APs in a group. To force a specific firmware version for all APs in a group, complete the following
steps:

1. In the Global dashboard, under Maintain, click Firmware.

The Access Points tab is selected by default.

2. Verify the firmware upgrade status for all APs.
3. Click Set Compliance at the top right and turn on the toggle switch to enable the Manage

Firmware Compliance window.
4. In the Groups drop-down list, select a single group, multiple, or All Groups.
5. Select a firmware version from the Firmware Version drop-down list.
6. Select one of the following radio buttons to specify if the compliance must be carried out

immediately or at a later date and time:
n Now—Allows you to set the compliance to be carried out immediately.
n Later Date—Allows you to set the compliance to be carried out at the later date and time.

Select a specific time zone from the Select Zone drop-down options to schedule the upgrade
at a specif zone time.
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7. Click Save.
Aruba Central On-Premises initiates a firmware upgrade operation only for the devices that
support the selected firmware version. If any of selected devices do not support the firmware
version selected for the upgrade, a list of unsupported devices is displayed.

Setting Firmware Compliance For Switches
To force a specific firmware version for all Aruba switches in a group, complete the following steps:

1. In the Global dashboard, under Maintain, click Firmware > Switches tab.
2. Verify the firmware upgrade status for all switches.
3. Click Set Compliance at the top right and turn on the toggle switch to enable the Manage

Firmware Compliance window.
4. In the Groups drop-down list, select a single group, multiple, or All Groups.
5. Select a AOS-S firmware version from the AOS-S Firmware Version drop-down list.
6. Select a CX firmware version from the CX Firmware Version drop-down list.
7. If you wish to upgrade the firmware version from your local, turn on the toggle switch and

provide the base URL and path of the selected CX firmware version.
8. Select one of the following radio buttons to specify if the compliance must be carried out

immediately or at a later date and time:
n Now—Allows you to set the compliance to be carried out immediately.
n Later Date—Allows you to set the compliance to be carried out at the later date and time.

Select a specific time zone from the Select Zone drop-down options to schedule the upgrade
at a specif zone time.

9. From the Install On drop-down, select any one of the following partition options:
n Primary partition—Select this if you want to install the firmware version in the primary

partition.
n Secondary partition— Select this if you want to install the firmware version in the secondary

partition.

10. Select the check box if you want Aruba Central On-Premises to automatically reboot.
11. Click Save. Aruba Central On-Premises initiates a firmware upgrade operation only for the

devices that support the selected firmware version. If any of selected devices do not support the
firmware version selected for the upgrade, a list of unsupported devices is displayed.

Setting Firmware Compliance For Controllers
To force a specific firmware version for all controllers in standalone mode, complete the following steps:

1. In the Global dashboard, under Maintain, click Firmware > Controllers tab.
All the controllers with standalone mode is displayed.

2. Verify the firmware upgrade status for all controllers.
3. Click Set Compliance at the top right and turn on the toggle switch to enable the Manage

Firmware Compliance window.
4. In the Groups drop-down list, select a single group, multiple, or All Groups.
5. Select a firmware version from the Firmware Version drop-down list.
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6. Select one of the following radio buttons to specify if the compliance must be carried out
immediately or at a later date and time:
n Now—Allows you to set the compliance to be carried out immediately.
n Later Date—Allows you to set the compliance to be carried out at the later date and time.

Select a specific time zone from the Select Zone drop-down options to schedule the upgrade
at a specif zone time.

7. From the Install On drop-down, select any one of the following partition options:
n Primary partition—Select this if you want to install the firmware version in the primary

partition.
n Secondary partition— Select this if you want to install the firmware version in the secondary

partition.

8. Select the check box if you want Aruba Central On-Premises to automatically reboot.
9. Click Save. Aruba Central On-Premises initiates a firmware upgrade operation only for the

devices that support the selected firmware version. If any of selected devices do not support the
firmware version selected for the upgrade, a list of unsupported devices is displayed.

To force a specific firmware version for all controllers in cluster mode, complete the following steps:

1. In the Global dashboard, under Maintain, click Firmware > Controllers tab.
All the controllers with cluster mode is displayed.

2. Verify the firmware upgrade status for all controllers.
3. Click Set Compliance at the top right and turn on the toggle switch to enable the Manage

Firmware Compliance window.
4. In the Groups drop-down list, select a single group, multiple, or All Groups.
5. Select a firmware version from the Firmware Version drop-down list.
6. Select one of the following radio buttons to specify if the compliance must be carried out

immediately or at a later date and time:
n Now—Allows you to set the compliance to be carried out immediately.
n Later Date—Allows you to set the compliance to be carried out at the later date and time.

Select a specific time zone from the Select Zone drop-down options to schedule the upgrade
at a specif zone time.

7. From the Install On drop-down, select any one of the following partition options:
n Primary partition—Select this if you want to install the firmware version in the primary

partition.
n Secondary partition— Select this if you want to install the firmware version in the secondary

partition.

8. Select the check box if you want Aruba Central On-Premises to automatically reboot.
9. Click Save. Aruba Central On-Premises initiates a firmware upgrade operation only for the

devices that support the selected firmware version. If any of selected devices do not support the
firmware version selected for the upgrade, a list of unsupported devices is displayed.



Chapter 9

Network Structure

Network Structure

The Network Structure page shows tiles view for groups, sites, labels, and certificates sections. You can
click on a tile to navigate to the respective page in Aruba Central On-Premises.

Viewing the Network Structure Page
To view the Network Structure page, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization.
3. Select the Network Structure tab.

The Network Structure page is displayed.

Figure 19 Network Structure Page

The Network Structure page displays tiles view for the following sections:

n Groups—Displays the number of groups and number of unprovisioned devices. Click on the tile to
navigate to the Groups page.

n Sites—Displays the number of sites and number of unassociated devices. Click on the tile to navigate
to the Managing Sites page.

n Labels—Displays the number of labels and number of unassociated devices. Click on the tile to
navigate to the Labels and How to Manage Them page.

n Device Preprovisioning—Displays the number of devices that are pre-provisioned to a group.
n Certificates—Displays the number of certificates available to upload. Click on the tile to navigate to

the Managing Certificates page.

Managing Groups
Aruba Central On-Premises simplifies the configuration workflow for managed devices by allowing
administrators to combine a set of devices into groups. A group in Aruba Central is the primary
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configuration element that functions as a container for device management, monitoring, and
maintenance. Groups enable administrators to manage devices efficiently by using either a UI-based
configuration workflow or CLI-based configuration template.

Groups provide the following functions and benefits:

n Ability to provision multiple devices in a single group. For example, a group can consist of multiple AP
Virtual Controllers (VCs). These VCs can share common configuration settings and push the
configuration updates to member APs in their respective AP clusters. For example, you can apply a
common security policy for the devices deployed in a specific geographical location.

n Ability to provision different types of devices in a group. For example, a group can consist of APs and
Switches.

n Ability to create a configuration base and add devices as necessary. When you assign a new device to
a group, it inherits the configuration that is currently applied to the group.

n Ability to create a clone of an existing group. If you want to build a new group based on an existing
group, you can create a clone of the group and customize it as per your network requirements.

n A device can be part of only one group at any given time.
n Groups in Aruba Central are mutually exclusive (independent) and do not follow a hierarchical model.

The following figure illustrates a generic group deployment scenario in Aruba Central.

Figure 20 Group Deployment

Group Operations
The following list shows the most common tasks performed at a group level:

n Configuration—Add, modify, or delete configuration parameters for devices in a group.
n User Management—Control user access to device groups and group operations based the type of

user role.
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n Device Status and Health Monitoring—View device health and performance for devices in a
specific group.

n Report Generation—Run reports per group.
n Alerts and Notifications—View and configure notification settings per group.
n Firmware Upgrades—Enforce firmware compliance across all devices in a group.

Group Configuration Modes
Aruba Central allows network administrators to manage device configuration using either UI workflows
or configuration templates:

n UI-based configuration method—For device groups that use UI-based workflows, Aruba Central
provides a set of UI menu options. You can use these UI menu options to configure devices in a
group. You can also secure the UI-based device groups with a password and thus restrict user access.

n Template-based configuration method—For device groups that use a template-based workflow,
Aruba Central allows you to manage devices using configuration templates. A device configuration
template includes a set of CLI commands and variable definitions that can be applied to all other
devices deployed in a group.

If your site or store has different types of devices, such as the Instant APs, Switches, and Controllers, and
you want to manage these devices using different configuration methods, that is, either using the UI or
template-based workflows, you can create a single group and define a configuration method to use for
each type of device. This allows you to use a single group for both UI and template based configuration
and eliminates the need for creating separate groups for each configuration method.

For example, you can create a group with the name Group1 and within this group, you can enable
template-based configuration method for switches and UI-based configuration method for APs and
Controllers. Aruba Central identifies both these groups under a single name ( Group1). If a device type
in the group is marked for template-based configuration method, the group name is prefixed with TG
prefix is added (TG Group1). You can use Group1 as the group ID for workflows such as user
management, monitoring, reports, and audit trail.

When you add APs, Controllers, and switches to a group, Aruba Central groups these devices based on
the configuration method you chose for the device type, and displays relevant workflows when you try
to access the respective configuration menu.

For information on how to create a group, see Groups.

Default Groups and Unprovisioned Devices
The default group is a system-defined group to which Aruba Central assigns all new devices with factory
default configuration. When a new device with factory default configuration connects to Aruba Central,
it is automatically added to the default group.

If a device has customized configuration and connects to Aruba Central, Aruba Central marks the device
as Unprovisioned. If you want to preserve the device configuration, you can create a new group and
assign this device to the newly created group. If you want to overwrite the configuration, you can move
the unprovisioned device to an existing group.

The unprovisioned state does not apply to Aruba Switches as only the factory-default switches can join Aruba
Central.
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Best Practices and Recommendations
Use the following best practices and recommendations for deploying devices in groups:

n Determine the configuration method (UI or template-based) to use based on your deployment,
configuration, and device management requirements.

n If there are multiple sites with similar characteristics. For example, with the same device
management and configuration requirements, assign the devices deployed in these sites to a single
group.

n Apply device-level or cluster-level configuration changes if necessary.
n Use groups cloning feature if you need to create a group with an existing group configuration

settings.
n If the user access to a particular site must be restricted, create separate groups for each site.

Groups
The Groups page allows you to create, edit, or delete a group, view the list of groups provisioned in
Aruba Central, and assign devices to groups.

This section describes the following topics:

n Creating a Group
n Group Persona
n Creating a Group Persona with ArubaOS 8.x Architecture
n Creating Groups for Switches
n Assigning Devices to Groups
n Viewing Groups and Associated Devices
n Creating a New Group by Importing Configuration from a Device
n Cloning a Group
n Moving Devices between Groups
n Deleting a Group
n Setting up Password for Devices in a Group

Creating a Group
Aruba Central On-Premises allows you to manage configuration for different types of devices, such as
Aruba APs, controllers, and switches in your inventory. These devices can be configured using either UI
workflows or configuration templates. You can define your preferred configuration method when
creating a group.

After you assign devices to group and when you access configuration containers, Aruba Central On-
Premises automatically displays relevant configuration options based on the configuration method you
defined for the device group.

For more information, see Creating a Group Persona with ArubaOS 8.x Architecture

Group Persona
A persona of a device represents the role that the device plays in a network deployment. Creating
persona for devices helps in customizing configuration workflows, automating parts of configurations,
showing the default configuration, showing relevant settings for the device. Persona configuration also
helps in customizing the monitoring screens and troubleshooting workflows appropriate for the device.
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Creating a Persona
Persona can be created when creating a group. Persona and architecture can be set at the group level.
All devices within a group inherit the same persona from the group settings.

While creating a group, the architecture and persona settings of the current group can be marked as
preferred settings for adding subsequent groups. For subsequent groups, you can either automatically
apply the preferred settings or manually select settings for the new group.

Persona for Access Points

Access Points can have the Campus/Branch persona, where AP provides the WLAN functionality.

Persona for Controllers

Controllers can have the Branch persona, where the controllers provide Aruba Instant OS SD-Branch
(LAN + WAN) functionality.

Architecture

The ArubaOS 8 architecture is supported for creating groups. It is an Instant AP-based deployment,
including 6.x/8.x IAP, IAP-VPN, or 8.x SD-Branch deployments.

Creating a Group Persona with ArubaOS 8.x Architecture
To manage device configuration using configuration containers in Aruba Central, you can create a group
and assign devices. During the group creation, you can assign a device persona and select an
architecture for the group.

Adding a Group
To add a group and assign a persona and ArubaOS 8 architecture, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization.

By default, the Network Structure tab is displayed.

3. Click the Groups tile.

The Groups page is displayed.

4. Click (+) Add Group on the Groups table.

The Add Group page is displayed.

5. Enter a name for the group.

The group name can be a maximum of 32 single byte ASCII characters if you use the UI to create
the names. However, if you are using an NB API, the character limit increases to 128. A group
name supports alphanumeric characters and only "-", "_", and space as special characters.
System-defined group names such as “default”, “unprovisioned”, and “global” are not allowed in
group names.

By default, Aruba Central enables the UI-based configuration. The template-based configuration is
displayed only when you select devices in the Add group page. Use the toggle button to enable the
Configure using templates.
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6. Select device types that will be part of this group. A group can contain following devices:
n Access points
n Controllers
n Switches

For detailed device combinations, refer to the Device Combinations for a Group Persona table.

7. Click Next.
By default the ArubaOS 8 architecture is applied for access points and controllers.

8. Select the check box for Make these the preferred group settings optionally to save the
architecture and persona settings of the current group for subsequent group creations.

9. Click Add.

A group with persona configuration is created.

n The group created by an user role that has read and write access is displayed in the Groups list only after
that group is assigned to the user by the administrator on HPE Greenlake. For information about how to
assign a group to the user, see Managing User Identity Access.

n You can also create a group that uses different provisioning methods for switch, IAP, device categories.
For example, you can create a group with template-based provisioning method for switches and UI-based
provisioning method for Instant APs.

Device Combinations

The following table lists the valid combinations for a group persona with ArubaOS 8 architecture.

Device Type Architecture AP Network Role
Controller
Network
Role

Switches Monitoring
Only

APs ArubaOS 8 Campus/Branch N/A N/A N/A

Controllers ArubaOS 8 N/A Branch N/A N/A

Switches No architecture N/A N/A n AOS-CX
only

n AOS-S
only

n Both
AOS-CX
and AOS-
S

Monitoring only
for AOS-S
(not applicable
for AOS-CX only
switch types)

n APs
n Controllers

ArubaOS 8 Campus/Branch Branch N/A N/A

Table 34: Device Combinations for a Group Persona
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Device Type Architecture AP Network Role
Controller
Network
Role

Switches Monitoring
Only

n APs
n Switches

ArubaOS 8 Campus/Branch N/A n AOS-CX
only

n AOS-S
only

n Both
AOS-CX
and AOS-
S

Monitoring only
for AOS-S
(not applicable
for AOS-CX only
switch types)

n APs
n Controllers
n Switch

ArubaOS 8 Campus/Branch Branch n AOS-CX
only

n AOS-S
only

n Both
AOS-CX
and AOS-
S

Monitoring only
for AOS-S
(not applicable
for AOS-CX only
switch types)

Editing a Group
You can edit a group to add a new device type to the group. The group architecture and persona cannot
be changed through group edit. You can mark the settings of an edited group as preferred settings for
subsequent group creations.

To edit a group, complete the following steps:

1. From the Aruba Central On-Premises app, filter All Groups.
2. Under Maintain, click Organization.

By default, the Network Structure tab is displayed.

3. Click the Groups tile.

The Groups page is displayed.

4. To edit an existing group, hover over the group in the groups table and click the Edit Group
icon.

The Edit Group page is displayed.

5. Add a new device type and its persona.
6. For valid edit operations, refer to the Editing a Group table.
7. Select check box for Make these the preferred group settings optionally to save the

architecture and persona settings of the current group for subsequent group creations.
8. Click Save.

The group edit changes are saved.

The following table lists the behavior for various edit operations.
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Original State
Action Edit Group Behaviour

Architecture Devices and Persona

ArubaOS 8 AP - Campus/Branch
No Controllers

n Add Controller
n Add Switches

Allowed
Controller persona - Branch
Switch types: AOS-CX only or AOS-S
only or Both AOS-CX and AOS-S

ArubaOS 8 No AP
Controllers - Branch

n Add AP
n Add Switches

Allowed
AP persona - Campus/Branch
Switch types: AOS-CX only or AOS-S
only or Both AOS-CX and AOS-S

No architecture No Access Points
No Controllers
Switches - AOS-CX only
or AOS-S only or Both
AOS-CX and AOS-S

n Add AP
n Add Controllers

Allowed
AP persona - Campus/Branch
Controllers persona - Branch

Table 35: Editing a Group

Creating Groups for Switches
You can create a group with switches only in it or you can also add a switch to an existing group
containing other devices such as APs and controllers. A switch group will not have any architecture.

Adding a Switch Group
To add a switch group, complete the following steps:

1. From the Aruba Central On-Premises app, filter Global.
2. Under Maintain, click Organization.

By default, the Network Structure tab is displayed.

3. Click the Groups tile.

The Groups page is displayed.

4. Click (+) Add Group on the Groups table.

The Add Group page is displayed.

5. Enter a name for the group.

The group name can be a maximum of 32 single byte ASCII characters if you use the UI to create
the names. However, if you are using an NB API, the character limit increases to 128. A group
name supports alphanumeric characters and only "-", "_", and space as special characters.
System-defined group names such as “default”, “unprovisioned”, and “global” are not allowed in
group names.

By default, Aruba Central enables the UI-based configuration. The template-based configuration is
displayed only when you select devices in the Add group page. Use the toggle button to enable the
Configure using templates.

6. From the Group will contain section, select the switch check box.
7. Click Next.
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8. Select the type of switches used in this group:
n AOS-CX only
n AOS-S only
n Both AOS-CX and AOS-S

You can select the 'Monitoring only for AOS-S' option for the AOS-S switches.

9. Select the check box for Make these the preferred group settings optionally to save the
architecture and persona settings of the current group for subsequent group creations.

10. Click Add.

A group for the selected switch type is created.

The group created by an user role that has read and write access is displayed in the Groups list only after that
group is assigned to the user by the administrator on HPE Greenlake. For information about how to assign a
group to the user, see Managing User Identity Access.

To add a switch type to an existing group, see Creating a Group Persona with ArubaOS 8.x Architecture

Assigning Devices to Groups
In Aruba Central On-Premises, devices are assigned to groups for configuration, monitoring, and
management purposes. A group in Aruba Central On-Premises is a primary configuration element that
acts like a container. In other words, groups are a subset of one or several devices that share common
configuration settings. Aruba Central On-Premises supports assigning devices to groups for the ease of
configuration and maintenance. For example, you can create a common group for controllers or Instant
APs that have similar configuration requirements.

Assigning Instant APs to Groups
The Instant AP groups may consist of the configuration elements:

n Instant AP Cluster—Consists of a master Instant AP and a set of slave Instant APs in the same VLAN.
n Virtual Controller—A virtual controller provides an interface for entire cluster. The slave Instant APs

and master Instant APs function together to provide a virtual interface.
n Master Instant AP and Slave Instant AP—In a typical Instant AP deployment scenario, the first Instant

AP that comes up is elected as the master Instant AP. All other Instant APs joining the cluster function
as the slave Instant APs. When a master Instant AP is elected, the slave Instant APs download the
configuration changes.

The following table describes the group assignment criteria for Instant APs.

APs with Default Configuration APs with Non-Default Configuration

If an Instant AP with factory default
configuration joins Aruba Central On-
Premises, it is automatically assigned to
the default group or to an existing group
with similar configuration settings.
The administrators can perform any of
the following actions:
n Manually assign them to a pre-

If an Instant AP with non-default or custom configuration joins
Aruba Central On-Premises, it is automatically assigned to an
unprovisioned group.

The administrators can perform any of the following actions:
n Create a new group for the device and preserve device

configuration.
n Move the device to an existing group and override the

Table 36: Instant AP Group Assignment
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APs with Default Configuration APs with Non-Default Configuration

provisioned group.
n Create a new group.

device configuration.

Assigning Switches to Groups
Aruba Central On-Premises allows switches to join groups only if the switches are running factory
default configuration. Switches with factory default configuration are automatically assigned to the
default group. Administrators can either move the switch to an existing group or create a new group.

n Aruba Central On-Premises does not support UI-based configuration workflows for Aruba 5400R Switch
Series and switch stacks. Aruba recommends that you assign these devices to template groups and
provision them using configuration templates.

n Aruba Central On-Premises does not support moving Aruba 5400R Switch Series from the template group
to a UI group. If Aruba 5400R Switch Series is pre-assigned to a UI group, the device is moved to an
unprovisioned group after it joins Aruba Central On-Premises.

Assigning Controllers to Groups
Aruba Central On-Premises allows controllers to join groups and the controllers with factory default
configuration are automatically assigned to the default group. Administrators can either move the
controller to an existing group or create a new group.

Assigning Devices to a Group
You can assign devices to groups for configuration, monitoring, and management purposes. A group is
a primary configuration element that acts like a container. In other words, a group is a subset of one or
several devices that share common configuration settings. For example, you can create a common
group for Branch Gateways or Instant APs that have similar configuration requirements.

To assign a device to a group from the Device Preprovisioning page, complete the following steps:

The following procedure is only for assigning groups to the devices that are connected for the first time. The
group management actions like moving devices between groups, or moving devices from unprovisioned group
to other groups is done on the Groups page. For more information, see Managing Groups.

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization.

By default, the Network Structure tab is displayed.

3. Click the Device Preprovisioning tile.

The Device List table is displayed. The Device List table lists the total number of devices in the
inventory.

4. Select the device(s) which you want to move to a selected group. You can select and move up to
50 devices at a time.
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If the selected device is already connected to Aruba Central On-Premises, the Move devices option
will not be available for the device.

5. Click the Move devices icon.

The Assign Group page is displayed.

6. Select the Destination Group from the drop-down list.

You can assign only particular device type for which the group is created. For example, if a group is
created for Access Points only, then only Access Points can be assigned to that group. You cannot
assign other device types to it.

7. Click Move.

The selected device(s) are moved to the destination group. These devices will adopt the
destination group configuration.

For every device pre-provisioning operation, a warning pop-up is displayed to check the audit trail log
for the status. If you are assigning the devices in bulk, ensure to check the audit trail to confirm if the all
devices are successfully assigned and reason for the rejected devices.

To assign a device to a group from the Groups page, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization.

By default, the Network Structure tab is displayed.

3. Click the Groups tile.

The Groups page is displayed.

4. Expand a group from which you want to move devices to the selected group. For example,
expand the Unprovisioned Devices group, select the devices, and then click the Move
devices icon.

The Move Devices page is displayed.

You can assign only particular device type for which the group is created. For example, if a group is
created for Access Points only, then only Access Points can be assigned to that group. You cannot
assign other device types to it.

5. Select the Destination Group from the drop-down list.
6. Click Move.

The selected devices are moved to the destination group. These devices will adopt the destination
group configuration.

Viewing Groups and Associated Devices
To view the groups dashboard, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization.

By default, the Network Structure tab is displayed.
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3. Click the Groups tile.

The Groups page is displayed.

The groups table lists all the groups and displays the following information:
n Group Name—Name of the group. You can filter the list with a group name and sort the

groups list in ascending and descending order. For each group, the next column displays the
devices icons that are part of the group. Hover over a group to see the Edit, Clone, Go to
Config, or Delete a group.

n Search—You can use the search functionality to search for a device name, MAC address, and
serial number.

n Devices—Number of devices assigned to a group.
n All Connected Devices—Total number of devices provisioned in Aruba Central On-Premises.

The table list shows all the devices provisioned in Aruba Central On-Premises.
n Unprovisioned devices—This group lists the licensed devices that are connected to Aruba

Central On-Premises but not assigned to any group. This group cannot be edited or deleted.

4. To view the devices assigned to a group, select the group from the table on the left.

The devices table displays the following information:
n Device Name—Name of the device.
n Type—Type of the device such as AP, Switch, or Controller.
n Serial Number—Serial number of the device.
n MAC Address—MAC address of the device.

Creating a New Group by Importing Configuration from a Device
You can create a new group by importing configuration from a device. The import configuration is
supported only for IAPs with ArubaOS 8 architecture. You can create a new group for IAPs with ArubaOS
8 architecture by importing configuration from an IAP. You can add more devices later by editing the
group.

To import configuration from an existing device to a new group, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization.

By default, the Network Structure tab is displayed.

3. Click the Groups tile.

The Groups page is displayed.

4. Expand a group which has IAP devices.
5. Select the IAP with ArubaOS 8 architecture.

6. Click the Import Group icon.
The Add Group pop-up window is displayed.

7. Enter a name for the group.

The group name can be a maximum of 32 single byte ASCII characters if you use the UI to create
the names. However, if you are using an NB API, the character limit increases to 128. A group
name supports alphanumeric characters and only "-", "_", and space as special characters.
System-defined group names such as “default”, “unprovisioned”, and “global” are not allowed in
group names.
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8. Click Add.

A group is created with the configuration imported from a device.

The group created by an user role that has read and write access is displayed in the Groups list only after that
group is assigned to the user by the administrator on HPE Greenlake. For information about how to assign a
group to the user, see Managing User Identity Access.

Cloning a Group
Cloning a group will clone the same architecture and persona from the source group.

To clone a group, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization.

By default, the Network Structure tab is displayed.

3. Click the Groups tile.

The Groups page is displayed.

4. To create a clone of an existing group, hover over the group on the Groups table and click the
Clone Group icon.

The Clone Group page is displayed.

5. Enter a name for the cloned group.

The group name can be a maximum of 32 single byte ASCII characters if you use the UI to create
the names. However, if you are using an NB API, the character limit increases to 128. A group
name supports alphanumeric characters and only "-", "_", and space as special characters.
System-defined group names such as “default”, “unprovisioned”, and “global” are not allowed in
group names.

6. Click Clone.

A new group is created from the source group settings.

When you clone a group, Aruba Central On-Premises also copies the configuration templates applied to
the devices in the group.

Moving Devices between Groups
This feature allows the user to move the Mobility Conductor and all the associated devices like the
standby Mobility Conductor, Managed Devices, and access points to a different group. When you move
the Mobility Conductor to a new group, the associated devices will automatically move to the same new
group. Similarly, when you move the managed device, all the managed devices in that cluster and the
corresponding APs will move automatically to the destined group.

To move a device to a different group, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization.

By default, the Network Structure tab is displayed.

3. Click the Groups tile.

The Groups page is displayed.
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4. Expand a group from which you want to move devices to the selected group. For example,
expand the Unprovisioned Devices group, select the devices, and then click the Move
devices icon.

The Move Devices page is displayed.

5. Select the Destination Group from the drop-down list. Based on the device, the following actions
are performed automatically:
a. If you have selected a Mobility Conductor to move to a different group, all the associated

devices like the standby Mobility Conductor, clusters and access points will automatically
move to the destined group.

b. If you have selected a managed device to move to a different group, all the managed devices
in that cluster and the corresponding APs will move automatically to the destined group.

6. Click Move.

The selected devices are moved to the destination group. These devices will adopt the
destination group configuration.

7. You can verify the device or group move information by navigating to Analyze > Audit Trail
page.

The sites and labels page should also display the updated group information.

Deleting a Group
Aruba Central On-Premises allows you to delete a group if there are no devices attached to that group.

When you delete a group, Aruba Central On-Premises removes all configuration, templates, and variable
definitions associated with the group. Before deleting a group, ensure that there are no devices attached to the
group.

To delete a group, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization.

By default, the Network Structure tab is displayed.

3. Click the Groups tile.

The Groups page is displayed.

4. From the list of groups, hover over the group in the groups table and click the Delete Group
icon.

The Delete Group confirmation window is displayed.

The delete icon is available only when all the devices are disassociated from the group you want to
delete.

5. Click Yes to confirm.

The group is deleted.

Restricting Access to Group-Level Configuration
Using the HPE GreenLake portal, you can restrict users to group-level configuration by configuring
appropriate options in the Central Permissions page. This feature allows users to edit configuration
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only at the device level. However, users are allowed to view the device configuration pages and the
Configuration Audit page at the group level.

To restrict access to group-level configuration, you must configure the following resource permissions
for a custom role in the HPE GreenLake portal:

1. Select the Edit option under NMS Service > NMS Service Configuration.

This allows access to the configuration at both group and device levels.

By default, the Edit option is cleared and the View option is selected.

2. Clear the Edit option in NMS Group Level Access under NMS Service > NMS Service
Configuration.

This allows access to configuration at the device level. At the group level, access is provided only
to view the device configuration.

By default, both Edit and View options are selected.

For more information about managing users and roles in the HPE GreenLake portal, see the
Assignments section in the HPE GreenLake Edge to Cloud Platform User Guide, using the following link:

https://www.arubanetworks.com/techdocs/central/latest/content/nms/intro-pages/related-info.htm

You can also gather additional details on managing users and roles in the HPE GreenLake portal, from
the User Roles for Aruba Central On-Premises section.

Setting up Password for Devices in a Group
To set the password for the devices in the groups, complete the following steps:

n Setting the Password for Access Points

n Setting the Password for AOS-S Switches

n Setting the Password for AOS-CX Switches

n Setting the Password for Controllers

When you create a new group and assign devices to the group, you must set the password for the devices
before proceeding with any device configuration.

Setting the Password for Access Points

To set the password for access points in a group, complete the following steps:

1. Navigate to the access points configuration page using either of the following methods:
n Set the filter to a Group containing access points, navigate to Manage > Devices, select the

Access Points tab, click the Config icon.
n Set the filter to Global, navigate to Maintain > Organization > Network Structure > Groups,

then select a group and click the Go to config icon.

 The Set Device Password pop-up is displayed to set the password for the access points.

2. Enter the password, confirm and click Set Password.

The password is set for the access points.

Setting the Password for AOS-S Switches

To set the password for AOS-S switches in a group, complete the following steps.
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If the password is not set for the AAOS-S switches, any user can access the switch using the SSH or Telnet and
perform the configuration. So, it is mandatory to set the password before proceeding with any configuration.

1. Navigate to the AOS-S switches configuration page using either of the following methods:
n Set the filter to a Group containing at least one AOS-S switch, , navigate to Manage > Devices,

select the Switches tab.
n Set the filter to Global, navigate to Maintain > Organization > Network Structure > Groups,

select a group containing at least one AOS-S switch, click the Go to config icon, and select the
Switches tab.

2. Select the AOS-S Config icon.
3. Navigate to System > Access/DNS.
4. Enter the Admin Username, Admin Password, then Confirm Password.
5. Click Save Settings.

The password is set for the AOS-S switches.

Setting the Password for AOS-CX Switches

To set the password for AOS-CX switches in a group, complete the following steps:

1. Navigate to the AOS-CX switches configuration page using either of the following methods:
n Set the filter to a Group containing at least one AOS-CX switch, navigate to Manage > Devices,

select the Switches tab.

n Set the filter to Global, navigate to Maintain > Organization > Network Structure > Groups,
select a group containing at least one AOS-CX switch, click the Go to config icon, and select
the Switches tab.

2. Select the AOS-CX Config icon.

The Set Device Password pop-up is displayed.

3. Enter the Administrator password and click Save.

The password is set for the AOS-CX switches.

Setting the Password for Controllers

To set the password for controllersin a group, complete the following steps:

1. Navigate to the controllers configuration page using either of the following methods:
n Set the filter to a Group, navigate to Manage > Devices, then select the Controllers tab, click

Config.
n Set the filter to Global, navigate to Maintain > Organization > Network Structure > Groups,

then select a group and click Go to config, select the Controllers tab.

2. In the Advanced Mode, select System > General > Basic Info.
3. Enter the password in the Password for user admin field.
4. Retype the password and click Save Settings.

The password is set for the controllers.

Provisioning Devices
This section on provisioning devices in groups, see the following topics

This section describes the following topics:
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n Provisioning Devices Using UI-based Workflows
n Provisioning Devices Using Configuration Templates

Provisioning Devices Using UI-based Workflows
This section describes the important points to consider when assigning devices to UI groups:

n Provisioning Devices Using UI-based Workflows
n Provisioning Devices Using UI-based Workflows

Provisioning APs using UI-based Configuration Method
An AP device group may consist of any of the following:

n AP Cluster—Consists of a conductor AP and member APs in the same VLAN.
n VC—A virtual controller. VC provides an interface for the entire cluster. The member APs and

conductor APs function together to provide a virtual interface.
n Conductor AP and Member AP—In a typical AP deployment scenario, the first AP that comes up is

elected as the conductor AP. All other APs joining the cluster function as the member APs. When a
conductor AP is configured, the member APs download the configuration changes. The conductor AP
may change as necessary from one device to another without impacting network performance.

Aruba Central On-Premises allows configuration operations at the following levels for a device group
with APs:

n Per group configuration—Aruba Central On-Premises allows you to maintain unique configuration
settings for each group. However, these settings are applied to all devices within that group. For
example, all VCs within a group can have common SSID settings.

n Per VC Configuration—Any changes that need to be applied at the AP cluster level can be
configured on a VC within a group. For example, VCs within a group can have different VLAN
configuration for the SSIDs.

n Per Device Configuration—Although devices are assigned to a group, the users can maintain
device-specific configuration such as radio, power, or uplink settings for an individual AP within a
group.

When the APs that are not pre-provisioned to any group join Aruba Central On-Premises, they are
assigned to groups based on their current configuration.

The following table lists the regular and default configurations for an Instant AP.

APs with Default Configuration APs with Non-Default Configuration

If an AP with factory default configuration
joins Aruba Central On-Premises, it is
automatically assigned to the default
group or an existing group with similar
configuration settings.
The administrators can perform any of the
following actions:
n Manually assign them to an existing

group.
n Groups.

If an AP with non-default or custom configuration joins Aruba
Central On-Premises, it is automatically assigned to an
unprovisioned group.
The administrators can perform any of the following actions:
n Groups for the device and preserve device configuration.
n Move the device to an existing group and override the device

configuration.

Table 37: Instant AP Provisioning
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Ensure that the conductor AP and member APs are assigned to the same group. You must convert the member
AP to a standalone AP in order to move the member AP to another group independently.

In the following illustration, APs from three different geographical locations are grouped under
California, Texas, and New York states. Each state has unique SSIDs and can support devices from
multiple locations in a state. As shown in , the California group has devices from different locations and
has the same SSID, while devices in the other states/groups have different SSIDs.

When a device with the factory default configuration connects to Aruba Central On-Premises, it is
automatically assigned to the default group. If the device has a custom configuration, it is marked as
unprovisioned. If you want to preserve the custom configuration, create a new group for the device. If
you want to overwrite the custom configuration, you can assign the device to an existing group.

The following illustration shows that APs from three different geographical locations are grouped under
California, Texas, and New York states.

Figure 21 AP provisioning

Provisioning Switches Using UI-based Configuration Method
Aruba Central On-Premises allows switches to join UI groups only if the switches are running factory
default configuration. Aruba Central On-Premises assigns switches with a factory default configuration
to the default group.

The administrators can either move the switch to an existing group or create a new group.

n Aruba Central On-Premises does not support UI-based configuration workflows for Aruba 5400R Switch
Series and switch stacks. Aruba recommends that you assign these devices to template groups and
provision them using configuration templates.

n Aruba Central On-Premises does not support moving Aruba 5400R Switch Series from the template group
to a UI group. If Aruba 5400R Switch Series is pre-assigned to a UI group, the device is moved to an
unprovisioned group after it joins Aruba Central On-Premises.
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Aruba Central On-Premises allows the following configuration operations at the following levels for
switches in a UI group: 

n Per group configuration— Aruba Central On-Premises allows you to maintain unique configuration
settings for each group. However, these settings are applied to all devices within that group. For
example, all switches within a group can have common VLAN settings.

n Per Device Configuration—Although the Switches inherit group configuration, the users can
maintain device-specific configuration, for example, ports or DHCP pools.

Provisioning Devices Using Configuration Templates
Aruba Central On-Premises allows you to provision devices using UI-based or template-based
configuration method. If you have groups with template-based configuration enabled, you can create a
template with a common set of CLI scripts, configuration commands, and variables. Using templates,
you can apply CLI-based configuration parameters to multiple devices in a group.

If the template-based configuration method is enabled for a group, the UI configuration wizards for the
devices in that group are disabled.

Creating a Group with Template-Based Configuration Method
To create a template group, complete the following steps:

1. From the Aruba Central On-Premises app, filter Global.
2. Under Maintain, click Organization.

By default, the Network Structure tab is displayed.

3. Click the Groups tile.

The Groups page is displayed.

4. Click (+) Add Group on the Groups table.

The Add Group page is displayed.

5. Enter the name of the group.

The group name can be a maximum of 32 single byte ASCII characters if you use the UI to create
the names. However, if you are using an NB API, the character limit increases to 128. A group
name supports alphanumeric characters and only "-", "_", and space as special characters.
System-defined group names such as “default”, “unprovisioned”, and “global” are not allowed in
group names.

By default, Aruba Central On-Premises enables the UI-based configuration. The template-based
configuration is displayed only when you select devices in the Add group page. Use the toggle button
to enable the Configure using templates.

6. Select the device type for which you want to create a template group:
n Access points
n Gateways/Controllers
n Switches

7. Click Next.
By default the ArubaOS 8 architecture is applied for access points and controllers.

8. Select the switch type for the group.
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9. Select the check box for Make these the preferred group settings optionally to save the
architecture and persona settings of the current group for subsequent group creations.

10. Click Add.

If the group is set as a template group, a configuration template is required for managing device
configuration.

Provisioning Devices Using Configuration Templates and Variable Definitions
For information on configuration template, see the following topics:

n Configuring IAPs Using Templates
n Configuring AOS-S Switches using Templates
n Configuring AOS-CX Switches using Templates
n Managing Variable Files

Configuring IAPs Using Templates
Templates in Aruba Central On-Premises refer to a set of configuration commands that can be used by
the administrators for provisioning devices in a group. Configuration templates enable administrators
to apply a set of configuration parameters simultaneously to multiple devices in a group and thus
automate access point (AP)  deployments.

To minimize configuration errors and troubleshoot device-specific configuration issues, Aruba recommends
that the device administrators familiarize themselves with the CLI configuration commands available on Aruba
IAPs.

For template-based provisioning, IAPs must be assigned to a group with template-based configuration
method enabled.

To create a template for the IAPs in a template group, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the template group under
Groups.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click the Config icon.

The tabs to configure APs in a template group are displayed.

4. In the Templates table, click + to add a new template.

The Add Template pop-up window is displayed.

5. Under Basic Info, enter the following information:
n Template Name—Enter the template name.
n Model—Set the model parameter to ALL.
n Version—Set the model parameter to ALL.

6. Under Template, add the CLI script content.
7. Check the following guidelines before adding content to the template:

n Ensure that the command text indentation matches the indentation in the running
configuration.
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n The template allows multiple per-ap-settings blocks. The template must include the per-ap-
settings %_sys_lan_mac% variable. The per-ap-settings block uses the variables for each AP.
The general VC configuration uses variables for conductor AP to generate the final
configuration from the provided template. Hence, Aruba recommends that you upload all
variables for all devices in a cluster and change values as required for individual AP variables.

n You can obtain the list of variables for per-ap-settings by using the show amp-audit

command.

The following example shows the list of variables for per-ap-settings.

(Instant AP)# show amp-audit | begin per-ap

per-ap-settings 70:3a:0e:cc:ee:60

hostname EE:60-335-24

rf-zone bj-qa

ip-address 10.65.127.24 255.255.255.0 10.65.127.1 10.65.6.15 ""

swarm-mode standalone

wifi0-mode access

wifi1-mode access

g-channel 6+ 21

a-channel 140 26

uplink-vlan 0

g-external-antenna 0

a-external-antenna 0

ap1x-peap-user peap22 282eaf1077b8d898b91ec41b5da19895

The commands in the template are case-sensitive.

IF ELSE ENDIF conditions are supported in the template. If the template text includes the if
condition, % sign is required at the beginning and the end of the text. For example, %if guest%.

The following example shows the template text with the IF ELSE ENDIF condition.

wlan ssid-profile %ssid_name%

%if disable_ssid=true%

disable-ssid

%endif%

%if ssid_security=wpa2%

opmode wpa2-aes

%else%

opmode opensystem

%endif%

Templates also support nesting of the IF ELSE END IF condition blocks.

The following example shows how to nest such blocks:

%if condition1=true%

routing-profile

route 10.10.0.0 255.255.255.0 10.10.0.255

%if condition2=true%

routing-profile

route 10.20.0.0 255.255.255.0 10.20.0.255

%else%

routing-profile

route 10.30.0.0 255.255.255.0 10.30.0.255

%endif%

%else%
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routing-profile

route 10.40.0.0 255.255.255.0 10.40.0.255

%if condition3=true%

routing-profile

route 10.50.0.0 255.255.255.0 10.50.0.255

%else%

routing-profile

route 10.60.0.0 255.255.255.0 10.60.0.255

%endif%

%endif%

For profile configuration CLI text, for example, vlan, interface, access-list, ssid and so on, the
first command must start with no white space. The subsequent local commands in given
profile must start with at least one initial space (' ') or indented as shown in the following
examples:

Example 1

wlan auth-server %auth_server_name%

ip %auth_server_ip%

port 1812

acctport 1813

%if auth_server_key%

key %auth_server_key%

%else%

key 123456

%endif%

Example 2

%if vlan_id1%

vlan %vlan_id1%

%if vlan_id1=1%

ip address dhcp-bootp

%endif%

no untagged %_sys_vlan_1_untag_command%

exit

%endif%

To comment out a line in the template text, use the pound sign (#). Any template text
preceded by # is ignored when processing the template.

To allow or restrict APs from joining the Instant Access Point (IAP) cluster, Aruba Central uses
the _sys_allowed_ap system-defined variable. Use this variable only when allowed APs
configuration is enabled. For example, _sys_allowed_ap: "a_mac, b_mac, c_mac". Use this
variable only once in the template.

8. Click OK.

Managing Variable Files
Aruba Central On-Premises allows you to configure multiple devices in bulk using templates. However,
in some cases, the configuration parameters may vary per device. To address this, Aruba Central On-
Premises identifies some customizable CLI parameters as variables and allows you to modify the
definitions for these variables as per your requirements.
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You can download a sample file with variables for a template group or for the devices deployed in a
template group, update the variable definitions, upload the file with the customized definitions, and
apply these configuration changes in bulk.

Downloading Sample Variables File

The sample variables file includes a set of sample variables that the users can customize. You can
download the sample variables file in the JSON or CSV format.

To download a sample variables file, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the template group under
Groups.

2. Under Manage, click Devices > Switches.
3. Click the Config icon.
4. Click Variables.
5. Select one of the following formats to download the sample variables file:

n JSON—shows the file in JSON format.
n CSV—Shows the variables in different columns.

6. Click Download Sample Variables File. The sample variables file is saved to your local directory.

Modifying a Variable File
The CSV file includes the following columns for which the variable definitions are mandatory:

n _sys_serial—For serial number of the device.
n _sys_lan_mac—For MAC address of the device.
n modified—To indicate the modification status of the device. The value for this column is set to N in

the sample variables file. When you edit a variable definition, set the modified column to Y to allow
Aruba Central On-Premises to parse the modified definition.

n The CSV file must contain only one modified column with the value Y in each row where the variables
are modified.

n The modified column is not required when using JSON files to upload the variables.

Following is an example format of the CSV file with the modified column.

Predefined Variables for Aruba Switches
The system defined variables in the sample variables files are indicated with _sys prefix.



Network Structure | 206

The following table lists the predefined variables for switches.

Variable
Name Description Variable Value

_sys_gateway Populates gateway IP address.  10.22.159.1

_sys_hostname Maintains unique host name.  HP-2920-48G-POEP

_sys_ip_address Indicates the IP address of the device.  10.22.159.201

_sys_module_
command

Populates module lines  module 1 type j9729a

_sys_netmask Netmask of the device.  255.255.255.0

_sys_oobm_
command

Represents Out of Band Management
(OOBM) block.

oobm                          
ip address dhcp-bootp        
exit

_sys_snmpv3_
engineid

Populates engine ID.  00:00:00:0b:00:00:5c:b9:01:22:4c:00

_sys_stack_
command

Represents stack block stacking
member 1 type "J9729A" mac-address 5cb901-
224c00
exit

_sys_template_
header

Represents the first two lines of the
configuration file. Ensure that this
variable is the first line in the
template.

 ; J9729A Configuration Editor; Created on release
#WB.16.03.0003+
; Ver
#0f:3f.f3.b8.ee.34.79.3c.29.eb.9f.fc.f3.ff.37.ef:91

_sys_use_dhcp Indicates DHCP status (true or false) of
VLAN 1

 0

_sys_vlan_1_
untag_
command

Indicates untagged ports of VLAN 1  1-28,A1-A2

_sys_vlan_1_tag_
command

Indicates tagged ports of VLAN 1  28-48

Table 38: Predefined Variables Example

The _sys_template_header_ and _sys_snmpv3 engineid are mandatory variables that must have the values
populated, irrespective of their use in the template. If there is no value set for these variables, Aruba Central
On-Premises re-imports the values for these mandatory variables when it processes the running configuration
of the device.

Predefined Variables for APs
For APs, the sample variables file includes the _sys_allowed_ap variable for which you can specify a
value to allow new APs to join the AP cluster.
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Important Points to Note
The following conditions apply to the variable files:

n The variable names must be on the left side of condition and its value must be defined on the right
side. For example, %if var=100% is supported and %if 100=var% is not supported.

n The < or <= or > or >= operators should have only numeric integer value on the right side. The
variables used in these 4 operations are compared as integer after flooring. For example, if any float
value is set as %if dpi_value > 2.8%, it is converted as %if dpi_value > 2 for comparison.

n The variable names should not include white space, and the & and % special characters. The variable
names must match regular expression [a-zA-Z0-9_]. If the variables values with % are defined, ensure
that the variable is surrounded by space. For example, wlan ssid-profile %ssid_name%.

n The first character of the variable name must be an alphabet. Numeric values are not accepted.
n The values defined for the variable must not include spaces. If quotes are required, they must be

included as part of the variable value. For example, if the intended variable name is wlan ssid-profile
"emp ssid”, then the recommended format for the syntax is "wlan ssid-profile %ssid_name%” and
variable as “ssid_name”: "\"emp ssid\"".

n If the configuration text has the percentage sign % in it—for example, "url "/portal/scope.cust-
5001098/Splash%20Profile%201/capture"—Aruba Central On-Premises treats it as a variable when
you save the template. To allow the use of percentage % as an escape character, use \" in the
variable definition as shown in the following example:

Template text

wlan external-captive-portal "Splash Profile 1_#guest#_" 

server naw1.cloudguest.central.arubanetworks.com

port 443

url %url%

Variable

"url": "\"/portal/scope.cust-5001098/Splash%20Profile%201/capture\""

n Aruba Central On-Premises supports adding multiple lines of variables in AP configuration templates.
If you want to add multiple lines of variables, you must add the HAS_MULTILINE_VARIABLE directive at
the beginning of the template.

Example

#define HAS_MULTILINE_VARIABLE 1

%if allowed_aps%

%allowed_aps%

%endif%

Variable

“allowed_aps”: “allowed-ap 24:de:c6:cb:76:4e\n allowed-ap ac:a3:1e:c5:db:d8\n

allowed-ap 84:d4:7e:c4:8f:2c"
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n For APs, you can configure a variable file with a set of values defined for a conductor AP in the
network. When the variable file is uploaded, the configuration changes are applied to all AP devices
in the cluster.

Examples

The following example shows the contents of a variable file in the JSON format for APs:

{ 

"CK0036968": {

"_sys_serial": "CK0036968",

"ssid": "s1",

"_sys_lan_mac": "ac:a3:1e:c5:db:7a",

"vc_name": "test_config_CK0036968",

"org": "Uber_org_test",

"vc_dns_ip":"22.22.22.22",

"zonename": "Uber_1",

"uplinkvlan": "0",

"swarmmode": "cluster",

"md5_checksum": "ed8a67a3d1be58261640ca53f8fd3bb8",

"hostname": "Uber_1"

},

"CJ0219729": {

"_sys_serial": "CJ0219729",

"ssid": "s1",

"_sys_lan_mac": "ac:a3:1e:cb:04:92",

"vc_name": "test_config_CK0036968",

"org": "Uber_org_test",

"vc_dns_ip":"22.22.22.22",

"zonename": "Uber_1",

"uplinkvlan": "0",

"swarmmode": "cluster",

"hostname": "Uber_2"

},

"CK0112486": {

"_sys_serial": "CK0112486",

"ssid": "s1",

"_sys_lan_mac": "ac:a3:1e:c8:29:76",

"vc_name": "test_config_CK0036968",

"org": "Uber_org_test",

"vc_dns_ip":"22.22.22.22",

"zonename": "Uber_1",

"uplinkvlan": "0",

"swarmmode": "cluster",

"md5_checksum": "ed8a67a3d1be58261640ca53f8fd3bb8",

"hostname": "Uber_3"

},

"CT0779001": {

"_sys_serial": "CT0779001",

"ssid": "s1",

"_sys_lan_mac": "84:d4:7e:c5:c6:b0",

"vc_name": "test_config_CK0036968",

"org": "Uber_org_test",

"vc_dns_ip":"22.22.22.22",

"zonename": "Uber_1",

"uplinkvlan": "0",

"swarmmode": "cluster",

"md5_checksum": "ed8a67a3d1be58261640ca53f8fd3bb8",

"hostname": "Uber_4"

},
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"CM0640401": {

"_sys_serial": "CM0640401",

"ssid": "s1",

"_sys_lan_mac": "84:d4:7e:c4:8f:2c",

"vc_name": "test_config_CK0036968",

"org": "Uber_org_test",

"vc_dns_ip":"22.22.22.22",

"zonename": "Uber_1",

"uplinkvlan": "0",

"swarmmode": "cluster",

"md5_checksum": "ed8a67a3d1be58261640ca53f8fd3bb8",

"hostname": "Uber_6"

},

"CK0037015": {

"_sys_serial": "CK0037015",

"ssid": "s1",

"_sys_lan_mac": "ac:a3:1e:c5:db:d8",

"vc_name": "test_config_CK0036968",

"org": "Uber_org_test",

"vc_dns_ip":"22.22.22.22",

"zonename": "Uber_1",

"uplinkvlan": "0",

"swarmmode": "cluster",

"md5_checksum": "ed8a67a3d1be58261640ca53f8fd3bb8",

"hostname": "Uber_7"

},

"CK0324517": {

"_sys_serial": "CK0324517",

"ssid": "s1",

"_sys_lan_mac": "f0:5c:19:c0:71:24",

"vc_name": "test_config_CK0036968",

"org": "Uber_org_test",

"vc_dns_ip":"22.22.22.22",

"zonename": "Uber_1",

"uplinkvlan": "0",

"swarmmode": "cluster",

"md5_checksum": "ed8a67a3d1be58261640ca53f8fd3bb8",

"hostname": "Uber_8"

}

}

The following illustration shows a sample variables file in the CSV format.

Figure 22 Variables File in the CSV Format

Uploading Variable Files
To upload a variable file, complete the following steps:

While uploading the variables file to Aruba Central On-Premisesin the CSV format, make sure to:

n Choose the default language in Microsoft Excel as English (United States).
n Add only one modified column in the CSV file with the value Y in each row where the variables are

modified.
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1. Ensure that the _sys_serial and _sys_lan_mac variables are defined with the serial number and
MAC address of the devices, respectively.

2. In the Aruba Central On-Premises app, set the filter to one of the template groups under
Groups.

3. Under Manage, click Devices > Switches.
4. Click the Config icon.
5. Click Variables.
6. Click Upload Variables File and select the variable file to upload.
7. Click Open.

The contents of the variable file is displayed in the Variables table.

8. To search for a variable, specify a search term and click Search icon.
9. To download variable file with device-specific definitions, click the download icon in the Variables

table

Modifying Variables
To modify variables without downloading a variable file, modifying the variable file, or uploading the
customized variable file, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the template groups under
Groups.

2. Under Manage, click Devices > Switches.
3. Click the Config icon.
4. Click Variables.
5. Select a device and variable.
6. Modify the value and click Add to Modifications.
7. Click Save.

Alternatively, to modify a single variable without downloading a variable file, modifying the variable file,
or uploading the customized variable file, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the template groups under
Groups.

2. Under Manage, click Devices > Switches.
3. Click the Config icon.
4. Hover over a desired variable and click Edit.
5. Modify the value and click Save.
6. Click Save.

Managing Sites and Labels
This section describes the various options to configure and manage sites and labels in the Aruba Central
On-Premises WebUI.

Managing Sites
In Aruba Central On-Premises, a site refers to a physical location where a set of devices are installed; for
example, campus, branch, or a venue. You can create a branch or a campus site; for example Branch A
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or Campus A, for a specific geographical location and assign devices to it. You can use these sites as
filters for viewing your deployment topology, monitoring network and device health.

The Manage Sites page allows you to create, edit, and delete sites, view the list of sites configured in
your setup, and assign devices to sites.

To access the Manage Sites page in the Aruba Central On-Premises app, navigate to Network
Structure tab under Maintain > Organization. Click the Sites tile to view the Manage Sites page.

The following table describes the various functions on the Manage Sites page.

Parameter Description

Convert Labels
to Sites

Allows you to convert existing labels to sites. To convert labels, download the CSV file with
the list of labels configured in your setup, add the site information, and upload the CSV file.
For more information, see Convert Existing Labels to Sites.

New Site Allows you to create a new site.

Bulk upload Allows you to add sites in bulk from a CSV file.

Table 39: Sites Page

Sites Table
The sites table displays a list of sites configured. It provides the following information:

Parameter Description

Site Name Name of the site.

Address Physical address of the site.

Device Count Number of devices assigned to a site.

Table 40: Sites Table

The table also includes the following sorting options to reset the table view on the right:

n All Devices—Displays all the devices provisioned in Aruba Central On-Premises.
n Unassigned—Displays the list of devices that are not assigned to any site.

You can also use the filter and sort icons on the Sites and Address columns to filter and sort sites
respectively.

Devices Table
The devices table displays a list of devices provisioned. It provides the following information:

Parameter Description

Name Name of the device.

Group Group to which the device is assigned.

Type Type of the device.

Table 41: Devices Table
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Creating a Site
A site refers to a physical location where a set of devices are installed; for example, campus or branch. If
your devices are deployed in a campus, you could create a site with the campus name. On a campus
with more than one building with the same address, site creation using the latitude and longitude
values helps to display the buildings correctly on the map. You can use the sites to monitor devices
installed on a physical location.

To create a site, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization.

By default, the Network Structure tab is displayed.

3. Click the Sites tile.

The Manage Sites page is displayed.

4. To add a new site, click (+) New Site.

The Create New Site pop-up window is displayed.

5. In the Create New Site pop-up window, configure the following parameters:
a. Site Name—Name of the site.

To name a site, see the following guidelines:
n The site name can be a maximum of 255 single-byte characters.
n The site name supports alphanumeric characters, and special characters. Special

characters that are not supported are <, >, and &.

n Default, Default Site, Default_Site and Default-Site cannot be used as a site names.

The above names are not case-sensitive; hence you cannot use words like DeFauLT_sIte as site
name.

b. Street Address—Address of the site.
c. City—City in which the site is located.
d. Country—Country in which the site is located.
e. State/Province—State or province in which the site is located.
f. ZIP/Postal Code—(Optional) ZIP or postal code of the site.
g. Latitude—(Optional) The latitudinal value of the site.
h. Longitude—(Optional) The longitudinal value of the site.

The latitudinal and longitudinal values are auto-filled, if not entered manually.
If a caution icon appears next to a newly created site, click the edit icon next to the site name and
manually enter the latitudinal and longitudinal values of the site.

6. Click Add.

The new site is added to the Sites table.

Adding Multiple Sites in Bulk
You can add multiple sites by creating and importing a CSV file with mandatory information such as the
site name, address, city, state, and country details.
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To import site information from a CSV file in bulk, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization.

By default, the Network Structure tab is displayed.

3. Click the Sites tile.

The Manage Sites page is displayed.

4. Click (+) Bulk upload.

The Bulk Upload pop-up window is displayed.

5. Download a sample file.
6. Fill the site information and save the CSV file in your local directory.

The CSV file for bulk upload of sites must include the mandatory information such as the name,
address, city, state, and country details.

7. In the Bulk Upload window, click Next.

8. In the Aruba Central On-Premises UI, click Browse and add the file from your local directory.
9. Click Upload.

The sites from the CSV file are added to the site table.

Assigning a Device to a site
Sites are used to group devices by a physical location. You can assign devices to a site to group them
and monitor based on the site name.

To assign a device to a site, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization.

By default, the Network Structure tab is displayed.

3. Click the Sites tile.

The Manage Sites page is displayed.

4. Select Unassigned.

The list of devices that are not assigned to any site is displayed.

5. Select device(s) from the list of devices.
6. Drag and drop the devices to the site on the left.

A pop-up window is displayed that prompts you to confirm the site assignment.

7. Click Yes.

Convert Existing Labels to Sites
To convert existing labels to sites, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization.

By default, the Network Structure tab is displayed.
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3. Click the Sites tile.

The Manage Sites page is displayed.

4. Click Convert Labels to Sites.

The Confirm Conversion pop-up window is displayed.

5. To download a CSV file with the list of labels configured in your setup, click Download file with
existing labels.

A CSV file with a list of all the labels in your setup is downloaded to your local directory.

6. Enter address, city, state, country, and ZIP code details for the labels that you want to convert to
sites.

In the CSV file, you must enter the following details: address, city, state, and country.

7. Save the CSV file.
8. On the Confirm Conversion pop-up window, click Next.
9. Click Browse and select the CSV file with the list of labels to convert.

10. Click Upload.
11. Click Convert.

The labels are converted to sites.

Points to Note

n If the conversion process fails for some labels, Aruba Central On-Premises generates and opens an
Excel file showing a list of labels that could not be converted to sites. Verify the reason for the errors,
update the CSV file, and re-upload the file.

n Aruba Central On-Premises does not allow conversion of sites to labels. If the existing labels are
converted to sites, you cannot revert these sites to labels.

n When the existing labels are converted to sites, Aruba Central On-Premises retains only the historical
data for these labels. Aruba Central On-Premises displays the historical data for these labels only in
reports and on the monitoring dashboard.

Editing a Site
You can edit a site to modify the site details such as site name, street address, city, county, state, or zip
or postal code.

To modify a site details, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization.

By default, the Network Structure tab is displayed.

3. Click the Sites tile.

The Manage Sites page is displayed.

4. Select the site to edit and click the edit icon.
5. Modify the site information and click Update.

Deleting a Site
If you no longer need a site, you can delete it.
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To delete a site, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization.

By default, the Network Structure tab is displayed.

3. Click the Sites tile.

The Manage Sites page is displayed.

4. Select the site to be deleted and click the delete icon.

A confirmation window is displayed.

The delete icon is available only when all the devices are disassociated from the site you want to delete.

5. Click Yes to confirm.

The site is deleted and devices associated with the site are moved to the unassigned devices list.

Removing devices from a site
Aruba Central supports removing devices from a site. You can either remove a single device or multiple
devices.

Removing a single device from the site
To remove a single device from a site, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization.

By default, the Network Structure tab is displayed.

3. Click the Sites tile.

The Manage Sites page is displayed.

4. Select the site from which you want to remove the device.

5. Hover over the device you want to remove and click the delete icon.
The selected device is removed from the site.

Removing multiple devices from a site
To remove multiple devices from a site, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization.

By default, the Network Structure tab is displayed.

3. Click the Sites tile.

The Manage Sites page is displayed.

4. Select the site from which you want to remove the devices.
5. In the devices list, select the devices you want to remove and click Remove Device(s). A

maximum of 20 devices can be deleted at a time.

A confirmation window is displayed.

6. Click Yes to confirm.

The selected devices are removed from the site.
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Moving devices from one site to another site
You cannot move devices directly from one site to another site. To move devices from site to another,
you must first remove the device from its current site. The device will be moved to the unassigned
device list. From the unassigned device list, move the device to desired site.

Site Search Terms
The search bar helps you to search a site's information on the Network Operation app.

Using the search bar, you can perform the following tasks:

n Hover over a client search card to view the monitoring summary for the site.
n Click the client name to open the Site Details page.

The following illustration is an example for the site search.

Figure 23 Search Card for a Site

Labels and How to Manage Them
Labels are tags attached to a device provisioned in the network. Labels determine the ownership,
departments, and functions of the devices. You can use labels for creating a logical set of devices and
use these labels as filters when monitoring devices and generating reports.

The Manage Labels page allows you to create and modify labels, sites, and assign devices to labels.

To access the Manage Labels page in the Aruba Central On-Premises app, under Maintain, navigate
to Network Structure > Organization > Labels.

The following table describes the various functions on the Manage Labels page.

Name Contents of the Table

Labels Displays a list of labels configured. The table provides the following information:
n Name of the label
n Number of devices assigned to a label

The table also includes the following sorting options to reset the table view on the right:
n All Devices—Displays all the devices provisioned in Aruba Central.
n Unassigned—Displays the list of devices that are not assigned to any label.

Devices Displays a list of devices provisioned. The table provides the following information about the
devices:

Table 42: Labels
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Name Contents of the Table

n Name—Name of the device
n Group—Group to which the device is assigned
n Type—Type of the device
n Labels—Number of labels assigned to a device

To know more about labels and how to manage them, see the following topics:

n Device Classification

n Creating a Label

n Assigning a Device to a Label

n Detaching a Device from a Label

n Editing a Label

n Deleting a Label

Device Classification
The devices can also be classified using Groups and Sites as described in the following points:

n The group classification can be used for role-based access to a device, while labels can be used for
tagging a device to a location or a specific area at a physical site. However, if a device is already
assigned to a group and has a label associated with it, it is classified based on both groups and labels.

n The site classification is used for logically grouping devices deployed at a given physical location. You
can also convert labels to sites.

Creating a Label
To create a label, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization.

By default, the Network Structure tab is displayed.

3. Click the Labels tile.

The Manage Labels page is displayed.

4. To add a new label, click (+) Add Label.
The Create New Label pop-up window is displayed.

5. Enter a name for the label.

The label name can be a maximum of 255 single byte characters. Special characters are allowed.

6. Click Add.

The new label is created.
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Assigning a Device to a Label
To assign a device to a label, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization.

By default, the Network Structure tab is displayed.

3. Click the Labels tile.

The Manage Labels page is displayed.

4. Locate the label to which you want to assign a device.
5. In the table that lists the labels, you can perform one of the following actions:

n Click All Devices to view all devices.
n Click Unassigned to view all the devices that are not assigned to any labels.

6. Select Unassigned.

The list of devices that are not assigned to any label is displayed.

7. Select device(s) from the list of devices.
8. Drag and drop the selected device(s) to a specific label.

A pop-up window asking you to confirm the label assignment is displayed.

9. Click Yes.

Detaching a Device from a Label
To remove a label assigned to a device or devices, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization.

By default, the Network Structure tab is displayed.

3. Click the Labels tile.

The Manage Labels page is displayed.

4. Select the label from which you want to detach a device.

The list of devices assigned to the label appears in the table on the right.

5. Select the device from the table.

6. Click the delete icon.
To detach labels from multiple devices at once, select the devices and click Batch Remove
Labels

7. Confirm deletion.

Editing a Label
To edit a label, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization.

By default, the Network Structure tab is displayed.
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3. Click the Labels tile.

The Manage Labels page is displayed.

4. Select the label to edit.
5. Click the edit icon.
6. Edit the label and click Update.

Deleting a Label
To delete a label, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization.

By default, the Network Structure tab is displayed.

3. Click the Labels tile.

The Manage Labels page is displayed.

4. Select the label to delete.
5. Click the delete icon.

The delete icon is available only when the label is not assigned to any device.

6. Confirm deletion.

Preprovision Devices
The device on-boarding procedures like adding devices and assigning licenses, which were earlier
available on the Account Home page of Aruba Central are now available on the HPE GreenLake account
home.

To know more about preprovisioned devices on the network, see the following topics:

n Viewing Devices List

n Assigning Devices to Groups

For more information, see the Managing Devices and Subscriptions.

Viewing Devices List
The devices provisioned in your account are listed in the Organization > Network Structure > Device
Preprovisioning pane.

To view the Device Preprovisioning page, complete the following steps:

1. In the Aruba Central app, set the filter to Global.
2. Under Maintain, click Organization.

By default, the Network Structure tab is displayed.

3. Click the Device Preprovisioning tile.

The Device List table is displayed.

The Device List table lists the total number of devices; and the number of access points,
switches, and gateways in the inventory.
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In the Serial Number column, you must enter the device serial number in full for filtering the data.
Entering a partial serial number does not show any search results in the table.

The following table describes the columns in the Device List table.

Parameter Description

Serial Number Serial number of the device.

MAC Address MAC address of the device.

Device Type Type of device. For example Instant AP, switch, or controller.

Model Hardware model of the device.

Part Number Part number of the device.

IP Address IP address of the device.

Name Name of the device.

Group Group assigned to the device.

Table 43: Device Details

Assigning Devices to Groups
To assign factory default devices to a group, complete the following steps in the Device
Preprovisioning page:

The following procedure is only for assigning groups to the devices that are not connected. The group
management actions like moving devices between groups, or moving devices from unprovisioned group to
other groups is done on the Groups page. For more information, see Groups.

1. In the Aruba Central app, set the filter to Global.
2. Under Maintain, click Organization.

By default, the Network Structure tab is displayed.

3. Click the Device Preprovisioning tile.

The Device List table is displayed.

4. Select the device(s) which you want to move to a selected group. You can select and move up to
50 devices at a time.

If the selected device is already connected to Aruba Central, the Move devices option will not be
available for the device.

5. Click the Move devices icon.

The Assign Group page is displayed.
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6. Select the Destination Group from the drop-down list.

You can assign only particular device type for which the group is created. For example, if a group is
created for Access Points only, then only Access Points can be assigned to that group. You cannot
assign other device types to it.

7. Click Move.

The selected device(s) are moved to the destination group. These devices will adopt the
destination group configuration.

For every device preprovisioning operation, a warning pop-up is displayed to check the audit trail log
for the status. If you are assigning the devices in bulk, ensure to check the audit trail to confirm if the all
devices are successfully assigned and reason for the rejected devices.

Managing Certificates
Certificates provide a secure way of authenticating devices and eliminate the need for less secure
password-based authentication. In certificate-based authentication uses digital certificates to identify a
user or device before granting access to a network or application.

Server certificates and the digital certificates issued by a CA validate the identities of servers and clients.
For example, when a client connects to a server for the first time or the first time since its previous
certificate expired or revoked. The server requests that the client to transmit its authentication
certificate and verifies it. Clients can also request and verify the authentication certificate of the server.

To avoid any error in the server certification, ensure to include the following Subject Alternate Name (SAN) in
the certificate:

n apigw-<FQDN>
n central-<FQDN>
n ccs-user-api-<FQDN>
n sso-<FQDN>

This topic includes the following sections:

n Device Certificates
n Central On Premises Certificates
n Certificate Revocation
n Certificate Signing Request
n Supported certificate Formats
n Wildcard Certificates

Device Certificates
Aruba devices use digital certificates to authenticate clients to access user-centric network services.
Most devices such as controllers and Instant APs include the certificate of the CA who issued the server
certificate for device authentication.
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Aruba recommends that you replace the default certificate with a custom certificate issued for your site or
domain by a trusted CA.

Devices can store certificates locally and used for device validation or user identification during
authentication.

Viewing the Certificate Store Parameters
To view the certificate store parameters, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization.

The Network Structure tab is displayed.

3. Click the Certificates tile.

The Certificates page is displayed.

4. If required, expand the Device Certificates accordion to view the Certificate Store table.

The Certificate Store table displays the following information.
Table 44: Certificate Store Parameters

Parameter Description

Certificate Name Name of the certificate.

Status Status of the certificate.

Expiry Date Expiry date of the certificate.

Services Type of services supported by the certificate.

Type Type of certificate.

SHA-1 Checksum The Secure Hash Algorithm 1 is a cryptographic hash function which takes an input and
produces a 160-bit (20-byte) hash value.

NOTE: In the Certificate Store table, click the icon to display the required columns.

Uploading Device Certificates
To upload certificates, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization.

The Network Structure tab is displayed.

3. Click the Certificates tile.

The Certificates page is displayed.

4. If required, expand the Devicel Certificates accordion to view the Certificate Store table.
5. Click the + icon to add the certificate to the Certificate Store.
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6. In the Add Certificate dialog-box, specify the following information:
n Name—Name of the certificate.
n Type—Select of certificate type. You can select any one of the following certificates:

o Server Certificate—Server certificates required for communication between devices and
authentication servers.

The Passphrase, and Retype Passphrase options are applicable only when you select Server
Certificate from the Type drop-down list.

o CA Certificate—Digital certificates issued by the CA.
o CRL—Certificate Revocation List contains the serial numbers of certificates that have been

revoked. To perform a certificate revocation check the Certificate Revocation List is
required.

o OCSP Responder Cert—OCSP responder certificates.
o OCSP Signer Cert—OCSP Response Signing Certificate.

The OCSP certificates are required for OCSP server authentication.

n Format—Select a certificate format. You can select any one of the following certificates:
o PEM—Privacy Enhanced Mail is a Base64 encoded DER certificate.
o DER—Distinguished Encoding Rules files are digital certificates in binary format. Both digital

certificates and private keys can be encoded in DER format.
o PKCS12—Public-Key Cryptography Standards 12 is an archive file format for storing many

cryptography objects as a single file.

The PKCS12 certificate format option is not applicable when you select CA Certificate from the
Type drop-down list.

n Passphrase—Enter a passphrase.
n Retype Passphrase—Retype the passphrase for confirmation.

The Passphrase and Retype Passphrase options are displayed only when you select Server
Certificate from the Type drop-down list.

n Certificate File—Click Choose File and browse to the location where the certificates are
stored and select the certificate files.

7. Click Add.

The certificate is added to the Certificate Store table.

Deleting Device Certificates
To delete certificates, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization.

The Network Structure tab is displayed.
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3. Click the Certificates tile.

The Certificates page is displayed.

4. If required, expand the Device Certificates accordion to view the Certificate Store table.

5. In the Certificate Store table, select the certificate that you want to delete and then click the
delete icon.

The Confirm Action pop-up window is displayed.

6. Click Yes in the Confirm Action pop-up window to delete the certificate.

Editing Device Certificates
To edit certificates, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization.

The Network Structure tab is displayed.

3. Click the Certificates tile.

The Certificates page is displayed.

4. If required, expand the Device Certificates accordion to view the Certificate Store table.

5. In the Certificate Store table, select the certificate that you want to edit and then click the edit
icon.

The Edit Certificate pop-up window is displayed.

6. Click Add to edit the certificate.

Central On Premises Certificates
To connect securely from a browser to access the Aruba Central On-Premises UI, a server certificate
must be uploaded to Aruba Central On-Premises. By default, Aruba Central On-Premises includes a self-
signed certificate. The default certificate is not signed by a trusted Certificate Authority (CA). Hence, the
browser displays a warning statement on launching the Aruba Central On-Premises application. To
avoid this you must upload a server certificate signed by a trusted certificate authority (CA).

Certificate Revocation
Aruba Central On-Premises now validates the revocation status of the client certificates. A certificate
revocation check validates a TLS or SSL protocol before its scheduled expiration date. A certificate
should be revoked immediately when its private key is compromised or when the domain for which it
was issued is no longer operational.

In an Online Certificate Status Protocol (OCSP) check, the clients send the certificate to the trusted CA
for validation and then CA validates and returns the status of the certificate as good, revoked, or
unknown. In a client certificate validation, Aruba Central On-Premises validates the client certificate and
if the validation fails, the communication between the client and Aruba Central On-Premises is
terminated.

The OCSP check and client certificate validation has the following two modes:

n In a non-strict mode, when a call to the OCSP server fails from the Aruba Central On-Premises server
as it is unreachable or the server has not processed the request, the communication to the external
server is not terminated. Also, the validation of the client certificate is not performed in a non-strict
mode for a client connecting to Aruba Central On-Premises server from the UI browser.
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n In a strict-mode, when a call to the OCSP server fails from the Aruba Central On-Premises server as it
is unreachable or the server has not processed the request, the communication to the external
server is terminated. Also, the validation of the client certificate is performed in a strict-mode for a
client connecting to Aruba Central On-Premises server from the UI browser.

When you enable the certificate revocation check in a Aruba Central On-Premises setup, the revocation settings
are applied only for Syslog and UI Client Cert Mutual Auth services.

Enabling certificate Revocation Check
To enable the revocation check, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization.

The Network Structure tab is displayed.

3. Click the Certificates tile.

The Certificates page is displayed.

4. If required, expand the Central On Premises Certificates accordion.
5. Enable the Enable revocation check toggle button.
6. Click Yes in the Confirm Action pop-up window.

The OCSP service is enabled to check the revocation status of the certificate.

7. Click the Enable Strict Checking checkbox to enable the certificate revocation check in a strict-
mode.

For using Mozilla Firefox browser in strict mode, set the parameters shown in the following image.

Figure 24 Strick-Mode Settings for Mozilla Firefox

8. Click Submit.
9. Click Yes in the Confirm Action pop-up window to submit the revocation settings.

To enable the revocation check, use the following Certificate Configuration commands:

n Enable client cert strict check- Enter option 10-1

n Disable client cert strict check- Enter option 10-2

n Generate device cert- Enter option 10-3

#https://www.arubanetworks.com/techdocs/CLI-Bank/Content/cop/10-CertConf/10-certconf.htm
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Viewing the certificate Store Parameters
To view the certificate store parameters, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization.

The Network Structure tab is displayed.

3. Click the Certificates tile.

The Certificates page is displayed.

4. Expand the Central On Premises Certificates accordion to view the Certificate Store table.

The Certificate Store table displays the following information.
Table 45: Certificate Store Parameters

Parameter Description

Certificate Name Name of the certificate.

Status Status of the certificate.

Expiry Date Expiry date of the certificate.

Services Type of services supported by the certificate.

Type Type of certificate.

SHA-1 Checksum The Secure Hash Algorithm 1 is a cryptographic hash function which takes an input and
produces a 160-bit (20-byte) hash value.

NOTE: In the Certificate Store table, click on the icon to display the required columns.

Uploading Central On Premises Certificates
To upload certificates, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization.

The Network Structure tab is displayed.

3. Click the Certificates tile.

The Certificates page is displayed.

4. Expand the Central On Premises Certificates accordion to view the Certificate Store table.
5. Click the + icon to add the certificate to the Certificate Store.
6. In the Add Certificate dialog box, specify the following information:

n Name—Name of the certificate.
n Type—Select of certificate type. You can select any one of the following certificates:

o Server Certificate—Server certificates are used between browsers and Aruba Central On-
Premises to access the Aruba Central On-Premises UI. A server certificate is also required
for communication between a device and Aruba Central On-Premises, when a device is
selected in supported services.
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o CA Certificate—Digital certificates issued by the CA. If a user intends to upload multiple CA
certificates, Aruba Central On-Premises allows you to combine and upload the certificates
as a single CA certificate.

The Operation Type option is applicable only when you select CA Certificate from the Type
drop-down list.

o Client Certificate—Client certificates are digital certificates for users to prove their identity
to a server. Client certificates are used in Aruba Central On-Premises to authenticate
requests made to remote servers.

The Services Supported, Passphrase, and Retype Passphrase options are applicable when you
select Server Certificate or Client Certificate from the Type drop-down list.

n Format—Select a certificate format. You can select any one of the following certificates:
o PEM—Privacy Enhanced Mail is a Base64 encoded DER certificate.
o DER—Distinguished Encoding Rules files are digital certificates in binary format. Both digital

certificates and private keys can be encoded in DER format.
o PKCS12—Public-Key Cryptography Standards 12 is an archive file format for storing many

cryptography objects as a single file.

The DER certificate format is not applicable when you select Server Certificate from the Type
drop-down list.

The PKCS12 certificate format option is not applicable when you select CA Certificate from the
Type drop-down list.

n Services Supported—Select the services to be supported by the certificate. A single server
certificate can be used for more that one supported services.

Web UI And API Gateway, Device and Secure AMON services are available when you select
Server Certificate from the Type drop-down list.

Only RadSec service is available when you select Client Certificate from the Type drop-down list.

o Web UI And API Gateway—The server certificate is applied to WebUI and API Gateway
service. The Web UI And API Gateway support RSA and Elliptical Curve Cryptography (ECC)
certificate. Only prime256v1, secp256r1, secp384r1 and secp521r1 types of ECC curves are
supported.

o Device—The server certificate is applied to device service.
o Secure AMON—The server certificate is applied to Secure Advanced Monitoring (SAMON)

service. To use Server certificates on Aruba Central On-Premises, the SAMON service uses
DTLS protocol.

o RadSec—The server certificate is applied to verify RadSec protocol. RadSec service secures
the communication between the Aruba Central On-Premises and RADIUS server.

n Operation Type—Select the action required while adding CA certificates. The Operation Type
option is applicable when you select CA Certificate from the Type drop-down list. You can
select any one of the following options:
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o Append—Adds the new CA certificates to the uploaded CA certificates along with its default
list of certificates. You can add a maximum of 10 CA certificates to the default list.

o Replace—Retains the default list and replaces the user-uploaded certificates only.
n Passphrase—Enter a passphrase that was used while generating the Private Key.
n Retype Passphrase—Retype the passphrase for confirmation.
n Certificate File—Click Choose File and browse to the location where the certificates are

stored and select the certificate files.

7. Click Add.

The certificate is added to the Certificate Store table.

Aruba Central On-Premises does not allow you to edit or delete the appliance certificates.

Certificate Signing Request
Aruba Central On-Premises also supports Certificate Signing Request (CSR) generation that will be used
when generating server certificates that needs to be used with Aruba Central On-Premises.

Certificate Revocation

To generate CSR for certificates, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization.

The Network Structure tab is displayed.

3. Click the Certificates tile.

The Certificates page is displayed.

4. Expand the Central On Premises Certificates accordion to view the Certificate Store table.
5. Under Central On Premises Certificate, click Generate and Download Certificate Signing

Request (CSR).
6. The Add Certificate Signing Request is displayed.
7. Enter the following details:

n Distinguished Name—Unique name.
n Organization—Name of your organization.
n Department Name—Department name of your organization.
n City—Name of the city of your organization.
n State—Name of the state of your organization.
n Country—Country code of your organization. See List of accepted country codes.
n Email Address—Contact email address.

8. Click Add.

A PEM file with the public key is generated and downloaded automatically.

9. Provide the downloaded PEM file to a CA for certificate generation.
10. Upload the certificate provided by the CA to Aruba Central On-Premises. The certificate must be

in PEM format.

https://www.digicert.com/ssl-certificate-country-codes.htm
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Supported certificate Formats
The following section describes the different certificate formats supported in Aruba Central On-
Premises.

PEM Format
The PEM format is the most common format used by Certificate Authorities issue certificates. PEM
certificates usually have extentions such as .pem, .crt, .cer, and .key. They are Base64 encoded ASCII files
and contain "-----BEGIN CERTIFICATE-----" and "-----END CERTIFICATE-----" statements. Server certificates,
intermediate certificates, and private keys can all be put into the PEM format.

Apache and other similar servers use PEM format certificates. Several PEM certificates, and even the
private key, can be included in one file, one below the other, but most platforms, such as Apache, expect
the certificates and private key to be in separate files. For more information, see Sample PEM file.

DER Format
The DER format is a binary form of a certificate instead of the ASCII PEM format. All types of certificates
and private keys can be encoded in DER format. DER is typically used with Java platforms. If you need to
convert a private key to DER, use the OpenSSL commands on this page.

PKCS#12 or PFX Format
The PKCS#12 or PFX format is a binary format for storing the server certificate, any intermediate
certificates, and the private key in one encryptable file. PFX files usually have extensions such as .pfx
and .p12. PFX files are typically used on Windows machines to import and export certificates and private
keys.

Wildcard Certificates
A wildcard certificate is a digital certificate that is applied to a domain and all its subdomains. SSL
certificates use the wildcards to extend SSL encryptions to subdomains. All the wildcard certificates have
a * in their common names. For example, a certificate that has *.arubathena.com in its common name,
is a wildcard certificate.

Requesting for Wildcard certificate
If the certificate is not secure or invalid, ensure to request for a wildcard certificate or a certificate for
the FQDN of the Aruba Central On-Premises server from an authorized certificate provider to resolve
the certificate error.

Uploading the Wildcard certificate
Once you get the certificates required, upload the certificate in the Aruba Central On-Premises system.

To add the wildcard certificate, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization.

The Network Structure tab is displayed.

3. Click the Certificates tile.

The Certificates page is displayed.

4. Expand the Central On Premises Certificates accordion to view the Certificate Store table.
5. Click the + icon to add the certificate to the Certificate Store.
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6. In the Add Certificate dialog box, enter the name.
7. Select Server Certificate from the Type drop-down list.
8. Select PEM from the Format drop-down list.
9. Select the Services supported for the Server Certificate.

10. Enter the Passphrase and Retype Passphrase.
11. In the Certificate File field, click Choose File and browse to the location where the certificates

are stored and select the wildcard certificate.

The PEM file contains the certificates and the private key. The private key must be in the PEM format
and appended after all the certificates. For more information, see Sample PEM format.

12. Click Add.

The new valid certificate is successfully added.

13. Once the valid certificate is uploaded, ensure to check the status of the certificate. For the steps,
see Checking the Status of the certificate

The wildcard certificate information is displayed.

This wildcard certificate can be applied to any server where the FQDN has one hostname followed by
.domainname.com. The same wildcard certificate cannot be used for servers which have other formats.
For example, .aw.domainname.com.

The following is a sample of the certificate file in PEM format:

-----BEGIN CERTIFICATE-----

MIIG2jCCBcKgAwIBAgIRAObNusiWw5M1dV3y8sEeS0cwDQYJKoZIhvcNAQELBQAw

gZAxCzAJBgNVBAYTAkdCMRswGQYDVQQIExJHcmVhdGVyIE1hbmNoZXN0ZXIxEDAO

BgNVBAcTB1NhbGZvcmQxGjAYBgNVBAoTEUNPTU9ETyBDQSBMaW1pdGVkMTYwNAYD

VQQDEy1DT01PRE8gUlNBIERvbWFpbiBWYWxpZGF0aW9uIFNlY3VyZSBTZXJ2ZXIg

-----END CERTIFICATE-----

-----BEGIN CERTIFICATE-----

MIIGCDCCA/CgAwIBAgIQKy5u6tl1NmwUim7bo3yMBzANBgkqhkiG9w0BAQwFADCB

hTELMAkGA1UEBhMCR0IxGzAZBgNVBAgTEkdyZWF0ZXIgTWFuY2hlc3RlcjEQMA4G

A1UEBxMHU2FsZm9yZDEaMBgGA1UEChMRQ09NT0RPIENBIExpbWl0ZWQxKzApBgNV

BAMTIkNPTU9ETyBSU0EgQ2VydGlmaWNhdGlvbiBBdXRob3JpdHkwHhcNMTQwMjEy

MDAwMDAwWhcNMjkwMjExMjM1OTU5WjCBkDELMAkGA1UEBhMCR0IxGzAZBgNVBAgT

/qJakXzlByjAA6quPbYzSf+AZxAeKCINT+b72x

-----END CERTIFICATE-----

-----BEGIN CERTIFICATE-----

MIIFdDCCBFygAwIBAgIQJ2buVutJ846r13Ci/ITeIjANBgkqhkiG9w0BAQwFADBv

MQswCQYDVQQGEwJTRTEUMBIGA1UEChMLQWRkVHJ1c3QgQUIxJjAkBgNVBAsTHUFk

ZFRydXN0IEV4dGVybmFsIFRUUCBOZXR3b3JrMSIwIAYDVQQDExlBZGRUcnVzdCBF

eHRlcm5hbCBDQSBSb290MB4XDTAwMDUzMDEwNDgzOFoXDTIwMDUzMDEwNDgzOFow

gYUxCzAJBgNVBAYTAkdCMRswGQYDVQQIExJHcmVhdGVyIE1hbmNoZXN0ZXn IxEDAO

-----END CERTIFICATE-----

-----BEGIN PRIVATE KEY-----

MIIEvwIBADANBgkqhkiG9w0BAQEFAASCBKkwggSlAgEAAoIBAQDXApH0YGJDko8W
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nYWSR+k3AFxYzVoVMRiJnodHEc+lYccWoBHWzlP/P8GkhRInHsPpA3RvG5idz/Jj

bi8RKbkWMnUU6DpBLPHexed8wpbmZ/O9CZAYTbe5OHNcC+igzhZ5U6nk4b7lxfth

mchBWAgmAKbzfmGiCQ/Gak/RTEqKtULDgBu3Em1GFzlmzE+yDRsHLqYtDGK+D2U6

v8rUXr+IGZfD2aWHtuZtCuOA+7rP9HexR2K776kqXLxj9jflj5rPH5N1VTNO1FUS

-----END PRIVATE KEY-----

Checking the Status of the certificate
Once Aruba Central On-Premises is installed by the user, a self-signed certificate gets generated
automatically and this certificate is not provided by any authorized CA providers. So, when you access
the Aruba Central On-Premises server using an FQDN, the browser displays a warning, Your
Connection is not private, because this certificate is not trusted by the browser.

The following illustration displays the warning message.

Figure 25 Connection Status

To check the status or validity of a certificate, complete the following steps:

1. Login to the Aruba Central On-Premises server.
2. Click the view site information icon next to the URL in the browser.
3. Click Certificates.

The certificate information is displayed. Here, you can check if the certificate is self-signed certificate
and more details like Country, Issues Name, etc.
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Figure 26 Certificate Details



Chapter 10

System Management

System Management

System management tab allows you to perform administrative tasks such as setting up the system,
enabling SMTP settings, notifications, migration, and even backup and restore.

All system operations will be disabled till the current or the ongoing system operation is complete.

Viewing System Management
To view the system management tab, which was earlier located under the Account Home page,
complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click System Management.

The System Management page is displayed.

3. In the system management page, the following tabs are displayed:
n Datacenter Redundancy
n Performance
n Version
n Network
n External Services
n Backup and Restore
n Migration

Viewing System Performance
To view the Aruba Central On-Premises system performance, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.

2. Under Global Settings, click System Management > Performance.

The Performance tab displays the following components:
n Central System—The Central System section displays the overall status of all the appliances,

Central Processing Units, memory units, and data storage units as Good or Poor. For more
information, see Viewing Central System Status.

n Appliance Resources—The Appliance Resources table displays details such as the
percentage of CPU and memory utilization, status of the appliances in the cluster, percentage
of disk space usage, and so on. For more information, see Viewing Appliance Resources.

n Service Monitoring—The Service Monitoring table displays details such as the status of
various deployments, the number of restarts undergone by the services, and the age of the
services, and so on. For more information, see Service Monitoring.
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n Logs—The Logs table displays the various log files that are related to the appliances and
services. The table also displays the time and date at which the log files were created. For
more information, see Viewing Appliance Resources.

n System Operations—The System Operations table displays details of various system
operations running across the cluster. For more information, see Viewing System Operations.

Viewing Central System Status
The Central System section displays the following details:

n Appliance Status—The Appliance Status indicates whether the overall status of the appliances in
the cluster is Goodor Poor.

n CPU Status—The CPU Status indicates whether the overall status of the processing units usage is
Good, Fair, or Poor.

n Memory Status—The Memory Status indicates whether the overall status of the memory units
usage is Good, Fair, or Poor.

n Disk Status—The Disk Status indicates whether the overall status of the disk usage is Good, Fair, or
Poor.

The Central System displays Poor in Appliance Status, CPU Status, Memory Status, and Disk Status even if
one of the appliances' status is Down or the status in CPU Status, Memory Status, and Disk Status is Poor,
respectively.

Viewing Appliance Resources
The Appliance Resources section displays a table with the following columns:

n Appliance—The Appliance column displays the FQDN of the appliance in the cluster.
n Status—The Status column displays the status of the appliance as Up or Down.
n CPU—The CPU column displays the percentage of CPU utilization of the appliance in the cluster.
n Memory—The Memory column displays the percentage of memory usage of the appliance in the

cluster.
n Storage—The Storage column displays the percentage of storage utilization of the appliance in the

cluster.
n Disk(Read)—The Disk(Read) column displays the percentage of disk utilization for the read

operation.
n Disk(Write)—The Disk(Write) column displays the percentage of disk utilization for the write

operation.
n Network Usage Up—The data transmitted from the appliance measured in bytes.
n Network Usage Down—The data received by the appliance measured in bytes.
n Uptime—The Uptime column displays the total duration for which the appliance was operational.

Clicking the at the top right corner of the table pops up the Add Appliance Resource page. Enter the
number of appliances to be added to the cluster along with corresponding FQDNs of the appliances and
click Add.
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The option is available for clusters that contain 3 or 5 appliances only. The option is unavailable in a setup
that contains a single or seven devices.

You can click the icon and select or de-select the columns required to be displayed in the table.

You can restart the appliance and generate logs by clicking the and icons, respectively.

To replace a device, click the icon corresponding to the device. The Replace Appliance Resource
page pops up. Enter the FDQN of the new appliance and click Replace.

Service Monitoring
The Appliance Resources section displays a table with the following columns:

n Deployment—The Deployment column displays the various deployment services running in the
cluster.

n Appliance—The Appliance column displays the FQDN of the appliance in which the service is
running.

n Namespace—The Namespace column displays the namespace of the services.
n Status—The Status column displays the status of the service as Up, Down, or Partially Up.
n Restarts—The Restarts column displays the number of restarts that the services have undergone.
n Age—The Age column displays the time duration for which the services were operational.

Click the icon at the top right corner of the Service Monitoring table to generate log files related to
all the listed services.

n You can restart the service, and generate logs related to a specific service in the Service Monitoring
table by clicking the and icons, respectively.

Viewing Log Files
The Logs section displays a table with the following columns:

n File—The File column displays the name of the log file that is generated.
n Type—The Type column displays whether the file is readable for a single pod log or non-readable

format snapshot for global level logs.
n Created—The Created column displays the time and date at which the log files were created.

You can click the icon and select or clear the columns required to be displayed in the table.

To download a specific log file, hover the mouse over the row in the Logs table and click the icon.

To delete a specific log file, hover the mouse over the row in the Logs table and click the icon.

Viewing System Operations
The System Operations section displays a table with the following columns:

n Operation Type—The Operation Type column displays the type of operation system running in the
cluster.

n Status—The Status column displays the current status of the system operations as Success, Failed,
In Progress, or Timeout.

n More Details—The More Details column displays additional details about the system operation
status.
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n Start Time—The Start Time column displays the time at which the system operation had begun.
n End Time—The End Time column displays the time at which the system operation had ended.

Aruba Central On-Premises Upgrade
Aruba Central On-Premises strongly recommends that you upgrade your On-premise version to the
next available major version for a smooth and hassle free operation of your account. Upgrade watcher
checks for any major versions release and notifies you for its availability on your next Aruba Central On-
Premises account login. The upgrade workflow differs based on the regular-online, occasional-online
user accounts, and offline users.

n The Upgrade operation can only be done by the user with admin rights.

n To upgrade to Aruba Central On-Premises 2.5.7, it is mandatory for the Aruba Central On-Premises setup
to be connected to the network through 10 Gig interfaces. For any assistance, contact Aruba TAC
(Technical Assistance Center) team.

n The time to perform a host upgrade from Aruba Central On-Premises 2.5.6 to Aruba Central On-Premises
2.5.7 for 7 node cluster is 1.5 to 2 hours.

n During Aruba Central On-Premises offline upgrade, it is recommended not to rename or modify any file
names for apps_upgrade_pkg-*.tar.gz, as renaming the file names might lead to upgrade failure.

Important Points

n 10 GbE interface: Users who have already switched from 1 GbE to 10 GbE can directly upgrade to the
Aruba Central On-Premises 2.5.7 version.

n 1 GbE interface: Users who are still on the 1GbE switch interface must first upgrade to Aruba Central
On-Premises 2.5.6.7 before switching to 10 GbE interface. This is mandatory.

This section includes the following topics:

n Online Upgrade through the Versions Page

n Offline Upgrade

n Handling Upgrade for Datacenter Redundancy

Online Upgrade through the Versions Page
Aruba Central On-Premises can be upgraded online to next version from Versions page on the user
interface.

Upgrade Watcher Workflow for Regular-Online User
This section describes the upgrade workflow and the requirements for the regular-online Aruba Central
On-Premises user accounts. Based on the version availability, upon logging onto your Aruba Central On-
Premises account, one of the following pages is displayed:

1. Upgrade Available—This window is displayed when you log in to your Aruba Central On-
Premises account within the deadline of the version upgrade (60 days from the date of version
release). The upgrade available window provides the following information:
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n Internet Connection is needed—Informs the connectivity requirement for the process.
n Current version—Current running version.
n New versions—Next major available version.
n Status—Provides the status and progress bar for file transfer, extract, and upgrade.
n Deadline—Displays the number of days remaining for upgrade. The number of days varies

depending on the version available date and the day of login. For example, if the version was
available on 10th of December and the user logs in on 12th of December, the remaining days
gets changed to 57 days within which the account needs to be upgraded.

n Upgrade Now—Allows you to initiate the upgrade process.
n Go to Versions—This tab is displayed if any one of the extraction stage is interrupted, in

progress or failed. Clicking on the Go to version navigates to System Management >
Version tab with version upgrade in process.

n Remind in x days—Allows you to snooze the notification for some days. Notification can be
snoozed for 7 days (60-20 remaining days), 5 days (20-10 remaining days), 3 days (10-5
remaining days), 2 days(5-3 remaining days), and 1 (for the rest remaining days). On snoozing
the notification, you can use the account normally and the next notification comes after the set
dates.

To upgrade the version once notified, click Upgrade Now to initiate the upgrade process. You can
also navigate to System Management > Version tab to initiate the upgrade. For more
information on how to navigate to version tab, see Version.

The following example image displays the Upgrade available window.

Figure 27 Upgrade Available

2. Upgrade Required—This window is displayed when you log in to your Aruba Central On-
Premises account after the deadline is missed. This window indicates that you have missed the
upgrade deadline and an immediate upgrade is required. All the account GUI functionality is
blocked till the Aruba Central On-Premises is upgraded to the latest version. To upgrade, click
Upgrade Now to initiate the upgrade. The upgrade required window provides the following
information:
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n Internet Connection is needed—Informs the connectivity requirement for the process.
n Current version—Current running version.
n New versions—Next major available version.
n Status—Provides the status and progress bar for file transfer, extract, and upgrade.
n Deadline—Displays the number of overdue days post deadline.
n Upgrade Now—Allows you to initiate the upgrade process.
n Retry—This tab is displayed only when any one of the upgrade stage fails. Click Retry to retry

the upgrade process. If the Upgrade fails after multiple retries, contact Aruba Central support
representative.

Once the upgrade is successful, the account comes to its normal functionality.

The following example image displays the Upgrade required window with retry option.

Figure 28 Upgrade Required

Upgrade Watcher Workflow for Occasional-Online User
This section describes the upgrade workflow and the requirements for the occasional-online Aruba
Central On-Premises user accounts. This scenario is based on the users that logs into Aruba Central On-
Premises after 39 days or a maximum of 45 days from the date of connectivity loss. All the account GUI
functionality is allowed and the user has to upgrade to the major available version within the prescribed
period. Based on the account login period, one of the following pages is displayed:

1. Upgrade Check Failed-—This window is displayed when the user logs into Aruba Central On-
Premises within the above mentioned periods. The upgrade check failed window provides the
following information:
n Internet Connection is needed—Informs the connectivity requirement for the process.
n Last Upgrade Check—Displays the date of last upgrade check.
n Deadline—Displays the remaining days for mandatory upgrade check.
n Check for Upgrade—Once connected, it check for the status and redirects you to the

Upgrade available/ Upgrade required page.
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n Remind in x days—Allows you to snooze the notification. Snoozing can be done for 5 days (on
39th day) and 1 day for the remaining.

The following example image displays the Upgrade check failed window.

Figure 29 Upgrade Check Failed

2. Upgrade Check Required—This window is displayed when the user logs into Aruba Central On-
Premises account after 45 days from the day of connectivity loss. In this scenario, the user
account is blocked and an immediate upgrade check is required. The upgrade check required
window displays the following information:
n Internet Connection is needed—Informs the connectivity requirement for the process.
n Last Upgrade Check—Displays the date of last upgrade check.
n Deadline—Displays the remaining days for mandatory upgrade check.
n Check for Upgrade—Once connected, it check for the status and redirects you to the Upgrade

available/ Upgrade required page.

The following example image displays the Upgrade check required window.
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Figure 30 Upgrade Check Required

Offline Upgrade
This section describes the upgrade workflow and the requirements for offline Aruba Central On-
Premises user accounts. This scenario is applicable for users who have enabled Airgap mode through
Command Line Interface (CLI) to enable offline upgrade. All the account GUI functionality is allowed and
the user has to upgrade to the major available version within the prescribed period and time range (49
days - 55 days).

Users get a notification on the Aruba Central On-Premises user interface or an email is sent notifying for
an upgrade.

For offline mode, upgrade notification is shown on the user interface only when users manually uploads the
update checker file or the upgrade package.

To update Aruba Central On-Premises on offline mode, complete the following steps:

Step 1: Enabling and Disabling Airgap via CLI

Step 2: Uploading the Watcher File

Step 3: Uploading Signature Files and Upgrade Packages

Step 4: Selecting the Uploaded Files

Step 5: Verification and Extraction of the Files

Step 6: Triggering Aruba Central On-Premises Upgrade

Step 7: Retry Upgrade

Step 1: Enabling and Disabling Airgap via CLI
Airgap can be enabled and disabled through CLI option 4 System Configuration commands. Under
option 4, you must use option 7, (4-7) for Airgap.

System Configuration Commands
Enter command option 4 from the main menu to view all the System Configuration commands.
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1. System

2. File Operations

3. Show

4. System Configuration

5. Advanced

6. Security

7. Support

8. Temporary Root Shell

9. Authentication

10. Certificate configuration

11. Search commands

====================================

0. exit

Enter option [ 0 - 11 ]: 4

The supported System Configuration commands are displayed. These commands are used to configure
system parameters like network setup, cluster setup, timezone setup. enable airgap mode, and also,
upgrade the setup or perform a complete factory reset.

1. Upgrade

2. Network Setup

3. Proxy Setup

4. Setup Timezone

5. Setup NTP

6. Node Setup

7. Airgap

8. Disaster Recovery

====================================

b. back

m. main menu

0. exit

Enter option [ 0 - 8 ]:

Airgap
Enter command option 7 from the System Configuration menu to enable or disable Airgap mode for
upgrade. Enabling Airgap allows you to upgrade the Aruba Central On-Premises setup offline without
any internet access.

1. Upgrade

2. Network Setup

3. Proxy Setup

4. Setup Timezone

5. Setup NTP

6. Node Setup

7. Airgap

8. Disaster Recovery

====================================

b. back

m. main menu

0. exit

Enter option [ 0 - 8 ]: 7
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1. Enable Airgap

2. Disable Airgap

3. Status

====================================

b. back

m. main menu

0. exit

Enter option [ 0 - 3 ]:

n Enable Airgap—Enter command option 1 from the Airgap menu to enable the same.

Enter option [ 0 - 3 ]: 1

Changing of Airgap mode requires restart of services and is recommended ONLY in

maintenance window.Do you want to continue?(Y/N):

n Disable Airgap—Enter command option 2 from the Airgap menu to disable the same.

Enter option [ 0 - 3 ]: 2

Airgap is already disabled.

Press [Enter] key to continue...

n Status—Enter command option 3 from the Airgap menu to see the status.

Enter option [ 0 - 3 ]: 3

Airgap is already disabled.

Press [Enter] key to continue...

Step 2: Uploading the Watcher File
Upgrading the Watcher file is mandatory for every Aruba Central On-Premises release. The Aruba
Central On-Premises watcher file is uploaded on the ASP site in every 30 days. The purpose of the
Watcher file is to check regarding availability of any new release. Users receive a notification/ prompt in
every 49 days in order to upload the Watcher file to verify if there is any new Aruba Central On-Premises
release available. The snooze period to upload the Watcher file is 6 days. If a user, doesn’t upload the
watcher file within the snooze period, the Aruba Central On-Premises user interface (UI) is completely
blocked and cannot be accessed.

For any minor Aruba Central On-Premises release there is no time restriction to do the upgrade.

Upgrade Status
Based on the account login period, one of the following pages is displayed:

1. Upgrade Available—This window is displayed when you log in to your Aruba Central On-
Premises account within the deadline of the version upgrade (55 days from the date of version
release). The upgrade available window provides the following information:
n Current version—Current running version.
n New versions—Next major available version.
n Status—Provides the status and progress bar for the file transfer, verification, extract, and

upgrade.
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n Deadline—Displays the number of days remaining for upgrade. The number of days varies
depending on the version available date and the day of login. For example, if the version was
available on 8th of December and the user logs in on 10th of December, the remaining days
gets changed to 53 days within which the account needs to be upgraded.

n Remind in x days—Allows you to snooze the notification for some days. Notification can be
snoozed for 7 days (55-20 remaining days), 5 days (20-10 remaining days), 3 days (10-5
remaining days), 2 days(5-3 remaining days), and 1 (for the rest remaining days). On snoozing
the notification, you can use the account normally and the next notification comes after the set
dates.

The following example image displays the Upgrade available window.

Figure 31 Upgrade Available

2. Upgrade Check Required—This window is displayed when you log in to your Aruba Central On-
Premises account after the deadline is missed. This window indicates that you have missed the
upgrade check deadline and an immediate upgrade check is required. All the account GUI
functionality is blocked till the upgrade availability is checked with the latest version of the update
checker file. To check, follow the steps mentioned on the screen, and upload the update checker
file. The upgrade check required window provides the following information:
n Current Version—Current running version.
n New Version—Next major available version.
n Last Upgrade Check—Displays the date of last upgrade check.
n Deadline—Displays the remaining days for mandatory upgrade check.
n Upgrade Check Steps—Displays the steps to update the check file.

To check the available version once notified, you can either drag and drop the update checker file
from your local browser, or you can click the upload update checker file. Once the upgrade
check is successful, you can use the account normally and the next notification comes after the
set dates.

Once the upgrade check is successful, the account comes to its normal functionality.
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The following example image displays the Upgrade check required window.

Figure 32 Upgrade Check Required

3. Upgrade Check Failed—This window is displayed when the user logs into Aruba Central On-
Premises within the above mentioned periods. The upgrade check can fail because of the
following reasons:
n User uploaded an old version of upgrade file as compared to the latest available file

Figure 33 Upgrade Version Check Required

n User uploaded a lower version of upgrade check file as compared to the running version
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Figure 34 Upgrade Version Mismatch

Step 3: Uploading Signature Files and Upgrade Packages
After every Aruba Central On-Premises release, upgrade packages are uploaded to ASP site. You should
download it to your local file server and from there you can upload it to the COP server using CLI option.

System Configuration Commands
The System Configuration commands are used to configure system parameters like network setup,
cluster setup, timezone setup and also, upgrade the setup or perform a complete factory reset.

Enter command option 4 from the main menu to view all the system configuration commands
supported.

Enter option [ 0 - 11 ]: 4

1. Upgrade

2. Network Setup

3. Proxy Setup

4. Setup Timezone

5. Setup NTP

6. Node Setup

7. Airgap

8. Disaster Recovery

====================================

b. back

m. main menu

0. exit

Enter option [ 0 - 8 ]:

Upgrade
Enter command option 4-1 from the System Configuration commands menu to upgrade the system for
either an online user or an offline user.
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Enter option [ 0 - 8 ]: 1

1. Upload Package

2. Upgrade Status

3. Proceed With Upgrade

====================================

b. back

m. main menu

0. exit

Enter option [ 0 - 3 ]:

n Upload Package
Enter command option 4-1-1 from the Upgrade commands menu to upload and select the upgrade
packages for offline update. The upgrade package includes the signature file and the upgrade file.

Enter option [ 0 - 3 ]: 1

1. Select Signature and Installation File

2. Upload Signature and Installation via SCP

3. Upload Signature and Installation via SFTP

=====================================

b. back

m. main menu

0. exit

Enter option [0 - 3]:

n Upload Signature and Installation via SCP
Enter command option 4-1-1-2 from the Upload Package commands menu to upload the signature
file and installation file through Secure Copy Protocol (SCP).

Enter option [ 0 - 3 ]: 2

This will scp a sign file from the remote server to COP server

Enter remote hostname and path (username@hostname:<filepath>):

admin@10.xx.xx.xx:/build/2.5.7/356-24567891/apps_upgrade_pkg_

-2.5.7-356-dev_from_10.0.0.GA.sign

Copying admin@10.xx.xx.xx:/build/2.5.7/356-24567891/apps_upgrade_pkg_

-2.5.7-356-dev_from_10.0.0.GA.sign to COP server

admin@10.xx.xx.xx's password:

apps_upgrade_pkg_-2.5.7-356-dev_from_10.0.0.GA.sign

Press [Enter] key to continue...

n Upload Signature and Installation via SFTP
Enter command option 4-1-1-3 from the Upload Package commands menu to upload the signature
file and installation file through Secure File Transfer Protocol (SFTP).

Enter option [ 0 - 3 ]: 3

This will scp a sign file from the remote server to COP server

Enter remote hostname and path (username@hostname:<filepath>):

admin@10.xx.xx.xx:/build/2.5.7/356-24567891/apps_upgrade_pkg_

-2.5.7-356-dev_from_10.0.0.GA.sign

Copying admin@10.xx.xx.xx:/build/2.5.7/356-24567891/apps_upgrade_pkg_

-2.5.7-356-dev_from_10.0.0.GA.sign to COP server

administrator@10.xx.xx.xx's password:

apps_upgrade_pkg_-2.5.7-356-dev_from_10.0.0.GA.sign
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Press [Enter] key to continue...

Step 4: Selecting the Uploaded Files
After uploading the upgrade packages to Aruba Central On-Premises server, you must select the
signature and installation files to initiate the offline upgrade.

Select Signature and Installation File
Enter command option 4-1-1-1 from the Upload Package commands menu to select the files.

Enter option [ 0 - 3 ]: 1

1. apps_upgrade_pkg-2.5.7-369-dev_from_10.0.0-GA02.sign

Choose a signature file [1 - 1]: 1

Selected file is :: apps_upgrade_pkg-2.5.7-369-dev_from_10.0.0-GA02.sign

1. apps_upgrade_pkg-2.5.7-369-dev_from_10.0.0-GA02.tar.gz

Choose an installation file [1 - 1]:

1 Selected file is :: apps_upgrade_pkg-2.5.7-369-dev_from_10.0.0-GA02.tar.gz

============Verification in progress===========

Press [Enter] key to continue...

Step 5: Verification and Extraction of the Files
After selecting the uploaded files, validation of the files begin and after the validation is successful, file
extraction is started. After the extraction is complete, you can manually trigger the upgrade through
either CLI or UI.

Upgrade Status
After selecting the file, to confirm regarding the extraction process you can monitor the status in the UI
as well in the CLI. For more information on selecting files, see Step 4: Selecting the Uploaded Files.

To monitor the status through CLI, enter command option 4-1-2 from the Upgrade commands menu.

Enter option [ 0 - 3 ]: 2

COP Server Status

--------------------------------------------------------------------------------

Current Version : 2.5.7.0

Latest Version : 2.5.7.0

Online Customer : false

Upgrade Status : EXTRACT_IN_PROGRESS

Upgrade Available : true

Sign File Transfer Completion Percentage : 100

Upg Pkg File Transfer Completion Percentage : 100

Pkg Sign Validate Completion Percentage : 100

Extract Completion Percentage : 100

Upgrade Stage Completion Percentage : 0

--------------------------------------------------------------------------------

-

Last Sign File Transfer Status : SUCCESS

Last Sign File Transfer Message :
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Last Sign File Transfer Time : 2023-07-26 06:10:50

Last Upg Pkg File Transfer Status : SUCCESS

Last Upg Pkg File Transfer Message :

Last Upg pkg File Transfer Time : 2023-07-26 06:10:54

Last Pkg Sign Validate Status : SUCCESS

Last Pkg Sign Validate Message :

Last Pkg Sign Validate Time : 2023-07-26 06:21:05

Last Extract Status : SUCCESS

Last Extract Message :

Last Extract Time : 2023-07-26 11:14:34

Last Upgrade Status : SUCCESS

Last Upgrade Message :

Last Upgrade Time : 2023-07-21 09:58:55

--------------------------------------------------------------------------------

Press [Enter] key to continue

To monitor the status through GUI, navigate to System Management > Versions page.

Figure 35 Upgrade Status through Versions tab

Step 6: Triggering Aruba Central On-Premises Upgrade
Once extraction is completed, upgrade status will change to UPGRADE_NOT_STARTED. You can trigger
the update through CLI or GUI.

For CLI, enter option 4-1-3 Proceed With Upgrade :

Enter option [ 0 - 3 ]: 3

Please confirm to start the upgrade to 2.5.7.0 version (Y/N):

To proceed upgrade through GUI, click the Upgrade Now button displayed on the System
Management > Versions page after verification and extraction of the files.
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Figure 36 Upgrade Status

Step 7: Retry Upgrade
In case the upgrade fails, you can perform a retry through the CLI or GUI.

n To retry upgrade through CLI you have to use the same option 4-1-3 Proceed with Upgrade again.

n To retry upgrade through GUI, click the Retry button on the System Management > Versions page.
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Figure 37 Retry Upgrade

Handling Upgrade for Datacenter Redundancy
Disaster Recovery is essential to resume business operations followed by any unexpected failure that
might damage or destroy data in a network. In case of Aruba Central On-Premises upgrade from one
version to another it is beneficial to have a secondary cluster for safe management of software and
hardware systems. For more information on Aruba Central On-Premises disaster recovery, see
Datacenter Redundancy.

Aruba Central On-Premises can be upgraded in two ways:

n Online Upgrade through the Versions Page
n Offline Upgrade

In order to upgrade Aruba Central On-Premises from one version to another, you should first upgrade
the primary cluster. Aruba Central On-Premises secondary cluster can only be upgraded once the
primary cluster is updated. The upgrade version of the secondary cluster must be the same as primary
cluster. Secondary cluster acts in maintenance mode, and is beneficial in case of any disaster scenario in
the network whereas, primary cluster is the functional one.

Upgrading Primary Cluster through UI
Primary cluster can be upgraded through user interface or command line interface (CLI) option. To
upgrade Aruba Central On-Premises primary cluster from the user interface navigate to Maintain >
System Management > Version. For more information on online upgrade, see Online Upgrade
through the Versions Page.
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Upgrading Primary and Secondary Clusters through CLI
Primary and secondary clusters can be upgraded for disaster recovery through CLI option 4 System
Configuration commands. Under option 4, you must use option 8, (4-8) for Disaster Recovery.

To perform any upgrade for secondary cluster, you must use the CLI option. You cannot update secondary
cluster through the user interface.

System Configuration Commands

The System Configuration commands are used to configure system parameters like network setup,
cluster setup, timezone setup and also, upgrade the setup or perform a complete factory reset.

Enter command option 4 from the main menu to view all the system configuration commands
supported.

1. System

2. File Operations

3. Show

4. System Configuration

5. Advanced switch

6. Security

7. Support

8. Temporary Root Shell

9. Authentication

10. Certificate configuration

11. Search commands

====================================

0. exit

Enter option [ 0 - 11 ]:

Disaster Recovery

Enter command option 8 from the System Configuration menu to handle upgrade for disaster recovery
in Aruba Central On-Premises network.

Enter option [ 0 - 8 ]: 8

1. Show Disaster Recovery Status

2. Configure Disaster Recovery

3. Automatic Failover

4. Initiate Switchover

5. Remove Disaster Recovery Configuration

====================================

b. back

m. main menu

0. exit

Enter option [ 0 - 5 ]:

n Show Disaster Recovery Status—Enter command option 1 from the Disaster Recovery commands
to display the disaster recovery status of the primary cluster.
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Enter option [ 0 - 5 ]: 1

----------------------------------

Disaster Recovery configuration

----------------------------------

Peer Cluster FQDN : central-cop-1node-dr-

vip.test.pdt1.arubathena.com

Initial Role : Secondary

Time to Failover (Minutes) : 15

Automatic Failover : True

Restore Frequency(Days) : 3

--------------------

State Data

--------------------

Cluster Role : Secondary

Primary Since : 0

--------------------

Health Info

--------------------

Disaster Recovery Health Status : Good

Failover In-Progress : False

Heartbeat Status : Successful

Failover Status : Successful

HB Failure Count : 0

Last heartbeat from Peer : Jun 19, 2023, 10:31

Last Failover Time : Jun 12, 2023, 05:58

Restore Status : Successful

Last Restore Time : Jun 17, 2023, 11:06

--------------------

Peer Health Info

--------------------

Peer Disaster Recovery Health Status : Error (Pairing Key mismatch)

Peer Heartbeat Status : Pairing Key mismatch

Peer Failover Status : Successful

Press [Enter] key to continue...

n Configure Disaster Recovery—Enter command option 2 from the Disaster Recovery commands to
configure the secondary cluster in the network.

n The version of the secondary cluster must be same as the primary cluster.
n Secondary cluster can download the running Aruba Central On-Premises build, but cannot be

upgraded until primary cluster is upgraded.

1.Show Config

2.Show Disasater Recovery Pairing Key

3.Configure

4.Enable Redundancy

5.Diasble Redundancy

=====================================

b. back

m. main menu

0. exit

Enter option [0 - 5]:



Aruba Central On-Premises 2.5.7 | User Guide 253

o Show Config—Enter option 1 from the Configure Disaster Recovery commands to display the
configuration specification of the secondary cluster.

Enter option [0 - 5]: 1

-----------------------------------------

Disaster Recovery configuration

-----------------------------------------

Peer Cluster FQDN : central-cop-lnode-dr-vip-

test.pdtl.arubaathena.com

Initial Role : Secondary

Time to Failover (Minutes) : 15

Automatic Failover : True

Restore Frequency (Days) : 3

Press [Enter] key to continue...

o Show Disaster Recovery Pairing Key—Enter option 2 from the Configure Disaster Recovery
commands to display the disaster recovery pairing key.

Enter option [0 - 5]: 2

eyJbHvyX2FtnjuiTh2YfhvdezxiKloiNhytfVbnhgt34Jirfcvdsa

aHR0HNc1JoiungfcVyhgfr56FTkijolpuU89nhupjjFrtgvczswRT

alpXmxWRThkIn0=

Press [Enter] key to continue...

o Configure—Enter option 3 from the Configure Disaster Recovery commands to configure the
secondary cluster for disaster recovery.

Enter option [0 - 5]: 3

Disaster Recovery is already configured. Do you want to continue(Y/N)?

o Enable Redundancy—Enter option 4 from the Configure Disaster Recovery commands to enable
data center redundancy. You can also enable data center redundancy from the Aruba Central On-
Premises user interface. For more information, see Datacenter Redundancy.

Enter option [0 - 5]: 4

Disaster Recovery is already enabled.

Press [Enter] key to continue...

o Disable Redundancy—Enter option 5 from the Configure Disaster Recovery commands to enable
data center redundancy. You can also enable data center redundancy from the Aruba Central On-
Premises user interface. For more information, see Datacenter Redundancy.
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Enter option [0 - 5]: 5

Changing of Disaster Recovery mode requires restart of services and is

recommended ONLY in maintenance window. Do you want to continue (Y/N)?

n Automatic Failover—Enter command option 3 from the Disaster Recovery commands to enable or
disable automatic failover for disaster recovery.

1.Disable

2.Enable

=====================================

b. back

m. main menu

0. exit

Enter option [0 - 2]:

o Disable—Enter option 1 from the Automatic Failover commands to disable automatic failover.

Enter option [0 - 2]: 1

Warning: Automatic Failover will be disabled. Do you want to continue (Y/N)?

o Enable—Enter option 1 from the Automatic Failover commands to enable automatic failover.

Enter option [0 - 2]: 2

Automatic Failover is already enabled.

Press [Enter] key to continue...

n Initiate Switchover—Enter command option 4 from the Disaster Recovery commands to initiate
Aruba Central On-Premises cluster switchover.

Enter option [0 - 5]: 4

Current role is Secondary.

Warning: Failover will be initiated. Devices may disconnect and come up on the

new primary. Do you want to continue (Y/N)?

n Remove Disaster Recovery Configuration—Enter command option 5 from the Disaster Recovery
commands to disaster recovery configuration from the Aruba Central On-Premises network.

Enter option [0 - 5]: 5

Disable Redundancy feature and Remove Disaster Recovery Configuration.

For more information, see Command Line Interface
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n Any data synchronization operation like backup and restore is not triggered if upgrade is going on.

n Secondary cluster can download the running Aruba Central On-Premises build, but cannot be upgraded
until primary cluster is upgraded.

Version
The Version tab displays the installed version, available version for upgrade, upgrade status, and you
can also generate logs related to events that occurred during an upgrade.

Viewing Installed and Available Version Information
To view the Aruba Central On-Premises versions, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click System Management.
3. Click the Version tab.

The Version pane displays the following information:

n The Installed Version displays the currently installed version in the Aruba Central On-Premises
server.

n The Available Version displays the version that is currently available and the user can upgrade to
this version.

Upgrading Aruba Central On-Premises

n Take a backup before the upgrade. If a hardware failure is encountered for any reason, only then the
restore operation must be performed. Only after resolving the hardware issue, restore the backup.

n Validate the cluster health before upgrading to the next version. For more information, see Verifying
Configuration Before Upgrade.

To upgrade Aruba Central On-Premises to the latest version, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click System Management.
3. Click the Version tab.
4. In the Upgrade pane, click Upgrade Now to upgrade to the latest version of Aruba Central On-

Premises.

The Upgrade pane displays the following information:

n Status— Displays the overall status of the upgrade.
n File Transfer—Displays the status of the file transfer.
n Extract—Displays the status of the file extraction.
n Upgrade—Displays the status of the upgrade.
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Generating Logs
Aruba Central On-Premises allows you to view and download logs related to the events that occurred
during the upgrade process. To generate the logs for the events, click Generate Logs in the Logs pane.
Once generated, the logs can be viewed in the Logs table.

The Logs table displays the following information and also allows you to download or delete logs:

n File—Displays the generated file name.
n Created—Displays the date and time of the log creation.
n Status—Displays the status of the generated logs.
n Action—Allows you to perform the following operations:

o

Download—Select the file and click the download icon to download the generated file.
o Delete—Select the file and click the delete icon to delete the file. In the Confirm Action pop-

up window, click Yes.

Verifying Configuration Before Upgrade
Aruba recommends to perform the pre-upgrade health check for validating the Aruba Central On-
Premises cluster configuration. This operation is required to avoid issues that may be encountered and
halt the upgrade. You must first ensure that the cluster complies with the requirements and verify the
stability before an upgrade.

If any check fails, rectify it and then proceed to upgrade. Otherwise, upgrade will fail. Contact Aruba
Support for any assistance or check details in the deployment-tools-pre-upgrade-health-check pod and
Audit Trial logs.

The following checks must be performed:

n Ensure that all mandatory CNAMEs are resolvable. If CNAMEs are not resolved, the CNAME_
UNRESOLVABLE error is encountered. Aruba Central On-Premises WebUI will list the CNAMEs that are
not resolvable.

n Ensure that the health status of infra services is in Good state on all nodes of the cluster. Otherwise,
the upgrade fails with the Pre Upgrade Health Check Failed error. For details regarding this error, see
the IVT logs. Download the logs by clicking Generate Logs under System Management > Version >
Logs.

n Ensure all nodes in the cluster run 512 GB RAM. Otherwise, the upgrade fails with the Pre Upgrade
Health Check Failed error. For details regarding this error, check logs in the Audit Trail page.

n Ensure all nodes in the cluster have 10 GbE interface bandwidth. Otherwise, the upgrade fails with
the Pre Upgrade Health Check Failed error. For details regarding this error, check logs in the Audit
Trail page.

n Ensure all nodes in the cluster have DNS server configuration that resolves both internal and
external URLs (core update and Quay). Otherwise, the upgrade fails with the Pre Upgrade Health
Check Failed error. For details regarding this error, check logs in the Audit Trail page.

n Ensure all nodes in the cluster have 3.4 TB disk space. Otherwise, the upgrade fails with the Pre
Upgrade Health Check Failed error. For details regarding this error, check logs in the Audit Trail page.

n Ensure that if any recent replace node operation is done, is successful. Otherwise, the upgrade fails
with the Pre Upgrade Health Check Failed error. For details regarding this error, check logs in the Audit
Trail page.
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Network
The Network tab displays the summary of the network settings configured for a cluster and allows you
to test the proxy server and configure the support connection.

Viewing Network Settings Information
To view the Aruba Central On-Premises network, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click System Management > Network tab.

The Network pane displays the following information:
n FQDN
n VIP
n Subnet Mask
n Gateway
n Primary DNS
n Secondary DNS
n Primary NTP IP or FQDN
n Secondary NTP IP or FQDN
n Tertiary NTP IP or FQDN
n NTP time Zone

The information displayed in the Network pane is read-only and based on the data that you configure while
setting up the network. For more information, see Aruba Central On-Premises Installation and Setup Guide.

Viewing Proxy settings
To view the Aruba Central On-Premises network, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click System Management > Network tab.
3. Click Network tab. In the Proxy pane, enter the following information:

n Port— Enter the proxy server port.
n Proxy Server— Enter the proxy server host name or IP address.
n Username— Enter the username.
n Password— Enter the password.
n Confirm Password— Re-enter the password to confirm.

4. Click Save or Test Proxy to validate the proxy settings.

n To validate the Proxy server, ensure that you provide a valid server details. You can also setup the Proxy
Server in the Proxy Server Setup Option while configuring the cluster. For more information, see Aruba
Central On-Premises Installation and Setup Guide.

n You can configure secondary and tertiary NTP servers in the Aruba Central On-Premises CLI.
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To validate the Proxy server, ensure that you provide a valid server details. You can also setup the Proxy Server
in the Proxy Server Setup Option while configuring the cluster. For more information, see Aruba Central On-
Premises Installation and Setup Guide.

Viewing Support Connection
To view the Aruba Central On-Premises network, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click System Management > Network tab.
3. The Support Connection pane with Status is displayed.

You can start the connection from the UI by clicking the Start button in the Support Connection pane.
After a connection is established between the tunnels, you can stop by clicking the Stop button in the
same pane. On successful operation, the status shown as active.

You can also start, stop, restart, upload support connection file, or check the status of the Support
Connection using the CLI command. For more information, see Support Command section in Aruba
Central On-Premises User Guide.

External Services
This tab helps you configure the SMTP server settings, syslog servers, and SNMP traps destination.

To view the External Services, complete the following steps:

1. In the the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click System Management.

3. Click the External Services tab.

The tab displays the following components:
n SMTP—The SMTP section displays a table of SMTP servers, the ports used by the servers, and

the serverstatus. You can configure only one SMTP server in COP. For more information, see
SMTP.

n SNMP Traps Destination—The SNMP Traps Destination table displays details such as the
trap destination IP addresses of the SNMP server where the trap is sent, and the SNMP server
versions. For more information, see SNMP Traps Destination.

n SysLog—The SysLog table displays a list of syslog servers with the corresponding IP addresses
and the associated ports. For more information, see SysLog Server Details.

SMTP
To ensure correct delivery of emails to the user accounts configured in your setup, you must configure
the server settings in Aruba Central On-Premises. Starting from Aruba Central On-Premises 2.5.3.0,
unencrypted email server communication is supported. A new option, No encryption is supported for
SMTP. When you configure SMTP, you can choose TLS, SSL, or No encryption.

The SMTP table displays the following details:

n Server—The Server column displays the SNMP server names.
n Port—The Port column displays the configured SNMP port for the server. The default Aruba SNMP

Port is 587.
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n Status—The Status indicates the status of the SNMP server. The status is indicated as Failure or
Success.

To edit the SMTP server, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click System Management.

The System Management page is displayed.

3. Click the External Services tab.
4. In the SMTP pane, hover over the SMTP server name and click the edit icon.

The Edit SMTP Server section is displayed.

5. Configure the following parameters:
n Host name or IP address—Host name or Address of the SMTP server.
n Port—Port number of the SMTP server.
n From address—From address for the email.
n User Name—Email address of the user.
n Password—Password.
n Confirm Password—Retype the password to confirm.
n Encryption—Enable TLS for secure communication.
n Test email—Add recipients email addresses and click Test.

6. Click Save.

SNMP Traps Destination
An SNMP trap is a notification that is sent to an SNMP server when certain events occur, such as faults
or security events. The trap destination IP address is the IP address of the SNMP server where the trap
will be sent.

The SNMP Traps Destination section displays a table with the following columns:

n Server—The Server column displays the SNMP trap server name or IP of the traps server.
n Version—The Version column displays the version of the SNMP. The version supported are v2 and

v3.

Click the + icon to display the Add SNMP Trap page:

n To add a new SNMPV2 trap destination, enter the SNMP server name, hostname, port details,
community string, and then click Save.

n To add a new SNMPV3 trap destination, enter the SNMP server name, hostname, port details, SNMP
username, authentication protocol(SHA/MD5), authentication password, privacy protocol (AES/DES),
privacy password, and then click Save.

Click the icon to download MIB files. You can download and use the MIB files in your SNMP manager
to monitor memory status, hardware status, etc. within the device.

SysLog Server Details
To enable Aruba Central On-Premises to send system events to a logging server, ensure that you
configure the syslog server details on Aruba Central On-Premises.
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In addition to UDP, Aruba Central On-Premises also supports TCP and Secure TCP connection types to
the syslog server.

When you select Secure TCP as the type of connection to the syslog server, ensure to upload a CA
certificate for the syslog server in the Organization > Network Structure > Certificates page. For
more information, see Managing Certificates.

To configure the syslog server, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click System Management.

The System Management page is displayed.

3. Click the External Services tab.
4. In the Syslog table, click +.

The Add Syslog Server window is displayed.

5. In the Add Syslog Server window, configure the following parameters:
n Syslog server—Name of the Syslog server.
n Hostname or IP Address—Hostname or IP address of the Syslog server.
n Port—Port of the Syslog server.
n Connection Type—Select a connection type to the Syslog server. Select any one of the

following connection types:
o Secure TCP
o TCP
o UDP

n Syslog Type—Select the message types to be sent to Syslog Server. You can select one or both
of the following options:
o Audit Trail
o System Log

By default, alerts are always sent as syslog messages to the syslog server and it does not
depend if the Syslog Type is selected or not.

6. Click Save to submit the details of the Syslog server.

The Syslog table displays the following details:

n Server—Name of the Syslog server.
n Hostname or IP Address—Hostname or IP address of the Syslog server.
n Port—Port of the Syslog server.
n Connection Type—Connection type to the Syslog server.
n Syslog Type—Syslog message types to be received on the Syslog Server.

In addition to alerts and audit trail messages, Aruba Central On-Premises also sends System logs as
syslog messages to the syslog server.

Aruba Central On-Premises sends the syslog messages to the syslog server in the Common Event
Format (CEF) format. The CEF format is a log management standard that uses a standardized logging
format so that data can easily be collected and aggregated for analysis by an enterprise management
system.
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You can configure a maximum number of seven syslog servers in Aruba Central On-Premises.

Backing up and Restoring System Data
Aruba Central On-Premises supports backing up of system information, group configuration data, alerts,
events, audit trail, sites, labels, and historical reports. You can backup Aruba Central On-Premises data
either manually or set a schedule for an automatic backing up of the data.

Important Points to Note
n Use Linux-based external backup server such as Ubuntu, CentOS, or RHEL.
n Use the SCP protocol because it is faster than SFTP at transferring files, especially on the high latency

networks.
n Before taking a data backup, you must have a file server configured and ready to save the files. Aruba

Central On-Premises supports the following Ciphers, MAC, and kexAlgorithms for SCP or SFTP
transfers:
o Ciphers—aes128-cbc, aes256-cbc, aes128-ctr, aes256-ctr
o MAC—hmac-sha2-256, hmac-sha2-512
o KexAlgorithm—ecdh-sha2-nistp256, ecdh-sha2-nistp384, ecdh-sha2-nistp521

n Backup consumes large amounts of space (up to 5 terabyte). Ensure you have sufficient space for a
successful backup operation.

n The restore operation deletes any configuration applied before the restore. It also deletes and
replaces device variables with the backup that is being restored.

n For restore operation, make sure you provide the file path that you used for backup and select the
appropriate backup file version.

n During backup and restore operation, the consider the IO system alert as normal because of the
intense read and write operation carried out on the file system.

The following topics explain the different type of backup and restore operations:

n Backing up Data Manually

n Creating a Backup Schedule

n Scheduling Incremental Backup

n Restoring Data

n Resetting the Host Key for Backup or Restore Operation

n Generating Logs

Backing up Data Manually
To manually backup data, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click System Management.
3. Select the Backup and Restore sub tab.
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4. In the Backup pane, click the Backup Now menu option.

The Immediate Backup window opens.

5. In the Immediate Backup window, configure the following parameters:
a. Host name or IP address— Specify the host name or IP address of the server.
b. Protocol Type— Specify SFTP or SCP. By default, SFTP is selected.
c. File Path— Specify the file path or folder name in the server to which you want to save the

data.

d. From the Select Authentication Method drop-down, select any one of the following
authentication method:

n Username and Password—If you select this option, specify the server SFTP or SCP
username and password

n SSH—If you select this option, enter the username of the backup server.

When you select SSH, use the Copy SSH public key to the clipboard option to copy the
authorized key. This key must be added in the backup server where you want to back up the data
else the back up operation will fail.

6. Use the Copy host key to the clipboard option to copy the host key.
7. Click Backup Now to start backing up the data to the server.

In case of successful backup, the Status in the backup pane shows Completed. You can also view
the status of the supported data types by clicking the Backed up Systems arrow. The status sign
against each data type turns green representing a successful backup and red representing a
failed backup.

If the backup fails due to a host key miss match, a pop-up message appears stating that the backup
operation has failed. The Status in the backup pane is displayed as Failed. The Reset host key for <ip
address> option appears in the Backup pane.

8. The following data types are supported:
a. PostgreSQL
b. Cassandra
c. Elasticsearch
d. Elasticsearch Aggregation
e. Minio
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Figure 38 Backup Now

Creating a Backup Schedule
A full backup is a basic and comprehensive backup method, where all data is sent to another location at
one go.

To set a schedule for regular full backup of Aruba Central data, complete the following steps:

1. In the Aruba Central On-Premisesapp, set the filter to Global.
2. Under Maintain, click System Management.
3. Click Backup and Restore tab.

The Backup and Restore page is displayed.

4. In the Backup pane, click the Backup Later menu option.

The Scheduled Backup window opens.

5. In the Scheduled Backup window, configure the following parameters:

a. Select an option from the Backup Mode drop-down list. The available options are:

n Disable—Use this option only when you do not want to start the scheduled backup.

n Full Backup—Use this option when you want to schedule a full backup.

n Incremental Backup—Use this option only for large databases backup. Incremental
backup is taken on a daily basis. For more information, see Scheduling Incremental
Backup.

b. Select an option from the Full Backup Occurs Every drop-down list.

The available options are:

n Daily—Select this option to set an everyday frequency for the full backup.

n Weekly—Select this option to set twice a week frequency for the full backup.
c. Select an option from the Backup Day drop-down list.

The full backup is processed only on the selected day. The available options are:
n Sunday
n Monday
n Tuesday
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n Wednesday
n Thursday
n Friday
n Saturday

d. Set the time under Starting at, use the top arrow and down arrow to choose the required
time.

e. Host name or IP address— Specify the host name or IP address of the server.
f. Protocol Type— Specify SFTP or SCP. By default, SFTP is selected.
g. File Path— Specify the file path or folder name in the server to which you want to save the

backup data.
h. From the Select Authentication Method drop-down, select any one of the following

authentication method:
n Username and Password—If you select this option, specify the server SFTP or SCP

username and password.

n SSH—If you select this option, enter the SSH key and administrator username of the
backup server.

i. SSH Key—When you select SSH, use the Copy SSH public key to the clipboard option to
copy the authorized key. This key must be added in the backup server where you want to
back up the data else the back up operation will fail.

j. Username—Specify the administrator user name.

k. Password—Specify the administrator role password.

l. Host Key—Use the Copy host key to the clipboard option to copy the host key.

6. Click Save.

If the backup fails due to a host key miss match, a pop-up message appears stating that the backup
operation has failed. The Status in the backup pane is displayed as Failed. The Reset host key for <ip
address> option appears in the Backup pane.



Aruba Central On-Premises 2.5.7 | User Guide 265

Figure 39 Backup Later

Scheduling Incremental Backup
An incremental backup is a method chosen when the amount of data is voluminous to do a full backup
every day. This is a method for taking daily incremental backups between scheduled full backups, where
data backup is taken in chunks and saved to the destination. The incremental backup method saves
more than 50% of the time comparatively to a full backup.

Scheduled incremental backup is an optimized method of backing up data for large databases. The
backup configuration determines how long is the back up cycle and when the full back up is taken.
Based on the defined backup configuration, on the first day of the cycle a full backup is taken and
consecutive daily incremental backups are taken until the next full backup day.

For example, consider an incremental backup is scheduled for a monthly cycle of 28 days. Then, a full
backup is taken on day one. Next, incremental backup is taken from day 2 to day 28. Lastly, a full backup
is taken on day 29.

The following frequency cycles are provided for the incremental backup schedule:

n Weekly frequency—The full backup occurs once a week on the selected day and the incremental
backup is taken consecutively after successful full backup.
o Day one—Full backup is taken.
o Day two to seven—Incremental backup is taken.
o Day eight—Full backup is taken.

n Biweekly frequency—The full backup occurs once every two weeks on the selected day and the
incremental backup is taken consecutively after successful full backup.
o Day one—Full backup is taken.
o Day 2 to day 14—Incremental backup is taken.
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o Day 15—Full backup is taken.
o Day 16 to day 28—Incremental backup is taken.
o Day 29—Full backup is taken.

n Monthly frequency—The full backup occurs once a month on the selected day and the incremental
backup is taken consecutively after successful full backup.
o Day 1—Full backup is taken.
o Day 2 to day 28th day—Incremental backup is taken.
o Day 29—Full backup is taken.

Scheduling Incremental Backup
To schedule incremental backup for a large database, complete the following steps:

1. In the Aruba Central On-Premisesapp, set the filter to Global.
2. Under Maintain, click System Management.
3. Click Backup and Restore tab.

The Backup and Restore page is displayed.

4. In the Backup pane, click the Backup Later menu option.

The Scheduled Backup window opens.

5. In the Scheduled Backup window, configure the following parameters:

a. Select Incremental Backup from the Backup Mode drop-down list.

Incremental Backup is used only for large databases. Incremental backup is taken on a daily
basis after a full backup on the first day of the schedule.

b. Select an option from the Full Backup Occurs Every drop-down list.

The available options are:

n Weekly—Select this option to set once a week frequency for the full backup.

n Biweekly—Select this option to set twice a week frequency for the full backup.

n Monthly—Select this option to set once a month frequency for the full backup.
c. Select an option from the Backup Day drop-down list.

The full backup is processed only on the selected day. The available options are:
n Sunday
n Monday
n Tuesday
n Wednesday
n Thursday
n Friday
n Saturday

d. Set the time under Starting at, use the top arrow and down arrow to choose the required
time.

e. Host name or IP address— Specify the host name or IP address of the server.
f. Protocol Type— Specify SFTP or SCP. By default, SFTP is selected.
g. File Path— Specify the file path or folder name in the server to which you want to save the

backup data.
h. From the Select Authentication Method drop-down, select any one of the following

authentication method:
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n Username and Password—If you select this option, specify the server SFTP or SCP
username and password.

n SSH—If you select this option, enter the SSH key and administrator username of the
backup server.

i. SSH Key—When you select SSH, use the Copy SSH public key to the clipboard option to
copy the authorized key. This key must be added in the backup server where you want to
back up the data else the back up operation will fail.

j. Username—Specify the administrator user name.

k. Password—Specify the administrator role password.

l. Host Key—Use the Copy host key to the clipboard option to copy the host key. If the
backup fails due to a host key miss match, a pop-up message appears stating that the backup
operation has failed. The Status in the backup pane is displayed as Failed. The Reset host
key for <ip address> option appears in the Backup pane.

6. Click Save.

Scenarios for Incremental Backup Schedule

n Upgrade, add node, and restore operations—The incremental backup schedule is reset for upgrade,
add node, and restore operations. The system restarts the incremental backup cycle in these
scenarios. Since full backup must be done on day one as defined in the configuration. Incremental
backup does not happen until the define day of full backup.

n Replace node—The incremental backup schedule is not reset for replace node operation.

Error Handling Mechanism
The backup cycle configuration operates as scheduled when the backup is successful. If a scheduled
backup is not successful for any reason, then it is re-tried the consecutive day.

n Incremental Backup Fails—If an incremental backup fails in between a cycle, it is re-tried the next
consecutive day. If the incremental backup fails the day prior (n-1) to the full backup, it is not re-tried
because full backup day is processed as per the configuration.

n Full Backup Fails—If a full backup fails, it is re-tried the next consecutive day and does not miss the
Backup Day configuration.

The following example describes the error-handling mechanism if a full backup or incremental backup
fails. Consider an incremental backup cycle configured for a weekly frequency with Sunday as the
Backup Day.



System Management | 268

Figure 40 Backup Failures in Weekly Incremental Cycle

Day
Number

Day of the
Week Backup Type Failed or Successful Backup

Day 1 Sunday Full Backup Failed.

Day 2 Monday Full Backup Full backup is re-tried because of
previous day's failure, successful.

Day 3 Tuesday Incremental
Backup

Failed.

Day 4 Wednesday Incremental
Backup

Incremental backup re-tried
because of previous day's failure,
successful. It consists of data from
the previous successful backup
(Day 2, Monday) until this
incremental backup re-try (Day 4,
Wednesday).

Day 5 Thursday Incremental
Backup

Successful.

Day 6 Friday Incremental
Backup

Successful.

Day 7 Saturday Incremental
Backup

Failed.

Table 46: Scenarios of Failed and Successful Backups
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Day
Number

Day of the
Week Backup Type Failed or Successful Backup

Day 8 Sunday Full Backup As per backup configuration, this is
the next consecutive Backup Day,
so full back is processed instead of
retrying the incremental backup.

Restoring Data
To restore the backed up data, complete the following steps:

1. In the Aruba Central On-Premisesapp, set the filter to Global.

2. Under Maintain, click System Management.
3. Click Backup and Restore tab.

The Backup and Restore page is displayed.

4. In the Restore pane, click the Restore Now menu option.

The Restore window opens.

5. In the Restore window, configure the following parameters:
a. Host name or IP address— Specify the host name or IP address of the server used to save

the backup data.
b. Protocol Type— Specify SFTP or SCP. By default, SFTP is selected.
c. File Path— Specify the file path or folder name in the server from which you want to restore

the saved data.

d. Select Authentication Method —Specify either of the following authentication method:

n Username and Password—If you select this option, specify the server SFTP or SCP
username and password

n SSH—If you select this option, enter the username of the backup server.

6. Use the Copy host key to the clipboard option to copy the host key.
7. Click Restore System.
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Figure 41 Restore

Resetting the Host Key for Backup or Restore Operation
When the Aruba Central On-Premises connects to an external server such as SCP and SFTP, the Aruba
Central On-Premises imports the host key automatically. For any reason, if the host key changes, Aruba
Central On-Premises cannot connect to the back up or restore server and the back up and restore
operation fails.

To reset the host key, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click System Management.
3. Select the Backup and Restore sub tab.
4. If there is a change in the host key, then you can see the Reset host key for <ip address> option

in the Backup or Restore panes.
5. Select the Reset host key for <ip address> option.
6. The Reset host key for <ip address> pop-up opens.
7. Click Reset.

Generating Logs

During the restore process, most of the services will be offline for the restore and get back online when the
restore is complete. You can view the progress of the restore operation by logging into Aruba Central CLI
through a serial console and use the show command to navigate to Backup-Restore status. For more
information, see Backup-Restore Status and Show Commands in the Aruba Central On-Premises user guide

The Logs table displays the following information and also allows you to download or delete logs:

n File— Displays the generated file name. Use the filter option to filter the file names. You can also use
the icon to sort the files in ascending or descending order.

#https://www.arubanetworks.com/techdocs/CLI-Bank/Content/cop/3-show/3-3-backup-restore.htm
#https://www.arubanetworks.com/techdocs/CLI-Bank/Content/cop/3-show/3-show.htm
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n Created— Displays the date and time of the log creation. Use the icon to sort the list in ascending
or descending order.

n Status— Displays the status of the generated logs. Use the icon to sort the list in ascending or
descending order.

n Action— Allows you to do the following actions:
o

Download— Select the file and click the icon to download the generated file.
o Delete— Select the file that you want to delete and click the delete icon. In the Confirm Action

pop-up window, click Yes.

Migrating the AirWave Server

Important Information for Migration
The following are the requirements and guidelines for the migration process:

n The AirWave system must be running a minimum AirWave version of 8.2.8.2 for the migration to
proceed. If the AirWave system is running an earlier version, refer to the AirWave documentation to
upgrade the version to 8.2.8.2 or later versions.

n Only those APs, controllers, and switches that are supported in Aruba Central On-Premises are
migrated. For information on supported hardware, see Supported Devices section.

n As part of migration, Visual RF and the device inventory for CAPs, IAPs, controllers, and Aruba/HPE
switches are migrated.

n For controllers, the device credentials for SNMP and HTTPS profiles are mapped.
n Migration of multiple AirWave systems to a single Aruba Central On-Premises server is supported.

That is, you can migrate multiple AirWave systems to Aruba Central On-Premises by adding the IP
addresses or AMP Hostnames of each AirWave system individually.

n All the historical data including data related to reports, monitoring, and stats are not migrated from
Airwave to Aruba Central On-Premises during the migration process.

n Templates are not migrated from Airwave to Aruba Central On-Premises during the migration
process. You must manually create a new template in Aruba Central On-Premises based on the
requirement.

n All data related to VisualRF is migrated from Airwave to Aruba Central On-Premises during the
migration process.

Accessing Aruba Central On-Premises
The Dashboard gives you access to the feature application card, Aruba Central On-Premises added to
your account. After launching the application, you can interact and use it through HPE GreenLake.

To launch the Aruba Central On-Premises app, perform the following steps.

1. From the HPE GreenLake home page, Aruba Central On-Premises is available on the Dashboard.

2. Click Launch on the Aruba Central On-Premises tile to launch the application.
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Logging Aruba Central On-Premises
To log out of Aruba Central On-Premises, complete the following steps:

1. On the Aruba Central On-Premises WebUI, click the user icon ( ) in the header pane.
2. Click Logout.

Accessing the Migration Page
To access the Migration page, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click System Management.
3. Click the Migration tab.

The Migration page is displayed.

4. Click the Migration tab at the top right corner of the table to add a new migration task.

The following image displays the Migration page.

Figure 42 Viewing the Migration Page

The following table provides Airwave Migration parameter details.

Name Description

Migration FQDN or IP address of the AMP server.

Migration
Status

Indicates the current status of the migration. For example, Migration Success, Waiting to
start migration, or Migration Failed.

Description Provides a description of the current status of migration.

Summary Provides a summary of the migration. Following are some of the messages displayed:
n Number of devices existing on Aruba Central On-Premises
n Number of devices on AirWave 8.x
n Number of devices to migrate

Table 47: Migration Parameters
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Name Description

n Number of devices successfully migrated
n Number of devices failed to migrate

Start Time Displays the start time of the migration.

End Time Displays the end time of the migration.

Migration Status
In the Airwave Migration table, the Status column displays the following list of migration status:

n Waiting to start migration
n Migration Stopped
n Migration Started
n AW8.X generating migration dump
n AW8.X migration dump is ready
n COP migration is in progress
n Migration Success
n Migration Failed

Migration Descriptions
In the Airwave Migration table, the Description column displays the following list of migration status:

n Migration of AMP not started
n Starting migration of AMP to COP
n Connecting to AMP
n Could not establish connection to AMP
n Could not prepare backup on AMP
n Waiting for AMP backup to be prepared
n AMP backup not prepared after 2 hours, please check AMP logs
n AMP backup is ready for download from AMP
n AMP backup is being downloaded to COP
n AMP backup download failed
n AMP backup downloaded successfully
n Restoring AMP backup in COP
n AMP version not supported for migration
n Migrating devices to COP Migrating profiles to COP
n Checking for VRF data to migrate VRF migration in progress
n Migration of VRF data failed VRF
n Migration did not complete after 4 hours, please check the VRF logs
n Migration of AMP completed successfully, VRF data not found
n Migration was terminated abruptly, please retry migration
n Migration of AMP completed successfully
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n Exception occurred during migration, please check the logs
n Another system operation is active, retry after sometime

During the migration process, a new AMP back up is created in AirWave and transferred to the Aruba Central
On-Premises. The scheduled nightly backup is independent of the backup operation performed as a part of the
migration process.

Performing the Migration
For performing the migration, you need to add the AirWave server that is running the older software
version to Aruba Central.

Aruba Central On-Premises supports both offline and online migration.

Online Migration
Aruba Central On-Premises establishes a connection with AirWave to perform an online migration of the
onboarded devices and VisualRF data from AirWave to Aruba Central On-Premises.

To perform an online migration, complete the following steps with active internet connection:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click System Management.
3. Click the Migration tab.

The Migration page is displayed.

4. Click in the Airwave Migration table.
The Add Migration window is displayed.

5. In the Add Migration window, select the Online Migration option.
6. Enter the following details:

n Hostname or IP Address—Enter the IP address of the AirWave Management Platform (AMP).
n AMP User name—During the migration process, a new AMP back up is created in AirWave

and transferred to the Aruba Central On-Premises. The scheduled nightly backup is
independent of the backup operation performed as a part of the migration process.

n Password—Enter the password associated with the administrative account.
n Confirm password—Re-enter the password.

7. Click Save to start the migration process.

The following image displays the online migration of the AirWave server using the hostname of the AMP
server.
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Figure 43 Online Migration using Hostname

The following image displays the online migration of the AirWave server using the IP address of the AMP
server.
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Figure 44 Online Migration using IP Address

n You can add multiple IP addresses to migrate from multiple AirWave servers to one Aruba Central On-
Premises server. In this case, each AMP will be migrated sequentially.

n You can not delete an AMP when the migration is in-progress.

n In the Airwave Migration table, the , , and icons allow you to edit, restart, and delete the
migration.

n All system operations are disabled until the active system operation is complete. The migration, backup
and restore, high availability processes, and the upgrade operations are the system operations in Aruba
Central On-Premises

Offline Migration
Aruba Central On-Premises performs an offline migration of the onboarded devices and VisualRF data
from AirWave to Aruba Central On-Premises by uploading the backup file that was earlier downloaded
from AirWave.

Offline Migration is also called as the Inplace Migration. The user need not have the AirWave server up
and running for an offline migration. Offline migration is required when the user wants to deploy Aruba
Central On-Premises on the same AirWave server. The advantage of an offline migration is that the user
can onboard all the devices to Aruba Central On-Premises from AirWave in a single operation.
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In offline migration, the Aruba Central On-Premises is installed on the servers where the AMP is
operational.

The minimum supported version for the migration is AirWave 8.2.8.2.

To perform an offline migration, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click System Management.
3. Click the Migration tab.

The Migration page is displayed.

4. Click in the Airwave Migration table.
The Add Migration window is displayed.

5. In the Add Migration window, select the Offline Migration option.
6. Browse to the location to choose the migration file that was downloaded from AirWave.
7. Click Save to start the migration process.

The following images displays the offline migration of the AirWave server.

Figure 45 Offline Migration

n In the Airwave Migration table, the icon allows you to delete the migration.

n You must not refresh the page when the upload is in-progress.

Validating the Migration Process
After you click Save on the migration window, the migration process starts. If multiple AMPs are added,
each AMP will be migrated sequentially.

The following image displays the offline migration main components of the Migration page.
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Figure 46 Screen Capture of Offline Migration

Figure 47 Screen Capture of a successful Migration

n During the migration process, a fresh AMP back up is created in AirWave 8.x and transferred to Aruba
Central On-Premises. The scheduled nightly backup is not performed as a part of the migration process.

n The default time out period for the backup process during the migration is 120 minutes.
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Logs
The Logs table displays all the logs related to the migrations that are either complete or failed.

You can generate the log files in one of the following ways:

n In the System Management > Migration > Logs table, click Generate Logs to create the log files.
n In the System Management > Performance > Service Monitoring table, select the deployment

service and click the icon.

The log files that are generated contains the cumulative data of all the AMP migrations.

n You can view the device migration POD logs from the Aruba Central On-Premises backend or from the
Aruba Central On-Premises UI.

n The VisualRF migration POD logs are available in one of the Aruba Central On-Premises cluster node and
can be viewed in the /var/log/visualrf path.

The following image displays the Logs table.

Figure 48 Log Files

The following table provides the Logs information.

Name Description

File Name of the log file.

Created The date and time when the log file is created.

Status Indicates the status of the logs that are generated. The status indicated is Download Ready, In
Progress, Successful, or Failed.

Action Enables you to perform the following actions:
n Click the icon to download the log files. The files are then saved to the local drive as a TAR

file.
n Click the icon to delete the log files.

Table 48: Logs Table

Datacenter Redundancy
In networking, Datacenter Redundancy (DR) is the practice of duplicating critical network components.
The availability of services is essential for business continuity. By implementing DR, you configure two
Aruba Central On-Premises clusters as primary and secondary that are located in different geographical
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locations. This ensures that if one cluster goes into a down state or encounters a failure, the peer cluster
attains primary role and manages the network with minimum downtime.

A failover is the ability to switch automatically to a redundant cluster. In case of primary cluster failure,
the failover is triggered and redundant cluster takes the role of primary to eliminate negative impact on
users.

The Datacenter Redundancy is processed in the following methods:

n Auto Failover: This is automatic failover method where the peer system switches over as primary
after the specified time and takes control of the processes when a failure is detected.

n Trigger Failover: This is to manually trigger the failover if you want to switch the primary as required.

The following topics explain how to configure and enable the Datacenter Redundancy operations:

n Navigating to Datacenter Redundancy Tab

n Enabling Redundancy

n Configure Redundancy
o Pairing and Configuring the Clusters

n Enabling Autofailover

n Triggering Redundancy Manually

n Handling Upgrade for Datacenter Redundancy

n Disabling Redundancy

Navigating to Datacenter Redundancy Tab
To navigate to the Datacenter Redundancy tab, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.

2. Under Global Settings, select System Management > Datacenter Redundancy.

The Datacenter Redundancy tab is displayed. It consists of the following parameters:

n Enable Redundancy—If the Enable Redundancy toggle switch is turned on, it indicates that
the disaster recovery is configured. When a failover is detected, the replicated Aruba Central
On-Premises cluster starts processing in its entirety.

n Auto Failover—If the Auto Failover toggle switch is in enabled state, it indicates that
replicated Aruba Central On-Premises cluster will automatically transfer control when a failure
is detected. If Auto Failover is not enabled, you can use the CLI to initiate the failover because
the WebUI is not accessible on the secondary cluster. For more information, see Handling
Upgrade for Datacenter Redundancy.

n Restore Frequency (Days)—The number of days between two consecutive successful restore
operations. For example, if it is set to 3 days. The restore function is processed on Day 1 and
Day 5.

n Time to Failover—Specify a number between 30 to 120. The value is specified in minutes. The
Aruba Central On-Premises clusters check the health status for the specified time before
failing over. For example, if the time is set to 30 minutes. When the secondary cluster does not
get a response from the primary cluster or vice versa, then the secondary cluster considers
primary cluster is down after 30 minutes. In such a scenario, the secondary cluster attains the
role of primary.
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n Initiate Redundancy Switchover—Click the Trigger Failover button to initiate a manual
switchover of the system.

n DR Pairing Key—Click the Copy DR Pairing Key To Clipboard link to copy the DR key for the
redundancy configuration. Copy the key for primary Aruba Central On-Premises cluster and
specify it in secondary cluster and vice versa.

n Data Sync Status—The data synchronization status between the Aruba Central On-Premises
clusters.

n Data Sync Time—The timestamp of when the latest data synchronization operation was
done.

n Redundancy Status—The configuration details are displayed on the Redundancy Status
table such as Appliance, Current Role, Status, Last Heartbeat Received from Peer, and
Time to Failover (in minutes).

Figure 49 Datacenter Redundancy Tab

Enabling Redundancy
The redundancy must be enabled only after pairing the Aruba Central On-Premises clusters. You can
enable the redundancy by clicking the Enable Redundancy toggle switch. For more information, see
Configure Redundancy and Enabling Autofailover.

The following workflow explains how the datacenter redundancy is achieved between two Aruba
Central On-Premises clusters. For example, consider cluster A (primary) and cluster B (secondary) are to
be configured for the datacenter redundancy.
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Figure 50 Datacenter Redundancy Configuration Workflow

After enabling datacenter redundancy on the cluster B (secondary), it goes into the maintenance mode.
The backup data from the cluster A (primary) is restored in the cluster B (secondary).

For information about how to disable the redundancy, see Disabling Redundancy.

Configure Redundancy
Datacenter Redundancy is configured between two Aruba Central On-Premises clusters to provide
data redundancy on the secondary cluster, so that it can continue to operate in the event of a failure.

The redundancy configuration can be done both on the WebUI using the Datacenter Redundancy tab
or using the CLIs. For information about how to use CLIs for redundancy, see Handling Upgrade for
Datacenter Redundancy.

On Aruba Central On-Premises WebUI, two similar clusters are paired for redundancy. Primary cluster
acts as a normal Aruba Central On-Premises cluster and secondary cluster has the redundant data. In
the event of a failure, the secondary will act as primary in order to continue the network functioning.

Prerequisites:

n DR works on both multi-node clusters as well as single-node deployments.

n Ensure both the Aruba Central On-Premises clusters are running on the same version.

n Ensure both the Aruba Central On-Premises clusters have same number of nodes on their clusters. If
you add more nodes to any cluster, ensure to add the same number of nodes to the other cluster
also. Otherwise, node mismatch error is encountered.

n Ensure both the Aruba Central On-Premises clusters are active.
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n Ensure both the Aruba Central On-Premises clusters have same deployment type (online, offline,
FIPS, appliance, or non-appliance)

n Backup and Restore is used for the data synchronization between the Aruba Central On-Premises
clusters when DR is enabled. Data back up is done on the primary cluster and that data is restored
on the secondary cluster. For more information, see Backing up and Restoring System Data.

n Backup server must have access to both the clusters and the clusters must have good latency and
bandwidth (above 1 gbps) for faster backup operation.

n A bandwidth of 10 Gbps throughput is recommended for optimal performance between the backup
server and Aruba Central On-Premises clusters. For smaller networks, a minimum of 1 Gbps
throughput is recommended.

n ArubaOS 8.x requirements for Datacenter Redundancy:
o Onboard the controller only on the primary cluster.
o Add both the clusters' virtual IP in the management server of the controller.

For information about how to pair and configure two Aruba Central On-Premises clusters for
redundancy, see Pairing and Configuring the Clusters

Limitations:

n Only Campus AP-deployments are supported for Datacenter Redundancy.

n If only one Aruba Central On-Premises cluster is upgraded, then the Redundancy Status is displayed
as Version Mismatch. It indicates that the peer Aruba Central On-Premises cluster must also be
upgraded.

n During an upgrade process, the DR operations such as failover or data synchronization is not allowed
until the upgrade is completed on both Aruba Central On-Premises clusters.

n During the data sync operation, if pre-check failed or system operation is in-progress on any cluster,
then previous data sync status is displayed. If the previous data sync status is successful and failover
is triggered, the new primary cluster keeps the data till the data sync time. However, if the data sync
status is unsuccessful (when data sync fails on the secondary system), failover is not allowed.

n After the failover, if one cluster is down, then you must manually configure the controller, otherwise
troubleshooting commands to do not work as per WebSocket configuration.

n If any hardware is replaced or factory reset is done on any cluster, then DR must be re-configured.

n When a node is replaced, it takes approximately 8 hours to process. This is a system operation and
datacenter redundancy is not available until it is completed.

Pairing and Configuring the Clusters
You must add two Aruba Central On-Premises clusters, where one is primary and the other is
secondary, and pair them for configuring the redundancy.

Before pairing the Aruba Central On-Premises clusters for the Datacenter Redundancy configuration,
ensure to schedule a full backup on both the clusters. For information on how to schedule a backup
operation, see Backing up and Restoring System Data.
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n Redundancy configuration must not be done between two primary clusters. If one cluster has the Initial
Role as Primary, then the other cluster must have the the Initial Role as Secondary.

n For Datacenter Redundancy, only the Full Backup option is supported. Select a scheduled backup time
that occurs after the completion of redundancy operation. This is necessary because both the redundancy
and backup are system operations and only one operation can execute at a time.

n If backup was scheduled only on the primary cluster and not done on secondary cluster before
configuring the DR. Then, after a failover, when the secondary cluster attains primary role, schedule the
backup.

To configure redundancy between two Aruba Central On-Premises clusters, complete the following
steps on both clusters:

1. In the Aruba Central On-Premises app, set the filter to Global.

2. Under Global Settings, select System Management > Datacenter Redundancy.

The Datacenter Redundancy tab is displayed.

3. Click the + icon on the Redundancy Status table.

The Add Redundant Cluster window is displayed.

4. On the Add Redundant Cluster window, specify the following details:

a. Initial Role—Assign the initial role to the Aruba Central On-Premises cluster that you are
currently accessing. The available options are Primary or Secondary. If primary is already
configured, then secondary must be assigned.

Initial role configuration is used for the following:

n When enabling the redundancy, the initial role is used for assigning the roles.

n If a role mismatch is encountered in the redundancy, the initial role may be used for
determining the new primary.

b. DR Pairing Key—This is the key of the peer cluster, it is required for the pairing. Copy the key
by clicking Copy DR Pairing Key To Clipboard on the Redundancy Status table from the
WebUI of the other Aruba Central On-Premises cluster.

5. Click Add.

One Aruba Central On-Premises cluster is successfully added.

6. Click the Enable Redundancy toggle switch.

The redundancy is successfully configured for one cluster. For information about how to enable
autofailover, see Enabling Autofailover.

7. Similarly, add the second cluster. Follow the same procedure as mentioned from step numbers 3
to 6.

After enabling datacenter redundancy on secondary cluster, it goes into the maintenance mode. The
backup data from the primary cluster is restored in the secondary cluster.
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Both the clusters are displayed in the Redundancy Status table. The following details are
displayed:

n Appliance—Name of the Aruba Central On-Premises application.

n Current Role—The role of the appliance.

n Status—The health status of the appliance. After clicking the Enable Redundancy toggle
switch, it takes approximately 10 minutes to process. The Status column displays Good for
both the clusters indicating that configuration is successful.

n Last Heartbeat Received from Peer—Time stamp indicating when the latest health status
was checked.

n Time to Failover (in minutes)—The time specified for the failover.

Figure 51 Configuring Redundancy

Enabling Autofailover
After pairing the Aruba Central On-Premises clusters for Datacenter Redundancy and scheduling the
backup on both primary and secondary, enable the autofailover. For more information, see Configure
Redundancy and Backing up and Restoring System Data.

To enable autofailover for Aruba Central On-Premises clusters, complete the following steps on both
clusters:

1. In the Aruba Central On-Premises app, set the filter to Global.

2. Under Global Settings, select System Management > Datacenter Redundancy.

The Datacenter Redundancy tab is displayed. Ensure both primary and secondary cluster is
displayed in the Redundancy Status table.

3. Click the Auto Failover toggle switch to enable.

This ensures that automatically control is transferred to the peer cluster when a failure is
detected. The automatic switch happens when the health status of the primary cluster continues
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to be poor or bad for the specified Time to Failover. A cluster is considered to be in poor state
when more than one node is in the Down state.

When an auto failover is detected, it takes approximately 30 minutes for the secondary cluster to attain
the primary role. The message This page is not working is displayed on the WebUI.

4. Choose a value for Restore Frequency (Days) from the drop-down list.

By default, it is set to 3 days. This value indicates that there is a 3-day interval between two
consecutive restore operations. For example, if the first restore is done on 6 June 2023, then after
an interval of three day, the next restore is done on 10 June 2023.

Autofailover in Split-Brain (Communication Failure) Scenario
If there is communication failure between the two Aruba Central On-Premises clusters, then both
clusters consider that the peer cluster is down. This is called a split-brain scenario. When autofailover is
enabled and split-brain scenario is encountered, the secondary fails to reach primary and attains the
primary role. This causes both the clusters operating as primary. In such a case, the devices monitoring
is split between the two clusters. After communication is resumed between the clusters, the old primary
attains the secondary role.

Triggering Redundancy Manually
You can trigger a manual failover or force a failover to initiate switchover for redundancy. A forced
failover is intended for disaster recovery or if autofailover is not possible.

Prerequisites for triggering a manual redundancy:

n Ensure the Enable Redundancy toggle switch is enabled.

n Ensure both Aruba Central On-Premises clusters are active.

n Ensure that the Data Sync Status or Restore Status of the secondary cluster is displayed as
Successful. To check Restore Status using CLI, use Backup-Restore Status. For more information,
see Backup and Restore Status.

To manually trigger redundancy, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.

2. Under Global Settings, select System Management > Datacenter Redundancy.

The Datacenter Redundancy tab is displayed.

3. Click Trigger Failover.
The Confirm Action window is displayed.

4. Click Yes.

The All system operations will be disabled till the active system operation is complete message is
displayed. The systems goes into maintenance mode and does not perform any operation. The
switchover is initiated and it takes approximately 30 minutes for the secondary cluster to attain
the primary role. The message This page is not working is displayed on the WebUI.

#https://www.arubanetworks.com/techdocs/CLI-Bank/Content/cop/3-show/3-3-backup-restore.htm
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The copadmin user can execute System Configuration > Disaster Recovery > show DR

status CLI to check the status. It is displayed as good, failover ongoing. For more information, see
Disaster Recovery.

5. After the switchover, the Sign In page is displayed on the Aruba Central On-Premises WebUI for
the primary appliance.

6. Logon to the application and navigate to the Datacenter Redundancy tab.

The Redundancy Status table displays the switched roles of the appliances and its
corresponding status. A log is added to the Audit Trail page under the System Setup category
with DR: Role change to Primary completed with status successful description. For more information,
see Viewing Audit Trail.

Disabling Redundancy
Upon disabling the Datacenter Redundancy, both Aruba Central On-Premises clusters act as
independent clusters. Database clean up is not done on the primary or secondary cluster after
disabling.

To disable the redundancy configuration, complete the following steps on both the primary and
secondary clusters:

1. In the primary Aruba Central On-Premises app, set the filter to Global.

2. Under Global Settings, select System Management > Datacenter Redundancy.

The Datacenter Redundancy tab is displayed.

3. Click the Enable Redundancy toggle switch to disable.

4. Click the Auto Failover toggle switch to disable.

5. On the Redundancy Status table, select the peer cluster and click the Delete icon.

6. Repeat the same procedure on the secondary Aruba Central On-Premises app.

The redundancy configuration is disabled.

#https://www.arubanetworks.com/techdocs/CLI-Bank/Content/cop/4-systemconfig/4-8-dstr-recvry.htm


Chapter 11

The AI Insights Dashboard

The AI Insights Dashboard

In an environment of rapidly changing business and user expectations driven by an explosion of
connectivity requirements from the edge to the cloud, a new approach to network management is
required. Aruba AIOps (Artificial Intelligence for IT operations) is the next generation of AI-powered
solutions that integrates proven Artificial Intelligence solutions with recommended and automated
action to provide both fast response to identified problems, along with proactive prediction and
prevention.

With data leveraged from huge network management systems, Aruba Central On-Premises and built-in
AI Insights proactively identifies and solves issues, and provides pinpoint configuration
recommendations. The result of this AI-based mechanism has enabled a consistent, reliable, and timely
flow of information about the network performance that helps IT work faster despite the increasing
demand and complexity that a network often brings. All of this comes from the Aruba advantage in
accessing an enormous volume and variety of data that is factored into insights. Aruba does not collect
or process personal data.

The AI Insights dashboard displays a report of network events that could possibly affect the quality of
the overall network performance. These are anomalies observed at the access point, connectivity, and
client level observed in the network for the selected time range. Each insight report provides specific
details on the occurrences of these events for ease in debugging.

To launch the AI Insights dashboard, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Manage, click Overview > AI Insights.

The Insights table is displayed. AI Insights listed in the dashboard are sorted from high priority to
low priority.

3. Click the arrow against each insight to view the details.

Figure 52 Insight Anomaly
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Callout
Number Description

1 Click this arrow to expand any specific insight to view further details.

2 Displays the insight severity, using the following colors:
Red—High priority
Orange—Medium priority
Yellow—Low priority

3 Short description of the insight.

4 Insight Summary displays the reason why the insight was generated along with the
recommendation. It also shows the number and percentage of failures that occurred against
each failure reason.

n Static—These reasons rely on Aruba's domain expertise.
n Dynamic—These reasons are generated based on error codes that is received from
infrastructure devices.

5 Time Series graph is a graphical representation of the events that occurred for the selected time
range.

6 Category of the insight. Insight category can be filtered by clicking the filter icon.

7 Short description of the impact.

8 Cards display additional information specific to each insight. Cards might vary for each insight
based on the context the insight is accessed from.
For more information, see Cards.

All AI Insights observed for the network are listed in the AI Insights dashboard in the Global context.
Alternatively, AI Insights reports for a specific site, device, or a client can be viewed by selecting the
appropriate context. For more information on available insights and the context, see Insight Context.

AI Insights are displayed for a selected time period based on the time selected in the Time Range Filter ( ).
You can select one of the following: 3 Hours, 1 Week, 1 Day, or 1 Month.

Wi-Fi Connectivity
The Wi-Fi Connectivity page displays an overall view of the connection details for all clients that are
connected to or tried to connect to each connection phase. The connection phases include Association,
Authentication, DHCP, and DNS.

To view the connectivity details page complete the following procedure:

1. In the Aruba Central On-Premises app, select one of the following options:

To select a group, site, or all devices in the filter, set the filter to one of the options under Group
or Site. For all devices, set the filter to Global.

2. Under Manage > Overview, click Wi-Fi Connectivity.

The dashboard context for the selected filter is displayed.
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By default, the graphs on the Wi-Fi Connectivity page is plotted for a time range of 3 hours. To view the
graphs for a different time range, click the Time Range Filter icon. You can choose to view graphs for a
time period of 3 hours, 1 day, 1 week, 1 month and 3 months.

This section includes the following topics:

n Connectivity Summary Bar
n Connection Experience
n AI Insights
n Connection Problems
n Connection Events

Connectivity Summary Bar
The connectivity summary bar displays the details of all clients in percentage. It displays the percentage
success rate of each stage for the users to know the network performance.

Figure 53 Connectivity Summary Bar

The following table describes the information displayed in each section:

Field Description

All Displays the aggregated success percentage of Association, Authentication, and DHCP for
all clients connected to the network.

Association Displays the percentage of successful attempts made by a client to connect to the
network.

Authentication Displays the percentage of successful attempts of client authentication.

DHCP Displays the percentage of successful attempts of DHCP requests and responses when
onboarding a client.

DNS Displays the percentage of successful attempts in the detected DNS resolutions, when a
client is connected to the network.

Table 49: Connectivity Summary Bar

Connection Experience
The Connection Experience tile displays the overall success percentage, total number of attempts,
number of successful attempts, total delays, and the total failures for each stage based on the selected
time range filter. To view the connection experience for individual stage, select the stage type from the
Connectivity Summary bar, the Connection Experience displays the chart for the selected stage.
Select All to view the success percentage for all the stages. You can hover over the time series graph to
view the success percentage for a specific time. The individual stage displays the Attempts, Failures,
Success, and Delays on the time series graph.
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Figure 54 Connection Experience tile

AI Insights
The AI Insights tile provides a list of AI Insights generated for a selected time range. To view the details,
click on a selected AI Insight. The page gets redirected to the AI Insights under the AI Insights page.
Click each of the listed AI Insight for a detailed analysis based on the impact on the network. For more
information on AI Insights, see The AI Insights Dashboard.

AI-Insights is not implemented for Association and DNS. AI Insights is not implemented at a Group level also.
The page displays No AI Insights observed.

For a visual representation of viewing an AI Insight, click here.

Connection Problems
The Connection Problems tile displays the details of Failures and Delays graphically for each of the
categories from the drop-down list. Each graph displays the top five MAC addresses or SSID based on
the selected category. Each category in the Connection Problems drop-down lists changes based on
the selected stage in the Connectivity Summary bar. Selecting the required category from the drop-
down displays the failures and delays in a pie chart with percentage, and a bar graph with the number
of failures and delays. Hover the cursor over each graph to view the number of failures or delays for
each stage.
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Figure 55 Connection Problems Tile

The following table describes the information displayed in each connection category based on the
selected stage:

Data Pane
Content Description

All Displays the details of the failures and delays that occurred during a client connection.
The chart displays the failure details of Association, Authentication, and DHCP for each
client. The Connection Problems drop-down list includes the following categories:

n By Stage
n By Clients
n By Access Points
n By Band
n By SSID

Association Charts the details of the failures and delays that occurred during a client association. The
Connection Problems drop-down list includes the following categories:

n By Clients
n By Access Points
n By Band
n By SSID
n By Reason

Authentication Charts the details of the failures and delays that occurred during a client authentication.
The Connection Problems drop-down list includes the following categories:

n By Type
n By Clients
n By Access Points
n By Band
n By SSID
n By Server

DHCP Charts the details of the failures and delays that occurred during the attempts of DHCP
requests and responses by a client. The Connection Problems drop-down list includes
the following categories:

n By Clients
n By Access Points
n By Reason

Table 50: Connection Problems Rolls-ups
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Data Pane
Content Description

DNS Charts the details of the failures and delays that occurred during the attempts in detected
DNS resolutions when a client is connected to the network. The Connection Problems
drop-down list includes the following categories:

n By Clients
n By Access Points
n By Reason
n By Server

Connection Events
Connection Events table details out the list of delays and failures for each client based on the client

MAC addresses. Click the icon to view the connection events table. Click the Connection Events
drop down to filter the events By Clients or By Access Points. The Connection Events table displays
the following information:

Data Pane
Content Description

MAC Address Displays the MAC address of the client.

Name Displays the name of the access point.

Delays Displays the delays that occurred during the event.

Failures Displays the failure details that occurred during the event.

Table 51: Connection Events

Connectivity Alerts
Aruba Central allows network administrators and users with admin permissions to configure alerts. For
more information, see Configuring Alerts.

Following are the connectivity alerts that you can configure:

n DNS Delay Detected—Generates an alert when clients experience significant delays in response
from the DNS server. Set the severity values to generate an alert if the percentage of delay from the
DNS server exceeds the threshold value. The Duration field displays the duration after which the
alert is generated. The default value is 30 minutes. You can add additional rule(s) for this alert.

n DNS Failure Detected—Generates an alert when wireless APs experience a high number of
connection failures with the DNS server. Set the severity values to generate an alert if the DNS failure
percentage exceeds the threshold value. The Duration field displays the duration after which the
alert is generated. The default value is 30 minutes. You can add additional rule(s) for this alert.

n DHCP Delay Detected—Generates an alert when there is excessive DHCP delay from client to AP in
the network. Set the severity values to generate an alert if the percentage of the DHCP delay exceeds
the threshold value. The Duration field displays the duration after which the alert is generated. The
default value is 30 minutes. You can add additional rule(s) for this alert.

n DHCP Failure Detected—Generates an alert when there is high number of DHCP failure observed
from client to AP in the network. Set the severity values to generate an alert if the DHCP failure



Aruba Central On-Premises 2.5.7 | User Guide 295

percentage exceeds the threshold value. The Duration field displays the duration after which the
alert is generated. The default value is 30 minutes. You can add additional rule(s) for this alert.

n Authentication Delay Detected—Generates an alert when there is excessive delay in the client
authentication process with the AP in the network. Authentication failures include the following:
o Wi-Fi security key-exchange failures
o 802.1x authentication failures
o MAC authentication failures
o Captive failures

Set the severity values to generate an alert if the percentage of the authentication delay exceeds the
threshold value. The Duration field displays the duration after which the alert is generated. The
default value is 30 minutes. You can add additional rule(s) for this alert.

n Authentication Failure Detected—Generates an alert when there are high number of client
authentication failures in the network. Authentication failures include the following:
o Wi-Fi security key-exchange failures
o 802.1x authentication failures
o MAC authentication failures
o Captive failures

Set the severity values to generate an alert if the authentication failure percentage exceeds the
threshold value. The Duration field displays the duration after which the alert is generated. The
default value is 30 minutes. You can add additional rule(s) for this alert.

n Association Delay Detected—Generates an alert when client association delay is detected in the
network. Set the severity values to generate an alert if the percentage of the association delay
exceeds the threshold value. The Duration field displays the duration after which the alert is
generated. The default value is 30 minutes. You can add additional rule(s) for this alert.

n Association Failure Detected—Generates an alert when client association failure is detected in the
network. Set the severity values to generate an alert if the association failure percentage exceeds the
threshold value. The Duration field displays the duration after which the alert is generated. The
default value is 30 minutes. You can add additional rule(s) for this alert.

n Wi-Fi Security Key-Exchange Failure Detected—Generates an alert when there are high number of
client authentication failures (Wi-Fi Security Key-Exchange) in the network. Set the severity values to
generate an alert if the percentage of the Wi-Fi Security Key-Exchange failure exceeds the threshold
value. The Duration field displays the duration after which the alert is generated. The default value is
30 minutes. You can add additional rules for this alert.

n 802.1X Authentication Delay Detected—Generates an alert when there is an excessive delay in the
802.1X authentication process in the network. Set the severity values to generate an alert if the
percentage of the association delay exceeds the threshold value. The Duration field displays the
duration after which the alert is generated. The default value is 30 minutes. You can add additional
rules for this alert.

n 802.1X Authentication Failure Detected—Generates an alert when there are high number of
802.1X authentication failures in the network. Set the severity values to generate an alert if the
percentage of the association delay exceeds the threshold value. The Duration field displays the
duration after which the alert is generated. The default value is 30 minutes. You can add additional
rules for this alert.

n MAC Authentication Delay Detected—Generates an alert when there is excessive an delay in the
MAC authentication process in the network. Set the severity values to generate an alert if the
percentage of the association delay exceeds the threshold value. The Duration field displays the
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duration after which the alert is generated. The default value is 30 minutes. You can add additional
rules for this alert.

n MAC Authentication Failure Detected—Generates an alert when there are high number of MAC
authentication failures in the network. Set the severity values to generate an alert if the percentage
of the association delay exceeds the threshold value. The Duration field displays the duration after
which the alert is generated. The default value is 30 minutes. You can add additional rules for this
alert.

n Captive Portal Delay Detected—Generates an alert when there is an excessive delay in the captive
portal authentication process in the network. Set the severity values to generate an alert if the
percentage of the association delay exceeds the threshold value. The Duration field displays the
duration after which the alert is generated. The default value is 30 minutes. You can add additional
rules for this alert.

n Captive Portal Failure Detected—Generates an alert when there are high number of captive portal
failures in the network. Set the severity values to generate an alert if the percentage of the
association delay exceeds the threshold value. The Duration field displays the duration after which
the alert is generated. The default value is 30 minutes. You can add additional rules for this alert.

Insight Context
Insights can be accessed from different contexts such as Global, Site, Clients, and Device. The
following table lists the different types of insights generated by Aruba Central and the path from where
it can be accessed.

Insights Category Context Navigation

Clients with High
Wi-Fi Security
Key-Exchange
Failures

Connectivity —
Wi-Fi

Global Aruba Central On-Premises app > Global >
Overview > AI Insights

Site Aruba Central On-Premises app > Sites > Overview
> AI Insights

Access
Points

Aruba Central On-Premises app > Global > Devices
> Access Points > Device Name > AI Insights

Clients Aruba Central On-Premises app > Global > Clients >
Client Name > AI Insights
Aruba Central On-Premises app > Site > Clients >
Client Name > AI Insights

Table 52: Insight Context
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Insights Category Context Navigation

Clients with High
802.1X
Authentication
Failures

Connectivity —
Wi-Fi

Global Aruba Central On-Premises app > Global >
Overview > AI Insights

Site Aruba Central On-Premises app > Sites > Overview
> AI Insights

Access
Points

Aruba Central On-Premises app > Global > Devices
> Access Points > Device Name > AI Insights

Clients Aruba Central On-Premises app > Global > Clients >
Client Name > AI Insights
Aruba Central On-Premises app > Site > Clients >
Client Name > AI Insights

Clients with
DHCP Server
Connection
Problems

Connectivity —
Wi-Fi

Global Aruba Central On-Premises app > Global >
Overview > AI Insights

Site Aruba Central On-Premises app > Sites > Overview
> AI Insights

Access
Points

Aruba Central On-Premises app > Global > Devices
> Access Points > Device Name > AI Insights

Clients Aruba Central On-Premises app > Global > Clients >
Client Name > AI Insights
Aruba Central On-Premises app > Site > Clients >
Client Name > AI Insights

Clients with High
Number of MAC
Authentication
Failures

Connectivity —
Wi-Fi

Global Aruba Central On-Premises app > Global >
Overview > AI Insights

Site Aruba Central On-Premises app > Sites > Overview
> AI Insights

Access
Points

Aruba Central On-Premises app > Global > Devices
> Access Points > Device Name > AI Insights

Clients Aruba Central On-Premises app > Global > Clients >
Client Name > AI Insights
Aruba Central On-Premises app > Site > Clients >
Client Name > AI Insights

Clients with
Captive Portal
Authentication
Problems

Connectivity —
Wi-Fi

Global Aruba Central On-Premises app > Global >
Overview > AI Insights

Site Aruba Central On-Premises app > Sites > Overview
> AI Insights

Access
Points

Aruba Central On-Premises app > Global > Devices
> Access Points > Device Name > AI Insights

Clients Aruba Central On-Premises app > Global > Clients >
Client Name > AI Insights
Aruba Central On-Premises app > Site > Clients >
Client Name > AI Insights
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Insights Category Context Navigation

Clients with High
Number of Wi-Fi
Association
Failures

Connectivity —
Wi-Fi

Global Aruba Central On-Premises app > Global >
Overview > AI Insights

Site Aruba Central On-Premises app > Sites > Overview
> AI Insights

Access
Points

Aruba Central On-Premises app > Global > Devices
> Access Points > Device Name > AI Insights

Clients Aruba Central On-Premises app > Global > Clients >
Client Name > AI Insights
Aruba Central On-Premises app > Site > Clients >
Client Name > AI Insights

Cards
All the insights in Aruba Central On-Premises display certain cards with additional information specific
to that insight. The top view of each card usually shows the most impacted data in a pie chart or a bar
graph view. The data in a pie chart can be modified based on your requirement. To highlight specific
entries in a card, click the checkbox next to each label. For a few cards, there is a further drill down
available, in the form of a drop-down. The cards might vary for each insight based on the context the
insight is accessed from.

The following table displays the card details available in different insights:

Cards Description

Access Points The Access Point card displays the number of APs impacted by an
Insight. Click the arrow to expand the card and view the top 5 APs
where the issue occurred. You can also click the drop-down list to
view further details about the impacted access points.

Site The Site card displays the number of sites impacted by an Insight.
Click the arrow to expand the card and view the top 5 sites where
the issue occurred.

Client The Client card displays the number of clients impacted by an insight.
Click the arrow to expand the card and view the top 5 clients
where the issue occurred.

Server The Server card displays the number of servers impacted by an
insight. Click the arrow to expand the card and view the top 5
servers where the issue occurred.

Table 53: Cards

If you click on the number displayed on each card, further details specific to that card is displayed in a
tabular format. The filter icon allows you to filter data in each column. The and icons allow you
to sort the columns in ascending and descending order. Few columns are displayed by default, whereas
there are few columns which do not appear in the table by default.

To customize a table, click the ellipses icon to select the required columns, or click Reset to default to
set the table to the default column. Click to download the card details in a CSV format.



Aruba Central On-Premises 2.5.7 | User Guide 299

Clients with High Number of Wi-Fi Association Failures
The Clients had a high number of Wi-Fi Association failures insight can be accessed from the
Global, Site, Access Points, and Clients context. This insight provides information on Wi-Fi association
failures observed in the network. It is categorized under connectivity since the users are unable to
connect to the WiFi network. This insight displays the following information:

n Insight Summary
n Time Series Graph
n Cards

Insight Summary
The insight summary provides the following details:

n Reason—Displays the possible causes for which the failure occurred.
n Recommendation—Displays the possible recommendation against each failure to resolve the same.
n Failures—Displays the exact number and percentage of failures that occurred against each failure

reason.

Time Series Graph
The time series graph displays the number of association failures observed in the network during the
selected time period. You can hover your mouse over each bar graph to see the exact number of
failures.

Cards
The cards vary based on the context that you access the insight from. Click one of the cards to view
further details:

Cards Context

Site Global

Access Point Global, Site, Client

Client Global, Site, Device

Table 54: Cards Context

Site
Lists the number of sites that experienced association authentication failures in the network. Click the
arrow to view a pictorial graph of the Most Impacted sites. Click the number displayed on the Site
card, to view a detailed description of the impacted sites:

n Site—Name of the site impacted by the insight.
n Failures—Number and percentage of failures occurred in each site.
n Total—Total number of association failures in each site.
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Access Point
Lists the number and the details of APs that experienced association failures in the network. Click the
arrow to view a pictorial graph of the Most Impacted access points. Click the Access Point drop-
down list to view the following:

n SSID—Pictorial graph of the percentage of association failures sorted by SSIDs.
n Model—Pictorial graph of the percentage of association failures sorted by AP models.
n FW Version—Pictorial graph of the percentage of association failures sorted by AP firmware version.

Click the number displayed on the Access Point card, to view the detailed description of the impacted
access points:

n AP Name—Name of the access points and link to the specific insight at the AP context.
n AP MAC—MAC address of the AP link to the specific insight at the AP context.
n Failures—Number and percentage of failures occurred in each AP.
n Total—Total number of failures in each AP.
n Serial—Serial number of the AP.
n IP—IP address of the AP.
n Model—Model number of each AP.
n FW Version—Version of the firmware running on each AP.
n Site—Name of the site where the AP resides.

Client
Lists the MAC address, name, host name, and auth ID of clients that experienced association failures in
the network. Click the arrow to view the pictorial graph of the Most Impacted clients. Click the
number displayed on the Client card, to view a detailed description of the impacted clients:

n Client Name—Name of the impacted client and link to the specific insight at the client context.
n Client MAC—MAC address of the client and link to the specific insight at the client context.
n Failures—Number and percentage of failures occurred in each client.
n Total—Total number of failures in each client.
n Client OS—OS type of the device.

Clients with High Number of MAC Authentication Failures
The Clients had an unusual number of MAC authentication failures insight can be accessed from
the Global, Site, Access Points, and Clients context. This insight provides information on excessive
MAC authentication failures observed in the network and is categorized under connectivity since the
users are unable to connect to the Wi-Fi network. It also helps in order to identify the rogue users in a
network. This insight displays the following information:

n Insight Summary
n Time Series Graph
n Cards
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Insight Summary
The insight summary provides the following details:

n Reason—Displays the possible causes for which the failure occurred.
n Recommendation—Displays the recommendation against each failure to resolve the same.
n Failures—Displays the exact number and percentage of failures that occurred against each failure

reason.

Time Series Graph
The time series graph displays the number of MAC authentication failures that occurred during the
selected time period. You can hover your mouse over each bar graph to see the exact number of
failures.

Cards
The cards vary based on the context that you access the insight from. Click one of the cards to view
further details:

Cards Context

Site Global

Access Point Global, Site, Client

Client Global, Site, Device

Cards Context

Site
Lists the number of sites that experienced MAC authentication failures in the network. Click the arrow

to view a pictorial graph with the Most Impacted sites. Click the number displayed on the Site card,
to view a detailed description of the impacted sites:

n Site—Name of the site impacted by the insight and link to the specific insight at the site context.
n Failures—Number of failures occurred in each site.
n Total—Total number of MAC authentications in each site.

Access Point
Lists the number and the details of APs that faced the MAC authentication failures in the network. Click
the arrow to view a pictorial graph of the Most Impacted access points. Click the Access Point drop-
down list to view the following:

n SSID—Pictorial graph of the percentage of MAC authentication failures sorted by SSIDs.
n Model—Pictorial graph of the percentage of MAC authentication failures sorted by AP models.
n FW Version—Pictorial graph of the percentage of MAC authentication failures sorted by AP firmware

version.
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Click the number displayed on the Access Point card, to view the detailed description of the impacted
access points:

n Name—Name of the access points and link to the specific insight at the AP context.
n MAC—MAC address of the AP and link to the specific insight at the AP context.
n Failures—Number of failures occurred in each AP.
n Total—Total number of MAC authentications in each AP.
n Serial—Serial number of the AP
n IP—IP address of each AP.
n Model—Model number of each AP.
n FW Version—Version of the firmware running on each AP.
n Site—Name of the site where the AP resides.

Client
Lists the MAC address, name, host name, and auth ID of clients that failed MAC authentication. Click the
arrow to view the pictorial graph of the Most Impacted clients. Click the number displayed on the
Client card, to view a detailed description of the impacted clients:

n Name—Name of the impacted client and link to the specific insight at the client context.
n MAC—MAC address of the client and link to the specific insight at the client context.
n Failures—Number of failures occurred in each client.
n Client OS—OS type of the device.

Clients with DHCP Server Connection Problems
The Clients had DHCP server connection problems insight can be accessed from the Global, Site,
Access Points, and Clients context. This insight provides information on excessive client to AP DHCP
failures observed in the network. This insight occurs when Wi-Fi clients attempt to acquire a DHCP IP
address multiple times but fails to do so. Clients had DHCP server connection problems insight is
categorized under connectivity since the users fail to get an IP address and are unable to connect to the
Wi-Fi network. It displays the following information:

n Insight Summary
n Time Series Graph
n Cards

Insight Summary
The insight summary provides the following details:

n Reason—Displays the possible causes for which the failure occurred.
n Recommendation—Displays the possible recommendation against each failure to resolve the same.
n Failures—Displays the exact number and percentage of failures that occurred against each failure

reason.

Time Series Graph
The time series graph displays the number of DHCP failures that occurred during the selected time
period. You can hover your mouse over each bar graph to see the exact number of failures.
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Cards
The cards vary based on the context that you access the insight from. Click one of the cards to view
further details:

Cards Context

Site Global

Server Global, Site, Device, Client

Access Point Global, Site, Client

Client Global, Site, Device

Table 55: Cards Context

Site
Lists the number of sites that experience DHCP server connection problems in the network. Click the
arrow to view a pictorial graph with the Most Impacted sites. Click the number displayed on the Site
card, to view a detailed description of the impacted sites:

n Site—Name of the site impacted by the insight and link to the specific insight at the site context.
n Failures—Number and percentage of failures occurred in each site.
n Total—Total number of DHCP requests.

Server
Lists the number of DHCP servers involved in this insight. Click the arrow to view the pictorial graph
of the Most Impacted sites. Click the number displayed on the Server card, to view a detailed
description of the impacted servers:

n Server IP—IP address of the server impacted by this insight.
n Failures—Number of failures occurred in each server.
n Total—Total number of DHCP requests.

Access Point
Lists the number and the details of the DHCP server connection problems observed in an AP. Click the
arrow to view a pictorial graph of the Most Impacted access points. Click the Access Point drop-
down list to view the following:

n SSID—Pictorial graph of the percentage of DHCP failures sorted by SSIDs.
n Model—Pictorial graph of the percentage of DHCP failures sorted by AP models.
n FW Version—Pictorial graph of the percentage of DHCP failures sorted by AP firmware version.

Click the number displayed on the Access Point card, to view the detailed description of the impacted
access points:

n AP Name—Name of the access points and link to the specific insight at the AP context.
n AP MAC—MAC address of the AP and link to the specific insight at the AP context.
n Failures—Number of failures occurred in each AP.
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n Total—Total number of DHCP requests.
n Serial—Serial number of the AP
n IP—IP address of each AP.
n Model—Model number of each AP.
n FW Version—Version of the firmware running on each AP.
n Site—Site name of the AP where the failure occurred.

Client
Lists the MAC address, host name, and auth ID of clients that failed DHCP handshake. Click the arrow
to view the pictorial graph of the Most Impacted clients. Click the number displayed on the Client card,
to view a detailed description of the impacted clients:

n Client Name—Name of the impacted client and link to the specific insight at the client context.
n Client MAC—MAC address of the client and link to the specific insight at the client context.
n Failures—Number of failures occurred in each client.
n Total—Total number of DHCP requests.
n Client OS—OS type of the device.

Clients with High Wi-Fi Security Key-Exchange Failures
The Clients had excessive Wi-Fi security key-exchange failures insight can be accessed from the
Global, Site, Access Points, and Clients context. This insight provides information on excessive Wi-Fi
security key-exchange failures observed in the network. When this failure occurs, users connecting to
Wi-Fi using PSK or 802.1X authentication, experience higher EAPOL Key exchange failures. This insight is
categorized under connectivity since the users are unable to connect to the WiFi network. This insight
displays the following information:

n Insight Summary
n Time Series Graph
n Cards

Insight Summary
The insight summary provides the following details:

n Reason—Displays the possible causes of Wi-Fi security key-exchange failure in the network.
n Recommendation—Displays the possible recommendation against each failure to resolve the same.
n Failures—Displays the exact number and percentage of failures that occurred against each failure

reason.

Time Series Graph
This time series bar graph displays the number of Wi-Fi security key-exchange failures that occurred in
the network during the selected time period. You can hover your mouse on each bar graph to see the
exact number of failures.
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Cards
The cards vary based on the context that you access the insight from. Click one of the cards to view
further details:

Cards Context

Site Global

Access Point Global, Site, Client

Client Global, Site, Device

Table 56: Cards Context

Site
Lists the number of sites that experienced excessive Wi-Fi security key-exchange failures in the network.
Click the arrow to view the pictorial graph of the Most Impacted sites. Click the number displayed on
the Site card, to view a detailed description of the impacted sites:

n Site—Name of the site impacted by the insight and link to the specific insight at the site context.
n Failures—Number and percentage of failures occurred in each site.
n Total—Total number of failures in each site.

Access Point
Lists the number of APs that experienced Wi-Fi security key-exchange failures in the network. Click the
arrow to view the pictorial graph of the Most Impacted access points. Click the Access Point drop-
down list to view the following:

n SSID: Pictorial graph of 4-way handshake authentication failures sorted by SSIDs.
n Model: Pictorial graph of 4-way handshake failures classified by AP models.
n FW Version: Pictorial graph of 4-way handshake failures classified by AP firmware versions.

Click the number displayed on the Access Point card to view a detailed description of the impacted
access points:

n AP Name—Name of the access points and link to the specific insight at the AP context.
n AP MAC—MAC address of the AP and link to the specific insight at the AP context.
n Failures—Number and percentage of failures occurred in each AP.
n Total—Total number of failures in each AP.
n Serial—Serial number of the AP.
n IP—IP address of the AP.
n Model—Model number of each AP.
n FW Version—Version of the firmware running on each AP.
n Site—Name of the site where the AP resides.
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Client
Lists the MAC Address, name, host name, and auth ID of clients that failed Wi-Fi security key-exchange
authentication. Click the arrow to view the pictorial graph of the Most Impacted clients. Click the
number displayed on the Client card, to view a detailed description of the impacted clients:

n Client Name—Name of the impacted client and link to the specific insight at the client context.
n Client MAC—MAC address of the client and link to the specific insight at the client context.
n Failures—Number and percentage of failures occurred in each client.
n Total—Total number of failures in each client.
n Client OS—OS type of the device.

Clients with High 802.1X Authentication Failures
The Clients had excessive 802.1X authentication failures insight can be accessed from the Global,
Site, Access Points, and Clients context. This insight provides information on excessive 802.1X
authentication failures observed in the network. It is categorized under connectivity since the users are
unable to connect to the WiFi network. This insight displays the following information:

n Insight Summary
n Time Series Graph
n Cards

Insight Summary
The insight summary provides the following details:

n Reason—Displays the possible causes for which the failure occurred.
n Recommendation—Displays the possible recommendation against each failure to resolve the same.
n Failures—Displays the exact number and percentage of failures that occurred against each failure

reason.

Time Series Graph
The time series graph displays the number of 802.1X authentication failures observed in the network
during the selected time period. You can hover your mouse over each bar graph to see the exact
number of failures.

Cards
The cards vary based on the context that you access the insight from. Click one of the cards to view
further details:

Cards Context

Site Global

Server Global, Site, Device, Client

Access Point Global, Site, Client

Table 57: Cards Context
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Cards Context

Client Global, Site, Device

Site
Lists the number of sites that experienced 802.1X authentication failures in the network. Click the arrow

to view a pictorial graph with the Most Impacted sites. Click the number displayed on the Site card,
to view a detailed description of the impacted sites:

n Site—Name of the site impacted by the insight and link to the specific insight at the site context.
n Failures—Number and percentage of failures occurred in each site.
n Total—Total number of 802.1X authentications in each site.

Server
Lists the number of servers that failed 802.1X authentication in the network. Click the arrow to view
the pictorial graph of the Most Impacted sites. Click the number displayed on the Server card, to view
a detailed description of the impacted servers:

n Server IP—IP address of each server.
n Failures—Number of 802.1X authentication failures in each server.
n Total—Total number of 802.1X authentications.

Access Point
Lists the number and the details of APs that failed 802.1X authentication in the network. Click the arrow

to view a pictorial graph of the Most Impacted access points. Click the Access Point drop-down list
to view the following:

n SSID—Pictorial graph of the percentage of 802.1X authentication failures sorted by SSIDs.
n Model—Pictorial graph of the percentage of 802.1X authentication failures sorted by AP models.
n FW Version—Pictorial graph of the percentage of 802.1X authentication failures sorted by AP

firmware version.

Click the number displayed on the Access Point card, to view the detailed description of the impacted
access points:

n AP Name—Name of the access points and link to the specific insight at the AP context.
n MAC—MAC address of the AP and link to the specific insight at the AP context.
n Failures—Number and percentage of failures occurred in each AP.
n Total—Total number of failures in each AP.
n Serial—Serial number of the AP.
n IP—IP address of the AP.
n Model—Model number of each AP.
n FW Version—Version of the firmware running on each AP.
n Site—Name of the site where the AP resides.

Client
Lists the MAC address, name, host name, and auth ID of clients that failed 802.1X authentication. Click
the arrow to view the pictorial graph of the Most Impacted clients. Click the number displayed on
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the Client card, to view a detailed description of the impacted clients:

n Client Name—Name of the impacted client and link to the specific insight at the client context.
n Client MAC—MAC address of the client and link to the specific insight at the client context.
n Failures—Number and percentage of failures occurred in each client.
n Total—Total number of failures in each client.
n Client OS—OS type of the device.

Clients with Captive Portal Authentication Problems
The Clients had problems authenticating with the Captive Portal insight can be accessed from the
Global, Site, Access Points, and Clients context. This insight provides information on captive portal
failures observed in the network. It is categorized under connectivity since the users are unable to
connect to the WiFi network. This insight displays the following information:

n Insight Summary
n Time Series Graph
n Cards

Insight Summary
The insight summary provides the following details:

n Reason—Displays the possible causes for which the failure occurred.
n Recommendation—Displays the possible recommendation against each failure to resolve the same.
n Failures—Displays the exact number and percentage of failures that occurred against each failure

reason.

Time Series Graph
The time series graph displays the number of client captive portal failures observed in the network
during the selected time period. You can hover your mouse over each bar graph to see the exact
number of failures.

Cards
The cards vary based on the context that you access the insight from. Click one of the cards to view
further details:

Cards Context

Site Global

Access Point Global, Site, Client

Client Global, Site, Device

Table 58: Cards Context

Site
Lists the number of sites that experienced captive portal failures in the network. Click the arrow to
view a pictorial graph of the Most Impacted sites. Click the number displayed on the Site card, to view
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a detailed description of the impacted sites:

n Site—Name of the site impacted by the insight.
n Failures—Number and percentage of failures occurred in each site.
n Total—Total number of captive portal authentication in each site.

Access Point
Lists the number and the details of APs that failed captive portal authentication in the network. Click the
arrow to view a pictorial graph of the Most Impacted access points. Click the Access Point drop-
down list to view the following:

n SSID—Pictorial graph of the percentage of captive portal authentication failures sorted by SSIDs.
n Model—Pictorial graph of the percentage of captive portal authentication failures sorted by AP

models.
n FW Version—Pictorial graph of the percentage of captive portal authentication failures sorted by AP

firmware version.

Click the number displayed on the Access Point card, to view the detailed description of the impacted
access points:

n AP Name—Name of the access points and link to the specific insight at the AP context.
n AP MAC—MAC address of the AP link to the specific insight at the AP context.
n Failures—Number and percentage of failures occurred in each AP.
n Total—Total number of failures in each AP.
n Serial—Serial number of the AP.
n IP—IP address of the AP.
n Model—Model number of each AP.
n FW Version—Version of the firmware running on each AP.
n Site—Name of the site where the AP resides.

Client
Lists the MAC address, name, host name, and auth ID of clients that failed captive portal authentication.
Click the arrow to view the pictorial graph of the Most Impacted clients. Click the number displayed
on the Client card, to view a detailed description of the impacted clients:

n Client Name—Name of the impacted client and link to the specific insight at the client context.
n Client MAC—MAC address of the client and link to the specific insight at the client context.
n Failures—Number and percentage of failures occurred in each client.
n Total—Total number of failures in each client.
n Client OS—OS type of the device.

AOS-CX Switch Ports with High Power-over-Ethernet
Problems
The CX Switch ports had a high number with Power-over-Ethernet problems insight can be
accessed from the Global, Site, and Switches context. This insight provides information on the switches
that have not received the required power from PoE devices connected to them. PoE issues occur in
switches when power is denied, or power is demoted from the device connected to them. It is
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categorized under availability since the impacted switches are unable to receive sufficient power. This
insight displays the following information:

n Time Series Graph
n Cards

Time Series Graph
In Global and Site context the time series graph displays the count of switches experiencing power
issues in the network during the selected time period. You can hover your mouse on each bar graph to
see the number of impacted switches during the selected time under each severity. In the Device
context, this graph displays the severity level of the selected switch experiencing power issues during
the selected time period.

Cards
The cards vary based on the context that you access the insight from. Click one of the cards to view
further details:

Cards Context

Site Global

Switch Global, Site

Wired Clients Global, Site

Table 59: Cards Context

Site
Lists the number of sites where switches have PoE issue. Click the arrow to view the pictorial graph
of the Most Impacted sites. Click the number displayed on the Site card, to view a detailed description
of the impacted sites:

n Site—Name of the site where the impacted switch resides and link to the specific insight at the site
context.

n Events—Number of events generated pertaining to PoE failures in each site.
n Ports—Number of ports for which power is denied.
n Switches—Number of switches for which power is denied.
n Impact (Minutes)—Amount of time (minutes) for which power is denied in each site.

Switch
Lists the number of switches that experience PoE issues in the network. Click the arrow to view the
pictorial graph of the Most Impacted switches. Click the Switch drop-down list to view the following:

n Switch Model—Pictorial graph of PoE issues classified by switch models.
n FW Version—Pictorial graph of PoE issues classified by switch firmware versions.

Click the number displayed on the Switch card to view a detailed description of the impacted switches:

n Switch Name—Name of the switch experiencing power issues and link to the specific insight at the
switch context.
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n Serial—Serial number of the impacted switch and link to the specific insight at the switch context.
n Events—Number of events generated pertaining to PoE failures in each switch.
n Wired Clients—Number of clients impacted by the PoE failures.
n Impact (Minutes)—Amount of time (minutes) for which power is denied in each switch.
n Stack ID—Stack ID of the impacted switch.
n Number of Events—Number of events generated pertaining to PoE failures in each switch.
n Model—Model number of the impacted switch.
n FW Version—Version of the firmware running on each switch.
n Site—Name of the site where the switch exists.

Wired Clients
Lists the MAC Address, name, host name, and auth ID of the clients connected to a switch that
experience PoE issues. Click the arrow to view the pictorial graph of the Most Impacted clients. Click
the Wired Clients drop-down list to view the following:

n Model—Pictorial graph of all the device types models connected to the impacted switch.
n Vendor—Pictorial graph of the device type vendors connected to the impacted switch.

Click the number displayed on the Wired Clients card to view a detailed description of the impacted
switches:

n Wired Client—Name of the client.
n Client MAC—MAC address of the client.
n Description—An overview of the connected devices, including the OS type, model, and version.
n Switch Name—Name of the impacted switch where the client resides and link to the specific insight

at the switch context.
n Serial—Serial number of the impacted switch and link to the specific insight at the switch context.
n Stack ID—Stack ID of the impacted switch where the client resides.
n Port Number—Port number of the switch the client device is connected to.
n Power Requested/Offered—PoE consumption for each client.
n Reason—Cause of the denied PoE power in each client.
n Status—Status of client.
n Model—Hardware model of the impacted switch where the client resides.
n Vendor—Vendor of the wired client.
n Site—Name of the site where the client resides.

AOS-S Switch Ports with High Power-over-Ethernet
Problems
The PVOS Switch ports had a high number with Power-over-Ethernet problems insight can be
accessed from the Global, Site, and Switches context. This insight provides information on the switches
that have not received the required power from PoE devices connected to them. PoE issues occur in
switches when power is denied, or power is demoted from the device connected to them. It is
categorized under availability since the impacted switches are unable to receive sufficient power. This
insight displays the following information:
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n Time Series Graph
n Cards

Time Series Graph
In Global and Site context the time series graph displays the count of switches experiencing power
issues in the network during the selected time period. You can hover your mouse on each bar graph to
see the number of impacted switches during the selected time under each severity. In the Device
context, this graph displays the severity level of the selected switch experiencing power issues during
the selected time period.

Cards
The cards vary based on the context that you access the insight from. Click one of the cards to view
further details:

Cards Context

Site Global

Switch Global, Site

Wired Clients Global, Site

Table 60: Cards Context

Site
Lists the number of sites where switches have PoE issue. Click the arrow to view the pictorial graph
of the Most Impacted sites. Click the number displayed on the Site card, to view a detailed description
of the impacted sites:

n Site—Name of the site where the impacted switch resides and link to the specific insight at the site
context.

n Events—Number of events generated pertaining to PoE failures in each site.
n Ports—Number of ports for which power is denied.
n Switches—Number of switches for which power is denied.
n Impact (Minutes)—Amount of time (minutes) for which power is denied in each site.

Switch
Lists the number of switches that experience PoE issues in the network. Click the arrow to view the
pictorial graph of the Most Impacted switches. Click the Switch drop-down list to view the following:

n Switch Model—Pictorial graph of PoE issues classified by switch models.
n FW Version—Pictorial graph of PoE issues classified by switch firmware versions.

Click the number displayed on the Switch card to view a detailed description of the impacted switches:

n Switch Name—Name of the switch experiencing power issues and link to the specific insight at the
switch context.

n Serial—Serial number of the impacted switch and link to the specific insight at the switch context.
n Events—Number of events generated pertaining to PoE failures in each switch.
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n Wired Clients—Number of clients impacted by the PoE failures.
n Impact (Minutes)—Amount of time (minutes) for which power is denied in each switch.
n Stack ID—Stack ID of the impacted switch.
n Number of Events—Number of events generated pertaining to PoE failures in each switch.
n Model—Model number of the impacted switch.
n FW Version—Version of the firmware running on each switch.
n Site—Name of the site where the switch exists.

Wired Clients
Lists the MAC Address, name, host name, and auth ID of the clients connected to a switch that
experience PoE issues. Click the arrow to view the pictorial graph of the Most Impacted impacted
clients. Click the Wired Clients drop-down list to view the following:

n Model—Pictorial graph of all the device types models connected to the impacted switch.
n Vendor—Pictorial graph of the device type vendors connected to the impacted switch.

Click the number displayed on the Wired Clients card to view a detailed description of the impacted
switches:

n Wired Client—Name of the client.
n Client MAC—MAC address of the client.
n Description—An overview of the connected devices, including the OS type, model, and version.
n Switch Name—Name of the impacted switch where the client resides and link to the specific insight

at the switch context.
n Serial—Serial number of the impacted switch and link to the specific insight at the switch context.
n Stack ID—Stack ID of the impacted switch where the client resides.
n Port Number—Port number of the switch the client device is connected to.
n Power Requested/Offered—PoE consumption for each client.
n Reason—Cause of the denied PoE power in each client.
n Status—Status of client.
n Model—Hardware model of the impacted switch where the client resides.
n Vendor—Vendor of the wired client.
n Site—Name of the site where the client resides.
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Managing APs

Managing APs

This section describes how to configure WLAN SSIDs, radio profiles, DHCP profiles, VPN routes, security
and firewall settings, uplink interfaces, logging servers on access points (APs).

APs offer an enterprise-grade networking solution with a simple setup. The WLAN solution with APs
supports simplified deployment, configuration, and management of Wi-Fi networks.

APs run the ArubaOS and Aruba Instant software that virtualizes ArubaMobility Controller capabilities on
802.11 APs and offers a feature-rich enterprise-grade Wi-Fi solution.

In an Instant deployment scenario, only the first AP or the conductor AP that is connected to a
provisioning network is configured. All other Instant APs in the same VLAN that join the conductor AP
inherit the configuration changes. The IAP clusters are configured through a common interface called
Virtual Controller. A Virtual Controller represents the combined intelligence of the IAPs in a cluster.

For more information on APs, see the following topics:

n Configuring IAPs
n Monitoring Access Points

Supported APs
Aruba Central On-Premises supports the following types of Aruba access points (APs).

n Instant APs—The Instant Access Point (IAP) based WLAN solution consists of a cluster of access points
in a Layer 2 subnet. The IAPs serve a dual role as both Virtual Controller (VC) and member APs. The
IAP WLAN solution does not require dedicated controller hardware and can be deployed through a
simplified setup process appropriate for smaller organizations, or for multiple geographically
dispersed locations without an on-site administrator. IAPs run on the Aruba Instant. Aruba Central
On-Premises supports both monitoring and management of IAPs. With Aruba Central On-Premises,
network administrators can configure, monitor, and troubleshoot IAP WLANs, upload new software
images, monitor devices, generate reports, and perform other vital management tasks from remote
locations.

n Campus APs—The Campus Access Point (CAP)s are used in private networks where APs connect over
private links (LAN, WLAN, WAN, or MPLS) and terminate directly on controllers. Campus APs are
deployed as part of the indoor campus solution in enterprise office buildings, warehouses, hospitals,
universities, and so on. Aruba Central On-Premises supports only onboarding and monitoring the
Campus APs.

n Remote APs—The Remote Access Point (RAP)s allow AP users at remote locations to connect to an
Aruba controller over the Internet. Since the Internet is involved, data traffic between the controller
and the remote AP is VPN encapsulated. That is the traffic between the controller and AP is
encrypted. Remote AP operations are supported on all of Aruba APs.
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Supported APs
Aruba Central On-Premises supports the following AP platforms and Aruba Instant software versions:

AP
Platform Installation Mode Minimum Supported Aruba

Instant Software Version
Latest Validated Aruba
Instant Software Version

AP-655 Indoor 8.10.0.1 8.11.1.0

AP-635 Indoor 8.9.0.0 8.11.0.0

AP-615 Indoor 8.11.0.0 8.11.0.0

AP-587EX Outdoor 8.10.0.0 8.11.0.0

AP-587 Outdoor 8.10.0.0 8.11.0.0

AP-585EX Outdoor 8.10.0.0 8.11.0.0

AP-585 Outdoor 8.10.0.0 8.11.0.0

AP-584 Outdoor 8.10.0.0 8.11.0.0

AP-577EX Outdoor 8.7.0.0 8.11.0.0

AP-577 Outdoor 8.7.0.0 8.11.0.0

AP-575EX Outdoor 8.7.0.0 8.11.0.0

AP-575 Outdoor 8.7.0.0 8.11.0.0

AP-574 Outdoor 8.7.0.0 8.11.0.0

AP-567EX Outdoor 8.7.1.0 8.11.0.0

AP-567 Outdoor 8.7.1.0 8.11.0.0

AP-565EX Outdoor 8.7.1.0 8.11.0.0

AP-565 Outdoor 8.7.1.0 8.11.0.0

AP-555 Indoor 8.6.0.0 8.11.0.0

AP-535 Indoor 8.6.0.0 8.11.0.0

AP-534 Indoor 8.6.0.0 8.11.0.0

AP-518 Indoor 8.7.0.0 8.11.0.0

AP-515 Indoor 8.6.0.0 8.11.0.0

AP-514 Indoor 8.6.0.0 8.11.0.0

AP-505H Indoor 8.7.0.0 8.11.0.0

AP-505 Indoor 8.6.0.0 8.11.0.0

Table 61: Supported AP Platforms
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AP
Platform Installation Mode Minimum Supported Aruba

Instant Software Version
Latest Validated Aruba
Instant Software Version

AP-504 Indoor 8.6.0.0 8.11.0.0

AP-503H Indoor 8.7.1.0 8.11.0.0

AP-503 Indoor 8.11.1.0 8.11.1.0

AP-387 Outdoor 8.6.0.0 8.10.0.0

AP-377EX Outdoor 8.6.0.0 8.11.0.0

AP-377 Outdoor 8.6.0.0 8.11.0.0

AP-375ATEX Outdoor 8.10.0.0 8.11.0.0

AP-375EX Outdoor 8.6.0.0 8.11.0.0

AP-375 Outdoor 8.6.0.0 8.11.0.0

AP-374 Outdoor 8.6.0.0 8.11.0.0

AP-367 Outdoor 6.5.4.8 8.11.0.0

AP-365 Outdoor 6.5.4.8 8.11.0.0

AP-345 Indoor 8.6.0.0 8.10.0.0

AP-344 Indoor 8.6.0.0 8.10.0.0

AP-318 Indoor 8.6.0.0 8.11.0.0

AP-303P Indoor 8.6.0.0 8.11.0.0

AP-303H Indoor 6.5.4.8 8.11.0.0

AP-303 Indoor 8.6.0.0 8.11.0.0

AP-203RP Indoor 6.5.4.8 8.10.0.0

AP-203R Indoor 6.5.4.8 8.10.0.0

AP-203H Indoor 6.5.4.8 8.10.0.0

IAP-335 Indoor 6.5.4.8 8.10.0.0

IAP-334 Indoor 6.5.4.8 8.10.0.0

IAP-325 Indoor 6.5.4.8 8.10.0.0

IAP-324 Indoor 6.5.4.8 8.10.0.0

IAP-315 Indoor 6.5.4.8 8.11.0.0

IAP-314 Indoor 6.5.4.8 8.11.0.0
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AP
Platform Installation Mode Minimum Supported Aruba

Instant Software Version
Latest Validated Aruba
Instant Software Version

IAP-305 Indoor 6.5.4.8 8.11.0.0

IAP-304 Indoor 6.5.4.8 8.11.0.0

IAP-277 Outdoor 6.5.4.3 8.6.0.0

IAP-275 Outdoor 6.5.4.3 8.6.0.0

IAP-274 Outdoor 6.5.4.3 8.6.0.0

IAP-207 Indoor 6.5.4.8 8.10.0.0

IAP-205H Indoor 6.5.4.8 6.5.4.8

IAP-205 Indoor 6.5.4.8 6.5.4.8

IAP-204 Indoor 6.5.4.8 6.5.4.8

RAP-109 Indoor 4.2.4.21 4.2.4.21

RAP-108 Indoor 4.2.4.21 4.2.4.21

RAP-3WN Indoor 4.2.4.21 4.2.4.21

RAP-3WNP Indoor 4.2.4.21 4.2.4.21

n IAP-203H, IAP-203R, IAP-203RP, IAP-207, IAP-324, IAP-325, IAP-334, IAP-335, IAP-344, IAP-345, IAP-387 IAPs
are no longer supported from Aruba Instant 8.11.0.0 onwards.

n IAP-214, IAP-215, IAP-224, IAP-225, IAP-228, IAP-274, IAP-275, and IAP-277 IAPs are no longer supported
from Aruba Instant 8.7.0.0 onwards.

n IAP-103, IAP-204, IAP-205, and IAP-205H IAPs are no longer supported from Aruba Instant 8.3.0.0
onwards.

n By default, AP-318, AP-374, AP-375, and AP-377 IAPs have Eth1 as the uplink port and Eth0 as the
downlink port. Aruba does not recommend you to upgrade these IAPs to Aruba Instant 8.5.0.0 or 8.5.0.1
firmware versions, as the upgrade process changes the uplink port from Eth1 to Eth0 port thereby making
the devices unreachable.

Supported Campus APs and Remote APs
Aruba Central On-Premises supports the following Campus AP and Remote AP platforms and ArubaOS
software versions:

AP
Platform

Minimum Supported ArubaOS
Software Versions

Latest Validated ArubaOS Software
Versions

AP-655 8.10.0.0 8.11.0.0

AP-635 8.9.0.0 8.11.0.0
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AP
Platform

Minimum Supported ArubaOS
Software Versions

Latest Validated ArubaOS Software
Versions

AP-615 8.11.0.0 8.11.0.0

AP-587EX 8.10.0.0 8.11.0.0

AP-587 8.10.0.0 8.11.0.0

AP-585EX 8.10.0.0 8.11.0.0

AP-585 8.10.0.0 8.11.0.0

AP-584 8.10.0.0 8.11.0.0

AP-577EX 8.7.0.0 8.11.0.0

AP-577 8.7.0.0 8.11.0.0

AP-575EX 8.7.0.0 8.11.0.0

AP-575 8.7.0.0 8.11.0.0

AP-574 8.7.0.0 8.11.0.0

AP-567EX 8.8.0.0 8.11.0.0

AP-567 8.8.0.0 8.11.0.0

AP-565EX 8.8.0.0 8.11.0.0

AP-565 8.8.0.0 8.11.0.0

AP-555 8.6.0.0 8.11.0.0

AP-535 8.6.0.0 8.11.0.0

AP-534 8.6.0.0 8.11.0.0

AP-518 8.7.0.0 8.11.0.0

AP-515 8.6.0.0 8.11.0.0

AP-514 8.6.0.0 8.11.0.0

AP-505HR 8.6.0.0 8.11.0.0

AP-505H 8.6.0.0 8.11.0.0

AP-505 8.6.0.0 8.11.0.0

AP-504 8.6.0.0 8.11.0.0

AP-503HR 8.8.0.0 8.11.0.0

AP-503H 8.8.0.0 8.11.0.0
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AP
Platform

Minimum Supported ArubaOS
Software Versions

Latest Validated ArubaOS Software
Versions

AP-503 8.11.1.0 8.11.1.0

AP-387 8.6.0.0 8.10.0.0

AP-377EX 8.6.0.0 8.11.0.0

AP-377 8.6.0.0 8.11.0.0

AP-375EX 8.6.0.0 8.11.0.0

AP-375 8.6.0.0 8.11.0.0

AP-374 8.6.0.0 8.11.0.0

AP-367 8.6.0.0 8.11.0.0

AP-365 8.6.0.0 8.11.0.0

AP-345 8.6.0.0 8.10.0.0

AP-344 8.6.0.0 8.10.0.0

AP-335 8.6.0.0 8.10.0.0

AP-334 8.6.0.0 8.10.0.0

AP-325 8.6.0.0 8.10.0.0

AP-324 8.6.0.0 8.10.0.0

AP-318 8.6.0.0 8.11.0.0

AP-315 8.6.0.0 8.11.0.0

AP-314 8.6.0.0 8.11.0.0

AP-305 8.6.0.0 8.11.0.0

AP-304 8.6.0.0 8.11.0.0

AP-303P 8.6.0.0 8.11.0.0

AP-303H 8.6.0.0 8.11.0.0

AP-303P 8.6.0.0 8.11.0.0

AP-277 8.6.0.0 8.10.0.0

AP-275 8.6.0.0 8.10.0.0

AP-274 8.6.0.0 8.10.0.0

AP-207 8.6.0.0 8.10.0.0
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AP
Platform

Minimum Supported ArubaOS
Software Versions

Latest Validated ArubaOS Software
Versions

AP-205H 8.6.0.0 8.10.0.0

AP-205 8.6.0.0 8.10.0.0

AP-204 8.6.0.0 8.10.0.0

AP-203RP 8.6.0.0 8.10.0.0

AP-203R 8.6.0.0 8.10.0.0

AP-203H 8.6.0.0 8.10.0.0

RAP-109 8.6.0.0 8.6.0.0

RAP-108 8.6.0.0 8.6.0.0

AP-103H 8.3.0.0 8.3.0.0

RAP-3WN 8.6.0.0 8.6.0.0

RAP-3WNP 8.6.0.0 8.6.0.0

n AP-615, AP-635, and AP-655 IAPs are Wi-Fi 6E capable APs that support 6 GHz radio band, in addition to
2.4 GHz and 5 GHz radio bands.

n The tri-radio feature is available only for AP-555. In the 5 GHz tab, the Radio 5 GHz (Secondary) data is
available only if the tri-radio mode is enabled. For more information, see About Tri-Radio Mode section
in the latest Aruba Central On-Premises user guide.

n For more information about Aruba's End-of-life policy and the timelines for hardware and software
products at the end of their lives, see: https://www.arubanetworks.com/support-services/end-of-life/

n Data sheets and technical specifications for the supported AP platforms are available at:
https://www.arubanetworks.com/products/networking/access-points/

Supported IAP Events
Aruba Central On-Premises provides an Events dashboard for viewing the events triggered from Instant
Access Point (IAP) devices.

The following table lists the IAP events that are supported in Aruba Central:

Event Description

AP IP Conflict IP Conflict detected for IP [Device IP] to MAC [Device MAC].

AP Crash AP crash detected on [AP Name].

Table 62: IAP Events

https://www.arubanetworks.com/support-services/end-of-life/
https://www.arubanetworks.com/products/networking/access-points/
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Event Description

AP Reboot [AP Name] has rebooted: Change in number of reboots detected (Detected: xxx, Expected:
xxx).

AP Upgrade
Failure

Upgrade failure.

AP Insufficient
Power Supply

AP [AP Name] at Site XX has received low POE power.

AP Modem
Plugged

Modem plugged.

AP Modem
Unplugged

Modem unplugged.

AP User Reboot User reboot triggered.

AP Tri-Radio
Enabled

Access point is online with tri-radio mode enabled.

AP Tri-Radio
Disabled

Access point is online with tri-radio mode disabled.

AP Thermal
Shutdown
Event

Thermal management enabled.

AP Thermal
Shutdown
Recovery Event

Thermal management disabled.

Radio Radar
Detected

802.11 Radar detected on channel [Channel].

Radio Radar
Cleared

802.11 Radar cleared on channel [Channel].

Radio Tx Hang 802.11 Radio Tx hanged on channel [Channel].

Radio Tx Clear 802.11 Radio Tx cleared on channel [Channel].

Radio 40MHz
Intolerance

40MHz Intolerance observed on channel [Channel].

Radio Cancel
40MHz
Intolerance

40MHz Intolerance cleared on channel [Channel].

Radio 40MHz
Align

40MHz aligned on channel [Channel].

Radio ARM
Interference

ARM Interference detected on channel [Channel].

Radio ARM
Invalid Channel

ARM invalid channel [Channel].
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Event Description

Radio ARM
Error Threshold
Exceeded

Radio errors threshold exceeded on channel [Channel].

Radio ARM
Noise
Threshold
Exceeded

Radio noise threshold exceeded.

Radio ARM
Empty Channel

ARM empty channel.

Radio ARM
Rogue
Containment
Triggered

Rogue containment triggered.

Radio ARM
Decreased
Power

Radio output power decreased to [EIRP] dBm.

Radio ARM
Increased
Power

Radio output power increased to [EIRP] dBm.

Radio RADAR
Turn Off Radio

Radar detected radio up.

Radio ARM
Turn On Radio

Radar detected radio down.

Radio ARM
Channel
Quality
Threshold
Exceeded

Radio channel quality threshold exceeded

Radio ARM
Dynamic BW

Channel width set to channel [Channel].

Radio ARM
Interference
CCA

Channel width set to channel [Channel].

Radio Freeze Radio stopped service.

Radio Un-
Freeze

Radio resumed service.

Mesh Link Up Mesh link established to Portal [Portal Device MAC].

Mesh Link
Down

Mesh link to Portal [Portal Device MAC] is down.

VPN IPSec
Tunnel Up

VPN IPSec Tunnel to Gateway peer [Peer Device Hostname] ([Peer Device IP]) is up.
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Event Description

VPN IPSec
Tunnel Down

VPN IPSec Tunnel to Gateway peer [Peer Device Hostname] ([Peer Device IP]) is down.

VPN GRE
Tunnel Up

VPN L3 GRE Tunnel to Gateway peer [Peer Device Hostname] ([Peer Device IP]) is up.

VPN GRE
Tunnel Down

VPN L3 GRE Tunnel to Gateway peer [Peer Device Hostname] ([Peer Device IP]) is down.

WLAN SSID
Scheduled
Active

SSID [SSID] scheduled activation.

WLAN SSID
Scheduled De-
active

SSID [SSID] scheduled deactivation.

Configuring IAPs
This section describes how to configure WLAN SSIDs, radio profiles, DHCP profiles, VPN routes, security
and firewall settings, uplink interfaces, and logging servers on Instant APs (IAPs).

For more information on IAP configuration, see the following topics:

n Configuring Device Parameters
n Configuring Network Profiles on IAPs
n Configuring Time-Based Services for Wireless Network Profiles
n Configuring ARM and RF Parameters on IAPs
n Configuring IDS Parameters on IAPs
n Configuring Authentication and Security Profiles on IAPs
n Configuring IAPs for VPN Services
n Configuring DHCP Pools and Client IP Assignment Modes on IAPs
n Configuring Services
n Configuring Uplink Interfaces on IAPs
n Configuring Enterprise Domains
n Configuring Syslog and TFTP Servers for Logging Events
n Mapping IAP Certificates

Getting Started with AP Deployments
Before you get started with the deployment operations, browse through the list of Supported APs in
Aruba Central On-Premises.

The UI-based provisioning of APs is available for AP Foundation licenses.

In Aruba Central On-Premises, you can only configure Instant APs. However, monitoring is supported for
Campus APs, Remote APs, and Instant APs.

Deploying APs in Aruba Central
The following figure illustrates a basic AP deployment and WLAN setup workflow in Aruba Central.
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Figure 56 Getting Started—APs

To deploy the AP and to configure a basic WLAN setup, complete the following steps:

1. On-board

To manage APs from Aruba Central On-Premises, you should on-board the APs to the device
inventory and assign a valid license. For more information about on-boarding devices and
assigning licenses to devices, see the Managing Devices and Subscriptions.

You can access Aruba Central On-Premises from the HPE GreenLake account homel. For more
information, see Getting Started with Aruba Central On-Premises.

2. Provision

The devices provisioned in your Aruba Central On-Premises account are listed on the
Organization > Network Structure > Device Preprovisioning page. For more information
about pre-provisioning the devices, see Getting Started with Aruba Central On-Premises.

Using Aruba Central On-Premises, you can manage the devices as follows:
n Create groups and assign devices to groups. For more information about assigning devices to

groups, see Assigning Devices to Groups.
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n Create sites and assign devices to sites. For more information about assigning devices to sites,
see Assigning Sites.

n Create labels and assign labels to devices. For more information about assigning labels to
devices, see Assigning Labels.

3. Configure

The following are the basic WLAN configuration steps to deploy an IAP. For more information
about advanced IAP configuration and deployment steps, see Configuring IAPs.
n The initial setup requires you to specify the country code for the country in which the AP

operates. For more information about setting a country code for the AP, see Setting Country
Code.

n On Access Points > Config > Show Advanced > System tab, you can configure the system
parameters for an IAP. For more information about configuring general system parameters for
an IAP in Aruba Central On-Premises, see Configuring Device Parameters .

n A wireless network profile allows you to establish a secure network connection between the
IAP and the client. You can create a wireless SSID network profile on Access Points > Config >
Show Advanced > WLANs tab. For more information about creating a wireless network
profile in Aruba Central On-Premises, see Configuring Device Parameters .

n On Access Points > Config > Show Advanced > WLANs tab, you can create a secure wireless
network profile and access rules for the guest users to use the enterprise Wi-Fi network. For
more information about configuring a guest network profile, see Configuring Wireless
Networks for Guest Users on IAPs.

n After configuring the network profile in WLANs tab, you can review the configuration changes
for the devices provisioned. For more information about auditing the configuration changes,
see Verifying Device Configuration Status.

4. Monitor

Following are the steps to monitor the APs in Aruba Central On-Premises:
n The AP dashboard and the health bar provides the overall health of the devices configured in

Aruba Central On-Premises. For more information about monitoring the APs in Aruba Central
On-Premises, see Monitoring Access Points.

n The Summary tab in the AP dashboard provides the device details, network information, radio
details including the topology of clients connected to each radio, and the health status of the
AP in the network. For more information about AP summary page, see Viewing the Summary
Tab.

n The Clients page displays the client summary details, AI Insights, and client sessions details for
the client. For more information about client summary details, see Client Details.

n On Analyze > Alerts & Events page, you can configure various types of alerts in Aruba Central
On-Premises. For more information about configuring alerts and events, see Alerts and Events.

n On Analyze > Reports page, you can configure and view various types of reports in Aruba
Central On-Premises. For more information about creating and viewing reports, see Reports .

5. Maintain

Following are the steps to maintain the APs in Aruba Central On-Premises:
n On Maintain > Firmware dashboard page, you can view the AP firmware details, upgrade the

device firmware to the latest version supported, and set firmware compliance. For more
information about steps to upgrade the device to latest firmware, see Upgrading Device
Firmware.
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n On Analyze > Audit Trail page, you can view the logs generated for device management,
configuration, and user management events triggered in Aruba Central On-Premises. For more
information about audit logs, see Viewing Audit Trail.

n On Analyze > Tools menu, you can troubleshoot and diagnose the device and network issues
in Aruba Central On-Premises. For more information about troubleshooting, see Using
Troubleshooting Tools.

Configuring IAPs Using Templates
Templates in Aruba Central On-Premises refer to a set of configuration commands that can be used by
the administrators for provisioning devices in a group. Configuration templates enable administrators
to apply a set of configuration parameters simultaneously to multiple devices in a group and thus
automate access point (AP)  deployments.

To minimize configuration errors and troubleshoot device-specific configuration issues, Aruba recommends
that the device administrators familiarize themselves with the CLI configuration commands available on Aruba
IAPs.

For template-based provisioning, IAPs must be assigned to a group with template-based configuration
method enabled.

To create a template for the IAPs in a template group, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the template group under
Groups.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click the Config icon.

The tabs to configure APs in a template group are displayed.

4. In the Templates table, click + to add a new template.

The Add Template pop-up window is displayed.

5. Under Basic Info, enter the following information:
n Template Name—Enter the template name.
n Model—Set the model parameter to ALL.
n Version—Set the model parameter to ALL.

6. Under Template, add the CLI script content.
7. Check the following guidelines before adding content to the template:

n Ensure that the command text indentation matches the indentation in the running
configuration.

n The template allows multiple per-ap-settings blocks. The template must include the per-ap-
settings %_sys_lan_mac% variable. The per-ap-settings block uses the variables for each AP.
The general VC configuration uses variables for conductor AP to generate the final
configuration from the provided template. Hence, Aruba recommends that you upload all
variables for all devices in a cluster and change values as required for individual AP variables.

n You can obtain the list of variables for per-ap-settings by using the show amp-audit

command.

The following example shows the list of variables for per-ap-settings.
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(Instant AP)# show amp-audit | begin per-ap

per-ap-settings 70:3a:0e:cc:ee:60

hostname EE:60-335-24

rf-zone bj-qa

ip-address 10.65.127.24 255.255.255.0 10.65.127.1 10.65.6.15 ""

swarm-mode standalone

wifi0-mode access

wifi1-mode access

g-channel 6+ 21

a-channel 140 26

uplink-vlan 0

g-external-antenna 0

a-external-antenna 0

ap1x-peap-user peap22 282eaf1077b8d898b91ec41b5da19895

The commands in the template are case-sensitive.

IF ELSE ENDIF conditions are supported in the template. If the template text includes the if
condition, % sign is required at the beginning and the end of the text. For example, %if guest%.

The following example shows the template text with the IF ELSE ENDIF condition.

wlan ssid-profile %ssid_name%

%if disable_ssid=true%

disable-ssid

%endif%

%if ssid_security=wpa2%

opmode wpa2-aes

%else%

opmode opensystem

%endif%

Templates also support nesting of the IF ELSE END IF condition blocks.

The following example shows how to nest such blocks:

%if condition1=true%

routing-profile

route 10.10.0.0 255.255.255.0 10.10.0.255

%if condition2=true%

routing-profile

route 10.20.0.0 255.255.255.0 10.20.0.255

%else%

routing-profile

route 10.30.0.0 255.255.255.0 10.30.0.255

%endif%

%else%

routing-profile

route 10.40.0.0 255.255.255.0 10.40.0.255

%if condition3=true%

routing-profile

route 10.50.0.0 255.255.255.0 10.50.0.255

%else%

routing-profile

route 10.60.0.0 255.255.255.0 10.60.0.255

%endif%

%endif%
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For profile configuration CLI text, for example, vlan, interface, access-list, ssid and so on, the
first command must start with no white space. The subsequent local commands in given
profile must start with at least one initial space (' ') or indented as shown in the following
examples:

Example 1

wlan auth-server %auth_server_name%

ip %auth_server_ip%

port 1812

acctport 1813

%if auth_server_key%

key %auth_server_key%

%else%

key 123456

%endif%

Example 2

%if vlan_id1%

vlan %vlan_id1%

%if vlan_id1=1%

ip address dhcp-bootp

%endif%

no untagged %_sys_vlan_1_untag_command%

exit

%endif%

To comment out a line in the template text, use the pound sign (#). Any template text
preceded by # is ignored when processing the template.

To allow or restrict APs from joining the Instant Access Point (IAP) cluster, Aruba Central uses
the _sys_allowed_ap system-defined variable. Use this variable only when allowed APs
configuration is enabled. For example, _sys_allowed_ap: "a_mac, b_mac, c_mac". Use this
variable only once in the template.

8. Click OK.

Viewing APs Configuration Tabs
Aruba Central On-Premises now constantly displays the default tabs under the Show Advanced and
Hide Advanced options in the Devices > Access Points page. When you click the Show Advanced or
Hide Advanced option, a set of default configuration tabs are displayed. The respective default tabs
under these two options are still displayed when you navigate out of the page, and visit the same page
next time.

Following are the default tabs displayed when you navigate to Devices > Access Points page and click
the Config icon:

n WLANs
n Access Points
n Radios
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When you click the Show Advanced option, the following tabs are displayed:

n WLANs
n Access Points
n Radios
n Interfaces
n Security
n VPN
n Services
n System
n IoT
n Configuration Audit

To view the default tabs, click Hide Advanced.

Configuring Device Parameters
To configure device parameters on an Instant AP (IAP), complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select an IAP group in the filter:

a. Set the filter to a group containing at least one IAP.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

n To select an IAP in the filter:
a. Set the filter to Global or a group containing at least one IAP.
b. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

c. Click an IAP listed under Device Name.

The dashboard context for the IAP is displayed.

d. Under Manage, click Devices > Access Point.

2. Click the Config icon.

The tabs to configure the IAPs are displayed.

3. Click the Access Points tab.

The Access Points page is displayed.

4. To edit an IAP, select an IAP in the Access Points table, and then click the edit icon.

5. Configure the parameters described in the Table 63.

6. Click Save Settings and then reboot the IAP.

The following table lists the access points configuration parameters.
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UI Parameters Description

Basic Info Name Configures a name for the IAP.
For IAPs running 8.7.0.0 or later versions, you can enter up to 128 ASCII
or non-ASCII characters. For IAPs running 8.6.0.0 or earlier versions, you
can enter up to 32 ASCII or non-ASCII characters.

AP Zone Configures the IAP zone.
For IAPs running firmware versions 6.5.4.7 or later, and 8.3.0.0 or later,
you can configure multiple AP zones by adding zone names as comma
separated values.
Aruba recommends that you do not configure zones in both SSID and in
the Per AP settings of an IAP. If the same zones are configured in SSID
and Per AP settings, APs may broadcast the SSIDs, but if the SSIDs and
Per AP settings have different zones configured, it may lead to a
configuration error. For more information on AP zones, see Aruba Instant
User Guide.

RF Zone Allows you to create an RF zone for the AP.
With RF zone, you can configure different power transmission settings
for APs in different zones or sections of a deployment site. For example,
you can configure power transmission settings to make Wi-Fi available
only for the devices in specific areas of a store.
You can also configure separate RF zones for the 2.4 GHz and 5 GHz
radio bands for the IAPs in a cluster. For more information, see
Configuring Radio Parameters on page 398.
Aruba recommends that you configure RF zone for either individual AP
or for the cluster. Any discrepancy in the RF zone names may lead to
configuration errors.

Swarm Mode Allows you to set one of the following operation modes:
n Cluster—Allows an IAP to operate in the cluster mode. When an

Instant AP operates in the cluster mode, it can form a cluster with
other virtual controller Instant APs in the same VLAN.

n Standalone—Allows an IAP to operate in the standalone mode.
When an Instant AP operates in the standalone mode, it cannot join a
cluster of Instant APs even if the Instant AP is in the same VLAN.

n Single-AP—Allows an Instant AP to operate in the single AP mode. It
is a type of Standalone AP deployment with additional security rules
to prevent local access to AP management. In the single AP mode,
the management access of the AP is exclusively reserved to the
remote management platform and is facilitated through a secure
tunnel between the AP and the management platform. The Local
WebUI and SSH access to the AP through the uplink port is disabled.
Additionally, the AP will not send or receive management frames
such as mobility packets, roaming packets, and hierarchy beacons
through the uplink port.

NOTE: After changing the AP operation mode, ensure that you reboot
the IAP.

LACP Mode Allows you to set one of the following LACP modes:
n Active—Allows you to enable the LACP on an IAP. In this mode, both

the ethernet ports on the Instant AP forms a static LAG.

Table 63: Access Points Configuration Parameters
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n Passive—Allows you to set the LACP on an IAP in a passive mode.
n Disabled—Allows you to disable the LACP on an IAP.

Preferred
Conductor

Turn on the toggle switch to provision the IAP as a conductor IAP.
After provisioning the IAP as a conductor IAP, ensure that you reboot the
IAP.

IP Address for
Access Point

Select one of the following options:
n Get IP Address from DHCP server—Allows IP to get an IP address

from the DHCP server. By default, the IAPs obtain IP address from a
DHCP server.

n Static—You can also assign a static IP address to the IAP. To specify a
static IP address for the IAP, complete the following steps:
o Enter the new IP address for the IAP in the IP Address text-box.
o Enter the subnet mask of the network in the Netmask text-box.
o Enter the IP address of the DNS server in the DNS Server text-box.
o Enter the domain name in the Domain Name text-box.

NOTE: You can configure up to two DNS servers separated by a comma.
If the first DNS server goes down, the second DNS server takes control of
resolving the domain name.

Radio Flexible Dual
Band

Configures a flexible dual radio band mode on AP-615 access points.
Select one of the following:
n 5 GHz and 2.4 GHz—Acts as two radios (interfaces), one operating

on 5 GHz band, and the other on the 2.4 GHz band. By default, the
flexible radio is set to this mode.

n 5 GHz and 6 GHz—Acts as two radios (interfaces), one operating on
5 GHz band, and the other on the 6 GHz band.

n 2.4 GHz and 6 GHz—Acts as two radios (interfaces), one operating
on 2.4 GHz band, and the other on the 6 GHz band.

Dual 5G Mode Select the Dual 5G Mode check-box to enable the dual 5G mode. In the
Dual 5G Mode, the Mode remains as Access and is non-editable. The
Dual 5G Mode is only supported on AP-344 and AP-345 running on
Aruba InstantOS 8.3.0.0. For more information, see Configuring Dual 5
GHz Radio Bands on an IAP.

Split Radio Select the Split Radio check-box to allow the radios of the IAP to operate
in the tri-radio mode. The Split Radio is only supported on AP-555
access points running Aruba InstantOS 8.5.0.0. For more information,
see About Tri-Radio Mode.

Enable Radio Select the Enable Radio check-box under 2.4GHz Band and 5GHz Band
to enable and disable the radio.

Mode From the Mode drop-down list, select any of the following options:
n Access—In this mode, the IAP serves clients, while also monitoring

for rogue IAPs in the background.
n Monitor—In this mode, the IAP acts as a dedicated monitor,

scanning all channels for rogue IAPs and clients.
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n Spectrum—In this mode, the IAP functions as a dedicated full-
spectrum RF monitor, scanning all channels to detect interference,
whether from the neighboring IAPs or from non-Wi-Fi devices such as
microwaves and cordless phones.

To get accurate monitoring details and statistics, it is highly
recommended to reboot the IAPs once the IAPs are toggled from the 2.4
or 5 GHz mode to dual 5 GHz radio mode or vice-versa.
The access, spectrum, and monitor mode of the radios of an access point
is available for Foundation and Advanced licenses for APs.

Adaptive radio
management
assigned

You can configure a radio profile on an Instant AP either manually or by
configuring the Adaptive radio management assigned option.
Adaptive Radio Management (ARM) feature is enabled on Aruba
Central by default. It automatically assigns appropriate channel and
power settings for the IAPs.

Administrator
assigned

You can also assign an administrator by using the Administrator
assigned option and selecting the number of channels in the Channel
drop-down list. In the Transmit Power field, enter the signal strength
measured in dBm.

Installation
Type

Installation Type Configure the Installation Type of the Instant AP. The Installation Type
drop-down consists of the following options:
n Default—Select this option to change the installation type to the

default mode.
n Indoor—Select this option to change the installation type to the

indoor mode.
n Outdoor—Select this option to change the installation type to the

outdoor mode.
The options in the Installation Type drop-down are listed based on the
Instant AP model.

Uplink Uplink
Management
VLAN

The uplink traffic on Instant AP is carried out through a management
VLAN. However, you can configure a non-native VLAN as an uplink
management VLAN. After an Instant AP is provisioned with the uplink
management VLAN, all management traffic sent from the Instant AP is
tagged to the management VLAN.
To configure a non-native uplink VLAN, click Uplink and specify the VLAN
in Uplink Management VLAN

Eth0 Mode Allows you to change the Eth0 bridging mode in your wired network. The
Eth0 Mode drop-down consists of the following options:
n Uplink—Select this option to change the Eth0 bridging mode to the

uplink port.
n Downlink—Select this option to change the Eth0 bridging mode to

the downlink port.

Eth1 Mode Allows you to change the Eth1 bridging mode in your wired network. The
Eth1 Mode drop-down consists of the following options:
n Default—Select this option to change the Eth1 bridging mode to the

default port.
n Uplink—Select this option to change the Eth1 bridging mode to the

uplink port.
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n Downlink—Select this option to change the Eth1 bridging mode to
the downlink port.

USB Port Select the check box to enable the USB port if you do not want to use the
cellular uplink or 3G/4G modem in your current network setup.

USB Power
Override

Select the check box to enable the USB power override.
This parameter is disabled by default.

PEAP User Create the PEAP user credentials for certificate based authentication.
Enter the user name, password, and retype password in the Username,
Password, and Retype Password field for creating the PEAP user.

Mesh Mesh enable Select the Mesh enable check-box to allow mesh access points to form
mesh network. The mesh feature ensures reliability and redundancy by
allowing the network to continue operating even when an Instant AP is
non-functional or if the device fails to connect to the network. For more
information, see Aruba Mesh Network and Mesh IAP

Clusterless
mesh name

Enter the name of mesh access points that do not belong to any cluster.
The Clusterless mesh name field is disabled when the Mesh enable
option is enabled.

Clusterless
mesh key

Enter the key of the mesh access points that do not belong to any
cluster. The Clusterless mesh key field is disabled when the Mesh
enable option is enabled.

Retype Re-enter the clusterless mesh key. The Retype is disabled when the
Mesh enable option is enabled.

Mesh mobility
RSSI threshold

Fast roaming is triggered on a mobility mesh point when the RSSI of the
parent is lower than the threshold value.
Enter the threshold value either in number between 10—50, high, or low.

External
Antenna

Antenna Gain Enter the Antenna Gain values in dBi for the 2.4 GHz Antenna Gain
and the 5 GHz Antenna Gain sections. For more information, see
Configuring External Antenna on page 338

Antenna
Polarization
Type

From the Antenna Polarization Type drop-down list, select any one of
the following:
n co-polarization—Select this option for the polarization of both the

transmitting and receiving antenna to be same.
n cross-polarization—Select this option for the polarization of both

the transmitting and receiving antenna to be different.
The integrated antenna of the wireless bridge sends a radio signal that is
polarized in a particular direction. The receive sensitivity of the antenna
is also higher for radio signals that have the same polarization. To
maximize the performance of the wireless link, both antennas must be
set to the same polarization direction.

Setting Country Code
The initial Wi-Fi setup of an Instant Access Point (IAP) requires you to specify the country code for the
country in which the IAP operates. This configuration sets the regulatory domain for the radio
frequencies that the IAP uses. The available 20 MHz, 40 MHz, or 80 MHz channels are dependent on the
specified country code.
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Country Code Configuration in Aruba Central On-Premises from UI
If you provision a new IAP without the country code, Aruba Central On-Premises exhibits the behavior
described in the following table.

Country Code Configured
at IAP

Country Code Configured
in Group Behavior

No Yes The country code of the group is pushed to
the newly added IAP.

No No Aruba Central On-Premises displays the
Country Code not set. Config not
updated message in Audit Trail. A
notification is also displayed at the bottom
of the main window to set the country
code of the new IAP.
To set the country code, perform the
following actions:

1. Click Set Country Code now link on
the notifications pane.
The Set Country Code pop up is
displayed.
2. In the Device(s) without country
code table, click the edit icon.
3. Specify a country code from the
Country Code drop-down list.
4. Click Save.

Table 64: IAP Provisioned To Aruba Central

If an IAP has a country code and joins Aruba Central On-Premises using ZTP configuration, then the country
code of the IAP is retained. In this case, Aruba Central On-Premises will not push the group country code.

Setting Country Code at a Group Level
To set the country code of the IAP at the group level, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one IAP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

3. Click the Config icon.

The default tabs to configure the virtual controller are displayed.

4. Click Show Advanced to view the advanced configuration options.
5. Click the System tab.

The System details page is displayed.

6. Expand the General accordion.
7. In the Set Country code for group drop-down list, select the country code for the IAP.
8. Click Save Settings and then reboot the IAP.
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n By default, the value corresponding to the Set Country code for group field is empty. This indicates that
any IAP with different country codes can be a part of the group.

n When the Set Country code for group field is set, the field cannot revert to the default value. When the
country code of the group is changed, the country code of the already connected IAP also will be updated.

Setting Country Code at a Device Level
To set the country code of the IAP at the device level, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one IAP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

3. In the Controller column, click the virtual controller link to navigate to the Access Points > List
view of the virtual controller.

When you click the virtual controller link in the Virtual Controller column, the dashboard context for
the virtual controller is dispalyed.

4. Click the Config icon.

The default tabs to configure the virtual controller are displayed.

5. Click Show Advanced to view advanced configuration options.
6. Click the System tab.

The System details page is displayed.

7. Expand the General accordion.
8. In the Virtual Controller table, select a virtual controller and then click the edit icon.
9. In the Edit IP Address window, select the country code from the Country Code drop-down list.

10. Click OK.
11. Click Save Settings and then reboot the IAP.

n By default, the value corresponding to the Country code is the country code set at the group level which
can be then modified at the device level from the drop-down list. The country code of the IAP will always
be the most recently set country code at the group level or device level.

n If there is a discrepancy in the country code configuration, Aruba Central On-Premises displays it as an
override in the Configuration Audit page.

Country Code Configuration at Group Level from API
Aruba Central On-Premises provides an option to set and get the country code at group level through
the APIs in API Gateway.

To set or get the country code at group level through API, complete the following steps:

1. In the Aruba Central On-Premises app, under Maintain, click Organization > Platform
Integration. Click API Gateway.
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The API Gateway page is displayed.

2. Click the Authorized Apps & Tokens tab and generate a token key.

The token key is valid only for 2 hours from the time it was generated.

3. Download and copy the generated token.
4. In the All Published APIs window, click the URL link listed under the Documentation column.

The Central Network Management APIs page is displayed.

5. On the left navigation pane, select Configuration from the URL drop-down list.
6. Paste the token key in the Token field and press enter.
7. Click NB UI Group Configuration.

 The following options are displayed:
n Set country code at group level ([PUT]/configuration/v1/country)—This API allows to set

country code for multiple groups at once. Aruba Central On-Premises currently allows country
codes of up to 50 IAP device groups to be configured simultaneously. To set the country codes
of multiple groups, enter the group names and country code as inputs corresponding to the
groups and country labels respectively in the script { "groups": [ "string" ], "country": "string" }
within the set_ group_config_ country_ code text box.

n Get country code set for group([GET]/configuration/v1/{group}/country)—This API allows
to retrieve the country code set for a specific IAP group. To get the country code information of
the IAP group, enter the name of the group for which the country code is being queried
corresponding to the country label in the script { "country": "string"} within the group text
box.

The APIs for setting and retrieving country code information are not available for the IAP devices deployed in
template groups.

The following are the response messages displayed in the Set country code at group level and Get
country code set for group sections.

Set country code
at group level Get country code set for group

n 201 - Successful
operation

n 400 - Bad
Request

n 401 -
Unauthorized
access,
authentication
required

n 403 - Forbidden,
do not have write
access for group

n 400 - Bad Request
n 401 - Unauthorized access authentication required
n 403 - Forbidden, do not have read access for group
n 413 - Request-size limit exceeded
n 417 - Request-size limit exceeded
n 429 - API Rate limit exceeded
n 500 - Internal Server Error
n 503 - Service unavailable, configuration update in progress

Table 65: Response Messages
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Set country code
at group level Get country code set for group

n 413 - Request-
size limit
exceeded

n 417 - Request-
size limit
exceeded

n 429 - API Rate
limit exceeded

n 500 - Internal
Server Error

n 503 - Service
unavailable,
configuration
update in
progress

For more information about APIs, see https://app1-apigw.central.arubanetworks.com/swagger/central.

Configuring Systems
This section describes how to configure the General, Administrator, Time-Based Services, DHCP, Layer-3
Mobility, Enterprise Domains, Logging, SNMP, WISPr, Proxy, and Named VLAN Mapping parameters on
an Instant Access Point (IAP).

n Configuring System Parameters for an IAP
n Configuring Users Accounts for the IAP Management Interface
n Configuring Mesh for Multiple Radios
n Configuring Time-Based Services for Wireless Network Profiles
n Configuring DHCP Pools and Client IP Assignment Modes on IAPs
n Mobility and Client Management
n Configuring Enterprise Domains
n Configuring Syslog and TFTP Servers for Logging Events
n Configuring SNMP Parameters
n Supported Authentication Methods
n Configuring HTTP Proxy on an IAP
n Configuring VLAN Name and VLAN ID

Configuring VLAN Name and VLAN ID
Aruba Central On-Premises allows you to map VLAN name to a VLAN ID for the ease of identifying the
existing VLANs.

To map a VLAN name to a VLAN ID, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one IAP.

The dashboard context for the group is displayed.

https://app1-apigw.central.arubanetworks.com/swagger/central
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2. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the IAPs are displayed.

4. Click Show Advanced.
5. Click the System tab.

The System page is displayed.

6. Expand the Named VLAN Mapping accordion.
7. Click the + icon in the VLAN Name to VLAN ID Mapping pane.

The VLAN Name to VLAN ID Mapping window is displayed.

8. In the VLAN Name to VLAN ID Mapping window, enter the VLAN Name and VLAN ID.
9. Click OK.

The VLAN Name to VLAN ID Mapping table in the Named VLAN Mapping section lists all the
mapped VLAN.

You can find the Named VLAN Mapping feature applied in the following fields of corresponding UI
pages of Aruba Central On-Premises:

n The VLAN ID field in the VLANs tab, when for when Custom for Instant AP Assigned and Static for
External DHCP server assigned is selected during WLAN SSID creation. For more information, see
Creating a Wireless Network Profile.

n The VLAN ID field in the VLANs tab, when Custom for Instant AP Assigned and Static for External
DHCP server assigned is selected during wired port profile creation. For more information, see
Configuring Wired Port Profiles on IAPs.

n The Access rules page in the Interfaces > Access tab and the WLANs > Access tab, when you add
rules for selected roles. Select VLAN Assignment as the rule type in the Access rules page to find
the mapped VLAN name in the VLAN ID field.

You can also map VLAN ID to a VLAN name when you customize the Client VLAN Assignment configuration in
VLANs tab during network profile creation. For more information, see VLANs Parameters.

Points to Remember

n The maximum number of Named VLAN ID Mapping allowed in Aruba Central On-Premises is 32.
n VLAN mapping cannot be performed if the VLAN name does not exist.
n The VLAN mapping record is deleted from the VLAN Name to VLAN ID Mapping table when the

VLAN name is deleted.
n You can only map a single VLAN id to a VLAN name.
n The VLAN name field is not case-sensitive.

Configuring External Antenna
If the Instant Access Point (IAP) has external antenna connectors, you need to configure the transmit
power of the system. The configuration must ensure that the system’s EIRP is in compliance with the
limit specified by the regulatory authority of the country in which the IAP is deployed. You can also
measure or calculate additional attenuation between the device and antenna before configuring the
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antenna gain. To know, if the IAP device supports external antenna connectors, see the Installation
Guide that is shipped along with the IAP device.

EIRP and Antenna Gain
The following formula can be used to calculate the EIRP limit related RF power based on selected
antennas (Antenna Gain) and feeder (Coaxial Cable Loss).

EIRP = Tx RF Power (dBm)+GA (dB) - FL (dB)

The following table describes the EIRP and antenna gain formula.

Formula
Element Description

EIRP Limit specific for each country of deployment.

Tx RF
Power

RF power measured at RF connector of the unit.

GA Antenna gain

FL Feeder loss

Table 66: Formula Variable Definitions

Configuring Antenna Gain
To configure antenna gain for IAPs with external connectors, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select an IAP group in the filter:

a. Set the filter to a group containing at least one IAP.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

n To select an IAP in the filter:
a. Set the filter to Global or a group containing at least one IAP.
b. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

c. Click an IAP listed under Device Name.

The dashboard context for the IAP is displayed.

d. Under Manage, click Devices > Access Point.

2. Click the Config icon.

The tabs to configure the IAPs are displayed.

3. Click the Access Points tab.

The Access Points page is displayed.

4. To edit an IAP, select an IAP in the Access Points table, and then click the edit icon.
5. Click the External Antenna tab.
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6. Enter the Antenna Gain values in dBi for the 2.4 GHz Antenna Gain and the 5 GHz Antenna
Gain.

7. From the Antenna Polarization Type drop-down list, select one of the following options:
n co-polarization—Select this option for the polarization of both the transmitting and receiving

antenna to be same.
n cross-polarization—Select this option for the polarization of both the transmitting and

receiving antenna to be different.

8. Click Save Settings.

After configuring the external antenna parameters, ensure that you reboot the IAP.

Configuring Dual 5 GHz Radio Bands on an IAP
Aruba Central On-Premises provides an option to retrieve the radio numbers of Instant Access Point
(IAP) through the APIs. It also provides an option to filter IAP details using radio numbers in the IAP
monitoring dashboard.

For regular IAPs with non-dual band, Aruba Central On-Premises automatically assigns Radio 1 to 2.4 GHz band
and Radio 0 to 5 GHz band respectively.

To retrieve the radio numbers through API, complete the following steps:

1. In the Aruba Central On-Premises app, under Maintain, click Organization > Platform
Integration. Click API Gateway.

The API Gateway page is displayed.

2. Click the APIs tab.

The token key is valid only for 2 hours from the time it was generated.

3. In the All Published APIs window, click the url link listed under the Documentation column.

The Central Network Management APIs page is displayed.

4. On the left navigation pane, select Monitoring from the URL drop-down list.

5. Click API Reference > AP.

The APIs listed in the Table 67 allow you to retrieve the radio number for the total number of IAP.

6. On the left navigation pane, click API Reference > Client.
The APIs listed in the Table 68 allow you to retrieve the radio number for the total number of IAP.

The following APIs allow you to retrieve the radio number for the total number of IAP.

API Description

[GET]/monitoring/v1/aps/
{serial}/neighbouring_clients

Allows you to filter data of neighbouring clients for a specific radio
number in a given time period.

Table 67: APIs to Get Radio Number in IAPs
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API Description

When there is no radio number entered in the radio_number field,
the API filters the data of neighbouring clients for both radio 0 and
radio 1. It is mandatory to provide the serial number of the IAP to
get the data of neighboring clients for a specific radio number.

[GET]/monitoring/v1/aps/rf_summary Retrieves information on RF summary such as channel utilization
and noise floor in positive, errors, drops for a given time period.
This API can also be used to filter RF health statistics for a specific
radio number in a given time period.
When there is no radio number entered in the radio_number field,
the API filters the RF health statistics for both radio 0 and radio 1. It
is mandatory to provide the serial number of the IAP to get the RF
health statistics for a specific radio number.

[GET]/monitoring/v1/aps/bandwith_
usage

This API can also be used to filter out bandwidth usage data for a
specific radio number in a given time period.
When there is no radio number entered in the radio_number field,
the API filters the bandwidth usage for both radio 0 and radio 1. It is
mandatory to provide the serial number of the IAP to get the
bandwidth usage for a specific radio number.

The following APIs allow you to retrieve the radio number for the total number of clients connected.

API Description

[GET]/monitoring/v1/clients/count This API is used to filter out the data for connected clients for a
specific radio number of IAP in a given time period.
When there is no radio number entered in the radio_number field,
the API filters the clients count for both radio 0 and radio 1. It is
mandatory to provide the serial number of the IAP to get the total
count of clients for a specific radio number.

Table 68: APIs to Get Radio Number in Connected Clients

For more details about APIs, see https://app1-apigw.central.arubanetworks.com/swagger/central.

Support for Dual 5 GHz IAP
Aruba Central On-Premises supports automatic opmode selection for dual 5 GHz IAP. When the
opmode is set to automatic, AirMatch determines whether to convert a radio in an IAP to 5 GHz
operation instead of the 2.4 GHz and 5 GHz dual band operation. Automatic is the default dual 5G mode
where Airmatch detects what is an optimal mode for the radios – dual band or dual 5G and updates the
running opmode without requiring an IAP reboot between the mode changes.

Manual setting of dual band and dual 5G is possible and the manual setting overrides the automatic
mode and explicitly enables or disables the dual 5G mode. In this scenario, the IAP immediately
switches to the specified mode without a reboot and AirMatch maintains the specified channel and
power assignments in the specified mode.

Automatic mode is not supported on AP-344. By default, AP-344 assumes the automatic mode to be the same
as dual 5G disabled and operates in the dual band mode. To switch AP-344 to dual 5G mode, explicitly enable
the dual 5G mode.

The following procedure describes how to configure automatic opmode selection for dual 5 GHz IAP:

https://app1-apigw.central.arubanetworks.com/swagger/central
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1. In the Aruba Central On-Premises app, select one of the following options:
n To select an IAP group in the filter:

a. Set the filter to a group containing at least one IAP.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

n To select an IAP in the filter:
a. Set the filter to Global or a group containing at least one IAP.
b. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

c. Click an IAP listed under Device Name.

The dashboard context for the IAP is displayed.

d. Under Manage, click Devices > Access Point.

2. Click the Config icon.

The tabs to configure the IAPs are displayed.

3. Click the Access Points tab.

The Access Points page is displayed.

4. To edit an IAP, select an IAP in the Access Points table, and then click the edit icon.
5. Click the Radio tab.
6. Set Dual 5G Mode to Automatic.
7. (Optional) Specify the manual channel by setting Channel Assignment to Manual.
8. (Optional) Specify the transmit power by setting Transmit Power Assignment to Manual.
9. Click Save Settings.

Configuring Intelligent Power Monitoring
The Intelligent Power Monitoring (IPM) feature actively measures the power utilization of an IAP and
dynamically adapts to the power resources. IPM allows you to define the features that must be disabled
to save power, allowing the IAPs to operate at a lower power consumption without hampering the
performance of the related features. This feature constantly monitors the IAP power consumption and
adjusts the power saving IPM features within the power budget.

IPM dynamically limits the power requirement of an IAP as per the available power resources. IPM
applies a sequence of power reduction steps as defined by the priority definition until the IAP functions
within the power budget. This happens dynamically as IPM constantly monitors the IAP power
consumption and applies the next power reduction step in the priority list if the IAP exceeds the power
threshold. To manage this prioritization, you can create IPM policies to define a set of power reduction
steps and associate them with a priority. The IPM policies, when applied to the IAP, are based on IPM
priorities, where the IPM policy can be configured to disable or reduce certain features in a specific
sequence to reduce the IAP power consumption below the power budget. IPM priority settings are
defined by integer values, where the lower values have the highest priority and are implemented first.

The Intelligent Power Monitoring feature is available only on APs running Aruba Instant OS 8.6.0.3.

To configure Intelligent Power Monitoring, complete the following steps:
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1. In the Aruba Central On-Premises app, set the filter to a group containing at least one IAP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the IAPs are displayed.

4. Click Show Advanced.
5. Click the System tab.

The System page is displayed.

6. Expand the IPM accordion.
7. Select the IPM Activation check box to enable IPM.
8. Click the + icon in the IPM Power Reduction Steps With Priorities pane.

The IPM Power Reduction Steps With Priorities window is displayed.

9. In the IPM Step Priority field, enter a value from 1 to 16 to define IPM priority.

A lower value implies the highest priority, and is implemented first over a priority with higher value.

10. From the IPM Step drop-down list, select a setting as described in Table 69.
11. Click OK.

The IPM Power Reduction Steps With Priorities table in the IPM section lists all the
IPM settings.

12. Click Save Settings.
13. Reboot the IAP for changes to take effect.

The following figure shows the IPM steps and priorities listed in the IPM Power Reduction Steps With
Priorities table.

Figure 57 IPM Steps and Priorities

The following table lists the intelligent power monitoring parameters.
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Parameters Description

cpu_throttle_25 Reduces CPU frequency to 25% of normal.

cpu_throttle_50 Reduces CPU frequency to 50% of normal.

cpu_throttle_75 Reduces CPU frequency to 75% of normal.

disable_alt_eth Disables the second Ethernet port.

disable_pse Disables Power Sourcing Equipment (PSE).

disable_usb Disables USB.

radio_2ghz_chain_1 Reduces 2 GHz chains to 1x1.

radio_2ghz_chain_2 Reduces 2 GHz chains to 2x2.

radio_2ghz_chain_3 Reduces 2 GHz chains to 3x3.

radio_2ghz_power_3dB Reduces 2 GHz radio power by 3 dB from the maximum value.

radio_2ghz_power_6dB Reduces 2 GHz radio power by 6 dB from the maximum value.

radio_5ghz_chain_1 Reduces 5 GHz chains to 1x1.

radio_5ghz_chain_2 Reduces 5 GHz chains to 2x2.

radio_5ghz_chain_3 Reduces 5 GHz chains to 3x3.

radio_5ghz_power_3dB Reduces 5 GHz radio power by 3 dB from the maximum value.

radio_5ghz_power_6dB Reduces 5 GHz radio power by 6 dB from the maximum value.

Table 69: Intelligent Power Monitoring Parameters

To reduce the CPU power gradually, the smallest reduction is allocated a higher priority value so that the
minimum reduction step is implemented first. For example, the cpu_throttle_50 parameter should have a
higher priority value than the cpu_throttle_25 parameter, so that IPM gradually reduces the CPU throttle or
power usage based on the priority list.

Points to Remember

n By default, Intelligent Power Monitoring is disabled.
n When enabled, IPM enables all IAP functionality initially. IPM then proceeds to shut down or restrict

functionality if the power usage of the IAP goes beyond the power budget of the IAP.

Configuring System Parameters for an IAP
To configure system parameters for an Instant Access Point (IAP), complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one IAP.

The dashboard context for the group is displayed.



Managing APs | 345

2. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the IAPs are displayed.

4. Click Show Advanced.
5. Click the System tab.

The System page is displayed.

6. Click the General accordion and configure the parameters in the Table 70.

7. Click Save Settings.

The following table lists the system parameters.

Data Pane Item Description

Virtual Controller This parameter configuration is only applicable for IAPs that operate in a cluster
deployment environment.
To configure the virtual controller name and IP address, click edit icon and update the
name and IP address. The IP address serves as a static IP address for the multi-AP
network. When configured, this IP address is automatically provisioned on a shadow
interface on the IAP that takes the role of a virtual controller. The IAP sends three ARP
messages with the static IP address and its MAC address to update the network ARP
cache.
n Name—Name of the virtual controller.
n IP address—IPv4 address configured for the virtual controller. The IPv4 address

uses the 0.0.0.0 notation.
n IPv6 address—IPv6 address configured for the virtual controller. You can configure

IPv6 address for the virtual controller only if the Allow IPv6 Management feature is
enabled.

IPv6 is the latest version of IP that is suitable for large-scale IP networks. IPv6 supports
a 128-bit address to allow 2128, or approximately 3.4×1038 addresses while IPv4
supports only 232 addresses.
The IP address of the IPv6 host is always represented as eight groups of four
hexadecimal digits separated by colons. For example
2001:0db8:0a0b:12f0:0000:0000:0000:0001. However, the IPv6 notation can be
abbreviated to compress one or more groups of zeroes or to compress leading or
trailing zeroes; for example 2001:db8:a0b:12f0::0:0:1.

Set Country code
for group

To configure a country code for the IAP at the group level, select the country code from
the Set Country code for group drop-down list. By default, no country code is
configured for the IAP device groups.
When a country code is configured for the group, it takes precedence over the country
code setting configured t the device level.

Timezone To configure a time zone, select a time zone from the Timezone drop-down list.
If the selected timezone supports DST, the UI displays the "The selected country
observes Daylight Savings Time" message.

Preferred Band Assign a preferred band by selecting an appropriate option from the Preferred Band
drop-down list.
Reboot the IAP after modifying the radio profile for changes to take effect.

Table 70: System Parameters
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Data Pane Item Description

NTP Server To facilitate communication between various elements in a network, time
synchronization between the elements and across the network is critical. Time
synchronization allows you to:
n Trace and track security gaps, network usage, and troubleshoot network issues.
n Validate certificates.
n Map an event on one network element to a corresponding event on another.
n Maintain accurate time for billing services and similar.
n NTP helps obtain the precise time from a server and regulate the local time in each

network element. Connectivity to a valid NTP server is required to synchronize the
IAP clock to set the correct time. If NTP server is not configured in the IAP network,
an IAP reboot may lead to variation in time data.

By default, the IAP tries to connect to pool.ntp.org to synchronize time. The NTP server
can also be provisioned through the DHCP option 42. If the NTP server is configured, it
takes precedence over the DHCP option 42 provisioned value. The NTP server
provisioned through the DHCP option 42 is used if no server is configured. The default
server pool.ntp.org is used if no NTP server is configured or provisioned through
DHCP option 42.
To configure an NTP server, enter the IP address or the URL of the NTP server and
reboot the IAP to apply the configuration changes.

Virtual Controller
Netmask
Virtual Controller
Gateway
Virtual Controller
DNS
Virtual Controller
VLAN

This parameter configuration is only applicable for IAPs that operate in a cluster
deployment environment.
The IP configured for the virtual controller can be in the same subnet as IAP or can be
in a different subnet. Ensure that you configure the virtual controller VLAN, controller,
and subnet mask details only if the virtual controller IP is in a different subnet.
Ensure that virtual controller VLAN is not the same as native VLAN of the IAP.

DHCP Option 82
XML

The DHCP Option 82 XML is not applicable for cloud IAPs.

DHCP Option 82 XML can be customized to cater to the requirements of any ISP using
the conductor IAP. To facilitate customization using a XML definition, multiple
parameters for Circuit ID and Remote ID options of DHCP Option 82 XML are
introduced.
The XML file is used as the input and is validated against an XSD file in the conductor
IAP. The format in the XML file is parsed and stored in the DHCP relay which is used to
insert Option 82 related values in the DHCP request packets sent from the client to the
server.
From the drop-down list, select one of the following XML files:
n default_dhcpopt82_1.xml
n default_dhcpopt82_2.xml

For more information, see Configuring DHCP Scopes on IAPs.

Dynamic CPU
Utilization

IAPs perform various functions such as wired and wireless client connectivity and traffic
flows, wireless security, network management, and location tracking. If an IAP is
overloaded, prioritize the platform resources across different functions. Typically, the
IAPs manage resources automatically in real time. However, under special
circumstances, if dynamic resource management needs to be enforced or disabled
altogether, the dynamic CPU management feature settings can be modified.
To configure dynamic CPU management, select any of the following options from
Dynamic CPU Utilization.
n Automatic—When selected, the CPU management is enabled or disabled

automatically during run-time. This decision is based on real time load calculations

Table 70: System Parameters
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Data Pane Item Description

taking into account all different functions that the CPU needs to perform. This is the
default and recommended option.

n Always Disabled in all APs—When selected, this setting disables CPU
management on all IAPs, typically for small networks. This setting protects user
experience.

n Always Enabled in all APs—When selected, the client and network management
functions are protected. This setting helps in large networks with high client
density.

Auto-Join Mode When enabled, IAPs can automatically discover the virtual controller and join the
network. The Auto-Join Mode feature is enabled by default.

APs allowed for
Auto-Join Mode

Displays the number of IAPs allowed for Auto-Join Mode.
n Click View Allowed APs to view the details of IAP allowed for Auto-Join mode.
n Click Hide Allowed APs to hide the details of IAP allowed for Auto-Join mode.

When Auto-Join Mode is enabled, the IAPs are automatically discovered and are
allowed to join the cluster. When the Auto-Join Mode is disabled on the IAP, the list of
allowed IAPs on Aruba Central may not be synchronized or up-to-date. In such cases,
you can manually add a list of IAPs that can join the IAP cluster in the Aruba Central UI.
To manually add the list of allowed IAP devices, complete the following steps:

1. Under View Allowed APs, click + in the Allowed APs pane.

2. In the Add Allowed AP window, enter the MAC address of the IAP in the MAC
Address field.

3. Click Save.

Allow IPv6
Management

Enables IPv6 address configuration for the virtual controller.
You can configure an IPv6 address for a virtual controller IP only when Allow IPv6
Management feature is enabled.

Uplink switch
native VLAN

Allows you to specify a VLAN ID, to prevent the IAP from sending tagged frames for
clients connected on the SSID that uses the same VLAN as the native VLAN of the
switch.
By default, the IAP considers the native VLAN of the upstream switch, to which it is
connected, as the VLAN ID 1.

Terminal Access When enabled, the users can access the IAP CLI through SSH.

Login Session
Timeout

Allows you to set a timeout for login session.

Console Access When enabled, the users can access IAP through the console port.

WebUI Access If an IAP is connected to Aruba Central, you can use this option to disable IAP Web UI
access and any communication via HTTPS or SSH. If you enable this feature, you can
manage the IAP only from Aruba Central.

Telnet Server When enabled, the users can start a Telnet session with the IAP CLI.

LED Display Enables or disables the LED display for all IAPs in a cluster.
The LED display is always enabled during the IAP reboot.

Table 70: System Parameters
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Data Pane Item Description

Extended SSID Extended SSID is enabled by default in the factory default settings of IAPs. This
disables mesh in the factory default settings.

NOTE: For AP devices that support Aruba InstantOS 8.4.0.0 firmware versions and
above, you can configure up to 14 SSIDs. By enabling Extended SSID, you can create up
to 16 networks.

Advanced Zone Turn on the Advanced Zone toggle switch to enable the advance zone.
When the advanced-zone feature is enabled and a zone is already configured with 16
SSIDs, ensure to remove the zone from two WLAN SSID profiles if you want to disable
extended SSID.

Deny Inter User
Bridging

If you have security and traffic management policies defined in upstream devices, you
can disable bridging traffic between two clients connected to the same IAP on the same
VLAN. When inter-user bridging is denied, the clients can connect to the Internet but
cannot communicate with each other, and the bridging traffic between the clients is
sent to the upstream device to make the forwarding decision.
To disable inter-user bridging, turn off the Deny Inter User Bridging toggle switch.

Deny Local Routing If you have security and traffic management policies defined in upstream devices, you
can disable routing traffic between two clients connected to the same IAP on different
VLANs. When local routing is disabled, the clients can connect to the Internet but
cannot communicate with each other, and the routing traffic between the clients is sent
to the upstream device to make the forwarding decision.
To disable local routing, move the slider to the right.

Dynamic
RADIUS Proxy

If your network has separate RADIUS authentication servers (local and centralized
servers) for user authentication, you may want to enable Dynamic RADIUS proxy to
route traffic to a specific RADIUS server. When Dynamic RADIUS proxy is enabled, the
IP address of the virtual controller is used for communication with external RADIUS
servers.
To enable Dynamic RADIUS Proxy, you must configure an IP address for the Virtual
Controller and set it as a NAS client in the RADIUS server profile.

Dynamic TACACS
Proxy

If you want to route traffic to different TACACS servers, enable Dynamic
TACACS Proxy. When enabled, the IAP cluster uses the IP address of the Virtual
Controller for communication with external TACACS servers.
If an IP address is not configured for the Virtual Controller, the IP address of the bridge
interface is used for communication between the IAP and TACACS servers. However, if
a VPN tunnel exists between the Instant AP and TACACS server, the IP address of the
tunnel interface is used.

Cluster Security This parameter is required to be set only for IAPs that operate in a cluster deployment
environment.
Enables or disables the cluster security feature. When enabled, the control plane
communication between the IAP cluster nodes is secured. The Disallow Non-DTLS
Members toggle switch appears. Turn on the toggle switch to allow member IAPs to
join a DTLS enabled cluster.
For secure communication between the cluster nodes, the Internet connection must be
available, or at least a local NTP server must be configured.
After enabling or disabling cluster security, ensure that the configuration is
synchronized across all devices in the cluster, and then reboot the cluster.
The Disallow Non-DTLS Members feature is only supported in IAP devices supporting
Aruba InstantOS 8.4.0.0 firmware versions and above.
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Data Pane Item Description

Low Assurance PKI Turn on the toggle switch to allow low assurance devices that use non-TPM chip, in the
network.
To enable the cluster security feature, turn on the Low Assurance PKI toggle switch.
For more information on Low Assurance PKI, refer to Cluster Security section in Aruba
Instant User Guide.
The Low Assurance PKI toggle switch is supported in IAP devices running Aruba
InstantOS 6.5.3.0 firmware versions and later.

Mobility Access
Switch Integration

Turn on the toggle switch to enable LLDP protocol for Mobility Access Switch
integration. With this protocol, IAPs can instruct the switch to turn off ports where
rogue access points are connected, as well as take actions such as increasing PoE
priority and automatically configuring VLANs on ports where IAPs are connected.

URL Visibility Turn on the toggle switch to enable URL data logging for client HTTP and
HTTPS sessions and allows IAPs to extract URL information and periodically log them
on ALE for DPI and application analytics.

Restrict uplink port
to specified VLANs

Turn on the toggle switch to restrict the uplink port to the specified VLANs.

VOIP QOS Trust Turn on the toggle switch to enable the RTP traffic based on the DSCP value set by the
end user device.

Swarm Mode Allows you to set one of the following operation modes:
n Cluster—Allows an IAP to operate in the cluster mode. When an IAP operates in the

cluster mode, it can form a cluster with other virtual controller IAPs in the same
VLAN.

n Standalone—Allows an IAP to operate in the standalone mode. When an IAP
operates in the standalone mode, it cannot join a cluster of IAPs even if the IAP is in
the same VLAN.

n Single-AP—Allows an IAP to operate in the single AP mode that is specifically
designed for IAP deployments with only one IAP in the site.

This mode is a type of standalone IAP deployment with additional security when the
IAP is directly facing a WAN connection. When configured as a single IAP, the IAP
does not send or receive management frames such as mobility packets, roaming
packets, and hierarchy beacons through the uplink port.

NOTE: After changing the AP operation mode, ensure that you reboot the IAP.

UTB Filter Block This parameter is used to control the band on which the Ultra Tri-Band (UTB) limitation
is applied in the regulatory-domain-profile.
The utb filter supports channel band on both 5 GHz and 6 GHz.
Listed below are the two options available:
n 5 GHz - Select 5 GHz for upper band blocking.
n 6 GHz - Select 6 GHz for lower band blocking.

Default value: 6 GHz

NOTE: The UTB Filter Block is supported only for AP-635 access points.

Table 70: System Parameters

Enabling 802.1X Authentication on Uplink Ports of an IAP
If your network requires all wired devices to authenticate using PEAP or TLS protocol, you must enable
802.1X authentication type on uplink ports of an IAP, so that the IAPs are granted access only after
completing the authentication as a valid client.
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To enable 802.1X authentication on uplink ports using PEAP or TLS protocol, complete the following
steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one IAP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the IAPs are displayed.

4. Click Show Advanced.
5. Click the Interfaces tab.

The Interfaces page is displayed.

6. Click the Uplink accordion.
7. Expand the AP1X section.

n To set PEAP based authentication, select PEAP in the AP1X Type drop-down list.

If you select PEAP protocol, ensure that the PEAP User is configured on the uplink port by selecting
an IAP group and navigating to Uplink section in the Access Points tab.

n To set TLS based authentication:
a. Select TLS in the AP1X Type drop-down list.
b. Select User in the Certificate Type drop-down list.

8. Select the Validate Server check-box to validate the server credentials using server certificate.

Ensure that the server certificates for validating server credentials are available in the IAP
database.

9. Click Save Settings.

Configuring HTTP Proxy on an IAP
If your network requires a proxy server for Internet access, ensure that you configure the HTTP proxy on
the Instant Access Point (IAP) to download the image from the cloud server. After setting up the HTTP
proxy settings, the IAP connects to the Aruba Central On-Premises or OpenDNS server through a secure
HTTP connection. You can also exempt certain applications from using the HTTP proxy (configured on
an IAP) by providing their host name or IP address under Exception. Aruba Central allows the user to
configure HTTP proxy on an IAP.

To configure HTTP proxy on IAP through Aruba Central On-Premises, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one IAP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the IAPs are displayed.

4. Click Show Advanced.
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5. Click the System tab.

The System page is displayed.

6. Click the Proxy accordion and specify the following:
n Enter the HTTP proxy server IP address in the Server text box.
n Enter the port number in the Port text box.
n Enter the Username and Password.

7. Click Save Settings.

Aruba Central On-Premises displays the Username, Password, and Retype Password fields under System >
Proxy for APs running ArubaInstantOS 8.3.0.0. The APs running ArubaInstantOS 8.3.0.0 firmware require user
credentials for proxy server authentication.

Configuring Network Profiles on IAPs
This section describes the following procedures:

n Configuring Wireless Network Profiles on IAPs on page 351
n Configuring Wireless Networks for Guest Users on IAPs on page 363
n Configuring Wired Port Profiles on IAPs on page 381
n Editing a Wireless Network Profile
n Deleting a Network Profile

Configuring Wireless Network Profiles on IAPs
You can configure up to 14 SSIDs. By enabling Extended SSID in the System > General accordion, you
can create up to 16 networks.

If more than 16 SSIDs are assigned to a zone and the extended zone option is disabled, an error message is
displayed.

This section describes the following topics:

n Creating a Wireless Network Profile
n Configuring VLAN Settings for Wireless Network
n Configuring Security Settings for Wireless Network
n Configuring ACLs for User Access to a Wireless Network
n Viewing Wireless SSID Summary

Creating a Wireless Network Profile
To configure WLAN settings, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one IAP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.
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3. Click the Config icon.

The tabs to configure the IAPs are displayed.

4. Click the WLANs tab.

The WLANs details page is displayed.

5. In the WLANs tab, click +Add SSID.

The Create a New Network pane is displayed.

6. In General tab, enter a name that is used to identify the network in the Name (SSID) text-box.

7. Under Advanced Settings, configure the parameters in the Table 71.

The following table lists the advanced settings parameters.

Parameter Description

Broadcast/Multicast

Broadcast filtering Select any of the following values:
n All—The IAP drops all broadcast and multicast frames except DHCP and ARP, IGMP

group queries, and IPv6 neighbor discovery protocols.
n ARP—The IAP drops broadcast and multicast frames except DHCP and ARP, IGMP

group queries, and IPv6 neighbor discovery protocols. Additionally, it converts ARP
requests to unicast and sends frames directly to the associated clients. By default,
the IAP is configured to ARP mode.

n Unicast ARP Only—This option enables Instant AP to convert ARP requests to
unicast frames thereby sending them to the associated clients.

n Disabled—The IAP forwards all the broadcast and multicast traffic is forwarded to
the wireless interfaces.

DTIM Interval The DTIM Interval indicates the DTIM period in beacons, which can be configured for
every WLAN SSID profile. The DTIM interval determines how often the IAP delivers the
buffered broadcast and multicast frames to the associated clients in the power save
mode. Range is 1 to 10 beacons.
The default value is 1, which means the client checks for buffered data on the IAP at
every beacon. You can also configure a higher DTIM value for power saving.

Multicast
Transmission
Optimization

Select the check-box if you want the IAP to select the optimal rate for sending broadcast
and multicast frames based on the lowest of unicast rates across all associated clients.
When this option is enabled, multicast traffic can be sent up to a rate of 24 Mbps.
The default rate for sending frames for 2.4 GHz is 1 Mbps and that for 5 GHz is 6 Mbps.
This option is disabled by default.

Dynamic Multicast
Optimization
(DMO)

Select the check-box to allow IAP to convert multicast streams into unicast streams over
the wireless link. Enabling DMO enhances the quality and reliability of streaming video,
while preserving the bandwidth available to the non-video clients.
When you enable DMO on multicast SSID profiles, ensure that the DMO feature is
enabled on all SSIDs configured in the same VLAN.

DMO channel
utilization
threshold

Specify a value to set a threshold for DMO channel utilization. With DMO, the IAP
converts multicast streams into unicast streams as long as the channel utilization does
not exceed this threshold. The default value is 90% and the maximum threshold value is
100%. When the threshold is reached or exceeds the maximum value, the IAP sends
multicast traffic over the wireless link.
This option will be enabled only when Dynamic Multicast Optimization is enabled.

Table 71: Advanced Settings Parameters
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Transmit Rates (Legacy Only)

2.4 GHz If the 2.4 GHz band is configured on an IAP, specify the minimum and maximum
transmission rates.
Default value: The default value for minimum transmission rate is 1 Mbps and
maximum transmission rate is 54 Mbps.

5 GHz If the 5 GHz band is configured on an IAP, specify the minimum and maximum
transmission rates.
Default value: The default value for minimum transmission rate is 6 Mbps and
maximum transmission rate is 54 Mbps.

Beacon Rate

2.4 GHz If the 2.4 GHz band is configured on an IAP, specify the transmission rates from the 2.4
GHz drop-down list. By default, the transmission rate is set as 1 Mbps. The minimum
transmission rate supported is 1 Mbps and the maximum transmission rate supported
is 54 Mbps.

5 GHz If the 5 GHz band is configured on an IAP, specify the transmission rates from the 5 GHz
drop-down list. By default, the transmission rate is set to 6 Mbps. The minimum
transmission rate supported is 6 Mbps and the maximum transmission rate supported
is 54 Mbps.

Zone

Zone Specify the zone for the SSID. If a zone is configured in the SSID, only the IAP in that
zone broadcasts this SSID. If there are no IAPs in the zone, SSID is broadcast.
If the IAP cluster has devices running IAP firmware versions 6.5.4.7 or later, and 8.3.0.0
or later, you can configure multiple IAP zones by adding zone names as comma
separated values.
Aruba recommends that you do not configure zones in both SSID and in the device
specific settings of an IAP. If the same zones are configured in SSID and Per AP settings,
IAPs may broadcast the SSIDs, but if the SSIDs and Per AP settings have different zones
configured, it may lead to a configuration error. For more information on IAP zones, see
Aruba Instant User Guide.

Bandwidth Control

Airtime Select this to specify an aggregate amount of airtime that all clients in this network can
use for sending and receiving data. Specify the airtime percentage.

Downstream Enter the downstream rates within a range of 1 to 65,535 Kbps for the SSID users. If the
assignment is specific for each user, select the Per User check-box.
The bandwidth limit set in this method is implemented at the device level and not
cluster level.

Upstream Enter the upstream rates within a range of 1 to 65,535 Kbps for the SSID users. If the
assignment is specific for each user, select the Per user check-box.
The bandwidth limit set in this method is implemented at the device level and not
cluster level.

Each Radio Select this to specify an aggregate amount of throughput that each radio is allowed to
provide for the connected clients. The value ranges from 1 through 65535.
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Parameter Description

Enable 11n When this option is selected, there is no disabling of High-Throughput (HT) on 802.11n
devices for the 5 GHz radio band. If HT is enabled for the 5 GHz radio profile on an IAP, it
is automatically enabled for all SSIDs configured on an IAP. By default, HT is enabled on
all SSIDs.
If you want the 802.11ac IAPs to function as 802.11n IAPs, clear this check-box to disable
VHT on these devices.

Enable 11ac When this option is selected, VHT is enabled on the 802.11ac devices for the 5 GHz radio
band. If VHT is enabled for the 5 GHz radio profile on an IAP, it is automatically enabled
for all SSIDs configured on an IAP. By default, VHT is enabled on all SSIDs.
If you want the 802.11ac IAPs to function as 802.11n IAPs, clear this check-box to disable
VHT on these devices.

Enable 11ax When this option is selected, VHT is enabled on the 802.11ax devices. If VHT is enabled
for a radio profile on an IAP, it is automatically enabled for all SSIDs configured on an
IAP. By default, VHT is enabled on all SSIDs.

WiFi Multimedia

Background Wifi
Multimedia Share

Allocates bandwidth for background traffic such as file downloads or print jobs. Specify
the appropriate DSCP mapping values within a range of 0–63 for the background traffic
in the corresponding DSCP mapping text-box. Enter up to 8 values with no white space
and no duplicate single DHCP mapping value.

Best Effort Wifi
Multimedia Share

Allocates bandwidth or best effort traffic such as traffic from legacy devices or traffic
from applications or devices that do not support QoS. Specify the appropriate DSCP
mapping values within a range of 0–63 for the best effort traffic in the corresponding
DSCP mapping text-box.

Video Wifi
Multimedia Share

Allocates bandwidth for video traffic generated from video streaming. Specify the
appropriate DSCP mapping values within a range of 0–63 for the video traffic in the
corresponding DSCP mapping text-box.

Voice Wifi
Multimedia Share

Allocates bandwidth for voice traffic generated from the incoming and outgoing voice
communication. Specify the appropriate DSCP mapping values within a range of 0–63
for the voice traffic in the corresponding DSCP mapping text-box.
In a non-WMM or hybrid environment, where some clients are not WMM-capable, you
can allocate higher values for Best Effort Wifi Multimedia share and Voice Wifi
Multimedia Share to allocate a higher bandwidth to clients transmitting best effort and
voice traffic.

Traffic
Specification
(TSPEC)

Select this check-box to set if you want the TSPEC for the wireless network. The term
TSPEC is used in wireless networks supporting the IEEE 802.11e Quality of Service
standard. It defines a series of parameters, characteristics and Quality of Service
expectations of a traffic flow.

TSPEC Bandwidth Enter the bandwidth for the TSPEC.

Spectralink Voice
Protocol(SVP)

Select this check-box to opt for SVP protocol.

WiFi Multimedia
Power Save (U-
APSD)

Select this check-box to enable WiFi Multimedia Power Save (U-APSD). The U-APSD is a
power saving mechanism that is an optional part of the IEEE amendment 802.11e, QoS.

Miscellaneous
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Parameter Description

Band Select a check box to specify the band at which the network transmits radio signals in
the Band. You can set the band to 2.4 GHz, 5 GHz, or 6 GHz. The 2.4 GHz and 5 GHz
options are selected by default.

NOTE: The 6 GHz band is only supported for devices with 6 GHz capability.

Content Filtering Select this check-box to route all DNS requests for the non-corporate domains to
OpenDNS on this network.

Primary Usage Based on the type of network profile, select one of the following options:
Mixed Traffic—Select this option to create an employee or guest network profile. The
employee network is used by the employees in an organization and it supports
passphrase-based or 802.1X-based authentication methods. Employees can access the
protected data of an enterprise through the employee network after successful
authentication. The guest network is created for guests, visitors, contractors, and any
non-employee users who use the enterprise Wi-Fi network. The VC assigns the IP
address for the guest clients. Captive portal or passphrase-based authentication
methods can be set for this wireless network. Typically, a guest network is an
unencrypted network. However, you can specify the encryption settings when
configuring a guest network.
Voice Only—Select this option to configure a network profile for devices that provide
only voice services such as handsets or applications that require voice traffic
prioritization.
When a client is associated with the voice network, all data traffic is marked and placed
into the high priority queue in QoS.

Inactivity timeout Specify an interval for session timeout. If a client session is inactive for the specified
duration, the session expires and the users are required to log in again. You can specify
a value within the range of 60–3600 seconds. The default value is 1000 seconds.

Hide SSID Select this check-box if you do not want the SSID to be visible to users.

Disable Network Select this check-box if you want to disable the SSID. When selected, the SSID is
disabled, but is not removed from the network. By default, all SSIDs are enabled.

Max clients
threshold

Specify the maximum number of clients that can be configured for each BSSID on a
WLAN. You can specify a value within the range of 0–255. The default value is 64.

ESSID Specify the identifier that serves as an identification and address for the device to
connect to a wireless router which can then access the internet. If the ESSID value
defined is not the same as the profile name, the SSID can be searched based on the
ESSID value and not by its profile name.

Local Probe
Request Threshold

Select either automatic or manual to set the Local Probe Request Threshold.
automatic: The local probe request threshold value changes to the recommended
value provided by the AI insights to improve the performance for the indoor Wi-Fi
clients. Threshold values are evaluated weekly, and new recommendations will be
updated automatically. To revert the applied AI insight recommended values, select
manual and specify the threshold value.
manual: Specify a threshold value to limit the number of incoming probe requests.
When a client sends a broadcast probe request frame to search for all available SSIDs,
this option controls system response for this network profile and ignores probe
requests, if required.

Min RSSI for auth
request

Select either automatic or manual to set the minimum RSSI for authentication request.
automatic: The minimum RSSI for authentication request value changes to the
recommended value provided by the AI insights to improve the performance for the
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Parameter Description

indoor Wi-Fi clients. Threshold values are evaluated weekly, and new recommendations
will be updated automatically. To revert the applied AI insight recommended values,
select manual and specify the threshold value.
manual: Enter the minimum RSSI threshold for authentication requests. You can specify
an RSSI value within the range of 0–100 dB.

Deauth inactive
clients

Select this option to allow the IAP to send a de-authentication frame to the inactive
client and the clear client entry.

Can be used
without uplink

Select this check-box if you do not want the SSID profile to use the uplink.

Deny inter user
bridging

Disables bridging traffic between two clients connected to the same SSID on the same
VLAN. When this option is enabled, the clients can connect to the Internet, but cannot
communicate with each other, and the bridging traffic between the clients is sent to the
upstream device to make the forwarding decision.

Enable SSID when Select an option from the drop-down list and specify the time period.

Disable SSID when Select an option from the drop-down list and specify the time period.

Deny Intra VLAN
Traffic

Disables intra VLAN traffic to enable the client isolation and disable all peer-to-peer
communication. Client isolation disables inter-client communication by allowing only
client to controller traffic from clients to flow in the network. All other traffic from the
client that is not destined to the controller or configured servers will not be forwarded
by the Instant AP. This feature enhances the security of the network and protects it from
vulnerabilities. For more information, see Configuring Client Isolation.

Management
Frame Protection

Turn on the Management Frames Protection toggle switch to provide high network
security by maintaining data confidentiality of management frames. The Management
Frame Protection (MFP) establishes encryption keys between the client and Instant AP
using 802.11i framework. For more information, see Management Frames Protection.

Fine Timing
Measurement
(802.11mc)
Responder Mode

Turn on the toggle switch to enable the fine timing measurement (802.11mc) responder
mode.

Advertise AP Name Turn on the toggle switch to enable the advertising of IAP name.

Time Range Profiles

Time Range
Profiles

Ensure that the NTP server connection is active.
Select a time range profile from the Time Range Profiles list and apply a status form
the drop-down list.
Click +New Time Range Profile to create a new time range profile. For more
information, see Configuring Time-Based Services for Wireless Network Profiles.

Configuring VLAN Settings for Wireless Network

To configure VLANs settings for an SSID, complete the following steps:

1. In the VLANs tab, select any of the following options for Client IP Assignment:
n Instant AP assigned—When selected, the client obtains the IP address from the VC.
n External DHCP server assigned—When selected, the client obtains the IP address from the

network.
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2. Based on the type of client IP assignment mode selected, configure the parameters in the Table
72.

3. Click Next.

The following table lists the VLAN parameters.

Parameter Description

Instant AP
assigned

When this option is selected, the client obtains the IP address from the virtual controller. The
virtual controller creates a private subnet and VLAN on the IAP for the wireless clients. The
network address translation for all client traffic that goes out of this interface is carried out at
the source. This setup eliminates the need for complex VLAN and IP address management for
a multi-site wireless network. For more information on DHCP scopes and server
configuration, see Configuring DHCP Pools and Client IP Assignment Modes on IAPs.
If this option is selected, specify any of the following options in Client VLAN Assignment:
n Internal VLAN—Assigns IP address to the client in the same subnet as the IAPs. By

default, the client VLAN is assigned to the native VLAN on the wired network.
n Custom—Allows you to customize the client VLAN assignment to a specific VLAN, or a

range of VLANs. When this option is selected, select the scope from the VLAN ID drop-
down list.

External DHCP
server
assigned

When this option is selected, specify any of the following options in Client VLAN
Assignment:
n Static—In VLAN ID, specify a VLAN ID for a single VLAN(s). If a large number of clients

need to be in the same subnet, you can select this option to configure VLAN pooling.
VLAN pooling allows random assignment of VLANs from a pool of VLANs to each client
connecting to the SSID.

n Dynamic—Assigns the VLANs dynamically from a DHCP server.
n Native VLAN—Assigns the client VLAN is assigned to the native VLAN.

To add a new VLAN assignment rule, complete the following steps:

1. Click +Add Rule in the VLAN Assignment Rules window. The New VLAN Assignment
Rule page is displayed.

2. Enter the Attribute, Operator, String, and VLAN details, and then click OK.

To add a new Named VLAN, complete the following steps:

1. Click +Add Named VLAN. The Add Named VLAN window is displayed.

2. Enter the VLAN Name and VLAN details, and then click OK.

NOTE: To show or hide the Named VLANs, click Show Named VLANs. Click the Show
Named VLANs, to view the Named VLAN table.
To delete a VLAN assignment rule, select a rule in the VLAN Assignment Rules window, and
then click the delete icon.
To delete, select a Named VLAN in the Named VLAN table, and then click the delete icon.

NOTE: From Aruba Central On-Premises 2.5.4, the Add Named VLAN window supports
adding multiple VLAN IDs and VLAN range.

Table 72: VLANs Parameters
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Configuring Security Settings for Wireless Network

To configure security settings for mixed traffic or voice network, complete the following steps:

1. In the Security tab, specify any one of the following options in the Security Level:
n Enterprise—On selecting Enterprise security level, the authentication options applicable to

the network are displayed.
n Personal—On selecting Personal security level, the authentication options applicable to the

personalized network are displayed.
n Visitors—On selecting Visitors security level, the authentication options applicable to the

captive portal is displayed. For more information on captive portal, see Configuring Wireless
Networks for Guest Users on IAPs.

n Open—On selecting Open security level, the authentication options applicable to an open
network are displayed.

The default security setting for a network profile is Personal.

2. Based on the security level specified, configure the basic WLAN security parameters in the Table
73.

3. Based on the security level specified, in the Advanced Settings section specify the parameters
described in the Table 74.

4. Click Next.

The following table lists the basic WLAN security parameters.

Data Pane Item Description

Key Management For Enterprise security level, select an encryption key from Key Management drop-down
list:
n WPA-2 Enterprise—Select this option to use WPA-2 security. The WPA-2 Enterprise

requires user authentication and requires the use of a RADIUS server for
authentication.

n WPA Enterprise—Select this option to use both WPA Enterprise.
n Both (WPA-2 & WPA)—Select this option to use both WPA-2 and WPA security.
n Dynamic- WEP with 802.1X—If you do not want to use a session key from the

RADIUS Server to derive pairwise unicast keys, turn on the Use Session Key for
LEAP toggle switch. This is required for old printers that use dynamic WEP through
LEAP authentication. The Use Session Key for LEAP feature is Disabled by default.

n WPA-3 Enterprise(CNSA)—Select this option to use WPA-3 security employing CNSA
encryption.

n WPA-3 Enterprise(CCM 128)—Select this option to use WPA-3 security employing
CCM encryption operation mode limited to encrypting 128 bits of plain text.

n WPA-3 Enterprise(GCM 256)—Select this option to use WPA-3 security employing
GCM encryption operation mode limited to encrypting 256 bits of plain text.

When WPA-2 Enterprise and Both (WPA2-WPA) encryption types are selected and if
802.1x authentication method is configured, OKC is enabled by default. If OKC is enabled,
a cached PMK is used when the client roams to a new IAP. This allows faster roaming of
clients without the need for a complete 802.1x authentication. OKC roaming can be
configured only for the Enterprise security level.

Table 73: Basic WLAN Security Parameters
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Data Pane Item Description

For Personal security level, select an encryption key from Key Management drop-down
list.
For WPA-2 Personal, WPA Personal, Both (WPA-2&WPA), and WPA-3 Personal keys,
specify the following parameters:
n Passphrase Format—Select a passphrase format. The options available are 8-63

alphanumeric characters and 64 hexadecimal characters.
n Passphrase—Enter a passphrase in
n Retype—Retype the passphrase to confirm.

For Static WEP, specify the following parameters:
n WEP Key Size—Select an appropriate value for WEP key size from the drop-down list.

Select an appropriate value from the Tx Key drop-down list.
n WEP Key—Enter an appropriate WEP key.
n Retype WEP Key—Retype the WEP key to confirm.

For MPSK-AES, select a primary server from the drop-down list.
For MPSK-LOCAL, select an MPSK Local server from the drop-down list.

For Visitors security level, select Open or Enhanced Open encryption key from Key
Management drop-down list.
For information on configuring captive portal, see Configuring Wireless Networks for
Guest Users on IAPs on page 363.

For Open security level, the Key Management includes Open and Enhanced Open
options.

EAP offload This option is applicable to Enterprise security levels only. To terminate the EAP portion
of 802.1X authentication on the Instant AP instead of the RADIUS server, turn on the EAP
offload toggle switch. Enabling EAP offload can reduce network traffic to the external
RADIUS server by terminating the authorization protocol on the Instant AP. By default, for
802.1X authorization, the client conducts an EAP exchange with the RADIUS server, and
the Instant AP acts as a relay for this exchange. When EAP Offload is enabled, the Instant
AP by itself acts as an authentication server and terminates the outer layers of the EAP
protocol, only relaying the innermost layer to the external RADIUS server. It can also
reduce the number of exchange packets between the Instant AP and the authentication
server.
Instant supports the configuration of primary and backup authentication servers in an
EAP termination-enabled SSID.
If you are using LDAP for authentication, ensure that Instant AP termination is configured
to support EAP.

Authentication
Server

Configure the following parameters:
n MAC Authentication—Turn on the MAC Authentication toggle switch to allow MAC

address based authentication for Personal, Visitors, and Open security levels.
n Primary Server—Set a primary authentication server. The Primary Server option

appears only for Enterprise security level, internal and external captive portal types.
Select the following option from the drop-down list:

Internal Server—To use an internal server, select Internal Server and add the clients
that are required to authenticate with the internal RADIUS Server. Click Users to add
the users.

To add a new server, click +. For information on configuring external servers, see
Configuring External Authentication Servers for IAPs.

Aruba Central On-Premises allows you to configure an external RADIUS server, TACACS
or LDAP server, and External Captive Portal for user authentication.
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Data Pane Item Description

n Secondary Server—To add another server for authentication, configure another
authentication server.

n Authentication Survivability—If an external server is configured for authentication,
you can enable authentication survivability. Specify a value in hours for Cache
Timeout to set the duration after which the authenticated credentials in the cache
expires. When the cache expires, the clients are required to authenticate again. You
can specify a value within range of 1 to 99 hours. By default, authentication
survivability is disabled.

n Load Balancing—Turn on the toggle switch to enable, if you are using two RADIUS
authentication servers, to balance the load across these servers. For more information
on the dynamic load balancing mechanism, see Configuring External Authentication
Servers for IAPs.

Users Click Manage Users to add the users. The registered users of Employee type will be able
to access the users of Enterprise network. To add a new user, click +Add User and enter
the new user in the Add Userpane. The Primary Server option appears only for
Enterprise security level, Internal Captive Portal, and External Captive Portal.

The following table lists the advanced WLAN security parameters.

Data pane item Description

Use Session Key
for LEAP

Turn on the toggle switch to use the session key for Lightweight Extensible Authentication
Protocol. This option is available only for Enterprise level.

Opportunistic
Key Caching
(OKC)

Turn on the Opportunistic key caching (OKC) toggle switch to reduce the time needed
for authentication. When OKC is used, multiple IAPs can share Pairwise Master Keys
(PMKs) among themselves, and the station can roam to a new access points that has not
visited before and reuse a PMK that was established with the current IAP. OKC allows the
station to roam quickly to an access point it has never authenticated to, without having to
perform pre-authentication. OKC is available specifically on WPA2 SSIDs only.

MAC
Authentication
for Enterprise
Networks

To enable MAC address based authentication for Personal and Open security levels, turn
on the toggle switch to enable MAC Authentication. For Enterprise security level, the
following options are available:
n Perform MAC authentication before 802.1X—Select this to use 802.1X

authentication only when the MAC authentication is successful.
n MAC Authentication Fail-Through—On selecting this, the 802.1X authentication is

attempted when the MAC authentication fails.
n If MAC Authentication is enabled, configure the following parameters:
n Delimiter Character—Specify a character (for example, colon or dash) as a delimiter

for the MAC address string. When configured, the IAP uses the delimiter in the MAC
authentication request. For example, if you specify the colon as a delimiter, MAC
addresses in the xx:xx:xx:xx:xx:xx format are used. If the delimiter is not specified, the
MAC address in the xxxxxxxxxxxx format is used. This option is available only when
MAC authentication is enabled.

n Uppercase Support—Turn on the toggle switch to allow the IAP to use uppercase
letters in MAC address string for MAC authentication. This option is available only if
MAC authentication is enabled.

Table 74: Advanced WLAN Security Parameters
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Data pane item Description

Reauth Interval Specify a value for Reauth Interval. When set to a value greater than zero, IAPs
periodically re-authenticate all associated and authenticated clients.
If the re-authentication interval is configured:
On an SSID performing L2 authentication (MAC or 802.1X authentication): When re-
authentication fails, the clients are disconnected. If the SSID is performing only MAC
authentication and has a pre-authentication role assigned to the client, the client will get a
post-authentication role only after a successful re-authentication. If re-authentication fails,
the client retains the pre-authentication role.
On an SSID performing both L2 and L3 authentication (MAC with captive portal
authentication): When re-authentication succeeds, the client retains the role that is
already assigned. If re-authentication fails, a pre-authentication role is assigned to the
client.
On an SSID performing only L3 authentication (captive portal authentication): When re-
authentication succeeds, a pre-authentication role is assigned to the client that is in a
post-authentication role. Due to this, the clients are required to go through captive portal
to regain access.

Denylisting By default, this option is disabled. To enable denylisting of the clients with a specific
number of authentication failures, select Denylisting and specify a value for Max
Authentication Failures. The users who fail to authenticate the number of times
specified in Max Authentication Failures field are dynamically denylisted. By default, the
Denylisting option is disabled.

Enforce DHCP Enforces WLAN SSID on IAP clients. When DHCP is enforced.
A layer-2 user entry is created when a client associates with an IAP.
The client DHCP state and IP address are tracked.
When the client obtains an IP address from DHCP, the DHCP state changes to complete.
If the DHCP state is complete, a layer-3 user entry is created.
When a client roams between the IAPs, the DHCP state and the client IP address is
synchronized with the new IAP.

WPA3 Transition Enable this option to allow transition from WPA3 to WPA2 and vice versa. The WPA3
Transition appears only when WPA3 is selected in the Key Management for Personal,
Captive Portal, and Open level.

Legacy Support Enable this option to allow backward compatibility of encryption modes in networks. The
Legacy Support appears only when WPA3 is selected in the Key Management for
Personal, Captive Portal, and Open level.

Use IP for Calling
Station ID

Enable this option to configure client IP address as calling station ID. When this option is
enabled, the following options are displayed:
n Called Station ID Type—Select any of the following options for configuring called

station ID:
o Access Point Group—Uses the VC ID as the called station ID.
o Access Point Name—Uses the host name of the IAP as the called station ID.
o VLAN ID—Uses the VLAN ID of as the called station ID.
o IP Address—Uses the IP address of the IAP as the called station ID.
o MAC address—Uses the MAC address of the IAP as the called station ID.

n Called Station ID Include SSID—Appends the SSID name to the called station ID.

NOTE: The Called Station ID Type detail can be configured even if the Use IP for Calling
Station ID is set to disabled.

n Called Station ID Delimiter—Sets delimiter at the end of the called station ID.
n Max Authentication Failures—Sets a value for the maximum allowed authentication

failures.
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Delimiter
Character

Specify a character (for example, colon or dash) as a delimiter for the MAC address string.
When configured, the IAP uses the delimiter in the MAC authentication request. For
example, if you specify the colon as a delimiter, MAC addresses in the xx:xx:xx:xx:xx:xx
format are used. If the delimiter is not specified, the MAC address in the xxxxxxxxxxxx
format is used. This option is available only when MAC authentication is enabled.

Uppercase
Support

Select this option to allow the IAP to use uppercase letters in MAC address string for MAC
authentication. This option is available only if MAC authentication is enabled.

Fast Roaming Enable the following fast roaming features as per your requirement:
n 802.11k—Turn on the 802.11k toggle switch to enable 802.11k roaming. The 802.11k

protocol enables IAPs and clients to dynamically measure the available radio
resources. When 802.11k is enabled, IAPs and clients send neighbor reports, beacon
reports, and link measurement reports to each other.

n 802.11v—Turn on the 802.11v toggle switch to enable 802.11v based BSS transition.
The 802.11v standard defines mechanisms for wireless network management
enhancements and BSS transition management. It allows the client devices to
exchange information about the network topology and RF environment. The BSS
transition management mechanism enables an IAP to request a voice client to
transition to a specific IAP, or suggest a set of preferred IAPs to a voice client, due to
network load balancing or BSS termination. It also helps the voice client identify the
best IAP to transition to as they roam.

n RRM Quiet IE—Configures a radio resource management IE profile elements
advertised by an IAP.

Configuring ACLs for User Access to a Wireless Network

You can configure up to 64 access rules for a wireless network profile. To configure access rules for a
network, complete the following steps:

1. In the Access tab, turn on the Downloadable Role toggle switch to allow downloading of pre-
existing user roles. For more information, see Configuring Downloadable Roles.

n The Downloadable Role feature is optional.

n The Downloadable Role feature is available only for networks that include APs that run a
minimum of Aruba Instant 8.4.0.0 firmware version with a minimum of ClearPass server version
6.7.8.

n At least one radius server must be configured to apply the Downloadable Role feature. For more
information on configuring radius server, see Authentication Servers for IAPs.

2. Click the action corresponding to the server.
The Edit Server page is displayed.
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Viewing Wireless SSID Summary

In the Summary tab, the Network Summary page displays all the settings configured in the General,
VLANs, Security, and Access tabs. Click Save Settings to complete the network profile creation and
save the settings.

Configuring Wireless Networks for Guest Users on IAPs
Instant Access Points (IAPs) support the captive portal authentication method in which a webpage is
presented to the guest users, when they try to access the Internet in hotels, conference centers, or Wi-Fi
hotspots. The webpage also prompts the guest users to authenticate or accept the usage policy and
terms. Captive portals are used at Wi-Fi hotspots and can be used to control wired access as well.

The captive portal solution for an IAP cluster consists of the following:

n The captive portal web login page hosted by an internal or external server.
n The RADIUS authentication or user authentication against internal database of the IAP.
n The SSID broadcast by the IAP.

The IAP administrators can create a wired or WLAN guest network based on captive portal
authentication for guests, visitors, contractors, and any non-employee users who can use the enterprise
Wi-Fi network. Administrators can also create guest accounts and customize the captive portal page
with organization-specific logo, terms, and usage policy. With captive portal authentication and guest
profiles, the devices associating with the guest SSID are assigned an initial role and are assigned IP
addresses. When a guest user tries to access a URL through HTTP or HTTPS, the captive portal webpage
prompts the user to authenticate with a user name and password.

Splash Page Profiles
Instant APs support the following types of splash page profiles:

n Internal Captive portal—Select this splash page to use an internal server for hosting the captive
portal service. Internal captive portal supports the following types of authentication:
o Internal Authenticated—When Internal Authenticated is enabled, a guest user who is pre-

provisioned in the user database has to provide the authentication details.
o Internal Acknowledged—When Internal Acknowledged is enabled, a guest user has to accept

the terms and conditions to access the Internet.
n External Captive portal—Select this splash page to use an external portal on the cloud or on a

server outside the enterprise network for authentication.
n None—Select to disable the captive portal authentication.

To create splash page profiles, see the following sections:

n Creating a Wireless Network Profile for Guest Users
n Configuring an Internal Captive Portal Splash Page Profile on page 365
n Configuring an External Captive Portal Splash Page Profile
n Configuring Wireless Networks for Guest Users on IAPs
n Configuring Wireless Networks for Guest Users on IAPs
n Configuring ACLs for Guest User Access
n Configuring Captive Portal Roles for an SSID
n Disabling Captive Portal Authentication
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Creating a Wireless Network Profile for Guest Users

To create an SSID for guest users, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group that contains at least one IAP.
The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of access points is displayed in the List view.

3. Click the Config icon.

The tabs to configure the access points are displayed.

4. Click the WLANs tab.

The WLANs details page is displayed.

5. In the WLANs page, click + Add SSID.

The Create a New Network pane is displayed.

6. Under General, enter a network name in the Name (SSID) text-box.
7. If configuring a wireless guest profile, set the required WLAN configuration parameters described

in Table 73.

8. Click Next.
The VLANs details are displayed.

9. Under VLANs, select the options for Client IP Assignment as described in Table 75.

The following table lists the VLAN assignment options.

Parameter Description

Instant AP assigned When this option is selected, the client obtains the IP address from the virtual
controller. The virtual controller creates a private subnet and VLAN on the IAP for
the wireless clients. The network address translation for all client traffic that goes
out of this interface is carried out at the source. This setup eliminates the need for
complex VLAN and IP address management for a multi-site wireless network. For
more information on DHCP scopes and server configuration, see Configuring DHCP
Pools and Client IP Assignment Modes on IAPs.
If this option is selected, specify any of the following options in Client VLAN
Assignment:
n Internal VLAN—Assigns IP address to the client in the same subnet as the IAPs.

By default, the client VLAN is assigned to the native VLAN on the wired network.
n Custom—Allows you to customize the client VLAN assignment to a specific

VLAN, or a range of VLANs. When this option is selected, select the scope from
the VLAN ID drop-down list.

External DHCP server
assigned

When this option is selected, specify any of the following options in Client VLAN
Assignment:
n Static—In VLAN ID, specify a VLAN ID for a single VLAN(s). If a large number of

clients need to be in the same subnet, you can select this option to configure
VLAN pooling. VLAN pooling allows random assignment of VLANs from a pool of
VLANs to each client connecting to the SSID.

n Dynamic—Assigns the VLANs dynamically from a DHCP server.

Table 75: VLANs Assignment
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Parameter Description

n Native VLAN—Assigns the client VLAN is assigned to the native VLAN.
To add a new VLAN assignment rule, complete the following steps:

1. Click +Add Rule in the VLAN Assignment Rules window. The New VLAN
Assignment Rule page is displayed.

2. Enter the Attribute, Operator, String, and VLAN details, and then click OK.

To add a new Named VLAN, complete the following steps:

1. Click +Add Named VLAN. The Add Named VLAN window is displayed.

2. Enter the VLAN Name and VLAN details, and then click OK.

NOTE: To show or hide the Named VLANs, click Show Named VLANs. Click the
Show Named VLANs, to view the Named VLAN table.
To delete a VLAN assignment rule, select a rule in the VLAN Assignment Rules
window, and then click the delete icon.
To delete, select a Named VLAN in the Named VLAN table, and then click the delete
icon.

NOTE: From Aruba Central On-Premises 2.5.4, the Add Named VLAN window
supports adding multiple VLAN IDs and VLAN range.

For more information, see Configuring VLAN Assignment Rule.

Configuring an Internal Captive Portal Splash Page Profile

To configure an internal captive portal profile, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group that contains at least one IAP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of access points is displayed in the List view.

3. Click the Config icon.

The tabs to configure the access points are displayed.

4. Click the WLANs tab.

The WLANs details page is displayed.

5. In the Wireless SSIDs table, select a guest SSID, and then click the edit icon.

6. Under Security tab, in the Security Level, select Visitors and configure the parameters
described in Table 76.

7. Click Save Settings.

The following table lists the Internal captive portal configuration parameters.

Parameter Description

Type Select Internal Captive Portal from the drop-down list.

Table 76: Internal Captive Portal Configuration Parameters



Aruba Central On-Premises 2.5.7 | User Guide 366

Parameter Description

Captive Portal
Location

Select Acknowledged or Authenticated from the drop-down list.

Customize Captive
Portal

Under Splash Page, when Customize Captive Portal is clicked, use the editor to
specify text and colors for the initial page that is displayed to the users connecting to
the network. The initial page asks for user credentials or email, depending on the
splash page type (Authenticated or Acknowledged) for which you are customizing
the splash page design.
Complete the following steps to customize the splash page design:
n Top banner title—Enter a title for the banner.
n Header fill color—Specify a background color for the header.
n Welcome text—To change the welcome text, click the first square box in the

splash page, enter the required text in the Welcome text box, and click OK.
Ensure that the welcome text does not exceed 127 characters.

n Policy text—To change the policy text, click the second square in the splash
page, enter the required text in the Policy text box, and click OK. Ensure that the
policy text does not exceed 255 characters.

n Page fill color—To change the color of the splash page, click the Splash page
rectangle and select the required color from the color palette.

n Redirect URL—To redirect users to another URL, specify a URL in Redirect URL.
n Logo image—To upload a custom logo, click Choose Fileto upload. Ensure that

the image file size does not exceed 16 KB. To delete an image, click Delete Logo.
To preview the captive portal page, click preview_splash_page.
To configure a captive portal proxy server or global proxy server to match your
browser configuration, enter the IP address and port number in the Captive-portal
proxy server IP and Captive Portal Proxy Server Port fields.

Encryption By default, this field is disabled. Turn on the toggle switch to enable and configure the
following encryption parameters:
n Key Management—Specify an encryption and authentication key.
n Passphrase format—Specify a passphrase format.
n Passphrase—Enter a passphrase.
n Retype—Retype the passphrase to confirm.

Key Management Select Open or Enhanced Open from the drop-down list.

Advanced Settings

Captive Portal Proxy
Server IP

Specify the IP address of the Captive Portal proxy server.

Captive Portal Proxy
Server Port

Specify the port number of the Captive Portal proxy server.

MAC Authentication Configure the following parameters:
n MAC Authentication—To enable MAC address based authentication for

Personal and Open security levels, turn on the MAC Authentication toggle
switch.

n Secondary Server—To add another server for authentication, configure another
authentication server.

n Load Balancing—Turn on the toggle switch to enable, if you are using two

Table 76: Internal Captive Portal Configuration Parameters
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Parameter Description

RADIUS authentication servers, to balance the load across these servers. For
more information on the dynamic load balancing mechanism, see Configuring
DHCP Server for Assigning IP Addresses to IAP Clients.

To use an internal server, select Internal Server and add the clients that are required
to authenticate with the internal RADIUS Server. Click Users to add the users.
To add a new server, click +. For information on configuring external servers, see
Configuring External Authentication Servers for IAPs.

Use IP for Calling
Station ID

Enable this option to configure client IP address as calling station ID.

Delimiter Character Specify a character (for example, colon or dash) as a delimiter for the MAC address
string. When configured, the IAP uses the delimiter in the MAC authentication
request. For example, if you specify the colon as a delimiter, MAC addresses in the
xx:xx:xx:xx:xx:xx format are used. If the delimiter is not specified, the MAC address in
the xxxxxxxxxxxx format is used. This option is available only when MAC
authentication is enabled.

Called Station ID
Type

Select any of the following options for configuring called station ID:
n Access Point Group—Uses the VC ID as the called station ID.
n Access Point Name—Uses the host name of the IAP as the called station ID.
n VLAN ID—Uses the VLAN ID of as the called station ID.
n IP Address—Uses the IP address of the IAP as the called station ID.
n MAC address—Uses the MAC address of the IAP as the called station ID.

Reauth Interval Specify a value for Reauth Interval. When set to a value greater than zero, IAPs
periodically re-authenticate all associated and authenticated clients.

Accounting Select an accounting mode for posting accounting information at the specified
Accounting interval. When the accounting mode is set to Authentication, the
accounting starts only after client authentication is successful and stops when the
client logs out of the network. If the accounting mode is set to Association, the
accounting starts when the client associates to the network successfully and stops
when the client disconnects. This is applicable for WLAN SSIDs only.

Denylisting If you are configuring a wireless network profile, turn on the Denylisting toggle
switch to denylist clients with a specific number of authentication failures. This is
applicable for WLAN SSIDs only.

Max Authentication
Failures

If you are configuring a wireless network profile, turn on the Denylisting toggle
switch to denylist clients with a specific number of authentication failures. This is
applicable for WLAN SSIDs only.

Enforce DHCP If you are configuring a wireless network profile, turn on the Denylisting toggle
switch to denylist clients with a specific number of authentication failures. This is
applicable for WLAN SSIDs only.

WPA3 Transition If you are configuring a wireless network profile, turn on the Denylisting toggle
switch to denylist clients with a specific number of authentication failures. This is
applicable for WLAN SSIDs only.

Called Station ID
Include SSID

If you are configuring a wireless network profile, turn on the Denylisting toggle
switch to denylist clients with a specific number of authentication failures. This is
applicable for WLAN SSIDs only.

Table 76: Internal Captive Portal Configuration Parameters
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Parameter Description

Uppercase Support If you are configuring a wireless network profile, turn on the Denylisting toggle
switch to denylist clients with a specific number of authentication failures. This is
applicable for WLAN SSIDs only.

Disable if uplink type
is

To exclude uplink(s), expand Disable if uplink type is, and turn on the toggle switch
for the uplink type(s). For example, Ethernet, Wi-Fi, and 3G/4G.

Table 76: Internal Captive Portal Configuration Parameters

Configuring an External Captive Portal Splash Page Profile

You can configure external captive portal profiles and associate these profiles to a user role or SSID. You
can create a set of captive portal profiles and associate these profiles with an SSID or a wired profile.
You can configure up to eight external captive portal profiles.

When the captive portal profile is associated to an SSID, it is used before user authentication. If the
profile is associated to a role, it is used only after the user authentication. When a captive portal profile
is applied to an SSID or wired profile, the users connecting to the SSID or wired network are assigned a
role with the captive portal rule. The guest user role allows only DNS and DHCP traffic between the
client and network, and directs all HTTP or HTTPS requests to the captive portal unless explicitly
permitted.

To configure an external captive portal profile, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one IAP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the IAPs are displayed.

4. Click the WLANs tab.

The WLANs details page is displayed.

5. In the Wireless SSIDs table, select a guest SSID, and then click the edit icon.
6. Under Security tab, in the Security Level, select Visitors.
7. Select the Splash Page type as External.
8. If required, configure a captive portal proxy server or a global proxy server to match your browser

configuration by specifying the IP address and port number in the Captive Portal Proxy Server
IP and Captive Portal Proxy Server Port fields.

9. Select a captive portal profile. To add a new profile, click + and configure the parameters
described in Table 77.

10. Click Save.
11. On the external captive portal splash page configuration page, specify encryption settings if

required.

12. Specify the following authentication parameters under Advanced Settings:
n MAC Authentication—To enable MAC address based authentication for Personal and Open

security levels, turn on the MAC Authentication toggle switch.
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n Primary Server—Sets a primary authentication server.
o To use an internal server, select Internal server and add the clients that are required to

authenticate with the internal RADIUS Server. Click Users to add the users.
o To add a new server, click +. For information on configuring external servers, see

Configuring External Authentication Servers for IAPs.
n Secondary Server—To add another server for authentication, configure another

authentication server.
n Load Balancing—Turn on the toggle switch to enable, if you are using two RADIUS

authentication servers, to balance the load across these servers.

13. If required, under Walled Garden, create a list of domains that are denylisted and also a allowlist
of websites that the users connected to this splash page profile can access.

14. To exclude uplink, select an uplink type.

15. If MAC authentication is enabled, you can configure the following parameters:
n Delimiter Character—Specify a character (for example, colon or dash) as a delimiter for the

MAC address string. When configured, the IAP uses the delimiter in the MAC authentication
request. For example, if you specify the colon as a delimiter, MAC addresses in the
xx:xx:xx:xx:xx:xx format are used. If the delimiter is not specified, the MAC address in the
xxxxxxxxxxxx format is used. This option is available only when MAC authentication is
enabled.

n Uppercase Support—Turn on the toggle switch to enable to allow the IAP to use uppercase
letters in MAC address string for MAC authentication. This option is available only if MAC
authentication is enabled.

16. Configure the Reauth Interval. Specify a value for Reauth Interval. When set to a value greater
than zero, IAPs periodically re-authenticate all associated and authenticated clients.

17. If required, enable denylisting. Set a threshold for denylisting clients based on the number of
failed authentication attempts.

18. Click Save Settings.

The following table lists the external captive portal profile configuration parameters.

Data Pane
Item Description

Name Enter a name for the profile.

Type Select any one of the following types of authentication:
n Radius Authentication—Select this option to enable user authentication against a

RADIUS server.
n Authentication Text—Select this option to specify an authentication text. The

specified text will be returned by the external server after a successful user
authentication.

IP or Hostname Enter the IP address or the host name of the external splash page server.

URL Enter the URL of the external captive portal server.

Table 77: External Captive Portal Profile Configuration Parameters
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Data Pane
Item Description

Port Enter the port number that is used for communicating with the external captive portal
server.

Use HTTPS Select this to enforce clients to use HTTPS to communicate with the captive portal server.
This option is available only if RADIUS Authentication is selected.

Captive Portal
Failure

This field allows you to configure Internet access for the guest users when the external
captive portal server is not available. Select Deny Internet to prevent guest users from
using the network, or Allow Internet to access the network.

Server Offload Select the check box to enable the server offload feature. The server offload feature
ensures that the non-browser client applications are not unnecessarily redirected to the
external captive portal server, thereby reducing the load on the external captive portal
server.

Prevent Frame
Overlay

Select this check box to prevent the overlay of frames. When enabled, the frames display
only those pages that are in the same domain as the main page.

Automatic URL
Allowlisting

On enabling this for the external captive portal authentication, the URLs that are allowed
for the unauthenticated users to access are automatically allowlisted.

Auth Text If the External Authentication splash page is selected, specify the authentication text
that is returned by the external server after successful authentication. This option is
available only if Authentication Text is selected.

Redirect URL Specify a redirect URL if you want to redirect the users to another URL.

Configuring ACLs for Guest User Access

To configure access rules for a guest network, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one IAP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the IAPs are displayed.

4. Click the WLANs tab.

The WLANs details page is displayed.

5. Under WLANs tab, in the Wireless SSIDs table, select a guest SSID and click the edit icon.
6. Click the Access tab.
7. Under Access rules, select any of the following types of access control:

n Unrestricted—Select this to set unrestricted access to the network.
n Network Based—Select Network Based to set common rules for all users in a network. By

default, Allow any to all destinations access rule is enabled. This rule allows traffic to all
destinations. To define an access rule, complete the following steps:

a. Click + and select appropriate options for Rule Type, Service, Action, Destination, and
Options fields.

b. Click Save.
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n Role Based—Select Role Based to enable access based on user roles.

For role-based access control, complete the following steps:

1. To create a user role:
a. Click +Add Role in Role pane.
b. Enter a name for the new role and click OK.

2. To create access rules for a specific user role:
a. Click +Add Rule in Access Rules for Selected Roles, and select appropriate options for Rule

Type, Service, Action, Destination, and Options fields.
b. Click Save.

3. To create a role assignment rule:
a. Under Role Assignment Rules, click +Add Role Assignment. The New Role Assignment

Rule pane is displayed.
b. Select appropriate options in Attribute, Operator, String, and Role fields.
c. Click Save.

4. To assign pre-authentication role, select the Assign Pre-Authentication Role check-box and
select a pre-authentication role from the drop-down list.

5. Click Save Settings.

Configuring Captive Portal Roles for an SSID

You can configure an access rule to enforce captive portal authentication for SSIDs with 802.1X
authentication enabled. You can configure rules to provide access to an external captive portal, internal
captive portal, so that some of the clients using this SSID can derive the captive portal role.

The following conditions apply to the 802.1X and captive portal authentication configuration:

n If captive portal settings are not configured for a user role, the captive portal settings configured for
an SSID are applied to the client's profile.

n If captive portal settings are not configured for a SSID, the captive portal settings configured for a
user role are applied to the client's profile.

n If captive portal settings are configured for both SSID and user role, the captive portal settings
configured for a user role are applied to the profile of the client.

To create a captive portal role for the Internal and External splash page types:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one IAP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the IAPs are displayed.

4. Click the WLANs tab.

The WLANs details page is displayed.

5. Under WLANs tab, in the Wireless SSIDs table, select a guest SSID and click the edit icon.
6. Click the Access tab.
7. Under Access rules, select Role Based.
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8. Click +Add Rule in Access Rules for Selected Roles.

9. In the Add Rules window, specify the parameters described in Table 78.

10. Click Save.

The enforce captive portal rule is created and listed as an access rule.

11. Click Save Settings.

The following table lists the access rule configuration parameters.

Data
Pane Item Description

Rule Type Select Captive Portal from the drop-down list.

Splash
Page Type

Select a splash page type from the drop-down list.

Internal If Internal is selected as Splash Page Type drop-down list, complete the following steps:
n Top banner title—Enter a title for the banner. To preview the page with the new banner

title, click Preview splash page.
n Header fill color—Specify a background color for the header.
n Welcome text—To change the welcome text, click the first square box in the splash page,

enter the required text in the Welcome text box, and click OK. Ensure that the welcome text
does not exceed 127 characters.

n Policy text—To change the policy text, click the second square in the splash page, enter the
required text in the Policy text box, and click OK. Ensure that the policy text does not exceed
255 characters.

n Page fill color—To change the color of the splash page, click the Splash page rectangle and
select the required color from the color palette.

n Redirect URL—To redirect users to another URL, specify a URL in Redirect URL.
n Logo image—To upload a custom logo, click Choose Fileto upload. Ensure that the image file

size does not exceed 16 KB. To delete an image, click Delete Logo.
To preview the captive portal page, click preview_splash_page.

External If External is selected as Splash Page Type drop-down list, complete the following steps:
n Captive Portal Profile—Select a profile from the drop-down list.

To create a profile, click the + icon and enter the following information in the External Captive
Portal window.
n Name
n Authentication Type—From the drop-down list, select either RADIUS Authentication (to

enable user authentication against a RADIUS server) or Authentication Text (to specify the
authentication text to returned by the external server after a successful user authentication).

n IP OR Hostname—Enter the IP address or the hostname of the external splash page server.
n URL—Enter the URL for the external splash page server.
n Port—Enter the port number for communicating with the external splash page server.
n Captive Portal Failure—This field allows you to configure Internet access for the guest

clients when the external captive portal server is not available. From the drop-down list,
select Deny Internet to prevent clients from using the network, or Allow Internet to allow
the guest clients to access Internet when the external captive portal server is not available.

Table 78: Access Rule Configuration Parameters
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Data
Pane Item Description

n Automatic URL Allowlisting—Turn on the toggle switch to enable or disable automatic
allowlisting of URLs. On selecting this for the external captive portal authentication, the URLs
allowed for the unauthenticated users to access are automatically allowlisted. The automatic
URL allowlisting is disabled by default.

n Server offload—Turn on the toggle switch to offload the server.
n Prevent Frame Overlay—Turn on the toggle switch to prevent frame overlay.
n Use VC IP in Redirect URL—Turn on the toggle switch to use the virtual controller IP

address as a redirect URL.
n Auth TEXT—Indicates the authentication text returned by the external server after a

successful user authentication.
n Redirect URL—Specify a redirect URL to redirect the users to another URL.

To edit a profile, click the edit icon and modify the parameters in the External Captive Portal
window.

Table 78: Access Rule Configuration Parameters

The client can connect to this SSID after authenticating with user name and password. After the user
logs in successfully, the captive portal role is assigned to the client.

Disabling Captive Portal Authentication

To disable captive portal authentication, perform the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one IAP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the IAPs are displayed.

4. Click the WLANs tab.

The WLANs details page is displayed.

5. In the Wireless SSIDs table, select a guest SSID, and then click the edit icon.
6. Under Security tab, in the Security Level, select Visitors.
7. Under Splash Page, select None from the Captive Portal Type drop-down list.
8. Click Save Settings.

Configuring Client Isolation
Aruba Central On-Premises supports the Client Isolation feature isolates clients from one another and
disables all peer-to-peer communication within the network. Client isolation disables inter-client
communication by allowing only client to gateway traffic from clients to flow in the network. All other
traffic from the client that is not destined to the gateway or configured servers will not be forwarded by
the Instant Access Point (IAP).

This feature enhances the security of the network and protects it from vulnerabilities. Client Isolation
can only be configured through the CLI. When Client Isolation is configured, the IAP learns the IP,
subnet mask, MAC, and other essential information of the gateway and the DNS server. A subnet table
of trusted destinations is then populated with this information. Wired servers used in the network
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should be manually configured into this subnet table to serve clients. The destination MAC of data
packets sent by the client is validated against this subnet table and only the data packets destined to the
trusted addresses in the subnet table are forwarded by the IAP. All other data packets are dropped.

Client Isolation feature is supported only in IPv4 networks. This feature does not support AirGroup and
affects Chromecast and Airplay services.

Enabling Client Isolation Feature for Wireless Networks in Aruba Central On-Premises
To enable the Client Isolation feature, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one IAP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the IAPs are displayed.

4. Click the WLANs tab.

The WLANs details page is displayed.

5. In the WLANs page, click +Add SSID.

The Create a New Network page is displayed.

6. Click Advanced Settings and expand Miscellaneous.
7. Turn on the Deny Intra VLAN Traffic toggle switch.
8. Click Next.

Management Frames Protection
Aruba Central On-Premises supports the Management Frame Protection (MFP) feature in networks that
include Aruba Instant 8.5.0.0 firmware version and later. This feature protects networks against forged
management frames spoofed from other devices that might otherwise disrupt a valid user session.

The MFP increases the security by providing data confidentiality of management frames. MFP uses
802.11i framework that establishes encryption keys between the client and Instant AP.

Enabling Management Frames Protection Feature for Wireless Networks in Aruba
Central On-Premises
To enable the MFP feature, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one IAP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the IAPs are displayed.

4. Click the WLANs tab.

The WLANs details page is displayed.
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5. In the WLANs page, click +Add SSID. To modify an existing SSID, select a wireless SSID from the
Wireless SSIDs table and then click the edit icon.

6. In the General tab, click Advanced Settings.
7. Expand Miscellaneous.
8. Turn on the Management Frames Protection toggle switch to enable the MFP feature.
9. Click Next.

10. Click Save Settings.

The MFP configuration is a per-SSID configuration. The MFP feature can be enabled only on WPA2-PSK and
WPA2-Enterprise SSIDs. The 802.11r fast roaming option will not take effect when the MFP is enabled.

Configuring Wired Networks for Guest Users on IAPs
Instant Access Points (IAPs) support the captive portal authentication method in which a webpage is
presented to the guest users, when they try to access the Internet in hotels, conference centres, or Wi-Fi
hotspots. The webpage also prompts the guest users to authenticate or accept the usage policy and
terms. Captive portals are used at Wi-Fi hotspots and can be used to control wired access as well.

The captive portal solution for an IAP cluster consists of the following:

n The captive portal web login page hosted by an internal or external server.
n The RADIUS authentication or user authentication against internal database of the IAP.
n The SSID broadcast by the IAP.

The IAP administrators can create a wired or WLAN guest network based on captive portal
authentication for guests, visitors, contractors, and any non-employee users who can use the enterprise
Wi-Fi network. Administrators can also create guest accounts and customize the captive portal page
with organization-specific logo, terms, and usage policy. With captive portal authentication and guest
profiles, the devices associating with the guest SSID are assigned an initial role and are assigned IP
addresses. When a guest user tries to access a URL through HTTP or HTTPS, the captive portal webpage
prompts the user to authenticate with a user name and password.

Splash Page Profiles
IAPs support the following types of splash page profiles:

n Internal Captive portal—Select this splash page to use an internal server for hosting the captive
portal service. Internal captive portal supports the following types of authentication:
o Internal Authenticated—When Internal Authenticated is enabled, a guest user who is pre-

provisioned in the user database has to provide the authentication details.
o Internal Acknowledged—When Internal Acknowledged is enabled, a guest user has to accept

the terms and conditions to access the Internet.
n External Captive portal—Select this splash page to use an external portal on the cloud or on a

server outside the enterprise network for authentication.
n None—Select to disable the captive portal authentication.

For information on how to create splash page profiles, see the following sections:

n Creating a Wired Network Profile for Guest Users
n Configuring an Internal Captive Portal Splash Page Profile
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n Configuring an External Captive Portal Splash Page Profile
n Configuring Wired Networks for Guest Users on IAPs

Creating a Wired Network Profile for Guest Users

To create a wired SSID for guest access, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one IAP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the IAPs are displayed.

4. Click Show Advanced.
5. Click the Interfaces tab.

The Interfaces page is displayed.

6. Click the Wired accordion.
7. To create a new wired SSID profile, click + Add Port Profile.

The Create a New Network pane is displayed.

8. Under General, enter the following information:
n Name—Enter a name.
n ports—Select port(s) form the drop-down list.

9. Click Next to configure the VLANs settings.

The VLANs details are displayed.

10. In the VLANs tab, select a type of mode from the Mode drop-down list.

11. Select the options for Client IP Assignment as described in Table 79

The following table lists the VLAN assignment options.

Parameter Description

Instant AP assigned Select this option to allow the Virtual Controller to assign IP addresses to the wired
clients. When the Virtual Controller assignment is used, the source IP address is
translated for all client traffic that goes through this interface. The Virtual Controller
can also assign a guest VLAN to a wired client.
If this option is selected, specify any of the following options in Client VLAN
Assignment:
n Default—When the client VLAN must be assigned to the native VLAN on the

network.
n Custom—To customize the client VLAN assignment to a specific VLAN, or a

range of VLANs.

External DHCP server
assigned

Select this option to allow the clients to receive an IP address from the network to
which the Virtual Controller is connected. On selecting this option, the New button
to create a VLAN is displayed. Create a new VLAN if required.

Table 79: VLANs Parameters
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Configuring an Internal Captive Portal Splash Page Profile

To configure internal captive portal profile, complete the following steps:

1. Open the guest SSID to edit and configure the parameters in the Ports > Security page described
in Table 80.

2. Click Save Settings.

The following table lists the Internal captive portal configuration parameters.

Parameter Description

Captive Portal Type Select any of the following from the drop-down list:
n Internal - Authenticated—When Internal Authenticated is selected, the guest

users are required to authenticate in the captive portal page to access the
Internet. The guest users who are required to authenticate must already be
added to the user database.

n Internal - Acknowledged—When Internal Acknowledged is selected, the guest
users are required to accept the terms and conditions to access the Internet.

n External—When External is selected, the guest users are required to enter the
proxy server details such as IP address and captive portal proxy server port
details. Also enter the details in Walled Garden, and Advanced section.

n None—Select this option if you do not want to set any splash page.

Captive Portal
Location

Select Acknowledged or Authenticated from the drop-down list.

Splash Page
Properties

Policy text for which you are customizing the splash page design.
Perform the following steps to customize the splash page design:
n Top Banner Title—Enter a title for the banner. To preview the page with the new

banner title, click Preview Splash Page.
n Header fill color—Specify a background color for the header.
n Welcome Text—To change the welcome text, click the first square box in the

splash page, enter the required text in the Welcome Text box, and click OK.
Ensure that the welcome text does not exceed 127 characters.

n Policy Text—To change the policy text, click the second square in the splash
page, enter the required text in the Policy Text box, and click OK. Ensure that the
policy text does not exceed 255 characters.

n Page Fill Color—To change the color of the splash page, click the Splash page
rectangle and select the required color from the color palette.

n Redirect URL—To redirect users to another URL, specify a URL in Redirect URL.
n Logo Image—To upload a custom logo, click Upload, browse the image file, and

click upload image. Ensure that the image file size does not exceed 16 KB. To
delete an image, click Delete.

To preview the captive portal page, click Preview splash page.
To configure a captive portal proxy server or global proxy server to match your
browser configuration, enter the IP address and port number in the Captive-portal
proxy server IP and Captive Portal Proxy Server Port fields.

Encryption By default, this field is disabled. Turn on the toggle switch to enable and configure the
following encryption parameters:
n Key Management—Specify an encryption and authentication key.

Table 80: Internal Captive Portal Configuration Parameters
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Parameter Description

n Passphrase format—Specify a passphrase format.
n Passphrase—Enter a passphrase and retype to confirm.

Authentication Configure the following parameters:
n MAC Authentication—To enable MAC address based authentication for

Personal and Open security levels, turn on the MAC Authentication toggle
switch.

n Secondary Server—To add another server for authentication, configure another
authentication server.

n Load Balancing—Turn on the toggle switch to enable, if you are using two
RADIUS authentication servers, to balance the load across these servers. For
more information on the dynamic load balancing mechanism, see Configuring
DHCP Server for Assigning IP Addresses to IAP Clients.

To use an internal server, select Internal Server and add the clients that are required
to authenticate with the internal RADIUS Server. Click Users to add the users.
To add a new server, click +. For information on configuring external servers, see
Configuring External Authentication Servers for IAPs.

Users Create and manage users in the captive portal network. Only registered users of type
Guest Employee will be able to access this network.

Advanced Settings >
MAC Authentication

To enable MAC address based authentication for Personal and Open security levels,
turn on the MAC Authentication toggle switch.

Advanced Settings >
Reauth Interval

Specify a value for Reauth Interval. When set to a value greater than zero, IAPs
periodically re-authenticate all associated and authenticated clients.

Advanced Settings >
Denylisting

If you are configuring a wireless network profile, turn on the Denylisting toggle
switch to denylist clients with a specific number of authentication failures. This is
applicable for WLAN SSIDs only.

Advanced Settings >
Disable If Uplink Type
Is

To exclude uplink, select an uplink type.

Table 80: Internal Captive Portal Configuration Parameters

Configuring an External Captive Portal Splash Page Profile

You can configure external captive portal profiles and associate these profiles to a user role or SSID. You
can create a set of captive portal profiles in the Security > External Captive Portal data pane and
associate these profiles with an SSID or a wired profile. You can also create a new captive portal profile
under the Security tab of the WLAN wizard or a Wired Network pane. You can configure up to eight
external captive portal profiles.

When the captive portal profile is associated to an SSID, it is used before user authentication. If the
profile is associated to a role, it is used only after the user authentication. When a captive portal profile
is applied to an SSID or wired profile, the users connecting to the SSID or wired network are assigned a
role with the captive portal rule. The guest user role allows only DNS and DHCP traffic between the
client and network, and directs all HTTP or HTTPS requests to the captive portal unless explicitly
permitted.
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To configure an external captive portal profile, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one IAP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the IAPs are displayed.

4. Click the WLANs tab.

The WLANs details page is displayed.

5. In the Wireless SSIDs table, select a guest SSID, and then click the edit icon.

6. Under Security tab, in the Security Level, select Visitors.
7. Select External Captive Portal from the Type drop-down list.
8. If required, configure a captive portal proxy server or a global proxy server to match your

browser configuration by specifying the IP address and port number in the Captive Portal Proxy
Server IP and Captive Portal Proxy Server Port fields.

9. Select a captive portal profile from the Captive Portal Profile drop-down list.

To add a new profile, click + and configure the parameters described in Table 81.

10. Click Save.
11. On the external captive portal splash page configuration page, specify encryption settings if

required.

12. Specify the following authentication parameters in Advanced Settings:
n MAC Authentication—To enable MAC address based authentication for Personal and Open

security levels, turn on the MAC Authentication toggle switch.
n Primary Server—Sets a primary authentication server.

o To use an internal server, select Internal server and add the clients that are required to
authenticate with the internal RADIUS Server. Click Users to add the users.

o To add a new server, click +. For information on configuring external servers, see
Configuring External Authentication Servers for IAPs.

n Secondary Server—To add another server for authentication, configure another
authentication server.

n Load Balancing—Turn on the toggle switch to enable, if you are using two RADIUS
authentication servers, to balance the load across these servers.

13. If required, under Walled Garden, create a list of domains that are denylisted and also an
allowlist of websites that the users connected to this splash page profile can access.

14. To exclude uplink, select an uplink type.

15. If MAC authentication is enabled, you can configure the following parameters:
n Delimiter Character—Specify a character (for example, colon or dash) as a delimiter for the

MAC address string. When configured, the IAP uses the delimiter in the MAC authentication
request. For example, if you specify the colon as a delimiter, MAC addresses in the
xx:xx:xx:xx:xx:xx format are used. If the delimiter is not specified, the MAC address in the
xxxxxxxxxxxx format is used. This option is available only when MAC authentication is
enabled.
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n Uppercase Support—Turn on the toggle switch to enable, to allow the IAP to use uppercase
letters in MAC address string for MAC authentication. This option is available only if MAC
authentication is enabled.

16. Configure the Reauth Interval. Specify a value for Reauth Interval. When set to a value greater
than zero, IAPs periodically re-authenticate all associated and authenticated clients.

17. If required, enable denylisting. Set a threshold for denylisting clients based on the number of
failed authentication attempts.

18. Click Save Settings.

The following table lists the external captive portal profile configuration parameters.

Data Pane Item Description

Name Enter a name for the profile.

Authentication
Type

Select any one of the following types of authentication from the drop-down list:
n Radius Authentication—Select this option to enable user authentication against a

RADIUS server.
n Authentication Text—Select this option to specify an authentication text. The

specified text will be returned by the external server after a successful user
authentication.

IP or Hostname Enter the IP address or the host name of the external splash page server.

URL Enter the URL of the external captive portal server.

Port Enter the port number that is used for communicating with the external captive portal
server.

Use HTTPS Select this to enforce clients to use HTTPS to communicate with the captive portal server.
This option is available only if RADIUS Authentication is selected.

Captive Portal
Failure

This field allows you to configure Internet access for the guest users when the external
captive portal server is not available. Select Deny Internet to prevent guest users from
using the network, or Allow Internet to access the network.

Automatic URL
Allowlisting

On enabling this for the external captive portal authentication, the URLs that are allowed
for the unauthenticated users to access are automatically allowlisted.

Server Offload Select the check box to enable the server offload feature. The server offload feature
ensures that the non-browser client applications are not unnecessarily redirected to the
external captive portal server, thereby reducing the load on the external captive portal
server.

Prevent Frame
Overlay

Select this check box to prevent the overlay of frames. When enabled, the frames display
only those pages that are in the same domain as the main page.

Auth Text If the External Authentication Splash page is selected, specify the authentication text
that is returned by the external server after successful authentication. This option is
available only if Authentication Text is selected from the Authentication Type drop-
down list.

Redirect URL Specify a redirect URL if you want to redirect the users to another URL.

Table 81: External Captive Portal Profile Configuration Parameters
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Configuring ACLs for Guest User Access

To configure access rules for a guest network, complete the following steps:

1. Under WLANs tab, in the Wireless SSIDs table, select a guest SSID and click the edit icon.

The Create a New Network pane is displayed.

2. Click the Access tab.
3. Under Access, select any of the following types of access control:

n Unrestricted—Select this to set unrestricted access to the network.
n Network Based—Select Network Based to set common rules for all users in a network. By

default, Allow any to all destinations access rule is enabled. This rule allows traffic to all
destinations. To define an access rule, complete the following steps:

a. Click + and select appropriate options for Rule Type, Service, Action, Destination, and
Options fields.

b. Click Save.
n Role Based—Select Role Based to enable access based on user roles.

i. Create a user role:
a. Click New in Role pane.
b. Enter a name for the new role and click OK

ii. Create access rules for a specific user role:
a. Click + and select appropriate options for Rule Type, Service, Action, Destination,

and Options fields.
b. Click Save.

iii. Create a role assignment rule.
a. Under Role Assignment Rule, click New. The New Role Assignment Rule pane is

displayed.
b. Select appropriate options in Attribute, Operator, String, and Role fields.
c. Click Save.

4. Click Save Settings.

Configuring Wired Port Profiles on IAPs
If the wired clients must be supported on the Instant Access Points (IAPs), configure wired port profiles
and assign these profiles to the ports of an IAP.

The wired ports of an IAP allow third-party devices such as VoIP phones or printers (which support only
wired port connections) to connect to the wireless network. You can also configure an ACL for additional
security on the Ethernet downlink.

To configure wired port profiles on IAP, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one IAP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the IAPs are displayed.

4. Click Show Advanced.
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5. Click the Interfaces tab.

The Interfaces page is displayed.

6. Click the Wired accordion.
7. To create a new wired port profile, click +Add Port Profile.

The Create a New Network pane is displayed.

Complete the configuration for each of the tabs in the Create a New Network page as described in the
below sections:

n Configuring General Network Profile Settings on page 382
n Configuring VLAN Network Profile Settings on page 383
n Configuring Security Settings on page 383
n Configuring Access Settings on page 385
n Configuring Network Port Profile Assignment on page 386

Configuring General Network Profile Settings
To configure general network profile settings, complete the following steps in the General tab:

1. Under General, enter the following information:
n Name—Enter a name.
n ports—Select port(s) form the drop-down list.

2. Under Advanced Settings section, configure the following parameters:
n Speed/Duplex—Select the appropriate value from the Speed and Duplex drop-down list.

Contact your network administrator if you need to assign speed and duplex parameters.
n Power over Ethernet—Turn on the Power over Ethernet toggle switch to enable PoE.
n Admin Status—The Admin Status indicates if the port is up or down.
n Content Filtering—Turn on the Content Filtering toggle switch to ensure that all DNS

requests to non-corporate domains on this wired port network are sent to OpenDNS.
n Uplink—Turn on the toggle switch to configure uplink on this wired port profile. If the Uplink

toggle switch is turned on and this network profile is assigned to a specific port, the port is
enabled as an uplink port.

n Spanning Tree—Turn on the toggle switch to enable STP on the wired port profile. STP
ensures that there are no loops in any bridged Ethernet network and operates on all downlink
ports, regardless of forwarding mode. STP does not operate on uplink ports and is supported
only on IAPs with three or more ports. By default, STP is disabled on wired port profiles.

n Inactivity Timeout—Enter the time duration after which an inactive user needs to be disabled
from the network. The user must undergo the authentication process to re-join the network.

n 802.3az—Turn on the toggle switch to enable, to support 802.3az Energy Efficient Ethernet
(EEE) standard on the device. This option allows the device to consume less power during
periods of low data activity. This setting can be enabled for provisioned IAPs or IAP groups
through the wired port network. If this feature is enabled for an IAP group, IAPs in the group
that do not support 802.3.az ignore this setting. This option is available for IAPs that support a
minimum of Aruba Instant 8.4.0.0 firmware version.

n Deny Intra VLAN Traffic—Turn on the toggle switch to disable intra VLAN traffic. It enables
the client isolation and disable all peer-to-peer communication. Client isolation disables inter-
client communication by allowing only client to gateway traffic from clients to flow in the
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network. All other traffic from the client that is not destined to the gateway or configured
servers will not be forwarded by the Instant AP. This feature enhances the security of the
network and protects it from vulnerabilities.

3. Click Next.
The VLANs details page is displayed.

Configuring VLAN Network Profile Settings
To configure VLAN settings, complete the following steps in the VLANs tab:

1. Mode—Specify any of the following modes:
n Access—Select this mode to allow the port to carry a single VLAN specified as the native VLAN.

If the Access mode is selected, perform one of the following options:
o If the Client IP Assignment is set to Virtual Controller Assigned, proceed to step 6.
o If the Client IP Assignment is set to Network Assigned, specify a value for Access VLAN

to indicate the VLAN carried by the port in the Access mode.
n Trunk—Select this mode to allow the port to carry packets for multiple VLANs specified as

allowed VLANs. If the Trunk mode is selected:
n Specify the Allowed VLAN, enter a list of comma separated digits or ranges, for example 1, 2,

5, or 1-4, or all. The Allowed VLAN refers to the VLANs carried by the port in Access mode.
n If the Client IP Assignment is set to Network Assigned, specify a value for Native VLAN. A

VLAN that does not have a VLAN ID tag in the frames is referred to as Native VLAN. You can
specify a value within the range of 1-4093.

2. Client IP Assignment—specify any of the following values:
n Instant AP Assigned—Select this option to allow the virtual controller to assign IP addresses

to the wired clients. When the virtual controller assignment is used, the source IP address is
translated for all client traffic that goes through this interface. The virtual controller can also
assign a guest VLAN to a wired client. In the Client VLAN Assignment section, select Default
when the client VLAN must be assigned to the native VLAN on the network. Select Custom to
customize the client VLAN assignment to a specific VLAN, or a range of VLANs. Click the Show
Named VLANs section to view all the named VLANs mapped to VLAN ID. Click +Add Named
VLAN and enter the VLAN Name and VLAN ID that is required to be mapped. Clicking OK
populates the named VLAN in the VLAN Name to VLAN ID Mapping table.

n External DHCP server Assigned—Select this option to allow the clients to receive an IP
address from the network to which the Virtual Controller is connected. On selecting this
option, the New button to create a VLAN is displayed. Create a new VLAN if required.

3. Click Next.
The Security details page is displayed.

Configuring Security Settings
To configure security-specific settings, complete the following steps in the Security tab:

1. On the Security pane, select the following security options as per your requirement:
n 802.1X Authentication—Set the toggle button to enable 802.1X Authentication. Configure

the basic parameters such as the authentication server, and MAC Authentication Fail-Through.
Select any of the following options for authentication server:
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o New—On selecting this option, an external RADIUS server must be configured to
authenticate the users. For information on configuring an external server, see Configuring
External Authentication Servers for IAPs.

o Internal Server—If an internal server is selected, add the clients that are required to
authenticate with the internal RADIUS server. Click the Manage Users link to add the users.

o Load Balancing—Set the toggle button to enable, if you are using two RADIUS
authentication servers, so that the load across the two RADIUS servers is balanced. For
more information on the dynamic load balancing mechanism, see Authentication Servers
for IAPs.

o MAC Authentication—To enable MAC authentication, enable the toggle button. The
MAC authentication is disabled by default.

o Captive Portal—Set the toggle button to enable captive portal authentication. For more
information on configuring security on captive portal, see Configuring Wired Networks for
Guest Users on IAPs.

o Open—Set the toggle button to enable, to set security for open network.

2. Enable the Port Type Trusted option to connect uplink and downlink to a trusted port only.

3. In the Primary Server field, perform one of the following steps:
n Internal Server—To use an internal server, select Internal Server and add the clients that are

required to authenticate with the internal RADIUS Server. Click Users to add the users. To add
a new server, click +. For information on configuring external servers, see Configuring External
Authentication Servers for IAPs.

n Secondary Server—To add another server for authentication, configure another
authentication server.

n Authentication Survivability—If an external server is configured for authentication, you can
enable authentication survivability. Specify a value in hours for Cache Timeout to set the
duration after which the authenticated credentials in the cache expires. When the cache
expires, the clients are required to authenticate again. You can specify a value within range of
1 to 99 hours. and the default value is 24 hours. By default, authentication survivability is
disabled.

n Load Balancing—Set the toggle button to enable, if you are using two RADIUS authentication
servers, to balance the load across these servers. For more information on the dynamic load
balancing mechanism, see Authentication Servers for IAPs.

4. MAC Authentication Fail-Thru—Set the toggle button to enable, to attempt 802.1X
authentication is attempted when the MAC authentication fails.

5. Under the Advanced Settings section, configure the following options:
n Use IP for Calling Station ID—Set the toggle button to enable, to configure client IP address

as calling station ID.
n Called Station ID Type—Select one of the following options:

o Access Point Group—Uses the VC ID as the called station ID.
o Access Point Name—Uses the host name of the IAP as the called station ID.
o IP Address—Uses the IP address of the IAP as the called station ID.
o MAC address—Uses the MAC address of the IAP as the called station ID.
o VLAN ID—Uses the VLAN ID of as the called station ID.
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The Called Station ID Type parameter can be configured even if the Use IP for Calling Station ID is
set to disabled.

n Reauth Interval—Specify the interval at which all associated and authenticated clients must
be re-authenticated.

6. Click Next.
The Access pane is displayed.

Configuring Access Settings
To configure access-specific settings, complete the following steps:

1. In the Access tab, turn on the Downloadable Role toggle switch to allow downloading of pre-
existing user roles. For more information, see Configuring Downloadable Roles.

n The Downloadable Role feature is optional. The Downloadable Role feature is available only for
networks that include APs that run a minimum of Aruba Instant 8.4.0.0 firmware version with a
minimum of ClearPass server version 6.7.8.

n At least one radius server must be configured to apply the Downloadable Role feature. For more
information on configuring radius server, see Authentication Servers for IAPs

2. Click the action corresponding to the server.

The Edit Server page is displayed.

The Edit Server page displays the radius server name. The Name field is non-editable.

3. Enter the CPPM username along with the CPPM authentication credentials for the radius server.
4. Click Ok.

5. Under Access Rules, configure the following access rule parameters:

a. Select any of the following types of access control:
n Role-based—Allows the users to obtain access based on the roles assigned to them.
n Unrestricted—Allows the users to obtain unrestricted access on the port.
n Network-based—Allows the users to be authenticated based on access rules specified for

a network.

b. If the Role-based access control is selected:
n Under Role, select an existing role for which you want to apply the access rules, or click

New and add the required role. To add a new access rule, click Add Rule under Access
Rules For Selected Roles.

The default role with the same name as the network is automatically defined for each network. The
default roles cannot be modified or deleted.

c. Configure role assignment rules. To add a new role assignment rule, click New under Role
Assignment Rules. Under New Role Assignment Rule:
n Select an attribute.
n Specify an operator condition.
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n Select a role.
n Click Save.

6. Click Finish to create the wired port profile successfully.

Configuring Network Port Profile Assignment
To map the wired port profile to ethernet ports, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one IAP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the IAPs are displayed.

4. Click Show Advanced.
5. Click the Interfaces tab.

The Interfaces page is displayed.

6. Click the Wired accordion.

The Wired Port Profiles table is displayed.

7. Select a wired port profile under Name and click the edit icon.

The Networks > Configuration - <wired_port_profile> page is displayed.

8. Under General tab, select Ethernet 0/0 and Ethernet 0/1 from the ports drop-down list.
9. If the IAP supports Ethernet 2, Ethernet 3, and Ethernet 4 ports, assign profiles to these ports by

selecting Ethernet 0/2, Ethernet 0/3, and Ethernet 0/4 from the ports drop-down list
respectively.

10. Click Save Settings.

Viewing Wired Port Profile Summary

In the Summary tab under Networks > Configuration - <wired_port_profile> page, the Network
Summary page displays all the settings configured in the General, VLANs, Security, and Access tabs.

Click Save Settings to complete the network profile creation and save the settings.

Configuring Downloadable Roles
Aruba Central On-Premises allows you to download pre-existing user roles when you create network
profiles.

The Downloadable Role feature is available only for networks that include access points (APs) that run a
minimum of Aruba Instant 8.4.0.0 firmware version with a minimum of ClearPass server version 6.7.8.

Aruba Instant and ClearPass Policy Manager include support for centralized policy definition and
distribution.

When ClearPass Policy Manager successfully authenticates a user, the user is assigned a role by
ClearPass Policy Manager. If the role is not defined on the IAP, the role attributes can also be
downloaded automatically. In order to provide highly granular per-user level access, user roles can be
created when a user has been successfully authenticated. During the configuration of a policy
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enforcement profile in ClearPass Policy Manager, the administrator can define a role that should be
assigned to the user after successful authentication. In RADIUS authentication, when ClearPass Policy
Manager successfully authenticates a user, the user is assigned a role by ClearPass Policy Manager.

If the role is not defined on the IAP, the role attributes can also be downloaded automatically. This
feature supports roles obtained by the following authentication methods:

n 802.1X (WLAN and wired users)
n MAC authentication
n Captive Portal

This section describes the following topics:

n ClearPass Policy Manager Certificate Validation for Downloadable Role
n Enabling Downloadable Role Feature for Wireless Networks in Aruba Central On-Premises
n Enabling Downloadable Role Feature for Wired Networks in Aruba Central

ClearPass Policy Manager Certificate Validation for Downloadable Role
When a ClearPass Policy Manager server is configured as the domain for RADIUS authentication for
downloading user roles, in order to validate the ClearPass Policy Manager customized CA, IAPs are
required to publish the root CA for the HTTPS server to the well-known URL (http://<clearpass-
fqdn>/.wellknown/ aruba/clearpass/https-root.pem). The IAP must ensure that an FQDN is defined
in the above URL for the RADIUS server and then attempt to fetch the trust anchor by using the RADIUS
FQDN. Upon configuring the domain of the ClearPass Policy Manager server for RADIUS authentication
along with a username and password, the IAP tries to retrieve the CA from the above well-known URL
and store it in flash memory. However, if there is more than one ClearPass Policy Manager server
configured for authentication, the CA must be uploaded manually.

Enabling Downloadable Role Feature for Wireless Networks in Aruba Central On-
Premises
To enable the Downloadable Role feature, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group that contains at least one IAP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the IAPs are displayed.

4. Click the WLANs tab.

The WLANs details page is displayed.

5. In the WLANs tab, click + Add SSID.

To modify an existing SSID, select a wireless SSID from the Wireless SSIDs table and then click
the edit icon.

6. In the Security tab, select the RADIUS server in Primary Server field.

At least one RADIUS server must be configured to apply the Downloadable User Roles feature. For
more information on configuring radius server, see Authentication Servers for IAPs
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7. Click Next.
The Access tab is displayed.

8. Turn on the Downloadable Role toggle switch to allow downloading of pre-existing user roles.
The CPPM Settings table with Name, CPPM Username, and Actions columns related to the
radius servers are displayed.

n The Downloadable Role feature is available only for networks that include APs that run a
minimum of Aruba InstantOS 8.4.0.0 firmware version with a minimum of ClearPass server
version 6.7.8.

n At least one radius server must be configured to apply the Downloadable Role feature. For more
information on configuring radius server, see Authentication Servers for IAPs

9. Click the action corresponding to the radius server listed in the CPPM Settings table.
The Edit Server page is displayed.

The Edit Server page displays the name of the radius server name. The Name field is non-editable.

10. Enter the following details:

n CPPM Username—Enter the ClearPass Policy Manager admin username.
n Password—Enter the password.
n Retype—Retype the password.

11. Click OK.

Enabling Downloadable Role Feature for Wired Networks in Aruba Central

To enable the Downloadable Role feature, perform the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group that contains at least one IAP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the IAPs are displayed.

4. Click Show Advanced, and click the Interfaces tab.

The Interfaces details page is displayed.

5. Click the Wired accordion.

6. Under Wired, click + Add Port Profile.

To modify an existing profile, select the network that you want to edit in the Wired Port Profiles
pane, and then click the edit icon.

7. In the Security tab, select the RADIUS server in Primary Server field.

At least one radius server must be configured to apply the Downloadable Role feature. For more
information on configuring radius server, see Authentication Servers for IAPs
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8. Click Next.
The Access tab is displayed.

9. Enable the Downloadable Role option to allow downloading of pre-existing user roles.
The CPPM Settings table with Name, CPPM Username, and Actions columns related to the
radius servers are displayed.

n The Downloadable Role feature is available only for networks that include APs that run a
minimum of Aruba InstantOS 8.4.0.0 firmware version with a minimum of ClearPass server
version 6.7.8.

n At least one radius server must be configured to apply the Downloadable Role feature. For more
information on configuring radius server, see Authentication Servers for IAPs

10. Click the action corresponding to the radius server listed in the CPPM Settings table.
The Edit Server page with the radius server name is displayed.

The Edit Server page displays the radius server name. The Name field is non-editable.

11. Enter the following details:
n CPPM Username—Enter the ClearPass Policy Manager admin username.
n Password—Enter the password.
n Retype—Retype the password.

12. Click OK.

Editing a Wireless Network Profile
To edit a network profile, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group that contains at least one IAP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the IAPs are displayed.

4. Click the WLANs tab.

The WLANs details page is displayed.

5. In the Wireless SSIDs table, select the network that you want to edit, and then click the edit icon
under the Actions column.

6. Modify the profile and click Save Settings.

You can directly edit the SSID name under the Display Name column of the Wireless SSIDs table.
Double-click the relevant SSID that you want to rename, and type the new name. Press Enter to
complete the process

Editing a Wired Port Profile
To edit a network profile, complete the following steps:
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1. In the Aruba Central On-Premises app, set the filter to a group that contains at least one IAP.
2. Under Manage, click Devices > Access Points.

3. Click the Config icon.

The tabs to configure IAPs are displayed.

4. Click Show Advanced, and click the Interfaces tab.

The Interfaces details page is displayed.

5. Click the Wired accordion.
6. In the Wired Port Profiles pane, select the network that you want to edit, and then click the edit

icon.
7. Modify the profile and click Save Settings.

Deleting a Network Profile
To delete a network profile, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group that contains at least one IAP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the IAPs are displayed.

4. Click the WLANs tab.

The WLANs details page is displayed.

5. In the Wireless SSIDs table, select the network that you want to delete, and then click the delete
icon.

6. Click Yes in the confirmation dialog box.

Aruba Mesh Network and Mesh IAP

Mesh Network Overview
The mesh solution effectively expands and configures network coverage for outdoor and indoor
enterprises in a wireless environment. The mesh network automatically reconfigures broken or blocked
paths when traffic traverses across mesh Instant Access Point (IAP). This feature provides increased
reliability by allowing the network to continue operating even when an IAP is non-functional or if the
device fails to connect to the network.

A mesh network requires at least one valid wired or 3G uplink connection. The mesh network must be
provisioned by plugging into the wired network for the first time.

Mesh IAPs
The IAPs that are configured for mesh can either operate as mesh portals or as mesh points based on
the uplink type.
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IAP as Mesh Portal

Any provisioned IAP that has a valid wired or 3G uplink connection functions as a mesh portal. A mesh
portal acts as a gateway between the wireless mesh network and the enterprise wired LAN. The mesh
roles are automatically assigned based on the IAP configuration. The mesh portal can also act as a
virtual controller.

The mesh portal reboots after 5 minutes, when it loses its uplink connectivity to a wired network.

IAP as Mesh Point

The IAP without an ethernet link functions as a mesh point. The mesh point establishes an all-wireless
path to the mesh portal and provides traditional WLAN services such as client connectivity, IDS
capabilities, user role association, and QoS for LAN-to-mesh communication to the clients, and
performs mesh backhaul or network connectivity. The mesh points authenticate to the mesh portal and
establish a secured link using AES encryption.

n A mesh point also supports LAN bridging by connecting any wired device to the downlink port of the
mesh point. In the case of single ethernet port platforms such as Instant AP-105, you can convert the Eth0
uplink port to a downlink port by enabling Eth0 Bridging.

n Redundancy is observed in a mesh network when two Instant APs have valid uplink connections, and
most mesh points try to mesh directly with one of the two portals.

There can be a maximum of eight mesh points per mesh portal in a mesh network. When mesh IAPs
boot up, they detect the environment to locate and associate with their nearest neighbor. The mesh
IAPs determine the best path to the mesh portal ensuring a reliable network connectivity.

In a dual-radio, the 2.4 GHz radio is always used for client traffic, and the 5 GHz radio is always used for both
mesh-backhaul and client traffic.

Automatic Mesh Role Assignment
Aruba Central On-Premises supports enhanced role detection during IAP boot-up and IAP running time.
When a mesh point discovers that the Ethernet 0 port link is up, it sends loop detection packets to check
the availability of Ethernet 0 link. If the Ethernet 0 link is available, the mesh point reboots as a mesh
portal. Else, the mesh point does not reboot.

Mesh Role Detection during System Boot-Up

If the ethernet link is down during Instant AP boot-up, the IAP acts as a mesh point. If the Ethernet link is
up, the IAP continues to detect if the network is reachable in the following scenarios:

n In a static IP address scenario, the IAP acts as a mesh portal if it successfully pings the controller.
Otherwise, it acts as a mesh point.

n In case of DHCP, the IAP acts as a mesh portal when it obtains the IP address successfully. Otherwise,
it acts as a mesh point.

n In case of IPv6, IAPs do not support the static IP address but only support DHCP for detection of
network reachability.
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If the IAP has a 3G or 4G USB modem plugged, it always acts as a mesh portal. If the IAP is set to Ethernet 0
bridging, it always acts as a mesh point.

Mesh Role Detection during System Running Time

The mesh point uses the Loop Protection for Secure Jack Port feature to detect the loop when the
ethernet is up. If the loop is detected, the Instant AP reboots. Otherwise, the Instant AP does not reboot
and the mesh role continues to act as a mesh point.

Setting up Instant Mesh Network
To provision Instant APs as mesh Instant APs, complete the following steps:

1. Connect the Instant APs to a wired switch.
2. Ensure that the virtual controller key is synchronized and the country code is configured.
3. Ensure that a valid SSID is configured on the Instant AP.
4. If the Instant AP has a factory default SSID (SetMeUp or Instant SSID), delete the SSID.
5. If an Extended SSID is enabled on the virtual controller, disable Extended SSID in the System >

General accordion and reboot the Instant AP cluster.
6. Disconnect the Instant APs that you want to deploy as mesh points from the switch, and place the

Instant APs at a remote location. The Instant APs come up without any wired uplink connection
and function as mesh points. The Instant APs with valid uplink connections function as mesh
portals.

Configuring Wired Bridging on Eth0 for Mesh Point
Aruba Central On-Premises supports wired bridging on the Eth0 port of an Instant AP. You can configure
wired bridging, if the Instant AP is configured to function as a mesh point.

To configure support for wired bridging on the Eth0 port of an Instant AP from Aruba Central On-
Premises UI, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select an IAP group in the filter:

a. Set the filter to a group containing at least one IAP.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

n To select an IAP in the filter:
a. Set the filter to Global or a group containing at least one IAP.
b. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

c. Click an IAP listed under Device Name.

The dashboard context for the IAP is displayed.

d. Under Manage, click Devices > Access Point.

2. Click the Config icon.

The tabs to configure the IAPs are displayed.
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3. Click the Access Points tab.

The Access Points table is displayed.

4. To edit an IAP, select an IAP in the Access Points table, and then click the edit icon.
5. Click the Uplink tab.
6. To configure a non-native uplink VLAN, specify the management VLAN number in the Uplink

Management VLAN text-box.
7. From the Eth0 Mode drop-down list, select any of the following:

n Uplink—Select this option to change the Eth0 bridging mode to the uplink port.
n Downlink—Select this option to change the Eth0 bridging mode to the downlink port.

8. Click Save Settings.

After configuring the support for wired bridging on the Eth0 port of an Instant AP, ensure that you reboot the
Instant AP.

Mesh Cluster Function
Aruba Central On-Premises introduces the mesh cluster function for easy deployments of Instant APs.
You can configure the ID, password, and also provision Instant APs to a specific mesh cluster.

In a cluster-based scenario, you can configure unlimited mesh profiles in a network. When an Instant AP
boots up, it attempts to find a mesh cluster configuration. The Instant AP fetches a pre-existing mesh
cluster configuration, if any. Otherwise, it uses the default mesh configuration in which the SSID,
password, and cluster name are generated by the virtual controller key.

Instant APs that belong to the same mesh network can establish mesh links with each other. The Instant APs
can establish a mesh link in a standalone scenario also. However, the network role election does not take place
in a standalone environment. Users can set the same mesh cluster configuration to establish mesh links with
other networks. For more information on mesh cluster configuration, refer to the Mesh Instant AP Configuration
chapter of Aruba Instant User Guide.

Configuring Mesh for Multiple Radios
Mesh clusters are grouped and defined by a mesh cluster profile, which provides the framework of the
mesh network. The mesh cluster profile contains the MSSID, authentication methods, security
credentials, and cluster priority required for mesh points to associate with their neighbors and join the
cluster. Associated mesh points store this information in flash memory. Although most mesh
deployments require only a single mesh cluster profile, you can configure and apply multiple mesh
cluster profiles to an individual IAP.

To configure a mesh for multiple radios, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one IAP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the IAPs are displayed.

4. Click Show Advanced.
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5. Click the System tab.

The System page is displayed.

6. Click the Mesh accordion.
7. Select the radio band to deploy mesh network from the Mesh Band drop-down list.
8. Click + in the Mesh table.

The Mesh pane is displayed.

9. Configure the following parameters described in Table 82

10. Click OK.
11. Click Save Settings.

The following table describes the mesh configuration parameters.

Data
pane item Description

Name Name for the mesh cluster profile.
Range: 8–32 characters

Key Configures a WPA2 PSK or passphrase as the cluster key.
Range: 8–64 characters

Priority Configures the priority of the mesh cluster profile. If more than two mesh cluster profiles are
configured, mesh points use this number to identify primary and backup profiles. The lower the
number, the higher the priority.
Range: 1—15

Opmode Configures the operation mode. Select WPA2 PSK or WPA3 SAE from the drop-down list.

Table 82: Mesh Configuration Parameters

Configuring ARM and RF Parameters on IAPs
This section provides the following information:

n ARM Overview
n Configuring ARM Features
n Configuring Radio Parameters

ARM Overview
ARM is a radio frequency management technology that optimizes WLAN performance even in the
networks with highest traffic by dynamically and intelligently choosing the best 802.11 channel and
transmitting power for each Instant Access Point (IAP) in its current RF environment. ARM works with all
standard clients, across all operating systems, while remaining in compliance with the IEEE 802.11
standards. It does not require any proprietary client software to achieve its performance goals. ARM
ensures low-latency roaming, consistently high performance, and maximum client compatibility in a
multi-channel environment. By ensuring the fair distribution of available Wi-Fi bandwidth to mobile
devices, ARM ensures that data, voice, and video applications have sufficient network resources at all
times. ARM allows mixed 802.11a, b, g, n, and ac client types to inter operate at the highest performance
levels.
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When ARM is enabled, an IAP dynamically scans all 802.11 channels within its 802.11 regulatory domain
at regular intervals and sends reports on WLAN coverage, interference, and intrusion detection to the
virtual controller. ARM computes coverage and interference metrics for each valid channel, chooses the
best performing channel, and transmit power settings for each IAP RF environment. Each IAP gathers
other metrics on its ARM-assigned channel to provide a snapshot of the current RF health state.

IAPs support the following ARM features:

n Channel or Power Assignment—Assigns channel and power settings for all the IAPs in the network
according to changes in the RF environment.

n Voice Aware Scanning—Improves voice quality by preventing an IAP from scanning for other
channels in the RF spectrum during a voice call and by allowing an IAP to resume scanning when
there are no active voice calls.

n Load Aware Scanning—Dynamically adjusts the scanning behavior to maintain uninterrupted data
transfer on resource intensive systems when the network traffic exceeds a predefined threshold.

n Band Steering—Assigns the dual-band capable clients to the 5 GHz band on dual-band IAPs thereby
reducing co-channel interference and increasing the available bandwidth for dual-band clients.

n Client Match—Continually monitors the RF neighborhood of the client to support the ongoing band
steering and load balancing of channels, and enhanced IAP reassignment for roaming mobile clients.

When Client Match is enabled on 802.11n capable IAPs, the Client Match feature overrides any settings
configured for the legacy band steering, station hand-off assist or load balancing features. The 802.11ac
capable IAPs do not support the legacy band steering, station hand off or load balancing settings, so these
IAPs must be managed using Client Match.

n Airtime Fairness—Provides equal access to all clients on the wireless medium, regardless of client
type, capability, or operating system to deliver uniform performance to all clients.

For more information on ARM features supported by the IAPs, see the Aruba Instant User Guide.

Configuring ARM Features
To configure the ARM features, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group that contains at least one IAP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the IAPs are displayed.

4. Click the Radios tab.

The Radios details page is displayed.

5. Under RF > Adaptive Radio Management (ARM), the Client Control section displays the
following components:
n Band Steering Mode
n Airtime Fairness Mode
n ClientMatch
n ClientMatch Calculating Interval
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n ClientMatch Neighbor Matching
n ClientMatch Threshold
n ClientMatch Key
n Spectrum Load Balancing Mode

6. For Band Steering Mode, configure the following parameters:
n Prefer 5 GHz—Enables band steering in the 5 GHz mode. On selecting this, the IAP steers the

client to the 5 GHz band (if the client is 5 GHz capable), but allows the client connection on the
2.4 GHz band if the client persistently attempts for 2.4 GHz association.

n Force 5 GHz—Enforces 5 GHz band steering mode on the IAPs.
n Force 6 GHz—Enforces 6 GHz band steering mode on the IAPs.

The 6 GHz band is supported by Wi-Fi 6E APs (AP-635 and AP-655 access points) only.

n Balance Bands—Allows the IAP to balance the clients across the two radios to best utilize the
available 2.4 GHz bandwidth. This feature takes into account the fact that the 5 GHz band has
more channels than the 2.4 GHz band, and that the 5 GHz channels operate in 40 MHz, while
the 2.5 GHz band operates in 20 MHz.

n Disable—Allows the clients to select the band to use.

7. For Airtime Fairness Mode, specify any of the following values:
n Default Access—Allows access based on client requests. When Airtime Fairness Mode is set

to Default Access option, per user and per SSID bandwidth limits are not enforced.
n Fair Access—Allocates air time evenly across all the clients.
n Preferred Access—Sets a preference where 802.11n clients are assigned more air time than

802.11a/11g. The 802.11a/11g clients get more airtime than 802.11b. The ratio is 16:4:1.

8. For ClientMatch, configure the following parameters:
n Client Match—Turn on the toggle switch to enable the Client Match feature on IAPs. When

enabled, client count is balanced among all the channels in the same band. When Client
Match is enabled, ensure that the Scanning option is enabled. For more information, see Click
Access Point Control, and configure the following parameters: on page 397.

When Client Match is disabled, channels can be changed even when the clients are active on a BSSID.
The Client Match option is disabled by default.

n ClientMatch Calculating Interval—Configures a value for the calculating interval of Client
Match. The interval is specified in seconds and the default value is 3 seconds. You can specify
a value within the range of 1-600.

n ClientMatch Neighbor Matching—Configures the calculating interval of Client Match. This
number takes into account the least similarity percentage to be considered as in the same
virtual RF neighborhood of Client Match. You can specify a percentage value within the range
of 20-100. The default value is 60%.

n ClientMatch Threshold—Configures a Client Match threshold value. This threshold is the
maximum difference allowed in the number of associated clients between channels, radios, or
channel + radios. When the client load on an IAP reaches or exceeds the threshold in
comparison, Client Match is enabled on that IAP. You can specify a value within range of 1-20.
The default value is 5.
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n ClientMatch Key—Enables the Client Match feature to work across different standalone IAPs
in the same management VLAN. All such standalone IAPs must be set with the same Client
Match key. Client Match uses the wired layer 2 protocol to synchronize information
exchanged between IAPs. Users have an option to configure the Client Match keys. IAPs verify
if the frames that they broadcast contain a common Client Match key. IAPs that receive these
frames verify if the sender belongs to the same network or if the sender and receiver both
have the same Client Match key. You can specify a value within the range of 1– 2147483646.

n Spectrum Load Balancing Mode—Enables the Spectrum Load Balancing mode to
determine the balancing strategy for Client Match. The following options are available:
o Channel—Balances client count based on each channel.
o Radio—Balances client count based on each radio.
o Channel + Radio—Balances client count based on each channel and each radio.

9. Click Access Point Control, and configure the following parameters:
n Customize Valid Channels—Allows you to select a custom list of valid 20 MHz and 40 MHz

channels for 2.4 GHz and 5 GHz bands, and up to 160 MHz channels for 6 GHz bands. By
default, the IAP uses valid channels as defined by the Country Code (regulatory domain). On
selecting Customize Valid Channels, a list of valid channels for both 2.4 GHz and 5 GHz are
displayed. The valid channel customization feature is disabled by default. The valid channels
automatically show in the Static Channel Assignment pane.

n Min Transmit Power—Allows you to configure a minimum transmission power within a range
of 3 to 33 dBm in 3 dBm increments. If the minimum transmission EIRP setting configured on
an IAP is not supported by the IAP model, this value is reduced to the highest supported power
setting. The default value for minimum transmit power is 18 dBm.

n Max Transmit Power—Allows you to configure the maximum transmission power within a
range of 3 to 33 dBm in 3 dBm increments. If the maximum transmission EIRP configured on
an IAP is not supported by the local regulatory requirements or IAP model, the value is
reduced to the highest supported power settings.

n Client Aware—Allows ARM to control channel assignments for the IAPs with active clients.
When the Client Match mode is disabled, an IAP may change to a more optimal channel,
which disrupts current client traffic. The Client Aware option is enabled by default.

n Scanning—Allows the IAP to dynamically scan all 802.11 channels within its 802.11 regulatory
domain at regular intervals. This scanning report includes WLAN coverage, interference, and
intrusion detection data. For Client Match configuration, ensure that Scanning is enabled.

n Wide Channel Bands—Allows the administrators to configure 40 MHz channels in the 2.4
GHz, 5 GHz, and 6 GHz bands. 40 MHz channels are two 20 MHz adjacent channels that are
bonded together. The 40 MHz channel effectively doubles the frequency bandwidth available
for data transmission. For high performance, you can select 5 GHz or 6 GHz. If the IAP density
is low, enable in the 2.4 GHz band.

n 80 MHz Support—Enables or disables the use of 80 MHz channels on IAPs. This feature allows
ARM to assign 80 MHz channels on IAPs with 5 GHz radios, which support a very high
throughput. This setting is enabled by default. Only the IAPs that support 802.11ac can be
configured with 80 MHz channels.

n 160 MHz Support—Enables or disables the use of 160 MHz channels on APs. This feature
allows ARM to assign 160 MHz channels on APs with 5 GHz and 6 GHz radios, which support
very high throughput. By default, it is set to is None.
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o Select one of the following options in the drop-down list:
l Auto—Allows automatic selection of contiguous frequency.
l Contiguous-only—To assign contiguous only 160 MHz channel bandwidth.
l Non-contiguous-only—To assign non-contiguous 160 MHz channel bandwidth.
l None—To disallow assigning 160 MHz channel bandwidth.

You can enable the 160 MHz support only if 80 MHz Support is enabled. The 160 MHz Support
does not apply to the 2.4 GHz frequency band.

10. Click Channel Control, and configure the following parameters:
n Backoff Time—Allows you to configure the time within a range of 10 to 3600 seconds, when

an IAP backs off after requesting a new channel or power. It can increase the time window of
channel interference check, and the time window of power check. The default value for
minimum back off time is 240 seconds.

n Free Channel Index—Allows you to check the difference in threshold in the channel
interference index between the new channel and the existing channel. An IAP only moves to a
new channel if the new channel has a lower interference index value than the current channel.
This parameter specifies the required difference between the two interference index values
before the IAP moves to the new channel. The lower this value, the more likely the IAP moves
to the new channel. It has a default value of 25.

n Ideal Coverage Index —Allows you to specify the ideal coverage index in the range of 2 to 20,
which an IAP tries to achieve on its channel. The denser the IAP deployment, the lower this
value should be. It has a default value of 10.

n Channel Quality Aware Arm Disable—Allows ARM to ignore the internally calculated
channel quality metric and initiates channel changes based on thresholds defined in the
profile. ARM chooses the channel based on the calculated interference index value. The option
Channel Quality Aware Arm Disable is disabled by default.

n Channel Quality Threshold—Allows you to specify the channel quality percentage within a
range of 0 to 100, below which ARM initiates a channel change. It has a default value of 70%.

n Channel Quality Wait Time—Specifies the time that the channel quality is below the channel
quality threshold value to initiate a channel change. It has a range of 1 to 3600 seconds, with a
default value of 120 seconds. If current channel quality is below the specified channel quality
threshold for this wait time period, ARM initiates a channel change.

11. Click Error Rate, and configure the following parameters:
n Error Rate Threshold—Configures the minimum percentage of errors in the channel that

triggers a channel change. It has a range of 0 to 100 % with a default value of 70%.
n Error Rate Wait Time—Configures the time that the error rate has to be at least equal to the

error rate threshold to trigger a channel change. The error rate must be equal to or more than
the error rate threshold to trigger a channel change. It has a range of 1 to 3600 seconds, with a
default value of 90 seconds.

12. Click Save Settings.

Configuring Radio Parameters
To configure RF parameters for the 2.4 GHz, 5 GHz, and 6 GHz radio bands on an Instant Access Point
(IAP), complete the following steps:
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1. In the Aruba Central On-Premises app, set the filter to a group containing at least one IAP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the IAPs are displayed.

4. Click the Radios tab.

The Radios details page is displayed.

5. Expand the Radio accordion in the RF dashboard.

6. Under 2.4 GHz band and 5 GHz band, and 6 GHz band, click the + sign and configure the
parameters in the .

7. Click Save Settings.

The following table lists the radio configuration parameters.

Data Pane Item Description

Zone Allows you to configure a zone per radio band for IAPs in a cluster. You can also configure
an RF zone per IAP.

NOTE: Aruba recommends that you configure RF zone for either individual IAP or for the
cluster. Any discrepancy in the RF zone names may lead to configuration errors.

Legacy Only Turn on the Legacy Only toggle switch. When enabled, the IAP runs the radio in the non-
802.11n mode. This option is disabled by default.

NOTE: This parameter is not visible for 6 GHz band option.

802.11d / 802.11h Turn on the 802.11d / 802.11h toggle switch. When enabled, the radios advertise their
802.11d (Country Information) and 802.11h (Transmit Power Control) capabilities. This
option is disabled by default.

Beacon Interval Configures the beacon period for the IAP in milliseconds. This indicates how often the
802.11 beacon management frames are transmitted by the IAP. You can specify a value
within the range of 60–500. The default value is 100 milliseconds.

Interference
Immunity Level

Configures the immunity level to improve performance in high-interference
environments. The default immunity level is 2.
Increasing the immunity level makes the IAP lose a small amount of range.
n Level 0—No ANI adaptation.
n Level 1—Noise immunity only. This level enables power-based packet detection by

controlling the amount of power increase that makes a radio aware that it has
received a packet.

n Level 2—Noise and spur immunity. This level also controls the detection of OFDM
packets, and is the default setting for the Noise Immunity feature.

n Level 3—Level 2 settings and weak OFDM immunity. This level minimizes false
detects on the radio due to interference, but may also reduce radio sensitivity. This
level is recommended for environments with a high-level of interference related to 2.4

Table 83: Radio Configuration Parameters
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Data Pane Item Description

GHz appliances such as cordless phones.
n Level 4—Level 3 settings, and FIR immunity. At this level, the IAP adjusts its sensitivity

to in-band power, which can improve performance in environments with high and
constant levels of noise interference.

n Level 5—The IAP completely disables PHY error reporting, improving performance by
eliminating the time the IAP spends on PHY processing.

NOTE: This parameter is not visible for 6 GHz band option.

Channel Switch
Announcement
Count

Configures the number of channel switching announcements to be sent before switching
to a new channel. This allows the associated clients to recover gracefully from a channel
change.

Background
Spectrum
Monitoring

Turn on the Background Spectrum Monitoring toggle switch. When enabled, the IAPs in
the access mode continue with their normal access service to clients, while performing
additional function of monitoring RF interference (from both neighboring IAPs and non
Wi-Fi sources such as, microwaves and cordless phones) on the channel they are
currently serving the clients.

Customize ARM
Power Range

Configures a minimum (Min Power) and maximum (Max Power) power range value for
the 2.4 GHz and 5 GHz, and 6 GHz band frequencies. The default value is 3 dBm. Unlike
the configuration in the ARM profile, the transmit power of all radios in the Radio profile
do not share the same configuration.

Enable 11ac Turn on the Enable 11ac toggle switch. When enabled, VHT is enabled on the 802.11ac
devices for the 5 GHz radio band. If VHT is enabled for the 5 GHz radio profile on an IAP, it
is automatically enabled for all SSIDs configured on an IAP. By default, VHT is enabled on
all SSIDs.

NOTE: If you want the 802.11ac IAPs to function as 802.11n IAPs, clear this check box to
disable VHT on these devices.

NOTE: This parameter is not visible for 2.4 GHz band and 6 GHz band options.

Smart antenna Turn on the Smart antenna toggle switch to combine an antenna array with a digital
signal-processing capability to transmit and receive in an adaptive, spatially sensitive
manner.

NOTE: This parameter is not visible for 6 GHz band option.

ARM/WIDS
Override

When ARM/WIDS Override is disabled, the IAP always processes frames for WIDS. WIDS
is an application that detects the attacks on a wireless network or wireless system
purposes even when it is heavily loaded with client traffic. When ARM/WIDS Override is
enabled, the IAP stops processing frames for WIDS.

RRM IE Select the Radio Resource Management Information Element (RRM IE) profiles advertised
by an AP from the drop-down for 6 GHz Band.

NOTE: This option is only available for 6 GHz Band.

Table 83: Radio Configuration Parameters
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Configuring IDS Parameters on IAPs
Aruba Central On-Premises supports the IDS feature that monitors the network for the presence of
unauthorized access points (APs). It also logs information about the unauthorized IAPs and clients, and
generates reports based on the logged information.

Rogue IAPs
The IDS feature in the Aruba Central On-Premises network enables you to detect rogue IAPs, interfering
IAPs, and other devices that can potentially disrupt the Aruba Central On-Premises app. A rogue IAP is
an unauthorized IAP plugged into the wired side of the network. An interfering IAP is an IAP seen in the
RF environment, but it is not connected to the wired network. While the interfering IAP can potentially
cause RF interference, it is not considered a direct security threat, because it is not connected to the
wired network. However, an interfering IAP may be reclassified as a rogue IAP.

The built-in IDS scans for IAPs that are not controlled by the VC. These are listed and classified as either
Interfering or Rogue, depending on whether they are on a foreign network or your network.

Configuring Wireless Intrusion Detection and Protection Policies
To configure a Wireless Intrusion Detection and Protection policy:

1. In the Aruba Central On-Premises app, set the filter to a group that contains at least one IAP.
2. The dashboard context for the group is displayed.
3. Under Manage, click Devices > Access Points.
4. Click the Config icon.

The tabs to configure IAPs is displayed.

5. Click Show Advanced.
6. Click Security.

The Security details page is displayed.

7. Click the Wireless IDS/IPS accordion. The following three sections are displayed:
n Detection
n Protection
n Firewall Settings

You can configure the following options in the above mentioned sections:

n Infrastructure Detection Policies—Specifies the policy for detecting wireless attacks on APs.
n Client Detection Policies—Specifies the policy for detecting wireless attacks on clients.
n Infrastructure Protection Policies—Specifies the policy for protecting APs from wireless attacks.
n Client Protection Policies—Specifies the policy for protecting clients from wireless attacks.
n Firewall Policies—Specifies the policies to set a firewall for a secured network access.
n Containment Methods—Prevents unauthorized stations from connecting to your Aruba Central

network.

Each of these options contains several default levels that enable different sets of policies. An
administrator can customize enable or disable these options accordingly.

Detection
The detection levels can be configured using the Detection section. The following levels of detection
can be configured in the WIP Detection page:



Aruba Central On-Premises 2.5.7 | User Guide 402

n High
n Medium
n Low
n Off
n Custom

The following table describes the detection policies enabled in the Infrastructure Detection field.

Detection
level Detection policy

High n Detect Windows Bridge—Enables detection of Windows station bridging.
n Signature Deassociation Broadcast—Configures signature matching for the

deassociation broadcast frame type.
n Signature Deauthentication Broadcast—Configures signature matching for the

deauthentication broadcast frame type.
n Detect AP Spoofing—Enables IAP Spoofing detection.
n Detect adhoc using VALID SSID—Enables detection of adhoc networks.
n Detect malformed large duration—Enables detection of unusually large durations in

frames.
n Detect Overflow EAPOL key—Enables detection of overflow EAPOL key requests.
n Detect Invalid Address Combination—Enables detection of invalid address

combinations.
n Detect AP Impersonation—Enables detection of IAP impersonation. In IAP impersonation

attacks, the attacker sets up an IAP that assumes the BSSID and ESSID of a valid IAP. IAP
impersonation attacks can be done for man-in-the-middle attacks, a rogue IAP attempting
to bypass detection, or a honeypot attack.

n Detect AP Flood—Enables detection of flooding with fake IAP beacons to confuse the
legitimate users and to increase the amount of processing needed on client operating
systems.

n Detect Beacon Wrong Channel—Enables detection of beacons advertising the incorrect
channel.

n Detect ht Greenfield—Enables detection of high throughput devices advertising
greenfield preamble capability.

n Detect Overflow IE—Enables detection of overflow Information Elements (IE).
n Detect RTS Rate Anomaly—Enables detection of rate anomalies.
n Detect Malformed HT IE—Enables detection of malformed HT Information Elements (IE).
n Detect CTS Rate Anomaly—Enables detection of CTS rate anomaly.
n Detect Malformed Frame Auth—Enables detection of malformed authentication frames.
n Detect invalid MAC OUI—Enables checking of the first three bytes of a MAC address,

known as the organizationally unique identifier (OUI), assigned by the IEEE to known
manufacturers. Often clients using a spoofed MAC address do not use a valid OUI and
instead use a randomly generated MAC address. Enabling MAC OUI check triggers an alarm
to be triggered if an unrecognized MAC address is in use.

n Detect Malformed Association Request—Enables detection of malformed association
requests.

n Detect Bad WEP—Enables detection of WEP initialization vectors that are known to be
weak and/or repeating. A primary means of cracking WEP keys is to capture 802.11 frames

Table 84: Infrastructure Detection Policies
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Detection
level Detection policy

over an extended period of time and search for implementations that are still used by
many legacy devices.

n Detect Wireless Bridge—Enables detection of wireless bridging.
n Detect HT 40 MHz intolerance—Enables detection of 802.11n 40 MHz intolerance setting

when the stations and APs advertise 40 MHz intolerance.
n Detect Valid SSID Misuse—Enables detection of interfering or neighbor APs using valid or

protected SSIDs.
n Detect Adhoc Network—Enables detection of adhoc networks.
n Detect Client Flood—Enables detection of client flood attack.

Medium n Detect Windows Bridge—Enables detection of Windows station bridging.
n Signature Deassociation Broadcast—Configures signature matching for the

deassociation broadcast frame type.
n Signature Deauthentication Broadcast—Configures signature matching for the

deauthentication broadcast frame type.
n Detect AP Spoofing—Enables AP Spoofing detection.
n Detect adhoc using VALID SSID—Enables detection of adhoc networks.
n Detect malformed large duration—Enables detection of unusually large durations in

frames.

Low n Detect Windows Bridge—Enables detection of Windows station bridging.
n Signature Deassociation Broadcast—Configures signature matching for the

deassociation broadcast frame type.
n Signature Deauthentication Broadcast—Configures signature matching for the

deauthentication broadcast frame type.
n Detect AP Spoofing—Enables AP Spoofing detection.

Off All detection policies are disabled.

Custom Allows you to select custom detection policies. To select, click the check box of respective
detection policy.

Table 84: Infrastructure Detection Policies

The following table describes the detection policies enabled in the Client Detection field.

Detection
level Detection policy

High n Detect Valid Client Misassociation—Enables detection of misassociation between a valid
client and an unsafe IAP. This setting can detect the following misassociation types:
o Misassociation to rogue IAP
o Misassociation to external IAP
o Misassociation to honeypot IAP
o Misassociation to adhoc IAP
o Misassociation to Hosted IAP

Table 85: Client Detection Policies
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Detection
level Detection policy

n Detect Hotspotter Attack—Enables detection of hotspot attacks.
n Detect Power Save DOS Attack—Enables detection of Power Save DoS attack.
n Detect Omerta Attack—Enables detection of Omerta attack.
n Detect Disconnect Station—Enables a station disconnection attack. In a station

disconnection, attacker spoofs the MAC address of either an active client or an active IAP.
The attacker then sends deauthenticate frames to the target device, causing it to lose its
active association.

n Detect unencrypted Valid —Enables detection of unencrypted valid clients.
n Detect Block ACK Attack—Enables detection of attempts to reset traffic receive windows

using the forged Block ACK Add messages.
n Detect FATA-Jack—Enables detection of fatjack attacks.
n Detect Rate Anomalies—Enables detection of rate anomalies.
n Detect ChopChop Attack—Enables detection of ChopChop attack.
n Detect EAP Rate Anomaly—Enables Extensible Authentication Protocol (EAP) handshake

analysis to detect an abnormal number of authentication procedures on a channel and
generate an alarm when this condition is detected.

n Detect TKIP Replay Attack—Enables detection of TKIP replay attack.
n Signature-Air Jack—Enables signature matching for the Air Jack frame type.
n Signature-ASLEAP—Enables signature matching for the ASLEAP frame type.

Medium n Detect Valid Client Misassociation—Enables detection of misassociation between a valid
client and an unsafe IAP. This setting can detect the following misassociation types:
o Misassociation to rogue IAP
o Misassociation to external IAP
o Misassociation to honeypot IAP
o Misassociation to adhoc IAP
o Misassociation to Hosted IAP

n Detect Hotspotter Attack—Enables detection of hotspot attacks.
n Detect Power Save DOS Attack—Enables detection of Power Save DoS attack.
n Detect Omerta Attack—Enables detection of Omerta attack.
n Detect Disconnect Station—Enables a station disconnection attack. In a station

disconnection, attacker spoofs the MAC address of either an active client or an active IAP.
The attacker then sends deauthenticate frames to the target device, causing it to lose its
active association.

n Detect unencrypted Valid —Enables detection of unencrypted valid clients.
n Detect Block ACK Attack—Enables detection of attempts to reset traffic receive windows

using the forged Block ACK Add messages.
n Detect FATA-Jack—Enables detection of fatjack attacks.

Low Detect Valid Client Misassociation—Enables detection of misassociation between a valid
client and an unsafe IAP. This setting can detect the following misassociation types:
n Misassociation to rogue IAP
n Misassociation to external IAP
n Misassociation to honeypot IAP
n Misassociation to adhoc IAP
n Misassociation to Hosted IAP
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Detection
level Detection policy

Off All detection policies are disabled.

Custom Allows you to select custom detection policies. To select, click the check box of the respective
detection policy.

Protection
The following levels of protection can be configured in the WIP Protection page:

n Off
n Low
n High
n Custom

The following table describes the protection policies that are enabled in the Infrastructure Protection
field.

Protection
level Protection policy

Off All protection policies are disabled

Low n Protect SSID—Enforces policy where the valid/protected SSIDs are used only by valid
IAPs. An offending IAP is contained by preventing clients from associating to it.

n Rogue Containment—Controls Rogue APs. When rogue APs are detected, they are not
automatically disabled. This option automatically disables a rogue IAP by preventing
clients from associating to it.

High n Protect SSID—Enforces policy where the valid/protected SSIDs are used only by valid APs.
An offending IAP is contained by preventing clients from associating to it.

n Rogue Containment—Controls Rogue APs. When rogue IAPs are detected, they are not
automatically disabled. This option automatically disables a rogue IAP by preventing
clients from associating to it.

n Protect AP Impersonation—Enables protection from IAP impersonation attacks. When
IAP impersonation is detected, both the legitimate and impersonating IAP are disabled
using a Denial of Service (DoS).

n Protect from Adhoc Networks—Enables protection from adhoc networks. When adhoc
networks are detected, they are disabled using a denial of service attack.

Custom Allows you to select custom protection policies. To select, click the check box of respective
protection policy.

Table 86: Infrastructure Protection Policies
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The following table describes the protection policies that are enabled in the Client Protection field.

Protection
level Protection policy

Off All protection policies are disabled

Low Protect Valid Station—Enables protection of valid stations. When enabled valid stations are
not allowed to connect to an invalid IAP.

High n Protect Valid Station—Enables protection of valid stations. When enabled valid stations
are not allowed to connect to an invalid IAP.

n Protect Windows Bridge—Enables protection of a Windows station bridging.

Custom Allows you to select custom protection policies. To select, click the check box of respective
protection policy.

Table 87: Client Protection Policies

Containment Methods

You can enable wired and wireless containment measures to prevent unauthorized stations from
connecting to your Aruba Central network.

Aruba Central supports the following types of containment mechanisms:

n Wired containment — When enabled, APs generate ARP packets on the wired network to contain
wireless attacks.

n Wireless containment — When enabled, the system attempts to disconnect all clients that are
connected or attempting to connect to the identified IAP.
o None — Disables all the containment mechanisms.
o Deauthenticate only — With deauthentication containment, the IAP or client is contained by

disrupting the client association on the wireless interface.
o Tarpit containment — With tarpit containment, the IAP is contained by luring clients that are

attempting to associate with it to a tarpit. The tarpit can be on the same channel or a different
channel as the IAP being contained.

o Tarpit all stations—Enables wireless containment by tarpit for all stations.

The FCC and some third parties have alleged that under certain circumstances, the use of containment
functionality violates 47 U.S.C. §333. Before using any containment functionality, ensure that your intended use
is allowed under the applicable rules, regulations, and policies. Aruba is not liable for any claims, sanctions, or
other direct, indirect, special, consequential or incidental damages related to your use of containment
functionality.

Protection Against Wired Attacks

In the Protection Against Wired Attacks section, enable the following options:

n Drop Bad ARP—Drops the fake ARP packets.
n Fix Malformed DHCP—Fixes the malformed DHCP packets.
n ARP Poison Check—Triggers an alert on ARP poisoning caused by the rogue APs.
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Firewall Settings
To configure firewall settings by specifying the policies for a secured network access, see Enabling ALG
Protocols on IAPs on page 450 and Configuring Firewall Parameters for Wireless Network Protection.

n For all subnets, a deny rule is created by default as the last rule. If at least one rule is configured, the deny
all rule is applied to the upstream traffic by default.

n Management access to the Instant AP is allowed irrespective of the inbound firewall rule.
n The inbound firewall is not applied to traffic coming through the GRE tunnel.

Configuring Time-Based Services for Wireless Network Profiles
Aruba Central On-Premises allows you to configure the availability of a WLAN SSID at a particular time
of the day. You can now create a time range profile and assign it to a WLAN SSID, so that you can enable
or disable access to the SSID and thus control user access to the network during a specific time period.

Instant Access Points (IAPs) support the configuration of both absolute and periodic time range profiles.
You can configure an absolute time range profile to execute during a specific time frame, or create a
periodic profile to execute at regular intervals based on the periodicity specified in the configuration.

This section describes the following topics:

n Creating a Time Range Profile
n Associating a Time Range Profile to an SSID
n Associating a Time Range Profile to ACL

Before You Begin
Before you configure time-based services, ensure that the NTP server connection is active.

Creating a Time Range Profile
To create a time range profile, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one IAP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the IAPs are displayed.

4. Click Show Advanced.
5. Click the System tab.

The System page is displayed.

6. Click the Time-Based Services accordion.
7. Click + in the Time Based Profiles table.

The New Profile window for creating a time range profile is displayed.

8. Configure the parameters that are listed in the Table 88

The following table liste the time range profile configuration parameters.
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Parameter Description

Name Specify a name for the time range profile.

Type Select the type of time range profile:
n Periodic—Allows you configure a specific periodicity and recurrence pattern for

a time range profile.
n Absolute—Allows you to configure an absolute day and time range.

Repeat Specify the frequency for the periodic time range profile:
n Daily—Enables daily recurrence.
n Weekly—Allows you define a specific time range with specific start and end

days in a week.

Day Range Absolute
For an absolute time range profile, this field allows you to specify the start day and
end day, both in mm/dd/yyyy format. You can also use the calendar to specify the
start and end days.
Periodic
For a periodic time range profile, the following Day Range options are available:
n For daily recurrence—If the Repeat option is set to Daily, this field allows you to

select the following time ranges:
o Monday—Sunday (All Days)
o Monday—Friday (Weekdays)
o Saturday—Sunday (Weekend)

For example, if you set the Repeat option to Daily and then select Monday—Friday
(Weekday) for Day Range, and Start Time as 1 and End time as 2, the applied time
range will be Monday to Friday from 1 am to 2 am; that is, on Monday at 3 am, the
profile will not be applied or disabled.
n For weekly occurrence—If the Repeat option is set to Weekly, this field allows

you to select the start and end days of a week and time range.
For example, if you set Start Day as Monday and End Day as Friday, and Start Time
as 1 and End Time as 2, the applied time range profile is Monday 1 am to Friday 2 am
every week; that is, on Monday at 3 am, the profile will be applied or enabled.

Start Time Select the start time for the time range profile from the Hours and Minutes drop-
down lists, respectively.

End Time Select the end time for the time range profile from the Hours and Minutes drop-
down lists, respectively.

Visualization Graph for
Time

The Visualization graph (approximated to the hour) provides a visual display of the
selected time range (Day Range, Start Time, and End Time) for periodic profiles.

Table 88: Time Range Profile Configuration Parameters

Associating a Time Range Profile to an SSID
To apply a time range profile to an SSID, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one IAP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the IAPs are displayed.
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4. Click the WLANs tab.

The WLANs details page is displayed.

5. In the Wireless SSIDs table, select a network profile for which you want to apply the time range
profile, and then click the edit icon. You can also add a time range profile when configuring an
SSID.

6. In General, click Time Range Profiles under Advanced Settings.
7. Expand the Time Range Profiles accordion, and enter the following information:

n Select a time range profile from the Time Range Profile list.
n Select a value from the Status drop-down list.
n When a time range profile is enabled on SSID, the SSID is made available to the users for the

configured time range. For example, if the specified time range is 12:00 to 13:00, the SSID
becomes available only between 12 PM to 1 PM on a given day.

n If a time range is disabled, the SSID becomes unavailable for the configured time range. For
example, if configured time-range is 14:00 to 17:00, the SSID is made unavailable from 2 PM to
5 PM on a given day.

Associating a Time Range Profile to ACL
Aruba Central allows you to configure time-based services for specific ACL. To apply a time range profile
to an access rule, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one IAP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the IAPs are displayed.

4. Click Show Advanced.
5. Click the Security tab.

The Security page is displayed.

6. In the Roles accordion, click the edit icon listed for access rules under Access Rules For Selected
Roles to which you want to apply the time range profile.

The Access Rules page is displayed.

7. In the Options section, select the Time Range check-box and select the time range profile from
the drop-down list.
n When a time range profile is associated with an ACL, the configured time range is applied on

all the WLAN SSID with the specific ACL.
n If a time range is disabled or if the time range profile is deleted for an ACL, all WLAN SSID with

the specific ACL will be able to access the network without any time constraint.

8. Click Save.

For more information on time range configuration, see the Aruba Instant User Guide.

Configuring Authentication and Security Profiles on IAPs
This section describes the authentication and security parameters to configure on an Instant Access
Point (IAP):
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n Supported Authentication Methods
n Authentication Servers for IAPs
n Configuring External Authentication Servers for IAPs
n Configuring Role Derivation Rules for AP Clients
n Configuring Users Accounts for the IAP Management Interface
n Configuring Guest and Employee User Profiles on IAPs
n Firewall and ACL Rules
n Configuring Firewall Parameters for Wireless Network Protection
n Support for Multiple PSK in WLAN SSID
n Configuring an MPSK Local Profile
n Configuring WPA3 Encryption
n Intra VLAN Traffic Allowlist
n Creating Role Derivation Rules for IAP Clients
n Configuring User Roles for AP Clients
n Configuring Firewall Parameters for Inbound Traffic
n Configuring Roles and Policies on IAPs for User Access Control
n Configuring Network Service ACLs
n Enabling ALG Protocols on IAPs
n Denylisting IAP Clients

Supported Authentication Methods
Authentication is a process of identifying a user through a valid username and password. Clients can
also be authenticated based on their MAC addresses.

The authentication methods supported by the Instant Access Points (IAPs) managed through Aruba
Central On-Premises are described in the following sections.

802.1X Authentication
802.1X is a method for authenticating the identity of a user before providing network access to the user.
The Aruba Central On-Premises network supports internal RADIUS server and external RADIUS server
for 802.1X authentication. For authentication purpose, the wireless client can associate to a NAS or
RADIUS client such as a wireless IAP. The wireless client can pass data traffic only after successful 802.1X
authentication.

The NAS acts as a gateway to guard access to a protected resource. A client connecting to the wireless network
first connects to the NAS.

Configuring 802.1X Authentication for a Network Profile

To configure 802.1X authentication for a wireless network profile, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one IAP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.
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3. Click the Config icon.

The tabs to configure the IAPs are displayed.

4. Click the WLANs tab.

The WLANs details page is displayed.

5. In the Wireless SSIDs table, select a network profile for which you want to enable 802.1X
authentication, and then click the edit icon.

You can directly edit the SSID name under the Display Name column in the Wireless SSIDs table.
Double-click the relevant SSID that you want to rename, and type the new name. Press Enter to
complete the process.

6. Under Security, for the Enterprise security level, select the preferred option from the Key
Management drop-down list.

7. Specify the type of authentication server to use.
8. Click Save Settings.

MAC Authentication

MAC authentication is used for authenticating devices based on their physical MAC addresses. MAC
authentication requires that the MAC address of a machine matches a manually defined list of
addresses. This authentication method is not recommended for scalable networks and the networks
that require stringent security settings.

MAC authentication can be used alone or it can be combined with other forms of authentication such as
WEP authentication.

Configuring MAC Authentication for a Network Profile
To configure MAC authentication for a wireless profile, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one IAP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the IAPs are displayed.

4. Click the WLANs tab.

The WLANs details page is displayed.

5. In the WLANs tab, select a network profile for which you want to enable MAC authentication and
click the edit icon.

6. Under Security, turn on the MAC Authentication toggle switch under Advanced Settings to
enable Personal or Open security level.

7. Specify the type of authentication server to use.
8. Click Save Settings.

MAC Authentication with 802.1X Authentication

The administrators can enable MAC authentication for 802.1X authentication. MAC authentication
shares all the authentication server configurations with 802.1X authentication. If a wireless or wired
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client connects to the network, MAC authentication is performed first. If MAC authentication fails,
802.1X authentication does not trigger. If MAC authentication is successful, 802.1X authentication is
attempted. If 802.1X authentication is successful, the client is assigned an 802.1X authentication role. If
802.1X authentication fails, the client is assigned a deny-all role or mac-auth-only role.

You can also configure the following authentication parameters for MAC and 802.1X authentication:

n MAC authentication only—Allows you to create a mac-auth-only role to allow role-based access
rules when MAC authentication is enabled for 802.1X authentication. The mac-auth-only role is
assigned to a client when the MAC authentication is successful and 802.1X authentication fails. If
802.1X authentication is successful, the mac-auth-only role is overwritten by the final role. The mac-
auth-only role is primarily used for wired clients.

n L2 authentication fall-through—Allows you to enable the l2-authentication-fallthrough mode.
When this option is enabled, the 802.1X authentication is allowed even if the MAC authentication
fails. If this option is disabled, 802.1X authentication is not allowed. The l2-authentication-
fallthrough mode is disabled by default.

Configuring MAC Authentication with 802.1X Authentication
To configure MAC authentication with 802.1X authentication for wireless network profile, configure the
following parameters:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one IAP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the IAPs are displayed.

4. Click the WLANs tab.

The WLANs details page is displayed.

5. In the WLANs tab, select a network profile for which you want to enable MAC and 802.1X
authentication, and the click the edit icon.

6. Under Security, for the Enterprise security level, turn on the Perform MAC Authentication
Before 802.1X toggle switch to use 802.1X authentication only when the MAC authentication is
successful.

7. Turn on the MAC Authentication Fail Through toggle switch to use 802.1X authentication even
when the MAC authentication fails.

8. Click Save Settings.

Captive Portal Authentication

Captive portal authentication is used for authenticating guest users. For more information, see
Configuring Wireless Networks for Guest Users on IAPs.

MAC Authentication with Captive Portal Authentication

The following conditions apply to a network profile with MAC authentication and Captive Portal
authentication enabled:

n If the captive portal splash page type is Internal-Authenticated or External-RADIUS Server, MAC
authentication reuses the server configurations.
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n If the captive portal splash page type is Internal-Acknowledged or External-Authentication Text
and MAC authentication is enabled, a server configuration page is displayed.

n If the captive portal splash page type is None, MAC authentication is disabled.
n The MAC authentication with captive portal authentication supports the mac-auth-only role.

Configuring MAC Authentication with Captive Portal Authentication
To configure the MAC authentication with captive portal authentication for a network profile, complete
the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group that contains at least one IAP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the IAPs are displayed.

4. Click the WLANs tab.

The WLANs details page is displayed.

5. In the WLANs tab, select an existing wireless profile for which you want to enable MAC
authentication with captive portal authentication, and then click the edit icon.

6. Under Access, specify the following parameters for a network with Role Based rules:
a. Select the Enforce Machine Authentication check box, when MAC authentication is

enabled for captive portal.

If the MAC authentication fails, the captive portal authentication role is assigned to the client.
b. For wireless network profile, turn on the Enforce MAC Auth Only Role toggle switch, when

MAC authentication is enabled for captive portal.

After successful MAC authentication, the MAC Auth Only role is assigned to the client.

7. Click Next.

802.1X Authentication with Captive Portal Authentication

This authentication method allows you to configure different captive portal settings for clients on the
same SSID. For example, you can configure an 802.1X SSID and create a role for captive portal access, so
that some of the clients using the SSID derive the captive portal role. You can configure rules to indicate
access to external or internal Captive portal, or none.

For more information on configuring captive portal roles for an SSID with 802.1X authentication, see
Configuring Wireless Networks for Guest Users on IAPs.

WISPr Authentication

WISPr authentication allows a smart client to authenticate on the network when they roam between
wireless Internet service providers, even if the wireless hotspot uses an ISP with whom the client may
not have an account.

If a hotspot is configured to use WISPr authentication in a specific ISP and a client attempts to access
the Internet at that hotspot, the WISPr AAA server configured for the ISP authenticates the client directly
and allows the client to access the network. If the client only has an account with a partner ISP, the
WISPr AAA server forwards the client’s credentials to the partner ISPs WISPr AAA server for
authentication. When the client is authenticated on the partner ISP, it is also authenticated on your
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hotspot own ISP as per their service agreements. The IAP assigns the default WISPr user role to the
client when your ISP sends an authentication message to the IAP.

IAPs support the following smart clients:

n iPass
n Boingo

These smart clients enable client authentication and roaming between hotspots by embedding iPass
Generic Interface Specification (GIS) redirect, authentication, and logoff messages within HTML messages
that are sent to the IAP.

Configuring WISPr Authentication
To configure WISPr authentication, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one IAP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the IAPs are displayed.

4. Click Show Advanced.
5. Click the System tab.

The System page is displayed.

6. Click the WISPr accordion.
7. Under WISPr, configure the following parameters:

n ISO Country Code—The ISO Country Code for the WISPr Location ID.
n E.164 Area Code—The E.164 Area Code for the WISPr Location ID.
n Operator Name—The operator name of the hotspot.
n E.164 Country Code—The E.164 Country Code for the WISPr Location ID.
n SSID/Zone—The SSID/Zone for the WISPr Location ID.
n Location Name—Name of the hotspot location. If no name is defined, the name of the IAP, to

which the user is associated, is used.

8. Click Save Settings.

The WISPr RADIUS attributes and configuration parameters are specific to the RADIUS server used by
your ISP for the WISPr authentication. Contact your ISP to determine these values. You can find a list of
ISO and ITU country and area codes at the ISO and ITU websites (www.iso.org and http://www.itu.int).

A Boingo smart client uses a NAS identifier in the format <CarrierID>_<VenueID> for location identification. To
support Boingo clients, ensure that you configure the NAS identifier parameter in the RADIUS server profile for
the WISPr server.

Walled Garden

On the Internet, a walled garden typically controls access to web content and services. The Walled
garden access is required when an external captive portal is used. For example, a hotel environment

http://www.iso.org/
http://www.itu.int/
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where the unauthenticated users are allowed to navigate to a designated login page (for example, a
hotel website) and all its contents.

The users who do not sign up for the Internet service can view the allowed websites (typically hotel
property websites). The website names must be DNS-based and support the option to define wildcards.
When a user attempts to navigate to other websites that are not in the allowlist of the walled garden
profile, the user is redirected to the login page. IAP supports Walled Garden only for the HTTP requests.
For example, if you add yahoo.com in Walled Garden allowlist and the client sends an HTTPS request
(https://yahoo.com), the requested page is not displayed and the users are redirected to the captive
portal login page.

In addition, a denylisted walled garden profile can also be configured to explicitly block the
unauthenticated users from accessing some websites.

Configuring Walled Garden Access
To configure walled garden access, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one IAP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the IAPs are displayed.

4. Click Show Advanced.
5. Click the Security tab.

The Security page is displayed.

6. Click the Walled Garden accordion.
7. To allow access to a specific set of websites, click + under Allowlist, and enter the domain name

in the New Allowlist window.

 This allows access to a domain while the user remains unauthenticated. Specify a POSIX regular
expression (regex(7)). For example:

n yahoo.com matches various domains such as news.yahoo.com, travel.yahoo.com and
finance.yahoo.com

n www.apple.com/library/test is a subset of www.apple.com site corresponding to path
/library/test/*

n favicon.ico allows access to /favicon.ico from all domains.

8. To deny users access to a domain, click + under Denylist, and enter the domain name in the New
Denylist window.

This prevents the unauthenticated users from viewing specific websites. When a URL specified in
the denylist is accessed by an unauthenticated user, IAP sends an HTTP 403 response to the client
with an error message.

9. Click Save Settings.

Authentication Servers for IAPs
Based on the security requirements, you can configure internal or external RADIUS servers. This section
describes the types of authentication servers and authentication termination, that can be configured for
a network profile.
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External RADIUS Server
In the external RADIUS server, the IP address of the Virtual Controller (VC) is configured as the NAS IP
address. Aruba Central RADIUS is implemented on the VC, and this eliminates the need to configure
multiple NAS clients for every Instant Access Points (IAPs) on the RADIUS server for client authentication.
Aruba Central RADIUS dynamically forwards all the authentication requests from a NAS to a remote
RADIUS server. The RADIUS server responds to the authentication request with an Access-Accept or
Access-Reject message, and users are allowed or denied access to the network depending on the
response from the RADIUS server.

When you enable an external RADIUS server for the network, the client on the IAP sends a RADIUS
packet to the local IP address. The external RADIUS server then responds to the RADIUS packet.

Aruba Central On-Premises supports the following external authentication servers:

n RADIUS
n LDAP

To use an LDAP server for user authentication, configure the LDAP server on the VC, and configure user
IDs and passwords.

To use a RADIUS server for user authentication, configure the RADIUS server on the VC.

RADIUS Server Authentication with VSA

An external RADIUS server authenticates network users and returns to the IAP the VSA that contains the
name of the network role for the user. The authenticated user is placed into the management role
specified by the VSA.

Internal RADIUS Server

Each IAP has an instance of free RADIUS server operating locally. When you enable the internal RADIUS
server option for the network, the client on the IAP sends a RADIUS packet to the local IP address. The
internal RADIUS server listens and replies to the RADIUS packet.

The following authentication methods are supported in the Aruba Central network:

n EAP-TLS—The EAP-TLS method supports the termination of EAP-TLS security using the internal
RADIUS server. The EAP-TLS requires both server and CA certificates installed on the IAP. The client
certificate is verified on the virtual controller (the client certificate must be signed by a known CA),
before the username is verified on the authentication server.

n EAP-TTLS (MSCHAPv2)—The EAP-TTLS method uses server-side certificates to set up authentication
between clients and servers. However, the actual authentication is performed using passwords.

n EAP-PEAP (MSCHAPv2)—EAP-PEAP is an 802.1X authentication method that uses server-side public
key certificates to authenticate clients with server. The PEAP authentication creates an encrypted SSL
/ TLS tunnel between the client and the authentication server. Exchange of information is encrypted
and stored in the tunnel ensuring the user credentials are kept secure.

n LEAP—LEAP uses dynamic WEP keys for authentication between the client and authentication server.

To use the internal database of an IAP for user authentication, add the names and passwords of the
users to be authenticated.

Aruba does not recommend the use of LEAP authentication because it does not provide any resistance to
network attacks.
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RADIUS Communication over TLS (RadSec)

RADIUS over TLS, also known as RadSec, is a RADIUS protocol that uses TLS protocol for end-to-end
secure communication between the RADIUS server and IAP. RadSec wraps the entire RADIUS packet
payload into a TLS stream. Enabling RadSec increases the level of security for authentication that is
carried out across the cloud network. When configured, this feature ensures that the RadSec protocol is
used for safely transmitting the authentication and accounting data between the IAP and the RadSec
server.

The following conditions applies to RadSec configuration:

n The RADIUS packets go through the tunnel when TLS tunnel is established.

n By default, the TCP port 2083 is assigned for RadSec. Separate ports are not used for authentication,
accounting, and dynamic authorization changes.

n Aruba Central supports dynamic CoA (RFC 3576) over RadSec and the RADIUS server uses an existing
TLS connection opened by the IAP to send the request.

n By default, the IAP uses its device certificate to establish a TLS connection with RadSec server. You
can also upload your custom certificates on to IAP. For more information on uploading certificates,
see Mapping IAP Certificates.

Authentication Termination on IAP

Aruba Central allows EAP termination for PEAP-Generic Token Card (PEAP-GTC) and Protected
Extensible Authentication Protocol-Microsoft Challenge Authentication Protocol version 2 (PEAP-
MSCHAPv2). PEAP-GTC termination allows authorization against an LDAP server and external RADIUS
server while PEAP-MSCHAPv2 allows authorization against an external RADIUS server.

This allows the users to run PEAP-GTC termination with their username and password to a local
Microsoft Active Directory server with LDAP authentication.

n EAP-GTC—This EAP method permits the transfer of unencrypted usernames and passwords from
client to server. The EAP-GTC is mainly used for one-time token cards such as SecureID and the use
of LDAP or RADIUS as the user authentication server. You can also enable caching of user credentials
on the IAP to an external authentication server for user data backup.

n EAP-MSCHAPv2—This EAP method is widely supported by Microsoft clients. A RADIUS server must
be used as the back-end authentication server.

Dynamic Load Balancing between Authentication Servers

You can configure two authentication servers to serve as a primary and backup RADIUS server and
enable load balancing between these servers. Load balancing of authentication servers ensures that the
authentication load is split across multiple authentication servers and enables the IAPs to perform load
balancing of authentication requests destined to authentication servers such as RADIUS or LDAP.

The load balancing in IAP is performed based on the outstanding authentication sessions. If there are
no outstanding sessions and if the rate of authentication is low, only primary server will be used. The
secondary is used only if there are outstanding authentication sessions on the primary server. With this,
the load balance can be performed across asymmetric capacity RADIUS servers without the need to
obtain inputs about the server capabilities from the administrators.

Configuring External Authentication Servers for IAPs
You can configure an external RADIUS server, TACACS, and LDAP server for user authentication. You can
configure guest network using External Captive Portal profile for external authentication.
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To configure a server, complete the following procedure:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one IAP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the IAPs are displayed.

4. Click Show Advanced.
5. Click the Security tab.

The Security page is displayed.

6. In the Authentication Server panel, click + to create a new server.
7. Select any of the server types and configure the parameters for your deployment scenario

described in Table 89.
8. Click Save.

To assign the authentication server to a network profile, select the newly added server when configuring
security settings for a wireless or wired network profile.

You can also add an external RADIUS server when configuring a WLAN SSID profile.

The following table lists the authentication server configuration parameters.

Type of Server Parameters

RADIUS

Name Name of the external RADIUS server.

Radsec Set Radsec to Enabled to enable secure communication between the RADIUS server and
IAP by creating a TLS tunnel between the IAP and the server.
If Radsec is enabled, the following configuration options are displayed:
Radsec Port—Communication port number for RadSec TLS connection. By default, the
port number is set to 2083.
n NAS Identifier
n NAS IP Address
n Service Type Framed User
n Query Status of RADIUS Servers (RFC 5997)
n Dynamic Authorization

IP Address/FQDN IP address or the FQDN of the external RADIUS server.

Auth Port Authorization port number of the external RADIUS server. The default port number is
1812.

Accounting Port The accounting port number used for sending accounting records to the RADIUS server.
The default port number is 1813.

Shared Key and
Retype Shared
Key

Shared key for communicating with the external RADIUS server.

Table 89: Authentication Server Configuration
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Type of Server Parameters

NAS IP Address Enter the IP address.
For IAP-based cluster deployments, ensure that you enter the VC IP address as the NAS IP
address.

NAS Identifier Use this to configure strings for RADIUS attribute 32, NAS Identifier, to be sent with
RADIUS requests to the RADIUS server.

Timeout The timeout duration for one RADIUS request. The IAP retries sending the request several
times (as configured in the Retry count) before the user is disconnected. For example, if
the Timeout is 5 seconds, Retry counter is 3, user is disconnected after 20 seconds. The
default value is 5 seconds.

Retry Count The maximum number of authentication requests that can be sent to the server group by
the IAP. You can specify a value within the range of 1–5. The default value is 3 requests.

Dead Time Specify a dead time for authentication server in minutes. When two or more
authentication servers are configured on the IAP and a server is unavailable, the dead
time configuration determines the duration for which the authentication server is
available if the server is marked as unavailable.
If Dynamic RADIUS Proxy (DRP) is enabled on the IAPs, configure the following
parameters:
n DRP IP—IP address to be used as source IP for RADIUS packets.
n DRP MASK—Subnet mask of the DRP IP address.
n DRP VLAN—VLAN in which the RADIUS packets are sent.

Service Type
Framed User

Select any of the following check boxes to send the service type as Framed User in the
access requests to the RADIUS server:
n 802.1X—Changes the service type to frame for 802.1X authentication.
n MAC—Changes the service type to frame for MAC authentication.
n Captive Portal—Changes the service type to frame for Captive Portal authentication.

Query Status of
RADIUS Servers
(RFC 5997)

Select any of the following check boxes to detect the server status of the RADIUS server:
Authentication—Select this check-box to ensure the IAP sends a status-server request to
determine the actual state of the authentication server before marking the server as
unavailable.
Accounting—Select this check-box to ensure the IAP sends a status-server request to
determine the actual state of the accounting server before marking the server as
unavailable.

Dynamic
Authorization

To allow the IAPs to process RFC 3576-compliant CoA and disconnect messages from the
RADIUS server, select this check box. Disconnect messages terminate the user session
immediately, whereas the CoA messages modify session authorization attributes such as
data filters. When you enable the Dynamic Authorization option, the AirGroup CoA
Port field is displayed with the port number for sending Bonjour support CoA on a
different port than on the standard CoA port. The default value is 5999.

LDAP

Name Name of the LDAP server.

IP Address IP address of the LDAP server.

Timeout Timeout interval within a range of 1–30 seconds for one RADIUS request. The default
value is 5.
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Type of Server Parameters

Retry Count The maximum number of authentication requests that can be sent to the server group.
You can specify a value within the range of 1–5. The default value is 3.

Auth Port Authorization port number of the LDAP server. The default port number is 389.

Admin-
Distinguished-
Name

A distinguished name for the admin user with read and search privileges across all the
entries in the LDAP database (the admin user need not have write privileges, but the
admin user must be able to search the database, and read attributes of other users in the
database).

Admin Password
and Retype
Admin Password

Password for the admin user.

Base-
Distinguished-
Name

Distinguished name for the node that contains the entire user database.

Filter The filter to apply when searching for a user in the LDAP database. The default filter
string is (objectclass=*).

Key Attribute The attribute to use as a key while searching for the LDAP server. For Active Directory, the
value is sAMAccountName.

TACACS

Name Name of the server.

IP Address IP address of the server.

Shared Key and
Retype Key

The secret key to authenticate communication between the TACACS client and server.

Timeout A number between 1 and 30 seconds to indicate the timeout period for TACACS+
requests. The default value is 20 seconds.

Retry Count The maximum number of authentication attempts to be allowed. The default value is 3.

Auth Port The TCP IP port used by the server. The default port number is 49.

Dead Time (in
mins)

Specify a dead time for authentication server in minutes. When two or more
authentication servers are configured on the IAP and a server is unavailable, the dead
time configuration determines the duration for which the authentication server is
available if the server is marked as unavailable.

Session
Authorization

Enable this option to allow the authorization of sessions.

External Captive Portal—The external captive portal servers are used for authenticating guest users in a
WLAN.

Name Enter a name for the profile.

IP or Hostname Enter the IP address or the host name of the external splash page server.
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Type of Server Parameters

URL Enter the URL of the external captive portal server.

Port Enter the port number that is used for communicating with the external captive portal
server.

Authentication
Type

Select any one of the following types of authentication:
n Radius Authentication—Select this option to enable user authentication against a

RADIUS server.
n Authentication Text—Select this option to specify an authentication text. The

specified text will be returned by the external server after a successful user
authentication.

Use HTTPS Select this to enforce clients to use HTTPS to communicate with the captive portal server.
This option is available only if RADIUS Authentication is selected from the
Authentication Type drop-down list.

Captive Portal
Failure

This field allows you to configure Internet access for the guest users when the external
captive portal server is not available. Select Deny Internet to prevent guest users from
using the network, or Allow Internet to access the network.

Automatic URL
Allowlisting

On enabling this for the external captive portal authentication, the URLs that are allowed
for the unauthenticated users to access are automatically allowlisted.

Server Offload Select the check box to enable the server offload feature. The server offload feature
ensures that the non-browser client applications are not unnecessarily redirected to the
external captive portal server, thereby reducing the load on the external captive portal
server.

Prevent Frame
Overlay

Select this check box to prevent the overlay of frames. When enabled, the frames display
only those pages that are in the same domain as the main page.

Use VC IP in
Redirect URL

Select this check box to use the virtual controller IP address as a redirect URL.

Auth Text If the External Authentication splash page is selected, specify the authentication text
that is returned by the external server after successful authentication. This option is
available only if Authentication Text is selected from the Authentication Type drop-
down list.

Redirect URL Specify a redirect URL if you want to redirect the users to another URL.

Dynamic Authorization Only

Name Name of the server.

IP Address/FQDN IP address or FQDN of the server.

Shared Key and
Retype Key

A shared key for communicating with the external RADIUS server.
Change of Authorization(CoA) is a subset of Dynamic Authorization include disconnecting
messages.

AirGroup CoA
Port

A port number for sending Bonjour support CoA on a different port than on the standard
CoA port. The default value is 5999.
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Creating Role Derivation Rules for IAP Clients
Aruba Central On-Premises allows you to configure role and VLAN derivation-rules. You can configure
these rules to assign a user role or VLAN to the clients connecting to an SSID or a wired profile.

Creating a Role Derivation Rule

You can configure rules for determining the role that is assigned for each authenticated client.

When creating more than one role assignment rule, the first matching rule in the rule list is applied.

To create a role assignment rule, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one IAP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the IAPs are displayed.

4. Click the WLANs tab.

The WLANs details page is displayed.

5. In the Wireless SSIDs table, select a network profile and then click the edit icon.
6. Click the Access tab.
7. Under Access rules, select Role Based to enable access based on user roles.
8. Under Role Assignment Rules, click +Add Role Assignment.
9. The New Role Assignment Rule pop-up window is displayed.

10. In New Role Assignment Rule, define a match method by which the string in Operand is
matched with the attribute value returned by the authentication server.

11. Select the attribute from the Attribute drop-down list that the rule it matches against.

The list of supported attributes includes RADIUS attributes, dhcp-option, dot1x-authentication-
type, mac-address, and mac-address-and-dhcp-options. For information on a list of RADIUS
attributes, see Authentication Servers for IAPs.

12. Select the operator from the Operator drop-down list. The following types of operators are
supported:
n contains—The rule is applied only if the attribute value contains the string specified in

Operand.
n Is the role—The rule is applied if the attribute value is the role.
n equals—The rule is applied only if the attribute value is equal to the string specified in

Operand.
n not-equals—The rule is applied only if the attribute value is not equal to the string specified in

Operand.
n starts-with—The rule is applied only if the attribute value starts with the string specified in

Operand.
n ends-with—The rule is applied only if the attribute value ends with string specified in Operand.
n matches-regular-expression—The rule is applied only if the attribute value matches the

regular expression pattern specified in Operand. This operator is available only if the mac-
address-and-dhcp-options attribute is selected in the Attribute list. The mac-address-and-
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dhcp-options attribute and matches-regular-expression are applicable only for WLAN
clients.

13. Enter the string to match in the String box.
14. Select the appropriate role from the Role drop-down list.
15. Click Save.

Configuring VLAN Derivation Rules

The users are assigned to a VLAN based on the attributes returned by the RADIUS server after users
authenticate.

To configure VLAN derivation rules for an SSID profile:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one IAP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the IAPs are displayed.

4. Click the WLANs tab.

The WLANs details page is displayed.

5. In the Wireless SSIDs table, select a network profile and then click the edit icon.
6. Under VLANs, select Dynamic under Client VLAN Assignment.
7. Click +Add Rule to create a VLAN assignment rule.

The New VLAN Assignment Rule pop-up window is displayed. In the New VLAN Assignment
Rule window, you can define a match method by which the string in Operand is matched with the
attribute values returned by the authentication server.

8. Select an attribute from the Attribute drop-down list.
9. Select an operator from the Operator drop-down list. The following types of operators are

supported:
n contains—The rule is applied only if the attribute value contains the string specified in

Operand.
n equals—The rule is applied only if the attribute value is equal to the string specified in

Operand.
n not-equals—The rule is applied only if the attribute value is not equal to the string specified in

Operand.
n starts-with—The rule is applied only if the attribute value starts with the string specified in

Operand.
n ends-with—The rule is applied only if the attribute value ends with string specified in

Operand.
n matches-regular-expression—The rule is applied only if the attribute value matches the

regular expression pattern specified in Operand. This operator is available only if the mac-
address-and-dhcp-options attribute is selected in the Attribute list. The mac-address-and-
dhcp-options attribute and matches-regular-expression are applicable only for the WLAN
clients.

10. Enter the string to match in the String field.
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11. Select the appropriate VLAN ID from the VLAN drop-down list.

Ensure that all other required parameters are configured.

12. Click OK.

Configuring Users Accounts for the IAP Management Interface
You can configure RADIUS or TACACS authentication servers to authenticate and authorize the
management users of an Instant Access Point (IAP). The authentication servers determine if the user has
access to administrative interface. The privilege level for different types of management users is defined
on the RADIUS or TACACS server. The IAPs map the management users to the corresponding privilege
level and provide access to the users based on the attributes returned by the RADIUS or TACACS server.

In Aruba Central On-Premises, the IAP management user passwords are stored and displayed as hash instead
of plain text. The hash-mgmt-user command is enabled by default on the IAPs provisioned in the template
and UI groups. If a pre-configured IAP joins Aruba Central and is moved to a new group, Aruba Central uses the
hash-mgmt-user configuration settings and discards mgmt-user configuration settings, if any, on the IAP. In
other words, Aruba Central hashes management user passwords irrespective of the management user
configuration settings running on an IAP.

To configure authentication parameters for local admin, read-only, and guest management
administrator account settings, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one IAP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the IAPs are displayed.

4. Click Show Advanced.
5. Click the System tab.

The System page is displayed.

6. Click the Administrator accordion and configure the parameters described in Table 90.

7. Click Save Settings.

The following table lists the parameters to configure the IAP users.

Type of the User Authentication
Options Steps to Follow

Client Control Internal In the Authentication drop-down list, select Internal if you want
to specify a single set of user credentials. If using an internal
authentication server:

1. In Username and Password, enter a username and
password.

2. In Retype Password, retype the password to confirm.

Table 90: Configuration Parameters for the IAP Users
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Type of the User Authentication
Options Steps to Follow

Authentication
Server

In the Authentication drop-down list, select the RADIUS or
TACACS authentication servers. You can also create a new server
by selecting New from the Authentication server drop-down
list.

Authentication
Server with
fallback to Internal

In the Authentication drop-down list, select Authentication
server with fallback to internal option if you want to use both
internal and external servers. When enabled, the authentication
switches to Internal if there is no response from the RADIUS
server (RADIUS server timeout).
To use this option, select the authentication servers from Auth
Server 1 and Auth Server 2 drop-down lists, and configure the
user credentials for internal server based authentication.

1. In Username and Password, enter a username and
password.

2. In Retype Password, retype the password to confirm.

Authentication
Server with
fallback to Internal
when timeout

In the Authentication drop-down list, select Authentication
server with fallback to internal when timeout option if you
want to use both internal and external servers after
RADIUS server timeout.
To use this option, select the authentication servers from Auth
Server 1 and Auth Server 2 drop-down lists, and configure the
user credentials for internal server based authentication.

1. In Username and Password, enter a username and
password.

2. In Retype Password, retype the password to confirm.

Load Balancing If two servers are configured, the users can use them in the
primary or backup mode, or load balancing mode. To enable load
balancing, select Enabled from the Load balancing drop-down
list. For more information on load balancing, see Authentication
Servers for IAPs.

TACACS Accounting If a TACACS server is selected, enable TACACS accounting to
report management commands, if required.

View Only To configure a user account with the read-only privileges:

1. In Username and Password, enter a username and
password.

2. In Retype Password, retype the password to confirm.

Guest
Registration Only

To configure a guest user account with the read-only privileges:

1. In Username and Password, enter a username and
password.

2. In Retype Password, retype the password to confirm.
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Configuring Guest and Employee User Profiles on IAPs
The local database of an Instant Access Point (IAP) consists of a list of guest and employee users. The
addition of a user involves specifying a login credentials for a user. The login credentials for these users
are provided outside the Aruba Central system.

A guest user can be a visitor who is temporarily using the enterprise network to access the Internet.
However, if you do not want to allow access to the internal network and the Intranet, you can segregate
the guest traffic from the enterprise traffic by creating a guest WLAN and specifying the required
authentication, encryption, and access rules.

An employee user is the employee who is using the enterprise network for official tasks. You can create
employee WLANs, specify the required authentication, encryption and access rules and allow the
employees to use the enterprise network.

The user database is also used when an IAP is configured as an internal RADIUS server. The local user database
of APs can support up to 512 user entries except IAP-92 and IAP-93. IAP-92 and IAP-93 supports only 256 user
entries. If there are already 512 users, IAP-92 and IAP-93 will not be able to join the cluster.

To configure users, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one IAP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the IAPs are displayed.

4. Click Show Advanced.
5. Click the Security tab.

The Security page is displayed.

6. Click User For Internal Server.
7. In the Users pane, click the + icon.
8. In the Add User window, enter the following information, and then click OK.

n In the Username text-box, enter a username.
n In the Password text-box, enter the password.
n In the Retype text-box, retype the password to confirm.
n In the Type drop-down list, select a type of user from the drop-down list.

9. To edit a user settings:
a. In the Users pane, select the username to edit.
b. Click the edit icon to modify the user settings.
c. Click OK.

10. To delete a user:
a. In the Users pane, select the username to delete.
b. Click the delete icon.
c. Click OK.

11. To delete all users, select Delete All in the Users pane, and then click Yes.
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Deleting a user only removes the user record from the user database, and will not disconnect the online user
associated with the username.

Firewall and ACL Rules
The Aruba Central On-Premises firewall provides identity-based controls to enforce application-layer
security, prioritization, traffic forwarding, and network performance policies for wired and wireless
networks. Using the Aruba Central On-Premises firewall, you can enforce network access policies that
define access to the network, areas of the network that users may access, and the performance
thresholds of various applications.

Aruba Central On-Premises supports a role-based stateful firewall. Aruba Central On-Premises firewall
recognizes flows in a network and keeps track of the state of sessions. The Aruba Central On-Premises
firewall manages packets according to the first rule that matches packet. The firewall logs on the Instant
Access Points (IAPs) are generated as syslog messages. The Aruba Central On-Premises firewall also
supports the Application Layer Gateway (ALG) functions such as SIP, Vocera, Alcatel NOE, and Cisco
Skinny protocols.

ACL Rules
You can use Access Control List (ACL) rules to either permit or deny data packets passing through the
IAP. You can also limit packets or bandwidth available to a set of user roles by defining access rules. By
adding custom rules, you can block or allow access based on the service or application, source or
destination IP addresses.

You can create access rules to allow or block data packets that match the criteria defined in an access
rule. You can create rules for either inbound traffic or outbound traffic. Inbound rules explicitly allow or
block the inbound network traffic that matches the criteria in the rule. Outbound rules explicitly allow or
block the network traffic that matches the criteria in the rule. For example, you can configure a rule to
explicitly block outbound traffic to an IP address through the firewall.

The IAP clients are associated with user roles, which determine the client’s network privileges and the
frequency at which clients re-authenticate. Aruba Central On-Premises supports the following types of
ACLs:

n ACLs that permit or deny traffic based on the source IP address of the packet.
n ACLs that permit or deny traffic based on source or destination IP address, or source or destination

port number.

You can configure up to 64 access control rules for a firewall policy.

Configuring Network Address Translation Rules
Network Address Translation (NAT) is the process of modifying network address information when
packets pass through a routing device. The routing device acts as an agent between the public (the
Internet) and private (local network), which allows translation of private network IP addresses to a
public address space.

Aruba Central On-Premises supports the NAT mechanism to allow a routing device to use the
translation tables to map the private addresses into a single IP address and packets are sent from this
address, so that they appear to originate from the routing device. Similarly, if the packets are sent to the
private IP address, the destination address is translated as per the information stored in the translation
tables of the routing device.
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Support for Multiple PSK in WLAN SSID
Aruba Central On-Premises allows you to configure multiple PSK (MPSK) in WLAN network profiles that
include APs running a minimum of Aruba InstantOS 8.4.0.0 firmware version and later. MPSK enhances
the WPA2 PSK mode by allowing device-specific or group-specific passphrases, which are generated by
ClearPass Policy Manager and sent to the Instant Access Point (IAP).

WPA2 PSK-based deployments generally consist of a single passphrase configured as part of the WLAN
SSID profile. This single passphrase is applicable for all clients that associate with the SSID. Starting from
Aruba InstantOS 8.4.0.0, multiple PSKs in conjunction with ClearPass Policy Manager are supported for
WPA and WPA2 PSK-based deployments. Every client connected to the WLAN SSID can have its own
unique PSK.

A MPSK passphrase requires MAC authentication against a ClearPass Policy Manager server. The MPSK
passphrase works only with wpa2-psk-aes encryption and not with any other PSK-based encryption. The
Aruba-MPSK-Passphrase radius VSA is added and the ClearPass Policy Manager server populates this
VSA with the encrypted passphrase for the device.

The workflow is as follows:

1. A user registers the device on a ClearPass Policy Manager guest-registration or device-registration
webpage and receives a device-specific or group-specific passphrase.

2. The device associates with the SSID using wpa2-psk-aes encryption and uses MPSK passphrase.
3. The IAP performs MAC authentication of the client against the ClearPass Policy Manager server.

On successful MAC authentication, the ClearPass Policy Manager returns Access-Accept with the
VSA containing the encrypted passphrase.

4. The IAP generates a PSK from the passphrase and performs 4-way key exchange.
5. If the device uses the correct per-device or per-group passphrase, authentication succeeds. If the

ClearPass Policy Manager server returns Access-Reject or the client uses incorrect passphrase,
authentication fails.

6. The IAP stores the MPSK passphrase in its local cache for client roaming. The cache is shared
between all the IAPs within a single cluster. The cache can also be shared with standalone IAPs in
a different cluster provided the IAPs belong to the same multicast VLAN. Each IAP first searches
the local cache for the MPSK information. If the local cache has the corresponding MPSK
passphrase, the IAP skips the MAC authentication procedure, and provides access to the client.

When multiple PSK is enabled on the wireless SSID profile, make sure that MAC authentication is not
configured for RADIUS authentication. Multiple PSK and MAC authentication are mutually exclusive and follows
a special procedure which does not require enabling MAC authentication in the WLAN SSID manually. Also,
ensure that the RADIUS server configured for the wireless SSID profile is not an internal server.

Points to Remember
The following configurations are mutually exclusive with MPSK for the WLAN SSID profile and does not
require to be configured manually:

n MPSK and MAC authentication
n MPSK and Denylisting
n MPSK and internal RADIUS server

Configuring Multiple PSK for Wireless Networks
To configure multiple PSK for wireless networks, complete the following steps:
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1. In the Aruba Central On-Premises app, set the filter to a group containing at least one IAP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the IAPs are displayed.

4. Click WLANs tab.

The WLANs detail page is displayed.

5. Click +Add SSID to create a new SSID.

To modify an existing SSID, select a wireless SSID from the Wireless SSIDs table and then click
the edit icon.

6. Click the Security tab.
7. Select Personal from the Security Level.

The authentication options applicable to the Enterprise network are displayed.
8. From the Key Management drop down list, select the MPSK-AES option.
9. From the Primary Server drop down list, select a server.

The RADIUS server selected from the list is the CPPM server.

10. Click Save Settings.

Enabling MPSK Local for Wireless Networks
To configure MPSK Local for wireless networks, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one IAP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the IAPs are displayed.

4. Click WLANs tab.

The WLANs detail page is displayed.

5. Click +Add SSID to create a new SSID.

To modify an existing SSID, select a wireless SSID from the Wireless SSIDs table and then click
the edit icon.

6. Click the Security tab.
7. Select Personal from the Security Level.

The authentication options applicable to the personal network are displayed.

8. From the Key Management drop down list, select the MPSK Local option.
9. From the MPSK Local drop down list, select an MPSK Local profile.

MPSK Local feature is supported for Aruba InstantOS 8.7.0.0 or later versions. You cannot select an
MPSK Local profile from the Mpsk Local drop-down list if the AP version is less than 8.7.0.0.

10. Click Save Settings.
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Configuring an MPSK Local Profile
MPSK Local allows the user to configure 24 PSKs per SSID locally on the device. These local PSKs would
serve as an extension of the base MPSK functionality.

Configuring a MPSK Local Profile
To configure an MPSK Local profile, complete the following steps

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one IAP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the IAPs are displayed.

4. Click Show Advanced.
5. Click the Security tab.

The Security page is displayed.

6. Click the MPSK Local accordion.
7. In the MPSK Local window, click + and enter a name for the MPSK Local profile.
8. To create an MPSK Local passphrase, click + in the MPSK Local Passphrase table.

The MPSK Local Passphrase pop-up window is displayed.

9. Enter the following information in the Mpsk Local Passphrase window:
n Name—Enter a name.
n Passphrase—Enter a passphrase.
n Retype Passphrase—Retype the passphrase to confirm.
n Role—Select a role from the drop-down list.

10. Click OK.
11. In the MPSK Local Passphrase window, select the MPSK Local passphrase name created in the

previous step, and then click OK.
12. Click Save Settings.

Configuring WPA3 Encryption
Aruba Central On-Premises supports WPA3 encryption for security profiles in SSID creation for networks
that include access points (APs) running Aruba InstantOS 8.4.0.0 firmware version and above. The WPA3
security provides robust protection with unique encryption per user session thereby ensuring a highly
secured connection even on a public Wi-Fi hotspot.

The following are the WPA3 encryptions based on the Enterprise, Personal, or Open network types:

n WPA-3 Enterprise when the security level is Enterprise.
n WPA-3 Personal when the security level is Personal.
n Enhanced Open when the security level is Open.

WPA3 Enterprise
WPA3-Enterprise enforces top secret security standards for an enterprise Wi-Fi in comparison to secret
security standards. Top secret security standards includes:
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n Deriving at least 384-bit PMK/MSK using Suite B compatible EAP-TLS.
n Securing pairwise data between STA and authenticator using AES-GCM-256.
n Securing group addressed data between STA and authenticator using AES-GCM-256.
n Securing group addressed management frames using BIP-GMAC-256.

Aruba Instant supports WPA3-Enterprise only in non-termination 802.1X and tunnel-forward modes. WPA3-
Enterprise compatible 802.1x authentication occurs between STA and CPPM.

WPA3-Enterprise advertises or negotiates the following capabilities in beacons, probes response, or
802.11 association:

n AKM Suite Selector as 00-0F-AC:12
n Pairwise Cipher Suite Selector as 00-0F-AC:9
n Group data cipher suite selector as 00-0F-AC:9
n Group management cipher suite (MFP) selector as 00-0F-AC:12

If WPA3-Enterprise is enabled, STA is successfully associated only if it uses one of the four suite
selectors for AKM selection, pairwise data protection, group data protection, and group management
protection. If a STA mismatches any one of the four suite selectors, the STA association fails.

To configure WPA3 for enterprise security, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one IAP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the IAPs are displayed.

4. Click WLANs tab.

The WLANs detail page is displayed.

5. Click +Add SSID to create a new SSID.

To modify an existing SSID, select a wireless SSID from the Wireless SSIDs table, and then click
the edit icon.

6. Click the Security tab.
7. Select Enterprise from the Security Level.

The authentication options applicable to the Enterprise network are displayed.

8. Select one of the following from the Key Management drop-down list:
n WPA3-Enterprise(GCM 256)—Select this option to use WPA-3 security employing GCM

encryption operation mode limited to encrypting 256 bits of plain text.
n WPA3-Enterprise(CCM 128)—Select this option to use WPA-3 security employing CCM

encryption operation mode limited to encrypting 128 bits of plain text.

9. Click Save Settings.

Configuring WPA3 for Personal Security

To configure WPA3 for personal security, complete the following steps:
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1. In the Aruba Central On-Premises app, set the filter to a group containing at least one IAP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the IAPs are displayed.

4. Click WLANs tab.

The WLANs detail page is displayed.

5. Click +Add SSID to create a new SSID.

To modify an existing SSID, select a wireless SSID from the Wireless SSIDs table and then click
the edit icon.

6. Click the Security tab.
7. Select Personal from the Security Level.

The authentication options applicable to the Personal network are displayed.

8. Select WPA3-Personal from the Key Management drop-down list.
9. Click Save Settings.

Intra VLAN Traffic Allowlist
The Intra VLAN Traffic Allowlist is a global allowlist for all WLAN SSIDs and wired networks configured
with the feature. For servers to serve the network, you must add them to the Intra VLAN Traffic Allowlist
using their IP or MAC address. When you configure wired servers with their IP address or MAC address,
the Instant Access Point (IAP) allows client traffic to the destination MAC addresses.

Configuring a Wired Server with the IP Address
To configure a wired server with the IP address, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one IAP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the IAPs are displayed.

4. Click Show Advanced.
5. Click the Security tab.

The Security page is displayed.

6. Click the Intra VLAN Traffic Allowlist accordion.
7. In the Wired Server IP window, click + and enter the IP address of the server.
8. Click OK.
9. Click Save Settings.

To edit a wired server, select the IP address of the wired server in the Wired Server IP window, and
then click the edit icon.

To delete a wired server, select the IP address of the wired server in the Wired Server IP window, and
then click the delete icon.
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Configuring a Wired Server with the MAC Address
To configure a wired server with the MAC address, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one IAP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the IAPs are displayed.

4. Click Show Advanced.
5. Click the Security tab.

The Security page is displayed.

6. Click the Intra VLAN Traffic Allowlist accordion.
7. In the Wired Server MAC window, click + and enter the MAC address of the server.
8. Click OK.
9. Click Save Settings.

To edit a wired server, select the IP address of the wired server in the Wired Server MAC window, and
then click the edit icon.

To delete a wired server, select the IP address of the wired server in the Wired Server MAC window,
and then click the delete icon.

Mapping IAP Certificates
When an Instant Access Points (IAPs) joins a group that does not have a certificate, the IAPs existing
certificate is retained. When an IAP joins a group that already has a certificate, the certificate of the IAP
is overwritten by the group certificate.

To map an IAP certificate name to a specific certificate type or category, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one IAP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the IAPs are displayed.

4. Click Show Advanced.
5. Click the Security tab.

The Security page is displayed.

6. Expand the Certificate Usage accordion.
7. To map a certificate, for each usage type under Usage Type, select the suitable certificate from

the Certificate drop-down list:
n Certificate Authority—To verify the identity of a client.
n Authentication Server—To verify the identity of the server to a client.
n Captive Portal—To verify the identity of internal captive portal server.
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n Radsec use EST Server—Turn on the Radsec use EST Server toggle switch to allow EST
certificates to be used in RADSEC applications.

n To enable Radsec use EST Server, you must enable EST Activate in EST Profile.
n If Radsec use EST Server is enabled, RadSec and RadSec Certificate Authority will not be

available in Certificate Usage.

n RadSec—To verify the identity of the TLS server.
n RadSec Certificate Authority—To verify the authentication between the IAP and the TLS

server.
n Clearpass—To verify the identity of the ClearPass server.
n AP1X CA—Sets the CA certificate used for 802.1X authentication.
n AP1X Client Cert—Sets the certificate used for 802.1X authentication.
n WebCC CA Cert—Selects a CA certificate for WebCC.
n IOT CA Cert—Selects a CA certificate for IoT.

8. Click Save Settings.

Configuring an EST Profile
EST supports automatic enrollment of certificates with the EST Server. The certificates can now be
enrolled or re-enrolled automatically by configuring an EST profile on the IAP. Certificate enrollment
with EST allows you to use your own PKI instead of the factory or self-signed certificates available on the
AP. This enables you to have maximum visibility and control over the management of the PKI used and
can address any issues related to security in a scaled environment.

To configure an EST profile, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one IAP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of IAPs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the IAPs are displayed.

4. Click Show Advanced.
5. Click the Security tab.

The Security page is displayed.

6. Expand the Certificate Usage > EST Profile accordion.
7. Configure the following parameters:

n EST Activate—Activates the EST profile.
n EST CA Certificate—Sets the EST CA Certificate from the drop-down list.
n Server Name/IP Address—Hostname of the EST server.
n Server Port—Indicates the port value of the EST server. The default value is 443.
n Arbitrary Label—Sets an arbitrary label for the EST URI to distinguish it from the other EST

profiles running on the EST server.
n Arbitrary Label Enrollment—Sets an arbitrary enrollment label for EST URL.
n Arbitrary Label Reenrollment—Sets an arbitrary re-enrollment label for EST URL.
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n Challenge Password—Sets a challenge password used in CSR.
n Retype Challenge Password—Retype challenge password used in CSR.
n Trust Anchor—Denotes the server's trust anchor.
n Organizational Unit Name—Sets the organizational unit name.
n Username—Sets a username for the EST Client.
n Password—Sets a password for the EST Client.
n Retype Password—Retype password for the EST Client.

8. Click Save Settings.

Configuring Roles and Policies on IAPs for User Access Control
Instant Access Points (IAPs) support identity-based access control to enforce application-layer security,
prioritization, traffic forwarding, and network performance policies for wired and wireless networks.
Using the IAP firewall policies, you can enforce network access policies to define access to the network,
areas of the network that the user may access, and the performance thresholds of various applications.

IAPs supports a role-based stateful firewall. In other words, Instant firewall can recognize flows in a
network and keep track of the state of sessions. The firewall logs on the IAPs are generated as syslog
messages. The firewall feature also supports ALG functions such as SIP, Auto Topology Rules, Restrict
Corporate Access, and Tunnel Trusted.

ACL Rules
You can use ACL rules to either permit or deny data packets passing through the IAP. You can also limit
packets or bandwidth available to a set of user roles by defining access rules. By adding custom rules,
you can block or allow access based on the service or application, source or destination IP addresses.

You can create access rules to allow or block data packets that match the criteria defined in an access
rule. You can create rules for either inbound traffic or outbound traffic. Inbound rules explicitly allow or
block the inbound network traffic that matches the criteria in the rule. Outbound rules explicitly allow or
block the network traffic that matches the criteria in the rule. For example, you can configure a rule to
explicitly block outbound traffic to an IP address through the firewall.

The IAP clients are associated with user roles, which determine the client’s network privileges and the
frequency at which clients re-authenticate. IAP supports the following types of ACLs:

n ACLs that permit or deny traffic based on the source IP address of the packet.
n ACLs that permit or deny traffic based on source or destination IP address, or source or destination

port number.

You can configure up to 64 access control rules for a firewall policy.

Configuring Network Address Translation Rules
NAT is the process of modifying network address information when packets pass through a routing
device. The routing device acts as an agent between the public (the Internet) and private (local network),
which allows translation of private network IP addresses to a public address space.

IAP supports the NAT mechanism to allow a routing device to use the translation tables to map the
private addresses into a single IP address and packets are sent from this address, so that they appear to
originate from the routing device. Similarly, if the packets are sent to the private IP address, the
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destination address is translated as per the information stored in the translation tables of the routing
device.

For more information, see:

n Configuring Network Service ACLs on page 436
n Configuring ACLs for Deep Packet Inspection on page 438
n Configuring User Roles for AP Clients on page 441
n Configuring Role Derivation Rules for AP Clients on page 443
n Configuring Firewall Parameters for Inbound Traffic on page 447

Configuring Network Service ACLs
To configure access rules for network services, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one AP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the APs are displayed.

4. Click Show Advanced.
5. Click the Security tab.

The Security page is displayed.

6. Click the Roles accordion.
7. Under Access Rules For Selected Roles, click + to add a new rule.

The Access Rule window is displayed.

8. Under Rule Type, select Access Control.
9. To configure access to applications or application categories, select a service category from the

following list:
n Network
n App Category
n Application
n Web Category
n Web Reputation

10. Based on the selected service category, configure the parameters described in Table 91.

11. Click Save to save the rules.

12. Click Save Settings.

The following table lists the access rule configuration parameters.
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Data Pane
Item Description

Rule Type Select a rule type from the list, for example Access Control.

Service Select a service from the list of available services. You can allow or deny access to any or all of
the following services based on your requirement:
n Any—Access is allowed or denied to all services.
n CUSTOM—Available options are TCP, UDP, and Other. If you select the TCP or UDP

options, enter appropriate port numbers. If you select the Other option, enter the
appropriate ID.

If TCP and UDP uses the same port, ensure that you configure separate access rules to permit
or deny access.

Action Select any of following attributes:
n Select Allow to allow access users based on the access rule.
n Select Deny to deny access to users based on the access rule.
n Select Destination-NAT to allow the changes to destination IP address.
n Select Source-NAT to allow changes to the source IP address.

Destination Select a destination option. You can allow or deny access to any the following destinations
based on your requirements.
n To all destinations—Access is allowed or denied to all destinations.
n To a particular server—Access is allowed or denied to a particular server. After selecting

this option, specify the IP address of the destination server.
n Except to a particular server—Access is allowed or denied to servers other than the

specified server. After selecting this option, specify the IP address of the destination
server.

n To a network—Access is allowed or denied to a network. After selecting this option,
specify the IP address and netmask for the destination network.

n Except to a network—Access is allowed or denied to networks other than the specified
network. After selecting this option, specify the IP address and netmask of the destination
network.

n To a Domain Name—Access is allowed or denied to the specified domains. After
selecting this option, specify the domain name in the Domain Name text box.

n To AP IP—Traffic to the specified IAP is allowed. After selecting this option, specify the
domain name in the IP text box.

n To AP IP all—Traffic to all IAP is allowed. After selecting this option, specify the domain
name in the IP text box.

n To AP Network—Traffic to the specified IAP network is allowed. After selecting this
option, specify the domain name in the IP text box.

n To conductor IP—Traffic to the specified conductor IAP or virtual controller is allowed.
After selecting this option, specify the domain name in the IP text box.

Log Select Log to create a log entry when this rule is triggered. The Aruba Central firewall
supports firewall based logging. Firewall logs on the IAPs are generated as security logs.

Denylist Select Denylist to denylist the client when this rule is triggered. The denylisting lasts for the
duration specified as Auth failure denylist time on the Denylisting tab of the Security
window.

Table 91: Access Rule Configuration Parameters
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Data Pane
Item Description

Disable
Scanning

Select Disable Scanning to disable ARM scanning when this rule is triggered.
The selection of the Disable Scanning applies only if ARM scanning is enabled.

DSCP TAG Select DSCP TAGto specify a DSCP value to prioritize traffic when this rule is triggered. Specify
a value within the range of 0 to 63.

802.1p
priority

Select 802.1p priority to specify an 802.1 priority. Specify a value between 0 and 7.

Time Range Select this check-box to allow a specific user to access the network for a specific time range.
You can select the time range profile from the drop-down list that appears when the Time
Range check box is selected.

Table 91: Access Rule Configuration Parameters

Configuring ACLs for Deep Packet Inspection
To configure ACL rules for a user role for Deep Packet Inspection (DPI), complete the following
procedure:

1. In the Aruba Central On-Premises app, set the filter to a group that contains at least one AP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of access points is displayed in the List view.

3. Click the Config icon.

The tabs to configure the access points are displayed.

4. Click Show Advanced.

5. Click the Security tab.

The Security page is displayed.

6. Under Roles, select the role for which you want to configure access rules.

7. Under Access Rules For Selected Roles, click + to add a new rule.

The Access Rule window is displayed.

8. Under Rule Type, select Access Control.
9. To configure access to applications or application categories, select a service category from the

following list:
n Network
n App Category
n Application
n Web Category
n Web Reputation

10. Based on the selected service category, configure the parameters in Table 92.

11. Click Save to save the access rules.

12. Click Save Settings.

The following table lists the access rule configuration parameters.
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Service
category Description

App Category Select the application categories to which you want to allow or deny access.

Application Select the applications to which you want to allow or deny access.

Application
Throttling

Application throttling allows you to set a bandwidth limit for an application and application
categories. For example, you can limit the bandwidth rate for video streaming applications
such as YouTube or Netflix, or assign a low bandwidth to high risk sites.
To specify a bandwidth limit:
n Select the Application Throttling check box.
n Specify the Downstream and Upstream rates in Kbps per user.

Action Select one of the following actions:
n Destination-NAT—Translation of the destination IP address of a packet entering the

network.
n Source-NAT—Used by internal users to access the internet.
n Allow—Select Allow to allow access users based on the access rule.
n Deny—Select Deny to deny access to users based on the access rule.

Destination Select a destination option for the access rules for network services, applications, and
application categories. You can allow or deny access to any the following destinations based
on your requirements.
n To all destinations— Access is allowed or denied to all destinations.
n To a particular server—Access is allowed or denied to a particular server. After selecting

this option, specify the IP address of the destination server.
n Except to a particular server—Access is allowed or denied to servers other than the

specified server. After selecting this option, specify the IP address of the destination
server.

n To a network—Access is allowed or denied to a network. After selecting this option,
specify the IP address and netmask for the destination network.

n Except to a network—Access is allowed or denied to networks other than the specified
network. After selecting this option, specify the IP address and netmask of the destination
network.

n To a Domain Name—Access is allowed or denied to the specified domains. After
selecting this option, specify the domain name in the Domain Name text box.

n To AP IP—Traffic to the specified IAP is allowed. After selecting this option, specify the
domain name in the IP text box.

n To AP IP all—Traffic to all IAP is allowed. After selecting this option, specify the domain
name in the IP text box.

n To AP Network—Traffic to the specified IAP network is allowed. After selecting this
option, specify the domain name in the IP text box.

n To conductor IP—Traffic to the specified conductor IAP or virtual controller is allowed.
After selecting this option, specify the domain name in the IP text box.

Log Select this check box if you want a log entry to be created when this rule is triggered. Aruba
Central supports firewall based logging. Firewall logs on the IAPs are generated as security
logs.

Table 92: Access Rule Configuration Parameters
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Service
category Description

Denylist Select the Denylist check-box to denylist the client when this rule is triggered. The denylisting
lasts for the duration specified as Auth failure denylist time on the Denylisting tab of the
Security window. .

Disable
Scanning

Select Disable Scanning check box to disable ARM scanning when this rule is triggered.
The selection of the Disable Scanning applies only if ARM scanning is enabled.

DSCP Tag Select this check box to add a DSCP tag to the rule. DSCP is an L3 mechanism for classifying
and managing network traffic and providing QoS on the network. To assign a higher priority,
specify a higher value.

802.1p
priority

Select this check box to enable 802.1p priority. 802.1p priority is an L2 protocol for traffic
prioritization to manage QoS on the network. There are eight levels of priority, 0-7. To assign
a higher priority, specify a higher value.

Time Range Select this check box to enable user to access network for a specific time period. You can
select the time range profile from the drop-down list that appears when the Time Range
check box is selected..

Table 92: Access Rule Configuration Parameters

Configuring ACLs on APs for Website Content Classification
You can configure web policy enforcement on an access point (AP) to block certain categories of
websites based on your organization specifications by defining ACL rules.

To configure ACLs for website content classification, follow the below procedure:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one AP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.
3. Click the Config icon.

The tabs to configure the APs are displayed.

4. Click Show Advanced.
5. Click the Security tab.
6. Under Roles, select the role to modify.
7. Under Access Rules For Selected Roles, click + to add a new rule.

The Access Rule window is displayed.

8. Under Rule Type, select Access Control.
9. Configure the following on the Access Rule window.

a. To set an access policy based on web categories:

i. Under Service, select Web Category.

ii. Select the categories to which you want to deny or allow access. You can also search for a
web category and select the required option.

iii. Under Action, select Allow or Deny.

iv. Click Save to save the rules.



Managing APs | 441

b. To filter access based on the security ratings of the website:

i. Select Web Reputation under Service.

ii. Move the slider to select a specific web reputation value to deny access to websites with a
reputation value lower than or equal to the configured value or to permit access to
websites with a reputation value higher than or equal to the configured value. The
following options are available:
n Trustworthy Web Reputation Index—These are well known sites with strong security

practices and may not expose the user to security risks. There is a very low probability
that the user will be exposed to malicious links or payloads.

n Low Risk Web Reputation Index—These are benign sites and may not expose the
user to security risks. There is a low probability that the user will be exposed to
malicious links or payloads.

n Moderate Web Reputation Index—These are generally benign sites, but may pose a
security risk. There is some probability that the user will be exposed to malicious links
or payloads.

n Suspicious Web Reputation Index—These are suspicious sites. There is a higher than
average probability that the user will be exposed to malicious links or payloads.

n High Risk Web Reputation Index—These are high risk sites. There is a high
probability that the user will be exposed to malicious links or payloads.

iii. Under Action, select Allow or Deny as required.

10. To set a bandwidth limit based on web category or web reputation score, select the Application
Throttling check box and specify the downstream and upstream rates in Kbps. For example, you
can set a higher bandwidth for trusted sites and a low bandwidth rate for high risk sites.

11. If required, select the following check boxes:
n Denylist —Select this check box to denylist the client when this rule is triggered. The

denylisting lasts for the duration specified as Auth Failure Denylist Time on the Denylisting
pane of the Security window. For more information, see Denylisting IAP Clients.

n Disable Scanning—Select Disable scanning check box to disable ARM scanning when this
rule is triggered. The selection of the Disable scanning applies only if ARM scanning is
enabled, For more information, see Configuring Radio Parameters.

n DSCP Tag—Select this check box to add a DSCP tag to the rule. DSCP is an L3 mechanism for
classifying and managing network traffic and providing QoS on the network. To assign a higher
priority, specify a higher value.

n 802.1p priority—Select this check box to enable 802.1p priority. 802.1p priority is an L2
protocol for traffic prioritization to manage QoS on the network. There are eight levels of
priority, 0-7. To assign a higher priority, specify a higher value.

12. Click Save to save the rules.
13. Click Save Settings in the Roles pane to save the changes to the role for which you defined ACL

rules.

Configuring User Roles for AP Clients
Every client in the Aruba Central On-Premises network is associated with a user role, which determines
the client’s network privileges, the frequency of re-authentication, and the applicable bandwidth
contracts. The user role configuration on an Instant Access Point (IAP) involves the following
procedures:
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n Creating a User Role
n Configuring User Roles for AP Clients

Creating a User Role

To create a user role, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one AP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the APs are displayed.

4. Click Show Advanced.
5. Click the Security tab.

The Security page is displayed.

6. Click the Roles accordion.
7. In the Roles pane, click +.
8. In the Add Role window, enter a name for the new role in Roles, and then click OK to save the

roles.
9. Click Save Settings.

You can also create a user role when configuring wireless profile. For more information, see Configuring
Wireless Network Profiles on IAPs.

Assigning Bandwidth Contracts to User Roles
The administrators can manage bandwidth utilization by assigning maximum bandwidth rates, or
bandwidth contracts to user roles. The administrator can assign a bandwidth contract configured in
Kbps to upstream (client to the IAP) or downstream (IAP to clients) traffic for a user role. The bandwidth
contract will not be applicable to the user traffic on the bridged out (same subnet) destinations. For
example, if clients are connected to an SSID, you can restrict the upstream bandwidth rate allowed for
each user to 512 Kbps.

By default, all users that belong to the same role share a configured bandwidth rate for upstream or
downstream traffic. The assigned bandwidth will be served and shared among all the users. You can
also assign bandwidth per user to provide every user a specific bandwidth within a range of 1 to 65535
Kbps. If there is no bandwidth contract specified for a traffic direction, unlimited bandwidth is allowed.

To assign bandwidth contracts to a user role, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one AP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the APs are displayed.
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4. Click Show Advanced.
5. Click the Security tab.

The Security page is displayed.

6. Click the Roles accordion.

7. Create a user role or select an existing role.

8. In the Access Rues For Selected Roles pane, click +.

9. In the Access Rule window, select Bandwidth Contract under Rule Type.

10. Specify the downstream and upstream rates in Kbps. If the assignment is specific for each user,
select Per User.

11. Click Saveto save the access rules and associate the user role to a WLAN SSID or wired profile.

12. Click Save Settings.

You can also create a user role and assign bandwidth contracts while configuring an SSID.

Configuring Role Derivation Rules for AP Clients
Aruba Central On-Premises allows you to configure role and VLAN derivation-rules. You can configure
these rules to assign a user role or VLAN to the clients connecting to an SSID or a wired profile.

Creating a Role Derivation Rule

You can configure rules for determining the role that is assigned for each authenticated client.

When creating more than one role assignment rule, the first matching rule in the rule list is applied.

To create a role assignment rule, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one AP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the APs are displayed.

4. Click the WLANs tab.

The WLANs details page is displayed.

5. In the Wireless SSIDs table, select a network profile and then click the edit icon.
6. Click the Access tab.
7. Under Access rules, select Role Based to enable access based on user roles.
8. Under Role Assignment Rules, click +Add Role Assignment. In New Role Assignment Rule,

define a match method by which the string in Operand is matched with the attribute value
returned by the authentication server.

9. Select the attribute from the Attribute list that the rule it matches against. The list of supported
attributes includes RADIUS attributes, dhcp-option, dot1x-authentication-type, mac-address, and
mac-address-and-dhcp-options.



Aruba Central On-Premises 2.5.7 | User Guide 444

10. Select the operator from the Operator list. The following types of operators are supported:
n contains—The rule is applied only if the attribute value contains the string specified in

Operand.
n Is the role—The rule is applied if the attribute value is the role.
n equals—The rule is applied only if the attribute value is equal to the string specified in

Operand.
n not-equals—The rule is applied only if the attribute value is not equal to the string specified in

Operand.
n starts-with—The rule is applied only if the attribute value starts with the string specified in

Operand.
n ends-with—The rule is applied only if the attribute value ends with string specified in Operand.
n matches-regular-expression—The rule is applied only if the attribute value matches the

regular expression pattern specified in Operand. This operator is available only if the mac-
address-and-dhcp-options attribute is selected in the Attribute list. The mac-address-and-
dhcp-options attribute and matches-regular-expression are applicable only for WLAN
clients.

11. Enter the string to match in the String box.
12. Select the appropriate role from the Role list.
13. Click Save.

Configuring VLAN Assignment Rule
To configure VLAN assignment rules for an SSID profile:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one AP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the APs are displayed.

4. Click the WLANs tab.

The WLANs details page is displayed.

5. In the Wireless SSIDs table, select a network profile and then click the edit icon.
6. Click the Access tab.
7. Select the access rule from Access rules.

8. In the Access Rules For Selected Roles, click + Add Rule to add a new rule.
The Access Rule page is displayed.

The VLAN Assignment option is also listed in the Access Rule page when you create or edit a rule for
wired port profiles in the Ports > Create a New Network > Access tab.

9. From the Rule Type drop-down list, select VLAN Assignment option.
10. Enter the VLAN ID in the VLAN ID field under Service section. Alternatively, you can select the

VLAN ID or the VLAN name from the drop-down list provided next to the VLAN ID field.
11. Click Save.
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Configuring VLAN Derivation Rules
The users are assigned to a VLAN based on the attributes returned by the RADIUS server after users
authenticate.

To configure VLAN derivation rules for an SSID profile:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one AP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the APs are displayed.

4. Click the WLANs tab.

The WLANs details page is displayed.

5. In the Wireless SSIDs table, select a network profile and then click the edit icon.
6. Under VLANs, select Dynamic under Client VLAN Assignment.

7. Click + Add Rule to create a VLAN assignment rule. The New VLAN Assignment Rule window is
displayed. In this window, you can define a match method by which the string in Operand is
matched with the attribute values returned by the authentication server.

8. Select an attribute from the Attribute list.

9. Select an operator from the Operator list. The following types of operators are supported:
n contains—The rule is applied only if the attribute value contains the string specified in

Operand.
n equals—The rule is applied only if the attribute value is equal to the string specified in

Operand.
n not-equals—The rule is applied only if the attribute value is not equal to the string specified in

Operand.
n starts-with—The rule is applied only if the attribute value starts with the string specified in

Operand.
n ends-with—The rule is applied only if the attribute value ends with string specified in

Operand.
n matches-regular-expression—The rule is applied only if the attribute value matches the

regular expression pattern specified in Operand. This operator is available only if the mac-
address-and-dhcp-options attribute is selected in the Attribute list. The mac-address-and-
dhcp-options attribute and matches-regular-expression are applicable only for the WLAN
clients.

10. Enter the string to match in the String field.
11. Select the appropriate VLAN ID from VLAN. Ensure that all other required parameters are

configured.
12. Click OK.

Configuring Firewall Parameters for Wireless Network Protection
To configure firewall settings, complete the following steps:
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1. In the Aruba Central On-Premises app, set the filter to a group containing at least one AP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the APs are displayed.

4. Click Show Advanced.
5. Click the Security tab.

The Security page is displayed.

6. Click the Firewall Settings accordion.
7. Turn on the toggle switch to enable SIP, Auto Topology Rules, Restrict Corporate Access, and

Tunnel Trusted protocols.
8. Under Protection, in the Protection Against Wired Attacks section, enable the following

options:
n Drop Bad ARP—Drops the fake ARP packets.
n Fix Malformed DHCP—Fixes the malformed DHCP packets.
n ARP Poison Check—Triggers an alert on ARP poisoning caused by the rogue APs.

Configuring Management Subnets
You can configure subnets to ensure that the IAP management is carried out only from these subnets.
When the management subnets are configured, Telnet, SSH, and UI access is restricted to these subnets
only.

To configure management subnets, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one AP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the APs are displayed.

4. Click Show Advanced.
5. Click the Security tab.

The Security page is displayed.

6. Click the Firewall Settings accordion.
7. Under Management Subnets pane, to add a new management subnet, complete the following

steps:
a. Enter the subnet address in Subnet field.
b. Enter the subnet mask in Mask field.
c. Click Add.

8. Click Save Settings.
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Configuring Custom Redirection URLs for IAP Clients
You can create a list of URLs to redirect users to when they access the blocked websites. You can define
an access rule to use these redirect URLs and assign the rule to a user role in the WLAN network.

Creating a List of Error Page URLs

To create a list of error page URLs, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one AP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the APs are displayed.

4. Click Show Advanced.
5. Click the Security tab.

The Security page is displayed.

6. Under Custom Blocked Page URL, click + and enter the URL to block.
7. Repeat the procedure to add more URLs. You can add up to 8 URLs to the list of blocked web

pages.
8. Click OK to save the URL.
9. Click Save Settings.

Configuring ACL Rules to Redirect Users to a Specific URL

To configure ACL rules to redirect users to a specific URL, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one AP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the APs are displayed.

4. Click Show Advanced.
5. Click the Security tab.

The Security page is displayed.

6. Under Roles, select the role for which you want to configure access rules.
7. Click + in the Access Rules section.
8. In the New Rule Window, select the rule type as Blocked Page URL.
9. Select the URLs from the existing list of custom redirect URLs. To add a new URL, click +.

10. Click Save to save the rules.
11. Click Save Settings.

Configuring Firewall Parameters for Inbound Traffic
Instant Access Points (IAPs) support an enhanced inbound firewall for the traffic that flows into the
network through the uplink ports of an IAP.
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To configure the firewall rules, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one AP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the APs are displayed.

4. Click Show Advanced.
5. Click the Security tab.

The Security page is displayed.

6. Click the Firewall Settings accordion.
7. In the Access Rule section, click the + icon.

The Inbound Firewall page is displayed.

8. In the Inbound Firewall page, configure the parameters described in Table 93.

9. Click Ok.
10. Click Save Settings.

For all subnets, a deny rule is created by default as the last rule. If at least one rule is configured, the deny all
rule is applied to the upstream traffic by default. The inbound firewall is not applied to traffic coming through
the GRE tunnel.

The following table lists inbound firewall rule configuration parameters.

Parameter Description

Service Select a service from the list of available services. You can allow or deny access to any or all of
the services based on your requirement:

n Any—Access is allowed or denied to all services.
n Custom—Customize the access based on available options such as TCP, UDP, and other
options. If you select the TCP or UDP options, enter appropriate port numbers. If the
Other option is selected, ensure that an appropriate ID is entered.

Action Select any of following actions:
n Select Allow to allow user access based on the access rule.
n Select Deny to deny user access based on the access rule.
n Select Destination-NAT to allow making changes to the destination IP address and the

port. Select Source-NAT to allow making changes to the source IP address. The
destination NAT and source NAT actions apply only to the network services rules.

Source Select any of the following options:
n From all sources—Traffic from all sources is either allowed, denied, or the IP address is

translated at the source or the destination as defined in the rule.
n From a particular host—Traffic from a particular host is either allowed, denied, or the IP

address is translated at the source or the destination as defined in the rule. After selecting
this option, specify the IP address of the host.

n From a network—Traffic from a particular network is either allowed, denied, or the IP

Table 93: Inbound Firewall Rule Configuration Parameters
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Parameter Description

address is translated at the source or the destination as defined in the rule. After selecting
this option, specify the IP address and netmask of the source network.

Destination Select a destination option for the access rules for network services, applications, and
application categories. You can allow or deny access to any the following destinations based
on your requirements.
n To all destinations—Traffic for all destinations is allowed, denied, or the IP address is

translated at the source or the destination as defined in the rule.
n To a particular server—Traffic to a specific server is allowed, denied, or the IP address is

translated at the source or the destination as defined in the rule. After selecting this
option, specify the IP address of the destination server.

n Except to a particular server—Access is allowed or denied to servers other than the
specified server. After selecting this option, specify the IP address of the destination
server.

n To a network—Traffic to the specified network is allowed, denied, or the IP address is
translated at the source or the destination as defined in the rule. After selecting this
option, specify the IP address and netmask for the destination network.

n Except to a network—Access is allowed or denied to networks other than the specified
network. After selecting this option, specify the IP address and netmask of the destination
network.

n To a Domain name—Traffic to the specified domain is allowed, denied, or the IP address
is translated at the source or the destination as defined in the rule. After selecting this
option, specify the domain name in the Domain Name text box.

n To AP IP—Traffic to the specified IAP is allowed. After selecting this option, specify the
domain name in the IP text box.

n To AP Network—Traffic to the specified IAP network is allowed. After selecting this
option, specify the domain name in the IP text box.

n To conductor IP—Traffic to the specified conductor IAP or virtual controller is allowed.
After selecting this option, specify the domain name in the IP text box.

Log Select the Log check box if you want a log entry to be created when this rule is triggered.
Instant supports firewall-based logging function. Firewall logs on the Instant APs are
generated as security logs.

Denylist Select the Denylist check box to denylist the client when this rule is triggered. The denylisting
lasts for the duration specified in the Auth failure denylist time on the Denylisting tab of
the Security window.

Classify Media Select the Classify Media check box to classify and tag media on HTTPS traffic as voice and
video packets.

Disable
scanning

Select the Disable scanning check box to disable ARM scanning when this rule is triggered.
The selection of Disable scanning applies only if ARM scanning is enabled.

DSCP TAG Select the DSCP TAG check box to specify a DSCP value to prioritize traffic when this rule is
triggered. Specify a value within the range of 0–63. To assign a higher priority, specify a higher
value.

802.1p priority Select the 802.1p priority check box to specify an 802.1p priority. Specify a value between 0
and 7. To assign a higher priority, specify a higher value.
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Configuring Restricted Access to Corporate Network

You can configure restricted corporate access to block unauthorized users from accessing the corporate
network. When restricted corporate access is enabled, corporate access is blocked from the uplink port
of conductor IAP, including clients connected to a member IAP.

To configure restricted corporate access, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one AP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the APs are displayed.

4. Click Show Advanced.
5. Click the Security tab.

The Security page is displayed.

6. Click the Firewall Settings accordion.
7. To restrict corporate access, turn on the Restrict Corporate Access toggle switch.
8. Click Save Settings.

Enabling ALG Protocols on IAPs
To configure ALG protocols on Instant Access Points (IAPs), complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one AP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the APs are displayed.

4. Click Show Advanced.
5. Click the Security tab.

The Security page is displayed.

6. Click the Firewall Settings accordion.
7. Turn on the toggle switch to enable SIP, Auto Topology Rules, Restrict Corporate Access, and

Tunnel Trusted protocols.
8. Click Save Settings.

When the protocols for the ALG are disabled, the changes do not take effect until the existing user sessions
have expired. Reboot the IAP and the client, or wait a few minutes for changes to take effect.

Denylisting IAP Clients
The client denylisting denies connection to the denylisted clients. When a client is denylisted, it is not
allowed to associate with an Instant Access Point (IAP) in the network. If a client is connected to the
network when it is denylisted, a deauthentication message is sent to force client disconnection.
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Denylisting Clients Manually

Manual denylisting adds the MAC address of a client to the denylist. These clients are added into a
permanent denylist. These clients are not allowed to connect to the network unless they are removed
from the denylist.

To add a client to the denylist manually, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one AP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the APs are displayed.

4. Click Show Advanced.
5. Click the Security tab.

The Security page is displayed.

6. Click the Denylisting accordion.
7. Under Manual Denylisting, click + and enter the MAC address of the client to be denylisted.
8. Click OK.
9. Click Save Settings.

To delete a client from the manual denylist, select the MAC Address of the client under the Manual
Denylisting, and then click the delete icon.

For the denylisting to take effect, you must enable the denylisting option when you create or edit the WLAN
SSID profile. Go to WLANs > Security > Advanced Settings and enable the Denylisting option. For more
information, see Configuring Wireless Network Profiles on IAPs.

Denylisting Clients Dynamically
The clients can be denylisted dynamically when they exceed the authentication failure threshold or
when a denylisting rule is triggered as part of the authentication process.

When a client takes time to authenticate and exceeds the configured failure threshold, it is
automatically denylisted by an IAP.

In session firewall based denylisting, an ACL rule automates denylisting. When the ACL rule is triggered,
it sends out denylist information and the client is denylisted.

To configure the denylisting duration, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one AP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the APs are displayed.

4. Click Show Advanced.
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5. Click the Security tab.

The Security page is displayed.

6. Click the Denylisting accordion.
7. Under Dynamic Denylisting, enter the following information:

n For Auth Failure Denylist Time, enter the duration after which the clients that exceed the
authentication failure threshold must be denylisted.

n For Policy Enforcement Failure Rule Denylisted Time, enter the duration after which the
clients can be denylisted due to an ACL rule trigger.

8. Click Save Settings.

n You can configure a maximum number of authentication failures by the clients, after which a client must
be denylisted. For more information on configuring maximum authentication failure attempts, see
Configuring Wireless Network Profiles on IAPs.

n To enable session-firewall-based denylisting, select the Denylist check box in the Access Rule page
during the WLAN SSID profile creation. For more information, see Access Rule Configuration Parameters.

Configuring IAPs for VPN Services
This section describes the following VPN configuration procedures:

n IAP VPN Overview
n Configuring IAPs for VPN Tunnel Creation
n Configuring Routing Profiles for IAP VPN

Configuring IAPs for VPN Tunnel Creation
Instant Access Point (IAP) supports the configuration of tunneling protocols such as GRE, IPsec, and
L2TPv3. This section describes the procedure for configuring VPN host settings on an IAP to enable
communication with a controller in a remote location:

n Configuring IPsec VPN Tunnel on page 453
n Configuring Automatic GRE VPN Tunnel on page 455
n Configuring a GRE VPN Tunnel on page 456
n Configuring an L2TPv3 VPN Tunnel on page 458

IAP VPN Overview
As Instant Access Point (IAP) use a virtual controller architecture, the IAP network does not require a
physical controller to provide the configured WLAN services. However, a physical controller is required
for terminating VPN tunnels from the IAP networks at branch locations or data centers, where the Aruba
controller acts as a VPN Concentrator.

When the VPN is configured, the IAP acting as the virtual controller creates a VPN tunnel to Aruba
Mobility Controller in your corporate office. The controller acts as a VPN endpoint and does not supply
the IAP with any configuration.

The VPN features are recommended for:

n Enterprises with many branches that do not have a dedicated VPN connection to the corporate
office.
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n Branch offices that require multiple APs.
n Individuals working from home, connecting to the VPN.

Supported VPN Protocols

IAPs support the following VPN protocols for remote access.

VPN Protocol Description

Aruba IPsec IPsec is a protocol suite that secures IP communications by authenticating and encrypting
each IP packet of a communication session.
You can configure an IPsec tunnel to ensure that to ensure that the data flow between the
networks is encrypted. However, you can configure a split-tunnel to encrypt only the
corporate traffic.
When IPsec is configured, ensure that you add the IAP MAC addresses to the allowlist
database stored on the controller or an external server. IPsec supports Local, L2, and L3
modes of IAP-VPN operations.

NOTE: The IAPs support IPsec only with Aruba Controllers.

Layer-2 (L2) GRE GRE is a tunnel protocol for encapsulating multicast, broadcast, and L2 packets between a
GRE-capable device and an endpoint. IAPs support the configuration of L2 GRE (Ethernet
over GRE) tunnel with an Aruba Controller to encapsulate the packets sent and received by
the IAP.
You can use the GRE configuration for L2 deployments when there is no encryption
requirement between the Instant AP and controller for client traffic.
IAPs support two types of GRE configuration:
n Manual GRE—The manual GRE configuration sends unencrypted client traffic with an

additional GRE header and does not support failover. When manual GRE is configured
on the IAP, ensure that the GRE tunnel settings are enabled on the controller.

n Aruba GRE—With Aruba GRE, no configuration on the controller is required except for
adding the IAP MAC addresses to the allowlist database stored on the controller or an
external server. Aruba GRE reduces manual configuration when Per-AP Tunnel
configuration is required and supports failover between two GRE endpoints.

IAPs support manual and Aruba GRE configuration only for L2 mode of operations. Aruba
GRE configuration is supported only with Aruba Controllers.

L2TP The L2TP version 3 feature allows IAP to act as L2TP Access Concentrator (LAC) and tunnel
all wireless clients L2 traffic from AP to LNS. In a centralized L2 model, the VLAN on the
corporate side are extended to remote branch sites. Wireless clients associated with IAP
gets the IP address from the DHCP server running on LNS. For this, AP has to transparently
allow DHCP transactions through the L2TPv3 tunnel.

Table 94: VPN Protocols

Configuring IPsec VPN Tunnel
An IPsec tunnel is configured to ensure that the data flow between the networks is encrypted. When
configured, the IPsec tunnel to the controller secures corporate data. You can configure an IPsec tunnel
from virtual controller using Aruba Central On-Premises.

To configure an IPsec tunnel from virtual controller, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one AP.

The dashboard context for the group is displayed.
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2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the APs are displayed.

4. Click Show Advanced.
5. Click the VPN tab.

The VPN page is displayed.

6. Click the Controller accordion.
7. In the Protocol drop-down list, select Aruba IPsec.
8. In the Primary host field, enter the IP address or FQDN for the main VPN/IPsec endpoint.

9. In the Backup host field, enter the IP address or FQDN for the backup VPN/IPsec endpoint. This
entry is optional. When you enter the primary host IP address and backup host IP address, other
fields are displayed.

10. Specify the following parameters:
n Select the Preemption check-box to allow the VPN tunnel to switch back to the primary host

when it becomes available again. This step is optional. If Preemption is enabled, specify a
value in seconds for Hold time. When preemption is enabled and the primary host comes up,
the VPN tunnel switches to the primary host after the specified hold-time. The default value for
Hold time is 600 seconds.

n Select the Fast Failover check-box to allow the IAP to create a backup VPN tunnel to the
controller along with the primary tunnel, and maintain both the primary and backup tunnels
separately. When fast failover is enabled and if the primary tunnel fails, the IAP can switch the
data stream to the backup tunnel. This reduces the total failover time to less than one minute.

n Specify a value in seconds for Seconds Between Test Packets. Based on the configured
frequency, the IAP can verify if an active VPN connection is available. The default value is 5
seconds, which means that the IAP sends one packet to the controller every 5 seconds.

n Enter a value for Max Allowed Test Packet Loss to define a number for lost packets, after
which the IAP can determine that the VPN connection is unavailable. The default value is 2.

n Select the Reconnect User On Failover check-box to disconnect all wired and wireless users
when the system switches during VPN tunnel transition from primary to backup and backup to
primary.

n Specify a value in seconds for Reconnect Time On Failover to configure an interval for which
wired and wireless users are disconnected during a VPN tunnel switch. By default, the
reconnection duration is set to 60 seconds. The Reconnect Time on Failover field is displayed
only when Reconnect User On Failover is enabled.

n From the Branch Name drop-down list, select any one of the following options:
o Master-MAC—Configures the MAC address of the conductor Instant AP as the branch key

name.
o VC-Name—Configures the name of the virtual controller in the branch as the branch key

name.
o String—Configures a custom name for the VPN branch key. The custom string should be a

maximum of 64 ASCII printable characters using UTF-8 encoding.
o None—The virtual-controller key parameter will be used as the default branch name.
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Ensure that the string is unique to each IAP branch. IAPs may lose connectivity with the controller if
multiple IAP branches have the same string as branch name. The branch name configured at the
device level takes higher precedence than a branch name configured at the group level.

11. Click Save Settings.

When the IPsec tunnel configuration is completed, the packets that are sent from and received by
an IAP are encrypted.

Configuring Automatic GRE VPN Tunnel
In Aruba Central On-Premises, you can configure an Instant Access Point (IAP) to automatically set up a
GRE tunnel from the IAP to the controller.

To configure an IAP to automatically set up a GRE tunnel, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one AP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the APs are displayed.

4. Click Show Advanced.
5. Click the VPN tab.

The VPN page is displayed.

6. Click the Controller accordion.

7. In the Protocol drop-down list, select Aruba GRE.

8. In the Primary host field, enter the IP address or FQDN for the main VPN/IPsec endpoint.

9. In the Backup host field, enter the IP address or FQDN for the backup VPN/IPsec endpoint. This
entry is optional. When you enter the primary host IP address and backup host IP address, other
fields are displayed.

10. Specify the following parameters:
a. Select the Preemption check-box to allow the VPN tunnel to switch back to the primary host

when it becomes available again. This step is optional. If Preemption is enabled, specify a
value in seconds for Hold time. When preemption is enabled and the primary host comes
up, the VPN tunnel switches to the primary host after the specified hold time. The default
value for Hold time is 600 seconds.

b. Select the Fast Failover check-box to allow the IAP to create a backup VPN tunnel to the
controller along with the primary tunnel, and maintain both the primary and backup tunnels
separately. If the primary tunnel fails, the IAP can switch the data stream to the backup
tunnel. This reduces the total failover time to less than one minute.

c. Select the Reconnect User On Failover to disconnect all wired and wireless users when the
system switches during VPN tunnel transition from primary to backup and backup to
primary,

d. Specify a value in seconds for Reconnect Time On Failover to configure an interval for
which wired and wireless users are disconnected during a VPN tunnel switch. By default, the
reconnection duration is set to 60 seconds.
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e. Specify a value in seconds for Seconds Between Test Packets. Based on the configured
frequency, the IAP can verify if an active VPN connection is available. The default value is 5
seconds, which means that the IAP sends one packet to the controller every 5 seconds.

f. Enter a value for Max Allowed Test Packet Loss to define a number for lost packets, after
which the IAP can determine that the VPN connection is unavailable. The default value is 2.

g. Select the Per-AP-Tunnel check-box to create a GRE tunnel from each IAP to the VPN/GRE
Endpoint rather than the tunnels created just from the conductor IAP. When enabled, the
traffic to the corporate network is sent through a Layer-2 GRE tunnel from the IAP itself and
need not be forwarded through the conductor IAP.

h. From the Branch Name drop-down list, select any one of the following options:
n Master-MAC—Configures the MAC address of the conductor Instant AP as the branch key

name.
n VC-Name—Configures the name of the virtual controller in the branch as the branch key

name.
n String—Configures a custom name for the VPN branch key. The custom string should be a

maximum of 64 ASCII printable characters using UTF-8 encoding.
n None—The virtual-controller key parameter will be used as the default branch name.

Ensure that the string is unique to each IAP branch. IAPs may lose connectivity with the controller
if multiple IAP branches have the same string as branch name. The branch name configured at the
device level takes higher precedence than a branch name configured at the group level.

11. Click Save Settings.

Configuring a GRE VPN Tunnel
You can also manually configure a GRE tunnel by configuring the GRE tunnel parameters on the Instant
Access Point (IAP) and controller. This procedure describes the steps involved in the manual
configuration of a GRE tunnel from virtual controller by using Aruba Central On-Premises.

During the manual GRE setup, you can either use the virtual controller IP or the IAP IP to create the GRE
tunnel at the controller side depending upon the following IAP settings:

n If a virtual controller IP is configured and if Per-AP tunnel is disabled, the virtual controller IP is used
to create the GRE tunnel.

n If a virtual controller IP is not configured or if Per-AP tunnel is enabled, the IAP IP is used to create the
GRE tunnel.

To configure the GRE tunnel manually, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one AP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the APs are displayed.

4. Click Show Advanced.
5. Click the VPN tab.

The VPN page is displayed.
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6. Click the Controller accordion.

7. In the Protocol drop-down list, select Manual GRE.

8. Specify the following parameters:
n Host—Enter the IPv4 or IPv6 address or FQDN for the main VPN/GRE tunnel.
n Backup Host—(Optional) Enter the IPv4 or IPv6 address or FQDN for the backup VPN/GRE

tunnel. You can edit this field only after you enter the IP address or FQDN in the Host field.
n Reconnect User On Failover—When you enter the host IP address and backup host IP

address, this field appears. Select this check-box to disconnect all wired and wireless users
when the system switches during VPN tunnel transition from primary to backup and backup to
primary. To disconnect all wired and wireless users when the system switches during
VPN tunnel transition from primary to backup and backup to primary, select the Reconnect
User On Failover.

n Reconnect Time On Failover—If you select the Reconnect User On Failover check-box, this
field appears. To configure an interval for which wired and wireless users must be
disconnected during a VPN tunnel switch, specify a value within a range of 30-90 seconds. By
default, the reconnection duration is set to 60 seconds.

n GRE Type—Enter a value for the parameter.
n GRE Mtu—Specify a size for the GRE MTU within the range of 1024–1500. After GRE

encapsulation, if packet length exceeds the configured MTU, IP fragmentation occurs. The
default MTU size is 1300.

n Per-AP-Tunnel—The administrator can enable this option to create a GRE tunnel from each
IAP to the VPN/GRE endpoint rather than the tunnels created just from the conductor IAP.
When enabled, the traffic to the corporate network is sent through a Layer-2 GRE tunnel from
the IAP itself and need not be forwarded through the conductor IAP.

By default, the Per-AP tunnel option is disabled.

n From the Branch Name drop-down list, select any one of the following options:
o Master-MAC—Configures the MAC address of the conductor Instant AP as the branch key

name.
o VC-Name—Configures the name of the virtual controller in the branch as the branch key

name.
o String—Configures a custom name for the VPN branch key. The custom string should be a

maximum of 64 ASCII printable characters using UTF-8 encoding.
o None—The virtual-controller key parameter will be used as the default branch name.

Ensure that the string is unique to each IAP branch. IAPs may lose connectivity with the controller if
multiple IAP branches have the same string as branch name. The branch name configured at the
device level takes higher precedence than a branch name configured at the group level.

9. Click Save Settings.

When the GRE tunnel configuration is completed on both the IAP and Controller, the packets sent
from and received by an IAP are encapsulated, but not encrypted.
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Configuring an L2TPv3 VPN Tunnel
The Layer 2 Tunneling Protocol version 3 (L2TPv3) feature allows Instant Access Point (IAP) to act as L2TP
Access Concentrator (LAC) and tunnel all wireless clients L2 traffic from AP to LNS. In a centralized L2
model, the VLAN on the corporate side are extended to remote branch sites. Wireless clients associated
with IAP gets the IP address from the DHCP server running on LNS. For this, AP has to transparently
allow DHCP transactions through the L2TPv3 tunnel.

To configure an L2TPv3 tunnel by using Aruba Central On-Premises, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one AP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the APs are displayed.

4. Click Show Advanced.
5. Click the VPN tab.

The VPN page is displayed.

6. Click the Controller accordion.
7. In the Protocol drop-down list, select L2TPv3.
8. To configure a tunnel profile, complete the following steps:

a. Turn on the Enable Tunnel Profile toggle switch.
b. Enter the profile name in the Profile Name text-box.
c. Enter the primary server IP address in the Primary Peer Address text-box.
d. Enter the remote end backup tunnel IP address in the Backup Peer Address text-box. This is

an optional field and is required only when backup server is configured.
e. Enter the peer UDP port numbers in the Peer UDP Port text-box. The default value is 1701.
f. Enter the local UDP port numbers in the Local UDP Port text-box. The default value is 1701.
g. Enter the interval in the Hello Interval text-box at which the hello packets are sent through

the tunnel. The default value is 60 seconds.
h. Select the message digest as MD5 or SHA from the Message Digest Type drop-down list for

message authentication.
i. Enter a shared key in the Shared Key text-box for the message digest. This key should match

with the tunnel end point shared key.
j. Set the Failover Mode. The following two failover modes are supported:

n Preemptive—In this mode, if the primary comes up when the backup is active, the backup
tunnel is deleted and the primary tunnel resumes as an active tunnel. If you configure the
tunnel to be preemptive, and when the primary tunnel goes down, it starts the persistence
timer which tries to bring up the primary tunnel.

n Non-Preemptive—In this mode, when the backup tunnel is established after the primary
tunnel goes down, it does not make the primary tunnel active again.

n Set an interval between every failover retry in Failover Retry Interval. The default value is
60 seconds.

n Configure a number of retries in Failover Retry Count before the tunnel fails over.
k. Ensure that Checksum check-box is enabled.
l. Specify a tunnel MTU value in the MTU check-box. The default value is 1460.
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9. To configure a session profile, complete the following steps:
a. Turn on the Enable Session Profile toggle switch.
b. Enter the session profile name.
c. Enter the tunnel profile name where the session will be associated.
d. Configure the tunnel IP address with the corresponding network mask and VLAN ID. This is

required to reach an AP from a corporate network. For example, SNMP polling.
e. Select the cookie length and enter a cookie value corresponding to the length. By default, the

cookie length is not set.
f. From the Branch Name drop-down list, select any one of the following options:

n Master-MAC—Configures the MAC address of the conductor Instant AP as the branch key
name.

n VC-Name—Configures the name of the virtual controller in the branch as the branch key
name.

n String—Configures a custom name for the VPN branch key. The custom string should be a
maximum of 64 ASCII printable characters using UTF-8 encoding.

n None—The virtual-controller key parameter will be used as the default branch name.

Ensure that the string is unique to each IAP branch. IAPs may lose connectivity with the controller
if multiple IAP branches have the same string as branch name. The branch name configured at the
device level takes higher precedence than a branch name configured at the group level.

10. Click Save Settings.

Configuring Routing Profiles for IAP VPN
Aruba Central On-Premises can terminate a single VPN connection on Aruba Mobility Controller. The
routing profile defines the corporate subnets which need to be tunneled through IPsec.

You can configure routing profiles to specify a policy based on routing into the VPN tunnel.

1. In the Aruba Central On-Premises app, set the filter to a group that contains at least one AP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of access points is displayed in the List view.

3. Click the Config icon.

The tabs to configure the access points are displayed.

4. Click Show Advanced, and click the VPN tab.

The VPN details page is displayed.

5. Click the Routing accordion.

6. Click + in the Routing pane.

The New Route page with the route parameters is displayed.

7. Update the following parameters:
n Destination—Specify the destination network that is reachable through the VPN tunnel. This

defines the IP or subnet that must reach through the IPsec tunnel. Traffic to the IP or subnet
defined here will be forwarded through the IPsec tunnel.

n Netmask—Specify the subnet mask to the destination defined for Destination.
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n Gateway—Specify the gateway to which traffic must be routed. In this field, enter one of the
following based on the requirement:
o The controller IP address on which the VPN connection will be terminated. If you have a

primary and backup host, configure two routes with the same destination and netmask, but
ensure that the gateway is the primary controller IP for one route and the backup controller
IP for the second route.

o The "tunnel" string if you are using the IAP in Local mode during local DHCP configuration.
n Metric—Specify the best optimal path for routing traffic. A value of 1 indicates the best path,

15 indicates the worst path, and 16 indicates that the destination is unreachable on the route.

8. Click OK.
9. Click Save Settings.

Configuring DHCP Pools and Client IP Assignment Modes on IAPs
This section provides the following information:

n Configuring DHCP Scopes on IAPs

n Configuring DHCP Server for Assigning IP Addresses to IAP Clients

Configuring DHCP Scopes on IAPs
The Virtual Controller (VC) supports the following types of DHCP address assignments:

n Configuring DHCP Scopes on IAPs on page 460

n Configuring DHCP Scopes on IAPs on page 460

n Configuring Local DHCP Scopes on page 465

Configuring Distributed DHCP Scopes
Aruba Central On-Premises allows you to configure the DHCP address assignment for the branches
connected to the corporate network through VPN. You can configure the range of DHCP IP addresses
used in the branches and the number of client addresses allowed per branch. You can also specify the
IP addresses that must be excluded from those assigned to clients, so that they are assigned statically.

Aruba Central On-Premises supports the following distributed DHCP scopes:

n Distributed, L2—In this mode, the VC acts as the DHCP server, but the default gateway is in the data
center. Based on the number of clients specified for each branch, the range of IP addresses is
divided. Based on the IP address range and client count configuration, the DHCP server in the VC
controls a scope that is a subset of the complete IP Address range for the subnet distributed across
all the branches. This DHCP Assignment mode is used with the L2 forwarding mode.

n Distributed, L3—In this mode, the VC acts as the DHCP server and the default gateway. Based on
the number of clients specified for each branch, the range of IP addresses is divided. Based on the IP
address range and client count configuration, the DHCP server in the VC is configured with a unique
subnet and a corresponding scope.

To configure distributed DHCP scopes such as Distributed, L2 or Distributed, L3, complete the following
steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one AP.

The dashboard context for the group is displayed.
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2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the APs are displayed.

4. Click Show Advanced.
5. Click the System tab.

The System page is displayed.

6. Click the DHCP accordion.

The DHCP configuring options are displayed.

7. Click + on Distributed DHCP Scopes.

The Distributed DHCP Scopes table is displayed.

8. To configure distributed DHCP scope, click + under Distributed DHCP Scopes table.

The New Distributed DHCP Scopes page is displayed.

9. Based on the type of distributed DHCP scope, configure the parameters described in .

10. Click Next.
The Branch Size tab is displayed.

11. Specify the number of clients to use per branch in Clients Per Branch.

The client count configured for a branch determines the use of IP addresses from the IP address range
defined for a DHCP scope. For example, if 20 IP addresses are available in an IP address range
configured for a DHCP scope and a client count of 9 is configured, only a few IP addresses (in this
example, 9) from this range will be used and allocated to a branch. The IAP does not allow the
administrators to assign the remaining IP addresses to another branch, although a lower value is
configured for the client count.

12. Click Next.
The Static IP tab is displayed.

13. Specify the number of first and last IP addresses to reserve in the subnet in Reserve First and
Reserve Last.

14. Click Finish.

The following table lists the distributed DHCP scope configuration parameters.

Data pane item Description

Name Enter a name for the DHCP scope.

Type Select any of the following options:
n Distributed, L2—On selecting Distributed, L2, the VC acts as the DHCP Server but the

default gateway is in the data center. Traffic is bridged into VPN tunnel.
n Distributed, L3—On selecting Distributed, L3, the VC acts as both DHCP Server and

default gateway. Traffic is routed into the VPN tunnel.

Table 95: Distributed DHCP Scope Configuration Parameters
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Data pane item Description

VLAN Specify a VLAN ID. To use this subnet, ensure that the VLAN ID specified here is assigned
to an SSID profile.

Netmask If Distributed, L2 is selected for type of DHCP scope, specify the subnet mask. The subnet
mask and the network determine the size of subnet.

Default Router If Distributed, L2 is selected for type of DHCP scope, specify the IP address of the default
router.

DNS Server If required, specify the IP address of a DNS server.

Domain Name If required, specify the domain name.

Lease Time Specify a lease time for the client in minutes.

DHCP Relay Select the DHCP Relay toggle switch to allow the IAPs to intercept the broadcast packets
and relay DHCP requests.

Helper Address Enter the IP address of the DHCP server.

Dynamic DNS Turn on the toggle switch to sent the updates of the clients periodically during the
specified time to the DNS server that is configured in the DHCP profile.

Key Enter the TSIG shared secret key..

DDNS Pointer
Record (PTR)

The Dynamic DNS updates of the clients are periodically sent during the specified time to
the DNS server that is configured in the DHCP profile. Turn on the toggle switch to enable
the Distributed L3 DHCP clients to send PTR updates to the DDNS server.

IP Address Range Specify a range of IP addresses to use. To add another range, click the + icon. You can
specify up to four different ranges of IP addresses.
n For Distributed, L2 mode, ensure that all IP ranges are in the same subnet as the

default router. On specifying the IP address ranges, a subnet validation is performed
to ensure that the specified ranges of IP address are in the same subnet as the default
router and subnet mask. The configured IP range is divided into blocks based on the
configured client count.

n For Distributed, L3 mode, you can configure any dis-contiguous IP ranges. The
configured IP range is divided into multiple IP subnets that are sufficient to
accommodate the configured client count.

You can allocate multiple branch IDs (BID) per subnet. The Instant Access Point (IAP)
generates a subnet name from the DHCP IP configuration, which the controller can use as
a subnet identifier. If static subnets are configured in each branch, all of them are
assigned the with BID 0, which is mapped directly to the configured static subnet.

DHCP
Reservation

Displays the total number of DHCP reservations. Click the number to view the list of DHCP
reservations.
You can configure DHCP reservation only on virtual controllers.
From the filter bar, select a virtual controller and click the + icon to configure
DHCP reservation. Specify the following details:
n MAC—Specify the MAC address of the device for which the IP address has to be

reserved.
n IP—Specify the IP address that has to be reserved for the MAC address. The IP address

should be in the IP address range.

Table 95: Distributed DHCP Scope Configuration Parameters
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Data pane item Description

NOTE: Aruba Central allows you to configure a maximum of 32 DHCP reservations.

To delete a DHCP reservation, click the delete icon.

Option Specify the type and a value for the DHCP option. You can configure the organization-
specific DHCP options supported by the DHCP server. For example, 176, 242, 161, and so
on. To add multiple DHCP options, click the + icon. You can add up to eight DHCP options.

Table 95: Distributed DHCP Scope Configuration Parameters

Configuring a Centralized DHCP Scope
The centralized DHCP scope supports L2 and L3 clients.

When a centralized DHCP scope is configured:

n The virtual controller does not assign an IP address to the client and the DHCP traffic is directly
forwarded to the DHCP Server.

n For L2 clients, the virtual controller bridges the DHCP traffic to the controller over the VPN/GRE
tunnel. The IP address is obtained from the DHCP server behind the controller serving the VLAN/GRE
of the client. This DHCP assignment mode also allows you to add the DHCP option 82 to the DHCP
traffic forwarded to the controller.

n For L3 clients, the virtual controller acts as a DHCP relay agent that forwards the DHCP traffic to the
DHCP server located behind the controller in the corporate network and reachable through the IPsec
tunnel. The centralized L3 VLAN IP is used as the source IP. The IP address is obtained from the DHCP
server.

To configure a centralized DHCP scope, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one AP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the APs are displayed.

4. Click Show Advanced.
5. Click the System tab.

The System page is displayed.

6. Click the DHCP accordion.

The DHCP configuring options are displayed.

7. Click + on Centralized DHCP Scopes.

The Centralized DHCP Scopes table is displayed.

8. To configure centralized DHCP scopes, click + under Centralized DHCP Scopes table.

The New Centralized DHCP Scopes pane is displayed.

9. Based on type of centralized DHCP scope, configure the parameters described in .

10. Click OK.
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The following table lists the centralized DHCP scope configuration parameters.

Data pane item Description

Name Enter a name for the DHCP scope.

Type Select one of the following options:
n Centralized, Layer-2
n Centralized, Layer-3

VLAN Specify a VLAN ID. To use this subnet, ensure that the VLAN ID specified here is assigned
to an SSID profile.

Split Tunnel Enable the split tunnel function if you want allow a VPN user to access a public network
and a local LAN or WAN network at the same time through the same physical network
connection. For example, a user can use a remote access VPN software client connecting
to a corporate network using a home wireless network. When the split tunnel function is
enabled, the user can connect to file servers, database servers, mail servers, and other
servers on the corporate network through the VPN connection.
When the user connects to resources on the Internet (websites, FTP sites, and so on), the
connection request goes directly to the gateway provided by the home network. The split
DNS functionality intercepts DNS requests from clients for non-corporate domains (as
configured in Enterprise Domains list) and forwards to the IAP's own DNS server.
When split tunnel is disabled, all the traffic including the corporate and the Internet
traffic is tunneled irrespective of the routing profile specifications. If the GRE tunnel is
down and when the corporate network is not reachable, the client traffic is dropped.

DHCP Relay Select the DHCP Relay check box to allow the IAPs to intercept the broadcast packets
and relay DHCP requests.

Helper Address Enter the IP address of the DHCP server.

VLAN IP Field is applicable only if you select Centralized, Layer-3. Specify the VLAN IP address of
the DHCP relay server.

VLAN Mask Field is applicable only if you select Centralized, Layer-3. Specify the VLAN subnet mask
of the DHCP relay server.

Option 82 Select one of the following options:
n None—If you have configured the DHCP Option 82 XML file, the ALU option scope is

disabled in the drop-down list. To enable ALU, set the drop-down list to None and
delete the DHCP Option 82 XML file. To enable the XML option, select None from the
drop-down list and select the XML file from the DHCP Option 82 XML drop-down list.

n ALU—ALU option is disabled if an XML file is selected from the DHCP Option 82 XML
drop-down list in the System > General pane. Select ALU to enable DHCP Option 82
to allow clients to send DHCP packets with the Option 82 string. The Option 82 string
is available only in the Alcatel (ALU) format. The ALU format for the Option 82 string
consists of the following:

n Remote Circuit ID; X AP-MAC; SSID; SSID-Type
n Remote Agent; X IDUE-MAC
n XML—XML option is enabled only if an XML file is selected from the DHCP Option 82

XML drop-down list in the System > General pane. Alternatively, to enable the XML
option, select None from the drop-down list and select the XML file from the DHCP
Option 82 XML drop-down list.

For information related to XML files, see Configuring System Parameters for an IAP

Table 96: DHCP mode configuration parameters
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The following table describes the behavior of the DHCP Relay Agent and Option 82 in the IAP.

DHCP Relay Option 82 Behavior

Enabled Enabled DHCP packet relayed with the ALU-specific
Option 82 string.

Enabled Disabled DHCP packet relayed without the ALU-
specific Option 82 string.

Disabled Enabled DHCP packet not relayed, but broadcast
with the ALU-specific Option 82 string.

Disabled Disabled DHCP packet not relayed, but broadcast
without the ALU-specific Option 82 string.

Table 97: DHCP Relay and Option 82

Configuring Local DHCP Scopes
You can configure the following types of local DHCP scopes on an IAP:

n Local—In this mode, the VC acts as both the DHCP Server and default gateway. The configured
subnet and the corresponding DHCP scope are independent of subnets configured in other IAP
clusters. The VC assigns an IP address from a local subnet and forwards traffic to both corporate
and non-corporate destinations. The network address is translated appropriately and the packet is
forwarded through the IPsec tunnel or through the uplink. This DHCP assignment mode is used for
the NAT forwarding mode.

n Local, L2—In this mode, the VC acts as a DHCP server and the gateway is located outside the IAP.
n Local, L3—In this mode, the VC acts as a DHCP server and default gateway, and assigns an IP

address from the local subnet. The IAP routes the packets sent by clients on its uplink. This DHCP
assignment mode is used with the L3 forwarding mode.

To configure a new local DHCP scope, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one AP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the APs are displayed.

4. Click Show Advanced.
5. Click the System tab.

The System page is displayed.

6. Click the DHCP accordion.

The DHCP configuring options are displayed.

7. Click + on Local DHCP Scopes.

The Local DHCP Scopes table is displayed.

8. To configure local DHCP scopes, click + under Local DHCP Scopes table.

The New DHCP Scopes pane is displayed.
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9. Based on type of local DHCP scope, configure the parameters described in Table 98.

10. Click OK.

The following table lists the local DHCP scope configuration parameters.

Data pane
item Description

Name Enter a name for the DHCP scope.

Type Select any of the following options:
n Local—On selecting Local, the DHCP server for local branch network is used for

keeping the scope of the subnet local to the IAP. In the NAT mode, the traffic is
forwarded through the uplink.

n Local, L2—On selecting Local, L2, the VC acts as a DHCP server and a default gateway
in the local network is used.

n Local, L3—On selecting Local, L3, the VC acts as a DHCP server and gateway.

VLAN Enter the VLAN ID. To use this subnet, ensure that the VLAN ID specified here is assigned to
an SSID profile.

Network Specify the network to use.

Netmask Specify the subnet mask. The subnet mask and the network determine the size of subnet.

Excluded
Address

Specify a range of IP addresses to exclude. You can add up to two exclusion ranges. Based
on the size of the subnet and the value configured for Excluded address, the IP addresses
either before or after the defined range are excluded.

DHCP
Reservation

Displays the total number of DHCP reservations. Click the number to view the list of DHCP
reservations.
You can configure DHCP reservation only on virtual controllers.
From the filter bar, select a virtual controller and click the + icon to configure
DHCP reservation. Specify the following details:
n MAC—Specify the MAC address of the device for which the IP address has to be

reserved.
n IP—Specify the IP address that has to be reserved for the MAC address. The IP address

should be in the IP address range.

NOTE: Aruba Central allows you to configure a maximum of 32 DHCP reservations.

To delete a DHCP reservation, click the delete icon.

Default Router Enter the IP address of the default router.

DNS Server Enter the IP address of a DNS server.

Domain Name Enter the domain name.

Lease Time Enter a lease time for the client in minutes.

DHCP Relay Select the DHCP Relay check box to allow the IAPs to intercept the broadcast packets and
relay DHCP requests.

Table 98: Local DHCP Configuration Parameters
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Data pane
item Description

Helper Address Enter the IP address of the DHCP server.

VLAN IP Field is applicable only if you select Local, L2. Specify the VLAN IP address of the DHCP
relay server.

VLAN Mask Field is applicable only if you select Local, L2. Specify the VLAN subnet mask of the DHCP
relay server.

Option Specify the type and a value for the DHCP option. You can configure the organization-
specific DHCP options supported by the DHCP server. To add multiple DHCP options, click
the + icon.

Table 98: Local DHCP Configuration Parameters

Configuring DHCP Server for Assigning IP Addresses to IAP Clients
The DHCP server is a built-in server, used for networks in which clients are assigned IP address by the
Virtual Controller (VC). You can customize the DHCP pool subnet and address range to provide
simultaneous access to more number of clients. The largest address pool supported is 2048. The default
size of the IP address pool is 512.

n When the DHCP server is configured and if the Client IP assignment parameter for an SSID profile is set
to Virtual Controller Assigned, the virtual controller assigns the IP addresses to the WLAN or wired
clients. By default, the Instant Access Point (IAP) automatically determines a suitable DHCP pool for
Virtual Controller Assigned networks.

n The IAP typically selects the 172.31.98.0/23 subnet. If the IP address of the IAP is within the 172.31.98.0/23
subnet, the IAP selects the 10.254.98.0/23 subnet. However, this mechanism does not avoid all possible
conflicts with the wired network. If your wired network uses either 172.31.98.0/23 or 10.254.98.0/23, and
you experience problems with the Virtual Controller Assigned networks after upgrading to Aruba
Central, manually configure the DHCP pool by following the steps described in this section.

To configure a domain name, DNS server, and DHCP server for client IP assignment, complete the
following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one AP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the APs are displayed.

4. Click Show Advanced.
5. Click the System tab.

The System page is displayed.

6. Click the DHCP accordion.

The DHCP configuring options are displayed.
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7. Click + on DHCP For WLANs and enter the following information:
n Domain Name—Enter the domain name of the client.
n DNS Server—Enter the IP addresses of the DNS servers. To add another DNS server, click the

+ icon.
n Lease Time—Enter the duration of the DHCP lease. Select Minutes, Hours, or Days for the

lease time from the list next to Lease Time. The default lease time is 0.
n Network—Enter the network name.
n Mask—Enter the mask name.
n DHCP Relay—Select the check box to allow the IAPs to intercept the broadcast packets and relay DHCP

requests.

n Helper Address—Enter the IP address of the DHCP server.

8. Click Save Settings.

To provide simultaneous access to more than 512 clients, use the Network and Mask fields to specify a larger
range. While the network (prefix) is the common part of the address range, the mask (suffix) specifies how long
the variable part of the address range is.

Configuring Services
This section describes how to configure AirGroup, location services, Lawful Intercept, OpenDNS, and
Firewall services.

n Configuring AirGroup Services
n Configuring an IAP for RTLS Support
n Configuring an IAP for ALE Support
n Managing BLE Beacons
n Configuring OpenDNS Credentials on IAPs
n Configuring CALEA Server Support on IAPs
n Configuring IAPs for Palo Alto Networks Firewall Integration
n Configuring XML API Interface
n Enabling Application Visibility on Instant APs
n Enabling Application Visibility on Campus APs
n Configuring RRM IE Profile

Configuring AirGroup Services
AirGroup is a zero configuration networking protocol that enables service discovery, address
assignment, and name resolution for desktop computers, mobile devices, and network services. It is
designed for flat, single-subnet IP networks such as wireless networking at home.

Bonjour can be installed on computers running Microsoft Windows and is supported by the new
network-capable printers. Bonjour uses multicast DNS (mDNS) to locate devices and the services offered
by these devices. The AirGroup solution supports both wired and wireless devices. Wired devices that
support Bonjour services are part of AirGroup when connected to a VLAN that is terminated on the
Virtual Controller.

In addition to the mDNS protocol, Instant Access Points (IAPs) also support UPnP, and DLNA enabled
devices. DLNA is a network standard derived from UPnP, which enables devices to discover the services
available in a network.
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DLNA also provides the ability to share data between the Windows or Android-based multimedia
devices. All the features and policies applicable to mDNS are extended to DLNA to ensure full
interoperability between compliant devices.

AirGroup Features
AirGroup provides the following features:

n Send unicast responses to mDNS queries and reduces mDNS traffic footprint.
n Ensure cross-VLAN visibility and availability of AirGroup devices and services.
n Allow or block AirGroup services for all users.
n Allow or block AirGroup services based on user roles.
n Allow or block AirGroup services based on VLANs.

For more information on AirGroup solution, see Aruba Instant User Guide.

AirGroup Services
Bonjour supports zero-configuration services. The services are pre-configured and are available as part
of the factory default configuration. The administrator can also enable or disable any or all services.

The following services are available for IAP clients:

n AirPlay — Apple AirPlay allows wireless streaming of music, video, and slide shows from your iOS
device to Apple TV and other devices that support the AirPlay feature.

n AirPrint — Apple AirPrint allows you to print from an iPad, iPhone, or iPod Touch directly to any
AirPrint compatible printer.

n iTunes— The iTunes service is used by iTunes Wi-Fi sync and iTunes home-sharing applications
across all Apple devices.

n RemoteMgmt— Use this service for remote login, remote management, and FTP utilities on Apple
devices.

n Sharing— Applications such as disk sharing and file sharing, use the service ID that are part of this
service on one or more Apple devices.

n Chat— The iChat® (Instant Messenger) application on Apple devices uses this service.
n ChromeCast—The ChromeCast service allows you to use a ChromeCast device to play audio or video

content on a high-definition television by streaming content through Wi-Fi from the Internet or local
network.

n DLNA Media—Applications such as Windows Media Player use this service to browse and play
content on a remote device.

n DLNA Print—This service is used by printers that support DLNA.

To enable AirGroup services:

1. In the Aruba Central On-Premises app, set the filter to a group that contains at least one AP.
The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.
3. Click the Config icon. The tabs to configure access points is displayed.
4. Click Show Advanced, and click Services tab. The Services page is displayed.
5. Click the AirGroup accordion.
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6. Select the AirGroup check-box.

The mDNS (Bonjour) and SSDP (DLNA/UPNP) check-boxes are selected by default.

Select at least mDNS (Bonjour) or SSDP (DLNA/UPNP) to proceed further.

Optionally, select the Guest Bonjour Multicast check-box to allow guest users to use the Bonjour
services that are enabled in a guest VLAN. When Guest Bonjour Multicast is enabled, the Bonjour
devices are visible only in the guest VLAN and AirGroup does not discover or enforce policies in guest
VLAN.

7. Under the AirGroup Settings sub-accordion, select the check-box against one or more AirGroup
services listed in AirGroup Services.

n Optionally, when enabling an AirGroup service, define disallowed roles. The disallowed roles
are not allowed to use the specific AirGroup service. To disallow roles, complete the following
steps:

1. Click Edit against Disallowed Roles.
2. Move the roles from the Available pool to the Selected pool.
3. Click Ok.

n Optionally, when enabling an AirGroup service, define disallowed VLANs. The disallowed
VLANs are not allowed to use the specific AirGroup service. To disallow VLANs, complete the
following steps:

1. Click Edit against Disallowed VLANs.
2. Type the VLANs in Enter comma-separated list of VLAN IDs. Separate multiple VLANs

with a comma.
3. Click Ok.

n Optionally, configure and enable a new AirGroup service. If defined, disallowed roles or VLANs
are not allowed to use the new AirGroup service. To configure and enable a new AirGroup
service, complete the following steps:

1. Click Add New Service.
2. Type the service name in Service Name. Use alphanumeric characters.
3. Type a service ID in Service ID. Use + to add additional service IDs.

n Sample service ID: urn:schemas-upnp-org:service:RenderingControl:1 or _sleep-proxy._
udp.

1. Click Ok.
2. Select the check-box against the new AirGroup service.

n Optionally, under ClearPass Settings sub-accordion, configure the parameters listed in Table
100.

8. Click Save Settings.

The following table lists the AirGroup services.
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Mode Description

AirGroup Across Mobility
Domains

AirGroup service availability in inter cluster domains.

AirPrint Wireless printing between AirPrint capable devices and AirPrint compatible
printers.

Enable AirPlay Wireless streaming of music, video, or slide shows from AirPlay capable
devices and AirPlay compatible devices.

iTunes iTunes service for home-sharing applications.

Remote Management Remote login, remote management, or FTP utilities on compatible devices.

Sharing Applications like disk sharing or file sharing on compatible devices.

Chat Instant messenger application between compatible devices.

Googlecast Wireless streaming of audio or video content from the Internet or local
network on a HDTV through a Chromecast device.

DIAL Wireless streaming between DIAL compatible devices likes devices like Roku,
Chromecast, or FireTV.

AmazonTV Wireless playing of content from the Internet or local network on a HDTV
through a FireTV device.

DLNA Print Wireless printing between DLNA capable devices and DLNA compatible
printers.

DLNA Media Wireless browsing or playing audio or video content by applications like
Windows Media Player on remote devices.

Allow All All AirGroup services.

Table 99: AirGroup Services

The following table lists the ClearPass settings.

Mode Description

ClearPass Policy
Manager Server 1

Specify the ClearPass Policy Manager server to use. Select one from the drop-down or
define a new ClearPass Policy Manager server.

Enforce ClearPass
Registration

Specify is ClearPass registration should be enforced.

Table 100: ClearPass Settings

Configuring an IAP for RTLS Support
Aruba Central supports the real time tracking of devices. With the help of the RTLS, the devices can be
monitored in real time or through history.

To configure RTLS, complete the following steps:
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1. In the Aruba Central On-Premises app, use the filter to select a group or a device.
2. Under Manage, click Devices > Access Points.
3. Click the Config icon. The tabs to configure access points is displayed.
4. Click Show Advanced, and click Services. The Services page is displayed.
5. Click Real Time Locating System > Aruba.
6. Select Aruba RTLS to send the RFID tag information to the Aruba RTLS server.
7. Click 3rd Party and select Aeroscout to send reports on the stations to a third-party server.
8. In the IP/FQDN and Port field, specify the IP address and port number of the RTLS server, to

which location reports must be sent.
9. In the Passphrase field, enter the passphrase required for connecting to the RTLS server.

10. Retype the passphrase in the Retype Passprahrse field.
11. Specify the update interval within the range of 6–60 seconds in the Update every field. The

default interval is 30 seconds.
12. If 3rd Party is selected, specify the IP address and port number of the 3rd party server.
13. Select Include Unassociated Stations to send reports on the stations that are not associated to

any Instant AP.
14. Click Save Settings.

Configuring an IAP for ALE Support
ALE is designed to gather client information from the network, process it and share it through a
standard API. The client information gathered by ALE can be used for analyzing a client’s Internet
behavior for business such as shopping preferences.

ALE includes a location engine that calculates the associated and unassociated device location every 30
seconds by default. For every device on the network, ALE provides the following information through
the Northbound API:

n Client user name
n IP address
n MAC address
n Device type
n Application firewall data, showing the destinations and applications used by associated devices.
n Current location
n Historical location
n ALE requires the access point (AP) placement data to be able to calculate location for the devices in a

network.

ALE with Aruba Central
Aruba Central supports Analytics and Location Engine (ALE). The ALE server acts as a primary interface
to all third-party applications and the IAP sends client information and all status information to the ALE
server.

To integrate IAP with ALE, the ALE server address must be configured on an IAP. If the ALE sever is
configured with a host name, the Virtual Controller performs a mutual certificated-based authentication
with ALE server, before sending any information.
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Enabling ALE support on an IAP
To configure an IAP for ALE support:

1. In the Aruba Central On-Premises app, set the filter to a group that contains at least one AP.
The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.
3. Click the Config icon. The tabs to configure access points is displayed.
4. Click Show Advanced, and click Services tab. The Services page is displayed.
5. Click the Real Time Locating System accordion.
6. Click Aruba, and then select Analytics & Location.
7. Specify the ALE server name or IP address in the Server.
8. Specify the reporting interval within the range of 6–60 seconds in the Report Interval. The IAP

sends messages to the ALE server at the specified interval. The default interval is 30 seconds.
9. Click Save Settings.

Managing BLE Beacons
Instant Access Points (IAPs) support Aruba BLE devices, such as BT-100 and BT-105, which are used for
location tracking and proximity detection. The BLE devices can be connected to an IAP and are managed
by a cloud-based Beacon Management Console. The BLE Beacon Management feature allows you to
configure parameters for managing the BLE beacons and establishing secure communication with the
Beacon Management Console.

Support for BLE Asset Tracking
IAP assets can be tracked using BLE tags, IAP beacons scan the network. When a tag is detected, the IAP
sends a beacon with information about the tag including the MAC address and RSSI of the tag to the
Virtual Controller.

To manage beacons and configure BLE operation mode, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group that contains at least one AP.
The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

3. Click the Config icon. The tabs to configure access points is displayed.

4. Click Show Advanced, and click Services tab.
The Services page is displayed.

5. Click the Real Time Locating System accordion.

6. Click Aruba.

7. Select Manage BLE Beacons to manage the BLE devices using BMC.
n Enter the authorization token in Authorization token. The authorization token is a text string

of 1–255 characters used by the BLE devices in the HTTPS header when communicating with
the BMC. This token is unique for each deployment.

n Enter the server URL in Endpoint URL. The BLE data is sent to the server URL for monitoring.

8. Select the options from BLE Operation Mode drop-down list described in Table 101.

9. To configure BLE web socket management server, enter the URL of BLE web socket management
server in BLE Asset Tag Mgmt Server(wss).
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10. Select BLE Asset Tag Mgmt Server(https) to configure BLE HTTPS management server.
n Enter the URL of BLE HTTPS management server in Server URL.
n Enter the authorization token in Authorization token.
n Enter the location ID in Location ID.

11. Click Save Settings.

The following table lists the BLE Operation Mode options.

Mode Description

beaconing The built-in BLE chip in the IAP functions as an iBeacon combined with the beacon
management functionality.

disabled The built-in BLE chip of the IAP is turned off. The BLE operation mode is set to Disabled by
default.

dynamic-
console

The built-in BLE chip of the IAP functions in the beaconing mode and dynamically enables
access to IAP console over BLE when the link to LMS is lost.

persistent-
console

The built-in BLE chip of the IAP provides access to the IAP console over BLE and also operates
in the Beaconing mode.

Table 101: BLE Operation Modes

Configuring OpenDNS Credentials on IAPs
Instant Access Points (IAPs) use the OpenDNS credentials to provide enterprise-level content filtering.

To configure OpenDNS credentials:

1. In the Aruba Central On-Premises app, use the filter to select a group or a device.
2. Under Manage, click Devices > Access Points.
3. Click the Config icon. The tabs to configure access points is displayed.
4. Click Show Advanced, and click Services. The Services page is displayed.
5. Click the OpenDNS accordion.
6. Enter the Username and Password.
7. Click Save Settings.

Configuring CALEA Server Support on IAPs
LI allows the Law Enforcement Agencies to perform an authorized electronic surveillance. Depending on
the country of operation, the ISPs are required to support LI in their respective networks.

In the United States, Service Providers are required to ensure LI compliance based on CALEA
specifications.

Aruba Central supports CALEA integration with an Instant Access Point (IAP) in a hierarchical and flat
topology, mesh IAP network, the wired and wireless networks.

Enable this feature only if lawful interception is authorized by a law enforcement agency.

For more information on the communication and traffic flow from an IAP to CALEA server, see Aruba
Instant User Guide.
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To enable an IAP to communicate with the CALEA server, complete the following steps:

n Creating a CALEA Profile
n Creating ACLs for CALEA Server Support

Creating a CALEA Profile
To create a CALEA profile, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group that contains at least one AP.
The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.
3. Click the Config icon. The tabs to configure access points is displayed.
4. Click Show Advanced, and click Services tab. The Services page is displayed.
5. Click the CALEA accordion.

6. Specify the following parameters:
n IP address— Specify the IP address of the CALEA server.
n Encapsulation type— Specify the encapsulation type. The current release of Aruba Central

supports GRE only.
n GRE type— Specify the GRE type.
n MTU— Specify a size for the MTU within the range of 68—1500. After GRE encapsulation, if

packet length exceeds the configured MTU, IP fragmentation occurs. The default MTU size is
1500. fragmentation occurs. The default MTU size is 1500.

7. Click Save Settings.

Creating ACLs for CALEA Server Support
To create an access rule for CALEA, complete the following steps:

1. In the Aruba Central On-Premises app, use the filter to select a group or a device.

2. If you select a group, perform the following steps:
a. Under Manage, click Devices > Access Points.
b. Click the Config icon. The tabs to configure the group is displayed.

3. If you select a device, under Manage, click Devices.
4. Click Show Advanced, and click Security tab. The Security page is displayed.
5. Click the Roles accordion.
6. Under Access Rules for Selected Roles, click + icon. The New Rule window is displayed.
7. Set the Rule Type to CALEA.
8. Click Save.
9. Create a role assignment rule if required.

10. Click Save Settings.

Configuring IAPs for Palo Alto Networks Firewall Integration
Instant Access Points (IAPs) maintains the network (such as mapping IP address) and user information
for its clients in the network. To integrate the IAP network with a third-party network, you can enable an
IAP to provide this information to the third-party servers.
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To integrate an IAP with a third-party network, you must add a global profile. This profile can be
configured on an IAP with information such as IP address, port, user name, password, firewall enabled
or disabled status.

Configuring an IAP for Network Integration
To configure an IAP for network integration:

1. In the Aruba Central On-Premises app, use the filter to select a group or a device.
2. Under Manage, click Devices > Access Points.
3. Click the Config icon. The tabs to configure access points is displayed.
4. Click Show Advanced, and click Services. The Services page is displayed.
5. Click the Network Integration accordion.
6. Select Enable to enable PAN firewall.
7. Specify the Username and Password. Ensure that you provide user credentials of the PAN

firewall administrator.
8. Re-enter the password in Retype.
9. Enter the PAN firewall IP Address.

10. Enter the port number within the range of 1—65535. The default port is 443.
11. Enter the client domain in Client Domain.
12. Click Save Settings.

Enabling Application Visibility on Instant APs
To view application usage metrics for WLAN clients, enable the Application Visibility feature on Instant
APs.

To enable the Application Visibility feature, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select an AP group in the filter:

a. Set the filter to a group containing at least one AP.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

n To select an AP in the filter:
a. Set the filter to Global or a group containing at least one AP.
b. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

c. Click an AP listed under Device Name.

The dashboard context for the AP is displayed.

d. Under Manage, click Devices > Access Point.

2. Click the Config icon.

The tabs to configure the APs are displayed.

3. Click Show Advanced.
4. Click the Services tab.

The Services page is displayed.
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5. Expand the AppRF accordion.
6. Select any of the following options for Deep Packet Inspection:

n All—Performs deep packet inspection on client traffic to application, application categories,
website categories, and websites with a specific reputation score.

n App—Performs deep packet inspection on client traffic to applications and application
categories.

n WebCC—Performs deep packet inspection on client traffic to specific website categories and
websites with specific reputation ratings.

n None—Disables deep packet inspection.

7. Click Save Settings.

Enabling Application Visibility on Campus APs
To enable Application Visibility feature on Campus APs, you must configure DPI classification and
firewall visibility feature on the managed device. The managed devices running ArubaOS 8.x.x.x send
sessions telemetry periodically to the Aruba Central On-Premises management server by using the
AMON protocol.

The following command enables DPI classification on the managed device.

(host) [mynode](config) #firewall dpi

The following command enables policy enforcement firewall visibility feature on the managed device.

(host) [mynode] (config) #firewall-visibility

The following command configures management server profile on the managed device and sends
firewall session messages to the Aruba Central On-Premises management server.

(host) [mynode](config) #mgmt-server profile <name>

(host) [mynode](Mgmt Config profile “<name>”) #sessions-enable

The following command displays whether the sessions are enabled in the default-amp management
server configuration profile.

Ensure that the profile name is same as the profile used for connecting to the Aruba Central On-Premises
management server.

(host) [mynode] (config) #show mgmt-server profile default-ampMgmt Config profile

"default-amp" (Predefined (changed))

--------------------------------------------------------

Parameter Value

--------- -----

Stats Enabled

Stats_Ext Disabled
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Generic_amon Enabled

Tag Enabled

Sessions Enabled

Monitored Info - Add/Update Disabled

You cannot enable the Application Visibility feature on Campus APs using Aruba Central On-Premises WebUI.
You must configure Application Visibility feature using ArubaOS WebUI.

For more information on the WebUI steps and the output displayed for the CLI commands, see the
following documents at the Aruba Support site:

n ArubaOS CLI Reference Guide

n ArubaOS User Guide

Enabling Application Visibility at Client and Site Level
To enable Application Visibility feature at client or site level for Campus APs, the firewall visibility
sessions telemetry must be grouped based on the same BSSID, and sent to Aruba Central On-Premises
server.

The following command enables grouping of firewall visibility sessions telemetry based on the same
BSSID on managed devices.

(host) [mynode] (config) #firewall-visibility feed sort-by-bssid

(host) [mynode] (config) #write memory

The following command displays whether BSSID-based grouping of firewall visibility sessions telemetry
is enabled on the managed devices.

(host) [mynode] #show firewall-visibility status

Firewall Visiblity Status:

enabled

Sort by Bssid Status:

sorting enabled: Enabled

sort by bssid needed: Enabled

https://asp.arubanetworks.com/
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This feature is supported in the following ArubaOS release versions:

n ArubaOS 8.6.0.17

n ArubaOS 8.7.1.9

n ArubaOS 8.10.0.0 and later versions

Enabling AirSlice on APs
Aruba AirSlice, based on IEEE 802.11ax standard, is similar to 5G network slicing architecture which
allows network operators to build virtual networks tailored for specific application requirements.
AirSlice allows network operators to monitor applications used by clients. AirSlice supports multiple
services such as gaming, IoT, voice, video, and so on. AirSlice is available for all clients; however,
802.11ax clients have enhanced benefits due to efficient uplink and downlink traffic scheduling
mechanism.

The AirSlice feature is available for only Advanced access points (APs) licenses. For devices that have
Advanced licenses, the AirSlice feature provides custom-applications prioritization with visibility,
configuration, and supports unlimited applications. For customers with legacy licenses, the Aruba
AirSlice feature is allow listed till the expiry of the legacy licenses.

AirSlice is supported only on 550 Series and 530 Series APs running Aruba InstantOS 8.7.0.0 and later version.
You must enable Deep Packet Inspection before configuring AirSlice.

AirSlice support is available only for the following applications:

n Zoom
n Slack
n Skype
n WebEx
n GoToMeeting Online Meeting
n Microsoft Office 365
n Dropbox
n Amazon Web Services/Cloudfront CDN
n GitHub
n Microsoft Teams
n ALG Wi-fi Calling

To enable AirSlice, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one AP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.
3. Click the Config icon.

The tabs to configure the APs are displayed.

4. Click Show Advanced.
5. Click the Services tab.

The Services page is displayed.
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6. Expand the AppRF accordion.
7. Select App from the Deep Packet Inspection drop-down list.
8. Enable the Application Monitoring toggle switch.
9. Enable the AirSlice Policy toggle switch.

10. Click Save Settings.

Configuring XML API Interface
The XML API interface allows Instant Access Points (IAPs) to communicate with an external server. The
communication between IAP and an external server through XML API Interface includes the following
steps:

n An API command is issued in the XML format from the server to the virtual controller.
n The virtual controller processes the XML request and identifies where the client is and sends the

command to the correct member IAP.
n Once the operation is completed, the virtual controller sends the XML response to the XML server.
n The administrators can use the response and take appropriate action to suit their requirements. The

response from the virtual controller is returned using the predefined formats.

To configure XML API for servers, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to select a group or a device.
2. Under Manage, click Devices > Access Points.
3. Click the Config icon. The tabs to configure access points is displayed
4. Click Show Advanced, and click Services. The Services page is displayed.
5. Go to Network Integration > XML API Server Configuration.
6. Click + to add a new XML API server.
7. Enter a name for the XML API server in the Name text box.
8. Enter the IP address of the XML API server in the IP Address text box.
9. Enter the subnet mask of the XML API server in the Mask text box.

10. Enter a passcode in the Passphrase text box, to enable authorized access to the XML API Server.
11. Re-enter the passcode in the Retype Passphrase box.
12. To add multiple entries, repeat the procedure.
13. Click Add.
14. Click Save Settings.
15. To edit or delete the server entries, use the Edit and Delete buttons, respectively.

For information on adding an XML API request, see Aruba Instant User Guide.

Client Match
Client Match is an Aruba Central service which helps to improve the experience of wireless clients. Client
match identifies wireless clients that are not getting the required level of service at the AP to which they
are currently associated and intelligently steers them to an access point (AP) radio that can provide
better service and thereby improves user experience.

Steer Types
Client match periodically checks the health of current association of the clients and determines if a
sticky steer or band steer should be considered.



Managing APs | 481

Sticky Steer
Sticky clients tend to stay associated to an AP despite deteriorating signal levels. Client match
continuously monitors the RSSI of sticky clients while they are associated to an AP, and if needed, move
them to a radio that would offer better experience. This prevents clients from remaining associated to
an AP with less than ideal RSSI, which can cause poor connectivity and reduce performance for other
clients associated with that AP.

Band Steer
Dual-band clients can associate with a 2.4 GHz radio or 5 GHz radio. In band steer, client match moves
dual-band clients from the 2.4 GHz radio to the 5 GHz radio of the same AP.

Steering Methods
After determining the steer type, client match determines the best neighbor radio to steer the client to
and orchestrates the client steer by sending action messages to the APs to carry out the steer. The way
client match steers the clients depends on whether the clients are 802.11v-capable.

Steering for 802.11v-capable Client
To steer 802.11v-capable clients, client match triggers the AP to send out an 802.11v BSS transition
management request to the client and waits for a response.

Steering for Non-802.11v-capable Client
To steer non-802.11v-capable clients, client match triggers all neighboring AP radios (except the
intended destination) to block the client from associating for 5 seconds. 2 seconds after that, the AP to
which the client is currently associated sends an 802.11 deauthentication management frame to the
client. When the client tries to re-associate, only the intended AP radio allows the client to associate with
it.

Monitoring Client Match in Aruba Central
To view client match events in Aruba Central:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Analyze, click Alerts & Events > Events.
3. Click Click here for advanced filtering.
4. Select Client Match Steer.
5. Click Filter.
6. Hover over the required event.

Configuring RRM IE Profile
Aruba Central On-Premises supports the Radio Resource Management Information Element (RRM IE)
profiles advertised by the AP. The RRM IE signal support is for the radio measurements in a device. The
clients use this IE to specify their radio measurement capabilities. The RRM IE profiles are available only
for 6 GHz radio profiles. You can assign the RRM IE profiles to the radio profiles on the Radios > RF >
Radio WebUI page. For more information, see Configuring Radio Parameters.

The RRM IE profiles are available only for 6 GHz radio profiles.

To configure RRM IE profiles, complete the following steps:
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1. In the Aruba Central On-Premises app, use the filter to select a group or a device.
2. Under Manage, click Devices > Access Points.
3. Click the Config icon.

The tabs to configure access points are displayed.
4. Click Show Advanced, and click Services.

The Services page is displayed.
5. Click RRM IE Profile accordion.

The RRM IE profile table is displayed.

6. Click + on the RRM IE profile table.

The RRM IE profile configuration window is displayed.

7. Configure the following parameters:
a. Name—Enter the name for the RRM IE profile.
b. Country—When enabled, the AP will advertise in beacon and probe responses the device's

regulatory domain.
c. Enabled Capabilities—When enabled, the AP will advertise in beacon and probe responses

support for radio measurements in a device.

8. Click OK.
9. Click Save Settings.

n To edit the RRM IE profile, select a profile from the RRM IE Profile table and click the edit icon.
n To delete the RRM IE profile, select a profile from the RRM IE Profile table and click the delete icon.

Configuring Uplink Interfaces on IAPs
This section provides the following information:

n Uplink Interfaces

n Uplink Preferences and Switching

Uplink Interfaces
Aruba Central On-Premises supports 3G/4G USB modems, ethernet, and the Wi-Fi uplink to provide
access to the corporate network.

By default, the AP-318, AP-374, AP-375, and AP-377 access points (APs) have Eth1 as the uplink port and Eth0 as
the downlink port. Aruba recommends you not to upgrade the mentioned access points to 8.5.0.0 and 8.5.0.1
firmware versions as the upgrade process changes the uplink from Eth1 to Eth0 port thereby making the
devices non-reachable.

The following types of uplinks are supported on Aruba Central:

n Uplink Interfaces
n Uplink Interfaces
n Uplink Interfaces
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LTE (4G) Uplink
Aruba Central On-Premises supports the use of LTE (4G) USB modems to provide the Internet back haul
to Aruba Central On-Premises. The LTE (4G) USB modems can be used to extend client connectivity to
places where an Ethernet uplink cannot be configured. This enables the IAPs to automatically choose
the available network in a specific region.

For more information about the supported interoperability devices, select 4G Modem from the
Product Category drop-down to see the list of supported 4G modems on
https://www.arubanetworks.com/support-services/interoperability/.

Configuring Cellular Uplink Profiles

To configure 3G or 4G uplinks using Aruba Central, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one AP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the APs are displayed.

4. Click Show Advanced.
5. Click the Interfaces tab.

The Interfaces page is displayed.

6. Click the Uplink accordion.
7. Under 3G/4G, perform any of the following steps:

n To configure a 3G or 4G uplink automatically, select the Country and ISP. The parameters are
automatically populated.

n To configure a 3G or 4G uplink manually, perform the following steps:
o Select the country from the Country drop-down list.
o Select the service protocol from the ISP drop-down list.
o Enter the type of the 3G/4G modem driver type:

n For 3G—Enter the type of 3G modem in the USB Type text box.
n For 4G—Enter the type of 4G modem in the 4G USB Type text box. Enter the following details:

o USB DEV—Enter the device ID of modem.
o USB TTY—Enter the TTY port of the modem.
o USB INIT—Enter the parameter to initialize the modem.
o USB Dial—Enter the parameter to dial the cell tower.
o USB Mode Switch—Enter the parameter used to switch a modem from the storage mode

to modem mode.
o USB Auth Type—Select the USB authentication type from the drop-down list.
o USB User—Enter the username used to dial the ISP.
o USB Password—Enter the password used to dial the ISP.

8. Click Save Settings.
9. Reboot the IAP for changes to affect.

https://www.arubanetworks.com/support-services/interoperability/
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Ethernet Uplink
The Ethernet 0 port on an IAP is enabled as an uplink port by default. The Ethernet uplink supports the
following:

n PPPoE
n DHCP
n Static IP

You can use PPPoE for your uplink connectivity in a single AP deployment.

Uplink redundancy with the PPPoE link is not supported.

When the Ethernet link is up, it is used as a PPPoE or DHCP uplink. After the PPPoE settings are
configured, PPPoE has the highest priority for the uplink connections. The IAP can establish a PPPoE
session with a PPPoE server at the ISP and get authenticated using PAP or the CHAP. Depending upon
the request from the PPPoE server, either the PAP or the CHAP credentials are used for authentication.
After configuring PPPoE, reboot the IAP for the configuration to take effect. The PPPoE connection is
dialed after the AP comes up. The PPPoE configuration is checked during IAP boot and if the
configuration is correct, Ethernet is used for the uplink connection.

When PPPoE is used, do not configure Dynamic RADIUS Proxy and IP address of the VC. An SSID created with
default VLAN is not supported with PPPoE uplink

You can also configure an alternate Ethernet uplink to enable uplink failover when an Ethernet port fails.

Configuring PPPoE Uplink Profile

To configure PPPoE settings, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one AP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the APs are displayed.

4. Click Show Advanced.
5. Click the Interfaces tab.

The Interfaces page is displayed.

6. Click the Uplink accordion.

7. Under PPPoE, configure the following parameters:
n Enter the PPPoE service name provided by your service provider in the Service Name.
n In the CHAP Secret and Retype CHAP Secret fields, enter the secret key used for CHAP

authentication. You can use a maximum of 34 characters for the CHAP secret key.
n To set a local interface for the PPPoE uplink connections, select a value from Local Interface.

The selected DHCP scope is used as a local interface on the PPPoE interface and the Local, L3
DHCP gateway IP address as its local IP address. When configured, the local interface acts as
an unnumbered PPPoE interface and allocated the entire Local, L3 DHCP subnet to the clients.
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n Enter the user name for the PPPoE connection in the User field.
n In the Password and Retype Password fields, enter a password for the PPPoE connection and

confirm it.

The options in Local Interface are displayed only if a Local, L3 DHCP scope is configured on the IAP.

8. Click Save Settings.
9. Reboot the IAP.

Wi-Fi Uplink
The Wi-Fi uplink is supported for all IAP models, except 802.11ac APs. Only the conductor IAP uses the
Wi-Fi uplink. The Wi-Fi allows uplink to open, PSK-CCMP, and PSK-TKIP SSIDs.

Important Points

n For single radio IAPs, the radio serves wireless clients and Wi-Fi uplink.
n For dual radio IAPs, both radios can be used to serve clients but only one of them can be used for Wi-

Fi uplink.

When Wi-Fi uplink is in use, the client IP is assigned by the internal DHCP server.

Configuring a Wi-Fi Uplink Profile

The following configuration conditions apply to the Wi-Fi uplink:

n To bind or unbind the Wi-Fi uplink on the 5 GHz band, reboot the IAP.
n If Wi-Fi uplink is used on the 5 GHz band, mesh is disabled. The two links are mutually exclusive.

To provision an IAP with Wi-Fi Uplink, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one AP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the APs are displayed.

4. Click Show Advanced.
5. Click the Interfaces tab.

The Interfaces page is displayed.

6. Click the Uplink accordion.
7. Under Wi-Fi, enter the name of the wireless network that is used for Wi-Fi uplink in the Name

(SSID) box.
8. From Band, select the band in which the VC currently operates. The following options are

available:
n 2.4 GHz (default)
n 5 GHz
n 6 GHz



Aruba Central On-Premises 2.5.7 | User Guide 486

9. From Key Management drop-down list, select the type of key for uplink encryption and
authentication.
n When WPA Personal, WPA-2 Personal, or WPA3 Personal key management type is selected,

the passphrase options are available for configuration.
o Select a passphrase format from the Passphrase Format drop-down list.

The following passphrase options are available:
l 8 - 63 alphanumeric characters
l 64 hexadecimal characters

Ensure that the hexadecimal password string is exactly 64 digits in length.

o Enter a PSK passphrase in Passphrase text box.
n When WPA Enterprise or WPA-2 Enterprise key management type is selected, the 802.1x

authentication options are available for configuration.
o From the WiFi1X drop-down list, select 802.1x authentication protocol to be used:

l Specify the certificate type to be used by selecting Cert TPM or Cert User.
l If PEAP authentication type is selected, enter the user credentials in the Username and
Password text box.

o Toggle the Validate Server button to enable or disable server certificate verification by the
AP.

10. Click Save Settings and reboot the IAP.

If the uplink wireless router uses mixed encryption, WPA-2 Personal or WPA-2 Enterprise is recommended for
Wi-Fi uplink.

Uplink Preferences and Switching
This section describes the following topics:

n Enforcing Uplinks
n Setting an Uplink Priority
n Enabling Uplink Pre-emption

Enforcing Uplinks
The following conditions apply to the uplink enforcement:

n When an uplink is enforced, the Instant Access Points (IAP) uses the specified uplink regardless of
uplink pre-emption configuration and the current uplink status.

n When an uplink is enforced and multiple Ethernet ports are configured and uplink is enabled on the
wired profiles, the IAP tries to find an alternate Ethernet link based on the priority configured.

n When no uplink is enforced and pre-emption is not enabled, and if the current uplink fails, the IAP
tries to find an available uplink based on the priority configured.

n When no uplink is enforced and pre-emption is enabled, and if the current uplink fails, the IAP tries to
find an available uplink based on the priority configured. If current uplink is active, the IAP
periodically tries to use a higher priority uplink and switches to the higher priority uplink even if the
current uplink is active.

To enforce a specific uplink on an IAP, complete the following steps:
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1. In the Aruba Central On-Premises app, set the filter to a group containing at least one AP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the APs are displayed.

4. Click Show Advanced.
5. Click the Interfaces tab.

The Interfaces page is displayed.

6. Expand the Uplink accordion.
7. Under Management > Enforce Uplink, select the type of uplink from the drop-down list.

If Ethernet uplink is selected, the Port field is displayed.
8. Specify the Ethernet interface port number.
9. Click Save Settings.

The selected uplink is enforced on the IAP.

Setting an Uplink Priority
To set an uplink priority, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one AP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the APs are displayed.

4. Click Show Advanced.
5. Click the Interfaces tab.

The Interfaces page is displayed.

6. Click the Uplink accordion.
7. Under Management > Uplink Priority List, move the uplink up or down to increase or decrease

the priority. By default, the Eth0 uplink is set as a high priority uplink.
8. Click Save Settings.

The selected uplink is prioritized over other uplinks.

Enabling Uplink Pre-emption
The following configuration conditions apply to uplink pre-emption:

n Pre-emption can be enabled only when no uplink is enforced.
n When pre-emption is disabled and the current uplink fails, the IAP tries to find an available uplink

based on the uplink priority configuration.
n When pre-emption is enabled and if the current uplink is active, the IAP periodically tries to use a

higher priority uplink, and switches to a higher priority uplink even if the current uplink is active.

To enable uplink pre-emption, complete the following steps:
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1. In the Aruba Central On-Premises app, set the filter to a group containing at least one AP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the APs are displayed.

4. Click Show Advanced.
5. Click the Interfaces tab.

The Interfaces page is displayed.

6. Click the Uplink accordion.
7. Under Management, ensure that the Enforce Uplink is set to None.
8. Select the Pre-emption check-box.
9. Specify value for Pre-emption Interval.

10. Click Save Settings.

Switching Uplinks based on the Internet Availability
You can configure Aruba Central to switch uplinks based on the Internet availability.

When the uplink switchover based on Internet availability is enabled, the IAP continuously sends ICMP
packets to some well-known Internet servers. If the request is timed out due to a bad uplink connection
or uplink interface failure, and the Internet is not reachable from the current uplink, the IAP switches to
a different connection.

To configure uplink switching, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one AP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the APs are displayed.

4. Click Show Advanced.
5. Click the Interfaces tab.

The Interfaces page is displayed.

6. Click the Uplink accordion.
7. Under Management, specify a value for Failover Internet IP.
8. Select the Internet Failover check-box.
9. Specify values for Failover Internet Packet Send Frequency, Failover Internet Packet Lost

Count, and Internet Check Timeout.
10. Click Save Settings.
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n By default, the conductor AP sends the ICMP packets to 8.8.8.8 IP address only if the out-of-service
operation based on Internet availability (internet-down state) is configured on the SSID. You can use
Failover Internet IP as an alternative to the default option to configure an IP address to which the AP
must send AP packets, and verify if the Internet is reachable when the uplink is down.

n When Internet Failover is enabled, the IAP ignores the VPN status, although uplink switching based on
VPN status is enabled.

Configuring Preferred Uplink on AP-318 and 370 Series APs
The AP-318 and 370 Series APs have an ethernet port for Eth0 and a fibreport for Eth1. Either of these
ports can be configured as the uplink port as required. By default, Eth1 port is configured as the uplink
for these AP platforms. All functionality of the Eth0 port is supported by Eth1 port with exception to the
following:

n Eth0 bridging feature is not supported when the Eth1 port is configured as preferred uplink.
n If LACP is enabled, the Eth1 port cannot be configured as the preferred uplink.

By default, the AP-318, AP-374, AP-375, and AP-377IAPs have Eth1 as the uplink port and Eth0 as the downlink
port. Aruba recommends you not to upgrade the mentioned access points to 8.5.0.0 and 8.5.0.1 firmware
versions as the upgrade process changes the uplink from Eth1 to Eth0 port thereby making the devices non-
reachable

Configuring Enterprise Domains
In a typical Instant Access Point (IAP) deployment without tunneling, all DNS requests from a client are
forwarded to the client’s DNS server by default. However, if an IAP is configured for tunneling, the IAP-
VPN enables split DNS by default, and the DNS behavior for both the clients on the IAP network is
determined by the enterprise domain settings.

The enterprise domain setting on the IAP specifies the domains for which DNS resolution must be
forwarded to the default DNS server of the client. For example, if the enterprise domain is configured
for arubanetworks.com, the DNS resolution for host names in the arubanetworks.com domain is
forwarded to the default DNS server of the client. The DNS resolution for host names in all other
domains is forwarded to the local DNS server of the IAP.

In a full-tunnel mode, all DNS traffic is forwarded over IPSec tunnel to DNS server of the client regardless of the
enterprise domain configuration. If an asterisk is configured in the enterprise domain list instead of a domain
name, then all DNS requests are forwarded to the default DNS server of the client. Split DNS functionality is
supported for IAP-VPN scenarios only.

To configure an enterprise domain, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one AP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the APs are displayed.
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4. Click Show Advanced.
5. Click the System tab.

The System page is displayed.

6. Click the Enterprise Domains accordion.
7. Click + in the Enterprise Domains pane, and enter a name in the New Domain Name window.
8. Click OK.
9. Click Save Settings.

To delete an enterprise domain, select the domain in the Enterprise Domains pane, and then click the
delete icon.

Configuring SNMP Parameters
This section describes the following topics:

n Configuring SNMP Parameters on page 490
n Configuring Community String for SNMP on page 491
n Configuring SNMP Trap Receivers on page 492

SNMP Configuration Parameters
Aruba Central On-Premises supports SNMPv1, SNMPv2c, and SNMPv3 for reporting purposes only. An
Instant Access Point (IAP) cannot use SNMP to set values in an Aruba system.

The following table lists the SNMP configuration parameters for an IAP.

Data Pane Item Description

Community
Strings for
SNMPV1 and
SNMPV2

An SNMP Community string is a text string that acts as a password, and is used to
authenticate messages sent between the virtual controller and the SNMP agent.

If you are using SNMPv3 to obtain values from the IAP, you can configure the following parameters.

Name A string representing the name of the user.

Authentication
Protocol

An indication of whether messages sent on behalf of this user can be authenticated, and if
so, the type of authentication protocol used. This can take one of the two values:
n MD5—HMAC-MD5-96 Digest Authentication Protocol
n SHA—HMAC-SHA-96 Digest Authentication Protocol

Authentication
protocol
password

If messages sent on behalf of this user can be authenticated, the (private) authentication
key for use with the authentication protocol. This is a string password for MD5 or SHA
depending on the choice above.

Privacy protocol An indication of whether messages sent on behalf of this user can be protected from
disclosure, and if so, the type of privacy protocol which is used. This takes the value DES
(CBC-DES Symmetric Encryption).

Privacy protocol
password

If messages sent on behalf of this user can be encrypted/decrypted with DES, the (private)
privacy key for use with the privacy protocol.

Table 102: SNMP Parameters
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Configuring Community String for SNMP
This section describes the procedure for configuring SNMPv1, SNMPv2, and SNMPv3 community strings
in Aruba Central.

Creating Community strings for SNMPv1 and SNMPv2 using Aruba Central
To create community strings for SNMPv1 and SNMPv2, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one AP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the APs are displayed.

4. Click Show Advanced.
5. Click the System tab.

The System page is displayed.

6. Click the SNMP accordion.
7. Under SNMP, click + to add a new community string.
8. In the New SNMP window, enter a name for the community string.
9. Click OK.

10. Click Save Settings.

To delete a community string, select the string in the SNMP pane, and then click the delete icon.

Creating community strings for SNMPv3 using Aruba Central
To create community strings for SNMPv3, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one AP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the APs are displayed.

4. Click Show Advanced.
5. Click the System tab.

The System page is displayed.

6. Click the SNMP accordion.
7. Under User for SNMPV3, click + to add a new community string for SNMPv3.
8. In the New SNMPv3 User window, enter the following information: 

n In the Name field, enter the name for the SNMPv3 user.
n In the Auth protocol drop-down list, select the type of authentication protocol.
n In the Password text-box, enter the authentication password and retype the password in the

Retype Password text-box.
n In the Privacy protocol drop-down list, select the type of privacy protocol.
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n In the Password text-box, enter the privacy protocol password and retype the password in the
Retype Password text box.

n Click OK.

9. Click Save Settings.

To edit the details for a particular user, select the user, and then click the edit icon.

To delete a particular user, select the user, and then click the delete icon.

Configuring SNMP Trap Receivers
Aruba Central On-Premises supports the configuration of external trap receivers. Only the Instant AP
acting as the VC generates traps. The OID of the traps is 1.3.6.1.4.1.14823.2.3.3.1.200.2.X.

To configure SNMP traps, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one AP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the APs are displayed.

4. Click Show Advanced.
5. Click the System tab.

The System page is displayed.

6. Click the SNMP accordion.
7. Under SNMP Traps Receivers, click + to add a new community string for SNMP Traps

Receivers.
8. In the New SNMP Trap Receiver window, enter the following information:

n In the IP Address text-box, enter the IP address of the new SNMP Trap Receiver.
n In the Version drop-down list, select the SNMP version, such as v1, v2c, v3. The version

specifies the format of traps generated by the access point.
n In the Community/Username text-box, specify the community string for SNMPv1 and

SNMPv2c traps and a username for SNMPv3 traps.
n In the Port text-box, enter the port to which the traps are sent. The default value is 162.
n In the Inform drop-down list, select Yes or No. When enabled, traps are sent as SNMP

INFORM messages. It is applicable to SNMPv3 only. The default value is Yes.
n Click OK.

9. Click Save Settings.

Configuring Syslog and TFTP Servers for Logging Events
This section describes the following topics:

n Configuring Syslog and TFTP Servers for Logging Events
n Configuring Syslog and TFTP Servers for Logging Events

Configuring Syslog Server on IAPs
To specify a syslog server for sending syslog messages to the external servers, complete the following
steps:
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1. In the Aruba Central On-Premises app, set the filter to a group containing at least one AP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the APs are displayed.

4. Click Show Advanced.
5. Click the System tab.

The System page is displayed.

6. Click the Logging accordion.
7. In the Servers section, enter the IP address of the syslog server in the Syslog Server text-box.

8. Click Syslog Facility Levels, and enter the required logging level from the drop-down in each of
the fields.

Syslog facility is an information field associated with a syslog message. It is an application or
operating system component that generates a log message. The IAP supports the following
syslog facilities:
n Syslog Level—Detailed log about syslog levels.
n AP-Debug—Detailed log about the AP device.
n Network—Log about change of network, for example, when a new IAP is added to a network.
n Security—Log about network security, for example, when a client connects using wrong

password.
n System—Log about configuration and system status.
n User—Important logs about client.
n User-Debug—Detailed log about client.

n Wireless—Log about radio.

9. Click Save Settings.

The following table describes the logging levels in order of severity, from the most severe to the least.

Logging level Description

Emergency Panic conditions that occur when the system becomes unusable.

Alert Any condition requiring immediate attention and correction.

Critical Any critical condition such as a hard drive error.

Error Error conditions.

Warning Warning messages.

Notice Significant events of a non-critical nature. The default value for all syslog facilities.

Information Messages of general interest to system users.

Debug Messages containing information useful for debugging.

Table 103: Logging Levels
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Configuring TFTP Dump Server IAPs
To configure a TFTP server for storing core dump files, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one AP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the APs are displayed.

4. Click Show Advanced.
5. Click the System tab.

The System page is displayed.

6. Click the Logging accordion.
7. In the Servers section, enter the IP address of the TFTP server in the TFTP Dump Server text-box.
8. Click Save Settings.

Mobility and Client Management
This section provides the following information on Layer-3 Mobility for Instant Access Points (IAPs)
clients:

n Layer-3 Mobility on page 494
n Configuring L3 Mobility Domain on page 494

Layer-3 Mobility
IAPs form a single Aruba Central On-Premises network when they are in the same Layer-2 (L2) domain.
As the number of clients increase, multiple subnets are required to avoid broadcast overhead. In such a
scenario, a client must be allowed to roam away from the Aruba Central On-Premises network to which
it first connected (home network) to another network supporting the same WLAN access parameters
(foreign network) and continue its existing sessions.

Layer-3 (L3) mobility allows a client to roam without losing its IP address and sessions. If WLAN access
parameters are the same across these networks, clients connected to IAPs in a given Aruba Central On-
Premises network can roam to IAPs in a foreign Aruba Central On-Premises network and continue their
existing sessions using their IP addresses. You can configure a list of Virtual Controller IP addresses
across which L3 mobility is supported.

Home Agent Load Balancing
Home Agent Load Balancing is required in large networks where multiple tunnels might terminate on a
single border or lobby AP and overload it. When load balancing is enabled, the VC assigns the home AP
for roamed clients by using a round robin policy. With this policy, the load for the APs acting as Home
Agents for roamed clients is uniformly distributed across the IAP cluster.

Configuring L3 Mobility Domain
To configure a mobility domain, you have to specify the list of all Aruba Central On-Premises networks
that form the mobility domain. To allow clients to roam seamlessly among all the APs, specify the VC IP
for each foreign subnet. You may include the local Aruba Central On-Premises or VC IP address, so that
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the same configuration can be used across all Aruba Central On-Premises networks in the mobility
domain.

Aruba recommends that you configure all client subnets in the mobility domain. When client subnets
are configured:

n If a client is from a local subnet, it is identified as a local client. When a local client starts using the IP
address, the L3 roaming is terminated.

n If the client is from a foreign subnet, it is identified as a foreign client. When a foreign client starts
using the IP address, the L3 roaming is set up.

n To configure a Layer-3 Mobility domain, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one AP.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click the Config icon.

The tabs to configure the APs are displayed.

4. Click Show Advanced.
5. Click the System tab.

The System page is displayed.

6. Click the Layer-3 Mobility accordion.
7. Turn on the Home Agent Load Balancing toggle switch. By default, home agent load balancing

is disabled.
8. Under IP Address, click +, and enter an IP address name in the New IP Address window, and

then click OK.

Repeat Step 8 to add the IP addresses of all VCs that form the L3 mobility domain.

9. Under Subnets, click +, and specify the following:
n Enter the client subnet in the IP Address box.
n Enter the mask in the Subnet Mask box.
n Enter the VLAN ID in the home network in the VLAN ID box.
n Enter the home VC IP address for this subnet in the Virtual Controller IP box.

10. Click OK.

Renaming an AP
You can change the name of an access point (AP) provisioned in Aruba Central. The AP can be online or
offline. When you rename an AP or a VC, the AP or VC does not reboot, and the client traffic is not
affected. The new name must be a character string of upto 32 ASCII or non-ASCII characters, including
spaces.

To rename an AP, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:

To select a group in the filter:

a. Set the filter to one of the options under Groups. Ensure that the filter selected contains at
least one active access point.
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The dashboard context for the group is displayed.

b. Under Manage, click Devices > Access Points.

A list of access points is displayed in the List view.

To select an access point in the filter:
a. Set the filter to Global.
b. Under Manage, click Devices > Access Points.

A list of access points is displayed in the List view.

c. Click an access point listed under Device Name.

The dashboard context for the access point is displayed.
d. Under Manage, click Device > Access Point.

2. Click the Config icon.

The tabs to configure access points are displayed.

3. Click the Access Points tab.

The Access Points table is displayed.

4. To edit an AP, select an AP in the Access Points table, and then click the edit icon.
5. Under Basic Info, modify the AP or VC name in the Name field.
6. Click Save Settings.

The AP name is updated on the AP immediately. It may take up to 1 minute for the new AP name to get
reflected in Aruba Central On-Premises.

Renaming an AP depends on various privileges and access permissions that are assigned to each user to make
configuration changes.

Monitoring Access Points
The access point (AP) dashboard enables you to manage, configure, monitor and troubleshoot APs
provisioned and managed through Aruba Central On-Premises.

For a list of all the available menu items in the AP dashboard, see The Access Point Dashboard.

The AP Health Bar provides a snapshot of the overall health of the APs configured in Aruba Central On-
Premises. For more information, see Health Bar Dashboard for Access Point.

The AP Foundation license is applicable for Access Point Monitoring.

Monitoring Access Points in Summary View
The access point (AP) Summary page provides all the metrics about the health, status, and clients
information associated with the AP provisioned and managed in Aruba Central On-Premises.

To navigate to the AP Summary page, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global. Ensure that the filter selected contains at
least one active AP.

The dashboard context for the selected filter is displayed.
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2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click the Summary icon.

The AP Summary page is displayed.

The AP Summary page displays the following information:

n Access Points—Displays the overall usage metrics for the APs provisioned in your Aruba Central On-
Premises account. Consists of the following tabs:
o Usage—Displays the incoming and outgoing data traffic detected on the APs.
o Total Clients—Displays the number of clients connected to an AP over a specific time period.
o Bandwidth Usage Per Network—Displays the incoming and outgoing traffic for all APs per SSID

over a specific duration.
o Client Count Per Network—Displays the number of clients connected to an AP per SSID over a

specific time period.

You can change the time range for the AP Summary page by clicking the time range filter and
selecting one of the available options: 3 hours, 1 day, 1 week, 1 month, and 3 months.

Monitoring Access Points in List View
The access point (AP) List view page provides information associated with the online and offline APs,
radios provisioned, and managed in Aruba Central On-Premises.

To navigate to the AP List view page, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups, Labels,
or Sites. For all devices, set the filter to Global. Ensure that the filter selected contains at least one
active AP.

The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

The AP List view page displays the following information:

n Access Points—Displays the total number of APs. When you click the Access Points tab, it provides
information about all APs in the Access Points table. For more information, see Access Points Table.

n Online—Displays the total number of online APs. When you click the Online tab, it provides
information about the online APs in the Access Points table.

n Offline—Displays the total number of offline APs. When you click the Offline tab, it provides
information about the offline APs in the Access Points table.

n Radios—Displays the total number of radios. When you click the Radios tab, it provides information
about all radios in the Radios table.
o 2.4 GHz—Displays the total number of 2.4 GHz radios. When you click the 2.4 GHz tab, it provides

information about 2.4 GHz radios in the Radios table.
o 5 GHz—Displays the total number of active 5 GHz and 5 GHz (Secondary) radios. When you click

the 5 GHz tab, it provides information about 5 GHz and 5 GHz (Secondary) radios in the Radios
table.
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o 6 GHz—Displays the total number of 6 GHz radios. When you click the 6 GHz tab, it provides
information about 6 GHz radios in the Radios table.

n The tri-radio feature is available only for AP-555. In the 5 GHz tab, the Radio 5 GHz (Secondary) data
is available only if the tri-radio mode is enabled. For more information, see About Tri-Radio Mode.

n The 6 GHz radios is only supported for devices with 6 GHz capability. For more information about the
APs that supports 6 GHz, see Supported APs.

Access Points Table
In the Access Points table, you can view and perform the following:

Figure 58 Access Points Table Parameter Descriptions

Parameter Description

Device Name Displays the name of the AP.

Status Displays the operational status of the AP. The status is as follows:

n Online—Indicates that the AP is online.

n Offline—Indicates that the AP is offline.

n Online—Indicates that the AP is operating under thermal management. For more
information, see Thermal Shutdown Support in Instant Access Points.

IP Address Displays the IP address of the AP.

Model Displays the model number of the AP.

Serial Displays the serial number of the device.

Firmware
Version

Displays the firmware version running on the AP.

Clients Displays the clients connected to the AP.

Alerts Displays the opens alerts related to APs.

MAC Address Displays the MAC address of the AP.

Controller Displays the name of the controller.

Secondary
Controller

Displays the name of the secondary controller.

Config Status Displays the configuration changes associated with the AP. The Config Status column is not
supported in the exported CSV file.

Group Displays the group to which the AP belongs.

Labels Displays the labels associated with the AP. If multiple labels are associated with the AP, hover
over the label link to view all the labels.
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Parameter Description

Site Displays the site to which the device belongs.

Uptime Displays the time since when the device is operational. The Uptime column is not applicable
for offline devices and remains blank for all the devices in the Offline page.

Last Seen Displays the last active time and date of the device. The Last Seen column is not applicable
for online devices and remains blank for all the devices in the Online page.

Public IP Displays the IP address logged by servers when the device is connected through internet
connection.

Persona Displays the type of role of the AP. For example, Campus AP and IAP.

LLDP
Neighbor

Displays the name of the LLDP neighbor. Click the LLDP Neighbor name to view the switch
details page, if the switch is managed by Aruba Central On-Premises.

LLDP Port Displays the port number of LLDP neighbor.

AI Insights Displays the number of insights generated for the AP in the last three hours. The AI Insights
column is not supported in the exported CSV file.

Note Displays the information captured in the Note parameter, in the AP Details section. The
search filter allows you to search for exact and partial text search with prefix. The text search
with suffix is not supported.

Zone Displays the zone to which the AP belongs. Zone details are displayed in the column only for
APs with firmware version ArubaOS 8.7.0.0 or later.

Controller AP
Group

Displays the name of the Controller AP group.

Click the icon to delete an offline AP. For more information, see Deleting an Offline AP.

Click the icon to reboot an AP. For more information, see Rebooting an Access Point in the List
View.

Click the icon to download the .csv file of the AP list table. For more information, see
Downloading the AP List View Table .
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n From Aruba Central On-Premises 2.5.4 release, LLDP Neighbor and LLDP Port details are also available
for Campus APs, Remote APs and not only Instant APs.

n A search filter is provided only for the Device Name, IP Address, Model, Serial, MAC Address,
Controller, Secondary Controller, Group, Labels, Site, LLDP Neighbor, Note, and Zone columns. The

and icons allow you to sort the Device Name, IP Address, Serial, MAC Address, Controller,
Secondary Controller, and Zone columns in an ascending and descending order.

n By default, the AP List table displays the Device Name, Status, IP Address, Model, Serial, and Firmware
Version. You can customize the view of AP List table with additional columns such as the Clients, Alerts,
MAC Address, Controller, Secondary Controller, Config Status, Group, Labels, Site, Uptime, Last
Seen, Public IP, Persona, LLDP Neighbor, LLDP Port, AI Insights, Note, and Zone. These additional
columns can be selected by clicking the icon provided at the right corner of the table that displays the AP
list. Click the Reset to default button provided in the drop-down list to reset the AP List with default
columns only. To autofit the columns, click the icon and select Autofit columns.

Downloading the AP List View Table

To download the .csv file of the AP list table, click the icon. If the table contains unicode value, you
must use a UTF-8 enabled software to view the contents. To view the file in Microsoft Excel spreadsheet
software, perform the following steps to view table with unicode values:

1. Open the Microsoft Excel software.
2. Click on the Data menu bar option.
3. Click on the From Text icon.
4. Browse to the location of the file that you want to import.
5. Select the file name and click Import.
6. The Text Import wizard is displayed.
7. Select the file type. For .csv format, select the Delimited option.
8. Select the 65001: Unicode (UTF-8)option from the drop-down list that is displayed next to the

File origin.
9. Click Next. The Text ImportWizard-Step 1 of 3 page is displayed.

10. Place a check mark next to the delimiter such as the comma or full stop that was used in the file
you wish to import into Microsoft Excel.

11. The Data Preview window displays the data based on the selected delimiter.

12. Click Next. The Text ImportWizard-Step 3 of 3 page is displayed. Select the appropriate data
format for each column that you want to import.

Importing one or more columns is optional.

13. Click Finish to import the data into Microsoft Excel.



Managing APs | 501

Radios Table
When you click the Radios, 2.4 GHz, 5 GHz, and 6 GHz tab on the Radios list page, the respective
tables with the following columns are displayed:

Figure 59 Radios Table Parameter Descriptions

Parameter Description

Device Name Displays the name of the AP.

NOTE: The online radios are displayed with a green dot and offline radios are displayed
with a red dot.

Radio MAC
Address

Displays the MAC address of the radios connected to the AP.

Band Displays the type of radio band. For example, 2.4 GHz, 5 GHz, and 5 GHz (Secondary), and 6
GHz.

NOTE: The tri-radio feature is available only for AP-555. In the Band column, the Radio 5 GHz
(Secondary) data is available only if the tri-radio mode is enabled. For more information, see
About Tri-Radio Mode.

NOTE: The 6 GHz radios is only supported for devices with 6 GHz capability. For more
information about the APs that supports 6 GHz, see Supported APs.

Bandwidth Displays the bandwidth of data transferred through the radios.

Channel Displays the channels assigned for the radios.

Utilization (%) Displays the percentage of time (normalized to 255) that the channels of the radios are
sensed to be busy. The AP uses either the physical or the virtual carrier sense mechanism to
sense a busy channel. This percentage not only depends on the data bits transferred but also
with the transmission overhead that makes use of the channel.

Power (dBm) Displays the transmit power of the radios measured in decibels.

Noise Floor
(dBm)

Displays the The noise at the radio receivers of the radios. Along with the thermal noise,
Noise Floor may be affected by certain types of interference sources, though not all
interference types result in increased noise floor. Noise Floor value may vary depending on
the noise introduced by components used in the computer or client device.

n A search filter is provided only for the Access Point column.
n If the Radios list has at least one IAP, Campus AP, or Remote AP that supports the 6 GHz radio band, then

the 6 GHz tab will be available on the Radios list page.

Deleting an Offline AP
To delete an offline access point (AP), complete the following steps:
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1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global. Ensure that the filter selected contains at
least one active AP.

The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. In the Access Points table, hover over the offline AP that you want to delete.

4. Click the delete icon.

To delete multiple offline APs, select the offline APs that you want to delete and click the delete
icon.

5. Click Delete in the confirmation dialog box.

Rebooting an Access Point in the List View
You can reboot an Instant Access Point, Campus Access Point, or Remote Access Point using the Aruba
Central On-Premises UI.

To reboot an access point (AP) from the List view page, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under groups, labels,
or sites. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.

n You can reboot only the APs that are in the online status (active).
n A WebSocket connection is required to reboot IAPs, Campus APs, and Remote APs.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. In the Access Points table, hover over the AP that you want to reboot.

4. Click the reboot icon.

To reboot multiple online APs, select the APs that are in online status and click the reboot icon.

5. Click Reboot in the confirmation dialog box.

You can also reboot an AP from the Details page, see Rebooting an AP in the Details Page.

Thermal Shutdown Support in Instant Access Points
Aruba AP-555 and AP-535 Instant Access Point (IAP) devices are equipped with an internal thermal
sensor. The sensor initiates a shutdown when the operating temperature crosses the temperature
threshold recommended for an Instant AP. When an IAP operates under thermal management, all the
radios are in Disabled mode in the AP Health Bar.
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In Aruba Central On-Premises, the thermal shutdown feature is supported on IAPs running Aruba Instant
8.6.0.0 or later versions.

Viewing Thermal Shutdown Events
To view the thermal shutdown events, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a group, label, site, or all devices in the filter:

a. set the filter to one of the options under Groups, Labels, or Sites. For all devices, set the
filter to Global.
The dashboard context for the selected filter is displayed.

n To select a device in the filter:
a. Set the filter to Global.
b. Under Manage, click Devices, and then click Access Points.
c. Click an AP listed under Device Name.

The dashboard context for the AP is displayed.

2. Under Analyze, click Alerts & Events.

The Alerts & Events page is displayed in the List view.

3. Click the Events tab.

A list of events is displayed in the Events table.

When the thermal shutdown feature is either enabled or disabled in an IAP, the Events table displays
the following details:

n The Event Type column includes the AP Thermal Shutdown type which can be used to filter
thermal shutdown events.

n The Description column includes the status of the thermal shutdown feature in the IAP. For
example, Thermal management enabled or Thermal management disabled.

About Tri-Radio Mode
Aruba Central On-Premises offers tri-radio mode support in Aruba AP-555, a flagship 802.11ax access
point (AP). In tri-radio mode or split 5 GHz mode, the 8x8 5 GHz radio is split into two independent 4x4 5
GHz radios. In the split 5 GHz Mode, Radio 5 GHz Secondary operates on channels from 36 to 64 and
Radio 5 GHz operates on channels from 100 to 165.

To enable tri-radio, go to Access Points > Radio in the IAP configuration dashboard, and select the Split
Radio check-box.

Tri-radio mode is only available for IAPs and not for Campus APs and Remote APs.

The split 5 GHz radio can operate in the following modes:

n Access
n Monitor
n Spectrum
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Enabling Tri-Radio Mode
To enable the tri-radio mode, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a group in the filter:

a. Set the filter to one of the options under Groups. Ensure that the filter selected contains
at least one active access point.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Access Points.

A list of access points is displayed in the List view.

n To select an access point in the filter:
a. Set the filter to Global.
b. Under Manage, click Devices > Access Points.

A list of access points is displayed in the List view.

c. Click an access point listed under Device Name.

The dashboard context for the access point is displayed.

d. Under Manage, click Devices > Access Point.

2. Click the Config icon.

The tabs to configure access points are displayed.

3. Click the Access Points tab.

The Access Points page is displayed.

4. To edit an AP, select an AP in the Access Points table, and then click the edit icon.
5. Click Radio.
6. Select the Split Radio check-box.
7. Click Save Settings.

Viewing Tri-Radio Events

To view the tri-radio events, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a group, label, site, or all devices in the filter:

a. set the filter to one of the options under Groups, Labels, or Sites. For all devices, set the
filter to Global.

The dashboard context for the selected filter is displayed.
n To select a device in the filter:

a. Set the filter to Global.
b. Under Manage, click Devices, and then click Access Points.
c. A list of APs is displayed in the List view.
d. Click an AP listed under Device Name.

The dashboard context for the AP is displayed.

2. Under Analyze, click Alerts & Events.The Alerts & Events page is displayed in the List view.
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3. Click the Events tab.

A list of events is displayed in the Events table.

When the tri-radio mode is either enabled or disabled in an AP, the Events table displays the following
details:

n The Event Type column includes the AP Tri-Radio type which can be used to filter tri-radio events.
n The Description column includes the status of the tri-radio mode in AP.

In Aruba Central On-Premises, the tri-radio feature is available only on AP-555 running Aruba Instant 8.6.0.0 or
later versions.

By default, the AP-555 operates in dual radio mode.

Viewing the Summary Tab
In the access point (AP) dashboard, the Summary tab displays the device details, network information,
radio details including the topology of clients connected to each radio, and the health status of the AP in
the network.

To navigate to the Summary tab, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups, Labels,
or Sites. For all devices, set the filter to Global. Ensure that the filter selected contains at least one
active AP.

The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click an AP listed under Device Name.

The Summary tab is displayed.

To exit the AP dashboard, click the back arrow on the filter.

You can change the time range for the Summary tab by clicking the time range filter and
selecting one of the available options: 3 hours, 1 day, 1 week, 1 month, and 3 months.

The Summary tab displays the following sections:
n Device
n Network
n Radios
n Data Path
n Health Status
n WLANS
n Actions
n Go Live
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Device
The Device section displays all or some of the following details:

n AP Model—The AP hardware model.
n Country Code—Country code in which the AP operates.
n MAC—MAC address of the AP.
n Serial Number—Serial number of the AP.
n Uptime—Time since when the AP is operational.
n Last Reboot Reason—The reason for the latest rebooting of AP.
n Firmware Version—The firmware version running on the AP. If the device is running an older

firmware version, this field prompts the user to upgrade to the latest firmware version along with the
link to the Maintenance > Firmware page.

n Configuration Status—Displays the configuration status and the timestamp of the last device
configuration changes.

n Band Selection—Displays the operating band of the AP. The supported bands are Dual Band, Dual
5 GHz, Tri-Radio, or Tri Band.

n Power Draw—The power utilized by the device in watts (W) or kilowatts (kW).
n Power Negotiation—The power in watts (W) negotiated on the ethernet port of the device in a wired

network.
n Recommended Power—The recommended power in watts (W) negotiated on the ethernet port of

the device in a wired network.
n Controller—The name of the controller.
n Secondary Controller—The name of the secondary controller.

n Group—The group to which the AP belongs. Click the group name to go to the Overview >
Summary page for that group.

When an AP belongs to an unprovisioned group, the hyperlink to the unprovisioned group is disabled

n Labels—The labels associated with the AP. You can also add a new label to the AP by clicking the edit
icon. To view all the labels associated with a device, hover your mouse over the Labels column.

n LEDs on Access Point—Enables the blinking of LEDs on the APs to identify the location. Click Blink
LED to enable the blinking of LEDs on the AP. The default blinking time is set to 5 minutes and it
stops automatically after 5 minutes. To stop the blinking, click Stop Blinking.

A WebSocket connection is required to enable Blink LED.

n Site—The site to which the AP belongs. Click the site name to go to the Overview > Site Health page
for that site.

n Location—The currently configured physical location of an AP. Location detail is displayed only for
APs with firmware version ArubaOS 8.9.0.0 or later.

n Contact—The currently configured contact of an AP. For example, E-mail ID, or contact number.
Contact detail is displayed only for APs with firmware version ArubaOS 8.9.0.0 or later.

n Controller AP Group—Displays the name of the Controller AP group.
n Note—When you click the edit icon, a text-box is displayed. It allows you to add information that

can be used as reference. For example, AP location, and upgrade information.
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n From Aruba Central On-Premises 2.5.6 release, Country Code, Last Reboot Reason, Power Draw, and
Power Negotiation details are supported for Campus APs and Remote APs as well.

n Recommended Power is only available for IAPs and not for Campus APs and Remote APs.
n Recommended Power is supported on IAPs from ArubaOS 8.4.0.0 version onwards, and the

Recommended Power will not be available on the Device page if the IAP is already running on
recommended power.

Network
The Network section displays information of the network and interfaces to which the AP is connected.
Along with the network profile name, the following fields are displayed in the Network section:

n ETH0—Displays the status of the ETH0 network.
n Speed (Mbps)/Duplex—The speed of the network measured in Mbps. This field also indicates

whether the network has a full-duplex or half-duplex communication.
n VLAN—The number of VLAN connections associated with the network.

o LLDP Details—Click the LLDP Details link to view the ETH0 LLDP details. The pop-up window
displays the Neighbor Name, Neighbor MAC, Neighbor Port, and Neighbor VLAN details.

n ETH1—Displays the status of the ETH1 network.
n Speed (Mbps)/Duplex—The speed of the network measured in Mbps. This field also indicates

whether the network has a full-duplex or half-duplex communication.
n VLAN—The number of VLAN connections associated with the network.

o LLDP Details—Click the LLDP Details link to view the ETH1 LLDP details. The pop-up window
displays the Neighbor Name, Neighbor MAC, Neighbor Port, and Neighbor VLAN details.

n Current Uplink—The current uplink connection on the AP.
n Uplink connected to—The switch name to which the AP is connected. Click this link to view the

switch details page, if the switch is managed by Aruba Central On-Premises.
o Port—The port number of the switch to which the AP is connected.

n IP Address—IP address of the AP.
n Public IP Address—IP address logged by servers when the AP device is connected through internet

connection.
n DNS Name Servers—The server that has a directory of domain names and their associated IP

addresses.
n Default Gateway—A 32 bit value that is used to uniquely identify the device on a public network.
n NTP Server—Displays information about the NTP Server.

n From Aruba Central On-Premises 2.5.6 release, Public IP Address, DNS Name Servers, and Default
Gateway details are supported for Campus APs and Remote APs as well.

n From Aruba Central On-Premises 2.5.4 release, LLDP Details feature is supported for Campus APs as
well.

Radios
The Radios section displays the following information related to Radio 2.4 GHz, Radio 5 GHz, Radio 5
GHz Secondary, and Radio 6 GHz:
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n Mode—The type of mode for the radios. For example, Client Access, Monitor, and Spectrum.
n Status—Displays the operational status of the radios connected to the AP. The status is as follows:

o Up—Indicates that the radio is online.
o Down—Indicates that the radio is offline.
o Down - Thermal shutdown—Indicates that the radio is offline as the AP is operating under

thermal management. For more information, see Thermal Shutdown Support in Instant Access
Points.

n Radio MAC Address—The MAC address of the radios connected to the AP.
n Channel—The channels assigned to the radios.
n Power—The transmit power of the radios.
n Type—The type of wireless LAN used for the radios.
n Clients—The number of clients connected to the AP.
n Wireless Networks—The number of SSIDs configured in the network.
n Antenna—The type of antennae. For example, internal and external.
n Spatial Stream—Displays the number of spatial streams. By default, the spatial stream value for

Radio 5 GHz is 8x8. When tri-radio mode is enabled, the spatial stream values for Radio 5 GHz and
Radio 5 GHz (Secondary) is 4x4.

n When the AP radios are set to spectrum scan mode, the Channel and Power values are empty.
n The tri-radio feature is available only for AP-555. In the Radios section, the Radio 5 GHz (Secondary) data

is available only if the tri-radio mode is enabled. For more information, see About Tri-Radio Mode.
n The 6 GHz radio band is only supported for devices with 6 GHz capability.

Data Path
The Data Path section displays the topology of the clients connected to each of the radios of the AP,
which in turn is connected to switches or controllers through VLAN. When you hover over the upstream
device in the data path topology, a pop-up displays the Name, Serial Number, and Port details of the
upstream devices.

PORT shows the number of ports available in the AP that also includes USB ports. CLIENTS connected
to the PORT in the data path shows the number of wired clients connected to the port.
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Figure 60 Data Path

n The tri-radio feature is available only for AP-555. In the Data Path section, the 5 GHz (Secondary) data is
available only if the tri-radio mode is enabled. For more information, see About Tri-Radio Mode.

n In the Data Path section, the 6 GHz radio band is only supported for devices with 6 GHz capability.

Health Status
The Health Status trend graph indicates the health status of the device in the network for the time
selected in the time range filter. When you hover over the graph, you can view information such as date
and time, Health Status, Noise Floor, CPU, Memory, Channel Utilization (Radio 1), Channel Utilization
(Radio 2), and Channel Utilization (Radio 3).

In the Health Status graph, the Poor Health Limit text indicates the poor health limit of the device in
the network.

Figure 61 Health Status
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n In the Health Status graph, the Channel Utilization (Radio 3) data is available if the tri-radio mode is
enabled or if 6 GHz radio is available. For more information, see About Tri-Radio Mode.

n The tri-radio feature is available only for AP-555.
n The 6 GHz radio band is only supported for devices with 6 GHz capability.

WLANS
The WLANS table provides a list of all the SSIDs configured for the AP.

Figure 62 WLANS

The WLANS table provides the following information:

n Name—Displays the name of the SSID.

In the WLANS table, the Type, VLANs, and Security values are empty.

Click to expand an SSID in the WLANS table. When you expand an SSID in the WLANS table, you can
view the following information for 2.4 GHz, 5 GHz, 5 GHz (Secondary), and 6 GHz radios:

n BSSID—Displays the MAC address of the radio.
n Radio Type—Dispalys the type of radio.
n Clients—Displays the number of connected clients.

Click to download the .csv file of the WLANS table.

n In the .csv file of the WLANS table, the 5 GHz (Secondary) columns are available only if the tri-radio
mode is enabled.

n The tri-radio feature is available only for AP-555. In the WLANS table, the 5 GHz (Secondary) data is
available only if the tri-radio mode is enabled. For more information, see About Tri-Radio Mode.

n The 6 GHz radio band is only supported for devices with 6 GHz capability.

Actions
The Actions drop-down list contains the following options:
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n Reboot AP—Reboots the AP point. For more information, see Rebooting an Access Point in the List
View and Rebooting an AP in the Details Page.

A WebSocket connection is required to reboot IAPs, Campus APs, and Remote APs.

n Reboot Swarm—Reboots the IAP cluster. For more information, see Rebooting an IAP Cluster .
n Tech Support—Enables the administrator to generate a tech support dump required for

troubleshooting the AP. For more information, see Tech Support for an AP .

Go Live
Aruba Central On-Premises supports live monitoring of IAPs that support Aruba Instant 8.4.0.0 firmware
version and above. Aruba Central On-Premises allows you to monitor live data of an AP updated at
every 5 seconds. For more information, see Enabling Live IAP Monitoring.

Viewing the AI Insights Tab
In the access point (AP) dashboard, the AI Insights tab displays information on AP performance issues
such as excessive channel changes, excessive reboots, airtime utilization, and memory utilization.

n AI Insights is supported in Aruba Central On-Premises for five node instance and above.

n AI Insights is supported for IAPs, Campus APs, and Remote APs.

To navigate to the AI Insights tab in the AP dashboard, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global. Ensure that the filter selected contains at
least one active AP.

The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Access Points.A list of APs is displayed in the List view.

3. Click an AP listed under Device Name.

The dashboard context for the AP is displayed.

4. In the AP dashboard context, click the AI Insights tab.

The Insights page is displayed.

5. To exit the AP dashboard, click the back arrow on the filter.

You can change the time range for the AI Insights tab by clicking the time range filter and selecting
one of the available options: 3 hours, 1 day, 1 week, 1 month, and 3 months.

AI Insights are displayed for the time range selected. Select the time range from the Time Range Filter ( ) to
filter reports.

AI Insights Categories
AI Insights are categorized in high, medium, and low priorities depending on the number of
occurrences.
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n Red—High priority
n Orange—Medium priority
n Yellow—Low priority

AI Insights listed in the dashboard are sorted from high priority to low priority. The AI Insights
dashboard displays a report of network events that could possibly affect the quality of the overall
network performance. Each insight report provides specific details on the occurrences of these events
for ease in debugging. For more information, see The AI Insights Dashboard

The AP Insights page displays the following insights:

n Clients with High Wi-Fi Security Key-Exchange Failures
n Clients with High 802.1X Authentication Failures
n Clients with DHCP Server Connection Problems
n Clients with High Number of MAC Authentication Failures
n Clients with High Number of Wi-Fi Association Failures
n Clients with Captive Portal Authentication Problems

Viewing the Floor Plan Tab
In the access point (AP) dashboard, the Floor Plan tab provides information regarding the current
location and the floor plan of the instant access points, campus access points, and remote access
points.

To navigate to the Floor Plan tab in the AP dashboard, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global. Ensure that the filter selected contains at
least one active AP.

The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click an AP listed under Device Name.

The dashboard context for the AP is displayed.

4. In the AP dashboard context, click the Floor Plan tab.

The Floor Plan tab is displayed.

To exit the AP dashboard, click the back arrow on the filter.

You can change the time range for the Floor Plan tab by clicking the time range filter and selecting one
of the available options: 3 hours, 1 day, 1 week, 1 month, and 3 months.

The Floor Plan tab displays a sitemap and the floor plan showing the current location of the IAP . The
sitemap is derived from the Visual RF application, if Visual RF service is enabled for the Aruba Central
On-Premises account. You can also edit the location of the IAP device by clicking the edit icon provided
next to the address in the Floor Plan tab.

Actions
The Actions drop-down list contains the following options:
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n Reboot AP—Reboots the AP. For more information, see Rebooting an AP in the Details Page and
Rebooting an Access Point in the List View.

A WebSocket connection is required to reboot IAPs, Campus AP, and Remote AP.

n Reboot Swarm—Reboots the IAP cluster. For more information, see Rebooting an IAP Cluster .
n Tech Support—Enables the administrator to generate a tech support dump required for

troubleshooting the AP. For more information, see Tech Support for an AP .

Go Live
Aruba Central On-Premises supports live monitoring of IAPs that support Aruba Instant 8.4.0.0 firmware
version and above. Aruba Central On-Premises allows you to monitor live data of an AP updated at
every 5 seconds. For more information, see Enabling Live IAP Monitoring.

Viewing the Performance Tab
In the access point (AP) dashboard, the Performance tab displays the size of data transmitted through
the AP.

To navigate to the Performance tab in the AP dashboard, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under groups, labels,
or sites. For all devices, set the filter to Global. Ensure that the filter selected contains at least one
active AP.

The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click an AP listed under Device Name.

The dashboard context for the AP is displayed.

4. In the AP dashboard context, click the Performance tab. The Performance tab is displayed.

To exit the AP dashboard, click the back arrow on the filter.

You can change the time range for the Performance tab by clicking the time range filter and
selecting one of the available options: 3 hours, 1 day, 1 week, 1 month, and 3 months.

The Performance tab provides the following details:

n Throughput
The Throughput graph indicates the size of data sent to and received by the device in bits per
second for the wired or wireless networks. For example, Eth 0 or Eth 1 wired network profiles and
specific SSIDs of wireless networks. You can also view data for all the wireless SSIDs by selecting All
SSIDS from the drop-down list. You can view the overall data usage measured in bytes in the Overall
Usage field.

n Clients
The Clients graph indicates the number of clients connected to the device for the wired, wireless, or
radio network profiles for a selected time range in the time range filter. For example, wired for wired
network profile, specific SSID or All SSIDs for wireless network profile, and 2.4 GHz, 5 GHz, 6 GHz or
2.4 GHz & 5 GHz for radio network profile. You can select a specific network profile from the drop-
down list provided in the Clients section to view the date, time and number of clients connected.
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n When you hover over the Throughput and Clients graphs, it displays specific data for the selected
timestamp.

n The 6 GHz radios is available in Clients drop-down only if the AP supports 6 GHz. For more
information about the APs that supports 6 GHz, see Supported APs.

Actions
The Actions drop-down list contains the following options:

n Reboot AP—Reboots the AP. For more information, see Rebooting an AP in the Details Page on page
817 and Rebooting an Access Point in the List View on page 817.

A WebSocket connection is required to reboot IAPs, Campus APs, and Remote APs.

n Reboot Swarm—Reboots the IAP cluster. For more information, see Rebooting an IAP Cluster .
n Tech Support—Enables the administrator to generate a tech support dump required for

troubleshooting the AP. For more information, see Tech Support for an AP .

Go Live
Aruba Central On-Premises supports live monitoring of IAPs that support Aruba Instant 8.4.0.0 firmware
version and above. Aruba Central On-Premises allows you to monitor live data of an AP updated at
every 5 seconds. For more information, see Enabling Live IAP Monitoring.

Viewing the RF Tab
In the access point (AP) dashboard, the RF tab provides details corresponding to 2.4 GHz, 5 GHz, 5 GHz
(secondary), and 6 GHz radios of the IAPs, Campus APs, and Remote APs

Starting from Aruba Instant 8.9.0.0, the Wi-Fi 6E standard is supported that introduces 6 GHz radio band
for few IAPs, Campus APs, and Remote APs. The 6 GHz radio band provides greater efficiency, higher
throughput, and increased levels of security to address bandwidth challenges. The 6 GHz radio band
also provides wider channels up to 160 MHz for dense environments and large number of IoT devices.
The Wi-Fi 6E IAPs support 2.4 GHz, 5 GHz, and 6 GHz radio bands simultaneously, allowing client devices
to switch seamlessly between the three radio bands. The Wi-Fi 6E IAPs are supported with Enhanced
Open and WPA3 encryption methods only.

AP-635 and AP-655 IAPs are Wi-Fi 6E IAPs that support 6 GHz radio band, in addition to 2.4 GHz and 5 GHz radio
bands.

To navigate to the RF tab in the AP dashboard, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under groups, labels,
or sites. For all devices, set the filter to Global. Ensure that the filter selected contains at least one
active AP.

The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click an AP listed under Device Name.
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The dashboard context for the AP is displayed.

4. In the AP dashboard context, click the RF tab.

The RF tab is displayed.

To exit the AP dashboard, click the back arrow on the filter.

You can change the time range for the RF tab by clicking the time range filter and selecting one of the
available options: 3 hours, 1 day, 1 week, 1 month, and 3 months.

You can hover over the graph to view more information. You can select or clear an option in each
graph to filter the data displayed on the graph. For example, if you uncheck the box corresponding
to Receiving and Non-Wifi interference in the Channel Utilization graph, only Transmitting data
is displayed on the graph.

The RF tab provides the following details corresponding to 2.4 GHz and 5 GHz, and 6 GHz radio
channels of the IAPs, Campus APs, and Remote APs:

Channel Utilization
The Channel Utilization graph indicates the percentage of channel utilization for the selected time
range from the time range filter. The channel utilization information is categorized as follows:

n Transmitting: The percentage of channel currently being transmitted.
n Receiving: The percentage of channel currently being received.
n Non-Wifi Interference: The percentage of channel currently being used by non-Wi-Fi interferers.

Total Utilization is the sum of Transmitting, Receiving, and Non-Wifi interference, which indicates the
total percentage of channel utilization for the selected time range.

The following figure displays the channel utilization graph for 2.4 GHz radio channel.

Figure 63 Channel Utilization Graph

Noise Floor
The Noise Floor graph indicates the noise floor detected in the network to which the device belongs.

Frames - 802.11
The Frames - 802.11 line graph indicates the trend of frames transmitted through the network. The
frames can be one of the following types: Drops, Errors, and Retries. The graph indicates the status of
data frames that were dropped, encountered errors, retried to be transferred, in a wireless network.
You can see the graph in percentage or frames/sec.
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Only Campus APs and Remote APs support the Issues & Transmitted Frames and Issue % filter options.

Select one of the following option from the drop-down:

n Issues & Transmitted Frames—Select to view the trend value for transmitted frames along with
retries, errors, and drops in frames per second

n Issue %—Select to view the trend value for retries, errors, and drops in percentage.

Figure 64 Frames - 802.11 Graph

Radio Errors
The Radio Errors graph indicates the Total Packets, Physical Errors, and MAC Errors in packets per
second.

Only Campus APs and Remote APs support the Physical Errors, and MAC Errors options.

Figure 65 Radio Errors Graph

Channel Quality
The Channel Quality graph indicates the quality of channel in percentage.

n When you hover over the Channel Utilization, Noise Floor, Frames - 802.11, and Channel Quality
graphs, it displays specific data for the selected timestamp.

n The tri-radio feature is available only for AP-555. In the RF tab, the Radio 5 GHz (Secondary) tab is
available only if the tri-radio mode is enabled. For more information, see About Tri-Radio Mode.

n The 6 GHz radio band is only supported for devices with 6 GHz capability.

Actions
The Actions drop-down list contains the following options:
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n Reboot AP—Reboots the AP. For more information, see Rebooting an AP in the Details Page.

A WebSocket connection is required to reboot IAPs, Campus APs, and Remote APs.

n Reboot Swarm—Reboots the IAP cluster. For more information, see Rebooting an IAP Cluster .
n Tech Support—Enables the administrator to generate a tech support dump required for

troubleshooting the AP. For more information, see Tech Support for an AP .

Go Live
Aruba Central On-Premises supports live monitoring of IAPs that support Aruba Instant 8.4.0.0 firmware
version and above. Aruba Central On-Premises allows you to monitor live data of an AP updated at
every 5 seconds. For more information, see Enabling Live IAP Monitoring.

Viewing the Spectrum Tab
In the access point (AP) dashboard, the Spectrum tab provides details for all Wifi and non-Wifi devices
associated to each radio.

When the radios of Instant Access Point (IAP) are set to spectrum scan mode, the IAP functions as a
dedicated full-spectrum RF monitor, scanning all channels to detect interference from neighboring IAPs
or interfering devices such as microwaves and cordless phones. To enable the spectrum scan feature on
a specific radio of an AP, see Access Points Configuration Parameters.

n When the spectrum scan feature is enabled, the Instant AP does not provide services to clients.

n The spectrum scan feature is available only on IAP devices running Aruba Instant 8.5.0.1 firmware version
and later.

To navigate to the Spectrum tab in the AP dashboard, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global. Ensure that the filter selected contains at
least one active AP.

The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click an AP listed under Device Name.

The dashboard context for the AP is displayed.

4. In the AP dashboard context, click the Spectrum tab. The Spectrum tab is displayed.

To exit the AP dashboard, click the back arrow on the filter.

You can change the time range for the Spectrum tab by clicking the time range filter and
selecting one of the available options: 3 hours, 1 day, 1 week, 1 month, and 3 months.

The Spectrum tab displays the following sections:

n Channel Utilization and Quality
n Interfering Devices
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n Actions
n Go Live

Channel Utilization and Quality
Click the Chart icon to view the Channel Utilization and Quality details corresponding to 2.4 GHz and
5 GHz radios of the AP. Click the 2.4 GHz and 5 GHz tabs on the Channel Utilization and Quality label
to view the Channel Utilization and Quality graphs for the radios.

n Channel Utilization—The Channel Utilization graph indicates the percentage of channel utilization
for the Available, Interference, and Wi-Fi Utilization categories associated to 2.4 GHz and 5 GHz
radios. You can view the following channel metrics when you hover over the Channel Utilization bar
graph:
o Channel—The channel number of the radio.
o Available—The percentage of the channel currently available for use.
o Interference—The percentage of the channel currently being used by interfering devices.
o Microwave—The percentage of the channel currently being used by microwaves. Common

residential microwave ovens with a single magnetron are classified as a Microwave. These types of
microwave ovens may be used in cafeterias, break rooms, dormitories, and similar environments.
Some industrial, healthcare, or manufacturing environments may also have other equipment that
functions like a microwave and may also be classified as a Microwave device.

o Bluetooth—The percentage of the channel currently being used by bluetooth devices. Any device
that uses the Bluetooth protocol to communicate in the 2.4 GHz band is classified as a Bluetooth
device. Bluetooth uses a frequency hopping protocol.

o Cordless Phone—The percentage of the channel currently being used by cordless phones.
o Wi-Fi Utilization—The percentage of the channel currently being used by Wi-Fi devices.

n Quality—The Quality graph display the channel quality corresponding to each of the WiFi and non-
WiFi devices connected to the radios. When you hover over the Quality bar graph, the following
channel metrics are displayed:
o Channel—The channel number of the radio.
o Quality—Current relative quality of the channel.
o Known APs—Number of valid Instant APs identified on the radio channel.
o Unknown APs—Number of invalid or rogue Instant APs identified on the radio channel.
o Max AP Signal—Signal strength of the Instant AP that has the maximum signal strength on a

channel in dBm.
o Max Interference— Signal strength of the non-Wi-Fi device that has the highest signal strength in

dBm.
o Max AP SSID— The network SSID with maximum APs.
o Max AP BSSID— The network BSSID with maximum APs.

o SNIR— The measure of SNIR detected in the network in dB.
o Noise Floor— The noise at the radio receivers of the radios.

Interfering Devices
Click the List icon to view Interfering Devices details detected by the spectrum scanner. The page
displays a table with following details of interfering devices:
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n Type—Device type. This parameter can be any of the following:
o Audio FF (fixed frequency)
o Bluetooth
o Cordless base FH (frequency hopper)
o Cordless phone FF (fixed frequency)
o Cordless network FH (frequency hopper)
o Generic FF (fixed frequency)
o Generic FH (frequency hopper)
o Generic interferer
o Microwave
o Microwave inverter
o Video
o Xbox

n ID—ID number assigned to the device by the spectrum monitor. Spectrum monitors assign a unique
spectrum ID per device type.

n Central Frequency—Center frequency of the signal sent from the device.
n Bandwidth—Channel bandwidth used by the device in KHz.

n Affected Channels—Radio channels affected by the wireless device.

n Signal Strength—Strength of the signal sent from the device measured in dBm.
n Duty Cycle—The device duty cycle. This value represents the percent of time the device broadcasts a

signal.
n First Seen—Time at which the device was first detected.
n Last Seen—Time at which the device status was updated.

The data displayed in the Spectrum tab is refreshed every 15 seconds. Aruba Central On-Premises displays the
last recorded data for 30 minutes, if the device turns offline.

Actions
The Actions drop-down list contains the following options:

n Reboot AP—Reboots the AP. For more information, see Rebooting an AP in the Details Page on page
817 and Rebooting an Access Point in the List View on page 817.

A WebSocket connection is required to reboot IAPs, Campus APs, and Remote APs.

n Reboot Swarm—Reboots the IAP cluster. For more information, see Rebooting an IAP Cluster .
n Tech Support—Enables the administrator to generate a tech support dump required for

troubleshooting the AP. For more information, see Tech Support for an AP .

Go Live
Aruba Central On-Premises supports live monitoring of IAPs that support Aruba Instant 8.4.0.0 firmware
version and above. Aruba Central On-Premises allows you to monitor live data of an AP updated at
every 5 seconds. For more information, see Enabling Live IAP Monitoring.
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Viewing the VPN Tab
The VPN tab provides information on VPN connections associated with the virtual controller along with
information on the tunnels and the data usage through each of the tunnels.

VPN tab is only available for IAPs and not for Campus APs and Remote APs.

To navigate to the VPN tab, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global. Ensure that the filter selected contains at
least one active AP.

The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click an AP listed under Device Name.

The dashboard context for the AP is displayed.

4. Under Manage, click Security > VPN.

The VPN tab is displayed.

You can change the time range for the VPN tab by clicking the time range filter and selecting one of the
available options: 3 hours, 1 day, 1 week, 1 month, and 3 months.

The VPN tab provides the following information:

n VPNC Tunnels Summary—The section displays information on tunnels with the following details:
o Total—Total tunnels established.
o Up—Number of tunnels currently active.
o Down—Number of tunnels currently inactive.
o Peers—Number of peer tunnels currently active.

nn The Tunnel table displays information on tunnels with the following columns:
o Tunnel—The type of the tunnels used in the VPN. For example, primary, secondary, or backup.
o Status—The status of the tunnel.
o Source—The source address of the tunnel.
o Destination—The destination address of the tunnel.

n Throughput Usage Per VPN—The Throughput Usage Per VPN graph indicates the successful data
usage per VPN in Mbps for the primary or backup tunnel selected from the drop-down list. The
Throughput Usage Per VPN displays a linear graph of sent and received data in the virtual private
network.

Rebooting an AP in the Details Page
You can reboot an Instant Access Point, Campus Access Point, or Remote Access Point using the Aruba
Central On-Premises UI.

A WebSocket connection is required to reboot IAPs, Campus APs, and Remote APs.
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For information about how to reboot an AP in the List view, see Rebooting an Access Point in the List
View.

To reboot, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under groups, labels,
or sites. For all devices, set the filter to Global. Ensure that the filter selected contains at least one
active AP.

The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click an AP listed under Device Name.

The dashboard context for the AP is displayed.

4. In the Actions drop-down list, click Reboot AP.

A Reboot dialog box is displayed.

5. Click Reboot to reboot the AP.

The AP dashboard takes approximately a minute to update the interface status, after the AP is rebooted and
reconnected to Aruba Central On-Premises.

Rebooting an IAP Cluster
You can reboot an Instant Access Point (IAP) cluster using the Aruba Central On-Premises UI.

To reboot an IAP cluster, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global. Ensure that the filter selected contains at
least one active AP.

The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click an AP listed under Device Name.

The dashboard context for the AP is displayed.

4. In the Actions drop-down list, click Reboot Swarm.

A Reboot dialog box is displayed.

5. Click Yes to reboot the AP cluster.

The AP dashboard takes less than a minute to update the interface status, after the VC is rebooted and
reconnected to Aruba Central On-Premises.

Tech Support for an AP
In Aruba Central On-Premises UI, the administrators can generate a tech support dump required for
troubleshooting the Instant Access Point (IAP).

To generate a tech support dump for an IAP, complete the following steps:
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1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global. Ensure that the filter selected contains at
least one active AP.

The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click an AP listed under Device Name.

The dashboard context for the AP is displayed.

4. In the Actions drop-down list, click Tech Support.
The Commands page is displayed. In the Commands page, the Device Type and Available
Devices fields are automatically selected. The AP Tech Support Dump command is automatically
selected in the Selected Commands pane.

5. Click Run. The output is displayed in the Device Output section.

For more information, see Performing Advanced Device Troubleshooting.

Enabling Live IAP Monitoring
Aruba Central On-Premises supports live monitoring of Instant APs that support Aruba Instant 8.4.0.0
firmware version and above. Aruba Central On-Premises allows you to monitor live data of an AP
updated at every 5 seconds.

Enabling and Disabling Go Live
To enable and disable the live monitoring of an AP, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global. Ensure that the filter selected contains at
least one active access point.

The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Access Points.

A list of access points is displayed in the List view.

3. Click an access point listed under Device Name.

The dashboard context for the access point is displayed.

4. Click the Go Live button to start live monitoring of the AP.
5. To exit, click the Stop Live button to exit the live monitoring of the AP.

n The Go Live feature is not applicable for offline Instant APs. The Go Live button remains grayed-out for all
the APs that are not associated with Instant AP devices running Aruba Instant 8.4.0.0 firmware version
and above.

n Aruba Central On-Premises allows you to monitor live data for 15 minutes. After this time period, Aruba
Central On-Premises redirects to the AP dashboard in a non-live mode to display the monitoring details
for the time selected in the Time Range Filter. For more information on AP dashboard in a non-live
mode, see Viewing the Summary Tab.
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AP Details in Go Live Mode
When you click the Go Live button, the page displays live graphs based on noise floor, frames, and
channel quality of the neighboring RF devices for 15 minutes, until you select Stop Live button.

The page displays Noise Floor, Frames, and Channel Quality live graphs for Radio 2.4 GHz, Radio 5
GHz, Radio 5 GHz Secondary, and Radio 6 GHz.

Important Information
The following are the important information to consider while enabling live IAP monitoring:

n The Go Live feature is not applicable for offline APs.
n Aruba Central allows you to monitor live data for 15 minutes. After this time period, Aruba Central

redirects to the AP dashboard in a non-live mode to display the monitoring details for the time
selected in the Time Range Filter. For more information on AP dashboard in a non-live mode, see
Viewing the Summary Tab.

n In Go Live mode, AP dashboard updates and displays data at every 5 seconds.
n The tri-radio feature is available only for AP-555. In the Go Live page, the Radio 5 GHz (Secondary)

tab is available only if the tri-radio mode is enabled. For more information, see About Tri-Radio
Mode.

n The Radio 6 GHz band is only supported for devices with 6 GHz capability.
n The time range selected in the Time Range Filter is not applicable when the Go Live button is

enabled.
n You can monitor live data for multiple APs simultaneously on different tabs.

Replacing an Access Point
Aruba Central On-Premises now supports Campus AP, Remote AP, and Instant Access Point
replacement workflow. You can now replace the APs from the AP dashboard in the Aruba Central On-
Premises WebUI. Navigate to Manage > Overview > Summary page to replace the AP.

Before you Replace a Campus AP or Remote AP
The following are the important points to consider before you replace a Campus AP or Remote AP:

n The device that has to be replaced can be either offline or online.

n The model number of the old AP and the new AP can be different. The AP that replaces another AP
need not be of the same model.

n The old AP must be a licensed device, and ensure to have an additional license available because the
new AP will procure a license during replacement.

n The new AP must be part of the device inventory and must not have any label or sites assigned to it
as it is inherited from the old AP.

n After the AP is replaced, the new AP gets licensed and inherits the Group, Label, and Site parameters
along with floor plan from the old device.

n The new AP does not inherit any configuration from the old AP.
n After the AP is replaced, the old AP is removed from:

o Device inventory
o Monitoring view
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o Visual RF if the AP is associated with the Visual RF floor plan
o Site, Label, and Group, if associated

n The new AP replaces the old AP in the VisualRF floor plan if the old AP was associated with the
VisualRF floor plan.

n The old AP is deleted from the monitoring view only after the validation process is complete. This
validation process takes about 15 minutes.

Before you Replace an Instant AP
The following are the important points to consider before you replace an Instant Access Point:

n The device that has to be replaced can be either offline or online.
n The model number of the old AP and the new AP must be the same. For example, an AP-505 must be

replaced with an AP-505 only.
n The new AP must be part of the device inventory and must not have any label or sites assigned to it

as it is inherited from the old AP.
n Subscription must be assigned for the new AP.
n If the AP that is going to be replaced is a member, the new AP automatically inherits the

configuration from the leader of the group.
n If the AP that is going to be replaced is a leader, the new AP does not automatically become the

leader. Although the replacement procedure ensures that the new AP inherits the configuration
settings, a new leader is elected after the new AP joins the cluster.

n After the AP is replaced, the new AP inherits the Group, Label, Site parameters, firmware version, and
device name from the old device.

n The old AP is deleted from the monitoring view only after the validation process is complete. This
validation process takes 15 minutes.

n After the device is replaced, the old AP is not removed from the device inventory. The AP can be
reused in the future.

Replacing an AP from the Summary Page
To replace an AP from the summary page, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Access Points.
A list of APs is displayed in the List view.

3. Click Offline to view a list of offline APs in the Access Points table.
4. In the Device Name column, click the AP that you want to replace.

The Overview > Summary page is displayed in the AP dashboard.
5. In the Actions drop-down list, click Replace Device.
6. In the Replace Device pop-up window, click Replace.
7. In the Replace Access Point page, perform the following steps:

a. Select a replacement AP and click Next.
b. Verify the attributes as described in Table 104 and Table 105.
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c. Click Next.

In the Confirmation page, the following warning is displayed:
This is an irreversible operation. Do you want to proceed with the device replacement?

d. In the Confirmation page, review the old and new device details and click Replace.
e. In the Request Accepted pop-up window, click Done to continue the workflow.

8. In the Access Point Details page, a progress bar displays the device replacement status. Hover
over the progress bar to view more details.

9. Optionally, hover over the progress bar and click Terminate if you wish you to discontinue
replacing the device.

If the device replacement process fails, click Terminate to end the procedure and retry.

10. Connect the new AP.

The status in the progress bar changes to Device replacement in progress. Hover over the
progress bar to view more details.

If the firmware upgrade fails for an Instant Access Point, Aruba Central automatically retries one more
time. If the firmware upgrade fails for the second time, the Firmware Updated status changes to
Failed. You can manually upgrade the firmware. For more information, see Upgrading Device
Firmware.

11. Navigate to the AP Summary page of the new device.
a.  In the Aruba Central On-Premises app, set the filter to Global.

The dashboard context for the selected filter is displayed.
b. Under Manage, click Devices > Access Points.

A list of AP is displayed in the List view.
c. Click Online to view a list of online APs in the Access Points table.
d. In the Device Name column, click the new AP.

The Overview > Summary page is displayed in the AP dashboard.
e.  In the Device section, you can view the following details:

n AP Model
n Country Code
n MAC Address
n Serial Number
n Last Seen
n Last Reboot Reason
n Firmware version
n Configuration Status
n Band Selection
n Power Negotiation
n Group
n Labels
n Site
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12. The Audit Trail page displays all the logs generated during the device replacement process. To
view the logs, set the filter to Global. Under Analyze, click Audit Trail.

The Audit Trail table is displayed.

The following table lists the attributes on the Replace Access Point page for Campus AP and Remote
AP.

Parameters Description

Device name The device name of the new AP.

Serial number The serial number for each AP is a unique value. The serial number reflects the value of the
new AP.

Subscription
assigned

The new AP is assigned the same subscription as the old one. For example, if the old AP had
a Foundation license, the new AP is assigned the same Foundation license.

Model number The model number of the new AP.

Group name The group name that is inherited from the old AP.

Site assigned The site that is inherited from the old AP.

Label(s)
assigned

The label(s) that is inherited from the old AP.

Table 104: Parameters for Campus AP and Remote AP

The following table lists the attributes on the Replace Access Point page for an Instant Access Point.

Parameters Description

Device name The name that is inherited from the old AP.

Serial number The serial number for each AP is a unique value. The serial number reflects the value of the
new AP.

Subscription
assigned

The same subscription is assigned to the new AP. For example, if the old AP had a
Foundation license, the new AP is assigned the same Foundation license.

Model number The model number is inherited from the old AP.

Group name The group name that is inherited from the old AP.

Site assigned The site that is inherited from the old AP.

Firmware
version

Firmware version is displayed as Unknown for the new AP. However, after the new AP is
connected and the configuration in synchronized, the firmware is upgraded to the same
version as the old device.

Table 105: Parameters for an Instant Access Point

Bulk Replacement of Access Points
Aruba Central On-Premises now allows you to perform bulk replacement of Campus APs and Remote
APs in the WebUI. You can replace the APs in bulk by using one of the following pages :
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n In the global dashboard, navigate to Maintain > Organization > Device Replacement. See,
Replacing an AP from the Device Replacement Tile.

n Manage Sites under Maintain > Organization > Network Structure. See, Bulk Replacement of APs
from the Manage Sites Page.

Important Points
Following are the important points to consider for replacing Campus APs or Remote APs in bulk:

n You can replace only the APs that can be either offline or online.

n The model number of the old APs and the new APs can be different.

n You cannot rename APs by using Device Replacement or Manage Sites page. To rename APs, see
Renaming an AP.

n The old APs must be licensed devices. Also, ensure to have additional licenses available because the
new APs will procure licenses during replacement.

n The new APs must be part of the device inventory.
n After the APs are replaced, the new APs inherit the Group, Label, Site, Visual RF parameters along

with licenses from the old APs.
n After the APs are replaced, the old APs are removed from:

o Device inventory
o Monitoring view
o Visual RF if the APs are associated with the Visual RF floor plan
o Site, Label, and Group, if associated

n The new APs replace the old or faulty APs that were associated with the VisualRF floor plan.

Replacing an AP from the Device Replacement Tile
To replace one or more APs from the device replacement tile, complete the following steps:

1. In the Aruba Central app, set the filter to Global.
The dashboard context for the selected filter is displayed.

2. Under Maintain, click Organization.

By default, the Network Structure tab is displayed.

3. In the Device Replacement tile, click Devices.

The Replace Devices page is displayed.

4. In the Select a device type drop-down, select either CAP/RAP or IAP.

5. In the Select a site drop-down, select a site in which the APs need to be replaced.

The Devices table lists the offline APs available for replacement from the selected site.

6. In the Devices table, select one or more APs that you want to replace and click the Replace

Offline Devices icon. You can select up to a maximum of 20 APs at a time for a replacement.
The New Device and Compliance Status columns are displayed.

7. In the New Device column, select a new AP from the drop-down for the selected faulty APs. You
can filter the new AP using the complete serial number or MAC address in the search box.
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Once the new AP is selected, Aruba Central On-Premises checks whether the faulty device can be
replaced with the new AP.

n If the selected AP is a good match for the faulty AP, then the Compliance Status column for
the selected AP is displayed as Good Match.

You can replace the faulty AP only when the Compliance Status is displayed as Good Match.

n If the selected AP is not a good match for the faulty AP, then the Compliance Status column
for the selected AP displays one or some of the following reasons:
o The model number of the faulty AP is not matching with the new AP.
o A valid license is not assigned to the faulty device.
o The new device is blocked by another replacement process.
o Not able to fetch faulty device details from the device inventory if the device is not available

in the device inventory.
o Not able to fetch details about the faulty device group.

8. Click Replace to initiate the device replacement.

The Replace button is enabled only if the selected device is a good match.

In the Compliance Status column, the status changes to: Your replacement request has been
accepted. You cannot terminate the device replacement process once the status changed to Your
replacement request has been accepted.

9. Plug in the new AP once the status changes to: Your replacement request has been accepted.

10. Click Status to check the progress of the device replacement process.

The Devices Under Replacement page is displays the following details:

n Old Device Name

n New Device Name

n Requested On

n Updated On

n Device Type

n Device Connection Status

n Site Name

n Group Name

n Old Device Serial

n New Device Serial

n Old Device MAC

n New Device MAC

n Model

n Group assignment

n Site assignment

n Labels assignment
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n License assignment

n VRF assignment

n Configuration assignment

n Firmware assignment

n Uplink assignment (This column is not applicable for APs)

n Status

Once all the assignments are Updated for an AP, it will take up to five minutes for the Status
column to change to Success. If any of the assignments failed, the Status column changes to
Failed.

You can click on the any of the old device serials to view the device replacement history details for
the particular device.

n You can also navigate to the Devices Under Replacement page from the Device Replacement
tile and AP summary page to view the status of the device replacement.

n Optionally, you can terminate the replacement process when the Status is displayed as
Requested by hovering over the row in the Devices Under Replacement page.

n The old device is not removed from the monitoring view if the device replacement fails.

11. To view the device replacement history, navigate to the Device Replacement tile and click
Replacement History.

The Replacement History page lists the details of all the device replacement details carried out in
Aruba Central On-Premises. You can click on the any of the old device serials to view the device
replacement details for the particular device.

12. To view the audit logs, in the global dashboard context, navigate to Analyze > Audit Trail and
filter the Category column to Device Replacement.
The Audit Trail page displays all the logs generated during the device replacement process.

Using Device Search
In the Devices Under Replacement and Replacement History pages, the search icon allows you to
filter devices using search queries. For example, the search query “Site name is Santa Clara AND device
type is Access Point" returns all APs in the Santa Clara site.

The search query can contain the following information:

n Device Attributes—Device serial, MAC address, device name, site name, and group name are
allowed.

n Operators—is, as, and equal sign (=) are allowed.
n Separators—AND, comma (,), semicolon (;), and ampersand (&) are allowed.

Sample Queries
The following table lists some sample queries that can be used as search queries:
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Query Result

new_AP1 Returns the device with the name new_AP1.

Serial is H9XHL Returns the device with the serial number H9XHL

Site name is Bangalore AND device type = switch Returns all the switches in the Bangalore site.

Group name as Outdoor & device type is Gateway Returns all the gateways in the Outdoor group.

Table 106: List of Sample Queries

Bulk Replacement of APs from the Manage Sites Page
To replace APs in bulk by using the Manage Sites page, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization.

By default, the Network Structure tab is displayed.
3. Click the Sites tile.

The Manage Sites page is displayed.

4. From the list of sites, select the site whose APs you want to replace.

5. Click the icon.
The Replace Offline Devices pop-up window is displayed.

6. Click Replace.

The Bulk Device Replacement page under Manage > Overview > Device Replacement is
displayed.

7. Select the number of offline APs under Devices table that you want to replace, and click the
icon.

The Replace Devices page is displayed.

You can select a maximum of 30 devices from the Devices table for bulk replacement.

8. In the Devices table, select the serial number of the new AP from the New Device drop-down
list.

In the Confirmation page, the following warning is displayed—
This is an irreversible operation. Do you want to proceed with the device replacement?

9. Click Replace.

The Replacement Status pop-up window is displayed.

The Replacement Status pop-up window displays the New device blocked for replacement
message for each of the newly replaced APs.

10. Click Done.
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Viewing the Clients Tab
In the access point (AP) dashboard, the Clients tab displays details of all the clients connected to a
specific AP.

To navigate to the Clients tab in the AP dashboard, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global. Ensure that the filter selected contains at
least one active AP.

The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click an AP listed under Device Name.

The dashboard context for the AP is displayed.

4. Under Manage, click Clients.

The Clients page is displayed in the List view.

To exit the Clients dashboard, click the back arrow on the filter.

You can change the time range for the Clients tab by clicking the time range filter and selecting
one of the available options: 3 hours, 1 day, 1 week, 1 month, and 3 months.

For more information, see All Clients.

Viewing the Alerts & Events Tab
In the access point (AP) dashboard, the Alerts & Events tab displays details of the alerts and events
generated for the AP.

To navigate to the Alerts & Events tab in the AP dashboard, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global. Ensure that the filter selected contains at
least one active AP.

The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click an AP listed under Device Name.

The dashboard context for the AP is displayed.

4. Under Analyze, click Alerts & Events.

The Alerts & Events page is displayed in the List view.

To exit the Alerts & Events dashboard, click the back arrow on the filter.

For more information, see Alerts and Events. You can also configure and enable certain categories of AP alerts.
For more information, see Access Point Alerts.
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Live Events
Aruba Central On-Premises allows you to troubleshoot issues related to Instant APs (IAPs) and IAP
wireless clients. The Live Events feature is similar to client live troubleshooting, but in this case, we can
enable live events at the Instant Access Point level. Currently, users can subscribe to Radio, VPN, and
Spectrum events.

n The IAP must be running ArubaInstantOS 8.5.0.0 or later versions to support this feature. Live Events is
not supported on single-node deployments.

n Live Events is only available for IAPs and not for Campus APs and Remote APs.

Troubleshooting an IAP
Aruba Central allows you to troubleshoot issues related to an IAP in real-time for detailed analysis.

To troubleshoot an IAP at the device level, perform the following steps:

1. In the Aruba Central On-Premises app, select an IAP from the Device list.

The dashboard context for the selected IAP is displayed.

2. Under Analyze, click Live Events.

The Live Events page is displayed.

The live monitoring session starts automatically. The status of the troubleshooting is displayed every
minute. The troubleshooting session runs for a duration of 15 minutes. You can stop live
troubleshooting at any point by clicking Stop Troubleshooting to go back to the historical view.

After the live troubleshooting session ends, the details of the events are displayed in the Live Events
table.

Live Events Details
The following details are captured and displayed in the Live Events table:

n Occurred On—Displays the timestamp of the event. Use the filter option to filter the events by date
or time.

n Category—Displays the category of the event. Use the filter option to filter the events by category.
n Description—Displays a description of the event. Use the filter option to filter the events based on

description.

You can download the list of live events to a CSV file for offline analysis. To download live events, click
the Download CSV icon on the Live Events table.
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Managing AOS-CX Switches

Managing AOS-CX Switches

AOS-CX is a modern and fully programmable operating system built using a database-centric design,
which ensures higher availability and dynamic software process changes for reduced downtime. In
addition to robust hardware reliability, the AOS-CX operating system includes additional software
elements not available with traditional systems, including:

n Automated visibility to help IT organizations scale
n Simplified programmability
n Faster resolution with network insights
n High availability
n Ease of roll-back to previous configurations

The AOS-CX operating system is a modular, database-centric operating system. Every aspect of the
switch configuration and state information is modeled in the AOS-CX switch configuration and state
database, including configuration information, status of all features, and network analytics. The AOS-CX
operating system also includes a time series database, which acts as a built-in network record. The time
series database makes the data seamlessly available to Aruba Network Analytics Engine agents that use
rules that evaluate network conditions over time.

Aruba Central On-Premises offers an on-premises management platform for managing AOS-CX
infrastructure. It simplifies switch management with flexible configuration options, monitoring
dashboards, and troubleshooting tools.

This section includes the following topics:

n Getting Started with AOS-CX Deployments
n Provisioning Factory Default AOS-CX Switches
n Provisioning Pre-Configured AOS-CX Switches
n Configuring AOS-CX Switches using Templates
n Configuring AOS-CX Switches in UI Groups
n Configuration Workflow for AOS-CX Switches in UI Groups
n Caveats for Using AOS-CX Switches in Aruba Central On-Premises
n Managing an AOS-CX VSF Stack
n Aruba Central NetConductor Overview
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Getting Started with AOS-CX Deployments
Before you get started with your onboarding and provisioning operations, browse through the list of
Supported AOS-CX Platforms in Aruba Central On-Premises.

Provisioning Workflow
The following sections list the steps required for provisioning AOS-CX switches in Aruba Central On-
Premises.

Provisioning a Factory Default AOS-CX Switch
Like most Aruba devices, AOS-CX switches support ZTP. Switches with factory default configuration have
very basic configuration for all ports in VLAN-1. You must manually add either the serial number, MAC
address, or part number of the new factory default switch in Aruba Central On-Premises. When the
switch identifies Aruba Central On-Premises as its management entity, it connects to Aruba Central On-
Premises.

To manage AOS-CX switches from Aruba Central On-Premises, you must onboard the switches to the
device inventory and assign a valid subscription.

For step-by-step instructions, see Provisioning Factory Default AOS-CX Switches.

Provisioning a Pre-configured or Locally-Managed AOS-CX Switch
Pre-configured switches have customized configuration; for example, an additional VLAN or static IP
address configured on the default.

Aruba Central On-Premises management service is enabled by default on AOS-CX switches. When the
switch is powered on, it identifies Aruba Central On-Premises as its management entity and connects to
Aruba Central On-Premises.

To manage AOS-CX switches from Aruba Central On-Premises, you must onboard the switches to the
device inventory and assign a valid subscription.

For step-by-step instructions, see Provisioning Pre-Configured AOS-CX Switches.
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Group Assignment
Aruba Central On-Premises supports provisioning AOS-CX switches in UI and template groups. Template
groups allow you to configure devices using CLI-based configuration templates. UI groups allow you to
configure devices using UI-based configuration options.

The following figure illustrates the group assignment workflow in Aruba Central On-Premises.

Figure 66 Group Assignment-AOS-CX Switches

Moving AOS-CX Switches Between Groups
AOS-CX switches can also be moved between groups in Aruba Central On-Premises. When moving
switches from an unprovisioned, template, or UI group to another UI group, the existing switch
configuration can be retained by selecting the Retain CX-Switch Configuration check box on the Move
Devices page. If the configuration on the device and the group are different, Aruba Central On-Premises
retains the device configuration as device overrides. Consider the following points when selecting this
check box:

n When moving the switches to the UI group, all supported UI group configurations except the
following, if present at the group-level for the destination group, are applied to the switches:
o System Properties—Only the device administrator password, if configured in the group, is

updated on the switch.
o Authentication (MAC and 802.1X)
o Spanning Tree (Loop Prevention)
o HTTP Proxy
o User-based tunneling
o Logging servers
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o SNMP
o Port interfaces

n If any group configuration has dependent configuration, then the dependent configuration will not
be applied to the device.

For example, any LAG configuration that is present at the group-level (not at the device level) will be
applied. However, the port configuration in a LAG will not be applied, as port configuration is a
dependent configuration of LAGs.

n Device-level RADIUS and TACACS server configuration will be retained, if present. And also any new
group-level configuration will be applied. However, if any retained device configuration conflicts with
group-level configuration, then group-level configuration takes precedence, and those conflicting
configuration will be replaced.

AOS-CX Switch Configuration
Aruba Central On-Premises supports managing AOS-CX switches configuration using configuration
templates and UI group configuration.

When an AOS-CX switch is connected to Aruba Central On-Premises and managed using the Aruba
Central On-Premises app, Aruba Central On-Premises becomes the single source of configuration for
the switch. In the Aruba Central On-Premises Manged mode, the switch cannot be configured using any
of the other switch configuration interfaces, such as the switch CLI, REST APIs, NBAPIs, and SNMP. You
can use any configuration options available in Aruba Central On-Premises to configure the AOS-CX
switches in the Managed mode. You can use the MultiEdit mode on the UI to run commands on the
switch through Aruba Central On-Premises. For information, see Using MultiEdit View for AOS-CX.

The Aruba Central On-Premises Manged mode is applicable to AOS-CX switches running the firmware
version 10.07 or later, and to those switches that have been added to an Aruba Central On-Premises
group. This mode is not applicable to switches in the unprovisioned state.

Configuration Using Templates
Aruba Central On-Premises supports managing AOS-CX switches configuration using configuration
templates. Ensure that you assign the AOS-CX switches to a template group.

n When initially onboarding an AOS-CX switch to Aruba Central On-Premises, you must manually create the
template for the switch in a group, along with the password in plaintext format. You can use the output of
the show running-config command to create the template. You can also add variables to use the same
template for onboarding multiple AOS-CX switches.

n In the AOS-CX template configuration, the pound sign (#) is used for adding comments. When using the
banner motd code in the template configuration, use a delimiter such as at (@) symbol or any other

special character, than using the pound sign (#). Using the pound sign (#) with the banner motd code will
cause the code to be dropped when processing the template.

For more information on managing AOS-CX switches in Aruba Central On-Premises using templates, see
Configuring AOS-CX Switches using Templates.

Configuration Using UI Groups
Aruba Central On-Premises supports managing AOS-CX switches configuration using UI groups. You can
configure AOS-CX switches that are added to a UI group, using the UI options and MultiEdit mode. You
can pre-configure groups in the absence of switches.



Aruba Central On-Premises 2.5.7 | User Guide 537

For more information on managing AOS-CX switches in Aruba Central On-Premises using UI group
configuration, see Configuring AOS-CX Switches in UI Groups.

Replacing a VSX member
When replacing a VSX switch member that is configured and managed through Aruba Central On-
Premises, ensure that the new replacement switch is assigned to the same group as the old switch. If
the assigned group is the template group, ensure that the variables for the new replacement switch are
same as the old switch. In the case of the UI group, if the VSX switch is configured using MultiEdit, you
need to copy the original configuration from the MultiEdit configuration editor and paste it to the new
replacement switch after moving it into the group.

AOS-CX Stack Configuration
Aruba Central On-Premises supports managing AOS-CX switch stacks configuration using UI group
configuration and templates.

For more information on managing AOS-CX switch stacks in Aruba Central On-Premises using UI group
configuration, see Configuring AOS-CX VSF Stacks Using UI Groups.

For more information on managing AOS-CX switch stacks in Aruba Central On-Premises using
templates, see Configuring AOS-CX Switches using Templates.

AOS-CX Switch Monitoring
To view the operation status of switches and health of wired access network, complete the following
steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites.

For all devices, set the filter to Global. Ensure that the filter selected contains at least one active
switch.

The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

3. Click an AOS-CX switch under Device Name.

The dashboard context for the switch is displayed.

For more information, see Monitoring Switches and Switch Stacks.

Viewing VSX Details
Aruba Central On-Premises displays information about VSX configuration of AOS-CX switches. For more
information, see Switch > VSX.

Last synced data is displayed in the Switch > VSX page only when VSX synchronization is enabled for the AOS-CX
switch. However, enabling VSX synchronization using template configuration in Aruba Central On-Premises is
not recommended. By enabling VSX synchronization, the peer switch may get into an unknown configuration
state.
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Viewing Topology Map
In Aruba Central On-Premises, the Topology tab in the site dashboard provides a graphical
representation of the site including the network layout, details of the devices deployed and health of
the WAN uplinks and tunnels. Aruba Central On-Premises supports AOS-CX switches to be displayed in
the Topology tab. For more information, see Monitoring Sites Topology Tab.

Troubleshooting and Diagnostics
If you are unable to view all details of the AOS-CX switch, then maybe the template configuration was
not applied correctly, the password was missing in the template configuration, or the password was not
in plaintext. See the audit trail to check the status of the switch. The audit trail should show the device
onboarded message for the switch serial number followed by the configuration push and login
successful messages. For more information on troubleshooting AOS-CX switch onboarding issues, see
Troubleshooting AOS-CX Switch Onboarding Issues.

Configuration Status
The Configuration Audit page under Aruba Central On-Premises app > Device(s) > Switches in the
Aruba Central On-Premises UI displays errors in configuration sync, template configuration, and a list of
configuration overrides. For more information, see Viewing Audit Trail.

The Configuration Status page under Aruba Central On-Premises app > Device(s) > Switches in the
Aruba Central On-Premises UI displays errors in configuration sync, templates, and a list of
configuration overrides. For more information, see Using Configuration Status on AOS-CX.

Troubleshooting Tools
To troubleshoot AOS-CX switches remotely, use the tools available under Aruba Central On-Premises
app > Analyze > Tools. For more information, see Using Troubleshooting Tools.

Actions Drop-down
You can also reboot, connect to the remote console of the switch, or generate a tech support dump for
troubleshooting the device, by using the tools available under the Actions drop-down. The Actions
drop-down is available in the switch monitoring pages.

The Actions tab displays the various options available for remote administration of the switch. The
following options are available:

n Reboot—Reboots the switch. See Rebooting Switches.
n Tech Support—Allows the administrators to generate a tech support dump for troubleshooting the

device. See Troubleshooting Aruba Switches.
n Console—Opens the remote console for a CLI session through SSH. Ensure that you allow SSH over

port 443. The default user ID is admin, but you can edit and customize the user ID. This custom user
ID must be mapped to the device. See Opening Remote Console for Switch.

n VSF Switchover—Triggers the standby conductor switch to take over the conductor role. This option
is applicable only for AOS-CX switch stacks. See VSF Switchover.
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For AOS-CX 8320 and 8325 switch series, you must enable SSH server on the default VRF. Add the ssh server

vrf default code to the template.

If the Copy and Paste function from the keyboard shortcut keys (CTRL+C and CTRL+V) do not work in your web
browser, use the Copy and Paste functions available under the menu options in the web browser.

You can only troubleshoot Aruba switches using the Console option in Aruba Central. You cannot configure the
switches.

Caveats for Using AOS-CX Switches in Aruba Central On-Premises
The following sections provide details on the caveats to be noted when onboarding, configuring,
monitoring, and troubleshooting AOS-CX switches using Aruba Central On-Premises.

Monitor-only mode is not supported for the AOS-CX switches in the UI or template groups. You can add the
AOS-CX switches to the UI or template groups to configure, monitor, and troubleshoot the AOS-CX switches.

Plaintext Password Override after Migrating from Version 2.5.3 to 2.5.4
After upgrading Aruba Central On-Premises to version 2.5.4, for security reasons, any plaintext
passwords, previously configured directly or using variables in the AOS-CX switch template, are hidden
and displayed as asterisk (*) symbols. The plaintext passwords, previously configured in the template,
directly or using variables, will work as expected; however, these plaintext passwords, displayed as
asterisk (*) symbols, will not work if you copy them to a new template. You must re-enter the plaintext
passwords in the new template for the template to work correctly.

Onboarding
The following limitations should be taken into consideration when onboarding AOS-CX switches in
Aruba Central On-Premises:

n ZTP does not work on inline data ports for AOS-CX 8320 and 8325 switch series. The following is an
example configuration for onboarding AOS-CX 8320 and 8325 switch series to Aruba Central On-
Premises:

interface 1/1/1

no shutdown

no routing

interface vlan 1

ip address <IP-ADDRESS/MASK>

ip route 0.0.0.0/0 <IP-GATEWAY>

ip dns server-address <DNS-SERVER>

https-server vrf default

ztp force-provision

n After the erase startup-config command is executed on the AOS-CX switches, the switches do not
onboard to Aruba Central On-Premises. It is recommended to execute the erase all zeroize

command, instead of the erase startup-config command.
n When an AOS-CX switch is first onboarded to Aruba Central On-Premises, Aruba Central On-Premises

must perform the following actions, before it can perform events such as rebooting the switch and
upgrading the firmware:
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o Login to the switch using the password provided in the template configuration
o Apply the template to the switch

n Only DHCP-based ZTP is supported on Aruba Central On-Premises for AOS-CX. Activate-based ZTP is
not supported.

n FQDN or hostname for Aruba Central On-Premises server is not supported. You must provide only
the IP address.

n The Aruba Central On-Premises URI that is received as part of DHCP option is not persistent across
reboots. You must include the Aruba Central On-Premises URI configuration when applying the
template configuration to avoid connectivity issues after initial onboarding using the DHCP option.

Applying Template, Using UI Groups, or the MultiEdit Mode
The following limitations should be taken into consideration when configuring AOS-CX switches using
UI groups, in the MultiEdit mode, or by applying the template in Aruba Central On-Premises:

n You must configure the admin password in the template configuration only in plaintext. The format
of the password configuration command must be user admin group administrators password

plaintext <string>.
n If the template for AOS-CX switches contains % in the configuration, Aruba Central On-Premises will

not save the configuration.

Although the % character is allowed in AOS-CX switches, for example in banners, the same is not
allowed in Aruba Central On-Premises. In Aruba Central On-Premises, the % character is reserved for
variables.

n Aruba Central On-Premises supports the following maximum number of lines when configuring AOS-
CX switches using UI groups, template groups , or the MultiEdit mode:
o For 6000 and 6100 Switch Series—500
o For all other supported AOS-CX switches—84000

Beyond the limits mentioned above, Aruba Central On-Premises will not apply the configuration to
the switches.

n Onboarding an AOS-CX switch with 10.05 firmware to Aruba Central On-Premises, using the Import
Configuration as Template option on the Add Template window, fails to import the configuration
and displays an error message. In this case, you must manually create the template for the switch
using the output of the show running-config command. You can successfully import the
configuration as a template for an AOS-CX switch with 10.05 firmware, only when the switch is part of
a template group and the config-sync status is in-sync.

To import the configuration as template when onboarding an AOS-CX switch, without the error
message, you must upgrade the switch to 10.06 firmware.

n Aruba Central does not support configuration of AOS-CX action commands in the MultiEditor or
templates.

Action commands are interactive commands that require user input in the CLI or commands that
generate additional configuration lines when applied, such as referencing of configured interface
personas. All configurations entered in the MultiEditor or templates must be in the format as they
appear in the running configuration of AOS-CX switches.

Configuring AOS-CX VSF Stack
The following are the VSF stacking limitations of AOS-CX switches in Aruba Central On-Premises:
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These limitations apply only when the switches are running AOS-CX 10.06 or earlier firmware versions.

Aruba Central On-Premises supports only a few functions related to AOS-CX switch stack, such as
onboarding a stack to Aruba Central On-Premises and replacing member switches having the same
model and part number, through template configuration. All other stacking related functions, such as
creating a stack, deleting, or adding a new member to the stack, must be performed offline, that is,
outside Aruba Central On-Premises. These stacking related functions must be performed before or after
onboarding the stack to Aruba Central On-Premises depending on the function.

For example, you must create a stack offline before onboarding the stack to Aruba Central On-Premises.
For more information, see Managing an AOS-CX VSF Stack.

AOS-CX VSF Stack Related Functions Not Supported on Aruba Central On-Premises
The following stack related functions are not supported on Aruba Central On-Premises with AOS-CX
10.06 or earlier firmware versions:

n Creating a new stack
n Adding a new member to an existing stack
n Deleting a member from the stack
n Replacing a member with different part number
n Modifying standby member ID
n Adding, deleting, and modifying VSF links

Using AOS-CX VSX
Last synced data is not displayed on the VSX page, in Aruba Central On-Premises, if VSX synchronization
is not enabled.

Managing Firmware Upgrade
The following are the limitations while managing firmware upgrade of AOS-CX switches in Aruba Central
On-Premises:

n To upgrade an AOS-CX switch in Aruba Central On-Premises, a WAN connection with a minimum
speed of 2 Mbps is required. The upgrade activity will time out after a period of 60 minutes.

n Uploading AOS-CX switch images to Aruba Central On-Premises server for firmware upgrade fails.

Troubleshooting
The following are the limitations while troubleshooting AOS-CX switches in Aruba Central On-Premises:

n For AOS-CX 8320 and 8325 switch series, to use the remote console feature, you must enable SSH
server on the VRF that the switch uses to connect to Aruba Central On-Premises. You must add one
of the following commands in the template:
o If the switch is connecting to Aruba Central On-Premises using the inline default VRF, add ssh

server vrf default to the template.
o If the switch is connecting to Aruba Central On-Premises using the OOBM management VRF, add

ssh server vrf mgmt to the template.
n The Chassis Locate option, in the Analyze > Tools > Device Check tab, is not displayed for AOS-CX

8320 and 8325 switch series.
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n When an AOS-CX switch is in the Aruba Central On-Premises Managed mode, and at any instant both
device-generated automatic changes are detected and there are any pending changes in Aruba
Central On-Premises, then Aruba Central On-Premises discards the pending changes and absorbs
the device changes. Device-generated changes can be any of the following physical modifications:
o Adding or removing a VSF stack member
o Adding or removing a line card in the chassis
o Enabling VSX-sync when VSX enabled devices are managed by Aruba Central.

To view details of the changes that were discarded by Aruba Central On-Premises, check the Audit
Trail details.

Monitoring
In the monitoring pages in Aruba Central On-Premises, the IP address for the connected wired clients
on AOS-CX switches might not be displayed if the Client IP tracker is not enabled on the switch.

To enable Client IP tracker, perform one of following steps:

n Using Template—Add the client track ip command to the template at the device and VLAN level.
n Using MultiEdit mode—Add the client track ip command in the MultiEdit mode at the device and

VLAN level.

For more information, see Switch > Clients > Clients.

For more information on client track ip command, see the IP Client Tracker chapter in the AOS-CX IP
Routing Guide.

Provisioning Factory Default AOS-CX Switches
Switches that run default configuration either after shipped from a factory or a factory reset are
referred to as factory default switches. This topic describes the steps for provisioning factory default
switches in Aruba Central On-Premises:

n Step 1: Onboard the AOS-CX Switch to Aruba Central On-Premises
n Step 2: Assign the AOS-CX Switch to a Group
n Step 3: Connect the AOS-CX Switch to Aruba Central On-Premises
n Step 4: Provision the AOS-CX Switch to a Group
n Step 5: Verify the Configuration Status

Step 1: Onboard the AOS-CX Switch to Aruba Central On-Premises

n Log in to Aruba Central On-Premises.
n Add switches to Aruba Central—Adding switches to Aruba Central is now done through the HPE

GreenLake account home. For more information , see the Managing Devices and Subscriptions.
n Assign subscriptions—Assigning subscriptions to devices is available in the HPE GreenLake account

home. For more information about HPE GreenLake, see the Managing Devices and Subscriptions.
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Step 2: Assign the AOS-CX Switch to a Group
Before assigning a group, determine if the switch must be provisioned in a UI or template group. By
default, Aruba Central On-Premises assigns the factory default switches to default group. You can create
a new group and assign switch to the new group.

For more information on creating a group, see Groups.

To assign a device to a group, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization.

By default, the Network Structure tab is displayed.

3. Click the Device Preprovisioning tile.

The Device Preprovisioning page is displayed

4. From the list of devices, select the switches to assign.

If the selected device is already connected to Aruba Central On-Premises, the Move devices option will
not be available for the device.

5. Click the Move devices icon.
The Assign Group window is displayed.

6. Select the Destination Group from the drop-down list.
7. Click Move.

The selected devices are moved to the destination group. These devices will adopt the destination
group configuration.

To assign a device to a group from the Aruba Central On-Premises app, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization.

By default, the Network Structure tab is displayed.

3. Click the Groups tile.

The Groups page is displayed.

4. From the list of devices, select the switches to assign.

5. Click the Move devices icon.
The Move Devices page is displayed.

6. Select the Destination Group from the drop-down list.

7. Click Move.

The selected devices are moved to the destination group. These devices will adopt the destination
group configuration.
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Step 3: Connect the AOS-CX Switch to Aruba Central On-Premises
Switches with factory default configuration have very basic configuration for all ports in VLAN-1 that is
required for obtaining an IP address and automatic provisioning (ZTP). For ZTP, switches must have a
valid IP address, DNS, and NTP configuration. You must manually add either the serial number, MAC
address, or part number of the factory default switch in Aruba Central On-Premises

Step 4: Provision the AOS-CX Switch to a Group
When the switch connects to Central, if it is already added to the device inventory and is assigned a
subscription in Aruba Central On-Premises, Aruba Central On-Premises assigns it to a pre-assigned
group. If there is no pre-assigned group, Aruba Central On-Premises moves the device to the default
group. Based on your configuration requirements, you create a template group and assign the switch.

The following figure illustrates the provisioning step required for each group type.

Figure 67 AOS-CX Switch Provisioning Steps Per Group Type

If the switch is assigned to a new UI group, you can modify the configuration of switches using the UI
menu options under the Aruba Central On-Premises app > Manage > Devices > Switches. For more
information, see Configuring AOS-CX Switches in UI Groups.

Provisioning AOS-CX Switches in Template Groups
After assigning the switch to a template group, create a new configuration template. To create a
configuration template, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a template group.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Switches.
3. Click the AOS-CX or Config icon to view the switch configuration dashboard.

The tabs to configure switches using templates is displayed.
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4. Click the Templates tab.

The Templates table is displayed.

5. Click + to add a new template.

The Add Template window is displayed.

6. In the Basic Info tab, enter a name for the template in the Template Name field.
7. In the Device Type drop-down list, select Aruba CX.
8. Select the switch model and software version. You can specify any of the following combinations:

n ALL for both Model and Version—To apply the template to all switch models and all
supported switch software versions.

n ALL for Model and a software version for Version—To apply the template to all switch models
running the selected software version.

n ALL for Version and a switch model for Model—To apply the template to a switch model and
all software versions supported by the selected switch model.

n A switch model and a software version—To apply the template to a specific switch model and
the software version. The template created for a switch model and a software version takes
precedence over the template that is created for all platforms and versions.

9. Select the manufacturing part number of the switch in the Part Name drop-down list.

n The Part Name drop-down list is displayed only if you select a switch model in the Model drop-down list.
n If you select a specific switch model and part number, you can apply the template to a standalone switch

and not to a stack.
n If you select All in the Model drop-down list, or if you select a switch model and All in the Part Name

drop-down list, you can apply a template to both a standalone switch and stack.

10. Click Next.
The Template tab is displayed.

11. Build a new template by adding the output of the show running-config from the switch CLI in
the Template text box.

Ensure that the template text adheres to the guidelines listed in Important Points to Note.
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n You must manually create the template for the AOS-CX switch in a group, along with the password
in plaintext format. You can use the output of the show running-config command to create
the template. You can also add variables to use the same template for onboarding multiple AOS-
CX switches. For more information on variables, see Managing Variable Files.

n All switch templates must include a password command to set a password for the device. The
template cannot be saved without adding a password command. If the configuration that is
pushed from Aruba Central On-Premises to the device does not contain a password command,
the configuration push is aborted for the device and a log is added to the audit trail. For example,
if you add the password command in a condition block and the condition evaluates to false, the
configuration that is pushed will not contain the password command. For more information, see
Managing Password in Configuration Templates.

n For AOS-CX switches, you must configure the password only in plaintext. Also, the format of
password must be user admin group administrators password plaintext <string>.

n In the AOS-CX template configuration, the pound sign (#) is used for adding comments. When
using the banner motd code in the template configuration, use a delimiter such as at (@) symbol
or any other special character, than using the pound sign (#). Using the pound sign (#) with the
banner motd code will cause the code to be dropped when processing the template.

12. Click Save.

After you apply the configuration template, switches reboot and reconnect to Aruba Central On-
Premises with the new configuration.

Step 5: Verify the Configuration Status
To verify the configuration status, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a template group.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Switches.
3. Click the AOS-CX or Config icon to view the AOS-CX switch configuration dashboard..

The tabs to configure switches using templates is displayed. Follow one of the following options:
n To verify the configuration status for the template group, click Configuration Audit.

The Configuration Audit dashboard displays the number of devices with template and
configuration synchronization errors.

n To view configuration errors for a specific device, select a switch from the filter bar.

The Configuration Audit dashboard displays the number of template and configuration
synchronization errors for the device.

4. To view template errors, click View Template Errors under Template Errors.
5. To view configuration synchronization errors, click View Details under Configuration Status.
6. To compare running configuration and pending changes, click View under Config Comparsion

Tool.

Provisioning Pre-Configured AOS-CX Switches
Unlike factory default switches, locally managed switches and the switches with custom configuration
require one touch provisioning. On AOS-CX switches, Aruba Central On-Premises is enabled, by default,
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as their management platform, and therefore the switches connect to Aruba Central On-Premises
automatically.

To onboard a locally-managed or a pre-configured AOS-CX switch to Aruba Central On-Premises, follow
one of the following options:

n Connect the AOS-CX switch directly to Aruba Central On-Premises. Aruba recommends that you use
this option if you want to preserve the current configuration running on the switch. For more
information on this procedure, see the workflows described in this topic.

To manually connect the switch to Aruba Central On-Premises, you must configure the Aruba Central On-
Premises URL on the switch. Issue the following commands in the switch CLI.

config terminal

aruba-central <Aruba Central On-Premises URL> vrf mgmt

exit

Aruba does not recommend to manually provision the URL in a cloud deployment.

n Reset the switch configuration and use ZTP to provision the switch. You must first create a backup of
the configuration, then reset the switch using the erase all zeroize command in the CLI. This
initiates ZTP on the switch, enabling the switch to obtain the IP address from the option 43 sent by
the DHCP server and then connect to Aruba Central On-Premises.

Aruba Central On-Premises supports provisioning AOS-CX switches by using one of the following
methods:

n Pre-provisioning—In this workflow, a switch is added to the device inventory and assigned a group in
Aruba Central On-Premises before it connects to Aruba Central On-Premises.

n See Workflow 1—Pre-Provisioning an AOS-CX Switch.
n Onboarding connected switches—In this workflow, Aruba Central On-Premises onboards the switch

that attempts to connect and then assigns a group.
n See Workflow 2—Provisioning an AOS-CX Switch On-Demand.
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The following figure illustrates provisioning procedure for a pre-configured switch.

Figure 68 Provisioning Workflow for Pre-Configured AOS-CX Switches

Workflow 1—Pre-Provisioning an AOS-CX Switch
The pre-provisioning workflow includes the following steps:

n Step 1: Onboard the AOS-CX Switch to Aruba Central On-Premises
n Step 2: Assign the AOS-CX Switch to a Group
n Step 3: Provision the AOS-CX Switch to a Group
n Step 4: Verify the Configuration Status

Step 1: Onboard the AOS-CX Switch to Aruba Central On-Premises

n Log in to Aruba Central On-Premises.
n Add switches to Aruba Central—Adding switches to Aruba Central is available in the HPE GreenLake

account homel. For more information about HPE GreenLake, see the Managing Devices and
Subscriptions.

n Assign subscriptions—Assigning subscriptions to devices is available in the HPE GreenLake account
home. For more information about HPE GreenLake, see the Managing Devices and Subscriptions.
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Step 2: Assign the AOS-CX Switch to a Group
AOS-CX switches can be provisioned in a template group only. If you want to preserve the existing
configuration on the switch, Aruba recommends that you create a new group for the switch.

For more information on creating a group, see Groups.

To assign a device to a group, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization.

By default, the Network Structure tab is displayed.

3. Click the Device Preprovisioning tile.

The Device Preprovisioning page is displayed

4. From the list of devices, select the switches to assign.

If the selected device is already connected to Aruba Central On-Premises, the Move devices option will
not be available for the device.

5. Click the Move devices icon.
The Assign Group window is displayed.

6. Select the Destination Group from the drop-down list.
7. Click Move.

The selected devices are moved to the destination group. These devices will adopt the destination
group configuration.

To assign a device to a group from the Aruba Central On-Premises app, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization.

By default, the Network Structure tab is displayed.

3. Click the Groups tile.

The Groups page is displayed.

4. From the list of devices, select the switches to assign.

5. Click the Move devices icon.
The Move Devices page is displayed.

6. Select the Destination Group from the drop-down list.

7. Click Move.

The selected devices are moved to the destination group. These devices will adopt the destination
group configuration.

Step 3: Provision the AOS-CX Switch to a Group
When the switch connects to Aruba Central On-Premises, Aruba Central On-Premises automatically
assigns it to the pre-assigned group.

The following figure illustrates the provisioning steps for each group type.
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Figure 69 Switch Provisioning Steps Per Group Type

If the switch is assigned to a new UI group, you can modify the configuration of switches in a group
using the UI menu options under the Aruba Central On-Premises app > Manage > Device(s) >
Switches. For more information, see Configuring AOS-CX Switches in UI Groups.

You can also move switches to a UI group. When moving switches from an unprovisioned, template, or
UI group to another UI group, the existing switch configuration can be retained by selecting the Retain
CX-Switch Configuration check box on the Move Devices page. For more information, see Moving
AOS-CX Switches Between Groups.

If you have assigned the switch to a template group, you can import the existing configuration to a new
configuration template and apply this template to other devices in the group.

To create a configuration template using the existing configuration on the switch, complete the
following steps:

1. In the Aruba Central On-Premises app, set the filter to a template group.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Switches.
3. Click the AOS-CX or Config icon to view the switch configuration dashboard.

The tabs to configure switches using templates is displayed.

4. Click the Templates tab.

The Templates page is displayed.

5. Click + to add a new template.

The Add Template pop-up window is displayed.

6. In the Basic Info tab, enter a name for the template in the Template Name field.
7. In the Device Type drop-down list, select Aruba CX.
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8. Select the switch model and software version. You can specify any of the following combinations:
n ALL for both Model and Version—To apply the template to all switch models and all

supported switch software versions.
n ALL for Model and a software version for Version—To apply the template to all switch models

running the selected software version.
n ALL for Version and a switch model for Model—To apply the template to a switch model and

all software versions supported by the selected switch model.
n A switch model and a software version—To apply the template to a specific switch model and

the software version. The template created for a switch model and a software version takes
precedence over the template that is created for all platforms and versions.

9. Select the manufacturing part number of the switch in the Part Name drop-down list.

n The Part Name drop-down list is displayed only if you select a switch model in the Model drop-
down list.

n If you select a specific switch model and part number, you can apply the template to a standalone
switch and not to a stack.

n If you select All in the Model drop-down list, or if you select a switch model and All in the Part
Name drop-down list, you can apply a template to both a standalone switch and stack.

10. Click Next.
The Template tab is displayed.

11. Build a new template by adding the output of the show running-config from the switch CLI in
the Template text box.

Ensure that the template text adheres to the guidelines listed in Important Points to Note.
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n You must manually create the template for the AOS-CX switch in a group, along with the password
in plaintext format. You can use the output of the show running-config command to create
the template. You can also add variables to use the same template for onboarding multiple AOS-
CX switches. For more information on variables, see Managing Variable Files.

n All switch templates must include a password command to set a password for the device. The
template cannot be saved without adding a password command. If the configuration that is
pushed from Aruba Central On-Premises to the device does not contain a password command,
the configuration push is aborted for the device and a log is added to the audit trail. For example,
if you add the password command in a condition block and the condition evaluates to false, the
configuration that is pushed will not contain the password command. For more information, see
Managing Password in Configuration Templates.

n For AOS-CX switches, you must configure the password only in plaintext. Also, the format of
password must be user admin group administrators password plaintext <string>.

n For AOS-CX switches, the password configured in the template must match the password
configured on the switch. Aruba Central On-Premises cannot override the password that is
configured on the switch.

n In the AOS-CX template configuration, the pound sign (#) is used for adding comments. When
using the banner motd code in the template configuration, use a delimiter such as at (@) symbol
or any other special character, than using the pound sign (#). Using the pound sign (#) with the
banner motd code will cause the code to be dropped when processing the template.

12. Click Save.

After you apply the configuration template, switches reboot and reconnect to Aruba Central On-
Premises with the new configuration.

Step 4: Verify the Configuration Status
To verify the configuration status, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a template group.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Switches.
3. Click the AOS-CX or Config icon to view the switch configuration dashboard.

The tabs to configure switches using templates is displayed. Select one of the following options:
n To verify the configuration status for the template group, click Configuration Audit.

The Configuration Audit dashboard displays the number of devices with template and
configuration synchronization errors.

n To view configuration errors for a specific device, select a switch from the filter bar.

The Configuration Audit dashboard displays the number of template and configuration
synchronization errors for the device.

4. To view template errors, click View Template Errors under Template Errors.
5. To view configuration synchronization errors, click View Details under Configuration Status.
6. To compare running configuration and pending changes, click View under Config Comparsion

Tool.
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Workflow 2—Provisioning an AOS-CX Switch On-Demand
To dynamically provision switches on-demand, complete the following steps:

n Step 1: Add the AOS-CX Switch to Aruba Central On-Premises
n Step 2 Assign a Subscription to the AOS-CX Switch
n Step 3: Provision the AOS-CX Switch to a Group
n Step 4: Verify the Configuration Status

Step 1: Add the AOS-CX Switch to Aruba Central On-Premises
Add the switch to the Aruba Central On-Premises device inventory. For more information, see Managing
Devices and Subscriptions.

Step 2 Assign a Subscription to the AOS-CX Switch
To allow Aruba Central On-Premises to manage the switch, ensure that a valid subscription is assigned
to the switch.

Step 3: Provision the AOS-CX Switch to a Group
If the switch has a valid subscription assigned, Aruba Central On-Premises marks the switch as
unprovisioned. To preserve the switch configuration, move it to a new template group.

To move the device to a UI group, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization.

By default, the Network Structure tab is displayed.

3. Click the Groups tile.

The Groups page is displayed.

4. Select the device.
5. Click Import Group.

The Add Group page is displayed.

6. Enter a name for the group.

Configure a password for the group.

7. Click Add.

Aruba Central On-Premises imports the switch configuration to the new group.

You can also modify the configuration of switches in a group using the UI menu options under the
Aruba Central On-Premises app > Manage > Devices > Switches.

For more information, see Configuring AOS-CX Switches in UI Groups.

To move the device to a template group, complete the following steps:

1. Create a template group.
2. In the Aruba Central On-Premises app, set the filter to Global.
3. Under Maintain, click Organization.

By default, the Network Structure tab is displayed.

4. Click the Groups tile.

The Groups page is displayed.
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5. Select the AOS-CX switch from a group.

6. Click the Move devices icon.
The Move Devices page is displayed.

7. Select the Destination Group from the drop-down list.

8. Click Move.

The selected devices are moved to the destination group. These devices will adopt the
destination group configuration.

9. To build a new configuration template, complete the following steps:
a. In the Aruba Central On-Premises app, set the filter to a template group.

The dashboard context for the group is displayed.
b. Under Manage, click Devices > Switches.
c. Click the AOS-CX or Config icon to view the switch configuration dashboard.

The tabs to configure switches using templates is displayed.
d. Click the Templates tab.

The Templates page is displayed.
e. Click + to add a new template.

The Add Template pop-up window is displayed.
f. In the Basic Info tab, enter a name for the template in the Template Name field.
g. In the Device Type drop-down list, select Aruba CX.
h. Select the switch model and the software version to which you want to apply the new

template. You can specify any of the following combinations:
n ALL for both Model and Version—To apply the template to all switch models and all

supported switch software versions.
n ALL for Model and a software version for Version—To apply the template to all switch

models running the selected software version.
n ALL for Version and a switch model for Model—To apply the template to a switch model

and all software versions supported by the selected switch model.
n A switch model and a software version—To apply the template to a specific switch model

and the software version. The template created for a switch model and a software version
takes precedence over the template that is created for all platforms and versions.

i. Select the manufacturing part number of the switch in the Part Name drop-down list.

n The Part Name drop-down list is displayed only if you select a switch model in the Model
drop-down list.

n If you select a specific switch model and part number, you can apply the template to a
standalone switch and not to a stack.

n If you select All in the Model drop-down list, or if you select a switch model and All in the
Part Name drop-down list, you can apply a template to both a standalone switch and stack.

j. Click Next.
The Template tab is displayed.

k. Build a new template by adding the output of the show running-config from the switch
CLI in the Template text box.

Ensure that the template text adheres to the guidelines listed in the Important Points to
Note.
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n You must manually create the template for the AOS-CX switch in a group, along with the
password in plaintext format. You can use the output of the show running-config

command to create the template. You can also add variables to use the same template for
onboarding multiple AOS-CX switches. For more information on variables, see Managing
Variable Files.

n All switch templates must include a password command to set a password for the device. The
template cannot be saved without adding a password command. If the configuration that is
pushed from Aruba Central On-Premises to the device does not contain a password
command, the configuration push is aborted for the device and a log is added to the audit
trail. For example, if you add the password command in a condition block and the condition
evaluates to false, the configuration that is pushed will not contain the password command.
For more information, see Managing Password in Configuration Templates.

n For AOS-CX switches, you must configure the password only in plaintext. Also, the format of
password must be user admin group administrators password plaintext

<string>.
n For AOS-CX switches, the password configured in the template must match the password

configured on the switch. Aruba Central On-Premises cannot override the password that is
configured on the switch.

n In the AOS-CX template configuration, the pound sign (#) is used for adding comments. When
using the banner motd code in the template configuration, use a delimiter such as at (@)
symbol or any other special character, than using the pound sign (#). Using the pound sign
(#) with the banner motd code will cause the code to be dropped when processing the
template.

l. Click Save.

After you apply the configuration template, switches reboot and reconnect to Aruba Central
On-Premises with the new configuration.

Step 4: Verify the Configuration Status
To verify the configuration status, configure the following steps:

1. In the Aruba Central On-Premises app, set the filter to a template group.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Switches.
3. Click the AOS-CX or Config icon to view the switch configuration dashboard.

The tabs to configure switches using templates is displayed. Select one of the following options:
n To verify the configuration status for the template group, click Configuration Audit.

The Configuration Audit dashboard displays the number of devices with template and
configuration synchronization errors.

n To view configuration errors for a specific device, select a switch from the filter bar.

The Configuration Audit dashboard displays the number of template and configuration
synchronization errors for the device.

4. To view template errors, click View Template Errors under Template Errors.
5. To view configuration synchronization errors, click View Details under Configuration Status.
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6. To compare running configuration and pending changes, click View under Config Comparsion
Tool.

Monitoring-Only Mode for AOS-CX Switches
Aruba Central On-Premises allows you to add AOS-CX switches to UI groups in the monitoring-only
mode, for monitoring, reporting, and troubleshooting. For switches that are added in this mode, you
cannot make configuration changes using the UI group in which they are added. You can monitor these
switches from the monitoring pages in Aruba Central On-Premises. For more information on monitoring
switches, see Monitoring Switches and Switch Stacks.

For switches that are added in this mode:

n At the group level, the configuration icon is replaced by a note, which clarifies that this group is a
monitoring-only group.

n At the device level, the Manage > Device option will not be available.

To add AOS-CX switches to a monitoring-only group, complete the following steps:

1. In the Organization > Groups page, create a UI group.

In the Add Group page, select the Monitoring only for AOS-CX check box.

You can add both AOS-S and AOS-CX switches in the same monitoring-only UI group. To add AOS-
S switches in the monitoring-only group, select the Monitoring only for AOS-S check box.

2. Add the AOS-CX switches to the UI group.

For more information about creating UI groups and assigning switches to UI groups, see Groups.

Verifying the Monitoring-Only Mode of AOS-CX Switches
To verify whether the switches are added in the monitoring-only mode, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter, set the filter to a group containing at least one switch.

The dashboard context for the group is displayed.
n To select a switch in the filter, set the filter to Global or a group containing at least one switch.

2. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

The Config Status column in the Switches table displays Monitoring only for the switches that
are added in the monitoring-only mode.

Configuring AOS-CX Switches using Templates
Templates in Aruba Central On-Premises refer to a set of configuration commands that can be used by
the administrators for provisioning devices in a group. Configuration templates enable administrators
to apply a set of configuration parameters simultaneously to multiple switches in a group and thus
automate switch deployments.
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n To minimize configuration errors and troubleshoot device-specific configuration issues, Aruba
recommends that the device administrators familiarize themselves with the CLI configuration commands
available on AOS-CX switches.

n The vsf member 1 line must be present in the configuration template for stackable AOS-CX switches
running 10.07 or later versions. This is required to apply configuration to the switches. In case, if a
template is applied to the switch that does not contain the vsf member 1 line, then the switch will be
zeroized.

Creating a Group for Template-Based Configuration
For template-based provisioning, switches must be assigned to a group with template-based
configuration method enabled.

For more information, see Groups and Groups.

The Import Configuration As Template feature is supported only on AOS-CX switches running firmware
version 10.06 or later.

Creating a Configuration Template
To create a configuration template for switches, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a template group.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Switches.
3. Click the AOS-CX or Config icon to view the switch configuration dashboard.

The tabs to configure switches using templates is displayed.

4. Click the Templates tab.

The Templates page is displayed.

5. Click + to add a new template.

The Add Template window is displayed.

6. In the Basic Info tab, enter a name for the template in the Template Name field.
7. In the Device Type drop-down list, select Aruba CX.
8. Select the switch model and software version. You can specify any of the following combinations:

n ALL for both Model and Version—To apply the template to all switch models and all
supported switch software versions.

n ALL for Model and a software version for Version—To apply the template to all switch models
running the selected software version.

n ALL for Version and a switch model for Model—To apply the template to a switch model and
all software versions supported by the selected switch model.

n A switch model and a software version—To apply the template to a specific switch model and
the software version. The template created for a switch model and a software version takes
precedence over the template that is created for all platforms and versions.
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9. Select the manufacturing part number of the switch in the Part Number drop-down list.

n The Part Number drop-down list is displayed only if you select a switch model in the Model drop-
down list.

n If you select a specific switch model and part number, you can apply the template to a standalone
switch and not to a stack.

n If you select All in the Model drop-down list, or if you select a switch model and All in the Part
Number drop-down list, you can apply a template to both a standalone switch and stack.

10. Click Next.
The Template tab is displayed.

11. Build a new template by adding the output of the show running-config from the switch CLI in
the Template text box.

Ensure that the template text adheres to the guidelines listed in the Important Points to Note.

n You must manually create the template for the AOS-CX switch in a group, along with the password
in plaintext format. You can use the output of the show running-config command to create
the template. You can also add variables to use the same template for onboarding multiple AOS-
CX switches. For more information on variables, see Managing Variable Files.

n All switch templates must include a password command to set a password for the device. The
template cannot be saved without adding a password command. If the configuration that is
pushed from Aruba Central On-Premises to the device does not contain a password command,
the configuration push is aborted for the device and a log is added to the audit trail. For example,
if you add the password command in a condition block and the condition evaluates to false, the
configuration that is pushed will not contain the password command. For more information, see
Managing Password in Configuration Templates.

n For AOS-CX switches, you must configure the password only in plaintext. Also, the format of
password must be user admin group administrators password plaintext <string>.

n In the AOS-CX template configuration, the pound sign (#) is used for adding comments. When
using the banner motd code in the template configuration, use a delimiter such as at (@) symbol
or any other special character, than using the pound sign (#). Using the pound sign (#) with the
banner motd code will cause the code to be dropped when processing the template.

12. Click Save.

After you apply the configuration template, switches reboot and reconnect to Aruba Central On-
Premises with the new configuration.

Configuring AOS-CX VSX Using Templates

When configuring VSX pairs in AOS-CX switches, you must configure commands, such as vsx-sync, only on the
primary switch.

When configuring VSX using templates, assign a variable—for example, vsx_role—and configure it as
primary for the primary VSX switch. Using the vsx_role variable in an if check, ensure all vsx-sync
related configuration lines are applied only to the primary VSX switch. An example vsx-sync

configuration in a template is as follows:
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Example variables for a VSX switch pair:

n On the primary VSX switch:

vsx_ka_dst_ip = 10.0.1.2

vsx_ka_src_ip = 10.0.1.1

vsx_role = primary

n On the secondary VSX switch:

vsx_ka_dst_ip = 10.0.1.1

vsx_ka_src_ip = 10.0.1.2

vsx_role = secondary

Example of template configuration on Aruba Central On-Premisesfor VSX switches:

vsx

inter-switch-link lag 256

keepalive peer %vsx_ka_dst_ip% source %vsx_ka_src_ip% vrf default

role %vsx_role%

%if vsx_role=primary%

vsx-sync aaa acl-log-timer bfd-global bgp copp-policy dhcp-relay dhcp-

server dhcp-snooping dns icmp-tcp lldp loop-protect-global mac-lockout mclag-

interfaces neighbor ospf qos-global route-map sflow-global snmp ssh stp-global

time vsx-global

%endif%

Example of uploaded configuration from Aruba Central On-Premises to VSX switches:

n For the primary VSX switch:

vsx

inter-switch-link lag 256

keepalive peer 10.0.1.2 source 10.0.1.1 vrf default

role primary

vsx-sync aaa acl-log-timer bfd-global bgp copp-policy dhcp-relay dhcp-

server dhcp-snooping dns icmp-tcp lldp loop-protect-global mac-lockout mclag-

interfaces neighbor ospf qos-global route-map sflow-global snmp ssh stp-global

time vsx-global

n For the secondary VSX switch:

vsx

inter-switch-link lag 256

keepalive peer 10.0.1.1 source 10.0.1.2 vrf default

role secondary

Example of running configuration for the VSX switch pair:
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n On the primary VSX switch:

vsx

inter-switch-link lag 256

keepalive peer 10.0.1.2 source 10.0.1.1 vrf default

role primary

vsx-sync aaa acl-log-timer bfd-global bgp copp-policy dhcp-relay dhcp-

server dhcp-snooping dns icmp-tcp lldp loop-protect-global mac-lockout mclag-

interfaces neighbor ospf qos-global route-map sflow-global snmp ssh stp-

global time vsx-global

n On the secondary VSX switch:

vsx

inter-switch-link lag 256

keepalive peer 10.0.1.1 source 10.0.1.2 vrf default

role secondary

vsx-sync aaa acl-log-timer bfd-global bgp copp-policy dhcp-relay dhcp-

server dhcp-snooping dns icmp-tcp lldp loop-protect-global mac-lockout mclag-

interfaces neighbor ospf qos-global route-map sflow-global snmp ssh stp-

global time vsx-global

The VSX primary switch pushes the vsx-sync related configuration commands to the VSX secondary

switch. With this method, Aruba Central On-Premises and the native vsx-sync mechanism are
complementary and work hand in hand.

Password Requirements for Template-Based Configuration
The following table provides information on password requirements for the template-based
configuration in Aruba Central On-Premises.

n If a factory default AOS-CX switch connects to Aruba Central On-Premises, Aruba Central On-Premises
moves the device to the default group. The default switch password will be inherited by the default
group password. In this case, the switch will not contain the default password as mentioned in the table.

n After upgrading Aruba Central On-Premises to version 2.5.4, for security reasons, any plaintext
passwords, previously configured directly or using variables in the AOS-CX switch template, are hidden
and displayed as asterisk (*) symbols. The plaintext passwords, previously configured in the template,
directly or using variables, will work as expected; however, these plaintext passwords, displayed as
asterisk (*) symbols, will not work if you copy them to a new template. You must re-enter the plaintext
passwords in the new template for the template to work correctly.



Aruba Central On-Premises 2.5.7 | User Guide 561

Software
Versions

Status of
Switch in
Aruba
Central

Default Switch Password
Password Requirement in Aruba
Central

AOS-CX switches
running 10.05 or
earlier versions

Online or
Offline

admin or no password The password configured on the switch
must match with the password
configured in the template in Aruba
Central On-Premises. If the password do
not match, then Aruba Central On-
Premises will be unable to push the
template configuration to the switch.

AOS-CX switches
running 10.06 or
later versions

Offline admin or no password The password configured on the switch
need not match with the password
configured in the template in Aruba
Central On-Premises. The password
configured in the template in the
plaintext format will be used by the
switch after the configuration is
successfully pushed by Aruba Central On-
Premises.

Online admin or <SERIAL>_central
(For Example: CN406THG_
central)

Table 107: Password Requirements for AOS-CX Switches when using Templates

You must modify the default switch password when you log in to the switch for the first time.

Important Points to Note
Note the following points when adding configuration text to a template:

n The CLI syntax in the switch template must be accurate. Aruba recommends that you validate the
configuration syntax on the switch before adding it to the template text.

n Ensure that the command text indentation matches the indentation in the running configuration.
n The commands in the template are case-sensitive and cannot contain the % character. In the

template-based configuration, the % character is reserved and is used to denote variables.
n The following example illustrates the case discrepancies that the users must avoid in the template

text.

ssh server vrf default

ssh server vrf mGmt
vsf member 1

type jl660ab
vlan 1

spanning-tree

interface Mgmt
no shutdown

ip dhcp

interface 1/1/1

no shutdown

no routing

vlan access 1

interface 1/1/2

no shutdown

no routing
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vlan access 1

interface 1/1/3

no shutdown

no routing

vlan access 1

interface 1/1/4

no shutdown

no routing

vlan access 1

interface 1/1/5

no shutdown

no routing

vlan access 1

interface 1/1/6

no shutdown

no routing

vlan access 1

interface 1/1/7

no shutdown

no routing

vlan access 1

interface 1/1/8

no shutdown

no routing

vlan access 1

interface 1/1/9

no shutdown

no routing

vlan access 1

interface vlan 1

ip dhcp

!

!

!

!

!

https-server vrf default

https-server vrf MGMT

Configuring AOS-CX Switches in UI Groups
You can configure AOS-CX switches that are added to a UI group, using the UI options and MultiEdit
mode. You can pre-configure groups in the absence of switches. You can configure 4100i, 6100, 6200,
6300, 8320, 8325, 8360 Switch Series using UI options, MultiEdit mode, and templates. You can
configure 6405, 6410, and 8400 Switch Series using only templates.

To configure AOS-CX switches using templates, see Configuring AOS-CX Switches using Templates.

The UI options and MultiEdit mode are available only when the AOS-CX switches are added to a UI group. The
UI options and MultiEdit mode are not available when the AOS-CX switches are added to a template group.

To configure or view the properties of AOS-CX switches that are added to UI groups, complete the
following steps:
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1. In the Aruba Central On-Premises app, select one of the following options:
n To select a UI group in the filter, complete the following steps:

a. Set the filter to a UI group.

The dashboard context for the UI group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-CX or Config icon to view the AOS-CX switch configuration dashboard.

n To select a switch, complete the following steps:
a. Set the filter to Global or a UI group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click an AOS-CX switch under Device Name.

The dashboard context for the switch is displayed.

d. Under Manage, click Device.

The AOS-CX UI configuration page is displayed.

The following table describes the different configuration pages and their functions.

Feature Description

Properties Edit system property settings such as contact, location, time zone, and
administrator password. You can also select the VRF to be used and add the
DNS and NTP servers.
See Configuring System Properties on AOS-CX.

HTTP Proxy Configure to enhance security for device management. An IP address can be made
a proxy for all HTTP connections.
See Configuring HTTP Proxy on AOS-CX.

SNMP Add, edit, or delete the following:
n SNMP v2c communities
n SNMP v3 users
n Trap notifications for SNMP v2c and v3

See Configuring SNMP on AOS-CX.

Logging Add, edit, or delete logging servers to view event logs from the AOS-CX switches.
Configure FQDN or IP address, log severity level, and the VRF to be used for each of
the logging servers. Also configure the global level debug log severity.
See Configuring Logging Servers for AOS-CX.

Administrator Add, edit, or delete server groups to be used for authentication, authorization, and
accounting. You must also configure the protocol required to enable connection to
these server groups.
See Configuring AAA for AOS-CX.

Source Interface Add, modify, or delete source interface configuration for Central and User-based
tunneling interfaces for AOS-CX switches.
See Configuring Source Interface for AOS-CX.

Stacking Create stack, add stack members, modify VSF link, change the secondary
conductor, delete stack and delete stack members.

Table 108: Configuring AOS-CX Switches Provisioned in UI Groups
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Feature Description

See Configuring AOS-CX VSF Stacks Using UI Groups.

Static Routing Add, edit, or delete static routes manually and configure destination IP addresses
and next hop values, VRF, and the administrative distance. You can add different
static routes for different VRFs on the switch.
See Configuring Static Routing on AOS-CX.

Ports & Link
Aggregations

View and edit port settings such as description, VLAN mode, speed duplex, routing,
and the operational status of the port. Add, edit, or delete LAGs by combining
different ports and configuring the speed duplex, VLAN mode, aggregation mode,
and the operational status of the LAG.
See Configuring Ports and LAGs on AOS-CX.

Port Profiles Configure interface-specific commands at the group level through an editor.
See Configuring Switch Ports on AOS-S Switches.

Authentication
Servers

Add, edit, or view the RADIUS and TACACS servers for authentication. Add settings
such as FQDN or IP address of the servers, authentication port number, response
timeout, retry count, and the VRF to be used when communicating with the
servers.
See Configuring Authentication Servers on AOS-CX.

Authentication View or edit details about 802.1X and MAC authentication methods. Configure the
precedence order and other parameters such as reauthentication timeout, cached
reauthentication timeout, and quiet period.
See Configuring Authentication on AOS-CX.

Access Control View or add access policies and rules to permit or deny passage of traffic.
See Configuring Access Control on AOS-CX.

User-Based
Tunneling

Enable to use GRE to tunnel ingress traffic on a switch interface to a gateway. For
further processing, provide a centralized security policy using per-user
authentication and access control to ensure consistent access and permissions.
See Configuring User-Based Tunneling for AOS-CX.

Client Roles Configure to allow administrators to assign network access to clients. The network
admin can create configuration profiles (roles) and associate them to clients.
See Configuring Client Roles for AOS-CX.

VLANs Add, edit, delete, or view VLANs, and associated parameters such as type of
IP assignment, operational status, IP address of the DHCP relay.
See Configuring VLANs on AOS-CX.

Loop Prevention Enable or disable loop protection and spanning tree protocol, and associated
parameters such as the mode and priority. Enable or disable various MSTP mode-
related settings such as BPDU filter, BPDU protection, admin edge, and root guard.
See Configuring Loop Prevention on AOS-CX.

2. To enable MultiEdit mode, move the MultiEdit toggle switch to the on position.

The Device-Level Configuration page is displayed with the list of devices displayed in the
Devices table.



Aruba Central On-Premises 2.5.7 | User Guide 565

At the device level, the Devices table lists only the switch that you have selected. Also, a pop-up is
displayed on the bottom-right corner of the page with the options View Config, Edit Config, and
Express Config.

Search for a switch by entering a search query in the Contextual Search Engine field.

For more information about search queries, see Using Device Search on AOS-CX.

The following table describes the options available in the MultiEdit mode of configuring AOS-CX
switches.

Feature Description

MultiEdit View and edit configuration on the AOS-CX switches using the CLI syntax. You can also
apply predefined set of configuration settings such as NAE to the switches.
See Using MultiEdit View for AOS-CX.

View Config View configuration of AOS-CX switches and find differences in the configuration across
switches.
See Viewing Configuration Using MultiEdit on AOS-CX.

Edit Config Edit configuration for one or more AOS-CX switches in the MultiEdit mode. Edit the entire
configuration in a familiar looking CLI with syntax checking, colorization, and command
completion.
See Editing Configuration Using MultiEdit on AOS-CX.

Express
Config

Apply predefined set of configuration settings such as NAE scripts and device profile to a
single or multiple switches.
See Express Configuration Using MultiEdit on AOS-CX.

Device
Search

Search for AOS-CX switches in the Devices table, in the MultiEdit mode, using search
queries such as device attributes, wildcard characters, Boolean operators, and by
grouping characters.
See Using Device Search on AOS-CX.

Table 109: Configuring AOS-CX Switches Provisioned in UI Groups using the MultiEdit Mode

3. To view configuration status, pending changes, and local overrides on the switches, click
Configuration Status.

This page allows you to commit the pending changes in a configuration. At the device level, this
page allows you to change the auto-commit state of the switch.

For more information, see Using Configuration Status on AOS-CX.

Multiple Browser Tab Support
You can open multiple browser tab sessions of the same Aruba Central On-Premises instance with
different switch group or device pages opened simultaneously. For example, you can open the group
configuration of a switch in one browser tab and the device-level configuration of a switch in another
browser tab. Aruba Central On-Premises stores the data from the different browser tabs separately.

However, if you edit the configuration of one AOS-CX switch in the MultiEdit mode in two different
browser tab sessions, and try to save the configuration one after the other, the following events occur:

1. The configuration that you save first in the editor in any of the two browser tabs is saved on the
switch.
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2. When you try to save the configuration in the editor in the other browser tab, Aruba Central On-
Premises displays a warning that the configuration has been changed outside the current editor.

3. If you ignore the warning and continue to save the configuration, Aruba Central On-Premises
overwrites the changes saved earlier with the current changes.

If you save any changes in the MultiEdit mode and the changes do not reflect on the switch, check the
Audit Trail details for any errors in the configuration sync.

UI Group Configuration Feature Matrix
The following table lists the UI group configurations supported on AOS-CX switches at the group and
device levels.

n All UI group configuration options are supported at the group level on all AOS-CX switches unless
otherwise specified.

n Stacking is supported only on AOS-CX 6200 and 6300 switch series at the group level.

Feature/Switch
Series 4100i 6100 6200 6300 8320 8325 8360

VRF Support Default VRF only Default and Management VRFs

Properties Yes Yes Yes Yes Yes Yes Yes

HTTP Proxy Yes Yes Yes Yes Yes Yes Yes

SNMP Yes Yes Yes Yes Yes Yes Yes

Logging Yes Yes Yes Yes Yes Yes Yes

Administrator
(AAA)

Yes Yes Yes Yes Yes Yes Yes

Source Interface Yes Yes Yes Yes Yes Yes Yes

Stacking No No No No No No No

Static Routing Yes Yes Yes Yes Yes Yes Yes

Ports & Link
Aggregations

Yes Yes Yes Yes Yes Yes Yes

Authentication
Servers

Yes Yes Yes Yes Yes Yes Yes

Authentication Yes Yes Yes Yes No No No

Access Control Yes Yes Yes Yes Yes Yes Yes

Dynamic
Segmentation

No No No Yes No No No

Table 110: AOS-CX UI Group Configuration Features Supported At The Device Level
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Feature/Switch
Series 4100i 6100 6200 6300 8320 8325 8360

Client Roles Yes Yes Yes Yes No No No

VLANs Yes Yes Yes Yes Yes Yes Yes

Loop Prevention Yes Yes Yes Yes Yes Yes Yes

Client Events-
Authentication and
DHCP

Yes Yes Yes Yes No Yes Yes

Important Points to Note

n Source Interface:
o At the group level, you can configure source interface only on ports or LAGs. However, you must

enable routing on the ports or LAGs.
o At the device level, you can configure source interface on ports, LAGs, VLANs, or an IPv4 address.

However, you must enable routing and configure an IP address on the ports, LAGs, or VLANs at
the device level.

n Client Roles:
o To enable the Gateway cluster and Gateway Role fields, you must enable the Dynamic

Segmentation feature and in turn configure user-based tunneling source interface.
n Loop Prevention:

o MCLAG is not supported in Aruba Central On-PremisesUI, although it is supported on the switch.
o ISL links for loop prevention can be configured in Aruba Central On-Premises UI, however, it might

result in switch config errors.
n Client Events:

o The information related to client authentication is not generated for AOS-CX 8400 switch series.

Configuration Workflow for AOS-CX Switches in UI Groups
The following figure displays the workflow to configure AOS-CX switches using UI options.
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Figure 70 UI Configuration Workflow for AOS-CX Switches

Workflow Steps
Following are the steps to configure AOS-CX switches using UI options:

1. Provision an AOS-CX switch to a UI group in Aruba Central On-Premises.

For more information, see Getting Started with AOS-CX Deployments.

When you add AOS-CX switches to a UI group, you can configure them using the following
options:
n Various UI options
n MultiEdit mode

2. Configure the switch using the different configuration options available on the UI.

You can add, edit, or delete configurations using the UI options.

For more information, see Configuring AOS-CX Switches in UI Groups.

3. Configure the switch in the MultiEdit mode.
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The MultiEdit mode offers a CLI syntax-based configuration functionality for AOS-CX switches. You
can view or edit the running configuration on the switch or apply express configuration, as
described in the following points:
n Edit Config—Edit switch configuration using the CLI syntax. You can edit the configuration of

switches. After you edit the configuration, you can view the difference between the running
configuration and the edited configuration in the same window. See Editing Configuration
Using MultiEdit on AOS-CX.

n Express Config—Apply a predefined set of configuration settings to switches using this option
for device profile and NAE configurations. See Express Configuration Using MultiEdit on AOS-
CX.

n View Config—View the running configuration on the switch using this option. The changes
made on the UI options, Edit Config, or the Express Config pages will appear on this page only
if the Auto-Commit state is on or if the changes are committed manually. See Viewing
Configuration Using MultiEdit on AOS-CX.

For more information, see Using MultiEdit View for AOS-CX

4. Depending on the Auto-Commit state of the switch, you can either view the configuration changes
immediately or commit the changes first and then view the configuration changes as described
below:
n If the Auto-Commit state is on, Aruba Central On-Premises applies the configuration changes

immediately to the switch. You can view the configuration on the View Config page in the
MultiEdit mode.

n If the Auto-Commit state is off, you must manually commit changes to the switch and then
view the configuration.

For more information, see Using Configuration Status on AOS-CX.

5. When the Auto-Commit state is off, check whether there are any pending changes to be applied
to the switch, in the Configuration Status page. Commit any pending configuration changes to the
switch and view the updated configuration.

Managing Configuration Overrides
Aruba Central On-Premises supports the following two levels of configuration hierarchy:

n Group-level—When you add a switch to a group, or move a switch from one group to, another, the
switch inherits the configuration of the group. Any configuration changes made at the group-level are
applied to the devices in the group. You can also pre-configure groups before adding switches.

Only configurations that are supported at the group-level are applied to the devices. The configurations that
are supported only at the device-level are preserved.

n Device-level—Any modifications made at the device-level override the configurations inherited from
the group. Local overrides are those modifications that you make on a particular device in a group.
Once a local override exists on a device, then any configuration changes performed at the group level
will not be applied or inherited to that device.

Configuration overrides are applicable to only those parameters, which are present at both group and
device levels.
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Managing Passwords for Groups and Devices using UI groups
In Aruba Central On-Premises, you can set a password for UI groups when creating a new group. This
group password is used to onboard the AOS-CX switches to the group. The group password must match
with the device password to onboard the device successfully to the group. For more information, see
Groups.

You can use the Properties page to change the administrator password for groups and devices. If you
set different password at the device-level, then the device can no longer be managed at the group-level.
For more information, Configuring System Properties on AOS-CX.

If you upgrade Aruba Central On-Premises from earlier versions to the latest version, the administrator
password is considered blank. Aruba Central On-Premises prompts the user to specify an administrator
password for the devices in the group. You cannot make any configuration update until a new password
is set.

Configuring System Properties on AOS-CX
From the Properties page, you can view or configure system property settings such as contact, location,
timezone, administrator username, and administrator password for AOS-CX switches. In addition, you
can select management VRF or default VRF, and configure DNS and NTP servers for the selected VRF.

To edit system properties, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter, complete the following steps:

a. Set the filter to a group.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-CX or Config icon to view the switch configuration dashboard.

n To select a switch in the filter, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click an AOS-CX switch under Device Name.

The dashboard context for the switch is displayed.

d. Under Manage, click Device.

The AOS-CX UI configuration page is displayed.

2. Click System > Properties.

The Edit Properties page is displayed.

3. Configure the parameters described in Table 111.
4. Click Save.
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Name Description Value

Name Name of the switch. This field is available
only at the device level.

You can enter up to a maximum of 32
characters including letters, numbers, and
special characters, except question mark (?)
and double quotes (").

Contact Contact details for the switch. Name, Email address, or phone number.
You can enter up to a maximum of 128
characters including letters, numbers, and
special characters, except question mark (?)
and double quotes (").

Location Location of the switch. You can enter up to a maximum of 128
characters including letters, numbers, and
special characters, except question mark (?)
and double quotes (")
For example: Portland, Oregon.

Timezone The time zone corresponding to the
location of the switch.

Time zone selected
from the drop-down.

VRF The VRF to be used for communicating with
DNS and NTP servers.

NOTE: If you change the VRF setting, then
the existing DNS and NTP server settings
will be removed.

Default or Management OOBM

NOTE: Management VRF is not supported
on the AOS-CX 4100i and 6100 switch
series.

DNS servers The IP address of DNS servers for the
selected VRF. Click + to add another DNS
server.
You can add up to three servers.

IPv4 address or IPv6 address

NTP servers The IP address of NTP servers for the
selected VRF. Click + to add another NTP
server.
You can add up to three servers.

IPv4 address or IPv6 address

Administrator
password

The password for the administrator
username.

NOTE: To manage devices in the group, the
password must be same at group and
device-levels.

You can enter up to a maximum of 32
characters including letters, numbers, and
special characters except question mark (?)
and double quotes (").

The following table describes the AOS-CX switch parameters.
Table 111: Switches Properties

Configuring HTTP Proxy on AOS-CX
HTTP proxy enhances security for device management. An IP address can be made a proxy for all HTTP
connections. If your network requires a proxy server for Internet access, ensure that you configure the
HTTP proxy on AOS-CX switch to download the image from the cloud server. After setting up the HTTP
proxy settings, the AOS-CX switch connects to Aruba Central On-Premises or OpenDNS server through a
secure HTTP connection.

To configure HTTP proxy on the AOS-CX switch, complete the following steps:
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1. In the Aruba Central On-Premises app, select one of the following options:
n To select a group in the filter, complete the following steps:

a. Set the filter to a group.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-CX or Config icon to view the AOS-CX switch configuration dashboard.

2. Click System > HTTP Proxy.

The Edit HTTP Proxy page is displayed.

3. Configure the parameters described in Table 112.
4. Click Save.

Parameter Description Value

FQDN or
IP address

FQDN or IPv4 address of the HTTP proxy
location.

IPv4 address in the x.x.x.x format or FQDN
of the proxy location.

Port Port number of the switch. Default value used for port is 80.

VRF VRF on which the system is configured. Default and Management.

The following table describes the HTTP proxy parameters.
Table 112: HTTP Proxy parameters

Configuring SNMP on AOS-CX
Simple Network Management Protocol (SNMP) SNMP is a TCP/IP standard protocol for managing
devices on IP networks. It is used mostly in network management systems to monitor network-attached
devices for events that require administrative attention.

From the SNMP page, you can perform the following actions:

n Enable or disable SNMP on the switch
n Select the VRF on which you want to configure SNMP
n Configure SNMP versions v2c or v3
n Configure communities and traps

For more information, see the following topics:

n Configuring SNMPv2c on AOS-CX
n Configuring SNMPv3 on AOS-CX

Configuring SNMPv2c on AOS-CX
You can configure SNMPv2c community settings and trap destinations through the UI.

To configure SNMPv2c on switch, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter, complete the following steps:

a. Set the filter to a group.

The dashboard context for the group is displayed.
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b. Under Manage, click Devices > Switches.
c. Click the AOS-CX or Config icon to view the switch configuration dashboard.

n To select a switch in the filter, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click an AOS-CX switch under Device Name.

The dashboard context for the switch is displayed.

d. Under Manage, click Device.

The AOS-CX UI configuration page is displayed.

2. Click System > SNMP.

The SNMP page is displayed.

3. Enable SNMP on the switch by moving the SNMP toggle to the on position.
4. Select the VRF on which you want to configure SNMP by selecting one or both of the following

check boxes under Enable SNMP on the selected VRF:
n Default VRF
n Management VRF

Management VRF is not supported on the AOS-CX 4100i and 6100 switch series.

5. Select v2c from the Mode drop-down list.

The Read Community and Trap Destination tables are displayed.

Adding an SNMP Community
You can add SNMP communities to restrict access to the switch from the SNMP management stations.
The default community name is Public.

To add an SNMP community, complete the following steps:

1. In the Read Community table, click the + add icon.

A new row is added in the table.

2. Type the name of the community in the new row.

You can enter up to a maximum of 32 characters including letters, numbers, and special
characters.

3. Click Save.

Editing an SNMP community
To edit an SNMP community, point to the row for the SNMP community, and click the edit icon.

You can edit an SNMP community name only before saving it to Aruba Central On-Premises. If the
SNMP community is saved, then it cannot be edited.

Deleting an SNMP Community
To delete an SNMP community, point to the row for the SNMP community, and click the delete icon.
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If you delete an SNMP community, trap destinations that belong to the community will also get deleted.

Adding a Trap Destination
You can add trap destinations to send notifications to SNMP management stations.

When adding a trap destination, you cannot edit the SNMP toggle switch and the Enable SNMP on the
selected VRF options.

To add a trap destination, complete the following steps:

1. In the Trap Destination table, click the + add icon.

A new row is added in the table.

2. Configure the following parameters:
n IP Address—Enter a valid IPv4 or IPv6 address of the SNMP host.
n VRF—Select the available VRF on the switch from the drop-down.
n Community—Select the name of the community from the drop-down.

3. Click Save.

Editing a Trap Destination
To edit a trap destination, point to the row for the trap destination, and click the edit icon.

You can edit only the community name.

Deleting a Trap Destination
To delete a trap destination, point to the row for the trap destination, and click the delete icon.

Configuring SNMPv3 on AOS-CX
SNMPv3 provides a secured access to SNMP management stations using authentication and privacy
protocols. You can add SNMPv3 user and configure notification settings using UI groups.

To configure SNMPv3 on switch, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter, complete the following steps:

a. Set the filter to a group containing at least one switch.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-CX icon to view the switch configuration dashboard.

n To select a switch in the filter, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click a switch under Device Name.

The dashboard context for the switch is displayed.
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d. Under Manage, click Device.

The tabs to configure the switch is displayed.

2. Click System > SNMP.

The SNMP page is displayed.

3. Enable SNMP service on the switch by moving the SNMP toggle to the on position.

4. Select the VRF on which you want to configure SNMP by selecting one or both of the following
check boxes under Enable SNMP on the selected VRF:
n Default VRF
n Management VRF

Management VRF is not supported on the AOS-CX 4100i and 6100 switch series.

5. Select v3 from the Mode drop-down list.

The Users and Trap Destination tables are displayed.

Adding an SNMPv3 User
You can add SNMPv3 users to provide secured access to SNMP management stations.

To add an SNMPv3 user, complete the following steps:

1. In the Users table, click the + add icon.

A new row is added in the table.

2. Configure the following parameters:
n Name—Enter the name of the SNMPv3 user.
n Authentication Mode—Select either md5 (Message Digest) or sha (Secure Hash Algorithm) as

the authentication mode to provide secured access to the user. After selecting the
authentication mode, enter the authentication password in the adjacent text box. The
password must be 8 to 32 characters long, and can contain alphabets, numbers, and special
characters.

n Privacy Mode—Select aes (Advanced Encryption Standard) or des (Data Encryption Standard)
as the privacy mode to provide secured access to the user. After selecting the privacy mode,
enter the privacy password in the adjacent text box. The password must be 8 to 32 characters
long, and can contain alphabets, numbers, and special characters.

3. Click Save.

Editing an SNMPv3 User
To edit an SNMPv3 user, point to the row for the user, and click the edit icon.

You can edit an SNMPv3 user only before saving it to Aruba Central On-Premises. If the user is saved to Aruba
Central On-Premises, then it cannot be edited.

Deleting an SNMPv3 User
To delete an SNMPv3 user, point to the row for the user, and click the delete icon.

If you delete the user, then the trap destination where the user is added will also get deleted.
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Adding a Trap Destination
You can add trap destinations to send notifications to SNMP management stations.

When adding a trap destination, you cannot edit the SNMP toggle switch and the Enable SNMP on the
selected VRF options.

To add a trap destination, complete the following steps:

1. In the Trap Destination table, click the + add icon.

A new row is added in the table.

2. Configure the following parameters:
n IP Address—Enter a valid IPv4 or IPv6 address of the SNMP host.
n VRF—Select the available VRF on the switch from the drop-down.
n Name—Select the user to whom the notifications should be sent.

3. Click Save.

Editing a Trap Destination
To edit a trap destination, point to the row for the trap destination, and click the edit icon.

You can only edit the user name.

Deleting a Trap Destination
To delete a trap destination, point to the row for the trap destination, and click the delete icon.

Configuring Logging Servers for AOS-CX
Logging allows you to add syslog servers where the event log messages related to the AOS-CX switches
are saved. For each of the syslog server you add, you can configure the severity of the event logs to be
saved on these servers. You can also configure the severity level for the debug logs by configuring the
severity at the global level. However, you must add a minimum of one syslog server to configure the
global severity level.

To configure logging servers, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a group in the filter, complete the following steps:

a. Set the filter to a group.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-CX or Config icon to view the AOS-CX switch configuration dashboard.

n To select a switch, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click an AOS-CX switch under Device Name.

The dashboard context for the switch is displayed.
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d. Under Manage, click Device.

The AOS-CX UI configuration page is displayed.

2. Click System > Logging.

The Logging page is displayed.

3. Select the debug syslog severity level at the global level from the Level drop-down list.

This severity level is applied to the debug logs that are saved on the syslog servers. You must add
a minimum of one event syslog server before configuring the global severity level.

4. In the Logging Servers table, click the + add icon to add a logging server and configure the
following parameters described in Table 113.

5. Click Apply and then click Save.
6. To edit parameters of a logging server, select the row in the Logging Servers table and click the

edit icon.

The Edit Logging Server page is displayed. You can edit only the event log severity level and the
VRF.

7. Click Apply, and then click Save.
8. To delete the syslog server, select the row in the Logging Servers table and click the delete icon.
9. Click OK in the confirmation pop-up window, and then click Save.

The following table describes the logging server parameters.

Parameters Description Value

FQDN or
IP address

FQDN hostname or
IP address of the logging
server.

IPv4 address in the x.x.x.x format or hostname of the
server.

Level Severity level of the
events that the logging
server must log.

Following severity levels are supported:
n Emergency
n Critical
n Alert
n Error
n Warning
n Notice
n Information
n Debug

VRF VRF on which the logging
server is configured.

Default or Management.

NOTE: Management VRF is not supported on the AOS-CX
4100i and 6100 switch series.

Table 113: Logging Server Parameters

Configuring AAA for AOS-CX
Authentication, Authorization, and Accounting (AAA) is a security framework to authenticate users,
authorize the type of access based on user credentials, and record authentication events and
information about the network access and network resource consumption.

From the Administrator page, you can configure the following AAA properties:
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n Authentication using TACACS, RADIUS, and local server groups.
n Authorization using TACACS and local server groups.
n Accounting using TACACS, RADIUS, and local server groups.

To configure AAA properties for AOS-CX switches, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter, complete the following steps:

a. Set the filter to a group.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-CX or Config icon to view the switch configuration dashboard.

n To select a switch in the filter, complete the following steps:
a. Set the filter to Global or a group containing at least one AOS-CX switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click an AOS-CX switch under Device Name.

The dashboard context for the switch is displayed.

d. Under Manage, click Device.

The AOS-CX UI configuration page is displayed.

2. Click System > Administrator.
The Administrator page is displayed with Authentication, Authorization, and Accounting tables.

3. You can configure authentication, authorization, and accounting by completing the following
steps from the respective tables:
n To configure authentication, click + in the Authentication table and configure the parameters

described in Table 114.
n To configure authorization, click + in the Authorization table and configure the parameters

described in .
n To configure accounting, click + in the Accounting table and configure the parameters

described in .

4. Click Save.

Name Description Value

Protocol The type of protocol to enable connection to the
server groups for authentication. You can add one or
more protocols by clicking + in the Authentication
table.

Console, Default, HTTPS
Server, and SSH.

Server Groups The list of server groups to be used for authentication.
You can select one server group at a time. To add the
next server group, click + either in the protocol row or
any of the server group rows.

TACACS, RADIUS, and Local.

The following table describes the parameters to configure authentication.
Table 114: Authentication Parameters
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Name Description Value

The server groups are accessed in the top-down
order. You can rearrange the order by dragging the
server group to a different position using the drag-
and-drop icon.

Name Description Value

Protocol The type of protocol to enable connection to the
server groups for authorization. You can add one or
more protocols by clicking + in the Authorization table.

Console, Default, and SSH.

Server Groups The list of server groups to be used for authorization.
You can select one server group at a time. To add the
next server group, click + either in the protocol row or
any of the server group rows.
The server groups are accessed in the top-down
order. You can rearrange the order by dragging the
server group to a different position using the drag-
and-drop icon.

TACACS, Local, and None.

The following table describes the parameters to configure authorization.
Table 115: Authorization parameters

Name Description Value

Protocol The type of protocol to enable connection to the
server groups for accounting. You can add one or
more protocols by clicking + in the Accounting table.

Console, Default, HTTPS
Server, and SSH.

Server Groups The list of server groups to be used for accounting.
You can select one server group at a time. To add the
next server group, click + either in the protocol row or
any of the server group rows.
The server groups are accessed in the top-down
order. You can rearrange the order by dragging the
server group to a different position using the drag-
and-drop icon.

TACACS, RADIUS, and Local.

The following table describes the parameters to configure accounting.
Table 116: Accounting Parameters

Deleting AAA properties
To delete authentication, authorization, or accounting, point to the row for the AAA property in the
respective tables, and click the delete icon.

Configuring Source Interface for AOS-CX
Source interface allows you to configure a single source interface for a service so that all traffic routed
through the switch is sent with the same IP address. The IP address is configured on the ports, LAGs, or
VLANs at the device level.

You can add, modify, or delete source interface configuration in Aruba Central On-Premises. At the
group level, Aruba Central On-Premises allows you to configure only the port or LAG information for the
interface. However, at the device level, you can also configure VLANs and IP address for the interface.
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Aruba Central On-Premises supports only Central and User-based tunneling source interfaces in the UI.
However, in the MultiEdit mode, you can configure source interfaces for other protocols such as, DNS,
NTP, and PTP. The source interfaces that you add in the MultiEdit mode (other than Central and User-
based tunneling) will not appear in the Source Interface page at the device level.

When you downgrade a switch from AOS-CX 10.07.0020 (with Central as source interface) to an earlier
firmware version where source interface is not supported, Aruba Central does not allow the configuration to
sync and displays a configuration conflict.

In such instances, you must delete the conflicting source interface configuration for Aruba Central to sync the
configuration.

Switch
Platform

Supported Source Interfaces

10.05, 10.06 10.07 10.08

AOS-CX 4100i
Switch Series

-N/A- -N/A- n Central and User-based
tunneling

n IP address, VLAN
configuration only

AOS-CX 6100
Switch Series

-N/A- n Central only
n IP address, VLAN

configuration only

-N/A-

AOS-CX 6200
Switch Series

n User-based tunneling
only

n IP address, VLAN
configuration only

n Central and User-based
tunneling

n IP address, VLAN
configuration only

-N/A-

AOS-CX 6300
Switch Series

User-based tunneling only Central and User-based
tunneling

-N/A-

AOS-CX 8320
Switch Series

-N/A- Central only -N/A-

AOS-CX 8325
Switch Series

-N/A- Central only -N/A-

AOS-CX 8360
Switch Series

-N/A- Central only -N/A-

The following table describes the supported source interfaces for AOS-CX switch series.
Table 117: Supported AOS-CX Switch Series

To add a source interface, you must configure the following at the device level:

n Enable routing for ports and LAGs.
n Configure an IP address for the ports, LAGs, and VLANs.
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Adding a Source Interface
To add a source interface, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter, complete the following steps:

a. Set the filter to a group.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-CX or Config icon to view the switch configuration dashboard.

n To select a switch in the filter, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click an AOS-CX switch under Device Name.

The dashboard context for the switch is displayed.

d. Under Manage, click Device.

The AOS-CX UI configuration page is displayed.

2. Click System > Source Interface.

The Source Interface page is displayed with a list of source interfaces that are configured.

3. In the Source Interface table, click the + add icon to add a source interface and configure the
parameters described in Table 118.

When both Central and User-based tunneling source interfaces are added for a switch, the + add icon is
disabled.

4. Click Save.

The source interface information is displayed in the Source Interface table.

Name Description Value

Interface The interface or the service name.
You can configure only two interfaces at any
given time.

Central or User-based tunneling

Port/LAG Type of interface you want to configure.
The name of this field is applicable only at the
group level.
At the device level, the field name is
Port/LAG/VLAN/Address.

n At the group level—Port or LAG
n At the device level—Port, LAG, VLAN, or

Address

Port name Port number for the source interface.
Applicable when you select Port in the
Port/LAG drop-down at the group level or
Port/LAG/VLAN/Address drop-down at the
device level.

Select a port from the drop-down.

NOTE:

n At the group level—Only the ports that

The following table describes the source interface parameters.
Table 118: Configuring and Viewing Source Interface Parameters
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Name Description Value

have routing enabled at the group level
are available in this drop-down.

n At the device level—Only the ports that
have routing enabled and IP address
configured on the ports at the device level
are listed in this drop-down.

LAG name LAG name for the source interface.
Applicable when you select Port in the
Port/LAG drop-down at the group level or
Port/LAG/VLAN/Address drop-down at the
device level.

Select a LAG from the drop-down.

NOTE:

n At the group level—Only the LAGs that
have routing enabled at the group level
are available in this drop-down.

n At the device level—Only the LAGs that
have routing enabled and IP address
configured on the LAGs at the device level
are listed in this drop-down.

VLAN ID VLAN ID for the source interface.

NOTE:

n Available only at the device level.
n Applicable when you select VLAN in the

Port/LAG/VLAN/Address drop-down at
the device level.

Select a VLAN from the drop-down.

NOTE:

n Only the VLANs that have an IP address
configured at the device level are listed in
this drop-down.

n The IP address must be a static IP address.
DHCP server is not supported.

Address IP address for the source interface.

NOTE:

n Available only at the device level.
n Applicable when you select Address in the

Port/LAG/VLAN/Address drop-down at
the device level.

IPv4 address

VRF Type of VRF for the source interface.

NOTE: You can configure the User-based
tunneling interface only on the Default VRF.

Default or Management

NOTE: Management VRF is not supported on
the AOS-CX 4100i and 6100 switch series.

Editing a source interface
To edit a source interface, point to the row for the source interface, and click the edit icon. You can
select only one source interface at a time for editing.

When editing the Central interface, you cannot edit the interface type.

When editing the User-based tunneling interface, you cannot edit the interface type and the VRF.
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Deleting a source interface
To delete a source interface, point to the row for the source interface, and click the delete icon.
Deleting source interface at device level and modifying configuration at group level will not add the
source interface again on the device. You can select only one source interface at a time for deleting.

Deleting the user-based tunneling source interface disables all configurations that depend on this source
interface, for example, Dynamic Segmentation, Client Roles.

Configuring Static Routing on AOS-CX
Static routes provide a means for restricting and troubleshooting routed traffic flows. In small networks,
static routes provide the simplest and most reliable configuration for routing. Static routes are manually
configured in the routing table.

For each static route, you can configure the destination and next hop IP addresses to route the packets,
VRF, and the administrative distance. You can add static routes only for the management and default
VRFs.

The following are the maximum number of static routes (IPv4 and IPv6) that are supported on AOS-CX
switches:

n AOS-CX 4100i, 6100 switch series—512
n AOS-CX 6200 switch series—2048
n AOS-CX 6300, 8360 switch series—65536
n AOS-CX 8320 switch series—163796
n AOS-CX 8325 switch series—29696

AOS-CX 6400 and 8400 switch series are not supported in Aruba Central On-Premises UI configuration.

To add static routes on AOS-CX switches, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a group in the filter, complete the following steps:

a. Set the filter to a group.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-CX icon to view the AOS-CX switch configuration dashboard.

n To select a switch, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click an AOS-CX switch under Device Name.

The dashboard context for the switch is displayed.

d. Under Manage, click Device.

The AOS-CX UI configuration page is displayed.

2. Click Routing > Static Routing.

The Static Routing page is displayed.
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3. In the Static Routing table, click the + add icon to add a static route and configure the
parameters described in Table 119.

When the maximum number of routes are added for a switch, the + add icon is disabled.

4. Click Save.

Parameters Description Value

Destination A valid network or
device IP address with
subnet mask.

IPv4 or IPv6 address.
n IPv4 address in the x.x.x.x/M format, where x is an integer

from 0 to 255, and /M is the subnet mask.
n IPv6 address in the

xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx/M format,

where x is a hexadecimal number from 0 to F, and /M is the
subnet mask.

Next Hop Address of the next
node in the route.

n IPv4 or IPv6 address without the subnet mask.
n Port number or LAG name that has routing enabled.

VRF VRF on which the
static route is
configured.

Default or Management.
When you select Management, you can configure only the Next
Hop field.

NOTE:

n When you configure a static route with the Management VRF,
the configured Next Hop address is updated as the default
gateway of the OOBM interface when the address mode of the
OOBM interface is configured as static IP.

n Management VRF is not supported on the AOS-CX 4100i and
6100 switch series.

Distance The administrative
distance helps routers
determine the best
route when there are
multiple routes to the
destination. A lower
value is
recommended.

The default administrative distance for static IP routes is 1, but can

be configured to any value in the range 1 to 255.

The following table describes the static route parameters.
Table 119: Static Route Parameters

If the administrative distance is set to a lower value for static routes, switches use the static IP routes as the
best route for routing traffic. For example, if the administrative distance for a static route is set to 20 and for an
OSPF-based route is set to its default value, 110, then the switch choose the static route as the best route for
routing traffic.
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Configuring Ports and LAGs on AOS-CX
Link aggregation group (LAG) bundles multiple physical Ethernet links into one logical link. Link
aggregation has the following benefits:

n Increased bandwidth beyond the limits of single link. In an aggregate link, traffic is distributed across
the member ports.

n Improved link reliability. The member ports dynamically back up one another. When a member port
fails, its traffic is automatically switched to other member ports.

From the Ports and Link Aggregation page, you can view all the ports, configure LAGs, and modify port
settings for AOS-CX switches using UI groups.

Following are the maximum number of LAGs that are supported on AOS-CX switches:

n AOS-CX 4100i, 6100 switch series—8
n AOS-CX 6200 switch series—32
n AOS-CX 6300 switch series—256
n AOS-CX 8320, 8360 switch series—54
n AOS-CX 8325 switch series—128

AOS-CX 6400 and 8400 switch series are not supported in Aruba Central On-Premises UI configuration.

Adding a LAG
To add a LAG, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter, complete the following steps:

a. Set the filter to a group.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-CX or Config icon to view the switch configuration dashboard.

n To select a switch in the filter, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click an AOS-CX switch under Device Name.

The dashboard context for the switch is displayed.

d. Under Manage, click Device.

The AOS-CX UI configuration page is displayed.

2. Click Interfaces > Ports & Link Aggregations.

The Ports & Link Aggregations page is displayed with the list of ports configured on the switch.

In the device view, all access ports are shown by default. Click the filter in the Name column to select
All Uplink Ports or All Access Ports. You can also search for a port using the port name.
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3. In the Ports & Link Aggregations table, click the + add icon to add a Lag.

The Add Lag window is displayed.

When the maximum number of LAGs are added for a switch, the + add icon is disabled.

4. Configure the parameters described in Table 120.
5. Click Add.

The configured parameters are displayed in the Ports & Link Aggregations table.

Name Description Value

Name Name of the LAG. Name starting with the string lag.
Example: lag1, Lag23, LAG123.

Description Description of the LAG. A maximum of 64 characters including
letters, numbers, and special characters,
except question mark (?) and double
quotes (").

Port Members The switch port members for the LAG. Select from the drop-down list.

Speed Duplex The speed and duplex configuration for the
client traffic.

NOTE: Speed Duplex is shown or hidden
depending on the value in Port Members field

Select from the drop-down list.

Routing Indicates whether routing is enabled.
If routing is enabled at the device level, then
specify the IP address with subnet mask for the
destination network. Format: (x.x.x.x/x).

NOTE: If Routing is enabled at the device level,
then port authentication configuration is reset
on all the selected ports.

Toggle the switch to on or off position.

VLAN Mode The operational mode of VLAN. This field is
available only when Routing is disabled.
In the access mode , port carries traffic only
for the VLAN to which it is assigned. In the
trunk mode, a port can carry traffic for
multiple VLANs.

trunk or access
For access mode, an Access VLAN can be
specified.
For trunk mode, the Native VLAN and
Allowed VLANs can be configured. You
can enter multiple Allowed VLANs by
specifying the range of VLANs or VLANs
separated by comma.
For example, 1-7 or 55, 56, 57.

NOTE: To specify the VLANs here, you
must have already added the VLANs in the
VLAN configuration page. See Configuring
VLANs on AOS-CX.

The following table describes the link aggregation parameters.
Table 120: Link Aggregation Parameters
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Name Description Value

Admin Up The operational status of the LAG. If the check
box is selected, then the LAG can receive and
transmit data as long as a cable is connected
and no physical or operational problems
exists.

Select the check box to enable.

Aggregation
Mode

The operational mode of link aggregation
control protocol (LACP).
LACP operates in these two modes:
n LACP active—When the LACP is operating

in active mode on either end of a link, both
ports can send Protocol Data Units (PDUs).
The active LACP initiates an LACP
connection by sending LACPDUs.

n LACP passive—When the LACP is
operating in passive mode on a local
member port and its peer port, both ports
cannot send PDUs. The passive LACP will
wait for the remote end to initiate the link.

None, LACP active, or LACP passive.

Editing a LAG
To edit a LAG, point to the row for the LAG, and click the edit icon.

You can edit only one LAG at a time.

Deleting a LAG
To delete a LAG, point to row for the LAG, and click the delete icon.

Editing Ports settings
You can edit port settings by selecting one or more ports. If ports selected have different values
configured, then changes made will be deployed on all the selected ports.

If a port is added to a LAG, then the port will not be displayed in the Ports and Link Aggregation table.

To edit ports, complete the following steps:

1. In the Ports & Link Aggregations table, select one or more ports you want to edit and click the
edit icon.

The Edit Ports window is displayed.

n To edit a single port, click the edit icon on the corresponding row.
n To edit multiple ports, select the rows you want to edit and click the edit icon in the <number of

ports> item(s) selected window at the right bottom of the page.
n In the device view, all ports are shown by default. Click the filter in the Name column to select All

Uplink Ports or All Access Ports. You can also search for a port using the port name.
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2. Configure the parameters described in Table 121.
3. Click Save.

Name Description Value

Description Description of the ports. When multiple ports are
selected, then you can provide the same description
for all the selected ports by selecting a set same
value for all ports check box. You can also provide
different descriptions by clicking on the individual port
fields.

A maximum of 64 characters
including alphabets and numbers.
Special characters are not allowed.

Speed Duplex The speed and duplex configuration for the client
traffic.

Select from the drop-down list. By
default, Speed Duplex is set to
Auto.

Routing Indicates whether routing is enabled. If routing is
enabled at the device level, then specify the IP address
with subnet mask for the destination network. Format:
(x.x.x.x/x), whereas IP address is not required at the
group level.

NOTE: If Routing is enabled at the device level, then
port authentication configuration is reset on all the
selected ports.

Toggle the switch to on or off
position.

VLAN Mode The operational mode of VLAN. This field is available
only when Routing is disabled.
By default, a port is in access mode and carries traffic
only for the VLAN to which it is assigned. In trunk
mode, a port can carry traffic for multiple VLANs.

NOTE: This option is not visible for VSF ports.

trunk or access
For access mode, an Access VLAN
can be specified.
For trunk mode, the Native VLAN
and Allowed VLANs can be
configured. You can enter multiple
Allowed VLANs by specifying the
range of VLANs or VLANs separated
by comma.
For example, 1-7 or 55, 56, 57.

Admin Up The operational status of the port. If the check box is
selected, then the port can send and receive data as
long as a cable is connected and no physical or
operational problems exist.

Select the check box to enable.

The following table describes the ports parameters.
Table 121: Ports Parameters

Editing OOBM Port
You can edit the Out of Band Management (OOBM) port at the device level.

To edit the OOBM port, complete the following steps:

1. Select the OOBM  port and click the edit icon.

The Edit Port OOBM page is displayed.

2. Configure the following parameters:
n IP assignment—Method of IP assignment as Static or DHCP. Enter the IP address for IP

assignment if the selected method is Static.
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n Admin UP—Operational status of the port. If the check box is selected, then the port can send
and receive data as long as a cable is connected and no physical or operational problems
exists.

3. Click Save.

Configuring Port Profiles on AOS-CX
Port profiles is a feature that allows you to configure interface-specific commands at the group level
through an editor. This feature is useful when configuring multiple devices, as it enables you to
configure more devices than the MultiEdit feature.

In Aruba Central On-Premises, from the Ports Profiles page, you can create a profile, apply a profile to
devices, clone a profile, modify profile configurations, and delete profiles at the group level. The port
profile editor supports syntax and semantic checking.

Port profile supports various interface types such as interface ranges, wild cards, LAG, MCLAG, split, sub-
interface, and management interface.

After applying a port profile on a device, you cannot view the association between the device and the applied
profile. You can use the MultiEdit feature to view the configuration on the devices.

Important Points to Note

n You must provide a complete configuration when applying a profile to an interface.
n The apply profile option will overwrite the current configuration with the new profile configuration.
n Before assigning an interface, you must configure any of the external references such as VLAN and

OSPF.
n The parent port of a sub-interface must be set to routing mode.
n Overlapping ports cannot be used when defining interface ranges.
n When creating split-child interfaces, you should specify a parent port.

Creating a Profile
To create a profile, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one switch.
2.  Under Manage, click Devices > Switches.
3. Click the AOS-CX or Config icon to view the switch configuration dashboard.
4. Click Interfaces > Port Profiles.

The Port Profiles page is displayed with a list of port profiles, including two sample profiles.

5. In the Port Profiles table, click + add icon to create a profile.

The Create Profile page is displayed.

6. Enter the name and descriptions for the profile in the respective fields.
7. Configure interface-specific commands using an editor.
8. Click Save.

A new port profile is created with the interface-specific configurations.

Applying a Profile to Devices
To apply a profile to devices, complete the following steps:



Managing AOS-CX Switches | 590

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one switch.
2.  Under Manage, click Devices > Switches.
3. Click the AOS-CX or Config icon to view the switch configuration dashboard.
4. Click Interfaces > Port Profiles.

The Port Profiles page is displayed with a list of port profiles including two sample profiles.

5. Hover over the port profile you want to apply to devices and click the apply icon.
The Apply <Profile-Name> page is displayed.

You can also apply a sample profile to devices.

6. In the Devices table, select the devices to which you want to apply the profile.

Optionally, you can make any edits to the configuration. When applying the profile, you can only
modify the interface line in the editor.

7. Click Save.

The profile is applied to the selected devices and the configuration are pushed to the devices.
Once the port profile is applied, all existing settings on the port will be replaced by settings in this
profile.

If you are applying configurations to the devices, ensure to check the audit trail to confirm if the
all configurations are successfully pushed to the devices.

If any feature is not supported on specific devices, the configuration is skipped and not pushed to those
devices. You can view the audit logs to verify whether the configuration is pushed to the devices.

Cloning a Profile
Cloning a profile will duplicate the interface configuration from the source profile.

To clone a group, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one switch.
2.  Under Manage, click Devices > Switches.
3. Click the AOS-CX or Config icon to view the switch configuration dashboard.
4. Click Interfaces > Port Profiles.

The Port Profiles page is displayed with a list of port profiles including two sample profiles.

5. Hover over the port profile you want to clone and click the clone icon.
The new profile is created from the source profile. After cloning, you can make any necessary
edits.

Editing a Profile
To edit a profile, hover over the profile you want to edit and click the edit icon.

You cannot edit the sample profiles.
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Deleting a Profile
To delete a profile, hover over the profile you want to remove and click the delete icon. If you delete a
profile, only the profile will be removed, the configurations applied through the profile to devices are
not deleted.

You cannot delete the sample profiles.

Sample Interface Configurations
The following are some sample configurations on the interface:

Configuring L2 LAG:

interface lag 1

no shutdown

description Sample-Uplink-Lag

no routing

vlan trunk native 1

vlan trunk allowed all

lacp mode active

dhcpv4-snooping trust

interface 1/1/1

no shutdown

mtu 1500

lldp transmit

lldp receive

lldp med poe

no lldp med poe priority-override

lldp dot3 poe

lldp dot3 macphy

lldp med network-policy

lldp med capability

lldp med topology-trap

cdp

lag 1

power-over-ethernet

no power-over-ethernet pre-std-detect

power-over-ethernet priority low

power-over-ethernet allocate-by usage

power-over-ethernet assigned-class 6

Configuring LAG using interface ranges and wildcards:
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interface lag 1

no shutdown

description Sample-Uplink-Lag

no routing

vlan trunk native 1

vlan trunk allowed all

lacp mode active

dhcpv4-snooping trust

interface lag 2

no shutdown

routing

description Sample-Uplink-Lag

no routing

vlan trunk native 1

vlan trunk allowed all

lacp mode active

dhcpv4-snooping trust

interface 1/1/1 - 1/1/10

no shutdown

lag 1

interface 1/1/11 - 1/1/15

no shutdown

lag 2

interface 1/1/1 - 1/*/15

no shutdown

lag 2

Configuring sub-interface:

interface 1/1/28

no shutdown

routing

interface 1/1/28.10

ip address 2.2.2.2/24

Configuring overlapping interfaces:

interface 1/1/1-1/1/5

no shutdown

routing



Aruba Central On-Premises 2.5.7 | User Guide 593

vlan trunk native 1

vlan trunk allowed 2-3000

interface 1/1/4-1/1/10

no shutdown

no routing

Configuring list of interfaces:

interface 1/1/1-1/1/10,1/1/15,1/1/2:1-1/1/2:4

description list of physical interfaces

Sample Audit Log
The following figures display sample audit log generated for the port profiles feature:

Configuring Authentication Servers on AOS-CX
From the Server groups page, you can configure RADIUS or TACACS authentication servers to
authenticate and authorize the users of an AOS-CX switch. The authentication servers determine if the
user has access to the administrative interface.
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n When moving AOS-CX switches from an unprovisioned, template, or UI group to another UI group, you
can retain the existing switch configuration by selecting the Retain CX-Switch Configuration check box
on the Move Devices page.

n Device-level RADIUS and TACACS server configuration will be retained, if present. And also any new group-
level configuration will be applied. However, if any retained device configuration conflicts with group-level
configuration, then group-level configuration takes precedence, and those conflicting configuration will be
replaced.

To configure authentication servers on a switch, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter, complete the following steps:

a. Set the filter to a group.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-CX icon to view the switch configuration dashboard.

n To select a switch in the filter, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click an AOS-CX switch under Device Name.

The dashboard context for the switch is displayed.

d. Under Manage, click Device.

The AOS-CX UI configuration page is displayed.

2. Click Security > Authentication Servers.

The Authentication Servers page is displayed with number of RADIUS and TACACS servers that
are configured on the switch.

Configuring a RADIUS Server on AOS-CX
To configure a RADIUS server, complete the following steps:

1. In the Authentication Servers table, point to the RADIUS server row and click the edit icon.

The RADIUS servers page is displayed with the list of RADIUS servers configured on the switch.

2. To add a RADIUS server, click the + add icon.

The Add RADIUS window is displayed.

3. Configure the parameters described in Table 123.
4. Click Apply.

The added server is displayed in the RADIUS servers page.

The server that was added first is accessed first, and if necessary, the second server is accessed
second, and so on. You can rearrange the order by dragging the server to a different position
using the drag-and-drop icon.

5. Click Save.
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Name Description Value

FQDN or IP
address

The IP address or fully qualified
domain name of the RADIUS server.

Shared secret The encryption key to be used during
authentication sessions with the
specified RADIUS server.

You can enter up to a maximum of 32
characters including letters, numbers, and
special characters, except question mark (?) and
double quotes (").

Authentication
Port

The authentication port number for
the specified server.

Range: 1-65535
Default: 1812

Timeout (secs) The number of seconds to wait for a
response from the RADIUS server
before trying the next RADIUS server.

Range: 1-60
Default: 5

VRF The VRF to be used for communicating
with the RADIUS server.

Default and Management

NOTE: Management VRF is not supported on
the AOS-CX 4100i and 6100 switch series.

Retry Count The number of retry attempts for
contacting the specified RADIUS
server.

Range: 0-5
Default: 1

The following table describes the RADIUS parameters.
Table 123: RADIUS Parameters

Configuring TACACS Server on AOS-CX
To configure a TACACS server, complete the following steps:

1. In the Authentication Servers table, point to the TACACS server row and click the edit icon.

The TACACS servers page is displayed with the list of TACACS servers configured on the switch.

2. To add a TACACS server, click the + add icon.

The Add TACACS window is displayed.

3. Configure the parameters described in Table 124.
4. Click Apply.

The added server is displayed in the TACACS servers page.

The server that was added first is accessed first, and if necessary, the second server is accessed
second, and so on. You can rearrange the order by dragging the server to a different position
using the drag-and-drop icon.

5. Click Save.

Name Description Value

FQDN or IP
address

The IP address or fully qualified
domain name of the TACACS server.

The following table describes the TACACS parameters.
Table 124: TACACS Parameters
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Name Description Value

Shared secret The encryption key to be used during
authentication sessions with the
specified TACACS server.

You can enter up to a maximum of 32
characters including letters, numbers, and
special characters, except question mark (?) and
double quotes (").

Authentication
Port

The authentication port number for
the specified TACACS server.

Range: 1-65535
Default: 49

Timeout (secs) The number of seconds to wait for a
response from the TACACS server
before trying the next TACACS server.

Range: 1-60
Default: 5

VRF The VRF to be used for communicating
with the TACACS server.

Default and Management

NOTE: Management VRF is not supported on
the AOS-CX 4100i and 6100 switch series.

Configuring Authentication on AOS-CX
Aruba Central On-Premises supports the following authentication methods for AOS-CX switches:

n 802.1X Authentication—Used for authenticating the identity of a user before providing network
access. 802.1x
o Supplicant: Device that tries to access the LAN.
o Authenticator: A network device, such as an Ethernet switch that authenticates the supplicant.
o Authentication Server: Typically a host running software supporting the RADIUS and EAP

protocols that provides an authentication service to the authenticator.
n MAC Authentication—Used for authenticating devices based on their physical MAC addresses. For

MAC authentication, the MAC address of a machine must match an approved list of MAC addresses
defined on the RADIUS server.

You must configure at least one RADIUS server to use 802.1X or MAC authentication.

To configure authentication at port level, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter, complete the following steps:

a. Set the filter to a group.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-CX icon to view the switch configuration dashboard.

n To select a switch in the filter, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click an AOS-CX switch under Device Name.

The dashboard context for the switch is displayed.



Aruba Central On-Premises 2.5.7 | User Guide 597

d. Under Manage, click Device.

The AOS-CX UI configuration page is displayed.

2. Click Security > Authentication.

The Authentication page is displayed.

3. Under the MAC authentication, select one of the following modes to communicate with
RADIUS servers:

n PAP (Password Authentication Protocol)

n CHAP (Challenge-Handshake Authentication Protocol)

At the global level, 802.1X Authentication uses the EAP (Extensible Authentication Protocol)

mode to communicate with the RADIUS server.

4. In the Ports table, select one or more ports for which you want to configure authentication, and
click the edit icon.

The Edit Ports page is displayed.

5. Configure the parameters described in Table 125.
6. Click Apply.

The authentication parameters are displayed in the Ports table.

7. Click Save.

Name Description Value

Authentication The method of authentication. Select any one of the following authentication
methods:
n None—Disables authentication. By default,

the authentication is disabled.
n 802.1X—Enables 802.1X method for

authentication.
n MAC—Enables MAC method for

authentication
n 802.1X, then MAC—Enables both 802.1X

and MAC authentication methods and sets
the precedence to 802.1X authentication.

n MAC, then 802.1X—Enables both 802.1X
and MAC authentication methods and sets
the precedence to MAC authentication.

n Concurrent—Enables both 802.1X and
MAC authentication methods to start
simultaneously for faster onboarding
process. You can select 802.1X or MAC
authentication from the Priority drop-
down menu. Default priority for concurrent

The following table describes the authentication parameters.
Table 125: Configuring Authentication
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Name Description Value

is 802.1X followed by MAC authentication.

Client Limit The maximum number of clients to
be allowed on the port.

Enter up to a maximum of 256 clients.
Default: 1
Following are the maximum clients supported
on switches:
n AOS-CX 4100i, 6100, 6200, switch series—32
n AOS-CX 6300 switch series—256

At the group level, the maximum clients
supported is 256.

NOTE:

n Port access authentication is not supported
on AOS-CX 8320, 8325, and 8360 switch
series.

n AOS-CX 6400 and 8400 switch series are not
supported in Aruba Central On-Premises
UI configuration.

Reauthentication
Timeout

The time (in seconds) that the switch
enforces on a client to re-
authenticate. The client remains
authenticated while the re-
authentication occurs. By default,
this field is disabled and the default
value is displayed. To edit the
default value, select the check box
and specify the value.

Default: 3600 seconds

Cached
Reauthentication
Timeout

The time (in seconds) when cached
re-authentication is allowed on the
port. By default, this field is disabled
and the default value is displayed.
To edit the default value, select the
check box and specify the value.

Default: 30 seconds

Quiet Period The time (in seconds) during which
the port does not try to acquire a
supplicant. The period begins after
the last attempt authorized by the
max-requests parameter fails.

Default: 60 seconds

Configuring Access Control on AOS-CX
Access control allows you to permit or deny traffic based on network addresses, protocols, service
ports, and other packet attributes. An Access policy defines a set of rules based on network traffic
addressing and uses these rules to permit or deny the passage of traffic through the switch. The permit
action allows the traffic to continue through the switch and the deny action causes the traffic to be
discarded (dropped).

From the Access Control page, you can add access policies and set different rules for the access policies
using UI groups.
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Adding an Access Policy
You can add access policies by defining traffic rules. A policy can be applied to an individual front plane
port, a Link Aggregation Group (LAG) interface, or a VLAN.

The following are the maximum number of policies that are supported on AOS-CX switches:

n AOS-CX 4100i, 6100 switch series—512
n AOS-CX 6200, 6300 switch series—4000
n AOS-CX 8320 switch series—16000
n AOS-CX 8325, 8360 switch series—4000

AOS-CX 6400 and 8400 switch series are not supported in Aruba Central On-Premises UI configuration.

To add an access policy, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter, complete the following steps:

a. Set the filter to a group.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-CX or Config icon to view the switch configuration dashboard.

n To select a switch in the filter, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click an AOS-CX switch under Device Name.

The dashboard context for the switch is displayed.

d. Under Manage, click Device.

The AOS-CX UI configuration page is displayed.

2. Click Security > Access Control.
The Access Control page is displayed with the name of the policy.

3. In the Access Control table, click the + add icon to add a policy.

The Add Policy page is displayed.

When the maximum number of policies are added for a switch, the + add icon is disabled.

4. Configure the parameters described in .
5. Click Apply.

The Access Control table is displayed with the number of ports & LAGs, and VLANs configured on
inbound and outbound traffic.
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Name Description Value

Name The name of the access policy. A maximum of 64 characters
including letters, numbers, and
special characters, except question
mark (?) and double quotes (").

Direction The traffic direction for Ports and LAGs. The available
directions are:
n Inbound—Controls the incoming traffic on the

selected ports or LAGs.
n Outbound—Controls the outgoing traffic on the

selected ports or LAGs.

Inbound or Outbound

Ports &
LAGs

The ports and LAGs on which the policy is applied. Select a value from the drop-down.

Direction The traffic direction for VLANs. The available directions
are:
n Inbound—Controls the incoming traffic on the layer

2 interface VLANs.
n Outbound—Controls the outgoing traffic on the layer

2 interface VLANs.
n Routed Inbound—Controls the incoming traffic on

the layer 3 interface VLANs.
n Routed Outbound—Controls the outgoing traffic on

the layer 3 interface VLANs.

Inbound, Outbound, Routed
Inbound, or Routed Outbound.

VLANs The VLANs on which the policy is applied. The list of layer
2 and layer 3 interface VLANs are displayed based on the
Direction selection.

Select one or more VLANs from the
drop-down list.

The following table describes the access policy parameters.
Table 126: Access Policy Parameters

Editing an Access Policy
To edit a policy, point to the row for the policy, and click the edit icon.

Deleting an Access Policy
To delete a policy, point to the row for the policy, and click the delete icon.

Adding a Rule for Policy
You can add access rules for a policy to either allow or deny the traffic passing through the switch.

The following are the maximum number of rules that are supported on AOS-CX switches:

n AOS-CX 4100i, 6100 switch series—4096
n AOS-CX 6200, 6300 switch series—8000
n AOS-CX 8320 switch series—32000
n AOS-CX 8325, 8360 switch series—4000

AOS-CX 6400 and 8400 switch series are not supported in Aruba Central On-Premises UI configuration.
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To add a access rule, complete the following steps:

1. In the Access Control table, select the policy for which you want to add a rule by clicking on the
policy.

The Policy Rules page is displayed.

2. In the <Policy name> Rules table, click the + add icon to add a rule.

The Add rule for policy "<policy name"> page is displayed.

n After adding the first rule, the + add icon in the <Policy name> Rules table is disabled. To add
more rules to the same policy, click the + add icon present in the row corresponding to the rule
after which you want to add the next rule.

n When the maximum number of rules are added for a switch series, the + add icon is disabled.

3. Configure the parameters described in .
4. To create another rule , select the Stay and create another check box and add a new rule.
5. Click Apply.

The new rules are displayed in the Policy Rules table.

By default, the rules are sequenced in the order in which they are added. You can rearrange the
sequence by dragging the rule to the position you want using the drag-and -drop icon.

6. Click Save.

Name Description Value

Action The action for the traffic passing through the
switch.

Permit or Deny

Description Description for the rule. A maximum of 256 characters including
letters, numbers, and special
characters, except question mark (?)
and double quotes (").

Source type The type of source for which you want to apply a
policy.

Any, Network, or Host.
If you select Network, enter the IP
address and Mask .
If you select Host, enter the IP address.

Destination
type

The type of destination for which you want to
apply a policy.

Any, Network, or Host.

If you select Network, enter the IP
address and Mask .
If you select Host, enter the IP address.

Protocol The type of data transfer protocol. If you select
SCTP, TCP, or UDP the Source port and Destination
port fields are displayed.

Protocol types: Any, AH, ESP, GRE,
ICMP, IGMP, IP, OSPF, PIM, SCTP, TCP,
and UDP.

The following table describes the access rules parameters.
Table 127: Access Rules Parameters
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Name Description Value

Source Port The port numbers of source. You can specify a
single port in the Source Port field or range of
ports in the Source Port and Source Port Max
fields.
For example, if you want to specify the source port
range as 1 to 7, then specify 1 in the Source Port
field and 7 in the Source Port Max field.

An integer

Source Port
Max

The end port number in the range of source ports.
This field is applicable only if you want to
configure a range of source ports.

An integer

Destination
Port

The port numbers of destination. You can specify a
single port in the Destination Port or range of
ports in the Destination Port and Destination
Port Max fields.
For example, if you want to specify port range as 1
to 7, then specify 1 in the Destination Port field
and 7 in the Destination Port Max field.

An integer

Destination
Port Max

The end port number in the range of destination
ports. This field is applicable only if you want to
configure a range of destination ports.

An integer

Editing a Rule
To edit a rule, point to the row for the rule, and click the edit icon.

Deleting a Rule
To delete a rule, point to the row for the rule, and click the delete icon.

Configuring User-Based Tunneling for AOS-CX
User-based tunneling (UBT) uses GRE to tunnel ingress traffic on a switch interface to a gateway for
further processing. User-based tunneling enables a switch to provide a centralized security policy, using
per-user authentication and access control to ensure consistent access and permissions.

User-based tunneling is supported on the following switches:

n AOS-CX 4100i switch series
n AOS-CX 6200 switch series
n AOS-CX 6300 switch series
n AOS-CX 6400 switch series

For provisioning User-based tunnel, the following configurations are necessary:

n All devices need to be Day 0 provisioned
n Underlay network is connected and reachability established
n All devices in the underlay and topology is clearly identified

To configure user-based tunnel, complete the following steps:



Aruba Central On-Premises 2.5.7 | User Guide 603

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter, complete the following steps:

a. Set the filter to a group.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-CX or Config icon to view the switch configuration dashboard.

n To select a switch in the filter, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click an AOS-CX switch under Device Name.

The dashboard context for the switch is displayed.

d. Under Manage, click Device.

The AOS-CX UI configuration page is displayed.

2. Click Security > Dynamic Segmentation to view the switch configuration dashboard.
3. Toggle the User based tunneling switch to on position.

The toggle switch is disabled by default. Enabling this toggle, shows a warning message on how to
configure the User-based tunnel.

4. Enter Primary controller IP address and Backup controller IP address.

Make sure that the primary and backup IP addresses are different.

5. Enter the VLAN ID under Client VLAN only when you select the Reserved option.
6. In the Source interface drop-down list, select Add new source interface.

The Edit Source Interface window is displayed.

If a user-based tunnel source interface is already added in the Source Interface page, it will appear in
the drop-down list. For more information about source interface, see Configuring Source Interface for
AOS-CX.

7. Configure the parameters described in Table 128.

8. Click Save.

Name Description Value

Interface The interface or the service name.
By default, only User-based tunneling is
selected in the Dynamic Segmentation page.

User-based tunneling

Port/LAG Type of interface you want to configure.
The name of this field is applicable only at the
group level.
At the device level, the field name is
Port/LAG/VLAN/Address.

n At the group level—Port or LAG
n At the device level—Port, LAG, VLAN, or

Address

The following table describes the new source interface parameters.
Table 128: New Source Interface Parameters



Managing AOS-CX Switches | 604

Name Description Value

Port name Port number for the source interface.
Applicable when you select Port in the
Port/LAG drop-down at the group level or
Port/LAG/VLAN/Address drop-down at the
device level.

Select a port from the drop-down.

NOTE:

n At the group level—Only the ports that
have routing enabled at the group level
are available in this drop-down.

n At the device level—Only the ports that
have routing enabled and IP address
configured on the ports at the device level
are listed in this drop-down.

LAG name LAG name for the source interface.
Applicable when you select Port in the
Port/LAG drop-down at the group level or
Port/LAG/VLAN/Address drop-down at the
device level.

Select a LAG from the drop-down.

NOTE:

n At the group level—Only the LAGs that
have routing enabled at the group level
are available in this drop-down.

n At the device level—Only the LAGs that
have routing enabled and IP address
configured on the LAGs at the device level
are listed in this drop-down.

VLAN ID VLAN ID for the source interface.

NOTE:

n Available only at the device level.
n Applicable when you select VLAN in the

Port/LAG/VLAN/Address drop-down at
the device level.

Select a VLAN from the drop-down.

NOTE:

n Only the VLANs that have an IP address
configured at the device level are listed in
this drop-down.

n The IP address must be a static IP address.
DHCP server is not supported.

Address IP address for the source interface.

NOTE:

n Available only at the device level.
n Applicable when you select Address in the

Port/LAG/VLAN/Address drop-down at
the device level.

IPv4 address

VRF The VRF to be used for communicating with
DNS and NTP servers.

Default

Configuring Client Roles for AOS-CX
You can assign network access to clients using client roles. The network admin can create configuration
profiles (roles) and associate them to clients. Client roles allow you to create and manage roles and
attributes for the network.

To create a client role, complete the following steps:
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1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter, complete the following steps:

a. Set the filter to a group.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-CX icon to view the switch configuration dashboard.

n To select a switch in the filter, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click an AOS-CX switch under Device Name.

The dashboard context for the switch is displayed.

d. Under Manage, click Device.

The AOS-CX UI configuration page is displayed.

2. Click Client Roles.
3. Under Client Roles table, click the + add icon to create a new role.
4. Configure the parameters described in Table 129.

5. Click Save.

Name Description Value

Name Name of the role. This is a mandatory parameter.
This parameter supports letters,
numbers, and special characters.

VLAN mode VLAN mode of the role. Access or Trunk
Default value is Access.

VLAN VLAN ID of the role. Default value is 1.

Authentication
mode

Select either MD5 (Message Digest) or SHA
(Secure Hash Algorithm) as the authentication
mode to provide secured access to the user.

Client-Mode or Device-Mode
Default value is Client-Mode.

Trust mode Trust mode for the role. None, DSCP, or COS
Default value is None.

Reauthentication
period

The time (in seconds) after which the switch
enforces on a client to reauthenticate. The
client remains authenticated while the
reauthentication occurs.

Default value is 30 seconds.

PoE priority PoE priority configured on the port. Critical, High, or Low.
Default value is Low.

The following table describes the client roles parameters.
Table 129: Client Roles Parameters
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Name Description Value

STP admin edge
port

Enable or disable STP admin edge port for the
role.

By default STP admin edge port is
enabled.

User-based tunnel Enable or disable user-based tunneling for the
role.

NOTE:

n To enable user-based tunnel for a client
role, user-based tunneling must be enabled
in Dynamic Segmentation.

n If User-based tunnel is enabled for a role
and if User-based tunnel feature is
disabled in the Dynamic Segmentation
page, then User-based tunnel for the role
is disabled automatically.

Move the toggle switch to the on
position to enable.
By default, it is disabled.

Gateway cluster Name of the gateway cluster zone.

NOTE: By default, the cluster zone name is
default. You cannot change the gateway
cluster name.

Gateway Role Name of the gateway role for the client role. This parameter supports letters,
numbers, and special characters.

You cannot edit client roles.

Deleting Client Roles
To delete a client role, point to the row for the role, and click the delete icon.

Configuring VLANs on AOS-CX
VLANs are primarily used to provide network segmentation at layer 2. VLANs enable the grouping of
users by logical function instead of physical location. VLANs make managing bandwidth usage within
networks possible by:

n Allowing grouping of high-bandwidth users on low-traffic segments
n Organizing users from different LAN segments according to their need for common resources and

individual protocols
n Improving traffic control at the edge of networks by separating traffic of different protocol types
n Enhancing network security by creating subnets to control in-band access to specific network

resources

From VLANs page, you can add VLANs and manage VLAN settings such as name, description, admin
status, and IP assignment for AOS-CX switches.

For AOS-CX 6200 and 6300 switch series, VLAN 1 (DEFAULT_VLAN_1) is associated with all interfaces on
the switch. The DHCP assignment of IP address is available only on the default VLAN.
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You can add only one VLAN at a time.

Adding a VLAN
To add a VLAN, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter, complete the following steps:

a. Set the filter to a group.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-CX or Config icon to view the switch configuration dashboard.

n To select a switch in the filter, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click an AOS-CX switch under Device Name.

The dashboard context for the switch is displayed.

d. Under Manage, click Device.

The AOS-CX UI configuration page is displayed.

2. Click Bridging > VLANs.

The VLANs page is displayed with a list of VLANs.

3. In the VLANs table, click the + add icon to add a VLAN.
4. Configure the parameters described in Table 130.

When the maximum number of VLANs are added for a switch, the + add icon is disabled.

5. Click Add.

The VLAN information is displayed in the VLANs table.

Name Description Value

ID The VLAN ID number. Following are the different ranges for
the VLANs supported on switches:
n AOS-CX 4100i, 6100 switch series—2

to 512
n AOS-CX 6200 switch series—2 to

2048
n AOS-CX 6300 and 8360 switch

series—2 to 4094
n AOS-CX 8320 and 8325 switch

series—2 to 4040

The following table describes the VLAN parameters.
Table 130: Configuring and Viewing VLAN Parameters
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Name Description Value

At the group level, the maximum VLANs
supported is 4094

NOTE: AOS-CX 6400 and 8400 switch
series are not supported in Aruba
Central On-Premises UI configuration.

Name The name of the VLAN. Only letters (a-z) and numbers (0-9) are
allowed.

Description The description of the VLAN. Letters, numbers, and special
characters are allowed except question
mark (?) and double quotes (").

Admin UP The operational status of the VLAN. The VLAN can
forward packets only when the check box is
selected.

Select the check box to enable.

Voice The VLAN support for voice. Select the check box to enable.

IP Assignment The method of IP assignment. The options to
enter the IP address is displayed only when you
select Static. This field is available only at the
device level.

NOTE: The DHCP option is available only for the
default VLAN on AOS-CX 6100, 6200, and 6300
switch series.

Static, DHCP, or None
Default: None

IP Address The IP address with subnet mask for
IP assignment.
This field is enabled only when you select Static
from the IP address assignment drop-down and
available only at the device level.

IPv4 address or IPv6 address with
subnet mask
Format: (x.x.x.x/x).

DHCP Relay The IP address of the DHCP relay server. This field
is enabled only when you select DHCP or Static
from the IP address assignment drop-down and
available only at the device level.

NOTE:

n AOS-CX 6100 and 6200 switch series—
DHCP relay is not supported

n AOS-CX 6300 switch series—DHCP relay is
available only on the default VLAN

IPv4 address

Editing a VLAN
To edit a VLAN, point to the row for the VLAN, and click the edit icon. You can select only one VLAN at a
time for editing.

You cannot edit the name of the default VLAN and admin status.
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Deleting a VLAN
To delete a VLAN, point to the row for the VLAN, and click the delete icon. Deleting VLAN at device level
and modifying configuration at group level will not add the VLAN again on the device. You can select
only one VLAN at a time for deleting.

You cannot delete the default VLAN.

Configuring Loop Prevention on AOS-CX
Loop prevention provides protection against infinite loops by transmitting loop protocol packets out of
the switch ports. You can enable loop prevention by configuring one of the following methods:

n Loop protection at the interface level (ports, LAGs).

Loop protection at the interface level:
o can find loops by sending loop protection packets on each port or LAG on which loop protection is

enabled.
o is useful when spanning tree protocols cannot prevent loops at the edge of the network.
o can be used to find loops in untagged layer 2 links and on tagged VLANs.
o can be configured either when the spanning tree protocol is configured on the interfaces or not.

n Spanning tree protocol at both global and interface level.

Spanning tree protocols such as MSTP and RPVST help prevent loops in networks by blocking
redundant links.

Loop protection and spanning tree are always disabled by default on AOS-CX switches.

To configure loop protection and spanning tree for switches provisioned in the UI groups, complete the
following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a group in the filter, complete the following steps:

a. Set the filter to a group.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-CX or Config icon to view the AOS-CX switch configuration dashboard.

n To select a switch, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click an AOS-CX switch under Device Name.

The dashboard context for the switch is displayed.

d. Under Manage, click Device.

The AOS-CX UI configuration page is displayed.

2. Click Bridging > Loop Prevention.

The Loop Prevention page is displayed.

The Ports table displays the information described in Table 131.



Managing AOS-CX Switches | 610

3. To enable spanning tree, move the Spanning Tree toggle switch to the on position.

 Configure the following parameters:
n Mode—Select MSTP from the drop-down list.

You can configure various MSTP parameters for the ports in the switches.

You cannot select RPVST from the Mode drop-down list. To configure RPVST mode for spanning
tree, you must use Edit Config in the MultiEdit mode and configure using the CLI commands.

However, after configuring the mode as RPVST, if you want to change the mode to MSTP, you can
select MSTP in the Mode drop-down list.

n Priority—Priority of the UI group.

At the group level, the priority is listed in multiples of 4096. A range from 0 to 61440 is
supported. The default value is 32768.

n Region—Region of the UI group.

4. To configure MSTP parameters for ports, select the row(s) in the Ports table and click the edit
icon.

The Loop Prevention page is displayed.

5. Configure the parameters described in Table 132.
6. To save the changes, click Apply.

Column Description

Number Port number or the name of the LAG.

Description Description of the port or LAG interface that you configure on the Ports & Link
Aggregations page.

LAG Members List of port numbers that are grouped to form the LAG.

Loop Protection Displays whether loop protection is enabled or disabled for that interface.

The ports table describes the following parameters.
Table 131: Information in the Ports Table

Parameters Description

Loop
Protection

Move the toggle switch to enable or disable loop protection on the interfaces.

Spanning Tree

Priority A number used to identify the root bridge in an STP instance.
The priority is listed in multiples of 16 in the drop-down. The priority ranges from 0 to 240.

The default priority is 128.

The following table describes the MSTP parameters for ports and LAGs.
Table 132: MSTP Parameters for Ports and LAGs
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Parameters Description

The switch with the lowest value has the highest priority and is considered the root bridge. A
higher numerical value means a lower priority; thus, the highest priority is 0.

BPDU
Protection

Security feature used to protect the active STP topology by preventing manipulated BPDU
packets from entering the STP domain.
Select the check box to enable BPDU protection on the interface.

BPDU Filter Enables control of STP participation for each port. The feature can be used to exclude
specific ports from becoming part of STP operations. A port or LAG with the BPDU filter
enabled ignores incoming BPDU packets and stays locked in the STP forwarding state.
Select the check box to enable BPDU filter on the interface.

Admin-Edge Configures the interface in the forwarding state.
Select the check box to enable Admin edge on the interface.

NOTE: If Admin edge is not configured on the switch, the default port type is admin-
network.

Root Guard Configures the interface to prevent from being configured as a root port when it receives
superior STP BPDUs.
Select the check box to enable root guard on the interface.

Configuring Authentication and DHCP Related Client Events on AOS-
CX
You can configure client events to generate authentication and DHCP events of clients. The DHCP events
will be generated only if DHCP snooping is enabled.

Client events can be enabled on the following switches running AOS-CX 10.11 or later versions:

n AOS-CX 4100i switch series
n AOS-CX 6000 switch series
n AOS-CX 6100 switch series
n AOS-CX 6200 switch series
n AOS-CX 6300 switch series
n AOS-CX 6400 switch series
n AOS-CX 8325 switch series
n AOS-CX 8360 switch series
n AOS-CX 8400 switch series
n AOS-CX 10000 switch series

The information related to client authentication is not generated for AOS-CX 8400 switch series.

To configure client events, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter:

a. Set the filter to a group.

The dashboard context for the group is displayed.
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b. Under Manage, click Devices > Switches.
c. Click the Config icon to view the switch configuration dashboard.

n To select a switch in the filter:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click an AOS-CX switch under Device Name.

The dashboard context for the switch is displayed.

d. Under Manage, click Device.

The AOS-CX UI configuration page is displayed.

2. Click Telemetry > Client Events.
The Client Events page is displayed.

3. Enable client events on the switch by moving the Authentication and DHCP Events toggle to
the on position.

4. To save the changes, click Save.
The generated client events can be viewed in the output of the show running-config command.

Automatic Rollback Configuration
Aruba Central On-Premises support an auto-rollback mechanism for AOS-CX switches running software
version 10.06 or later versions. The rollback mechanism is triggered when the switch loses its
connectivity to Aruba Central On-Premises after a configuration push. A period of about 10 minutes is
taken by switch to complete the rollback with the last known stable configuration and connect back to
Aruba Central On-Premises.

If there is a switch rollback, an event will be logged in the Audit Trail page as shown in the following
figure:

Figure 71 Audit Trail Page

Using MultiEdit View for AOS-CX
This section describes the configuration and viewing procedures for the AOS-CX switches in the
MultiEdit mode.

n MultiEdit mode configuration is applicable only at the device level and allows configuring a single or
multiple switches using the CLI syntax.

n MultiEdit mode displays only the running configuration on a switch. It supports only those commands that
appear in the switch running configuration.

To configure or view details of the switches provisioned in UI groups, complete the following steps:
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1. In the Aruba Central On-Premises app, select one of the following options:
n To select a group in the filter, complete the following steps:

a. Set the filter to a group.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-CX or Config icon to view the AOS-CX switch configuration dashboard.

n To select a switch, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click an AOS-CX switch under Device Name.

The dashboard context for the switch is displayed.

d. Under Manage, click Device.

The AOS-CX UI configuration page is displayed.

2. To enable MultiEdit mode, move the MultiEdit toggle switch to the on position.

The Device-Level Configuration page is displayed with the list of devices displayed in the
Devices table.

At the device level, the Devices table lists only the switch that you have selected. Also, a pop-up is
displayed on the bottom-right corner of the page with the options View Config, Edit Config, and
Express Config.

3. Search for a switch by entering a search query in the Contextual Search Engine field.

For more information about search queries, see Using Device Search on AOS-CX.

The following table describes the columns in the Devices table.

Column Function

Name Name of the AOS-CX switch.

Firmware
Version

Firmware version installed on the switch.

Config Modified Timestamp when the configuration on the switch was last modified.

Status Status of the switch, whether Online or Offline.

Config Status Status of the configuration sync between Aruba Central On-Premises and the switch.
n Sync—Configuration is in sync between Aruba Central On-Premises and the

switch.
n Not in sync (Connection error)—Configuration is not in sync due to a

connection error.
n Not in sync (Modified outside Central)—Configuration is not in sync because

configuration was modified outside Aruba Central On-Premises.
n Not in sync (Pushing config)—Configuration is not in sync because Aruba

Table 133: Columns in the Devices Table in the MultiEdit Mode
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Column Function

Central On-Premises is still pushing configuration to the switch.

NAE Status Consolidated status of the NAE agents running on the switch. Following are the
supported values:
n Critical—The agent has encountered a critical error during execution.
n Major—The agent has encountered a major error during execution.
n Minor—The agent has encountered a minor error during execution.
n Normal—The agent is actively monitoring network conditions and handling

events.
n Disabled—The agent is disabled.
n Unknown—The agent status is unknown.

MAC Address MAC address of the switch.

IP Address IP address of the switch.

Serial Serial number of the switch.

Model Model number of the switch.

The MultiEdit mode provides an option to view or edit switch configuration or apply predefined
configurations to the switches.

n Viewing Configuration Using MultiEdit on AOS-CX
n Editing Configuration Using MultiEdit on AOS-CX
n Express Configuration Using MultiEdit on AOS-CX

Using Device Search on AOS-CX
In the MultiEdit mode, the Contextual Search Engine allows you to filter a set of AOS-CX switches using
search queries. The search queries can contain one or more search terms in the format, label:value. For
example: model:6300F, where model is the label and 6300F is the value. When a search query contains
a list of terms, by default, all terms are required to match. For example, the search query "model:8400
current-firmware:10.04.0001" will return only 8400 switches running 10.04.0001 firmware. The filtered
switch details are displayed in the Devices table.

The search queries can contain the following information:

n Device attributes—Attributes that denote the device details such as the model and current-firmware.

n Wildcard characters—Asterisk (*) and question mark (?) are allowed in search queries.
n Boolean operators—For complex queries, you can use the boolean operators AND, OR, NOT, + (the

plus sign), and - (the minus sign).
n Grouping characters—Multiple search terms with logical operators can be grouped using parenthesis

().

You must use quotes (" ") for any strings with spaces and for the default, running-config, and startup-
config search. A default search is specified by entering quoted text instead of a label:value search term.
The default search runs the search against the running configurations of the devices. For example,
entering "ntp server172.16.0.100" searches for that string in the running configuration of all managed
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devices in the MultiEdit mode. Multiple search terms can be used in a query and can be combined using
logical operators.

Searching for Devices
To access Contextual Search Engine and perform search, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one switch.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Switches.
3. Click the Config icon to view the switch configuration dashboard.
4. Slide the MultiEdit toggle switch to the on position to enable MultiEdit mode.

The Devices table displays the list of devices in the selected group.

5. Hover over the values in the table cells to view the labels that can be used in the search query.

For example, if you hover over a cell in the Status column, a pop-up is displayed with the label
that can be used in the search term and an example.

6. In the Contextual Search Engine field, enter a search query, and click Search & Filter to filter a
set of switches.

The Devices table lists the devices that match the search query.

Device Attributes
The following table lists the field names that can be used in the search query as device attributes.

Field Name Definition Example

active-image Active image location  active-image:primary

chassis Name of the chassis if available chassis:1

config-auto-commit Configuration auto commit
state

config-auto-commit:On
config-auto-commit:Off

config-failure-
reasons

Reason for configuration
failure when the configuration-
state is "Not in sync"

config-failure-reasons:”Connection error”
config-failure-reasons:"Configuration conflicts"
config-failure-reasons:"Internal error"
config-failure-reasons:"Modified outside Central"
config-failure-reasons:"Initial group config pending"
config-failure-reasons:"Pushing config"
config-failure-reasons:"Connection error with pending
changes"
config-failure-reasons:"Auto commit off"

configuration-state Configuration sync state  configuration-state:"Sync"
configuration-state:"Auto commit off"
configuration-state:"Not in sync"
configuration-state:"Connection error"
configuration-state:"Internal error"
configuration-state:"Configuration conflicts"
configuration-state:"Modified outside Central"
configuration-state:"Login pending"
configuration-state:"Initial group config pending"

Table 134: List of Field Names
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Field Name Definition Example

configuration-state:"Pushing config"
configuration-state:"Connection error with pending
changes"
configuration-state:"Monitoring Only"

current-firmware Current firmware version current-firmware:10.02.0001

default-image Default image location default-image:secondary

fabric-card Name of the fabric cards, if
available

fabric-card:1\/1

firmware-version Firmware version on the device firmware-version:FL.10.1

hw-serial Serial number of attached
hardware

hw-serial:TW0989W

ip-address Management IP address ip-address:172.16.0.100

label Label assigned to the device  label:Floor1

last-sync-time Last time when configuration
in central and device are in
sync

last_sync_time:2020-08-27
last_sync_time:2020-08-27T19
last_sync_time:[2020-08-27 TO 2020-08-28]
last_sync_time:[2020-08-27T20 TO 2020-08-27T23]
last_sync_time:[2020-08-27T19:00:00 TO 2020-08-
27T23:00:00]
last_sync_time:[2020-08-27T11:30:00Z TO 2020-08-
27T23:00:00Z]

line-card Name of the line cards, if
available

line-card:1\/1

local-override Device local override is enabled
or not

local-override:Yes
local-override:No

mac-address Base MAC address mac-address:e7c7dc-32f000

management-
module

Name of the management
module, if available

management-module:1\/1

manufacturer Manufacturer name manufacturer:Aruba

model Model number model:6300F

nae-status NAE status of the switch  nae-status:normal

name The devices user-defined name name:cx_6300F_ERIA000001

part-number Product names of the device
and attached hardware

part-number:JL635A

power-supply Name of the power-supply, if
available

power-supply:1\/1

primary-version Primary image version primary-version:GL.10.11
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Field Name Definition Example

product-name  Product names of the device
and attached hardware

product-name:"8325 Mgmt Mod"

product-number Product number of the device  product-number:8325

running-config Contents of the desired
configuration (this is the
default search field)

running-config:”ospf”

running-config-
modified

Date and time of latest running
configuration change

running-config-modified:2020-08-27
running-config-modified:2020-08-27T19
running-config-modified:[2020-08-27 TO 2020-08-28]
running-config-modified:[2020-08-27T20 TO 2020-08-
27T23]
running-config-modified:[2020-08-27T19:00:00 TO
2020-08-27T23:00:00]
running-config-modified:[2020-08-27T11:30:00Z TO
2020-08-27T23:00:00Z]

running-deployed-
by

User who deployed running
configuration

running-deployed-by:system

secondary-version Secondary image version  secondary-version:GL.10.11

serial Serial number serial:SGIA000001

site Site assigned to the device site:”Santa Clara”

startup-config Contents of the desired
configuration

startup-config:”ntp server 192.168.0.7”

startup-config-
modified

Date and time of latest start-up
configuration change

startup-config-modified:2020-08-27
startup-config-modified:2020-08-27T19
startup-config-modified:[2020-08-27 TO 2020-08-28]
startup-config-modified:[2020-08-27T20 TO 2020-08-
27T23]
startup-config-modified:[2020-08-27T19:00:00 TO
2020-08-27T23:00:00]
startup-config-modified:[2020-08-27T11:30:00Z TO
2020-08-27T23:00:00Z]

startup-deployed-
by

User who deployed start-up
configuration

startup-deployed-by:system

status Device status status:Online
status:Offline

system-contact SNMP system contact system-contact:JohnSmith

system-location SNMP system location system-location:Zurich

Wildcard Characters
Wildcard characters are used in search queries to match one or more other characters. The valid
wildcard characters are asterisk (*) and question mark (?).
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Use asterisk (*) to match multiple characters in a search query. For example, the search query
Serial:SG* will return all the devices starting with SG, such as SG0010223, SG0110224, SG1110225, and
so on.

Use question mark (?) to match a single character in a search query . For example, the search query
Serial:SG001022? will return all the devices starting with SG001022 series replacing the last digit, such as
SG0010221, SG0010222, SG0010223, and so on.

Search queries with wildcard characters must be used without quotes. For example: Serial:SG*.

Reserved Characters
Reserved characters are used for performing operations in search queries. For example, the plus (+)
and minus (-) symbols are used as Boolean operators. Parenthesis () is used to group search queries.
Reserved characters include + - && || ! ( ) { } [ ] ^ " ~ * ? : \.

If reserved characters appear in searches, then they must be preceded by an escape character such as a
backslash (\). If the search terms are enclosed in quotes, then you need not add a backslash (\) before
the reserved characters. For example, system-location:"santaclara(office)". If the search terms are not
enclosed in quotes, then you must add a backslash (\) before the reserved characters. For example,
system-location:santaclara\(office\).

Operators
The following table lists the operators that can be used in search queries.

Operator Example Result

AND model:8400 AND current-
firmware:10.04.000

Returns all 8400 model switches running the 10.04.000
firmware version.

OR model:8400 OR current-
firmware:10.04.000

Returns all 8400 model switches, all the switches running
10.04.000 firmware version, or both.

NOT model:8400 NOT current-
firmware:10.04.000

Returns all 8400 model switches, but not switches running
10.04.000 firmware version.

+
(Includes)

model:8400 + running-
config:"access-list ip hvac_
segmentation"

Returns all 8400 model switches that contain the ACL named
"hvac_segmentation" in their running configuration.

-
(Excludes)

model:8400 - running-
config:"access-list ip hvac_
segmentation"

Returns 8400 model switches that do not have the ACL
named "hvac_segmentation" in their running configuration.

( )
(Grouping)

(model:8400 OR model:6300)
AND NOT current-
firmware:10.04.0001

Returns all 8400 and 6300 model switches that are not
running firmware version 10.04.000.

Table 135: List of Operators

Sample Queries
The following table lists some sample queries that can be used as search queries.
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Query Result

"ospf" Switches that contain the string "ospf" in their running configuration file.

model:8400 current-
firmware:10.04.0001

Model 8400 switches running firmware version 10.04.0001.

model:8400 -current-
firmware:10.04.0001

All 8400 switches that are not running version 10.04.0001.

(model:8400 OR model:6300)
AND NOT current-
firmware:10.04.0001

All 8400 and 6300 switches that are not running version 10.04.0001.

model:6300 -running-
config:"access-list ip hvac_
segmentation"

Model 6300 switches that do not have the ACL named "hvac_segmentation" in
their running configuration.

hostname-AUS-05-.* Devices with a hostname matching the regular expression. For example, in a
deployment where host names are encoded as ( <site>-<building>-<floor>-
<number>).

site:Aruba* Devices with the Ssite name starting with Aruba.

Table 136: List of Sample Queries

Viewing Configuration Using MultiEdit on AOS-CX
View configuration of switches and find differences in the configuration across switches in the MultiEdit
mode.

To view switch configuration in the MultiEdit mode, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a group in the filter, complete the following steps:

a. Set the filter to a group.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-CX or Config icon to view the AOS-CX switch configuration dashboard.

n To select a switch, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click an AOS-CX switch under Device Name.

The dashboard context for the switch is displayed.

d. Under Manage, click Device.

The AOS-CX UI configuration page is displayed.

2. To enable MultiEdit mode, move the MultiEdit toggle switch to the on position.

The Device-Level Configuration page is displayed with the list of devices displayed in the
Devices table.
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At the device level, the Devices table lists only the switch that you have selected. Also, a pop-up is
displayed on the bottom-right corner of the page with the options View Config, Edit Config, and
Express Config. Go to step 6.

3. Search for a switch by entering a search query in the Contextual Search Engine field.

For more information about search queries, see Using Device Search on AOS-CX.

4. In the Devices table, select one or more switches by clicking the corresponding rows.

A pop-up window is displayed on the bottom-right corner of the page with the View Config, Edit
Config, and Express Config options.

5. To view the configuration of switches, click View Config.
n If you select a single switch, the View Configuration page is displayed. The running switch

configuration is displayed in the Configuration window.
n If you select multiple switches, the View Multi-Device Configuration page is displayed with the

following panes:
o Devices—Lists the selected switch names.

Select the switches for which you want to view the configuration by selecting the
corresponding check box.

o Configuration—Displays the aggregate running configuration of all selected switches.

The following features are supported in the view page:

n Configuration that is same across all switches is displayed as normal text.
n Differences in configuration is displayed as one of the following:

o Highlighted parameters (in green)—When parameter value differs across switches. Hover
over the parameter to view the list of switches that have this parameter.

o Entire line differences—Entire line differences are displayed by highlighting the lines along
with a description mentioning the switch name that has this line in the configuration. When
more than one switch contains this line, a summary of the number of switches is displayed.
For example, 2/7 is displayed if two out of seven switches that are selected contain this line
in the configuration. To view the list of switches, hover over this summary.

To view the values of these parameters, right click on the parameter.

The View Parameters pane is displayed. If the parameter is already configured on a switch,
the value is displayed. Else, N/A is displayed.

Editing Configuration Using MultiEdit on AOS-CX
Edit configuration for one or more switches in the MultiEdit mode. Edit the entire configuration in a
familiar looking CLI with syntax checking, colorization, and command completion.
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MultiEdit mode displays only the running configuration on a switch. It supports only those commands that
appear in the switch running configuration.

For a list of unsupported commands, see Commands Not Supported in the MultiEdit Mode.

For example, to delete VLAN 25 from the switch configuration in the Edit Config page, instead of entering no

vlan 25, you must perform one of the following actions:

n If VLAN 25 is a standalone line in the configuration, then delete this line in the Edit Config page.
n If VLAN 25 is part of a range of VLANs 1 to 30, then delete VLAN 25 by editing the VLAN configuration line

as vlan 1-24,26-30.

To edit and review switch configuration in the MultiEdit mode, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a group in the filter, complete the following steps:

a. Set the filter to a group.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-CX or Config icon to view the AOS-CX switch configuration dashboard.

n To select a switch, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click an AOS-CX switch under Device Name.

The dashboard context for the switch is displayed.

d. Under Manage, click Device.

The AOS-CX UI configuration page is displayed.

2. To enable MultiEdit mode, move the MultiEdit toggle switch to the on position.

The Device-Level Configuration page is displayed with the list of devices displayed in the
Devices table.

At the device level, the Devices table lists only the switch that you have selected. Also, a pop-up is
displayed on the bottom-right corner of the page with the options View Config, Edit Config, and
Express Config. Go to step 6.

3. Search for a switch by entering a search query in the Contextual Search Engine field.

For more information about search queries, see Using Device Search on AOS-CX.

4. In the Devices table, select one or multiple switches by clicking the corresponding rows.

A pop-up window is displayed on the bottom-right corner of the page with the View Config, Edit
Config, and Express Config options.

5. To edit the configuration of switches, click Edit Config.
n If you select a single switch, the Edit Configuration page is displayed.
n If you select multiple switches, the Edit Multi-Device Configuration page is displayed with

the following panes:
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o Devices—Lists the selected switch names.

Select the switches for which you want to edit the configuration by clicking the row
corresponding to the switches.

o Configuration—Displays the aggregate running configuration of all switches.

In both the pages, the following views are available:
n Editor View—Displays the aggregate running configuration on the switches in the

Configuration pane. Edit the configuration in this view.

When editing multiple switches, the Devices pane is also displayed. Select the check box for
the switches you want to edit. The following features are supported in the Editor View:
o Configuration that is same across all switches is displayed as normal text.
o Differences in configuration is displayed as one of the following:

l Highlighted parameters (in green)—When parameter value differs across switches.
Hover over the parameter to view the list of switches that have this parameter.

l Entire line differences—Entire line differences are displayed by highlighting the lines
along with a description mentioning the switch name that has this line in the
configuration. When more than one switch contains this line, a summary of the number
of switches is displayed. For example, 2/7 is displayed if two out of seven switches that
are selected contain this line in the configuration. To view the list of switches, hover over
this summary.

To modify the values of these parameters, right-click the parameter.
The Modify Parameters pane is displayed with the following options:
l If the parameter is already configured on a switch, you can modify the value. Otherwise,
N/A is displayed for the value and it cannot be modified.

l If you want to apply the same value to all selected switches, select the Set same value
for all devices check box.

l To save the changes, click Save Changes in the Modify Parameters pane.

Clicking Save at the bottom of the Editor View discards the changes made in the Modify
Parameters pane.

o Command completion and help text are available by pressing the CTRL+SPACE key
combination.
An inline drop-down list is displayed with the available commands or parameters within
commands. To insert a command or parameter, select an option and press TAB.

o Syntax errors are marked (in red) directly under the incorrect text.
o If a command line is not inserted in the correct position, the line is automatically moved to

the correct position in the configuration.
For example, if the configuration contains information for VLAN IDs 1 to 3, and you are
adding VLAN 4 after VLAN 1 in the configuration, the editor moves the VLAN 4 command
line after VLAN 3.

n Diff View—Displays the difference between changes made in the Editor View and the
running configuration on a switch. In this view, two panes, Running and Candidate, are
displayed. When viewing details of multiple switches, select a switch from the drop-down list.
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n The Running pane displays the running configuration on the switch.
n The Candidate pane highlights the changes made in the Editor View in addition to displaying

the running configuration on the switch. You cannot edit the switch configuration in this view.

6. Edit the configuration in the Editor View, and click Save.

Configuration Drift Warning in Edit Config
When you edit the configuration of the same AOS-CX switch, in the MultiEdit mode, in two different
browser tab sessions, and try to save the configuration one after the other, the following events occur:

1. The configuration that you save first in the editor in any of the two browser tabs is saved on the
switch.

2. When you try to save the configuration in the editor in the other browser tab, Aruba Central On-
Premises displays a warning that the configuration has been changed outside the current editor.

3. If you ignore the warning and continue to save the configuration, Aruba Central On-Premises
overwrites the changes saved earlier with the current changes.

If you save any changes in the MultiEdit mode and the changes do not reflect on the switch, check the
Audit Trail details for any errors in the configuration sync.

Commands Not Supported in the MultiEdit Mode
The following table lists the AOS-CX switch commands that are not supported and details about how
they function in the MultiEdit mode in Aruba Central On-Premises. It is recommended to use these
commands in the MultiEdit Edit Config page with caution.

Command Caution When Editing or Deleting Command

configuration-lockout Users must not delete or replace this command. If this command is deleted or
replaced in Aruba Central On-Premises, a warning is displayed and the user
must undo the changes made to this command.
n Aruba Central On-Premises Managed mode is disabled and changes can

be made outside of Aruba Central On-Premises.
n Changes made using NAE, REST APIs, or the switch CLI will be absorbed

into Aruba Central On-Premises, hence causing a local override. The
switch template will be deleted and replaced by the switch configuration.

vsx in switches running AOS-
CX 10.06 or earlier versions

Users can add, edit, delete this command . However, VSX peer switch must be
managed as a separate device in Aruba Central On-Premises.

vsx-sync in sub-contexts Users must not add, edit, or delete this command in Aruba Central On-
Premises. If users perform any of these actions, a warning is displayed and
the user must undo the changes made to this command.

vsf member <n> if all
switches are running AOS-CX
10.07 or later versions

Users must not delete this command. If users attempt to delete this
command, a warning is displayed however, the user is allowed to proceed
with configuration.
n In case this command is deleted from the member, the member restarts

and resets the configuration.

Table 137: AOS-CX Commands not Supported in the MultiEdit Mode
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Command Caution When Editing or Deleting Command

n In case this command is deleted from the conductor, then Aruba Central
On-Premises loses connectivity with the stack.

type <jnumber> Users must not delete or edit this command. If users perform any of these
actions, a warning is displayed however, the user is allowed to proceed with
configuration.
n In case this command is deleted or edited on the member, the member

restarts and resets the configuration.
n In case this command is deleted or edited on the conductor, then Aruba

Central On-Premises loses connectivity with the stack.

aaa authorization

commands default group

tacacs local

Users must not add this command. If users add this command, they will be
forced to delete the command.

access-list Users must not add, edit, or delete this command in Aruba Central On-
Premises. If users perform any of these actions, a warning is displayed and
the user must undo the changes made.

port-access role Users must not add, edit, or delete this command in Aruba Central On-
Premises. If users perform any of these actions, a warning is displayed and
the user must undo the changes made.

Show commands (for example,
show running-config, show

interface brief)

N/A
These commands do not appear in the running configuration of a switch and
hence will not be visible in the MultiEdit mode (View Config or Edit Config).

Action commands (for
example, ping, boot system,

erase)

N/A
These commands do not appear in the running configuration of a switch and
hence will not be visible in the MultiEdit mode (View Config or Edit Config).

Commands used to reset
entities to defaults (for
example, no bfd, no vrf, no
router ospf, default

interface <IFRANGE>)

N/A
These commands do not appear in the running configuration of a switch and
hence will not be visible in the MultiEdit mode (View Config or Edit Config).

Configuration context
switching commands (for
example, interface 1/1/1-

1/1/5)

N/A
These commands do not appear in the running configuration of a switch and
hence will not be visible in the MultiEdit mode (View Config or Edit Config).

Express Configuration Using MultiEdit on AOS-CX
Express configuration provides a way to efficiently apply a predefined set of configuration settings to
switches. Each set of configuration settings can contain settings for Network Analytics Engine (NAE) or
device profile features.

To apply express configuration, complete the following steps:



Aruba Central On-Premises 2.5.7 | User Guide 625

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a group in the filter, complete the following steps:

a. Set the filter to a group.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-CX or Config icon to view the AOS-CX switch configuration dashboard.

n To select a switch, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click an AOS-CX switch under Device Name.

The dashboard context for the switch is displayed.

d. Under Manage, click Device.

The AOS-CX UI configuration page is displayed.

2. To enable MultiEdit mode, move the MultiEdit toggle switch to the on position.

The Device-Level Configuration page is displayed with the list of devices displayed in the
Devices table.

At the device level, the Devices table lists only the switch that you have selected. Also, a pop-up is
displayed on the bottom-right corner of the page with the options View Config, Edit Config, and
Express Config. Go to step 6.

3. Search for a switch by entering a search query in the Contextual Search Engine field.

For more information about search queries, see Using Device Search on AOS-CX.

4. In the Devices table, select one or more switches by clicking the corresponding rows.

A pop-up window is displayed on the bottom-right corner of the page with View Config, Edit
Config, or Express Config options.

5. Click Express Config.

The Express Config (N) window is displayed, where N represents the number of switches
selected.

6. Select the required feature from the drop-down list. The following features are supported:
n Device Profile
n Network Analytics Engine

7. Configure the following parameters corresponding to the selected feature as described in Table
138 and Table 139.

8. Click Save.

You can view the express configuration that you apply in the Configuration Status page if the Auto-
Commit state is off, or in the View Config page if the Auto-Commit state is on. For more information
on viewing the pending changes, local overrides, and the configuration status, see Using Configuration
Status on AOS-CX.
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Name Description Value

Enable Enables or disables the device profile configuration on the
switches.

Select or clear the check box.

Profile Name Name of the device profile. This field is pre-configured
and cannot be edited.

VLAN Mode VLAN mode for the device profile. Depending on the
VLAN mode, configure one of the following:
n Access:

o Access vlan—ID of the access VLAN.
n Trunk:

o Native vlan—ID of the native VLAN.
o Allowed vlan list—Single or a range of allowed VLAN

IDs.

Integer in the range 1 to

4094.

PoE Priority PoE priority for the device. Low, High, Critical

Allow Jumbo
frames

Enables or disables processing of jumbo frames by the
switches.

Select or clear the check box.

The following table describes the device profile parameters.
Table 138: Device Profile Parameters

Name Description

NAE Script
Name

Name of the NAE script. You can also configure the agent parameters.
The following NAE scripts are supported:
n software_device_health_monitor.1.8—Monitors overall software device health.
n hardware_device_health_monitor.1.6—Monitors overall hardware device health.
n application_health_monitor.1.3—Monitors application health using TCP SYN and ACK

packets, and VoIP IP SLA sessions.
n stp_health_monitor.3.1—Monitors health of ports that are involved in spanning tree

protocol.

n client_services_health_monitor.2.0—Monitors overall client health services.

n routing_health_monitor.1.2—Monitors overall routing health.

n system_resource_health_monitor.4.0—Monitors overall system resource health.

n vsf_health_monitor.1.0—Monitors overall VSF health.

The following table describes the network analytics engine parameters.
Table 139: Network Analytics Engine Parameters

Using Configuration Status on AOS-CX
Aruba Central On-Premises provides an audit dashboard for reviewing configuration changes for the
AOS-CX switches provisioned in UI groups. The Configuration Status page displays the configuration
status of the switches, pending changes, and local overrides present in the AOS-CX switches. It also
provides options to push uncommitted changes to the switches.

To view and commit the configuration changes, complete the following steps:
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1. In the Aruba Central On-Premises app, select one of the following options:
n To select a group in the filter, complete the following steps:

a. Set the filter to a group.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-CX or Config icon to view the AOS-CX switch configuration dashboard.

n To select a switch, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click an AOS-CX switch under Device Name.

The dashboard context for the switch is displayed.

d. Under Manage, click Device.

The AOS-CX UI configuration page is displayed.

2. Click Configuration Status.

The Configuration Status page is displayed with details about the configuration status of AOS-
CX switches.

The page displays the following information at the group and device levels:
n  At the group level:

o Auto-commit Changes State section—Click a number to view corresponding results
filtered in the Auto Commit State column in the Switches table.
l Devices auto-commit state—Count of switches that have the auto-commit state on

and off.
o Configuration Issues section—Click a number to view corresponding results filtered in the

Config Status column in the Switches table.
l Pending changes—Count of switches that have configuration changes that are pending

commitment to the switch.
l Configuration errors—Count of switches for which errors in the pending configuration

caused an attempted commit to fail.
In the Config Status column, click the link corresponding to the status to view the pending
changes in a configuration or the Error - Configuration conflicts link to view any issues in
a pending configuration. For more information, see Viewing and Committing Configuration
Issues and Pending Changes at the Group Level.

o Local Overrides section—Displays whether a switch in the group has any local overrides.
Click Yes to view the local overrides. The Local Overrides window is displayed. You can
view configuration differences for each device within the group. The overrides are grouped
based on the features that are configured in the UI and are displayed as drop-down
sections. For example, all overrides for VLANs are listed under a separate drop-down with
the heading VLANs. The new configurations are highlighted in green, and the deleted
configurations are struck through in red. You can also filter the devices in the table based
on whether there are local overrides available for a switch.
To view all unchanged information, click the Hide unchanged values check box. By default,
the check box is enabled which displays only the changed values (overrides).
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If there’s no override for a switch in the group, the Local Overrides column displays No, and
users cannot click No.

Some overrides displayed in the Local Overrides window may also come from workflows.

n  At the device level:
o Auto-commit Changes State section—Enable or disable the auto-commit mode by

moving the toggle switch to the on or off position.
l Toggle switch in the on position—Displays a message that the configuration changes will

be committed to the device immediately.
l Toggle switch in the off position—Displays a message that the configuration changes will

not be committed to the device immediately.
o Configuration State Issues section—Displays a message defining the status of

configuration on the switch. For a list of all status messages, see the description of the
Config Status column in Table 140.
Click the Pending Changes link to view the pending changes in a configuration or the Error
- Configuration conflicts link to view any issues in a pending configuration. For more
information, see Viewing and Committing Configuration Issues and Pending Changes at the
Group Level.

o Overrides section—Displays a message to indicate whether there are any overrides in the
switch configuration at the device level or not. Click View Local Overrides to view the local
overrides of the device. The Local Overrides window is displayed. The overrides are
grouped based on the features that are configured in the UI and are displayed as drop-
down sections. For example, all overrides for VLANs are listed under a separate drop-down
with the heading VLANs. The new configurations are highlighted in green, and the deleted
configurations are struck through in red.
To view all unchanged information, click on the Hide unchanged values check box. By
default, the check box is enabled which displays only the changed values (overrides).

If there’s no override, then the View Local Overrides option is disabled.

Some overrides displayed in the Local Overrides window may also come from workflows.

3.  Click the number in the sections to apply the corresponding filter in the Switches table.

The Switches table displays the information described in Table 140.

The Switches table appears only at the group level.

Column Description Value

Name Name of the switch.

Auto
Commit
State

Status of the auto commit option for the switch. On, Off

Table 140: Details in the Switches Tables



Aruba Central On-Premises 2.5.7 | User Guide 629

Column Description Value

Config
Status

Status of switch configuration between the device and Aruba Central On-
Premises. The following statuses are available:
n Error - Configuration conflicts
n Error - Internal error
n Error - Login pending
n Error - Modified outside Central
n Offline
n Pending changes
n Pending changes - Offline
n Pending group configuration
n Synchronized
n Synchronizing

Local
Overrides

Indicates whether any overrides exist in the switches.
n Interfaces

n LAGs

n Client Roles

n Loop Prevention

n Properties

n VLANs

n Static Routing

n TACACS Servers

n Radius Servers

n Source Interface

n Dynamic Segmentation

Note: To view all unchanges information, click on the Hide unchanged
values checkbox. By default, the checkbox is enabled which displays only
the changed values (overrides).

Yes, No

Viewing and Committing Configuration Issues and Pending Changes at the
Group Level
To view and commit configuration issues and pending changes in AOS-CX switches at the group level,
complete the following steps:

1. To view the pending changes in a configuration click the link corresponding to the following
statuses in the Config Status column for the switch:
n Error - Internal error
n Error - Modified outside Central
n Pending changes
n Pending changes - Offline
n Synchronizing

The Pending Configuration Changes window is displayed for that switch. This window displays
the running and pending configurations of the switch and lets you review the changes made in
configuration.
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2. Click one of the following buttons depending on the status:
n Click Commit Now—Displayed only when the user has modify permissions for the group, and

when auto-commit state is off and there are pending changes but no errors.

Click this button to push the pending changes to the switch.
n Click Close—Click this button to close the Pending Configuration Changes window without

modifying the switch configuration.

3. To view issues with a pending configuration, click the Error - Configuration conflicts link in the
Config Status column for the switch.

The Configuration Conflicts window is displayed for that switch. This window displays a
description for each error and the line number in the configuration file where the error has
occurred.

The line number displayed in the Configuration Conflicts window might not be same as in the
configuration editor. You must look for the correct line in the editor by searching the command where
the error occurs.

4. Click Close.

Viewing and Committing Configuration Issues and Pending Changes at the
Device Level
 To view and commit configuration issues and pending changes in AOS-CX switches at the device level,
complete the following steps:

1. To view the pending changes in a configuration click the Pending Changes link in the
Configuration State Issues section.

The Pending Configuration Changes window is displayed for that switch. This window displays
the running and pending configurations of the switch and lets you review the changes made in
configuration.

If the pending changes do not have any errors, the Commit Now button is displayed, both in the
Configuration State Issues section and in the Pending Configuration Changes window.

2. Click Commit Now to push the pending changes to the switch.

3. To view issues with a pending configuration, click the Error - Configuration conflicts link in the
Configuration State Issues section.

The Configuration Conflicts window is displayed for that switch. This window displays a
description for each error and the line number in the configuration file where the error has
occurred.

The line number displayed in the Configuration Conflicts window might not be same as in the
configuration editor. You must look for the correct line in the editor by searching the command where
the error occurs.

4. Click Close.

Managing an AOS-CX VSF Stack
A switch stack is a set of switches that are interconnected through stacking ports. By default, the first
member in a stack becomes conductor. You must configure the standby conductor manually and there
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is no default standby conductor. All the switches in the stack other than the conductor and standby
conductor become members.

The following table lists the AOS-CX switches that support stacking.

Switch
Platform

Maximum
Number
of Stack
Members

Minimum
Supported
Version

Recommended
Version

Supported
Stack Type

Supported
Configuration
Group Type for
Stacking (UI /
Template)

AOS-CX 6200
Switch Series

8 10.06.0200,
10.10.1000
and later

10.12.xxxx VSF UI and Template

AOS-CX 6300
Switch Series

10 10.06.0200,
10.10.1000
and later

10.12.xxxx VSF UI and Template

Table 141: AOS-CX Switch Stacking Support

For more information on topology and configuration of switch stacks, see the AOS-CX Virtual Switching
Framework (VSF) Guide for the respective switch series.

Supported Switch Stacking Functions
The following table lists the functions supported in Aruba Central On-Premises, using UI and template
configurations, based on the switch firmware versions.

Firmware
Versions Functions Supported in Aruba Central

10.06 and
earlier

n Onboarding pre-configured AOS-CX stack
n Pushing switch configuration from Aruba Central using UI options, MultiEdit, or templates
n Rebooting a conductor

NOTE: This will reboot the entire stack.

10.07 and
later

n Onboarding pre-configured AOS-CX stack
n Pushing switch configuration from Aruba Central using UI options, MultiEdit, or templates
n Creating a stack
n Adding a stack member
n Removing a stack member
n Modifying VSF links
n Changing the secondary member
n Rebooting a conductor

NOTE: This will reboot the entire stack.

Table 142: Supported Stacking Functions

The other stacking related configurations such as replacing a conductor, replacing a standby conductor,
and replacing a stack member must be performed offline, that is, outside Aruba Central. The changes
are reflected in Aruba Central.
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For information on these configurations, see the AOS-CX Virtual Switching Framework (VSF) Guide for the
respective switch series and the ArubaOS-CX VSF Best Practices document.

General Recommendations
The following are the general recommendations to note when configuring an AOS-CX switch stack:

n To maximize available VSF link bandwidth, use the following Direct Attach Copper (DAC) cables for
VSF links:
o AOS-CX 6300 Switch Series: 50G
o AOS-CX 6200 Switch Series: 10G

n All VSF link ports in a stack must operate at the same speed (10G, 25G, or 50G).
n For maximum stack resiliency, the conductor and secondary conductor should be the same switch

models with redundant power supplies connected to different circuits. This is required to minimize
the probability that a single-source power failure will disable both the stack conductor and standby.

n A secondary member must always be defined to assume the VSF standby role.
n The out-of-band management (OOBM) ports on the conductor and secondary conductor must be

connected to each other, either directly or through a dedicated management network. This is
required to utilize the VSF split detection, which must always be enabled.

Monitoring AOS-CX Switch Stacks
To monitor and troubleshoot switch stacks that are provisioned and managed through Aruba Central,
see Monitoring AOS-CX Switch Stacks.

Viewing AOS-CX Switch Stacks in Site Topology
See Monitoring Sites Topology Tab.

This section contains the following topics:

n Onboarding AOS-CX VSF Stack to Aruba Central On-Premises
n Configuring AOS-CX VSF Stacks Using UI Groups
n Configuring AOS-CX VSF Stacks Using Template Groups
n Replacing an AOS-CX VSF Stack Member
n Removing an AOS-CX VSF Stack Member Using UI
n Changing an AOS-CX VSF Stack to Standalone Switches on page 650

Onboarding AOS-CX VSF Stack to Aruba Central On-Premises
The following figure illustrates the provisioning steps for each group type for a VSF stack.

https://arubapedia.arubanetworks.com/arubapedia/images/5/53/AOS-CX_VSF_Best_Practices.pdf
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Figure 72 Stack Provisioning Steps Per Group Type

When moving a pre-configured stack to a UI group, Aruba Central configuration at the group level will
overwrite configuration on the switch. Before moving a pre-configured stack to a UI group in Aruba
Central, if you want to preserve any group-level configuration that is present on the stack, you must
configure them at the group level in Aruba Central. However, since multiple stacks can be managed
using the same UI group, if you do not want any particular configuration on some stacks, you must
delete them at the device level in Aruba Central.

For example, if you want to preserve the VLANs 20, 30 on stack1 and VLANs 40, 50 on stack2, then you
must configure VLANs 20, 30, 40, and 50 at the group level in Aruba Central. After moving the stacks to
the UI group, you must delete VLANs 40, 50 on stack1 and VLANs 20, 30 on stack2.

The following are the details of the configurations supported at the group level and device level for a
stack:

n Configurations supported at the group level for a stack—SNMP, Logging, Administrator, Access
Control, VLANs, and other features available at the group level

n Configurations supported only at the device level for a stack—Ports & Link Aggregations,
Authentication Servers, Authentication, Access Control, VLANs, Loop Prevention, and Static
Routing

To onboard an AOS-CX VSF stack to Aruba Central On-Premises, complete the following steps:

1. Setup the switch stack using the Aruba CX mobile application or the CLI.

This step must be performed outside Aruba Central On-Premises.

For information , see AOS-CX Virtual Switching Framework (VSF) Guide.
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If you want to create a new stack with devices that are already present in Aruba Central On-Premises,
you must first disconnect and delete all these devices from Aruba Central On-Premises and then
convert them as conductor, standby, and members. For information about deleting offline switches
from Aruba Central On-Premises, see Deleting an Offline Switch.

2. Add and subscribe the conductor, standby conductor, and all members in the AOS-CX stack to
Aruba Central On-Premises. The other members are optional to be added to Aruba Central On-
Premises.

Adding and subscribing devices is done through the HPE GreenLake account home. For more
information about HPE GreenLake, see the Managing Devices and Subscriptions..

3. Create a template group or UI group for the AOS-CX VSF stack in Aruba Central On-Premises.

In the template group, all user-defined template variables for the conductor and standby devices
should contain the same values, to ensure template consistency after a stack failover event. For
information on variables for template-based configuration, see Managing Variable Files.

4. Assign the stack members to the template group from the following page:
n Groups page under Maintain > Organization in the Aruba Central On-Premises app.

For more information on assigning a stack, see Assigning Devices to Groups.

You can move a stack across different UI groups or template groups.

5. To push switch configurations to the conductor and members in the AOS-CX VSF stack from
Aruba Central On-Premises, use one of the following ways:
n Template group—Create a configuration template in the template group for the AOS-CX VSF

stack in one of the following ways:
o Copy the details of the show running config command of the AOS-CX VSF stack from the

conductor and paste it in the template.
Ensure to update the password in plaintext.

o Use the Import Configuration As Template option.
The switches must be running AOS-CX 10.06 or a later version.

n UI group—Use UI options and MultiEdit mode in the AOS-CX switch configuration dashboard.

Before moving the stack to a UI group in Aruba Central On-Premises, save the output of the
show running config command from the conductor. This is required to restore or apply any
configuration that might be lost because of group-level overwrite of configuration. You can
apply this configuration after moving the stack to the UI group using the Edit Config option in
the MultiEdit mode.

The UI options and MultiEdit mode are available only when the AOS-CX VSF stacks are added
to a UI group. For more information, see Configuring AOS-CX Switches in UI Groups.

https://support.hpe.com/hpesc/public/docDisplay?docId=a00120892en_us
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n In Aruba Central On-Premises, select the serial number of the conductor switch to push switch
configuration to the conductor, standby conductor, and all members in the stack.

n Port-specific configurations such as Ports & Link Aggregations, Authentication Servers,
Authentication, Access Control, VLANs, Loop Prevention, and Static Routing can be
configured on stack members only at the device level.

n It is not recommended to perform any stacking-related configurations, such as setting up a
stack, using the MultiEdit mode.

6. To make stack-topology changes, use one of the following ways:
n Template group—Update the configuration template in the template group for the AOS-CX VSF

stack.
n UI group—Use the VSF Stacking page in the AOS-CX configuration dashboard.

The UI options are available only at the group-level.

This step is applicable only for the switches running AOS-CX 10.07 or later firmware versions.

Configuring AOS-CX VSF Stacks Using UI Groups
You can create VSF stacks, add stack members, modify VSF links, change standby conductor and remove
stack members through the UI.

Stacks can be configured only at the group-level.

To create and manage stacks through the UI, ensure that the following prerequisites are met:

n All switches in the VSF stack are added to the device inventory and assigned with a license.
n All switches in the VSF stack are set to the factory default configuration.
n All switches in the VSF stack are running 10.07 or later firmware versions.
n All switches in the VSF stack are of the same switch series. Stacks cannot be created with a mixed set

of switches. The stacks must be made up of either only 6200 or only 6300 switches.
n Members in the VSF stack other than the conductor should not have an uplink connectivity.

Otherwise, auto-stacking will not work.
n Before creating a stack, only the conductor must be moved to the UI group. All other stack members

will be automatically moved to the UI group once the stack is created.
n  For auto-stacking to work, the switches should be connected in the direction of the higher

denomination port to the lower denomination port.

The following ports are reserved for auto-stacking:
o 24-port switch models— Ports 25 and 26
o 48-port switch models— Ports 49 and 50

For more information on auto-stacking configuration, refer to the AOS-CX Virtual Switching
Framework (VSF) Guide.

For more information, see the following topics:

n Creating an AOS-CX VSF Stack Using UI
n Adding a Stack Member Using UI
n Modifying VSF Links Using UI
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n Changing the Standby Conductor Using UI
n Removing an AOS-CX VSF Stack Member Using UI

Creating an AOS-CX VSF Stack Using UI
In Aruba Central On-Premises, you can create a create a VSF stack by selecting and configuring the
conductor switch through the UI.

Before creating a stack, you must physically connect the members of the stack in the chain or ring
topology on the ports reserved for auto-stacking. For auto-stacking to work, the members should be
connected in the direction of the higher denomination port to the lower denomination port.

The following ports are reserved for auto-stacking:

n 24-port switch models— Ports 25 and 26
n 48-port switch models— Ports 49 and 50

Auto-stacking peer discovery is a uni-directional process. It starts with the VSF link containing the higher
denomination VSF port. Member discovery starts on the higher-numbered port for each member in
line. For a three-member stack in the ring topology, use the following connection example for auto-
stacking to work:

n Connect port 50 of member 1 to port 49 of member 2
n Connect port 50 of member 2 to port 25 of member 3
n Connect port 26 of member 3 to port 49 of member 1

For more information on auto-stacking configuration, refer to the AOS-CX Virtual Switching Framework
(VSF) Guide.

The stack can be created only at the group-level.

To create an AOS-CX VSF stack, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one switch.
2.  Under Manage, click Devices > Switches.
3. Click the AOS-CX or Config icon to view the switch configuration dashboard.
4. Click System > Stacking.

The VSF Stacking page is displayed with a list of stacks.

5. In the VSF Stacking table, click + to create a stack.

The Create VSF Stack page is displayed.

6. Configure the parameters described in Table 143.

7. Click Save.

The new stack is displayed in the Stacking table with the conductor switch. The stack creation may
take up to 10 minutes. You can use the Configuration Audit page to verify the status of a stack
formation.

To monitor switch stacks and troubleshoot any stack-related errors, select the conductor switch
of stack from the Devices list and navigate to the LAN > Ports tab. For more information, see
Monitoring AOS-CX Switch Stacks.
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Parameters Description Value

Switch Series The switch platform for the VSF Stack. 6200 or 6300

Conductor The Conductor switch in a Stack, Select the switch from the drop-down.

Link 1 port(s) One or more port numbers for the first VSF
link separated by commas.

Following are the default port values:
n 24-port switch models—25
n 48-port switch models—49

Link 2 port (s) One or more port numbers for the second VSF
link separated by commas.

Following are the default port values:
n 24-port switch models—26
n 48-port switch models—50

Split Mode
detect

Indicates whether VSF split detection mode is
enabled. If this is enabled, during a split, the
fragment that has the conductor becomes the
active fragment and keeps its front plane
(non-VSF) interfaces up and running. The
other fragment becomes inactive and all non-
VSF interfaces on the inactive fragment are
brought down to avoid network disruption.

NOTE: It is recommended to enable this field
during the stack creation. Also, ensure that the
conductor and standby conductor are
connected to the management interface.

Select the check box to enable or disable.

The following table describes the VSF stack parameters.
Table 143: Create VSF Stack

Editing the Conductor

To edit the conductor, point to the row for the conductor, and click the edit icon.
You can only edit the following parameters:

n Split Mode detect
This parameter is available only for the conductor.

n Link 1 Port(s) and Link 2 Port(s)
For more information on changing the VSF links, see Modifying VSF Links Using UI.

Removing a Stack

To remove a stack, point to the stack you want to remove and click the delete icon. In the VSF
Stacking page, you can delete a stack only in the following scenarios:

n If there is only one member in a stack.
n If all other stack members except conductor are down.

Stacks cannot be deleted when the status of members are online.

To remove a stack with more than one member, it is recommended to remove individual members, one
at a time, starting from the last member in the stack. For more information, see Removing an AOS-CX
VSF Stack Member Using UI.
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n Deleting the stack from the VSF Stacking page will remove the VSF stacking configuration from the
conductor. Once the stack is deleted, the conductor will reboot and move to the unprovisioned group as a
standalone device.

n Conductor member cannot be deleted as an individual member.

Adding a Stack Member Using UI
In Aruba Central On-Premises, you can add and configure the members through the UI. Before adding a
stack member, it is recommended to navigate to the Switch> LAN > Ports tab in the switch dashboard,
to see whether there are any errors in the stack. For more information, see Monitoring AOS-CX Switch
Stacks.

If you are onboarding a pre-configured stack or if the stack is formed through auto-stacking, then you do not
need to add the stack through the UI. Aruba Central On-Premises will automatically sync the configuration
done on the switch and display the members in the VSF Stacking table.

To add a switch to stack as a new member, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a group containing at least one switch.
2.  Under Manage, click Devices > Switches.
3. Click the AOS-CX or Config icon to view the switch configuration dashboard.
4. 4. Click System > Stacking.

The VSF Stacking page is displayed with a list of stacks.

5. Expand the stack for which you want to add a member.

The table is displayed with the list of members for that particular stack.

6. To add a stack member, point to the row for the stack and click + in the VSF Stacking table.

The Add Stack Member page is displayed.

7. Configure the parameters described in Table 144.
8. Click Save.

The newly added member is displayed in the VSF Stacking table. It may take up to 10 minutes for
the new member to join the stack. Expand the stack to see the member and its status. You can
use the Configuration Audit page to verify the status of stack formation and the Ports tab in the
switch dashboard to monitor and troubleshoot switch stacks. For more information, see
Monitoring AOS-CX Switch Stacks.

Parameters Description Value

Member ID The identification number of the member in the stack.
This field is auto-generated and the value is
incremented by 1.

Integer

Standby
conductor

The standby conductor of the stack. By default, secondary member
will be selected as the Standby
conductor.

The following table describes the parameters for adding stack member.
Table 144: Add stack member



Aruba Central On-Premises 2.5.7 | User Guide 639

Parameters Description Value

Switch Series The switch platform of the member. This field is auto-
generated and switch mode is displayed based on the
selection of conductor.
The stacking cannot be done with a mixed set of
switches. The stack must be made up of only 6200 or
only 6300 switches.

6200 or 6300

Device The device model of the switch. Select from the drop-down.

Link 1 Port(s) One or more port numbers for the first VSF link
separated by commas.

Following are the default port
values:
n 24-port switch models—25
n 48-port switch models—49

Link 2 Port(s) One or more port numbers for the second VSF link
separated by commas.

Following are the default port
values:
n 24-port switch models—26
n 48-port switch models—50

Editing a Stack Member

To edit a stack member, point to row for the member you want to edit and click the edit icon.

You can only edit the following parameters:

n Standby conductor
n Link 1 Port(s) and Link 2 Port(s)

For more information, see Changing the Standby Conductor Using UI and Modifying VSF Links Using UI.

Modifying VSF Links Using UI
You can modify VSF ports in the VSF links through the UI only when the admin status in the Ports &
Link Aggregations page and operational status in the switch details page for the VSF link ports are
down.

To change the VSF links in the VSF stack, complete the following steps:

1. Set the filter to Global or the group containing the stack.
2. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

3. Select the conductor switch of the stack for which you want to modify the links and navigate to
the Ports & Link Aggregations page.

4. Select the VSF ports that you want to modify and click the edit icon.
5. In the Edit Ports page, clear the Admin Up check box to shut down the port.
6. Remove the physical VSF links from the port that need to be modified.
7. Reconnect the physical links to the port as required.
8. At the group level, navigate to the VSF Stacking page and expand the stack and point to the

member for which you want to modify the links, and click the edit icon.
9. In the Edit Stack Member window, modify the VSF links as required. You cannot edit the

VSF links when the ports are up. Both Link 1 port(s) and Link 2 port(s) should not be modified
at the same time. Otherwise, the stack might break.
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Before modifying VSF links, power down all non-standby members that are connected to the member you are
going to modify. This prevents the members from getting into the recovery mode, after multiple reboots, when
they get disconnected.

Changing the Standby Conductor Using UI
You can change the standby conductor in the stack through the UI.

To change the standby conductor in the VSF stack, complete the following steps:

1. In the VSF Stacking page, expand the stack for which you want to change the secondary
conductor.

2. Point to the row for the member for which you want to select as Standby conductor and click the
edit icon.

3. In the Edit Stack Member page, select the standby conductor check box.

A confirmation window is displayed.

4. Click OK.

Both the existing standby conductor and the new standby conductor will go for a reboot. After
rebooting, the selected member will join the stack as the new standby conductor.

5. Click Save.

Removing an AOS-CX VSF Stack Member Using UI
You can remove a member from the AOS-CX VSF stack in Aruba Central On-Premises only when the
member is offline. It involves completing procedures both inside and outsideAruba Central On-
Premises. The procedure will vary based on the switches firmware versions.

Switches running AOS-CX 10.07 or later versions
If your switches are running AOS-CX 10.07 or later versions, complete the following steps:

1. Shut down the member in the stack.
2. Disconnect the physical VSF links for the member.

Otherwise, the switch will reboot and join the stack again through auto-stacking.

3. Reconnect the physical links as desired.
4. In Aruba Central On-Premises, navigate to the VSF Stacking page and complete the following

steps:
a. Expand the stack for which you want to delete the member.
b. Point to the row for the member you want to delete and click the delete icon.

A confirmation window is displayed.
c. Click Delete.

The member is removed from the VSF Stacking table.

n The removed member must be reset to the factory-default configuration before connecting back
to Aruba Central On-Premises again.

n Conductor member cannot be deleted as an individual member.
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Switches running AOS-CX 10.6 or earlier versions
If your switches are running AOS-CX 10.06 or earlier versions, complete the following steps:

1. Disable Aruba Central On-Premises from the switch CLI.

You must execute these commands only on the conductor of the stack.

switch# configure

switch(config)# aruba-central

switch(config-aruba-central)# disable

2. Wait for the stack to display as offline in the List view.

It may take up to five minutes for the stack to appear offline in Aruba Central On-Premises.

3. Delete the stack from the template group or UI group in Aruba Central On-Premises.

See Deleting an Offline Switch.

4. Remove the member from the VSF stack in the switch CLI.

For example, in a three-member stack, issue the following commands to remove member 3.

switch# configure

switch(config)# no vsf member 3

The specified switch will be unconfigured and rebooted

Do you want to continue (y/n)? y

n When a member (other than the conductor) is removed from the stack, then the member reboots
as a standalone switch and the configuration resets to factory default. The stack will remain with
the conductor and other remaining members.

n However, when the conductor itself is removed from the stack, then the conductor reboots as a
standalone switch and its configuration resets to factory default, and the standby takes the role of
the conductor in the stack.

5. Disconnect the physical VSF links for the member.
6. In the case of template group, update the template in template group Aruba Central On-Premises

with the configuration from the remaining stack.
7. Enable Aruba Central On-Premises from the switch CLI.

If this does not work, run the https-server session close all command.

switch(config-aruba-central)# enable

OR

switch# https-server session close all
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8. In the case of UI group, after enabling Aruba Central, complete the following steps:

Before moving the stack to a UI group in Aruba Central, save the output of the show running config

command from the conductor. This is required to restore or apply any configuration that might be lost
because of group-level overwrite of configuration. You can apply this configuration after moving the
stack to the UI group using the Edit Config option in the MultiEdit mode.

a. Move the stack to the UI group.
b. Paste the running configuration of the conductor, which you copied before moving the stack

to the UI group, in the MultiEdit mode using the Edit Config option.
c. Save the running configuration.

9. Add and subscribe the remaining members in the AOS-CX stack to Aruba Central On-Premises.

Configuring AOS-CX VSF Stacks Using Template Groups
You can create VSF stacks, add stack members, remove stack members, modify VSF links, and change
standby conductor through the template.

To create and manage stacks through the UI, ensure that the following prerequisites are met:

n All the switches in the VSF stack are added to the device inventory and assigned with a valid
subscription.

n All the switches in the VSF stack are set to the factory default configuration.
n All the switches in the VSF stack are running 10.07 or later firmware versions.
n All the switches in the VSF stack are of the same switch series.
n Members in the VSF stack other than the conductor should not have uplink connectivity. Otherwise,

auto-stacking will not work.
n The vsf member 1 line must be present in the configuration template for stackable AOS-CX switches

running 10.07 or later versions. This is required to apply configuration to the switches. Also, the vsf

member 1 line cannot be removed from the template.
n All switches in the VSF stack must be physically connected in the chain or ring topology on the ports

reserved for auto-stacking. For auto-stacking to work, the members should be connected in the
direction of the higher denomination port to the lower denomination port.

The following ports are reserved for auto-stacking:
o 24-port switch models— Ports 25 and 26
o 48-port switch models— Ports 49 and 50

For more information on auto-stacking configuration, refer to the AOS-CX Virtual Switching Framework
(VSF) Guide.

For more information, see the following topics:

n Creating an AOS-CX Stack Using Template
n Adding a Stack Member Using Template
n Modifying VSF Links Using Template
n Changing the Standby Conductor Using Template
n Removing a Stack Member Using Template
n Removing a Stack Using Template
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Creating an AOS-CX Stack Using Template
In Aruba Central On-Premises, you can create stacks through the template. Before creating a stack, you
must physically connect the members of the stack in the chain or ring topology on the ports reserved
for auto-stacking. For auto-stacking to work, the members should be connected in the direction of the
higher denomination port to the lower denomination port.

The following ports are reserved for auto-stacking:

n 24-port switch models— Ports 25 and 26
n 48-port switch models— Ports 49 and 50

Auto-stacking peer discovery is a uni-directional process. It starts with the VSF link containing the higher
denomination VSF port. Member discovery starts on the higher-numbered port for each member in line.
For a three-member stack in the ring topology, use the following connection example for auto-stacking
to work:

n Connect port 50 of member 1 to port 49 of member 2
n Connect port 50 of member 2 to port 25 of member 3
n Connect port 26 of member 3 to port 49 of member 1

For more information on VSF configuration, refer to the AOS-CX Virtual Switching Framework (VSF) Guide.

To create a stack using the template, complete the following steps:

1. In Aruba Central On-Premises, assign the switches to the template from any of the following
pages:
n Device Preprovisoning page under Organization > Maintain > Network Structure.
n Groups page under Maintain > Organization, in the Aruba Central On-Premises app.

For more information on assigning a stack, see Assigning Devices to Groups.

2. Create a configuration template in the template group for the AOS-CX VSF stack.

The following example shows the sample VSF configuration template snippet for a three-member
stack.

It is recommended to configure the VSF split-detection method in the template during stack creation.
Also, ensure that the conductor and standby conductor are connected to the management interface. If
the split-detection method is configured, during a split, the fragment that has the conductor becomes
the active fragment and keeps its front plane (non-VSF) interfaces up and running. The other fragment
becomes inactive and all non-VSF interfaces on the inactive fragment are brought down to avoid
network disruption.

vsf split-detect mgmt

vsf secondary-member 2

vsf member 1

type jl660a

link 1 1/1/26

link 2 1/1/25

vsf member 2

type jl664a

link 1 2/1/25

link 2 2/1/26

vsf member 3
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type jl664a

link 1 3/1/25

link 2 3/1/26

3. Save the template.
4. Connect the uplink to the switch that should act as the conductor.

The switch connects to Aruba Central On-Premises as a standalone device, and is added to the
assigned template group.

Once the switch is added to the template group, Aruba Central On-Premises pushes the template
group configuration to the switch. After the configuration is pushed, starting with the second
switch, each switch in the stack reboots automatically and joins the stack one after another. Each
member may take up to 10 minutes to join the stack.

If the switch is not assigned to any group, then the switch will be added to the default group or
unprovisioned group. The factory default switch is added to the default group and non-factory default
switch will be added to the unprovisioned group. You can verify the serial number of the switch once it
is onboarded and move the switch to the template group as required.

5. To monitor switch stacks and troubleshoot any stack-related errors, select the conductor switch
of the stack from the Devices list and navigate to the LAN > Ports tab.

For more information, see Monitoring AOS-CX Switch Stacks.

Adding a Stack Member Using Template
In Aruba Central On-Premises, you can add and configure the members through the template. Before
adding a stack member, it is recommended to navigate to the stack faceplate in the Switch > LAN
> Ports tab of the switch dashboard, to see whether there are any errors in the stack. For more
information, see Monitoring AOS-CX Switch Stacks.

To add a stack member through the template, complete the following steps:

1. In Aruba Central On-Premises, add the member to the device inventory and assign a valid license.

Ensure that the new member does not have an uplink connectivity to Aruba Central On-Premises.

2. In Aruba Central On-Premises, update the template with the VSF configuration and interface
configurations of the new member.

For example, if you want to add the third member to a two-member VSF stack, add the third-
member VSF configuration to the template, as shown in the following snippet.

vsf member 3

type jl664a

link 1 3/1/25

link 2 3/1/26

3. Save the template.

Once the configuration is pushed to the conductor, the new member reboots and joins the stack.

4. Physically connect the members to the ports reserved for auto-stacking on the switch interfaces.

The member should be connected in the direction of the higher denomination port to the lower
denomination port. The member may take up to 10 minutes to join the stack.
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5. Verify the status of the member addition using switch monitoring pages.

For more information, see Switch > Overview > Summaryand Monitoring AOS-CX Switch Stacks.

Modifying VSF Links Using Template
You can modify VSF links through the template only when the VSF interfaces of all the switches in the
stack are in the shutdown state.

To modify VSF links using the template, complete the following steps:

1. In the Aruba Central On-Premises template, use a variable to hold the shutdown state of the VSF
interfaces for all switches in the stack.

2. Push the template with the interfaces state variables changed to shutdown for the device and
wait for the links to go down.

3. Change the links in the template as required.

4. Change the state to no shutdown in the template variable for the switches in the stack and save
the template.

Changing the Standby Conductor Using Template
To change the standby conductor using the template, update vsf secondary-member <ID> line in the
Aruba Central On-Premises template. For example, if you want to change the standby conductor from
member 2 to member 3 in the stack, update member ID in the line from vsf secondary-member 2 to
vsf secondary-member 3 and save the template. Both the existing standby conductor and the new
standby conductor are rebooted. After rebooting, member 3 joins the stack as the new standby
conductor. The earlier standby conductor becomes a member of the stack.

Removing a Stack Member Using Template
You can remove a stack member using the template. It involves completing procedures both in Aruba
Central On-Premises and on the switch directly.

To remove a stack member using the template, complete the following steps:

1. Shut down the member in the stack.
2. Disconnect the physical VSF links from the member you want to remove.
3. Reconnect the physical links of remaining members in the stack in the ring or chain topology.
4. In the Aruba Central On-Premises template, delete the VSF configuration and interface

configurations of the member.
5. Save the template. Once the configuration is pushed to the conductor, the member will be

removed from the stack.
6. Verify the status of the member deletion using switch monitoring pages.

For more information, see Switch > Overview > Summary and Monitoring AOS-CX Switch Stacks.

Member 1 in the stack cannot be removed from the template.

Removing a Stack Using Template
You can remove a stack member using the template. It involves completing procedures both in Aruba
Central On-Premises and on the switch directly.

To remove a stack using the template, complete the following steps:
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1. In Aruba Central On-Premises, set the Auto Commit State to OFF in the Configuration Audit
page.

2. Shut down all the members in the stack.
3. Remove all the physical VSF links from the members of the stack.
4. Run the erase all zeroize command on the switch CLI for all the switches in the stack.

This causes the switches to reboot, rollback to factory defaults, and connect back to Aruba
Central On-Premises as standalone devices.

5. In Aruba Central On-Premises, set the Auto Commit State to ON in the Configuration Audit
page.

Once the configuration is pushed, the stack is removed from Aruba Central On-Premises.

Replacing an AOS-CX VSF Stack Member
You can replace either the conductor, standby, or any other member of the stack with the same part
number or different part number. These configurations must be performed directly on the switch and
switch CLI, outside Aruba Central On-Premises. The configurations performed directly on the switch are
synced in Aruba Central On-Premises.

This section includes the following topics:

n Switches Running AOS-CX 10.07 or Later Versions
o Same Part number

l Replacing the Conductor
l Replacing the Standby or Other Members

o Different Part Number
l Replacing the Conductor
l Replacing the Standby or Other Members

n Switches running AOS-CX 10.06 or earlier versions
o Replacing the Conductor
o Replacing the Standby or Other Members

Switches Running AOS-CX 10.07 or Later Versions

The new replacement switch must be in the factory-default configuration and running the same firmware
version. Also, ensure that the new switch is added and licensed in Aruba Central On-Premises.

Same Part number
The following section describes the procedures for replacing the conductor, standby, or any other
member with the same part number.

Replacing the Conductor

To replace the conductor in the VSF stack, complete the following steps:

1. Shut down the conductor member in the stack.
2. Wait for the standby member to become the conductor.
3. Replace the conductor switch.
4. Move the VSF link from the old conductor to the new conductor.
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5. Power up the new conductor switch.
6. Switchover to the new conductor in the switch CLI.
7. Verify the status of the stack in the switch monitoring pages.

For more information, see Switch > Overview > Summary and Monitoring AOS-CX Switch Stacks.

Replacing the Standby or Other Members

To replace the standby or any other member of the VSF stack, complete the following steps:

1. Shut down the member in the stack.
2. Replace the old member and renumber the new member using the vsf renumber-to command.

For example, if the member ID of the old member was 2, renumber the new VSF member to 2.

3. Move the VSF link DAC cable from the old member to the new member.
4. Verify the status of the stack in the switch monitoring pages.

For more information, see Switch > Overview > Summary and Monitoring AOS-CX Switch Stacks.

Different Part Number
The following section describes the procedures for replacing the conductor, standby, or any other
member with the different part number.

In case of template groups, the following actions are required:

n Before replacing any stack member, set the Auto Commit State to OFF in the Configuration Audit page.
n After replacing any stack member:

1. In Aruba Central On-Premises, update the template with the new VSF configuration.

2. Set the Auto Commit State to ON in the Configuration Audit page.

Replacing the Conductor

To replace the conductor in the VSF stack, complete the following steps:

1. If Aruba Central On-Premises support mode is disabled, issue the following command in the
switch console to enable Aruba Central On-Premises support mode.

aruba-central support-mode

2. Power off the conductor.

The standby conductor takes over as conductor. Make sure Aruba Central On-Premises is
updated with this failover change.

3. Remove the VSF links from the old conductor.
4. Delete the old conductor from the VSF stack in the switch CLI using the no vsf member <MEMBER-

ID>.

All configuration associated with the member, as well as the subsystems and interfaces of the
member are also removed.

5. Replace the conductor and wait for the member to come up.
6. Configure the new conductor in the switch CLI using the vsf member <MEMBER-ID> command.
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7. Connect the VSF links to the new conductor.
8. Switchover to the new conductor in the switch CLI.
9. In the case of template group, update the template in Aruba Central On-Premises with the new

part number and interface configurations of the new conductor.
10. In the switch console, issue the following command to disable Aruba Central support mode.

no aruba-central support-mode

11. Verify the status of the stack in the switch monitoring pages.

For more information, see Switch > Overview > Summary and Monitoring AOS-CX Switch Stacks.

Replacing the Standby or Other Members

To replace the standby or any other member of the VSF stack, complete the following steps:

1. If Aruba Central On-Premises support mode is disabled, issue the following command in the
switch console to enable Aruba Central On-Premises support mode.

aruba-central support-mode

2. Reset the replacement member with the factory-default configuration.
3. Shut down the member in the stack.
4. Delete the member from the VSF stack in the switch CLI using the no vsf member <MEMBER-ID>.

All configuration associated with the member, as well as the subsystems and interfaces of the
member are also removed.

5. Renumber the VSF member using the vsf renumber-to command.

For example, if the member ID of the old member was 2, renumber the new VSF member to 2.

6. Move the VSF link DAC cable from the old member to the new member.
7. In the case of template group, update the template in Aruba Central On-Premises with the new

part number and interface configurations of the new member.
8. In the switch console, run the following command to disable Aruba Central support mode.

no aruba-central support-mode

9. Verify the status of the stack in the switch monitoring pages.

For more information, see Switch > Overview > Summary and Monitoring AOS-CX Switch Stacks.

Switches running AOS-CX 10.06 or earlier versions
The following section describes the procedures for replacing the conductor, standby, or any other
member with the same or different part number.

Replacing the Conductor

To replace the conductor in the VSF stack, complete the following steps:
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1. Power off the conductor.

The standby conductor takes over as conductor. Make sure Aruba Central On-Premises is
updated with this failover change.

2. Remove the VSF links from the old conductor.
3. Disable Aruba Central On-Premises from the switch CLI by issuing the following commands.

switch# configure

switch(config)# aruba-central

switch(config-aruba-central)# disable

4. Wait for the standby member to become the conductor.
5. If you are replacing the conductor with a different part number, delete the old conductor from

the VSF stack in the switch CLI using the no vsf member <MEMBER-ID>.

All configuration associated with the member, as well as the subsystems and interfaces of the
member are also removed.

6. Replace the member and wait for the member to come up.
7. Configure the new conductor in the switch CLI using the vsf member <MEMBER-ID> command.

8. Configure the new part number and VSF links in the switch CLI using type <TYPE> and link

<LINK-ID> commands for the new conductor.
9. Configure the new member and the VSF links to the new member.

10. In the case of template groups, update the template in Aruba Central On-Premises with the new
part number and the interface configurations of the new conductor.

11. Enable Aruba Central On-Premises from the switch CLI by issuing the following command.

switch(config-aruba-central)# enable

If this does not work, issue the https-server session close all command.

switch# https-server session close all

12. Switchover to the new conductor in the switch CLI.
13. Verify the status of the stack in the switch monitoring pages.

For more information, see Switch > Overview > Summary and Monitoring AOS-CX Switch Stacks.

Replacing the Standby or Other Members

To replace the standby or any other member of the VSF stack, complete the following steps:

1. Reset the replacement member with the factory-default configuration.
2. Disable Aruba Central On-Premises from the switch CLI by issuing the following commands.

switch# configure

switch(config)# aruba-central

switch(config-aruba-central)# disable

3. Shut down the member in the stack.
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4. If you are replacing the member with a different part number, delete the member from the VSF
stack in the switch CLI using the no vsf member <MEMBER-ID>.

All configuration associated with the member, as well as the subsystems and interfaces of the
member will also be removed.

5. Configure the new member in the switch CLI using the vsf member <MEMBER-ID> command .

6. Configure the new part number and VSF links in the switch CLI using type <TYPE> and link

<LINK-ID> commands for the new member.
7. Renumber the VSF member using the vsf renumber-to command.

For example, if the member ID of the old member was 2, renumber the new VSF member to 2.

8. Move the VSF link DAC cable from the old member to the new member.
9. In the case of template groups, update the template in Aruba Central On-Premises with the new

part number and the interface configurations of the new member.
10. Enable Aruba Central On-Premises from the switch CLI by issuing the following command.

switch(config-aruba-central)# enable

If this does not work, run the https-server session close all command.

switch# https-server session close all

11. Verify the status of the stack in the switch monitoring pages.

For more information, see Switch > Overview > Summary and Monitoring AOS-CX Switch Stacks.

Changing an AOS-CX VSF Stack to Standalone Switches
You can change an AOS-CX VSF stack in Aruba Central On-Premises to standalone switches. It involves
completing procedures both in Aruba Central On-Premises and the switch CLI.

Using the VSF Stacking page UI, you can only change the conductor switch to standalone switch.

To change an AOS-CX VSF stack in Aruba Central On-Premises to standalone switches, complete the
following steps:

1. Make a note of the serial numbers of switches that are part of the stack.
2. Disable Aruba Central On-Premises from the switch CLI by issuing the following commands.

switch# configure

switch(config)# aruba-central

switch(config-aruba-central)# disable

3. Wait for the stack to display as offline in the List view.
4. Delete the stack from Aruba Central On-Premises.

For more information, see Deleting an Offline Switch.



Aruba Central On-Premises 2.5.7 | User Guide 651

5. Issue the erase all zeroize command on the switch CLI of the conductor.

This causes the switches to reboot, rollback to factory defaults, and function as standalone
switches. The switches are added to the default group. You can verify the serial number of the
switches once they are onboarded and move the switches to template or UI group as required.

The password for AOS-CX switch will be SERIALNUM_central, until the switches are moved to
template or UI group and custom password is set. For more information on passwords, see the
Password Requirements for Template-Based Configuration section in the Configuring AOS-CX Switches
using Templates topic.

Monitoring AOS-CX Switch Stacks
In the switch dashboard, the Ports tab for a switch stack displays the faceplate of all the switches that
are part of the stack. This allows you to manage, configure, monitor, and troubleshoot switch stacks that
are provisioned and managed through Aruba Central On-Premises.

To navigate to the Ports tab in the Switch dashboard, complete the following steps:

1. Set the filter to Global or the group containing the stack.
2. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

3. Select the conductor switch of the stack from the devices list and navigate to the LAN > Ports tab.

The Ports tab is displayed with the faceplate of all the switches that are part of the stack.

For more information, see Switch > LAN > Ports.

The following figure shows a four-member stack with the conductor, standby, and members with their
corresponding ports and connections.

Figure 73 Switch Stack Faceplate

Stack-Related Errors
The switch stack faceplate displays the following configuration and connection errors related to the
stack. You can monitor and troubleshoot the following errors from the Ports tab:

n Auto-Join Eligibility Error
n VSF Link Errors
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n Cabling Error
n Incompatible Switch Firmware Error

In some cases, there can be multiple VSF errors associated with one VSF link. However, the faceplate
displays only one error at a time. In such cases, you need to fix one error to see another error. For
example, if the VSF link has both auto-join eligibility error and cabling error, only the auto-join eligibility
error is displayed first. Once the auto-join eligibility error is resolved, the cabling error is displayed.

The faceplate will not be displayed when an auto-join eligibility or cabling error occurs on any interface
connected to an existing member. The only exception is the peer-timeout error. This is because there is no
peer MAC for peer-timeout error. Hence, it cannot be determined whether the peer connected to the interface
is already a member of the stack.

Auto-Join Eligibility Error
The auto-join eligibility error is displayed in the Ports faceplate when the conductor or any of the
member switches running AOS-CX 10.07 or later firmware versions in the stack do not have a factory
default configuration.

Member connected to Aruba Central On-Premises

If the member is connected to Aruba Central On-Premises, then click the reset icon in the faceplate.
The RESOLVE AUTO-JOIN window is displayed with a message to reboot the non-factory switch with the
default configuration and join the stack. Click Continue . The switch reboots and joins the stack.

The following error and recommendation are displayed in the faceplate.

Error
Invalid stack configuration/connection
Recommendation
Reset the switch configuration and reboot

Member not connected to Aruba Central On-Premises

If the member is not connected to Aruba Central On-Premises, then the reset icon in the faceplate is
disabled. In this case, execute vsf force-autojoin command through the switch CLI to resolve this
error.

The following error and recommendation are displayed in the faceplate.

Error
Invalid stack configuration/connection
Recommendation
Configure vsf force-auto-join on the switch

The force auto-join will not work if the switch contains any existing VSF configuration. In this case, execute the
erase all zeroize command from the switch CLI. This causes the switch to reboot, rollback to factory-
default configuration, and join the stack if there is no other auto-join error. For more information, refer to the
AOS-CX Virtual Switching Framework (VSF) Guide.

The following figure displays an auto-join eligibility error.
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Figure 74 Auto-Join Eligibility Error

VSF Link Errors
The VSF link errors are displayed in the switch stack faceplate when there are any issues between
VSF links. The faceplate displays a red-warning symbol to help you identify the type of link error in the
switch stacks. You can hover over the warning symbol to identify the interfaces that are disconnected.

The following VSF link errors can be identified from the face plate:

n Broken Link—The broken link error is displayed when a link between the two VSF members is down.
n No peer interface—The no peer interface error is displayed when there is connection issue between

some of interfaces between the two members.

The following figure displays the VSF link errors.

Figure 75 VSF Link Errors

Cabling Error
The cabling error is displayed in the switch stack faceplate when stack cables are connected incorrectly.

For auto-stacking to work, all the stack members must be connected using the following auto-stacking
reserved VSF link ports:

n 24-port switch models— Ports 25 and 26
n 48-port switch models— Ports 49 and 50

Auto-stacking peer discovery is a uni-directional process. It starts with the VSF link containing the higher
denomination VSF port. Member discovery starts on the higher-numbered port for each member in line.
For a three-member stack in the ring topology, use the following connection example for auto-stacking
to work:

n Connect port 50 of member 1 to port 49 of member 2
n Connect port 50 of member 2 to port 25 of member 3
n Connect port 26 of member 3 to port 49 of member 1

The following error and recommendation are displayed in the faceplate:

Error
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Invalid stack configuration/connection
Recommendation
Follow best practices for cabling
For more information on cabling, see the AOS-CX Virtual Switching Framework (VSF) Guide

The following figure displays the cabling error.

Figure 76 Cabling Error

Incompatible Switch Firmware Error
The incompatible switch firmware error is displayed in the faceplate when the switch trying to join the
stack is running the firmware prior to AOS-CX 10.07 version. To resolve this error, you need to upgrade
the switch to a compatible firmware offline, outside Aruba Central On-Premises.

The following error and recommendation are displayed in the faceplate:

Error
Incompatible switch firmware/product type
Recommendation
Upgrade the switch to a compatible firmware
The following figure displays the incompatible switch firmware error.

Figure 77 Incompatible Switch Firmware Error

VSF Switchover
In AOS-CX switch stacks, you can manually switchover the conductor role to the standby conductor
switch. This can be done in the event of hardware failure or if you want to assign any specific SKU as the
conductor.

To switchover the conductor role to the standby switch, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. Ensure that the filter selection contains at least one switch. For all devices, set
the filter to Global.
The dashboard context for the selected filter is displayed.
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2. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

3. Click Online to display a table with the list of online switches.
4. In the Switches table, click on the conductor switch.

The Switch Details page corresponding to the stack that the conductor switch belongs to is
displayed.

5. In the Actions drop-down, click VSF Switchover.
A VSF Switchover dialog box is displayed.

6. Click Continue.

The standby conductor becomes the conductor of the stack. The conductor switch goes for a
reboot and join the stack as a member.

Aruba Central NetConductor Overview
With an ever-growing focus on security and scale, the enterprise network is becoming more and more
complex in terms of design, deployment, and operations. There is an increasing reliance on BYOD (Bring
Your Own Device) and IoT (Internet of Things) for business efficiency and digital transformation
initiatives. This increases the risk of security threats to the enterprise due to a sharp increase in the
unknown or rogue clients and an ever-expanding threat front. Defining policy manually for these clients
using the complex policy constructs available today can prove to be a challenging task for security and
network administrators. Furthermore, intent-based networking has become an increasingly popular
paradigm that many customers are looking to adopt and implement. The goal of intent-based
networking is not only to abstract the underlying complexities of network but instead allow users to
design, implement, and operate their networks based on their business intents. Automated network
provisioning and orchestration has been identified to achieve this level of abstraction by many network
vendors. Thus, the focus has shifted to the security, scalability, and simplification of these networks.

Aruba Central NetConductor is a security framework designed to tackle these problems for the modern
enterprise network. Intelligent overlays are built on highly available underlays and are tied to a full
policy-based micro-segmentation model, based on global roles, across the entire network infrastructure
of the customer. Role-based policies abstract policy from the underlying network and enable flexible
and simplified policy definition and enforcement. This is enhanced by the full automation of the
underlay, orchestration of the overlay, a single pane of glass for management and monitoring, and a
rich array of complementary services. The Aruba Central NetConductor framework has evolved to
enhance the policy and orchestration components to deliver true intent-based network evolution and
optimization.

The following are the main pillars of Aruba Central NetConductor:

n Role-based Segmentation—Aruba Central NetConductor provides the ability to deploy a zero-trust
enforcement model using role-based segmentation. Traditional policies use location specific entities
like IP addresses or subnets to define security policies. Role-based policies abstract policy from the
underlying network by assigning roles to endpoints or users and using roles to enforce policies. Role-
based policies can be enforced in a distributed manner at different parts of the network. also
provides the ability to automate and simplify policy definition for IoT devices with behavior-based
profiling using AI or ML based classification. This greatly simplifies policy definition and ensures
consistent policy enforcement across wired and wireless campus networks, the datacenter, and
across the WAN.
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n Intelligent Overlays—Overlay networks provide the ability to deploy flexible services based on ever-
changing demands of the endpoints and applications. Decoupling of overlay network from the
physical topology enables on-demand deployment of layer 2 and layer 3 services irrespective of
underlay physical topology. Overlay networks also enable the ability to carry endpoint or user role
information across the network without requiring all devices in the path to understand or manage
the roles. Aruba Central NetConductor provides customers the flexibility to choose between
centralized overlays or distributed overlays to address their unique requirements. The centralized
overlay provides simplified operations and advanced security features for distributed enterprise and
smaller campus deployments. For large enterprise campus deployments, Aruba Central
NetConductor provides the ability to use distributed overlays for wired and wireless endpoints. This
enables large enterprises to deploy a standards-based and scalable overlay network. Both overlay
models support the Colorless Ports feature, which enables automated client on-boarding and access
control for ease of operations.

Benefits of Aruba Central NetConductor
The following are some of the key benefits of the Aruba Central NetConductor solution. The objective of
this guide is to highlight these capabilities to the customer.

n Simplified and Consistent Security Policies
o Simplified policy definition based on customer identity
o Security policies agnostic of location, network, and devices
o Policy follows the endpoint, user, or application across wired and wireless networks
o Consistent policies across Campus, Branch, and Datacenter
o Increase scale by eliminating the need for enforcement nodes to maintain endpoint to role

mappings to enforce polices

n Flexible Overlays Agnostic of Underlay Architecture
o Flexible choice of centralized or distributed Aruba Central NetConductor fabrics on any underlay

physical network architecture
o Automated stich-up and tear-down of layer 2 and layer 3 services based on customer on-boarding
o Address requirements of small, distributed enterprise to a large campus network

n Simplified Network Deployments and Operations with Intent-Driven Workflows
o Abstract complexity of the underlying protocols from network architects or operators
o Enables global orchestration of roles and role-based policies from Aruba Central On-Premises
o Unified monitoring and troubleshooting across all device types and network locations
o Actionable insights enable ease of troubleshooting for network issues

Supported AOS-CX Switch Platforms

Aruba Central NetConductor only supports AOS-CX Switches within Aruba Central On-Premises.

The following table lists the AOS-CX switches, supported software versions, and the supported personas
in Aruba Central On-Premises.
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Switch Platform Supported Software Versions Supported
Persona

AOS-CX 6300 Switch Series 10.10.1020 or later Edge

AOS-CX 6400 Switch Series 10.10.1020 or later Edge

AOS-CX 8325 Switch Series 10.10.1020 or later Route
Reflector

AOS-CX 8360 Switch Series 10.10.1020 or later Edge
Stub
Border
Route
Reflector

AOS-CX 8400 Switch Series 10.10.1020 or later Route
Reflector

Table 145: Supported AOS-CX Switch Series and Software Versions

Features for Aruba Central NetConductor
The following features are available as select features in Aruba Central On-Premises.

1. Global Client Roles
2. Fabric Wizard Overview
3. Network Wizard Overview

Aruba Central NetConductor Vocabulary
The following table provides a brief description of the technical terms used in this guide.

Term Description

Border Border device persona connects the fabric to external networks. For
example, connect fabric to WAN or Internet or firewalls.

Border Gateway Protocol (BGP) BGP is a standardized routing method that enables the internet to
exchange routing information between autonomous systems (AS).

Ethernet VPN (EVPN) EVPN is an extension of the BGP protocol for layer 2 (bridging) and layer 3
(routing) VPNs.

Edge Edge is a device persona that connects endpoints to the fabric.

External BGP (eBGP) Refers to BGP connection between external peers.

Fabric Fabric is a group of AOS-CX Switches that are part of the BGP-EVPN VXLAN
overlay. The overlay fabric is created by configuring VXLAN tunnels
between stub and edge Switches.

Table 146: List of Technical Terms used in Aruba Central NetConductor
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Term Description

Group-based Policy (GBP) GBP is used to segment user traffic in a network by grouping the users
into roles based on user authentication at the source or VTEP. Source-
based roles will remain effective even if a device authenticates at a
different location, or if the device is assigned a different IP address.

Internal BGP (iBGP) Refers to BGP connection between internal peers.

Inter-Switch Link (ISL) ISL is a layer 2 interface between two VSX peer Switches. Each VSX Switch
must be configured with an ISL link connected to its peer VSX Switch.

Open Shortest Path First (OSPF) OSPF refers to an Interior Gateway Protocol (IGP). OSPF distributes
routing information between routers belonging to a single Autonomous
System (AS).

Policy Identifier Policy Identifier is a unique identification number mapped to a client role.

Route Reflector Route Reflector refers to a concept that is specific to BGP which is used to
optimize route propagation.

Stub Stub is a device persona that supports both static VXLAN tunnels and
EVPN VXLAN tunnels.

Switch Virtual Interface (SVI) An SVI (also known as VLAN interface) refers to a logical layer 3 interface
on a Switch.

Virtual Extensible LAN (VXLAN) VXLAN is an Overlay Technology which address the scalability problems
associated with large cloud computing deployments.

Virtual Routing and Forwarding
(VRF)

VRF is a technology that allows multiple instances of a routing table to co-
exist within the same router simultaneously in an IP-based computer
network.

VXLAN Network Identifier (VNI) Refers to VXLAN network identifier or VXLAN segment ID.

VXLAN Tunnel End Point (VTEP) An entity that originates and/or terminates VXLAN tunnels.

Table 146: List of Technical Terms used in Aruba Central NetConductor

Global Client Roles
Aruba Central On-Premises allows you to configure client roles for role-to-role policy enforcement. To
make client roles more powerful and consistent within the dynamic-segmentation security framework,
you can now manage the client roles globally from Aruba Central On-Premises. For example, if you have
five roles in your network, a role-to-role policy is created by defining permissions from one role to
another.

Prerequisites
Ensure that all the required Aruba devices are on-boarded and connected to Aruba Central On-
Premises, prior to configuring global client roles and performing selective enablement of subnets.

For more information, see the following topis:

n Configuring the Global Client Roles

n Editing a Role

n Deleting Global Client Roles
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n Performing Selective Enablement of Subnets

n Deleting a Subnet

n Performing Selective Enablement of Groups

n Deleting a Group

Configuring the Global Client Roles
Global client roles configuration affects all the access Switches and wireless Gateways in the network, as
part of the global policy enforcement.

To configure client roles for role-to-role policy enforcement, complete the following procedure:

1. In the Aruba Central On-Premises app, complete the following steps:
a. Set the filter to Global.
b. Under Manage, click Security > Client Roles. The Client Roles page is displayed.

2. Toggle the Role-to-Role Policy Enforcement Switch to the on position, to apply the roles and
permissions that are defined.

Figure 78 Client Roles Page

3. In the Roles table, click the + icon. The Create new role page is displayed.

Figure 79 Create New Role page
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4.  In the Create new role page, configure the following parameters: 
n Name—Enter the name of the role that you want to create. For example, Admin.
n Description—Enter the description of the role. For example, all employees in the organization.
n Policy Identifier—Policy Identifier is a unique auto-generated identifier for the role. You can

modify identifier, if required. For example, 100.

5. In the Permissions table, click the edit icon to create bi-directional policies between roles.

The Allow Source to Destination column is used to enable permissions from the source role to
the selected destination role. The Allow Destination to Source column is used to enable
permissions from the selected destination role to the source role. For example, if you open the
Assign Permissions window for the Admin role, you must select the check box corresponding to
the BYOD role in the Allow Source to Destination column to allow network traffic from Admin
role to BYOD role. You must click IOT under the Allow Destination to Source column to allow
network traffic from IOT role to Admin role.

Selecting either of the check boxes for self, selects both the check boxes by default. Selecting self
enables bi-directional network traffic between devices of the same role.

Figure 80 Assign Permissions Page

6. In the Allow Source to Destination and the Allow Destination to Source columns, select the
appropriate check box.

7. Click Assign.
8. In the Use a switch fabric for a role propagation? options, select Yes if you have configured

distributed overlay fabric for role propagation. For more information about distributed overlay
fabric, see Fabric Wizard Overview .

9. In the Create new role page, click Save.
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The role is created, and the assigned permissions are saved.

Configuring custom policy rules on switches is possible using the Multi-Editor with sequence numbers above
9999.

Editing a Role
To edit a role, complete the following procedure:

1. In the Aruba Central On-Premises app, complete the following steps:
a. Set the filter to Global.
b. Under Manage, click Security > Client Roles. The Client Roles page is displayed.

2. In the Roles table, hover over the row, and click the edit icon.
3. In the Edit Role window, modify the required permissions.

The Allow default role to source role permissions for wired clients checkbox cannot be modified while
editing a role.

4. Click Save.

Deleting Global Client Roles
To delete a role, complete the following procedure:

1. In the Aruba Central On-Premises app, complete the following steps:
a. Set the filter to Global.
b. Under Manage, click Security > Client Roles. The Client Roles page is displayed.

2. In the Roles table, select the role and click the delete icon. The Confirm Action window is
displayed.

3. Click Yes.

Performing Selective Enablement of Subnets

Perform selective enablement of subnets if you have not configured distributed overlay fabric for role
propagation. For more information about distributed overlay fabric, see Fabric Wizard Overview .
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Selective enablement of subnets is used to select the client subnets for which you want to enable role-
based policy enforcement on the third-party Gateways. Typically, these client subnets are mapped to
different sites in the network.

To selectively enable the subnets that map to the clients in the respective sites using Aruba Central On-
Premises, complete the following procedure:

1. In the Aruba Central On-Premises app, complete the following steps:
a. Set the filter to Global.
b. Under Manage, click Security > Client Roles. The Client Roles page is displayed.

2. In the Use a switch fabric for a role propagation? options, select No.

Delete all configured groups before enabling a switch fabric for role propagation.

3. In the What is the role of the Aruba gateways? options, select Mobility. Delete all configured
groups to change the role to WLAN gateways.

4. Click the + icon to add the groups.

5. Select the groups you want to assign.
6. Click Assign.
7. Click Save.

Deleting a Subnet
To delete a subnet, complete the following procedure:

1. In the Aruba Central On-Premises app, complete the following steps:
a. Set the filter to Global.
b. Under Manage, click Security > Client Roles. The Client Roles page is displayed.

2. In the ENFORCE ROLES BETWEEN THESE SUBNETS table, select the subnet and click the
delete icon. The Confirm Action window is displayed.

3. Click Yes.
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Performing Selective Enablement of Groups

Perform selective enablement of groups if you have not configured distributed overlay fabric for role
propagation. For more information about distributed overlay fabric, see Fabric Wizard Overview .

Selective enablement of groups is used to select the Aruba Central On-Premises group for which you
want to enable role propagation on gateway. Typically, these client groups are mapped to different SD-
WAN branch sites within the Aruba Central network.

To selectively enable the groups that map to the clients in the respective sites using Aruba Central On-
Premises, complete the following procedure:

1. In the Aruba Central On-Premises app, complete the following steps:
a. Set the filter to Global.
b. Under Manage, click Security > Client Roles. The Client Roles page is displayed.

2. In the Use a switch fabric for a role propagation? options, select No.

Delete all configured groups before enabling a switch fabric for role propagation.

3. In the What is the role of the Aruba gateways? options, select Branch. Delete all configured
groups to change the role to WLAN gateways.

4. Click the + icon to add the groups.

5. Select the groups you want to assign.
6. Click Assign.
7. Click Save.

Deleting a Group
To delete a role, complete the following procedure:

1. In the Aruba Central On-Premises app, complete the following steps:
a. Set the filter to Global.
b. Under Manage, click Security > Client Roles. The Client Roles page is displayed.
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2. In the SELECT GROUPS TO ENFORCE ROLES table, select the group and click the delete icon.
The Confirm Action window is displayed.

3. Click Yes.

Fabric Wizard Overview
Aruba Central On-Premises allows you to create an overlay fabric by configuring VXLAN tunnels
between Stub and Edge Switches and configure overlay segments for the existing overlay fabrics.

Prerequisites
Before provisioning the overlay fabric using Aruba Central On-Premises, ensure that the following
prerequisites are completed:

n All Aruba CX switches should be on firmware version 10.10.1020 and above.

n All Switches must be on-boarded on Aruba Central On-Premises and added to the same UI group.

n All the required Aruba devices are on-boarded and connected to Aruba Central On-Premises.

n The underlay network must be set up before attempting to add any overlay to the network.
n At least two loopback (loopback 0 and loopback 1) interfaces are configured on all devices of the

overlay fabric.

n The IP addresses of the loopback interfaces are unique on each device of the overlay fabric except on
the VSX pair (VSX pair has at least one loopback interface whose IP address is the same on both
primary and secondary).

n At least one instance of OSPF or BGP should be configured on all devices of the overlay fabric.

n OSPF or BGP router ID should be the IP address of an existing loopback interface.

n OSPF or BGP is configured on at least two loopback interfaces (one is used for OSPF and BGP, and
the other for the VXLAN source IP).

n If the device has VSX configuration, the following validations must be performed:
o The VSX pair has at least one loopback interface with the same IP address (used as VXLAN source

IP).
o Virtual MAC is configured on the device.
o Virtual MAC is used for VSX configuration.
o Keep alive is configured.
o ISL link—LAG interface with member ports is configured.
o The Virtual MAC should be assigned to the Primary and Secondary switches of the VSX Pair. Virtual

MAC is auto-generated and pushed to stand alone devices and VSF conductors only.

Configuring the overlay fabric workflow is applicable only to AOS-CX Switches.

For more information on overlay fabric and overlay segment see the following topics:

n Overlay Fabric Overview

n Overlay Segment Overview
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Overlay Fabric Overview
The distributed overlay fabric is a group of AOS-CX Switches that are part of the BGP-EVPN VXLAN
overlay. The overlay fabric is created by configuring VXLAN tunnels between Stub and Edge Switches.
The AOS-10 Gateways also participate in the overlay fabric, using static VXLAN tunnels to the Stub VTEP.
Aruba Central On-Premisesallows you to configure the overlay fabric on top of a virtual network using
AOS-CX Switches. You can assign a list of fabric personas such as Border VTEP, Route Reflectors, Edge
VTEP, or Stub VTEP to the overlay fabric.

Fabric Personas

This section describes the different fabric personas and their functions in the Aruba Central On-
PremisesBGP EVPN overlay fabric workflow.

n Border VTEP—Refers to a Gateway or an external facing device from the overlay fabric to the
external network. Border VTEP participates in the Layer 3 VNI or VRF but does not have overlay
VLANs or SVIs configured on this device.

n Route Reflector—Refers to a concept that is specific to iBGP that uses to optimize route
propagation. Route reflector reduces the configuration required on all the devices and optimizes the
way BGP sessions establishes. In a typical scenario, every edge device in the network peers with
every other edge device. To avoid this, a route reflector is introduced where all the devices in the
overlay fabric peer with the route reflector. Optimizing the configuration and route distribution. Core
Switches are generally used as route reflectors in an overlay fabric.

n Edge VTEP—Refers to a traditional access Layer where the clients are onboarded. It is also the Layer
3 Gateway for all the clients that are associated with it. Edge VTEP typically has the SVI interface, and
it is the entry point of all the wired clients onto the BGP EVPN overlay fabric.

n Stub VTEP—Supports static VXLAN and EVPN VXLAN. Stub VTEP is used to establish static VXLAN
tunnel to the Gateway and EVPN-VXLAN towards the overlay fabric. Stub VTEP helps to carry role
information between EVPN-VXLAN overlay fabric and devices like Gateway that only support Static
VXLAN.

Optionally, you can create additional overlay networks, which are on the same VRF and Layer 3 VNI, if
required. You can also configure the Gateway IP cluster for wireless Gateways.

For more information, see the topics listed below:

n Configuring an Overlay Fabric

n Modifying an Overlay Network Fabric

n Re-syncing the Overlay Fabric

n Deleting an Overlay Network Fabric

n Viewing the Fabric Configuration Status

Configuring an Overlay Fabric
The following workflow describes the steps to set up the overlay fabric for the AOS-CX Switches.

1. Step 1: Create the Overlay Fabric Name

2. Step 2: Assign Devices and Personas

3. Step 3: Add the Overlay Network
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4. Step 4: Creating Static Tunnels from Stub VTEPs to a Gateway Cluster

5. Step 5: View Fabric Summary

Step 1: Create the Overlay Fabric Name
To configure an overlay fabric for the AOS-CX Switch, complete the following steps:

1. In the Aruba Central On-Premises app, complete the following steps:
n To select a group in the filter:

a. Set the filter to a group.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-CX icon to view the switch configuration dashboard.

2. Click Routing > Fabrics.

3. In the Fabrics table, click the + icon.

The Create a New Fabric page is displayed.

Figure 81 Create a New Fabric Page

4. In the Fabric Name field, enter a name.

The value in the BGP AS Number field is auto-generated. BGP AS Number can be modified, if
necessary.

5. Click Next. The Devices table is displayed with a list of all the Switches in the network.

6. In the Host Name column, in the Devices table, select the devices that you want to assign to the
Switches on the overlay network. The Assign selected device to window is displayed with a list of
Switch personas.
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Figure 82 Create a New Fabric Page

Step 2: Assign Devices and Personas
To assign the selected devices to a fabric on the virtual network, complete the following steps:

1. In the Assign selected device to window, select the persona to which you want to assign the
devices.

2. Click Apply.
3. Click Next. The Overlay Networks section is displayed.

Personas under the VSX pair should be the same.

Step 3: Add the Overlay Network

A default overlay network is created automatically. You can create, move or delete an additional overlay
network, if required.

To create an additional overlay network, complete the following steps:
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1. In the Overlay Networks table, click the + icon.

Figure 83 Overlay Networks Table

2. In the Name field, enter a name for the overlay network.

3. In the VNI field, enter a virtual tunnel identifier.

The VNI is auto-generated, but it can be modified if necessary.

Step 4: Creating Static Tunnels from Stub VTEPs to a Gateway Cluster
To create a static tunnel from Stub VTEP to a Gateway cluster, complete the following steps:

1. In the Tunnels table, click the + icon.

The list of Switches and Gateway IP addresses is displayed.

Figure 84 Stub Tunnels to Gateways Section

2. Select a Switch from the Switch drop-down list.

3. In the Gateway IP List field, enter the IP address of the AOS-10 Gateway, which will be the tunnel
termination point for the static VXLAN tunnel.

To input multiple values in the Gateway IP List parameter, use commas between the IP addresses. For
example, 10.1.1.2, 10.1.1.3.

Step 5: View Fabric Summary
To view the fabric summary, complete the following steps:
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1. In the Stub Tunnels to Gateway page, click Next. The Summary section is displayed.

Figure 85 Create a New Fabric Section

2. In the Summary page, view the fabric summary and check the following:

n Device personas are assigned correctly

n Overlay networks are created properly

n Stub tunnels to the Gateways are configured properly

Modifying an Overlay Network Fabric
To edit or modify a fabric, complete the following steps:

1. In the Aruba Central On-Premises app, complete the following steps:
n To select a group in the filter:

a. Set the filter to a group.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. To view the AOS-CX Switch configuration dashboard, click the AOS-CX or Config icon.

2. Click Routing > Fabrics.

3. Hover over the tunnel row and click the edit icon.

4. Input the tunnel details.

5. Click Save.

The overlay network fabric is saved.

Re-syncing the Overlay Fabric

The re-sync button is only visible when there are configuration conflicts on the devices.

The re-sync button resolves configuration conflicts within existing overlay fabric devices. You no longer
need to run the entire workflow of configuring a fabric to resolve configuration conflicts on devices.
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1. In the Aruba Central On-Premises app, complete the following steps:
n To select a group in the filter:

a. Set the filter to a group.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. To view the AOS-CX Switch configuration dashboard, click the AOS-CX or Config icon.

2. Click Routing > Fabrics.

3. In the Fabrics table, hover over the Fabric that you want to re-sync and click the re-sync icon.

Figure 86 Re-sync Button

To view the status of the fabric, go to the Device Level Configuration screen's Config Status column.

Deleting an Overlay Network Fabric
To delete a fabric, follow the steps below:

1. In the Aruba Central On-Premises app, complete the following steps:
n To select a group in the filter:

a. Set the filter to a group.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. To view the AOS-CX Switch configuration dashboard, click the AOS-CX or Config icon.

2. Click Routing > Fabrics.

3. Hover over the tunnel row in the Fabrics table and click the delete icon.
4. Click Yes to delete the fabric.

The overlay network fabric is deleted.

Viewing the Fabric Configuration Status
To view the fabric configuration status, complete the following steps:

1. In the Aruba Central On-Premises app, complete the following steps:

To select a group in the filter:
a. Set the filter to a group.

The dashboard context for the group is displayed.
b. Under Manage, click Devices > Switches
c. Click the Config icon.
d. Click Configuration Audit.

The Configuration Status page is displayed.
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Figure 87 Configuration Status Page

2. In the Configuration Status tab, you can view the configuration status of the overlay network
fabric.

Overlay Segment Overview
Overlay segment defines a broadcast domain. This maps the VLAN/VNI that will be deployed on the
overlay network. You can define the VLAN ID, IP Subnet, default Gateway, DHCP relay server, and roles
that can be present on this segment and define which devices

For more information, see the topics listed below:

n Setting Up a Layer 2 Segment

n Setting up a Layer 3 Overlay Segment

n

n Modifying the Overlay Segment

n Deleting the Overlay Segment

n Viewing the Fabric Configuration Status

Setting Up a Layer 2 Segment
Layer 2 segments supports use cases where the default gateway of the segment is external to the fabric.
Example of such use-cases includes, IoT devices connecting to gateway or fabric traffic that terminates
at the firewall.

The following workflow describes the steps for configuring Layer 2 segments:

1. Step 1: Configure the Layer 2 Segment
2. Step 2: Assign Roles
3. Step 3: Select Edge and Stub Devices for the Layer 2 Segment
4. Step 4: View the Layer 2 Segment summary

Step 1: Configure the Layer 2 Segment
To configure an overlay segment for the AOS-CX Switch, complete the following steps:
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1. In the Aruba Central On-Premises app, complete the following steps:
n To select a group in the filter:

a. Set the filter to a group.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. To view the AOS-CX Switch configuration dashboard, click the AOS-CX or Config icon.

2.2. In the Fabrics table, select the Fabric on which you want to enable Layer-2 segment and click the
icon.

3. Enable the Layer 2 Segment toggle.

4. In the Overlay Network & VLAN table, populate the Overlay network and VLAN table with the
relevant information.
The following table describes the Layer 2 segment parameters.

Column Function

VLAN
Name

Option to provide the VLAN name.

VLAN ID The VLAN ID number.

Table 147: Overlay Network & VLAN Table Parameter

5. Click Next. The Roles section is displayed with a list of all the global roles defined on the Client
Roles page.
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Step 2: Assign Roles
This section describes the steps to assign roles to endpoints or users that are part of the Layer 2
segment.

1. Select the roles for assigning the Layer 2 overlay network segment.

2. Click Next. The Devices section is displayed.

Step 3: Select Edge and Stub Devices for the Layer 2 Segment
In the Devices section, select the devices to apply on the segment.

1. Select individual devices or select all the devices and assign them to the overlay fabric.

2. Click Next. The Summary section is displayed.
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Step 4: View the Layer 2 Segment summary

1. The Summary section is displayed where you can view the summary of your configuration.

2. Click Save to complete the configuration.

Setting up a Layer 3 Overlay Segment
The following workflow describes the steps for configuring overlay segments for the existing overlay
fabrics in Aruba Central On-Premises.

1. Step 1: Configure the Layer 3 Overlay Segment
2. Step 2: Assign Roles
3. Step 3: Select Edge and Stub Devices for the Overlay Segments
4. Step 4: View the Overlay Segment Summary

Step 1: Configure the Layer 3 Overlay Segment
To configure an overlay segment for the AOS-CX Switch, complete the following steps:

1. In the Aruba Central On-Premises app, complete the following steps:
n To select a group in the filter:

a. Set the filter to a group.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. To view the AOS-CX Switch configuration dashboard, click the AOS-CX or Config icon.

2. Click Routing > Fabrics.

A list of overlay fabrics is displayed in the Fabrics table.

3. In the Fabrics table, to select the row for the fabric, click the icon.
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The Overlay Network & VLAN section is displayed.

Figure 88 Overlay Network & VLAN Page

Column Function

Overlay
Network

List of overlay networks. You can select the overlay network that you want to create the
service segment for, from the list.

VLAN
Name

Option to provide the VLAN name.

VLAN ID The VLAN ID number.

IP Version Option to select the IP version.
n IPv4

n IPv6

n Dual Stack

The following table describes the columns in the Devices table.
Table 148: Overlay Network & VLAN Table Parameters
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Column Function

Default
Gateway IP

Option to define the default Gateway IP for the overlay network.

Subnet
Mask

Option to provide the subnet mask for the IP address.

DHCP
Server VRF

The default DHCP server VRF value or you can add manually.
Note: You can manually add multiple DHCP server relays.

DHCP
Server

The IP address of the DHCP relay server.

4. In the Overlay Network & VLAN table, provide all the details.

5. Click Next. The Roles section is displayed with a list of all the global roles defined on the Client
Roles page.

Step 2: Assign Roles
This section indicates the roles that can be assigned to endpoints or users that are part of this segment.

To assign roles that you want to allow to participate in the overlay network segment, complete the
following steps:

Figure 89 Roles Page

1. Select the roles which you want to allow to participate in the overlay network segment.

2. Click Next. The Devices section is displayed.

Step 3: Select Edge and Stub Devices for the Overlay Segments
In the Devices section, select the devices which you want to apply on the segment. You can either select
individual devices or select all the devices and attach to the overlay fabric.
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Figure 90 Devices Page

Step 4: View the Overlay Segment Summary
To view the overlay segment summary, complete the following steps:

In the Devices section, click Next. The Summary section is displayed where you can view the summary
of your configuration.

Figure 91 Summary Page

Viewing the Overlay Fabric
To view the newly created overlay fabric or view an existing fabric , complete the following steps:

1. In the Aruba Central On-Premises app, complete the following steps:
n To select a group in the filter:

a. Set the filter to a group.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. To view the AOS-CX Switch configuration dashboard, click the AOS-CX or Config icon.

2. Click Routing > Fabrics.
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3. In the overlay segment row, click the arrow down icon to expand the fabric.

4. View the overlay segment.

Column Function

Overlay
Network

List of overlay networks.

VLAN
Name

The VLAN name.

VLAN ID The VLAN ID number.

IP Version The IP version.
n IPv4

n IPv6

n Dual Stack

Default
Gateway IP

The default Gateway IP for the overlay network.

Subnet
Mask

The subnet mask for the IP address.

DHCP
Server VRF

The default DHCP server VRF value or you can add manually.
Note: You can manually add multiple DHCP server relays.

DHCP
Server

The IP address of the DHCP relay server.

Roles The number of roles assigned to this network.

NOTE: When you delete a role in the Clients Role page. The number of updated role is not
reflected in this column, unless you edit the overlay segment.

Devices The number of devices assigned to this network.

The following table describes the columns in the Fabrics table.
Table 149: Overlay Segment Table Parameters

Modifying the Overlay Segment
To edit or modify an overlay fabric, complete the following steps:
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1.1.1. In the Aruba Central On-Premises app, complete the following steps:
n To select a group in the filter:

a. Set the filter to a group.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. To view the AOS-CX Switch configuration dashboard, click the AOS-CX or Config icon.

2.2. Click Routing > Fabrics.
3. In the overlay segment row, click the edit icon and provide the required details.
4. Click Save.

The overlay segment is saved.

Deleting the Overlay Segment
To delete an overlay segment, complete the following steps:

1.1.1. In the Aruba Central On-Premises app, complete the following steps:
n To select a group in the filter:

a. Set the filter to a group.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. To view the AOS-CX Switch configuration dashboard, click the AOS-CX or Config icon.

2.2. Click Routing > Fabrics.
3. In the overlay segment row, click the delete icon.

The overlay segment is deleted.

Network Wizard Overview
Network Wizard is the workflow to set up an underlay network. To establish an underlay network, Aruba
Central On-Premises automates the L3 and OSPF switching connectivity by auto-assigning the loopback
IP address, ROP links, and creating the Aruba Virtual switching Extension.

Prerequisites
To complete the provisioning of underlay network using Aruba Central On-Premises, complete the
following

n All Aruba CX switches must be running AOS-CX 10.10.1020 or later.

n Move all devices and switches that are on-boarded in Aruba Central On-Premises into the same UI
group.

n All the physical cabling between the switches needs to be setup and running.

n LLDP must be enabled on all devices and ports.

n Ensure all the previously existing underlay network configurations are removed from the switches.

For more information, see the following topics:

n Setting Up a Campus (3 tier L3 access) Underlay Network

n Setting Up a of Data Center (Spine and Leaf) Underlay Network

n Modifying and Deleting an Underlay Network
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Setting Up a Campus (3 tier L3 access) Underlay Network
To set an underlay network of Campus (3 tier L3 access) for the AOS-CX switches, complete the following
workflow.

n Step 1: Configuring the Network Type

n Step 2: Setting the Structure of the Underlay Network

n Step 3: Assigning Devices to the Network

n Step 4: Configuring the Underlay Network

n Step 5: Viewing the summary Page

Step 1: Configuring the Network Type
To configure an underlay network for an AOS-CX switch, complete the following steps:

1. In the Aruba Central app, complete the following steps:
n To select a group in the filter:

a. Set the filter to a group.
The dashboard context for the group is displayed.

b. Under Manage, click Devices > switches.
c. To view the AOS-CX switch configuration dashboard, click the Config icon.

2. Click Routing > Underlay Networks.

3. In the Networks table, click the + icon.

The Guided Setup for Underlay Network page is displayed.
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4. Enter the Network Name.

5. Select the Campus(3 tier L3 access) checkbox under What type of Network to configure.

6. To display the Structure section, click Next.

Step 2: Setting the Structure of the Underlay Network
To assign WAN and WLAN gateways to the core switches, complete the following step.

1. In the Structure section, select the type of switch to be connected to the WAN gateway.

a. Core switches—Connects the WAN gateway directly to the core switches.

b. Service Aggregation switches—Connects the WAN gateway to the core switches through a
service aggregation switch.

2. Select one of the checkboxes if you are connected to the WLAN gateway.

a. No—Select if there is no WLAN gateway connected directly to one or more core switches.

b. Yes, Connected to Core switches—Select when there is a WLAN gateway connected to the
core switches.

c. Yes, Connected to Service Aggregation switches—Select when there is a WLAN gateway
connected to the core switches through a service aggregation switch.

3. To display the Device Assignment section, click Next.

Step 3: Assigning Devices to the Network
This section displays the device persona suggestions for the core switches present in the network.
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The Device assignment section consists of subsections that auto populates suggestions depending on
the selections that you made in the Structure section. The switches table displays the Name, Serial,
MAC Address, Model, and Discovered Network Personas across all subsections of the Device
Assignment page.

n Core—Select new switches or edit the selection based on your requirements and click Next.

n Access Aggregation—Select and confirm the switches to use as access aggregation switches in the
underlay network and click Next.

n WAN Service Aggregation—This section is displayed when WAN gateways (site uplink) are
connected to the service aggregation switches. Select new switches or edit the selection based on
your requirements and click Next.

n WLAN Service Aggregation—This section is displayed when WLAN gateways are connected to the
service aggregation switches. Select new switches or edit the selection based on your requirements
and click Next.

n Access—Select new switches or edit the selection based on your requirements and Click Next to
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display Configuring your underlay network page.

Step 4: Configuring the Underlay Network
The Configuring your underlay network page displays various parameters to configure the underlay
network. After providing the required information for the parameters. Click Next to open the Summary
Page.

Column Function

Interface IPv4
subnet pool

Enter the ROP interface IPv4 subnet pool address for the underlay network.

Loopback IPv4
subnet pool

Enter the loopback IPv4 subnet pool address for the underlay network.

MTU size
(bytes)

Enter the MTU size within the range of 1–9168 bytes.

VSX-Pair Transit
VLAN

Enter the VSX-pair transit VLAN within the range of 1–4098.

Use out-of-band
management
port for VSX
keepalive

The toggle remains disabled by default to use dedicated ports for the VSX keepalive.
Enable the toggle to use out-of-band ports for VSX keepalive

Use NTP
servers

Enable the toggle to enter the NTP server address for the underlay network. You can add
more than one address for the server by clicking the add (+) icon.
Clicking the delete icon deletes the NTP server address.

Use DNS
servers

Enable the toggle to enter the DNS server address for the underlay network. You can add
more than one address for the server by clicking the add (+) icon.
Clicking the delete icon deletes the DNS server address.

The following table describes the parameters in the Configuring your underlay network table.
Table 150: Configuring your Underlay Network Parameters.
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Step 5: Viewing the summary Page
This section displays all the parameter that you have configured under the Details and Device
Management sections.

Click Finish to complete the underlay network configuration.

Setting Up a of Data Center (Spine and Leaf) Underlay Network
To set an underlay network of Data Center (Spine and Leaf) for the AOS-CX switches, complete the
following workflow.

n Step 1: Configuring the Network Type

n Step 2: Setting the Structure of the Underlay Network

n Step 3: Assigning Devices to the Network

n Step 4: Configuring the Underlay Network

n Step 5: Viewing the Summary Page

Step 1: Configuring the Network Type
To configure an underlay network for the AOS-CX switch, complete the following steps:

1. In the Aruba Central app, complete the following steps:
n To select a group in the filter:

a. Set the filter to a group.
The dashboard context for the group is displayed.
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b. Under Manage, click Devices > switches.
c. To view the AOS-CX switch configuration dashboard, click the Config icon.

2. Click Routing > Underlay Networks.

3. In the Networks table, click the + icon.

The Guided Setup for Underlay Network page is displayed.

4. Enter the Network Name.

5. Select the Data Center(Spine and Leaf)) checkbox under What type of Network to configure.

6. Click Next to display the Structure section.

Step 2: Setting the Structure of the Underlay Network
To assign WAN gateways to the spine or border switches, complete the following steps.

1. In the Structure section, select the type of switch to be connected to the WAN gateway.

a. Spine switches—Connects the WAN gateway to the spine switches.

b. Border switches—Connects the WAN gateway to the border switches.

2. To display the Device Assignment section, click Next.

Step 3: Assigning Devices to the Network
This section displays the device persona suggestions for the switches present in the network.
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The Device assignment section consists of three subsections of Spine, Border, and Leaf. The switches
table displays the Name, Serial, MAC Address, Model, and Discovered Network Personas across all
subsections of the Device assignment page.

n Spine—Select the switches to use as spine switches in the underlay network and click Next.

n Border—Select the switches to use as border switches (uplink) in the underlay network and click
Next.

n Leaf—Select the switches to use as leaf switches in the underlay network and click Next to display
Configuring your underlay network page.

Step 4: Configuring the Underlay Network
The Configuring your underlay network page displays various parameters to configure underlay
network. After providing the required information for the parameters.

Click Next to open the Summary Page.

Column Function

Interface IPv4
subnet pool

Enter the ROP interface IPv4 subnet pool address for the underlay network.

Loopback IPv4
subnet pool

Enter the loopback IPv4 subnet pool address for the underlay network.

MTU size
(bytes)

Enter the MTU size within the range of 1–9168 bytes.

VSX-Pair Transit
VLAN

Enter the VSX-pair transit VLAN within the range of 1–4098.

The following table describes the parameters in the Configuring your underlay network table.
Table 151: Configuring your Underlay Network Parameters.
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Column Function

Use out-of-band
management
port for VSX
keepalive

The toggle remains disabled by default to use dedicated ports for the VSX keepalive.
Enable the toggle to use out-of-band ports for VSX keepalive

Use NTP
servers

Enable the toggle to enter the NTP server address for the underlay network. You can add
more than one address for the server by clicking the add (+) icon.
Clicking the delete icon deletes the NTP server address.

Use DNS
servers

Enable the toggle to enter the DNS server address for the underlay network. You can add
more than one address for the server by clicking the add (+) icon.
Clicking the delete icon deletes the DNS server address.

Step 5: Viewing the Summary Page
This section displays all the parameter that you have configured under the Details and Device
Management sections.

Click Finish to complete the underlay network configuration.

Modifying and Deleting an Underlay Network

The Network Type and Structure sections are not editable.

You can add devices to the underlay network incrementally by editing the underlay network. To edit or
modify an underlay network, complete the following steps:

1. In the Aruba Central On-Premises app, complete the following steps:
n To select a group in the filter:

a. Set the filter to a group.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. To view the AOS-CX Switch configuration dashboard, click the AOS-CX or Config icon.

2. Click Routing > Underlay Networks.

3. Hover over the tunnel row in the Networks table and click the edit icon.
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4. Edit the details for Device Assignment and complete this section if you have added new devices
to your underlay network.

5. Edit the details for Configuration and complete this section if you have added new devices to
your underlay network.

6. Click Next to display the Summary section
7. The Summary section highlights the new devices that were added in the network.
8. Click Finish in the Summary section to save the new underlay network.

Deleting an Underlay Network

Deleting an underlay network only removes the network configuration from Aruba Central On-Premises but
not the actual switches. You have to manually remove the switch configurations by using the multi-editor
mode.

To delete an underlay network, click the delete icon in the tunnel row.



Chapter 14

Configuring AOS-S Switches

Configuring AOS-S Switches

AOS-S switches enable secure, role-based network access for wired users and devices, independent of
their location or application.

AOS-S switches can also operate as a wired access point when deployed with an Aruba Mobility
Controller. As a wired access point, users and their devices are authenticated and assigned a unique role
by the Mobility Controller. These roles are applied irrespective of whether the user is a Wi-Fi client, or is
connected to a port on the switch. The use of switches allows an enterprise workforce to have consistent
and secure access to network resources based on the type of users, client devices, and connection
method used.

Local firmware upgrade is not supported for switches due to a known issue.

Aruba Central On-Premises supports provisioning switches in UI and template groups. Aruba Central
On-Premises supports basic configuration options in the UI. The users can also assign switches to
template groups and use configuration templates and variables to manage switches from Aruba Central
On-Premises.

See the following topics for more information on managing AOS-S switches in Aruba Central On-
Premises:

n Configuring AOS-S Switches using Templates
n Configuring AOS-S Switches in UI Groups
n AOS-S Stack

Getting Started with AOS-S Deployments
Before you get started with your onboarding and provisioning operations, browse through the list of
AOS-S switches supported in Aruba Central On-Premises.

Provisioning Workflow
The following sections list the steps required for provisioning switches in Aruba Central On-Premises.

Provisioning a Factory Default AOS-S Switch
Like most Aruba devices, AOS-S switches support ZTP. Switches with factory default configuration have
very basic configuration for all ports in VLAN-1. You must manually add either the serial number, MAC
address, or part number of the new factory default switch in Aruba Central On-Premises. When the
switch identifies Aruba Central On-Premises as its management entity, it connects to Aruba Central On-
Premises.

To manage switches from Aruba Central On-Premises, you must onboard the switches to the device
inventory and assign a valid subscription.

For step-by-step instructions, see Provisioning Factory Default AOS-S Switches.
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Provisioning a Pre-configured or Locally-Managed Switch
Pre-configured switches have customized configuration; for example, an additional VLAN or static IP
address configured on the default.

Unlike factory default switches, locally managed switches and the switches with custom configuration
require one touch provisioning. These switches do not automatically identify Aruba Central On-
Premises as their management platform, therefore you must manually enable the Aruba Central On-
Premises management service on these switches to allow them to connect to Aruba Central On-
Premises.

For step-by-step instructions, see Provisioning Pre-Configured AOS-S Switches.

Group Assignment
Aruba Central On-Premises supports provisioning switches in one of the following types of groups:

n UI group—Allows you to customize and manage device parameters using the UI workflows, that is,
the menu options and knobs available under Aruba Central On-Premises app.

n Template Group—Allows you to configure devices using CLI-based configuration templates.
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The following figure illustrates the group assignment workflow in Aruba Central On-Premises.

Figure 92 Group Assignment-Switches

AOS-S Switch Configuration and Management
Aruba Central On-Premises supports managing switch configuration using UI workflows or
configuration templates. Based on your configuration requirements, ensure that you assign switches to
either UI group or template group.

For more information on managing switches in Aruba Central On-Premises, see the following topics:

n Configuring AOS-S Switches using Templates
n Configuring AOS-S Switches in UI Groups

AOS-S Switch Monitoring
To view the operation status of switches and health of wired access network, complete the following
steps:
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1. In the Aruba Central On-Premises app, use the filter to select a group that has switches.
2. Under Manage, click Devices > Switches.

For more information, see Monitoring Switches and Switch Stacks.

Troubleshooting and Diagnostics
The Configuration Audit page under Aruba Central On-Premises app > Device(s) > Switches in the
Aruba Central On-Premises UI displays errors in configuration sync, templates, and a list of
configuration overrides. For more information, see Verifying Device Configuration Status.

To troubleshoot switches remotely, use the troubleshooting tool available under Aruba Central On-
Premises app > Analyze > Tools. For more information, see Using Troubleshooting Tools.

Provisioning Factory Default AOS-S Switches
Switches that run default configuration either after shipped from a factory or a factory reset are
referred to as factory default switches. This topic describes the following steps for provisioning factory
default switches in Aruba Central On-Premises:

n Step 1: Onboard the AOS-S Switch to Aruba Central On-Premises
n Step 2: Assign the AOS-S Switch to a Group
n Step 3: Connect the AOS-S Switch to Aruba Central On-Premises
n Step 4: Provision the AOS-S Switch to a Group
n Step 5: Verify the Configuration Status

Step 1: Onboard the AOS-S Switch to Aruba Central On-Premises

n Log in to Aruba Central On-Premises.
n Add switches to Aruba Central—Adding switches to Aruba Central is available in the HPE GreenLake

account home. For more information, see the Managing Devices and Subscriptions.
n Assign subscriptions—Assigning subscriptions to devices is available in the HPE GreenLake account

home. For more information about HPE GreenLake, see the Managing Devices and Subscriptions.

Step 2: Assign the AOS-S Switch to a Group
Before assigning a group, determine if the switch must be provisioned in a UI or template group. By
default, Aruba Central On-Premises assigns the factory default switches to the default group. You can
create a new group and assign switch to the new group.

For step-by-step instructions on creating a group, see Groups.

To assign a device to a group, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization.

By default, the Network Structure tab is displayed.

3. Click the Device Preprovisioning tile.
4. Select the device that you want to assign to a group.

If the selected device is already connected to Aruba Central On-Premises, the Move devices option will
not be available for the device.
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5. Click Assign Group.

The Assign a Group to the Selected Devices window is displayed.

6. Select the group to which you want to assign.

7. Click the Move devices icon.
The Move Devices page is displayed.

8. Select the Destination Group from the drop-down list.
9. Click Move.

The selected devices are moved to the destination group. These devices will adopt the destination
group configuration.

To assign a device to a group from the Aruba Central On-Premises app, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization.

By default, the Network Structure tab is displayed.

3. Click the Groups tile.

The Groups page is displayed.

4. From the list of devices, select the switches to assign.

5. Click the Move devices icon.
The Move Devices page is displayed.

6. Select the Destination Group from the drop-down list.

7. Click Move.

The selected devices are moved to the destination group. These devices will adopt the destination
group configuration.

Step 3: Connect the AOS-S Switch to Aruba Central On-Premises
Switches with factory default configuration have very basic configuration for all ports in VLAN-1 that is
required for obtaining an IP address and automatic provisioning (ZTP). For ZTP, switches must have a
valid IP address, DNS, and NTP configuration. You must manually add either the serial number, MAC
address, or part number of the factory default switch in Aruba Central On-Premises

Step 4: Provision the AOS-S Switch to a Group
When the switch connects to Central, if it is already added to the device inventory and is assigned a
subscription in Aruba Central On-Premises, Aruba Central On-Premises assigns it to a pre-assigned
group. If there is no pre-assigned group, Aruba Central On-Premises moves the device to default group.
Based on your configuration requirements, you create a UI group or template group and assign the
switch.

The following figure illustrates the provisioning step required for each group type.
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Figure 93 Switch Provisioning Steps Per Group Type

If the switch is assigned to a new UI group, Aruba Central On-Premises uses the current configuration of
switch as base configuration and applies it to the other switches that join this group later. You can also
modify the configuration of switches in a group using the UI menu options under Aruba Central On-
Premises app > Manage > Device(s) > Switches. For more information, see Configuring AOS-S
Switches in UI Groups.

Provisioning AOS-S Switches in Template Groups
If you have assigned the switch to a template group, create a new configuration template.

To create a configuration template, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a template group.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Switches.
3. Click the AOS-S or Config icon to view the switch configuration dashboard.

The tabs to configure switches using templates is displayed.

4. Click the Templates tab.

The Templates page is displayed.

5. Click + to add a new template.

The Add Template page is displayed.

6. In the Basic Info tab, enter a name for the template in the Template Name field.
7. In the Device Type drop-down list, select Aruba Switch.
8. Select the switch model and software version. You can specify any of the following combinations:

n ALL for both Model and Version—To apply the template to all switch models and all
supported switch software versions.

n ALL for Model and a software version for Version—To apply the template to all switch models
running the selected software version.

n ALL for Version and a switch model for Model—To apply the template to a switch model and
all software versions supported by the selected switch model.

n A switch model and a software version—To apply the template to a specific switch model and
the software version. The template created for a switch model and a software version takes
precedence over the template that is created for all platforms and versions.
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9. Select the manufacturing part number of the switch in the Part Name drop-down list.

n The Part Name drop-down list is displayed only if you select a switch model in the Model drop-
down list.

n If you select a specific switch model and part number, you can apply the template to a standalone
switch and not to a stack.

n If you select All in the Model drop-down list, or if you select a switch model and All in the Part
Name drop-down list, you can apply a template to both a standalone switch and stack.

10. Click Next.
The Template tab is displayed.

11. Choose one of the following options:
n To build a new template, add the switch command information in the Template text box.

Ensure that the template text adheres to the guidelines listed in Important Points to Note.
n To import configuration text from a switch that is already provisioned in the template group,

complete the following steps:
a. Click Import Configuration As Template.
b. From the search box, select the switch from which you want to import the configuration.

The imported configuration is displayed in the Template text box.

n Importing configuration from an existing device in the template group allows you to
quickly create a basic template. However, before applying the template to other
switches in the group, ensure that the template text is variabilized as per your
deployment requirements. For more information on variables, see Managing Variable
Files.

n All switch templates must include a password command to set a password for the
device. The switch template cannot be saved without adding a password command. If
the configuration that is pushed from Aruba Central to the device does not contain a
password command, the configuration push is aborted for the device and a log is
added to the audit trail. For example, if you add the password command in a condition
block and the condition evaluates to false, the configuration that is pushed will not
contain the password command. For more information, see Managing Password in
Configuration Templates.
For more information about using password commands, see the Configuring
Username and Password Security chapter in the ArubaOS-Switch Access Security Guide.

c. To view the variables present in the imported configuration template, click Show
Variables List.
The Variables in Template column is displayed.

For more information on variables, see Managing Variable Files.

d. To download the variables as a CSV or plain text file, click the download icon and select
one of the following options:
n Download .CSV
n Download plain text (.txt)
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12. Click Save.

After you apply the configuration template, switches reboot and reconnect to Aruba Central On-
Premises with the new configuration.

Step 5: Verify the Configuration Status
To verify the configuration status, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a template group.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Switches.
3. Click the Config icon.

The tabs to configure switches using templates is displayed. Choose one of the following options:
n To verify the configuration status for the template group, click Configuration Audit. The

Configuration Audit dashboard displays the number of devices with template and
configuration synchronization errors.

n To view configuration errors for a specific device, select a switch from the filter bar. The
Configuration Audit dashboard displays the number of template and configuration
synchronization errors for the device.

4. To view template errors, click View Template Errors under Template Errors.
5. To view configuration synchronization errors, click View Details under Configuration Status.
6. To compare running configuration and pending changes, click View under Config Comparsion

Tool.

Provisioning Pre-Configured AOS-S Switches
Unlike factory default switches, locally managed switches and the switches with custom configuration
require one touch provisioning. These switches do not automatically identify Aruba Central On-
Premises as their management platform, therefore you must manually enable the Aruba Central On-
Premises management service on these switches to allow them to connect to Aruba Central On-
Premises.

Aruba Central On-Premises does not support adding pre-configured switches to a UI group. Pre-configured
switches that have pre-assigned UI switch groups are added to the Unassigned Devices group. To provision a
pre-configured switch to a UI group or move a switch from a template group to a UI group, complete the
following steps:

1. Clear the switch configuration.

2. Delete the device from Aruba Central On-Premises.

3. Provision the switch as a new device in a UI group.

To onboard a locally-managed or a pre-configured switch to Aruba Central On-Premises, follow one of
the following options:

n Manually enable Aruba Central On-Premises management service on the switch and connect it to
Aruba Central On-Premises. Aruba recommends that you use this option if you want to preserve the
current configuration running on the switch. For more information on this procedure, see the
workflows described in this topic.
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To manually connect the switch to Aruba Central On-Premises, you must configure the Aruba Central On-
Premises URL on the switch. Issue the following commands in the switch CLI.

conf t

aruba-central url <Aruba Central On-Premises URL>/ws

exit

Aruba does not recommend to manually provision the URL in a cloud deployment.

n Reset the switch configuration and use ZTP to provision the switch. You must first create a backup of
the configuration, then reset the switch using the erase all zeroize command in the CLI. This
initiates ZTP on the switch, enabling the switch to obtain the IP address from the option 43 sent by
the DHCP server and then connect to Aruba Central On-Premises.

Aruba Central On-Premises supports provisioning switches by using one of the following methods:

n Pre-provisioning—In this workflow, a switch is added to the device inventory and assigned a group in
Aruba Central On-Premises before it connects to Aruba Central On-Premises.

See Workflow 1—Pre-Provisioning an AOS-S Switch.
n Onboarding connected switches—In this workflow, Aruba Central On-Premises onboards the switch

that attempts to connect and then assigns a group.

See Workflow 2—Provisioning an AOS-S Switch On-Demand.

The following figure illustrates the provisioning procedure for a pre-configured switch.

Figure 94 Provisioning Workflow for Pre-Configured AOS-S Switches
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Workflow 1—Pre-Provisioning an AOS-S Switch
The pre-provisioning workflow includes the following steps:

n Step 1: Onboard the AOS-S Switch to Aruba Central On-Premises
n Step 2: Assign the AOS-S Switch to a Group
n Step 3: Enable Aruba Central On-Premises Management Service on the AOS-S Switch
n Step 4: Provision the AOS-S Switch to a Group
n Step 5: Verify the Configuration Status

Step 1: Onboard the AOS-S Switch to Aruba Central On-Premises

n Log in to Aruba Central On-Premises.
n Add switches to Aruba Central—Adding switches to Aruba Central is available in the HPE GreenLake

account home. For more information , see Managing Devices and Subscriptions.
n Assign subscriptions—Assigning subscriptions to devices is available in the HPE GreenLake account

home. For more information, see Managing Devices and Subscriptions.

Step 2: Assign the AOS-S Switch to a Group
Before assigning a group, determine if the switch must be provisioned in a UI or template group. If you
want to preserve the existing configuration on the switch, Aruba recommends that you create a new
group for the switch.

For more information on creating a group, see Groups.

To assign a device to a group, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization.

By default, the Network Structure tab is displayed.

3. Click the Device Preprovisioning tile.
4. Select the device that you want to assign to a group.

If the selected device is already connected to Aruba Central On-Premises, the Move devices option will
not be available for the device.

5. Click Assign Group.

The Assign a Group to the Selected Devices window is displayed.

6. Select the group to which you want to assign.

7. Click the Move devices icon.
The Move Devices page is displayed.

8. Select the Destination Group from the drop-down list.
9. Click Move.

The selected devices are moved to the destination group. These devices will adopt the
destination group configuration.

To assign a device to a group from the Aruba Central On-Premises app, complete the following steps:
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1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization.

By default, the Network Structure tab is displayed.

3. Click the Groups tile.

The Groups page is displayed.

4. From the list of devices, select the switches to assign.

5. Click the Move devices icon.
The Move Devices page is displayed.

6. Select the Destination Group from the drop-down list.

7. Click Move.

The selected devices are moved to the destination group. These devices will adopt the destination
group configuration.

Step 3: Enable Aruba Central On-Premises Management Service on the AOS-S Switch
A locally-managed or pre-configured switch cannot connect to Aruba Central On-Premises, unless it is
configured to identify Aruba Central On-Premises as its management entity. To manage such a device
from Aruba Central On-Premises, you must manually enable the provisioning and management service
on the switch.

To enable switches to automatically connect to Aruba Central On-Premises, enforce ZTP on the switch
by issuing the following command.

(switch)# erase all zeroize

The switch obtains the IP address from the option 43 sent by the DHCP server and then connects to
Aruba Central On-Premises. If the switch is already added to the device inventory and is assigned a
subscription, Aruba Central On-Premises assigns it to a pre-assigned group.

Step 4: Provision the AOS-S Switch to a Group
When the switch connects to Aruba Central On-Premises, Aruba Central On-Premises automatically
assigns it to the pre-assigned group.

The following figure illustrates the provisioning steps for each group type.
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Figure 95 Switch Provisioning Steps Per Group Type

If the switch is assigned to a new UI group, you can modify the configuration of switches in a group
using the UI menu options under Aruba Central On-Premises app > Manage > Device(s) > Switches.
For more information, see Configuring AOS-S Switches in UI Groups.

If you have assigned the switch to a template group, you can import the existing configuration to a new
configuration template and apply this template to other devices in the group.

To create a configuration template using the existing configuration on the switch, complete the
following steps:

1. In the Aruba Central On-Premises app, set the filter to a template group.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Switches.
3. Click the AOS-S or Config icon to view the switch configuration dashboard.

The tabs to configure switches using templates is displayed.

4. Click the Templates tab.

The Templates page is displayed.

5. Click + to add a new template.

The Add Template page is displayed.

6. In the Basic Info tab, enter a name for the template in the Template Name field.
7. In the Device Type drop-down list, select Aruba Switch.
8. Select the switch model and software version. You can specify any of the following combinations:

n ALL for both Model and Version—To apply the template to all switch models and all
supported switch software versions.

n ALL for Model and a software version for Version—To apply the template to all switch models
running the selected software version.

n ALL for Version and a switch model for Model—To apply the template to a switch model and
all software versions supported by the selected switch model.

n A switch model and a software version—To apply the template to a specific switch model and
the software version. The template created for a switch model and a software version takes
precedence over the template that is created for all platforms and versions.
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9. Select the manufacturing part number of the switch in the Part Name drop-down list.

n The Part Name drop-down list is displayed only if you select a switch model in the Model drop-down list.
n If you select a specific switch model and part number, you can apply the template to a standalone switch

and not to a stack.
n If you select All in the Model drop-down list, or if you select a switch model and All in the Part Name

drop-down list, you can apply a template to both a standalone switch and stack.

10. Choose one of the following options:
n To build a new template, add the switch command information in the Template text box.

Ensure that the template text adheres to the guidelines listed in Important Points to Note.
n To import configuration text from a switch that is already provisioned in the template group,

complete the following steps:
a. Click Import Configuration As Template.
b. From the search box, select the switch from which you want to import the configuration.

The imported configuration is displayed in the Template text box.

c. If required, modify the configuration parameters. Ensure that the template text adheres
to the guidelines listed in Configuring AOS-S Switches using Templates.

11. Click Next.
 The Template tab is displayed.

n Importing configuration from the switch allows you to quickly create a basic configuration
template that you can apply for all devices in a template group. Before applying the template to
other switches in the group, ensure that the template text is variabilized based on the deployment
requirements. For more information on configuration templates and variable definitions, see
Configuring AOS-S Switches using Templates and Managing Variable Files.

n All switch templates must include a password command to set a password for the device. The
template cannot be saved without adding a password command. If the configuration that is
pushed from Aruba Central On-Premises to the device does not contain a password command,
the configuration push is aborted for the device and a log is added to the audit trail. For example,
if you add the password command in a condition block and the condition evaluates to false, the
configuration that is pushed will not contain the password command. For more information, see
Managing Password in Configuration Templates.
For more information about using password commands, see the Configuring Username and
Password Security chapter in the ArubaOS-Switch Access Security Guide.

12. a. To view the variables present in the imported configuration template, click Show Variables
List.
The Variables in Template column is displayed.

For more information on variables, see Managing Variable Files.

b. To download the variables as a CSV or plain text file, click the download icon and select one of
the following options:
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n Download .CSV
n Download plain text (.txt)

13. Click Save.

After you apply the configuration template, switches reboot and reconnect to Aruba Central On-
Premises with the new configuration.

Step 5: Verify the Configuration Status
To verify the configuration status, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a template group.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Switches.
3. Click the AOS-S or Config icon to view the switch configuration dashboard.

The tabs to configure switches using templates is displayed. Choose one of the following options:
n To verify the configuration status for the template group, click Configuration Audit. The

Configuration Audit dashboard displays the number of devices with template and
configuration synchronization errors.

n To view configuration errors for a specific device, select a switch from the filter bar. The
Configuration Audit dashboard displays the number of template and configuration
synchronization errors for the device.

4. To view template errors, click View Template Errors under Template Errors.
5. To view configuration synchronization errors, click View Details under Configuration Status.
6. To compare running configuration and pending changes, click View under Config Comparsion

Tool.

Workflow 2—Provisioning an AOS-S Switch On-Demand
To dynamically provision switches on-demand, complete the following steps:

n Step 1: Enable Aruba Central On-Premises Management Service on the AOS-S Switch
n Step 2: Add the AOS-S Switch to Aruba Central On-Premises
n Step 3: Assign a Subscription
n Step 4: Provision the AOS-S Switch to a Group
n Step 5: Verify the Configuration Status

Step 1: Enable Aruba Central On-Premises Management Service on the AOS-S Switch
A locally-managed or pre-configured switch cannot connect to Aruba Central On-Premises, unless it is
configured to identify Aruba Central On-Premises as its management entity. To manage such a device
from Aruba Central On-Premises, you must manually enable the provisioning and management service
on the switch.

To enable switches to automatically connect to Aruba Central On-Premises, enforce ZTP on the switch
by issuing the following command.

(switch)# erase all zeroize

The switch obtains the IP address from the option 43 sent by the DHCP server and then connects to
Aruba Central On-Premises.
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Step 2: Add the AOS-S Switch to Aruba Central On-Premises
Add the switch to the Aruba Central On-Premises device inventory. Adding switches to Aruba Central
On-Premises is available in the HPE GreenLake account home. For more information, see Managing
Devices and Subscriptions.

Step 3: Assign a Subscription
To allow Aruba Central On-Premises to manage the switch, ensure that a valid subscription is assigned
to the switch. Assigning subscriptions to devices is available in the HPE GreenLake account home. For
more information, see Managing Devices and Subscriptions.

Step 4: Provision the AOS-S Switch to a Group
If the switch has a valid subscription assigned, Aruba Central On-Premises marks the switch as
unprovisioned. To preserve the switch configuration, move it to a new group.

To move the device to a UI group, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
The dashboard context for the group is displayed.

2. Under Maintain, click Organization.

By default, the Network Structure tab is displayed.

3. Click the Groups tile.

The Groups page is displayed.

4. Select the device.
5. Click Import Group.

The Add Group page is displayed.

6. Enter a name for the group.
7. Configure a password for the group.
8. Click Add.

Aruba Central On-Premises imports the switch configuration to the new group.

You can also modify the configuration of switches in a group using the UI menu options under the
Aruba Central On-Premises app > Manage > Devices > Switches. For more information, see
Configuring AOS-S Switches in UI Groups.

To move the device to a template group, complete the following steps:

1. Create a template group.
2. On the Groups page, select the switch.
3. Drag and drop the switch the new template group that you just created.

Aruba Central On-Premises adds the switch to the new template group.

4. To import switch configuration to a new configuration template, complete the following steps:
a. In the Aruba Central On-Premises app, set the filter to a template group.

The dashboard context for the group is displayed.
b. Under Manage, click Devices > Switches.
c. Click the AOS-S or Config icon to view the switch configuration dashboard.

The tabs to configure switches using templates is displayed.
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d. Click the Templates tab.

The Templates page is displayed.
e. Click + to add a new template.

The Add Template page is displayed.
f. In the Basic Info tab, enter a name for the template in the Template Name field.
g. In the Device Type drop-down list, select Aruba Switch.
h. Select the switch model and the software version to which you want to apply the new

template. You can specify any of the following combinations:
n ALL for both Model and Version—To apply the template to all switch models and all

supported switch software versions.
n ALL for Model and a software version for Version—To apply the template to all switch

models running the selected software version.
n ALL for Version and a switch model for Model—To apply the template to a switch model

and all software versions supported by the selected switch model.
n A switch model and a software version—To apply the template to a specific switch model

and the software version. The template created for a switch model and a software version
takes precedence over the template that is created for all platforms and versions.

i. Select the manufacturing part number of the switch in the Part Name drop-down list.

n The Part Name drop-down list is displayed only if you select a switch model in the Model
drop-down list.

n If you select a specific switch model and part number, you can apply the template to a
standalone switch and not to a stack.

n If you select All in the Model drop-down list, or if you select a switch model and All in the
Part Name drop-down list, you can apply a template to both a standalone switch and stack.

j. Click Next.
The Template tab is displayed.

k. Build a new template or import configuration information from a switch that is already
provisioned in the template group. See step 11.

n Importing configuration from the switch allows you to quickly create a basic configuration
template that you can apply for all devices in a template group. Before applying the template
to other switches in the group, ensure that the template text is variabilized based on the
deployment requirements. For more information on configuration templates and variable
definitions, see Configuring AOS-S Switches using Templates and Managing Variable Files.

n All switch templates must include a password command to set a password for the device.
The template cannot be saved without adding a password command. If the configuration
that is pushed from Aruba Central On-Premises to the device does not contain a password
command, the configuration push is aborted for the device and a log is added to the audit
trail. For example, if you add the password command in a condition block and the condition
evaluates to false, the configuration that is pushed will not contain the password command.
For more information, see Managing Password in Configuration Templates.
For more information about using password commands, see the Configuring Username and
Password Security chapter in the ArubaOS-Switch Access Security Guide.
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l. To view the variables present in the imported configuration template, click Show Variables
List.
The Variables in Template column is displayed.

For more information on variables, see Managing Variable Files.
m. To download the variables as a CSV or plain text file, click the download icon and select one of

the following options:
n Download .CSV
n Download plain text (.txt)

n. Click Save.

After you apply the configuration template, switches reboot and reconnect to Aruba Central
On-Premises with the new configuration.

Step 5: Verify the Configuration Status
To verify the configuration status, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a template group.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Switches.
3. Click the AOS-S or Config icon to view the switch configuration dashboard.

The tabs to configure switches using templates is displayed. Select one of the following options:
n To verify the configuration status for the template group, click Configuration Audit. The

Configuration Audit dashboard displays the number of devices with template and
configuration synchronization errors.

n To view configuration errors for a specific device, select a switch from the filter bar. The
Configuration Audit dashboard displays the number of template and configuration
synchronization errors for the device.

4. To view template errors, click View Template Errors under Template Errors.
5. To view configuration synchronization errors, click View Details under Configuration Status.
6. To compare running configuration and pending changes, click View under Config Comparsion

Tool.

Managing Password in Configuration Templates
All IAP and switch templates must include a password command to set a password for the device. The
template cannot be saved without adding a password command. If the configuration that is pushed
from Aruba Central On-Premises to the switch does not contain a password command, the
configuration push is aborted for the device and a log is added to the audit trail. For example, if you add
the password command in a condition block and the condition evaluates to false, the configuration that
is pushed will not contain the password command.

n When configuring a password, you must add the include-credentials command in the template. This
command stores the password in the running-config file associated with the switch. Aruba Central On-
Premises automatically executes this command while reading the switch configuration.

n For AOS-CX switches, you must configure the password only in plaintext.



Configuring AOS-S Switches | 706

Password for Switches
The following format of the passwords can be set on AOS-S series.

password manager plaintext <string>

password manager sha1 <string>

password manager sha256 <string>

password manager user-name <string> plaintext <string>

password manager user-name <string> sha1 <string>

password manager user-name <string> sha256 <string>

The following format of the passwords can be set on AOS-CX switches.

user manager group <string> password plaintext <string>

user manager password plaintext <string>

Password for APs
The following format of the passwords can be set on the APs.

mgmt-user <STRING:username:User_name> { <STRING:password:Password> }

hash-mgmt-user <STRING:username:User_name> password cleartext <STRING:cleartext_

password:Password>

hash-mgmt-user <STRING:username:User_name> password hash <STRING:hash_

password:Password>

Setting Password using Variables
User cannot enter the entire password line in a variable. The following examples show the valid and
invalid format for entering password using a variable.

Valid format where the variable contains only the password (for example, %pass_var% = Aruba@123) for
the device.

hostname "Aruba-2930M-24G"

password manager plaintext "%pass_var%"

include-credentials

no cwmp enable

Invalid format where the variable contains the password command (for example, %pass_var% =

password manager plaintext Aruba@123) for the device.

hostname "Aruba-2930M-24G"

%pass_var%

include-credentials

no cwmp enable

Encrypting Credentials on AOS-S Switches using Templates
There is a security threat when the credentials used for authentication in the configuration file are
displayed in plain text. The support for encrypting credentials allows storing, displaying, and
transferring of credentials in the encrypted form.
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Aruba Central On-Premises allows encrypting credentials on AOS-S switches using templates. This
procedure involves configuring encrypt-credentials both on switch CLI and templates created in Aruba
Central On-Premises.

Encrypting credentials on AOS-S Switches Using Default 256-Bit Key
Aruba Central On-Premises allows encrypting credentials on AOS-S switches using the default 256-bit
key. This involves completing configuration procedures both in the switch CLI and Aruba Central On-
Premises.

By default, a fixed, default 256-bit key that is common to all AOS-S switches is used. This allows transfer
of configurations with all relevant credentials and provides more security than plain-text passwords in
the configuration.

To enable the encrypt-credentials feature using the default 256-bit key, complete the following steps:

Switch CLI

1. Configure all the switch features that need encrypted credentials from the switch CLI.

For example, if you want to configure a RADIUS server with encrypted credentials, issue the
following command:

switch(config)# radius-server host 10.1.1.1 key "123123"

2. Enable encrypt credentials by issuing the following command.

This command enables the encryption of relevant security parameters in the configuration.

switch(config)# encrypt-credentials

3. Enter the show running config command and copy the output of the entire running
configuration.

The following is an example of the show running config output with the encrypted credentials
configuration:

; JL262A Configuration Editor; Created on release #WC.16.10.0016

; Ver #14:67.6f.f8.1d.9b.3f.bf.bb.ef.7c.59.fc.6b.fb.9f.fc.ff.ff.37.ef:44

; encrypt-cred

tFOJkMeZma+Hd2xb6MYcTzulT4U5e+wtUPmBFeRD9eSrEahUow/jvPG44dOZvjpk

hostname "Aruba-2930F-48G-PoEP-4SFP"

module 1 type jl262a

encrypt-credentials

trunk 3 trk1 trunk

trunk 7 trk2 trunk

include-credentials

encrypted-password manager user-name "admin"

"bOF7OITZ0/fchgEYsEJXx9pceKnGI6Ie182o5e7dHgT7LhVKaDFq0TWe3/bXZIJOEgmTZAOVo/1

jzQcHtB1QdQ=="
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radius-server host 10.1.1.1 encrypted-key

"Ak12qUjAjzwrkKE/Wwy7AsZetv62tk9QmuUgY/VLGRU="

ip access-list extended "abcsdfds"

exit

snmp-server community "public"

snmp-server enable traps mac-count-notify

snmpv3 engineid "00:00:00:0b:00:00:f4:03:43:f6:de:40"

vlan 1

name "DEFAULT_VLAN"

no untagged 32

untagged 1-2,4-6,8-31,33-52,Trk1-Trk2

ip address dhcp-bootp

ipv6 enable

ipv6 address dhcp full

exit

vlan 2

name "vlan2"

untagged 32

tagged Trk1

ip address dhcp-bootp

exit

vlan 3

name "vlan3"

ip address dhcp-bootp

exit

vlan 4

name "vlan4"

tagged Trk2

ip address dhcp-bootp

exit

spanning-tree Trk1 priority 4

spanning-tree Trk2 priority 4

no tftp server

no autorun

no dhcp config-file-update

no dhcp image-file-update

no dhcp tr69-acs-url

dhcp-server pool "dummy1"

lease 01:05:06
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network 44.44.0.0 255.255.0.0

range 44.44.0.20 44.44.0.80

exit

Aruba Central On-Premises

1. In Aruba Central On-Premises, set the filter to one of the template groups under Groups.
2. Under Manage, click Devices > Switches > Templates and click the edit icon in the template you

want to edit. The Edit Template screen is displayed.
3. Paste the entire running configuration copied from the switch CLI or Import Configuration as

Template from Aruba Central On-Premises.

Importing the configuration from a switch will replace the existing template content.

4. Click Save. The switch configurations along with encrypted credentials are pushed to the
switches.

Important Points to Note

n To disable the encrypt-credentials feature in Aruba Central On-Premises, you must first disable the
encrypted credentials from the switch CLI, copy the running configuration and update the Aruba
Central On-Premises template.

Encrypting Credentials on AOS-S Switches Using User-Defined Pre-Shared Key
Aruba Central On-Premises allows encrypting credentials on AOS-S switches using a user-defined pre-
shared key (PSK). This involves completing configuration procedures both in the switch CLI and Aruba
Central On-Premises.

The support for encrypting credentials using a user-defined pre-shared key (PSK). is available only for AOS-S
switches running the following firmware versions:

n For 16.10, the minimum supported version is 16.10.0022.
n For 16.11, the minimum supported version is 16.11.0006.

If the encrypt-credentials feature is configured on switches running firmware versions 16.10.0022 or later, and
you want to upgrade to 16.11, then you must upgrade to 16.11.0006 or later versions. Otherwise, the encrypt-
credentials feature will not work.

To enable the encrypt-credentials feature using a user-defined pre-shared key, complete the following
steps:

Switch CLI

1. Configure all the switch features that need encrypted credentials from the switch CLI.

For example, if you want to configure a RADIUS server with encrypted credentials, issue the
following command:
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switch(config)# radius-server host 10.1.1.1 key "123123"

2. Create a pre-shared key in the hexadecimal or plaintext string by issuing the following command:

switch(config)# encrypt-credentials pre-shared-key <hex | plaintext>

3. Enable encrypt credentials by issuing the following command.

This command enables the encryption of relevant security parameters in the configuration.

switch(config)# encrypt-credentials

4. Enter the show running config command and copy the output of the entire running
configuration.

The following is an example of the show running config output with the encrypted credentials
configuration:

; JL262A Configuration Editor; Created on release #WC.16.10.0022

; Ver #14:67.6f.f8.1d.9b.3f.bf.bb.ef.7c.59.fc.6b.fb.9f.fc.ff.ff.37.ef:44

; encrypt-cred

tFOJkMeZma+Hd2xb6MYcTzulT4U5e+wtUPmBFeRD9eSrEahUow/jvPG44dOZvjpk

hostname "Aruba-2930F-48G-PoEP-4SFP"

module 1 type jl262a

encrypt-credentials

trunk 3 trk1 trunk

trunk 7 trk2 trunk

include-credentials

encrypted-password manager user-name "admin"

"bOF7OITZ0/fchgEYsEJXx9pceKnGI6Ie182o5e7dHgT7LhVKaDFq0TWe3/bXZIJOEgmTZAOVo/1

jzQcHtB1QdQ=="

radius-server host 10.1.1.1 encrypted-key

"Ak12qUjAjzwrkKE/Wwy7AsZetv62tk9QmuUgY/VLGRU="

ip access-list extended "abcsdfds"

exit

snmp-server community "public"

snmp-server enable traps mac-count-notify

snmpv3 engineid "00:00:00:0b:00:00:f4:03:43:f6:de:40"

vlan 1

name "DEFAULT_VLAN"

no untagged 32
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untagged 1-2,4-6,8-31,33-52,Trk1-Trk2

ip address dhcp-bootp

ipv6 enable

ipv6 address dhcp full

exit

vlan 2

name "vlan2"

untagged 32

tagged Trk1

ip address dhcp-bootp

exit

vlan 3

name "vlan3"

ip address dhcp-bootp

exit

vlan 4

name "vlan4"

tagged Trk2

ip address dhcp-bootp

exit

spanning-tree Trk1 priority 4

spanning-tree Trk2 priority 4

no tftp server

no autorun

no dhcp config-file-update

no dhcp image-file-update

no dhcp tr69-acs-url

dhcp-server pool "dummy1"

lease 01:05:06

network 44.44.0.0 255.255.0.0

range 44.44.0.20 44.44.0.80

exit

5. Issue the show encrypt-credentials command and copy the pre-shared key from the switch CLI.

switch(config)# show encrypt-credentials

Encryption : Enabled

Pre-shared Key:

c63895c8516a73d0491f59ee750f2d75354b1888e689ae18f1b5b37255b63c1f

Aruba Central On-Premises
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1. In Aruba Central On-Premises, set the filter to one of the template groups under Groups.
2. Under Manage, click Devices > Switches > Templates and click the edit icon in the template you

want to edit. The Edit Template screen is displayed.
3. Paste the entire running configuration copied from the switch CLI or Import Configuration as

Template from Aruba Central On-Premises.

Importing the configuration from a switch will replace the existing template content.

4. In Aruba Central On-Premises, append the pre-shared key obtained from issuing the show

encrypt-credentials after the running configuration as shown in the following format:

encrypt-credentials pre-shared-key hex

c63895c8516a73d0491f59ee750f2d75354b1888e689ae18f1b5b37255b63c1f

5. Click Save. The switch configurations along with encrypted credentials are pushed to the
switches.

Important Points to Note

n In the Aruba Central template, only the SHA256 hash is supported as a pre-shared key.
n To disable the encrypt-credentials feature in Aruba Central On-Premises, you must first disable the

encrypted credentials from the switch CLI, copy the running configuration and update the Aruba
Central On-Premises template. You must also delete the pre-shared key appended at the end of the
template.

n An audit log is added to the Audit Trail page in the following scenario.

Scenario Audit log

When the switch is running a lower
firmware version than the
supported firmware version.

Configuration push aborted, the encrypt-credentials feature is
supported from firmware 16.10.0022 and above.

n In all the following cases, you must first configure the changes from the switch CLI, copy the running
configuration, and update the Aruba Central On-Premises template. You must also append the pre-
shared key at the end of the template.
o Changing the credentials (Example: switch manager password)
o Changing the pre-shared key used for encryption
o Adding a new configuration with the password

n The switch configuration must be imported from the Aruba Central On-Premises template.

Monitoring-Only Mode for AOS-S Switches
Aruba Central On-Premises allows you to add AOS-S switches to UI groups in the monitoring-only mode,
for monitoring, reporting, and troubleshooting. For switches that are added in this mode, configuration
changes are not allowed to be performed using UI groups in Aruba Central On-Premises.

To configure these switches using Aruba Central On-Premises, you must add them to a template group.
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The recommended software version to configure AOS-S switches in this mode is 16.10.0010.

For switches that are added in this mode:

n At the group level, the configuration icon is replaced by a note icon displaying that this group is a
monitoring-only group.

n At the device level, the Manage > Device option will not be available.

To add AOS-S switches in the monitoring-only group, complete the following steps:

1. In the Organization > Groups page, create a UI group.

In the Add Group page, select the Monitoring only for AOS-S check box.

2. Add the AOS-S switches to the UI group.

Verifying the Monitoring-Only Mode of AOS-S Switches
To verify whether the switches are added in the monitoring-only mode, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter, set the filter to a group containing at least one switch.

The dashboard context for the group is displayed.
n To select a switch in the filter, set the filter to Global or a group containing at least one switch.

2. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

The Config Status column in the Switches table displays Monitoring only for the switches that
are added in the monitoring-only mode.

Configuring AOS-S Switches using Templates
Templates in Aruba Central On-Premises refer to a set of configuration commands that can be used by
the administrators for provisioning devices in a group. Configuration templates enable administrators
to apply a set of configuration parameters simultaneously to multiple switches in a group and thus
automate switch deployments.

To minimize configuration errors and troubleshoot device-specific configuration issues, Aruba recommends
that the device administrators familiarize themselves with the CLI configuration commands available on AOS-S.

For template-based provisioning, switches must be assigned to a template group.

Creating a Group for Template-Based Configuration
Unlike UI groups, template groups have minimal UI options and use the CLI commands to provision a
device. Template groups allow you to automate switch deployments. For template-based provisioning,
switches must be assigned to a group with template-based configuration method enabled.

To manage devices using configuration templates, you can create a template group and assign devices.

For more information, see Groups and Groups.
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Creating a Configuration Template
To create a configuration template for switches, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a template group.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Switches.
3. Click the AOS-S or Config icon to view the switch configuration dashboard.

The tabs to configure switches using templates is displayed.

4. Click the Templates tab.

The Templates table is displayed.

5. Click + to add a new template.

The Add Template page is displayed.

6. In the Basic Info tab, enter a name for the template in the Template Name field.
7. In the Device Type drop-down list, select Aruba Switch.
8. Select the switch model and software version. You can specify any of the following combinations:

n ALL for both Model and Version—To apply the template to all switch models and all
supported switch software versions.

n ALL for Model and a software version for Version—To apply the template to all switch models
running the selected software version.

n ALL for Version and a switch model for Model—To apply the template to a switch model and
all software versions supported by the selected switch model.

n A switch model and a software version—To apply the template to a specific switch model and
the software version. The template created for a switch model and a software version takes
precedence over the template that is created for all platforms and versions.

9. Select the manufacturing part number of the switch in the Part Name drop-down list.

n The Part Name drop-down list is displayed only if you select a switch model in the Model drop-down list.
n If you select a specific switch model and part number, you can apply the template to a standalone switch

and not to a stack.
n If you select All in the Model drop-down list, or if you select a switch model and All in the Part Name

drop-down list, you can apply a template to both a standalone switch and stack.

10. Click Next.
The Template tab is displayed.

11. Choose one of the following options:
a. To build a new template, add the switch command information in the Template text box.

Ensure that the template text adheres to the guidelines listed in the Important Points to
Note.

b. To import configuration text from a switch that is already provisioned in the template group,
complete the following steps:
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i. Click Import Configuration As Template.

ii. From the search box, select the switch from which you want to import the configuration.

The imported configuration is displayed in the Template text box.

iii. If required, modify the configuration parameters. Ensure that the template text adheres
to the guidelines listed in the Important Points to Note.

n Importing configuration from an existing device in the template group allows you to
quickly create a basic template. However, before applying the template to other switches
in the group, ensure that the template text is variabilized as per your deployment
requirements. For more information on variable definitions, see Managing Variable Files.

n All switch templates must include a password command to set a password for the device.
The template cannot be saved without adding a password command. If the configuration
that is pushed from Aruba Central On-Premises to the device does not contain a
password command, the configuration push is aborted for the device and a log is added
to the audit trail. For example, if you add the password command in a condition block
and the condition evaluates to false, the configuration that is pushed will not contain the
password command. For more information, see Managing Password in Configuration
Templates.
For more information about using password commands, see the Configuring Username
and Password Security chapter in the ArubaOS-Switch Access Security Guide.

iv. To view the variables present in the imported configuration template, click Show
Variables List.
The Variables in Template column is displayed.

For more information on variables, see Managing Variable Files.

v. To download the variables as a CSV or plain text file, click the download icon and select
one of the following options:
n Download .CSV
n Download plain text (.txt)

12. Click Save.

After you apply the configuration template, switches reboot and reconnect to Aruba Central On-
Premises with the new configuration.

Important Points to Note
Note the following points when adding configuration text to a template:

n The CLI syntax in the switch template must be accurate. Aruba recommends that you validate the
configuration syntax on the switch before adding it to the template text.

n Ensure that the command text indentation matches the indentation in the running configuration.
n The commands in the template are case-sensitive.

The following example illustrates the case discrepancies that the users must avoid in templates and
variable definitions.
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trunk E1-E4 trk1 trunk

interface Trk1
dhcp-snooping trust

exit

trunk E1-E4 trk1 trunk

switch-interconnect trk1

trunk E5-E6 trk2 trunk

vlan 5

name "VLAN5"

untagged Trk2
tagged Trk1
isolate-list Trk1
ip igmp forcedfastleave Trk1
ip igmp blocked Trk1
ip igmp forward Trk1
forbid Trk1

loop-protect Trk2

trunk E1-E4 trk1 trunk

trunk E4-E5 trk2 trunk

spanning-tree Trk1 priority 4

spanning-tree Trk2 admin-edge-port

trunk A2-A4 trk1 trunk

igmp fastlearn Trk1

trunk E4-E5 trk2 trunk

ip source-binding 2 4.5.6.7 b05ada-96a4a0 Trk2

[no] ip source-binding trap OutOfResources

snmp-server mib hpSwitchAuthMIB ..

snmp-server mib hpicfMACsec unsecured-access ..

[no] lldp config <P-PORT-LIST> dot1TlvEnable ..

[no] lldp config <P-PORT-LIST> medTlvEnable ..

no lldp config <P-PORT-LIST> medPortLocation..

[no] lldp config <P-PORT-LIST> dot3TlvEnable ..

[no] lldp config <P-PORT-LIST> basicTlvEnable ..

[no] lldp config <P-PORT-LIST> ipAddrEnable <lldp-ip>

trunk-load-balance L4-based

trunk-load-balance L3-based

See also: Managing Variable Files.

Best Practices
Aruba recommends you to follow the below steps to use configuration templates in managing switches:

1. Configure the switch.
2. Add the switch to Aruba Central On-Premises.
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3. Create the template, You can use Import template option to import an existing template created
for switches.

4. Modify the template based on the user requirement. For example, addition or removal of
variables.

5. Save the edited template.

Configuring AOS-S Switches in UI Groups
This section describes the configuration and viewing procedures for the switches in the UI groups.

Aruba Central On-Premises does not support adding pre-configured switches to a UI group. Pre-configured
switches that have pre-assigned UI switch groups are added to the Unassigned Devices group. To provision a
pre-configured switch to a UI group or move a switch from a template group to a UI group, complete the
following steps:

1. Clear the switch configuration.

2. Delete the device from Aruba Central On-Premises.

3. Provision the switch as a new device in a UI group.

To configure or view properties of the switches provisioned in UI groups, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter, complete the following steps:

a. Set the filter to a group containing at least one switch.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-S or Config icon to view the switch configuration dashboard.

n To select a switch in the filter, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click a switch under Device Name.

The dashboard context for the switch is displayed.

d. Under Manage, click Device.

The tabs to configure the switch is displayed.

2. Click the configuration icon to edit the switch properties.

Tabs to access different configuration pages are displayed.

The following table describes the different configuration pages and their functions.
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Tab Function

Switches Configure or view general switch properties, such as, hostname, type of IP addressing,
and so on.
See Configuring or Viewing Switch Properties.

Stacks Create stacks, add members, or view stacking details such as stack type, stack id, topology
and so on.
See AOS-S Stack.

Ports Assign or view port properties, such as, PoE, access policies, and trunk groups.
See Configuring Switch Ports on AOS-S Switches

PoE Configure or view PoE settings for each port.
See Configuring PoE Settings on AOS-S Ports.

Trunk Groups Configure or view trunk groups and their associated properties, such as, members of the
trunk group, type of trunk group and so on.
See Configuring Trunk Groups on AOS-S Switches in UI Groups.

VLANs Configure or view VLANs and the associated ports and access policies.
See Configuring VLANs on AOS-S Switches.

Spanning Tree Configure or view spanning tree protocol and its associated properties.
See Enabling Spanning Tree Protocol on AOS-S Switches in UI Groups.

Loop Protection Configure or view loop protection and its associated properties.
See Configuring Loop Protection on AOS-S Switch Ports.

Access Policy Add or view access policies.
See Configuring Access Policies on AOS-S Switches.

DHCP Snooping Configure or view DHCP snooping, authorized DHCP servers IP addresses, and their
associated properties.
See Configuring DHCP Snooping on AOS-S Switches.

Port Rate Limit View or specify bandwidth to be used for inbound or outbound traffic for each port.
See Configuring Port Rate Limit on AOS-S Switches in UI Groups.

RADIUS Configure or view RADIUS (Remote Authentication Dial-In User Service) server
settings on switches.

See Configuring RADIUS Server Settings on AOS-S Switches.

Downloadable
User Role

Enable Downloadable User Role option and configure ClearPass settings to download
user-roles, policy, and class from the ClearPass Policy Manager server.
See Configuring Downloadable User Role on AOS-S Switches.

Tunnel Node
Server

Configure or view tunneled node on switches.
See Configuring Tunnel Node Server on AOS-S Switches.

Authentication Configure or view 802.1X authentication and MAC authentication for switches.
See Configuring Authentication for AOS-S Switches.

Access/DNS Configure or view the administrator and operator logins.
See Configuring System Parameters for AOS-S Switches.

Table 152: Tabs for Configuring AOS-S Switches Provisioned in a UI Group
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Tab Function

Time Configure time synchronization in switches.
See Configuring Time Synchronization on AOS-S Switches.

SNMP Add or view SNMP community and its trap destination.
See Configuring SNMP on AOS-S Switches.

CDP Configure CDP and its associated properties.
See Configuring CDP on AOS-S Switches.

Routing Configure or view a specific routing path to a gateway.
See Configuring Routing on AOS-S Switches.

DHCP Enable DHCP server and add DHCP pools on switches.
See Configuring DHCP on AOS-S Switches.

IGMP Configure IGMP and its associated properties.
See Configuring IGMP on AOS-S Switches.

IP Client Tracker Configure IP Client Tracker to access trusted and untrusted client networks.
See Configuring IP Client Tracker on AOS-S Switches.

QoS Create QoS traffic policies. define QoS classes and change the priorities of traffic on
switches.
See Configuring QoS Settings on AOS-S Switches.

Device Profile Configure or view device profile and device identifier settings on switches.
See Configuring Device Profile and Device Identifier on AOS-S Switches.

Configuration
Audit

View configuration sync errors and overrides.
See Verifying Device Configuration Status.

Configuring or Viewing Switch Properties
When you add a switch to a group, the switch inherits the configuration of the group.

It is not recommended to add a switch with an existing configuration to a group that already has a
defined configuration. Aruba Central On-Premises permits device-level overrides, however the overrides
are resolved or preserved based on the requirements.

You can create a new group and add a pre-configured switch to that group so that the group inherits the
configuration of the switch. If the switch inherits the group configuration, the configuration parameters
are already defined. If required, you can edit these parameters. All factory default switches are
provisioned in a new group and these parameters can also be defined at the group level.

To edit the configuration parameters for the switch in an UI group, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter, complete the following steps:

a. Set the filter to a group containing at least one switch.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-S or Config icon to view the switch configuration dashboard.
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n To select a switch in the filter, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click a switch under Device Name.

The dashboard context for the switch is displayed.

d. Under Manage, click Device.

The tabs to configure the switch is displayed.

2. Click the Switches tab.

The Switches page is displayed with the information described in the following table.

Name Description Value

MAC Address MAC address of the switch. Property inherited from the
switch.

Hostname Name of the host. A string.

IP Assignment Method of IP assignment as static or DHCP. Static or DHCP.

IP Address IP address for static IP assignment.

Netmask Netmask for static IP assignment.

Default
Gateway

Default gateway for static IP assignment.

Location Location of the switch. For example: Portland, Oregon.

Contact Email address or phone number. For example:
admin@xyzcompany.com.

Table 153: AOS-S Switch Parameters

3. To edit the switch configuration parameters, click the edit icon.

The Edit Switches page is displayed.

4. Edit the required parameters.

You can edit only Hostname, Location, and Contact information. Use the VLANs page to configure IP
Assignment, IP address, and Netmask and Default Gateway parameters. For more information, see
Configuring VLANs on AOS-S Switches.

5. Click OK.
6. Click Save Settings.

Configuring Switch Ports on AOS-S Switches
To view the port details of a switch, complete the following steps:
Switches
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1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter, complete the following steps:

a. Set the filter to a group containing at least one switch.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-S or Config icon to view the switch configuration dashboard.

n To select a switch in the filter, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click a switch under Device Name.

The dashboard context for the switch is displayed.

d. Under Manage, click Device.

The tabs to configure the switch is displayed.

2. Click Interface > Ports. The Ports page is displayed with the list of ports configured on the switch.

For AOS-S switches, the Ports page displays the information described in Table 154.

To list the unsupported transceivers, turn on the Unsupported transceivers toggle switch.

After enabling the Unsupported transceivers toggle switch, reboot the switch or replug the
transceivers. Disabling the unsupported transceivers will cause all the ports with unsupported
transceiver modules to go down.

Disabling the unsupported transceivers will cause all the ports with unsupported transceiver modules
to go down.

3. Select the port row, click Edit.
The Edit Ports pop-up window is displayed.

4. Configure the required parameters.
5. Click Save.

Name Description Value

Port Number Indicates the number assigned to the switch
port.

Dependent on the switch type.

Name Name of the port for easy identification.
You can add or edit port names. However,
do not delete port names as it may cause
config push to fail. The config push failure
may also arise if you move a switch from a
group configured with port names to a new
group. This issue is only applicable to switch
firmware versions earlier than 16.08.0002.

For example:
UPLINK-SRVR-ROOM

The following table describes the Ports page parameters for AOS-S switches.
Table 154: Ports Page—AOS-S Switches
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Name Description Value

Admin Status Allows you to set the operational status of
the port.

Up or Down

Speed-Duplex
(Mbps)

Allows you to set the maximum bandwidth
of the port traffic.

Select from drop-down.
Default is Auto.

Tunneled Indicates whether the port is tunneled or
not.

Enable or Disable
To configure a Tunnel Node Server, see
Configuring Tunnel Node Server on AOS-S
Switches.

DHCP Snooping Status of port to filter DHCP messages
received at the port.

Trust or Untrust
See Configuring DHCP Snooping on AOS-S
Switches.

Access Policy (In) Allows you to apply an existing access policy
for the inbound traffic on the port.

Select from drop-down.
See Configuring Access Policies on AOS-S
Switches.

Access Policy
(Out)

Allows you to apply an existing access policy
for the outbound traffic on the port.

Select from drop-down.
See Configuring Access Policies on AOS-S
Switches.

Trunk Group Displays the name of the trunk group to
which the port is assigned.

To configure a Trunk Group, see
Configuring Trunk Groups on AOS-S
Switches in UI Groups.

Support for Flexible Modules and SFP Ports
In Aruba Central On-Premises, you can manage Flexible modules and SFP ports using template and UI
groups. Flexible modules and SFP ports are supported on both standalone switches and switch stacks.
In the case of standalone switches in UI groups, the Flexible modules and SFP ports can be managed
only if the AOS-S switches are running 16.10.0010 or later firmware versions. These ports are available
for configuration at both group and device-levels.

At the group-level, the port numbers for Flexible modules and SFP ports are listed in the Ports page as
alphanumeric characters (A1-A4 and B1-B4) . At the device-level, only the ports that are listed in the
Ports page can push the configuration updates to Aruba Central On-Premises.

When you insert a new module, you might need to reboot or re-sync the device to detect the ports in
Aruba Central On-Premises. If the Flexible modules and SFP ports are successfully detected, the audit
trail displays the following message: Additional Alphanumeric SFP ports are detected. The Flexible
modules and SFP ports will not be removed from Central even when the modules are removed
physically from the device.

Configuring PoE Settings on AOS-S Ports
PoE is a technology that allows the switches to deliver power to the powered devices (PD). If you have
switches provisioned in UI groups, you can enable or disable PoE operation on switch ports. The PoE
page displays the configuration details of all PoE enabled ports.

To configure the PoE settings of a switch, complete the following steps:
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1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter, complete the following steps:

a. Set the filter to a group containing at least one switch.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-S or Config icon to view the switch configuration dashboard.

n To select a switch in the filter, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click a switch under Device Name.

The dashboard context for the switch is displayed.

d. Under Manage, click Device.

The tabs to configure the switch is displayed.

2. Click Interface > PoE.

The PoE page is displayed.

3. Select the port(s) you want to edit and click Edit.
The Edit Power Over Ethernet Settings pop-up window is displayed.

4. Configure the parameters described in Table 155
5. Click OK.
6. Click Save Settings.

Name Description Value

Port The number assigned to the switch port. The port number is
auto-generated and cannot be changed in the settings.

Auto-generated port number

PoE The status of the PoE operation on the port. When PoE is
enabled, the switch sends power to the powered device (PD).

Enabled or Disabled

Priority The PoE priority level of the port. If there is not enough
power available to provision all active PoE ports, then PoE
ports at priority level as critical are powered first, then high
and low priority at the last.

Low, High or Critical

LLDP MED
TLV (PoE)

The status of the LLDP MED TLV configuration. Switches use
LLDP to repeatedly query the PD to discover the power
requirement and send the exact power required.

Enabled or Disabled

LLDP Dot3
TLV (PoE+)

The status of the LLDP Dot3 TLV configuration. Enabled or Disabled

Allocation By The PoE power allocation method used for the port. If usage
is selected, then the allocation is made based on the
automatic allocation by the PD. If class is selected, then the
allocation is made based on class of the PD.

Usage or Class

The following table describes the PoE parameters.
Table 155: PoE Parameters
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Name Description Value

Pre Std
Detect

The status of support for pre-standard devices. When this
option is enabled, switch supports some pre-802.3af devices.

Enabled or Disabled

Configured
type

The user-defined identifier for the port to identify its
intended use.

A string

The status of LLDP in PoE page is displayed as Enabled only if one or both LLDP settings (LLDP MED TLV (PoE)
and LLDP Dot3 TLV (PoE+)) are enabled for the port.

Configuring Trunk Groups on AOS-S Switches in UI Groups
If you have switches provisioned in an UI group, Aruba Central On-Premises enables you to configure
port trunking on these switches using the UI workflows. The network administrator can configure a
trunk group on switches to create one logical link or a trunk by aggregating multiple links. The trunk link
functions as a high-speed link to provide increased bandwidth.

A trunk group is a set of up to eight ports configured as members of the same port trunk.

The following table describes the valid trunk groups for each switch platform.

AOS-S Platform Valid Trunk Groups

Aruba 2540 Switch Series Trk1-Trk26

Aruba 2930F Switch Series
Aruba 2930M Switch Series

Trk1-Trk60

Aruba 3810 Switch Series Trk1-Trk144

Table 156: Trunk Group Configuration Support Per AOS-S Platform

The following are some guidelines:

n All ports in the same trunk group must be of the same trunk type (LACP or trunk).

n The names of the trunk groups include the prefix Trk followed by the numbers in a sequential order.
For example, Trk1, Trk2 and so on.

n When STP is enabled on the switch, the STP configuration is applied for all ports at the trunk group
level. Individual ports cannot be configured for STP or VLAN operation.

Adding Trunk Groups on AOS-S Switches
To configure a trunk group on switches, ensure that the switches are onboarded and provisioned to a UI
group in Aruba Central On-Premises.

To add trunk groups on AOS-S switches, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter, complete the following steps:

a. Set the filter to a group containing at least one switch.

The dashboard context for the group is displayed.
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b. Under Manage, click Devices > Switches.
c. Click the AOS-S or Config icon to view the switch configuration dashboard.

n To select a switch in the filter, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click a switch under Device Name.

The dashboard context for the switch is displayed.

d. Under Manage, click Device.

The tabs to configure the switch is displayed.

2. Click Interface > Trunk Groups.

The Trunk Groups page is displayed.

3. In the Trunk Groups table, click + to add a trunk group and configure the parameters described
in Table 157.

Name Description Value

Name Indicates the number assigned to the switch
port.

String.

Type A name of the port for easy identification. Trunk or LACP.

Untagged
VLANs

If the switch ports are untagged, select a VLAN
from the Untagged VLAN list.

Select from drop-down menu.

Tagged
VLANs

If the switch ports are tagged, select the VLANs
from the Tagged VLAN list.

Select from drop-down menu.

Ports Select the ports for trunking. You can use up to
eight ports for link aggregation. The ports in a
trunk group need not be consecutive.

Select from drop-down menu.

DHCP
Snooping

Select the status of port to filter DHCP
messages received at the port.

Trust or Untrust. Default is Untrust.

Table 157: Ports Page—AOS-S switches

4. Click OK.
5. Click Save Settings.

If your AOS-S switches are running 16.10.0013 or later firmware versions:

n You can remove the untagged VLAN from the trunk group at the group and device levels. At the group
level, if you remove untagged VLAN from the devices running the firmware prior to the 16.10.0013
version, an event will be logged in the Audit Trail page stating that the untagged VLAN deletion is not
supported.

n You must either configure tagged VLAN or untagged VLAN as a mandatory parameter for the trunk group.
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Editing Trunk Groups on AOS-S Switches
To edit details of a trunk group, point to the row for the trunk group, and click the edit icon and
configure the parameters.

Deleting Trunk Groups on AOS-S Switches
To delete a trunk group, point to the row for the trunk group, and click the delete icon.

Configuring VLANs on AOS-S Switches
Aruba switches support the following types of VLANs:

n Port-based VLANs—In the case of trusted interfaces, all untagged traffic is assigned a VLAN based on
the incoming port.

n Tag-based VLANs—In the case of trusted interfaces, all tagged traffic is assigned a VLAN based on the
incoming tag.

Adding VLAN Details
By default, all ports in the Switches are assigned to VLAN 1. However, if the ports are assigned to
different VLANs, the VLANs page displays their details.

To add a VLAN, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter, complete the following steps:

a. Set the filter to a group containing at least one switch.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-S or Config icon to view the switch configuration dashboard.

n To select a switch in the filter, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click a switch under Device Name.

The dashboard context for the switch is displayed.

d. Under Manage, click Device.

The tabs to configure the switch is displayed.

2. Click Interface > VLANs.

The VLANs page is displayed.

3. In the VLANs Settings accordion, click + to add a VLAN and configure the parameters described
in Table 158.

4. To configure the VLAN ports, complete the following steps:
a. In the Ports table, select the port number(s).
b. Select any of the following port modes:

n Tagged Ports
n Untagged Ports
n None
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5. To assign the VLAN to a trunk group, select the trunk group in the Trunk Groups table.
6. Click OK.
7. Click Save Settings.

The following table describes the VLAN parameters in the VLANs Settings accordion.

Name Description Value

Name The name of the VLAN. A string

IP Assignment The method of IP assignment.
The static option is displayed only at the device
level.
The options to assign Primary VLAN and
Management VLAN are displayed only when you
select Static or DHCP.

Static, DHCP, or Disabled
Default: DHCP

IP Address The IP address for static IP assignment.
This field is enabled only when you select Static
from the IP Assignment drop-down.

IPv4 address

Netmask The netmask for static IP assignment.
This field is enabled only when you select Static
from the IP Assignment drop-down.

IPv4 address

DHCP Server Indicates whether the switch is configured as the
DHCP server on the VLAN.
This field is enabled only when you select Static
from the IP Assignment drop-down.
You can enable DHCP Server option only when
there are no DHCP Helper IP addresses
configured.

Toggle switch to the on or off position

DHCP Helper IP IP address of the DHCP helper server for that
VLAN.
You can configure a maximum of 16 DHCP helper
IP addresses for each VLAN.
You can configure DHCP Helper IP addresses only
when DHCP Server option is disabled.

IPv4 address

Voice Indicates whether support for voice VLANs are
enabled for the VLAN interface.

Toggle switch to the on or off position

Primary VLAN Indicates whether the VLAN is assigned as the
primary VLAN for the switches. To assign primary
VLAN, at least one tagged or untagged port
should be configured. This is a mandatory field.

Toggle switch to the on or off position

Management
VLAN

Indicates whether the VLAN is assigned as the
management VLAN for the switches.

Toggle switch to the on or off position

Default
Gateway

Default gateway for static IP assignment. This
field is enabled only when you select Static from
the IP Assignment drop-down.

IPv4 address

Jumbo Indicates whether jumbo packet handling is
enabled for the VLAN interface.

Toggle switch to the on or off position

Table 158: Configuring and Viewing VLAN Parameters
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Name Description Value

Access Policy
(In)

The security policy that you want to apply for the
inbound traffic.

See Configuring Access Policies on
AOS-S Switches.

Access Policy
(Out)

The security policy that you want to apply for the
outbound traffic.

VLAN Access
Policy (In)

The security policy that you want to apply for the
bridged and routed inbound packets on the
VLAN.

VLAN Access
Policy (Out)

The security policy that you want to apply for the
bridged and routed outbound packets on the
VLAN.

When you upgrade to Aruba Central On-Premises version 2.5.2, the static IP address configured at group level
for VLANs is migrated to device level and preserved as overrides. The static IP assignment is available only at
the device level.

Editing the VLAN Details
To edit the details of a VLAN, point to the row for the VLAN, and click the edit icon in the Actions
column, and configure the parameters.

Deleting VLAN Details
To delete the VLAN details, complete the following steps:

1. Ensure that the VLANs are not tagged to any ports.
2. Point to the row for the VLAN, and click the edit icon in the Actions column.

VLAN 1 is the primary VLAN and cannot be deleted.

Configuring DHCP Relay Settings
You can configure a switch as a DHCP relay agent for transmitting DHCP messages between the
DHCP server and client. You can also configure the option-82 feature for the switch to include DHCP
relay information in the forwarded DHCP request messages.

To configure a switch as a DHCP relay agent, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter, complete the following steps:

a. Set the filter to a group containing at least one switch.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-S or Config icon to view the switch configuration dashboard.
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n To select a switch in the filter, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click a switch under Device Name.

The dashboard context for the switch is displayed.

d. Under Manage, click Device.

The tabs to configure the switch is displayed.

2. Click Interface > VLANs.

The VLANs page is displayed.

3. Expand the DHCP Relay Settings accordion.
4. To enable DHCP relay, move the DHCP Relay toggle switch to the on position.

DHCP Relay option is enabled by default.

5. To enable option-82 feature, move the DHCP Relay Option 82 toggle switch to the on position.
6. Click Save Settings.

Enabling Spanning Tree Protocol on AOS-S Switches in UI Groups
The Spanning Tree Protocol (STP) eliminates Layer 2 loops in networks, by selectively blocking some
ports and allowing other ports to forward traffic, based on global (bridge) and local (port) parameters
you can configure.

STP is always disabled by default on AOS-S switches. To configure STP for switches provisioned in the UI
groups, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter, complete the following steps:

a. Set the filter to a group containing at least one switch.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-S or Config icon to view the switch configuration dashboard.

n To select a switch in the filter, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click a switch under Device Name.

The dashboard context for the switch is displayed.

d. Under Manage, click Device.

The tabs to configure the switch is displayed.

2. Click Interface > Spanning Tree.

The Spanning Tree page is displayed.

3. Enable the MSTP toggle switch if you want to avoid bridge loops between network nodes and to
maintain a single active path between the network nodes.
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MSTP is enabled for all VLANs assigned to switch ports. If you have a trunk group configured for
the switches in the group, MSTP is enabled at the trunk level.

4. Set the priority of the UI group.
5. To configure MSTP parameters for ports, select the port row(s) in Port Settings, click Edit.
6. To configure MSTP parameters for trunks, select the trunk group row(s) in Trunk Group

Settings, click Edit.
7. Configure the MSTP parameters for ports or trunks of individual switches described in Table 159.
8. Click OK.
9. Click Save Settings.

Name Description Value

Priority A number used to identify the root bridge in an STP instance. The
switch with the lowest value has the highest priority and is the root
bridge. A higher numerical value means a lower priority; thus, the
highest priority is 0.

When the switches in a network select their root bridge, two
parameters are considered, the STP priority and the MAC address
of the switch. All AOS-S switches have a default STP priority of 8. So
the switch with the lowest MAC automatically gets selected as a
root bridge. This is not a recommended process as it randomizes
the selection of the root bridge.

0 – 8
Default: 8

BPDU
Protection

A security feature used to protect the active STP topology by
preventing spoofed BPDU packets from entering the STP domain.
In a typical implementation, BPDU protection is applied to the edge
ports and access ports connected to end-user devices that do not
run STP. If STP BPDU packets are received on a protected port, the
port is disabled and the network manager is alerted via SNMP
traps.

Enable or Disable
Default: Disable

BPDU Filter Enables control of STP participation for each port. The feature can
be used to exclude specific ports from becoming part of STP
operations. A port with the BPDU filter enabled ignores incoming
BPDU packets and stays locked in the STP forwarding state. All
other ports maintain their role.

Recommended ports for BPDU filter: Ports or trunks connected to
client devices.

Enable or Disable
Default: Disable

Admin-Edge When set, the port directly goes into forwarding state.
This configuration is not recommended for ports which connect to
infrastructure devices. A BPDU guard also assists when a port
inadvertently goes into a forwarding state.

Enable or Disable
Default: Disable

Root Guard Sets the port to ignore superior BPDUs to prevent the switch from
becoming the Root Port.

Enable or Disable
Default: Disable

Trunk Group Sets the trunk group to which the port is assigned. Enable or Disable
Default: Disable

The following table describes the port and trunk settings.
Table 159: Viewing or Configuring Port and Trunk Settings
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Configuring Loop Protection on AOS-S Switch Ports

Enabling Loop Protection consumes CPU resources.

Loop protection provides protection against loops by transmitting loop protocol packets out of ports.
For switches provisioned in UI groups, administrators can enable or disable loop protection on the
switch ports or trunks.

Loop protection is always disabled by default on AOS-S switches. For switch console access, non-
administrators can configure a timer to auto-recover ports if the switch detects any loop.

To configure loop protection for switches provisioned in the UI groups:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter, complete the following steps:

a. Set the filter to a group containing at least one switch.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the Config icon to view the switch configuration dashboard.

n To select a switch in the filter, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click a switch under Device Name.

The dashboard context for the switch is displayed.

d. Under Manage, click Device.

The tabs to configure the switch is displayed.

2. Click Interface > Loop Protection.

The Loop Protection page is displayed.

3. Depending on whether you want to configure a port or trunk, complete one of the following
steps:
n In the Port Settings tab, select the port(s), and click Edit to configure the following

parameters:

Name Description Value

Port The number assigned to the switch port. 0 – 65535

Loop
Protection

Enables or disables loop protection. Enable or Disable
Default: Disable

Trunk Group Name of the trunk group to which the port
belongs.

Dependent on the switch type.

Table 160: Viewing or Configuring Port Settings

n In the Trunk Group Settings tab, select the trunk(s), and click Edit to configure the following
parameters:



Configuring AOS-S Switches | 732

Name Description Value

Trunk Group Name of the trunk group to which the port
belongs.

Dependent on the switch type.

Loop
Protection

Enables or disables loop protection. Enable or Disable
Default: Disable

Table 161: Viewing or Configuring Trunk Group Settings

4. Click OK.
5. To auto-recover ports when the switch detects a loop, configure the following parameters:

n Disable Timer—Move the toggle switch to the on position to send an SNMP trap when a port
detects a disabled loop and manually re-enables the loop.

n Time (in secs)—Configure the time to auto-enable the Disable Timer. This field supports
integers between 1 to 604800.

6. Click Save Settings.

Configuring Access Policies on AOS-S Switches
To restrict certain types of traffic on physical ports of AOS-S switches, you can configure ACLs from the
Aruba Central On-Premises UI.

To create an access policy, complete the following steps:

1. In the Aruba Central On-Premisesapp, select one of the following options:
n To select a switch group in the filter, complete the following steps:

a. Set the filter to a group containing at least one switch.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-S or Config icon to view the switch configuration dashboard.

n To select a switch in the filter, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click a switch under Device Name.

The dashboard context for the switch is displayed.

d. Under Manage, click Device.

The tabs to configure the switch is displayed.

2. Click Security > Access Policy.

The Access Policy page is displayed.

3. Click + to add a new access policy.

The New Access Policy pop-up window is displayed.

4. Enter a name for the policy.
5. Click Add.
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6. To add a rule to the access policy, click + under Rules for test, and configure the parameters
described in Table 162.

7. Click OK.
8. Click Save Settings.

Name Description Value

Source Select a source of the traffic for which
you want to an access rule.

Any, Network, or Host
n For Network, specify IP address and mask
n For Host, specify IP address

Destination Select a destination. Any, Network, or Host
n For Network, specify IP address and mask
n For Host, specify IP address

Protocol Select the type of protocol from the
drop-down. If you select SCTP, TCP, or
UDP, the Source Port and Destination
Port fields are displayed.

SCTP, TCP, UDP, AH, ESP, GRE, ICMP, IGMP, IP,
IPv6_IN_IP, IP_IN_IP, OSPF, PIM, and VRRP.

Source Port Port number of the source for SCTP,
TCP, or UDP protocols.

Single or range of port numbers.
n For single port number, use the same port

number in the Min Port and Max Port
number fields.

Destination
Port

Port number of the destination for
SCTP, TCP, or UDP protocols.

Single or range of port numbers.
n For single port number, use the same port

number in the Min Port and Max Port
number fields.

Action The action that the switch must perform
on the traffic received at a port.

Permit or Deny

The following table describes the parameters for configuring rules for access policies.
Table 162: Configuring Rules for Access Policies

The access policies must be applied to a switch port and the VLAN assigned to a port. For more
information on access policy assignment to ports and VLANs, see the following topics:

n Configuring Switch Ports on AOS-S Switches
n Configuring VLANs on AOS-S Switches

Configuring DHCP Snooping on AOS-S Switches
DHCP snooping provides network security by filtering untrusted DHCP messages. Filtering is performed
by distinguishing trusted ports connected to a DHCP server or switch and untrusted ports connected to
end-users.

When you enable DHCP snooping, DHCP packets received at untrusted ports will be dropped, because
all ports are configured as untrusted by default. You must configure the ports to be trusted in the
Switches > Interface > Ports page.

You must also configure authorized DHCP servers for the network to have a functional DHCP server that
serves clients on this switch.
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By default, DHCP snooping is disabled for the switch.

Enabling DHCP Snooping on a Switch
To enable DHCP snooping on a switch, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter, complete the following steps:

a. Set the filter to a group containing at least one switch.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-S or Config icon to view the switch configuration dashboard.

n To select a switch in the filter, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click a switch under Device Name.

The dashboard context for the switch is displayed.

d. Under Manage, click Device.

The tabs to configure the switch is displayed.

2. Click Security > DHCP Snooping.

The DHCP Snooping page is displayed.

3. To enable DHCP snooping for the switch, move the DHCP Snooping toggle switch to the on
position.

4. To enable option-82 for the switch, move the DHCP Snooping Option-82 toggle switch to the on
position.

5. When you enable both DHCP snooping and option-82, the switch drops the option-82
information from the DHCP packets.

6. Click Save Settings.

Adding Authorized DHCP Servers for a Switch
To add the list of IP addresses of authorized DHCP servers for a switch, complete the following steps:

1. In the DHCP Snooping page, click + in the Authorized DHCP Servers IP table.

The Add Authorized DHCP Server IP pop-up window is displayed.

2. Enter the IP address in the Authorized DHCP Servers IP field.
3. Click OK.
4. Click Save Settings.
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Deleting Authorized DHCP Servers for a Switch
To delete the authorized DHCP servers IP addresses, in the Authorized DHCP Servers IP table, point to
IP address, and click the delete icon for the DHCP server IP you want to delete.

Enabling DHCP Snooping for a VLAN
To enable DHCP snooping for a VLAN, complete the following steps:

1. In the DHCP Snooping Settings table, select the VLAN row(s) for which you want to configure
DHCP snooping, and click Edit.

2. Select Enable or Disable from the DHCP Snooping drop-down list.
3. Click OK.
4. Click Save Settings.

Configuring Port Rate Limit on AOS-S Switches in UI Groups
Rate limiting allows allocating a specific bandwidth for the incoming and outgoing traffic from each port.
When traffic exceeds the configured limit, it is dropped. This effectively sets a usage level on a given port
and is a tool for enforcing maximum service level commitments granted to network users. This feature
operates on a per-port level and is not configurable on port trunks. Rate-limiting is designed to be
applied at the network edge to limit traffic from non-critical users or to enforce service agreements such
as those offered by Internet Service Providers (ISPs) to provide only the bandwidth for which a customer
has paid.

Port rate limit is always disabled by default on Aruba switches.

To configure port rate limit for switches provisioned in the UI groups, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter, complete the following steps:

a. Set the filter to a group containing at least one switch.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-S or Config icon to view the switch configuration dashboard.

n To select a switch in the filter, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click a switch under Device Name.

The dashboard context for the switch is displayed.

d. Under Manage, click Device.

The tabs to configure the switch is displayed.

2. Click Security > Port Rate Limit.
The Port Rate Limit page is displayed.

3. Under Port Rate Limit, select the port or ports you want to modify and click Edit.
The Edit Port Rate Limit pop-up window is displayed.

4. Set the value of Limit to Traffic by Category if you prefer to set individual limitations.

Else, set the value of Limit to All Traffic to set a collective limitation.
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Percentage limits are based on link speed. For example, if a 100 Mbps port negotiates a link at 100
Mbps and the inbound rate-limit is configured at 50%, then the traffic flow through that port is limited
to no more than 50 Mbps. Similarly, if the same port negotiates a 10 Mbps link, then it allows no more
than 5 Mbps of inbound traffic. Configuring a rate limit of 0 (zero) on a port blocks all traffic on that
port. However, if this is the desired behavior on the port, disable the port instead of configuring a rate
limit of 0.

a. If you select All Traffic, rate limit is placed on all packets received from unknown sources.
Move the slider to Enable and then enter the values for IN and OUT in percentage values.

b. If you select Traffic by Category, refer to Table 163 to set the correct parameters.

Name Description Value

Broadcast Sets a rate limit on broadcast traffic. Expressed as percentage of the
total bandwidth.

Multicast Indicates the operational status of the port.

Unknown
Unicast

Indicates the mode of operation. The port can be
configured to function in Trunk or Access mode.

ICMP Sets a rate limit on ICMP traffic.

Table 163: Traffic by Category Parameters

Configuring RADIUS Server Settings on AOS-S Switches
Aruba Central On-Premises allows you to configure RADIUS (Remote Authentication Dial-In User Service)
server settings on switches.

To configure a RADIUS server, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter, complete the following steps:

a. Set the filter to a group containing at least one switch.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-S or Config icon to view the switch configuration dashboard.

n To select a switch in the filter, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click a switch under Device Name.

The dashboard context for the switch is displayed.

d. Under Manage, click Device.

The tabs to configure the switch is displayed.

2. Click Security >Authentication Servers> RADIUS Settings. The RADIUS server settings
accordion is displayed.
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3. Click + to add a RADIUS server.

The Add RADIUS Server pop-up window is displayed.

4. Configure the following parameters.

Name Description Value

Dynamic
Authorization

Indicates whether the dynamic authorization is enabled.
When enabled, the RADIUS server can dynamically terminate or
change the authorization parameters used in an active client
session on the switch.

Toggle switch to
the on or off
position

ClearPass
Server

Indicates whether the ClearPass server is enabled on the
RADIUS server.

Toggle switch to
the on or off
position

Server IP The IP address of the RADIUS server.

Port The destination port for authentication requests to the
specified RADIUS server.

Default: 1812

Shared Key The encryption key for use during authentication sessions with
the specified RADIUS server.

You can enter up
to a maximum of
32 characters
including
alphabets,
numbers, and
special
characters.

Confirm Shared
Key

Retype the shared key.

Time Window Select Positive or Plus Minus from the drop-down menu. Default value is
Positive.

Window Size
(Seconds)

Enter the time in seconds. Default value is
300 seconds.

Table 164: RADIUS Parameters

5. Click Save.

Editing a RADIUS Server Settings
To edit a RADIUS server, point to the row and click the edit icon.

If you have only one RADIUS server with ClearPass enabled and Downloadable User Role is enabled, then you
cannot disable ClearPass server for the RADIUS server.

Deleting a RADIUS Server Settings
To delete a RADIUS server, point to the row and click the delete icon.

If the Downloadable User Role option is enabled, then at least one RADIUS server must be configured with
ClearPass server. Hence, you cannot delete the last RADIUS server on which ClearPass server is enabled.
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Configuring TACACS Server Settings on AOS-S Switches
Aruba Central On-Premises allows you to configure TACACS (Terminal Access Controller Access Control
System) server settings on switches.

To configure a TACACS server, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter:

a. Set the filter to a group containing at least one switch.
The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-S or configure icon to view the switch configuration dashboard.

n To select a switch in the filter:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.
c. Click a switch under Device Name.

The dashboard context for the switch is displayed.
d. Under Manage, click Device.

The tabs to configure the switch are displayed.

2. Click Security >Authentication Servers> TACACS Settings. The TACACS server settings
accordion is displayed.

3. Click + to add a TACACS server. The Add TACACS Server window is displayed.
4. Configure the following parameters.

Name Description Value

Server IP The IP address of the TACACS server.

Key The encryption key for use during authentication sessions with the
specified TACACS server.

You can enter up
to a maximum of
32 characters
including
alphabets,
numbers, and
special
characters.

Confirm
Shared
Key

Retype the shared key.

Table 165: TACACS Parameters

5. Click Save.

A maximum of three TACACS servers can be added.

Editing a TACACS Server Settings
To edit a TACACS server, point to the server and click the edit icon.
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The server IP cannot be edited once created, only the key can be edited.

Deleting a TACACS Server Settings
To delete a TACACS server, point to the server and click the delete icon.

Configuring Downloadable User Role on AOS-S Switches
Aruba Central On-Premises allows you to enable Downloadable User Role and configure ClearPass
settings to download user-roles, policy, and class from the ClearPass Policy Manager server.

To enable Downloadable User Role and configure ClearPass server settings, complete the following
steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter, complete the following steps:

a. Set the filter to a group containing at least one switch.
The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-S or Config icon to view the switch configuration dashboard.

n To select a switch in the filter, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.
c. Click a switch under Device Name.

The dashboard context for the switch is displayed.
d. Under Manage, click Device.

The tabs to configure the switch is displayed.

2. Click Security > Downloadable User Role.

The Downloadable User Role page is displayed.

3. Slide the Downloadable User Role toggle switch to on position to allow switch to download user-
roles.

To enable downloadable user role, ClearPass server must be configured in the RADIUS page. The
Downloadable User Role toggle is disabled if ClearPass server is not enabled for any of the RADIUS
settings. For more information, see Configuring RADIUS Server Settings on AOS-S Switches.

4. Configure the following ClearPass parameters:
n User Name—Enter the ClearPass Policy Manager administrator username.
n Password—Enter the password to access ClearPass server.
n Confirm Password—Retype the password.
n Retry Interval—Specify the retry interval to download TA certificate.

This certificate is used to authenticate ClearPass server before downloading the user-role. The
valid range is 0 to 5.

5. Click Save Settings.
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Configuring Authentication for AOS-S Switches
Aruba Central On-Premises supports enabling 802.1X and MAC authentication for switches. You can
enable and configure 802.1X authentication of clients at the switch and port level, and enable
authentication of 802.1X access through a RADIUS server using either EAP or CHAP protocol. You can
also enable and configure ports to authenticate clients based on MAC addresses.

See the following topics for more information on authentication:

n Configuring 802.1X Authentication
n Configuring MAC Authentication
n Configuring Authentication Order and Priority

Configuring 802.1X Authentication
802.1X is a method for authenticating the identity of a user before providing network access. Aruba
Central On-Premises supports internal RADIUS server and external RADIUS server for 802.1X
authentication.

To configure 802.1X authentication for the switch, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter, complete the following steps:

a. Set the filter to a group containing at least one switch.
The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-S or Config icon to view the switch configuration dashboard.

n To select a switch in the filter, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.
c. Click a switch under Device Name.

The dashboard context for the switch is displayed.
d. Under Manage, click Device.

The tabs to configure the switch is displayed.

2. Click Security > Authentication.

The Authentication page is displayed.

3. Expand the 802.1X Authentication accordion.
4. To enable 802.1x authentication at group level in the group context, slide the 802.1X toggle

switch to on position.
5. Select either EAP or CHAP from the Authentication Method drop-down list.

If you select EAP or CHAP, you must configure the RADIUS server.

The Port Settings table displays the number of ports and the parameters configured for the
ports.

6. Select one or more ports for which you want to enable 802.1X authentication, and click the edit
icon.
The Edit Ports Selected pop-up window is displayed.
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7. Select Enable from the 802.1X drop-down list.
8. Configure the parameters described in Table 166.
9. Click Save Settings.

Name Description Value

Client Limit The maximum number of clients to allow on the port. Default: 0

UnAuthorized
VLAN ID

The VLAN to use for an unauthorized client. Default:0

Authorized
VLAN ID

The VLAN to use for an authorized client. Default: 0

Reauth Period The time (in seconds) that the switch enforces on a client to re-
authenticate. The client remains authenticated while the re-
authentication occurs. When set to 0, re-authentication is disabled.

Default: 300
seconds

Cached Reauth
Period

The time (in seconds) when cached re-authentication is allowed on
the port.

Default: 0

Log off Period The time (in seconds) that the switch enforces for an implicit logoff. Default: 300
seconds

Quiet Period The time (in seconds) during which the port does not try to acquire a
supplicant. The period begins after the last attempt authorized by
the max-requests parameter fails.

Default: 60 seconds

Tx Period The time (in seconds) the port waits to retransmit the next EAPOL
PDU during an authentication session.

Default: 30 seconds

Server Timeout The time (in seconds) that the switch waits for a server response to
an authentication request

Default: 300
seconds

Supplicant
Timeout

The time (in seconds) that the switch waits for a supplicant response
to an EAP request. If the supplicant does not respond within the
configured time frame, the session times out.

Default: 300
seconds

The following table describes the 802.1x authentication parameters.
Table 166: Configuring 802.1X Authentication

Configuring MAC Authentication
MAC authentication is used for authenticating devices based on their physical MAC addresses. For MAC
authentication, the MAC address of a machine must match an approved list of manually defined
addresses on the switch.

MAC authentication can be used alone or it can be combined with 802.1X authentication.

To configure MAC authentication for the switch ports, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter, complete the following steps:

a. Set the filter to a group containing at least one switch.
The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-S or Config icon to view the switch configuration dashboard.
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n To select a switch in the filter, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.
c. Click a switch under Device Name.

The dashboard context for the switch is displayed.
d. Under Manage, click Device.

The tabs to configure the switch is displayed.

2. Click Security > Authentication.
3. In the Authentication tab, expand the MAC Authentication accordion.

The Port Settings table displays the parameters configured for the port.

4. Select one or more ports for which you want to enable MAC authentication and click the edit icon.

The Edit Ports Selected pop-up window is displayed.
5. Select Enable from the MAC Auth drop-down list.
6. Configure the following parameters described in Table 167.
7. Click Save Settings.

Name Description Value

Client Limit The maximum number of clients to allow on the port. Default: 0

UnAuthorized
VLAN ID

The VLAN to use for an unauthorized client. Default: 0

Authorized
VLAN ID

The VLAN to use for an authorized client. Default: 0

Reauth Period The time (in seconds) that the switch enforces on a client to re-
authenticate. The client remains authenticated while the re-
authentication occurs. When set to 0, re-authentication is disabled.

Default: 300
seconds

Cached Reauth
Period

The time (in seconds) when cached re-authentication is allowed on
the port.

Default: 0

Log off Period The time (in seconds) that the switch enforces for an implicit logoff. Default: 300
seconds

Quiet Period The time (in seconds) during which the port does not try to acquire a
supplicant. The period begins after the last attempt authorized by
the max-requests parameter fails.

Default: 60 seconds

The following table describes the MAC authentication parameters.
Table 167: Configuring MAC Authentication

Configuring Authentication Order and Priority
Users can set the authentication order and priority for the 802.1X and MAC authentication methods for
each port. The switch attempts to authenticate a client based on the authentication order and priority
settings.
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n If both 802.1X and MAC authentication are enabled on the same port without configuring
authentication order and priority , then both the authentication methods are triggered in parallel and
might cause issues for the clients.

n If authentication order and priority are configured, then authentication requests are processed
sequentially and authentication method with high priority is used to access the client. If both 802.1X
and MAC authentication are enabled on the same port, and 802.1X authentication is set as the first
authentication method and MAC authentication is set as the first authentication priority , then MAC
authentication is used to authenticate the clients.

n If only one authentication method is enabled on the port, then the switch will not consider
authentication order and priority for authentication.

To configure the authentication order and priority, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter, complete the following steps:

a. Set the filter to a group containing at least one switch.
The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-S or Config icon to view the switch configuration dashboard.

n To select a switch in the filter, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.
c. Click a switch under Device Name.

The dashboard context for the switch is displayed.
d. Under Manage, click Device.

The tabs to configure the switch is displayed.

2. Click Security > Authentication.

The Authentication page is displayed.

3. Expand the Authentication Order and Priority accordion.

The Ports Settings table displays the Authentication Order and Authentication Priority
columns for the specified ports.

4. Click + to add ports with authentication order and priority.

The Add Ports pop-up window is displayed.

5. Configure the following parameters:
n Ports—Select one or more ports for setting authentication order and priority.
n Authentication Order—Select either 802.1X or MAC as the first method for authentication.

For example, if you select 802.1X as the first authentication method, then 802.1X is used first
for authenticating clients on the port.

n Authentication Priority—Select either 802.1X or MAC as the first priority for authentication.
Authentication priority takes precedence over authentication order, and the authentication
method with higher priority is used to access clients.

6. Click Save.
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Editing the Authentication Order and Priority
To edit the authentication order and priority, select one or more ports for which you want to modify
authentication order and priority, and click the edit icon.

When editing multiple ports, if authentication order and priority are different on ports, then the existing
settings are preserved. You can override the existing settings by selecting an order or a priority.

Deleting the Authentication Order and Priority
To delete the authentication order and priority, select one or more ports for which you want to delete
authentication order and priority, and click the delete icon.

Configuring Tunnel Node Server on AOS-S Switches
Aruba Central On-Premises allows you to configure tunneled node on switches. The tunneled node
connects to one or more client devices at the edge of the network and then establishes a secure Generic
Routing Encapsulation (GRE) tunnel to the controlling concentrator server. You can configure either
Port-Based Tunnel or User-Based Tunnel using UI groups.

To modify the reserved VLAN, change the mode to No Tunnel and click Save Settings, and then change the
mode back to User-Based Tunnel.

The Tunnel Node Server configuration cannot be modified when tunneled clients are active.

To configure a tunneled node on the switch, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter, complete the following steps:

a. Set the filter to a group containing at least one switch.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-S or Config icon to view the switch configuration dashboard.

n To select a switch in the filter, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click a switch under Device Name.

The dashboard context for the switch is displayed.

d. Under Manage, click Device.

The tabs to configure the switch is displayed.

2. Click Security > Tunnel Node Server.
The Tunnel Node Server page is displayed.

3. Configure the parameters described in Table 168.
4. Click Save Settings.

The following table describes the tunnel node server parameters.
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Name Description Value

Mode The mode of tunneling from the drop-down:
n No Tunnel—switch does not tunnel traffic.
n Port Based Tunnel—Allows the switch to tunnel traffic to an

Aruba controller on a per-port basis.
n User-Based Tunnel—Allows the switch to tunnel traffic to an

Aruba controller on an assigned user role basis.

Port- Based
Tunnel , User-
Based Tunnel, or
No Tunnel

Primary Gateway
IP

The IP address of the primary gateway. A valid IPv4 address

Backup Gateway
IP

The IP address of the backup gateway. This field is optional. A valid IPv4 address

Reserved VLAN The reserved VLAN ID to tunnel traffic to an Aruba controller. This
field is available only for User-Based tunnel.
The default VLAN or a VLAN that is already configured cannot be
used as a reserved VLAN. To view the list of configured VLANs,
navigate to Interface > VLANs.

Numeric value

Table 168: Configuring Tunnel Node Server

For more detailed information, refer to Dynamic Segmentation white paper at
https://www.arubanetworks.com/assets/so/SO_Dynamic-Segmentation.pdf

Configuring System Parameters for AOS-S Switches
System access and DNS parameters allow you to configure administrator and operator credentials, and
DNS servers.

To configure administrator credentials for AOS-S switches, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter, complete the following steps:

a. Set the filter to a group containing at least one switch.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click on the AOS-S or Config icon to view the switch configuration dashboard.

n To select a switch in the filter, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click a switch under Device Name.

The dashboard context for the switch is displayed.

d. Under Manage, click Device.

The tabs to configure the switch is displayed.

2. Click System > General > Administration.

The Administration accordion is displayed.

3. Enter the username for the administrator user in the Admin Username text box.

https://www.arubanetworks.com/assets/so/SO_Dynamic-Segmentation.pdf
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4. Enter the password for admin in the Admin Password text box and confirm the administrator
password. A maximum of 64 characters are allowed.

5. To configure the operator user credentials, complete the following steps:
a. Move the Set Operator Username toggle switch to the on position.
b. Enter a username and password for the operator user.
c. Confirm the password.

6. Click Save Settings.

Configuring a DNS Server
To configure a name server, complete the following steps:

Configuring the Admin Username and Admin Password is optional when configuring a DNS.

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter, complete the following steps:

a. Set the filter to a group containing at least one switch.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-S or Config icon to view the switch configuration dashboard.

n To select a switch in the filter, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click a switch under Device Name.

The dashboard context for the switch is displayed.

d. Under Manage, click Device.

The tabs to configure the switch is displayed.

2. Click System > Access/DNS.

The Access/DNS page is displayed.

3. Select DHCP or Static from the Name Server drop-down list.

 The default option is DHCP.

n You must add at least one DNS server IP address, when you select Static in the drop-down list.
n You can add only a valid IPv4 address.
n You can add a maximum of two DNS server IP addresses.
n The first static IP address that you add is considered as priority. The second IP address that you

add is considered secondary.

4. Under Name Server field, complete the following steps:
a. Enter the static IPv4 address of the DNS server in the text box.
b. Click the + add icon.
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c. To delete a static IP address, click the delete icon.
If two IP addresses are configured, you can first delete the second priority IP address.

5. Click Save Settings.

Adding Message of the Day
When the user connects to a switch, the login banner appears before the login prompt.

To add a Message of the Day (MOTD) in the Login Banner, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter:

a. Set the filter to a group containing at least one switch.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the Config icon to view the switch configuration dashboard.

n To select a switch in the filter:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click a switch under Device Name.

The dashboard context for the switch is displayed.

d. Under Manage, click Device.

The tabs to configure the switch is displayed.

2. Click System > General > Login Banner.
The MOTD text-box is displayed.

3. Type the message in the text-box.

A maximum of 4132 characters can be entered in the MOTD text-box.

4. Click Save Settings.

Configuring Time Synchronization on AOS-S Switches
Time synchronization in a switch ensures maintaining a uniform time among all interoperating devices.
Aruba Central On-Premises offers the Simple Network Time Protocol (SNTP) time synchronization
protocol for switches. In SNTP, Aruba Central On-Premises supports broadcast, unicast, and DHCP
modes.

Time synchronization in a switch ensures maintaining a uniform time among all interoperating devices.
Aruba Central On-Premises offers the following time synchronization protocols for switches:

n Network Time Protocol (NTP)
n Simple Network Time Protocol (SNTP)

To configure time synchronization in a switch, complete the following steps:
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1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter, complete the following steps:

a. Set the filter to a group containing at least one switch.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-S or Config icon to view the switch configuration dashboard.

n To select a switch in the filter, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click a switch under Device Name.

The dashboard context for the switch is displayed.

d. Under Manage, click Device.

The tabs to configure the switch is displayed.

2. Click System > Time.

The Time page is displayed.

3. Configure the parameters described in Table 169.
4. Click Save Settings.

Name Description Value

Time Sync
Method

The synchronization method or protocol to use for
synchronizing the time on the switch.

SNTP
Default: NTP

Mode The operating mode for connecting to a time server. The
following modes are supported:
n Broadcast—The switch acquires time updates from the

data that any time server broadcasts to the network. The
switch uses the time data from the first server detected
and ignores others. If the poll interval expires thrice
without the switch acquiring a time update from the first
server detected, the switch accepts a time update from the
next server broadcast.

NOTE: To use the Broadcast mode, the switch and the
time server must be in the same subnet. Also, the time
server must be configured to broadcast time updates to
the network broadcast address.

n Unicast—The switch acquires time updates from a
specific server for time synchronization. This mode
requires at least one server address to be configured in
the Server Address field.

n DHCP—The switch attempts to acquire a time server IP
address from the DHCP server. If the switch receives a
server address, it polls the server for time updates

SNTP
Supported modes: Broadcast,
Unicast, DHCP, and Disabled
Default mode: DHCP

NTP
Supported modes: Broadcast,
Unicast
Default mode: Broadcast

Default: DHCP

Table 169: Configuring Time Synchronization Parameters
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Name Description Value

according to the poll interval. If the switch does not receive
a time server IP address, it cannot perform time
synchronization updates. This mode is applicable only for
SNTP.

n Disabled—Time synchronization is disabled. You cannot
disable synchronization if NTP is selected.

Server
Address

IP address of the time server that the switch accesses for
obtaining time synchronization updates. This field is
applicable only when you select the Unicast mode for
synchronization.
You can configure a maximum of three time server
IP addresses. When you add more than one IP address, the
priority that the switch considers in selecting the IP address is
the order in which you add the IP address. Therefore, the first
IP address that you add will be priority 1, second IP address
will be priority 2, and so on.
You can delete the IP addresses by clicking the delete icon
corresponding to the address. When more than one IP
addresses are added, you must first delete the IP address you
added last.

IPv4 address

Timezone The time zone corresponding to the location of the switch. Time zone selected from the
drop-down.

Daylight
Time Rule

The rule that the switch uses to adjust the time for Daylight
Saving Time (DST).
For information about the predefined and user-defined times,
see Predefined DST Rules.
When you select the User-defined option, you must configure
the beginning and ending months and dates for DST changes
in the Begin Month and Day and End Month and Day fields.
All DST rules begin and end at 2 a.m. on the configured dates.

Alaska, Canada and
Continental US, Middle
Europe and Portugal,
Southern Hemisphere,
Western Europe, and User-
defined.

Begin
Month and
Day

The beginning month and date for the user-defined
DST changes. This field appears only when you select User-
defined in the Daylight Time Rule field.

Month and date selected from
the drop-down.

End Month
and Day

The ending month and date for the user-defined DST changes.
This field appears only when you select User-defined in the
Daylight Time Rule field.

Month and date selected from
the drop-down.

Predefined DST Rules
The following table describes the details of the beginning and ending days for the predefined DST rules.

Predefined DST Rule Name Description

Alaska n Begin DST at 2 a.m. on March 8.
n End DST at 2 a.m. on November 1.

Canada and Continental US

Middle Europe and Portugal n Begin DST at 2 a.m. on March 25.
n End DST at 2 a.m. on September 24.

Table 170: Predefined DST Rules
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Predefined DST Rule Name Description

Southern Hemisphere n Begin DST at 2 a.m. on October 25.
n End DST at 2 a.m. on March 1.

Western Europe n Begin DST at 2 a.m. on March 25.
n End DST at 2 a.m. on October 25.

Configuring SNMP on AOS-S Switches
Simple Network Management Protocol (SNMP) is an Internet-standard protocol used for managing and
monitoring the devices connected to a network by collecting, organizing and modifying information
about managed devices on IP networks.

In Aruba Central On-Premises, you can configure either SNMP versions V2C or V3 using UI groups. By
default, SNMP is disabled on AOS-S switches.

SNMP settings can be configured only when a switch is installed with the firmware version of 16.09 or later.

For more information, see the following topics:

n Configuring SNMPv2c on AOS-S Switches
n Configuring SNMPv3 on AOS-S Switches
n Disabling SNMP on AOS-S Switches

Configuring SNMPv2c on AOS-S Switches
You can configure SNMPv2c community settings and trap settings through the UI.

To enable SNMPv2c on a switch, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter, complete the following steps:

a. Set the filter to a group containing at least one switch.
The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-S or Config icon to view the switch configuration dashboard.

n To select a switch in the filter, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.
c. Click a switch under Device Name.

The dashboard context for the switch is displayed.
a. Under Manage, click Device.

The tabs to configure the switch is displayed.

2. Click System > SNMP.

The SNMP page is displayed.

3. Select V2C from the SNMP mode drop-down list to enable SNMPv2C.

Changing SNMP mode from V3 to V2C displays a confirmation message window stating that
changing SNMP mode will remove existing SNMP configuration.
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4. Type REMOVE in the text box and click Proceed.
5. Click Save Settings.

Configuring Community Settings
You can add or delete SNMP communities to restrict access to the switch.

Adding a Read Community

To add an SNMP community, complete the following steps:

1. In the SNMP page, expand the Community/Trap Settings accordion.
The Read Community table displays the list of communities that have read-only access.

2. To add a read community, click +.

The Add Community pop-up window is displayed.

3. Enter the name of the community in the Community text box, and click OK.

Deleting a Read Community

To delete a read community, point to the row for the trap destination, and click the delete icon.

Configuring Trap Settings
You can configure authentication, trap destination, and trap categories using trap settings.

Adding a Trap Destination

To add a trap destination, complete the following steps:

1. In the SNMP page, expand the Trap Category Settings accordion.
2. To add a read destination, click +.

The Add Trap Destination pop-up window is displayed.

3. Configure the following parameters:
n Destination IP—Enter the destination IP address for sending the trap.
n Community—Enter the community name used for sending the trap.

4. Click OK.

Deleting a Trap Destination

To delete a trap destination, point to the row for the trap destination, and click the delete icon.

Enabling Trap Categories
To enable trap categories, complete the following steps:

1. In the Trap Settings accordion, select the authentication type used to connect to the SNMP
server from the Authentication drop-down list.

2. In the Trap Category table, select the checkbox for the trap category that you want to enable.
3. Click Save Settings.

The availability of trap categories differs based on the device model.
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Configuring SNMPv3 on AOS-S Switches
SNMPv3 provides a secured access to SNMP management stations using authentication and privacy
protocols. You can add SNMPv3 user and configure notification settings using UI groups.

To enable SNMPv3 on a switch, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter, complete the following steps:

a. Set the filter to a group containing at least one switch.
The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-S or Config icon to view the switch configuration dashboard.

n To select a switch in the filter, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.
c. Click a switch under Device Name.

The dashboard context for the switch is displayed.
a. Under Manage, click Device.

The tabs to configure the switch is displayed.

2. Click System > SNMP.

The SNMP page is displayed.

3. Select V3 from the SNMP mode drop-down list to enable SNMPv3.

Changing SNMP mode from V2C to V3 displays a confirmation message window stating that
changing SNMP mode will remove existing SNMP configuration.

4. Type REMOVE in the text box, and click Proceed.

You must add at least one user to enable SNMPv3.

5. Click Save Settings.

Configuring User Settings
You can add SNMPv3 users to provide secured access to SNMP management stations.

Adding an SNMPv3 User

To add an SNMPv3 user, complete the following steps:

1. In the SNMP page, expand the User/Notification Settings accordion.
The Users table displays the list of users with associated authentication mode and privacy mode.

2. To add an SNMPv3 user, click +.

The Add User pop-up window is displayed.

3. Configure the following parameters:
n User Name—Enter the user name.
n Authentication Mode—Select either MD5 (Message Digest) or SHA (Secure Hash Algorithm)

as the authentication mode to provide secured access to the user.
n Password—Enter the authentication password.
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n Confirm Password—Re-enter the authentication password.
n Privacy Mode—Select AES (Advanced Encryption Standard) or DES (Data Encryption Standard)

as the privacy mode to provide secured access to the user.
n Privacy Password—Enter the privacy password.
n Confirm Privacy Password—Re-enter the privacy password.

4. Click OK.

Editing an SNMPv3 User

To edit an SNMPv3 user, point to the row for the user, and click the edit icon.

Deleting an SNMPv3 User

To delete an SNMPv3 user, point to the row for the user, and click the delete icon.

Configuring Notification Settings
You can configure notification settings to send notifications to SNMPv3 users.

Adding an SNMPv3 Notification

To add a notification, complete the following steps:

1. In the SNMP page, expand the User/Notification Settings accordion.
The Notifications table displays the list of users with associated IP addresses for sending
notifications.

2. To add a notification, click +.

The Add Notification pop-up window is displayed.

3. Configure the following parameters:
n IP address—Enter the destination IP address for sending notifications.
n User Name—Select the user to whom the notifications should be sent.

4. Click OK.

Editing an SNMPv3 Notification

To edit a notification, point to the row for the notification, and click the edit icon.

You can edit only the user name.

Deleting an SNMPv3 Notification

To delete an SNMPv3 user, point to the row for the notification, and click the delete icon.

Enabling Trap Categories
To enable trap categories, complete the following steps:

1. In the Trap Category Setting accordion, select the authentication type used to connect to the
SNMP server from the Authentication drop-down list.

2. In the Trap Category table, select the checkbox for the trap category you want to enable.



Configuring AOS-S Switches | 754

3. Click Save Settings.

The availability of trap categories differs based on the device model.

Disabling SNMP on AOS-S Switches
You can disable SNMP on AOS-S switches. Disabling SNMP will remove all the existing SNMP
configurations.

To disable SNMP, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter, complete the following steps:

a. Set the filter to a group containing at least one switch.
The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-S or Config icon to view the switch configuration dashboard.

n To select a switch in the filter, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.
c. Click a switch under Device Name.

The dashboard context for the switch is displayed.
a. Under Manage, click Device.

The tabs to configure the switch is displayed.

2. Click System > SNMP.

The SNMP page is displayed.

3. Select Disable from the SNMP mode drop-down list to disable SNMP.

Changing SNMP mode from V2C or V3 to Disable displays a confirmation message window
stating that changing SNMP mode will remove existing SNMP configuration.

4. Type REMOVE in the text box and click Proceed.
5. Click Save Settings.

Configuring CDP on AOS-S Switches
Cisco Discovery Protocol (CDP) is used to share information about connected network devices. It is used
to share information such as device type, model, interfaces, IP addresses, operating system versions,
and VLANs. You can configure CDP modes for the switch.

To enable CDP for the switch, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter, complete the following steps:

a. Set the filter to a group containing at least one switch.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-S or Config icon to view the switch configuration dashboard.
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n To select a switch in the filter, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click a switch under Device Name.

The dashboard context for the switch is displayed.

d. Under Manage, click Device.

The tabs to configure the switch is displayed.

2. Click System > CDP.

The CDP page is displayed.

3. To enable CDP for the switch, move the CDP toggle switch to the on position.
4. Select one of the following modes from the Mode drop-down list:

n rx-only—Switch only receives CDP information from other connected devices and stores this
information in the database. However, it does not send its own information to other devices.

n pass-through—CDP information passes through the switch to other connected devices.
n pre-standard-voice—Enables CDP-compatible voice VLAN discovery with pre-standard VoIP

phones.

5. Click Save Settings.

Configuring DHCP on AOS-S Switches
Dynamic Host Configuration Protocol (DHCP) is a protocol that enables a server to automatically assign
IP addresses to hosts. The server uses the configured IP address pools or ranges to assign to hosts. You
can configure multiple IP pools to not have duplicate or overlapping IP subnets. You can configure the
IP address pools with various options to share with the hosts. For example, network address, subnet
mask, DNS server address.

In Aruba Central On-Premises 2.5.3, DHCP Pools configuration is renamed to DHCP and moved from the IP
Settings tab to the System tab.

To enable the DHCP service and to add DHCP pools on a switch, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter, complete the following steps:

a. Set the filter to a group containing at least one switch.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the Config icon to view the switch configuration dashboard.

n To select a switch in the filter, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click a switch under Device Name.

The dashboard context for the switch is displayed.
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d. Under Manage, click Device.

The tabs to configure the switch is displayed.

2. Click System > DHCP.

The DHCP page is displayed.

If any of the devices is running a lower version, a warning message is displayed, and the DHCP
configuration changes are pushed only to the devices that support the DHCP. If the devices are
upgraded to a supported version or moved out of the group, the warning message will not be
displayed.

3. To activate the DHCP service, move the Enable DHCP service toggle switch to the on position.

The DHCP service can be enabled only if there is a valid DHCP pool.

4. To add a new DHCP pool, click +.

The Add New DHCP Pool pop-up window is displayed.

Configure the parameters described in Table 171.

5. Click OK.
6. Click Save Settings.
7. To edit the details of a DHCP pool, point to the row for the DHCP pool, and click the edit icon in

the Edit column, and configure the parameters.
8. To delete a DHCP pool, point to the row for the DHCP pool, and click the delete icon in the Delete

column. Click Yes in the confirmation window.

Name Description Value

Name Name of the pool. A string.

Network A valid network IP address to assigned to the
DHCP pool.

IPv4 address

Netmask Netmask of the DHCP pool. Subnet mask

Lease Time The lease time for the DHCP pool in days-hours-
minutes format.

You can set a maximum value of 365 days
23 hours and 59 minutes in the DD-HH-
MM format.

Default
Router

IP address of the default router in the subnet. You can add up to 8 IP addresses.

DNS Server Address of the DNS server. To add multiple DNS
servers, click +.

You can add up to 8 DNS servers.

Netbios
Server

Address of the Netbios server. To add multiple
Netbios servers, click +.

You can add up to 8 Netbios servers.

The following table describes the DHCP Pool parameters.
Table 171: Configuring a DHCP Pool
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Name Description Value

IP Address
Range

IP address range within the network and
network mask combination. To add multiple IP
address range, click +.

You can add up to 64 IP address range.

Option The code type, and ASCII or HEX value of the
DHCP option to configure. To add multiple
options, click +.

You can add up to 8 options.
A value within the range of 2-254 with type
as hexadecimal and ASCII is valid.

Configuring IP Client Tracker on AOS-S Switches
The IP Client tracker module identifies both trusted and untrusted clients that access the system. This
feature is available for AOS-S 2930F, 2930M, and 3810 switches.

This feature is supported on AOS-S 16.10.0008 and later versions.

To configure IP client tracker, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter, complete the following steps:

a. Set the filter to a group containing at least one switch.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-S or Config icon to view the switch configuration dashboard.

n To select a switch in the filter, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click a switch under Device Name.

The dashboard context for the switch is displayed.

d. Under Manage, click Device.

The tabs to configure the switch is displayed.

2. Click System > IP Client Tracker.
The IP Client Tracker page is displayed.

3. To enable the client tracker, move the IP Client Tracker toggle to on position.

The IP Client Tracker is disabled by default.

4. Select one of the following options under Enable IP Client Tracker for field:
n All clients
n Trusted clients only
n Untrusted clients only

5. Move the Probe Delay toggle to on position.
6. Enter a value in the Enter probe delay text box.

The default value is 15. You can set a value in the range of 15 to 300 seconds.
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7. Click Save Settings.

Configuring IGMP on AOS-S Switches
In a network where IP multicast traffic is transmitted for various multimedia applications, Internet
Group Management Protocol (IGMP) helps reduce bandwidth usage on a per-port basis on a switch.
Enabling IGMP for a VLAN allows the ports to detect IGMP queries and report packets, and manage IP
multicast traffic through the switch.

By default, IGMP is disabled for all VLANs.

To enable IGMP for a VLAN, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter, complete the following steps:

a. Set the filter to a group containing at least one switch.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-S or Config icon to view the switch configuration dashboard.

n To select a switch in the filter, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click a switch under Device Name.

The dashboard context for the switch is displayed.

d. Under Manage, click Device.

The tabs to configure the switch is displayed.

2. Click IGMP.

The IGMP page is displayed with the list of existing VLANs.

3. Select the VLAN row(s) for which you want to configure IGMP, and click Edit.
The Edit IGMP pop-up window is displayed.

4. Select Enable or Disable from the IGMP drop-down list.
5. Click OK.
6. To configure the switch to filter unknown multicast messages, move the Filter Unknown

Multicast toggle switch to the on position.
7. Click Save Settings.

Configuring Routing on AOS-S Switches

In Aruba Central On-Premises 2.5.3, Routing configuration is moved from the IP Settings tab to the Routing
tab.

Static routes provide a means for restricting and troubleshooting routed traffic flows and in small
networks can provide the simplest and most reliable configuration for routing. Static routes are
manually configured in the routing table.

To enable routing and to add routes on a switch, complete the following steps:
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1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter, complete the following steps:

a. Set the filter to a group containing at least one switch.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-S or Config icon to view the switch configuration dashboard.

n To select a switch in the filter, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click a switch under Device Name.

The dashboard context for the switch is displayed.

d. Under Manage, click Device.

The tabs to configure the switch is displayed.

2. Click Routing.

The Routing page is displayed.

3. To enable routing, move the Routing toggle switch to the on position.

Before enabling routing, ensure that you have already configured a path to the gateway.

4. In the Routes table, click + to add a VLAN.

The Add Routing pop-up window is displayed.

5. Configure the parameters described in Table 172.
6. Click Save.

7. To delete a route, hover over the row for the route in the Routes table and click the delete icon in
the Distance column. Click Yes in the confirmation window.

Name Description Value

Network A valid network IP address for the destination
network or host.

IPv4 address.

Netmask Netmask of the IP address. Netmask address.

Gateway Default gateway IP address. IPv4 address.

Metric A parameter used by the routers to determine the
best optimal path for routing traffic.

This is a fixed metric for static IP routes,
and is set to “1”.

Distance The administrative distance helps routers
determine the best route when there are multiple
routes to the destination. A lower value is
recommended.

The default administrative distance for
static IP routes is 1, but can be
configured to any value in the range of 1
- 255.

The following table describes the routing path parameters.
Table 172: Routing Path Parameters

If the routing metric and administrative distance are set to a lower value for static routes, switches use
the static IP routes as the best route for routing traffic.
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Configuring QoS Settings on AOS-S Switches
QoS is used to classify and prioritize traffic throughout a network. QoS enables you to establish an end-
to end traffic-priority policy to improve the control and throughput of important data. You can manage
available bandwidth so that the most important traffic goes first.

Aruba Central On-Premises allows you to configure QoS settings on individual or group of switches
through the UI. The settings that you apply at the group level are applied to all switches in the group,
except in the following conditions:

n A switch has a configuration override—That is, a QoS setting is changed at the device level. Once you
update or apply a setting at the device level, any further changes that you make at the group level
are not applied to the switch. A notification for the configuration override is added to the Audit Trail.
If you remove local overrides on a switch, then all QoS configurations that were applied to the switch
are removed, and the configurations available at the group level are applied to the switch.

For example, when a switch does not have any policies, if you add a policy for port 2 and 3 at the
group level, then the policy is applied to the switch. If you add a policy for port 4 at the device level,
and then add a policy for port 5 at the group level, then the policy for port 5 is not applied to the
switch. You must add the same policy again at the device level to apply the policy. If you remove the
local overrides on the switch, then any policies that were updated or added to the switch and the
associated QoS class are replaced by the policies at the group level.

n A switch has invalid port number or VLAN ID—The port or VLAN to which the setting was applied at
the group level is not available or is invalid on the switch. For example, if you apply a setting to port
15 and 16 at the group level, and a switch has only ports 1 to 10, then the settings will not be applied
to that switch.

The setting that can be configured using the UI are:

n Creating QoS traffic policies on switches in your network to enable traffic-handling rules across the
network.

n Defining QoS classes for a QoS Policy.
n Changing the priorities of traffic from various segments of your network as your business needs

change.

Creating a QoS Traffic Policy
To create a QoS traffic policy, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter, complete the following steps:

a. Set the filter to a group containing at least one switch.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-S or Config icon to view the switch configuration dashboard.

n To select a switch in the filter, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click a switch under Device Name.

The dashboard context for the switch is displayed.
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d. Under Manage, click Device.

The tabs to configure the switch is displayed.

2. Click QoS.

The QoS page is displayed.

3. In the QoS Traffic Policy accordion, click + to add a new QoS traffic policy.

The New QoS Policy pop-up window is displayed.

4. Configure the following parameters:
n Policy Name—Enter a name of the QoS policy.
n Target—Select Port or VLAN from the drop-down list to specify the target where the policy is

applied.
n ID—Select an IPv4 address for static IP assignment from the drop-down list.

This field is enabled only when you select Static from the IP Assignment drop-down list.

5. Click Save.

Editing a QoS Policy
To edit a QoS policy, point to the row for the Qos policy, and click the edit icon.

Deleting a QoS Policy
To delete a QoS policy, point to the row for the Qos policy, and click the delete icon.

Adding a QoS Class for the Policy
To define a QoS class for the a policy, complete the following steps:

1. Select a QoS policy from the New QoS Policy table.

The QoS Class table is displayed below the New QoS Policy table with the configured QoS
classes.

2. Click + to add a QoS classifier for the selected policy.

The Add QoS Classifier pop-up window is displayed.

3. Configure the parameters described in Table 173.
4. Click OK.

Name Description Value

Class Name The class name of the QoS policy. A string

Packet Matching Criteria

Source The type of source for which you want to
apply a policy.

Any, Network, or Host.
If you select Network, enter the IP
address and wildcard mask .
If you select Host, enter the IP address.

Destination The type of destination for which you
want to apply a policy.

Any, Network, or Host.

The following table describes the QoS class parameters.
Table 173: Configuring QoS class
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Name Description Value

If you select Network, enter the IP
address and wildcard mask .
If you select Host, enter the IP address.

Protocol Select the type of data transfer protocol
from the drop-down. If you select SCTP,
TCP, or UDP, the source ports and
destination ports fields are displayed.

Protocol types: GRE, ESP, AH, OSPF, PIM,
VRRP, ICMP, IGMP, IP, SCTP, TCP, UDP, IP_
IN_IP and IPv6_IN_IP.

Source Port(s) The port numbers of source. You can
specify a comma separated list of ports or
range of ports. For example: 10-12 or
10,12.

Numeric value

Destination
Port(s)

The port numbers of destination. You can
specify a comma separated list of ports or
range of ports. For example: 10-12 or
10,12.

Numeric value

Actions

DSCP Select a Differentiated Service Code Point
(DSCP) from the drop-down.

DSCP value range from 0 to 63.
Default value is No Change.
In few cases, such as 10| af11 and 10|
af12

Priority Select a priority value for the selected
DSCP.

The priority range from 0 to 7.
n 0 – Normal Priority
n 1 – Low Priority
n 7 – High Priority

Default value is No Change.

Editing a QOS Class
To edit a QoS Class, point to the row for the Qos policyclass, and click the edit icon.

Deleting a QOS Class
To delete a QoS Class, point to the row for the Qos policyclass, and click the delete icon.

Configuring DSCP Map
DSCP map table displays mappings between Incoming DSCP and priority.

To change priority value associated with a DSCP code point, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter, complete the following steps:

a. Set the filter to a group containing at least one switch.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-S or Config icon to view the switch configuration dashboard.
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n To select a switch in the filter, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click a switch under Device Name.

The dashboard context for the switch is displayed.

d. Under Manage, click Device.

The tabs to configure the switch is displayed.

2. Click QoS.

The QoS page is displayed.

3. Expand the DSCP Map accordion.
4. Select the Incoming DSCP row for which you want to change the priority and click the edit icon.

The Edit DSCP pop-up window is displayed.

5. Select the priority value from the Priority drop-down list.
6. Click OK.

Configuring Device Profile and Device Identifier on AOS-S Switches
Device profile configuration allows Aruba Central On-Premisesto dynamically detect an Aruba AP, AOS-
S, or other devices, which are directly connected to the switch, and apply predefined configurations to
ports on which the devices are detected. The device profile configuration has default device profiles and
device identifiers, which cannot be deleted. In addition to the default device profiles and device
identifiers, you can create custom device profiles and device identifiers.

The following pre-configured device types under device profile are available:

n Aruba-AP—All Aruba APs
n Aruba-Switch—Aruba switches
n SCS-WAN-CPE—Swisscom WAN devices (Swiss service provider)

To apply device profiles on other device types, you must configure the devices under device identity and
associate that identity with a profile, only if the device is detectable by the LLDP TLV 127 and CDP (VOIP)
attributes.

To configure device profile, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter, complete the following steps:

a. Set the filter to a group containing at least one switch.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-S or Config icon to view the switch configuration dashboard.
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n To select a switch in the filter, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click a switch under Device Name.

The dashboard context for the switch is displayed.

d. Under Manage, click Device.

The tabs to configure the switch is displayed.

2. Click Device Profile.

The Device Profile page is displayed.

3. Depending on whether you want to add a new device profile or identifier, complete one of the
following steps:

n In the Device Profile table, click + to add a device profile. For more information, see Adding a
Device Profile.

n In the Device Identifier table, click + to add a device identifier. For more information, see
Adding a Device Identifier.

If no device profile is mapped to a device identifier, the default device profile Default-AP-Profile is
associated with the device identifier.

Adding a Device Profile
Configuration changes made on the device profiles always takes precedence over other UI
configurations on the switch. For example, the PoE Priority and PoE Allocation configuration on the
device profile takes precedence over the configurations on the Interface > PoE page.

Configuring profiles through device CLI removes existing configurations and sets it to the default
configuration, but this may not apply in some instances.

To add a device profile, complete the following steps:

1. In the Device Profile table, click + to add a profile.

The Add Device Profile pop-up window is displayed.

2. Configure the parameters described in Table 174.
3. Click Save.

Name Description Value

Name The name of the profile configured. A unique name for the device profile.
This field cannot contain tilde(~), forward
slash(/), and space characters.

Class of
Service (CoS)

Indicates data and voice protocols for classifying
packets into different types of traffic and setting
a service priority.

0,1,2,3,4,5,6,7
Default is Disabled

The following table describes the device profile parameters.
Table 174: Device Profile Parameters
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Name Description Value

Supported only on AOS-S switches running
firmware version 16.10.0004 or later.

Tagged VLAN The tagged member of the VLAN. Select from the drop-down.
You can configure multiple VLANs by
selecting the check boxes in the drop-
down.

UnTagged
VLAN

The untagged member of the VLAN. Select from the drop-down.
Default value is 1.

PoE Priority The PoE priority for the device port. Low, High or Critical

PoE
Allocation

The PoE allocation for the switch port.
Not supported on Aruba 2920 Switch Series.

Usage or Class

Device
Identifier
Name

The device identifiers associated with the device
profile.

Select from the drop-down.
This field lists only the default device
identifiers. To add a custom device
identifier, see <>

Jumbo Indicates whether jumbo packet handling is
enabled for the VLAN interface.

Toggle switch to the on or off position

Editing a Device Profile
To edit a device profile, click the edit icon.

Deleting a Device Profile
To delete a device profile, click the delete icon.
You cannot delete the default device profile or a device profile that is associated with a device identifier.

You can validate the device profiles using the show device-profile status and show vlan <id>

commands.

Adding a Device Identifier
The Device Identifiers configuration allows you to configure multiple identifiers for a single device
profile. Aruba-AP, Aruba-Switch, and SCS-WAN-CPE are the default device identifiers under device
profile. The device identifier allows you to identify devices based on CDP and LLDP (TLV type 127, TLV
type 6, and TLV type 5) information.

Device identifiers are supported on AOS-S switches running firmware version 16.10.0004 or later.

To add a device identifier, configure the following steps:

1. In the Device Identifier table, click + to add a identifier.

The Add Device Identifier pop-up window is displayed.

2. Configure the parameters described in Table 175.
3. Click Save.
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Name Description Value

Name The name of the identifier configured. A unique name for the device identifier.
This parameter cannot contain tilde(~),
forward slash(/), and space characters.

Status Status of the device identifier is enabled or
disabled.

Toggle switch to the on or off position.

Type Type of device identity. CDP or LLDP

VOIP VLAN
query

The VOIP VLAN query name.
Applicable only when you select CDP in the Type
parameter.
Not supported on the Aruba 2920 Switch Series.

Alphanumeric characters

MAC OUI OUI part in the MAC address.
Applicable only when you select LLDP in the
Type parameter.

Hexadecimal value in the range 000001
and FFFFFF.

Enter
subtype

Subtype associated with LLDP.
Applicable only when you select LLDP in the
Type parameter.

Integer value between 0 and 255.

The following table describes the device identifier parameters.
Table 175: Device Identifier Parameters

Editing a Device Identifier
To edit a device identifier, click the edit icon.
You can only edit the status of the default device identifiers.

Deleting a Device Identifier
To delete a device identifier, click the delete icon.
You cannot delete the default device identifiers.

Automatic Rollback Configuration
Aruba Central On-Premises supports auto-rollback mechanism for AOS-S switches running software
version 16.10.0009 or later. The auto-rollback mechanism is triggered when the switch loses
connectivity to Aruba Central On-Premises after the configuration is applied. The switch rolls back to the
last known stable configuration and reconnects to Aruba Central On-Premises within a period of 10
minutes. After recovery, the Auto Commit State in the Configuration Audit page is set to Off to stop
subsequent configuration push from Aruba Central On-Premises. Before changing the Auto Commit
state to ON, you must review the configuration change that resulted in the network disconnect.

When a switch rollback occurs, an event is logged in the Audit Trail page as shown in the following
figure.
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Figure 96 Example of Audit Trail Page for Automatic Rollback Configuration

Enabling Unsupported Transceivers on AOS-S Switches
AOS-S switches running software versions 16.02.0013 or later, support the use of third-party
transceivers. Allowing unsupported transceivers enables the AOS-S to unblock the port and allow third-
party transceivers to connect to the switch.

To enable this feature, complete the following procedure in Aruba Central On-Premises:

1. Open the console of the switch using the console option in Aruba Central. For more information,
see Opening Remote Console for Switch.

2. Login to the switch in the console.
3. Run the following command to enable Aruba Central support mode:

aruba-central support-mode enable

4. Run the following command to allow third -party transceivers to be connected to the AOS-S:

allow-unsupported-transceiver

5. Run the following command to save the running configuration of the switch to the startup
configuration.

write memory

6. Run the following command to disable Aruba Central support mode:

aruba-central support-mode disable

7. Reboot the switch. For more information, see Rebooting Switches.
8. Verify the transceiver details by running the following command:

show tech transceivers
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AOS-S Stack
A switch stack is a set of switches that are interconnected through stacking ports. The switches in a
stack elect a primary switch called Conductor and a backup switch as Member.

The following table lists the switches that support stacking.

AOS-S Platform
Maximum
Number of
Stack Members

Minimum
Supported
Version

Supported Stack
Type (Frontplane
(VSF) /
Backplane
(BPS))

Supported
Configuration
Group Type for
Stacking (UI /
Template)

Aruba 2930F Switch
Series

8 n WC.16.08.0019 or
later

n WC.16.09.0015 or
later

n WC.16.10.0012 or
later

VSF UI and Template

Aruba 2930M
Switch Series

10 n WC.16.08.0019 or
later

n WC.16.09.0015 or
later

n WC.16.10.0012 or
later

BPS UI and Template

Aruba 3810 Switch
Series

10 n KB.16.08.0019 or
later

n KB.16.09.0015 or
later

n KB.16.10.0012 or
later

BPS UI and Template

Aruba 5400R
Switch Series

2 n KB.16.08.0019 or
later

n KB.16.09.0015 or
later

n KB.16.10.0012 or
later

VSF Template only

Table 176: Switch Stacking Support

Provisioning and configuring of Aruba 5400R Switch Series and switch stacks is supported only through
configuration templates. Aruba Central On-Premises does not support moving Aruba 5400R Switch Series from
the template group to a UI group. If an Aruba 5400R switch is preassigned to a UI group, then the device is
moved to an unprovisioned group after it joins Aruba Central On-Premises.

For more information on topology and configuration of switch stacks, see the ArubaOS-Switch
Management and Configuration Guide for the respective switch series.
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Provisioning AOS-S Stacks in Aruba Central On-Premises
The switch elected as the conductor establishes a WebSocket connection to Aruba Central On-Premises.
The following criteria apply to provisioning and management of switch stacks in Aruba Central On-
Premises:

n Switch stacks can be added only to a template group and cannot be moved to a UI group.
n If the standalone switches in a group join to form a switch stack, the switch is moved to the

Unprovisioned state.
n If a switch stack in the template group joins Aruba Central On-Premises as a stand-alone Switch, it is

blocked unless it is deleted from the stack. After it is removed from the stack, the stand-alone switch
is moved to the pre-provisioned group.

n If a switch stack is moved from a pre-provisioned group to an existing group in the UI, it will be
moved to Unprovisioned state.

n After forming a switch stack, you can remove a member and erase its stacking configuration.
However, the member can join Aruba Central On-Premises as a standalone switch only after it is
deleted from the switch stack.

n When a stack is removed, the stack members cannot join Aruba Central On-Premises until the stack
entry is deleted. For more information on deleting the stack, see Configuring AOS-S Stacks Using UI
Groups. When a stack entry is not deleted and the member tries to rejoin Aruba Central On-
Premises, an event is triggered in the Audit Trail page stating that the stack association is detected.

Assigning Labels and Sites
Aruba Central On-Premises supports organizing your devices into sites for ease of monitoring. Sites
refer to physical locations in which the devices are installed. Administrators can assign switch stacks to a
single site for ease of managing installations and monitoring the overall site health. For more
information on assigning devices to sites, see Managing Sites.

Similarly, switch stacks can also be tagged using labels. Labels allow you to identify or tag devices
installed in a specific site for ease of monitoring. For more information on assigning labels, see Labels
and How to Manage Them.

If any one member of the switch stack is assigned to a site, Aruba Central On-Premises automatically
assigns all other members in a switch stack to the same site. Similarly, if a label is assigned to an
individual member in a stack, the same label is applied to all other members of the stack.

Because all members of a switch stack must be assigned to the same site and label, Aruba Central On-Premises
automatically corrects the site and label assignment for switch stacks that were earlier assigned to different
labels or sites. If you have such switch stacks in your account, you will notice that all stack members are
migrated to the same site or label to which the conductor was assigned. Aruba recommends that you review
the sites and labels assigned by Aruba Central On-Premises to verify that the switch stacks in your account are
assigned to sites and labels that you intended to use, and if required, assign all members of stack to a common
site or label of your choice.

Configuring AOS-S Stacks
For information on configuring switch stacks using template groups, see Configuring AOS-S Stacks Using
Template Groups.

For information on configuring switch stacks using UI groups, see Configuring AOS-S Stacks Using UI
Groups.
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Monitoring Switch Stacks
For information on monitoring switch stacks, see Monitoring Switches and Switch Stacks.

Viewing Switch Stacks in Site Topology
For information on viewing switch stacks in site topology, see Monitoring Sites Topology Tab.

Configuring AOS-S Stacks Using Template Groups
The switch stacks are provisioned under template groups in Aruba Central On-Premises. The template
groups allow you to configure and modify the settings of a switch stack using configuration templates.

When uploading a configuring template, ensure that the variables are uploaded for all the members of
the stack. when you upload or edit variables of conductor or any one of the members, all the stack
members are automatically synced with the same set of variables using the UI or Aruba Central API. For
more information, see Integrated Management of Template Variables for AOS-S Stacks.

To create a configuration template for switch stack, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a template group.

The dashboard context for the group is displayed.

2. Under Manage, click Devices > Switches.
3. Click the AOS-S or Config icon.

The tabs to configure switches using templates is displayed.

4. Click + to create a template for the Aruba switch stack.
5. Specify a name for the template.
6. Select Aruba Switch from the Device Type drop-down list.
7. Select the AOS-S model in the Model drop-down list.
8. Select the AOS-S software version in the Version drop-down list.
9. Enter the template text in the Template box.

All switch templates must include a password command to set a password for the device. The switch
template cannot be saved without adding a password command. If the configuration that is pushed
from Aruba Central to the device does not contain a password command, the configuration push is
aborted for the device and a log is added to the audit trail. For example, if you add the password
command in a condition block and the condition evaluates to false, the configuration that is pushed will
not contain the password command.

10. Click Save.

Aruba Central On-Premises does not support the use of part number (J-number) in place of Switch model
number in configuration templates for the Aruba switch stack.

The following pre-defined variables are refreshed and re-imported from a switch stack when a new
stack member is added or removed, or when a failover occurs.

n _sys_template_header
n _sys_module_command
n _sys_stack_command
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n _sys_oobm_command
n _sys_vlan_1_untag_command
n _sys_vlan_1_tag_command

For information about deploying VSF stacks of ArubaOS Switches using Zero Touch Provisioning (ZTP) in
Aruba Central, see the VSF Stacking Guide.

For information about switch stacks using UI groups, see Configuring AOS-S Stacks Using UI Groups.

Integrated Management of Template Variables for AOS-S Stacks
For stacks to work seamlessly without any template variable errors, the template variables of all stack
members must be in sync. If a stack has many members, then it is difficult for a user to manually edit
the variables for each member in a stack to keep the variables in sync. If the variables are not in sync,
then during failover, the configuration error occurs. To automatically sync the variables for all stack
members, Aruba Central On-Premisesintroduces integrated management of template variables for an
AOS-S stack to keep the variables of all members in sync. All the stack members are automatically
synced with the same set of variables when you upload or edit variables using the UI or Aruba Central
On-Premises API.

When you upgrade Aruba Central On-Premises from earlier versions to 2.5.5 or later versions, the stack
member variables are preserved from the earlier versions. The variables change happens only after the
variables are updated using the UI or Aruba Central On-PremisesAPI in the latest version.

The following table explains the behavior of the management of template variables using the UI.

Action Behavior

Uploading variables for the
conductor

Conductor variables are copied to all other members.

Editing variables for the conductor

Uploading variables for any other
member

Member variables are copied to all other members including the
conductor.

Editing variables of any other
member

Uploading variables of multiple
members along with the variables for
the conductor

Conductor variables are copied to other members. For example,
consider a three-member stack with the conductor, standby, and
member. If you upload the variables JSON with different variable values
for conductor, standby, and member, then the conductor variables are
copied to the standby and member.

Uploading variables of multiple
members without conductor
variables

Variables of the member with the highest priority are copied to the
conductor and other members. For example, consider a three-member
stack with the conductor, standby, and member with priority values 255,
254, and 253 respectively. If you upload variables JSON with standby
and member of different values, then standby variables are copied to
the conductor and member.

Adding a new member to the stack Conductor variables are copied to the new member.

Table 177: UI Behavior

https://support.hpe.com/hpsc/doc/public/display?docId=a00091437en_us
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Action Behavior

Deleting a member No changes to the variables.

Changing the conductor No changes to the variables.

In order to upload variables without any conflicts, it is recommended to upload variables for only one member
(either the conductor or any one of the stack members).

The following table explains the behavior of the management of template variables using NB APIs.

API Description Behavior

Updating values of existing template
variables and add new variables to the
existing set of variables for one of the
members
PATCH /configuration/v1/devices/
{device_serial}/template_variables

Variables of other members are also updated.

Creating template variables for one of the
members
POST /configuration/v1/devices/
{device_serial}/template_variables

Replacing all the template variables or
deleting some of the variables of one of
the members
PUT /configuration/v1/devices/{device_
serial}/template_variables

Deleting all template variables for one of
the members
DELETE /configuration/v1/devices/
{device_serial}/template_variable

Variables of other members are also deleted.

Updating template variables for all
members (only JSON Payload)
PATCH
/configuration/v1/devices/template_
variables

n If a conductor or any one of the members is part of the
payload, then the conductor or the member variables are
copied to other members.

n If multiple members are part of the payload, then the variables
of the member with the highest priority are copied to all other
members.Creating template variables for all

members
POST
/configuration/v1/devices/template_
variables

Replacing all the template variables or
deleting some of the template variables
for all members
PUT
/configuration/v1/devices/template_
variables

Table 178: Aruba Central API Behavior
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Configuring AOS-S Stacks Using UI Groups
Aruba Central On-Premises supports both Backplane stacking (BPS) and Virtual Switching Framework
(VSF) switch stacking. You can create switch stacks and add stack members through the UI. The stack
configuration is possible only when the switches are online.

Stacks created using UI groups can only be managed in a UI group. If a device is moved to a template group,
then the device cannot be managed in a UI group without rebuilding the stack.

Fiber modules / SFP ports are manageable in a UI group when the stack is created .These modules are available
for configuration at the device level context.

See the following topics for more information on managing switch stacks using UI groups:

n Onboarding Conductor and Members for VSF Stacking
n Onboarding Conductor and Members for BPS Stacking
n Creating an AOS-S Stack
n Adding a Stack Member

Onboarding Conductor and Members for VSF Stacking
The following is a high-level process flow for configuring VSF switch stacks:

1. Add the switches to the device inventory and assign a valid subscription.

All the switch members must be set to factory default and powered off.

2. Power on the switch you intend to add as a conductor.

The switch comes up online in Central as a standalone switch.

3. Create a stack with the standalone switch.

After stack creation, the switch reboots and comes up as a stack conductor. For more
information, see the section Creating an AOS-S Stack.

4. Add other members to the stack when the status of the conductor switch is active.

For more information, see Adding a Stack Member.

5. After adding members, connect the Ethernet cables between the switches to form the desired
topology.

6. Power on the switches one at a time.

The second switch that is powered on will be elected as standby. The subsequent switches that
get powered on will be designated as the members of the stack.

For more information on deploying a VSF stack, see Onboarding Conductor and Members for VSF
Stacking section.

For more information on topology and configuration of switch stacks, see the ArubaOS-Switch Installation
and Getting Started Guide and ArubaOS-Switch Advanced Traffic Management Guide for the respective
switch series.

If the stack members are connected and powered on before adding to a stack, then the members might not
join the stack and status of the stack members are displayed as Inactive in the UI. In this scenario, stack cannot
be managed through the UI.
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Recommended Deployment Workflow
The following procedure provides the recommended workflow for deploying three-member VSF stack
(Conductor, Standby, and a Member switch):

1. Connect a staging port on the first switch in the VSF stack to a DHCP enabled network or a device
that has access to the internet.

After rebooting and initialization, the switch assumes its role as conductor and the LED on the
VSF stack ports of the switch will turn amber.

2. Connect a VSF port of the next switch to the VSF port of the conductor switch.

During initialization, the switch acts as standby and the LED on the VSF port turns amber.

3. Connect a VSF port of the next switch to the VSF port of the standby switch.

During initialization, the new switch acts as a member and the LED on the VSF port of the switch
turns amber.

4. Connect the VSF port of the conductor switch to the VSF port of the member to complete the
loop.

If the stack members are connected and powered on before adding to a stack, then the members might not
join the stack in Aruba Central On-Premises. In such scenarios, the status of the stack members is displayed as
Inactive in the UI. Also, the stack cannot be managed using UI groups in Aruba Central On-Premises.

Onboarding Conductor and Members for BPS Stacking
The following is a high-level process flow for configuring BPS switch stacks:

1. Add the switches to the device inventory and assign a valid subscription.

All the switch members must be set to factory default and powered off.

2. Insert the stacking module to the switch you intend to add as a conductor.
3. Power on the conductor switch.

The switch comes up online in Central as one-member BPS switch stack. A one-member BPS
switch stack is a single BPS switch with stacking enabled.

4. Move the one-member switch stack from the Unassigned Devices group to a UI group.

The stacking information is displayed in the Stacks configuration page with switch member
added as the conductor.

5. Add other members to the stack when the status of the conductor switch is active in the
Members table.

For more information, see Adding a Stack Member.

6. After adding members, connect the stacking modules and stacking cables between the switches
to form the desired topology.

7. Power on the switches one at a time.

The second switch that is powered on is elected as standby. The subsequent switches that get
powered on are designated as the members of the stack.
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If the stack members are connected and powered on before adding to a stack, then the members might not
join the stack in Aruba Central On-Premises. In such scenarios, the status of the stack members is displayed as
Inactive in the UI. Also, the stack cannot be managed using UI groups in Aruba Central On-Premises.

For more information on topology and configuration of switch stacks, see the ArubaOS-Switch Installation
and Getting Started Guide and ArubaOS-Switch Advanced Traffic Management Guide for the respective
switch series.

Creating an AOS-S Stack
To create an AOS-S stack, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter, complete the following steps:

a. Set the filter to a group containing at least one switch.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-S or Config icon to view the switch configuration dashboard.

n To select a switch in the filter, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click a switch under Device Name.

The dashboard context for the switch is displayed.

d. Under Manage, click Device.

The tabs to configure the switch is displayed.

2. Click Stacks. The Stacks page is displayed.
3. Configure the parameters described in Table 179.

Name Description Value

Name The name of the switch stack. A string

Type The type of switch stacking. BPS or VFS

Stack ID The ID of the switch stack. The stack ID is auto-
generated and cannot be changed in the
settings.

Auto-generated String

Members The number of members on the switch stack. Integer

MAC
Address

The MAC address of the switch stack. Alphanumeric MAC address

Topology The type of switch stack topology. Chain, Ring, or unknown

Table 179: Stacks table
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Name Description Value

Status The status of the stack formation. Pending, In-progress, Active, or Failed

VSF Port
Speed

The port speed in the case of VSF stacking. This
column is hidden by default. You must select
the column from the columns list.

1G or 10G

4. In the Stacks table, click + to add a stack.

The Create New Stack pop-up window is displayed.

5. Select a conductor switch from the Select Conductor Switch drop-down list.

The model number and serial number of switches are displayed in the drop-down list.

The conductor switch must be installed with the minimum supported firmware version of 16.06 or
later.

If the selected switch supports VSF Stacking, configure the following parameters:
n Link 1 Name and Port(s)—The name of the link 1 and its corresponding ports.

n Link 2 Name and Port(s)— The name of the link 2 and its corresponding ports.

n Domain ID—The domain ID of the switch stack.

n Port Speed—The VSF port speed from the drop-down list.

If the selected switch supports BPS stacking, insert the stacking module in switch and continue to
step 5.

6. Click Save & Reboot Stack.

When the stack reboots, the status of the stack formation is displayed in the Stacks table. Do not
make any changes to the stack until the status changes from In Progress to Active or Failed. If
stack creation fails due to some issues, delete the stack entry and retry.

Editing a Stack
To edit a stack, select the stack row you want to edit and click the edit icon.

You can edit a stack only when its status is Active.

Removing a Stack
To remove a stack, select the stack row that you want to remove and click the delete icon.

You can remove a stack only when its status is Failed.

Adding a Stack Member
Stacking allows you to add switches to the stack only when the conductor is active.

To add a switch to stack as a new member, complete the following steps:
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1. In the Aruba Central On-Premises app, select one of the following options:
n To select a switch group in the filter, complete the following steps:

a. Set the filter to a group containing at least one switch.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Switches.
c. Click the AOS-S or Config icon to view the switch configuration dashboard.

n To select a switch in the filter, complete the following steps:
a. Set the filter to Global or a group containing at least one switch.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click a switch under Device Name.

The dashboard context for the switch is displayed.

d. Under Manage, click Device.

The tabs to configure the switch is displayed.

2. Click Stacks.

The Stacks page is displayed.

3. In the Stacks table, select the stack row for which you want to add a member.

The Members table displays the list of members for that particular stack. The Members table
displays the information described in Table 180.

Name Description Value

Name The name of the switch stack member. A string

MAC
Address

The MAC address of the stack member. Alphanumeric MAC address

Model The hardware model of the switch. A String

Priority The priority level of the stack member. 1 to 255

Role The role of a stack member. Conductor, Member, or Standby

Status The status of the switch stack member. Active, Inactive, or Not Joined

Link1 | Port The name of the link and its corresponding port of
the stack member.

A string

Link2 | Port

Table 180: Members table

4. In the Members table, click + to add a stack member.
The Add Stack Member For <stack name> pop-up window is displayed.

 The following information is auto-generated:

n Member ID—Identification number of the member.

n Priority—Priority of the member.
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5. Select the member using one of the following options:
n Same as Conductor—Use this option when your conductor and member have the same

model number.
n Select Model —Use this option when your conductor and member have different model

numbers.

Select the switch model from the model drop-down list.

6. If the selected switch supports VSF Stacking, configure the following parameters:
n Link1 Name and Port(s)—Specify the name of the link 1 and its corresponding port.
n Link2 Name and Port(s)—Specify the name of the link 2 and its corresponding port.

7. To add another stack member, click Save & Add Another.

A message is displayed above the Members table when the maximum number of switches in a stack
has been added.

8. Click Save.

After the stack members appear in Members table, connect the stacking modules and stacking
cables to all switches and power on the switches.

Editing a stack member
To edit a stack member, select the member row you want to edit and click the edit icon.

Removing a stack member
To delete a stack member, select the member row that you want to delete and click the delete icon.

After removing a member, disconnect the switch from the stack. To disconnect the switch from the
stack, do one of the followings:

n Turn off the power from the switch.
n Restart the switch using switch reset button.

You can remove only the stack member that has the lowest priority. For example, if there are three stack
members with priority 254, 253 and 252 respectively and if you want to remove a stack member with priority
253, then first you need to remove the member with priority 252.
Priority cannot be assigned manually. Conductor switch is always assigned with priority 255. The priority of
other subsequent members is decremented by 1.

Replacing an AOS-S Switch
Aruba Central On-Premises supports replacing a faulty AOS-S switch. A faulty AOS-S switch can be
replaced through the Aruba Central On-Premises Web UI from the Device Replacement tile.

After the switch is replaced, all device attributes and configuration parameters of the old switch are
inherited by the new switch, and the old switch is removed from the monitoring view, but not from the
device inventory.

This chapter includes the following topics:

n Important Points to Note
n Replacing an AOS-S Switch from the Device Replacement Tile
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Important Points to Note
n Before starting the procedure, ensure that the faulty switch that has to be replaced is offline.
n The faulty switch must be in the device inventory.
n A valid license must be assigned to the faulty switch.
n The model number and part number of the faulty switch and the new switch must be the same.
n Only one switch can be replaced at a time.
n Only standalone switches can be replaced. The switches that are part of a stack cannot be replaced.
n The faulty switch is deleted from the monitoring view only after the validation process is complete.
n If the faulty switch belongs to a UI group, then the new switch also must belong to a UI group. If it

belongs to a template group, then the new switch also must belong to a template group.
n The old switch is not removed from the device inventory after the device is replaced. The switch can

be reused in the future.
n After the device is replaced, the license of the old switch is removed.

Replacing an AOS-S Switch from the Device Replacement Tile
To replace an AOS-S switch from the device replacement tile, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.

The dashboard context for the selected filter is displayed.

2. Under Maintain, click Organization.

By default, the Network Structure tab is displayed.

3. In the Device Replacement tile, click Devices.

The Replace Devices page is displayed.

4. In the Select a device type drop-down, select Switch.
5. In the Select a site drop-down, select a site in which the switch has to be replaced.

The Devices table lists the offline switches available for replacement from the selected site.

6. In the Devices table, hover over the faulty switch that you want to replace and click the Replace

Offline Devices icon.
The New Device and Compliance Status columns are displayed.

7. In the New Device column, select a new switch from the drop-down for the selected faulty
switch. The new switch can be filtered using the serial number or MAC address.

Once the new switch is selected, Aruba Central On-Premises checks whether the faulty device can
be replaced with the new switch.
n If the selected switch is a good match for the faulty switch, then the Compliance Status

column for the selected switch is displayed as Good Match.

You can replace the faulty switch only when the Compliance Status is displayed as Good Match.

n If the selected switch is not a good match for the faulty switch, then the Compliance Status
column for the selected switch displays one or some of the following reasons:
o The model number or part number of the faulty switch is not matching with the new switch.
o A valid license is not assigned to the faulty device.
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o The group type is not the same for the faulty device and the new device, if the new device is
already connected to Aruba Central On-Premises. For example, if the faulty switch belongs
to a UI group, then the new switch also must belong to a UI group.

o The new device is blocked by another replacement process.
o Not able to fetch faulty device details from the device inventory if the device is not available

in the device inventory.
o Not able to fetch details about the faulty device group.

8. Click Replace to initiate the device replacement.

In the Compliance Status column, the status changes to: Your replacement request has been
accepted.

You cannot terminate the device replacement process once the status changed to Your replacement
request has been accepted.

9. Plug in the new switch once the status changes to: Your replacement request has been accepted.
10. Click Status to check the status of the device replacement process.

The Devices Under Replacement table displays the following details:
n Old Device Name
n New Device Name
n Requested On
n Updated On
n Device Type
n Device Connection Status
n Site Name
n Group Name
n Old Device Serial
n New Device Serial
n Old Device MAC
n New Device MAC
n Model
n Group assignment
n Site assignment
n Labels assignment
n License assignment
n VRF assignment (This column is not applicable for switches)
n Configuration assignment
n Firmware assignment
n Uplink assignment
n Status

Once all the assignments are Updated, it will take up to five minutes for the Status column to
change to Success. If any of the assignments failed, the Status column changes to Failed.

You can click on the any of the old device serials to view the device replacement details for the
particular device.
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n You can also navigate to the Devices Under Replacement page from the Device Replacement
tile to view the status of the device replacement process.

n Optionally, you can terminate the replacement process when the Status is displayed as
Requested by hovering over the row in the Devices Under Replacement page.

n The old device is not removed from the monitoring view if the device replacement fails.

11. To view the device replacement history, navigate to the Device Replacement tile and click
Replacement History.

The Replacement History page lists the details of all the device replacements carried out in
Aruba Central On-Premises. You can click on the any of the old device serials to view the device
replacement history details for the particular device.

12. To view the audit logs, in the global dashboard context, navigate to Analyze > Audit Trail and
filter the Category column to Device Replacement.
The Audit Trail page displays all the logs generated during the device replacement process.

The following table lists some sample queries that can be used as search queries:

Using Device Search
In the Devices Under Replacement and Replacement History pages, the search icon allows you to
filter devices using search queries. For example, the search query “Site name is Santa Clara AND device
type is switches" returns all switchesin the Santa Clara site.

The search query can contain the following information:

n Device Attributes—Device serial, MAC address, device name, site name, and group name are allowed.
n Operators—is, as, and equal sign (=) are allowed.
n Separators—AND, comma (,), semicolon (;), and ampersand (&) are allowed.

Sample Queries

Query Result

new_switch1 Returns the device with the name new_switch1.

Serial is H9XHL Returns the device with the serial number H9XHL.

Site name is Bangalore AND device type = switch Returns all the switches in the Bangalore site.

Group name as Outdoor & device type is Gateway Returns all the gateways in the Outdoor group.

Table 181: List of Sample Queries



Chapter 15

Managing Controllers

Managing Controllers

This section covers the following topics:

n Aruba Central On-Premises offers monitoring service for WLAN networks configured and managed
using ArubaMobility Controllers.

n Aruba Central On-Premises allows you to onboard and monitor controller clusters, the Mobility
Conductor setup, and the conductor and local controller setup.

n When you add a conductor controller or a Mobility Conductor, Aruba Central On-Premises discovers
all the associated controllers and campus APs, and adds them to the device inventory.

Aruba Central On-Premises does not support configuring wired clients on a controller. To configure and
deploy , use the WebUI and CLI.

Before You Begin
Before adding controllers to Aruba Central On-Premises, ensure that the controller has the following
parameters configured:

n Management Server profile—The Aruba Central On-Premises server must be configured as a
management server on the controller such as SNMP or HTTP.

n Advanced Monitoring Messages—Enable AMON for communication between the Aruba Central On-
Premises server and controller. When AMON is enabled on the controller over UDP 8211, the
controller periodically sends information about user sessions, AP and client association, and other
such information required for managing and monitoring controllers on Aruba Central On-Premises.

n Syslog Messages and SNMP Traps—Although AMON is a preferred option for polling data from
controllers, to obtain data pertaining to AP lists, you may want to enable SNMP, and configure SNMP
traps and syslog server for logging system events.

n WebSocket connection—To enable controller firmware upgrade and troubleshooting from Aruba
Central On-Premises, ensure that the Aruba Central On-Premises server URL and IP address are
configured on the controllers running ArubaOS 8.4.0.0 or later.

For more information on configuring controllers, see ArubaOS User Guide.

Tools support is available for controllers that support Websocket connection. For example, controllers running
Firmware version 8.4.0.0 or later. For information on how to create a WebSocket connection, see Creating a
WebSocket Connection.

This section covers the following topics:

n Adding Mobility Controllers
n The Controller Dashboard
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Supported Aruba Mobility Controllers
Aruba Central On-Premises supports provisioning, management, and monitoring of the following Aruba
Mobility Controllers.

The following table lists the supported Mobility Controllers and latest validated software versions.

Supported Device Latest Validated Software
Versions

Aruba 7000 Series Mobility Controllers n 8.7.1.9

n 8.8.0.0

n 8.9.0.0

n 8.10.0.3

Aruba 7200 Series Mobility Controllers n 8.7.1.9
n 8.8.0.0
n 8.9.0.0
n 8.10.0.3

Aruba 9004 non-LTE Mobility Controllers 8.8.0.0

Aruba 9240 Mobility Controllers n 8.9.0.0
n 8.10.0.3

NOTE:

n Controllers WebSocket connection must be manually set up to Aruba Central.
n The minimum software version required for monitoring controller clusters and Mobility Conductor managed

networks is ArubaOS 8.2.1.0.

Table 182: Supported Devices and Software Versions

Adding Mobility Controllers
You can add controllers on the HPE GreenLake portal. For more information about how to add devices
on the HPE GreenLake account home, see Managing Devices and Subscriptions.

Deleting a Controller
You can only delete controllers that are in the offline state.

If the controller is in the online state, first you must unassign or unlicense the subscription on the HPE
GreenLake account home to make it offline. Then, you can delete the controller from the WebUI. For
information about how to unassign a device subscription, see Managing Devices and Subscriptions.

To delete a controller that is in offline state, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under groups, labels,
or sites. Ensure that the filter selection contains at least one controller. For all devices, set the
filter to Global.
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The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Controllers.

A list of controllers is displayed in List view.

3. Click Offline to display a table with the list of offline controllers.
4. From the Controllers table, select the controller(s) that you want to delete.

To select a controller, click on any column except Controller Name. Clicking on a device name in the
Controller Name column opens the controller dashboard.

5. Click the Delete button at the bottom of the page to delete all the selected controllers. To delete
a particular controller, click the Delete icon available at the end of the row for that controller.

The selected controller is deleted.

The following table describes the conditions of when the delete option is available for controllers on
different scenarios based on its status and association with AP.

Action Controller
Status AP Status Action Result

Deleting a
controller

Offline Offline When an offline controller is deleted, the
associated AP is also deleted
automatically.

Deleting a
controller

Online Online Delete option is not available.

Deleting a
controller

Offline Few APs are offline
and few APs are
online

Delete action fails and a message is
displayed in the pop-up window.

Deleting a
controller

Online Few APs are offline
and few APs are
online

Delete option is not available.

Deleting an AP Offline Offline When an offline AP is deleted, the
associated controller is not deleted. Only
the AP is deleted.

Deleting an AP Online Online Delete option is not available.

Deleting an AP Offline Online Delete option is not available.

Deleting an AP Online Offline When an offline AP is deleted, the
associated controller is not deleted. Only
the AP is deleted.

Deleting multiple
controllers

Offline Offline When offline controllers are deleted, the
associated APs are also deleted
automatically.

Deleting multiple
controllers

Online Online Delete option is not available.

Table 183: Controller Delete Scenarios
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Action Controller
Status AP Status Action Result

Deleting multiple
controllers

Offline Few APs are offline
and few APs are
online

Delete action fails and a message is
displayed in the pop-up window.

Deleting multiple
controllers

Online Few APs are offline
and few APs are
online

Delete option is not available.

Deleting controller
through NBAPI

Offline Offline When an offline controller is deleted
through NBAPI, the associated APs are also
deleted automatically.

Deleting the
Controller through
NBAPI

Online Online Delete option is not available.

Verify deleting
options for RBAC
roles

Offline Offline Read-only access—Delete option is not
available for both AP and controller (built-
in and custom role)

Read and Write access—Deletes both
offline AP's and controllers ( built-in and
custom role)

Online Online Delete option is not available.

Creating a WebSocket Connection
WebSocket is a bi-directional communication protocol from a user's web browser to a server. The
WebSocket connection is required for upgrading firmware or troubleshooting AOS 8.x controllers.

WebSocket communications protocol is initiated by sending a WebSocket handshake request from a
browser's HTTP connection to a server to upgrade the connection. WebSocket endpoint and access
token is used to establish a WebSocket connection and start streaming data for the devices to which
you have enabled the subscription.

The following workflow explains the process to create a WebSocket connection for the AOS 8.x
controllers by installing a certificate:

1. Upload the certificate — The certificate for managed device (MD) or Mobility Conductor (MM) is
imported from the Mobility Controller WebUI and pending changes are saved.

2. Mapping the Certificate — Logon to MM and deploy the pending changes.

Uploading the MD certificate
All devices connect using the virtual IP address of the Aruba Central On-Premises cluster. All devices
contain the HPN Root CA in the trust store. The HPN Root CA validates the server certificate of Aruba
Central On-Premises cluster when connecting to the Aruba Central On-Premises using the virtual IP
address.

You cannot export certificates from the managed device.

To import a certificate into the managed device, complete the following steps:
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1. Login to the Mobility Controller WebUI.
2. In the Managed Network node hierarchy, navigate to the Configuration > System > Certificates

tab.
3. Expand the Import Certificates accordion.
4. In the Import Certificates table, click +.
5. For Certificate Name, enter a user-defined name.
6. For Certificate Filename, click Browse to navigate to the file on your computer.

If the certificate is encrypted, press Enter and repeat the passphrase.

7. From the Certificate Format drop-down list, select DER.
8. From the Certificate Type drop-down list, select TrustedCA.
9. Click Submit.

10. Click Pending Changes.
11. In the Pending Changes window, select the required check box and click Deploy Changes.

The certificate is added successfully.

If deployment fails, then retry the Deploy Changes step.

Mapping the Certificate
After importing the certificate, you must map the certificate to the managed device.

To map the certificate, complete the following steps:

1. Login to the Mobility Conductor.
2. Change the configuration node to the required managed device.
3. Execute aruba-central customca <certificate-name>.

For example, aruba-central customca Test-WI-cert.

Execute the following commands to map the certificate.

(CHN-8x-Test-MM1) *[mynode] #change-config-node /md

(CHN-8x-Test-MM1) *[md] # configure terminal

Enter Configuration commands, one per line. End with CNTL/Z

(CHN-8x-Test-MM1) *[md] (config) #aruba-central customca Test-WI-cert

(CHN-8x-Test-MM1) ^*[md] (config) # write memory

4. Write memory.
5. Login to the managed device.
6. Execute the show command to confirm that the changes are updated.

The following command confirms that the changes are updated.

(CHN-8x-Test-MD1)# show aruba-central

Aruba Central

-------------

Parameter Value

--------- -----

Aruba Central Connection Enabled
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Aruba Central Server aw10-testarea-3node-vip.arubathena.com

Trusted CA Cert Name Test-WI-cert

7. Logon to the MM and change the node to managed device to add the COP server.
8. Execute aruba-central server <serverip or hostname>.

The following command changes the node to the managed device.

(CHN-8x-Test-MM1) *[mynode] #change-config-node /md

(CHN-8x-Test-MM1) *[md] # configure terminal

Enter Configuration commands, one per line. End with CNTL/Z

(CHN-8x-Test-MM1) *[md] (config) # aruba-central server <server ip or

hostname>

(CHN-8x-Test-MM1) *[md] (config) # write memory

Saving Configuration...

Configuration Saved

The certificate is successfully added and the WebSocket connection is established.

The Controller Dashboard
In the Aruba Central On-Premises app, the controller dashboard is displayed when a controller is
selected. To navigate to a controller dashboard, see About the Aruba Central On-Premises App User
Interface.

The following table lists all the available menu items in the Aruba Central On-Premises app for the
controller dashboard.

Table 184: Contents of the Controller Dashboard

Left Navigation
Menu First-Level Tabs Description

Manage >
Overview

Summary The Summary tab displays the Controller Details and Health
Status.
For more information, see Controller > Overview > Summary.

Routing Displays a summary of the IP routes configured on the controller.
For more information, see Controller > Overview > Routing

Manage > LAN Summary Displays information about Port Status, LAN Interfaces Summary,
and VLAN Interfaces Summary. For more information, see
Controller > LAN > Summary.

Manage > Clients Clients Displays a list of clients connected to a controller.
For more information, see All Clients.

Analyze > Alerts
and Events

Alerts & Events The Alerts & Events tab displays details of the alerts and events
generated for the controller.
For more information, see Controller Alerts and Viewing Events
List View

Analyze > Audit
Trail

Audit Trail Displays the logs generated in Aruba Central On-Premises.
For more information, see Viewing Audit Trail.
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Left Navigation
Menu First-Level Tabs Description

Analyze > Tools Network Check Enables network administrators and users to identify, diagnose,
and debug issues detected by performing diagnostics tests on
devices and networks managed by Aruba Central On-Premises.
For more information, see Troubleshooting Controller
Connectivity Issues.

Commands The Commands tab allows network administrators and users with
troubleshooting permission to execute the CLI to validate the
details of the device.
For more information, see Troubleshooting Controllers and
Command Line Interface.

Analyze > Reports Reports Enables network administrators to create various types of reports.
You can create recurrent reports or configure the reports to run
on demand.
For more information, see Reports .

Maintain >
Firmware

List Provides an overview of the latest supported version of firmware
for the device, details of the device, and the option to upgrade.
For more information, see Upgrading Device Firmware.

Config Provides an upgrade status and compliance status for APs that are
connected to the selected controller.
For more information, see Upgrading Device Firmware.

Viewing the Controllers Tab
To view the Controller dashboard, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Click Devices > Controllers.

Controllers Dashboard
The Controllers dashboard page displays a complete list of offline or online controllers provisioned in
Aruba Central. You can also use the following filtering options to view a specific set of controllers.

n All—Displays a complete list of controllers. For more information, see Monitoring Controllers in List
View.

n Cluster—Displays controller clusters deployed in Aruba Central. A controller cluster includes multiple
controllers working together as a single managed entity. Controller clusters enable seamless roaming
of clients between AP and ensure service continuity in the event of a failover. Controller clustering is
supported only on devices running ArubaOS 8.x or later software versions. To view the cluster
components, expand the cluster in the Cluster Name column. For more information, see Monitoring
Clusters in List View.

n Mobility Conductor—Displays a list of controllers that are functioning as Mobility Conductors. The
Aruba Mobility Conductor is an advanced controller deployed as a virtual machine (VM) or installed
on an x86-based hardware appliance. A single Mobility Conductor or a cluster of Mobility Conductors
oversees co-located controllers. It also displays the details about the APs associated with each
controller. For more information, see Monitoring Mobility Conductors in List View.

#https://www.arubanetworks.com/techdocs/CLI-Bank/Content/landing-pages/cop-home.htm
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Monitoring Controllers in List View
The Controllers > All page provides information associated with the controllers provisioned and
managed in Aruba Central On-Premises.

To navigate to the Controllers > All page, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global. Ensure that the filter selected contains at
least one active controller.

The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Controllers.

By default, the All tab is displayed.

3. Click the All tab.

The Controllers > All page displays the following information:

n All—Displays the total number of controllers. When you click the All tab, it provides information
about all the controllers in the Controllers table.

n Online—Displays the total number of online controllers. When you click the Online tab, it provides
information about the online controllers in the Controllers table.

n Offline—Displays the total number of offline controllers. When you click the Offline tab, it provides
information about the offline controllers in the Controllers table.

Controllers Table
The Controllers table displays the following information:

n Controller Name—The name of the controller.

—Indicates that the controller is online.
—Indicates that the controller is offline.

n Mobility Conductor Name—The name of the Mobility Conductor.
n Cluster Name—The name of the cluster.
n AP—The table displays the following information related to the AP:

o Total—Total number of APs.
o Down—Total number of offline APs.
o Active—Total number of online APs.
o Standby—Total number of standby APs.

n Client—The number of clients connected to the controller.
n Model—The model number of the controller.
n Status—The status of the controller.
n IP Address—The IP address of the controller.
n MAC Address—The MAC address of the controller.
n Serial—The serial number of the controller.
n Group—The group to which the controller belongs.
n Labels—The labels associated with the controller. If multiple labels are associated with the

controller, hover over the label link to view all the labels.
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n Site—The site to which the controller belongs.
n Version—The version of the controller.

A search filter is provided only for the Controller Name, Model, IP Address, MAC Address, Serial, Group,
Labels, Site, and Version columns. By default, the Controllers table sorts the offline devices and then the
online devices.

Click the icon to customize the view of Controllers table with additional columns. Click the Reset to default
button provided in the drop-down list to reset the Controllers table with default columns only. To autofit the
columns, select Autofit columns.

To download the .csv file of the Controllers table, click the icon.

Monitoring Clusters in List View
The Controllers > Clusters page provides information associated with the Clusters provisioned and
managed in Aruba Central On-Premises.

To navigate to the Controllers > Clusters page, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global. Ensure that the filter selected contains at
least one active controller.

The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Controllers.

By default, the All tab is displayed.

3. Click the Clusters tab.

The Controllers > Clusters page displays the total number of Clusters. When you click the Clusters tab,
it provides information about all the Clusters in the Clusters table.

Clusters Table
The Clusters table displays the following information:

n Cluster Name—The name of the Mobility Conductor.

Click the icon to expand a cluster in the Clusters table. For more information, see Monitoring Controllers
in List View.

Click the icon to view the Overview > Summary details of the cluster.

n controller—The table displays the following information related to the controller:
o Total—Total number of controllers.
o Down—Total number of offline controllers.

n Client—The number of clients connected to the Cluster.
n Health Score—The health status of the Cluster.
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A search filter is provided only for the Cluster Name column.

Click the icon to customize the view of Clusters table with additional columns. Click the Reset to default
button provided in the drop-down list to reset the Clusters table with default columns only. To autofit the
columns, select Autofit columns.

To download the .csv file of the Clusters table, click the icon.

Monitoring Mobility Conductors in List View
The Controllers > Mobility Conductor page provides information associated with the Mobility
Conductors provisioned and managed in Aruba Central On-Premises.

To navigate to the Controllers > Mobility Conductor page, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global. Ensure that the filter selected contains at
least one active controller.

The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Controllers.

By default, the All tab is displayed.

3. Click the Mobility Conductor tab.

The Controllers > Mobility Conductor page displays the following information:

n Mobility Conductor—Displays the total number of Mobility Conductors. When you click the
Mobility Conductor tab, it provides information about all the Mobility Conductors in the Mobility
Conductor table.

n Online—Displays the total number of online Mobility Conductors. When you click the Online tab, it
provides information about the online Mobility Conductors in the Mobility Conductor table.

n Offline—Displays the total number of offline Mobility Conductors. When you click the Offline tab, it
provides information about the offline Mobility Conductors in the Mobility Conductor table.

Mobility Conductor Table
The Mobility Conductor table displays the following information:

n Mobility Conductor Name—The name of the Mobility Conductor.

—Indicates that the Mobility Conductor is online.
—Indicates that the Mobility Conductor is offline.

n Controller—The table displays the following information related to the controller:
o Total—Total number of controllers.
o Down—Total number of offline controllers.

n AP—The table displays the following information related to the AP:
o Total—Total number of APs.
o Down—Total number of offline APs.

n Role—The role of the Mobility Conductor.
n Client—The number of clients connected to the Mobility Conductor.
n Model—The model number of the Mobility Conductor.
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n Status—The status of the Mobility Conductor.
n IP Address—The IP address of the Mobility Conductor.
n MAC Address—The MAC address of the Mobility Conductor.
n Serial—The serial number of the Mobility Conductor.
n Group—The group to which the Mobility Conductor belongs.
n Labels—The labels associated with the Mobility Conductor. If multiple labels are associated with the

Mobility Conductor, hover over the label link to view all the labels.
n Site—The site to which the Mobility Conductor belongs.
n Version—The version of the Mobility Conductor.

A search filter is provided only for the Mobility Conductor Name, Role, Model, IP Address, MAC Address,
Serial, Group, Labels, Site, and Version columns. By default, the Mobility Conductor table sorts the offline
devices and then the online devices.

Click the icon to customize the view of Mobility Conductor table with additional columns. Click the Reset to
default button provided in the drop-down list to reset the Mobility Conductor table with default columns only.
To autofit the columns, select Autofit columns.

To download the .csv file of the Mobility Conductor table, click the icon.

Guided Steps for Replacing a Controller
Aruba Central On-Premises allows controllers, that is, managed devices and mobility conductors
replacement only through guided steps. The different scenarios of replacing a controller with minimum
disruption is explained in this topic.

The following scenarios explain the replacement of a managed device and mobility conductor:

n Managed Device Replacement in Aruba Central On-Premises
o Scenario 1—When the Old Managed Device is Offline and the New Managed Device is Online
o Scenario 2: When Both the Old and New Managed Devices are Online
o Scenario 3: When an Old Managed Device is Online in the Network and the New Managed Device

is Yet to be Replaced

n Mobility Conductor Replacement in Aruba Central On-Premises
o Scenario 1: Online Mobility Conductor Replacement - When Old and New Mobility Conductors are

Online
o Scenario 2: Standby Mobility Conductor Replacement - When Old Standby Mobility Conductor is

Offline and New Standby Mobility Conductor is Online
o Scenario 3: Standby Mobility Conductor Replacement - When Old Standby Mobility Conductor and

New Standby Mobility Conductor are Online on Aruba Central On-Premises

Managed Device Replacement in Aruba Central On-Premises
The following examples are scenarios for managed device replacement:

Scenario 1—When the Old Managed Device is Offline and the New Managed Device is
Online
To replace the managed device, complete the following steps:
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1. Ensure that the old managed device that you want to replace from the network is in the Offline
state and delete the corresponding managed device entry from the active Mobility Conductor.

2. Disable the auto-subscription for the managed device, if enabled.

3. Unassign the subscription for the old and new managed device.

4. Allow the managed device and its associated APs to change to Offline state.

5. Delete the offline old and new managed device listed in Devices > Controllers > All page.

The associated APs automatically gets deleted from the monitoring page in Devices > Access
Points > List.

6. Delete the offline old managed device and new managed device from the Device Inventory
page.

7. Delete the old and new managed devices controller profile in Devices > Auto-Provisioning >
Controller Profiles page.

8. The new managed device automatically gets discovered through the existing active Mobility
Conductor.

Do not add the managed device manually using Serial Number, MAC, or Part Number.

9. Controller profile automatically gets created for the new managed device.

10. Assign subscription to the new managed device either through auto-subscription or manual
subscription.

The APs associated to the new managed device automatically gets discovered. The new managed
device is displayed in Online state on sDevices > Controllers > All page and its associated APs is
displayed in Online state on Devices > Access Points > List.

Scenario 2: When Both the Old and New Managed Devices are Online
To replace the managed device, complete the following steps:

1. Bring down the old managed device that you want to replace from the network and delete it from
the active Mobility Conductor.

2. Disable the auto subscription for the managed device, if enabled.

3. Unassign the subscription for the old and new managed device.

4. Allow the managed device and its associated APs to change to the Offline state.

5. Delete the old and new managed device listed in Devices > Controllers > All page.

The associated offline APs automatically gets deleted from the monitoring page in Devices >
Access Points > List.

6. Delete the offline old and new managed device from the Device Inventory page.

7. Delete the old and new managed device controller profile in the Devices > Auto-Provisioning >
Controller Profiles page.

8. The new managed device automatically gets discovered through the existing active Mobility
Conductor.
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Do not add the managed device manually using Serial Number, MAC, or Part Number.

9. Controller profile automatically gets created for the new managed device.

10. Assign subscription to the managed device either through auto-subscription or manual
subscription.

The APs associated to the new managed device automatically gets discovered. The new managed
device is displayed in Online state on sDevices > Controllers > All page and its associated APs is
displayed in Online state on Devices > Access Points > List.

Scenario 3: When an Old Managed Device is Online in the Network and the New
Managed Device is Yet to be Replaced
To replace the managed device, complete the following steps:

1. Bring down the managed device that you want to replace from the network and delete from the
active Mobility Conductor.

2. Disable the auto-subscription for the managed device, if enabled.

3. Unassign the subscription for the old managed device.

4. Allow the managed device and its associated APs to change to the Offline state.

5. Delete the old managed device listed in Devices > Controllers > All page.

The associated APs automatically gets deleted from the monitoring page in Devices > Access
Points > List.

6. Delete the old managed device from the Device Inventory page.

Do not delete the old AP from the Device Inventory page.

7. Delete the old managed device controller profile in the Devices > Auto-Provisioning >
Controller Profiles page.

It is recommended to wait for 30 minutes before adding the new managed device to the network.

8. Add the new managed device to the network.

9. The new managed device automatically gets discovered through the existing active Mobility
Conductor on Aruba Central On-Premises.

Do not add the managed device manually using Serial Number, MAC, or Part Number.

10. Controller profile automatically gets created for the new managed device.

11. Assign subscription to the new managed device either through auto-subscription or manual
subscription.

The APs associated to the new managed device automatically gets discovered. The new managed
device is displayed in Online state on sDevices > Controllers > All page and its associated APs is
displayed in Online state on Devices > Access Points > List.
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Mobility Conductor Replacement in Aruba Central On-Premises
The following examples are scenarios for Mobility Conductor replacement:

Scenario 1: Online Mobility Conductor Replacement - When Old and New Mobility
Conductors are Online
To replace the mobility conductor, complete the following steps:

1. Ensure that the online old Mobility Conductor that you want to replace from the network is in the
Offline state.

2. Disable the auto subscription for the Mobility Conductor, if enabled.

3. Unassign the subscription for the following:

n Old and new online active Mobility Conductors.

n Standby Mobility Conductors.

n Associated Managed Devices and its APs.

4. Allow the old or new online active Mobility Conductors, standby Mobility Conductor, associated
managed devices, and associated APs to change to the Offline state.

5. Delete the offline managed device listed in Devices > Controllers > All page.

The associated APs automatically gets deleted from the monitoring page in Devices > Access
Points > List.

6. Delete the offline standby Mobility Conductors listed in Devices > Controllers > All page.

7. Delete the old or new offline active Mobility Conductors listed in Devices > Controllers > All
page.

8. Delete the old or new offline active Mobility Conductors, standby Mobility Conductors, and
associated managed devices in the Device Inventory page.

9. Delete the old or new offline Mobility Conductor, standby Mobility Conductor, and associated
managed devices' HTTPS and SNMP profiles in Devices > Auto-Provisioning > Controller
Profiles.

It is recommended to wait for 30 minutes before adding the new active Mobility Conductor to the
network.

10. Create new HTTPS and SNMP profiles for the new active Mobility Conductor in Devices > Auto-
Provisioning > Controller Profiles.

11. Add the new active Mobility Conductor to Aruba Central On-Premises using controller IP address
in Add Devices > Device Discovery.

The new online Mobility Conductor automatically gets discovered for the standby Mobility
Conductor and the associated managed devices in Aruba Central On-Premises.

You can find the controller IP address by executing the command, show controller-ip, and then,
select the SNMP profile and HTTPS profile details of a compatible device to begin the device discovery
process.
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12. Controller profile automatically gets created for standby Mobility Conductor and associated
managed devices.

13. Assign subscription for active and standby Mobility Conductors and its associated managed
devices either through auto-subscription or manual subscription.

The APs associated to the managed device automatically gets discovered. The new managed
device is displayed in Online state on Devices > Controllers > All page and its associated APs is
displayed in Online state on Devices > Access Points > List.

Scenario 2: Standby Mobility Conductor Replacement - When Old Standby Mobility
Conductor is Offline and New Standby Mobility Conductor is Online
To replace the Mobility Conductor, complete the following steps:

1. Ensure that the standby Mobility Conductor that you want to replace from the network is in the
Offline state and delete the corresponding standby Mobility Conductor entry from the active
Mobility Conductor.

2. Disable the auto-subscription for the Mobility Conductor, if enabled.

3. Unassign the subscription for the old and new standby Mobility Conductor.

Allow the standby Mobility Conductor to change to the Offline state.

4. Delete the old and new standby Mobility Conductors from the Devices > Controllers > All page .

5. Delete the old and new standby Mobility Conductor in the Device Inventory page.

6. Delete the old and new standby Mobility Conductor controller profile in the Devices > Auto-
Provisioning > Controller Profiles page.

7. The new standby Mobility Conductor auto discovers through the existing active Mobility
Conductor.

Do not add the standby Mobility Conductor manually using the Serial Number, MAC, or Part Number.

8. Controller profile automatically gets created for the new standby Mobility Conductor.

9. Assign subscription to the new standby Mobility Conductor after discovery either through auto-
subscription or manual subscription.

The new standby Mobility Conductor is displayed as Online in on the Devices > Controllers > All
page .

Scenario 3: Standby Mobility Conductor Replacement - When Old Standby Mobility
Conductor and New Standby Mobility Conductor are Online on Aruba Central On-
Premises
To replace the Mobility Conductor, complete the following steps:

1. Bring down the old standby Mobility Conductor that you want to replace from the network and
delete from the active Mobility Conductor.

2. Disable the auto-subscription for the Mobility Conductor, if enabled.

3. Unassign the subscription for the old and new standby Mobility Conductor.

Allow both the old and new standby Mobility Conductor to change to the Offline state.
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4. Delete the offline old and new standby Mobility Conductor from the Devices > Controllers > All
page.

5. Delete the offline old and new standby Mobility Conductor from the Device Inventory page.

6. Delete the old and new standby Mobility Conductor profiles from the Devices > Auto-
Provisioning > Controller Profiles page.

7. The new standby Mobility Conductor auto discovers through the existing Mobility Conductor on
Aruba Central On-Premises.

Do not add the standby Mobility Conductor manually using the Serial Number, MAC, or Part Number.

8. Controller profile automatically gets created for the new standby Mobility Conductor.

9. Assign subscription to the new standby Mobility Conductor after discovery either through auto-
subscription or manual subscription.

The new standby Mobility Conductor is displayed as Online under Devices > Controllers > All.

Post Replacement Guidelines
The following guidelines are recommended after the managed device or Mobility Conductor
replacement:

n After replacing he controller, ensure to reassign the device to the required group or site or label.

n Enable the auto-subscription for controller and AP, as required.

Controller > Overview > Summary
The Summary tab under Manage > Overview in the controller dashboard displays the following two
sections:

n Device Info
n Health Status

Viewing the Overview > Summary Tab
To navigate to the Summary tab in the controller dashboard, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. Ensure that the filter selection contains at least one controller. For all devices,
set the filter to Global.
The dashboard context for the selected filter is displayed.

2. Under Manage > Devices, click the Controllers tab.

A list of controllers is displayed.

3. Click a controller or cluster under Device Name.

The dashboard context for the specific controller or cluster is displayed.

4. Under Manage, click Overview > Summary.

To exit the controller dashboard, click the back arrow on the filter.

You can change the time range for the Summary tab by clicking the time range filter and
selecting one of the available options: 3 hours, 1 day, 1 week, 1 month, and 3 months.
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Device Info
The Device Info section displays the following details.

Figure 97 Device Info

n Name—The name of the controller.

n Serial Number—Serial number of the controller.
n Model—The hardware model of the controller.
n MAC Address—The MAC address of the controller.
n System IP address—The IP address of the controller.
n Firmware Version—The firmware version running on the controller. If a new version of the firmware

is available, this information is also displayed. Clicking on the new firmware version redirects you to
the Maintain > Firmware > controller page in the controller dashboard, where you can select the
controller to upgrade it.

n Group Name—The name of the group, if the controller is configured as part of a group. Click the
group name to go to the Overview > Summary page for that group.

n Labels—The name of the label, if the controller is configured as part of a single or multiple labels.
n Site—The name of the site, if the controller is configured as part of a site. Hover over the i icon to

display the complete address of the site. Click the site name to go to the Overview > Site Health page
for that site.

n Role— The role of the controller; for example, conductor or local.
n Conductor— The name of the conductor controller.
n Last Reboot Reason—The reason for the last reboot.
n POE (DRAW/MAX)—The amount of power that the devices connected to the controller consume and

the maximum PoE power capacity. For example, if the value displayed is 6/120, the devices draw 6
watts and the maximum PoE power allocated is 120 watts.

n Redundancy Peer—Displays the redundant controller if it is configured.
n NTP Server—The name of the NTP server configured and its synchronization status.
n Cluster Name—The name of the cluster controller.
n 4G/LTE Modem Status—Displays the modem connectivity status. The status shows only 'Connected'

when the modem type is not internal.
n 4G/LTE Modem Type—Displays the LTE connection type.

n Location—The currently configured physical location of the controller. Location details are displayed
only for controllers running on firmware version ArubaOS 8.9.0.0 or later.
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n Contact—The currently configured contact information of the controller. For example, E-mail ID or
contact number. Contact details are displayed only for controllers running on firmware version
ArubaOS 8.9.0.0 or later.

n Last Contacted—The date and time when the controller last contacted Aruba Central On-Premises.
n Uptime—The time since the last boot denoted in hours and minutes.

Health Status
The Health Status section displays the health of the controller in terms of CPU, Memory and device
connectivity to Aruba Central On-Premises.

The health status is plotted using health indicators such as Good, Fair, Poor and Offline. You can hover
over the chart to see the health status for a particular time frame.

The following image indicates the health status of the controller.

Figure 98 Health Status

Controller > Overview > Routing
The Routing tab under Manage > Overview in the controller dashboard displays the following
sections:

n Routes Summary
n Routes

The details are displayed on the Routing page only if the routing is configured for the controller.

Displays a summary of the IP routes configured on the controller. The following details are displayed:

n Type—The type of IP route.
n Network—IP address of the destination network.
n VIA—IP address through the routes are forwarded.

Viewing the Overview > Routing Tab
To navigate to the Routing tab in the controller dashboard, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. Ensure that the filter selection contains at least one controller. For all devices,
set the filter to Global.
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The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Controller .

A list of controllers is displayed.

3. Click a controller or cluster under Device Name.

The dashboard context for the specific controller is displayed.

4. Under Manage, click Overview > Routing .

To exit the controller dashboard, click the back arrow on the filter.

You can change the time range for the Routing tab by clicking the time range filter and selecting
one of the available options: 3 hours, 1 day, 1 week, 1 month, and 3 months.

Controller > LAN > Summary
The Summary tab under Manage > LAN page in the controller dashboard displays the following
sections:

n Port Status
n LAN Interfaces Summary
n VLAN Interfaces Summary

Viewing the LAN > Summary Tab
To navigate to the LAN > Summary tab in the controller dashboard, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. Ensure that the filter selection contains at least one controller. For all devices, set
the filter to Global.
The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Controller.
A list of controllers is displayed.

3. Click a controller or cluster under Device Name.

The dashboard context for the specific controller is displayed.

4. Under Manage, click LAN > Summary.

To exit the controller dashboard, click the back arrow on the filter.

You can change the time range for the Summary tab by clicking the time range filter and
selecting one of the available options: 3 hours, 1 day, 1 week, 1 month, and 3 months.

Port Status
Provides a graphical representation of the controller's LAN link availability. Also provides a quick view of
the LAN port status. Click a LAN port to view the port detail graphs based on Packets or Errors.

Figure 99 Port Status

The following graphs are displayed under the Packets tab:
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n Unicast—The number of unicast packets per second.
n Multicast—The number of multicast packets per second.
n Broadcast—The number of broadcast packets per second.

LAN Interfaces Summary
n The table displays the summary of LAN interfaces total number of LAN interfaces. The following

details are displayed for the port:

n Port—Port number.
n Admin State—Administrative state of the LAN interface.
n Operational State—Operational state of the LAN interface.
n Port Speed—Port speed.
n VLANs—Range of VLANs.
n MTU—MTU value.

Figure 100 LAN Interface Summary

Click a LAN port to view the port detail graphs based on Packets or Errors.
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Figure 101 Port Details - Packet

The following graphs are displayed under the Errors tab:

n CRC Errors—The number of cyclic redundancy errors logged.
n Error Frames—The number of error frames logged.
n Collisions—The number of collisions encountered.
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Figure 102 Port Details - Errors

VLAN Interface Summary
n The table displays the summary of VLAN interfaces and total number of VLAN interfaces. The

following details are displayed:

n VLAN ID—VLAN ID number.
n IP Address—IP address.
n Admin State—Administrative state of the VLAN interface.
n Oper. State—Operational state of the VLAN interface.
n Addressing Mode—Type of addressing mode.
n Description—Description of the VLAN.

Figure 103 VLAN Interfaces Summary
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Support for Third-Party Devices

Aruba Central On-Premises supports adding and monitoring third-party devices.

Aruba Central On-Premises currently supports the following third-party devices:

n Cisco Catalyst 9200 series switches

n Cisco Catalyst 9300 series switches

To onboard third-party switches in HPE GreenLake Account Home, follow this workflow:

1. Add Subscriptions.

2. Add an SNMP profile.

3. Create a .csv file and onboard the third-party devices.

4. Filter the onboarded third-party devices.

The onboarding of Cisco switches may take up to 15 minutes.

Adding Subscriptions
A new subscription key is supported for third-party devices with Device Type, NW_Third_Party and Tier,
Foundation-NW-Third-Party.

To add subscriptions, see Managing Device Subscriptions.

Adding an SNMP Profile
You can use auto-provisioning to add and manage various SNMP profiles. These pre-defined profiles
and keys make it easier to manage device onboarding during the device discovery process. The
SNMP profile created must be added in the CSV file, that is used to onboard devices.

To add an SNMP profile, see Managing Device Profiles .

Creating CSV File and Onboarding Third-Party Devices
You can onboard third-party devices by uploading a CSV file in the Device Inventory. To onboard third-
party devices, complete the following steps:

1. Create a .csv file with the following parameter details:

a. HostName—Host name of the Cisco switches.

b. IP_Address—IP Address of the Cisco switches.

c. MAC_Address—MAC Address of the Cisco switches.
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d. Serial_No—Serial number of the Cisco switches.

e. SNMP_Profile—The SNMP Profile details of the Cisco switches.

2. In HPE GreenLake, navigate to Devices > Inventory.

3. Click Add Devices.

4. Select the Third-Party .CSV File option.

5. Click the Select File option to upload the .csv file.

6. Click Finish.

The CSV file is uploaded, and the devices are added to the Device Inventory.

Filtering Third-Party Devices
You can search and list the third-party devices that are onboarded. To filter third-party devices,
complete the following steps:

1. In HPE GreenLake, navigate to Devices > Inventory.

2. Click Total Devices.

The Filter pop-up box is displayed.

3. Select Third Party option for the Device Type.

4. Select Show All Devices option for Archived Devices Visibility.

5. Click Apply Filters.

The Inventory page displays the number of devices that are added as third-party devices, with
details on each device.

Supported Number of Third-Party Devices
The following table lists the maximum number of third-party devices that Aruba Central On-Premises
supports across multiple nodes.

Node Size
Third-Party Switches

(Cisco 9200 and 9300 series)

Single Node 75

Three Node 250

Five Node 500

Seven Node 750

Table 185: Supported Third-Party Devices based on the
Deployment Types

Monitoring Third-Party Devices
The switch dashboard allows you to monitor third-party devices, such as Cisco 9200 and 9300 series
switches through Aruba Central On-Premises.
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To view third-party switches in the monitoring pages, you must first onboard the devices in HPE GreenLake
Account Home. For more information, see Support for Third-Party Devices.

To navigate to the dashboard for third-party switches, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

3. Click a third-party switch listed under Device Name.

The dashboard context for the specific switch is displayed.

The following table lists all the available menu items in the Aruba Central On-Premises app for the
third-party switch dashboard.

The Actions drop-down list is not available for third-party devices in the switch dashboard.

Left
Navigation
Menu

First-Level Tab Description

Manage >
Overview

Summary Displays details about a specific switch, including device information,
network summary, and port and hardware status. The Summary
tab also displays details on client data traffic usage and switch stack
members. Use the time range filter to change the time period for
the displayed information.
For more information, see Switch > Overview > Summary.

Hardware Displays switch hardware details, including status of power supplies
and fans, CPU and memory utilization, and device temperature. Use
the time range filter to change the time period for the displayed
information.
For more information, see Switch > Overview > Hardware.

Manage >
Neighbors

Neighbors Displays details about the devices neighboring the switch. Use the
time range filter to change the time period for the displayed
information.
For more information, see Switch > Neighbors > Neighbors.

Manage > LAN Ports Displays details about ports and the LAGs configured on the switch.
Use the time range filter to change the time period for the displayed
information.
For more information, see Switch > LAN > Ports.

VLAN Displays VLAN information configured on the switch along with
details about tagged and untagged ports. Use the time range filter
to change the time period for the displayed information.
For more information, see Switch > LAN > VLAN.

Table 186: Third-Party Switch Dashboard
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Left
Navigation
Menu

First-Level Tab Description

Analyze >
Alerts

Alerts Displays all types of alerts generated for events pertaining to device
provisioning, configuration, and user management. For more
information, see Third-Party Device Alerts.

Analyze >
Audit Trail

Audit Trail Displays the details of logs generated for all device management,
configuration, and user management events triggered in Aruba
Central On-Premises. Use the time range filter to change the time
period for the displayed information.
For more information, see Viewing Audit Trail.

Analyze >
Reports

Reports The Reports tab allows you to create, manage, and view various
reports. You can create recurrent reports, generate reports on
demand, or schedule reports to run at a later time.
For more information, see Third-Party Device Reports.

Switch > Neighbors > Neighbors
In the switch dashboard, the Neighbors tab displays details about the neighboring devices on AOS-S,
AOS-CX, and third-party switches.

Viewing the Neighbors > Neighbors Tab
To navigate to the Neighbors tab in the switch dashboard, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global. Ensure that the filter selected contains at
least one active switch.

The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

3. Click a switch listed under Device Name.

The dashboard context for the specific switch is displayed.

4. Under Manage, click Neighbors.

The Neighbors tab is displayed.

5. To exit the switch dashboard, click the back arrow on the filter.

You can change the time range for the Neighbors tab by clicking the time range filter and
selecting one of the available options: 3 hours, 1 day, 1 week, 1 month, or 3 months.

Neighbor Devices
The Neighbors tab displays the following details:

n MAC Address—Displays the MAC address of the neighboring device.
n Hostname—Displays the hostname of the neighboring device.
n IP Address—Displays the IP address of the neighboring device.
n Description—Displays the description of the neighboring device.
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n Local Port—Displays the local port number of the neighboring device.
n Remote Port—Displays the remote port number of the neighboring device.
n Capabilities—Displays the capabilities of the neighboring device.
n VLAN ID(s)—Displays the VLAN IDs of the neighboring device.

The Actions drop-down list is not available for third-party devices in the switch dashboard.

Third-Party Device Alerts
Aruba Central On-Premises allows network administrators and users with admin permissions to
configure alerts. For more information, see Configuring Alerts.

Following are the AOS-S switch alerts that you can configure:

To enable or disable all the switch alerts on a single click, you can use the Enable All or Disable All button
respectively.

The following are the third-party device alerts that you can configure:

n New Switch Connected—Generates an alert when a new switch is connected.

n Stack Member Added/Removed—Generates an alert when a stack member is added or removed.
This alert is enabled by default and the alert severity is Major.

n Switch CPU Utilization—Generates an alert when the switch CPU utilization exceeds the threshold
value. In the Duration field, enter the duration after which the alert must be generated. You can add
additional rule(s) for this alert.

n Switch Stack Conductor Change—Generates an alert when there is a change in Stack conductor.
This alert is enabled by default and the alert severity is Major.

For more information, see the following sections:

n Alerts and Events
n Viewing Alerts in List view
n Viewing Alerts and Events in Summary view
n Viewing Events List View
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Figure 104 Third-Party Device Alerts Page

Third-Party Device Reports
The Reports dashboard in the context of a third-party device enables you to create, generate, and
schedule reports. To create a report, you must have Read/Write or Admin access.

The Client Usage report in the Analyze > Reports page generates an empty document for third-party devices.
This is because wired clients are not supported for third-party devices.

The following reports under the Infrastructure category are available for third-party devices:

n Capacity Planning—Provides information about the subscription utilization and most used devices
in the network that assists the administrator to add more devices in a specific location to enhance
the scalability and to increase the uplink capacity of the switching infrastructure.

n Infra Inventory—Provides information about the inventory and subscription for the devices that are
online or offline during a specific time period. It has a consolidated summary of each device type
with its model name and corresponding count for each site.

n Network—Provides the summary details of the network that aids in measuring the availability of a
device in the network and projects compliance to the defined Network SLAs.

n Switch Capacity Planning—Provides insights on the used and unused ports along with power
consumed by clients to help planning the scalability.

For more information, see the following sections

n Reports
n Report Categories
n Report Configuration Options
n Previewing a Report
n Creating a Report
n Editing a Report
n Viewing the Generated Report
n Viewing the Scheduled Report
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n Downloading a Report
n Deleting a Report

Figure 105 Third-Party Device Reports Page
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Monitoring Your Network

This section describes the various options available for viewing the device, client and network details.

Network Overview
In the Aruba Central On-Premises app, complete the following steps to access the overall network
summary page:

1. Set the filter to Global.
The Global dashboard is displayed.

2. Under Manage > Overview, the network summary page displays the following tabs:
n Network Health—Displays vital information of the network sorted by site. For more

information, see Network Health.
n Summary—Displays details such as the bandwidth usage in the network, client counts, and

cluster-specific details. For more information, see Global—Summary.

Monitoring Access Points
The access point (AP) dashboard enables you to manage, configure, monitor and troubleshoot APs
provisioned and managed through Aruba Central On-Premises.

For a list of all the available menu items in the AP dashboard, see The Access Point Dashboard.

The AP Health Bar provides a snapshot of the overall health of the APs configured in Aruba Central On-
Premises. For more information, see Health Bar Dashboard for Access Point.

The AP Foundation license is applicable for Access Point Monitoring.

Monitoring Access Points in Summary View
The access point (AP) Summary page provides all the metrics about the health, status, and clients
information associated with the AP provisioned and managed in Aruba Central On-Premises.

To navigate to the AP Summary page, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global. Ensure that the filter selected contains at
least one active AP.

The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click the Summary icon.

The AP Summary page is displayed.

The AP Summary page displays the following information:

Aruba Central On-Premises 2.5.7 | User Guide 811



Monitoring Your Network | 812

n Access Points—Displays the overall usage metrics for the APs provisioned in your Aruba Central On-
Premises account. Consists of the following tabs:
o Usage—Displays the incoming and outgoing data traffic detected on the APs.
o Total Clients—Displays the number of clients connected to an AP over a specific time period.
o Bandwidth Usage Per Network—Displays the incoming and outgoing traffic for all APs per SSID

over a specific duration.
o Client Count Per Network—Displays the number of clients connected to an AP per SSID over a

specific time period.

You can change the time range for the AP Summary page by clicking the time range filter and
selecting one of the available options: 3 hours, 1 day, 1 week, 1 month, and 3 months.

Monitoring Access Points in List View
The access point (AP) List view page provides information associated with the online and offline APs,
radios provisioned, and managed in Aruba Central On-Premises.

To navigate to the AP List view page, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups, Labels,
or Sites. For all devices, set the filter to Global. Ensure that the filter selected contains at least one
active AP.

The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

The AP List view page displays the following information:

n Access Points—Displays the total number of APs. When you click the Access Points tab, it provides
information about all APs in the Access Points table. For more information, see Access Points Table.

n Online—Displays the total number of online APs. When you click the Online tab, it provides
information about the online APs in the Access Points table.

n Offline—Displays the total number of offline APs. When you click the Offline tab, it provides
information about the offline APs in the Access Points table.

n Radios—Displays the total number of radios. When you click the Radios tab, it provides information
about all radios in the Radios table.
o 2.4 GHz—Displays the total number of 2.4 GHz radios. When you click the 2.4 GHz tab, it provides

information about 2.4 GHz radios in the Radios table.
o 5 GHz—Displays the total number of active 5 GHz and 5 GHz (Secondary) radios. When you click

the 5 GHz tab, it provides information about 5 GHz and 5 GHz (Secondary) radios in the Radios
table.

o 6 GHz—Displays the total number of 6 GHz radios. When you click the 6 GHz tab, it provides
information about 6 GHz radios in the Radios table.
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n The tri-radio feature is available only for AP-555. In the 5 GHz tab, the Radio 5 GHz (Secondary) data
is available only if the tri-radio mode is enabled. For more information, see About Tri-Radio Mode.

n The 6 GHz radios is only supported for devices with 6 GHz capability. For more information about the
APs that supports 6 GHz, see Supported APs.

Access Points Table
In the Access Points table, you can view and perform the following:

Figure 106 Access Points Table Parameter Descriptions

Parameter Description

Device Name Displays the name of the AP.

Status Displays the operational status of the AP. The status is as follows:

n Online—Indicates that the AP is online.

n Offline—Indicates that the AP is offline.

n Online—Indicates that the AP is operating under thermal management. For more
information, see Thermal Shutdown Support in Instant Access Points.

IP Address Displays the IP address of the AP.

Model Displays the model number of the AP.

Serial Displays the serial number of the device.

Firmware
Version

Displays the firmware version running on the AP.

Clients Displays the clients connected to the AP.

Alerts Displays the opens alerts related to APs.

MAC Address Displays the MAC address of the AP.

Controller Displays the name of the controller.

Secondary
Controller

Displays the name of the secondary controller.

Config Status Displays the configuration changes associated with the AP. The Config Status column is not
supported in the exported CSV file.

Group Displays the group to which the AP belongs.

Labels Displays the labels associated with the AP. If multiple labels are associated with the AP, hover
over the label link to view all the labels.

Site Displays the site to which the device belongs.
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Parameter Description

Uptime Displays the time since when the device is operational. The Uptime column is not applicable
for offline devices and remains blank for all the devices in the Offline page.

Last Seen Displays the last active time and date of the device. The Last Seen column is not applicable
for online devices and remains blank for all the devices in the Online page.

Public IP Displays the IP address logged by servers when the device is connected through internet
connection.

Persona Displays the type of role of the AP. For example, Campus AP and IAP.

LLDP
Neighbor

Displays the name of the LLDP neighbor. Click the LLDP Neighbor name to view the switch
details page, if the switch is managed by Aruba Central On-Premises.

LLDP Port Displays the port number of LLDP neighbor.

AI Insights Displays the number of insights generated for the AP in the last three hours. The AI Insights
column is not supported in the exported CSV file.

Note Displays the information captured in the Note parameter, in the AP Details section. The
search filter allows you to search for exact and partial text search with prefix. The text search
with suffix is not supported.

Zone Displays the zone to which the AP belongs. Zone details are displayed in the column only for
APs with firmware version ArubaOS 8.7.0.0 or later.

Controller AP
Group

Displays the name of the Controller AP group.

Click the icon to delete an offline AP. For more information, see Deleting an Offline AP.

Click the icon to reboot an AP. For more information, see Rebooting an Access Point in the List
View.

Click the icon to download the .csv file of the AP list table. For more information, see
Downloading the AP List View Table .
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n From Aruba Central On-Premises 2.5.4 release, LLDP Neighbor and LLDP Port details are also available
for Campus APs, Remote APs and not only Instant APs.

n A search filter is provided only for the Device Name, IP Address, Model, Serial, MAC Address,
Controller, Secondary Controller, Group, Labels, Site, LLDP Neighbor, Note, and Zone columns. The

and icons allow you to sort the Device Name, IP Address, Serial, MAC Address, Controller,
Secondary Controller, and Zone columns in an ascending and descending order.

n By default, the AP List table displays the Device Name, Status, IP Address, Model, Serial, and Firmware
Version. You can customize the view of AP List table with additional columns such as the Clients, Alerts,
MAC Address, Controller, Secondary Controller, Config Status, Group, Labels, Site, Uptime, Last
Seen, Public IP, Persona, LLDP Neighbor, LLDP Port, AI Insights, Note, and Zone. These additional
columns can be selected by clicking the icon provided at the right corner of the table that displays the AP
list. Click the Reset to default button provided in the drop-down list to reset the AP List with default
columns only. To autofit the columns, click the icon and select Autofit columns.

Downloading the AP List View Table

To download the .csv file of the AP list table, click the icon. If the table contains unicode value, you
must use a UTF-8 enabled software to view the contents. To view the file in Microsoft Excel spreadsheet
software, perform the following steps to view table with unicode values:

1. Open the Microsoft Excel software.
2. Click on the Data menu bar option.
3. Click on the From Text icon.
4. Browse to the location of the file that you want to import.
5. Select the file name and click Import.
6. The Text Import wizard is displayed.
7. Select the file type. For .csv format, select the Delimited option.
8. Select the 65001: Unicode (UTF-8)option from the drop-down list that is displayed next to the

File origin.
9. Click Next. The Text ImportWizard-Step 1 of 3 page is displayed.

10. Place a check mark next to the delimiter such as the comma or full stop that was used in the file
you wish to import into Microsoft Excel.

11. The Data Preview window displays the data based on the selected delimiter.

12. Click Next. The Text ImportWizard-Step 3 of 3 page is displayed. Select the appropriate data
format for each column that you want to import.

Importing one or more columns is optional.

13. Click Finish to import the data into Microsoft Excel.
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Radios Table
When you click the Radios, 2.4 GHz, 5 GHz, and 6 GHz tab on the Radios list page, the respective
tables with the following columns are displayed:

Figure 107 Radios Table Parameter Descriptions

Parameter Description

Device Name Displays the name of the AP.

NOTE: The online radios are displayed with a green dot and offline radios are displayed
with a red dot.

Radio MAC
Address

Displays the MAC address of the radios connected to the AP.

Band Displays the type of radio band. For example, 2.4 GHz, 5 GHz, and 5 GHz (Secondary), and 6
GHz.

NOTE: The tri-radio feature is available only for AP-555. In the Band column, the Radio 5 GHz
(Secondary) data is available only if the tri-radio mode is enabled. For more information, see
About Tri-Radio Mode.

NOTE: The 6 GHz radios is only supported for devices with 6 GHz capability. For more
information about the APs that supports 6 GHz, see Supported APs.

Bandwidth Displays the bandwidth of data transferred through the radios.

Channel Displays the channels assigned for the radios.

Utilization (%) Displays the percentage of time (normalized to 255) that the channels of the radios are
sensed to be busy. The AP uses either the physical or the virtual carrier sense mechanism to
sense a busy channel. This percentage not only depends on the data bits transferred but also
with the transmission overhead that makes use of the channel.

Power (dBm) Displays the transmit power of the radios measured in decibels.

Noise Floor
(dBm)

Displays the The noise at the radio receivers of the radios. Along with the thermal noise,
Noise Floor may be affected by certain types of interference sources, though not all
interference types result in increased noise floor. Noise Floor value may vary depending on
the noise introduced by components used in the computer or client device.

n A search filter is provided only for the Access Point column.
n If the Radios list has at least one IAP, Campus AP, or Remote AP that supports the 6 GHz radio band, then

the 6 GHz tab will be available on the Radios list page.

Deleting an Offline AP
To delete an offline access point (AP), complete the following steps:
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1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global. Ensure that the filter selected contains at
least one active AP.

The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. In the Access Points table, hover over the offline AP that you want to delete.

4. Click the delete icon.

To delete multiple offline APs, select the offline APs that you want to delete and click the delete
icon.

5. Click Delete in the confirmation dialog box.

Rebooting an Access Point in the List View
You can reboot an Instant Access Point, Campus Access Point, or Remote Access Point using the Aruba
Central On-Premises UI.

To reboot an access point (AP) from the List view page, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under groups, labels,
or sites. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.

n You can reboot only the APs that are in the online status (active).
n A WebSocket connection is required to reboot IAPs, Campus APs, and Remote APs.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. In the Access Points table, hover over the AP that you want to reboot.

4. Click the reboot icon.

To reboot multiple online APs, select the APs that are in online status and click the reboot icon.

5. Click Reboot in the confirmation dialog box.

You can also reboot an AP from the Details page, see Rebooting an AP in the Details Page.

Rebooting an AP in the Details Page
You can reboot an Instant Access Point, Campus Access Point, or Remote Access Point using the Aruba
Central On-Premises UI.

A WebSocket connection is required to reboot IAPs, Campus APs, and Remote APs.
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For information about how to reboot an AP in the List view, see Rebooting an Access Point in the List
View.

To reboot, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under groups, labels,
or sites. For all devices, set the filter to Global. Ensure that the filter selected contains at least one
active AP.

The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click an AP listed under Device Name.

The dashboard context for the AP is displayed.

4. In the Actions drop-down list, click Reboot AP.

A Reboot dialog box is displayed.

5. Click Reboot to reboot the AP.

The AP dashboard takes approximately a minute to update the interface status, after the AP is rebooted and
reconnected to Aruba Central On-Premises.

Thermal Shutdown Support in Instant Access Points
Aruba AP-555 and AP-535 Instant Access Point (IAP) devices are equipped with an internal thermal
sensor. The sensor initiates a shutdown when the operating temperature crosses the temperature
threshold recommended for an Instant AP. When an IAP operates under thermal management, all the
radios are in Disabled mode in the AP Health Bar.

In Aruba Central On-Premises, the thermal shutdown feature is supported on IAPs running Aruba Instant
8.6.0.0 or later versions.

About Tri-Radio Mode
Aruba Central On-Premises offers tri-radio mode support in Aruba AP-555, a flagship 802.11ax access
point (AP). In tri-radio mode or split 5 GHz mode, the 8x8 5 GHz radio is split into two independent 4x4 5
GHz radios. In the split 5 GHz Mode, Radio 5 GHz Secondary operates on channels from 36 to 64 and
Radio 5 GHz operates on channels from 100 to 165.

To enable tri-radio, go to Access Points > Radio in the IAP configuration dashboard, and select the Split
Radio check-box.

Tri-radio mode is only available for IAPs and not for Campus APs and Remote APs.

The split 5 GHz radio can operate in the following modes:

n Access
n Monitor
n Spectrum
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Enabling Tri-Radio Mode

To enable the tri-radio mode, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a group in the filter:

a. Set the filter to one of the options under Groups. Ensure that the filter selected contains
at least one active access point.

The dashboard context for the group is displayed.

b. Under Manage, click Devices > Access Points.

A list of access points is displayed in the List view.

n To select an access point in the filter:
a. Set the filter to Global.
b. Under Manage, click Devices > Access Points.

A list of access points is displayed in the List view.

c. Click an access point listed under Device Name.

The dashboard context for the access point is displayed.

d. Under Manage, click Devices > Access Point.

2. Click the Config icon.

The tabs to configure access points are displayed.

3. Click the Access Points tab.

The Access Points page is displayed.

4. To edit an AP, select an AP in the Access Points table, and then click the edit icon.
5. Click Radio.
6. Select the Split Radio check-box.
7. Click Save Settings.

Viewing Tri-Radio Events
To view the tri-radio events, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a group, label, site, or all devices in the filter:

a. set the filter to one of the options under Groups, Labels, or Sites. For all devices, set the
filter to Global.

The dashboard context for the selected filter is displayed.
n To select a device in the filter:

a. Set the filter to Global.
b. Under Manage, click Devices, and then click Access Points.
c. A list of APs is displayed in the List view.
d. Click an AP listed under Device Name.

The dashboard context for the AP is displayed.

2. Under Analyze, click Alerts & Events.The Alerts & Events page is displayed in the List view.
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3. Click the Events tab.

A list of events is displayed in the Events table.

When the tri-radio mode is either enabled or disabled in an AP, the Events table displays the following
details:

n The Event Type column includes the AP Tri-Radio type which can be used to filter tri-radio events.
n The Description column includes the status of the tri-radio mode in AP.

In Aruba Central On-Premises, the tri-radio feature is available only on AP-555 running Aruba Instant 8.6.0.0 or
later versions.

By default, the AP-555 operates in dual radio mode.

Viewing the Summary Tab
In the access point (AP) dashboard, the Summary tab displays the device details, network information,
radio details including the topology of clients connected to each radio, and the health status of the AP in
the network.

To navigate to the Summary tab, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups, Labels,
or Sites. For all devices, set the filter to Global. Ensure that the filter selected contains at least one
active AP.

The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click an AP listed under Device Name.

The Summary tab is displayed.

To exit the AP dashboard, click the back arrow on the filter.

You can change the time range for the Summary tab by clicking the time range filter and
selecting one of the available options: 3 hours, 1 day, 1 week, 1 month, and 3 months.

The Summary tab displays the following sections:
n Device
n Network
n Radios
n Data Path
n Health Status
n WLANS
n Actions
n Go Live
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Device

The Device section displays all or some of the following details:

n AP Model—The AP hardware model.
n Country Code—Country code in which the AP operates.
n MAC—MAC address of the AP.
n Serial Number—Serial number of the AP.
n Uptime—Time since when the AP is operational.
n Last Reboot Reason—The reason for the latest rebooting of AP.
n Firmware Version—The firmware version running on the AP. If the device is running an older

firmware version, this field prompts the user to upgrade to the latest firmware version along with the
link to the Maintenance > Firmware page.

n Configuration Status—Displays the configuration status and the timestamp of the last device
configuration changes.

n Band Selection—Displays the operating band of the AP. The supported bands are Dual Band, Dual
5 GHz, Tri-Radio, or Tri Band.

n Power Draw—The power utilized by the device in watts (W) or kilowatts (kW).
n Power Negotiation—The power in watts (W) negotiated on the ethernet port of the device in a wired

network.
n Recommended Power—The recommended power in watts (W) negotiated on the ethernet port of

the device in a wired network.
n Controller—The name of the controller.
n Secondary Controller—The name of the secondary controller.

n Group—The group to which the AP belongs. Click the group name to go to the Overview >
Summary page for that group.

When an AP belongs to an unprovisioned group, the hyperlink to the unprovisioned group is disabled

n Labels—The labels associated with the AP. You can also add a new label to the AP by clicking the edit
icon. To view all the labels associated with a device, hover your mouse over the Labels column.

n LEDs on Access Point—Enables the blinking of LEDs on the APs to identify the location. Click Blink
LED to enable the blinking of LEDs on the AP. The default blinking time is set to 5 minutes and it
stops automatically after 5 minutes. To stop the blinking, click Stop Blinking.

A WebSocket connection is required to enable Blink LED.

n Site—The site to which the AP belongs. Click the site name to go to the Overview > Site Health page
for that site.

n Location—The currently configured physical location of an AP. Location detail is displayed only for
APs with firmware version ArubaOS 8.9.0.0 or later.

n Contact—The currently configured contact of an AP. For example, E-mail ID, or contact number.
Contact detail is displayed only for APs with firmware version ArubaOS 8.9.0.0 or later.

n Controller AP Group—Displays the name of the Controller AP group.
n Note—When you click the edit icon, a text-box is displayed. It allows you to add information that

can be used as reference. For example, AP location, and upgrade information.
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n From Aruba Central On-Premises 2.5.6 release, Country Code, Last Reboot Reason, Power Draw, and
Power Negotiation details are supported for Campus APs and Remote APs as well.

n Recommended Power is only available for IAPs and not for Campus APs and Remote APs.
n Recommended Power is supported on IAPs from ArubaOS 8.4.0.0 version onwards, and the

Recommended Power will not be available on the Device page if the IAP is already running on
recommended power.

Network

The Network section displays information of the network and interfaces to which the AP is connected.
Along with the network profile name, the following fields are displayed in the Network section:

n ETH0—Displays the status of the ETH0 network.
n Speed (Mbps)/Duplex—The speed of the network measured in Mbps. This field also indicates

whether the network has a full-duplex or half-duplex communication.
n VLAN—The number of VLAN connections associated with the network.

o LLDP Details—Click the LLDP Details link to view the ETH0 LLDP details. The pop-up window
displays the Neighbor Name, Neighbor MAC, Neighbor Port, and Neighbor VLAN details.

n ETH1—Displays the status of the ETH1 network.
n Speed (Mbps)/Duplex—The speed of the network measured in Mbps. This field also indicates

whether the network has a full-duplex or half-duplex communication.
n VLAN—The number of VLAN connections associated with the network.

o LLDP Details—Click the LLDP Details link to view the ETH1 LLDP details. The pop-up window
displays the Neighbor Name, Neighbor MAC, Neighbor Port, and Neighbor VLAN details.

n Current Uplink—The current uplink connection on the AP.
n Uplink connected to—The switch name to which the AP is connected. Click this link to view the

switch details page, if the switch is managed by Aruba Central On-Premises.
o Port—The port number of the switch to which the AP is connected.

n IP Address—IP address of the AP.
n Public IP Address—IP address logged by servers when the AP device is connected through internet

connection.
n DNS Name Servers—The server that has a directory of domain names and their associated IP

addresses.
n Default Gateway—A 32 bit value that is used to uniquely identify the device on a public network.
n NTP Server—Displays information about the NTP Server.

n From Aruba Central On-Premises 2.5.6 release, Public IP Address, DNS Name Servers, and Default
Gateway details are supported for Campus APs and Remote APs as well.

n From Aruba Central On-Premises 2.5.4 release, LLDP Details feature is supported for Campus APs as
well.

Radios

The Radios section displays the following information related to Radio 2.4 GHz, Radio 5 GHz, Radio 5
GHz Secondary, and Radio 6 GHz:
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n Mode—The type of mode for the radios. For example, Client Access, Monitor, and Spectrum.
n Status—Displays the operational status of the radios connected to the AP. The status is as follows:

o Up—Indicates that the radio is online.
o Down—Indicates that the radio is offline.
o Down - Thermal shutdown—Indicates that the radio is offline as the AP is operating under

thermal management. For more information, see Thermal Shutdown Support in Instant Access
Points.

n Radio MAC Address—The MAC address of the radios connected to the AP.
n Channel—The channels assigned to the radios.
n Power—The transmit power of the radios.
n Type—The type of wireless LAN used for the radios.
n Clients—The number of clients connected to the AP.
n Wireless Networks—The number of SSIDs configured in the network.
n Antenna—The type of antennae. For example, internal and external.
n Spatial Stream—Displays the number of spatial streams. By default, the spatial stream value for

Radio 5 GHz is 8x8. When tri-radio mode is enabled, the spatial stream values for Radio 5 GHz and
Radio 5 GHz (Secondary) is 4x4.

n When the AP radios are set to spectrum scan mode, the Channel and Power values are empty.
n The tri-radio feature is available only for AP-555. In the Radios section, the Radio 5 GHz (Secondary) data

is available only if the tri-radio mode is enabled. For more information, see About Tri-Radio Mode.
n The 6 GHz radio band is only supported for devices with 6 GHz capability.

Data Path

The Data Path section displays the topology of the clients connected to each of the radios of the AP,
which in turn is connected to switches or controllers through VLAN. When you hover over the upstream
device in the data path topology, a pop-up displays the Name, Serial Number, and Port details of the
upstream devices.

PORT shows the number of ports available in the AP that also includes USB ports. CLIENTS connected
to the PORT in the data path shows the number of wired clients connected to the port.
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Figure 108 Data Path

n The tri-radio feature is available only for AP-555. In the Data Path section, the 5 GHz (Secondary) data is
available only if the tri-radio mode is enabled. For more information, see About Tri-Radio Mode.

n In the Data Path section, the 6 GHz radio band is only supported for devices with 6 GHz capability.

Health Status

The Health Status trend graph indicates the health status of the device in the network for the time
selected in the time range filter. When you hover over the graph, you can view information such as date
and time, Health Status, Noise Floor, CPU, Memory, Channel Utilization (Radio 1), Channel Utilization
(Radio 2), and Channel Utilization (Radio 3).

In the Health Status graph, the Poor Health Limit text indicates the poor health limit of the device in
the network.

Figure 109 Health Status
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n In the Health Status graph, the Channel Utilization (Radio 3) data is available if the tri-radio mode is
enabled or if 6 GHz radio is available. For more information, see About Tri-Radio Mode.

n The tri-radio feature is available only for AP-555.
n The 6 GHz radio band is only supported for devices with 6 GHz capability.

WLANS

The WLANS table provides a list of all the SSIDs configured for the AP.

Figure 110 WLANS

The WLANS table provides the following information:

n Name—Displays the name of the SSID.

In the WLANS table, the Type, VLANs, and Security values are empty.

Click to expand an SSID in the WLANS table. When you expand an SSID in the WLANS table, you can
view the following information for 2.4 GHz, 5 GHz, 5 GHz (Secondary), and 6 GHz radios:

n BSSID—Displays the MAC address of the radio.
n Radio Type—Dispalys the type of radio.
n Clients—Displays the number of connected clients.

Click to download the .csv file of the WLANS table.

n In the .csv file of the WLANS table, the 5 GHz (Secondary) columns are available only if the tri-radio
mode is enabled.

n The tri-radio feature is available only for AP-555. In the WLANS table, the 5 GHz (Secondary) data is
available only if the tri-radio mode is enabled. For more information, see About Tri-Radio Mode.

n The 6 GHz radio band is only supported for devices with 6 GHz capability.

Actions
The Actions drop-down list contains the following options:
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n Reboot AP—Reboots the AP point. For more information, see Rebooting an Access Point in the List
View and Rebooting an AP in the Details Page.

A WebSocket connection is required to reboot IAPs, Campus APs, and Remote APs.

n Reboot Swarm—Reboots the IAP cluster. For more information, see Rebooting an IAP Cluster .
n Tech Support—Enables the administrator to generate a tech support dump required for

troubleshooting the AP. For more information, see Tech Support for an AP .

Go Live
Aruba Central On-Premises supports live monitoring of IAPs that support Aruba Instant 8.4.0.0 firmware
version and above. Aruba Central On-Premises allows you to monitor live data of an AP updated at
every 5 seconds. For more information, see Enabling Live IAP Monitoring.

Viewing the AI Insights Tab
In the access point (AP) dashboard, the AI Insights tab displays information on AP performance issues
such as excessive channel changes, excessive reboots, airtime utilization, and memory utilization.

n AI Insights is supported in Aruba Central On-Premises for five node instance and above.

n AI Insights is supported for IAPs, Campus APs, and Remote APs.

To navigate to the AI Insights tab in the AP dashboard, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global. Ensure that the filter selected contains at
least one active AP.

The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Access Points.A list of APs is displayed in the List view.

3. Click an AP listed under Device Name.

The dashboard context for the AP is displayed.

4. In the AP dashboard context, click the AI Insights tab.

The Insights page is displayed.

5. To exit the AP dashboard, click the back arrow on the filter.

You can change the time range for the AI Insights tab by clicking the time range filter and selecting
one of the available options: 3 hours, 1 day, 1 week, 1 month, and 3 months.

AI Insights are displayed for the time range selected. Select the time range from the Time Range Filter ( ) to
filter reports.

AI Insights Categories
AI Insights are categorized in high, medium, and low priorities depending on the number of
occurrences.
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n Red—High priority
n Orange—Medium priority
n Yellow—Low priority

AI Insights listed in the dashboard are sorted from high priority to low priority. The AI Insights
dashboard displays a report of network events that could possibly affect the quality of the overall
network performance. Each insight report provides specific details on the occurrences of these events
for ease in debugging. For more information, see The AI Insights Dashboard

The AP Insights page displays the following insights:

n Clients with High Wi-Fi Security Key-Exchange Failures
n Clients with High 802.1X Authentication Failures
n Clients with DHCP Server Connection Problems
n Clients with High Number of MAC Authentication Failures
n Clients with High Number of Wi-Fi Association Failures
n Clients with Captive Portal Authentication Problems

Viewing the Floor Plan Tab
In the access point (AP) dashboard, the Floor Plan tab provides information regarding the current
location and the floor plan of the instant access points, campus access points, and remote access
points.

To navigate to the Floor Plan tab in the AP dashboard, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global. Ensure that the filter selected contains at
least one active AP.

The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click an AP listed under Device Name.

The dashboard context for the AP is displayed.

4. In the AP dashboard context, click the Floor Plan tab.

The Floor Plan tab is displayed.

To exit the AP dashboard, click the back arrow on the filter.

You can change the time range for the Floor Plan tab by clicking the time range filter and selecting one
of the available options: 3 hours, 1 day, 1 week, 1 month, and 3 months.

The Floor Plan tab displays a sitemap and the floor plan showing the current location of the IAP . The
sitemap is derived from the Visual RF application, if Visual RF service is enabled for the Aruba Central
On-Premises account. You can also edit the location of the IAP device by clicking the edit icon provided
next to the address in the Floor Plan tab.

Actions
The Actions drop-down list contains the following options:
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n Reboot AP—Reboots the AP. For more information, see Rebooting an AP in the Details Page and
Rebooting an Access Point in the List View.

A WebSocket connection is required to reboot IAPs, Campus AP, and Remote AP.

n Reboot Swarm—Reboots the IAP cluster. For more information, see Rebooting an IAP Cluster .
n Tech Support—Enables the administrator to generate a tech support dump required for

troubleshooting the AP. For more information, see Tech Support for an AP .

Go Live
Aruba Central On-Premises supports live monitoring of IAPs that support Aruba Instant 8.4.0.0 firmware
version and above. Aruba Central On-Premises allows you to monitor live data of an AP updated at
every 5 seconds. For more information, see Enabling Live IAP Monitoring.

Viewing the Performance Tab
In the access point (AP) dashboard, the Performance tab displays the size of data transmitted through
the AP.

To navigate to the Performance tab in the AP dashboard, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under groups, labels,
or sites. For all devices, set the filter to Global. Ensure that the filter selected contains at least one
active AP.

The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click an AP listed under Device Name.

The dashboard context for the AP is displayed.

4. In the AP dashboard context, click the Performance tab. The Performance tab is displayed.

To exit the AP dashboard, click the back arrow on the filter.

You can change the time range for the Performance tab by clicking the time range filter and
selecting one of the available options: 3 hours, 1 day, 1 week, 1 month, and 3 months.

The Performance tab provides the following details:

n Throughput
The Throughput graph indicates the size of data sent to and received by the device in bits per
second for the wired or wireless networks. For example, Eth 0 or Eth 1 wired network profiles and
specific SSIDs of wireless networks. You can also view data for all the wireless SSIDs by selecting All
SSIDS from the drop-down list. You can view the overall data usage measured in bytes in the Overall
Usage field.

n Clients
The Clients graph indicates the number of clients connected to the device for the wired, wireless, or
radio network profiles for a selected time range in the time range filter. For example, wired for wired
network profile, specific SSID or All SSIDs for wireless network profile, and 2.4 GHz, 5 GHz, 6 GHz or
2.4 GHz & 5 GHz for radio network profile. You can select a specific network profile from the drop-
down list provided in the Clients section to view the date, time and number of clients connected.
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n When you hover over the Throughput and Clients graphs, it displays specific data for the selected
timestamp.

n The 6 GHz radios is available in Clients drop-down only if the AP supports 6 GHz. For more
information about the APs that supports 6 GHz, see Supported APs.

Actions
The Actions drop-down list contains the following options:

n Reboot AP—Reboots the AP. For more information, see Rebooting an AP in the Details Page on page
817 and Rebooting an Access Point in the List View on page 817.

A WebSocket connection is required to reboot IAPs, Campus APs, and Remote APs.

n Reboot Swarm—Reboots the IAP cluster. For more information, see Rebooting an IAP Cluster .
n Tech Support—Enables the administrator to generate a tech support dump required for

troubleshooting the AP. For more information, see Tech Support for an AP .

Go Live
Aruba Central On-Premises supports live monitoring of IAPs that support Aruba Instant 8.4.0.0 firmware
version and above. Aruba Central On-Premises allows you to monitor live data of an AP updated at
every 5 seconds. For more information, see Enabling Live IAP Monitoring.

Viewing the RF Tab
In the access point (AP) dashboard, the RF tab provides details corresponding to 2.4 GHz, 5 GHz, 5 GHz
(secondary), and 6 GHz radios of the IAPs, Campus APs, and Remote APs

Starting from Aruba Instant 8.9.0.0, the Wi-Fi 6E standard is supported that introduces 6 GHz radio band
for few IAPs, Campus APs, and Remote APs. The 6 GHz radio band provides greater efficiency, higher
throughput, and increased levels of security to address bandwidth challenges. The 6 GHz radio band
also provides wider channels up to 160 MHz for dense environments and large number of IoT devices.
The Wi-Fi 6E IAPs support 2.4 GHz, 5 GHz, and 6 GHz radio bands simultaneously, allowing client devices
to switch seamlessly between the three radio bands. The Wi-Fi 6E IAPs are supported with Enhanced
Open and WPA3 encryption methods only.

AP-635 and AP-655 IAPs are Wi-Fi 6E IAPs that support 6 GHz radio band, in addition to 2.4 GHz and 5 GHz radio
bands.

To navigate to the RF tab in the AP dashboard, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under groups, labels,
or sites. For all devices, set the filter to Global. Ensure that the filter selected contains at least one
active AP.

The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click an AP listed under Device Name.
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The dashboard context for the AP is displayed.

4. In the AP dashboard context, click the RF tab.

The RF tab is displayed.

To exit the AP dashboard, click the back arrow on the filter.

You can change the time range for the RF tab by clicking the time range filter and selecting one of the
available options: 3 hours, 1 day, 1 week, 1 month, and 3 months.

You can hover over the graph to view more information. You can select or clear an option in each
graph to filter the data displayed on the graph. For example, if you uncheck the box corresponding
to Receiving and Non-Wifi interference in the Channel Utilization graph, only Transmitting data
is displayed on the graph.

The RF tab provides the following details corresponding to 2.4 GHz and 5 GHz, and 6 GHz radio
channels of the IAPs, Campus APs, and Remote APs:

Channel Utilization
The Channel Utilization graph indicates the percentage of channel utilization for the selected time
range from the time range filter. The channel utilization information is categorized as follows:

n Transmitting: The percentage of channel currently being transmitted.
n Receiving: The percentage of channel currently being received.
n Non-Wifi Interference: The percentage of channel currently being used by non-Wi-Fi interferers.

Total Utilization is the sum of Transmitting, Receiving, and Non-Wifi interference, which indicates the
total percentage of channel utilization for the selected time range.

The following figure displays the channel utilization graph for 2.4 GHz radio channel.

Figure 111 Channel Utilization Graph

Noise Floor
The Noise Floor graph indicates the noise floor detected in the network to which the device belongs.

Frames - 802.11
The Frames - 802.11 line graph indicates the trend of frames transmitted through the network. The
frames can be one of the following types: Drops, Errors, and Retries. The graph indicates the status of
data frames that were dropped, encountered errors, retried to be transferred, in a wireless network.
You can see the graph in percentage or frames/sec.
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Only Campus APs and Remote APs support the Issues & Transmitted Frames and Issue % filter options.

Select one of the following option from the drop-down:

n Issues & Transmitted Frames—Select to view the trend value for transmitted frames along with
retries, errors, and drops in frames per second

n Issue %—Select to view the trend value for retries, errors, and drops in percentage.

Figure 112 Frames - 802.11 Graph

Radio Errors
The Radio Errors graph indicates the Total Packets, Physical Errors, and MAC Errors in packets per
second.

Only Campus APs and Remote APs support the Physical Errors, and MAC Errors options.

Figure 113 Radio Errors Graph

Channel Quality
The Channel Quality graph indicates the quality of channel in percentage.

n When you hover over the Channel Utilization, Noise Floor, Frames - 802.11, and Channel Quality
graphs, it displays specific data for the selected timestamp.

n The tri-radio feature is available only for AP-555. In the RF tab, the Radio 5 GHz (Secondary) tab is
available only if the tri-radio mode is enabled. For more information, see About Tri-Radio Mode.

n The 6 GHz radio band is only supported for devices with 6 GHz capability.

Actions
The Actions drop-down list contains the following options:
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n Reboot AP—Reboots the AP. For more information, see Rebooting an AP in the Details Page.

A WebSocket connection is required to reboot IAPs, Campus APs, and Remote APs.

n Reboot Swarm—Reboots the IAP cluster. For more information, see Rebooting an IAP Cluster .
n Tech Support—Enables the administrator to generate a tech support dump required for

troubleshooting the AP. For more information, see Tech Support for an AP .

Go Live
Aruba Central On-Premises supports live monitoring of IAPs that support Aruba Instant 8.4.0.0 firmware
version and above. Aruba Central On-Premises allows you to monitor live data of an AP updated at
every 5 seconds. For more information, see Enabling Live IAP Monitoring.

Viewing the Spectrum Tab
In the access point (AP) dashboard, the Spectrum tab provides details for all Wifi and non-Wifi devices
associated to each radio.

When the radios of Instant Access Point (IAP) are set to spectrum scan mode, the IAP functions as a
dedicated full-spectrum RF monitor, scanning all channels to detect interference from neighboring IAPs
or interfering devices such as microwaves and cordless phones. To enable the spectrum scan feature on
a specific radio of an AP, see Access Points Configuration Parameters.

n When the spectrum scan feature is enabled, the Instant AP does not provide services to clients.

n The spectrum scan feature is available only on IAP devices running Aruba Instant 8.5.0.1 firmware version
and later.

To navigate to the Spectrum tab in the AP dashboard, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global. Ensure that the filter selected contains at
least one active AP.

The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click an AP listed under Device Name.

The dashboard context for the AP is displayed.

4. In the AP dashboard context, click the Spectrum tab. The Spectrum tab is displayed.

To exit the AP dashboard, click the back arrow on the filter.

You can change the time range for the Spectrum tab by clicking the time range filter and
selecting one of the available options: 3 hours, 1 day, 1 week, 1 month, and 3 months.

The Spectrum tab displays the following sections:

n Channel Utilization and Quality
n Interfering Devices
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n Actions
n Go Live

Channel Utilization and Quality
Click the Chart icon to view the Channel Utilization and Quality details corresponding to 2.4 GHz and
5 GHz radios of the AP. Click the 2.4 GHz and 5 GHz tabs on the Channel Utilization and Quality label
to view the Channel Utilization and Quality graphs for the radios.

n Channel Utilization—The Channel Utilization graph indicates the percentage of channel utilization
for the Available, Interference, and Wi-Fi Utilization categories associated to 2.4 GHz and 5 GHz
radios. You can view the following channel metrics when you hover over the Channel Utilization bar
graph:
o Channel—The channel number of the radio.
o Available—The percentage of the channel currently available for use.
o Interference—The percentage of the channel currently being used by interfering devices.
o Microwave—The percentage of the channel currently being used by microwaves. Common

residential microwave ovens with a single magnetron are classified as a Microwave. These types of
microwave ovens may be used in cafeterias, break rooms, dormitories, and similar environments.
Some industrial, healthcare, or manufacturing environments may also have other equipment that
functions like a microwave and may also be classified as a Microwave device.

o Bluetooth—The percentage of the channel currently being used by bluetooth devices. Any device
that uses the Bluetooth protocol to communicate in the 2.4 GHz band is classified as a Bluetooth
device. Bluetooth uses a frequency hopping protocol.

o Cordless Phone—The percentage of the channel currently being used by cordless phones.
o Wi-Fi Utilization—The percentage of the channel currently being used by Wi-Fi devices.

n Quality—The Quality graph display the channel quality corresponding to each of the WiFi and non-
WiFi devices connected to the radios. When you hover over the Quality bar graph, the following
channel metrics are displayed:
o Channel—The channel number of the radio.
o Quality—Current relative quality of the channel.
o Known APs—Number of valid Instant APs identified on the radio channel.
o Unknown APs—Number of invalid or rogue Instant APs identified on the radio channel.
o Max AP Signal—Signal strength of the Instant AP that has the maximum signal strength on a

channel in dBm.
o Max Interference— Signal strength of the non-Wi-Fi device that has the highest signal strength in

dBm.
o Max AP SSID— The network SSID with maximum APs.
o Max AP BSSID— The network BSSID with maximum APs.

o SNIR— The measure of SNIR detected in the network in dB.
o Noise Floor— The noise at the radio receivers of the radios.

Interfering Devices
Click the List icon to view Interfering Devices details detected by the spectrum scanner. The page
displays a table with following details of interfering devices:
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n Type—Device type. This parameter can be any of the following:
o Audio FF (fixed frequency)
o Bluetooth
o Cordless base FH (frequency hopper)
o Cordless phone FF (fixed frequency)
o Cordless network FH (frequency hopper)
o Generic FF (fixed frequency)
o Generic FH (frequency hopper)
o Generic interferer
o Microwave
o Microwave inverter
o Video
o Xbox

n ID—ID number assigned to the device by the spectrum monitor. Spectrum monitors assign a unique
spectrum ID per device type.

n Central Frequency—Center frequency of the signal sent from the device.
n Bandwidth—Channel bandwidth used by the device in KHz.

n Affected Channels—Radio channels affected by the wireless device.

n Signal Strength—Strength of the signal sent from the device measured in dBm.
n Duty Cycle—The device duty cycle. This value represents the percent of time the device broadcasts a

signal.
n First Seen—Time at which the device was first detected.
n Last Seen—Time at which the device status was updated.

The data displayed in the Spectrum tab is refreshed every 15 seconds. Aruba Central On-Premises displays the
last recorded data for 30 minutes, if the device turns offline.

Actions
The Actions drop-down list contains the following options:

n Reboot AP—Reboots the AP. For more information, see Rebooting an AP in the Details Page on page
817 and Rebooting an Access Point in the List View on page 817.

A WebSocket connection is required to reboot IAPs, Campus APs, and Remote APs.

n Reboot Swarm—Reboots the IAP cluster. For more information, see Rebooting an IAP Cluster .
n Tech Support—Enables the administrator to generate a tech support dump required for

troubleshooting the AP. For more information, see Tech Support for an AP .

Go Live
Aruba Central On-Premises supports live monitoring of IAPs that support Aruba Instant 8.4.0.0 firmware
version and above. Aruba Central On-Premises allows you to monitor live data of an AP updated at
every 5 seconds. For more information, see Enabling Live IAP Monitoring.
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Viewing the VPN Tab
The VPN tab provides information on VPN connections associated with the virtual controller along with
information on the tunnels and the data usage through each of the tunnels.

VPN tab is only available for IAPs and not for Campus APs and Remote APs.

To navigate to the VPN tab, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global. Ensure that the filter selected contains at
least one active AP.

The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click an AP listed under Device Name.

The dashboard context for the AP is displayed.

4. Under Manage, click Security > VPN.

The VPN tab is displayed.

You can change the time range for the VPN tab by clicking the time range filter and selecting one of the
available options: 3 hours, 1 day, 1 week, 1 month, and 3 months.

The VPN tab provides the following information:

n VPNC Tunnels Summary—The section displays information on tunnels with the following details:
o Total—Total tunnels established.
o Up—Number of tunnels currently active.
o Down—Number of tunnels currently inactive.
o Peers—Number of peer tunnels currently active.

nn The Tunnel table displays information on tunnels with the following columns:
o Tunnel—The type of the tunnels used in the VPN. For example, primary, secondary, or backup.
o Status—The status of the tunnel.
o Source—The source address of the tunnel.
o Destination—The destination address of the tunnel.

n Throughput Usage Per VPN—The Throughput Usage Per VPN graph indicates the successful data
usage per VPN in Mbps for the primary or backup tunnel selected from the drop-down list. The
Throughput Usage Per VPN displays a linear graph of sent and received data in the virtual private
network.

Rebooting an IAP Cluster
You can reboot an Instant Access Point (IAP) cluster using the Aruba Central On-Premises UI.

To reboot an IAP cluster, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global. Ensure that the filter selected contains at
least one active AP.
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The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click an AP listed under Device Name.

The dashboard context for the AP is displayed.

4. In the Actions drop-down list, click Reboot Swarm.

A Reboot dialog box is displayed.

5. Click Yes to reboot the AP cluster.

The AP dashboard takes less than a minute to update the interface status, after the VC is rebooted and
reconnected to Aruba Central On-Premises.

Tech Support for an AP
In Aruba Central On-Premises UI, the administrators can generate a tech support dump required for
troubleshooting the Instant Access Point (IAP).

To generate a tech support dump for an IAP, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global. Ensure that the filter selected contains at
least one active AP.

The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click an AP listed under Device Name.

The dashboard context for the AP is displayed.

4. In the Actions drop-down list, click Tech Support.
The Commands page is displayed. In the Commands page, the Device Type and Available
Devices fields are automatically selected. The AP Tech Support Dump command is automatically
selected in the Selected Commands pane.

5. Click Run. The output is displayed in the Device Output section.

For more information, see Performing Advanced Device Troubleshooting.

Enabling Live IAP Monitoring
Aruba Central On-Premises supports live monitoring of Instant APs that support Aruba Instant 8.4.0.0
firmware version and above. Aruba Central On-Premises allows you to monitor live data of an AP
updated at every 5 seconds.

Enabling and Disabling Go Live
To enable and disable the live monitoring of an AP, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global. Ensure that the filter selected contains at
least one active access point.

The dashboard context for the selected filter is displayed.
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2. Under Manage, click Devices > Access Points.

A list of access points is displayed in the List view.

3. Click an access point listed under Device Name.

The dashboard context for the access point is displayed.

4. Click the Go Live button to start live monitoring of the AP.
5. To exit, click the Stop Live button to exit the live monitoring of the AP.

n The Go Live feature is not applicable for offline Instant APs. The Go Live button remains grayed-out for all
the APs that are not associated with Instant AP devices running Aruba Instant 8.4.0.0 firmware version
and above.

n Aruba Central On-Premises allows you to monitor live data for 15 minutes. After this time period, Aruba
Central On-Premises redirects to the AP dashboard in a non-live mode to display the monitoring details
for the time selected in the Time Range Filter. For more information on AP dashboard in a non-live
mode, see Viewing the Summary Tab.

AP Details in Go Live Mode
When you click the Go Live button, the page displays live graphs based on noise floor, frames, and
channel quality of the neighboring RF devices for 15 minutes, until you select Stop Live button.

The page displays Noise Floor, Frames, and Channel Quality live graphs for Radio 2.4 GHz, Radio 5
GHz, Radio 5 GHz Secondary, and Radio 6 GHz.

Important Information

The following are the important information to consider while enabling live IAP monitoring:

n The Go Live feature is not applicable for offline APs.
n Aruba Central allows you to monitor live data for 15 minutes. After this time period, Aruba Central

redirects to the AP dashboard in a non-live mode to display the monitoring details for the time
selected in the Time Range Filter. For more information on AP dashboard in a non-live mode, see
Viewing the Summary Tab.

n In Go Live mode, AP dashboard updates and displays data at every 5 seconds.
n The tri-radio feature is available only for AP-555. In the Go Live page, the Radio 5 GHz (Secondary)

tab is available only if the tri-radio mode is enabled. For more information, see About Tri-Radio
Mode.

n The Radio 6 GHz band is only supported for devices with 6 GHz capability.
n The time range selected in the Time Range Filter is not applicable when the Go Live button is

enabled.
n You can monitor live data for multiple APs simultaneously on different tabs.

Viewing the Clients Tab
In the access point (AP) dashboard, the Clients tab displays details of all the clients connected to a
specific AP.

To navigate to the Clients tab in the AP dashboard, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global. Ensure that the filter selected contains at
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least one active AP.

The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click an AP listed under Device Name.

The dashboard context for the AP is displayed.

4. Under Manage, click Clients.

The Clients page is displayed in the List view.

To exit the Clients dashboard, click the back arrow on the filter.

You can change the time range for the Clients tab by clicking the time range filter and selecting
one of the available options: 3 hours, 1 day, 1 week, 1 month, and 3 months.

For more information, see All Clients.

Viewing the Alerts & Events Tab
In the access point (AP) dashboard, the Alerts & Events tab displays details of the alerts and events
generated for the AP.

To navigate to the Alerts & Events tab in the AP dashboard, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global. Ensure that the filter selected contains at
least one active AP.

The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Access Points.

A list of APs is displayed in the List view.

3. Click an AP listed under Device Name.

The dashboard context for the AP is displayed.

4. Under Analyze, click Alerts & Events.

The Alerts & Events page is displayed in the List view.

To exit the Alerts & Events dashboard, click the back arrow on the filter.

For more information, see Alerts and Events. You can also configure and enable certain categories of AP alerts.
For more information, see Access Point Alerts.

Supported Client Events for Campus AP and Instant AP Devices
Aruba Central On-Premises provides an Events dashboard for viewing the events triggered from
Campus Access Point (CAP) and Instant Access Point (IAP) devices.

The following table lists the client events that are supported for IAP and CAP in Aruba Central On-
Premises:
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Event Description Campus AP Instant AP

Client 802.11
Association Reject

802.11 Association rejected for client [Client MAC]
to BSSID [BSSID] on channel [Channel] of AP
hostname [Device Hostname].

Supported Supported

Client 802.11
Disassociation to Client

802.11 Disassociation sent to client [Client MAC]
from BSSID [BSSID] on channel [Channel] of AP
hostname [Device Hostname].

Supported Supported

Client 802.11
Disassociation from
Client

802.11 Disassociation received from client [Client
MAC] associated to BSSID [BSSID] on channel
[Channel] of AP hostname [Device Hostname].

Supported Supported

Client 802.11
Authentication Failure

802.11 Authentication failed for client [Client MAC]
on BSSID [BSSID] on channel [Channel] of AP
hostname [Device Hostname].

Supported Supported

Client 802.11 De-
authentication to Client

De-authentication sent to client [Client MAC] from
BSSID [BSSID] on channel [Channel] of AP
hostname [Device Hostname].

Supported Supported

Client 802.11 De-
authentication from
Client

De-authentication sent from client [Client MAC]
associated to BSSID [BSSID] on channel [Channel]
of AP hostname [Device Hostname].

Supported Supported

Client Roaming Success Client [Client MAC] associated to BSSID [From
BSSID (roamed from)] on channel [From Channel
(roamed from)] of AP hostname [From Device
Hostname (roamed from)] roamed successfully to
BSSID [BSSID] on channel [Channel] of AP
hostname [Device Hostname].

Supported Supported

Client MAC
Authentication Reject

MAC Authentication failed for client [Client MAC]
to Radius Server [Radius Server IP] through BSSID
[BSSID] on channel [Channel] of AP hostname
[Device Hostname].

Supported Supported

Client 802.1x Radius
Reject

802.1x Radius Reject received for client [Client
MAC] on BSSID [BSSID] on channel [Channel] of AP
hostname [Device Hostname].

Supported Supported

Client 802.1x Radius
Timeout

802.1x Radius Timeout occurred for client [Client
MAC] on BSSID [BSSID] on channel [Channel] of AP
hostname [Device Hostname].

Supported Supported

Client Captive Portal
Authentication Failure

Captive Portal failure occurred for client [Client
MAC] associated to BSSID [BSSID] of AP hostname
[Device Hostname].

Supported Supported

Client EAP Failure EAP failure occurred for client [Client MAC]
associated to BSSID [BSSID] on channel [Channel]
of AP hostname [Device Hostname].

Supported Supported

Client EAP Timeout from
Client

EAP response from client [Client MAC] associated
to BSSID [BSSID] on channel [Channel] of AP
hostname [Device Hostname] timed out.

Not
Supported

Supported

Table 187: Client Events
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Event Description Campus AP Instant AP

Client VoIP Call Start VoIP call initiated from station [Source Client
Name] ([Source Client IP]) to station [Destination
Client Name] ([Destination Client IP]) on AP
hostname [Device Hostname].

Not
Supported

Supported

Client VoIP Call Stop VoIP call terminated from station [Source Client
Name] ([Source Client IP]) to station [Destination
Client Name] ([Destination Client IP]) on AP
hostname [Device Hostname].

Not
Supported

Supported

Client DHCP
Acknowledged

DHCP acknowledgment received from DHCP
server [DHCP Server IP] for client [Client MAC]
([Client IP]) associated to BSSID [BSSID] on channel
[Channel] of AP hostname [Device Hostname].

Supported Supported

Client DHCP Not
Acknowledged

DHCP NACK to DHCP server [DHCP Server IP] from
client [Client MAC] ([Client IP]) associated to BSSID
[BSSID] on channel [Channel] of AP hostname
[Device Hostname].

Supported Supported

Client DHCP Declined DHCP declined from DHCP server [DHCP Server IP]
for client [Client MAC] ([Client IP]) associated to
BSSID [BSSID] on channel [Channel] of AP
hostname [Device Hostname].

Supported Supported

Client DNS Failure DNS failure to [Domain Name] detected for client
[BSSID] on BSSID [BSSID] of AP hostname [Device
Hostname].

Not
Supported

Supported

Client DHCP Timeout DHCP request to DHCP server [DHCP Server IP]
from client [Client MAC] timed out.

Supported Supported

Client Blacklisted Blacklisted client [Client MAC] on AP hostname
[Device Hostname] for SSID [SSID name].

Not
Supported

Supported

Client Fast Roaming
Failure

Fast Roaming failed for client [Client MAC] with
roaming type [Roaming Type] on AP hostname
[Device Hostname].

Not
Supported

Supported

Client Roaming Success Client [Client MAC] roamed successfully to SSID
[SSID name] on channel [Channel] of AP hostname
[Device Hostname].

Not
Supported

Supported

Client Match Steer
Attempt

Client match attempted a [Steer Type] using [Steer
Mode] for client [Client MAC] from radio BSSID
[From BSSID] to radio BSSID [To BSSID] with result:
[Steer Result].

Not
Supported

Supported

Client Match Steer
Reject

Client match attempted a [Steer Type] using [Steer
Mode] for client [Client MAC] from radio BSSID
[From BSSID] to radio BSSID [To BSSID] which was
rejected by the client with reason code [802.11v
Move Result].

Not
Supported

Supported
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Event Description Campus AP Instant AP

Client Match Steer
Wrong Destination

Client match attempted a [Steer Type] using [Steer
Mode] for client [Client MAC] from radio BSSID
[From BSSID] to radio BSSID [To BSSID] which
resulted in the client moving to a different radio
BSSID [Destination Radio BSSID].

Not
Supported

Supported

Client Match Success Client match attempted a [Steer Type] using [Steer
Mode] for client [Client MAC] from radio BSSID
[From BSSID] to radio BSSID [To BSSID] with result:
Success info : <11v reason if any > and steer
reason [Sticky Client, Dynamic load balancing,
capability mismatch, channel steering, band
steering ]

Supported Not
Supported

Client Match Steer
Uncontrolled Moves

Client match attempted a [Steer Type] using [Steer
Mode] for client [Client MAC] from radio BSSID
[Client MAC] to radio BSSID [To BSSID] with result:
Move result info : <11v reason if any > and steer
reason [Sticky Client , Dynamic load balancing,
capability mismatch, channel steering, band
steering ]

Supported Not
Supported

Client Match Steer No
Move

Client match attempted a [Steer Type] using [Steer
Mode] for client [Client MAC] from radio BSSID
[Client MAC] to radio BSSID [To BSSID] with result:
Move result info : <11v reason if any > and steer
reason [Sticky Client, Dynamic load balancing,
capability mismatch, channel steering, band
steering ]

Supported Not
Supported

Client Authentication
Server Timeout

Authentication request to a Radius server [Radius
Server IP] from a client [Client MAC] timed out.

Supported Not
Supported

Client Accounting
Server Timeout

Accounting request to a Radius server [Radius
Server IP] from a client [Client MAC] timed out.

Supported Not
Supported

Radius-COA Failure Timestamp: Radius COA failure received from <
Server IP> for a <Client MAC> associated to <BSSID
MAC/SSID> on <Radio Index:Channel> of <AP
Hostname>
Reason Code : <Description>

Supported Not
Supported

Monitoring Switches and Switch Stacks
The switch dashboard enables you to manage, configure, monitor and troubleshoot AOS-S, AOS-CX
switches, and switch stacks provisioned and managed through Aruba Central On-Premises.
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To view AOS-CX switches in the monitoring and topology pages, you must create a template configuration for
the switch with the password in plaintext. See Configuring AOS-CX Switches using Templates.

If you are unable to view all details of the AOS-CX switch, then maybe the template configuration was not
applied correctly, the password was missing in the template configuration, or the password was not in
plaintext. See the audit trail to check the status of the switch. The audit trail should show the device onboarded
message for the switch serial number followed by the configuration push and login successful messages. For
more information on troubleshooting AOS-CX switch onboarding issues, see Troubleshooting AOS-CX Switch
Onboarding Issues.

Monitoring Switches in List View
The switch List page provides information associated with the online and offline AOS-S, AOS-CX, and
third-party switches provisioned and managed in Aruba Central On-Premises.

Viewing the Switches List Page
To navigate to the Switches List page, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

The Switches List page displays the following information:
n Switches—Displays the total number of switches, both online and offline. When you click the

Switches tab, it provides information about all switches in the Switches table.
n Online—Displays the number of online switches. When you click the Online tab, it provides

information about all switches that are currently online and connected to Aruba Central On-
Premises in the Switches table.

n Offline—Displays the number of offline switches. When you click the Offline tab, it provides
information about all switches that are currently offline or not connected to Aruba Central On-
Premises in the Switches table.

The online switches are displayed with a green dot and offline switches are displayed with a red dot.

Even when the AOS-CX switches are displayed as online, there might be instances when the details of
the switches are not displayed completely. This may be because of the following reasons:

n Template configuration is not applied correctly on the switch
n Password is not configured in the template configuration
n Password is not in plaintext format

See the audit trail to check the status of the AOS-CX switches. The audit trail should show the device
onboarded message for the switch serial number followed by the configuration push and login
successful messages. For more information on troubleshooting AOS-CX switch onboarding issues, see
Troubleshooting AOS-CX Switch Onboarding Issues.
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Switches Table
The Switches table displays the following information:

n Device Name—Name of the switch or switch stack. For a switch stack, a stack icon is displayed next
to the device name.

n Type—Type of switch. Following are the supported values:
o AOS
o CX
o AOS Stack
o Third Party Stack

n Clients—Number of clients connected.
n Alerts—Number of alerts from the switch or switch stack.
n Model—Model number of the switch. For a switch stack, the term Stack is displayed.
n Config Status—Configuration status of the switch or switch stack. Following are the supported

values:
o In sync
o Not in sync
o Monitoring only

n Monitoring only status is available only for AOS-S switches and third-party switches when they are
configured in UI groups in the monitoring only mode. In this mode the switches can only be monitored
for details.

n The recommended software version is 16.10.0010.

n You cannot configure the switches in Aruba Central On-Premises in this mode. However, you can
configure the switches at the device level using the CLI.

n Last Seen—Date and time when the switch or switch stack was last connected.
n Usage—Data usage on the switches.
n IP Address—IP address of the switch or switch stack.
n MAC—MAC address of the switch or switch stack.
n Firmware Version—Firmware version of the switch or switch stack.
n Group—Name of the group to which the switch or switch stack is assigned.
n Labels—Name of the label associated with the switch or switch stack.
n Site—Site in which the switch or switch stack is provisioned.
n Uptime—Duration for which the switch is operational.
n Serial/Stack ID—Serial number of the switch or switch stack.
n Uplink Ports—Uplink ports configured on the switch or switch stack.
n Port Utilization—Utilization percentage of the port.

A search filter is provided only for the Device Name and Model columns.
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To download the switch details as a .csv file, click the Download CSV icon. If the table contains unicode
value, you must use a UTF-8 enabled software to view the contents. To view the file, open the file in a
Microsoft Excel spreadsheet software.

Assigning Uplink Ports
To assign uplink port(s):

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

3. In the Switches table, hover over the switch for which you want to assign uplink port(s).
4. Click Uplinks.

For offline switches, click Actions > Uplinks in the pop-up window.

5. In the Assign Uplink Ports/Trunks dialog box, select the ports in the Assigned Uplink
Ports/Trunks drop-down. On selecting the ports, the uplink rates for the selected ports are
displayed in the uplink trend chart. For more information, see Uplink.

6. Select the port(s), and click Assign.

Deleting an Offline Switch
To delete an offline switch:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global. Ensure that the filter selection contains at
least one switch.

The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

3. Click Offline to display a table with the list of offline switches.
4. In the Switches table, hover over the offline switch that you want to delete.

5. Click the delete icon.

To delete multiple offline switches, select the offline switches that you want to delete, and click the delete
icon at the bottom of the page.

6. Click Yes in the Confirm Action dialog box.

Downloading Switch Details
You can download the switch details as a .csv file.
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To download the switch details, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.

2. Under Manage click Devices > Switches.

A list of switches is displayed in the List view.

3. In the Switches table, click the download icon to download the switches details as a .csv file.

A .csv file is downloaded.

Monitoring Switches in Summary View
The switches Summary page provides a graphical view of all metrics about the usage and clients
information associated with the AOS-S, AOS-CX, and third-party switches provisioned and managed in
Aruba Central On-Premises.

Viewing the Switches Summary Page
To navigate to the switches Summary page, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

3. Click the Summary icon.

The Switches Summary page is displayed with the following information:
n Usage—Displays aggregate client data traffic detected on the switches.
n Clients—Displays the number of clients connected to a switch.

You can change the time range by clicking the time range filter and selecting one of the available
options: 3 hours, 1 day, 1 week, 1 month, or 3 months.

Switch > Overview > Summary
In the switch dashboard, the Summary tab provides a summary of the switch device details, network
details, ports, hardware, uplink graph, usage graph, and details about the AOS-S, AOS-CX, and third-
party switches in the network.

The Summary tab displays the following sections:

n Switch
n Network
n Ports
n Hardware
n Uplink
n Usage
n Stack Members
n Actions
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Viewing the Overview > Summary Tab
To navigate to the Summary tab in the switch dashboard, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global. Ensure that the filter selected contains at
least one active switch.

The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

3. Click a switch listed under Device Name.

The dashboard context for the specific switch is displayed.

4. Under Manage, click Overview > Summary .

The Summary tab is displayed.

5. To exit the Switch dashboard, click the back arrow on the filter.

You can change the time range for the Summary tab by clicking the time range filter and
selecting one of the available options: 3 hours, 1 day, 1 week, 1 month, or 3 months.

Switch

The Switch section displays the following details:

n Model—Hardware model of the switch.
n J-Number—Part number of the switch. This field is displayed only for standalone switches that are

not part of switch stacks. This field is not available for third-party switches.
n Location—Current location of the switch.
n Contact—E-mail address of the contact person.
n Conductor—Serial number of the conductor switch in a switch stack. This field is displayed only for

switch stacks.
n Serial—Serial number of the switch. This field is displayed only for standalone switches that are not

part of switch stacks. This field is not available for third-party switches.
n MAC Address—MAC address of the switch. This field is displayed only for standalone switches that

are not part of switch stacks. This field is not available for third-party switches.
n Uptime—Time duration for which the switches are operational. This field is not available for third-

party switches.
n Last Reboot—Timestamp of when the switch was last rebooted. This field is not available for third-

party switches.
n Configuration—Configuration status of the switch.
n Last Sync:—Timestamp when the configuration was last synched between the peer switches in the

stack.
n Last Stats Received—Timestamp of when the last statistics were received.
n Firmware Version—Firmware version of the switch. If an updated version is available, the version

number is displayed and you can click the link to navigate to the firmware management page and
upgrade the firmware.

n Last Updated—Timestamp of when the switch firmware was last changed. This field is not available
for third-party switches.
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n Firmware Status—Displays whether a new firmware version is available. This field is not available
for third-party switches.

n Group—Name of the group to which the switch belongs. Click the group name to view the dashboard
context for the group.

n Site—Name of the site to which the switch belongs. Click the site name to view the dashboard
context for the site.

n Label(s)—Name of the label to which the switch belongs.

Figure 114 Switch Overview

Network

The Network section displays the following details:

n IP Address—IP address of the switch. For AOS-CX switches, a value is displayed only if the IP address
is configured for the management interface of the switch. If IP address is obtained from the
DHCP server, this field will appear blank for AOS-CX switches.

n Default VLAN—Default VLAN ID of the switch.
n Management VLAN—Management VLAN ID of the switch. This field is displayed only for AOS-S

switches.
n Stack/Standalone— Indicates whether the switch is part of a stack or if it is a standalone switch.
n Stack Members—Total number of members in the stack. This field is displayed only for switch

stacks.
n Stack Topology—Topology of the stack.
n Stack ID—Stack ID used to identify the stack. This field is displayed only for switch stacks.

Figure 115 Network Details
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Ports

The Ports section displays the following details:

n Status—Number of ports in Up and Down state, and number of alerts.
n Power Over Ethernet (PoE)—Number of PoE ports enabled and disabled, and number of alerts.

This field is not available for third-party switches.

Figure 116 Port Summary

Hardware

The Hardware section displays the following details:

n Power Supply—Total number of power supplies and number of power supplies in Up state.
n Fans—Total number of fans and the number of fans in the Up and Down states.
n CPU—CPU utilization status.
n Memory—Memory utilization status.
n Temperature—Temperature status. Hover your mouse over the status to view the temperature

data.
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Figure 117 Hardware Details

Uplink

The Uplink section displays the uplink rate (bps) trend chart for the duration specified in the time range
filter. Hover the mouse over the trend chart to view the uplink rate at a particular time. This section is
not available for third-party switches.

Figure 118 Uplink Trend Chart

Usage

The Usage section displays the trend chart for client data traffic detected on the switch. Hover the
mouse over the trend chart to view data transmitted and received at a particular time.

Stack Members

The Stack Members table displays the following details:

n Name—Name of the switch stack member.
n Member ID—Identification number of the member.
n Model—The hardware model of the switch.
n MAC Address— The MAC address of the stack member.
n Serial— The serial number of the switch.
n Role —The role of a stack member.
n Status—The status of the switch stack member.
n Priority—Priority of the member. This column is not displayed for AOS-CX switches.
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Figure 119 Stack Members Table

Actions

This section is not available for third-party switches.

The Actions tab displays the various options available for remote administration of the switch. The
following options are available:

n Reboot—Reboots the switch. See Rebooting Switches.
n Tech Support—Allows the administrators to generate a tech support dump for troubleshooting the

device. See Troubleshooting Aruba Switches.
n Console—Opens the remote console for a CLI session through SSH. Ensure that you allow SSH over

port 443. The default user ID is admin, but you can edit and customize the user ID. This custom user
ID must be mapped to the device. See Opening Remote Console for Switch.

n VSF Switchover—Triggers the standby conductor switch to take over the conductor role. This option
is applicable only for AOS-CX switch stacks. See VSF Switchover.

For AOS-CX 8320 and 8325 switch series, you must enable SSH server on the default VRF. Add the ssh server

vrf default code to the template.

If the Copy and Paste function from the keyboard shortcut keys (CTRL+C and CTRL+V) do not work in your web
browser, use the Copy and Paste functions available under the menu options in the web browser.

You can only troubleshoot Aruba switches using the Console option in Aruba Central. You cannot configure
the switches.

Switch > Overview > Hardware
In the switch dashboard, the Hardware tab displays information related to hardware, power supplies,
fans, CPU, memory, temperature, and thermals of the AOS-S, AOS-CX, and third-party switches in the
network.

The Hardware tab displays the following sections:
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n Hardware
n Power Supplies
n Fans
n CPU
n Memory
n Temperature
n Thermals
n Actions

Viewing the Overview > Hardware Tab
To navigate to the Hardware tab in the switch dashboard, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global. Ensure that the filter selected contains at
least one active switch.

The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

3. Click a switch listed under Device Name.

The dashboard context for the specific switch is displayed.

4. Under Manage, click Overview > Hardware .

The Hardware tab is displayed.

5. To exit the switch dashboard, click the back arrow on the filter.

You can change the time range for the Hardware tab by clicking the time range filter and
selecting one of the available options: 3 hours, 1 day, 1 week, 1 month, or 3 months.

Hardware

The Hardware table displays the overall hardware summary:

n Name—Name of the device.
n Power Supplies

o Total—Total number of power supplies.
o Up—Number of power supplies in Up state.
o Down—Number of power supplies in Down state.

n Fans
o Total—Total number of fans.
o Up—Number of fans in Up state.
o Down—Number of fans in Down state.

n Utilization
o CPU—Current CPU utilization percentage.
o Memory—Current memory utilization percentage.

n Temperature
o Current—Current temperature. This column is available only for AOS-S switches and third-party

switches.
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o Min—Minimum temperature. This column is available only for AOS-S switches and third-party
switches.

o Max—Maximum temperature. This column is available only for AOS-S switches and third-party
switches.

o Sensors—Number of sensors present in the switch. The number inside the brackets show the
number of sensors whose status is high. This column is available only for AOS-CX switches.

Figure 120 Hardware table details for AOS-S

Figure 121 Hardware table details for AOS-CX switch

Figure 122 Hardware table details for third-party switch

Power Supplies

The Power Supplies table displays the following details:

n Name—Name of the power supply.
n Status—Current status of the power supply.

Fans

The Fans table displays the following details:

n Name —Name of the fan.
n Status—Current status of the fan.

CPU

The CPU section displays the current CPU utilization percentage and trend chart for the duration
specified in the time range filter. Hover your mouse over the trend chart to view the CPU utilization at a
particular time.

Memory

The Memory section displays the current memory utilization percentage and trend chart for the
duration specified in the time range filter. Hover your mouse over the trend chart to view the memory
utilization at a particular time.
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Temperature

This section is available only for AOS-S switches.

The Temperature section displays the current, minimum, and maximum temperature and trend chart
for the duration specified in the time range filter. Hover over the trend chart to view the temperature at
a particular time.

Figure 123 Temperature

Thermals

This section is available only for AOS-CX switches.

The Thermals table displays the following details of each of the sensors that are present in the AOS-CX
switches:

n Name—Name of the component where the sensor is present.
n Status—Current status of the fan.
n Current—Current temperature of the component.
n Min—Minimum temperature of the component.
n Max—Maximum temperature of the component.

Expand each of the rows to display the fan status, location of the fan, current, minimum, and maximum
temperatures, and a temperature trend chart. Hover over the trend chart to view the temperature at a
particular time.

Figure 124 Thermals

Actions

This section is not available only for third-party switches.

The Actions tab displays the various options available for remote administration of the switch. The
following options are available:
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n Reboot—Reboots the switch. See Rebooting Switches.
n Tech Support—Allows the administrators to generate a tech support dump for troubleshooting the

device. See Troubleshooting Aruba Switches.
n Console—Opens the remote console for a CLI session through SSH. Ensure that you allow SSH over

port 443. The default user ID is admin, but you can edit and customize the user ID. This custom user
ID must be mapped to the device. See Opening Remote Console for Switch.

n VSF Switchover—Triggers the standby conductor switch to take over the conductor role. This option
is applicable only for AOS-CX switch stacks. See VSF Switchover.

For AOS-CX 8320 and 8325 switch series, you must enable SSH server on the default VRF. Add the ssh server

vrf default code to the template.

If the Copy and Paste function from the keyboard shortcut keys (CTRL+C and CTRL+V) do not work in your web
browser, use the Copy and Paste functions available under the menu options in the web browser.

You can only troubleshoot Aruba switches using the Console option in Aruba Central. You cannot configure
the switches.

Switch > Overview > Routing

The Routing tab is displayed only for AOS-S switches that run the firmware version 16.09 or later.

In the switch dashboard, the Routing tab displays the following sections:

n Overview of Routing Information
n Routing
n Actions

Viewing the Overview > Routing Tab
To navigate to the Routing tab in the Switch dashboard, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global. Ensure that the filter selected contains at
least one active switch.

The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

3. Click a switch listed under Device Name.

The dashboard context for the specific switch is displayed.

4. Under Manage, click Overview > Routing .

The Routing tab is displayed.

5. To exit the Switch dashboard, click the back arrow on the filter.

You can change the time range for the Routing tab by clicking the time range filter and selecting
one of the available options: 3 hours, 1 day, 1 week, 1 month, or 3 months.

Overview of Routing Information

n This section displays the following routing information:
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n Total—Displays the total number of routes on the switch.
n Static—Displays the total number of static routes on the switch.
n Connected—Displays the total number of connected routes on the switch.

Routing

The Routing table displays the following details:

n Destination—Displays the network address of the destination route.
n Gateway—Displays the IP address of the controller.
n VLAN—Displays the VLAN ID of the route destination.
n Type—Displays the following types of routes:

o Static—The routes that are manually added to the routing table in the switch.
o Connected—The routes that are directly connected to the interface.

n Sub Type—Displays the subtype of the route as Internal or External.
n Metric—Displays the measure used to calculate the best path to reach the destination. A value of 1

indicates the best path, 15 indicates the worst path, and 16 indicates that the destination is
unreachable on the route.

n Distance—Displays the administrative distance of the route. The administrative distance helps
routers determine the best route when there are multiple routes to the destination.

The routing information is displayed from the Aruba 3810 Switch Series and Aruba 5400R Switch Series in the
network. The details displayed on the Routing tab are refreshed every five minutes.

Actions

The Actions tab displays the various options available for remote administration of the switch. The
following options are available:

n Reboot—Reboots the switch. See Rebooting Switches.
n Tech Support—Allows the administrators to generate a tech support dump for troubleshooting the

device. See Troubleshooting Aruba Switches.
n Console—Opens the remote console for a CLI session through SSH. Ensure that you allow SSH over

port 443. The default user ID is admin, but you can edit and customize the user ID. This custom user
ID must be mapped to the device. See Opening Remote Console for Switch.

n VSF Switchover—Triggers the standby conductor switch to take over the conductor role. This option
is applicable only for AOS-CX switch stacks. See VSF Switchover.

For AOS-CX 8320 and 8325 switch series, you must enable SSH server on the default VRF. Add the ssh server

vrf default code to the template.

If the Copy and Paste function from the keyboard shortcut keys (CTRL+C and CTRL+V) do not work in your web
browser, use the Copy and Paste functions available under the menu options in the web browser.

You can only troubleshoot Aruba switches using the Console option in Aruba Central. You cannot configure the
switches.
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Switch > Overview > AI Insights
In the switch dashboard, the AI Insights tab displays information on switch performance issues such as
PoE issues, port errors, port flaps, airtime utilization, and memory utilization.

Viewing Switches > AI Insights
To navigate to the AI Insights tab in the switch dashboard, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Group, Label,
or Site. For all devices, set the filter to Global. Ensure that the filter selected contains at least one
active switch.

2. The dashboard context for the selected filter is displayed.
3. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

4. Click a switch listed under Device Name.

The dashboard context for the switch is displayed.

5. In the switch dashboard context, click the AI Insights tab.

The Insights page is displayed.

To exit the switch dashboard, click the back arrow on the filter.

You can change the time range for the AI Insights tab by clicking the time range filter and
selecting one of the available options: 3 hours, 1 day, 1 week, 1 month, and 3 months.

AI Insights are displayed for the time range selected. Select the time range from the Time Range Filter ( ) to
filter reports.

AI Insights Categories
AI Insights are categorized in high, medium, and low priorities depending on the number of
occurrences.

n Red—High priority
n Orange—Medium priority
n Yellow—Low priority

AI Insights listed in the dashboard are sorted from high priority to low priority. The AI Insights
dashboard displays a report of network events that could possibly affect the quality of the overall
network performance. Each insight report provides specific details on the occurrences of these events
for ease in debugging.

Switch > Clients > Clients
In the switch dashboard, the Clients tab displays details about the wired clients that are connected to
the switch. This tab also displays a visual representation of the switch faceplate with port details.

The Clients tab displays the following details:

n Overview of Connected Devices
n Faceplate
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n Client Devices
n Actions

To experience improved monitoring updates performance for clients connected to AOS-CX switches, the
recommended AOS-CX firmware version is 10.09.0130 or later, or 10.10.0001 or later.

Viewing the Clients > Clients Tab
To navigate to the Clients tab in the Switch dashboard, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global. Ensure that the filter selected contains at
least one active switch.

The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

3. Click a switch listed under Device Name.

The dashboard context for the specific switch is displayed.

4. Under Manage, click Clients > Clients.

The Clients tab is displayed.

5. To exit the Switch dashboard, click the back arrow on the filter.

You can change the time range for the Clients tab by clicking the time range filter and selecting
one of the available options: 3 hours, 1 day, 1 week, 1 month, and 3 months.

Overview of Connected Devices

This section displays the following details:

n Total—Total number of clients connected to the switch.
n Non-Tunneled—Number of clients, that are not tunneled connected, to the switch.
n User Based Tunneled (UBT)—Number of UBT clients connected to the switch.
n Port Based Tunneled (PBT)—Number of PBT clients connected to the switch.

To view the details about dynamic segmentation, a controller must be licensed in Aruba Central On-Premises
and connected to the switch.

Faceplate

If the switch is a standalone switch, the faceplate of the switch is displayed. For a switch stack, faceplate
of all the switches part of the stack is displayed. From the faceplate, click on a port to view port-level
information. On the switch faceplate, hover over a port to view the following details:

n Port Number
n Port Name
n Speed
n Type
n Tunneled
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Client Devices

The Client Devices tab displays the following details:

n The wired client is listed in the Client Devices table only if the client is connected to an Aruba 2540 Switch
Series, Aruba 2920 Switch Series, Aruba 2930F Switch Series, Aruba 2930M Switch Series, Aruba 3810
Switch Series, Aruba 5400R Switch Series, or any of the AOS-CX switches.

n The VLAN Type, Primary VLAN ID, and Primary VLAN Name columns are not displayed for AOS-CX
switches.

n Name—Displays the name of the client device.
n Status—Displays the status of the client as Connected, Disconnected, Failed, Connecting, or

Denylisted.
n Port—Displays the port number of the switch the client device is connected to. If the port is part of a

LAG, the LAG name is displayed.
n MAC Address—Displays the MAC address of the client device.
n IP Address—Displays the IP address of the client device. The IP address is displayed only if the client

is directly connected to the switch or if the IP tracker is enabled on the switch. IP tracker is not
available for AOS-CX switches.

n VLAN ID—Displays the VLAN ID of the client device.
n VLAN Name—Displays the VLAN name of the client device.
n VLAN Type—Displays the following VLAN types of the client device:

o Normal—The subnetwork which can group devices on separate physical LANs.
o Primary—The standard VLAN that is partitioned to create a private VLAN.
o Isolated—Secondary VLAN that carries unidirectional traffic upstream from the hosts toward the

promiscuous ports.
o Community— Secondary VLAN that forwards traffic between ports which belong to the same

community and to the promiscuous ports.
n Primary VLAN ID—Displays the primary VLAN ID of the client device.
n Primary VLAN Name—Displays the primary VLAN name of the client device.
n Authentication—Displays the authentication type of the client device.
n Usage—Displays the total data usage by the client device for the selected time period.
n Tunneled—Indicates whether the client is a tunneled client or not. Yes or No.
n Segmentation—Displays the type of dynamic segmentation configured for the client. Supported

values are UBT, PBT, Underlay, Overlay, or None.
n Switch Role—Name of the role that the switch assigns to the client.
n Gateway Role—Name of the role that the controller assigns to the client.
n Gateway Name—Name of the controller.

The wired client will show up in the Client Devices table only if the client is connected to an Aruba 2540 Switch
Series, Aruba 2920 Switch Series, Aruba 2930F Switch Series, Aruba 2930M Switch Series, Aruba 3810 Switch
Series, Aruba 5400R Switch Series, or any of the AOS-CX Switch Series.
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Actions

The Actions tab displays the various options available for remote administration of the switch. The
following options are available:

n Reboot—Reboots the switch. See Rebooting Switches.
n Tech Support—Allows the administrators to generate a tech support dump for troubleshooting the

device. See Troubleshooting Aruba Switches.
n Console—Opens the remote console for a CLI session through SSH. Ensure that you allow SSH over

port 443. The default user ID is admin, but you can edit and customize the user ID. This custom user
ID must be mapped to the device. See Opening Remote Console for Switch.

n VSF Switchover—Triggers the standby conductor switch to take over the conductor role. This option
is applicable only for AOS-CX switch stacks. See VSF Switchover.

For AOS-CX 8320 and 8325 switch series, you must enable SSH server on the default VRF. Add the ssh server

vrf default code to the template.

If the Copy and Paste function from the keyboard shortcut keys (CTRL+C and CTRL+V) do not work in your web
browser, use the Copy and Paste functions available under the menu options in the web browser.

You can only troubleshoot Aruba switches using the Console option in Aruba Central. You cannot configure the
switches.

Switch > Clients > Neighbors
In the switch dashboard, the Neighbors tab displays details about the neighboring devices on AOS-S,
AOS-CX, and third-party switches.

Viewing the Clients > Neighbors Tab
To navigate to the Clients tab in the switch dashboard, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global. Ensure that the filter selected contains at
least one active switch.

The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

3. Click a switch listed under Device Name.

The dashboard context for the specific switch is displayed.

4. Under Manage, click Clients > Neighbors.

The Neighbors tab is displayed.

5. To exit the switch dashboard, click the back arrow on the filter.

You can change the time range for the Neighbors tab by clicking the time range filter and
selecting one of the available options: 3 hours, 1 day, 1 week, 1 month, or 3 months.
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Neighbor Devices

The Neighbors tab displays the following details:

n MAC Address—Displays the MAC address of the neighboring device.
n Hostname—Displays the hostname of the neighboring device.
n IP Address—Displays the IP address of the neighboring device.
n Description—Displays the description of the neighboring device.
n Local Port—Displays the local port number of the neighboring device.
n Remote Port—Displays the remote port number of the neighboring device.
n Capabilities—Displays the capabilities of the neighboring device.
n VLAN ID(s)—Displays the VLAN IDs of the neighboring device.

Actions

The Actions tab displays the various options available for remote administration of the switch. The
following options are available:

n Reboot—Reboots the switch. See Rebooting Switches.
n Tech Support—Allows the administrators to generate a tech support dump for troubleshooting the

device. See Troubleshooting Aruba Switches.
n Console—Opens the remote console for a CLI session through SSH. Ensure that you allow SSH over

port 443. The default user ID is admin, but you can edit and customize the user ID. This custom user
ID must be mapped to the device. See Opening Remote Console for Switch.

n VSF Switchover—Triggers the standby conductor switch to take over the conductor role. This option
is applicable only for AOS-CX switch stacks. See VSF Switchover.

For AOS-CX 8320 and 8325 switch series, you must enable SSH server on the default VRF. Add the ssh server

vrf default code to the template.

If the Copy and Paste function from the keyboard shortcut keys (CTRL+C and CTRL+V) do not work in your web
browser, use the Copy and Paste functions available under the menu options in the web browser.

You can only troubleshoot Aruba switches using the Console option in Aruba Central. You cannot configure
the switches.

Switch > LAN > Ports
In the switch dashboard, the Ports tab displays details about ports and the LAGs configured in the AOS-
S, AOS-CX, and third-party switches in the network.

The Ports tab displays the following details:

n Port Status
n Faceplate
n Ports
n LAGS
n Viewing Port-Level Information
n Actions
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Viewing the LAN > Ports Tab
To navigate to the Ports tab in the switch dashboard, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global. Ensure that the filter selected contains at
least one active switch.

The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

3. Click a switch listed under Device Name.

The dashboard context for the specific switch is displayed.

4. Under Manage, click LAN > Ports.

The Ports tab is displayed.

5. To exit the switch dashboard, click the back arrow on the filter.

You can change the time range for the Ports tab by clicking the time range filter and selecting one
of the available options: 3 hours, 1 day, 1 week, 1 month, or 3 months.

Port Status

The Port Status section displays the total number of ports for the following:

n Up—Ports in up state
n Down—Ports in down state
n Alert—Alerts generated
n Uplink—Number of uplink ports

Faceplate

This section is not available for third-party switches.

If the switch is a standalone switch, the faceplate of the switch is displayed. For a switch stack, faceplate
of all the switches part of the stack is displayed. From the faceplate, click on the port to drill down and
view port-level information. On the switch faceplate, hover over a port to view the following details:

n Port
n Name
n Type
n Speed
n LAG
n Reason (Applicable only to AOS-CX switches)

Ports

The Ports table displays the following details:

n Port—Port number. Use the column filter to search for a particular port and use the sort option to
sort the ports in ascending or descending order.

n Name—Name of the switch.
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n Status—Status of the switch. Use the column filter to filter by status.
n Type—Type of switch port. Use the column filter to filter by type.
n MTU (Bytes)—MTU size of the switch.
n Speed (Mbps)—Port speed of the switch.
n Duplex—The duplex configuration for the client traffic.
n LAG—If the port is part of a trunk group or LAG, the name of the trunk group or LAG is displayed.
n Admin—Admin status of the switch.
n MAC Address-MAC address of the switch.
n VLAN—VLAN ID of the port.
n VLAN Mode—VLAN mode of the port. Supported values are Access or Trunk.
n Native VLAN—Native VLAN ID of the port.
n Reason—Indicates the reason when the switch is down. This field is displayed only for AOS-CX

switches.

LAGS

The LAGs table displays the list of LAGs along with the following details:

n Name—Name of the LAG. Use the sort option to sort the LAGs in ascending or descending order.
n Up Ports—Number of uplink ports in the LAG and their port numbers.
n Down Ports—Number of downlink ports in the LAG and their port numbers.
n VSX—Indicates whether VSX is enabled or disabled in the LAG. This column is displayed only for AOS-

CX switches.

Viewing Port-Level Information

This section is not available for third-party switches.

Use one of the following options to navigate to the port and view port-level information:

n In the switch faceplate, click on the port number.
n In the Ports table, click the port number.

The port-level information page consists of the following sections:

n Status—The Status section displays the following details:
o Operational status
o Admin status
o Type of port
o Description
o MAC Address
o Name
o Untagged VLAN
o Tagged VLAN
o Trunk group
o Usage In
o Usage Out
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n Port Usage—The Port Usage section provides a graphical representation of data received and
transmitted by the port. Each line in the graph is a sum of the received and sent traffic for a given
uplink port.Hover over the graph to view data for a particular time of the day.

n Frame Counters—The Frame Counters section provides a graphical representation of the interface
frame counters. From the drop-down, select one of the following options:
o Unicast
o Broadcast
o Multicast
o Discards
o Error

Actions

This section is not available for third-party switches.

The Actions tab displays the various options available for remote administration of the switch. The
following options are available:

n Reboot—Reboots the switch. See Rebooting Switches.
n Tech Support—Allows the administrators to generate a tech support dump for troubleshooting the

device. See Troubleshooting Aruba Switches.
n Console—Opens the remote console for a CLI session through SSH. Ensure that you allow SSH over

port 443. The default user ID is admin, but you can edit and customize the user ID. This custom user
ID must be mapped to the device. See Opening Remote Console for Switch.

n VSF Switchover—Triggers the standby conductor switch to take over the conductor role. This option
is applicable only for AOS-CX switch stacks. See VSF Switchover.

For AOS-CX 8320 and 8325 switch series, you must enable SSH server on the default VRF. Add the ssh server

vrf default code to the template.

If the Copy and Paste function from the keyboard shortcut keys (CTRL+C and CTRL+V) do not work in your web
browser, use the Copy and Paste functions available under the menu options in the web browser.

You can only troubleshoot Aruba switches using the Console option in Aruba Central. You cannot configure the
switches.

Switch > LAN > PoE
In the switch dashboard, the PoE tab displays details, such as, PoE status summary, PoE ports, and PoE
consumption.

The PoE tab displays the following details:

n PoE Status
n Faceplate
n Ports PoE
n PoE Consumption
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n Viewing PoE Port-Level Information
n Actions

Viewing the LAN > PoE Tab
To navigate to the PoE tab in the Switch dashboard, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global. Ensure that the filter selected contains at
least one active switch.

The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

3. Click a switch listed under Device Name.

The dashboard context for the specific switch is displayed.

4. Under Manage, click LAN > PoE.

The PoE tab is displayed.

5. To exit the Switch dashboard, click the back arrow on the filter.

You can change the time range for the PoE tab by clicking the time range filter and selecting one
of the available options: 3 hours, 1 day, 1 week, 1 month, or 3 months.

The PoE tab is displayed only if the AOS-S or the AOS-CX switch supports PoE.

The PoE tab displays monitoring data only if the AOS-S firmware version is 16.08.0001 or later.

PoE Status

The PoE Status section displays the following details:

n Available—Power available for consumption for the switch or stack.
n Used—Power used by various devices.
n Remaining—Power remaining to be utilized in the stack or device.
n PoE Denied Ports—Number of ports for which power is denied.
n Alerts—Number of alerts generated.

Faceplate

If the switch is a standalone switch, the faceplate of the switch is displayed. For a switch stack, faceplate
of all the switches part of the stack is displayed. From the faceplate, click on the port to drill down and
view port-level information. On the switch faceplate, hover over a PoE port to view the following details:

n Port
n Name
n Type
n Class
n Priority
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From the Context drop-down list, select the context:

n POE-STATUS—Displays the sate of each port. The state can be: Uplink, Drawing, Enabled, Disabled,
or Alert.

n POE-CLASS—Power class of the PoE port. The class can be: Class0, Class1, Class2, Class3, Class4, or
Disabled.

n POE PRIORITY—PoE priority configured on the port. The priority can be: Critical, High, or Low.

Ports PoE

The Ports PoE table displays the following details:

n Port—Port number.
n Name—Name of the port.
n PoE—PoE state: Enabled or Disabled.
n Priority—PoE priority: Critical, High, or Low.
n Status—Current power status of the PoE port: Searching, Delivering, Disabled, or Fault.
n Pre-STD Detect—Displays whether PoE for pre-802.3af-standard powered devices is enabled on the

switch: On or Off.
n Alloc Actual—Power actually being used on the port.
n Alloc Configured—The maximum amount of power allocated for the port.
n PLC Class—Power class of the PoE port.
n PLC Type—Physical layer classification type.

PoE Consumption

The PoE Consumption section displays a trend chart for the PoE power drawn from the Switch in watts.
Hover your mouse over the trend chart to view the PoE power drawn at a particular time. For a stack,
select the switch from the drop-down list to view the PoE consumption for the specific device.

Viewing PoE Port-Level Information

Use one of the following options to navigate to the PoE port and view port-level information:

n In the switch faceplate, click on the port number.
n In the Ports PoE table, click the port number.

The port-level information page consists of the following tabs:

n Summary
n Slot Info & PoE Configuration
n LLDP Information

Summary
The Summary tab displays the following sections:

n Summary—Displays the following details:
o PSE Reserved Power—Power reserved for the port in the Power Sourcing Equipment (PSE).
o PSE Voltage—Total voltage, in volts (V), currently being delivered to the powered device

connected to the port
o PD Power Draw—Power drawn by the powered device.
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o PD Amperage Draw—Amperage drawn by the powered device.
o Over Current Count—Number of times a powered device connected to the port attempted to

draw more power than was allocated to the port.
o MPS Absent Count—Number of times the powered device has no longer requested power from

the port MPS is Maintenance Power Signature.
o Power Denied Count—Number of power requests from the port that were denied because

sufficient power was unavailable.
o Short Count—Number of times the switch provided insufficient current to the powered device

connected to the port.
n PoE Consumption—Displays the trend chart for PoE consumption and power available for the

duration specified in the time range filter.

Slot Info & PoE Configuration
The Slot Info & PoE Configuration tab displays the following sections:

n PoE Slot Information—Displays the following details:
o Slot—Slot where the port is located.
o Operation Status—Displays PoE power is available for the slot: On, Off, or Faulty.
o Maximum Power—Maximum PoE wattage available to provision active PoE ports in the slot.
o Power In Use—PoE power currently being used by the slot.
o Usage Threshold—Configured percentage of available PoE power provisioning the switch must

exceed to generate a usage notice.
n PoE Configuration—Displays the following details:

o PoE Power—Displays whether PoE power is enabled on the port.
o Pre STD Detect—Displays whether PoE for pre-802.3af-standard powered devices is enabled on

the switch: On or Off. This field is not displayed for AOS-CX switches.
o PoE Port Status—Current power status of the PoE port: Searching, Delivering, Disabled, or Fault.
o Power Priority—Power priority configured on ports enabled for PoE: Low, High, or Critical.
o Allocate by Configuration—Maximum amount of power allocated for the port.
o Allocate by Actual—Power actually being used on the port.
o PLC Class Type—Physical layer classification type.
o DLC Class Type—Data link layer classification type.
o Configured Type—If configured, shows the user-specified identifier for the port. If not

configured, this field is empty.
o PoE Value configuration—PoE power value configured for the port. This field is not displayed for

AOS-CX switches.

LLDP Information
The LLDP Information tab displays the following details:

n UPSE Allocated Power—Power allocated for the port in the PSE.
n PD Requested Power—Power requested by the powered device.
n PD TLV Sent Type—TLV that is actually sent from the powered device.
n PSE TLV Configured—TLV that is configured for the switch port to send to the powered device.
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n PSE TLV Sent Type—TLV that is actually sent from the PSE.
n MED LLDP Detect—Status of the PoE LLDP detection.

Actions
The Actions tab displays the various options available for remote administration of the switch. The
following options are available:

n Reboot—Reboots the switch. See Rebooting Switches.
n Tech Support—Allows the administrators to generate a tech support dump for troubleshooting the

device. See Troubleshooting Aruba Switches.
n Console—Opens the remote console for a CLI session through SSH. Ensure that you allow SSH over

port 443. The default user ID is admin, but you can edit and customize the user ID. This custom user
ID must be mapped to the device. See Opening Remote Console for Switch.

n VSF Switchover—Triggers the standby conductor switch to take over the conductor role. This option
is applicable only for AOS-CX switch stacks. See VSF Switchover.

For AOS-CX 8320 and 8325 switch series, you must enable SSH server on the default VRF. Add the ssh server

vrf default code to the template.

If the Copy and Paste function from the keyboard shortcut keys (CTRL+C and CTRL+V) do not work in your web
browser, use the Copy and Paste functions available under the menu options in the web browser.

You can only troubleshoot Aruba switches using the Console option in Aruba Central. You cannot configure the
switches.

Switch > LAN > VLAN
In the switch dashboard, the VLAN tab displays VLAN information configured on the AOS-S, AOS-CX, and
third-party switches and details about tagged and untagged ports.

The VLAN tab displays the following details:

n VLANs
n Faceplate
n Actions

Viewing the LAN > VLAN Tab
To navigate to the VLAN tab in the switch dashboard, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global. Ensure that the filter selected contains at
least one active switch.

The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

3. Click a switch listed under Device Name.

The dashboard context for the specific switch is displayed.
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4. Under Manage, click LAN > VLAN.

The VLAN tab is displayed.

5. To exit the switch dashboard, click the back arrow on the filter.

You can change the time range for the VLAN tab by clicking the time range filter and selecting
one of the available options: 3 hours, 1 day, 1 week, 1 month, or 3 months.

VLANs

The VLANs table displays the following details:

The Type, Primary VLAN, Promiscuos, ISL, and Jumbo columns are not displayed for AOS-CX switches.

n Name—Displays the name of the VLAN. Click the sort icon to sort the VLAN names in the column.
n ID—Displays the VLAN ID associated with the VLAN.
n Status—Displays the status of the VLAN as Up or Down.
n Type—Displays the following types of VLANs:

o Regular VLAN—A regular VLAN is a single broadcast domain.
o Private-Primary—The regular VLAN which partitions one broadcast domain into multiple smaller

broadcast sub-domains.
o Private-isolated—Secondary VLAN that carries unidirectional traffic upstream from the hosts

toward the promiscuous ports.
o Private-Community—Secondary VLAN that forwards traffic between ports which belong to the

same community and to the promiscuous ports.
n Primary VLAN—Displays the primary VLAN details.
n Promiscuous—Displays the promiscuous port value. A promiscuous port is a switch port that is

connected to an uplink router, firewall, or other common gateway device, and can communicate with
all ports within a private VLAN, including the ports in the isolated and community VLANs. By default,
every primary VLAN port acts as a promiscuous port.

n ISL—Displays the Inter-switch Link (ISL) port value (range). ISL port is also called PVLAN member port.
ISL port is required in multi-switch PVLAN configurations to span the switches. The ISL port will
automatically become a member of all VLANs within the PVLAN and it carries traffic from the primary
VLAN and all secondary VLANs.

n Tagged Ports—Displays the ports that have marked the VLAN as tagged.
n Untagged Ports—Displays the ports that have marked the VLAN as untagged.
n IP address—Displays the IP address of the VLAN.
n Voice—Displays whether the Voice is enabled or disabled for the VLAN.
n IGMP—Displays whether the IGMP is enabled or disabled for the VLAN.
n Jumbo—Displays whether the Jumbo packets are enabled or disabled for the VLAN.

Faceplate

From the VLANs table, select a VLAN to view the tagged and untagged ports, promiscuous port, ISL port,
and the VLAN types in the faceplate.

This section is not available for third-party switches.
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Figure 125 VLANs tab details for AOS-S

Figure 126 VLANs tab details for AOS-CX switch

Actions

This section is not available for third-party switches.

The Actions tab displays the various options available for remote administration of the switch. The
following options are available:

n Reboot—Reboots the switch. See Rebooting Switches.
n Tech Support—Allows the administrators to generate a tech support dump for troubleshooting the

device. See Troubleshooting Aruba Switches.
n Console—Opens the remote console for a CLI session through SSH. Ensure that you allow SSH over

port 443. The default user ID is admin, but you can edit and customize the user ID. This custom user
ID must be mapped to the device. See Opening Remote Console for Switch.
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n VSF Switchover—Triggers the standby conductor switch to take over the conductor role. This option
is applicable only for AOS-CX switch stacks. See VSF Switchover.

For AOS-CX 8320 and 8325 switch series, you must enable SSH server on the default VRF. Add the ssh server

vrf default code to the template.

If the Copy and Paste function from the keyboard shortcut keys (CTRL+C and CTRL+V) do not work in your web
browser, use the Copy and Paste functions available under the menu options in the web browser.

You can only troubleshoot Aruba switches using the Console option in Aruba Central. You cannot configure
the switches.

Switch > VSX
Aruba Virtual Switching Extension (VSX) is virtualization technology for aggregation and core AOS-CX
switches. The VSX solution lets the switches present as one virtualized switch in critical areas.

VSX is supported in the AOS-CX 6400, AOS-CX 8320, and AOS-CX 8325 Switch Series.

Aruba Central On-Premises provides support for VSX by displaying information about the configurations
of the switches and the status of the inter-switch link (ISL) between the switches.

Viewing the VSX Page
To navigate to the VSX page in the Switch dashboard, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Group, Label,
or Site. Ensure that the filter selection contains at least one AOS-CX switch. For all devices, set the
filter to Global.
The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

3. Click an AOS-CX switch under Device Name.

The dashboard context for the switch is displayed.

4. Under Manage, click VSX.

The VSX page displays the following details:
n VSX Summary
n Info
n Actions

5. To exit the switch dashboard, click the back arrow on the filter.

VSX Summary

Displays state information of the switch, connections to the peer switch, and the role of the switch in the
VSX configuration.

Field Description

ISL State State of the ISL connection with the peer AOS-CX switch. Following are the supported values:

Table 188: VSX Summary Details
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Field Description

n WAITING_FOR_PEER—Waiting for connectivity to the peer.
n PEER_ESTABLISHED—Steady state. VSX LAGs are up when the device is in this state.
n SPLIT_SYSTEM_PRIMARY—Lost ISL connectivity to the peer and the device is operating

as primary.
n SPLIT_SYSTEM_SECONDARY—Lost ISL connectivity to the peer and the device is

operating as secondary.
n SYNC_PRIMARY—ISL connectivity to the peer restored and the device is syncing states

to the peer.
n SYNC_SECONDARY—ISL connectivity to the peer restored and he device is learning

states from the peer. VSX LAGs are down when the device is in this state.
n SYNC_SECONDARY_LINKUP_DELAY—Device has learned its states from the peer and

monitoring for hardware is to be programmed. VSX LAGs are down when the device is in
this state.

ISL Mgmt State Management state of the ISL. Following are the supported values:
n OPERATIONAL—ISL management is operational.
n INTER_SWITCH_LINK_MGMT_INIT—ISL management is in initialization state.
n CONFLICTING_OR_MISSING_DEVICE_ROLES—Either the role is missing on one of the

VSX peers or the same role is configured on both VSX peers.
n SW_IMAGE_VERSION_MISMATCH_ERROR—Software version on the primary device

does not match with the software version on the secondary device.
n INTER_SWITCH_LINK_DOWN—ISL is down.
n INTERNAL_ERROR—ISL management has internal errors.

Config Sync
Status

Status of the configuration synchronization between the VSX switches. Following are the
supported values:
n IN-SYNC—Configuration synchronization is operational and the VSX switches are in

sync.
n DISABLED—Configuration synchronization is disabled.
n SW_IMAGE_VERSION_MISMATCH_ERROR—Software image version on the primary

device does not match with the software image version on the secondary device.
n CONFLICTING_OR_MISSING_DEVICE_ROLES—Either the role is missing on one of the

VSX peers or the same role is configured on both VSX peers.
n PEER_DB_CONNECTION_ERROR—Error in connecting to peer database. It involves

errors due to ISL or ISL management.
n CONFIGURATION_SYNC_CONFLICT—Configuration synchronization is operational but

has conflicts synchronizing the configuration. Conflicts can occur if the configuration on
the primary device is marked for sync, but the same configuration on the secondary
device is not marked for sync.

n CONFIGURATION_SYNC_MISSING_REFERENCE—Configuration synchronization is
operational but has missing references in synchronizing the configuration.

NAE Status of the NAE connection between the VSX switches.

HTTPS Server Status of the HTTPS server connection between the VSX switches.

Last Synched Timestamp of when the configuration was synched between the peer switch.
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Field Description

Last synced data is displayed in the Switch > VSX page only when VSX synchronization is
enabled for the AOS-CX switch. However, enabling VSX synchronization using template
configuration in Aruba Central On-Premises is not recommended. By enabling VSX
synchronization, the peer switch may get into an unknown configuration state.

Role Role of the AOS-CX switch in the VSX configuration. Supported values are Primary and
Secondary

Info

Displays system and configuration information of the switch and its peer. The following details are
displayed:

n System
o Local MAC—MAC address of the selected switch.
o Peer MAC—MAC address of the peer switch.
o Peer Hostname—Hostname of the peer switch.
o Peer IP—IPv4 address of the peer switch.

n Configuration
o Config Sync—Indicates whether the configuration synchronization between the peers are

enabled or disabled.
o ISL Port—Inter-switch Link (ISL) port number of the selected AOS-CX switch. If the ISL is a LAG,

then this field displays the LAG name.
o Peer ISL Port—ISL port number of the peer switch. If the ISL is a LAG, then this field displays the

LAG name.
o MC LAGs—List of MC LAG names present in the switches.

Actions

The Actions tab displays the various options available for remote administration of the switch. The
following options are available:

n Reboot—Reboots the switch. See Rebooting Switches.
n Tech Support—Allows the administrators to generate a tech support dump for troubleshooting the

device. See Troubleshooting Aruba Switches.
n Console—Opens the remote console for a CLI session through SSH. Ensure that you allow SSH over

port 443. The default user ID is admin, but you can edit and customize the user ID. This custom user
ID must be mapped to the device. See Opening Remote Console for Switch.

n VSF Switchover—Triggers the standby conductor switch to take over the conductor role. This option
is applicable only for AOS-CX switch stacks. See VSF Switchover.
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For AOS-CX 8320 and 8325 switch series, you must enable SSH server on the default VRF. Add the ssh server

vrf default code to the template.

If the Copy and Paste function from the keyboard shortcut keys (CTRL+C and CTRL+V) do not work in your web
browser, use the Copy and Paste functions available under the menu options in the web browser.

You can only troubleshoot Aruba switches using the Console option in Aruba Central. You cannot configure the
switches.

Rebooting Switches
You can reboot a switch using the Aruba Central On-Premises UI.

To reboot a switch, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. Ensure that the filter selection contains at least one switch. For all devices, set
the filter to Global.
The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

3. Click Online to display a table with the list of online switches.
4. In the Switches table, click the switch to reboot.

The Switches Details page corresponding to the switch is displayed.

5. In the Actions drop-down, click Reboot.
A Reboot Switch dialog box is displayed.

6. Click Continue to reboot the switch.

All clients connected to this switch are disconnected and the switch reboots.

The Switches Details page takes less than a minute to update the interface status after the switch is rebooted
and reconnected to Aruba Central On-Premises.

Opening Remote Console for Switch
In the Aruba Central On-Premises UI, you can open the remote console for a CLI session through SSH
for a switch. Ensure that you allow SSH over port 443.

For AOS-CX 8320 and 8325 switch series, you must enable SSH server on either the default VRF or the
management VRF depending on the type of VRF that the switch uses to connect to Aruba Central On-
Premises. You must add one of the following commands in the template:

n If the switch is connecting to Aruba Central On-Premises using inline default VRF, add ssh server

vrf default to the template.
n If the switch is connecting to Aruba Central On-Premises using OOBM management VRF, add ssh

server vrf mgmt to the template.

You can only troubleshoot switches using the Console option in Aruba Central On-Premises. You cannot
configure the switches.



Monitoring Your Network | 874

To open the remote console for a switch, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. Ensure that the filter selection contains at least one switch. For all devices, set
the filter to Global.
The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

3. Click Online to display a table with the list of online switches.
4. In the Switches table, click the switch for which you want to open the remote console.

The Switch Details page corresponding to the switch is displayed.

5. In the Actions drop-down, click Open Remote Console.

A CLI session dialog box is displayed. The default user ID is admin, but you can edit and
customize the user ID. This custom user ID must be mapped to the device.

Troubleshooting Aruba Switches
You can troubleshoot a switch using the Aruba Central On-Premises UI.

To troubleshoot a switch, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. Ensure that the filter selection contains at least one switch. For all devices, set
the filter to Global.
The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

3. In the Switches table, click the switch to troubleshoot.

The Switch Details page corresponding to the switch is displayed.

4. In the Actions drop-down, click Tech Support.
The Commands page is displayed.

5. Select any command category in the Categories pane and the Commands pane displays the
associated commands.

AOS-CX switches support only the show tech and show running-config commands.

6. Click Add > to add the selected commands to the Selected Commands pane.
7. If you have selected a command marked with either '*' or '+', enter the filtration parameters as

displayed in the Additional Filters dialog box. For more information on filtering commands, see
Filtering Commands.

8. (Optional) Select command(s) and click < Remove to remove selected command(s) or click <
Remove All to clear the Selected Commands pane.

9. (Optional) To set a frequency for automatically executing the troubleshooting commands:
a. Click the Repeat check box.
b. Specify an interval for executing the troubleshooting commands. You can also specify how

frequently the commands must be executed during a given interval.
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c. Click Reset to modify the values in all the fields, and Cancel All for canceling all the repeats.
Click the stop icon to stop a particular repeat.

10. Click Run. The output is displayed in the Device Output section.

For information about viewing and downloading the output, see Viewing the Device Output.

Troubleshooting AOS-CX Switch Onboarding Issues
Though an AOS-CX switch is displayed as online, there might be instances where the complete switch
details are not displayed. To troubleshoot such issues, you can see the audit trail page to check the
status of the switch.

To see the audit trail for a switch, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. Ensure that the filter selection contains at least one switch. For all devices, set
the filter to Global.
The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Switches.

A list of switches is displayed.

3. In the Switches table, click the switch you wish to troubleshoot.

The dashboard context for the switch is displayed.

4. Under Analyze, click Audit Trail.
The Audit Trail page is displayed.

If a switch is onboarded successfully, the audit trail log displays the following messages:
a. Device : <Device Serial Number> Onboarded
b. Applying template <Template Configuration Name> to device
c. Login Successful reading running configuration
d. Config push successful

If applying template configuration to the AOS-CX switch fails, the Template/Variable
Configuration Error error message is displayed:

If any of the messages listed in step 4b, 4c, 4d, or Template/Variable Configuration Error is not
displayed in the audit trail logs, one of the following might be the reason:

n User has not created a template group with template configuration for the AOS-CX switch.
n User has created a template group with template configuration but has not moved the AOS-CX

switch to the template group.

The following image displays the audit trail log of a switch that is successfully onboarded.
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Figure 127 Example audit trail log for successfully onboarded AOS-CX switch

Controller > Overview > Summary
The Summary tab under Manage > Overview in the controller dashboard displays the following two
sections:

n Device Info
n Health Status

Viewing the Overview > Summary Tab
To navigate to the Summary tab in the controller dashboard, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. Ensure that the filter selection contains at least one controller. For all devices,
set the filter to Global.
The dashboard context for the selected filter is displayed.

2. Under Manage > Devices, click the Controllers tab.

A list of controllers is displayed.

3. Click a controller or cluster under Device Name.

The dashboard context for the specific controller or cluster is displayed.

4. Under Manage, click Overview > Summary.

To exit the controller dashboard, click the back arrow on the filter.

You can change the time range for the Summary tab by clicking the time range filter and
selecting one of the available options: 3 hours, 1 day, 1 week, 1 month, and 3 months.

Device Info
The Device Info section displays the following details.
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Figure 128 Device Info

n Name—The name of the controller.

n Serial Number—Serial number of the controller.
n Model—The hardware model of the controller.
n MAC Address—The MAC address of the controller.
n System IP address—The IP address of the controller.
n Firmware Version—The firmware version running on the controller. If a new version of the firmware

is available, this information is also displayed. Clicking on the new firmware version redirects you to
the Maintain > Firmware > controller page in the controller dashboard, where you can select the
controller to upgrade it.

n Group Name—The name of the group, if the controller is configured as part of a group. Click the
group name to go to the Overview > Summary page for that group.

n Labels—The name of the label, if the controller is configured as part of a single or multiple labels.
n Site—The name of the site, if the controller is configured as part of a site. Hover over the i icon to

display the complete address of the site. Click the site name to go to the Overview > Site Health page
for that site.

n Role— The role of the controller; for example, conductor or local.
n Conductor— The name of the conductor controller.
n Last Reboot Reason—The reason for the last reboot.
n POE (DRAW/MAX)—The amount of power that the devices connected to the controller consume and

the maximum PoE power capacity. For example, if the value displayed is 6/120, the devices draw 6
watts and the maximum PoE power allocated is 120 watts.

n Redundancy Peer—Displays the redundant controller if it is configured.
n NTP Server—The name of the NTP server configured and its synchronization status.
n Cluster Name—The name of the cluster controller.
n 4G/LTE Modem Status—Displays the modem connectivity status. The status shows only 'Connected'

when the modem type is not internal.
n 4G/LTE Modem Type—Displays the LTE connection type.

n Location—The currently configured physical location of the controller. Location details are displayed
only for controllers running on firmware version ArubaOS 8.9.0.0 or later.

n Contact—The currently configured contact information of the controller. For example, E-mail ID or
contact number. Contact details are displayed only for controllers running on firmware version
ArubaOS 8.9.0.0 or later.
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n Last Contacted—The date and time when the controller last contacted Aruba Central On-Premises.
n Uptime—The time since the last boot denoted in hours and minutes.

Health Status
The Health Status section displays the health of the controller in terms of CPU, Memory and device
connectivity to Aruba Central On-Premises.

The health status is plotted using health indicators such as Good, Fair, Poor and Offline. You can hover
over the chart to see the health status for a particular time frame.

The following image indicates the health status of the controller.

Figure 129 Health Status

Viewing the Controllers Tab
To view the Controller dashboard, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Click Devices > Controllers.

Controllers Dashboard
The Controllers dashboard page displays a complete list of offline or online controllers provisioned in
Aruba Central. You can also use the following filtering options to view a specific set of controllers.

n All—Displays a complete list of controllers. For more information, see Monitoring Controllers in List
View.

n Cluster—Displays controller clusters deployed in Aruba Central. A controller cluster includes
multiple controllers working together as a single managed entity. Controller clusters enable seamless
roaming of clients between AP and ensure service continuity in the event of a failover. Controller
clustering is supported only on devices running ArubaOS 8.x or later software versions. To view the
cluster components, expand the cluster in the Cluster Name column. For more information, see
Monitoring Clusters in List View.

n Mobility Conductor—Displays a list of controllers that are functioning as Mobility Conductors. The
Aruba Mobility Conductor is an advanced controller deployed as a virtual machine (VM) or installed
on an x86-based hardware appliance. A single Mobility Conductor or a cluster of Mobility Conductors
oversees co-located controllers. It also displays the details about the APs associated with each
controller. For more information, see Monitoring Mobility Conductors in List View.
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Controller > Access Points > Access Points
The Access Points tab under Manage > Access Points page in the controller dashboard displays
details of all the access points (AP) connected to a specific controller.

Viewing the Access Points > Access Points Tab
To navigate to the Access Points > Access Points tab in the controller dashboard, complete the
following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. Ensure that the filter selection contains at least one controller. For all devices, set
the filter to Global.
The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Controllers.

A list of controllers is displayed.

3. Click a controller under Controller Name.

The dashboard context for the specific controller is displayed.

4. Under Manage, click Access Points.

The Access Points page is displayed.

To exit the controller dashboard, click the back arrow on the filter.

You can change the time range for the Summary tab by clicking the time range filter and selecting one
of the available options: 3 hours, 1 day, 1 week, 1 month, and 3 months.

The Access Points table displays the following details:

n AP Name—Name of the AP. Click an AP name to view the AP details page.
n IP Address—IP address of the AP.
n Status—The status of the AP.
n Serial—The serial number of the device.
n Active—The name of the active controller. Click an active controller name to view the active

controller details page.
n Standby—The name of the standby controller. Click an standby controller name to view the standby

controller details page.
n MAC Address—MAC address of the AP.
n Model—The model number of the AP.

In the Access Points table, the additional columns can be selected by clicking the icon provided at the right
corner of the table. Click the Reset to default button provided in the drop-down list to reset the AP List with
default columns only. To autofit the columns, click the icon and select Autofit columns.

Controller > LAN > Summary
The Summary tab under Manage > LAN page in the controller dashboard displays the following
sections:
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n Port Status
n LAN Interfaces Summary
n VLAN Interfaces Summary

Viewing the LAN > Summary Tab
To navigate to the LAN > Summary tab in the controller dashboard, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. Ensure that the filter selection contains at least one controller. For all devices,
set the filter to Global.
The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Controller.
A list of controllers is displayed.

3. Click a controller or cluster under Device Name.

The dashboard context for the specific controller is displayed.

4. Under Manage, click LAN > Summary.

To exit the controller dashboard, click the back arrow on the filter.

You can change the time range for the Summary tab by clicking the time range filter and
selecting one of the available options: 3 hours, 1 day, 1 week, 1 month, and 3 months.

Port Status
Provides a graphical representation of the controller's LAN link availability. Also provides a quick view of
the LAN port status. Click a LAN port to view the port detail graphs based on Packets or Errors.

Figure 130 Port Status

The following graphs are displayed under the Packets tab:

n Unicast—The number of unicast packets per second.
n Multicast—The number of multicast packets per second.
n Broadcast—The number of broadcast packets per second.

LAN Interfaces Summary
n The table displays the summary of LAN interfaces total number of LAN interfaces. The following

details are displayed for the port:

n Port—Port number.
n Admin State—Administrative state of the LAN interface.
n Operational State—Operational state of the LAN interface.
n Port Speed—Port speed.
n VLANs—Range of VLANs.
n MTU—MTU value.
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Figure 131 LAN Interface Summary

Click a LAN port to view the port detail graphs based on Packets or Errors.

Figure 132 Port Details - Packet

The following graphs are displayed under the Errors tab:

n CRC Errors—The number of cyclic redundancy errors logged.
n Error Frames—The number of error frames logged.
n Collisions—The number of collisions encountered.
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Figure 133 Port Details - Errors

VLAN Interface Summary
n The table displays the summary of VLAN interfaces and total number of VLAN interfaces. The

following details are displayed:

n VLAN ID—VLAN ID number.
n IP Address—IP address.
n Admin State—Administrative state of the VLAN interface.
n Oper. State—Operational state of the VLAN interface.
n Addressing Mode—Type of addressing mode.
n Description—Description of the VLAN.

Figure 134 VLAN Interfaces Summary
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Controller > Overview > Routing
The Routing tab under Manage > Overview in the controller dashboard displays the following sections:

n Routes Summary
n Routes

The details are displayed on the Routing page only if the routing is configured for the controller.

Displays a summary of the IP routes configured on the controller. The following details are displayed:

n Type—The type of IP route.
n Network—IP address of the destination network.
n VIA—IP address through the routes are forwarded.

Viewing the Overview > Routing Tab
To navigate to the Routing tab in the controller dashboard, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. Ensure that the filter selection contains at least one controller. For all devices, set
the filter to Global.
The dashboard context for the selected filter is displayed.

2. Under Manage, click Devices > Controller .

A list of controllers is displayed.

3. Click a controller or cluster under Device Name.

The dashboard context for the specific controller is displayed.

4. Under Manage, click Overview > Routing .

To exit the controller dashboard, click the back arrow on the filter.

You can change the time range for the Routing tab by clicking the time range filter and selecting
one of the available options: 3 hours, 1 day, 1 week, 1 month, and 3 months.

Network Health
The Network Health dashboard displays information of the network sorted by site. This dashboard
displays information on network devices and WAN connectivity of individual sites.

To launch the Network Health dashboard, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Manage, click Overview > Network Health to launch the Network Health dashboard.

The Network Health dashboard has two views—Summary and List. You can toggle between
them by clicking on the view icons.

Offline map is not available on the Summary view.

The Summary and List views are described below:
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n Summary— This view displays the vital network information of individual sites on cards mapped by
geographical location. Sites are marked with location pins- red pin for a site with potential issues and
green pin for a site with no issues. To view the information card of a site, click on the location pin of a
site. Hover over a site to view the Network Health card.

The Network Health menu option in the Manage > Overview section provides detailed information
of the network health status and usage for the sites configured in your setup.

The following table lists the information displayed in a Network Health card.

Item Description

User
experience

Displays the user experience of the devices in the site. This information is displayed when
there is at least one UXI sensor deployed in a site. Clicking on User experience redirects
you to the UXI dashboard for further troubleshooting. The UXI Dashboard allows you to
configure and manage UXI sensors. For more information, see User Experience Insight
Sensors Integration

Insights Displays the number of AI Insight reports available for the site. The reports are organized
by degree- High, Medium, and Low depending on the number of events in the network.

Devices Displays the number of connected and offline APs for the site. Clicking on one of the
numbers redirects you to the Devices dashboard page of the site.

Clients Displays the number of connected and failed clients for the site. Clicking on one of the
numbers redirects you to the Clients dashboard page of the site.

RF Coverage Provides a link to view or configure the floorplan for the site. Clicking on the Floorplan
redirects you to the floor plans page of the site

Uplinks Displays the uplink connectivity status of devices in the site. This information is displayed
when there is at least one uplink in the site.

Tunnels Displays the connectivity status of tunnels in the site. This information is displayed when
there is at least one tunnel in the site.

High Mem
usage

Displays the number of devices with high memory utilization in the site. This information is
displayed when there is at least one device with high memory utilization in the site.

High CPU
usage

Displays the number of devices with high CPU usage in the site. This information is
displayed when there is at least one device with high CPU usage in the site.

High CH
utilization

Displays the number of APs with a higher channel utilization in the 5 GHz and 2.4 GHz radio
bands. This information is displayed when there is at least one AP with a higher channel
utilization in the 5 GHz or 2.4 GHz radio bands in the site.

High noise
utilization

Displays the number of APs with high RF noise in the 5 GHz and 2.4 GHz bands. This
information is displayed when there is at least one AP with a higher noise utilization in the
5 GHz or 2.4 GHz radio bands in the site.

Table 189: Network Health Card

n List—This view displays the global network report in a list sorted according to individual sites.
Clicking on the site name will take you to the Site Health dashboard page. The data columns listed in
the page can be managed by clicking on the hamburger icon ( ) on the right of the column header.
The report can be filtered by clicking on the filter labels below the column name. Selecting a filter
label filters the results based on the field values of the column is ascending or descending order,
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sites with zero issues will not be displayed. The order of the results displayed can be toggled by

clicking the or icon beside the filter.

The Network Health dashboard displays the information listed in the table below.

Header Description

Site Name The name of the site. Clicking on the site name will take you to the Site Health dashboard
page (Site > Overview > Site Health tab). To search for a site by name, click on the Site Name
label and enter the name of the site.

AI Insights Displays the number of AI Insight reports available for the site. The reports are organized by
degree- High, Medium, and Low depending on the number of events in the network.

Number of Devices

Status The number of devices that are in Up or Down state in a site. Click the List icon and hover your
mouse over a field in the column to view the following details:

n WLAN Devices Down
n Wired Devices Down
n Branch Devices Down

High
Memory
Usage

The number of devices with high memory utilization in the site. Click the List icon and hover
your mouse over a field in the column to view the following details:

n WLAN High Memory
n Wired High Memory
n Branch High Memory

High CPU
Usage

The number of devices with high CPU usage in the site. Click the List icon and hover your
mouse over a field in the column to view the following details:

n WLAN CPU High
n Wired CPU High
n Branch CPU High

High CH
Utilization

The number of APs with a higher channel utilization in the 5 GHz and 2.4 GHz radio bands.

Clients Displays the number of connected and failed clients for the site.

High Noise The number of APs with high RF noise in the 5 GHz and 2.4 GHz bands.

WAN

Uplink
Status

Displays the uplink connectivity status of devices in the site. The data is classified into two
columns: devices with no issues and devices with no uplink connectivity.

Tunnel
Status

Displays the connectivity status of tunnels in the site. The data is classified into two columns:
tunnels with no issues and tunnels with no connectivity.

Table 190: Network Health Dashboard
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Global—Summary
In the Global dashboard, the Summary tab displays the Usage, Clients, Bandwidth Usage Per
Network, Client Count Per Network, Top APs By Usage, Top Clients By Usage, Top IAP Clusters By
Usage, Top IAP Clusters By Clients, and WLAN network details.

You can change the time range for the Summary tab by clicking the time range filter and selecting one
of the available options: 3 hours, 1 day, 1 week, 1 month, and 3 months.

Viewing the Global Summary Page
To navigate to the Global Summary page, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
The dashboard context for the selected filter is displayed.

2. Under Manage, click Overview > Summary.

The Global Summary page is displayed.

The Global Summary page displays the following information:

Data Pane
Item Description

Usage Displays the incoming and outgoing data traffic detected on the APs.

Clients Displays the number of clients connected to an AP over a specific time period.

Bandwidth
Usage Per
Network

Displays the incoming and outgoing traffic for all APs per SSID over a specific duration.

Client Count
Per Network

Displays the number of clients connected to an AP per SSID over a specific time period.

Top APs By
Usage

Displays the list of top APs that utilize the maximum bandwidth in the network. Bandwidth
usage includes the sum total of data transmitted and received on the radio interfaces and
wired clients connected to the AP.

Top Clients
By Usage

Displays the list of top clients connected to the currently available SSIDs that utilize the
maximum bandwidth in the network.

Top
IAP Clusters
By Usage

Displays the list of top AP clusters that utilize the maximum bandwidth in the network.

Top
IAP Clusters
By Clients

Displays the list of top AP clusters connected to the client that utilize the maximum
bandwidth in the network.

WLANs Displays the list of SSIDs configured. The WLANs table displays the SSID details such the
Name, Clients, Type, and Security.

Table 191: Global Summary Page Parameters

Site Health Dashboard
The Site Health dashboard displays details of wired and wireless devices deployed on the site. This
page includes information on client connectivity statistics, change logs, health of devices, and RF health
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of the site.

To launch the Site Health dashboard, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a site.
2. Under Manage, click Overview > Site Health to launch the Site Health dashboard.

Alternatively, the Site Health dashboard can be accessed by selecting a site from the Network Health
dashboard page.

Health Bar
The Health Bar provides a snapshot of the overall health of the devices configured at the site. If there
are any potential issues, it is indicated by the status icon and corresponding descriptions are
displayed. When there are multiple criteria issues, only the issue criteria with the highest priority is
displayed. The <+x> next to the description indicates that there are more issues. You can hover over the
value to view the description of the issue in a pop-up window. For more information, see Health Bar
Dashboard for Site.

The descriptions displayed for the Potential Issue are corresponding to the issue encountered at the
site. The following is a list of possible messages:

n Offline controller
n Offline switch
n Offline access point
n Access point high noise floor (2.4 GHz)
n Access point high noise floor (5 GHz)
n Controller high CPU usage
n Access point high CPU usage
n Switch high CPU usage
n Controller high memory usage
n Access Point high memory usage
n Switch high memory usage
n Access point high channel utilization (2.4 GHz)
n Access point high channel utilization (5 GHz)
n Silverpeak state <major or critical alarm>
n Cape network state <issue>
n Uplink down
n Tunnel down

To launch the Health Bar, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a site.
2. Under Manage, click Overview > Site Health.

3. Click the status icon next to the site name.

The Health Bar pop-up window is displayed.

4. Click the pin icon to pin the Health Bar to the Site Health page.

For information about what the status icons and the indicators denote, see Health Bar Icons.

The following figure displays the site health bar page.
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Figure 135 Site Health Bar

The Site Health dashboard displays the information listed in the table below.

Content

Name Name of the site.

Location Location of the site.

Timezone Timezone name and local time. For example, IST-11:25 AM.

APs Number of APs deployed on the site.

Switches Number of switches deployed on the site.

Controllers Number of controllers deployed on the site.

Summary Statistics A graphical representation of the number of clients (wired and
wireless) and their bandwidth usage for the selected time range.

Change Log A visual representation of change logs for configuration, firmware,
and reboot changes in the selected time range. Select a column in
the graph and click on the Config Log, Firmware Log and Reboot
Log button to view detailed information logs on the
corresponding events in the site.

System Health Indicators

Down Devices This graph shows the count of devices with DOWN status. The
graph displays the following information:
n Total number of devices
n Number of unique devices that were DOWN
n Minimum and maximum device downtime.

Table 192: Site Health Dashboard
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Content

To view more details, select a time range in the graph and click on
See Devices. A pop-up window displays the details of devices with
DOWN status and their Up and Down time in percentage. You can
also add other metrics such as CPU, Memory, 5 GHz and 2.4 GHz
Channel Utilization, and 5 GHz and 2.4 GHz Noise Floor by clicking
on the Add Metric button. A particular device can be filtered from
the list by clicking on the filter icon and entering the name of
the device.

High CPU & High Memory This graph shows the total count or percentage of devices with
high CPU utilization and high memory utilization.
n High CPU Utilization—This graph displays the total number

of devices, number of unique devices with high CPU
utilization, and minimum and maximum number of devices
with high CPU utilization. You can also view the total count or
percentage of maximum and minimum number of devices
with high CPU utilization for a specific time when you hover
your mouse over the graph.

n High Memory Utilization—This graph displays the total
number of devices, number of unique devices, the minimum
and maximum number of devices with high memory
utilization. You can also view the total count or percentage of
maximum and minimum number of devices with high
memory utilization for specific time when you hover your
mouse over the graph.

n Threshold Setting Widget—You can also choose to view the
graph details based one of the following criteria by clicking the

settings icon and selecting any of the following options:
o > 70% CPU utilization.
o > 80% CPU utilization.
o > 90% CPU utilization.
o > 70% memory utilization.
o > 80% memory utilization.
o > 90% memory utilization.

To view more details, select a time range in the graph and click on
See Devices. A pop-up window displays the details of devices with
high CPU utilization and memory utilization with their individual
minimum and maximum values. You can add other metrics such
as 5 GHz and 2.4 GHz Channel Utilization , 5 GHz and 2.4 GHz
Noise Floor, and Device Down time for the devices by clicking on
the Add Metric button. A particular device can be filtered from
the list by clicking on the filter icon and entering the name of
the device.

RF Health Indicators

5 GHz Utilization and Noise This graph displays the total count or percentage of devices with
high channel utilization and high noise floor levels for 5 GHz band.
n Device Details—The graph displays total number of devices,

number of unique devices with high 5 GHz channel utilization

Table 192: Site Health Dashboard
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Content

and high noise floor levels, and the minimum and maximum
number of devices with high channel utilization. You can also
view the total count of maximum and minimum number of
devices with high 5 GHz channel utilization and noise for a
specific time when you hover your mouse over the graph.

n Threshold setting—You can also choose to view the graph

details based one of the following criteria by clicking the
settings icon and selecting any of the following options:
o > 60% 5 GHz Utilization.
o > 70% 5 GHz Utilization.
o > 80% 5 GHz Utilization.
o > -75 dBm 5 GHz Noise.
o > -80 dBm 5 GHz Noise.
o > -85 dBm 5 GHz Noise.

To view more details, select a time range in the graph and click on
See Devices. A pop-up window displays the details of devices with
high CPU utilization and memory utilization with their individual
minimum and maximum CPU utilization values. You can add
other metrics such as CPU, Memory, 2.4 GHz Channel Utilization,
2.4 GHz Noise Floor, and Device Down time for the devices by
clicking on the Add Metric button. A particular device can be
filtered from the list by clicking on the filter icon and entering
the name of the device.

2.4 GHz Utilization and Noise This graph displays the total count or percentage of devices with a
higher channel utilization and high noise floor levels for 2.4 GHz
channel.
n Device Details—The graph displays the total number of

devices, number of unique devices with high 2.4 GHz channel
utilization and noise floor levels, minimum and maximum
number of devices with high channel utilization and noise
levels. You can also view the total count of maximum and
minimum number of devices with high 2.4 GHz Utilization and
Noise for a specific time when you hover your mouse over the
graph.

n Threshold Setting widget —You can also choose to view the
graph details based one of the following criteria by clicking the

settings icon and selecting any of the following options:
o > 60% 2.4 GHz Utilization.
o > 70% 2.4 GHz Utilization.
o > 80% 2.4 GHz Utilization.
o > -75 dBm 2.4 GHz Noise.
o > -80 dBm 2.4 GHz Noise.
o > -85 dBm 2.4 GHz Noise.

Table 192: Site Health Dashboard
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Content

To view more details, select a time range in the graph and click on
See Devices. A pop-up window displays the details of devices with
2.4 GHz channel utilization and 2.4 GHz noise floor with their
individual minimum and maximum values. You can add other
metrics such as CPU, Memory, 5 GHz Channel Utilization, 5 GHz
Noise Floor, and Device Down time for the devices by clicking on
the Add Metric button. A particular device can be filtered from
the list by clicking on the filter icon and entering the name of
the device.

NOTE: The threshold setting icon is visible only when you bring the mouse pointer closer to its position
slightly above the right-hand side of each graph.

Table 192: Site Health Dashboard

WAN Health—Site
The WAN Health page displays details for the wired, wireless, and controller devices deployed on the
site.

To launch the WAN dashboard, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a site.
2. Under Manage, click Overview > WAN to launch the WAN dashboard.
3. Click the site on the map, or the site from the Site Name column in the List view, to view details

of that site.

The following table displays the WAN Health dashboard information.

Content Description

Site Name Name of the site.

Time Range Time range selection drop-down for viewing site health. You can set the time range to 3 hours,
1 day, 1 week, 1 month, or 3 months.

Summary The following details are available:
n Name—Name of the site.
n Location—Location of the site.
n APs—Number of APs deployed on the site.
n Switches—Number of switches deployed on the site.
n Controllers—Number of controllers deployed on the site.

Site
Availability
graph

Site availability metrics per provider represented in a chart. The graph displays detailed
metrics for the number of sites in the down status, percentage of site availability, and the
number of unknown sites.

Policy
Compliance
graph

Policy compliance metrics for the site. The path steering data is used to calculate this metric.

Table 193: Site Health Controllers Page
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Content Description

Bandwidth
graph

Bandwidth utilization of the selected site. From the drop-down list, select one of the following:
n All Traffic
n Internet vs. VPN

Bandwidth
graph

Bandwidth utilization of the selected uplink. From the drop-down list, select the uplink.

Transport
Health graph

Displays the transport health of the site based on active monitoring probes. Site transport
health is an average of MOS score across all probes.

NOTE: If you hover over any graph, a pop-up window opens and displays the data specific to that graph. Click on
the graph to lock the time range. After you lock the selection, the same time range is selected across all the
graphs in the Site Health page.

NOTE: If you click on any graph, a see devices button in enabled below all the graphs. Click see details to view
the list of devices. From the Add Metric drop-down list, select one or more of the following: Site Availability,
Bandwidth or Internet vs. VPN.

Table 193: Site Health Controllers Page

User Experience Insight Sensors Integration
The integration of User Experience Insight (UXI) sensors in Aruba Central On-Premises enables
monitoring the network health of a site from end-user perspective, as seen by the UXI sensors deployed
in a site. Once integrated with Aruba Central On-Premises, the high-level summary of UXI sensor alerts
are displayed in the UXI field of the Network Health card in map view.

UXI Field in Network Health Card
The UXI field in the Network Health card displays the top alert coming from UXI sensors at a site. This
information is displayed when there is at least one UXI sensor deployed in the site. Ensure that the UXI
sensor is connected to an AP or an SSID that is broadcast by the AP in the site.

To display the UXI field of the Network Health card in the Network Health dashboard, complete the
following steps:

1. Ensure that the AP that connects to the UXI sensor is mapped to a site in Aruba Central On-
Premises. To create sites, see Managing Sites.

2. Generate an API token and enable UXI integration in Aruba Central On-Premises. For more
information, see UXI Sensors Integration in Aruba Central On-Premises.

3. Configure UXI integration using the generated API token in UXI Dashboard. For more information,
see Aruba Central On-Premises Integration in UXI Dashboard.

Clicking on the UXI field leads to the UXI Dashboard for further troubleshooting. The following image
displays the Network Health card for a test site called San Diego. The highlighted part of the Network
Health card displays the UXI field.
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Figure 136 User Experience Insight in Network Health Card

For more information about each field in the Network Health card, see Network Health.

The UXI integration with Aruba Central On-Premises is achieved through APIs to monitor end-user experience
at a given site.

To integrate a UXI sensor in Aruba Central On-Premises, refer to the documentation available at
https://help.capenetworks.com/en/articles/4305360-aruba-central-integration.

UXI Sensors Integration in Aruba Central On-Premises
To generate an API token and enable UXI integration, complete the following steps:

1. Log in to Aruba Central On-Premises.

2. Under Maintain, click Organization.

3. Select Platform Integration tab, and click Rest API.
The API Gateway page is displayed.

4. Click System Apps & Tokens tab, and click +Add Apps and Tokens.

The New Token pop-up window is displayed.

5. Configure the name of the application that will use the new token in the Application Name field
of the New Token window.

6. (Optional) Specify appropriate URI in the Redirect URI field.
7. Click Generate.

The token is generated and displayed in the Token List table.

8. Click Download Token to download and save the token in JSON file format.
9. Navigate to Platform Integration > API Gateway > APIs tab.

Make a note of the URL listed under Documentation column.

https://help.capenetworks.com/en/articles/4305360-aruba-central-integration
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The URL is required for Aruba Central On-Premises integration in the UXI dashboard.

Aruba Central On-Premises Integration in UXI Dashboard
To configure UXI integration using the generated API token, complete the following steps:

1. Log in to UXI dashboard.
2. Navigate to Settings > Account > Integrations.
3. Click Link Central Account.
4. Select On-Prem in the Server Type parameter.
5. Configure the following parameters with information generated from Aruba Central On-Premises:

n Central Client ID—Configure the Client ID generated from Aruba Central On-Premises.
n Secret—Configure the Client Secret generated from Aruba Central On-Premises.
n Cluster URL—Configure the API URL collected from Aruba Central On-Premises.
n Token—Upload the JSON file downloaded from Aruba Central On-Premises.

Turn off the SSL Verification toggle switch, if your server is using a self-signed certificate.

6. Click Add.

When the Aruba Central On-Premises integration is completed, the UXI field of the Network Health
card is displayed in the map view of the Network Health dashboard, within the range of 5-10 minutes.
Clicking the UXI field redirects you to the UXI dashboard for further troubleshooting.

About Floor Plan
Floor Plan allow you to plan sites, create and manage floor plans, and provision access points. You can
use Floor Plan to do basic planning procedures, such as, creating a floor plan and provisioning access
points. The Floor Plan dashboard can be accessed only from a site context.

Floor Plan provide a real-time picture of the radio environment of your wireless network and the ability
to plan the wireless coverage of new sites. For a better understanding of your wireless network, you
must know the location of your devices and users, and the RF environment of your network. Floor Plan
provide this information at your fingertips through integrated mapping and location data.

Floor Plan use sophisticated RF fingerprinting to accurately display coverage patterns and calculate the
location of every wireless device in range. Floor Plan does not require dedicated RF sensors or a costly
additional location appliance, because it gathers all the necessary information from your existing
devices.

https://dashboard.capenetworks.com/
https://dashboard.capenetworks.com/
https://dashboard.capenetworks.com/
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n Floor Plan is supported only on access points running 6.5.2.0 or a later version.
n Do not use the back or front navigation. Instead, use the breadcrumbs.
n APs are removed from the floorplan and deployed device list based on the device unlicensing. For

example, When you unassign a license for an AP, it gets removed from the deployed device list and
floorplans, and when you assign back the license for an AP, it gets added back to the deployed device list
and to the same co-ordinates of the floorplan location. Also, when your license gets auto expired, the
devices gets removed from the list and floorplan location and the same gets added back on license
renewal. Make sure that you check the assigned AP device licensing status before adding them to the
floorplan.

Floor Plan offer the following features:

n Create and import floor plans.
n Pictorial navigation that allows you to view the floor plans associated with access points, associated

clients, rogues, buildings, and floors.
n Accurate calculation of the location of all associated client devices using RF data from your devices.
n Accurate calculation of the location of all rogue devices (as classified by RAPIDS) using RF data from

your devices.
n A map view that shows the location of devices and heatmaps that depict the strength of RF coverage

in each location.

Related Topics

n Floor Plan Dashboard
n Planning and Provisioning Devices
n Customizing the Floor Plans View

Floor Plan Dashboard
The Floor Plan dashboard can be accessed from a site context or an access point context. You can view
the floor plan dashboard in List view and Summary view. By default, the floor plan for a site is
displayed in the summary view.

The following table describes the options displayed in floor plan dashboard in the summary view.

Data Pane
Content Description

Allows you to search the floor names and APs.

Allows you to add a new floor.

Allows you to edit or modify the floor plan properties.

Allows you to delete a floor plan.

Table 194: Floor Plan Dashboard in Summary View
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The following table describes the information displayed in each column of the Floor table in the list
view.

Data Pane
Content Description

Number Displays the floor number. Use the sort option to sort the numbers in ascending or descending
order.

Name Displays the name of floors. Use the sort option to sort the floor names in ascending or
descending order. Use the filter option to select a specific floor name.

Deployed
Access
Points

Displays the number of deployed APs ( AP, planned AP, and air monitors) associated with the
floor. Use the sort option to sort the APs in ascending or descending order.

Planned
Access
Points

Displays the number of planned APs associated with the floor. Use the sort option to sort the
APs in ascending or descending order.

Width
(m/ft)

Displays the width of the floor in meter/feet.

Length
(m/ft)

Displays the length of the floor in meter/feet.

Ceiling
Height
(m/ft)

Displays the ceiling height of the floor in meter/feet.

Allows you to add a new floor.

Allows you to edit or modify the floor plan properties.

Allows you to delete a floor plan.

Table 195: Floor Plan Dashboard in List View

You can either navigate to a specific site to view the floor plan or view a specific site floor plan from the
Network Health tab in the Global context.

To view the Floor Plan dashboard from the Network Health tab in the Global context, complete the
following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
The global dashboard is displayed.

2. Under Manage > Overview, the Network Health page is displayed.
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3. Hover over a site to view the following details:

Figure 137 Site-level Details with Floorplan Option

4. Click FloorPlan under RF Coverage. By default, the Floor Plan dashboard with all floors is
displayed in the summary view.

5. Click any one of the floor tile under All Floors to navigate to the floor plan. To go back to the all
floor tiles, click the back arrow next to the floor name.

6. To view all floors in a list, click the Lists view.
A Floor table with a list of floors is displayed in the list view.

7. In the Floor table, click any one of the floor under Name column or enter the floor name in the
Name column and then click the floor name to navigate to the floor plan to navigate to the floor
plan. To go back to the floor list, click the back arrow next to the floor name.

To view the Floor Plan dashboard from a site context, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Sites.

The dashboard context for the selected site is displayed.

2. Under Manage > Overview, click Floor Plan. By default, the Floor Plan dashboard with all floors
is displayed in the summary view.

3. Click any one of the floor tile under All Floors to navigate to the floor plan. To go back to the all
floor tiles, click the back arrow next to the floor name.

4. To view all floors in a list, click the Lists view.
A Floor table with a list of floors is displayed in the list view.

5. In the Floor table, click any one of the floor under Name column or enter the floor name in the
Name column and then click the floor name to navigate to the floor plan.

6. To download the bill of material, click Download Bill of Material (BOM) under Floor Details
window.

7. To go back to the floor list, click the back arrow next to the floor name.

To view the Floor Plan dashboard from an access point context, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
The global dashboard is displayed.
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2. Under Manage, click Devices > Access Points.

A list of access points is displayed in the List view.

3. Click the Access Point name to view the Access Point Details page. If there are many APs
connected to the network, click Online or Offline to filter the online or offline APs.

4. Additionally, enter the access point name in the Device Name column and then click the AP
name. The AP Summary page is displayed.

5. Under Manage > Overview, click Floor Plan. The floor plan details with the highlighted AP is
displayed.

6. Click anywhere on the floor plan to navigate to the exact floor for a site with the AP highlighted.
By default, the Access point Details window pops up displaying the highlighted AP details.

The floor plan details for an AP is only accessible for the devices that are assigned with license.

Planning and Provisioning Devices
Floor Plan provide the capability to plan buildings, floors, and location for device provisioning before
the actual deployment. You can create a floor plan and add devices to the floor plan.

The planning and provisioning workflow includes the following procedures:

n Creating a Floor Plan
n Importing a Floor Plan
n Modifying Floor Plan Properties
n Adding Devices to the Floor Plan
n Deleting a Floor with in a Site

Creating a Floor Plan
Floor Plan allow you to add, modify, and import a floor plan background image file. When importing RF
plans ensure that the devices from the device catalog are included.

To create a new floor plan, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Sites.

The dashboard context for the selected site is displayed.

2. Under Manage > Overview, click Floor Plan. The Floor Plan dashboard is displayed.
3. Click Add Floor. The Floor Plans tab is displayed.
4. Click Edit in the slide out pane on the right.
5. Click New Floorplan. You can also add the floor plan by right-clicking on the center gray area and

click New Floorplan. The New Floorplan pop-up window is displayed.
6. Click Choose File and locate a floor plan image file from your local file system. You can import

the floor plan image file in the jpg, jpeg, gif, bmp, pdf, png, dwg, and svg format.
7. Assign a floor name and a floor number in the Floor name and Floor number text boxes,

respectively.
8. Click Save.
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9.

Make sure that you add a new floor plan image within the recommended size of 2625*2625 feet or
800*800 meter. You can also use the measure tool to resize the current image to the recommended
size.

You can define new floor by clicking the Define New Floor option on the top right corner.
10. The Define New Floor includes the following option:

a. Scale—Shows the dimensions of the floor.
b. Region—Allows you to define floor plan boundary and planning region.
c. CAD Layer—Allows you to import walls from the CAD file.
d. Access Points—Allows you to add the access point's to the floor plan.

11. Click Next button after you set the Scale, Region, and CAD layer for the floor.
12. To add a planned access point, under Access Points > Planned APs, select the device type from

the Type drop-down menu.
13. In the Count field, enter the number of devices to add to the new floor.
14. Click and drag the Deployment Type slider bar to adjust data rates for a high density or low

density environment.
15. Optionally, click the Advance link to configure the advance deployment options:

a. Service Level—Select Speed or Signal to plan coverage by adjusting the data rate
requirements (speed) or AP signal strength settings. Click Calculate AP Count to recalculate
the suggested number of APs based on these settings.

b. Client Density—In the Max Clients field, set the anticipated number of clients that will be
stationed in the floor. In the Clients Per AP field, enter the maximum number of clients
supported by each radio. Click Calculate AP Count to recalculate the suggested number of
APs based on these settings.

16. Click Add APs to Floorplan to add the planned APs to the floor.
17. Click Finish.
18. To remove the planned device from the floor plan, right-click on that device and click Remove.

Importing a Floor Plan
The devices in the backup must be added to Aruba Central On-Premisesbefore importing the floor plan.
Onboarding Devices is moved to the HPE GreenLake Account Home. For more information on adding
devices, refer to the HPE GreenLake User Guide.

To import a floor plan exported from AirWave, Aruba Central On-Premises, or Ekahau, complete the
following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Sites.

The dashboard context for the selected site is displayed.

2. Under Manage > Overview, click Floor Plan and click the add icon . The Floor Plans
dashboard is displayed.

3. Click Add Floor.
The Floor Plan tabs are displayed.

4. Click the Import menu option.

https://support.hpe.com/hpesc/public/docDisplay?docId=a00120892en_us
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5. Click Choose File and select the file with the floor plan to import.

Ekahau Import is currently supported for the files exported from the Ekahau tool (version: ekahau pro
10.4.0.135 ).

The supported file formats for Ekahau import are ZIP and ESX files; for AirWave import, it is ZIP files.
The maximum file size supported for the import file is 250 MB.

6. Click Import.
When an import is complete, the UI displays a notification to alert the user. The Imported Sites
table displays the import summary information of the last import operation.

After successfully importing the floor plan, a new site gets created if the site does not exist.

Types of import files:

n Import file created in AirWave or Aruba Central On-Premises- If the device's MAC address matches
the Aruba Central On-Premises inventory, the device gets mapped to the site according to the
imported floor plan.

n Import file created in Ekahau- If the device's name matches with the MAC address of a device in the
Aruba Central On-Premises inventory, then the device gets mapped to the site according to the
imported floor plan. Unsupported APs will appear as AP-635 in the floor plan.

Modifying Floor Plan Properties
To edit the properties of an existing floor plan, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a Site.
The dashboard context for the selected site is displayed.

2. Under Manage > Overview, click Floor Plan.
3. Select any one of the floors under All Floors and click Edit to modify the properties.

If the dashboard is in List view, hover over any one of the floors and click Edit to modify the
properties. For more information, see Customizing the Floor Plans View.

In case of multiple floors, the floor plan view page allows you to select the floor from the drop-down
list. Click Edit to modify the properties.

4. Click Save.

Adding Devices to the Floor Plan
You can add planned devices or devices available in Aruba Central On-Premises, to a floor plan. Planned
devices are used to simulate AP behaviors (heatmap coverage) on the floor plan, instead of real devices.
You can match and replace planned devices with real devices that are available in Aruba Central On-
Premises.

To add the already deployed devices to the floor plan, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Sites.

The dashboard context for the selected site is displayed.

2. Under Manage > Overview, click Floor Plan.
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3. Select any one of the floors under All Floors and click Edit to modify the properties.

If the dashboard is in List view, hover over any one of the floors and click Edit to modify the
properties.

In case of multiple floors, the floor plan view page allows you to select the floor from the drop-down
list. Click Edit to modify the properties.

4. Under Edit, click the Add Deployed Devices. A list of devices is displayed.
5. Expand the group containing the APs which need to be provisioned on this floor plan. Note that

by default, devices that have already been added to Floor Plan are hidden. To show them, clear
the Hide APs that are already added check box at the bottom of the list.

6. Click and drag an AP to its proper location on the floor.
7. To remove a device from the floor plan, right-click that device and then click Remove.

To add planned devices when creating a new floor plan, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Sites.

The dashboard context for the selected site is displayed.

2. Under Manage > Overview, click Floor Plan. By default, the Floor Plan dashboard with all floors
is displayed in the summary view.

3. Select any one of the floors under All Floors and click Edit to modify the properties.

If the dashboard is in List view, hover over any one of the floors and click Edit to modify the
properties.

In case of multiple floors, the floor plan view page allows you to select the floor from the drop-down
list. Click Edit to modify the properties.

4. Under Edit, click Add Planned Devices and select a device type (model) from the list of available
devices.

5. Click and drag the device to the desired location on the floor.
6. To replace a planned AP with an AP that is available in Aruba Central On-Premises, click Auto-

Match Planned Devices from the Action tab.

7.

To auto-match devices, ensure that you edit the device name or MAC address of the planned AP to
match the name or MAC address of the AP added to Aruba Central On-Premises.

To remove a planned device from the floor plan, right-click on that device and then click Remove.

Deleting a Floor with in a Site
To delete a floor within a site in summary view, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Sites.

The dashboard context for the selected site is displayed.

2. Under Manage > Overview, click Floor Plan. By default, the Floor Plan dashboard with all floors
is displayed in the summary view.

3. Hover over the floor and click the delete icon and confirm the delete action to delete the floor.

To delete a floor within a site in list view, complete the following steps:



Monitoring Your Network | 902

1. In the Aruba Central On-Premises app, set the filter to one of the options under Sites.

The dashboard context for the selected site is displayed.

2. Under Manage > Overview, click Floor Plan. By default, the Floor Plan dashboard with all floors
is displayed in the summary view.

3. Click List view. The floor plan dashboard with a list of floors is displayed.

4. Hover over the floor and click the delete icon and confirm the delete action to delete the floor.

Customizing the Floor Plans View
To customize the floor plan view page, select any one of the floors and click View Settings on the right
side panel. The View Settings displays the access points, air monitors, clients, heatmap, regions walls,
and labels.

To modify the properties, click Edit on the right side panel. In edit mode, the right pane consists of the
Properties, View, and Edit tabs. The following tables describe the menu options available for a floor
and building:

Tabs Options

Properties The Properties tab has the following menu options:
n APs—Displays the total number of APs, the planned APs, and the number of APs that are
offline.
n Floor name—Displays the floor name.
n Floor number—Displays the floor number.
n Width—Displays the current width of the floor plan. To change these settings, click the
Measure icon and measure a portion of the floor.
n Height—Displays the current height of the floor plan. To change these settings, click the
Measure icon and measure a portion of the floor.
n Gridsize—Displays the grid. Decreasing the grid size enables the location to place clients
in a small grid which increases accuracy.
n Advanced—Allows you to set the values to indicate if the environment is related to an
office space, cubicles, offices, or concrete.

View The View tab has the following menu options:
n Devices—Displays APs, clients, and rogue devices detected on the floor.
n AP Overlays—Shows the heatmap for the current and adjacent floors.
n Floorplan Features—Displays the following details:
lGrid Lines—Allows you to change the grid size and color.
lLabels—Shows or hides the labels tagged to the devices on the floor.
lOrigin—To ensure that multi-floor heatmaps display properly, ensure that your floor
plans are vertically aligned. Floor Plan use the origination point for this alignment. By
default, the origin appears in the upper left corner of the floor plan. You can drag and
drop the origin point to the correct position.
lRegions—Displays the regions defined within a floor plan. For example, you can
define two small regions of high density clients within a larger floor plan with lower
client density.
lWalls—Displays walls drawn on the floor.

Edits The Edit tab has the following menu options:
n Drawing—Allows you to draw a region or wall for the floor.
n Devices—Allows you to add and delete the already deployed or planned devices.
n Actions—Displays the following options:
lSelect All—Selects all floors.
lExport Floor Plans—Exports the floor plan of a specific floor. Export function is
classified as a selectively available feature in Aruba Central On-Premises. Contact your

Table 196: Floorplan Menu Options
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Tabs Options

Aruba Account Manager to enable it in your Aruba Central On-Premises account.
lUndo—Cancels the previous action.
lNew Floorplan—Allows you to create a new floor plan.
lAuto-match Planned Devices—Automatically matches the devices that are planned
for deployment and reloads the page.
lGo to floor above—Allows you to navigate to the floor above.
lGo to floor below—Allows you to navigate to the floor below.
lRefresh—Refreshes the page.
lReplace Background—Allows you to replace the current background.

Tabs Options

Properties The Properties tab has the following menu options:
n APs—Displays the total number of APs, the planned APs, and the number of APs
that are offline in the building.
n Floors—Displays the number of floors.
n Name—Name of the building
n Ceiling Height—Displays the building ceiling height.
n Attenuation—Displays the attenuation value for the building.

View The View tab displays the complete list of floors in the building along with the number of
APs in each floor, which includes the planned APs and the offline APs.

Edits The Edit tab has the following menu options:
n Select All—Selects all floors. You can perform the following actions when floors
are selected:
lRemove—Removes the selected buildings.
lBill of Materials—Enables showing or hiding heatmap, speed, sensor coverage,
wired range and other details.
lAuto match planned devices—Automatically matches the devices that are
planned for deployment and reloads the page.

n Export Floor Plans—Exports the floor plan of the entire building or entire account.
Export function is classified as a selectively available feature in Aruba Central. Contact
your Aruba Account Manager to enable it in your Aruba Central account.
n Undo—Cancels the previous action.
n New Floorplan—Allows you to create a new floor plan.

Table 197: Building floor plan Menu Options

User Interface Elements of the Floor Plan Dashboard
The Floor Plan dashboard provides various options to customize your view. The customizable
parameters include:

UI Element Description

Click the drop-down to select a specific floor from the site.

Click any of the AP to view the details of the access point and the RF environment
in the Access Point Details window.

Table 198: User Interface Elements
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UI Element Description

Click any of the clients to view the client details in the Client Details window.

Click the + or - icon to zoom in or zoom out of a floor plan. Additionally, click the
box icon to view the floor plan in full screen mode and click the inward box icon to
exit the full screen mode.

Click the home icon to reset the floor plan view.

Click the eye icon to view the floor plan settings. The View Settings window
includes the following information:

n Access Points
lDeployed Access Points—Shows or hides the deployed access points in
the floor plan.
lPlanned Access Points—Shows or hides the planned access points in the
floor plan.
lRogue access points—Shows or hides the rogue access points in the
floor plan.

n Air Monitors
lDeployed Access Monitors—Shows or hides the deployed air monitors
in the floor plan.
lPlanned Access Monitors—Shows or hides the planned air monitors in
the floor plan.

n Clients
lClients—Shows or hides the clients in the floor plan.

n Heatmap
lShow Heatmap—Shows or hides the strength of RF coverage in each
location.
lMonochrome Heatmap—Select the check box to select either the
monochrome display or the colored display of heatmaps.
l2.4 GHz and 5 GHz—Select the check box to show or hide the strength of
RF coverage for 2.4 GHz and 5 GHz APs.
lShow Regions—Select the check box to view the segregation of regions in
the selected floor.
lShow Walls—Shows or hides the segregation of walls in the selected
floor.
lShow labels—Shows or hides the labels tagged to the devices on the
floor.
lMeters and Feet—shows the dimensions in feet or meters.

Allows you to search for APs, Clients, and Rogues.

Click the edit icon to edit or modify the floor plan properties.

Table 198: User Interface Elements

Alerts and Events
The Alerts and Events dashboard displays a list of alerts and events generated for events pertaining to
device provisioning, configuration, and user management.

You can view the alerts and events in the following views:
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n List—Provides a detailed view of the alerts and also provides option to acknowledge alerts. Alerts are
acknowledged automatically when the event count drops below the lowest severity threshold
configured for the alert. Users with admin access can acknowledge alerts irrespective of the severity
configuration. As manually acknowledging an alert does not reset the count data, the alert service
continues to aggregate events. When the number of new events meets the configured threshold, an
alert is triggered again.

n Summary—Provides a comprehensive graphical representation of all the alerts and events by type
and severity at the global level and device level.
The graphs in the Summary view displays the alerts and events in the following categories:
o Alerts By Type—Displays the alert categories under which the maximum alerts are generated.

Hover your mouse over the bar graphs to see the total count of alerts generated under each
category.

o Alerts By Severity—Displays the alert severity categorized under Critical, Major, Minor, and
Warning. Hover your mouse to see the total count of alerts generated under each severity level.

o Events By Type—Displays the event categories under which the maximum events are generated.
Hover your mouse over the bar graphs to see the total count of events generated under each
category.

The components of the List view is different for Alerts and Events tab whereas the Summary view
displays similar components.

n Configuration—Provides a view to configure alerts and is available only at the Global context.

Users with admin role and custom roles that allow edit or view access to the Alerts and Events module
can edit or view the alerts and events generated. For more information on user roles, see Managing
Users and Roles.

The Alerts & Events pane is not visible to users who do not have edit or view permission to the Alerts and
Events module.

This section includes the following topics:

n Viewing Alerts in List view
n Applying Advanced Filters to Alerts List view
n Viewing Events List View
n Applying Advanced Filters to Events List View
n Viewing Alerts and Events in Summary view

Viewing Alerts in List view
To view the list of alerts and events and acknowledge alerts, complete the following procedure:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a group, label, site, or all devices in the filter, set the filter to one of the options under

Groups, Labels, or Sites. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.
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n To select a device in the filter:
a. Set the filter to Global.
b. Under Manage, click Devices, and then click Access Points, Switches, or Controllers.

A list of devices is displayed in the List view.

c. Click a device listed under Device Name.

The dashboard context for the device is displayed.

2. Under Analyze, click Alerts & Events.
By default, the Alerts & Events page displays the alert and events in the List view.

The Alerts & Events page offers a list view, summary view, and a configuration view.

Configuration view is only available at the Global context.

By default, the Alerts tab is selected and the Open Alerts table is displayed. The table displays all the
generated alerts. The Alerts bar categorizes the alerts as Critical, Major, Minor, and Warning.

3. Optionally, click Acknowledge All to acknowledge all the alerts at once.

Important Points:
Once an alert is acknowledged, the alert is moved to the Acknowledged tab.

All Acknowledged Alerts can be viewed when the Show Acknowledged Alerts button is ON.

If the user does not acknowledge an alert, the alert is suppressed for 5 minutes. The alert
notification is then sent to the user every 5 minutes in case the issue still persists.

If the user acknowledges an alert, the alert is suppressed until the issue is resolved. After
resolving the issue, if it re-occurs the alert is sent again.

4. Optionally, enable the Show Acknowledged Alerts button to display the list of acknowledged
alerts.

Data Pane
Content

Description

Acknowledged
On

Displays the timestamp of the acknowledged alert. Use the
sort option to sort the events by date and time. Use the filter
option to select a specific time range to display the alerts.

Acknowledged
By

Displays the entry by whom the alert is acknowledged.

Occurred On Displays the timestamp of the alert. Use the sort option to
sort the events by date and time. Use the filter option to
select a specific time range to display the alerts.

Elapsed Time Displays the timestamp difference between when the alert
actually occurred and, when the alert was acknowledged.

Category Displays the category of the alert. Use the filter option to filter
the alert by category.

Table 199: Acknowledged Alerts pane
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Data Pane
Content

Description

Label Displays the label name of the alert.

Site Displays the site name of the alert.

Group Displays the group name of the alert.

Severity Displays the severity level of the alert. The severity can be
Critical, Major, Minor, or Warning.

Description Displays a description of the alert. Use the search option in
filter bar to filter the alert based on description.

Applying Advanced Filters to Alerts List view
Aruba Central allows you to filter the alerts based on the alert categories. To filter alerts based on alert
categories, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a group, label, site, or all devices in the filter, set the filter to one of the options under

Groups, Labels, or Sites. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.

n To select a device in the filter:
a. Set the filter to Global.
b. Under Manage, click Devices, and then click Access Points, Switches, or Controllers.

A list of devices is displayed in the List view.

c. Click a device listed under Device Name.

The dashboard context for the device is displayed.

2. Under Analyze, click Alerts & Events.
By default, the Alerts & Events page displays the alert and events in the List view.

The Alerts & Events page offers a list view, summary view, and a configuration view.

Configuration view is only available at the Global context.

By default, the Alerts tab is selected and the Open Alerts table is displayed.

3. In the Alerts page, click Click here for advanced filtering to filter the alerts based on alert
categories.

4. Select the alert category and click Filter. You can select multiple categories from the advanced
filtering option.
The Open Alerts table displays the list of alerts generated in each alert category. The filter
summary bar displays the total number of alerts in the selected categories.

5. To clear the advanced filtering option, click Clear All on the alerts summary bar.
The advanced filtering gets cleared.

The following table describes the information displayed in each column of the Alerts table:
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Data Pane
Content

Description

Occurred On Displays the timestamp of the alert. Use the sort option to
sort the events by date and time. Use the filter option to
select a specific time range to display the alerts.

Category Displays the category of the alert. Use the filter option to filter
the alert by category.

Label Displays the label name of the alert.

Site Displays the site name of the alert.

Group Displays the group name of the alert.

Severity Displays the severity level of the alert. The severity can be
Critical, Major, Minor, or Warning.

Description Displays a description of the alert. Use the search option in
filter bar to filter the alert based on description.

Table 200: Alerts pane

6. To customize the Alerts & Events table, click the ellipses icon and select the required
columns.

7. To set the table to the default columns, click Reset to default.

Viewing Events List View
To view a list of events generated, complete the following steps:

1. In the Aruba Central On-Premisesapp, select one of the following options:
n To select a group, label, site, or all devices in the filter, set the filter to one of the options under

Groups, Labels, or Sites. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.

n To select a device in the filter:
a. Set the filter to Global.
b. Under Manage, click Devices, and then click Access Points, Switches, or Controllers.

A list of devices is displayed in the List view.

c. Click a device listed under Device Name.

The dashboard context for the device is displayed.

2. Under Analyze, click Alerts & Events.
By default, the Alerts & Events page displays the alert and events in the List view.

The Alerts & Events page offers a list view, summary view, and a configuration view.

Configuration view is only available at the Global context.

3. In the Alerts & Events summary bar, click Events.
By default, the List view is selected and a consolidated list of events is displayed in the events
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table.
The following table describes the information displayed in each column of the Events table:

Data Pane Content Description

Occurred On Displays the timestamp of the event. Use the sort option to
sort the events by date and time. Use the filter option to
select a specific time range to display the events.

Device Type Displays the type of the device, Access Point, Controller,
Switch. Use the filter option to filter events by device types.

Device Hostname Displays the host name of the device where the event is
generated.

Device MAC Displays the MAC address of the device.

Client MAC Displays the MAC address of the device to which the client is
connected.

BSSID Displays the BSSID of the device.

Event Type Displays the type of the event.

Serial Displays the serial number of the device.

Label Displays the label name of the event.

Site Displays the site name of the event.

Group Displays the group name of the event.

Description Displays the description of the event. Use the column filter to
perform a free search and filter an event based on the
description. You can type a search phrase including client
MAC, reason code, or BSSID and filter the events.

Table 201: Events pane

Applying Advanced Filters to Events List View
Aruba Central allows you to filter the events based on the event types. To filter events based on event
types, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a group, label, site, or all devices in the filter, set the filter to one of the options under

Groups, Labels, or Sites. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.

n To select a device in the filter:
a. Set the filter to Global.
b. Under Manage, click Devices, and then click Access Points, Switches, or Controllers.

A list of devices is displayed in the List view.

c. Click a device listed under Device Name.

The dashboard context for the device is displayed.
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2. Under Analyze, click Alerts & Events.
By default, the Alerts & Events page displays the alert and events in the List view.

The Alerts & Events page offers a list view, summary view, and a configuration view.

Configuration view is only available at the Global context.

3. In the Alerts & Events summary bar, click Events.
By default, the List view is selected and a consolidated list of events is displayed in the events
table.

4. In the Events page, click Click here for advanced filtering to filter the events based on event
types.

5. Select the event type and click Filter. You can select multiple event types from the advanced
filtering option.
The events table displays the list of events generated in each event type. The filter summary bar
displays the total number of events in the selected category and the type(s) of events.

6. To clear advanced filtering option, click Clear All on the events summary bar.
The advanced filtering gets cleared.

The event columns allows free text search at all column levels to enhance filtration.

Click the icon to see additional details for events related to controllers, switches, IAPs, and
CAPs.

7. To customize the Alerts & Events table, click the ellipses icon and select the required
columns.

8. To set the table to the default columns, click Reset to default.

Aruba Central allows you to download the global list of events to your local browser. Click to
download the events list in a CSV format.

No data is exported in the .csv file downloaded on the Events table, if the selected event type has huge
amount of data.

Viewing Alerts and Events in Summary view
To view a summary of alerts and events, complete the following procedure:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a group, label, site, or all devices in the filter, set the filter to one of the options under

Groups, Labels, or Sites. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.

n To select a device in the filter:
a. Set the filter to Global.
b. Under Manage, click Devices, and then click Access Points, Switches, or Controllers.

A list of devices is displayed in the List view.
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c. Click a device listed under Device Name.

The dashboard context for the device is displayed.

2. Under Analyze, click Alerts & Events.
By default, the Alerts & Events page displays the alert and events in the List view.

The Alerts & Events page offers a list view and summary view, and a configuration view.

Configuration view is only available at the Global context.

3. To view the graphs displaying alerts and events, click the Summary icon. By default, ALL tab is
selected. Select each tab Access Points, Switches, or Controllers to view the graphs pertaining
to each device type.

The Alerts & Events graphs are displayed for the time range selected. Select the time range from the Time

Range Filter ( ) to filter alerts and events.

Configuring Alerts
To configure alerts, complete the following steps:

1. In the Aruba Central On-Premises app, use the filter to select Global.
The dashboard context for the selected filter is displayed.

2. Under Analyze, click Alerts & Events.

The Alerts & Events page is displayed in the List view.

3. In the Alerts & Events page, click the Config icon.

The Alert Severities & Notifications is displayed.

4. Use the tabs to navigate between the alert categories.
5. Optionally, for Access Point, Switch, Controller, and Central System alerts, you can click the

Enable All or Disable All button respectively to enable all the disabled alerts on a single click and
vice versa. For more information on Enabled Alerts, see Viewing Enabled Alerts.

6.  Select an alert and click + to enable the alert with default settings. To configure alert parameters,
click on the alert tile and do the following:
a. Severity—Set the severity. The available options are Critical, Major, Minor, and Warning. By

default, the following alerts are enabled and the severity is Major:
n Virtual Controller Disconnected
n Rogue AP Detected
n New User Account Added
n Switch Detected
n Switch Disconnected

For a few alerts, you can configure threshold value for one or more alert severities. Enter a value in
the exceeds text box to set a threshold value for the alerts. The alert is triggered when one of the
threshold values exceed the duration.

b. Duration—Enter the duration in minutes.
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c. Device Filter Options—(Optional) You can restrict the scope of an alert by setting one or
more of the following parameters:
n Group—Select a group to limit the alert to a specific group.
n Label—Select a label to limit the alert to a specific label.
n Device—Select a device to limit the alert to a specific device.
n Site—Select a site to limit the alert to a specific site.

d. Other Filter Options
n Band—For few Access Point alerts, you can select the band, 2.4 GHz or 5 GHz or 6 GHz to

limit the alert to a specific band.

6 GHz Band is only supported for devices with 6 GHz capability.

n Interface—For few switch port alerts, you can mention an interface value to limit the alert
criteria to a specific port.

n SSID—For few Connectivity alerts, you can select a SSID to limit the alert to a specific
SSID.

e. Notification Options
n Email—Select the Email check box and enter an email address to receive notifications

when an alert is generated. You can enter multiple email addresses, separate each value
with a comma. The Default Recipient check box is selected by default. If you want to
disable specific email addresses from the default list to avoid sending alert notification,
click the number displayed in parenthesis and click against each email address. To add
or delete default recipient, see Adding Default Recipients. Uncheck the Default Recipient
check box in order to disable alert notifications to all the default email addresses.

The number displayed in the parenthesis denotes the total number of email addresses that
have been already configured as default recipients to receive notifications when an alert is
generated.

n Streaming—Select the Streamingcheck box o receive the streaming notifications when
an alert is generated.

n Webhook—Select the Webhook check box and select the Webhook from the drop-down
list. For more information on Webhooks, see Aruba Central Help Center.

n Syslog—Select the Syslog checkbox to receive the syslog notifications when an alert is
generated.

n SNMP Trap—Select the SNMP Trapcheckbox to receive SNMP notifications when an alert
is generated.

f. Click Save.
g. Add Rule—(Optional) For a few alerts, the Add Rule option appears. For such alerts, you can

add additional rule(s). The rule summaries appear at the top of the page.

You can use the Search box, to search for alerts using keywords.

Aruba Central allows you to configure the following alerts:

n User Alerts

n Access Point Alerts

n AOS-S Switch Alerts
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n AOS-CX Switch Alerts

n Third-Party Device Alerts

n Controller Alerts

n Connectivity Alerts

n Audit Alertst

n Central System Alerts

n Site Alerts

n IP Management System Alert

User Alerts
Aruba Central allows you to configure and enable the following user management alerts:

n New User Account Added—Generates an alert when a new user account is added. This alert is
enabled by default and the alert severity is Major.

n User Account Deleted—Generates an alert when a user account is deleted.
n User Account Edited—Generates an alert when a user account is edited.

Access Point Alerts
Aruba Central On-Premises allows you to configure and enable Access Point alerts. Access Point alerts
are configurable based on the devices types.

To enable or disable all the access point alerts on a single click, you can use the Enable All or Disable All
button respectively.

n New Virtual Controller Detected—Generates an alert when a new virtual controller is detected. It
is only supported for IAP devices.

n Virtual Controller Disconnected—Generates an alert when a virtual controller is disconnected. This
alert is enabled by default and the alert severity is Major. In the Duration field, enter the duration
after which the alert must be generated. The default value is 10 minutes. It is only supported for IAP
devices.

n New AP Detected—Generates an alert when a new AP is detected. It is supported for both IAP and
CAP/ RAP devices.

n AP Disconnected—Generates an alert when an AP is disconnected. In the Duration field, enter the
duration after which the alert must be generated. The default value is 15 minutes. It is supported for
both IAP and CAP/ RAP devices.

n Rogue AP Detected—Generates an alert when a rogue AP is detected. This alert is enabled by
default and the alert severity is Major. It is only supported for IAP devices.

n Infrastructure Attack Detected—Generates an alert when an infrastructure attack is detected. It is
only supported for IAP devices.

n Client Attack Detected—Generates an alert when a client attack is detected. It is only supported for
IAP devices.
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n Uplink Changed—Generates an alert when an uplink has changed. It is only supported for IAP
devices.

n Modem Plugged—Generates an alert when the modem is plugged. It is only supported for IAP
devices.

n Modem Unplugged—Generates an alert when the modem is unplugged. It is only supported for IAP
devices.

n Insufficient Power Supplied—Generates an alert when the AP is supplied with lesser power than
the required power. It is supported for both IAP and CAP/ RAP devices.

n AP With Missing Radios—Generates an alert when the AP radio is faulty. It is supported for both
IAP and CAP/ RAP devices.

n AP CPU Utilization—Generates an alert when the AP CPU utilization exceeds the threshold value. In
the Duration field, enter the duration after which the alert must be generated. You can add
additional rule(s) for this alert. It is supported for both IAP and CAP/ RAP devices.

n AP Memory Utilization—Generates an alert when the AP memory utilization exceeds the threshold
value. In the Duration field, enter the duration after which the alert must be generated. You can add
additional rule(s) for this alert. It is supported for both IAP and CAP/ RAP devices.

n Radio Channel Utilization—Generates an alert when the AP radio channel utilization exceeds the
threshold value. In the Duration field, enter the duration after which the alert must be generated.
From the Band drop-down, select the spectrum band: 2.4 GHz or 5 GHz or 6 GHz. You can add
additional rule(s) for this alert. It is supported for both IAP and CAP/ RAP devices.

n Radio Noise Floor—Generates an alert when the Noise Floor (dBm) exceeds the threshold value. In
the Duration field, enter the duration after which the alert must be generated. From the Band drop-
down, select the spectrum band: 2.4 GHz or 5 GHz or 6 GHz. You can add additional rule(s) for this
alert. It is supported for both IAP and CAP/ RAP devices.

n Connected Clients per VC—Generates an alert when the number of connected clients to the VC
exceeds the threshold value. In the Duration field, enter the duration after which the alert must be
generated. You can add additional rule(s) for this alert. It is only supported for IAP devices.

n Connected Clients per AP—Generates an alert when the number of connected clients to the AP
exceeds the threshold value. User can enter the threshold value after which the alerts must be
generated. The recommended value is 15 minutes and above. You can add additional rule(s) for this
alert. It is supported for both IAP and CAP/ RAP devices.

n Radio Frames Retry Percent—Generates an alert when the AP radio frames retry percent exceeds
the threshold value. In the Duration field, enter the duration after which the alert must be
generated. From the Band drop-down, select the spectrum band: 2.4 GHz or 5 GHz or 6 GHz. You
can add additional rule(s) for this alert. It is supported for both IAP and CAP/ RAP devices.

n AP Tunnel Down—Generates an alert when a single L3 tunnel configured on the AP goes down. It is
only supported for IAP devices.

n All AP Tunnels Down—Generates an alert when all the L3 tunnels configured on the AP go down. It
is only supported for IAP devices.

n Radio Non Wi-Fi Utilization—Generates an alert when the AP radio non-Wi-Fi utilization exceeds
the threshold value. In the Duration field, enter the duration after which the alert must be
generated. From the Band drop-down, select the spectrum band: 2.4 GHz or 5 GHz or 6 GHz. You
can add additional rule(s) for this alert. It is supported for both IAP and CAP/ RAP devices.

n AP Crash—Generates an alert when an AP crash is detected. It is only supported for CAP/ RAP
devices.

n AP Reboot—Generates an alert when an AP reboot is detected. It is only supported for CAP/ RAP
devices.
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n Airgroup Cache Overflow—Generates an alert when cache records cross a specific limit and the AP
is flooded. Memory on the AP is limited, so a maximum limit of 2k records on discovered-cache
entries and 4k records on central-cache entries is set. This alert is generated for APs that run AOS
10.x or higher. It is only supported for IAP devices.

n AP Routing Table Limit—Generates an alert when the number of routes on Microbranch solution
reaches 80% of the maximum routes. The maximum number of routes supported is 512 out of
which, 16 route entries are reserved for default and connected routes, leaving only 496 routes for
protocol routes, static and overlay. This event is cleared when route table utilization goes below 70%
of the total route table size.

n DPP Attack—Generates an alert when there is a DPP-related DoS attack in the network.

n AP DHCP Pool Consumption Alert—Generates a Microbranch IAP alert when the client uses an IP
address from the AP DHCP Pool which exceeds the threshold value.

n IAP Firmware Upgrade Failed—Generates an alert when there is any IAP upgrade failure such as,
no firmware image is available or there is no response from the device. It is only supported for IAP
devices.

AOS-S Switch Alerts
Aruba Central On-Premises allows network administrators and users with admin permissions to
configure alerts. For more information, see Configuring Alerts.

Following are the AOS-S switch alerts that you can configure:

To enable or disable all the switch alerts on a single click, you can use the Enable All or Disable All button
respectively.

n New Switch Connected—Generates an alert when a new switch is connected.
n Switch Disconnected—Generates an alert when a switch is disconnected. This alert is enabled by

default and the alert severity is Major. In the Duration field, enter the duration during which the
condition persists. The alert must be generated if the condition persists even after this duration. The
default value is 10 minutes.

n Switch Mismatch Config—Generates an alert when there is a mismatch in switch configuration.
n Switch CPU Utilization—Generates an alert when the switch CPU utilization exceeds the threshold

value. In the Duration field, enter the duration after which the alert must be generated. You can add
additional rule(s) for this alert.

n Switch Memory Utilization—Generates an alert when the switch memory utilization exceeds the
threshold value. In the Duration field, enter the duration after which the alert must be generated.
You can add additional rule(s) for this alert.

n Switch Port Tx Rate—In the Transform Function drop-down, select either absolute or
percentage. Select absolute to generate an alert if the data transmission rate of the port (in terms
of Mbps) exceeds the threshold value. Select percentage to generate an alert if the data
transmission rate of the port (in terms of utilization as a percentage of total bandwidth available)
exceeds the threshold value. In the Interface field, enter the interface name. You can add additional
rule(s) for this alert.

n Switch Port Rx Rate—In the Transform Function drop-down, select either absolute or
percentage. Select absolute to generate an alert if the data reception rate of the port (in terms of
Mbps) exceeds the threshold value. Select percentage to generate an alert if the data reception rate
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of the port (in terms of utilization as a percentage of total bandwidth available) exceeds the
threshold value. In the Interface field, enter the interface name. You can add additional rule(s) for
this alert.

n Switch Port Input Errors—Generates an alert when the percentage of input errors on the port
exceeds the threshold value. In the Interface field, enter the interface name. You can add additional
rule(s) for this alert.

n Switch Port Output Errors—Generates an alert when the percentage of output errors on the port
exceeds the threshold value. In the Interface field, enter the interface name. You can add additional
rule(s) for this alert.

n Switch Port Duplex Mode—Generates an alert when the port is operating in half-duplex mode. In
the Interface field, enter the interface name.

n Switch PoE Utilization—Generates an alert when the PoE utilization for a port exceeds the critical
and major threshold value. This alert is enabled by default and the alert severity is Critical. You can
add additional rule(s) for this alert.

n Switch Uplink Port Status Change—Generates an alert when there is a change in the status of the
uplink port. This alert is generated when the uplink port goes down and it is cleared when the port
status is restored.

n Switch Hardware Failure—Generates an alert when the switch hardware fails. The following are the
typical hardware failures for AOS-S switches:
o Fan failure
o Power supply failure
o Redundant power supply failure
o High temperature
o Management module failures—Management module failed self-test or lost communication with

management module
o Slot failure—Lost communications detected, slot self-test failure or unsupported module, or

chassis hot swap failure
o Fabric power failure
o Internal power supply: Fan failure
o Internal power supply failure
o Internal power supply main PoE power failure
o Internal power supply: Main inlet exceeds/within total fault count
o Bad driver—Too many undersized/giant packets
o Bad transceiver—Excessive jabbering
o Bad cable—Excessive CRC/alignment errors
o Too long cable—Excessive late collisions
o Over bandwidth—High collision or drop rate
o Broadcast storm—Excessive broadcasts
o Duplex mismatch HDx—Duplex mismatch. Reconfigure to Full Duplex
o Duplex mismatch FDx—Duplex mismatch. Reconfigure port to Auto
o Link flap—Rapid detection of link faults and recoveries

n Switch STP Root Change—Generates an alert when there is a change in the Spanning Tree Protocol
(STP) root. This alert is enabled by default and the alert severity is Major.
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n Switch Uplink Port Usage—Generates an alert when the total uplink port usage of a switch at a site
exceeds the configured value in gigabytes (GB) within a specified duration. The severity for this alert
is Warning. In the exceeds field, enter the uplink port usage value in GB. In the Duration field, enter
the duration after which the alert occurs. The alert must be generated if the condition persists even
after this duration.

AOS-CX Switch Alerts
Aruba Central On-Premises allows network administrators and users with admin permissions to
configure alerts. For more information, see Configuring Alerts.

Following are the AOS-CX switch alerts that you can configure:

To enable or disable all the switch alerts on a single click, you can use the Enable All or Disable All button
respectively.

n New Switch Connected—Generates an alert when a new switch is connected.
n Switch Disconnected—Generates an alert when a switch is disconnected. This alert is enabled by

default and the alert severity is Major. In the Duration field, enter the duration during which the
condition persists. The alert must be generated if the condition persists even after this duration. The
default value is 10 minutes.

n Switch Mismatch Config—Generates an alert when there is a mismatch in switch configuration.
n Switch CPU Utilization—Generates an alert when the switch CPU utilization exceeds the threshold

value. In the Duration field, enter the duration after which the alert must be generated. You can add
additional rule(s) for this alert.

n Switch Memory Utilization—Generates an alert when the switch memory utilization exceeds the
threshold value. In the Duration field, enter the duration after which the alert must be generated.
You can add additional rule(s) for this alert.

n Switch Port Tx Rate—In the Transform Function drop-down, select either absolute or
percentage. Select absolute to generate an alert if the data transmission rate of the port (in terms
of Mbps) exceeds the threshold value. Select percentage to generate an alert if the data
transmission rate of the port (in terms of utilization as a percentage of total bandwidth available)
exceeds the threshold value. In the Interface field, enter the interface name. You can add additional
rule(s) for this alert.

n Switch Port Rx Rate—In the Transform Function drop-down, select either absolute or
percentage. Select absolute to generate an alert if the data reception rate of the port (in terms of
Mbps) exceeds the threshold value. Select percentage to generate an alert if the data reception rate
of the port (in terms of utilization as a percentage of total bandwidth available) exceeds the threshold
value. In the Interface field, enter the interface name. You can add additional rule(s) for this alert.

n Switch Port Input Errors—Generates an alert when the percentage of input errors on the port
exceeds the threshold value. In the Interface field, enter the interface name. You can add additional
rule(s) for this alert.

n Switch Port Output Errors—Generates an alert when the percentage of output errors on the port
exceeds the threshold value. In the Interface field, enter the interface name. You can add additional
rule(s) for this alert.

n Switch Port Duplex Mode—Generates an alert when the port is operating in half-duplex mode. In
the Interface field, enter the interface name.
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n Switch PoE Utilization—Generates an alert when the PoE utilization for a port exceeds the critical
and major threshold value. This alert is enabled by default and the alert severity is Critical. You can
add additional rule(s) for this alert.

n Switch Uplink Port Status Change—Generates an alert when there is a change in the status of the
uplink port. This alert is generated when the uplink port goes down and it is cleared when the port
status is restored.

n Switch Hardware Failure—Generates an alert when the switch hardware fails. The following are the
typical hardware failures for AOS-CX switches:
o Endurance Storage Utilization Failure (eMMC)—Generates an alert when the eMMC storage

reaches critical utilization levels.
o Critical hardware faults

This alert is supported only on the AOS-CX 6200 and 6300 Switch Series.
o Thermal alerts—Platform temperature crossed the lower or higher threshold.

This alert is supported only on the AOS-CX 4100i, 6100, 6200, 6300, 8320, 8360, 9300, and 10000
Switch Series running firmware version 10.10.1000 or later. For the 8400 and 6400 Switch Series,
this alert is supported from 10.11.1000 or later versions.

o Management module failure—Generates an alert when the state of the management module
changes to down or failed.

o Line-card failure —Generates an alert when the state of the line card changes to down or failed.
o Fan tray failure —Generates an alert when the state of the fan tray in the slot changes to down or

failed.
o Fan failure —Generates an alert when the state of the fan in the slot tray changes to fault.
o Power supply failure—Generates an alert when the state of the power supply in the slot changes

to fault input or warning.
n Switch NAE Status—Generates an alert when the NAE Status for the AOS-CX switches exceed the

Normal value, based on the severity configured. This alert is disabled by default and the alert
severity is Major. If you want to generate alerts for the NAE Status of value Disabled, then set the
alert severity to Warning.

n Stack Member Added/Removed—Generates an alert when a stack member is added or removed.
This alert is enabled by default and the alert severity is Major.

n Switch Stack Conductor Change—Generates an alert when there is a change in Stack conductor.
This alert is enabled by default and the alert severity is Major.

n Stack Link Status Change—Generates an alert when there is a change in the VSF link between stack
members. This alert is disabled by default and the alert severity is Major. This alert is generated and
displayed in the Open Alerts tab when the VSF link goes down. However, the same alert will be
acknowledged and displayed in the Acknowledged Alerts tab when the VSF link is restored or
enabled.

n o Switch Reboot (AOS-CX)—Generates an alert when a switch reboots, crashes, or when the
Redundancy Switchover action is executed on the active module in the switch.

Reboot alerts are generated for devices with firmware greater than 10.10.1000 with a reboot history of
less than 30 minutes from the time they are connected / last connected to Aruba Central On-Premises.
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Third-Party Device Alerts
Aruba Central On-Premises allows network administrators and users with admin permissions to
configure alerts. For more information, see Configuring Alerts.

Following are the AOS-S switch alerts that you can configure:

To enable or disable all the switch alerts on a single click, you can use the Enable All or Disable All button
respectively.

The following are the third-party device alerts that you can configure:

n New Switch Connected—Generates an alert when a new switch is connected.

n Stack Member Added/Removed—Generates an alert when a stack member is added or removed.
This alert is enabled by default and the alert severity is Major.

n Switch CPU Utilization—Generates an alert when the switch CPU utilization exceeds the threshold
value. In the Duration field, enter the duration after which the alert must be generated. You can add
additional rule(s) for this alert.

n Switch Stack Conductor Change—Generates an alert when there is a change in Stack conductor.
This alert is enabled by default and the alert severity is Major.

For more information, see the following sections:

n Alerts and Events
n Viewing Alerts in List view
n Viewing Alerts and Events in Summary view
n Viewing Events List View

Figure 138 Third-Party Device Alerts Page

Controller Alerts
Aruba Central allows you to configure and enable the following Controller alerts:

To enable or disable all the controller alerts on a single click, you can use the Enable All or Disable All button
respectively.
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n New Controller Connected—Generates an alert when new controller is connected to NMS.
n Controller Disconnected—Generates an alert when authorized, monitored controller has failed to

respond to the NMS.
n Controller CPU Utilization—Generates an alert when the controller CPU utilization exceeds the

threshold value. You can add additional rule(s) for this alert.
n Controller Memory Utilization—Generates an alert when the controller memory utilization

exceeds the threshold value. You can add additional rule(s) for this alert.
n Controller Cluster AP Capacity—Generates an alert when the Controller Cluster AP capacity

exceeds the threshold limit. This alert is applicable to Controller Cluster deployment.
n Controller Cluster Client Capacity—Generates an alert when the Controller Cluster Client capacity

exceeds the threshold limit. This alert is applicable to Controller Cluster deployment.
n Controller Cluster Tx Rate—Generates an alert when the Controller Cluster Tx rate exceeds the

threshold limit. This alert is applicable to Controller Cluster deployment.
n Controller Cluster Rx Rate— Generates an alert when the Controller Cluster Rx rate exceeds the

threshold limit. This alert is applicable to Controller Cluster deployment.
n Connected Clients To Controller—Generates an alert when the total client count on the controller

exceeds the threshold limit. This alert is applicable for all the controllers in different deployments.
n Controller Tx Rate—Generates an alert when the controller level Tx value exceeds the threshold

limit. This alert is applicable for all the controllers in different deployments.
n Controller Rx Rate—Generates an alert when the controller level Rx value exceeds the threshold

limit. This alert is applicable for all the controllers in different deployments.
n Controller Port Input Errors—Generates an alert when the controller port input errors rate

exceeds the threshold.
n Controller Port Output Errors—Generates an alert when the controller port output errors rate

exceeds the threshold.
n Controller Port Tx Rate—Generates an alert when the controller port Tx rate exceeds the

threshold.
n Controller Port Rx Rate—Generates an alert when the controller port Rx rate exceeds the

threshold.
n Controller Reboot—Generates an alert when the controller gets rebooted.

Connectivity Alerts
Aruba Central allows network administrators and users with admin permissions to configure alerts. For
more information, see Configuring Alerts.

Following are the connectivity alerts that you can configure:

n DNS Delay Detected—Generates an alert when clients experience significant delays in response
from the DNS server. Set the severity values to generate an alert if the percentage of delay from the
DNS server exceeds the threshold value. The Duration field displays the duration after which the
alert is generated. The default value is 30 minutes. You can add additional rule(s) for this alert.

n DNS Failure Detected—Generates an alert when wireless APs experience a high number of
connection failures with the DNS server. Set the severity values to generate an alert if the DNS failure
percentage exceeds the threshold value. The Duration field displays the duration after which the
alert is generated. The default value is 30 minutes. You can add additional rule(s) for this alert.

n DHCP Delay Detected—Generates an alert when there is excessive DHCP delay from client to AP in
the network. Set the severity values to generate an alert if the percentage of the DHCP delay exceeds
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the threshold value. The Duration field displays the duration after which the alert is generated. The
default value is 30 minutes. You can add additional rule(s) for this alert.

n DHCP Failure Detected—Generates an alert when there is high number of DHCP failure observed
from client to AP in the network. Set the severity values to generate an alert if the DHCP failure
percentage exceeds the threshold value. The Duration field displays the duration after which the
alert is generated. The default value is 30 minutes. You can add additional rule(s) for this alert.

n Authentication Delay Detected—Generates an alert when there is excessive delay in the client
authentication process with the AP in the network. Authentication failures include the following:
o Wi-Fi security key-exchange failures
o 802.1x authentication failures
o MAC authentication failures
o Captive failures

Set the severity values to generate an alert if the percentage of the authentication delay exceeds the
threshold value. The Duration field displays the duration after which the alert is generated. The
default value is 30 minutes. You can add additional rule(s) for this alert.

n Authentication Failure Detected—Generates an alert when there are high number of client
authentication failures in the network. Authentication failures include the following:
o Wi-Fi security key-exchange failures
o 802.1x authentication failures
o MAC authentication failures
o Captive failures

Set the severity values to generate an alert if the authentication failure percentage exceeds the
threshold value. The Duration field displays the duration after which the alert is generated. The
default value is 30 minutes. You can add additional rule(s) for this alert.

n Association Delay Detected—Generates an alert when client association delay is detected in the
network. Set the severity values to generate an alert if the percentage of the association delay
exceeds the threshold value. The Duration field displays the duration after which the alert is
generated. The default value is 30 minutes. You can add additional rule(s) for this alert.

n Association Failure Detected—Generates an alert when client association failure is detected in the
network. Set the severity values to generate an alert if the association failure percentage exceeds the
threshold value. The Duration field displays the duration after which the alert is generated. The
default value is 30 minutes. You can add additional rule(s) for this alert.

n Wi-Fi Security Key-Exchange Failure Detected—Generates an alert when there are high number of
client authentication failures (Wi-Fi Security Key-Exchange) in the network. Set the severity values to
generate an alert if the percentage of the Wi-Fi Security Key-Exchange failure exceeds the threshold
value. The Duration field displays the duration after which the alert is generated. The default value is
30 minutes. You can add additional rules for this alert.

n 802.1X Authentication Delay Detected—Generates an alert when there is an excessive delay in the
802.1X authentication process in the network. Set the severity values to generate an alert if the
percentage of the association delay exceeds the threshold value. The Duration field displays the
duration after which the alert is generated. The default value is 30 minutes. You can add additional
rules for this alert.

n 802.1X Authentication Failure Detected—Generates an alert when there are high number of
802.1X authentication failures in the network. Set the severity values to generate an alert if the
percentage of the association delay exceeds the threshold value. The Duration field displays the
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duration after which the alert is generated. The default value is 30 minutes. You can add additional
rules for this alert.

n MAC Authentication Delay Detected—Generates an alert when there is excessive an delay in the
MAC authentication process in the network. Set the severity values to generate an alert if the
percentage of the association delay exceeds the threshold value. The Duration field displays the
duration after which the alert is generated. The default value is 30 minutes. You can add additional
rules for this alert.

n MAC Authentication Failure Detected—Generates an alert when there are high number of MAC
authentication failures in the network. Set the severity values to generate an alert if the percentage
of the association delay exceeds the threshold value. The Duration field displays the duration after
which the alert is generated. The default value is 30 minutes. You can add additional rules for this
alert.

n Captive Portal Delay Detected—Generates an alert when there is an excessive delay in the captive
portal authentication process in the network. Set the severity values to generate an alert if the
percentage of the association delay exceeds the threshold value. The Duration field displays the
duration after which the alert is generated. The default value is 30 minutes. You can add additional
rules for this alert.

n Captive Portal Failure Detected—Generates an alert when there are high number of captive portal
failures in the network. Set the severity values to generate an alert if the percentage of the
association delay exceeds the threshold value. The Duration field displays the duration after which
the alert is generated. The default value is 30 minutes. You can add additional rules for this alert.

Audit Alerts
Aruba Central allows administrators to enable alerts for configuration changes at group level. The
Config Change Detected alert is under Audit tab. Configuration change alerts are intended for
administrators handling large distributed network.
Alerts are triggered under the following scenarios:

n Create New Template
n Update Existing Template
n Variable Upload

o Device Level: Sends an alert with additional parameters such as serial number and MAC address
of the device.

o Group Level: Sends an alert with respective group name.
o Configuration restore

n Configuration change at Device Level
n Configuration change at Group Level

The alert content includes the following information:

n Group Name
n Device Type
n User ID
n Config Change
n Device Serial number and MAC Address

The following table describes the behavior of the alert and alert content depending on the user action:
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User Action Group Name Device Type User ID Config
Change

Device
Serial/
MAC

Created a template Template group
name

IAP/ Switch/
Controller

User ID No Content NO

Updated existing
template

Template group
name

IAP/ Switch/
Controller

User ID Changed
content is
displayed

NO

Uploaded variable
at device level

Group name to
which the device
belongs

IAP/ Switch/
Controller

User ID No Content YES

Uploaded variable
at group level

Template group
name

IAP/ Switch/
Controller

User ID No Content NO

Made configuration
at the device level

Group name to
which the device
belongs

IAP/ Switch/
Controller

User ID Changed
content is
displayed

YES

Made configuration
change at the
group level

UI group name IAP/ Switch/
Controller

User ID Changed
content is
displayed

NO

Table 202: Config Alert Behavior

Central System Alerts
Aruba Central allows you to configure and enable the following Central System alerts:

To enable or disable all the central system alerts on a single click, you can use the Enable All or Disable All
button respectively.

n System CPU Utilization—Generates an alert when the system CPU utilization exceeds the threshold
value at a specific period of time.

n System Memory Utilization—Generates an alert when the system memory utilization exceeds the
threshold value at a specific period of time.

n System Disk I/O Utilization—Generates an alert when the system disk I/O utilization exceeds the
threshold value at a specific period of time.

n System Disk Usage—Generates an alert when the system disk usage exceeds the threshold value at
a specific period of time.

n COP Service Status—Generates an alert when the status of the service is red for a certain duration.
n Infra CPU Usage—Generates an alert for when a pod's CPU usage is above threshold for a specific

period of time.
n Infra Memory Usage—Generates an alert when a pod's memory usage is above threshold for a

specific period of time.
n Infra Disk Usage—Generates an alert when a node's disk usage is above threshold for a specific

period of time. This alert is enable by default.
n Infra Load Average—Generates an alert when a node's load average is above threshold for a

specific period of time.
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n Node Not Ready—Generates an alert when a node is not up or is in Not Ready status for a specific
period of time. This alert is enable by default.

n COP Upgrade Schedule—Generates an alert when there is a new COP version available for upgrade.
The grace period for the upgrade is set to 30 days. If the upgrade is not performed, then the COP
user interface is locked for the customers. By default, the alert severity is set to Critical and the alert
interval is set to 3 days, which indicates that every 3 days a notification is sent to the customer to
complete the upgrade.

n COP Upgrade Check Failed—If the COP system is not connected to the internet, and upgrade check
fails, then the system generates an alert to inform the customer to connect to the internet in 45 days.
If not connected then the COP user interface is locked for the customers. By default, the alert
severity is set to Critical and the alert interval is set to 3 days, which indicates that every 3 days a
notification is sent to the customer to connect to the internet.

n ILO Fans Status—Generates an alert when the fan fails. This alert is enabled by default and the alert
severity is set to Critical. In the Duration field, enter the period after which the alert must be
generated. The default value is 5 minutes.

n ILO Network Status—Generates an alert when a network is disconnected for a specific period. This
alert is enabled by default and the alert severity is set to Critical. In the Duration field, enter the
period after which the alert must be generated. The default value is 5 minutes.

n ILO Power Supply Status—Generates an alert when the power supply fails or when the power
supply is redundant. This alert is enabled by default and the alert severity is set to Critical. In the
Duration field, enter the period after which the alert must be generated. The default value is 5
minutes.

n ILO Storage Status—Generates an alert when the ILO storage exceeds the threshold value. This
alert is enabled by default and the alert severity is set to Critical. In the Duration field, enter the
period after which the alert must be generated. The default value is 5 minutes.

n ILO Temperature Status—Generates an alert when the temperature is high for a specific period.
This alert is enabled by default and the alert severity is set to Critical. In the Duration field, enter the
period after which the alert must be generated. The default value is 5 minutes.

n COP Certificate Expiry Status—Generates an alert about the expiry of a certificate. It is generated
60 days before the certificate expiry date. By default, the alert severity is set to Critical and the alert
interval is set to 1 day, which indicates that every day a notification is sent to the customer to check
the certificate status.

n COP Certificate Revocation Status—Generates an alert when the COP certificate is revoked. By
default, the alert severity is set to Critical and the alert interval is set to 1 day, which indicates that
every day a notification is sent to the customer to notify about the certificate revocation.

n Datacenter Redundancy—Generates an alert when the following scenarios occur:
o Datacenter Redundancy (DR) configuration update fails in the network
o User fails to enable or disable the feature
o The role changes of the DR clusters in the network fail
o Data synchronization between the DR clusters, primary and secondary fails
o Automatic failover is triggered

For more information, see Datacenter Redundancy.

Site Alerts
Aruba Central allows you to configure and enable this alert for aggregated device disconnects.
Aggregate device disconnect is intended to reduce the number of alerts that are generated for
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customers that prefer to have a single notification or a handful of notifications for mass outages where
several devices may go down simultaneously in a given site.

For example, if site alerts are configured with Severity as Major, Duration being 10 minutes, and Site
as site1, a single alert saying Aggregated Device Disconnects is raised on the user interface for every
set of device belonging to site1 that goes down within 10 minutes of the first DOWN event limited to 100
devices per alert. Any device that is not a part of site1 is treated as not being aggregated.

The alert content includes the following information for each device:

n Hostname
n Device Serial Number
n MAC Address
n IP Address

Unlike other alerts types, site alerts will not be auto closed.

IP Management System Alert
Aruba Central allows you to configure this alert to notify exceeding IPMS pool capacity. For more
information on how to configure alerts, see Configuring Alerts.

IPMS Pool Capacity Alert—Generates an alert when IPMS pool allocation crosses 80% of assigned pool
size. The alert is cleared when the pool capacity is below 80% of the assigned capacity in the network.

Adding Default Recipients
To set default recipients for alert notification, complete the following procedure:

1. In the Aruba Central On-Premises app, set the filter to Global.
The dashboard context for the selected filter is displayed.

2. Under Analyze, click Alerts & Events.

The Alerts & Events page is displayed in the List view.

3. In the Alerts & Events page, click the Config icon.

The Alert Severities & Notifications is displayed.

4. In the Alert Severities & Notifications page, click Default Recipients.

The Default Recipients dialog box is displayed.

5. Click the + icon to add the email address that you want add as a default recipient to receive
notifications when an alert is generated.

You can add multiple email addresses as required.

6. Click Save.

n You can also delete the existing email addresses that is already added as default recipients.
n While configuring email addresses in the site dashboard, select the Override or Append button to either

override or append the email addresses configured as default recipient in the global dashboard.
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Suppressing Alert Notifications in the Site Dashboard
Suppressing alerts for a particular site prevents all devices within the site from generating alert
notifications. You can enable alert suppression only at the Site level.

To suppress alerts, complete the following procedure:

1. In the Aruba Central On-Premises app, use the filter to select a Site.

The dashboard context for the selected filter is displayed.

2. Under Analyze, click Alerts & Events.

The Alerts & Events page is displayed in the List view.

3. In the Alerts & Events page, click the Config icon.

The Alert Notifications screen is displayed.

4. Enable the Suppress Alerts toggle button.
5. To configure emails to receive notifications when an alert is generated, select one of the following

options:
n Override—When this option is selected, the effective email list that receives alert notification

are the email addresses configured at the site level.
n Append—When this option is selected, the effective email list that receives alert notification

includes the configured default recipients list, emails configured at individual alert level, and
emails configured at the site level.

When none of these options are configured the effective email list that receives alert notifications
include default recipients list and emails configured at individual alert level. For more information
on configuring alert notifications and default recipients, see

6. Click the + icon to add the email address to receive notifications when an alert is generated.

You can add multiple email addresses as required.

7. From the time range drop-down list, select one of the following:
n All time—This allows you to suppress alerts permanently for the selected site.
n Custom date & time—This allows you to customize the time range for which you want to

suppress alerts for the selected site. Select the time range from the drop-down list and then,
select the period for which you to suppress the alerts.

8. Click Save.

Configuring Site-specific Email Notifications
Aruba Central On-Premises enables you to configure site-specific email addresses for notifying alerts.
When alerts are generated for a specific site, the email notification is automatically sent to the email
addresses configured for that site. The email addresses configured in the site dashboard overrides the
email addresses configured in the global dashboard. For more information on configuring alerts in the
global dashboard, see Configuring Alerts.

To add an email address, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Sites.

The dashboard context for the selected filter is displayed.

2. Under Analyze, click Alerts & Events.

The Alerts & Events page is displayed in the List view.
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3. Click the Config icon.

The Alert Notifications page is displayed.

4. In the Email Configuration Override window, click + to add an email address.
5. In the text-box, enter a valid email address.
6. Click Save.

n You can add up to a maximum of 10 email addresses for alert notifications in the site dashboard.
n When you configure email addresses in the site dashboard, it overrides the email addresses configured in

the global dashboard.

Deleting an Email Address in the Site Dashboard
To delete an email address, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Sites.

The dashboard context for the selected filter is displayed.

2. Under Analyze, click Alerts & Events.

The Alerts & Events page is displayed in the List view.

3. Click the Config icon.

The Alert Notifications page is displayed.

4. In the Email Configuration Override window, click the delete icon beside the email address, that
you want to delete.

5. Click Save.

Viewing Enabled Alerts
To view alerts that you have enabled, complete the following procedure:

1. In the Aruba Central On-Premises app, use the filter to select Global.
The dashboard context for the selected filter is displayed.

2. Under Analyze, click Alerts & Events.

The Alerts & Events page is displayed in the List view.

3. In the Alerts & Events page, click the Config icon.

The Alert Severities & Notifications is displayed.

4. In the Alert Severities & Notifications page, click Enabled.

Use the tabs to navigate between the alert categories. The alerts enabled for each category are
displayed in the respective tabs.

Reports
The Aruba Central On-Premises dashboard enables you to create various types of reports. To create a
report, you must have Read/Write or Admin access.

The Reports feature is available for Foundation license of APs, switches, and controllers.
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Viewing the Reports Page
To view the Reports page, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under groups, labels,
or sites. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.

2. Under Analyze, click Reports.

The Reports page is displayed in the Summary view.

The Reports page has the following sections:

n Browse—Allows you to browse through the generated reports.
n Manage—Allows you to manage the scheduled reports.
n Create—Allows you to create and schedule a report.

This section includes the following topics:

n Report Categories
n Report Configuration Options
n Previewing a Report
n Creating a Report
n Editing a Report
n Viewing the Generated Report
n Viewing the Scheduled Report
n Downloading a Report
n Deleting a Report

Report Categories
The following list provides information about the types of report under each category of the report. For
information about how to configure the Context, Transport Type, Report Order, Top N Count, Classify
On, Report Subtype, Report Period, Recurrence, and Report Information for a report, see Report
Configuration Options.

n Clients
o Client Inventory—The Client Inventory report provides information about the total number of

clients and the type of connected networks. This information aids the administrators in planning
for scalability and evaluates the deviations from the baseline. When you generate the report at
the group context, you can filter the data by SSID or Role for IAPs, Campus APs, and Remote APs.
The report displays the client details summarized by all aggregation fields and includes the
following details:
l Client count by SSID
l Client count by role

Currently, Roles are not displayed for Remote APs and Campus APs . Use the Custom field to
specify the role name and generate the Client Inventory report for Remote APs and Campus APs .

l Client count by connection mode
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l Client count by connection type
l Client count by OS
l Client count by vendors

n Client Session—The Client Session report monitors the sessions of all the users in the network and
provides insights related to usage analysis and connectivity patterns. The report also projects the
WLAN user experience to assist the user in measuring the efficiency of the deployed networks. When
you generate the report at the group context, you can filter the data by SSID or Role for IAPs, Campus
APs, and Remote APs. The report displays the details of client sessions for the SSIDs provisioned on
Instant APs and includes the following details:
o Clients

l Unique Clients
l Average Bandwidth
l Sessions

l Total

The Client Session report considers any change in the connectivity of a client connected to BSSID
or AP as a new session for the session count and calculates the Total sessions.

l Average Duration
l Traffic
l Top 100 sites by poor WLAN health (2.4GHz / 5.0GHz / combined)
l Session Data by OS / Connection Mode / SSID / Role / MAC Vendor
l Clients by OS / Connection Mode / SSID / Role / MAC Vendor
l Time Spent by OS / Connection Mode / SSID / Role / MAC Vendor
l Data Usage by OS / Connection Mode / SSID / Role / MAC Vendor
l Client Device OS / Connection Mode / SSID / Role / MAC Vendor

Currently, Roles are not displayed for Remote APs and Campus APs . Use the Custom field to
specify the role name and generate the Client Session report for Remote APs and Campus APs.

l Top 10 clients by usage that you can filter by SSIDs or Connection Types
o Client Usage—The Client Usage report displays the client usage and client connectivity details to

assist the administrator in planning the expansion of the network and the application
requirements. The report displays the client usage and count details and includes the following
details:
l Client Usage
l Top 10 Clients by Usage that you can filter by SSIDs or Connection Types
l Client Count by Wireless / Wired
l Top 10 Applications by Usage
l Top 10 Web Categories by Usage
l Top 10 App Categories
l Web Reputation

o Guest—Displays the guests and guest session details for all the SSIDs for a specific time period.
The Guest report provides visibility for all the users associated to the guest network that assists
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the user in conducting campaigns and also provides analytics of the guest users in the network.

Guest report does not support location based filtering for any selected device group, site, or label to
ensure end user privacy protection.

n Summary—Displays the details about the wireless and wired clients, and the usage details of the
wireless and wired clients over a time period of one year. The Summary reports assists the user in
measuring the Key Performance Indicator (KPI) trends over a time period of one year that aids the
user in planning for scalability.

In the Summary report, you can choose to generate a report from Trends such as Unique clients per
day, Clients per SSID, Unique client sessions per day, Average client sessions per day, Average clients
per day, and Usage over time. The Average clients per day is the number of concurrent users at a
given time (updated every five minutes). Unique clients per day is the total number of clients that
were seen for that day. For example, consider a scenario where four clients were connected in a day,
and after every hour, one client disconnected and another was connected. Then, the count for
Average clients per day was four and Unique clients per day was 27 (3+24 =27).

You can further chose to generate a report form Top N Widgets such as Top clients by usage, Top OS
by usage, Top APs by usage, Bottom APs by usage, Top sites by WLAN usage, and Bottom sites by
WLAN usage. The Top sites by WLAN usage and Bottom sites by WLAN usage options are only
available under Top N widgets section, when you select All in the Groups context level. You can
choose Top 5, Top 10, Top 25, or Top 50 from the Show Results drop-down list to view the data for
top 5, top 10, top 25, or top 50 widgets. The report displays wireless and wired clients, and wireless
and wired usage for one year and includes the following details:
o Usage

l Total Data Transfer, Total Data Downloaded, and Total Data Uploaded
o Unique clients per day
o Average clients per day
o Clients per SSID
o Unique client sessions per day

The Summary report considers any change in the connectivity of a client connected to an AP as an unique
session for the session count and calculates the Unique Client Sessions Per Day.

o Average client sessions per day
o Usage over time
o Top N Widgets—Top 5, Top 10, Top 25, or Top 50
o Top OS by usageTop APs by usage
o Bottom APs by usage
o Top sites by WLAN usage
o Bottom sites by WLAN usage

Summary report is supported from Aruba Central 2.5.2 onwards and the data is available only after an
upgrade to version 2.5.2 or later. Data prior to the 2.5.2 upgrade is not available in the report.
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n Infrastructure
o Capacity Planning—The Capacity Planning report provides information about the subscription

utilization and most used devices in the network that assists the administrator to add more
devices in a specific location to enhance the scalability and to increase the uplink capacity of the
switching infrastructure. The report displays the throughput and client density information for
devices provisioned in Aruba Central and includes the following details:
l Subscription Utilization

l Total Subscription, Used subscriptions, and Available subscriptions
l Top 25 APs by usage
l Top 25 switches by usage
l Top 25 APs by peak clients (only for IAPs)
l Top 25 APs by average clients (only for IAPs)

o Configuration & Audit—Displays the configuration and audit logs for all the device management,
configurations, and user management events triggered in Aruba Central. The Configuration
& Audit report aids the user in tracking the configuration changes in the network that assists in
tracking the deviations from the IT policies. The context available for this report is only Groups
and Show overrides option under Audit Report. The report displays the configuration and audit
logs for all the device management, configurations, and user management events triggered in
Aruba Central and includes the following details:
l Configuration Audit Status
l Aruba Switches Configuration Audit Status
l Virtual Controllers Configuration Audit Status

o Infra Inventory—Displays the inventory and subscription information for the devices that are
online or offline during a specific time period. It has a consolidated summary of each device type
with its model name and corresponding count for each site. The Infra Inventory report aids the
user in maintaining a record of the infrastructure devices and validate the firmware versions
compliance. The report displays the inventory and subscription information for the devices that
are online during a specific duration and includes the following details:
l Subscription Utilization

l Total Subscription, Used subscriptions, and Available subscriptions
l Subscription Keys
l Number of APs
l Number of Switches
l Number of Controllers
l Firmware Version Summary (AP)
l Firmware Version Summary (Switch)
l Firmware Version Summary (Controller)
l Devices by Site
l Model and Firmware version (AP)
l Model and Firmware version (Switch)
l Model and Firmware version (Controller)
l AP interfaces summary

o Network—Displays the summary details of the network that aids the user in measuring the
availability of every device in the network and projects compliance to the defined Network SLAs.
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The report displays the following parameters:

The - (hyphen) symbol in the Uptime column in APs table indicate that the IAP is in offline status.

l Top-Bottom Sites
l Top 20 Sites By Availability
l Bottom 20 Sites By Availability
l Top 20 Sites By WLAN Usage
l Bottom 20 Sites By WLAN Usage

l Number of APs
l Name, Model, Virtual Controller, IP Address, Uptime, and Availability
l AP model

l Number of Clients that you can filter based on SSIDs or Connection Types
l Top Ten Clients by Usage
l Device Types (Current)

l Data Usage
l Top Ten APs By Usage
l Total Usage By SSID
l Wireless Clients by SSID
l Wired Clients
l Peak and Average Wireless Data Usage
l Peak and Average Wired Data Usage

l Number of Switches
l Switch Model
l Top Ten Switches by Usage
l Top Ten Ports by Usage
l Switch Wired Peak and Average Uplink Stats

l Number of Controllers
l Controller Model

o New Infra Inventory— The New Infra Inventory report provides detail of the infrastructure
devices added in a time period that assists the administrator in validating the network
deployment progress against the deployment schedule. The report displays the inventory and
subscription information to the devices that are newly added in Aruba Central and includes the
following details:
l Subscription Utilization

l Total Subscription, Used subscriptions, and Available subscriptions
l Subscription Keys
l APs Added by Model
l APs Added by Group
l Switches Added by Model
l Switches Added by Group
l Controllers Added by Model
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l Controllers Added by Group
l Total APs

l Name
l Model
l Controller AP Group
l Virtual Controller
l Date Added
l IP Address
l Uptime

l Total Switches
l Name
l Model
l Date Added
l IP Address
l Uptime

l Total Controllers
l Name
l Model
l Date Added
l IP Address
l Uptime

o Resource Utilization—Displays the details of the infrastructure devices that exceeded the
configured thresholds on a daily, weekly, and monthly basis in the report. The Resource Utilization
report provides information about the devices with high CPU and memory utilization that assists
the administrator in evaluating the deviations against the device utilization baselines. The report
displays the details of infrastructure devices that exceeded the configured thresholds on a daily,
weekly, and monthly basis and includes the following details:
l Resource Utilization Threshold
l CPU/Memory Compliance
l Sites with Non-Compliant Devices
l Non-Compliance by Device Type
l Non-Compliant Access Points
l Non-Compliant Switches
l Non-Compliant Controllers

o RF Health—The RF Health report provides details of the radios of an access point that has poor
health indicators. This information assists the administrator in evaluating the deviation from the
network baselines. The report displays the following RF usage statistics for the AP radios:
l Problem Radios (6 GHz / 5 GHz / 2.4 GHz)
l Most Noise (6 GHz / 5 GHz / 2.4 GHz)
l Most Errors (6 GHz / 5 GHz / 2.4 GHz)
l Most Utilized by Channel Usage (6 GHz / 5 GHz / 2.4 GHz)
l Least Utilized by Channel Usage (6 GHz / 5 GHz / 2.4 GHz)
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l Most Channel Changes (6 GHz / 5 GHz / 2.4 GHz)
l Most Transmit Power Changes (6 GHz / 5 GHz / 2.4 GHz)
l Radio with Least Goodput (6 GHz / 5 GHz / 2.4 GHz)

For APs that support 5 GHz dual band in synchronization with Aruba Instant 8.3.0.0, the Device column
in the RF Health Report shows the radio number of the operating radio along with the model number
of the device.

o Switch Capacity Planning—The Switch Capacity Panning report provides an user with insights
on the used and unused ports usage along with power consumed by clients that helps the user
plan for scalability. The report displays the following details about the switch ports usage:
l Total Used / Unused Switch Ports
l Switch Port Summary
l Switch POE Usage Summary

The data for this report is generated only after you upgrade to Aruba Central version 2.5.2. You can view
or generate the report for 1, 7, 30, and 90 days after upgrading to Aruba Central version 2.5.2.

n Security Compliance

The security compliance reports are not supported for a single-node deployment.

o PCI Compliance—Displays the PCI Compliance result with the number of violations and the PCI
DSSv3.2 for an Instant AP. The PCI compliance report automatically executes some of the test
cases of the PCI DSS test requirements and projects compliance results that reduces the manual
efforts in validating the test cases. The report displays the following details:
l Netmask
l Compliance result as Fail or Pass with the number of violations

l PCI DSSv3.2
l Description
l Result

o RAPIDS—Displays the details of all the rogue devices in the network that aids the administrator
about the possible threat and provides essential information needed to locate and manage the
threat. The report contains the following details:
l Name
l Classification
l Encryption
l Last Detecting Device
l First seen
l Last seen
l SSID
l Radio
l Radio MAC
l Total Detecting Devices
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o Security Compliance—Displays the details of the rogue APs and wireless intrusions detected in
the network that assists the administrator in validating the compliance to the security guidelines.
The report includes the following details:
l Rogue APs

l MAC Address
l Detecting AP
l Date/Time Detected
l SSID
l MAC Vendor
l Channel
l Radio
l RSSI

l Wireless Intrusions
l Total Wireless Intrusions

n Applications
o AppRF—Displays the application usage report for a specific device group in the network. The

AppRF report provides information about the application usage patterns and the web usage
patterns in the network that assists the administrators in evaluating the deviations from the data
usage patterns. The report displays the following widgets:
l Top 10 applications accessed by the clients
l Top 10 web categories accessed by the clients
l Top 10 applications for device types
l Others

l Application
l Total Bytes

Important Points to Note

n When you select Custom range under Report Period, the Every day, Every week, and Every
month options are not available under Recurrence.

n For the Client Session report, the Show Detailed Report option is available only for a selected site.
Selecting this option restricts the Report Period to Last Day and Custom Range only. Selecting
custom range enables you to select a one day time range from the particular day till the last seven
days only.

n In the Infra Inventory report, select the Offline option in the Device Inventory section to generate
the report with details of the devices that are offline. The PDF displays the distribution of inactive
devices by the device type and CSV displays the list with additional information.

n In the Configuration and Audit report with local overrides details, the count for device override is
available only for the Groups context. To include local overrides column in the Configuration and
Audit report, select the Show Override option in the Audit Report section.

n When a new switch connects to Aruba Central, the Last Used at and Unused Since (Days) columns
value is displayed as NA for all the ports that are down in the .csv file, that is created for the Switch
Ports in the Switch Capacity Planning report. When a port continues to be in a down state, the Last
Used at and Unused Since (Days) columns value will be displayed as NA for the time period of the
generated report.
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Report Configuration Options
Aruba Central allows you to create various types of reports based on your network requirements. For
information about each type of report, see Report Categories.

The types of report categories supported by Aruba Central are:

n Clients
n Infrastructure
n Security Compliance
n Applications

Sections in Reports

Context
Allows you to select the context for which you want to create the report. Select one of the available
options from the following:

n Groups—Allows you to generate the report for the devices attached to a group.
o Filter By—Select either Roles or SSIDs to filter the IAPs, Remote APs, or Campus APs within the

selected group(s) based on their roles or SSIDs.
l Roles—Select a device from the list of roles for which you want to generate the report.

Currently, Roles are not displayed for Remote APs and Campus APs . Use the Custom field to
specify the role name and generate the Client Session or Client Inventory report for Remote APs
and Campus APs.

l SSIDs—Select a device from the list of SSIDs for which you want to generate the report.
o Trends—Select a trend or multiple trends from the list for which you want to generate the report.

Select All to generate the report for all the available trends in the list. Allows you to generate the
report to view the data for one year for trends such as Unique clients per day, Clients per SSID,
Unique client sessions per day, Average client sessions per day, Average clients per day,
and Usage over time.

o Top N Widgets—Select a widget or multiple widgets from the list for which you want to generate
the report. Select All to generate the report for all the available widgets in the list. Allows you to
generate the report to view the data for one year for widgets such as Top clients by usage, Top
OS by usage, Top APs by usage, Bottom APs by usage, Top sites by WLAN usage, and
Bottom sites by WLAN usage.

o Audit Report—Select Show Overrides to include the override data of the devices within the
group in the Configuration & Audit report.

o Device Inventory—Select Offline Devices (CSV) to include the details of the offline devices
within the group in the Infra Inventory report. Select Device Types and Models by Site (CSV) to
view a consolidated summary for each device type with model name and corresponding count for
each site is generated in the CSV format. Select Wired AP Port Status (CSV) to view a
consolidated list of wired AP port details such as model, serial, site name, port, status, speed, and
duplex in the CSV format.

o Threshold—Select the Same as AP threshold check-box to set the same threshold as the AP.
Allows you to set the percentage of the CPU and the memory thresholds for APs, switches, and
controllers within the group.
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o Criteria—Select Used/Unused Ports and/or PoE to include the data regarding the used ports,
unused ports, and/or PoE usage in the Switch Capacity Planning report. When you select
Used/Unused Ports, the Switch Port Summary report is generated. When you select PoE, the
Switch PoE Usage Summary report is generated. The individual port details are available only in
the .csv export of the Switch Port Summary report.

o Subnet/SSID List—Select Subnet/SSID List to generate the report based on the CDE SSIDs or
CDE subnets.

o CDE SSIDs—Select an SSID from the list for which you want to generate the report. The security
compliance report is not supported for a single-node deployment.

o CDE Subnets—Select a subnet from the list for which you want to generate the report. The
security compliance report is not supported for a single-node deployment.

n Label—Allows you to generate the report for the devices attached to a label.
o Label—Select a label or multiple labels from the list for which you want to generate the report.

Select All to generate the report for all the available labels in the list. The search bar allows you to
filter a label from the list.

n Site—Allows you to generate the report for the devices attached to a site.
o Site—Select a site or multiple sites from the list for which you want to generate the report. Select

All to generate the report for all the available sites in the list. The search bar allows you to filter a
site from the list.

o Detailed Report—Select Show Detailed Report to include the client session details for each
client within the site in the Client Session report.

Top N Count
Enter the range in the Top N for the number of results you want the include in the report. The Top N
range should be between 1 to 250.

Classify On
Select either web category or web reputation to include data about the total usage of each device
based on the web reputation or web category in the report.

Report Subtype
Select either summary report or blocked urls report to include the summary or blocked urls details in
the report. A blocked URLs report will contain blocked URL Information along with the number of
attempted session count.

Optional Widgets
Select the required options to include in the CSV format of the RF Health report:

n RF Details (CSV)—Select RF Details (CSV) to include the radio details in the CSV report.
n IAP Uplink Usage (CSV)—Select IAP Uplink Usage (CSV) to include the usage details of an IAP

uplink in the CSV report. The IAP Uplink Usage information is available only for Instant APs with
Advanced license.

Report Period
Specify the time period for which you want to create the report. Select one of the available options from
the following:
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n Last day—Select Last day to generate the report for the last day.
n Last 7 days—Select Last 7 days to generate the report for the last 7 days.
n Last 30 days—Select Last 30 days to generate the report for the last 30 days.
n Last Calendar Month—Select Last Calendar Month to generate the report for the previous

calendar month.
n Last 90 days—Select Last 90 days to generate the report for the last 90 days.
n Last year—Select Last year to generate the Summary report for the last year.
n Custom range—Select Custom range to generate the report for a time period within the last 90

days. When you select Custom range, the Date Range option is displayed. In the Date Range
window, select a time period within the last 90 days for which you want to create the report.

The Custom range for the Summary report is available for the last one year, except the current date (today).
All other reports are available for 90 days.

The Report Period for the Outdoor Clients report consists only the Custom Period. The options available are
two-week time ranges that begin one week after a recommendation was updated in the Outdoor clients are
impacting Wi-Fi performance AI Insights. For more information, see The AI Insights Dashboard.

Recurrence
Select Recurrence to schedule the report. Select one of the available options from the following:

n One time (Now)—Select One time (Now) to schedule the report generation once for the current
time.

n One time (Later)—Select One time (Later) to schedule the report generation once for a later time.
When you select One time (Later), the Run Day and Run Time options are displayed. In the Run
Day window, select the date for which you want to schedule the report. In the Run Time window,
select the time for which you want to schedule the report.

n Every day—Select Every day to schedule the report generation for every day. When you select
Every day, the Run Time option is displayed. In the Run Time window, select the time for which you
want to schedule the report.

n Every week—Select Every week to schedule the report generation for every week. When you select
Every week, the Run Day and Run Time options are displayed. In the Run Day window, select the
day for which you want to schedule the report. In the Run Time window, select the time for which
you want to schedule the report.

n Every month—Select Every month to schedule the report generation for every month. When you
select Every week, the Run Day and Run Time options are displayed. In the Run Day window,
select the date from the Day drop-down list for which you want to schedule the report. In the Run
Time window, select the time for which you want to schedule the report.

Report Information
Allows you to add a title, an email address, and specify the format of report to receive the email. Enter
the following information:

n Report title—Enter the title of the report.
n Email to—Enter an email address to receive the report over an email.
n Email Format—Select PDF and/or CSV to specify the format of the report to receive the email.
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Previewing a Report
Aruba Central allows you to preview a type of report prior to generating the report. The preview of the
report displays dummy values.

To preview the report, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.

2. Under Analyze, click Reports.

The Reports page is displayed in the Summary view.

3. Click Create.

The Reports page is displayed in the List view.

4. Hover over a report and then click Preview to preview the report.

The preview report provides the following details:

n Report Name—Name of the report.
n Report Type—Type of the report.
n Date Run—Time when the report was last run.
n Group/Device—The group or device for which the report was run.

In the preview of the report, the PDF, CSV, and Email to icons are dummy icons.

For more information about the reports under each category, see Report Categories.

Creating a Report
Aruba Central On-Premises allows you to generate a report for devices associated with a group, multi-
group, label, or a site.

Although your page view is set to a specific group, site, or label, you can create reports for a different group,
site, or a label. However, if your page view is set to an Instant Access Point (IAP) cluster or switch, you can
schedule a report only for that IAP cluster or switch.

To create a report, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.

2. Under Analyze, click Reports.

The Reports page is displayed in the Summary view.

3. Click Create.

The Reports page is displayed.

4. Select the type of report you want to create and then click Next.
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5. Based on the type of report you select, a few options are displayed.

Select one of the available options to set the context of the report. For example, for the Client
Inventory report, select one of the available options under Context, which is either Groups,
Labels, or Sites.
n Groups—Select Groups to generate reports for the devices attached to a group.
n Labels—Select Labels to generate reports for the devices attached to a label.
n Sites—Select Sites to generate reports for the devices attached to a site.

Based on the selected context, further options are displayed to create a report with more details.
For more information, see Report Configuration Options.

6. Click Next.

The Report Period option is displayed.
7. Under Report Period, select one of the available options to create a report for the last day, last 7

days, last 30 days, last year, or for a custom range.

The Custom range for the Summary report is available for the last one year, except the current date
(today). All other reports are available for 90 days.

8. Click Next.

The Recurrence option is displayed.
9. Under Recurrence, select one of the available options to schedule a report for the current time,

later time, every day, every week, or every month.
10. Under Report Information, enter the title of the report and an email address.
11. Select PDF and/or CSV to specify the format of the report to receive the email.
12. Click Generate.

The report gets generated and is displayed under the Scheduled Reports table. The report gets
emailed as an attachment to the email address provided.

Editing a Report
Aruba Central allows you to edit a report for devices associated with a group, multi-group, label, or a
site.

To edit a report, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.

2. Under Analyze, click Reports.

The Reports page is displayed in the Summary view.

3. Click Manage.

The Scheduled Reports table is displayed in the Config view.

4. In the Scheduled Reports table, select a report and then click the edit icon.

The report that you want to edit is auto-selected in the Reports page.

5. Click Next.
6. Based on the type of report you select, a few options are displayed. Select one of the available

options to set the context of the report. For example, for the Client Inventory report, select one
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of the available options under Context, which is either Groups, Labels, or Sites.
n Groups—Select Groups to generate reports for the devices attached to a group.
n Labels—Select Labels to generate reports for the devices attached to a label.
n Sites—Select Sites to generate reports for the devices attached to a site.

Based on the selected context, further options are displayed to create a report with more details.
For more information, see Report Configuration Options.

7. Click Next.
The Report Period option is displayed.

8. Under Report Period, select one of the available options to edit a report for the last day, last 7
days, last 30 days, last year, or for a custom range.

The Custom range for the Summary report is available for the last one year, except the current date
(today). All other reports are available for 90 days.

9. Click Next.
The Recurrence option is displayed.

10. Under Recurrence, select one of the available options to re-schedule a report for the current
time, for a later time, every day, every week, or every month.

11. Under Report Information, edit the title of the report and an email address.
12. Select PDF and/or CSV to specify the format of the report to receive the email.
13. Click Generate.

The report gets generated and is displayed under the Scheduled Reports table. The report gets
emailed as an attachment to the email address provided.

Viewing the Generated Report
To view a generated report, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.

2. Under Analyze, click Reports.

The Reports page is displayed in the Summary view.

3. Click Browse.

The Generated Reports table is displayed in the List view.

4. In the Generated Reports table, click a report name listed under Title.

The report details are displayed.

The Generated Reports table provides the following information:

n Title—Name of the report. Click to filter the report based on the name of the report.
n Date Run—Timestamp indicating when the report was generated.
n Group/Device—The group or device for which the report was generated.
n Label/Site—The label or site for which the report was generated.
n Type—Type of report. Click to filter the report based on the type of the report. Click to select a
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type of report from the drop-down list.
n Created By—Email address of the user who created the report.

The reports are listed in the Generated Reports table only for one year from the date when the reports were
generated. After one year, the reports are removed from the table.

Viewing the Scheduled Report
To view a scheduled report, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.

2. Under Analyze, click Reports.

The Reports page is displayed in the Summary view.

3. Click Manage.

The Scheduled Reports table is displayed in the Config view.

4. In the Scheduled Reports table, click a report name listed under Title.

The report details are displayed.

The Scheduled Reports table provides the following information:

n Title—Name of the report. Click to filter the report based on the name of the report.
n Next Run—Time when the report will run in the future.
n Group/Device—The group or device for which the report was run.
n Label/Site—The label or site for which the report was run.
n Recurrence—Time period of the scheduled report.
n Type—Type of report. Click to filter the report based on the type of the report. Click to select a

type of report from the drop-down list.
n Created By—Email address of the user who created the report.
n Status—Status of the report. Click to filter the report based on the status of the report. Click to

select a status of report from the drop-down list.

Downloading a Report
To download a report, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.

2. Under Analyze, click Reports.

The Reports page is displayed in the Summary view.

3. Click Browse.

The Generated Reports table is displayed in the List view.

4. In the Generated Reports table, hover over the report you want to download.



Aruba Central On-Premises 2.5.7 | User Guide 943

5. Click the PDF or the CSV icon to download the report to the local system.
6. Optionally, click the Email to icon to generate an email attachmnent of the report.

Deleting a Report
To delete a report, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.

2. Under Analyze, click Reports.

The Reports page is displayed in the Summary view.

3. Click Browse.

The Generated Reports table is displayed in the List view.

4. In the Generated Reports table, hover over the report that you want to delete.
5. Click the Delete icon.

The Delete Report pop-up window is displayed.

6. Click Yes to delete the report.

The selected report is deleted.

Deleting Multiple Reports
To bulk delete multiple reports, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.

2. Under Analyze, click Reports.

The Reports Reports page is displayed in the Summary view.

3. Click Browse.

The Generated Reports table is displayed in the List view.

4. To bulk delete, select multiple reports by clicking the rows. Alternatively, press and hold the Ctrl
key and select the reports.

The number of selected reports is displayed in a pop-up window.

5. In the pop-up window, click the icon.

The Delete Report pop-up window is displayed.

6. Click Yes to bulk delete the selected reports.

The selected reports are deleted.

RAPIDS
Aruba Central On-Premises supports the rogue detection and classification feature that enables
administrators to detect intrusion events and classify rogue devices. Rogue devices refer to the
unauthorized devices in your WLAN network. With Rogue Access Point Detection System (RAPIDS), you
can create a detailed defintion of what constitutes a rogue device, and act on an rogue or interfering
devices that can be later considered for investigation, restrictive action, or both. Once the interfering
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devices are discovered, Aruba Central On-Premises sends alerts to your network administrators about
the possible threat and provides essential information needed to locate and manage the threat.

RAPIDS is not supported on single-node deployments.

Aruba Central On-Premises supports the following features:

n Automatic detection of unauthorized wireless devices.
n Wireless detection, using authorized wireless APs to report other devices within range to calculate

and display rogue location on a VisualRF map.
n Ability to make a decision based on the AP classifications and send the information back to the AP.
n Obtaining the MAC address table from a switch to identify the switch port to which the rogue device

is connected.

Viewing the RAPIDS Page
1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,

Labels, or Sites.
For all devices, set the filter to Global.

2. Under Manage, click Security > RAPIDS.
By default, the IDS page with WIDS Events table is displayed.

3. Click Rogues tab to view the rogues details page.

This section includes the following topics:

n WIDS Events
n Rogues
n Configuring RAPIDS

WIDS Events
WIDS events are generated at the AP side based on some pre-defined signatures on the ArubaOS
software.

The Manage > Security > RAPIDS > IDS tab provides a summary of the total number of wireless
attacks detected for a given duration.

The WIDS Events table displays events from the following categories:

n Infrastructure attacks—These attacks are identified by the AP against the wireless infrastructure.
n Client attacks—These attacks are identified by the AP against the wireless clients.

The WIDS Events table displays a consolidated list of events and filters out the duplicate events for
better visibility. The event types are synchronized and categorized based on levels, High, Medium, and
Low.

WIDS Events displays data for a maximum time period of 1 month because the volume of data that is collected
is huge.
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Field Description

Event Type The type of the intrusion or attack detected. Click the drop-down arrow at the column heading
to filter the event types based on your requirement.

Category Category of the intrusion or attack, infrastructure, or client attack. Click the drop-down arrow
at the column heading to filter the category that you want to display.

Level The level of the intrusion or attack detected as High, Medium, or Low. Click the drop-down
arrow at the column heading to filter the attack level.

Time Time of the intrusion or attack.

Station MAC MAC address of the station under attack or BSSID of the AP under attack.

Detecting AP The MAC address of the device that detected the intrusion or attack.

Radio Band Radio band on which the intrusion was detected. There are three radio band signals available,
2.4 GHZ, 5 GHZ, and 6 GHZ. Click the drop-down arrow at the column heading to filter the
radio band where the intrusion was detected.

Description Details of the attack or the intrusion.

Table 203: WIDS Events

Note the following important points:

n Clicking icon enables you to customize the WIDS Events table columns or set it to the default
view.

n To view the details of each event that is generated, click the arrow against each row in the table.

Figure 139 Event Expansion

n Intrusions are displayed for the time selected in Time Range Filter. The WIDS Events displays data
for a maximum time period of 1 month only.

Configuring IDS Parameters
The type and severity of Intrusion Detections raised by an access point (AP) is configurable and affects
the data that is seen in the WIDS Events table. For more information, see Configuring IDS Parameters
on IAPs.

Generating Alerts for Security Events
Aruba Central supports configuring alerts for IDS events.

For IDS events, you can generate alerts for infrastructure attacks and client attacks whereas, for rogues,
you can generate alerts for rogue APs in the network.

To generate alerts, complete the following steps:



Monitoring Your Network | 946

1. In the Aruba Central app, use the filter to select Global.
2. Under Analyze, click Alerts & Events. The Alerts & Events page is displayed.
3. In the Alerts & Events page, click the Config icon.

The Alert Severities & Notifications is displayed.

4. Select Access Point tab to display the AP dashboard. Aruba Central supports three alert types for
identifying interfering devices:
n Rogue AP Detected
n Infrastructure Attacks Detected
n Client Attack Detected

5. Select an alert and click + to enable the alert with default settings. To configure alert parameters,
click on the alert tile (anywhere within the rectangular box) and do the following:
a. Severity—Set the severity. The available options are Critical, Major, Minor, and Warning.

For a few alerts, you can configure threshold value for one or more alert severities. To set the
threshold value, select the alert and in the exceeds text box, enter the value. The alert is triggered
when one of the threshold values exceed the duration.

b. Device Filter Options—(Optional) You can restrict the scope of an alert by setting one or
more of the following parameters:
n Group—Select a group to limit the alert to a specific group.
n Label—Select a label to limit the alert to a specific label.
n Sites—Select a site to limit the alert to a specific site.

c. Notification Options
n Email—Select the Email check box and enter an email address to receive notifications

when an alert is generated. You can enter multiple email addresses, separate each value
with a comma.

n Streaming—Select the Streaming check box to receive the streaming notifications when
an alert is generated.

n Webhook—Select the Webhook check box and select the Webhook from the drop-down
list. For more information, see Webhook.

n Syslog—Select the Syslog check box to receive the syslog notifications when an alert is
generated.

d. Click Save.

For more information on how to configure Alerts, see Configuring Alerts.

Generating Reports for Security Events
Aruba Central supports generating reports for IDS events. To generate reports, complete the following
steps:

1. In the Aruba Central app, use the filter to select Global.
2. Under Analyze, click Reports.
3. In the Reports page, click Create. Aruba Central supports Security Compliance to display the

report of all wireless intrusions. For more information on how to create Reports, see Creating a
Report.
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For creating RAPIDS report, you need not select the Groups or Labels option. Also, you need not select the
device groups name or labels name from the Device Groups or Labels drop-down lists, respectively.

Rogues
Rogue Access Point Intrusion Detection System is used as a security service for detecting and classifying
rogues and intruders automatically as well as manually. The Rogues tab provides a summary of the
rogue APs, suspected rogue APs, interfering APs, neighboring APs, and the total number of manually
contained APs for a given duration.

Viewing the Rogues Page
To view the rogues detail page in order to find information on monitored APs, complete the following
steps:

1. In the Aruba Central app, use the filter to select a group, device, site, or a label.
2. Under Manage, click Security.

By default, the RAPIDS > IDS tab is displayed.
3. Click the Rogues tab to view rogue detail page.

The access points in Aruba Central are classified as one of the following:

Classification Description

Rogue AP An unauthorized access point plugged into the wired side of the network.

Suspect Rogue AP An unauthorized access point with a signal strength greater or equal to -75 that could have
connected to the wired network.

Interfering AP An access point seen in the RF environment with a signal strength lesser than -75 but is
not connected to the wired network. These access points may potentially cause RF
interference, but cannot be considered as a direct security threat as these devices are not
connected to the wired network. For example, an interfering AP can be an access point
that belongs to a neighboring office’s WLAN but is not part of your WLAN network

Neighbor AP A neighboring AP, for which the BSSIDs are known. Once classified, a neighboring AP does
not change its state.

Manually
contained

Manual classification which enables rogue containment against the selected AP.

Table 204: Access Points Classification in Aruba Central

The Security > RAPIDS > Rogues page displays the following information tabs:

n Total—Shows the total number of rogues classified as Rogue , Suspected Rogue, or Interfering,
that are detected in the network.

n Rogues—Shows the total number of devices classified as rogue APs.
n Suspected Rogues—Shows the total number of devices classified as suspected rogues APs.
n Interfering—Shows the total number of devices classified as interfering APs.
n Neighbors—Shows the total number of devices classified as neighbor APs.
n Manually Contained—Shows the total number of devices classified as manually contained.



Monitoring Your Network | 948

n The feature for enabling wireless containment under the IDS Unauthorized Device profile and IDS
Impersonation profile may be in violation of certain FCC regulatory statutes.

n Users with admin role can see all the rogue APs and interfering devices.

Click the respective tabs to display specific rogue information pertaining to each classification. By
default, the Total information tab is selected and the Detected Access Points table displays all the
detected rogue APs.

Fields Description

BSSID The BSSIDs broadcast by the rogue device.

Name Name of the rogue device detected in the network.

Classification Classification of the rogue device (monitored device) as Suspect Rogue, or
Interferer. Click the drop-down arrow at the column heading to filter the
rogue classification that you want to display.

Last Seen The time relative to the current moment, for example, 6 minutes; an hour, at
which the rogue device was last detected in the network.

Last Seen By The AP name of the last device to report to have seen the monitored AP.

First Seen The time relative to the current moment (for example, 6 minutes; an hour) at
which the rogue device was f detected in the network.

Encryption The type of encryption used by the device that detected the rogue; for
example, WPA, Open, WEP, Unknown. Generally, this field alone does not
provide enough information to determine if a device is a rogue, but it is a
useful attribute. If a rogue is not running any encryption method, you have a
wider security hole than with an AP that is using encryption.

Mac Vendor The vendor name associated to the MAC OUI of the rogue AP.

SSID The SSID broadcast by the rogue device.

Signal The signal strength of the AP that detected the rogue device.

Containment Status Details of the containment status. Click the drop-down arrow at the column
heading to filter the status that you want to display.

Table 205: Rogues Pane

Each rogue can be detected by multiple APs and these APs can be part of a different group at the same time.
You can see the set of APs that detected a rogue in the rogue details section. Even if one of the APs stop
detecting a rogue, other APs can still render the rogue itself and can be seen when filtered by different groups.

Reclassifying APs Manually
You can reclassify the rogue devices manually. To reclassify, complete the following steps:

1. Select the device that you want to reclassify.

Alternatively, you can also hover over the device and click the icon.



Aruba Central On-Premises 2.5.7 | User Guide 949

2. Click Reclassify.

The Reclassify dialog box appears.

3. Select the type of classification from the drop-down list, Rogue, Neighbor, or Manually
contained.

4. Click Reclassify.

Note the following important points:

n Click to customize the Detected Access Points table columns or set it to the default view.
n VisualRF uses the heard signal information to calculate the physical location of the device.

n Rogues APs are displayed for a selected time period based on the time selected in Time Range Filter.
Rapids displays data for a maximum time period of 1 week because the volume of data that is
collected is huge.

n To view the details of each rogue or event that is generated, click the arrow against each row in the
table.

Generating Reports for RAPIDS
Aruba Central supports generating reports for IDS events. To generate reports, complete the following
steps:

1. In the Aruba Central app, use the filter to select Global.
2. Under Analyze, click Reports.
3. In the Reports page, click Create. Aruba Central supports Security Compliance to display the

report of all wireless intrusions. For more information on how to create Reports, see Creating a
Report.

For creating RAPIDS report, you need not select the Groups or Labels option. Also, you need not select the
device groups name or labels name from the Device Groups or Labels drop-down lists, respectively.

Configuring RAPIDS
Aruba Central RAPIDS allow users to configure RAPIDS rules to customize classification. Users can
configure a predefined set of classification criteria at the global level to determine the classification of a
neighboring AP.

To enable RAPIDS, click the Config icon in Manage > Security > RAPIDS and enable the Enable RAPIDS
toggle button.

The Enable RAPIDS page displays the default classification rules in a table:
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Field Description

Name Name of the rule created.

Classification Classification of the detected AP:
n Rogue
n Suspected Rogue
n Manually Contained

Enabled Status of the rogue detected.

Table 206: Classification Rules

The default classification rules that are already configured and visible in the table are as follows:

n Suspected AP On Prem—This rule detects an AP with a signal strength greater than -50 dbm. The AP
must either be very close to the network or on the network premises for it to have such high signal
strength. Hence, the classification results into a suspected rogue.

n Hotspot Demotion—This rule detects a rogue device when wireless BSSID is seen simultaneously as
a wireless client and neighbor AP. The classification results into a suspected rogue.

n Detected on the wire—This rule detects a rogue device when a wireless BSSID matches a wired MAC
address reported from one of the managed switches is the network. The classification results into a
rogue.

You can reorder the rules in the table by dragging it up or down. AP classification checks the rules from
the top of the table, that is, the first rule of the table takes precedence and then moves on to the next
and so on. Once a match is found at any point then, that is the resulting classification of the monitored
AP. RAPIDS then pushes the final classification back to the Virtual Controller or the AP providing the user
a consistent classification value across the network.

To customize the Classification Rules table, click the icon to select the required columns, or click
Reset to default to set the table to the default columns. To autofit the columns, click the icon and
select Autofit columns.

Hover over the classification rule and click the icon to delete the rule and click the icon to edit the
rule.

Configuring a New Rule
Apart from the default rules that are already configured, you can also configure or add your own rules.
To add a rule, complete the following steps:

1. In the Aruba Central app, set the filter to Global.
The dashboard context for the selected filter is displayed.

2. Under Manage, click Security > RAPIDS.

By default, the WIDS Events table is displayed in the List view.

3. Click the Config icon.

4. Enable the Enable RAPIDS toggle button if you are logging in for the first time. If the toggle
button is already enabled, the enable RAPIDS page is displayed.

The already configured classification rules are displayed.

5. Click the icon to add a new rule.
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The Add Rule page is displayed.

6. Enter the Rule Name and Classification type, as required.

7. Select the This rule is enabled checkbox, if you want to enable the rule that you are adding.

8. Click the icon to add the conditions and select the configurable classification criteria that can
be applied from the Criteria drop-down list.

You can choose multiple criteria for a single rule. For more information on classification criteria,
see Rule Classification Criteria.

All the criteria in a single rule is applied together at once. A rule can only be applied if all the criteria in
that rule evaluate as a match.

9. Click Save.

Clicking save displays the newly added rule on the Classification Rules table.

Rule Classification Criteria
The following table describes the configurable classification criteria that can be applied to a rule:

Criteria Description

Signal Users can specify a minimum signal strength. The range varies from -85 to 0.

Detecting AP Count The number of detecting APs that can see the rogue device in the network. The range
varies from 2 to 255. For example, in a store, there are 4 APs and 1 AP is in the freezer
area. AP1, AP2, and AP3 can hear ("see") signals of the rogue device in the network.
However, AP4 cannot detect any signals because of the freezer walls hence, in this
scenario there are 3 detecting APs for the rogue device.

WLAN Classification This criteria results in a match when a classification value received from the detecting
device matches any of the devices that are classified under the following values:

n Valid
n Interfering
n Neighbor
n Rogue
n Suspected Rogue
n Manually Contained

SSID Matches A list of patterns are compared to the rogue SSID. This criteria results in a match if any of
the strings are found as sub-strings of the rogue SSID.

SSID Does Not
Match

A list of patterns are exempted from this rule. This criteria results in a match if the rogue
SSID contains any of these sub-strings.

Known valid SSIDs Exact match against all known valid SSIDs configured on the customer's account.

Plugged into wired
network

For AOS-CX and AOS-PVOS switch customers, a neighbor AP is determined to be plugged
into the network by matching a wireless BSSID to a wired MAC address connected to the
switch.
The wired to wireless MAC correlation is done by matching the first 40 bits of both the
MAC addresses.
For example, 11:22:33:44:55:61 matches 11:22:33:44:55:11 => 11:22:33:44:55:XX matches
11:22:33:44:55:XX

Table 207: Classification Criteria
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Criteria Description

Time on network Minimum number of minutes since the monitored AP was first seen on the network.

Site Matches There are up to 32 site IDs for which this rule is applied. This criteria results in a match if
the device site is not in the "Site excludes" list.

Site Does not match There are up to 32 site IDs for which this rule is skipped. The criteria results in a match if
the site IDs are mutually exclusive between the "Site includes" and "Site excludes" lists.

Band The radio band of the monitored AP.

Valid client MAC
match

Match any monitored BSSID against the current valid station cache list. This must be an
exact match.

Encryption Encryption: OPEN, WEP, WPA, WPA2, WPA3

Viewing Audit Trail
The Audit Trail page shows the total number logs generated for all device management, configuration,
access logs, and user management events triggered in Aruba Central On-Premises. Audit Trail logs
provide users both user-initiated and system-initiated actions.

The Audit Trail logs are displayed for the following types of operations:

n Device status and configuration
n Firmware upgrade
n Device assignment to groups
n Label assignment to devices
n User addition and deletion
n User unsuccessful login attempt
n CLI and UI Access logs

To view the Audit Trail logs perform the following steps:

1. In the Aruba Central On-Premises app, use the filter to select a group or a device.
2. Under Analyze, click Audit Trail. The Audit Trail table is displayed with the following details:

n Occurred On— Timestamp of the audit log. Use the sort option to sort the audit logs by date
and time. Use the filter option to select a specific time range to display the audit logs.

n IP Address—IP address of the client device.
n Username—Username of the admin user who applied the changes.
n Target—The group or device to which the changes were applied.
n Category—Type of modification and the affected device management category. It shows audit

trail categories for system and user actions.
n Description—A short description of the changes such as subscription assignment, firmware

upgrade, and configuration updates. Click to view the complete details of the event. For
example, if an event was not successful, clicking the ellipsis displays the reason for the failure.

To customize the Audit Trail table, click the eclipses icon to select the required columns, or click Reset to
default to set the table to the default columns.
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Viewing Access Logs in Audit Trail
Users can now see logs for any kind of Aruba Central On-Premises access that is either done through
the web or Command Line Interface (CLI). To view access logs perform the following steps:

1. In the Aruba Central On-Premises app, use the filter to select a group or a device.

2. Under Analyze, click Audit Trail. The Audit Trail table is displayed.

3. Click the Add Access Log tab at the top right corner.
The Add Access Log dialog box appears.

4. Enable the CLI Access and Web Access toggle button to start displaying access logs in details.

5. Click Save.
To filter the access logs on the Audit Trail table, select CLI Access or Web Access from the
category column.

Accessing and Exporting Audit Logs
All user activity is logged in HPE GreenLake as audit trails logs. View the following topics to understand
more about accessing and managing HPE GreenLake audit logs.

Accessing HPE GreenLake Audit Logs
1. On the HPE GreenLake Home page, under Menu, click Manage.

The Manage Account page displays.

2. On the Manage Account page, click Audit Log.

The Audit Log page displays a table with a list of the changes and processes within your account,
following is a list of the same:

n Category - Type of modification and the affected device management category.

n Description - A short description of the changes such as subscription assignment, firmware
upgrade, and configuration updates.

n IP Address - IP address of the client device.

n Target - The group or device to which the changes were applied.

n Time - Timestamp of the audit log. Use the sort option to sort the audit logs by date and time.
Use the filter option to select a specific time range to display the audit logs.

n Username - Username of the admin user who applied the changes.

Viewing Audit Log Details

1. On the Audit Log page, select a Category or Description to view details.

The User Management page displays the user activity, description, and activity details.

2. To filter audit logs by column type, select the Edit Columns link. You can select up to six columns
to display in the table at one time.

Some columns are required and cannot be turned off.
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Editing Columns

1. Click the Edit Columns link to filter or change the data returned in the Audit Log table list.

The Edit Columns pane displays.

2. Check or uncheck any of the options.

3. Click Save or Reset to Default to return to the default column settings.

Exporting Audit Logs
1. On the Audit Log page, click the Export Log button.

The Export Log dialog box displays.

2. Select the file type you want to export.

Audit Log PDF exports can only support a maximum of 6 table columns.

3. Select the table entries and columns you want to include in the exported file.

a. Select Current Search Result to export only the files from your current search results.

b. Select Entire Audit Log to export the entire audit log to your computer.

4. Click Save after you make your selections.

Customizing Audit Log Categories

1. On the Audit Log page, click Advanced Search. The Advanced Search pane displays.

2. Select the categories of the audit log you want to display, and click Search. The audit log table is
updated with your changes.

3. Click Reset Search to reset the table to the default categories.

Monitoring Sites Topology Tab
In Aruba Central On-Premises, the Topology tab is displayed only when you select a site from the filter.
The Topology tab provides a graphical representation of the site including the network layout, details of
the devices deployed, and the health of the WAN uplinks and tunnels.

For APs and Gateways, the topology feature is available for both Foundation and Advanced licenses;
and for switches, the feature is available for Foundation licenses.

In Aruba Central On-Premises, the Topology tab does not support Campus controllers and Campus APs.

The Topology feature is available for Foundation and Advanced licenses for APs, switches, and
controllers.

For more information, see the following topics:

n Pre-requisites for Topology Tab
n Viewing the Topology Map
n Features on Topology User Interface
n Viewing the Topology Map for Device or Link Details
n Viewing the Topology Map for Details Pane
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n Viewing the Topology Map for Unreachable Devices
n Viewing the Topology Map for VLAN Overlay Details

Pre-requisites for Topology Tab
The following types of devices are displayed as part of the Topology tab:

n Access Point (AP)
n AOS-S and AOS-CX switch
n AOS-S and AOS-CX switch stack

In the topology map, Aruba Central On-Premises supports third-party routers, switches, and APs from
the vendors listed below:

n Cisco
n Procurve
n Juniper
n HPE Comware
n Meraki
n Cumulus
n Huawei
n Mikrotik
n Extreme
n HPE OfficeConnect Switch
n Arista
n 3Com
n Ruckus
n Mojo
n Mist
n Motorola
n Netgear
n Dell
n Comware
n Hirschmann Railswitch
n Ubiquiti

Pre-requisites
This section discusses the pre-requisites associated with the devices so that they are displayed correctly
in the Topology tab:

n The topology map filters devices based on sites. To view the topology map, ensure that you have
assigned the devices to sites.

n The minimum required ArubaOS version for access points (APs) in the topology map is ArubaOS
version 8.1.0.0-1.0.1.1.

n To view AOS-CX switches in the topology map, you must create a template configuration for the
switch with the password in plaintext.
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n According to the current topology, there should be a one-to-one mapping between a site and a device.
Topology does not currently support unmanaged devices belonging to multiple sites. All Aruba Central
On-Premises managed devices that are connected to a common unmanaged device must terminate on
the same site.

n In Aruba Central On-Premises, the maximum number of devices supported per site in the topology tab is
500.

n To identify a valid third-party device in the topology, the neighbor device must have a valid third-party
vendor name in either hostname or system description for the devices on the site. Also, the enabled
capability for the unmanaged neighbor device must include one of the following:
o Access Point
o Router
o Bridge
o Repeater
o Other
o Unknown but not Station or Telephone

Viewing the Topology Map
To view the topology map, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a site for which you want to view the
topology map.

The dashboard context for the site is displayed.

2. Under Manage, click Overview > Topology.

The topology map for the selected site is displayed.

3. In the topology map, hover over a device or a link to view the details. For more information, see
Viewing the Topology Map for Device or Link Details .

4. In the device or the link details, click the Show Details link to view the Details pane. For more
information, see Viewing the Topology Map for Details Pane.

Features on Topology User Interface
The following figure shows the different features available on the Topology tab:
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Figure 140 Features on Topology Tab

Callout
Number Description

1 Click the icon to show or hide the VLANs pane.

2 Click the toggle switch to show or hide the device name.

3
Click the filter icon to filter the type of devices to be shown on the map. The following
options are available:
n Access Points—Allows you to show or hide the APs from the topology map.
n Security Cloud—Allows you to show or hide the Zscaler and Palo Alto Prisma Access™ Cloud

Service from the topology map.
n Switch—Allows you to show or hide the switches from the topology map.
n VPNC—Allows you to show or hide the VPNCs and the virtual controllers from the topology

map.
n Unmanaged—Allows you to show or hide the unmanaged devices from the topology map.
n Show Devices Without Link—Allows you to show or hide the devices without link from the

topology map.

4
Click the icon to view the topology map in a left to right orientation. The default orientation
of the topology map is left to right orientation.

5
Click the icon to view the topology map in a top-down orientation.

Table 208: Icon Details
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Callout
Number Description

6 The search bar allows you to locate a device in the topology map. The search bar field supports
exact and partial text searches.

7 Click the icon to reset the topology map to the default view.

8
Click the , icons to change the zoom level of the topology map. Alternatively, you can drag
the slider to set the zoom level of the topology map.

9 Click the icon to view the topology map in full-screen view. In the full-screen view, the device
or link details feature is disabled in the topology map.

When the number of downstream devices connected to a device is less than or equal to 10, the devices are
visible in the topology map. When the number of downstream devices connected to a device is more than 10,
click the device icon to view the devices in the topology map. A bubble icon on the device represents the
number of connected downstream devices.

Icon Type

AP

Switch

Switch Stack

Unmanaged Device

Table 209: Icon Types

Icon Status

n —Indicates that the device health is poor when the CPU usage is greater than 90% and the memory
usage is greater than 90%.

n —Indicates that the device health is good when the CPU usage is lower than or equal to 75% and
the memory usage is lower than or equal to 75%.

n —Indicates that the device health is fair when the CPU usage is greater than 75% and the memory
usage is greater than 75%.

n —Indicates that the device is online.
n —Indicates that the device is offline.

Viewing the Topology Map for Device or Link Details
To view the topology map, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to a site for which you want to view the
topology map.

The dashboard context for the site is displayed.
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2. Under Manage, click Overview > Topology.

The topology map for the selected site is displayed.

3. In the topology map, hover over a device or a link to view the details.

When you hover over a device or link, a pop-up displays the following details:

Figure 141 Device or Link Details

Type Description

Access Point Displays the following details:
n Name—Hostname of the access point.
n Type—Type of the device.
n Model—Hardware model of the access point.
n Health Reason—The health status of the access point. This parameter is only available

when the access point is offline.
n Show Details—Click the link to view the Details pane.

Unmanaged Displays the following details:
n Name—Name of the unmanaged device.
n IP Address—IP address of the unmanaged device.
n Show Details—Click the link to view the Details pane.

NOTE: The value of the IP Address parameter is empty if LLDP does not provide the neighbor

Table 210: Device or Link Details
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Type Description

information.

Switch Displays the following details:
n Name—Hostname of the switch.
n Type—Type of the device.
n Model—Hardware model of the switch.
n Children—Number of devices connected to the switch categorized, based on the health

and status of the devices. The Children field displays the following details:
o Health—Count of devices connected to the switch based on the health of the device.

For more information, see Viewing the Topology Map for Device or Link Details .
o Status—Count of devices connected to the switch based on the current status of the

devices. The arrow in green indicates that the device is online. The arrow in red
indicates that the device is offline.

n VLANs—List of VLANs configured on the switch. This field is displayed only when the
VLANs option is selected under Overlays. For more information, see Viewing the
Topology Map for Device or Link Details .

n Show Details—Click the link to view the Details pane.

Switch Stack Displays the following details:
n Name—Hostname of the switch stack.
n Type—Type of the device.
n Model—Hardware model of the switch.
n Children—Number of devices connected to the switch categorized based on the health

and status of the devices. The Children field displays the following details:
o Health—Count of devices connected to the switch based on the health of the device.

For more information, see Viewing the Topology Map for Device or Link Details .
o Status—Count of devices connected to the switch based on the current status of the

devices. The arrow in green indicates that the device is online. The arrow in red
indicates that the device is offline.

n VLANs—List of VLANs configured on the switch. This field is displayed only when the
VLANs option is selected under Overlays. For more information, see Viewing the
Topology Map for Device or Link Details .

n Show Details—Click the link to view the Details pane.

AOS-CX VSX
Switch

Displays the following details:
n Name—Name of the AOS-CX switch that is configured with VSX. The name is displayed in

the VSX_<Device Name> format. For example, VSX_8320-switch-primary.
n Type—Type of the device.
n Model—Hardware model of the AOS-CX switch.
n VSX Role—Role of the AOS-CX switch in the VSX configuration. Supported values are

Primary and Secondary.
n Children—Number of devices connected to the switch categorized based on the health

and status of the devices. The Children field displays the following details:
o Health—Count of devices connected to the switch based on the health of the device.

For more information, see Viewing the Topology Map for Device or Link Details .
o Status—Count of devices connected to the switch based on the current status of the

devices. The arrow in green indicates that the device is online. The arrow in red
indicates that the device is offline.
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Type Description

n VLANs—List of VLANs configured on the switch. This field is displayed only when the
VLANs option is selected under Overlays. For more information, see Viewing the
Topology Map for Device or Link Details .

n Show Details—Click the link to view the Details pane.

Edge Displays the following information about the edge link:
n <Interface of the device>—Interface number of the device.
n <Name of the device>—Displays the name of the device.
n Health Reason—Displays the health status of the down edge link. This parameter is only

available when the edge link is down.
n Alternative links—Number of the alternative links.

The edge in green color indicates that the edge is up. The edge in red color indicates that the
edge is down.
Click the edge link to view the Details pane.

Unmanaged
edge

Displays the following information about the link:
n <Name of the connected device>—Name of the device connected with the edge link.
n <Port Identifier>—Port number of the device.
n Health Reason—Displays the health status of the down edge link. This parameter is only

available when the edge link is down.
n Alternative links—Number of the alternative links.

The unmanaged edge in green color indicates that the unmanaged edge is up. The
unmanaged edge in red color indicates that the unmanaged edge is down.
Click the unmanaged edge link to view the Details pane.

ISL edge in
AOS-CX VSX
toplogy map

Displays the following information about the link:
n ISL—Number of inter-switch link (ISL) present between the AOS-CX switches configured

with VSX.
n Other Links—Number of other links present between the AOS-CX switches configured

with VSX.

Viewing the Topology Map for Details Pane
In the topology map, the Details pane provides a summary of the devices, uplinks, and tunnel details.

A green bullet icon indicates that the device health is good when the CPU usage is lower than or equal to
75% and the memory usage is lower than or equal to 75%. A yellow bullet icon indicates that the device
health is fair when the CPU usage is greater than 75% and the memory usage is greater than 75%. A red
bullet icon indicates that the device health is poor when the CPU usage is greater than 90% and the
memory usage is greater than 90%. The arrow in green indicates that the device is online. The arrow in
red indicates that the device is offline.

1. In the Aruba Central On-Premises app, set the filter to a site for which you want to view the
topology map.

The dashboard context for the site is displayed.

2. Under Manage, click Overview > Topology.

The topology map for the selected site is displayed.

3. In the device or the link details, click the Show Details link to view the Details pane.
4. To view the Details pane for a tunnel, uplink, or edge, click the link.
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The Details task pane displays the following information:

Figure 142 Details Pane

Type Description

Access Point Displays the following details:
n Name—Hostname of the access point. Click the access point name to view the Access

Point Details page.
n IP—IP address of the access point.
n MAC—MAC address of the access point.
n Type—Type of the device.
n Serial—Serial number of the access point.
n Model—Hardware model of the access point.
n Status—Operational status of the access point.
n Health—Operational health of the access point.

Unmanaged Displays the following details:
n Name—Name of the unmanaged device.
n Description—Description of the unmanaged device.
n IP—IP address of the unmanaged device.
n Capabilities—Displays the capabilities of the unmanaged device.
n Supported—Lists the supported capabilities of the unmanaged device.
n Enabled—Lists the enabled capabilities of the unmanaged device.

Table 211: Contents of the Details Pane
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Type Description

NOTE: The value of the parameters are empty if LLDP does not provide the neighbor
information.

Switch Displays the following details:
n Name—Hostname of the switch. Click the switch name to view the Switch Details page.
n IP—IP address of the switch.
n MAC—MAC address of the switch.
n Type—Type of the device.
n Serial—Serial number of the switch.
n Model—Hardware model of the switch.
n Status—Operational status of the switch.
n Health—Operational health of the switch.

Switch Stack Displays the following details:
n Name—Hostname of the switch. Click the switch name to view the Switch Details page.
n IP—IP address of the switch.
n MAC—MAC address of the switch.
n Type—Type of the device.
n Serial—Serial number of the switch.
n Stack Role—Role of the switch in the stack.
n Model—Hardware model of the switch.
n Status—Operational status of the switch stack.
n Health—Operational health of the switch stack.
n Stack Members—Provides the Name, Role, and State details of the stack member. Click

the stack member name to view the Switch Details page.

AOS-CX VSX Displays the following details:
n Name—Hostname of the AOS-CX switch with VSX configured. Click the switch name to

view the Switch Details page.
n IP—IP address of the switch.
n MAC—MAC address of the switch.
n Type—Type of the device.
n Serial—Serial number of the switch.
n Model—Hardware model of the switch.
n Status—Operational status of the switch.
n Health—Operational health of the switch.

VSX section displays the following details:
n ISL State—State of the ISL connection with the peer AOS-CX switch. Following are the

supported values:
o WAITING_FOR_PEER—Waiting for connectivity to the peer.
o PEER_ESTABLISHED—Steady state. VSX LAGs are up when the device is in this state.
o SPLIT_SYSTEM_PRIMARY—Lost ISL connectivity to the peer and the device is operating

as primary.
o SPLIT_SYSTEM_SECONDARY—Lost ISL connectivity to the peer and the device is

operating as secondary.
o SYNC_PRIMARY—ISL connectivity to the peer restored and the device is syncing states

to the peer.
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Type Description

o SYNC_SECONDARY—ISL connectivity to the peer restored and he device is learning
states from the peer. VSX LAGs are down when the device is in this state.

o SYNC_SECONDARY_LINKUP_DELAY—Device has learned its states from the peer and
monitoring for hardware is to be programmed. VSX LAGs are down when the device is
in this state.

n ISL Port—ISL port number of the selected AOS-CX switch. If the ISL is a LAG, then this field
displays the LAG name.

n ISL Mgmt State—Management state of the ISL. Following are the supported values:
o OPERATIONAL—ISL management is operational.
o INTER_SWITCH_LINK_MGMT_INIT—ISL management is in initialization state.
o CONFLICTING_OR_MISSING_DEVICE_ROLES—Either the role is missing on one of the

VSX peers or the same role is configured on both VSX peers.
o SW_IMAGE_VERSION_MISMATCH_ERROR—Software version on the primary device

does not match with the software version on the secondary device.
o INTER_SWITCH_LINK_DOWN—ISL is down.
o INTERNAL_ERROR—ISL management has internal errors.

n Config Sync Enabled—Configuration synchronization between the VSX switches are
enabled or disabled.

n Config Sync Status—Status of the configuration synchronization between the VSX
switches. Following are the supported values:
o IN-SYNC—Configuration synchronization is operational and the VSX switches are in

sync.
o DISABLED—Configuration synchronization is disabled.
o SW_IMAGE_VERSION_MISMATCH_ERROR—Software image version on the primary

device does not match with the software image version on the secondary device.
o CONFLICTING_OR_MISSING_DEVICE_ROLES—Either the role is missing on one of the

VSX peers or the same role is configured on both VSX peers.
o PEER_DB_CONNECTION_ERROR—Error in connecting to peer database. It involves

errors due to ISL or ISL management.
o CONFIGURATION_SYNC_CONFLICT—Configuration synchronization is operational, but

has conflicts synchronizing the configuration. Conflicts can occur if the configuration on
the primary device is marked for sync, but the same configuration on the secondary
device is not marked for sync.

o CONFIGURATION_SYNC_MISSING_REFERENCE—Configuration synchronization is
operational, but has missing references in synchronizing the configuration.

n Role—Role of the AOS-CX switch in the VSX configuration. Supported values are Primary
and Secondary.

n Peer IP—IPv4 address of the peer switch.
n Peer Serial—Serial number of the peer switch.
n Peer MAC—MAC address of the peer switch.
n Peer Name—Hostname of the peer switch.
n Last Seen—Date on which the peer switch was last synced.

Edge Displays the following information about the link:
n Interface numbers—Interface numbers of the device.
n Interface—Interface number of the individual device.
n Serial—Serial number of the individual device.
n Device Name—The name of the individual device.
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Type Description

n Port Number—The port number of the individual device.

Unmanaged
edge

Displays the following information about all the links:
n Interface numbers—Interface numbers of the device.
n Health Reason—Displays the health status of the edge link. This parameter is only

available when the edge link is down.
n Interface—Interface number of the device.
n Serial—Serial number of the device.
n Device Name—Name of the device.
n Port Number—Port number of the device.
n Interface—Interface number of the unmanaged device.
n MAC—MAC address of the unmanaged device.
n Device Name—Name of the unmanaged device.
n Port Identifier—Displays the port ID, port name, or MAC address of the unmanaged

device.

ISL edge in
AOS-CX VSX
toplogy map

Displays the following information about the ISL edge:
n Inter-Switch Link Status—Status of the ISL connection with the peer.
n <LAG-name> - ISL section displays details about all the interfaces that are part of the LAG.

The section also displays the details of the devices connected to these interfaces. It
displays the following details:
o Serial—Serial number of the individual device.
o Device Name—Name of the individual device.
o Port Number—Port number of the individual device.

n Other—This section displays details about the other links present between the VSX
configured AOS-CX switches. It displays the following details:
o Serial—Serial number of the individual device.
o Device Name—Name of the individual device.
o Port Number—Port number of the individual device.

Viewing the Topology Map for Unreachable Devices
The Unreachable Devices pane provides information about the orphan and the offline unmanaged
devices. An unmanaged device is considered to be orphan when all its neighboring Aruba devices get
deleted and are only displayed in the Unreachable Devices list. An unmanaged device is considered to
be offline when all its neighboring Aruba devices are offline and are displayed both in the Topology
map and in the Unreachable Devices list.

When an unmanaged device is either offline or disconnected, they are only displayed in the
Unreachable Devices list. The devices listed in the Unreachable Devices pane are deleted after 15
days.

To view unreachable devices, perform the following steps:

1. In the Aruba Central On-Premises app, set the filter to a site for which you want to view the
topology map.

The dashboard context for the site is displayed.

2. Under Manage, click Overview > Topology.

The topology map for the selected site is displayed.
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3. To view the Unreachable Devices pane, click the Unreachable Devices button.
4. The Unreachable Devices pane displays the following details:

n Name—Name of the unmanaged device.
n Type—Type of the unreachable device.
n MAC—MAC address of the unmanaged device.
n Last Seen—The last active time and date of the unmanaged device.

Viewing the Topology Map for VLAN Overlay Details
The topology map displays information about the VLANs configured on switches running AOS-S and
AOS-CX software. To view the VLAN information:

To view unreachable devices, perform the following steps:

1. In the Aruba Central On-Premises app, set the filter to a site for which you want to view the
topology map.

The dashboard context for the site is displayed.

2. Under Manage, click Overview > Topology.

The topology map for the selected site is displayed.

3. Select the VLANs option under Overlays
The VLANs pane is displayed and the network elements in the topology map, such as device
icons and edge links, are grayed out.

4. Select a VLAN from the VLANs pane. You can also enter a VLAN name or ID in the search box.

The topology map displays the following information:
n The switches that have the selected VLANs configured are highlighted in a color depending on

the status of the switch, green for online and red for offline.
n The edge link connecting two switches is highlighted in blue, if the following conditions are

met:
o The VLAN IDs are present in both the switches and in the ports associated with the edge

link between the switches.
o The VLAN type (tagged or untagged) configured is the same in both the switches.

5. Hover over the switch to view the list of all VLANs (comma separated) configured on the switch.
The VLAN IDs are also listed as a range if consecutive VLAN IDs are configured. For example, 100-
178, 190, 210.

6. Hover over the edge link connecting the two switches. The pop-up displays the following
information:
n Host name of the switch
n Serial number of the switch
n VLAN ID
n Type of VLAN: tagged, untagged, or missing



Chapter 18

All Clients

All Clients

The Clients page provides a summary view of all the clients connected to the network. You can filter
clients based on the network the clients are connected to. The page displays key client information and
also allows you to view a specific client detail page.

By default, the Clients page displays a unified list of clients for the selected group. The list of clients is
populated for a time range of 3 hours. To view the list of clients for a different time range, click the Time
Range Filter link and select the required time period. Total data usage for the selected time period is
displayed above the client summary bar.

To filter clients based on the device to which the clients are connected, select the device type from the
Clients drop-down list:

n All—Displays a unified list of clients connected to the network.
n AP—Displays a list of clients connected to the Instant AP.
n Switch—Displays a list of clients connected to the switch.
n Controller—Displays a list of clients connected to the Aruba Controller.

The wired client will show up in the Clients page only if the client is connected to an Aruba 2540 Series, Aruba
2920 Series, Aruba 2930F Series, Aruba 2930M Series, Aruba 3810 Series, or Aruba 5400R Series switch.

To filter clients based on the network to which the clients are connected, click the network type from the
Client Summary bar:

n Wireless—Displays a list of clients connected to the wireless network. The wireless clients are
denoted by the icon.

n Wired—Displays a list of clients connected to the wired network. The wired clients are denoted by the
icon.

n Remote—Displays a list of clients connected through VPN. The remote clients are denoted by the
icon.

The Clients table lists the details of each client. By default, All clients is selected and the table displays
the following columns: Client Name, Status, IP Address, Connected To, VLAN, SSID/Port, AP Role,
Controller Role, and Health.

The following functions are available in the table:

n Click to download the client details in the .csv file format.
n Click to select more columns or reset the table view to the default columns.
n If a filter icon appears next to the column header, click and enter the filter criteria or select a filter

criteria. For example, to search a client, click the predefined filter criteria: ConnectingConnected,
Offline, Failed, or Blocked from the Client Summary bar and in the Client Name column enter the
name of the client.

n To disconnect a wireless client, hover over the corresponding wireless client and click Disconnect
from AP. For more details, see Disconnecting a Wireless Client from an AP.
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Column Applicability Description

Client Name n All
n AP
n Switch
n Controller

Username, hostname, or MAC address of the client. Click the client
name to view the client details page.

Status n All
n AP
n Switch
n Controller

Client connection status. Use the filter option to view the
following:
n Connecting clients
n Connected clients
n Offline clients
n Failed clients
n Blocked clients

Hover your mouse over the status to view:
n Client name
n IP address
n Connected—Date and time at which the client connected.
n Offline—Last seen time.
n Failed—Failure reason and last seen time.

IP Address n All
n AP
n Switch
n Controller

IP address of the client.

VLAN n All
n AP
n Switch
n Controller

VLAN of the device to which the client is connected.

Connected To All AP name, Switch name, or Controller name. This is the first layer 2
hop for the client. If the device does not have a name, the
MAC address is displayed.

SSID/Port n All
n AP
n Switch
n Controller

Displays the SSID for wireless clients and the port number for
wired clients. The column title displays SSID and Port
interchangeably based on the device filters. For APs, the column
title displays SSID. For switch and controller, the column title
displays as Port.

AP Role AP Role assigned by the Instant AP.

Controller Role Controller Role assigned by the Aruba Controller.

Health AP Client health. The value can be one of the following:
n Good—71-100.
n Fair—31-70.
n Poor—0-30.

Failure Stage AP Stage of the connection where the client failed to connect. The
failure reasons could be:
n Association failure

Table 212: Unified Client List View
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n MAC authentication failure
n 802.1X authentication failure
n Key exchange failure
n DHCP failure
n Captive Portal failure

Group Name n All
n AP
n Switch
n Controller

Group name of the device managed by Aruba Central.

Site Name n All
n AP
n Switch
n Controller

Name of the site in which the devices managed by Aruba Central
are installed.

MAC Address n All
n AP
n Switch
n Controller

MAC address of the client.

NOTE: The filter criteria supports all delimiters in the MAC
address. For example, if you search a MAC address with a comma,
it is automatically converted to semicolon and the corresponding
result is displayed.

Hostname n All
n AP
n Switch
n Controller

Host name of the client.

User Name n All
n AP
n Switch
n Controller

Username of the client.

Key Management AP Security mode used by the client.

Authentication n All
n AP
n Switch
n Controller

Authentication type used by the client to connect with the device.

Global Unicast
IPv6 Address

n All
n AP
n Controller

When the IPv6 address is present for a client, you can view its
Global Unicast IPv6 address. Click the ellipsis and select the
column to view the value if the column is not displayed.

Link Local IPv6
Address

n All
n AP
n Controller

When the IPv6 address is present for a client, you can view its Link
Local IPv6 address. Click the ellipsis and select the column to view
the value if the column is not displayed.

Capabilities AP Client 802.11 capabilities.

Table 212: Unified Client List View



All Clients | 970

Column Applicability Description

Usage n All
n AP
n Switch
n Controller

Total data usage for the selected time period.

OS n All
n AP
n Switch
n Controller

Operating system of the client.

Last Seen Time n All
n AP
n Switch
n Controller

Date and time at which the client was last seen.

Connected Since n All
n AP
n Switch
n Controller

Date and time since when the client was connected.

AP Name AP Name of the Instant AP.

AP Mac Address AP MAC address of the Instant AP.

Channel/Band AP Last connected channel and band.

Switch Name n All
n Switch

Name of the switch.

Port n All
n AP
n Switch
n Controller

Port number of the switch.

Controller Name n All
n Controller

Name of the Aruba Controller.

Tunneled n All
n AP
n Switch
n Controller

Tunnel mode applicable for the Aruba Gateway managed WLAN,
UBT, or PBT client.

Segmentation n All
n AP
n Switch
n Controller

Type of segmentation. The type of segmentation can be:
n None
n UBT
n PBT
n Underlay
n Overlay

Table 212: Unified Client List View
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NOTE: To view the details about dynamic segmentation, a
gateway must be licensed in Aruba Central and connected to the
switch.

Table 212: Unified Client List View

Client Overview
The Clients page displays the details of clients connected to the devices and their connectivity status.

To view the clients overview page:

1. In the Aruba Central On-Premises app, use the filter bar to select a group, label, site, or a
device.

2. Under Manage, click Clients. The All Clients overview page is displayed.

3. Click the icon to view the client summary page.

The overview page displays the total number of clients, bandwidth usage, and the application usage by
the clients connected to the wired and wireless networks. The following table describes the information
displayed in each section:

Data Pane
Content Description

Time Range
Filter

By default, the graphs on the Clients page are plotted for a time range of 3 hours. To view
the graphs for a different time range, click the Time Range Filter link. You can choose to
view graphs for a time period of 3 hours, 1 day, 1 week, 1 month and 3 months.
However, the Distribution data (Client OS) under the Distribution tab does not honor the
time range you selected in the time range filter.

Total Displays the total number of clients.

Wireless Displays the total number of clients connected to wireless network.

Wired Displays the total number of clients connected to the wired network.

Remote Displays the total number of remote clients connected through VPN.

Usage Displays the Bandwidth Usage and Remote Bandwidth Usage of the incoming and
outgoing throughput traffic for all clients and remote clients during a specific time range in
kilobits per second (Kbps). The graph will not show any data for the clients that are connected
to the network for less than two hours.

Distribution Displays the type of client device connected to the wireless network.

Top N Displays a list of clients connected to the currently available SSIDs that utilize the maximum
bandwidth in the network.
The Top Clients by Usage table displays data only for the clients that are connected to the
network for a total duration of two or more hours.

Table 213: Client Overview Page
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Client Details
The Clients page displays the number of clients connected to the wireless, wired, or remote networks.
By default, the Clients page displays a unified list of clients for the selected group.

The client details page shows a summary of the client and allows you to navigate to the corresponding
device details page.

The wired client shows up in the Clients page only if the client is connected to an Aruba 2540 Series, Aruba
2920 Series, Aruba 2930F Series, Aruba 2930M Series, Aruba 3810 Series, or Aruba 5400R Series switch.

This section includes the following topics:

n Wireless Client Details
n Wired Client Details
n Remote Client Details

Wireless Client Details
The wireless client overview page displays the client summary details, applications, and events details
for the selected client.

This section includes the following topics:

n Viewing Clients Connected to Wireless Networks
n Summary
n Overview
n Disconnecting a Wireless Client from an AP
n Blocking a Wireless Client from an AP
n Applications
n Events

Viewing Clients Connected to Wireless Networks
To view the details of a client connected to the wireless network:

1. In the Aruba Central On-Premises app, use the filter bar to select a group or a device.
2. Under Manage, click Clients. The clients overview page is displayed.
3. Click the icon to view the client table.
4. By default, the Clients table displays a unified list of clients for the selected group.
5. Click the client name to view the client details page. If there are many clients connected to the

network, click Wireless to filter the clients connected to the wireless network and enter the client
name in the Client Name column and then click the client name. The Summary page is
displayed.

Summary
The client summary page displays the following information:
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Wireless Client Health Bar

Field Description

Connection
status icon

Displays the icons with the connection status of the client. Connection status is updated
immediately on state change. The available statuses are:
n Connecting—Displays a list of client connections that are in progress.
n Connected—Displays a list of clients that are successfully connected to the network.
n Failed—Displays a list of all failed client connections.
n Offline—Displays a list of all offline clients.
n Blocked—Displays a list of all blocked clients.

Device Health Signal strength of the client device. The signal strength value is displayed in percentage:
0-30—Poor
31-70—Fair
>71—Good

Signal Quality SNR for the client as measured by the AP. The SNR value is displayed in decibels:
0-20—Poor
21-35—Fair
>35—Good

Tx| Rx Rate Data transmission or reception rate.

Connected To Name of the AP that broadcasts the SSID to which the client is connected. Click the name of
the AP to view the device details page.

Refresh icon Restarts the Live Health Bar session. This icon appears only after 15 minutes of pinning the
Health Bar to the Client Details page and it is called as the Live Health Bar because the
data is updated every 5 seconds. For more information, see Live Health Bar.

Table 214: Wireless Client Health Bar

Overview
The Overview tab displays information about the type of data path that the client uses, the network
and connectivity details, and basic client details such as IP address of the client, type of encryption etc.
The following table describes the information displayed in each section:

Section Description

Data Path Displays the data path of the client in the network. Click the AP icon to view the AP details
page.
The data path can be one of the following:
n Client > SSID > AP
n Client > SSID > AP > Switch
n Client > SSID > AP > Switch > Controller
n Client > SSID > AP > Controller

Client Displays the following information:
n Username—User name of the client.
n Hostname—Hostname of the client.
n Client Type—Type of the client device.
n IP Address—IP address of the client.

Table 215: Client Details
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Section Description

n MAC Address—MAC address of the client.
n Client OS—Operating system running on the client device.
n Connected Since—Date and time since when the client is connected.
n Manufacturer—Manufacturer of the client device.
n Encryption—Type of client encryption.
n AI Insights—See AI Insights

Network Displays the following information:
n VLAN—Displays the VLAN ID on which the client is connected to the AP.

n Switch Role—Displays the role assigned to the client by the Switch.
n Role—Displays the role assigned to the client by the AP.

n Segmentation—Displays the type of dynamic segmentation configured for the client.
Supported values are UBT, PBT, Underlay, or Overlay.

n Auth Server—Server that last authenticated the client device. The field displays the IP
address of the server that performed either 802.1X or MAC authentication for the client
device. If the client connects to the network through 802.1X and MAC authentication,
Aruba Central displays only the IP address of the server that performed 802.1X
authentication.

n DHCP Server—DHCP server that last assigned IP address to the client.

n Tunneled—Displays whether the client is tunneled or not.

n Tunnel ID—Displays the tunnel ID the client is connected to.

Connection Displays the following information:
n Channel—Radio channel assigned to the client.
n Band—Radio band on which the client is connected.
n Client Capabilities—Capabilities of the client device.
n Client Max Speed—Wireless link data transfer speed.
n LEDs on Access Point—Enables or disables the LED indication on the corresponding AP

to which the client is connected. Click Blink LED to enable the blinking of LEDs on the AP.
The default blinking time is set to 5 minutes and it stops automatically after 5 minutes. To
stop the blinking, click Stop.

Throughput Displays the incoming and outgoing throughput traffic for the client during a specific time
range. By default, the graph on the Throughput pane is plotted for a time range of 3 hours.
To view the graph for a different time range, click the Time Range Filter link. You can choose
to view the graph for a time period of 3 hours, 1 day, 1 week, 1 month, or 3 months.

Health Displays the health score and status of a wireless client. By default, the graph on the Health
pane is plotted for a time range of 3 hours. To view the graph for a different time range, click
the Time Range Filter link. You can choose to view the graph for a time period of 3 hours, 1
day, 1 week, 1 month, or 3 months. The graph is plotted against the client health and client
score, where the client health is measured as Poor, Fair, or Good and the health score ranges
between 0 to 100.
n 0-30—Poor
n 31-70—Fair
n >71—Good

Signal Quality Displays the signal quality and the SNR for the wireless client as measured by the AP. The SNR
value is displayed in decibels:

Table 215: Client Details
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Section Description

n 0-20—Poor
n 21-35—Fair
n >35—Good

Retry Frames Displays the percentage of Tx and Rx retries by a wireless client.

Tx/Rx Rate Displays the data transmission and reception rate for the wireless client .

Roaming
Experience

Displays the details of a roaming event and the latency of the client. When a wireless client
roams between two APs, the destination AP creates an event. By default, the Roaming Events
& Latency table displays data for the last 3 hours. To view the table for a different time range,
click the Time Range Filter link. You can choose to view the data for a time period of 3 hours, 1
day, 1 week, 1 month, or 3 months. The Roaming Events & Latency displays two views, grid
view and trend view. The grid view displays the following information:
n Date/Time—Displays the time of occurrence of the client roaming/ association events.
n SSID—The SSID to which the client is connected.
n Latency(ms)—Roaming Latency in milliseconds between source and destination AP.
n To BSSID—The BSSID of the destination AP.
n Source AP—AP to which the client was connected.
n Destination AP—AP to which the client is connected.
n Roaming Type—The type of roam.
n Band—Radio band on which the client is connected.
n RSSI(dBm)—Received Signal Strength Indicator (RSSI) on the client, estimated measure of

power level that the client is receiving from the AP.
The trend view displays a chart that shows the percentage of high latency roaming events,
total roaming events, and the number of high latency roaming events at a particular instance
based on the value selected in the Time Range Filter. Clicking the chart icon brings you back
to the grid view.

Table 215: Client Details

Association History
The Association History table is available only for Campus APs. It consists of a list of events for client
association or dissociation such as when it disconnects from an AP, roams between APs, changes SSID,
or change in the radio or BSSID. The table launches only the default parameters, click the Ellipsis icon
and select all columns to view all the parameters. By default, the data is displayed for a time range of 3
hours. To change the time range, click the Time Range Filter link and select the required option as 3
hours, 1 day, 1 week, 1 month, or 3 months. Additionally, you can use the filter option in the
Association Time column to set a different time range other than the given options. The maximum
time range configured for the association history data is seven days.

Click the download icon to download the association history details as a .csv file.

Fetching details for the Avg. Speed, Total Data Used, and Avg. Signal Quality parameters might encounter a
delay of 2 to 3 minutes due to processing the messages in queue. These values are fetched from the stats
message and the details are received only if the session duration is more than 5 minutes. Sometimes, these
values are not available for 15 minutes if the Aruba Central On-Premises has not received the message from
the device.

Filtering Options:
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n The icon allows to filter a particular item in the column.
n The icon allows to sort the items of a column in ascending or descending order.

The following table describes the parameters displayed in Association History.

Column Description

Username Username of the client.

Role Role of the client.

Association Time Time stamp of when the client associated or roamed.

Disassociation
Time

Time stamp of when the client disassociated or roamed.

Session Duration Time duration of the connection.

Device Device to which the client was connected.

VLAN VLAN of the device to which the client was connected.

SSID SSID to which the client was connected.

LAN IP Address LAN IP address of the client.

Controller Name of the controller.

Avg. Speed Average speed of the data transferred.

Total Data Used Total data received and transmitted.

Avg. Signal
Quality

Average SNR in dB.

Connection
Mode

Mode of connection.

Client MAC
Address

MAC address.

Channel Width Channel width while establishing the connection.

Client OS OS of the client.

MAC Vendor MAC address of the vendor.

Cipher Encryption method.

Key
Management

Key management information.

Table 216: Association History

AI Insights
The AI Insight tab displays information about client performance and connectivity issues. AI Insights
are displayed for a selected time period based on the time selected in Time Range Filter. The user can
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select 3 hours, 1 week, 1 day, or 1 month to view the insight data. AI Insights are categorized in high,
medium, and low priorities depending on the number of occurrences.

n Red—High priority
n Orange—Medium priority
n Yellow—Low priority

Each insight report specific details on the occurrences of these events for ease in debugging. For more
information, see The AI Insights Dashboard

The client AI Insights page displays the following insights:

n Clients with High Wi-Fi Security Key-Exchange Failures
n Clients with High 802.1X Authentication Failures
n Clients with DHCP Server Connection Problems
n Clients with High Number of MAC Authentication Failures

Live Client Monitoring
Click Go Live to start live monitoring of the client. Live monitoring is supported only if the Instant AP is
running 8.4.0.0 firmware version. Live monitoring stops after 15 minutes. At any point, you can click
Stop Live to go back to the historical view.

Five seconds after you start live monitoring, the following data starts getting populated:

n Throughput
n Signal to Noise Ratio (SNR)

Live Health Bar
The Live Health Bar is present in the Summary page for a wireless client. It provides live data every 5
seconds for a session duration of 15 minutes.

To launch the Live Health Bar:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.

2. Under Manage, click Clients. The All Clients page is displayed.
3. By default, the Clients table displays a unified list of clients.
4. Click the client name to view the client details page. If there are many clients connected to the

network, click Wireless to filter the clients connected to the wireless network.
5. Enter the client name in the Client Name column and then click the client name.

The contextual dashboard for the selected client is displayed and opens the Summary page by
default.

6. Hover over the client name, the Health Bar pop-up appears. The pop-up displays the latest
values that is updated every 5 seconds.

The Live Health Bar session is for 15 minutes only, after that time period, the refresh icon
appears. If you click the refresh icon, the Live Health Bar session restarts where the values are
updated every 5 seconds.

7. Click the pin icon to pin the Health Bar to the Summary page for the constant view.

The parameters available in the Live Health Bar are:
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n Connection status icon
n Device Health
n Signal Quality
n Tx | Rx Rate
n Connected To

Disconnecting a Wireless Client from an AP
You can disconnect a wireless client using the following pages:

n List view
n Client Details

You can disconnect the wireless client from the AP only if the AP is in the online status.

Disconnecting a Client Using the List View
To disconnect a wireless client connected to an AP on the List view, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under groups, labels,
or sites. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.

2. Under Manage, click Clients.

The clients overview page is displayed in List view. By default, the Clients table displays a unified
list of clients.

3. Hover over the wireless client that you want to disconnect and click Disconnect From AP.

If there are many clients connected to the network, click Wireless to filter the clients connected
to the wireless network, enter the client name in the Client Name column, and click the client
name.

4. Click Yes in the dialog box.

The client is disconnected from the AP.

Disconnecting a Client using the Client Details Page
To disconnect a wireless client from an online AP:

1. In the Aruba Central On-Premises app, use the filter bar to select a group or a device.
2. Under Manage, click Clients. The clients overview page is displayed.
3. Click the list icon to view the client table.
4. By default, the Clients table displays a unified list of clients for the selected group.
5. Click the name of the wireless client to open the corresponding Client Details page. If there are

many clients connected to the network, click Wireless to filter the clients connected to the
wireless network, enter the client name in the Client Name column, and click the client name.

6. From the Actions drop-down list, click Disconnect from AP.
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The Actions drop-down is disabled if the AP is offline.

To disconnect a wireless client, ensure that there is an established Websocket connection from the controller
to Aruba Central.

Blocking a Wireless Client from an AP
To block a wireless client from an online AP:

1. In the Aruba Central On-Premises app, use the filter bar to select a group or a device.
2. Under Manage, click Clients. The clients overview page is displayed.
3. Click the list icon to view the clients table.
4. By default, the Clients table displays a unified list of clients for the selected group.
5. Click the name of the wireless client to open the corresponding Client Details page. If there are

many clients connected to the network, click Wireless to filter the clients connected to the
wireless network, enter the client name in the Client Name column, and click the client name.

6. From the Actions drop-down list, click Block Client.
The clients is unblocked from the network.

To remove a client from the blocked status, select the blocked client and click Remove Block from the Actions
drop-down list in the Client Details page.

Applications
The Application page consists of the Visibility , UCC and AirGroup tab.

Visibility
The Visibility dashboard provides a summary of client traffic and their data usage to and from
applications, and websites. You can also analyze the client traffic flow using the graphs displayed in the
Visibility dashboard. The tab consists of a list view and a graph view. The Visibility dashboard displays
metrics and graphs related to client traffic flow in the following sections:

n Applications
n Websites

For more information about enabling Application Visibility, list of supported Instant APs, and the data
displayed on the Applications and Websites sections, see Application Visibility.

UCC
The UCC tab displays the detailed call records for the client if any. To view this data, ensure that the
Unified Communication application service is enabled on the APs. The following table describes the
information displayed in each session:

Section Description

Calls Displays the total number of calls. The call quality is displayed as:

Table 217: UCC Tab
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Section Description

n Good
n Fair
n Poor
n Unknown

Client
Health

Displays the health of the client.

Session
Type

Displays the type of the call or session. For example, audio, or video, or desktop sharing.

Quality Displays the quality of the call.

Table 217: UCC Tab

AirGroup
The AirGroup displays the details of the servers a client is connected to. The following table describes
the information displayed in each session:

Section Description

Hostname Displays the host name.

MAC Address Displays the MAC address of the server the client is connected to.

IP Address Displays the IP address.

Role Displays the user role assigned to the client.

Service Displays the type of service.

VLAN Displays the connected VLAN details.

Connected
To

Displays the network the client is connected to. Name of the AP that broadcasts the SSID to
which the client is connected.

Table 218: AirGroup Tab

Events
In the Events page, the table displays the following columns by default: Occurred On, Event Type, and
Description. Click the ellipsis icon to perform additional operations:

n Autofit columns—Adjusts the column width of the table to fit the page evenly.
n Reset to default—Resets the table view to the default columns.

If a filter icon appears next to the column header, click it and enter the filter criteria or select a filter
criteria. The following table describes the information displayed in each event:
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Section Description

Occurred On Displays the time at which the event occurred.

Device
Hostname

Displays the host name of the device, Access Point, Controllers, Switch. Use the filter option to
filter events by hostname.

Event Type Displays the type of the event.

Description Displays the detailed description of the event.

Device MAC Displays the MAC address of the device.

BSSID Displays the BSSID.

Table 219: Events Tab

To download events into a CSV format, click the download button. Aruba Central generates the CSV
report of all the events for the selected client.

You can also filter the events based on the type of events, click the Click here for Advance Filtering.
Select the type of events from the list and click Filter. The events under the selected categories get
listed in the Events table.

Wired Client Details
The wired client overview page displays the client summary details, applications, and events details for
the selected client.

This section includes the following topics:

n Viewing Clients Connected to Wired Networks
n Overview
n Applications
n Events
n Tools

To experience improved monitoring updates performance for clients connected to AOS-CX switches, the
recommended AOS-CX firmware version is 10.09.0130 or later, or 10.10.0001 or later.

Viewing Clients Connected to Wired Networks
To view the details of a client connected to the wired network:

1. In the Aruba Central On-Premises app, use the filter bar to select a group or a device.
2. Under Manage, click Clients. The clients overview page is displayed.
3. Click the list icon to view the clients table.
4. By default, the Clients table displays a unified list of clients for the selected group.
5. Click the name of the wired client to open the corresponding Client Details page. If there are

many clients connected to the network, click Wired to filter the clients connected to the wired
network, enter the client name in the Client Name column, and click the client name.
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Wired Client Details
The wired client details page displays the client details summary and the client sessions information.

Summary
The client summary page displays the following information:

Wired Client Health Bar

Field Description

Connection
status icon

Displays the icons with the connection status of the client. Connection status is updated
immediately on state change. The available statuses are:
n Connecting—Displays a list of client connections that are in progress.
n Connected—Displays a list of clients that are successfully connected to the network.
n Failed—Displays a list of all failed client connections.
n Offline—Displays a list of all offline clients.
n Blocked—Displays a list of all blocked clients.

Connected
Port

Name of the port through which the is connected.

Connected To Name of the controller to which the client is connected. Click the name of the controller to
view the device details page.

Refresh icon Refreshes the data on the Health Bar for the wired client.

Table 220: Wired Client Health Bar

Overview
The Overview tab consists of the following sections.

Section Description

Data Path Displays the data path of the client in the network. Click the device icon to view the
corresponding device details page. The data path can be one of the following:
n Client > Wired Profile > AP
n Client > Wired Profile > AP > Switch
n Client > Wired Profile > AP > Switch > Controller
n Client > Wired Profile > AP > Controller
n Client > Switch
n Client > Switch > Controller
n Client > Controller

Client Displays the following information:
n Username—User name of the client.
n Hostname—Hostname of the client.
n Client Type—Type of the client device.
n IP Address—IP address of the client.

n MAC Address—MAC address of the client.
n Client OS—Operating system running on the client device.

Table 221: Overview Tab
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Section Description

n Connected Since—Date and time since when the client is connected.
n Manufacturer—Manufacturer of the client device.

Network Displays the following information:
n VLAN—VLAN ID on which the client is connected to the AP.
n Role—Controller role associated to the client.

Table 221: Overview Tab

Applications
To view application usage metrics for the client connected to the wired network, enable Deep Packet
Inspection.

The Applications tab consists of two sections:

n Applications—Displays a table with details on the client traffic flow to and from various applications.
Click the bar graph icon to view bar graphs indicating the traffic flow.

n Websites—Displays a table with details on client traffic flow and their data usage by various
websites. Click the bar graph icon to view bar graphs indicating the data usage by various websites.

For more information about enabling Application Visibility, list of supported Instant APs, and the data
displayed on the Applications and Websites sections, see Application Visibility.

UCC
The UCC tab displays the detailed call records for the client if any. To view this data, ensure that the
Unified Communication application service is enabled on the APs. The following table describes the
information displayed in each session:

Section Description

Calls Displays the total number of calls. The call quality is displayed as:
n Good
n Fair
n Poor
n Unknown

Client
Health

Displays the health of the client.

Session
Type

Displays the type of the call or session. For example, audio, or video, or desktop sharing.

Quality Displays the quality of the call.

Table 222: UCC Tab

AirGroup
The AirGroup displays the details of the servers a client is connected to. The following table describes
the information displayed in each session:
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Section Description

Hostname Displays the host name.

MAC Address Displays the MAC address of the server the client is connected to.

IP Address Displays the IP address.

Role Displays the user role assigned to the client.

Service Displays the type of service.

VLAN Displays the connected VLAN details.

Connected
To

Displays the network the client is connected to. Name of the AP that broadcasts the SSID to
which the client is connected.

Table 223: AirGroup Tab

Events
The Events page displays the details of events generated by the AP and client association. By default,
the table displays the following columns: Occurred On, Event Type, and Description. Click the ellipsis
icon to perform additional operations:

n Autofit columns—Adjusts the column width of the table to fit the page evenly.
n Reset to default—Resets the table view to the default columns.

If a filter icon appears next to the column header, click it and enter the filter criteria or select a filter
criteria. The following table describes the information displayed in each event.

Section Description

Occurred On Displays the time at which the event occurred.

Event Type Displays the type of the event.

Description Displays the detailed description of the event.

Device MAC Displays the MAC address of the device.

BSSID Displays the BSSID.

Table 224: Events Tab

To download events into a CSV format, click the download button. Aruba Central On-Premises
generates the CSV report of all the events for the selected client.

Tools
The Tools page is automatically filtered based on the client you select. This enables network
administrators to perform checks on the client and debug client connectivity issues. For more
information, see Using Troubleshooting Tools.
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Remote Client Details
The remote clients are clients that are connected to the network through VPN. The in-house wireless
and wired clients can also be authenticated using the VPN (VIA). The overview page displays the client
summary details, applications, and events for the selected remote client.

This section includes the following topics:

n Viewing Remote Clients Connected through VPN
n Summary
n Overview
n Remote Client Details
n Events

Viewing Remote Clients Connected through VPN
To view the details of a remote client:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global. The dashboard context for the selected
filter is displayed.

2. Under Manage, click Clients. The All Clients page is displayed.
3. By default, the Clients table displays a unified list of clients for the selected group, label, site or

device.
4. Click the name of the remote client to open the corresponding Client Details page. If there are

many clients connected to the network, click Remote to filter the clients connected to the
network.

5. Enter the client name in the Client Name column, and click the client name. The client Summary
page is displayed.

6. Click the required tab name to navigate and view the details.

Summary
The client summary page displays the following information.

Health Bar

Field Description

Connection status icon Displays the icons with the connection status of the client. Connection status is
updated immediately on state change. The available statuses are:
n Connecting—Displays a list of client connections that are in progress.
n Connected—Displays a list of clients that are successfully connected to the

network.
n Failed—Displays a list of all failed client connections.
n Offline—Displays a list of all offline clients.
n Blocked—Displays a list of all blocked clients.

Connected To Displays the name of the AP that broadcasts the SSID to which the client is
connected. Click the name of the AP to view the device details page.

Table 225: Health Bar
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Overview
The Overview tab displays information about the type of data path that the client uses, the network
and connectivity details, and basic client details such as IP address of the client, type of encryption etc.
The following table describes the information displayed in each section:

Section Description

Data Path Displays the data path of the client in the network. Click the controller to view the
details page. The data path can be Client > Tunnel > Controller

Client Displays the following information:
n Username—User name of the client.
n Hostname—Hostname of the client.
n Client Type—Type of the client device.
n Local IP Address—Link local IP address of the client.
n IP Address—IP address of the client.
n MAC Address—MAC address of the client.
n Client OS—Operating system running on the client device.
n Connected Since—Date and time since when the client is connected.

Network Displays the following information:
n Controller Role—Displays the role assigned to the client.

n Authentication Type—Displays the authentication method as VIA VPN.

Throughput Displays the incoming and outgoing throughput traffic for the client during a specific
time range. By default, the graph on the Throughput pane is plotted for a time
range of 3 hours. To view the graph for a different time range, click the Time Range
Filter link. You can choose to view the graph for a time period of 3 hours, 1 day, 1
week, 1 month, or 3 months.

Table 226: Remote Client Details

AI Insights
The AI Insight tab displays information about client performance and connectivity issues. AI Insights
are displayed for a selected time period based on the time selected in Time Range Filter. The user can
select 3 hours, 1 week, 1 day, or 1 month to view the insight data. AI Insights are categorized in high,
medium, and low priorities depending on the number of occurrences.

n Red—High priority
n Orange—Medium priority
n Yellow—Low priority

Each insight report specific details on the occurrences of these events for ease in debugging. For more
information, see The AI Insights Dashboard

The client AI Insights page displays the following insights:

n Clients with High Wi-Fi Security Key-Exchange Failures
n Clients with High 802.1X Authentication Failures
n Clients with DHCP Server Connection Problems
n Clients with High Number of MAC Authentication Failures
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Applications
The Application page consists of the Visibility , UCC and AirGroup tab.

Visibility
The Visibility dashboard provides a summary of client traffic and their data usage to and from
applications, and websites. You can also analyze the client traffic flow using the graphs displayed in the
Visibility dashboard. The tab consists of a list view and a graph view. The Visibility dashboard displays
metrics and graphs related to client traffic flow in the following sections:

n Applications
n Websites

For more information about enabling Application Visibility, list of supported Instant APs, and the data
displayed on the Applications and Websites sections, see Application Visibility.

Sessions
The client sessions page consists of the firewall session details for the client connected to a Branch
Gateway. The Sessions page displays information filtered by the IP address of the client. The Sessions
Summary pane displays the device the client is connected to, total number of sessions, and the time
stamp of when the page was last refreshed. The sessions details page refreshes automatically, to
refresh the page manually, click the refresh icon after the timestamp.

The Sessions table lists the details of each session. By default, the table displays the following columns:
Application, Destination IP, Protocol, , Dest Port, DSCP, Flags, Packets, State and Action.

Click the ellipsis icon to perform additional operations:

n Autofit columns—Adjusts the column width of the table to fit the page evenly.
n Reset to default—Resets the table view to the default columns.

If a filter icon appears next to the column header, click it and enter the filter criteria or select a filter
criteria. The following table describes the information displayed in each session:

Section Description

Application Displays the list of applications.

Source IP Displays the source IP address.

Destination IP Displays the destination IP address.

Protocol Displays the communication protocol used.

Source Port Displays the source port number.

Dest Port Displays the destination port number.

DSCP Displays the DSCP value.

Flags Displays the active flags

Table 227: Sessions Tab
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Section Description

Packets Displays the number of packets.

Bytes Displays the total number of bytes.

State Displays the connection state of the application. The state can either be
Denied, Active, or Inactive.

Action Displays the application specific action.

VLAN Displays the VLAN the client is connected to.

Start Time Displays the start time.

Receive Time Displays the receive time.

WebCC Category Displays the WebCC category.

WebCC Reputation Displays the WebCC reputation.

WebCC Score Displays the WebCC score.

Application Category Displays the application category.

Priority Displays the priority value.

Table 227: Sessions Tab

Events
In the Events page, the table displays the following columns by default: Occurred On, Event Type, and
Description. Click the ellipsis icon to perform additional operations:

n Autofit columns—Adjusts the column width of the table to fit the page evenly.
n Reset to default—Resets the table view to the default columns.

If a filter icon appears next to the column header, click it and enter the filter criteria or select a filter
criteria. The following table describes the information displayed in each event:

Section Description

Occurred On Displays the time at which the event occurred.

Event Type Displays the type of the event.

Description Displays the detailed description of the event.

Device MAC Displays the MAC address of the device.

BSSID Displays the BSSID.

Table 228: Events Tab

To download events into a CSV format, click the download button. Aruba Central generates the CSV
report of all the events for the selected client.
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You can also filter the events based on the type of events, click the Click here for Advance Filtering.
Select the type of events from the list and click Filter. The events under the selected categories get
listed in the Events table.

Client Live Events
Aruba Central On-Premises allows you to troubleshoot issue related to client at both client device level
and site level in real time for detailed analysis. Live troubleshooting is supported only if the wireless
client is connected to the access point running Aruba Instant 8.4.0.0 or a later version. You can also
enable packet capture during live troubleshooting and download the PCAP file if the access point is
running Aruba Instant 8.6.0.5 or a later version.

The live troubleshooting can only be performed at a site level or for a specific client.

Live Events are supported only on Instant APs.

Troubleshooting a Client
To troubleshoot a client at a site level, perform the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Sites that
contains at least one device.

The dashboard context for the selected site is displayed.

2. Under Analyze, click Live Events.

The Live Events page is displayed.

3. Enter the MAC address of the client and click Start Troubleshooting.

To troubleshoot a wireless or wired client, perform the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.

2. Under Manage, click Clients.

The clients overview page is displayed in List view.

3. By default, the Clients table displays a unified list of clients.
4. Click the name of the wireless or wired client to open the corresponding Client Details page. If

there are many clients connected to the network, click Wireless or Wired to filter the clients
connected to the wireless or wired client respectively.

5. Enter the client name in the Client Name column, and then click the client name.
6. Under Analyze, click Live Events.

The Live Events page is displayed.

The client live troubleshooting starts automatically for the selected client.

The status of the troubleshooting is displayed every minute. The troubleshooting session runs for a
duration of 15 minutes. You can stop live troubleshooting at any point by clicking Stop
Troubleshooting and to go back to the historical view.

After the live troubleshooting session ends, the details of the events are displayed in the live events
table.
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Live Events Details
The following details are captured and displayed in the Live Events table:

n Occurred On—Displays the timestamp of the event. Use the filter option to filter the events by date
and time.

n Device Name—Displays the name of the device the client is connected to. Set the filter to select a
specific device under Site.

n Device Type—Displays the type of device the client is connected to.
n Category—Displays the category of the event. Use the filter option to filter the events by category.
n Description—Displays a description of the event. Use the filter option to filter the events based on

description.

You can download the list of live events to a CSV file for offline analysis. To download live events, click
the Download CSV icon on the Live Events table.

Packet Capture
Aruba Central On-Premises allows you to interact and launch a targeted packet capture on a client
connected to a specific access point. Users with read-write and admin role can use live packet capture
for troubleshooting devices. After you start packet capture from the UI, Aruba Central notifies the
access point and the switch. The default packet capture duration is 15 minutes. After you start packet
capture, use the toggle button to stop packet capture, or go back to the Client Overview page.

Starting Packet Capture
You can start packet capture from the wireless or wired clients page. Packet capture can be done at a
site level (wireless client only) or for a selected client.

At a site level, Aruba Central On-Premises does not support Packet Capture in the following scenarios:

n For a wired client connected to a switch.

n If there are more than 25 APs in a site.

To start packet capture at a site level, perform the following steps:

1. In the Aruba Central On-Premises app, set the filter to a Site that contains at least one device.
The dashboard context for the selected site is displayed.

2. Under Analyze, click Live Events.The Live Events page is displayed.
3. Enter the MAC address of the client.
4. Enable the Packet Capture toggle button to start live packet capture for the selected client.
5. Click Start Troubleshooting.

To start packet capture for a wireless or wired client, perform the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.

2. Under Manage, click Clients. The clients overview page is displayed in List view.
3. By default, the Clients table displays a unified list of clients.
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4. Click the name of the wireless or wired client to open the corresponding Client Details page. If
there are many clients connected to the network, click Wireless or Wired to filter the clients
connected to the wireless or wired client respectively.

5. Enter the client name in the Client Name column, and click the client name.
6. Under Analyze, click Live Events. The Live Events page is displayed. The client live

troubleshooting starts automatically for the selected client.
7. Click Stop Troubleshooting to stop live troubleshooting.
8. Enable the Packet Capture toggle button to start live packet capture for the selected client.
9. Click Start Troubleshooting to live troubleshoot the selected client. Live packet capture starts for

the selected client.

The live troubleshooting session runs for a duration of 15 minutes. After the live troubleshooting
session ends, a Download PCAP text appears above the live events table. Click Download
PCAP to download the generated pcap file on your local system.

Packet capture can only be enabled or disabled before live troubleshooting is started. You cannot enable or
disable packet capture while a live troubleshooting session is in progress.

Packet capture is not supported in single node deployments.

Failed Wireless Client Events or Reasons
The Clients page provides a summary view of all the clients connected to the network. You can filter
clients based on the network the clients are connected to. The page displays key client information and
also allows you to view a specific client detail page.

By default, the Clients page displays a unified list of clients for the selected group. The list of clients is
populated for a time range of 3 hours. To view the list of clients for a different time range, click the Time
Range Filter link and select the required time period. Total data usage for the selected time period is
displayed above the client summary bar.

To filter clients based on the device to which the clients are connected, select the device type from the
Clients drop-down list:

n Unified—Displays a unified list of clients connected to the network.
n AP—Displays a list of clients connected to the Instant AP.
n Switch—Displays a list of clients connected to the switch.
n Controller—Displays a list of clients connected to the Aruba Controller.

The wired client will show up in the Unified Clients page only if the client is connected to an Aruba 2540 Series,
Aruba 2920 Series, Aruba 2930F Series, Aruba 2930M Series, Aruba 3810 Series, or Aruba 5400R Series switch.

To view failed clients and the reason for their failure, complete the following steps:

1. In the Aruba Central On-Premises app, use the filter bar to select a group, label, site, or a
device.

2. Under Manage, click Clients. The All Clients overview page is displayed.
3. Click Failed from the clients summary bar to view a list of all the failed clients.
4. Hover over the status of a particular client to view the following information. This information is

provided by the AI Insights feature based on algorithms and smart analytics:
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n Last seen - Date and time at which the client was last seen
n Failure Stage - Failure status of the client that failed to connect. The failure reasons could be:

o Association error
o MAC authentication error
o 802.1X authentication error
o Key exchange error
o DHCP error
o Captive Portal error

n Failure Reason - Based on the failure stage, failure reason is populated. For example, if it is a
802.1X authentication error, the reason for the failure could be Authentication Server
Timeout.

5. You can also view if any AI Insight is associated with the failed client by clicking on the number
under the AI Insights column. This will lead to Insights page.

Client Events
Aruba Central On-Premises allows you to troubleshoot issues related to a wired or wireless clients
connected to APs. The Events tab at the client context provides a capability to filter events further to
identity a specific issue and troubleshoot it. It provides an aggregate view of events based on its severity
level categorized under Negative, Positive, or Neutral

Events
To access the client event information connected to an IAP, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.

2. Under Manage, click Clients. The clients overview page is displayed in List view.
3. By default, the Clients table displays a unified list of clients.
4. Click the name of the wireless or wired client to open the corresponding Client Details page. If

there are many clients connected to the network, click Wireless or Wired.
5. Enter the client name in the Client Name column, and click the client name.
6. Under Analyze, click Events.

By default the Events tab is selected and the Events table is displayed with the list of events
specific to the selected client. The Events tab categorizes the events as Negative, Positive, or
Neutral.

Filtering Events in the List View
Aruba Central allows you to filter the events based on the event types. Perform the following steps to
filter events based on event types in the List view:
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1. In the Events page, click Click here for advanced filtering to filter the events based on event
types.

2. Select the event type and click Filter. You can select multiple event types from the advanced
filtering option.

3. The events table displays the list of events generated in each event type. The filter summary bar
displays the total number of events in the selected category and the type(s) of events.

4. Optionally, to clear advanced filtering option, from the events summary bar, click Clear All.

The following table describes the information displayed in each column of the Events table:

Data Pane
Content Description

Occurred On Displays the timestamp of the event. Use the sort option to
sort the events by date and time. Use the filter option to
select a specific time range to display the events.

Device
Hostname

Displays the host name of the device where the event is
generated. Use the filter option to filter events by hostname.

Device MAC Displays the MAC address of the device. Use the filter option
to filter events by device MAC address.

BSSID Displays the BSSID of the device. Use the filter option to filter
events by the BSSID.

Event Type Displays the type of the event along with the severity level
represented by an icon for each event type.

Description Displays the description of the event. Use the column filter to
perform a free search and filter an event based on the
description. You can type a search phrase including client
MAC, reason code, or BSSID and filter the events.

Table 229: Events Pane

The event columns allows free text search at all column levels to enhance filtration.

Additionally, it displays an event frequency bar which shows the time range of the events that occurred.
This allows you to view the actual time of the failure, which helps in troubleshooting the issue. Drag and
select a specific range to filter events occurred in that time range. Hover over each bar to see the
proportion of negative, positive and neutral events distributed in a specific time range. The distribution
changes based on the time range selected in the Time Range Filter ( ).
To clear any time range selected on the frequency bar, click Clear.

Filtering Events in the Summary View
Aruba Central allows you view different event types for the selected client distributed across the time
line. You can filter the events based on the event types and drill down further to diagnose client's
health. It gives a deep insight on the failure events that occur in the network.

Select the Summary view icon to display the list of events. The graphs in the Summary view displays
the events in the following categories:
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n Events by severity—Displays the event severity categorized under Negative, Positive, or Neutral.
Click each tab to drill down to each category. The frequency bar and the event type chart changes
accordingly and displays events based on the selected tab.
o Events Frequency Bar—Displays the time range of the events that occurred. This allows you to

view the actual time of the failure, which helps in troubleshooting the issue. Drag and select a
specific range to filter events occurred in that time range. Hover over each bar to see the
proportion of negative, positive and neutral events distributed in a specific time range. The
distribution changes based on the time range selected in the Time Range Filter ( ). To clear any
time range selected on the frequency bar, click Clear.

n Events per type—Displays the different event types categorized based on severity and color codes as
following:
o Red—Indicates negative severity
o Green—Indicates positive severity
o Grey—Indicates neutral severity

This Events per type section has the following capabilities:
o Click on the event type to open a new pane which displays details regarding that event type. It

shows the time range when the specific event occurred, the APs that were impacted, and a
pictorial pie chart of the reason codes for that failure event. Hover your mouse to see the
different reason codes differentiated with color codes. Clicking on the reason codes redirects you
to the events list with appropriate reason selected.
The new pane provides advanced links to troubleshoot at the device level:
l Click on the AP name or the bar to navigate to the AP details page for that particular event. On

the AP details page, you can click the Events tab to see the event details.
l Click on the number displayed against each bar to navigate to AP events page along with the

filter for the selected client and the event type. The number displayed against each bar is the
frequency of the selected event occurred on that particular AP.

o Click on the number displayed against each event type bar to go back to the event list view for
that particular event. You can see the list of all the events with details within the selected time
range. In this case all the details is pre-selected for the user.

The components of the Events summary page is displayed for a selected time period based on the time

selected in the Time Range Filter ( ). You can select one of the following: 3 Hours, 1 Week, 1 Day, or 1
Month.

Supported Client Events for Campus AP and Instant AP Devices
Aruba Central On-Premises provides an Events dashboard for viewing the events triggered from
Campus Access Point (CAP) and Instant Access Point (IAP) devices.

The following table lists the client events that are supported for IAP and CAP in Aruba Central On-
Premises:
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Event Description Campus AP Instant AP

Client 802.11
Association Reject

802.11 Association rejected for client [Client MAC]
to BSSID [BSSID] on channel [Channel] of AP
hostname [Device Hostname].

Supported Supported

Client 802.11
Disassociation to Client

802.11 Disassociation sent to client [Client MAC]
from BSSID [BSSID] on channel [Channel] of AP
hostname [Device Hostname].

Supported Supported

Client 802.11
Disassociation from
Client

802.11 Disassociation received from client [Client
MAC] associated to BSSID [BSSID] on channel
[Channel] of AP hostname [Device Hostname].

Supported Supported

Client 802.11
Authentication Failure

802.11 Authentication failed for client [Client MAC]
on BSSID [BSSID] on channel [Channel] of AP
hostname [Device Hostname].

Supported Supported

Client 802.11 De-
authentication to Client

De-authentication sent to client [Client MAC] from
BSSID [BSSID] on channel [Channel] of AP
hostname [Device Hostname].

Supported Supported

Client 802.11 De-
authentication from
Client

De-authentication sent from client [Client MAC]
associated to BSSID [BSSID] on channel [Channel]
of AP hostname [Device Hostname].

Supported Supported

Client Roaming Success Client [Client MAC] associated to BSSID [From
BSSID (roamed from)] on channel [From Channel
(roamed from)] of AP hostname [From Device
Hostname (roamed from)] roamed successfully to
BSSID [BSSID] on channel [Channel] of AP
hostname [Device Hostname].

Supported Supported

Client MAC
Authentication Reject

MAC Authentication failed for client [Client MAC]
to Radius Server [Radius Server IP] through BSSID
[BSSID] on channel [Channel] of AP hostname
[Device Hostname].

Supported Supported

Client 802.1x Radius
Reject

802.1x Radius Reject received for client [Client
MAC] on BSSID [BSSID] on channel [Channel] of AP
hostname [Device Hostname].

Supported Supported

Client 802.1x Radius
Timeout

802.1x Radius Timeout occurred for client [Client
MAC] on BSSID [BSSID] on channel [Channel] of AP
hostname [Device Hostname].

Supported Supported

Client Captive Portal
Authentication Failure

Captive Portal failure occurred for client [Client
MAC] associated to BSSID [BSSID] of AP hostname
[Device Hostname].

Supported Supported

Client EAP Failure EAP failure occurred for client [Client MAC]
associated to BSSID [BSSID] on channel [Channel]
of AP hostname [Device Hostname].

Supported Supported

Client EAP Timeout from
Client

EAP response from client [Client MAC] associated
to BSSID [BSSID] on channel [Channel] of AP
hostname [Device Hostname] timed out.

Not
Supported

Supported

Table 230: Client Events
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Event Description Campus AP Instant AP

Client VoIP Call Start VoIP call initiated from station [Source Client
Name] ([Source Client IP]) to station [Destination
Client Name] ([Destination Client IP]) on AP
hostname [Device Hostname].

Not
Supported

Supported

Client VoIP Call Stop VoIP call terminated from station [Source Client
Name] ([Source Client IP]) to station [Destination
Client Name] ([Destination Client IP]) on AP
hostname [Device Hostname].

Not
Supported

Supported

Client DHCP
Acknowledged

DHCP acknowledgment received from DHCP
server [DHCP Server IP] for client [Client MAC]
([Client IP]) associated to BSSID [BSSID] on channel
[Channel] of AP hostname [Device Hostname].

Supported Supported

Client DHCP Not
Acknowledged

DHCP NACK to DHCP server [DHCP Server IP] from
client [Client MAC] ([Client IP]) associated to BSSID
[BSSID] on channel [Channel] of AP hostname
[Device Hostname].

Supported Supported

Client DHCP Declined DHCP declined from DHCP server [DHCP Server IP]
for client [Client MAC] ([Client IP]) associated to
BSSID [BSSID] on channel [Channel] of AP
hostname [Device Hostname].

Supported Supported

Client DNS Failure DNS failure to [Domain Name] detected for client
[BSSID] on BSSID [BSSID] of AP hostname [Device
Hostname].

Not
Supported

Supported

Client DHCP Timeout DHCP request to DHCP server [DHCP Server IP]
from client [Client MAC] timed out.

Supported Supported

Client Blacklisted Blacklisted client [Client MAC] on AP hostname
[Device Hostname] for SSID [SSID name].

Not
Supported

Supported

Client Fast Roaming
Failure

Fast Roaming failed for client [Client MAC] with
roaming type [Roaming Type] on AP hostname
[Device Hostname].

Not
Supported

Supported

Client Roaming Success Client [Client MAC] roamed successfully to SSID
[SSID name] on channel [Channel] of AP hostname
[Device Hostname].

Not
Supported

Supported

Client Match Steer
Attempt

Client match attempted a [Steer Type] using [Steer
Mode] for client [Client MAC] from radio BSSID
[From BSSID] to radio BSSID [To BSSID] with result:
[Steer Result].

Not
Supported

Supported

Client Match Steer
Reject

Client match attempted a [Steer Type] using [Steer
Mode] for client [Client MAC] from radio BSSID
[From BSSID] to radio BSSID [To BSSID] which was
rejected by the client with reason code [802.11v
Move Result].

Not
Supported

Supported
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Event Description Campus AP Instant AP

Client Match Steer
Wrong Destination

Client match attempted a [Steer Type] using [Steer
Mode] for client [Client MAC] from radio BSSID
[From BSSID] to radio BSSID [To BSSID] which
resulted in the client moving to a different radio
BSSID [Destination Radio BSSID].

Not
Supported

Supported

Client Match Success Client match attempted a [Steer Type] using [Steer
Mode] for client [Client MAC] from radio BSSID
[From BSSID] to radio BSSID [To BSSID] with result:
Success info : <11v reason if any > and steer
reason [Sticky Client, Dynamic load balancing,
capability mismatch, channel steering, band
steering ]

Supported Not
Supported

Client Match Steer
Uncontrolled Moves

Client match attempted a [Steer Type] using [Steer
Mode] for client [Client MAC] from radio BSSID
[Client MAC] to radio BSSID [To BSSID] with result:
Move result info : <11v reason if any > and steer
reason [Sticky Client , Dynamic load balancing,
capability mismatch, channel steering, band
steering ]

Supported Not
Supported

Client Match Steer No
Move

Client match attempted a [Steer Type] using [Steer
Mode] for client [Client MAC] from radio BSSID
[Client MAC] to radio BSSID [To BSSID] with result:
Move result info : <11v reason if any > and steer
reason [Sticky Client, Dynamic load balancing,
capability mismatch, channel steering, band
steering ]

Supported Not
Supported

Client Authentication
Server Timeout

Authentication request to a Radius server [Radius
Server IP] from a client [Client MAC] timed out.

Supported Not
Supported

Client Accounting
Server Timeout

Accounting request to a Radius server [Radius
Server IP] from a client [Client MAC] timed out.

Supported Not
Supported

Radius-COA Failure Timestamp: Radius COA failure received from <
Server IP> for a <Client MAC> associated to <BSSID
MAC/SSID> on <Radio Index:Channel> of <AP
Hostname>
Reason Code : <Description>

Supported Not
Supported

Viewing Applications Monitored by AirSlice
To view the applications monitored by AirSlice, ensure to enable AirSlice. For more information, see
Enabling AirSlice on APs.

To view the applications monitored by AirSlice, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to one of the options under Groups,
Labels, or Sites. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.

2. Under Manage, click Clients. The Clients page is displayed in List view.

By default, the Clients table displays a list of all clients.

3. Click a client listed under Client Name.

The dashboard context for the client is displayed.
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4. Click Applications.

The Visibility > Applications page is displayed in List view. The Applications table provides the
following information:
n Application—Name of the application.
n Category—Category to which the application belongs. The application can belong to any of

the categories. For example, Unclassified, Standard, Social Networking, Streaming, Web, Cloud
File Storage, Instant Messaging, and so on.

n Usage—The usage size by the respective application.
n Sent—The size of data sent from the application.
n Received—The size of data received by the application.

In the Visibility > Applications page, under the Application column, indicates that the applications
are prioritized by AirSlice.

5. Click an application listed under Application. The following information along with the graph of
minimum, maximum, and average values are displayed:
n Usage
n Loss
n Latency
n Jitter

The above information is available only in the client dashboard.

The Usage, Loss, Latency, and Jitter data is available only for applications that are prioritized by
AirSlice.

The Usage, Loss, Latency, and Jitter data are displayed only for the following applications:

n Zoom
n Slack
n Skype
n WebEx
n GoToMeeting Online Meeting
n Microsoft Office 365
n Dropbox
n Amazon Web Services/Cloudfront CDN
n GitHub
n Microsoft Teams
n ALG Wi-fi Calling
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Figure 143 AirSlice—Applications



Chapter 19

Application Visibility

Application Visibility

The Manage > Applications tab provides detailed information on data usage by the clients connected
to APs and controllers in the network. Clicking the Applications tab displays a Visibility dashboard that
provides a summary of client traffic and their data usage to and from applications, and websites. You
can also analyze the client traffic flow using the graphs displayed in the Visibility dashboard.

To view the graphs on the Visibility pane, ensure that the Application Visibility service is enabled. For
more information, see the following sections:

n Enabling Application Visibility on Instant APs on page 476

n Enabling Application Visibility on Campus APs

Viewing Visibility Dashboard
To view the Visibility dashboard, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
a. To navigate to the applications tab for a site, set the filter to one of the options under Sites.

For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.

b. To navigate to the applications tab for a client, set the filter to one of the options under
Groups. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.
n Under Manage, click Clients.

A list of all connected clients is displayed in the List view.
n Select any one of the connected clients from the list.

2. Under Manage, click Applications. The visibility dashboard is displayed.

n The applications data for a client is available only for a month. When you select 3 months option on the
time range filter, the client data is displayed only for one month.

n For application visibility at the site level, controllers running 8.6.0.17_83573, 8.7.1.9_83631, and 8.10.0.1_
84079 versions and above are supported.

The Visibility dashboard displays metrics and graphs related to client traffic flow in the following
sections:

n Applications
n Websites
n Blocked Traffic
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n To view the client traffic details, ensure that the DPI access rules are enabled on the AP device. For more
information, see Aruba Central Help Center.

n The Blocked Traffic tab is only displayed in Global level.
n Application Visibility data is updated every 0th minute of every hour. The data population on the

Applications > Visibility dashboard may be delayed by an hour when compared to the Application
Visibility data displayed in the Applications pages for the Group, Global, and APs.

Graph View in Visibility Dashboard
Click the Summary icon in the Visibility dashboard to view both the applications and websites
graphical information:

n Applications
o Applications—The stacked bar graph and the pie chart in this tab displays details of the client

traffic flowing to or from the top five classified applications listed in the Applications table. The
legend below the graphs displays the list of applications to which the traffic flow is detected.
Select or deselect the application check box to show or hide the traffic flow data from the pie
chart and stacked bar. By hovering the mouse on pie chart and stacked bar, you can view the size
of data flowing to and from the application.

o Categories—The stacked bar graph in this tab displays details of the client traffic flowing to or
from the top five classified application categories listed in the Applications table. The legend
below the graphs displays the list of applications categories to which the traffic flow is detected.
Select or deselect the application category check box to show or hide the traffic flow data from
the pie chart and stacked bar. By hovering the mouse on pie chart and stacked bar, you can view
the size of data flowing to and from the application.

n Websites
o Reputations—The stacked bar graph and the pie chart in this tab displays details of client traffic

flow for the top three reputations listed in the Websites table. The legend displays the list of
websites based on its reputation, to which the traffic flow is detected. Select or deselect the
reputation check box to show or hide the data from the pie chart and stacked bar. By hovering
the mouse on pie chart and stacked bar, you can view the size of data flowing to and from each of
the websites that are categorized based on reputation.

o Web Categories—The stacked bar graph and the pie chart in this tab displays details of client
traffic flow for the top five web categories listed in the Websites table. Select or deselect the web
category check box to show or hide the data from the pie chart and stacked bar. You can view the
size of data flowing to and from each of the web categories by hovering the mouse on both the
stacked bar graph and pie chart. The legend below the graphs displays the list of websites based
on its reputation, to which the traffic flow is detected.

Related Topics:

n Application Visibility
n Websites
n Blocked Traffic
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Applications
The Applications tab includes a table view and a graph view related to the client traffic flow to and from
various applications. These graphs are displayed for a specific time frame (3 Hours, 1 Day, 1 Week, 1
Month, 3 Months). By default, the graphs display real-time client traffic data or usage trend in last three
hours.

Table View in Application Section
Click the List icon in the Applications tab to display a table with the following columns:

n Application—Displays the top N applications based on total bandwidth usage. Apart from the top N,
the rest of the applications are grouped under the Unclassified category. Click the sign next to the
service name to expand an application in List view. A graph is displayed with date and time on the x-
axis and usage on the y-axis. The graph displays the amount of data sent and received by the
application over a period of time. To get the data sent and data received information for a specific
day, hover over a point on the x-axis.
Search Options:
o The filter icon allows you to search a particular application by its name.
o The and sort icons allow you to sort the application in ascending or descending order.

n Category—The category to which the application belongs. The application can belong to any of the
categories, such as Unclassified, Standard, Social Networking, Streaming, Web, Cloud File
Storage, Instant Messaging Network Service and so on.
Search Options:
o The filter icon allows you to search a particular category by its name.
o The and sort icons allow you to sort the category in ascending or descending order.

n Usage—Data consumed by an application.
Search Options:
o The and sort icons allow you to sort the usage in ascending or descending order.
o Sent—The size of data sent from the application.
o Received—The size of data received by the application.

Graph View in Visibility Dashboard
To view the application section in summary view, see Graph View in Visibility Dashboard

Websites
The Websites tab includes a table view and a bar graph view related to the client traffic flow and their
data usage by various websites. These graphs are displayed for a specific time frame (3 Hours, 1 Day, 1
Week, 1 Month, 3 Months). By default, the graphs display real-time client traffic data or usage trend in
last three hours.

Table View in Websites Section
The Websites tab displays the following details:

n Reputation—The reputation of the application categories, for example, Trustworthy, Incomplete,
Moderate Risk, Low Risk, High Risk and so on. The reputations are set based on the risk levels
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exhibited by the application categories.
n Usage—The percentage of data usage by application categories based on their reputation.
n Category—The category of the client traffic that sends and receives data, for example, Unclassified,

Social Networking, Streaming, Web, Cloud File Storage, Instant Messaging and so on.
n Usage—The size and percentage of data usage by the corresponding categories.

Graph View in Websites Section
To view the application section in summary view, see Graph View in Visibility Dashboard.

Blocked Traffic
Based on the group selection from the Blocked Traffic drop-down list, the Blocked Traffic section of
the Application > Visibility > Blocked Traffic dashboard allows you to view the following information:

n Blocked devices of the selected group as CSV file.
n The number of user sessions that are blocked. This information is displayed under Blocked

Sessions.

The blocked traffic details are shown only for the APs on which the Application Visibility or DPI ACLs are
enabled. For more information, see Aruba Central Help Center.

Downloading Blocked Session Details
To download the blocked session details in the CSV format, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
The global dashboard is displayed.

2. Under Manage, click Applications. The visibility dashboard is displayed.
3. Click Blocked Traffic tab in the visibility dashboard.
4. To download the blocked sessions report, select the device group from the Select Group drop-

down. If the device group is already selected from the Groups drop-down on the filter bar, the
page displays the group name and the number of sessions blocked for the clients connected to
devices in that group.

5. Click Download CSV. Aruba Central generates the CSV report with data from the last 7 days.

The CSV file shows up to 50000 blocked sessions for a single AP cluster.
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Using Troubleshooting Tools

Using Troubleshooting Tools

In the Aruba Central On-Premises app, use the filter to select a group or a device and then, select
Tools menu option under Analyze. The Tools menu allows network administrators and users with
troubleshooting permission to perform troubleshooting or diagnostics tests on devices and networks
managed by Aruba Central. Users with admin role and custom roles that allow edit access to the
troubleshooting module can troubleshoot network and device issues. For more information on user
roles, see User Roles for Aruba Central On-Premises

n The Tools menu option is not visible to users who do not have troubleshooting permission.
n Aruba Central does not support performing diagnostic checks on offline devices.

The Tools page is divided into the following tabs:

n Network Check—Allows you to run diagnostic checks on networks and troubleshoot client
connectivity issues. You must have admin privileges or read-write privileges to perform network
checks.

n Device Check—Allows you to run diagnostic checks and troubleshoot switches. You must have
admin privileges or read-write privileges to perform device checks.

n Commands—Allows you to perform network health check on devices at an advanced level using
command categories. Read-only users can also perform advance checks.

Chapter 20

Troubleshooting Network Issues
Network check aims to identify, diagnose, and debug issues detected in an Aruba Central-managed
network. The Network Check tab on the Tools page captures the troubleshooting utilities that are used
to test a network entity and collect results based on your selection.

To perform a diagnostic check on the Aruba Central-managed network, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a group, label, site, or all devices in the filter, set the filter to one of the options under

Groups, Labels, or Sites. For all devices, set the filter to Global.The dashboard context for the
selected filter is displayed.

n To select a device in the filter:
a. Set the filter to Global.
b. Under Manage, click Devices, and then click Access Points, Switches, or Controllers.
c. A list of devices is displayed in the List view.
d. Click a device listed under Device Name.

The dashboard context for the device is displayed.
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2. Under Analyze > Tools, click the Network Check tab.

The Network Check page is displayed.

3. Select a device. You can run diagnostic checks on the following types of devices managed by
Aruba Central:
n Troubleshoot AP Connectivity Issues
n Troubleshooting Switch Connectivity Issues
n Troubleshooting Controller Connectivity Issues

The following table lists the tests available for each type of device.

Test Campus Access
Point

Instant Access
Point Switch Controller

Ping Test Not Available Available Available Available

Traceroute Not Available Available Available Available

HTTP Test Not Available Available Not
Available

Not Available

HTTPS Test Not Available Available Not
Available

Not Available

TCP Test Not Available Available Not
Available

Not Available

Speed Test
(iPerf)

Available Available Not
Available

Available

Ping Sweep
Test

Not Available Not Available Not
Available

Not Available

NSLOOKUP Available Available Not
Available

Not Available

Table 231: Tests and Devices

Devices which are already running commands shall not execute newly added commands.

This section includes the following topics:

n Troubleshoot AP Connectivity Issues
n Troubleshooting Switch Connectivity Issues
n Troubleshooting Controller Connectivity Issues

Troubleshoot AP Connectivity Issues
The following tests are available to diagnose issues pertaining to WLAN network connections:

n Troubleshooting AP Connectivity Issues by Ping Test

n Troubleshooting AP Connectivity Issues by Traceroute

n Troubleshooting AP Connectivity Issues by HTTP Test

../../../../../Content/trblshooting/AP-connect-test-issues/ping-test.htm
../../../../../Content/trblshooting/AP-connect-test-issues/traceroute.htm
../../../../../Content/trblshooting/AP-connect-test-issues/http.htm
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n Troubleshooting AP Connectivity Issues by TCP Test

n Troubleshooting AP Connectivity Issues by Speed Test (iPerf)

n Troubleshooting AP Connectivity Issues by NSLOOKUP

Troubleshooting CAP Connectivity Issues
To diagnose issues pertaining to network connections for Campus Access Points, you can use Speed
Test. Performs a speed test to measure network speed and bandwidth.

To perform a speed test, you must provide the iPerf server address, protocol type, and speed test
options such as bandwidth.

To execute a speed test on CAPs, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a group, label, site, or all devices in the filter, set the filter to one of the options under

Group, Label, or Site. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.

n To select a device in the filter:
a. Set the filter to Global.
b. Under Manage, click Devices > Access Points.

A list of access points is displayed in the List view.

c. Click an access point listed under Device Name for which you want to perform
diagnostic test.

The dashboard context for the access point is displayed.

2. Under Analyze > Tools, click Network Check.
3. From the Device Type drop-down list, select Access Point.
4. From the Test drop-down list, select Speed Test.
5. From the Sources drop-down list, select source(s). You can select multiple APs.

While performing troubleshooting on APs, a maximum of 20 APs are listed in the drop-down list. If
there are more than 20 APs, use the Search option to search for an AP on which you would like to
perform diagnostic checks.
If you navigate from the device details page, the Tools page appears, where the device context is
already set and the Source field is automatically populated based on your selection.

6. In the Host field, enter a valid hostname.
7. From the Protocol drop-down list, select the protocol. The available options are TCP or UDP.
8. To use additional parameters, click Show Additional Test Settings, and in the Options field,

enter an option. For example, bandwidth.

Show Additional Test Settings is not displayed when a Test type is not selected.

9. Click Run.

The test output is displayed in the Device Output section.

For Campus AP only Speed Test is available to diagnose the connectivity issues.

../../../../../Content/trblshooting/AP-connect-test-issues/tcp.htm
../../../../../Content/trblshooting/AP-connect-test-issues/speedtest.htm
../../../../../Content/trblshooting/AP-connect-test-issues/nslookup.htm
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For information about viewing and downloading the output, see Viewing the Device Output.

Troubleshooting Switch Connectivity Issues
The following tests are available to diagnose issues related to wired network connections:

Ping Test
Sends ICMP echo packets to the IP address of the selected switch to check for latency issues.

To perform a ping test on switches, complete the following procedure:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a group, label, site, or all devices in the filter, set the filter to one of the options under

Groups, Labels, or Sites. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.

n To select a switch in the filter:
a. Set the filter to Global.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click a switch under Device Name for which you want to perform diagnostic test.

The dashboard context for the switch is displayed.

2. Under Analyze > Tools, click Network Check.
3. From the Device Type drop-down, select Switch.
4. From the Test drop-down, select Ping Test.
5. From the Sources drop-down, select the switch. You can select multiple switches.
6. From the Destination Type drop-down, select one of the following:

n Hostname/IP Address—Enter the hostname or IP address in the Hostname/IP Address field.
n Client—Select a client from the Client drop-down.

7. To use additional parameters, click Show Additional Test Settings and enter values in the
following fields:

Show Additional Test Settings is not displayed when a Test type is not selected.

n In the Repetitions field, enter the repetition value. The value should be between 1 to 500.
n In the Data Size field, enter the data size. The value should be between 0 to 65399.

8. Select the Use Management Interface option if you want to use VRF Management interface. To
use VRF Default interface, clear this option, which is the default.

Use Management Interface option is available only for AOS-CX switches.

9. Click Run.

The test output is displayed in the Device Output section.

Traceroute
Tracks the packets routed from a network host.

To perform a traceroute test on switches, complete the following procedure:
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1. In the Aruba Central On-Premises app, select one of the following options:
n To select a group, label, site, or all devices in the filter, set the filter to one of the options under

Group, Label, or Site. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.

n To select a switch in the filter:
a. Set the filter to Global.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click a switch under Device Name for which you want to perform diagnostic test.

The dashboard context for the switch is displayed.

2. Under Analyze > Tools, Network Check.
3. From the Device Type drop-down, select Switch.
4. From the Test drop-down list, select Traceroute.
5. From the Sources drop-down, select source(s). You can select multiple switches.
6. Enter the hostname or IP address in the Hostname/IP Address field.
7. To use additional parameters, click Show Additional Test Settings, and select the Use

Management Interface option, if you want to use the VRF Management interface. To use the
VRF Default interface, clear this option.

n Show Additional Test Settings is disabled when no Test type is selected.
n Use Management Interface option is available only for AOS-CX switches.

8. Click Run.

The output is displayed in the Device Output section.

For information about viewing and downloading the output, see Viewing the Device Output.

If you navigate from the device details page, the Tools page appears, where the device context is already set
and the Source field is automatically populated based on your selection.

Troubleshooting Controller Connectivity Issues
The following tests are available to diagnose issues pertaining to controller network connections:

Ping Test
Sends ICMP echo packets to the IP addresses of the selected devices to check for latency issues.

To perform a ping test on Controllers, complete the following procedure:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a group, label, site, or all devices in the filter, set the filter to one of the options under

Groups, Labels, or Sites. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.
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n To select a device in the filter:
a. Set the filter to Global.
b. Under Manage, click Devices > Controllers.

A list of controllers is displayed in the List view.

c. Click a controller listed under Device Name for which you want to perform diagnostic
test.

The dashboard context for the controller is displayed.

2. Under Analyze > Tools, click Network Check.
3. From the Device Type drop-down list, select Controller.
4. From the Test drop-down list, select Ping Test.
5. From the Sources drop-down list, select source(s). You can select multiple Controllers.
6. From the Destination Type drop-down list, select one of the following:

n Hostname/IP Address—Enter the hostname or IP address.
n Client—Select a client.
n VPNC—Select the VPN Concentrator.

7. To use additional parameters, click Show Additional Test Settings and enter values in the
following fields:

Show Additional Test Settings is not displayed when a Test type is not selected.

a. In the Packet Size field, enter the packet size to capture and store the data packet to analyze
network issues at a later stage. The range is from 10 to 2000 bytes.

b. In the Count field, enter the count. The value should be between 1 to 1000.
c. In the Time to Live field, enter the time range. The value should be between 1 to 225

seconds.
d. In the DSCP field, enter the packet header value. The value should be between 0 to 63.
e. From the Source Interface drop-down list, select one of the following:

n Loopback—Select loopback to verify if ping functionality is working when the source
address is set as logical address. It is a logical interface.

n Management Interface—Select management interface to verify if ping functionality is
working when the source address is set as management interface. It is a physical interface
which is dedicated to configuration and management operation in the network.

n VLAN Interface—Select VLAN interface to verify if ping functionality is working when the
source address is set as VLAN interface. It is a virtual LAN used to avoid broadcast domain
in a switch or controller.

f. Optionally, you can select the Don't Fragment toggle button. This option is used when the
packet size is more than the Maximum Transmission Unit (MTU) size of the interface.

8. Click Run.

The output is displayed in the Device Output section.

Traceroute
Tracks the packets routed from a network host.

To perform a traceroute test on Controllers, complete the following procedure:



Aruba Central On-Premises 2.5.7 | User Guide 1010

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a group, label, site, or all devices in the filter, set the filter to one of the options under

Group, Label, or Site. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.

n To select a device in the filter:
a. Set the filter to Global.
b. Under Manage, click Devices > Controllers.

A list of s is displayed in the List view.

c. Click a controller listed under Device Name for which you want to perform diagnostic
test.

The dashboard context for the controller is displayed.

2. Under Analyze > Tools, click Network Check.
3. From the Device Type drop-down list, select Controller.
4. From the Test drop-down list, select Traceroute.
5. From the Sources drop-down list, select source(s). You can select multiple Controllers.
6. Enter the hostname or IP address.
7. To use additional parameters, click Show Additional Test Settings, and from the Source

Interface drop-down list, select VLAN Interface.
8. From the VLAN Interface drop-down list, select the required VLAN ID displayed along with the IP

address.
9. Click Run.

The output is displayed in the Device Output section.

If you navigate from the device details page, the Tools page appears, where the device context is already set
and the Source field is automatically populated based on your selection.

Speed Test (iPerf)
Performs a speed test to measure network speed and bandwidth. To perform a speed test, you must
provide the iPerf server address, protocol type, and speed test options such as bandwidth.

To execute a speed test on Controllers, complete the following procedure:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a group, label, site, or all devices in the filter, set the filter to one of the options under

Group, Label, or Site. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.

n To select a device in the filter:
a. Set the filter to Global.
b. Under Manage, click Devices > Controllers.

A list of access points is displayed in the List view.

c. Click an access point listed under Device Name for which you want to perform
diagnostic test.

The dashboard context for the access point is displayed.

2. Under Analyze > Tools, click Network Check.
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3. From the Device Type drop-down list, select Controller.
4. From the Test drop-down list, select Speed Test (iPerf).
5. From the Sources drop-down list, select source(s). You can select multiple Controllers.
6. In the Host field, enter a valid hostname or IP address.
7. To use additional parameters, click Show Additional Test Settings and enter values in the

following fields:

Show Additional Test Settings is not displayed when a Test type is not selected.

a. Port—Select the port.
b. VLAN Interface—Select the VLAN ID from the drop-down list.

8. Click Run.

The test output is displayed in the Device Output section.

For more information about viewing and downloading the output, see Viewing the Device Output.

Viewing the Device Output
After you execute troubleshooting commands on the devices, Aruba Central displays the output in the
Device Output section of the Tools page.

The output pane displays a list of devices on which the troubleshooting commands were executed, the
test type, initial timestamp, source, and target. It also shows the status of the tests as, in progress,
complete, and the buffer time. If there are multiple devices, select the device for which you want to view
the output.

Output history of device with buffer space issues shall be automatically cleared.

You can perform the following tasks from the Device Output section:

n Click Clear to clear the output. You can clear the output for a single device or for all devices. The
Clear option is disabled for read-only users.

n Click the search icon to search for text in the output.
n Click the email icon and click Send to send the output as an email. You can also add email recipients

in the CC field.
n Click the download icon to export the command output as a zip file.
n Click the maximize icon to maximize the device output pane.

For more information on the output displayed for the CLI commands, see the following documents:

n Aruba Instant CLI Reference Guide for Instant AP CLI command output
n HPE ArubaOS-Switch Management and Configuration Guide for Aruba Switch CLI command output

Chapter 20
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Troubleshooting Device Issues
Device check aims to identify, diagnose, and debug issues on your device. The Device Check tab in the
Tools page can be used to perform troubleshooting check for Aruba Switches only. When a
troubleshooting operation is initiated, Aruba Central establishes a session with the Switch selected for
the troubleshooting operation and displays the output in the Device Output section.

To perform a device check on a switch, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a group, label, site, or all devices in the filter, set the filter to one of the options under

Groups, Labels, or Sites. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.

n To select a device in the filter:
a. Set the filter to Global.
b. Under Manage, click Devices > Switches.
c. A list of devices is displayed in the List view.
d. Click a switch listed under Device Name for which you want to perform diagnostic test.

The dashboard context for the switch is displayed.

2. Under Analyze, click Tools. The Tools page opens.
3. Click the Device Check tab.

n By default, the Device Type is set to Switch if a switch is configured in the data path, else a
warning is displayed.

n Multiple device selection is not allowed at this level.
n Devices which are already running commands shall not execute newly added commands.

4. From the Switch drop-down list, select the switch.

5. Select one of the following tests to perform diagnostic checks on the selected switch:
n Cable Test—Enables testing of the electrical connections in the switch cable. It checks whether

the cabling is conformed to the cabling plans and is of expected quantity. It is useful for
production and maintenance.

To use the Cable Test feature, make sure that your switch is running the following software
versions:

n AOS-S switches: 16.05.000 and later versions
n AOS-CX switches: 10.11.1000 and later versions

n Interface Bounce—Restarts the port interface and forces a client to re-initiate a DHCP
request. This option is available only for Aruba Switches.

n PoE Bounce—Restarts the PoE port and the device that is either connected to the PoE port or
powered by it. This option is available only for Aruba Switches.
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n If you select Cable Test, PoE Bounce, or Interface Bounce, you must enter the port number
or the port number range as mentioned in the example text.

n If you navigate to the Tools page from the Clients page, under Device Check the client
context is already set and the port number is auto filled based on the client selected.

n Chassis Locate—Activates the Switch locator LED. The locator LED indicates the physical
location where an Aruba Switch is currently installed.

6. Click Run.

The output is displayed in the Device Output section.

Important Points to Note
n Interface Bounce, PoE Bounce, and Chassis Locate tests are supported only from the following

versions in switches:
n AOS-S: See Supported AOS-S Platforms.
n AOS-CX: See Supported AOS-CX Platforms.

Viewing the Device Output
After you execute troubleshooting commands on the devices, Aruba Central displays the output in the
Device Output section of the Tools page.

The output pane displays a list of devices on which the troubleshooting commands were executed, the
test type, initial timestamp, source, and argument. It also shows the status of the tests as, in progress,
complete, and the buffer time.

Output history of device with buffer space issues shall be automatically cleared.

You can perform the following tasks from the Device Output section:

n Click Clear to clear the output. You can clear the output for a single device or for all devices. The
Clear option is disabled for read-only users.

n Click the search icon to search for text in the output.
n Click the email icon and click Send to send the output as an email. You can also add email recipients

in the CC field.
n Click the export to export the command output as a zip file.
n Click the maximize icon to maximize the device output pane.

Unlike the other tests, for Cable Test, the output is displayed in a tabular format, and you cannot
download, email, or export the output.

For more information on the output displayed for the CLI commands, see the following documents:

n Aruba Instant CLI Reference Guide for Instant AP CLI command output
n HPE ArubaOS-Switch Management and Configuration Guide for Aruba Switch CLI command output.

After you execute troubleshooting commands on the devices, Aruba Central displays the output in the
Device Output section of the Tools page.



Aruba Central On-Premises 2.5.7 | User Guide 1014

The output pane displays a list of devices on which the troubleshooting commands were executed, the
test type, initial timestamp, source, and argument. It also shows the status of the tests as, in progress,
complete, and the buffer time.

Output history of device with buffer space issues shall be automatically cleared.

You can perform the following tasks from the Device Output section:

n Click Clear to clear the output. You can clear the output for a single device or for all devices. The
Clear option is disabled for read-only users.

n Click the search icon to search for text in the output.
n Click the email icon and click Send to send the output as an email. You can also add email recipients

in the CC field.
n Click the export to export the command output as a zip file.
n Click the maximize icon to maximize the device output pane.

Unlike the other tests, for Cable Test, the output is displayed in a tabular format, and you cannot
download, email, or export the output.

For more information on the output displayed for the CLI commands, see the following documents:

n Aruba Instant CLI Reference Guide for Instant AP CLI command output
n HPE ArubaOS-Switch Management and Configuration Guide for Aruba Switch CLI command output

Performing Advanced Device Troubleshooting
Advanced device check aims to identify, diagnose, and debug issues on your device at an advanced level
using commands. The Commands tab on the Tools page lists commands specific to a particular device
to test the device entity and collect results based on your selection. When a troubleshooting operation is
initiated, Aruba Central establishes a session with the devices selected for the troubleshooting
operation and displays the output in the Device Output section.

For detailed information about the commands, see The CLI Bank. Use the search feature to locate the required
CLI. A command name can be same between the products, so ensure to choose your command based on the
native product or feature. For example, ArubaOS or Aruba Instant.

To perform advanced troubleshooting on devices, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a group, label, site, or all devices in the filter, set the filter to one of the options under

Groups, Labels, or Sites. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.

n To select a device in the filter:
a. Set the filter to Global.
b. Under Manage, click Devices, and then click Access Points, Switches, or Controllers.

A list of devices is displayed in the List view.

c. Click a device listed under Device Name.

The dashboard context for the device is displayed.

https://www.arubanetworks.com/techdocs/CLI-Bank/Content/home.htm
https://www.arubanetworks.com/techdocs/CLI-Bank/Content/CLI RG/cli-home-aos.htm
https://www.arubanetworks.com/techdocs/CLI-Bank/Content/CLI RG/cli-home-instant.htm
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2. Under Analyze > Tools, click the Commands tab.

The Commands page is displayed.

3. Select a device. Network administrators can perform advanced troubleshooting on the following
types of devices managed by Aruba Central:
n Troubleshooting Access Points
n Troubleshooting Switches
n Troubleshooting Controllers

Devices which are already running will not execute newly added commands.

Troubleshooting Access Points
To troubleshoot APs at an advanced level, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a group, label, site, or all devices in the filter, set the filter to one of the options under

Groups, Labels, or Sites. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.

n To select a device in the filter:
a. Set the filter to Global.
b. Under Manage, click Devices > Access Points.

A list of access points is displayed in the List view.

c. Click an access point listed under Device Name for which you want to perform
diagnostic test.

The dashboard context for the access point is displayed.

2. Under Analyze > Tools, click Commands.
3. In the Commands tab, select the device type as Access Point.
4. From the Available Devices drop-down list, select the AP. You can select multiple APs.
5. Select any command category and the Commands pane displays the associated commands.
6. Click Add> to add the selected commands to the Selected Commands pane.
7. If you have selected a command marked with either '*' or '+', enter the filtration parameters as

displayed in the Additional Filters dialog box. For more information on filtering commands, see
Filtering Commands.

8. (Optional) Select command(s) and click <Remove to remove selected command(s) or click
<Remove All to clear the Selected Commands pane.

9. (Optional) To set a frequency for automatically executing the troubleshooting commands,
complete the following steps:
a. Click the Repeat checkbox.
b. Specify an interval for executing the troubleshooting commands. You can also specify how

frequently the commands must be executed during a given interval.
c. Click Reset to modify the values in all the fields, and Cancel All for canceling all the repeats.

Click the stop icon to stop a particular repeat.

10. Click Run.

The output is displayed in the Device Output section.

For information about viewing and downloading the output, see Viewing the Device Output.
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n To perform advanced troubleshooting on APs, the minimum software version required on Instant APs is
6.4.3.1-4.2.0.3.

n If you navigate from the device details page, the Tools page appears, where the device context is already
set and the Source field is automatically populated based on your selection.

Troubleshooting Switches
To troubleshoot switches at an advanced level, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a group, label, site, or all devices in the filter, set the filter to one of the options under

Groups, Labels, or Sites. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.

n To select a switch in the filter, complete the following steps:
a. Set the filter to Global.
b. Under Manage, click Devices > Switches.

A list of switches is displayed in the List view.

c. Click a switch under Device Name for which you want to run a diagnostic test.

The dashboard context for the switch is displayed.

2. Under Analyze > Tools, click Commands.

The Commands page is displayed.

3. From the Device Type drop-down, select Switch.
4. From the Available Devices drop-down, select the switch. You can select multiple switches.
5. Select any command category in the Categories pane and the Commands pane displays the

associated commands.

AOS-CX switches support only the show tech and show running-config commands.

6. Click Add > to add the selected commands to the Selected Commands pane.
7. If you have selected a command marked with either '*' or '+', enter the filtration parameters as

displayed in the Additional Filters dialog box. For more information on filtering commands, see
Filtering Commands.

8. (Optional) Select command(s) and click < Remove to remove selected command(s) or click <
Remove All to clear the Selected Commands pane.

9. (Optional) To set a frequency for automatically executing the troubleshooting commands,
complete the following steps:
a. Click the Repeat checkbox.
b. Specify an interval for executing the troubleshooting commands. You can also specify how

frequently the commands must be executed during a given interval.
c. Click Reset to modify the values in all the fields, and Cancel All for canceling all the repeats.

Click the stop icon to stop a particular repeat.

10. Click Run.

The output is displayed in the Device Output section.

For information about viewing and downloading the output, see Viewing the Device Output.
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Troubleshooting Controllers
To troubleshoot Controllers at an advanced level, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a group, label, site, or all devices in the filter, set the filter to one of the options under

Groups, Labels, or Sites. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.

n To select a device in the filter:
a. Set the filter to Global.
b. Under Manage, click Devices > Controllers.

A list of controllers is displayed in the List view.

c. Click a controller listed under Device Name for which you want to perform diagnostic
test.

The dashboard context for the controller is displayed.

2. Under Analyze > Tools, click Commands.
3. In the Commands tab, select the device type as Controller.
4. From the Available Devices drop-down list, select the controller. You can select multiple

controllers.
5. Select any command category and the Commands pane displays the associated commands.
6. Click Add> to add the selected commands to the Selected Commands pane.
7. If you have selected a command marked with either '*' or '+', enter the filtration parameters as

displayed in the Additional Filters dialog box. For more information on filtering commands, see
Filtering Commands.

8. (Optional) Select command(s) and click <Remove to remove selected command(s) or click
<Remove All to clear the Selected Commands pane.

9. (Optional) To set a frequency for automatically executing the troubleshooting commands,
complete the following steps:
a. Click the Repeat checkbox.
b. Specify an interval for executing the troubleshooting commands. You can also specify how

frequently the commands must be executed during a given interval.
c. Click Reset to modify the values in all the fields, and Cancel All for canceling all the repeats.

Click the stop icon to stop a particular repeat.

10. Click Run.

The output is displayed in the Device Output section.

For information about viewing and downloading the output, see Viewing the Device Output.

Filtering Commands
In order to streamline the debug process and avoid huge data generation while troubleshooting, few
commands enable Client MAC address, IP Address, and Port filtration.

To filter commands, complete the following steps:

1. In the Aruba Central On-Premises app, select one of the following options:
n To select a group, label, site, or all devices in the filter, set the filter to one of the options under

Groups, Labels, or Sites. For all devices, set the filter to Global.
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The dashboard context for the selected filter is displayed.
n To select a device in the filter:

a. Set the filter to Global.
b. Under Manage, click Devices, and then click Access Points, Switches, or Controllers.

A list of devices is displayed in the List view.

c. Click a device listed under Device Name.

The dashboard context for the device is displayed.

2. Under Analyze > Tools, click Commands.

The Commands page is displayed.

3. Select the device type, Access Point, Switch, or Controller as required from the drop-down list.
4. Select any command category and the Commands pane displays the associated commands.

If you navigate from the device details page, the Tools page appears, where the device context is already set
and the Source field is automatically populated based on your selection.

Mandatory filters—Commands marked with '*'
To filter commands based on mandatory filters, complete the following steps:

1. Select a command marked with '*' and click Add.

The Additional Filters dialog box appears.

2. Enter the parameters such as, Client MAC address, IP address, port number, port list, or policy
name as required.

The parameters are generated based on the commands selected.

3. Click Apply.

In case of mandatory filter commands, if you do no enter the filtering parameters in the additional
filters dialog box, the command does not get added to the selected command pane and you cannot
perform the troubleshooting.

4. (Optional) Click Edit All to reset the filtration parameters for all the commands added in the
selected command pane.

Optional filters— Commands marked with '+'
To filter commands based on optional filters, complete the following steps:

1. Select a command marked with '+' and click Add.

The Additional Filters dialog box appears.

2. (Optional) Enter the parameters such as, Client MAC address, IP address, port number, port list,
or policy name as required.

The parameters are generated based on the commands selected.
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3. Click Apply.

In case of optional filter commands, if you do no enter the filtering parameters in the additional filters
dialog box, the command still gets added to the selected command pane and you can perform your
troubleshooting.

4. (Optional) Click Edit All to reset the filtration parameters for all the commands added in the
selected command pane.

Viewing the Device Output
After you execute troubleshooting commands on the devices, Aruba Central displays the output in the
Device Output section of the Tools page.

If there are multiple devices, select the device for which you want to view the output. It shows the status
of the tests as, in progress, complete, and the buffer time.

Output history of device with buffer space issues shall be automatically cleared.

You can perform the following tasks from the Device Output section:

n Click Clear to clear the output. You can clear the output for a single device or for all devices. The
Clear option is disabled for read-only users.

n Click the search icon to search for text in the output.
n Click the email icon and click Send to send the output as an email. You can also add email recipients

in the CC field.
n Click the download icon to export the command output as a zip file.
n Click the maximize icon to maximize the device output pane.

For more information on the output displayed for the CLI commands, see the following documents:

n Aruba Instant CLI Reference Guide for Instant AP CLI command output
n HPE ArubaOS-Switch Management and Configuration Guide for Aruba Switch CLI command output

Troubleshooting System Issues
To monitor the performance of the Aruba Central appliance, use the Grafana dashboard. This provides
useful metrics on CPU, Memory and IO usage of the Aruba Central node. It also provides cluster wide
information in case of an Aruba Central cluster.

To access Grafana dashboard from a web browser, go to https://<hostname or IP address>/grafana

Use the following default credentials to access the Grafana dashboard:

n Username—grafana
n Password—grafana#21

In order to debug Aruba Central logs, use the Kibana dashboard.

To access Kibana dashboard from a web browser, go to https://<hostname or IP
address>/airwavelogging

Use the following default credentials to access the Kibana dashboard:
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n Username—grafana
n Password—grafana#21

Enter the following index pattern to access the Aruba Central logs:

<IP Address>-coplogs-<category>-<year>.<month>.<data>.<hour>

Collecting Logs
To collect logs generated for the Aruba Central, complete the following steps:

1. Log in to Aruba Central.
2. The setup shows a list of 9 commands that can be used to perform different tasks.
3. In order to collect Aruba Central logs, run the following commands:

Support

Collect All Logs

The script generates a tar.gz file that you can share with the Aruba support team for debugging
issues.

The following archive (tar.gz file) contains all the log information required for troubleshooting issues:

/home/core/log_collection/aw10-setup91.arubathena.com_log_collection_2019-08-

07_05-29-15_UTC.tar.gz

Creating Log Snapshot
You can now collect log snapshots of specific categories. To create log snapshots for the Aruba Central,
complete the following steps:

1. Log in to Aruba Central.
2. The setup shows a list of 10 commands that can be used to perform different tasks.
3. To create Aruba Central log snapshot, run the following commands:

Support

Log Snapshot Operations

Generate Snapshots for a Category

The script captures logs for the following pods:

n kube
n nginx
n alert
n infra
n syslog
n system
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Downloading Log Snapshot
After creating the snapshot, it is saved as a file and to download the snapshot file, complete the
following steps:

1. Log in to Aruba Central.
2. The setup shows a list of 10 commands that can be used to perform different tasks.
3. To download Aruba Central log snapshots, run the following commands:

Support

Log Snapshot Operations

Download Logs/Snapshots

The list of available snapshots and their status is displayed.

1. Enter the snapshot name to download. For example, upgrade-snap-<time range>-<create time>.
2. Enter the remote host and path name.

Creating Pod Logs
To create pod logs, complete the following steps:

1. Log in to Aruba Central.
2. The setup shows a list of 10 commands that can be used to perform different tasks.
3. To generate Aruba Central pod logs, run the following commands:

Support

Log Snapshot Operations

Generate Pod Logs

4. Enter a pod name to generate logs.

Deleting Log Snapshot
To delete a log snapshot, complete the following steps:

1. Log in to Aruba Central.
2. The setup shows a list of 10 commands that can be used to perform different tasks.
3. In order to delete Aruba Central log snapshots run the following commands:

Support

Log Snapshot Operations

Delete Logs/Snapshots

4. Select the snapshot name that you want to delete.

Downloading Upgrade Logs
Aruba Central On-Premises allows you to view and download logs related to the events that occurred
during the upgrade process.
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1. In the Aruba Central On-Premises app, set the filter to Global.

2. Under Maintain, click System Management > Version.

3. Click Generate Logs in the Logs pane.

Once generated, the logs can be viewed from the logs table. The Logs table displays the following
information and also allows you to download or delete logs:

n File— Displays the generated file name.
n Created— Displays the date and time of the log creation.
n Status— Displays the status of the generated logs.
n Action— Allows you to do the following actions:

o

Download— Select the file and click the icon to download the generated file.
o Delete— Select the file that you want to delete and click the delete icon. In the Confirm Action

pop-up window, click Yes.
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Unified Communications

Unified Communications

The growing use of Wi-Fi and the proliferation of mobile, tablet, portable, and smart devices and
clients cause control and visibility challenges for communication and collaboration applications such
as Lync or Skype for Business. To overcome these challenges, Aruba Central On-Premises offers the
Unified Communications service to manage your enterprise communication ecosystem.

The Unified Communications service provides a seamless user experience for voice and video calls
and application sharing when using Lync or Skype for Business applications. The service actively
monitors and provides visibility into Lync or Skype for Business traffic and allows you to prioritize
sessions. The Unified Communications service leverages the functions of the service engine and
provides rich visual metrics for analytical purposes.

UCC is not supported on Instant APs.

The Unified Communications service supports the following functions based on the type of device:

n Session prioritization— Based on the type of device provisioned in your network, the Unified
Communication service receives call control information from APs, switches, and Aruba Central
On-Premises. The Unified Communications service uses this data to detect and classify the traffic
type and dynamically prioritize voice and video call traffic over data traffic. Based on the type of
device, the following information sources are used for session prioritization.
o The Lync or Skype for Business SDN API— The SDN API provides an interface for the Aruba

Central On-Premises devices to access diagnostic information for a comprehensive and a real-
time view of applications, users, devices, the Wi-Fi, and the LAN network infrastructure. The
Unified Communications service uses this data to prioritize voice and video traffic. The SDN API
can be installed on a Lync or Skype for Business server.

o Heuristics— A built-in method that detects the Lync or Skype for Business traffic and works
with all on-premises and Skype for Business online deployments. The heuristics data detection
and classification method is used to identify clients in the call, classify, and prioritize media
packets. Switches do not support heuristics-based prioritization. The session prioritization for
switches is based on the data from the Skype server through OpenFlow.

n Session visibility— The application also provides call session visibility correlated across the Skype
server and mobility network to simplify operations for the network administrator. The
administrators can monitor wireless and wired network connectivity health on a per-session basis
and analyze the quality of experience.

Licensing
Multi-tier licensing is applicable to Unified Communications applications. A foundation license
provides heuristics-based prioritization of the media traffic without visibility. An advanced license
provides session prioritization with visibility.

See the following sections for information about configuring and monitoring UCC:
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n Configuring UCC
n Monitoring UCC in List View
n Monitoring UCC in Summary View

Configuring UCC
The following topics are discussed in this section:

n Enabling Unified Communications
o Enabling Retain Client QoS
o Editing a Protocol

n Configuring Devices for Session Prioritization
o OpenFlow Configuration

n SDN API-Based Classification
o Configuring SDN Manager for SDN API
o HTTPS Connectivity with SDN Manager

n Heuristics Classification
o Configuring ACLs on Controllers for Media Classification
o Configuring UCC
o Creating a Management Server Profile on Controller
o Configuring Devices for Session Visibility

Enabling Unified Communications
To access the Unified Communications application, obtain a valid subscription. To obtain a
subscription for the Unified Communications application, contact the Aruba Central Sales team.

UCC is available for 8.x version or later IAPs and APs that run on foundation license.

To enable Unified Communications, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Manage, click Applications > UCC.
3. Click the Config icon.

The Settings page is displayed.

4. Move the Activate UCC slider to the right.

The Unified Communications is enabled.

Enabling Retain Client QoS
When retain client QoS is enabled, all configured ALGs are disabled, all traffic is treated as Real-Time
Transport Protocol (RTP) traffic, default prioritization defined by the client is honored, and call
visibility is provided.

To enable retain client QoS, complete the following steps:
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1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Manage, click Applications > UCC.
3. Click the Config icon.

The Settings page is displayed.

4. Move the Retain Client QoS slider to the right.

Editing a Protocol
To edit a protocol, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Manage, click Applications > UCC.
3. Click the Config icon.

The Settings page is displayed with the Protocols table.

4. In the Protocols table, hover over the required protocol and click the icon in the Action
column.

Unified Communications supports SIP, Skype for Business, and Wi-Fi Calling protocols.

5. Edit the protocol parameters listed below:
n Voice— Configure voice priority tag.
n Video— Configure video priority tag.
n DNS Pattern— Configure the carrier for Wi-Fi calling.

6. Click Save Settings.

Adding Carriers to Wi-Fi Calling Protocol
To add carriers to the Wi-Fi Calling protocol, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Manage, click Applications > UCC.
3. Click the Config icon.

4. Hover over the Wi-Fi Calling protocol and click the icon in the Action column.
The Edit Wi-Fi Calling page is displayed.

5. Click Show Advanced Setting.

The DNS Pattern table displays the default carriers list.

6. Click + to add a new carrier.

The DNS Pattern window is displayed.

7. Specify Carrier Name and DNS Pattern.
8. Click Save.

The new carrier name is displayed in the DNS Pattern table.
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Configuring Devices for Session Prioritization
Based on the ArubaOS software version, controllers support session prioritization using both SDN
API and heuristics as the source for information. If both methods are enabled, the SDN API-based
Skype for Business classification takes precedence.

OpenFlow Configuration
For both SDN API and heuristics-based classification and prioritization, OpenFlow configuration is
required.

n In the SDN API-based Skype for Business classification method, the Unified Communications
application receives the media identification data from the SDN Manager and call quality report
from the devices through OpenFlow.

n In heuristics-based media classification method, the Unified Communications application receives
media identification and the call quality reports from the devices through OpenFlow.

Enabling OpenFlow on Controller
To enable the OpenFlow on controller, issue the following commands in the CLI:

(host)# configure terminal

(host)(config)# openflow-profile

(host)(openflow-profile)# controller-ip <controller-ip> 30633

(host)(openflow-profile)# bind-vlan 1

(host)(openflow-profile)# bind-vlan add <range of vlan-ids>

(host)(openflow-profile)# openflow-enable

(host)(openflow-profile)# write memory

(host)(openflow-profile)# exit

To enable OpenFlow in the user-role and virtual AP of a controller, issue the following commands in
the CLI:

(host)(config) # user-role <user-role>

(host)(config-submode)# openflow-enable

(host)(config-submode)# exit

(host)(config) #wlan virtual-ap <virtual-ap>

(host)(Virtual AP profile "<virtual-ap>") #openflow-enable

(host)(Virtual AP profile "<virtual-ap>") #write memory

Enable OpenFlow on Switch
To enable OpenFlow on switch:

1. To configure OpenFlow on switch, issue the following commands in the CLI:

(host)# configure terminal

(host)(config)# openflow

(host)(openflow)# controller-id <number> ip <ip-addr-of-OFC> port <OFC-

TCP-port> controller-interface vlan <vlan-id-used-to-connect-to-OFC>

(host)(openflow)# write memory

(host)(openflow)# exit
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2. To configure OpenFlow instance on switch, issue the following commands in the CLI:

(host)# configure terminal

(host)(config)# openflow

(host)(openflow)# instance <instance-name>

(host)(openflow)# member vlan <vlan-id-of-the-member>

(host)(openflow)# controller-id <same as the number given for controller-

id in the OFC details>

(host)(openflow)# version 1.3

(host)(openflow)# pipeline-model standard-match

(host)(openflow)# exit

3. To enable OpenFlow and OpenFlow instance on switch, issue the following commands in the
CLI:

(host)(config)# configure terminal

(host)(config)# openflow instance <instance-name> enable

(host)(config)# openflow enable

(host)(config)# exit 

Aruba switches support only the SDN API source for session prioritization.

Enabling OpenFlow on AP
If the Unified Communications subscription is enabled on the APs, OpenFlow is automatically
enabled on the APs. Therefore, no explicit configuration from the user is required for enabling
OpenFlow.

SDN API-Based Classification
For the Lync/Skype for Business SDN API to dynamically prioritize traffic at the edge of a network
using OpenFlow, the OpenFlow controller and its instances must be configured on controllers and
switches. For information on configuring OpenFlow instances, see OpenFlow Configuration.

Configuring SDN Manager for SDN API
To enable Skype SDN Manager to send XML messages to the Unified Communications application,
complete the following configuration:

1. Log in to the Skype SDN Manager.
2. Ensure that you have the SDNManager.exe program installed.
3. Open the command prompt and go to the folder in which the SDNManager.exe program is

installed.
4. Execute the following command:

SDNManager.exe p s <some-string> submituri=[https://<Cluster-

IP>/skypeSDN/<customer-id>
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Use the GET /v1/SkypeCentralURL API to get the Lync/Skype for Business URL for the Aruba Central
cluster that you are using.

HTTPS Connectivity with SDN Manager
The customer premises with the Lync/Skype for Business SDN infrastructure must access Aruba
Central through an HTTPS connection only. Aruba Central acts as a server while Lync/Skype for
Business SDN Manager acts as a client.

For the client and server mutual authentication and TLS handshake, the client must have a root
CA certificate provided by GeoTrust to validate the certificate presented by Aruba Central.

Heuristics Classification
In the heuristics method, APs perform deep packet inspection on the Skype for Business traffic to
determine Skype for Business voice and video traffic. For the heuristics classification method, no
changes or additional components are required on the Skype for Business server.

The heuristics classification method includes the following steps:

n ACL definition on the controller to listen on port TCP 5061 and 5063. The classify-media option in
the ACL is enabled and is mapped to a user role.

n When the Skype for Business calls are established, classify-media in the ACL is triggered and
Skype for Business clients are marked as media-capable clients.

n Any subsequent UDP data flow with source/destination port numbers above 1023 from or to
media-capable users go through the Skype for Business media DPI.

n If an RTP session is based on DPI, the payload type in the RTP header is used to determine if it is a
voice or video session.

Configuring ACLs on Controllers for Media Classification
If the controllers are running ArubaOS 6.5.x release version, configure the following commands to
classify media:

host)(config)# ip access-list session <acl-name> any any tcp 5061 permit

classify-media

or

host)(config)# user-role authenticated access-list session skype-acl

or

host)(config)# firewall allow-stun

For more information on configurations steps related to heuristics classification method, see the
ArubaOS User Guide.
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Creating a Management Server Profile on Controller
If the controllers are running ArubaOS 6.5.x.x or 8.x.x.x, configure the controllers to send call session
data through AMON periodically. After Aruba Central receives these AMON messages, it displays the
aggregated and per-client statistics on the Unified Communications > Activity page. This helps the
administrator to assess the overall health and troubleshoot issues if any.

To configure the management server profile on controller:

1. Access the controller CLI.
2. Configure the following commands:

(host)(config)# mgmt-server profile <name>

(host)(Mgmt Config profile “<name>”)# uccmonitoring-enable

(host)(Mgmt Config profile “<name>”)# stats-enable

(host)(Mgmt Config profile “<name>”)# sessions-enable

(host)(Mgmt Config profile “<name>”)# monitored-info-enable

(host)(Mgmt Config profile “<name>”)# monitored-info-del-enable

(host)(Mgmt Config profile “<name>”)# monitored-info-snapshot-enable

(host)(Mgmt Config profile “<name>”)# mgmt-server primary-server <Central-

SE-cluster-virtual IP> profile <profile-name>

(host)(Mgmt Config profile “<name>”)# write memory

(host)(openflow)# exit

Configuring Devices for Session Visibility
If the controllers are running ArubaOS 6.5.x.x or 8.x.x.x, configure the controllers to send call session
data through Application Monitoring (AMON) periodically. After Aruba Central receives these AMON
messages, it displays the aggregated and per-client statistics in the UI. This helps the administrator
to assess the overall health and troubleshoot issues if any.

To enable controllers to send AMON feeds about Unified Communications statistics to Aruba Central,
ensure that the Aruba Central management server profile is configured on the controller.

To configure the management server profile, complete the following steps:

1. Access the controller CLI.
2. Configure the following commands:

(host)(config)# mgmt-server profile <name>

(host)(Mgmt Config profile “<name>”)# uccmonitoring-enable

(host)(Mgmt Config profile “<name>”)# write memory

(host)(openflow)# exit

For more information about configuration required for the Unified Communications application on
the controller, see the ArubaOS User Guide.

Monitoring UCC in List View
The Application > UCC page displays graph and table view to assess the quality of calls in the network.
You can view data for the Global level.
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n For the Application Layer Gateway (ALG) like Skype SDN, the end-to-end Mean Opinion Score (MOS) is
used. A good call has a MOS of more than 3.5, a fair call has a MOS in the range of 2.0 to 3.5, a poor call
has a MOS of less than 2.0, and an unknown call does not have a MOS.

n Wi-Fi Calling calls are not assigned an UCC RTPA score (RTP analysis) and are categorized as unknown.

List view
The List view in the Applications > UCC page provides a lists to assess the quality of calls in the
network.

Time Filter

The time filter allows you to set a time range to display the corresponding data on the graph. You
can set the filter to any of the following time ranges:

n 3 Hours—The graph displays the details for the past three hours.
n 1 Day—The graph displays the details for the current day.
n 1 Week—The graph displays the details for the current week.
n 1 Month—The graph displays the details for the current month.

Calls List
The Calls list displays the following details:

Parameter Description

CDR Displays the Call Detail Record (CDR). The value displayed in the
column indicates the number of calls for the corresponding client.

The icon indicates wireless and icon indicates wired
connection type. Click the value displayed in the column to view
detailed information. For more information, see Monitoring UCC
in List View.

Start Time Displays the date and time when the call was started.

Client Name Displays the name of the client.

Call Quality Displays the quality of the call. You can filter the data by:
n Good
n Fair
n Poor
n Unknown

Client Health Displays the client health score.

SSID Displays the SSID.

Protocol Type Displays the type of protocol. You can filter the data by:
n Facetime
n RTP
n SIP

Table 232: Calls
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Parameter Description

n Skype for Business
n Wi-Fi Calling
n H.323
n Jabber
n Microsoft Teams
n SCCP
n WebRTC

Session Type Displays the type of session. You can filter the data by:
n Audio
n Desktop Sharing
n Unknown
n Video

OS Displays the operating system running on the client.

User Role Displays the user role that initiated the call.

Call Duration Displays the duration of the call.

Client IP Address Displays the IP address of the client.

Peer IP Address Displays the peer IP address of the client.

AP Host Name Displays the host name of the AP.

AP type Displays the type of AP.

UCC MOS Displays the UCC Mos.

BSSID Displays the BSSID of the client.

DSCP Displays the DSCP of the client.

Quality Score Displays the quality score of the call.

Source Port Displays the source port number.

Destination Port Displays the destination port number.

WMM Priority Displays the priority value for Wifi Multimedia (WMM).

Codec Displays the Codec name.

From Displays the device originating the call.

To Displays the device receiving the call.

Table 232: Calls

Call Details
The following image shows the Call Details window that is displayed when you click the value in the CDR
column.
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Figure 144 Call Details

Monitoring UCC in Summary View
The Application > UCC page displays graph and table view to assess the quality of calls in the network.
You can view data for the Global level.

n For the Application Layer Gateway (ALG) like Skype SDN, the end-to-end Mean Opinion Score (MOS) is
used. A good call has a MOS of more than 3.5, a fair call has a MOS in the range of 2.0 to 3.5, a poor call
has a MOS of less than 2.0, and an unknown call does not have a MOS.

n Wi-Fi Calling calls are not assigned an UCC RTPA score (RTP analysis) and are categorized as unknown.

Summary view
The Summary view in the Applications > UCC page provides the following information:

Time Filter

The time filter allows you to set a time range to display the corresponding data on the graph. You
can set the filter to any of the following time ranges:

n 3 Hours—The graph displays the details for the past three hours.
n 1 Day—The graph displays the details for the current day.
n 1 Week—The graph displays the details for the current week.
n 1 Month—The graph displays the details for the current month.

Summary Bar
The banner in the header pane shows the following details:

n Calls—Displays the total number of calls that have ended.
n Good—Displays the total number of good calls that have ended. A good call has an UCC RTPA score

of more than 70.
n Fair—Displays the total number of fair calls that have ended. A fair call has an UCC RTPA score in the

range of 30 to 70.
n Poor—Displays the total number of poor calls that have ended. A poor call has an UCC RTPA score of

less than 30.
n Unknown—Displays the total number of calls whose status is unknown. A call is classified as

unknown if the ALG does not support RTPA or the UCC score is not available.
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Click any option to view the corresponding graph. For example, if you click Good. The graph displays
only the calls that are categorized as good for the selected time range.

Calls
The Calls section displays a donut graph and bar graph of all, good, fair, poor, or unknown calls. You can
filter the graph by SSID, Protocol, Operating System (OS), Session Type, or Quality. By default, the
graph is displayed for Protocol. You can hover over any segment on the graph to view additional

information. Click the enlarge icon to view the graph in a zoom in.

Figure 145 Summary View
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Webhook

Webhook

Webhooks allow you to implement event reactions by providing real-time information or notifications to
other applications. Aruba Central On-Premises allows you to create Webhooks and select Webhooks as
the notification delivery option for all alerts.

Using Aruba Central On-Premises, you can integrate Webhooks with other third-party applications such
as ServiceNow, Zapier, IFTTT, and so on.

You can access the Webhooks service either through the Aruba Central On-Premises UI or API Gateway.
Aruba Central On-Premises supports creating up to 10 Webhooks. To enable redundancy, Aruba Central
On-Premises allows you to add up to three URLs per Webhook.

From Aruba Central On-Premises, you can add, list, or delete Webhooks; get or refresh Webhooks token;
get or update Webhooks settings for a specific item; and test Webhooks notification.

Creating and Updating Webhooks Through the UI
To access the Webhooks service from the UI, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization > Platform Integration > Webhooks.

The Webhooks page is displayed.

3. In the Webhook tab, click + sign. The Add Webhook pop-up window is displayed.
4. To create webhooks, enter the following details:

a. Name—Enter a name for the Webhook.
b. Retry Policy—Select one of the following options:

n None—No retries.
n Important—Up to 5 retries over 6 minutes.
n Critical—Up to 5 retries over 32 hours.

c. URLs—Enter the URL. Click + to enter another URL. You can add up to three URLs.

5. Click Save. The Webhooks is created and listed in the Webhook table.

Viewing and Editing Webhooks
To view the Webhooks, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization > Platform Integration > Webhooks.
3. The Webhooks page with Webhook table is displayed.

The Webhook table allows you to test, view dispatch logs, and delete Webhooks. The webhooks
table displays the following information:
n Name—Name of the Webhooks.
n URL—Number of URLs in Webhooks.
n Last Updated—Date and time at which Webhooks was updated.
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n Retry Policy—Displays the selected retry policy.
n Test Webhooks—Hover over a Webhook from the list and click the Test Webhooks icon to

test the Webhook by posting sample webhook payload to the configured URL. The Test
Webhooks table provides the URL and Status of the selected Webhook.

n View Dispatch Logs—Hover over a Webhook from the list and click the View Dispatch Log
icon to view the Dispatch Logs for the selected Webhook. The Dispatch Logs table provides
the URL, Status, and Dispatched Time. Click the arrow against each row to view the Log
Details and Attempts in the drop-down for the respective URL.

n Delete—Hover over a Webhook from the list and click the Delete icon and click Yes to delete
the Webhook.

To edit a Webhooks, complete the following steps:

1. Select a webhook from the list of webhooks and click icon. The following information are
displayed:
n Name—Name of the Webhooks.
n Webhook ID—Displays the webhooks ID.
n Retry Policy—Displays the selected retry policy. You can select any policy from the Retry

Policy drop-down option.
n Token—Webhooks token. Webhooks token enables header authentication and the third-party

receiving service must validate the token to ensure authenticity. To refresh a token, click the
refresh icon.

n URL—Number of URLs in Webhooks. Click + to enter another URL. You can add up to three
URLs.

2. Click Save to save the settings.

The following figure displays the dispatch log details for a webhook.

Figure 146 Dispatch Logs Details Page
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Refreshing Webhooks Token Through the UI
To refresh Webhooks token through the UI:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization > Platform Integration > Webhooks.

The Webhooks page is displayed.

3. In the Webhook table, select the Webhook from the list and click icon to edit.
4. Click the Refresh icon next to the token. The token is refreshed.

Creating and Updating Webhooks Through the API Gateway
To access and use the API Webhook service

1. In the Aruba Central On-Premises app, under Maintain, click Organization > Platform
Integration > Rest API. The API Gateway page is displayed.

2. In the APIs tab, click the Swagger link under the Documentation header. The Swagger website
opens.

3. In the Swagger, from the URL drop-down list, select Webhook. All available Webhooks APIs are
listed under API Reference.

For further help on API Webhook Service and creating a Webhook ID (WID), refer to https://apigw-<fqdn of the
Aruba Central Instance>/swagger/apps/nms/.

The following HTTP methods are defined for Aruba Central API Webhook resource:

n GET 
n POST
n PUT
n DELETE

You can perform CRUD operation on the Webhook URL configuration. The key configuration elements
that are required to use API Webhook service are Webhook URL and a shared secret.

It is mandatory to use HTTPS Web APIs signed by a public CA certificate to validate the Webhooks URL.

Validating a Webhooks URL using custom CA certificate is not supported.

A shared secret token is generated for a Webhook URL when you register for Webhooks. A hash key is
generated using HMAC-SHA256 algorithm by using the payload and the shared secret token. The API
required to refresh the shared secret token is provided for a specific Webhook configuration. You can
choose the frequency at which you want to refresh the secret token.

Sample Webhook Format for a New Alert Generation

URL POST <webhook-url>

Custom Headers

Content-Type: application/json

https://apigw-yodacop-vip.arubathena.com/swagger/apps/nms/
https://apigw-yodacop-vip.arubathena.com/swagger/apps/nms/
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X-Central-Service: Alerts

X-Central-Event: Radio-Channel-Utilization

X-Central-Delivery-ID: 72d3162e-cc78-11e3-81ab-4c9367dc0958

X-Central-Delivery-Timestamp: 2016-07-12T13:14:19-07:00

X-Central-Customer-ID: <########>

Body

{

"alert_type": "AP_RADIO_NOISE_FLOOR",

"description": "Noise floor on AP iap-303-iphone456-offline operating on

Channel 10 and serving 0 clients has been above -110 dBm

for about 10 minutes since 2019-07-24 07:06:00 UTC.",

"timestamp": 1563952560,

"webhook": "780c65a0-10b6-4eb1-b725-21b0d52aa432",

"setting_id": "201804170291-1253",

"state": "Open",

"nid": 1253,

"details": {

"_rule_number": "0",

"group": "3",

"name": "iap-303-iphone456-offline",

"_radio_num": "1",

"client_count": "0",

"labels": "3,118",

"_band": "0",

"duration": "10",

"time": "2019-07-24 07:06:00 UTC",

"threshold": "110",

"ds_key": "201804170291.CNGHKGX004.radio.noisefloor",

"serial": "CNGHKGX004",

"channel": "10"

},

"operation": "create",

"device_id": "CNGHKGX004",

"id": "AWwi1jjgVQO1ZtiGThDB",

"severity": "Critical"

}

Integrating Aruba Central with ServiceNow
ServiceNow is an IT service management platform that allows you to automatically create incidents or IT
tickets based on a live data feed from a Webhook service. If you have a ServiceNow instance, you can
configure a Webhook service on Aruba Central On-Premises to send a notification feed. The ServiceNow
integration enables your current IT Infrastructure management systems to automatically generate an IT
incident or a ticket whenever an alert is triggered due to a user-generated event in Aruba Central On-
Premises.

Before You Begin
Before you begin, ensure that you have a valid ServiceNow account. If you do not have a ServiceNow
instance, create an instance before you proceed with the steps described in following sections.

For more information on creating a ServiceNow instance, see the ServiceNow user documentation.

https://docs.servicenow.com/
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Integration Workflow
Complete the following steps to enable ServiceNow integration with Aruba Central:

n Step 1: Add the Hash Library to Your ServiceNow Instance
n Step 2: Create a Scripted REST API to Obtain a Webhook URL
n Step 3: Configure a Webhook in Aruba Central
n Step 4: Configure an Alert in Aruba Central
n Step 5: Verify the Integration Status

Step 1: Add the Hash Library to Your ServiceNow Instance
To get started with the ServiceNow integration, create a new script with the hash library in your
ServiceNow instance. The hash library is required for header authentication.

1. Log in to ServiceNow with your user credentials.
2. Click Manage > Instance and log in to your instance.
3. Go to System Definition > Script Includes.
4. Click New.
5. Name the script as Hashes.
6. Select All application scopes from the Accessible from drop-down list.
7. Select the Client callable check box.
8. Go to the GitHub Gist website that hosts the hash library.
9. Copy the snow_hashes.js file content and paste it in the Script text box.

10. Click Submit.

Step 2: Create a Scripted REST API to Obtain a Webhook URL
To create a Scripted REST API to obtain a webhook URL, complete the following steps:

1. In your ServiceNow instance, go to System Web Services > Scripted REST APIs.
2. Click New. The REST API creation page is displayed.
3. Provide a name and the API ID.
4. Click Submit. The API is added to the list of REST APIs.
5. Open the REST API you just created.
6. To add a REST resource with header and query parameters, click New in the Resources tab. The

Scripted REST Resource New record page is displayed.
7. Provide a name for the resource.
8. Select POST for the HTTP method.
9. Clear the Requires authentication check box.

10. In the Script section, add the following text:

(function process( /*RESTAPIRequest*/ request, /*RESTAPIResponse*/ response) {

// Calcuate signature for verification using request headers, data and token

var centralService = request.getHeader('X-Central-Service');

https://github.com/aruba/central-integration-snippets/blob/master/notifications-webhooks-snow/snow_hashes.js
https://developer.servicenow.com/app.do#!/home
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var centralDeliveryId = request.getHeader('X-Central-Delivery-ID');

var centralDeliveryTimestamp = request.getHeader('X-Central-Delivery-

Timestamp');

var token = "<webhook_token>";
var body = request.body.dataString;

var message = body + centralService + centralDeliveryId +

centralDeliveryTimestamp;

var calculatedSign = new Hashes.SHA256().b64_hmac(token, message);

var signFromServer = request.getHeader('X-Central-Signature'); // Signature

sent by Aruba Central

var low_severities = ["Minor", "Warning"];

if (calculatedSign == signFromServer) {

event = JSON.parse(body);

// Only process events from Central which has status Open

if (event.state == "Open") {

var inc = new GlideRecord('incident');

inc.initialize();

inc.short_description = event.alert_type;

inc.state = 1;

if (low_severities.includes(event.severity)) {

inc.impact = 3;

inc.urgency = 3;

} else if (event.severity == "Major") {

inc.impact = 2;

inc.urgency = 2;

} else if (event.severity == "Critical") {

inc.impact = 1;

inc.urgency = 1;

}

inc.description = event.description;

inc.insert();

}

response.setStatus(200);

response.setBody({

status: "success"

});

} else {

response.setStatus(200);

response.setBody({

status: "failure"

});

}

})(request, response); 

After you create a Webhook in Aruba Central, replace the Webhook token (see highlighted text in the
above code sample) in your Scripted REST API.
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11. Click Submit. The Scripted REST API you just created is added to your list of APIs.
12. Note the base API path. The base API path must be appended to your Webhook URL.
13. Ensure that your Webhook URL is in the following format:

https://<yourInstanceName>.service-now.com/<baseApiPath>.

Step 3: Configure a Webhook in Aruba Central
To create a Webhook in Aruba Central, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization > Platform Integration > Webhooks.

The Webhooks page is displayed.

3. In the Webhook tab, click + sign. The Add Webhook pop-up window is displayed.
4. To create webhooks, enter the following details:

a. Name—Enter a name for the Webhook.
b. Retry Policy—Select one of the following options:

n None—No retries.
n Important—Up to 5 retries over 6 minutes.
n Critical—Up to 5 retries over 32 hours.

c. URLs—Enter the URL. Click + to enter another URL. You can add up to three URLs.
https://<yourInstanceName>.service-now.com/<baseApiPath>
The URL must include your ServiceNow instance and the base API path generated for your
Scripted REST API.

5. Click Save. The Webhooks is created and listed in the Webhook table.

6. Note the token ID.

7. Go back to your ServiceNow instance and update the Webhook token in the script text of the
Scripted REST API you created in step 2.

You can also create a Webhook using the API interface. For more information, see Webhook
documentation in Aruba Central documentation portal.

8. Click Save. The Webhooks is created and listed in the Webhook table.
9. Note the token ID.

10. Go back to your ServiceNow instance and update the Webhook token in the script text of the
Scripted REST API you created in step 2.

Step 4: Configure an Alert in Aruba Central
To configure an alert in Aruba Central, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Analyze, click Alerts & Events to view the alert and events dashboard.
3. To configure alerts, click the Config icon.
4. In the Alert Severities & Notifications page, click All.
5. Select an alert and click + to enable the alert with default settings.

https://www.arubanetworks.com/techdocs/central/latest/content/nms/api/api_webhook.htm
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6. Configure the following alert parameters.
a. Severity—Set the severity. The available options are Critical, Major, Minor, and Warning.
b. Duration—Enter the duration in minutes.
c. Device Filter Options—(Optional) You can restrict the scope of an alert by setting any of the

following parameters:
n Group—Select a group to limit the alert to a specific group.
n Label—Select a label to limit the alert to a specific label.
n Device—Select a device to limit the alert to a specific device.

d. Select Webhook check box under Notification Options and select a webhook from the
drop-down list.

e. Click Save.

Step 5: Verify the Integration Status
To verify if the integration is successful, complete the following steps:

1. Trigger an alert from Aruba Central On-Premises.
2. Verify if an incident is created in your ServiceNow instance.
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API Gateway

API Gateway

The API Gateway feature in Aruba Central On-Premises supports the REST API for all Aruba Central On-
Premises services. This feature allows Aruba Central On-Premises users to write custom applications,
embed, or integrate the APIs with their own applications. The REST APIs support HTTP GET and POST
operations by providing a specific URL for each query. The output for these operations is returned in the
JSON format.

For secure access to the APIs, the Aruba Central On-Premises API Framework plug-in supports OAuth
protocol for authentication and authorization. The access tokens provide a temporary and secure access
to the APIs. The access tokens have a limited lifetime for security reasons and the applications should
use the refresh API to obtain new tokens periodically (every 2 hours).

n To access the API Gateway interface, you must ensure that the FQDN in the API Gateway URL resolves to
the same IP address as the Aruba Central On-Premises server.

n To avoid any error in the server certification, make sure that you include the API gateway FQDN as a
Subject Alternate Name (SAN) in the certificate. For more information, refer to Aruba Central On-Premises
User Guide.

The following figure illustrates the API gateway workflow for the users:
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This section includes the following topics:

n Accessing API Gateway
n Viewing Swagger Interface
n List of Supported APIs

Accessing API Gateway
To access the API Gateway:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization > Platform Integration.
3. Under the API Gateway tile, click Rest API.

The API Gateway page is displayed. You can get new tokens and refresh old tokens. To obtain a new
token application, you must set authentication parameters for a user session.

Important Points to Note

n The admin user has System Apps & Tokens tab which displays all the apps and tokens generated
locally in the admin user profile. This tab also displays all the apps created in the non-admin user
profiles. Clicking these apps lists out all the associated tokens created for the non-admin user profile.

Viewing Swagger Interface
To view the APIs managed through Aruba Central On-Premises, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.

2. Under Maintain, click Organization > Platform Integration > Rest API.
3. To view the Swagger interface, click the link in the Documentation column. A new window is

displayed with the Swagger documentation. In case of multiple accounts, select one of the
accounts to view the Swagger documentation in a new window.

On selecting the bookmarked Swagger documentation URL, a window is displayed with a sign-in
request. To view the Swagger documentation, authenticate using the SSO and select one of the
accounts.

Figure 147 API Gateway Dashboard
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List of Supported APIs
Aruba Central On-Premises supports the following APIs for the managed devices.

API Description

Monitoring Gets network, client, and event details. It also allows you to manage labels and switches.

Configuration Allows you to configure and retrieve the following:
n Groups
n Templates
n Devices

AppRF Gets Top N AppRF statistics.

User Management Allows you to manage users and also allows you to configure various types of users with
a specific level of access control.

Audit Event Logs Gets a list of audit events and the details of an audit event.

Device Inventory Gets device details and device statistics.

Licensing Allows you to manage and retrieve subscription keys.

Device
Management

Allows you to manage devices.

Firmware Allows you to manage firmware.

Troubleshooting Gets a list of troubleshooting commands for a specific type of device.

Notification Gets notification alerts generated for events pertaining to device provisioning,
configuration, and user management.

Unified
Communications

Retrieves data for all sessions for a specific period of time. It also retrieves the total
number of clients who made calls in the given time range and gets the Lync/Skype for
Business URL for the Aruba Central cluster that you are using.

Refresh API Token Allows you to refresh the API token.

Reporting Gets the list of configured reports for the given customer ID.

WAN Health Allows you to the following:
n Get list of configured WAN health policies.
n Create a new WAN health policy.
n Delete an existing WAN health policy.
n Get the details of any specific WAN health policy.
n Update an existing WAN health policy.
n Get policy schedule details.
n Create a schedule for a WAN health policy.
n Get statistics for WAN health cookie generated for a site.
n Get WAN health test results.
n Get WAN health test results for a specific site.

Table 233: APIs and Description
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API Description

Network Health Allows you to get data for all the labels and sites.

VisualRF Allows you retrieve information on floor plans, location of APs, clients and rogue
devices.

Table 233: APIs and Description

For a complete list of APIs and the corresponding documentation, see https://apigw-<fqdn of the Aruba
Central Instance>/swagger/apps/nms/.

This section also includes the following topics:

n Creating Application and Token
n Using OAuth 2.0 for Authentication
n Obtaining Token Using Offline Token Mechanism
n Viewing Usage Statistics
n Changes to Aruba Central On-Premises APIs

Creating Application and Token
To create an application, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization > Platform Integration > Rest API.

The API Gateway page is displayed.

3. Click the My Apps & Tokens tab.

The user with Aruba Central On-Premises Administrator role will be able to create new apps for all
the non-admin user by clicking + Add Apps & Tokens in the System Apps & Tokens tab.

4. Click + Add Apps & Tokens.

Figure 148 Add Apps and Tokens Option Page

5. In the New Token pop-up window, do the following:
a. Enter the application name. In non-admin user profile, the Application Name field contains

the logged-in user name and is non-editable.
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b. In the Redirect URI field, enter the redirect URL.
c. Click Generate. A new application is created and added to the My Apps & Tokens table.

The My Apps & Tokens table displays the following details:
n Name—Name of the application. In non-admin user profile, the Application Name field

contains the logged-in user name and is non-editable. Any new tokens generated in non-
admin user profile is associated with the same application name.

n Client ID—Unique ID for each application.
n Client Secret—Unique secret ID for each application.
n Redirect URI—Redirect URL.
n Application—Name of the application. For example, Aruba Central.
n Tokens—Token created for the application. The option is available to admin user profile

only.
n Created At—Date on which the application was created.

To delete the added application, click delete icon on the row corresponding to an application
and click Yes to delete that application.

Only users with Aruba Central On-Premises Administrator role will be able to generate tokens with multiple
application names. In non-admin user profile, the Application Name field contains the user name and is non-
editable. Any new tokens generated in non- admin user profile is associated with the same application name.
However, all the multiple application names and the associated tokens in non-admin user profiles from the
earlier versions is retained in the Token List table.

Using OAuth 2.0 for Authentication
For secure access to the APIs, the Aruba Central On-Premises API Framework plug-in supports the
OAuth protocol for authentication and authorization. OAuth 2.0 is a simple and secure authorization
framework. It allows applications to acquire an access token for Aruba Central On-Premises through a
variety of work flows supported within the OAuth 2.0 specification.

All OAuth 2.0 requests must use the SSL endpoint available at https://apigw-<fqdn> of the Aruba Central
instance>/swagger/central.

Access and Refresh Tokens
The access token is a string that identifies a user, an application, or a web page. Applications use the
access token to access an API. The access tokens provide temporary and secure access to the APIs.

The access tokens have a limited lifetime. If the application uses web server or user-agent OAuth
authentication flows, a refresh token is provided during authorization. Using the refresh token you can
get a new access token.

If you are writing a long-running application (web app) or native mobile application, you must refresh
the token periodically. For more information, see Refreshing a token.

This section includes the following topics:

n Obtain an Access Token
n Access APIs
n Viewing and Revoking Tokens
n Adding a New Token
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Obtain an Access Token
Users can generate the OAuth token using one of the following methods:

n Obtaining Token Using Offline Token Mechanism
n Obtaining Token Using OAuth Grant Mechanism

Obtaining Token Using Offline Token Mechanism
To obtain tokens using the offline token method, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization > Platform Integration > Rest API.

Displays the API Gateway page.

3. Click My Apps & Tokens.

Only users with Aruba Central On-Premises Administrator role can view the System Apps &
Tokens tab. The System Apps & Tokens tab displays all the apps and tokens generated in all the non-
admin user profiles and the admin user profile.

4. Click + Add Apps & Tokens.

Displays the NEW TOKEN pane.

5. Enter the application name and redirect URI in the Application Name and Redirect URI fields
respectively.
In a non-admin user profile, the Application Name field contains the logged-in user name and is
non-editable.

6. Click Generate.

Creates and adds a new application to the My Apps & Tokens table.

The My Apps & Tokens table displays the following details:

n Token ID—Token ID of the application.
n User Name—Name of the user to whom this token is associated to. An application can be associated

to multiple users.
n Application—Name of the application to which this token is associated to. For example, Aruba

Central On-Premises.
n Generated At—The token generation date.
n Revoke Token—Click Revoke Token and click Yes to revoke the token associated to a particular

user. For example, if two users are associated to an application and if you want to remove access to a
particular user, revoke the token associated to that user.

n Download Token—Click Download Token to download the token.

Obtaining Token Using OAuth Grant Mechanism
The following section describes the steps to obtain the access token, and refresh the token using the
authorization code grant mechanism:

API calls limit is one API per second. This rate-limit is applicable only to the APIs in the first three steps
mentioned in the following procedure.
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Step 1: Authenticate a User and Create a User Session
The following API authenticates a user and returns a user session value. You can use the session value
to create future requests for a client with the specified username and password. As a prerequisite, you
must have a client ID for your application. For more information on how to create an application and
obtain tokens, see Creating Application and Token.

If user authentication is successful, the request will return HTTP code 200, and the response header will
include the following attributes.

Header Key Values Description

https://apigw-<FQDN of the Aruba Central On-Premises
instance>/oauth2/authorize/central/api/login?client_
id=<client_id>

csrftoken=xxxx;
session=xxxx

The server returns a CSRF
token and identifies the
user session. Use the
CSRF token and session
value for all subsequent
HTTP requests.

Table 234: Authentication and User session Response Codes

Example

Request Method: POST

URL: https://apigw-<FQDN of the Aruba Central On-Premises
instance>/oauth2/authorize/central/api/login?client_id=<client_id>

Host: apigw.central.arubanetworks.com

Request Header:

Accept: application/json

Content -Type: application/json

POST Request Body(JSON):
{

"username": "xxxxx",

"password": "xxxxx"

}

Error Response:
400: Bad Request

Response Body (JSON):
{

"extra": {},

"message": "<error string>"

}

401: Auth failure

Response Body (JSON):
{

"message": "Auth failure",

"status": false

}

429: API rate limit exceeded

Response Body (JSON):
{

"message": "API rate limit exceeded"

}

Success Response:
200: OK
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Response Body (JSON):
{

"status": true

}

Response Header:
Set-Cookie: csrftoken=xxxx;session=xxxx;

Use the csrf token value received in the successful response as a parameter for all subsequent POST/PUT
requests. Use the session value for all subsequent requests to maintain the user session context.

Step 2: [Optional] Generating Client Credentials
To generate client credentials, use the following URI and the request method.

Example

Request Method: POST

URI—https://apigw-<FQDN of the Aruba Central On-Premises instance>/central/api/client_
credentials?client_id=<client_id>

POST Request Body(JSON):
{

"customer_id": "<tenant_id>"

}

Request Header: (Values from login API request)

Set-Cookie: csrftoken=xxxx;session=xxxx;

Response Body(JSON):
{

"client_id": "<new-client-id>",

"client_secret": <new-client-secret>"

}

Error Response
429: API rate limit exceeded

Response Body (JSON):
{

"message": "API rate limit exceeded"

}

Step 3: Generate Authorization Code
After the user is authenticated and you have a valid session for that user, use this API to get an
authorization code. The authorization code is valid only for 5 minutes and you must exchange the
authorization code for a token within that time.

URL Description

https://apigw-<FQDN of the Aruba Central On-Premises
instance>/oauth2/authorize/central/api

The endpoint is a POST call to get an
authorization code.

Table 235: URL for to Generate an Authorization Code

Query parameters for this API are as follows.
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Parameter Values Description

client_id client_id is a unique hexadecimal string The client_id is a unique identifier that
identifies the caller. Application developers
obtain a client ID and a client secret when they
register with the API gateway admin.

response_type code Use code as the response type to get the
authorization code. You can exchange the
authorization code for a token.

scope all or read Requested API permissions may be either all
(for both read and write access) or read for
read-only access.

Table 236: Query Parameters for the Auth Code API

Example

Request Method: POST

URL: https://apigw-<FQDN of the Aruba Central On-Premises
instance>/oauth2/authorize/central/api/?client_id=<client_id>&response_type=code&scope=all HTTP/1.1

Host: apigw.central.arubanetworks.com

Request Header:

Accept: application/json Cookie: “session=xxxx” X-CSRF-Token: xxxx

Content -Type: application/json

POST Request Body(JSON):
{

"customer_id": "xxxxx"

}

Error Response:
400: Bad Request

Response Body (JSON):
{

"extra": {},

"message": "<error string>"

}

401: Auth failure

Response Body (JSON):
{

"message": "Auth failure",

"status": false

}

429: API rate limit exceeded

Response Body (JSON):
{

"message": "API rate limit exceeded"

}

Success Response:
200: OK

Response Body (JSON):
{

" auth_code ": “xxxx”

}
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The request is rejected if you do not pass the csrf-token value that you obtained in step one in the request
header. Note the auth_code value in the response, as you will use this code to obtain an OAuth token.

Response Header:
Set-Cookie: csrftoken=xxxx;session=xxxx;

Step 4: Exchange Auth Code for a Token
After you have an authorization code, you use the code to request access from the server. The
exchange must be done within 300 seconds of obtaining the auth code in the previous step. If the
exchange is not done withing 300 seconds, the API will return an error.

URL Description

https://apigw-<FQDN of the Aruba Central On-Premises
instance>/oauth2/token

The endpoint is a POST call to get an access token
using the authorization code obtained from the
server.

Table 237: URL for to Generate an Auth Token

Query parameters for this API are as follows.

Parameter Values Description

client_id client_id is a unique hexadecimal string The client_id is a unique identifier that identifies
the caller. Application developers obtain a client
ID and a client secret when they register with the
API gateway admin.

client_secret client_secret is a unique hexadecimal
string

The client_secret is a unique identifier provided
to each developer at the time of registration.
Application developers can obtain a client ID and
client secret when they register with the API
gateway admin.

grant_type authorization_ code Use the code to get the authorization code. You
can use the authorization code to exchange for
the token.

code auth_code received in step one The authorization code received from the
authorization server.

redirect_uri string The redirect URI must be the same as the one
given at the time of registration. The redirect_uri
is an optional parameter.

Table 238: Query Parameters for the Auth Code API

The response to this API query is a JSON dictionary with the following values.

Parameter Values Description

token_type bearer Identifies the token type. Central supports only the
bearer token type (See
https://tools.ietf.org/html/rfc6750)

Table 239: Auth Token Values
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Parameter Values Description

refresh_token string Refresh tokens are credentials used to renew or
refresh the access_token when it expires without
repeating the complete authentication flow. A refresh
token is a string representing the authorization
granted to the client by the resource owner.

expires_in seconds The lifetime, in seconds, of the access token.

access_token string Access tokens are credentials used to access
protected resources. An access token is a string
representing an authorization issued to the client.

Example

Request Method: POST

URL: https://apigw-<FQDN of the Aruba Central On-Premises instance>/oauth2/token\

Content -Type: application/json

Body Parameters: Enter the parameter values to call the API.

n client_id
n client_secret
n grant_type
n code

Response:
{

"refresh_token": "xxxx",

"token_type": "bearer",

"access_token": "xxxx",

"expires_in": 7200

}

Step 5: Refreshing a Token
You can update the access token without having to repeat the authentication process by using the
refresh token obtained in the previous step. The following list are some of the important points to note:

n A token created on Central API Gateway contains access and refresh tokens, and is available for 15
days.

n An access token is valid for 2 hours (7200 seconds).
n If the token is not used or refreshed for a period of 15 days, it is revoked from Central API Gateway.
n After a token is revoked, you have to add or generate a new token through the API Gateway.
n It is recommended to refresh the access token when it is invalid or at least once within 15 days so

that Central can honor refreshing the token and does not revoke it.
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URL Description

https://apigw-<FQDN of
the Aruba Central On-
Premises
instance>/oauth2/token

The endpoint is a POST call to refresh the access token using the refresh token
obtained from the server.

Table 240: URL to Refresh a Token

Query parameters for this API are as follows.

Parameter Value Description

client_id client_id is a unique hexadecimal
string

The client_id is a unique identifier that identifies the
caller. Application developers obtain a client ID and a
client secret when they register with the API gateway
admin.

client_secret client_secret is a unique
hexadecimal string

The client_secret is a unique identifier provided to
each developer at the time of registration. Application
developers obtain a client ID and a client secret when
they register with the API gateway admin.

grant_type refresh_token Specify refresh_token as the grant type to request
that an authorization code be exchanged for a token.

refresh_token string A string representing the authorization granted to the
client by the resource owner.

Table 241: Query Parameters for Refresh Tokens

The response to this API query is a JSON dictionary with the following values.

Parameter Value Description

token_type bearer Identifies the token type. Only the bearer token type is supported. For
more information, see https://tools.ietf.org/html/rfc6750.

refresh_token string Refresh tokens are credentials used to renew or refresh the access
token when it expires without going through the complete
authorization flow. A refresh token is a string representing the
authorization granted to the client by the resource owner.

expires_in seconds The expiration duration of the access tokens in seconds.

access_token string Access tokens are credentials used to access the protected resources.
An access token is a string representing an authorization issued to the
client.

Example

Method: POST

https: //apigw-<FQDN of the Aruba Central On-Premises instance>/oauth2/token?client_id=<Ccentral-
API-app-clientid>&client_secret=xxxx&grant_type=authorization_code&code=xxxx \

Response
{

"refresh_token": "xxxx",

https://tools.ietf.org/html/rfc6750
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"token_type": "bearer",

"access_token": "xxxx",

"expires_in": 7200

}

Step 6: Deleting a Token
To delete the access token, access the following URL.

URL Description

https://apigw-<FQDN of
the Aruba Central On-
Premises
instance>/oauth2/token

This endpoint is accessible over SSL. The HTTP (non-SSL) connections are
redirected to the SSL port. Customer ID is a string.

Table 242: URL to Delete a Token

Example

Method: DELETE

URL:https://apigw-<FQDN of the Aruba Central On-Premises instance>/oauth2/api/tokens

JSON Body:
{

"access_token": "<access_token_to_be_deleted>",

"customer_id": "<customer_id_to_whom_token_belongs_to>"

}

Headers:

Content-Type: application/json

X-CSRF-Token: <CSRF_token_obatained_from_login_API>

Cookie: "session=<session_obatained_from_login_API>"

Access APIs
To access the API, use the following URL:

https://apigw-<FQDN> of the Aruba Central instance>/.

This endpoint is accessible over SSL and the HTTP (non-SSL) connections are redirected to the SSL port.

URL Description

https://apigw-
<FQDN> of the
Aruba Central
instance>/.

The API gateway URL. All APIs can be accessed from this URL by providing a correct access
token.

Table 243: Accessing the API

The parameters for the API are as follows.
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Parameter Value Description

request_path URL Path URL path of an API,
for example, to
access monitoring
APIs, use the path
/monitoring/v1/aps.

Table 244: Parameters for the API

Header Value Description

Authorization Bearer ouzMaXEBbB6XqGtsWomK7MvaTuhrqDQ1 Pass the access
token in the
header.

Table 245: Header for the API

Example

Request Method: GET

https://apigw-<fqdn> of the Aruba Central instance>/monitoring/v1/aps

Request Header:

Authorization: Bearer ouzMaXEBbB6XqGtsWomK7MvaTuhrqDQ1

Response:

{

"aps": [

{

"firmware_version": "6.4.4.4-4.2.3.1_54637",

"group_name": "00TestVRK",

"ip_address": "10.29.18.195",

"labels": [

"Filter_242",

"Ziaomof",

"roster",

"242455",

"Diegso"

],

"macaddr": "6c:f3:7f:c3:5d:92",

"model": "AP-134",

"name": "6c:f3:7f:c3:5d:92",

"radios": [

{

"band": 0,

"index": 1,

"macaddr": "6c:f3:7f:b5:d9:20",

"status": "Down"

},

{

"band": 1,

"index": 0,

"macaddr": "6c:f3:7f:b5:d9:30",

"status": "Down"

}

],

"serial": "AX0140586",
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"status": "Down",

"swarm_id": "e3bf1ba201a6f85f4b5eaedeead5e502d85a9aef58d8e1d8a0",

"swarm_master": true

}

],

"count": 1

}

Viewing and Revoking Tokens
To view or revoke tokens, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization > Platform Integration > Rest API.

Displays the API Gateway page.

3. Click My Apps & Tokens. The Token List table displays the following:
n Token ID—Token ID of the application.
n User Name—Name of the user to whom this token is associated. An application can be

associated to multiple users.
n Application—Name of the application to which this token is associated. For example, Aruba

Central.
n Generated At—Token generated date and time.
n Revoke Token—Click Revoke Token and click Yes to revoke the token associated to a

particular user. For example, if two users are associated to an application and if you want to
remove access to a particular user, revoke the token associated to that user.

n Download Token—Click Download Token to download the token.

The admin user has a System Apps & Tokens tab which displays all the apps and tokens generated in all non-
admin user profiles and admin user profile. To view all the tokens of admin and non-admin users, go to
Organization > Platform Integration > Rest API > System Apps & Tokens.

Adding a New Token
To add a new token, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization > Platform Integration > Rest API.

The API Gateway page is displayed.

3. Click My Apps & Tokens. The Token List table displays the following:
n Token ID—Token ID of the application.
n User Name—Name of the user to whom this token is associated to. An application can be

associated to multiple users.
n Application—Name of the application to which this token is associated to. For example, Aruba

Central.
n Generated At—Date on which the token was generated.
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n Revoke Token—Click Revoke Token and click Yes to revoke the token associated to a
particular user. For example, if two users are associated to an application and if you want to
remove access to a particular user, revoke the token associated to that user.

n Download Token—Click Download Token to download the token.

The user with Aruba Central Administrator role can create new tokens for all non-admin users by clicking +
Add Apps & Tokens in the System Apps & Tokens tab.

4. Click + Add Apps & Tokens to add a new token.
5. Enter the application name in the Application Name box and click Generate.

If you have registered a custom URI when creating a new app under System Apps and Tokens, the Redirect
URI option is disabled for you in the My Apps and Tokens > + Add Apps & Tokens > New Token. In such
cases, the Redirect URI option in + Add Apps & Tokens > New Token under My Apps and Tokens
populates the registered URI.

Viewing Usage Statistics
The API Gateway page includes the Usage tab that displays the API usage. The Usage tab is available
only for users with Aruba Central On-Premises Administrator role and the usage data is stored only
for the previous 30 days. The following details are displayed:

n Current Usage
n Last one week API usage data
n Per user usage.

To view the usage statistics for users of API Gateway, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization > Platform Integration > Rest API.

The API Gateway page with the list of published APIs is displayed.

3. Click Usage. The following details are displayed:
a. Current usage—Current usage of API calls assigned for a day along with the reset time in

local time zone.
b. Last one week API usage data:

n Date—Date of usage.
n API Calls Per Day—Number of API calls made on a specific date.
n Usage Rate—Percentage of API calls made compared to the total API calls available on a

specific date.
n Success—Percentage of successful API calls made on a specific date.
n Failed—Percentage of unsuccessful API calls made on a specific date including rate-

limited calls per day.
n Rate-Limited—Number of API calls failed because of exceeding the daily or per-second

rate limit.
n Read(GET)—Percentage of read API calls made on a specific date.
n Write (POST/PATCH/PUT/DELETE)—Percentage of write API calls made on a specific date.
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c. Top 10 API Endpoints (Last 7 days):
n Methord—Type of API call
n API Path—The API path, for example GET/visualrf_api/v1/floor/{floor_id}.
n Count—Number of times the API was called in the past seven days.

d. Per User Usage:
n User—User id information.
n Date—Date on which the user accessed the application.
n API Calls/Day—Number of API calls made by the user on a specific date.
n Usage Rate—Percentage of API calls made by the user compared to the total API calls

available on a specific date.
n Success—Percentage of successful API calls made by the user on a specific date.
n Failed—Percentage of unsuccessful API calls made by the user, including the rate-limited

calls on a specific date.
n Rate-Limited—Number of API calls failed because the user exceeded the daily or per-

second rate limit.
n Read—Percentage of read API calls made by the user on a specific date.
n Write—Percentage of write API calls made by the user on a specific date.

4. To download the API gateway usage statistics, click Download CSV icon.

API calls are limited to 150000 calls per day.

Changes to Aruba Central On-Premises APIs
The Swagger interface lists all the APIs that are managed through Aruba Central On-Premises. For more
information on how to access the swagger interface, see Viewing Swagger Interface. Once you gain
access to the Aruba Central On-Premises APIs from swagger, select one of the services from the URL
drop-down list. The URL allows you to access all the services and their respective APIs that are managed
through Aruba Central On-Premises. For example, to try out the monitoring service APIs, select the
Monitoring service from the URL drop-down list and select one of the respective APIs under API
Reference.

This section lists the new APIs, deprecated APIs, alternative APIs, and APIs removed from Aruba Central:

n New APIs
n Modified API
n Deprecated API
n Removed APIs

New APIs
The following table lists the new APIs.

New API Description

Service RAPIDS > Aruba Rapids
For more information on classification criteria, see Configuring RAPIDS.

Table 246: New APIs



API Gateway | 1059

New API Description

n [GET] /rapids-config/v1/node_list/{node_type}/
{node_id}/config/

This API is introduced to fetch the complete global
RAPIDS configuration.

n [POST] /rapids-config/v1/node_list/{node_type}/
{node_id}/config/

This API is introduced to create a complete global
RAPIDS configuration.

n [PUT] /rapids-config/v1/node_list/{node_type}/
{node_id}/config/

This API is introduced to update a complete global
RAPIDS configuration.

n [DELETE] /rapids-config/v1/node_list/{node_
type}/{node_id}/config/

This API is introduced to delete a complete global
RAPIDS configuration.

n [GET] /rapids-config/v1/node_list/{node_type}/
{node_id}/config/classification_rule/

This API is introduced to fetch all classification rules.

n [GET] /rapids-config/v1/node_list/{node_type}/
{node_id}/config/classification_rule/{rule_
name}/

This API is introduced to fetch information on a
classification rule by rule_name.

n [POST] /rapids-config/v1/node_list/{node_type}/
{node_id}/config/classification_rule/{rule_
name}/

This API is introduced to create a classification rule by
rule_name.

n [PUT] /rapids-config/v1/node_list/{node_type}/
{node_id}/config/classification_rule/{rule_
name}/

This API is introduced to create or modify a
classification rule by rule_name.

n [DELETE] /rapids-config/v1/node_list/{node_
type}/{node_id}/config/classification_rule/
{rule_name}/

This API is introduced to delete a classification rule by
rule_name.

n [GET] /rapids-config/v1/node_list/{node_type}/
{node_id}/config/classification_rule/{rule_
name}/match_criteria/

This API is introduced to fetch information of match_
criteria for a given classification rule_name.

n [POST] /rapids-config/v1/node_list/{node_type}/
{node_id}/config/classification_rule/{rule_
name}/match_criteria/

This API is introduced to create a match_criteria for a
given classification rule_name.

n [PUT] /rapids-config/v1/node_list/{node_type}/
{node_id}/config/classification_rule/{rule_
name}/match_criteria/

This API is introduced to create or update a match_
criteria for a given classification rule_name.

n [DELETE] /rapids-config/v1/node_list/{node_
type}/{node_id}/config/classification_rule/
{rule_name}/match_criteria/

This API is introduced to delete all match_criteria for
a given classification rule_name.

Table 246: New APIs
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New API Description

n [GET] /rapids-config/v1/node_list/{node_type}/
{node_id}/config/classification_rules/{rule_
name}/match_criteria/site_excludes/

This API is introduced to fetch information for all sites
in the site-excludes list for a given classification rule_
name.

n [GET] /rapids-config/v1/node_list/{node_type}/
{node_id}/config/classification_rules/{rule_
name}/match_criteria/site_excludes/{name}/

This API is introduced to fetch information of a site by
name in the site-excludes list for a given classification
rule_name.

n [PUT] /rapids-config/v1/node_list/{node_type}/
{node_id}/config/classification_rules/{rule_
name}/match_criteria/site_excludes/{name}/

This API is introduced to create or update a site by
name in the site-excludes list for a given classification
rule_name.

NOTE: The same site must not be specified in both
site_includes and site_excludes API.

n [POST] /rapids-config/v1/node_list/{node_type}/
{node_id}/config/classification_rules/{rule_
name}/match_criteria/site_excludes/{name}/

This API is introduced to create sites by name in the
site-excludes list for a given classification rule_name.

NOTE: The same site must not be specified in both
site_includes and site_excludes API.

n [DELETE] /rapids-config/v1/node_list/{node_
type}/{node_id}/config/classification_rules/
{rule_name}/match_criteria/site_excludes/
{name}/

This API is introduced to delete sites by name in the
site-excludes list for a given classification rule_name.

NOTE: The same site must not be specified in both
site_includes and site_excludes API.

n [GET] /rapids-config/v1/node_list/{node_type}/
{node_id}/config/classification_rules/{rule_
name}/match_criteria/site_includes/

This API is introduced to fetch information for all sites
in the site-Includes list for a given classification rule_
name.

n [GET] /rapids-config/v1/node_list/{node_type}/
{node_id}/config/classification_rules/{rule_
name}/match_criteria/site_includes/{name}/

This API is introduced to fetch information of sites by
name in the site-includes list for a given classification
rule_name.

n [PUT] /rapids-config/v1/node_list/{node_type}/
{node_id}/config/classification_rules/{rule_
name}/match_criteria/site_includes/{name}/

This API is introduced to create or update sites by
name in the site-includes list for a given classification
rule_name.

NOTE: The same site must not be specified in both
site_includes and site_excludes API.

n [POST] /rapids-config/v1/node_list/{node_type}/
{node_id}/config/classification_rules/{rule_
name}/match_criteria/site_includes/{name}/

This API is introduced to create sites by name in the
site-includes list for a given classification rule_name.

NOTE: The same site must not be specified in both
site_includes and site_excludes API.

n [DELETE] /rapids-config/v1/node_list/{node_ This API is introduced to delete sites by name in the
site-includes list for a given classification rule_name.

Table 246: New APIs
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New API Description

type}/{node_id}/config/classification_rules/
{rule_name}/match_criteria/site_includes/
{name}/

NOTE: The same site must not be specified in both
site_includes and site_excludes API.

n [GET] /rapids-config/v1/node_list/{node_type}/
{node_id}/config/classification_rules/{rule_
name}/match_criteria/ssid_excludes/

This API is introduced to fetch information for all SSIDs
in the ssid_excludes list for a given classification rule_
name.

n [GET] /rapids-config/v1/node_list/{node_type}/
{node_id}/config/classification_rules/{rule_
name}/match_criteria/ssid_excludes/{essid}/

This API is introduced to fetch information of an ESSID
in the ssid_excludes list for a given classification rule_
name.

n [POST] /rapids-config/v1/node_list/{node_type}/
{node_id}/config/classification_rules/{rule_
name}/match_criteria/ssid_excludes/{essid}/

This API is introduced to create an ESSID in the ssid_
excludes list for a given classification rule_name.

n [PUT] /rapids-config/v1/node_list/{node_type}/
{node_id}/config/classification_rules/{rule_
name}/match_criteria/ssid_excludes/{essid}/

This API is introduced to create or update an ESSID in
the ssid_excludes list for a given classification rule_
name.

n [DELETE] /rapids-config/v1/node_list/{node_
type}/{node_id}/config/classification_rules/
{rule_name}/match_criteria/ssid_excludes/
{essid}/

This API is introduced to deleted an ESSID in the ssid_
excludes list for a given classification rule_name.

n [GET] /rapids-config/v1/node_list/{node_type}/
{node_id}/config/classification_rules/{rule_
name}/match_criteria/ssid_includes/

This API is introduced to fetch information all SSIDs in
the ssid_includes list for a given classification rule_
name.

n [GET] /rapids-config/v1/node_list/{node_type}/
{node_id}/config/classification_rules/{rule_
name}/match_criteria/ssid_includes/{essid}/

This API is introduced to fetch information of an ESSID
in the ssid_includes list for a given classification rule_
name.

n [POST] /rapids-config/v1/node_list/{node_type}/
{node_id}/config/classification_rules/{rule_
name}/match_criteria/ssid_includes/{essid}/

This API is introduced to create an ESSID in the ssid_
includes list for a given classification rule_name.

n [PUT] /rapids-config/v1/node_list/{node_type}/
{node_id}/config/classification_rules/{rule_
name}/match_criteria/ssid_includes/{essid}/

This API is introduced to create or update an ESSID in
the ssid_includes list for a given classification rule_
name.

n [DELETE] /rapids-config/v1/node_list/{node_
type}/{node_id}/config/classification_rules/
{rule_name}/match_criteria/ssid_includes/
{essid}/

This API is introduced to deleted an ESSID in the ssid_
includes list for a given classification rule_name.

VisualRF > GeoFence

Table 246: New APIs
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New API Description

GeoFence is a virtual perimeter surrounding a physical location.

n [GET] /visualrf_api/v1/geofence This API is introduced to get the status of the
GeoFence feature.

n [POST] /visualrf_api/v1/geofence This API is introduced to enable the GeoFence feature

n [DELETE] /visualrf_api/v1/geofence This API is introduced to disable the GeoFence feature.

Table 246: New APIs

To view the APIs introduced in previous releases, see APIs Introduced In Previous Releases.

Modified API
The following table lists the modified APIs.

Modified API Description

Configuration > Certificates

n [POST] /configuration/v1/certificates
n [PUT] /configuration/v1/msp/certificate

The string entered in the passphrase parameter is
encoded with base64 encoding scheme.

n [PUT] /configuration/v1/non_msp/certificate This API is used to update certificates for non MSP
customers.
The string entered in the passphrase parameter is
encoded with base64 encoding scheme.

Configuration > Device

n [GET] /configuration/v1/devices/{device_
serial}/group

n [GET] /configuration/v1/devices/{device_
serial}/configuration

n [GET] /configuration/v1/devices/{device_
serial}/config_details

n [GET] /configuration/v1/devices/{device_
serial}/variablised_template

A user can fetch device information using these APIs if
the following criteria are fulfilled:
n Built-In role or custom role assigned to the user

must have View access to the NMS Service
Configuration application. If user is assigned with
Aruba CentralAdministrator built-in role, then
the user has View and Edit access to all Aruba
Central applications.

n User must be assigned with a group set having at
least one group scope or allgroup. To assign a
group set, toggle the switch next to Limit
Resource Access and select the group set from
the Resource Restriction Policy* drop-down list.

NOTE: Group set must be assigned to a role (built-
in role or custom role). If Limit Resource Access
is not enabled, then by default all the groups are
assigned to the user role.

Table 247: Modified APIs
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Modified API Description

n The serial number entered in the device_serial
field must belong to a group scope that is part of
the group set assigned to the user.

For more information on managing users and roles in
the HPE GreenLake portal, see Identity & Access
section in the HPE GreenLake Edge to Cloud Platform
User Guide.

Configuration > MM-MD

n [POST] /configuration/v1/devices/{device_
serial}/recover_device

A user can fetch device information using these APIs if
the following criteria are fulfilled:
n Built-In role or custom role assigned to the user

must have Edit access to the NMS Service
Configuration application. If user is assigned with
Aruba CentralAdministrator Built-In role, then
the user has View and Edit access to all Aruba
Central applications.

n User must be assigned with a group set having at
least one group scope or allgroup. To assign a
group set, toggle the switch next to Limit
Resource Access and select the group set from
the Resource Restriction Policy* drop-down list.

NOTE: Group set must be assigned to a role (Built-
In role or Custom role). If Limit Resource Access
is not enabled, then by default all groups are
assigned to the user.

n The serial number entered in the device_serial
field must belong to a group scope that is part of
the group set assigned to the user.

For more information on managing users and roles in
the HPE GreenLake portal, see Identity & Access
section in the HPE GreenLake Edge to Cloud Platform
User Guide.

Configuration > WLAN Configuration

n [POST] /configuration/v2/wlan/{group_name_
or_guid_or_serial_number}/{wlan_name}

n [PUT] /configuration/v2/wlan/{group_name_or_
guid_or_serial_number}/{wlan_name}

n [PATCH] /configuration/v2/wlan/{group_name_
or_guid_or_serial_number}/{wlan_name}

The APIs are updated to support Enhanced Open
Authentication.
Enhanced Open Authentication provides improved
data encryption in open Wi-Fi networks and protects
data from sniffing attacks. To set the SSID to Enhanced
Open mode, configure the following:
n Keep the wpa_passphrase parameter value empty
n Set the wpa_passphrase_changed parameter

value to true
n Set the type to employee

Firmware
AOS-CX switches now support the following APIs in the Firmware category.

Table 247: Modified APIs

https://support.hpe.com/hpesc/public/docDisplay?docId=a00120892en_us
https://support.hpe.com/hpesc/public/docDisplay?docId=a00120892en_us
https://support.hpe.com/hpesc/public/docDisplay?docId=a00120892en_us
https://support.hpe.com/hpesc/public/docDisplay?docId=a00120892en_us
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Modified API Description

n [GET] /firmware/v1/devices
n [GET] /firmware/v1/devices/{serial}
n [GET] /firmware/v1/versions
n [GET] /firmware/v1/versions/{firmware_

version}
n [GET] /firmware/v1/status
n [POST] /firmware/v1/upgrade
n [POST] /firmware/v1/upgrade/cancel
n [GET] /firmware/v2/upgrade/compliance_

version
n [DELETE] /firmware/v2/upgrade/compliance_

version
n [GET] /firmware/v1/upgrade/compliance_

version
n [POST] /firmware/v1/upgrade/compliance_

version
n [POST] /firmware/v1/msp/upgrade
n [POST] /firmware/v1/msp/upgrade/customers/

{customer_id}
n [POST] /firmware/v1/msp/upgrade/cancel
n [POST] /firmware/v1/msp/upgrade/customers/

{customer_id}/cancel
n [POST] /firmware/v2/msp/upgrade/cancel
n [POST] /firmware/v2/msp/upgrade/customers/

{customer_id}/cancel
n [GET] /firmware/v1/models
n [DELETE]

/firmware/v1/msp/upgrade/compliance_
version

n [GET] /firmware/v1/msp/upgrade/compliance_
version

n [POST]
/firmware/v1/msp/upgrade/compliance_
version

n [DELETE]
/firmware/v1/msp/upgrade/customers/
{customer_id}/compliance_version

n [GET] /firmware/v1/msp/upgrade/customers/
{customer_id}/compliance_version

n [POST] /firmware/v1/msp/upgrade/customers/
{customer_id}/compliance_version

n [GET] /firmware/v1/msp/tenants/{tenant_id}

These APIs are modified to extend support on AOS-CX
switches.

Monitoring > AP

n [GET] /monitoring/v2/aps/
n [GET] /monitoring/v1/aps/{serial}

In the response body, a new parameter controller_
ap_group is introduced.

Table 247: Modified APIs
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Modified API Description

The controller_ap_group displays the name of the
controller group to which the Campus APs and
Remote APs are assigned.

NOTE: Instant Access Points are not connected to a
controller. As a result, the controller_ap_group field
does not display any information.

Monitoring > Switch
Monitoring > Gateway
Using the APIs, a user can fetch Switch or Gateway related information if the following criteria are fulfilled:
n Built-In role or Custom role must have at least View access for the NMS Service application. If user is

assigned with Aruba CentralAdministrator Built-In role, then the user has View and Edit access to all
Aruba Central applications.

n Input parameters such as device serial number, group name, label name, etc., must belong to a group scope
that is part of the group set assigned to the user. To assign a group set, toggle the switch next to Limit
Resource Access and select a Resource Restriction Policy* drop-down list.

NOTE: Group set must be assigned to a role (Built-In role or Custom role). If Limit Resource Access is not
enabled, then by default all groups are assigned to the user role.

For more information on managing users and roles in the HPE GreenLake portal, see Identity & Access section
in the HPE GreenLake Edge to Cloud Platform User Guide.

New Device Inventory > Devices

n [GET] /platform/device_inventory/v1/devices A new parameter subscription_key is added to the
response sample.
The subscription_key parameter displays the
subscription key information to which the device is
assigned.

New Licensing

n [GET] /platform/licensing/v1/subscriptions New filter parameters subscription_key and

device_type are added.
n subscription_key—Enter the subscription key

information. The response will display the
following:
o Total—Displays the total number of devices that

can associate with the subscription key.
o Available—Displays the number of devices that

can associate with the subscription key based
on the current usage.

n device_type—Select the device type from the
drop-down list.

Table 247: Modified APIs

To view the APIs modified in previous releases, see APIs Modified In Previous Releases.

https://support.hpe.com/hpesc/public/docDisplay?docId=a00120892en_us
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Deprecated API
The following table lists the APIs that have been deprecated. These APIs will continue to function but
could be removed in a future release. Aruba Central On-Premises strongly discourages the use of these
APIs and recommends that you use the alternative API.
APIs deprecated as part of Aruba Central On-Premises 2.5.7 release:
No deprecated APIs in Aruba Central On-Premises 2.5.7 release.
APIs deprecated as part of Aruba Central On-Premises 2.5.6 release:
No deprecated APIs in Aruba Central On-Premises 2.5.6 release.
APIs deprecated as part of Aruba Central On-Premises 2.5.5 release:

Modified API Description

Configuration > Pre Provisioned Group

[POST] /device_
management/v1/group/assign

NA

Table 248: Deprecated APIs in Aruba Central On-Premises 2.5.5 release

Removed APIs
The following table lists the APIs that have been removed and the alternative APIs:
APIs removed as part of Aruba Central On-Premises 2.5.7 release:
No APIs removed in Aruba Central On-Premises 2.5.7 release.

Deprecated API Alternative API

Rapids > SSIDs
The list of APIs in Rapids > SSIDs are removed. You can now configure RAPIDS from the RAPIDS
configuration page. For more information, see Configuring RAPIDS.

n [GET] /rapids/v1/ssid_allow
n [POST] /rapids/v1/ssid_allow
n [DELETE] /rapids/v1/ssid_allow
n [GET] /rapids/v1/ssid_block
n [POST] /rapids/v1/ssid_block
n [DELETE] /rapids/v1/ssid_block

-

APIs removed as part of Aruba Central On-Premises 2.5.6 release:

Removed API Alternative API

Service Cloud Security

n [GET] /cloud-security-
config/v1/node_list/

No alternate API

n [GET] /cloud-security-
config/v1/node_list/{node_type}/

No alternate API

Table 249: Removed and Alternative APIs in Aruba Central On-Premises 2.5.6 release
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Removed API Alternative API

{node_id}/config/

n [GET] /cloud-security-
config/v1/node_list/{node_type}/
{node_id}/config/zscaler/

No alternate API.

Table 249: Removed and Alternative APIs in Aruba Central On-Premises 2.5.6 release

APIs Introduced In Previous Releases
The section list the APIs introduced in the previous releases of Aruba Central On-Premises.
Aruba Central On-Premises 2.5.6

New API

Client Match

n [GET] /bandsteer-6ghz-enable/v1/{tenant_id}

n [POST] /bandsteer-6ghz-enable/v1/{tenant_id}

Configuration > AOS-S

n [GET]/configuration/v1/aos_switch/system/groups/{group_name}

n [PUT] /configuration/v1/aos_switch/system/groups/{group_name}

n [GET] /configuration/v1/aos_switch/system/devices/{device_serial}

n [PUT] /configuration/v1/aos_switch/system/devices/{device_serial}

n [GET] /configuration/v1/aos_switch/system_time/groups/{group_
name}

n [PUT] /configuration/v1/aos_switch/system_time/groups/{group_
name}

n [GET] /configuration/v1/aos_switch/system_time/devices/{device_
serial}

Configuration > AP Configuration

n [GET] /configuration/v1/group/ssh_credential/{group_name}

n [POST] /configuration/v1/group/ssh_credential/{group_name}

n [GET] /configuration/v1/device/ssh_credential/{serial_number_or_
guid}

n [POST] /configuration/v1/device/ssh_credential/{serial_number_or_

Table 250: New APIs in Aruba Central On-Premises 2.5.6 release
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New API

guid}

Configuration > CX Configuration

n [GET] /configuration/v1/switch/cx/port-access-auth

n [POST] /configuration/v1/switch/cx/port-access-auth

Service Airgroup

n [DELETE] /airgroup-config/v2/custom_services/{name}/service_ids/
{service_id}/

n [GET] /airgroup-config/v2/custom_services/{name}/service_ids/
{service_id}/

n [POST] /airgroup-config/v2/custom_services/{name}/service_ids/
{service_id}/

n [PUT] /airgroup-config/v2/custom_services/{name}/service_ids/
{service_id}/

n [GET] /airgroup-config/v2/custom_services/{name}/service_ids/

n [DELETE] /airgroup-config/v2/custom_services/{name}/

n [GET] /airgroup-config/v2/custom_services/{name}/

n [POST] /airgroup-config/v2/custom_services/{name}/

n [PUT] /airgroup-config/v2/custom_services/{name}/

n [GET] /airgroup-config/v2/custom_services/

VisualRF > Import

n [POST] /visualrf_api/v1/restore_sites

n [GET] /visualrf_api/v1/restore_sites/status

VisualRF > Anonymization

n [DELETE] /visualrf_api/v1/anonymization

n [GET] /visualrf_api/v1/anonymization

n [POST] /visualrf_api/v1/anonymization

Table 250: New APIs in Aruba Central On-Premises 2.5.6 release

Aruba Central On-Premises 2.5.5
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New API

Configuration > AOS-S

n [GET] /configuration/v1/aos_switch/ports/groups/{group_name}

n [GET] /configuration/v1/aos_switch/ports/devices/{device_serial}

n [GET] /configuration/v1/aos_switch/vlans/groups/{group_name}

n [GET] /configuration/v1/aos_switch/vlans/devices/{device_serial}

n [PUT] /configuration/v1/aos_switch/ports/groups/{group_name}

n [PUT] /configuration/v1/aos_switch/ports/devices/{device_serial}

n [PUT] /configuration/v1/aos_switch/vlans/groups/{group_name}

n [PUT] /configuration/v1/aos_switch/vlans/devices/{device_serial}

Configuration > Pre Provisioned Group

n [POST] /configuration/v1/preassign

Table 251: New APIs in Aruba Central On-Premises 2.5.5 release

Aruba Central On-Premises 2.5.4

New API

AI OPs > AI Insights Details

n [GET] /aiops/v2/insights/global/id/{insight_id}/export

n [GET] /aiops/v2/insights/site/{site_id}/id/{insight_id}/export

n [GET] /aiops/v2/insights/ap/{ap_serial}/id/{insight_id}/export

n [GET] /aiops/v2/insights/client/{sta_mac}/id/{insight_id}/export

n [GET] /aiops/v2/insights/gateway/{gw_serial}/id/{insight_id}/export

n [GET] /aiops/v2/insights/switch/{sw_serial}/id/{insight_id}/export

AI OPs > AI Insights List

n [GET] /aiops/v2/insights/global/list

n [GET] /aiops/v2/insights/site/{site_id}/list

n [GET] /aiops/v2/insights/ap/{ap_serial}/list
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New API

n [GET] /aiops/v2/insights/client/{sta_mac}/list

n [GET] /aiops/v2/insights/gateway/{gw_serial}/list

n [GET] /aiops/v2/insights/switch/{sw_serial}/list

AI OPs > Wi-Fi Connectivity at Global

n [GET] /aiops/v1/connectivity/global/stage/{stage}/export

n [GET] /aiops/v1/connectivity/site/{site_id}/stage/{stage}/export

n [GET] /aiops/v1/connectivity/group/{group}/stage/{stage}/export

Authentication & Policy > Client Policy

n [GET] /client_policy

n [DELETE] /client_policy

n [PUT] /client_policy

Authentication & Policy > Client Registration

n [GET] /client_registration

n [DELETE] /client_registration/{mac_address}

n [POST] /client_registration

n [PATCH] /client_registration/{mac_address}

Authentication & Policy > User policy

n [GET] /user_policy

n [DELETE] /user_policy

n [PUT] /user_policy

Configuration > WLAN Configuration

n [GET] /configuration/full_hotspot/{group_name_or_guid}

n [GET] /configuration/full_hotspot/{group_name_or_guid}/{mode_
name}

n [GET] /configuration/full_hotspot/{group_name_or_guid}/template

n [GET] /configuration/full_hotspot/{group_name_or_guid}/{hotspot_
name}/{mode_name}



API Gateway | 1071

New API

n [DELETE] /configuration/full_hotspot/{group_name_or_guid}/
{hotspot_name}/{mode_name}

n [POST] /configuration/full_hotspot/{group_name_or_guid}/{hotspot_
name}/{mode_name}

n [PUT] /configuration/full_hotspot/{group_name_or_guid}/{hotspot_
name}/{mode_name}

Monitoring > Clients

n [GET] /monitoring/v2/clients

n [GET] /monitoring/v2/clients/{macaddr}

Service IPMS > Aruba ipms

n [GET] /ipms-config/v1/node_list/{node_type}/{node_
id}/config/address_pool/{pool_name}/ip_range/

n [GET] /ipms-config/v1/node_list/{node_type}/{node_id}/config/

n [GET] /ipms-config/v1/node_list/{node_type}/{node_
id}/config/address_pool/

n [GET] /ipms-config/v1/node_list/{node_type}/{node_
id}/config/address_pool/{pool_name}/

n [GET] /ipms-config/v1/node_list/{node_type}/{node_
id}/config/address_pool/{pool_name}/ip_range/{range_id}/

n [GET] /ipms-config/v1/node_list/{node_type}/{node_id}/

n [DELETE] /ipms-config/v1/node_list/{node_type}/{node_id}/config/

n [DELETE] /ipms-config/v1/node_list/{node_type}/{node_
id}/config/address_pool/{pool_name}/

n [DELETE] /ipms-config/v1/node_list/{node_type}/{node_
id}/config/address_pool/{pool_name}/ip_range/{range_id}/

n [POST] /ipms-config/v1/node_list/{node_type}/{node_
id}/config/address_pool/{pool_name}/

n [POST] /ipms-config/v1/node_list/{node_type}/{node_
id}/config/address_pool/{pool_name}/ip_range/{range_id}/

n [PUT] /ipms-config/v1/node_list/{node_type}/{node_
id}/config/address_pool/{pool_name}/
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New API

n [PUT] /ipms-config/v1/node_list/{node_type}/{node_
id}/config/address_pool/{pool_name}/ip_range/{range_id}/

Troubleshooting

n [GET] /troubleshooting/v1/running-config-backup/serial/{serial}

n [GET] /troubleshooting/v1/running-config-backup/serial/
{serial}/prefix/{prefix}

n [GET] /troubleshooting/v1/running-config-backup/name/{name}

n [POST] /troubleshooting/v1/running-config-backup/serial/
{serial}/prefix/{prefix}

n [POST] /troubleshooting/v1/running-config-backup/group_name/
{group_name}/prefix/{prefix}

APIs Modified In Previous Releases
The section list the APIs modified in the previous releases of Aruba Central On-Premises.
Aruba Central On-Premises 2.5.6

Modified API

VisualRF > Client Location

n [GET] /visualrf_api/v1/floor/{floor_id}/client_location

n [GET] /visualrf_api/v1/client_location/{macaddr}
n [GET] /visualrf_api/v1/floor/{floor_id}/client_location

VisualRF > Rogue Location

n [GET] /visualrf_api/v1/floor/{floor_id}/rogue_location

n [GET] /visualrf_api/v1/rogue_location/{macaddr}
n [GET] /visualrf_api/v1/floor/{floor_id}/rogue_location

VisualRF > Floorplan

n [GET] /visualrf_api/v1/campus
n [GET] /visualrf_api/v1/campus/{campus_id}

User Management> Roles

n [GET] /platform/rbac/v1/roles
n [DELETE] /platform/rbac/v1/apps/{app_name}/roles/{rolename}
n [GET] /platform/rbac/v1/apps/{app_name}/roles/{rolename}

Table 252: Modified APIs in Aruba Central On-Premises 2.5.6 release
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Modified API

n [PATCH] /platform/rbac/v1/apps/{app_name}/roles/{rolename}
n [POST] /platform/rbac/v1/apps/{app_name}/roles

Service Airmatch

n [GET] /airmatch-config/v1/node_list/{node_type}/{node_
id}/config/system/

n [POST] /airmatch-config/v1/node_list/{node_type}/{node_
id}/config/system/

n [PUT] /airmatch-config/v1/node_list/{node_type}/{node_
id}/config/system/

n [GET] /airmatch-config/v1/node_list/{node_type}/{node_id}/config/
n [POST] /airmatch-config/v1/node_list/{node_type}/{node_id}/config/
n [PUT] /airmatch-config/v1/node_list/{node_type}/{node_id}/config/
n [GET] /airmatch-config/v1/node_list/{node_type}/{node_id}/

Monitoring > Site

n [POST] /central/v2/sites
n [PATCH] /central/v2/sites/{site_id}

n [DELETE] /central/v2/sites/{site_id}

Monitoring > Label

n [DELETE] /central/v1/labels/{label_id}

Table 252: Modified APIs in Aruba Central On-Premises 2.5.6 release

Aruba Central On-Premises 2.5.5

Modified API

Configuration > Groups

n [GET] /configuration/v2/groups

User Management > Roles

n [PATCH] /platform/rbac/v1/apps/{app_name}/roles/{rolename}

n [POST] /platform/rbac/v1/apps/{app_name}/roles

Table 253: Modified APIs in Aruba Central On-Premises 2.5.5 release

Aruba Central On-Premises 2.5.4

Modified API

Monitoring > Client

Table 254: Modified APIs in Aruba Central On-Premises 2.5.4 release
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Modified API

n [GET] /monitoring/v1/clients/wireless

n [GET] /monitoring/v1/clients/wired

Topology

n [GET] /{site_id}

n [GET] /devices/{device_serial}

Table 254: Modified APIs in Aruba Central On-Premises 2.5.4 release
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Streaming APIs
Streaming APIs allow customers to subscribe to a select set of services instead of polling the NB API to
get an aggregated state or statistics of the events. For example, with streaming APIs, the customers can
get notifications about the following types of events:

n The UP and DOWN status of the devices
n Change in the location of APs

For a complete list of supported services, see the next section. With streaming API, the customers can
write value-added applications based on the aggregated context.

API streaming is not supported on a single node clusters.

Supported Services
The streaming API supports the following services, for a definition of each of the services, see the next
section.

n Location
n Security
n AppRF
n Audit
n Monitoring

Viewing the Streaming API Page
Perform the following steps to view the Streaming API page:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization > Platform Integration > Streaming API.

The following is an illustration of the Streaming API page.
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Figure 149 View of the Streaming API Page

The parameters in the page are described in the following table. Refer to the callout numbers.

Table 255: Parameters of the Streaming API Page

Callout API Description

1 Topic A list of available topics for streaming APIs. To receive
streaming events from a topic, subscribe to the specific
topic.

2 Subscribe Enables Aruba Central On-Premises to stream events for a
specific topic when this box is enabled.

3 Protobuf Definition Definition of the specific topic. All WebSocket response
messages are encapsulated in a protocol buffer, the
format of which you can download.

4 Key Access token for establishing a WebSocket connection.

5 Endpoint WebSocket endpoint address for the Aruba Central On-
Premises instance.

6 Streaming Protobuf
Definition

The protocol buffer in which all the incoming streaming
messages are encapsulated. This protobuf is further used
to identify the topic of the message received and decode
the topic-specific protobuf message.

Subscribing or Unsubscribing a Streaming API Topic
To receive streaming events from a topic, first subscribe to the topic in Aruba Central On-Premises.
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n Only users with Aruba Central On-Premises Administrator role can subscribe to, or unsubscribe from,
a topic. For more information on role assignment, see Managing Users and Roles section in Aruba Central
On-Premises User Guide.

n In case a live WebSocket connection breaks, reconnect the connection.

To subscribe to a streaming API topic, complete the following steps:

1. In the Aruba Central On-Premises app, set the filter to Global.
2. Under Maintain, click Organization > Platform Integration > Streaming API.
3. In the Streaming APIs tab, select the check box corresponding to the topic that you want to

subscribe.

To unsubscribe a topic, clear the corresponding check box. The following topics are available for
download:
n Location—The location messages publish the location of associated clients or rogues and

these are published every 50 messages or 10 seconds apart.
n Security—When a new rogue is detected or a suspect is promoted to rogue, a rogue event is

published to the streaming server.
n AppRF—AppRF stream is the flow of all the client sessions which is intra-internet bound

happening in the network.
n Audit—The Audit messages are sent to notify events like device connectivity, configuration

status, and firmware status.
n Monitoring—Monitoring publishes the messages about statistics and states of monitoring

data.

Downloading Protobuf Definition for a Streaming API topic
To download the protobuf definition, complete the following steps:

1. In the Streaming APIs table, click the Download button corresponding to the protobuf definition
for the topic to which you have subscribed. The following topics are available for download:
n Apprf—Protocol buffer specification of the AppRF topic.
n Audit—Protocol buffer specification of the Audit topic.
n Monitoring—Protocol buffer specification of the Monitoring topic.
n Location—Protocol buffer specification of the Location topic.
n Security—Protocol buffer specification of the Security topic.

Decoding WebSocket Response Messages
All WebSocket response messages are encapsulated in a protocol buffer. When a message is received,
use the subject (topic) to identify the message and invoke an appropriate message processor. To
decode the message, refer to the protocol buffer specification of the respective topic.

The format is as follows:

message MsgProto {

string subject = 2; // subject

bytes data = 3; // payload
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int64 timestamp = 4; // received timestamp

string customer_id = 5; // customer id to which this data belongs

string msp_id = 6; // optional field indicating the msp_id

}

Enabling Data Streaming From a Topic
Use the WebSocket endpoint and access token to establish a WebSocket connection and start streaming
data for the topics to which you have enabled subscription. Create a WebSocket connection to enable
API streaming from Aruba Central On-Premises.

Complete the following steps to receive streaming events from Aruba Central On-Premises:

1. Create a WebSocket connection:
wss://<central-host>/streaming/api

2. Set the following additional headers.
n UserName—Username of the admin. This is an optional header.
n Authorization—Access token. For more information about how to generate the key, see

Subscribing or Unsubscribing a Streaming API Topic.
n Topic—Value of the topic to which you have subscribed. The value should be one of the

following:
o Location
o Security
o AppRF
o Audit
o Monitoring

3. Start the read loop to read the events. The payload is a protocol buffer message.

Retrieving a New Token
The access token comes with a validity of seven days after which a new token needs to be generated.

You can retrieve the token either directly from the UI or by using the API.

1. To retrieve the new access token from the Aruba Central On-Premises UI, complete the following
steps:
a. In the Aruba Central On-Premises app, under Maintain, click Organization > Platform

Integration > Streaming API tab.
The Streaming page is displayed.

b. You can retrieve the valid token from the Key field. The token gets refreshed automatically
after seven days of its generation.

2. To retrieve the new access token from the API, here are the details required:
n API— https://<central-host>/streaming/token/validate

n Method—GET
n Authorization—Enter the current token

The API will return the same token if the old token is not expired or will return a new token in
case the old token is expired.
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Related Information

Related Information

This section lists the documents that provide information related to Aruba Central On-Premises and the
devices managed by Aruba Central On-Premises.

Aruba Central On-Premises Release Notes
n Aruba Central On-Premises 2.5.7.2 Release Notes

n Aruba Central On-Premises 2.5.7.1 Release Notes

Aruba Central On-Premises 2.5.7 PDF Documents
Aruba Central On-Premises User Guide

Aruba Central On-Premises Release Notes

Aruba Central On-Premises API Reference Guide

Aruba Central On-Premises Installation and Setup Guide

Aruba Central On-Premises Migration Guide

Aruba Central On-Premises Supported Devices Guide

Aruba Central APIs
For a complete list of APIs and the corresponding documentation, see Swagger. For more information
about accessing the API documentation on Swagger, see Aruba Central On-Premises API Reference Guide.

ArubaOS and Aruba Instant Documentation
For information on controllers and Instant APs, see the following documents at the Aruba Support site:

n ArubaOS User Guide

n ArubaOS CLI Reference Guide

n Aruba Instant User Guide

n Aruba Instant CLI Reference Guide

Aruba Switch Documentation
For information on Aruba switches, see the following documents at the HPE support site:

n HPE ArubaOS-Switch Management and Configuration Guide

n HPE ArubaOS-Switch Software Feature Support Matrix
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https://www.arubanetworks.com/techdocs/centralonprem/PDFs/2.5.7/Aruba_Central_On-Premises_2.5.7.2_Release_Notes.pdf
https://www.arubanetworks.com/techdocs/centralonprem/PDFs/2.5.7/Aruba_Central_On-Premises_2.5.7.1_Release_Notes.pdf
https://www.arubanetworks.com/techdocs/centralonprem/PDFs/2.5.7/Aruba_Central_on-premises_2.5.7_User_Guide.pdf
http://www.arubanetworks.com/techdocs/centralonprem/PDFs/2.5.7/Aruba_Central_On-Premises_2.5.7.0_Release_Notes.pdf
https://www.arubanetworks.com/techdocs/centralonprem/PDFs/2.5.7/Aruba_Central_on-premises_2.5.7_API_Guide.pdf
https://www.arubanetworks.com/techdocs/centralonprem/PDFs/2.5.7/Aruba_Central_on-premises_2.5.7_Installation_Guide.pdf
https://www.arubanetworks.com/techdocs/centralonprem/PDFs/2.5.7/Aruba_Central_on-premises_2.5.7_Migration_Guide.pdf
https://www.arubanetworks.com/techdocs/centralonprem/PDFs/2.5.7/Aruba_Central_on-premises_2.5.7_Supported_Devices.pdf
https://asp.arubanetworks.com/
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Accessing Documentation on Support Sites
To view documents hosted on the Aruba support site:

1. Go to Aruba Support Portal.

2. Click the Documentation tab.

3. Navigate to the desired product category.

To view documents on the HPE support site:

1. Go to www.hpe.com/support/hpsc.

2. On the product support page, search for the desired product category. For example, Aruba 3810
Switches. The support information for the selected product category is displayed.

3. Click the Manuals tab.

4. Click view all. The list of documents published for the selected product category is displayed.

5. From the list, click the required document.

https://asp.arubanetworks.com/
http://www.hpe.com/support/hpsc
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