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Important Information

SOME TIBCO SOFTWARE EMBEDS OR BUNDLES OTHER TIBCO SOFTWARE. USE OF SUCH
EMBEDDED OR BUNDLED TIBCO SOFTWARE IS SOLELY TO ENABLE THE FUNCTIONALITY (OR
PROVIDE LIMITED ADD-ON FUNCTIONALITY) OF THE LICENSED TIBCO SOFTWARE. THE
EMBEDDED OR BUNDLED SOFTWARE IS NOT LICENSED TO BE USED OR ACCESSED BY ANY
OTHER TIBCO SOFTWARE OR FOR ANY OTHER PURPOSE.

USE OF TIBCO SOFTWARE AND THIS DOCUMENT IS SUBJECT TO THE TERMS AND
CONDITIONS OF A LICENSE AGREEMENT FOUND IN EITHER A SEPARATELY EXECUTED
SOFTWARE LICENSE AGREEMENT, OR, IF THERE IS NO SUCH SEPARATE AGREEMENT, THE
CLICKWRAP END USER LICENSE AGREEMENT WHICH IS DISPLAYED DURING DOWNLOAD
OR INSTALLATION OF THE SOFTWARE (AND WHICH IS DUPLICATED IN THE LICENSE FILE)
OR IF THERE IS NO SUCH SOFTWARE LICENSE AGREEMENT OR CLICKWRAP END USER
LICENSE AGREEMENT, THE LICENSE(S) LOCATED IN THE “LICENSE” FILE(S) OF THE
SOFTWARE. USE OF THIS DOCUMENT IS SUBJECT TO THOSE TERMS AND CONDITIONS, AND
YOUR USE HEREOF SHALL CONSTITUTE ACCEPTANCE OF AND AN AGREEMENT TO BE
BOUND BY THE SAME.

ANY SOFTWARE ITEM IDENTIFIED AS THIRD PARTY LIBRARY IS AVAILABLE UNDER
SEPARATE SOFTWARE LICENSE TERMS AND IS NOT PART OF A TIBCO PRODUCT. AS SUCH,
THESE SOFTWARE ITEMS ARE NOT COVERED BY THE TERMS OF YOUR AGREEMENT WITH
TIBCO, INCLUDING ANY TERMS CONCERNING SUPPORT, MAINTENANCE, WARRANTIES,
AND INDEMNITIES. DOWNLOAD AND USE OF THESE ITEMS IS SOLELY AT YOUR OWN
DISCRETION AND SUBJECT TO THE LICENSE TERMS APPLICABLE TO THEM. BY PROCEEDING
TO DOWNLOAD, INSTALL OR USE ANY OF THESE ITEMS, YOU ACKNOWLEDGE THE
FOREGOING DISTINCTIONS BETWEEN THESE ITEMS AND TIBCO PRODUCTS.

This document is subject to U.S. and international copyright laws and treaties. No part of this
document may be reproduced in any form without the written authorization of TIBCO Software Inc.

TIBCO, Two-Second Advantage, TIBCO ActiveMatrix BusinessWorks, TIBCO ActiveMatrix
BusinessWorks Plug-in for PeopleSoft, TIBCO Business Studio, and TIBCO Enterprise Administrator
are either registered trademarks or trademarks of TIBCO Software Inc. in the United States and/or other
countries.

Enterprise Java Beans (EJB), Java Platform Enterprise Edition (Java EE), Java 2 Platform Enterprise
Edition (J2EE), and all Java-based trademarks and logos are trademarks or registered trademarks of
Oracle Corporation in the U.S. and other countries.

All other product and company names and marks mentioned in this document are the property of their
respective owners and are mentioned for identification purposes only.

This software may be available on multiple operating systems. However, not all operating system
platforms for a specific software version are released at the same time. Please see the readme.txt file for
the availability of this software version on a specific operating system platform.

THIS DOCUMENT IS PROVIDED “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS
OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

THIS DOCUMENT COULD INCLUDE TECHNICAL INACCURACIES OR TYPOGRAPHICAL
ERRORS. CHANGES ARE PERIODICALLY ADDED TO THE INFORMATION HEREIN; THESE
CHANGES WILL BE INCORPORATED IN NEW EDITIONS OF THIS DOCUMENT. TIBCO
SOFTWARE INC. MAY MAKE IMPROVEMENTS AND/OR CHANGES IN THE PRODUCT(S)
AND/OR THE PROGRAM(S) DESCRIBED IN THIS DOCUMENT AT ANY TIME.

THE CONTENTS OF THIS DOCUMENT MAY BE MODIFIED AND/OR QUALIFIED, DIRECTLY OR
INDIRECTLY, BY OTHER DOCUMENTATION WHICH ACCOMPANIES THIS SOFTWARE,
INCLUDING BUT NOT LIMITED TO ANY RELEASE NOTES AND "READ ME" FILES.
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This and other products of TIBCO Software Inc. may be covered by registered patents. Please refer to
TIBCO's Virtual Patent Marking document (https://www.tibco.com/patents) for details.

Copyright © 2017-2019. TIBCO Software Inc. All Rights Reserved.

TIBCO Software Inc. Confidential Information
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TIBCO Documentation and Support Services

How to Access TIBCO Documentation

Documentation for TIBCO products is available on the TIBCO Product Documentation website, mainly
in HTML and PDF formats.

The TIBCO Product Documentation website is updated frequently and is more current than any other
documentation included with the product. To access the latest documentation, visit https://
docs.tibco.com.

Product-Specific Documentation

Documentation for TIBCO products is not bundled with the software. Instead, it is available on the
TIBCO Documentation site at https://docs.tibco.com/products/tibco-activematrix-businessworks-plug-
in-for-peoplesoft. To directly access documentation for this product, double-click the following file:

TIBCO_HOME/release_notes/TIB_bwpluginpeoplesoft_version_docinfo.html

where TIBCO_HOME is the top-level directory in which TIBCO products are installed. On Windows,
the default TIBCO_HOME is C:\Program Files\tibco\bw. On UNIX systems, the default
TIBCO_HOME is /opt/tibco/bw.

The following documents for this product can be found on the TIBCO Documentation site:

● TIBCO ActiveMatrix BusinessWorks Plug-in for PeopleSoft Installation

● TIBCO ActiveMatrix BusinessWorks Plug-in for PeopleSoft User's Guide

● TIBCO ActiveMatrix BusinessWorks Plug-in for PeopleSoft Release Notes

How to Contact TIBCO Support

You can contact TIBCO Support in the following ways:

● For an overview of TIBCO Support, visit http://www.tibco.com/services/support.

● For accessing the Support Knowledge Base and getting personalized content about products you are
interested in, visit the TIBCO Support portal at https://support.tibco.com.

● For creating a Support case, you must have a valid maintenance or support contract with TIBCO.
You also need a user name and password to log in to https://support.tibco.com. If you do not have a
user name, you can request one by clicking Register on the website.

How to Join TIBCO Community

TIBCO Community is the official channel for TIBCO customers, partners, and employee subject matter
experts to share and access their collective experience. TIBCO Community offers access to Q&A forums,
product wikis, and best practices. It also offers access to extensions, adapters, solution accelerators, and
tools that extend and enable customers to gain full value from TIBCO products. In addition, users can
submit and vote on feature requests from within the TIBCO Ideas Portal. For a free registration, go to 
https://community.tibco.com.
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Product Overview

TIBCO ActiveMatrix BusinessWorks™ Plug-in for PeopleSoft serves as a gateway to PeopleSoft
applications from TIBCO ActiveMatrix BusinessWorks™ applications. With the plug-in, you can invoke
PeopleSoft Component Interfaces.

TIBCO ActiveMatrix BusinessWorks is a leading integration platform that can integrate a wide variety
of technologies and systems within enterprise and on cloud. TIBCO ActiveMatrix BusinessWorks
includes an Eclipse-based graphical user interface (GUI) provided by TIBCO Business Studio™ for
design, testing, and deployment. If you are not familiar with TIBCO ActiveMatrix BusinessWorks, see
the TIBCO ActiveMatrix BusinessWorks documentation for more details.

TIBCO ActiveMatrix BusinessWorks™ Plug-in for PeopleSoft extends the palette functionality provided
by TIBCO ActiveMatrix BusinessWorks. After installing the plug-in, a PeopleSoft configuration shared
resource and a PeopleSoft palette becomes available in TIBCO Business Studio. You can add the plug-in
activities to the business processes you are designing, and integrate them into the process flow. At run
time, the plug-in activities are executed as part of the TIBCO ActiveMatrix BusinessWorks™ process
execution.

The TIBCO ActiveMatrix BusinessWorks™ Plug-in for PeopleSoft provides the following activites:

● CI Request

● CI Request Response
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Comparison between Adapter and Plug-in

This section is useful for users that have previously used the TIBCO ActiveMatrix ® Adapter for
PeopleSoft to help understand differences in the plug-in where supported features have overlap with
adapter.

Feature
TIBCO ActiveMatrix®

Adapter for PeopleSoft

TIBCO ActiveMatrix
BusinessWorks™ Plug-in for
PeopleSoft

Services Provided CI Publication service,
Message Publication
service, Message
Subscription service,
Request-Response
invocation service,
Request-Response service,
Subscription service.

The plug-in is a replacement of
the PeopleSoft Adapter and AE
Palette available in TIBCO
BusinessWorks.

CIRequest activity is equivalent
to PeopleSoft adapter's CI
subscription service with
"Publish to adapter" activity.

CIRequestResponse activity is
equivalent to PeopleSoft
adapter's CI Request-Response
service with "Invoke an
Adapter Request-Response
Service" activity.

Transport Type JMS and RV The plug-in is native to TIBCO
BusinessWorks and no longer
requires messaging.

TRA Properties TRA properties are
maintained in TIBCO
Administrator and/or
adpsft8.tra file.

TRA properties are not
applicable in plug-in.

Reply Schema, Request Schema,
and Custom AESchema

Custom schema supported. Custom schema not supported.

Design time adapter (DTA) Needed in the adapter to
establish connection and
download schema.

Not present in the plugin as
connection and schema
download functionality is part
of PeopleSoft Configuration
shared resource.

DTA transport RV and JMS As DTA itself is not needed, its
transport is not present.

PeopleTools version This drop down was
present under
"Configuration" tab to
select PeopleTools version.

Plugin supports PeopleTools
version 8.56 and above. It does
not provide drop down.
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Feature
TIBCO ActiveMatrix®

Adapter for PeopleSoft

TIBCO ActiveMatrix
BusinessWorks™ Plug-in for
PeopleSoft

Number of Threads Used for spawning that
many of connections with
PeopleSoft.

One connection per activity is
used.

Logging Configured in the
"Logging" tab.

Plugin uses BW6 logging.

Number of reconnect attempts
before suspending impacted
services

Used in adapter in the
reconnection logic.

As there is no service concept
in the plugin, this is not
present.

Connection Connection configuration
is from the Adapter
service.

Connection configuration is
from the PeopleSoft
configuration shared resource.

Direction column from schema tab It indicates whether field is
input parameter or output
parameter for Request-
Response service.

As there is no service concept
in plugin and there is output
tab in case of
CIRequestResponse activity,
this is not present.

FINDKEYS_SEQ in the schema tab Present in schema tab of
adapter for Request-
Response service.

Plugin shows this in the output
tab when user performs find
keys operation.

Errors from PeopleSoft Server Reply message contains
information on error from
PeopleSoft Server.

Fault message is created.
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Preparing PeopleSoft

This chapter explains how to prepare PeopleSoft Component Interfaces in your PeopleSoft system, and
also how to prepare PeopleSoft components for publishing through the plug-in. Information is also
provided that you should have ready before starting plug-in configuration.

This chapter explains the following:

● PeopleSoft Integration Technology Overview

● Loading the PeopleSoft Project

● Preparing PeopleSoft Component Interfaces

PeopleSoft Integration Technology Overview
PeopleSoft is a leading provider of ERP software solutions that meet the changing business needs of
enterprises worldwide. It offers a complete suite of enterprise solutions for accounting, material
management, distribution, manufacturing, and human resources.

PeopleSoft Integration Technologies

The internet architecture introduced with PeopleSoft supports powerful functionality for internet
access, integration of external applications with PeopleSoft applications, and the integration of both into
the enterprise.

Component Interface

The PeopleSoft integration technology, which PeopleSoft internet architecture makes use of, is
Component Interfaces. These are object-oriented software devices that allow external applications to
invoke PeopleSoft business logic. Component Interfaces are ideal for use in PeopleSoft environments
that require tightly coupled integration, where data must be transmitted in real time.

Configuring PeopleSoft
Before you use TIBCO ActiveMatrix BusinessWorks™ Plug-in for PeopleSoft, do the following
preparation with PeopleSoft:

1. Load the TIBCO resources:

● Loading the PeopleSoft Project

Finish this step to load a pre-built PeopleSoft project into PeopleTools.

2. Prepare the PeopleSoft integration technology you use:

● Preparing PeopleSoft Component Interfaces

Loading the PeopleSoft Project

The software includes a pre-built PeopleSoft project (TIB_PEOPLESOFT_PLUGIN) that contains the
server side code, to be used in PeopleTools 8.56. The project also contains Component Interfaces,
components, fields, menus, pages and records. For more information, see PeopleSoft Project.

You must set up the project in your PeopleSoft database before using the plug-in. The
TIB_PEOPLESOFT_PLUGIN project to be imported into PeopleTools is located in the BW\PALETTES
\PEOPLESOFT\7.0\samples\TIB_PEOPLESOFT_PLUGIN folder. For more information on loading the
project, see Loading the TIB_PEOPLESOFT_PLUGIN Project.
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PeopleSoft Project
The following table describes all the items in the TIB_PEOPLESOFT_PLUGIN project.

Type of Item Name Description

Component Interface TIB_CI_COMPINTFC Used by the plug-in to retrieve
the list of Component
Interfaces in the database.

TIB_MQUEUE_DATA_CI Used by the plug-in to retrieve
queue records.

TIB_MQUEUE_SRCH_CI Used by the plug-in to retrieve
queue records.

TIB_PUB_COMPINTFC Used by the plug-in to store
data back into PeopleSoft.
Applicable only to integration
scenarios.

TIB_MSGVER_CI Used by the plug-in to retrieve
names and versions of
messages.

TIB_MSGREC_CI Used by the plug-in to retrieve
the details of a particular
message.

TIB_MSGDET_CI Used by the plug-in to retrieve
the details of a particular
message.

Component TIB_CI_GROUP Used by TIB_CI_COMPINTFC.

TIB_MQUEUE_DATA_COMP Used by
TIB_MQUEUE_DATA_CI.

TIB_MQUEUE_SRCH_COMP Used by
TIB_MQUEUE_SRCH_CI.

TIB_PUB_COMP Used by
TIB_PUB_COMPINTFC.

TIB_MSGVER_COMP Used by TIB_MSGVER_CI.

TIB_MSGREC_COMP Used by TIB_MSGREC_CI.

TIB_MSGDET_COMP Used by TIB_MSGDET_CI.
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Type of Item Name Description

Field TIB_ATTRIBUTE_NAME Name of the field.

TIB_BCITEMPARENT Name of the parent field.

TIB_BCNAME Name of the Business Event

TIB_DESCRIPTION Description of the field.

TIB_EVENT_NAME Stores name of the event.

TIB_FIELDNAME Name of the field.

TIB_FIELDTYPE Type of the field.

TIB_GUID Stores GUID - Unique identifier
for the message.

TIB_IS_MSG_TRIGGER Stores TRUE or FALSE.
Purpose is to determine
whether to trigger the
publisher if this field changes.

TIB_ISKEY Key field.

TIB_ISKEY_FLAG Stores TRUE or FALSE key
field.

TIB_LENGTH Length of the field.

TIB_LEVELNUM

TIB_MENUACTION

TIB_MODE TIB_MODE has the following
values:

A - Add.

U - Update.

L - Update All.

C - Correction.

TIB_MSG_DATA Content of this field.

TIB_MSG_FIELDID

TIB_MSG_ORIGIN
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Type of Item Name Description

TIB_MSG_TIMESTAMP Stores Timestamp
corresponding to the message.

TIB_MSG_TYPE

TIB_OBJECT_NAME

TIB_OPERATION

TIB_PARENT_RECNAME Field Parent Record Name.

TIB_PARENTRECNAME Field Parent Record Name.

TIB_PNLGRPNAME

TIB_RECNAME

TIB_SEQUENCE_NO Stores Sequence number of
message.

TIB_SERIALIZEDATA

TIB_STATUS TIB_STATUS can have any of
the

following values:

N - Not processed.

I - Intermediate stage.

P - Processed successfully.

E - Error.

TIB_MSGNAME Name of the Application
Messaging component.

TIB_APMSGVER Version of Application
Messaging.

TIB_RECDNAME Name of the Record.

TIB_FLDNAME Name of the Field.

TIB_FLDTYPE Type of the Field.

TIB_PRNTRECNAME Name of the parent record
name.

TIB_RECALIAS Name of the record alias name.
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Type of Item Name Description

TIB_FLDALIAS Name of the field alias.

Menu TIBCO_MAINT_MENU

Page TIB_CI_ADAPTER_WRK Page that has all the
PeopleCode used to capture
data from PeopleSoft and store
it in the MQUEUE table.

TIB_CI_MQUEUE_PGE

TIB_CI_PUBLISHER

TIB_COMP_INTERFACE

TIB_MQUE_DATA_PGE

TIB_MQUE_SRCH_PGE

TIB_MSGVER_PG

TIB_MSGREC_PG

TIB_MSGDET_PG

Record TIB_BCITEM_VW

TIB_CI_BUS_DTL Stores the details of the
component to be captured.

TIB_CI_BUS_HDR Stores the events to be
published and in what mode.

TIB_CI_DTLWRK

TIB_CI_GET_VW

TIB_CI_MQUEUE Stores the data to be published.

TIB_CI_MSG_VW

TIB_CI_PARNT_VW

TIB_CI_SEQUENCE Stores the sequence number of
the published event.

TIB_CI_TIDLOG Has the PeopleCode required
for capturing data to be
published.
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Type of Item Name Description

TIB_MQUEUE_SRCH

TIB_PUB_WRK

TIB_MSGVER_VW

TIB_MSGREC_VW

TIB_MSG_VW_TBL

SQL TIB_BCITEM_VW

TIB_CI_GET_VW Captures the GETKEYS for a
particular Component
Interface.

TIB_CI_MSG_VW Captures the details of the
fields and records to be
published.

TIB_CI_PARNT_VW Captures the parent-child
relationship for Component
Interfaces.

TIB_MQUEUE_SRCH Captures the range of sequence
numbers for TIB Events and
groups them by the status
(processed/ unprocessed).

TIB_MSGVER_VW

TIB_MSGREC_VW

TIB_MSG_VW_TBL
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Type of Item Name Description

PeopleCode TIB_CI_TIDLOG.RowInit This event is fired for all the
records the first time a row of
data is encountered. This is
usually used to set the initial
state of a component or a page.
The plug-in uses this particular
record's RowInit event to host
the PeopleCode to perform the
following:

Check if the panel is invoked
online.

Call a function to get the data
to be captured from the TIB
tables, only if the panel is
invoked online and not via the
Component Interface.

TIB_CI_TIDLOG.SavePreChan
ge

This event is fired just before
the data is updated in the
database by the PeopleSoft
component processor. It gives
you one last chance to
manipulate the data before it is
saved to the database. The
plug-in uses this particular
record's SavePreChange event
to host the PeopleCode to
perform the following:

Set the various global variables.

Calls a function to start the
processing of an event.

Calls a function to write the
message to the MQUEUE table
after an event has been
processed.

TIB_CI_TIDLOG.FieldFormula This event is fired in more than
one context but primarily it is
used to declare and store
functions to be used to by
PeopleCode of other events.
Hence the plug-in uses this
particular record's
FieldFormula event to host the
PeopleCode defining various
functions, which do the
processing required to capture
and write the data to the
MQUEUE table.
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Loading the TIB_PEOPLESOFT_PLUGIN Project
To load the project to the PeopleSoft server, you need to finish these tasks in sequence:

● Back Up and Delete the Existing TIB_PEOPLESOFT PLUGIN Project in the PeopleSoft Database

● Copy the TIB_PEOPLESOFT_PLUGIN Project

● Oracle Only: Create a Tablespace for Records

● Build the TIB_PEOPLESOFT_PLUGIN Project

● Grant Permissions for Working with CI

For more information on PeopleSoft configuration, see PeopleSoft (Enterprise PeopleTools)
Documentation Library.

Back Up and Delete the Existing TIB_PEOPLESOFT_PLUGIN Project in the PeopleSoft Database

Before loading the TIB_PEOPLESOFT_PLUGIN project, you need to check whether the project is
already in the PeopleSoft database. If there is an existing TIB_PEOPLESOFT_PLUGIN project in the
database, you must delete it and load the project from the plug-in with the version you want to use.

To check whether the TIB_PEOPLESOFT_PLUGIN project is already in PeopleSoft Database:

Procedure

1. Open PeopleTools Application Designer and log in to the server where you want to add the project.

2. Verify that there is no existing TIB_PEOPLESOFT_PLUGIN project already in the database:
a) From the menu, select File > Open.
b) In the Open Definition dialog, open the TIB_PEOPLESOFT_PLUGIN project.

3. Check the listed projects:

● If there is no existing TIB_PEOPLESOFT_PLUGIN project, skip to, Copy of
TIB_PEOPLESOFT_PLUGIN Project

● If there is an existing TIB_PEOPLESOFT_PLUGIN project, continue to step 4.

4. Back up any contents of the TIB_CI_MQUEUE table associated with the project.

5. Delete the existing TIB_PEOPLESOFT_PLUGIN project.

6. From the menu, select File > Delete. In the Delete Definition dialog, delete all of the items in the
TIB_PEOPLESOFT_PLUGIN project in the following order:
a) Menus
b) Component Interfaces
c) Components
d) Pages
e) Records
f) Fields

7. Delete the TIB_PEOPLESOFT_PLUGIN project itself and close the Delete Definition dialog.

8. If necessary, also delete the cache.

9. Exit PeopleTools Application Designer.

Copy the TIB_PEOPLESOFT_PLUGIN Project

To load the project:
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Procedure

1. Open PeopleTools Application Designer and log in to the server where you want to add the project.

2. From the menu, select Tools > Copy Project > From File.

3. In the displayed dialog, browse to the following directory: BW\PALETTES\PEOPLESOFT
\7.0\samples\TIB_PEOPLESOFT_PLUGIN.

4. Select the TIB_PEOPLESOFT_PLUGIN project from the displayed list and click Select.

5. In the Copy From File dialog, select all the Definition Types, then click Copy.

6. Save the project and exit PeopleTools Application Designer.

Oracle Only: Create a Tablespace for Records

If you are using an Oracle database, you need to create a separate tablespace for the following records:

● TIB_CI_BUS_DTL

● TIB_CI_BUS_HDR

● TIB_CI_MQUEUE

● TIB_CI_SEQUENCE

● TIB_CI_TIDLOG

To create a tablespace and assign records:

Procedure

1. Create a tablespace in the Oracle database exclusively for records. The recommended size for the
tablespace is 50MB. If you want to increase the tablespace size, contact your database administrator.

2. Open PeopleTools Application Designer and log in to the target server where you added the project.

3. Open a record(s) to be allocated to the new tablespace.

4. From the menu, select Tools > Data Administration > Set Tablespace.

5. Select Oracle from the Platform drop-down list.

6. Select the created tablespace from Available Space Name-DB Name drop-down list. Change the
original setting if required.

7. Click OK.

8. Save the record(s). A new tablespace is added to the record(s).

9. Repeat step 3 to step 8 to add the tablespace to the five records.

10. Save the project and exit PeopleTools Application Designer.

Build the TIB_PEOPLESOFT_PLUGIN Project

To build the project:

Procedure

1. Open PeopleTools Application Designer and log in to the target server where you added the project.

2. Open the TIB_PEOPLESOFT_PLUGIN project using PeopleTools Application Designer.

3. From the menu, select Build > Project.
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4. In the Build dialog, configure the following settings and options.
a) Click the Settings button and in the displayed Build Settings dialog, select all the options that

regenerate tables, views, and indexes, and click OK.
b) In the Build Options group box, check the Create Tables checkbox and the Create Views

checkbox.
c) In the Build Execute Options group box, select Execute And Build Script radio button.

5. Click Build to build the project.

6. Save the project and exit PeopleTools Application Designer.

Grant Permissions for Working with CI

To grant permissions for an plug-in working with CI

Procedure

1. Restart the PeopleSoft application server where you added the project.

2. Log in to PIA and navigate to PeopleTools > PeopleTools > Security > Permissions & Roles >
Permission Lists.

3. Find the permission list with a description containing "all pages" and open it. The name of the
permission list is different for varied PeopleSoft applications. For example, find HCCPCSSA1000 CS
Administration - All Pages in the Permission List

4. Click to open the page and set the permissions:
a) Click the Pages tab, add or find the TIBCO_MAINT_MENU menu and grant all permissions to

the related components. Then save the change.
b) Click the Component Interfaces tab, grant Full Access permissions for the following

Component Interfaces. If they do not exist, insert them into the Component Interfaces list first.

● TIB_CI_COMPINTFC

● TIB_MQUEUE_DATA_CI

● TIB_MQUEUE_SRCH_CI

● TIB_MSGDET_CI

● TIB_MSGREC_CI

● TIB_MSGVER_CI

● TIB_PUB_COMPINTFC

5. Save all the changes.

6. Restart the PeopleSoft application server.

Preparing PeopleSoft Component Interfaces
TIBCO ActiveMatrix BusinessWorks™ Plug-in for PeopleSoft uses PeopleSoft component interfaces as
schemas and as APIs for formatting and processing data between a PeopleSoft application and the
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TIBCO environment. You must prepare PeopleSoft component interfaces so the plug-in can download
them inside the studio.

● Use the Test Component Interface tool in PeopleTools Application Designer to determine which
fields are required and what values are valid for sending into PeopleSoft.

● Eliminate any unnecessary records and fields from a component interface. The simpler the
component interface, the easier it is to set up and test the plug-in. Component interfaces containing
fields from derived records are likely to cause errors.

● The package inside the CI.jar should be PeopleSoft.Generated.CompIntfc

Procedure

Before configuring the plug-in, complete the following tasks in your PeopleSoft system:

● Develop Component Interfaces

● Build PeopleSoft Component Interface Java APIs

● Compile the Built PeopleSoft Component Interface Java APIs

● Grant Permissions for the Required Component Interfaces

Develop Component Interfaces
To develop the required component interfaces, you need to create or change the required component
interfaces by using PeopleTools Application Designer. Make sure the component interfaces have all the
records and fields you need for the type of data the plug-in is processing.

Build PeopleSoft Component Interface Java APIs
To build PeopleSoft Java APIs:

Procedure

1. Open the component interface you want to use from PeopleSoft Application Designer.

2. From the menu, select Build > PeopleSoft APIs.

3. In the Build PeopleSoft API Bindings dialog:
a) Uncheck the Build checkbox for COM Type Library.
b) Uncheck the Build checkbox for C Header Files.
c) Check the Build checkbox for Java Classes. Navigate to open your Target Directory and select

the following from the PeopleSoft APIs to Build list:

● PeopleSoft.*

● CompIntfc.CompIntfc*

● APIs for required component interfaces: For example, for the COUNTRY component interface,
select CompIntfc.COUNTRY and CompIntfc.COUNTRYCollection.

● Click OK in the Build PeopleSoft API Bindings dialog to build the APIs.

Compile the Built PeopleSoft Component Interface Java APIs
Compile all the sources which we get after building Component Interfaces in the above step and make
a Jar (CI.jar) file from it.

Grant Permissions for the Required Component Interfaces
To grant permissions for the component interfaces:
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Procedure

1. Log in to PIA and navigate to PeopleTools > Security > Permissions & Roles > Permission Lists.

2. Find the permission list which includes the required component interfaces and open it.

3. Click the Component Interfaces tab and find the desired component interfaces. For example, if you
want to work with the Country component interface, make sure it is in the list.

4. Edit each component interface and grant Full Access permissions to all its methods.
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Getting Started

This tutorial is designed to get users started with TIBCO ActiveMatrix BusinessWorks™ Plug-in for
PeopleSoft in TIBCO Business Studio.

All operations are performed in TIBCO Business Studio. Refer to TIBCO ActiveMatrix BusinessWorks™
Concepts Guide to familiarize yourself with TIBCO Business Studio.

Steps to create and deploy an application by using ActiveMatrix BusinessWorks™ Plug-in for
PeopleSoft are as follows:

1. TIBCO Business Studio Overview
2. Creating a Project
3. Creating a PeopleSoft Configuration Shared Resource
4. Configuring a Process
5. Testing a Process
6. Deploying an Application

TIBCO Business Studio Overview
TIBCO Business Studio is an Eclipse-based integration development environment that is used to
design, develop, and test ActiveMatrix BusinessWorks applications.

TIBCO Business Studio provides a workbench in which you can create, manage, and navigate resources
in your workspace. A workspace is the central location on your machine where all data files are stored.

The workbench consists of:

● Menu: contains menu items such as File, Edit, Diagram, Navigate, Search, Project, Run, Window,
and Help.
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● Toolbar: contains buttons for frequently used commands such as New , Save , Enable/

Disable Business Studio Capabilities , Create a new BusinessWorks Application Module ,

Create a new BusinessWorks Shared Module , Debug , Run , and so on.

● Perspective: contains an initial set and layout of views that are required to perform a certain task.
TIBCO Business Studio launches the Modeling perspective by default. You can change the
perspective from the menu Window > Open Perspective > Perspective_Name.

● View: displays resources. For example, the Project Explorer view displays the ActiveMatrix
BusinessWorks applications, modules, and other resources in your workspace, and the Properties
view displays the properties for the selected resource. You can open a view from the menu Window
> Show View > View_Name.

● Editor: provides a canvas to configure, edit, or browse a resource. Double-click a resource in a view
to open the appropriate editor for the selected resource. For example, double-click an ActiveMatrix
BusinessWorks process MortgageAppConsumer.bwp in the Project Explorer view to open the process
in the editor.

● Palette: contains a set of widgets and a palette library. A palette groups activities that perform similar
tasks, and provides quick access to activities when configuring a process.

Creating a Project
To use the plug-in, the first task is to create the project. You can add resources and processes after
creating a project.

An Eclipse project is an application module configured for TIBCO ActiveMatrix BusinessWorks. The
Eclipse project is named, versioned, and packaged as part of the application.

Procedure

1. Start TIBCO Business Studio:

● Microsoft Windows: Click Start > All Programs > TIBCO > TIBCO_HOME > TIBCO Business
Studio version_number > Studio for Designers.

● Linux: Run the TIBCO Business Studio executable file located atTIBCO_HOME/studio/
version_number/eclipse directory.

2. On the File menu, click New > BusinessWorks Resources. The BusinessWorks Resource wizard is
displayed.

3. On the "Select a wizard" page, click BusinessWorks Application Module, and click Next.

4. On the Project page, enter the following details and click Finish:
a) In the Project name field, enter a project name.
b) By default, the created project is located in the workspace current in use. If you do not want to

use the default location for the project, clear the Use default location check box, and click
Browse to select a new location.

c) Use the default version of the application module, or enter a new version in the Version field.
d) Keep the Create empty process and Create Application check boxes selected to automatically

create an empty process and an application when creating the project.
e) Select the Use Java configuration check box if you want to create a Java module.

A Java module provides Java tooling capabilities.

Result

The project with the specified settings is displayed in the Project Explorer view.
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Creating a PeopleSoft Configuration Shared Resource
After you create a project, you create a PeopleSoft Configuration Shared Resource to connect to
PeopleSoft application server and download the schema.

Prerequisites

Before creating the PeopleSoft Configuration Shared Resource, make sure a project is created. See 
Creating a Project for more details.

Procedure

1. Expand an existing project in the Project Explorer view.

2. Right-click the Resources folder, and click New > PeopleSoft Configuration.

3. In the PeopleSoft Configuration wizard, the resource folder, package name, and resource name of
the PeopleSoft configuration are provided by default. If you do not want to use the default
configurations, change them accordingly. Click Finish.

4. Configure the connection in the Connection tab of PeopleSoft Configuration shared resource. The
PeopleSoft Configuration has two tabs, Connection and Schema. For more details see, PeopleSoft
Configuration Shared Resource section.

5. Click Test Connection to validate the connection.

6. Click File > Save to save the process.

Result

A configuration resource is created: PeopleSoftConfiguration.peopleSoftResource. The
configuration resource is saved in the Resources\package_name directory by default or the directory
you specified.
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Configuring a Process
When you create a project, an empty process is created by default. You can add activities to the empty
process to complete a task.

Prerequisites

Ensure that you have created an empty process when creating a project. For more information, see 
Creating a Project.

Procedure

1. In the Project Explorer view, click the created project, and open the empty process from the
Processes folder.

2. Select activities from the Palette view, and drag them in it in the Process editor.
For example, you can drag the Timer activity from the General Activities palette, and the CI Request
activity from the PeopleSoft palette, to the process editor.

3. Click an activity in the Process editor and drag the  icon to create a transition between the
added activities.

4. Configure the activities as described in PeopleSoft Palette.

A PeopleSoft connection is required when configuring the PeopleSoft activities. See 
Creating a PeopleSoft Configuration Shared Resource for more details about how to create
a PeopleSoft connection.

5. To save the process, click File > Save.

Result

The process with configured activities is saved: process_name.bwp. The process is saved in the
Processes\package_name directory by default or the directory you specified.

Testing a Process
After configuring the process, you might want to debug or test the process.

Prerequisites

Ensure that you have configured the process. For more information, see Configuring a Process.
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Procedure

1. In TIBCO Business Studio, navigate to the process that you want to test.

2. On the toolbar, click  and select Debug > Debug Configurations

3. Click BusinessWorks Application > BWApplication in the left panel of the opened dialog. By
default, all applications in the current workspace are selected on the Applications tab. Ensure that
only the application you want to debug is selected in the right panel of the Applications tab.

4. Click Debug to test the process in the selected application.
TIBCO Business Studio switches to the Debug perspective. The debug information is displayed in
the Console view, as shown in the following figure.

5. In the Debug tab, expand the debugged process and click an activity.

6. In the upper-right corner, click the Job Data view, and then click the Output tab to check the
activity output.

Deploying an Application
After testing the process, if the configured process works as expected, you can deploy the application
that contains the configured process into a runtime environment, and then use the bwadmin utility to
manage the deployed application.
Before deploying an application, generate an application archive, which is an enterprise archive (EAR)
file in TIBCO Business Studio.

Deploying an application involves:

1. Uploading an application archive.

2. Deploying an application archive.

3. Starting an application.

See TIBCO ActiveMatrix BusinessWorks Administration for more details about how to deploy an
application.
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PeopleSoft Configuration Shared Resource

The PeopleSoft Configuration shared resource contains the required information to establish a
connection at runtime to the PeopleSoft server and is used by the activities to connect with the server.
The PeopleSoft Configuration has two tabs, Connection and Schema. On the Connection tab, you can
connect to the PeopleSoft server, and the Schema tab is used to fetch the Component Interfaces from
the PeopleSoft server and view the schema details.

Connection Tab

On the Connection tab, you can provide the necessary information to connect the plug-in with the
PeopleSoft server

The Connection tab contains the following fields:

General

On the General panel, you can specify the package that stores the PeopleSoft Configuration shared
resource and the shared resource name.

The General panel contains the following fields:

Field
Module
Property? Description

Package No The name of the package where the new shared resource is
added.

Name No The name to be displayed as the label for the shared resource
in the process.

The default is PeopleSoftConfiguration.

Description No A short description of the shared resource.

Configuration

On the Configuration panel, you can provide the information about the PeopleSoft server to which the
plug-in connects.

The Configuration panel contains the following fields:

Field
Module
Property? Description

Application Server Yes The IP address and port number to connect to
the PeopleSoft server, which is provided in the
following format:

<Host>:<Port>

For example, 10.97.106.89:9033

Login Name Yes The user name of a PeopleSoft application server
used to access PeopleSoft.
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Field
Module
Property? Description

Password Yes The password of a PeopleSoft application server
used to access PeopleSoft.

Use Domain Password No By selecting this checkbox, the Domain
Password field appears and you can enter the
domain password.

Domain Password Yes The Domain Password field is only visible after
the Use Domain Password field is checked. The
Domain Password is used to protect the domain
for more security.

Test Connection No Used to test whether the connection to
PeopleSoft can be established.

Advanced

The Advanced panel contains the following fields:

Field
Module
Property? Description

Maximum Reconnect Attempts Yes The maximum number of reconnection
attempts to make after a connection is lost.

The default value is -1. This indicates, the
plug-in attempts to reconnect to PeopleSoft
indefinitely when a connection fails.

Reconnect Intervals
(milliseconds)

Yes The time interval in milliseconds to elapse
between reconnection attempts.

The default value is 100.

Schema Tab

On the Schema tab, you can download the schemas from the PeopleSoft server and view the schema
details.

Only one schema can be added at a time for every connection.

To add a schema,

1. Click the Add button or right click and select Add in the Schema Types panel.

2. On clicking Add, the Fetch Component Interface window opens. Click the Fetch button and a list of
all available Component Interfaces appears. You can use a partial name or full name of the
Component Interface that are present in the top-down list when you click the Fetch button. If you
provide a partial name, then the Component Interfaces beginning with that string is displayed. If
you provide a full name of the Component Interface, only the paticular Component Interface is
displayed.
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While fetching schemas no regular expression or wildcard is allowed. Only substrings is
allowed.

3. Select a schema and click OK. The schema is added to the list on Schema Types panel.

To delete a schema,

1. Select the schema and click the Remove button or right-click on the schema and select Remove.

The Schema details are as follows:

Field Description

Name The name of the record fields.

Field Type The data type of the record fields.

Key This column indicates whether the field is a key in a
PeopleSoft database.

Runtime Input This column indicates whether the field should be included in
the runtime input.

The Runtime Input check box is unavailable for
fields that are identified as aKey in the PeopleSoft
database.
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PeopleSoft Palette

The PeopleSoft palette contains two activities to be integrated with PeopleSoft.

● CI Request

● CI Request Response

CI Request
In the CI Request activity, the plug-in recieves messages from the TIBCO environment, parses the
request and performs specified operations on the message data in the PeopleSoft database through
Component Interface.

General Tab

On the General tab, you must specify the required parameters before you can use this activity. The
General tab contains the following fields:

Field
Module
Property? Description

Name No The name to be displayed as the label for the activity in the
process.

Connection Yes The reference to PeopleSoft Configuration Shared Resource. It is
used to get connection and the schema details.

Schema No The name of the schema to be used in the activity.

The search results list all the schemas downloaded for the
particular connection selected in the Connection field.

Description Tab

On the Description tab, you can enter a short description for the CI Request activity.

Input Tab

On the Input tab, you can view the input data for the CI Request activity. The values in the Input tab
are populated based on the schema selected in the Schema field.

Operation Code

The input data of CI Request contains a field called operation code (OPRN_CODE) if the Component
Interface contains records that are level 1 and above. The value in the operation code field determines
the mode of operation carried out on child records in the PeopleSoft database. The values that can be
specified in the input data for OPRN_CODE are:

● Insert (I) - For inserting a new record.

● Update (U) - For inserting a record if the record does not exist or for updating a record if it exists.
The Update operation inserts the value for the fields that are defined in the schema if the record
does not exist, and updates the value for the fields if the record exists.

● Delete (D) - For deleting an existing record.

● Null - If no operation code is specified an update is carried out.
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For more information on Operation Code, see Implemention of Keys in TIBCO ActiveMatrix
BusinessWorks™ Plug-in for PeopleSoft

Fault Tab

The Fault tab, has the following exceptions:

● PeopleSoftPluginException
● PeopleSoftOperationException

PeopleSoftPluginException throws an error and cause the activity to stop. This exception is caused for
all cases other than PeopleSoftOperation exception.

Field Type Description

msg string The error message description returned by the plugin.

msgCode? string The error code returned by the plugin.

PeopleSoftOperationException throws an error and cause the activity to stop. This exception is caused
when any error occurs during an API invoke for Operation processing on the PeopleSoft Server.

Field Type Description

msg string The error message description returned by the plugin.

msgCode? string The error code returned by the plugin.

CI Request Response
The CI Request Response activity receives requests from the TIBCO environment, parses the request,
performs specified operation on the input fields, and then returns output fields using the Component
Interface.

General Tab

On the General tab, you can specify the required parameters before you can use this activity. The
General tab contains the following fields.

Field
Module
Property? Description

Name No The name to be displayed as the label for the activity in the
process.

Connection Yes The reference to PeopleSoft Configuration Shared Resource. It is
used to get connection and the schema details.

Schema No The name of the schema to be used in the activity.

On clicking the search symbol, a dialog box opens which lists
downs all the schema downloaded for the particular connection
selected in the Connection field.
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Description Tab

On the Description tab, you can enter a short description for the CI Request Response activity.

Input Tab

On the Input tab, you can view the input data for the CI Request Response activity. The values in the
Input tab are populated based on the schema selected in the Schema field.

Operation Code

The input data received by CI Request Response contains a field called operation code (OPRN_CODE)
if the Component Interface contains records that are level 1 and above. The value in the operation code
field determines the mode of update carried out on child records in the PeopleSoft database. The values
that can be specified in the input data for OPRN_CODE are:

● Insert (I)- For inserting a new record.

● Update (U)- For inserting a record if the record does not exist or for updating a record if it exists.
The Update operation inserts the value for the fields that are defined in the schema if the record
does not exist, and updates the value for the fields if the record exists.

● Delete (D)- For deleting an existing record.

● Null - If no operation code is specified an update is carried out.

For more information on Operation Code see, Implementation of Keys in TIBCO ActiveMatrix
BusinessWorks™ Plug-in for PeopleSoft

Output Tab

The values on the Output tab are populated based on the values passed to the fields in the Input tab
and the operation performed on the server. If the process executes successfully, output data gets
displayed in the Output tab.

If the process fails a Fault is generated. The error or an exception is displayed in the Fault tab.

Fault Tab

The Fault tab, has the following exceptions:

● PeopleSoftPluginException
● PeopleSoftOperationException

PeopleSoftPluginException throws an error and cause the activity to stop. This exception is caused for
all cases other than PeoplSoftOperation exception.

Field Type Description

msg string The error message description returned by the plugin.

msgCode? string The error code returned by the plugin.

PeopleSoftOperationException throws an error and cause the activity to stop. This exception is caused
when any error occurs during API invoke for Operation processing on the PeopleSoft Server.
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Field Type Description

msg string The error message description returned by the plugin.

msgCode? string The error code returned by the plugin.
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Implementation of Keys in TIBCO ActiveMatrix
BusinessWorks™ Plug-in for PeopleSoft

The PeopleSoft component interfaces become schemas in the plug-in. When applying a PeopleSoft
Component Interface to a CI Request and CI Request Response in the plug-in, the fields in the
CREATEKEYS (if applicable), GETKEYS and FINDKEYS buckets in every Component Interfaces
definition hold a special significance.

GETKEYS

The plug-in primarily uses GETKEYS to update a particular record in PeopleSoft. For CI Request
Response activity, if the FINDKEYS values are not specified in the incoming request, the plug-in looks for
GETKEYS values. For a CI Request activity, the plug-in by default looks for GETKEYS and ignores the
FINDKEYS completely.

If the GETKEYS values are specified, the plug-in queries PeopleSoft to check if the record exists. If the
record exists, the plug-in updates that record in PeopleSoft fields with values specified under the
PROPERTIES keys.

The GETKEYS keys should be a subset of the FINDKEYS keys. This is to avoid an error scenario wherein
the plug-in tries to search for a record with a key that is not a part of the FINDKEYS in the CI definition.

If the record does not exist, the plug-in looks for CREATEKEYS.

FINDKEYS

The FINDKEYS functionality of PeopleSoft Component Interface is a feature that can be used with the
plug-in's CI Request-Response activity. If the FINDKEYS values are specified in the incoming request,
they take precedence over any GETKEYS or CREATEKEYS values specified. The plug-in's CI Request-
Response activity uses the same to query PeopleSoft and return a sequence of FINDKEY keys with
values, which satisfy the query criterion, as a reply. Please note that any other part of the incoming
request (GETKEYS, CREATEKEYS or PROPERTIES) is ignored.

Fields in FINDKEYS should be a superset of fields in GETKEYS() as the fields under these decide the
query criterion.

CREATEKEYS

The plug-in primarily uses CREATEKEYS to create a record in PeopleSoft. If neither GETKEYS nor
FINDKEYS are specified in the incoming requests (or due to the conditions arising out of the two
scenarios described in GETKEYS), the plug-in looks for CREATEKEYS in the incoming request.

If specified, the plug-in queries PeopleSoft to check if the record already exists. If the record is not
found, the plug-in creates a new record with the CREATEKEYS fields as primary fields and PROPERTIES
keys as values for the non-primary fields. If the record already exists, an error is thrown by the plug-in
saying CREATEKEYS failed.

The CREATEKEYS should be a subset of the FINDKEYS keys. This is to avoid an error scenario wherein the
plug-in is trying to search a record with a key which is not a part of FINDKEYS in the CI definition.

Each CI can have multiple levels up to Level 3. In this case, the plug-in mandates the occurrence of key
fields at all levels in this scenario for performing the CREATE, UPDATE, or DELETE operations
successfully at all levels.

For NULLKEYS, if user does not provide any values in the FINDKEYS, GETKEYS, and CREATEKEYS and
provides value in the PROPERTIES a new record gets created. But user is not recommended to use
NULLKEYS, as this differs from CI to CI, as some CI allow blank records to be added at child level while
some CI do not allow this, and therefore the operation fails. Therefore it is recommended to use
CREATEKEYS, to create a new record.
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Valid Operation Codes for the Plug-in

PeopleSoft Component Interface can have multiple levels up to level 3. The plug-in can INSERT or
UPDATE the records at all these levels. The DELETE operation can be performed only at level 1 and above.
In these case, the key fields should be present at all levels and the user needs to provide the operation
code at all levels.

Valid values for OPRN_CODE for CREATEKEYS and GETKEYS scenario are:

● UPDATE - U

● INSERT - I

● DELETE- D

CREATEKEYS Scenarios

For all CREATEKEYS scenarios, specify I as the value for OPRN_CODE for all the records in the request.

GETKEYS Scenarios

1. To update details of an existing record, specify U as the value for OPRN_CODE at all levels.

2. To insert a new record under an existing record, specify I as the OPRN_CODE for the record to be
inserted. If the new record to be inserted is not a Level1 record, specify U as the OPRN_CODE for the
parent records under which the new record is inserted in the following format:

● Level1 record - 'U'

— Level2 record - 'I'

3. To delete a record under an existing record, specify D as the OPRN_CODE for the record to be deleted.
If the record to be deleted is not a Level1 record, specify U as the OPRN_CODE for the parent record(s)
from which the record is to be deleted in the following format:

● Level1 record - 'U'

— Level2 record - 'D'

4. While inserting a new Level1 record with Level2 and Level3 records under it, specify the value for
the OPRN_CODE in the following format:

● Level1 record - 'I'

— Level2 record - 'I'

— Level3 record - 'I'

For some CIs, PeopleSoft by default creates child records while inserting a new record. For example,
while inserting a new Level1 record for some CIs, PeopleSoft creates Level2 and Level3 records by
default. In such a scenario specify the value for the OPRN_CODE in the following format:

● Level1 record - 'I'

— Level2 record - 'U'

— Level3 record - 'U'
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Sample Project Overview

The sample projects help to understand how TIBCO ActiveMatrix BusinessWorks™ Plug-in for
PeopleSoft operates.

TIBCO ActiveMatrix BusinessWorks™ Plug-in for PeopleSoft is packaged with sample projects. After
installing the plug-in, the following sample projects can be found in TIBCO_HOME\bw\palettes
\peoplesoft\version_number\samples\Examples directory.

This plug-in provides the following sample project:

● Bargaining Unit

If the example throws an exception related to missing classes, update the CI jar with the jar containing
the classes for the required Component Interface.
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Prerequisites of Running the Examples

This section explains the prerequisits of running the examples:

● The Plug-in Examples Files
● Importing Sample Projects

The Plug-in Examples File
The plug-in software includes the following files that are required when you run the examples:

● The PeopleSoft Project file:

The plug-in includes pre-built PeopleSoft project (TIB_SAMPLE) that contain the component
interfaces to be used in PeopleTools 8.56.

The TIB_SAMPLE project to be imported into PeopleTools 8.56 is located in BW\PALETTES
\PEOPLESOFT\7.0\samples\TIB_EXAMPLES_PT85x folder.

You must set up the projects in your PeopleSoft database before running the examples. See Loading
the PeopleSoft Project for Examples

● The ZIP archives:

The example ZIP files are included in the plug-in installation. After installation, the files are
installed in the following directories:

● Component Interface examples:
BW\PALETTES\PEOPLESOFT\7.0\samples\Examples\BARGAINING_UNIT

You cannot directly open a ZIP archive in Studio for Designer and make modifications to the
configurations. To work with a ZIP file, see Importing Sample Projects

Loading the PeopleSoft Project for Examples
To import the TIB_SAMPLE project into PeopleTools:

Procedure

1. Open PeopleTools Application Designer and log into the server where you want to add the project.

2. Verify that there is no existing TIB_SAMPLE project in the database:
a) Select File > Open.
b) In the Open Definition dialog, select Project from the Definition drop-down list and enter

TIB_SAMPLE in the Name field of the Selection Criteria area. If there is no existing
TIB_SAMPLE project, skip to step 3.

c) Open the existing TIB_SAMPLE project and delete all the component interfaces.
d) Delete the TIB_SAMPLE project itself.
e) If necessary, also delete the cache.
f) Exit PeopleTools Application Designer and then log in again.

3. Import the project:
a) In PeopleTools 8.56, select File > Copy Project from File.
b) In the displayed Copy From File: Select Project dialog, browse to locate the BW\PALETTES

\PEOPLESOFT\7.0\samples\TIB_EXAMPLES_PT85x directory. The TIB_SAMPLE project is
displayed in the list. Select the TIB_SAMPLE project to open it.

c) In the displayed Copy From File dialog, make sure all the definition types are selected, then click
Copy.
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4. Grant permissions to work on the component interfaces:
a) Log in to PIA and navigate to PeopleTools > Security > Permission & Roles > Permission Lists.
b) Choose the appropriate permission list for the account used by the plug-in.
c) Grant permissions to work on the component interfaces you have just imported. Make sure full

access is given to all the component interfaces for the account being used by the plug-in.
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Importing Sample Projects

Before running a sample project, you have to import it to TIBCO Business Studio™.

Procedure

1. Start TIBCO Business Studio.

2. From the menu bar, click File > Import.

3. In the Import dialog, expand the General folder, and then click Existing Studio Projects into
Workspace. Click Next.

4. In the Import Projects dialog, click Select archive file, and then click Browse next to it to locate a
sample project. For example, select the BARGAINING_UNIT.zip file, and then click Open.

The sample projects are located in the TIBCO_HOME/bw/palettes/
peoplesoft/version_number/samples/Examples directory.

5. Click Finish.

Result

The BARGAINING_UNIT project is imported to TIBCO Business Studio.
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Bargaining Unit Project

The Bargaining Unit project contains two processes: CIRequest.bwp and CIRequestResponse.bwp.
These example projects show how the CI Request and CI Request Response activities behave. The
example shows the Insert, Update, and Delete on these activities.

CI Request process
The following figure describes the CI Request activity process:

The CI Request activity process performs the following operations:

● The CIRequest_Insert operation inserts the value for the fields that are defined in the schema.

● The CIRequest_Update operation updates the value for the fields that are defined in the schema.

● The CIRequest_Delete operation deletes the value for the fields that are defined in the schema.

Setting Up the Project
Before running the project, you have to set it up.

Prerequisites

You have to import the Bargaining Unit example before setting it up. For more information, see the 
Importing Sample Projects topic.
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Procedure

1. Expand the imported project in the Project Explorer view.

2. Expand the Module Descriptors resource, and then double-click Module Properties.

3. The values are stored here. You can modify the values if needed.

4. From the menu bar, click File > Save to save the project.

Running the Project
To run the project for the CI Request activity process, perform the following steps:

Procedure

1. In the Project Explorer view, expand the Processes > bargaining unit resource, and then double-
click CIRequest.bwp.

2. Click Run > Debug Configurations...
The Debug Configurations dialog opens.

3. Expand the BusinessWorks Application option and select BWApplication.

4. In the Applications tab, all processes are selected. Click the Deselect All button and select the
bargaining_unit.CIRequest option.

5. Click the Apply button and click the Debug button.

6. Click Debug to run the process.

7. Click the  icon to stop the process.

CI Request Response process
The following figure describes the CI Request Response activity process:
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The CI Request Response activity process performs the following operations:

● The CIRequestResponse_Insert operation inserts the value for the fields that are defined for the
schema in the Input tab .

● The CIRequestResponse_Update operation updates the value for the fields that are defined for the
schema in the Input tab.

● The CIRequestResponse_Delete operation deletes the value for the fields that are defined for the
schema in the Input tab

Setting Up the Project
Before running the project, you have to set it up.

Prerequisites

You have to import the Bargaining Unit example before setting it up. For more information, see the 
Importing Sample Projects topic.

Procedure

1. Expand the imported project in the Project Explorer view.

2. Expand the Module Descriptors resource, and then double-click Module Properties.

3. The values are stored here. You can modify the values if needed.

4. From the menu bar, click File > Save to save the project.

Running the Project
To run the project for the CI Request Response activity process, perform the following steps:

Procedure

1. In the Project Explorer view, expand the Processes > bargaining unit resource, and then double-
click CIRequestResponse.bwp.

2. Click Run > Debug Configurations...
The Debug Configurations dialog opens.

3. Expand the BusinessWorks Application option and select BWApplication.

4. In the Applications tab, all processes are selected. Click the Deselect All button and select the
bargaining_unit.CIRequestResponse option.

5. Click the Apply button and click the Debug button.

6. Click Debug to run the process.

7. Click the  icon to stop the process.
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Troubleshooting

When you encounter problems with the project, ensure that you have cleaned up the project.
If errors occur when you run a process in TIBCO Business Studio, you can do a cleaning first. Cleaning
deletes all the old files and reorganizes the project.

Procedure

1. Right-click the project in the Project Explorer view and click Refresh.

2. Select Project > Clean to start the cleaning.
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Log Management

When an error occurs, you can check logs to trace and troubleshoot plug-in exceptions.

By default, error logs are displayed in the Console view when you run a process in Debug Mode. You
can change the log level of the plug-in to trace different messages and export logs to a file. Different log
levels correspond to different messages, as described in Log Levels.

Log Levels
Different log levels include different information.

The plug-in supports the following log levels:

Log Level Description

Trace Includes all information regarding the running process.

Debug Indicates a developer-defined tracing message.

Info Indicates normal plug-in operations. No action is required. A tracing message
tagged with Info indicates that a significant processing step is reached, and
logged for tracking or auditing purposes. Only info messages preceding a
tracking identifier are considered as significant steps.

Warn Indicates that an abnormal condition occurred. Processing continues, but
special attention from the administrator is recommended.

Error Indicates that an unrecoverable error occurred. Depending on the severity of
the error, the plug-in might continue with the next operation or might stop.

Setting Up Log Levels
You can configure a different log level for the plug-in and plug-in activities to trace different messages.

By default, the plug-in uses the default log level of TIBCO ActiveMatrix BusinessWorks. The default log
level of TIBCO ActiveMatrix BusinessWorks is Error.

Procedure

1. Navigate to the TIBCO_HOME\bw\version_number\config\design\logback directory, and open
the logback.xml file.

2. Add the following node in the BusinessWorks Palette and Activity loggers area to specify a log
level for the plug-in:
<logger name="com.tibco.bw.palette.peoplesoft.runtime">
   <level value="DEBUG"/>
</logger>

The value of the level element can be Error, Info, Debug or Trace.

If you set the log level to Debug, the input and output for the plug-in activities are also
displayed in the Console view. See Log Levels for more details regarding each log level.

3. Optional: Add one of the following nodes in the BusinessWorks Palette and Activity Loggers area
to specify a log level for the activity.

44

TIBCO ActiveMatrix BusinessWorks™ Plug-in for PeopleSoft User's Guide



● For example, to control the debug log level for the CI Request activity, set the following
parameters:
<logger name="com.tibco.bw.palette.peoplesoft.CIRequestActivity">
   <level value="DEBUG"/>
</logger>

● For example, to control the debug log level for the CI Request Response activity, set the
following parameters:
<logger name="com.tibco.bw.palette.peoplesoft.CIRequestResponseActivity">
   <level value="DEBUG"/>
</logger>

● For example, to control the debug log level for the PeopleSoft Configuration shared resource, set
the following parameters:
<logger name="com.tibco.bw.sharedresource.peoplesoft.runtime">
   <level value="DEBUG"/>
</logger>

The activities that are not configured with specific log levels use the default log level of the
plug-in.

4. Save the file.

Exporting Logs to a File
You can update the logback.xml file to export plug-in logs to a file.

Procedure

1. In Windows system, navigate to TIBCO_HOME\bw\version_number\config\design\logback
directory, and open the logback.xml file.

After deploying an application in TIBCO Enterprise Administrator, navigate to the
TIBCO_HOME\bw\version_number\domains\domain_name\appnodes\appspace_name

\appnode_name directory and locate the logback.xml file.

2. Add the following node to specify the file to which the log is exported:
<appender name="FILE" class="ch.qos.logback.core.FileAppender">
   <file>c:/bw6-peoplesoft.log</file>
      <encoder>
        <pattern>%d{HH:mm:ss.SSS} [%thread] %-5level %logger{36}-%msg%n</pattern>
      </encoder>
</appender>

The value of the file element is the absolute path of the file that stores the exported logs.

3. Add the following node to the root node at the end of the logback.xml file:
<root level="DEBUG">
   <appender-ref ref="STDOUT" />
   <appender-ref ref="FILE" />
</root>

4. Save the file.
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Error Codes

The following table lists the error codes, detailed explanation of each error, where applicable, and ways
to solve different errors.

Error Code and Error
Message Role Category Description Solution

TIBCO-BW-PALETTE-
PEOPLESOFT-100001

Startup Error.

Unable to create a

connection with the

target application

using connection

parameters : ID {0},

server and port {1}.

Trace BW-Plug-
in

Message is shown
when there is problem
in connecting with
PeopleSoft server

This is a trace
message and
resolution is not
applicable

TIBCO-BW-PALETTE-
PEOPLESOFT-100002

Processing failed

for event {0} with

message {1}.

Trace BW-Plug-
in

Message is shown
when save operation
is not successful on
PeopleSoft server

This is a trace
message and
resolution is not
applicable

TIBCO-BW-PALETTE-
PEOPLESOFT-100003

In Sequence

Collection of

setProperties()-

>getCollection()

returned NULL.

Trace BW-Plug-
in

Message is shown
when collection is
returned as null

This is a trace
message and
resolution is not
applicable

TIBCO-BW-PALETTE-
PEOPLESOFT-100004

In Sequence

Collection of

setProperties()-

>getElementByIndex()

returned NULL

Trace BW-Plug-
in

Message is shown
when element is
returned as null for
given index

This is a trace
message and
resolution is not
applicable

TIBCO-BW-PALETTE-
PEOPLESOFT-100005

Deleted

Trace BW-Plug-
in

Message is shown
when element is
deleted

This is a trace
message and
resolution is not
applicable
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Error Code and Error
Message Role Category Description Solution

TIBCO-BW-PALETTE-
PEOPLESOFT-100006

In Sequence

Collection of

setProperties()-

>deleteItem()

Failed.

Trace BW-Plug-
in

Message is shown
when delete operation
is failed

This is a trace
message and
resolution is not
applicable

TIBCO-BW-PALETTE-
PEOPLESOFT-200001

Incoming event has

both GET and CREATE

Keys specified,

GETKEYS will take

precedence.

Debug BW-Plug-
in

Message is shown
when input has both
GET and CREATE
Keys specified,
GETKEYS will take
precedence..

This is a debug
message and
resolution is not
applicable

TIBCO-BW-PALETTE-
PEOPLESOFT- 200002

Setting GETKEYS.

Debug BW-Plug-
in

Message is shown
while setting get keys

This is a debug
message and
resolution is not
applicable

TIBCO-BW-PALETTE-
PEOPLESOFT-200003

Incoming Message has

CREATEKEYS as NULL.

Debug BW-Plug-
in

Message is shown
when user does not
specify create keys

This is a debug
message and
resolution is not
applicable

TIBCO-BW-PALLETTE-
PEOPLESOFT-200004

Setting CREATEKEYS.

Debug BW-Plug-
in

Message is shown
while setting create
keys

This is a debug
message and
resolution is not
applicable

TIBCO-BW-PALLETTE-
PEOPLESOFT-200005

Call to CreateKeys

API successful..

Debug BW-Plug-
in

Message is shown
while create keys are
generated
successfully.

This is a debug
message and
resolution is not
applicable

TIBCO-BW-PALLETTE-
PEOPLESOFT-200006

Incoming Message has

GETKEYS as NULL.

Debug BW-Plug-
in

Message is shown
when user does not
specify get keys

This is a debug
message and
resolution is not
applicable

TIBCO-BW-PALLETTE-
PEOPLESOFT-200007

Calling Set on

Fields.

Debug BW-Plug-
in

Message is shown
when fields are
getting set

This is a debug
message and
resolution is not
applicable
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Error Code and Error
Message Role Category Description Solution

TIBCO-BW-PALLETTE-
PEOPLESOFT-200008

Calling Set Data for

{0} and value is

{1}.

Debug BW-Plug-
in

Message is shown
when fields are
getting set and their
values are also
displayed

This is a debug
message and
resolution is not
applicable

TIBCO-BW-PALLETTE-
PEOPLESOFT-200009

No keys Specified

for Level(s)

Debug BW-Plug-
in

Message is shown
when no keys are
specified

This is a debug
message and
resolution is not
applicable

TIBCO-BW-PALLETTE-
PEOPLESOFT-200010

keyExists()

componentInterfaceNa

me is NULL.

Debug BW-Plug-
in

Message is shown
when component
interface name is null
inside keyExists()
method

This is a debug
message and
resolution is not
applicable

TIBCO-BW-PALLETTE-
PEOPLESOFT-200011

IncomingData = {0},

ParsedData ={1}.

Debug BW-Plug-
in

Message is shown to
display file name for
component interface

This is a debug
message and
resolution is not
applicable

TIBCO-BW-PALLETTE-
PEOPLESOFT-200012

Finished processing

event {0}

Debug BW-Plug-
in

Message is shown to
when save api call on
peoplesoft returns
true

This is a debug
message and
resolution is not
applicable

TIBCO-BW-PALLETTE-
PEOPLESOFT-200013

Caught Base Error

{0}

Debug BW-Plug-
in

Message is shown to
when an exception is
thrown from
peoplesoft but plug-in
proceed towards
processing rest of the
data

This is a debug
message and
resolution is not
applicable

TIBCO-BW-PALLETTE-
PEOPLESOFT-200014

Operation code

cannot be empty for

CI {0}

Debug BW-Plug-
in

Message is displayed
in case operation code
is empty

This is a debug
message and
resolution is not
applicable

TIBCO-BW-PALLETTE-
PEOPLESOFT-200015

About to call API

getPropertyByName({0

}).

Debug BW-Plug-
in

Message is shown
before
getPropertyByName
api call with record
name ()

This is a debug
message and
resolution is not
applicable
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Error Code and Error
Message Role Category Description Solution

TIBCO-BW-PALLETTE-
PEOPLESOFT-200016

Reconnect attempt

{0}.

Debug BW-Plug-
in

Message is shown
when reconnect
attempts are made
and shows reconnect
count

This is a debug
message and
resolution is not
applicable

TIBCO-BW-PALLETTE-
PEOPLESOFT-200017

Reconnect succeeded

on attempt {0}

Debug BW-Plug-
in

Message is shown
when reconnect
attempts is successful
and shows reconnect
count

This is a debug
message and
resolution is not
applicable

TIBCO-BW-PALLETTE-
PEOPLESOFT-200018

{0}. Output:\n{1}

Debug BW-Plug-
in

Message is shown
with output for ci
request response
activity

This is a debug
message and
resolution is not
applicable

TIBCO-BW-PALLETTE-
PEOPLESOFT-200018

{0}. Output:\n{1}

Debug BW-Plug-
in

Message shows the
output of both
activities

This is a debug
message and
resolution is not
applicable

TIBCO-BW-PALLETTE-
PEOPLESOFT-200019

{0}. Input:\n{1}

Debug BW-Plug-
in

Message shows the
input of both activities

This is a debug
message and
resolution is not
applicable

TIBCO-BW-PALLETTE-
PEOPLESOFT-400001

Setting default

oprn_code to "U" at

{0} as oprn_code is

empty

Warn BW-Plug-
in

Message is shown
when user leaves
oprn_code empty

This is a warning
message and
resolution is not
applicable

TIBCO-BW-PALLETTE-
PEOPLESOFT-500001

Failed to Connect to

Application Server

with Following

Parameters {0}:{1},

OprID {2}.

Error BW-Plug-
in

Message is shown
when connection
parameters are not
correct

Provide correct
parameters for
connection to the
PeopleSoft server.
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Error Code and Error
Message Role Category Description Solution

TIBCO-BW-PALLETTE-
PEOPLESOFT-500002

CI Request/Response

error. CI Request/

response Activity

for {0} threw an

Exception. The event

Name is {1}.

Error BW-Plug-
in

Message is shown
when there is an
exception in activity

Check errors listed
in the error
message, and take
an appropriate
action.

TIBCO-BW-PALLETTE-
PEOPLESOFT-500003

Input properties are

NULL.

Error BW-Plug-
in

Message is shown
when properties are
not specified

Provide input
values to the child
elements of
Properties in the
input tab.

TIBCO-BW-PALLETTE-
PEOPLESOFT-500004

Processing of the

event {0} failed.

Error BW-Plug-
in

Message is shown
when processing is
failed for an activity

Check errors listed
in the error
message, and take
an appropriate
action.

TIBCO-BW-PALLETTE-
PEOPLESOFT-500005

Primary Key field

{0} cannot be NULL.

Error BW-Plug-
in

Message is shown
when primary key is
not specified

Enter a value for
the primary key
field.

TIBCO-BW-PALLETTE-
PEOPLESOFT-500006

Call to CreateKeys

API failed.. {0}

Error BW-Plug-
in

Message is shown
when processing of
create keys is failed

Check errors listed
in the error
message, and take
an appropriate
action.

TIBCO-BW-PALLETTE-
PEOPLESOFT-500007

Error while setting

values for {0} for

event {1}

Error BW-Plug-
in

Message is shown
when set value api call
fails

Check errors listed
in the error
message, and take
an appropriate
action.

TIBCO-BW-PALLETTE-
PEOPLESOFT-500008

Error while fetching

component interface

object for {0}

Error BW-Plug-
in

Message is shown
when retrieval of CI
object fails

Check connection
with PeopleSoft
server and confirm
that your CI jar has
the required
component
Interface.
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Error Code and Error
Message Role Category Description Solution

TIBCO-BW-PALLETTE-
PEOPLESOFT-500009

getPropertyByName({0

}) operation Failed

on {1}

Error BW-Plug-
in

Message is shown
when
getPropertyByName
api call fails

Check errors listed
in the error
message, and take
an appropriate
action.

TIBCO-BW-PALLETTE-
PEOPLESOFT-500010

{0} operation Failed

on {1}

Error BW-Plug-
in

Message is shown
when setProperty api
call fails

Check errors listed
in the error
message, and take
an appropriate
action.

TIBCO-BW-PALLETTE-
PEOPLESOFT-500011

getPropertyByName

({0}) operation

Failed on {1}

Error BW-Plug-
in

Message is shown
when
getPropertyByName
api call fails

Check errors listed
in the error
message, and take
an appropriate
action.

TIBCO-BW-PALLETTE-
PEOPLESOFT-500012

{0} operation Failed

on {1}

Error BW-Plug-
in

Message is shown
when invokeMethod
api call fails

Check errors listed
in the error
message, and take
an appropriate
action.

TIBCO-BW-PALLETTE-
PEOPLESOFT-500013

{0} operation Failed

on {1}

Error BW-Plug-
in

Message is shown
when
getElementByCollecti
on api call fails

Check errors listed
in the error
message, and take
an appropriate
action.

TIBCO-BW-PALLETTE-
PEOPLESOFT-500014

Method not Found

{0}.{1}({2})

Error BW-Plug-
in

Message is shown
when an api call
cannot find the
method invoked

Check errors listed
in the error
message, and take
an appropriate
action.

TIBCO-BW-PALLETTE-
PEOPLESOFT-500015

{0}.{1}({2}) in

setProperty(),

unknown Data Type

{2}

Error BW-Plug-
in

Message is shown
when unknown data
type is received

Enter the correct
datatype value for
field specified in
error message.

TIBCO-BW-PALLETTE-
PEOPLESOFT-500017

Caught Base Error

{0}

Error BW-Plug-
in

Message is shown
when base error is
caught at the time of
peoplesoft api call

Check errors listed
in the error
message, and take
an appropriate
action.
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