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Chapter 1
About This Document

About This Document
This user guide describes the Aruba Software-DefinedWAN (SD-WAN ) Solution and provides detailed
instructions for setting up, configuring, andmanaging SD-WAN Gateways fromAruba Central.

Intended Audience
This guide is intended for network administrators whomanage andmonitor branch networks.

Related Documents
In addition to this document, see the following documents formore details on the SD Branch devices and
Aruba Central:

n Aruba Central Help Center

n ArubaOS User Guide

n HPE-ArubaOS Switch Management and Configuration Guide

n Aruba ClearPass Policy Manager User Guide

Conventions
Table 1 lists the typographical conventions used throughout this guide to emphasize important concepts:

Type Style Description

Italics This style is used to emphasize important terms and to mark the titles of books.

System items This fixed-width font depicts the following:
n Sample screen output
n System prompts

Bold n Keys that are pressed
n Text typed into a GUI element
n GUI elements that are clicked or selected

Table 1: Typographical Conventions

The following informational icons are used throughout this guide:

n Indicates helpful suggestions, pertinent information, and important things to remember.

n Indicates a risk of damage to your hardware or loss of data.

n Indicates a risk of personal injury or death.

Aruba SD-WAN Solution | User Guide 7
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Terminology Change
As part of advancing HPE's commitment to racial justice, we are taking amuch-needed step in overhauling
HPE engineering terminology to reflect our belief systemof diversity and inclusion. Some legacy products
and publicationsmay continue to include terminology that seemingly evokes bias against specific groups of
people. Such content is not representative of our HPE culture andmoving forward, Arubawill replace
racially insensitive terms and instead use the following new language:

Usage Old Language New Language

Campus Access
Points +
Controllers

Master-Slave Conductor-Member

Instant Access
Points

Master-Slave Conductor-Member

Switch Stack Master-Slave Conductor-Member

Wireless LAN
Controller

Mobility Master Mobility Conductor

Firewall
Configuration

Blacklist, Whitelist Denylist, Allowlist

Types of
Hackers

Black Hat, White Hat Unethical, Ethical

Contacting Support

Main Site arubanetworks.com

Support Site support.arubanetworks.com

Airheads Social Forums and Knowledge
Base

community.arubanetworks.com

North American Telephone 1-800-943-4526 (Toll Free)
1-408-754-1200

International Telephone arubanetworks.com/support-services/contact-support/

Software Licensing Site lms.arubanetworks.com

End-of-life Information arubanetworks.com/support-services/end-of-life/

Security Incident Response Team Site: arubanetworks.com/support-services/security-bulletins/
Email: aruba-sirt@hpe.com

Table 2: Contact Information

http://www.arubanetworks.com/
https://support.arubanetworks.com/
http://community.arubanetworks.com/
http://www.arubanetworks.com/support-services/contact-support/
https://lms.arubanetworks.com/
http://www.arubanetworks.com/support-services/end-of-life/
http://www.arubanetworks.com/support-services/security-bulletins/
mailto:aruba-sirt@hpe.com


Chapter 2
Aruba SD-Branch Solution

Aruba SD-Branch Solution
The Aruba SD Branch solution offers the best-in-class wireless and wired infrastructure andmanagement
orchestration features with the SD-WAN capabilities. The SD Branch solution extends the SD-WAN concept
to all elements in the branch to deliver a full stack solution that addresses the business challenges of
distributed enterprises. Coupled with Aruba Central, the solution provides a cloud-hosted environment for
simplified operations and improved agility.

Why SD-WAN?
A traditional branch setup supports client connectivity requirements across different geographical locations
for various types of business operations. The sites in remote geographical locations serve as branch offices,
while the headquarters ormain office serves as a data center that hosts network resources to store, manage,
and distribute data. Themain office also hosts a centralized Virtual Private Network (VPN) management
system to aggregate traffic from the remote branch sites. AWide Area Network (WAN) —withMultiprotocol
Label Switching (MPLS), T1, T3, Broadband, or Cellular links—is used for connectingmultiple local area
networks to a central corporate network or data centers separated by distance.

Due to an increase in the number of client devices at the remote sites and the new bandwidth requirements,
branch office networks are expected rapidly scale to provide uninterrupted user experience. A traditional
branch infrastructurewithmultiple appliances, different operating systems, andmanagement tools only
adds to the cost, involves amaintenance overhead, and demands skilled IT personnel.

The Aruba SD-WAN solution simplifies your branch deployments with a singlemanagement interface for
administering, managing, andmonitoring your branch networks. It also provides a unified policy
enforcement framework with operational ease.

Key Features and Benefits
The SD-WAN solution comeswith the following key capabilities:

n Zero Touch Provisioning of devices—Ability to self-provision without operator's intervention.

n Centralized overlay management and control—A single cloud-based network management interface for
managing andmonitoring SD Branch devices. Aruba Central, the cloud based network management
system, supports unifiedmanagement of SD branch devices with ZTP and hierarchical configuration.

n IPsec based Automatic VPN Tunnels—Support for high-performance and automatic IPsec VPN for secure
overlay networking.

n Unified security policy for wired, wireless, andWAN—Support for a common security policy framework
based on user roles forWAN,WLAN, and LAN users.

n Dynamic path selection—Support for dynamically steering traffic or a service request to the best available
path. For example, you can configure a policy to dynamically route the real-time voice and video traffic on
the link with the lowest latency and jitter, and the bulk file traffic on the link with themaximumbandwidth.

n Deep Packet Inspection andWeb Content Classification—Support formonitoring and analyzing application
usage by clients.

Aruba SD-WAN Solution | User Guide 9
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n Visibility, analytics, and troubleshooting—Dashboards formonitoring branch health, device performance,
and client connectivity metrics. Alerts, reports, and audit trails formonitoring and troubleshooting network
performance issues.

n Policy-based Routing—In addition to the traditional destination-based routing, the SD Branch devices
support routing client traffic based on user role or type of application, For example, traffic generated from
the guest devices can be routed directly to the internet, while traffic from the employees can be routed to
theMPLS network.

Formore information about how SD-WANworks, see Understanding SD-WAN.

Understanding SD-WAN
The SD-WAN solution includes a new set of devices called Aruba Gateways that inter-operate Aruba Switches
and Instant APs to provide a full-fledgedWAN architecture.

Based on the size of your branch setup, you can choose device combination that best suits your
requirement:

n Medium to large branches—For branches that requiremore than 24 ports, you can use a combination of
Branch Gateways and one ormore Aruba switches at the branch site, with Aruba Gateways as
VPN Concentrator at the data center.

n Small to mediumbranches—For branches that require less than 24 ports (including all
WAN and LAN ports), you can deploy Branch Gateways at the branch sites, with Aruba  Gateways as
VPN Concentrator at the data center.

n Micro branches—Formicro branches, you can deploy an Instant AP cluster at the branch site, with
Aruba Gateway as the VPN Concentrator at the data center.

See Supported SD-Branch Components for information on Aruba Gateways that can be deployed as
VPNCs.

Figure 1 shows a typical deployment topology of an SD Branch with Branch Gateways and amicro branch
with Instant APs:

Figure 1 SD Branch Topology

Figure 2 illustrates the communication flow between Aruba Central, branch sites, and data center.
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Figure 2 Aruba Central and Cloud Communication

Figure 3 shows all elements in an SD Branch and the SD-WAN data flow.

Figure 3 Aruba SD-WAN Data Flow

What are the Solution Requirements?
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The Aruba Gateways are themost important components of the Aruba SD-Branch Solution. The SD-WAN
Gateway portfolio includes and Aruba Branch Gateways and VPN Concentrators.

At the Branch Site
The following are the components in a branch:

n Branch Gateways—Function at the branch to optimize and control WAN, LAN, and cloud security
services.

n Switches—Function with Branch Gateways to detect and isolate rogue APs, and blacklist rogue devices.

n Instant APs—Function as VPN clients at branch sites. The client data traffic from these APs are aggregated
by the VPN Concentrator located at the data center

At the Data Center
At the data center, you can deploy Aruba Gateways as VPN Concentrator. For data center redundancy, you
can deploy two VPN concentrators in the active-standby or active-activemode.

The following are the components operational at the Data Center:

n VPNC—AVPN Concentrator functions as a VPN management system that aggregates data traffic from
the branches and terminates IPsec VPN tunnels.

n Virtual Gateway—The headend gateway at the enterprise data center can be hosted as a virtual
appliance. The virtualised instance enterprise data center gateway in public or private cloud is referred to
as Virtual Gateway. Aruba Virtual Gateways function as VPN Concentrators.

For a list of supported Gateways, Switches, and APs, see Supported SD-Branch Components.

In the Cloud
A valid Aruba Central subscription is required to avail cloud-based administration, management,
configuration andmonitoring of SD branch components such as Branch Gateways, VPN Concentrators,
Instant APs, and Aruba Switches.

Supported SD-Branch Components
The Aruba SD-WAN Gateway portfolio includes Aruba Gateways that function as Branch Gateways and
VPN Concentrators.

The following table lists the Aruba Gateway platforms and ArubaOS software versions that function as
Branch Gateways:

Platform Minimum Supported
Software Version

Latest Software
Version

Recommended
Software Version

Aruba 9004-LTE ArubaOS 8.5.0.0-2.1.0.0 ArubaOS 8.6.0.4-
2.2.0.0

ArubaOS 8.5.0.0-2.1.0.0

Aruba 9012 ArubaOS 8.5.0.0-2.0.0.0 ArubaOS 8.6.0.4-
2.2.0.0

ArubaOS 8.5.0.0-2.0.0.4

Table 3: Supported Aruba Gateways
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Platform Minimum Supported
Software Version

Latest Software
Version

Recommended
Software Version

Aruba 9004 ArubaOS 8.5.0.0-1.0.7.0 ArubaOS 8.6.0.4-
2.2.0.0

ArubaOS 8.5.0.0-2.0.0.4

Aruba 7210, 7220,
and 7240XM

ArubaOS 8.5.0.0-2.0.0.0 ArubaOS 8.6.0.4-
2.2.0.0

ArubaOS 8.5.0.0-2.0.0.4

Aruba 7030  ArubaOS 8.1.0.0-1.0.4.0 ArubaOS 8.6.0.4-
2.2.0.0

ArubaOS 8.4.0.0-2.0.0.4

Aruba 7024  ArubaOS 8.1.0.0-1.0.4.0 ArubaOS 8.6.0.4-
2.2.0.0

ArubaOS 8.4.0.0-2.0.0.4

Aruba 7010  ArubaOS 8.1.0.0-1.0.4.0 ArubaOS 8.6.0.4-
2.2.0.0

ArubaOS 8.4.0.0-2.0.0.4

Aruba 7008  ArubaOS 8.1.0.0-1.0.4.0 ArubaOS 8.6.0.4-
2.2.0.0

ArubaOS 8.4.0.0-2.0.0.4

Aruba 7005  ArubaOS 8.1.0.0-1.0.4.0 ArubaOS 8.6.0.4-
2.2.0.0 ArubaOS 8.4.0.0-2.0.0.4

The following table lists the Aruba Gateway platforms and ArubaOS software versions that function as VPN
Concentrators:

Platform Minimum Supported
Software Version

Latest Software
Version

Recommended Software
Version

Aruba 7280 ArubaOS 8.4.0.0-1.0.6.0 ArubaOS 8.6.0.4-
2.2.0.0

ArubaOS 8.4.0.0-2.0.0.4

Aruba 7240XM  ArubaOS 8.1.0.0-1.0.4.0 ArubaOS 8.6.0.4-
2.2.0.0

ArubaOS 8.4.0.0-2.0.0.4

Aruba 7220  ArubaOS 8.1.0.0-1.0.4.0 ArubaOS 8.6.0.4-
2.2.0.0

ArubaOS 8.4.0.0-2.0.0.4

Aruba 7210 ArubaOS 8.1.0.0-1.0.4.0 ArubaOS 8.6.0.4-
2.2.0.0

ArubaOS 8.4.0.0-2.0.0.4

vGW-4G ArubaOS 8.4.0.0-1.0.6.0 ArubaOS 8.6.0.4-
2.2.0.0

ArubaOS 8.4.0.0-2.0.0.4

vGW-2G ArubaOS 8.4.0.0-1.0.6.0 ArubaOS 8.6.0.4-
2.2.0.0

ArubaOS 8.4.0.0-2.0.0.4

vGW-500M ArubaOS 8.4.0.0-1.0.6.0 ArubaOS 8.6.0.4-
2.2.0.0

ArubaOS 8.4.0.0-2.0.0.4

Aruba 7030 ArubaOS 8.1.0.0-1.0.4.0 ArubaOS 8.6.0.4-
2.2.0.0

ArubaOS 8.4.0.0-2.0.0.4

Table 4: Supported Aruba VPN Concentrators
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Platform Minimum Supported
Software Version

Latest Software
Version

Recommended Software
Version

Aruba 7024 ArubaOS 8.1.0.0-1.0.4.0 ArubaOS 8.6.0.4-
2.2.0.0

ArubaOS 8.4.0.0-2.0.0.4

Aruba 7010 ArubaOS 8.1.0.0-1.0.4.0 ArubaOS 8.6.0.4-
2.2.0.0

ArubaOS 8.4.0.0-2.0.0.4

Table 4: Supported Aruba VPN Concentrators

Aruba Virtual Gateways also function as VPN Concentrators. The minimum supported software version
for Virtual Gateways is ArubaOS 8.1.0.0-1.0.4.1.

Data sheets and technical specifications for the supported Gateways are available at:
https://www.arubanetworks.com/products/networking/gateways-and-controllers/

The following table lists the hardware platforms and ArubaOS software versions for Aruba Switches and
Instant APs that can be deployed in the branch:

SD Branch Component Hardware Platforms Minimum Software
Version

Aruba Switches Aruba 3810 Switch Series KB.16.05.0007 or later

Aruba 5400R Switch
Series

KB.16.05.0007 or later

Aruba 2920 Switch Series WB.16.05.0007 or later

Aruba 2930F Switch
Series

WC.16.05.0007 or later

Instant APs Aruba 310 Series and 300
Series Instant APs

Aruba Instant 6.5.3.x
Aruba Instant 8.3.0.0 or
later

Table 5: SD Branch Site Devices

https://www.arubanetworks.com/products/networking/gateways-and-controllers/


Chapter 3
Getting Started

Getting Started
To start using the SD-WAN solution, ensure that you have a valid Aruba Central subscription and licenses for
the SD-Branch devices.

n If you are an existing Aruba Central customerwith a valid subscription key and device licenses, access the
Aruba Central UI and complete the provisioning tasks.

n If you are an existing Aruba customerwith valid device licenses, but not an Aruba Central customer, sign up
for Aruba Central. After a successful registration, Aruba sends a verification e-mail with a link to the Aruba
Central portal. Formore information, see Aruba Central Help Center.

Aruba Central offers a 90 day evaluation subscription for customers who want to try the Aruba cloud
solution for managing their networks. When you sign up for Aruba Central, an evaluation subscription
is automatically assigned, unless you purchased a subscription. To purchase subscriptions, contact the
Aruba support team.

Gateway Provisioning Tasks

Complete the following provisioning tasks to bring up your devices in the Aruba Central management
interface:

n Onboard Devices

n Assign Subscriptions

n Assign Devices to Sites

n Assign Labels

n Assign Groups

n Assigning a Group Role or Persona

n Provision Gateways

n Open Firewall Ports for Device Communication

Onboarding Devices to Aruba Central
If you are a registered Aruba Central portal user, Aruba Central automatically retrieves the devices associated
with your account and adds it to the device inventory. To verify, if the devices are added to Aruba Central's
device inventory, navigate to Global Settings > Device Inventory in the Aruba Central UI.

The users with the evaluation subscriptionmay have to add the devices manually using their Aruba
Activate credentials.

n If the devices are listed in the inventory, proceed to assign devices to groups, labels, and sites.

n If the devices do not show up in the inventory, click Sync Now to synchronize the inventory with the
Activate database.

n If the devices do not show up in the inventory even after the sync operation, manually add these devices.

Aruba SD-WAN Solution | User Guide 15
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Manually Adding Devices to Inventory
Tomanually add the devices, on theDevice Inventory page, click one of the device addition options
described in the following table:

Device Addition
Method Description

Add by MAC
Address/Serial Number

Allows you to add devices based onMAC address and serial numbers. You can
add up to 32 devices.

Add with Cloud Activation
Key

Allows you to addmultiple devices from a single purchase order by using the
cloud activation key. To add devices:

1. Enter the Cloud Activation Key andMAC address of the device.
2. Click Add. Aruba Central retrieves all devices that belong to the same
purchase order and displays the list.

Add Using Activate Allows you to retrieve the devices associated with an Activate user account.
To add devices:

1. Enter the username and password of the Activate user account.
2. Click Add. The devices associated with the Activate account are retrieved
and added to the list of devices displayed on the Device Inventory page.

NOTE: You can use this option only once. After the devices are added, Aruba
Central does not allow you to modify or re-import the devices using your Aruba
Activate credentials.

Table 6: Adding Devices

Assigning Subscriptions to Aruba Gateways
For Aruba gateways to start functioning, youmust onboard them to the device inventory in Aruba Central
and ensure that a valid subscription is assigned to each gateway. A valid subscription allows the gateway to
bemanaged by Aruba Central.

This section includes the following topics:

n Gateway Subscriptions

n Gateway Subscriptions with Security License

n Virtual Gateway Subscriptions

Gateway Subscriptions
Aruba Central supports the following types of subscriptions for gateways:

n DM Assigned—Displays whether the devicemanagement subscription has been assigned.

n Unassigned—Select gateway(s) and select Unassigned from the drop-down list to unassign the
subscription.

n Foundation—This subscription can be assigned to these gateways:
o Aruba 70xx series
o Aruba 72xx series
o Aruba 90xx series
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n Foundation-Base—This subscription can be assigned to Aruba 70xx series and Aruba 90xx series
Gateways. Gateway devices with the Foundation-Base capacity subscription can support up to 75 client
devices per branch.

When the client capacity reaches the threshold:
o Aruba Central triggers theGateway base license capacity limit exceeded alert.
o If the notification options for theGateway base license capacity limit exceeded alert is configured,

Aruba Central sends an email notification with a list of Aruba gateways that exceed the client capacity
threshold. You can also configure alerts to trigger an incident usingWebhook. .

n Advanced—This subscription is available for all Aruba gateways. It allows users to use advanced features
and services such as SaaS Express. This subscription can be assigned to these gateways:
o Aruba 70xx series
o Aruba 72xx series
o Aruba 90xx series

Gateway Subscriptions with Security License
The following gateway subscriptions are packaged along with security license that includes the Intrusion
Detection and Prevention System (IDPS) feature. These subscriptions can be assigned to Aruba IDPS
supported gateways:

n Foundation with Security—All features of a Foundation subscription along with security license.

n Foundation-Base with Security—All features of a Foundation-Base capacity subscription along with
security license.

n Advanced with Security—All features of an Advanced subscription along with security license.

You can evaluate Aruba IDPS with Advanced with Security subscription for a period of 90 days.

Assigning Subscriptions to Gateways
To assign subscription to a gateway, complete the following steps:

1. In theAccount Home page, underGlobal Settings, click Subscription Assignment.
The Subscription Management page is displayed.

2. UnderGateway Subscriptions, select the device to which you want to assign a subscription.

3. Expand the drop-down in theAssignment column for the selected device.

4. Select the subscription; for example, Foundation.

5. To assign subscription to multiple devices:

a. Select the devices in the table.

b. Click Batch Assignment.

c. Select the subscription to assign.

When a subscription assigned to a gateway expires, Aruba Central automatically assigns a valid subscription
from the same subscription category.
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When you assign a subscription with security license, the gateways reboot to enable the traffic
inspection engine for the first time. It is recommended that you apply the security license after
business hours, as this might result in a downtime in the network.
When assigning subscriptions, if you change a subscription with security license to a subscription
without a security license, youmust reboot the gateway manually to release the CPU resources that
were assigned to the traffic inspection engine. It is recommended to reboot the gateway after
business hours, as this might result in a down time in the network.

Virtual Gateway Subscriptions
Aruba Virtual Gateway is a virtual instance of headend gateway for SD-WAN. Aruba Central supports
licenses based on the bandwidth capacity for virtual gateways. All license assignments are undertaken by
the virtual gateway orchestration app.

Aruba Central supports VGW licenses that cater to a variety of requirements. The options include one, three,
and five year periods and the bandwidth options are 500 Mbps, 2 Gbps, and 4 Gbps capacity licenses.

The base SKUs available are: VGW-500M, VGW-2G, and VGW-4G. The availability of SKUs is also dependent
on the installation consuming the license.

The account maintains a pool of VGW licenses, upon license expiry or if the license pool has no licenses left
(all consumed) the license is unassigned from the account. When deployed without valid or paid licenses,
four evaluation (90 day) licenses of each base SKU is allocated to every customer account.

License consumption can be tracked in theKey Management or Subscription Assignment pages.
The list of licenses available against consumed licenses are also displayed during the deployment of a virtual
gateway.

When the client capacity reaches the threshold:

n Aruba Central triggers theGateway base license capacity limit exceeded alert.

n If the notification options for theGateway base license capacity limit exceeded alert is configured,
Aruba Central sends an email notification with a list Aruba virtual gateways that exceed the client capacity
threshold. You can also configure alerts to trigger an incident usingWebhook. .

For Paid licenses email notifications are sent out in 30 day intervals starting at 90th day before
expiration and the last notification a day before the expiry of the license.
For Evaluation licenses email notifications are sent out on the 30th day before expiration and a day
before the expiry of the license.

Assigning Subscriptions to Virtual Gateways

1. UnderVirtual Gateway, select the device to which you want to assign a subscription.

2. Expand the drop-down in theAssignment column for the selected device.

3. Select the subscription SKU. For example, VGW-500MB.

4. To assign subscription to multiple devices:
Aruba Central automatically assigns a valid subscription to a virtual gateway. When a subscription
expires, Aruba Central automatically assigns a valid subscription from the same subscription
category.

For more information on available SKUs, contact your Aruba Sales Specialist.
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Assigning Gateways to a Group
A group in Aruba Central is a primary configuration element that acts like a container. In other words, groups
are a subset of one or several devices that share common configuration settings. Aruba Central supports
assigning devices to groups for the ease of configuration andmaintenance. For example, you can create a
common group for Branch Gateways that have similar configuration requirements.

Aruba Gateway Groups for SD-WAN Deployments
The device groups in Aruba Central support the following features:

n Combining Branch Gateways of identical characteristics and configuration requirements under a single
group.

n Creating groups according to your branch requirements.
o You can create separate groups for the small, medium, and large sized branches.
o You can also create separate groups for the branch sites in different geographical locations; for example,

East Coast andWest Coast branch sites. If these groups have similar characteristics withminor
differences, you can create the first group and then clone it.

o You can use either a single group for all the devices or deploy devices inmultiple groups. For example,
you can deploy 7008 controllers and Aruba 2930F Switch Series with 24 ports in a single group for every
branch.

o You can also deploy 7005 controller and Aruba 2930F Switch Series with 24 ports in one group and
provision 7008 controller with Aruba 2930F Switch Series with 48 ports in another group.

n Provisioning Branch Gateways and VPN Concentrators in separate groups. As the configuration
requirements for Branch Gateways and VPN Concentrators are different, the Branch Gateways and
VPN Concentratorsmust be assigned to different groups.

n Combining different types of devices under a group. For example, a group can have Instant APs, switches,
and SD-WAN gateways. .

Important Points to Note
n The groups in Aruba Central are not device-specific, so you can provision Branch Gateways, switches, and

Instant APs in a single group. However, VPN Concentrators and Branch Gatewaysmust be assigned to
different groups.

n A device can be part of only one group at any given time.

n After assigning the SD-WAN gateways to groups, youmust set the group persona or role as Branch
Gateway or VPN Concentrator.

To assign gateways to a group, complete the following steps:

1. In theNetwork Operations app, set the filter to Global.
The dashboard context for the selected filter is displayed.

2. UnderMaintain, click Organization > Groups.
TheGroups page is displayed. By default, theGroups page is displayed.
3. UnderManage Groups, from the devices table on the right, select the gateway that you want to
assign to a new group.

4. Drag and drop the device to the group to which you want to assign the device.

5. Click Yes in the confirmation dialog box.
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If the group is not available in the list, click New Group to create a new group, and then drag and drop
the gateways to the group that you just created.

Assigning Gateways to Sites
A site in Aruba Central refers to a physical location where a set of devices are installed; for example, campus,
branch, or a venue. You can create a branch or campus site; for example Branch A or Campus A, for a
specific geographical location and assign devices to it. You can use these sites as filters for viewing your
deployment topology, monitoring network and device health.

To assign gateways to a site, complete the following steps:

1. In theNetwork Operations app, set the filter to Global.
The dashboard context for the selected filter is displayed.

2. UnderMaintain, click Organization > Sites and Labels.
The Sites and Labels page is displayed. By default, the Sites page is displayed.

3. UnderManage Sites, locate the site to which you want to assign a device.

You can also add a new site by clicking New Site and providing details, such as site name and
address.

4. Click Unassigned to view devices that are not assigned to any site.

5. Select one or several devices from the list of devices.

6. Drag and drop the devices to the site on the left.

7. Click Yes in the confirmation dialog box.

Formore information, see Sites in Aruba Central documentation.

Assigning Labels to Gateways
In Aruba Central, labels refer to the tags attached to a device provisioned in the network. You can use labels
for tagging devices to a specific area in a physical location, to an owner or a specific branch, or a business
unit. You can use these labels as filters formonitoring branch and device health, and generating reports.

To assign a label to a gateway, complete the following steps:

1. In theNetwork Operations app, set the filter to Global.
The dashboard context for the selected filter is displayed.

2. UnderMaintain, click Organization > Sites and Labels.
The Sites and Labels page is displayed. By default, the Sites page is displayed.

3. Use the toggle switch to access the Labels page.

4. Locate the label to which you want to assign a device. You can also create a new label by clicking
Add Label and providing a label name.

5. In the table that lists the labels, you can perform one of the following actions:
n Click All Devices to view all devices.

n Click Unassigned to view all the devices that are not assigned to any labels.
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6. Select Unassigned. A list of devices that are not assigned to any label is displayed.

7. Select one or several devices from the list of devices.

8. Drag and drop the selected devices to a specific label. A pop-up window opens and prompts you to
confirm the label assignment.

9. Click Yes in the confirmation dialog box.

Formore information, see Labels in Aruba Central documentation.

Assigning a Group Role to an Aruba Gateway Group
The termpersona in Aruba Central refers to a group role that you can set for the device groups. To deploy
gateways for the SD-WAN orWLAN solution, youmust configure a group role to designate gateways as
Branch Gateways or VPN Concentrators.

To assign a group role to the gateways in a group, complete the following steps:

1. In theNetwork Operations app, set the filter to one of the options underGroups. Ensure that the
group selected contains at least one active gateway.

The dashboard context for the selected group is displayed.

2. UnderManage, click Devices > Gateways.

3. A list of gateways is displayed in the List view.

4. Click theConfig icon.

5. In the Set Group Type pop-up window, select the group role asBranch Gateway orVPNC.

6. Select a group role and save settings.

After you define a group role as a VPNC or Branch Gateway, Aruba Central does not allow you to edit
or modify the group role.
You can configure Aruba IDPS only on Aruba 9004 gateways. For the current release, Aruba 9004
gateways can be deployed only as Branch Gateways.

Gateways in MSP Mode
Aruba Central does not support managing gateways at theMSP level. However, gateways can be configured
andmanaged at the tenant account level. The persona of a default group at the tenant account level in MSP
is set to Branch Gateway. The VPNC option is disabled.

Connecting Aruba Gateways to Aruba Central
The Aruba gateways have the ability to automatically provision themselves and connect to Aruba Central
once they are powered on. The gateways also support multiple active uplinks for ZTP (also referred to as
automatic provisioning). The supported ZTP ports for different hardware platforms are listed in the
following table. All these ZTP ports are assigned to VLAN 4094.
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ArubaOS Hardware Platform Supported ZTP Ports

Aruba 7005 Gateway ALL ports except 0/0/1

Aruba 7008 Gateway ALL ports except 0/0/1

Aruba 7010 Gateway ALL ports except 0/0/1

Aruba 7030 Gateway ALL ports except 0/0/1

Aruba 7024 Gateway ALL ports except 0/0/1

Aruba 7210 Gateway ALL ports except 0/0/1

Aruba 7220 Gateway ALL ports except 0/0/1

Aruba 7240 Gateway ALL ports except 0/0/1

Aruba 7280 Gateway ALL ports except 0/0/1

Aruba 9004 Gateway ALL ports except 0/0/1

Aruba 9004-LTE Gateway ALL ports except 0/0/1

Aruba 9012 Gateway ALL ports except 0/0/1

Table 7: ArubaOS Hardware Platforms and Supported ZTP
Ports

To know theminimum software version required for the gateways, see Supported SD-Branch Components.

To automatically provision the gateways:

1. Connect your SD-WAN gateway to the provisioning network.

2. Wait for the device to obtain an IP address through DHCP. Gateways support multiple uplink ports.
The first port to receive theDHCP IP connects to the Activate server and completes the provisioning
procedure:

n If the device has factory default configuration, it receives an IP address through DHCP, connects to
Aruba Activate, and downloads the provisioning parameters. When a device identifies Aruba Central
as itsmanagement entity, it automatically connects to Aruba Central.

n If the device is running a software version that does not have the SD-WAN image, the devices are
automatically upgraded to a supported SD-WAN software version.

3. Observe the LED indicators. Table 2 describes the LED behavior.

LED Indicator LCD Text Description

Solid Amber Getting
DHCP IP

Indicates that the uplink connection is UP, but DHCP IP is yet to be
retrieved.

Blinking Amber Activate
Wait

Indicates that the device was able to reach the DHCP server and the
connection to the Activate server is yet to be established.

Table 8: LED Indicators
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LED Indicator LCD Text Description

Solid Green Activate
OK

Indicates that the device was able to retrieve provisioning parameters
from the Activate server.

Alternating Solid
Green and Amber

Activate
Error

Indicates that the device was not able to retrieve provisioning parameters.

Table 8: LED Indicators

After successfully connecting to Aruba Central, the gateways download the configuration fromAruba
Central and reload.

The gateways also include service ports that the technicians can use for manually provisioning devices
in the event of ZTP failure. For more information on ports available for Aruba 7000 Series Mobility
Controllers and Aruba 7200 Series Mobility Controllers, see ArubaOS User Guide.

Recovering an Aruba Gateway
The following procedure outlines the steps to recover an account using the disaster-recovery on

command and thebranchsupport account options.

Using the disaster-recovery on command in the Gateway's Local
Configuration
Using the disaster-recovery on command allows you to enable the configmode edit the config in the
Aruba Central local Gateway-node.

In the local gateway-node screen, you canmake changes to the configuration that enable communication
between the gateway and Aruba Central.

1. Ensure the configuration sent to the gateway allows communication with Aruba Central. This can be
verified by executing a show aruba-central details from the CLI.

2. In Aruba Central CLI, execute show configuration effective <path to local-node of Gateway>

command.

3. When you turn disaster-recovery off using the disaster-recovery off command, the gateway
contacts Aruba Central again and synchronizes the configuration.

If Aruba Central reverts to the earlier non-functional state, recheck and test the configuration used.

Using the branchsupport account
Thebranchsupport account allows the network administrator to gain access to a gateway that is in the
factory default state and is failing to connect to Aruba Central.

To prevent security loopholes, this account is deleted automatically as soon as the device gets any
configuration pushed fromAruba Central.

Thebranchsupport account is only available when:

n There is no configured admin account.

n Themanaged device is not in contact with the Aruba Central.

To access thebranchsupport account, use these credentials:
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n Username—branchsupport

n Password—mac-address-lowercase-colondelim

Configuring Communication Ports
The SD Branch appliances useHTTPSWebSockets and IPsec tunnels for secure communication.

n TheHTTPSWebSockets is used for themanagement traffic; that is, for communication between Aruba
Central and Aruba gateways.

n The IPsec tunnel is used for communication between Branch Gateways and VPN Concentrators.

For a complete list of domain URLs, ports, and protocols that youmust allow over a network firewall, see
Opening Firewall Ports for Device Communication in Aruba Central Help Center.

When configuring ACLs to allow traffic over a network firewall, Aruba recommends that you use the
domain names instead of IP addresses. For more information on ACLs, see Configuring Firewall
Policies and ACLs on page 289.
For Branch Gateways to set up IPsec tunnel with the VPN Concentrators, the UDP 4500 port must be
open. For more information on firewall ports required for communication between Aruba gateways
and other network elements, see ArubaOS User Guide.

Certificates
By default, Aruba Central includes a self-signed certificate that is available on theCertificates page. The
default certificate is not signed by a root certificate authority (CA). For devices to validate and authorize
Aruba Central, administratorsmust upload a valid certificate signed by a root CA.

Aruba devices use digital certificates for authenticating a client's access to user-centric network services.
Most devices such as controllers and Instant APs include a server certificate by default for captive portal
server authentication. However, Aruba recommends that you replace the default certificate with a custom
certificate issued for your site or domain by a trusted CA. Certificates can be stored locally on the devices
and used for validating device or user identity during authentication.

Aruba Central-managed devices such as Instant AP and switches support the following root CA certificates:

Instant APs Switches

n AddTrust
n GeoTrust
n VeriSign
n Go Daddy

n Comodo
n GeoTrust

Uploading Certificates
To upload certificates, complete the following steps:

1. In theNetwork Operations app, set the filter to Global.

2. UnderMaintain, click Organization.

3. Select theCertificates tab.
TheCertificates page opens.
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4. Click the plus icon to add the certificate to the certificate store.

5. In theAdd Certificate dialog box, do the following:

a. In theName text box, specify the certificate name.

b. Select the type of certificate. You can select any one of the following certificates:
n CA —Digital certificates issued by the CA.

n Server—Server certificates required for communication between devices and authentication servers.

n CRL—Certificate Revocation List that contains the serial numbers of certificates that have been
revoked. This certificate is required for performing a certificate revocation check.

n OCSP Responder Cert—OCSP responder certificates.

n OCSP Signer Cert—OCSP Response Signing Certificate.

OCSP certificates are required for OCSP server authentication.

c. From the Format drop-down list, select a certificate format; for example, PEM, DER, and PKCS12.

d. In the Passphrase text box, enter a passphrase.

e. In theRetype Passphrase text box, retype the passphrase for confirmation.

The Passphrase and Retype Passphrase text boxes are displayed only when you select Server
Certificate from the Type drop-down list.

f. In theCertificate File field, click Browse and select the certificate files.

g. Click Add. The certificate is added to the Certificate Store.

Managing Certificates on Instant APs Configured Using Templates
Aruba Central supports uploadingmultiple certificates to Instant APs configured using templates. You can
manage certificates either from the Aruba Central UI or through the API Gateway. Formore information
about APIs, see API Documentation.

To push certificates to Instant APs configured using templates:

1. Upload certificate(s) through one of the followingmethods:
n UI—SeeUploading Certificates on page 24.

n API—Use the [POST] /configuration/v1/certificates API.

2. Get the certificate name andMD5 checksum through one of the followingmethods:
n UI—In theNetwork Operations app, filterAll Devices. UnderMaintain, click Organization and

select theCertificates tab. TheCertificate Store table displays these details.

n API—Use the [GET] /configuration/v1/certificates API.

3. In the template, anywhere before theper-ap settings block, depending on your requirement, add
one ormore of the following commands:

ca-cert-checksum <ca_cert_checksum/ca_cert_name>

cp-cert-checksum <captive_portal_cert_checksum/captive_portal_cert_name>

radsec-ca-checksum <radsed_ca_checksum/radsed_ca_name>
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radsec-cert-checksum <radsed_cert_checksum/radsed_cert_name>

server-cert-checksum <server_cert_checksum/server_cert_name>

You can either use the certificate name or the checksum value in the command. Or, you can set
it as a variable and enter the variable value for the Instant AP. Aruba recommends using the
certificate name.

Example 1

ca-cert-checksum my_default_cert

Example 2

ca-cert-checksum %ca_cert_name%

variable:

{

"ca_cert_name": "my_default_cert"

}



Chapter 4
Provisioning Aruba Gateways in Aruba

Central

Provisioning Aruba Gateways in Aruba Central
Aruba Central offers the following options to configure Gateways for SD-WAN deployments:

n Groups—You can create a logical subset of devices as groups. If you have devices that must share common
configuration settings, ensure that you assign these devices to the same group. Any new device joining a
group inherits the configuration that is already applied to the devices in a group. Similarly, you can also
maintain separate groups for Branch Gateways and VPN Concentrators by assigning a group role for the
devices. Formore information, see Assigning Gateways to a Group on page 19.

n Device-specific configuration—If you have considerably lesser number of devices that do not have the
same configuration requirements, you can apply configuration changes at the device level. In some cases,
although the devices are assigned to a group, youmay want to have a slightly different configuration to one
specific device in a group. In such cases, you canmodify the device configuration and apply changes at the
device level. Aruba Central marks the discrepancies in the group and device configuration as overrides on
the Configuration Audit page.

n Bulk Configuration—Aruba Central supports several bulk configuration options for Aruba Gateways:
o Bulk Configuration Upload—Allows you to download a list of Aruba Gateways fromAruba Central in the

CSV file format. You can add the configuration parameters for host name, system IP address, VLAN, and
Ports, and then upload the CSV file to Aruba Central. Formore information, see Uploading Bulk
Configuration Template on page 159.

o Gateway Pools—Allows you to create a common pool of IP addresses and enables automatic assignment
of IP addresses to Aruba Gateways. Formore information, see Configuring Gateway Pools for Aruba
Gateways on page 153.

o DHCP Pools—Allows you to configure a DHCP pool, using which Aruba Central automatically assigns a
subnet to each ArubaGateway for a given VLAN. Formore information, see Configuring DHCP Address
Pools on ArubaGateways on page 154.

n APIs—Allows you to configure andmonitor devices using NB APIs.

Different Modes of Configuring Gateways and
Gateway Groups
Aruba Central supports the followingmethods to configure Gateway groups and Gateways.

n Guided Setup—You can use theGuided Setup to quickly configure basic and essential parameters on
ArubaGateways for deploying the SD-WAN solution. TheGuided Setup provides awizard-based workflow
for provisioning Gateways. Thewizard allows you to configure Gateways at your own pace, pause, and
resumewhen required. However, the Guided Setup will not be available after you complete the
provisioning workflow for a Gateway group or a Gateway.

Formore information on configuring Gateways using theGuided Setup, see the following topics:
o Configuring Branch Gateways Using theGuided Setup
o Configuring Branch Gateway Groups Using theGuided Setup
o Configuring VPN Concentrator Group Using theGuided Setup
o Configuring VPN Concentrators Using theGuided Setup
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n Basic Mode—Allows you to configure your Gateways in a non-linear fashion. Thismode allows you to
make configuration changes after you provision your gateways for the first time using Guided setup.

Figure 4 Basic Mode

n Advanced Mode—Allows you to configure advanced features for SD-WAN deployments. Formore
information, see Configuring an SD-Branch Network Using the Advanced Setup

Figure 5 Advanced Mode

n Before you proceed with the configuration tasks, browse through the recommendations and best practices
described in the Aruba SD-Branch Fundamentals Guide and Aruba SD-Branch Security Hardening Guide.

Configuring Branch Gateway Groups Using the Guided
Setup
Aruba Branch Gateways operate at the branch to optimize and control WAN, LAN, and cloud security
services. The Branch Gateway provides features such as routing, firewall, security, website content filtering,
andWAN compression. With support formultipleWAN connection types, the Branch Gateway routes traffic
over themost efficient link based on availability, application, user-role, and link health. This allows
organizations to take advantage of high-speed, lower-cost broadband links to supplement or replace
traditional WAN links such asMPLS.

You can configure a Branch Gateway group or Branch Gateway device using either theGuided Setup, Basic
mode, or Advancedmode. This section describes the procedure to configure Branch Gateway groups using
theGuided Setup.

Before You Begin
Ensure that you have completed the following procedures:

n Gateways are onboarded to Aruba Central.

n Gateways are assigned valid subscriptions in Aruba Central.

n Gateways are assigned to groups.

n Gateways are assigned the Branch Gateway group role.

Ensure that the devices in the group are not running the guided setup at device level. If the device is
being configured using the Guided Setup, the group level setup will not be executed.

Configuring a Branch Gateway Group using the Guided Setup
To configure a Branch Gateway group, complete the following steps:

1. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway.
The dashboard context for a group is displayed.

https://community.arubanetworks.com/t5/Validated-Reference-Design/SD-Branch-Fundamentals-Guide/ta-p/482038
https://support.arubanetworks.com/Documentation/tabid/77/DMXModule/512/Default.aspx?EntryId=34365
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2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click theConfig icon.
The gateway group configuration page is displayed.

If you are accessing the Branch Gateway group configuration page for the first time, theGuided
Setupwizard opens automatically. Otherwise, click Guided Setup.

TheGuided Setupwizard displays the following tabs:

n System—Allows you to configure systemparameters.

n LAN—Allows you to configure LAN interfaces.

n WAN—Allows you to configureWAN interfaces.

n SD-WAN & Routing—Allows you to configure an SD-WAN overlay and routing profiles.

n Policies—Allows you to configure various traffic policies such as User Roles, Applications, WAN and
QoS, and security policies also.

4. Click Begin to start the guided setup process and complete the steps provided in the following
sections:

a. Configuring SystemParameters for a Branch Gateway Group.

b. Configuring a LAN Interface for a Branch Gateway Group.

c. Configuring aWAN Interface for a Branch Gateway Group

d. Configuring VPN Hubs and Routing Profiles for a Branch Gateway Group.

e. Configuring Policies for a Branch Gateway Group.

Many procedures involve adding or configuring parameters in tables. Note that you have options to

edit and delete the existing configurations.

Configuring System Parameters for a Branch Gateway Group
Before you begin, ensure that the following conditions are satisfied:

n Every Aruba Gateway must have a System IP assigned, in order to be fully-functional. Aruba Central does
not send any configuration to a Branch Gateway unless it has a System IP assigned to the device.

Control plane traffic such as RADIUS, TACACS+, SNMP, and Syslog are sourced from the System IP
address.

n Other parameters such as NTP and DNS are also required for the device’s operation.

To configure systemparameters, complete the following steps:

1. In the System tab configure a System IP using one of the following options:
n Define system IP address pool—Select this option to define an IP address pool for the gateways

in this group. You can configure an IP address range by providing the start and end IP addresses.
Aruba Central automatically allocates an IP address to each gateway, and assigns it to VLAN 4087
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which is the System IP address of the device.

n Specify static IP addresses later—Select this option to configure the system IP address at the
device level.

2. Click Next.
TheModel page is displayed.

3. Select the Gateway from theModel drop-down list.

4. Click Next.
The Time page is displayed. Configure theNTP server for system clock synchronization. The
system automatically updates the time zone including the relevant daylight savings time (DST)
across time zones. you can optionally specify a time zonewhich is applied to all the gateways in
the group. The default time zone is set to GMT.

5. In the Public NTP Servers table, click + to add a Public NTP Provider:
n IPV4 Address/FQDN—Enter the IPV4 address or the FQDN of the public NTP provider to add the

NTP servers to the Branch Gateways in this group.

n Burst Mode—Select this option to expedite the system clock calibration.

n Timezone—Choose the time zone from the drop-down list. The list contains a list of Primary time
zones followed by other time zones.

6. Click Next.
TheDNS page is displayed.

7. Select one of the following options to configure a DNS server:
n Specify DNS servers—Select this option to configure a DNS server and define the following

parameters:
a. Enter aDomain name.

b. Click + to add a Public DNS server. You can select one ormoreDNS service providers from
the list or you can select User Defined for Provider and specify the IPv4 addresses of two or
more public DNS name servers.

c. Enter the IPv4 address if you have selected User Defined for provider. If you have selected
theDNS service providers from the list, the IP addresses will be auto-populated.

n Learn DNS server from ISP—Select this option if you want the gateway to learn theDNS server
dynamically from the ISP.

The DNS servers configured here are the ones that the gateway uses to resolve addresses. It
must be reachable through the underlay as the device needs it to communicate with and the
SD-WAN Orchestrator.

8. Click Next.

TheManagement User page is displayed.
Amanagement user refers to the admin user with credentials to log in to the local management interface
of the device.

1. To add a user, click + in the Local Management Users table. TheAdd management user pop-up
is displayed.
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2. Enter the user name and password that you want to configure.

3. Select a user role from theRole drop-down. The following options are available:
n Super user role—Administrator user role.

n Guest provisioning role—Administrator role for provisioning guest users.

n Read only—Read-only user role.

4. Click Save.

5. To authenticate an admin user using AAA policy, turn on theAAA authentication toggle switch.

6. Click + in theAAA Servers table to create an AAA server for authenticating devicemanagement user.
TheAdd AAA server pop-up is displayed.

7. Configure the following parameters:
n Name—Nameof the authentication server.

n Server IP—IP address of the authentication server.

n AAA authentication—Enables centralizedmanagement user authentication using RADIUS or
TACACS servers. For each AAA server, youmust specify the IPv4 address or FQDN of the servers
along with the protocol and shared secret.

n Key—Shared key for authenticating a device administrator.

n Retype key—Enter the key again to confirm.

8. Click Save.

9. Review the summary page and click Finish.

Finish button is disabled if there are any errors in the configuration. Resolve the errors to
proceed to the next step.

10. Click Continue to configure a LAN interface.

1. To relay the incoming DHCP requests to an external DHCP server, turn on the Enable DHCP Relay
toggle switch and add the IP address of the external DHCP servers.

2. Click Save.

3. Click Next.

Configuring a LAN Interface for a Branch Gateway Group
This section focuses on the LAN configuration of the Branch Gateways. By default, LAN interfaces have
LLDP enabled and a role-based security. However, this setting can be changed when you configure security
policies.

To configure VLANS on Branch Gateway group:

1. In theVLAN tab, select the IP DHCP server check box for the gateways to act as DHCP servers.

2. Click + in theVLANs table to add a new VLAN.

3. Enter the VLAN name.

4. Enter the VLAN ID.

5. Select one of the following IP addressing mode from the drop-down list:
n Static—Select this option to use a static IP address. If you want to configure the LAN IP addresses at

the device level, leave the IPv4 address and netmask fields empty. You can also set the same static
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IP/netmask for all the devices in the group.
o IPV4 Address—Enter a unique static IP address for each gateway in the group or a common

address for all gateways in the group.
o Netmask—Enter the subnet mask of the IP address.

Ensure that this VLAN is not routable, as it will overlap with the other gateways.

n Dynamic DHCP Pool—Select this option to assign IP address from a dynamically carved DHCP
pool. To configure an IP address range for dynamic assignment of DHCP IP addresses, configure the
following parameters:
o Dynamic DHCP Pool Start IP Address—The starting IP address in theDHCP pool that gateways

allocate to branch devices.
o Dynamic DHCP Pool End IP Address—The last IP address in theDHCP pool that gateways

allocate to branch devices.
o Hosts per Branch—The number of hosts per branch. This determines the subnet size that is

allocated to each Branch Gateway in the group.
o Domain name—TheDNS domain name assigned to branch devices.
o DNS server type—Type of theDNS server. You can use either a Public DNS Service or add a

DNS server by selecting theUser DefinedDNS option.
o DNS Service Provider—If you use a Public DNS Service, select the name of theDNS service

provider from the list. For example, Google.
o DNS Server IPv4 Addresses—The IPv4 address of the DNS server. You can specify up to eight IP

addresses separated by a comma.

6. To configure branch gateways as DHCP server, turn on theAct as DHCP server toggle switch and
configure the following parameters:
n Network—The network IP address.

n Netmask—The subnet mask of the network.

n Default Router—The IP address of the device used by clients if they want to communicatewith
devices outside of their subnet. Predominantly, this will be the Branch Gateway IP address for the
particular VLAN, or the VRRP virtual IP, if configured.

n Domain name—TheDNS domain name assigned to branch devices.

n DNS server type—Type of theDNS server. You can use either a public DNS server or add aDNS
server by selecting the user-defined DNS option.
o DNS Service Provider—If you use a Public DNS Service, select the name of theDNS service

provider from the list. For example, Google.
o DNS server IPv4 addresses—If you use aUser DefinedDNS server, enter the IP addresses

here. You can specify up to eight IP addresses separated by a comma.

7. Turn on the Enable DHCP relay toggle switch to relay the incoming DHCP requests to an external
DHCP server. Select this option when centralized DHCP servers are deployed to provide addressing
to branch devices or if device profiling is performed by services such as Aruba ClearPass.

8. Click + in the External DHCP Server table.

9. Add the IPV4 addresses.

10. Click Save.

11. Click Next.
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The LAN Ports page is displayed.

1. To add a LAN port, click + in the LAN Ports/Ports Channel table.

2. Enter aName for the port.

3. Select a port channel or a port from the Ports drop-down list.
n If you have selected Port Channel for the LAN port, configure the following parameters:

o Port channel protocol—Select a port channel protocol; for example, LACP (Link Aggregation
Control Protocol). If you have selected LACP, select the LACPmode as active or passive from the
LACP mode drop-down list.

o Port channel members—Select the port channelmembers.

4. Select one of the following VLAN modes:
n Access—Select this option to allow the LAN port to carry traffic only for the VLAN to which they are

assigned. All transmitted and received traffic on the port is untagged.

n Access VLAN—Select the VLAN ID assigned to the port or port channel.

n Trunk—Select this option to allow the LAN port to carry traffic formultiple VLANs. If you select the
Trunkmode, configure a list of allowed VLANs. The following options are available:

n Native VLAN—The untagged VLAN ID for the port or port channel.

n Allowed VLAN—The range of VLAN IDs assigned to the port or port channel including theNative
VLAN.

5. Click Next.

6. Review the summary page and click Finish.

7. Click Continue to configure aWAN interface.

Configuring a WAN Interface for a Branch Gateway Group
This section focuses on theWAN configuration of the branch gateways.

To configure aWAN interface, complete the following steps:

1. In theWAN tab, turn on the Enable health checks toggle switch.
TheWAN health check enables sending probes to measure availability and SLA of the uplinks.
When the health check feature is enabled, the probes are sent through the underlay at regular
intervals to verify if the Internet is reachable over the uplink interfaces configured on
Gateways.

2. Configure the following health check parameters:
n Health check destination—You can configure aUser defined IP address or use the default

Aruba cloud instance to sendWAN health check probes.

n Health check IP address—If it is aUser defined destination, enter the IPv4 address or FQDN of a
host that is reachable through theWAN paths outside the VPN tunnel.

n Health check probe mode—Select one of the following probemodes:
o Ping—Sends ICMP probes to measure latency and packet loss.
o UDP—Sends UDP Probes through UDP port 4500 to measure latency, packet loss, and jitter.

3. Click Next.
The Load Balancing page is displayed.
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4. Select one of the followingmodes for uplink load balancing:
n Round robin—Select this option to sequentially distribute outgoing sessions betweenWAN links. It

is the simplest algorithm to configure and implement, but may result in uneven traffic distribution
over time.

n Session count—Select this option to balance traffic among the uplinks based on the current
number of active sessionsmanaged by each link, so that the load for each active uplink stays within
5% of the other active uplinks. For example, if there are two active uplinks with theWeight
parameter defined as 10 and 20, the active uplink with aweight of 20 will havemore sessions
assigned.

n Uplink utilization—Select this option to distribute traffic between activeWAN uplinks based on
the utilization % of each activeWAN uplink. Uplink utilization considers the link speed to calculate
the utilization and allows amaximumpercentage of bandwidth threshold to be defined. When the
bandwidth threshold exceeds the defined value, theWAN uplink will no longer be considered for
session allocation. When you configureWAN ports, it is important that you configure theWAN
uplink speed appropriately.

5. Click Next.
TheWAN Details page is displayed. This section defines uplink interfaces by creatingWAN-facing
VLANs, labeling them as uplink interfaces, and assigning them to the desired uplink ports.

6. Turn on Enable HA deployment toggle switch to deploy LAN redundancy.

7. To add aWAN port, click + in theWAN Uplinks/Ports table.
TheAdd/Edit WAN Port pop-up is displayed.

8. Enter a name for theWAN port in theUplink field.

9. Select theWAN type from the drop-down list; for example, Internet, MPLS, orMetro-Ethernet.

10. Configure theWAN  speed. By default, theWAN uplink speed is set to 20 Mbps. You can configure a
custom value for uplink speed as per your requirements. The allowed range of values is 1–10000
Mbps.

11. To enable NAT for the outbound traffic on theWAN interface, select Source NAT.

12. To use the uplink in the standby mode, select theUse as backup check box. By default, all uplinks
operate as active uplinks.

13. Select an IP addressing method from the following options :
n DHCP—When selected, the IP address is dynamically assigned from aDHCP pool for the

WAN uplink.

n PPPOE—This is the Point to Point Protocol over Ethernet. When selected, you need to select an
authentication type to connect to the ISP.
o Turn on theGroup credentials toggle switch.
o Select an Authentication type. If you select Password Authentication Protocol (PAP), enter the

username and password for PPPoE authentication. If you select Challenge handshake
authentication protocol (CHAP), enter the user name and CHAP secret for authentication.

14. Select a port from the Port drop-down list.

a. If you select LTE, theWAN type field displays Cellular.

b. Select the connection type (Internal orUSB) in theCellular type drop-down list.

15. To apply the default inbound security ACL forWAN ports, select the Secure with ACL check box.
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16. Click Next.

17. Review the summary page and click Finish.

Finish button is disabled if there are any errors in the configuration. Resolve the errors to
proceed to the next step.

18. Click Continue to configure VPN hubs and routing profiles.

1. To use a DHCP server, turn on the Enable DHCP Server toggle switch and configure the following
parameters:

2. To relay the incoming DHCP requests to an external DHCP server, turn on the Enable DHCP Relay
toggle switch and add the IP address of the external DHCP servers.

3. Click Save.

4. Click Next.

Configuring VPN Hubs and Routing Profiles for a Branch Gateway
Group
To configure VPN hubs and routing profiles, complete the following steps:

1. In theDC Preference page, click + in theDC Preference table to add a VPN hub group.

2. Configure a primary and secondary VPNC .

3. Review the overlay topology configuration.

4. Click Next.
The Static Routing page is displayed.

5. To create a default route, click + in theDefault Routes table:
n Type—Select the default route type; Next Hop orVPNC.
n Next Hop/VPNC—Enter the IP address of theNext Hop or VPNC.

n Uplink—Select the uplink from the drop-down list.

n Cost—The cost metric of the route.

6. To create a static route, click + in the Static Routes table:
n Destination IP—The destination IP address.

n Destination mask—The subnet mask of the destination IP address.

n Type—Select the type of route.
o Nexthop—Select this option to configure a nexthop destination.
o Blackhole—Select this option to route packets to a Blackhole. Blackholes refer to places in the

network where incoming or outgoing traffic is discarded (or dropped), without informing the
source that the data did not reach its intended recipient. When examining the topology of the
network, the black holes themselves are invisible, and can only be detected by monitoring the lost
traffic.

n Next Hop—The IP address for the next hop.

n Cost—The cost metric for the route.

7. Click Next to configure an Overlay Routing profile.
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8. To allow Branch Gateways to Redistribute connected routes to hubs, select the VLANs to be
advertised.

9. To allow Branch Gateways to redistribute static routes, select theRedistribute static route check
box.

10. Click Next.

11. Review the summary page and click Finish.

Finish button is disabled if there are any errors in the configuration. Resolve the errors to
proceed to the next step.

12. Click Continue to configure security and traffic steering policies.

Configuring Policies for a Branch Gateway Group
In the Policies tab, you can configure the following types of policies on Branch Gateway groups:

n Role assignment policy—Policy for determining client access based on the user roles assigned to a client.

n Application usage policy—Policy for deep packet inspection of application usage by clients.

n Traffic steering policy—Policy for dynamically steering client traffic to best performing uplink.

n QoS policy—Quality of service (QoS) policy allows you to prioritize critical traffic, prevent bandwidth
hogging, andmanage network bottlenecks to prevent packet drops.

n Security policy—Firewall policies website content filtering.

Configuring a Role Assignment Policy

To configure a role assignment policy, complete the following steps:

1. In the Policies > Roles page of theGuided Setup wizard, click + to add a user role in theRoles table.
The policies that are associated to this role will be configured in subsequent steps.

2. Click + in theRole assignment table.

3. Select a VLAN ID to which this role needs to be applied, from theVLAN ID drop-down list.

4. Select a role from the Initial role drop-down list. This is the default user role that would be assigned
to the clients connecting through this VLAN.

5. To enable authentication, turn on theAuthentication toggle switch.

6. Select theDefault authentication role from the drop-down list.

7. Select one of the following authenticationmodes:
n MAC authentication—Select this check box to assign a role after a client device completesMAC

authentication. The default role forMAC authentication is the guest user role.
n 802.1X authentication—Select this check box to assign a role after a client device completes

802.1X authentication. You can also enableMAC authentication fail through to allow clients to
complete 802.1X authentication whenMAC authentication fails and vice-versa

8. Configure primary and backup authentication servers. This will define them as Authentication,
Accounting and CoA (RFC3676) servers.

9. To add a AAA server, click + in the Select AAA servers table and configure the following parameters:
n Name—The server name.

n Server IP—The IP address or FQDN of the server.
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n Password—The password to use for authentication.

n Retype Password—Confirm password.

10. Click Save.

11. Click Next to configure application policies.

Configuring Applications

To define applications, and other security aliases, complete the following steps:

1. In the Policies > Applications page of theGuided Setup wizard, view the list of applications and
application categories available for Branch Gateways to create a policy. Click + in the Applications
table and configure the following parameters to add an application or the application category with
the server name and the corresponding domain URI.:
n Name—Enter the name of the application.

n Category—Enter the application category.

n In the Servers table, click + to add the server name and theURL that the application uses.

2. View the list of network aliases that are available on Branch Gateways. To create a network alias, click
+ in theNetwork Aliases table and configure the following parameters:
n Name—Enter a name of the network alias.

n Description—Enter description text for the alias.

n Invert—Select this check box if you want to apply the firewall rules to all the destinations except the
one configured in the alias.

n User Rules—Click + to add user rules. The following rule types are available:
o Network—Allows you to configure a rule for a specific network IP address and subnet mask.
o Host—Allows you to configure a rule for a specific host IP address.
o Domain Name—Allows you to configure a rule for a specific domain name.
o Override Host—Allows you to configure a rule for overriding a specific host.
o Override VLAN—Allows you to configure a rule for overriding a specific VLAN.
o Range—Allows you to configure a rule for a range of IP addresses.

3. Click Save.

4. View a list of service aliases available on Branch Gateways. To create a service alias, click + in the
Service Aliases table and configure the following parameters:

a. Enter a value in the Service name field.

b. In the Protocol drop-down list, select one of the following options:
n TCP
n UDP
n Protocol

c. If you select Protocol, enter the IP protocol number in the Protocol number field.

d. If you select UDP or TCP, in the Port type drop-down list, select one of the following options:



Different Modes of Configuring Gateways and Gateway Groups | 38

n Range—If you select range to provide a contiguous list of ports, enter the starting and ending port
numbers in the Start port and End port fields, respectively.

n List—If you select List, enter a comma-separated list of port numbers in the Port list field.

e. To limit the service alias to a specific application, select a service type from the ALG (Application Level
Gateway) drop-down list.

5. Click Save.

6. Click Next to add a traffic steering policy.

Configuring a Traffic Steering Policy

To configure a traffic steering policy, complete the following steps:

1. In the Policies > DPS page of theGuided Setup wizard, view the list of default traffic policies. If you
want to create a new traffic steering policy, click + in theDPS table.

2. Enter the name of the policy and click Save.

3. Select the policy for which you want to set rules.

4. In the Traffic Rules for <Policy name> table, click the edit icon to create traffic specification rules
for the policy, and configure the following parameters.
n Source—Select one of the following options from the drop-down list to define a source point for

the traffic policy rule:
o Any—Applies rule to incoming traffic from any source.
o Host—Applies rule to traffic originating from a specific host IP address. Enter the host IP address.
o Network—Applies rule to the traffic that originates from a specific network. Enter the IP address

and the subnet mask of the source network.
o Alias—Applies rule to the traffic originating from an alias of a host or network. Select the Source

alias from the drop-down list.
o User Role—Applies rule to traffic originating from a specific user role. Select a user role from the

default list, or create a custom role.

n Destination—Select one of the following options to define a destination for the traffic policy rule:

n Any—Applies rule to the outgoing traffic to any destination.

n Host—Applies rule to the traffic routed to a specific host IP address. Enter the host IP address.

n Network—Applies rule to the traffic routed to a specific network. Enter the IP address and the
subnet mask of the source network.

n Alias—Applies rule to the traffic routed to a specific alias of a host or network. Select the Source
alias from the drop-down list.

n Application/Port—Select one of the following options for application or port:
o Application—Applies rule to the selected applications.
o Application category—Applies rule to the selected application categories
o Web category/Reputation—Applies rule to the selected web category based on reputation.
o Service—Applies rules to the selected services.
o TCP—Applies rules for the source and the destination ports.
o UDP—Applies rules for the source and the destination ports.
o Any—Applies the policy to all applications and application service ports.
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5. Click Save.

6. Review the default SLAs available for the traffic policy. To create an SLA profile, click the edit icon in
the SLA table.

The default list of SLA profiles is displayed. The default SLA profiles includeBestForInternet,
BestForVoice, BestForSaas, and HighlyAvailable. The threshold set in these profiles are just
placeholders and should be taken as best-practice values.

7. Click + to create a new SLA profile and configure the following parameters:
n Name—Nameof the SLA profile.

n Latency (MS)—The latency threshold inmilliseconds to measure the round-trip ping time.

n Jitter (MS)—The jitter threshold value inmilliseconds to measure if the packets are delivered in a
proper order.

n Loss (%)—The percentage of packet loss allowed.

n Utilization (%)—The percentage of bandwidth utilization as ametric to prioritize and load-balance
the traffic.

8. Click Save.

9. Review the default WAN uplink paths. To create a newWAN uplink path profile, click the edit icon in
theWAN Path table.

10. Click + to create a newWAN path profile and configure the following parameters:
n Primary path—Select a primary uplink path. For example, if you are configuring policies for critical

traffic such as voice or VOIP, you can set MPLS as the primary path. The list shows uplinks
configured on Branch Gateways. You can select multiple uplinks in a sequential order.

n Secondary path—Select a secondary uplink path to route traffic through the secondary path in the
event of failover or for load balancing. The session continues on the link as long as it is good
irrespective of the status of the primary uplink. When a primary path becomes active andmeets the
configured SLA, the new sessions are steered back to the primary path.

n Last resort path—Select a last-resort uplink path to route traffic through another path as a last
attempt (when both primary and secondary paths are down). When a session is steered to a tertiary
path, it stays on the link until the end. When a primary path becomes active andmeets the
configured SLA, the new sessions are steered back to the primary path.

11. Click Save.

12. Review the default bandwidth and QoS priority assigned for each policy. To edit the bandwidth
priority for a policy, select edit icon in theQoS and add aQoS profile with custom values for
thefollowing parameters:

13. Click Save.

14. Click Next to configureQoS policies.

Configuring a QoS Policy

To configure aQoS policy, complete the following steps:

1. In the Policies > QOS page of theGuided Setup wizard, review the bandwidth contracts, and QoS
priorities assigned for each role or an application.

2. To edit theQoS for a user role, select the user role in theRoles table. Click + in theQOS for Default-
VPN-Role table and configure the following parameters:
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3. Type—Select the policy type as Application or Application Category from the drop-down list.
n Enter theApplication orApplication category based on the policy type that is selected.

4. QOS Profile—Select one of the following from the drop-down list for QoS profile:
n Realtime—Select this option if the policy applies to realtime, delay-sensitive data transmission such

as audio and video conferencing.

n Transactional—Select this profile for applications such as SAP, PeopleSoft where the response time
required ismore than the generic client-server applications.

n Collaboration—Select this option for highly interactive applications that require user feedback such
as Instant Messaging applications.

n Best effort—This profile is used formajority of the data traffic unless the data requires a
preferential treatment.

5. Upstream B/W—Define the upstreambandwidth in Mbits or Kbits.

6. Downstream B/W—Define the downstreambandwidth in Mbits or Kbits.

7. Click Save.

8. Click Next to configure security policies.

You can view the DSCP marking for individual QoS profiles in the Show QOS Profiles table.

Configuring Security Policies

To configure Security Policies, complete the following steps:

In the Policies > Security Policies page of theGuided Setup wizard, view the list of roles and policies.

1. To add a role, click + in theRoles table.

2. To add a policy to a role, click + in the Policies table.

3. To add an access rule to a policy, click + in theRules table and configure the following parameters:
n Source —Select one of the following options from the drop-down list to define the source of the

traffic:
o Any—Applies a rule to incoming traffic from any source.
o User—Applies a rule to the traffic originating from a specific user.
o Host—Applies a rule to traffic originating from a specific host IP address. Enter the host IP

address.
o Network—Applies a rule to the traffic that originates from a specific network. Enter the IP

address and the subnet Mask of the source network.
o Role—Applies a rule to traffic originating from a specific user role. Select aUser role from the

drop-down list.

n Destination—Select one of the following options from the drop-down list to define a destination
for the traffic policy rule:
o Any—Applies a rule to the outgoing traffic to any destination.
o Host—Applies a rule to the traffic routed to a specific host IP address. Enter the host IP address.
o Network—Applies a rule to the traffic routed to a specific network. Enter the IP address and the

subnet mask of the source network.
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o Alias—Applies rule to the traffic routed to a specific alias of a host or network. Select the Source
alias from the drop-down list.

n Service/app—Select one of the following network services from the drop-down list :
o Any—Applies a rule to all network services.
o TCP—Applies a rule to the incoming and outgoing traffic from the TCP ports. If you have selected

the TCP service, specify a list of TCP ports. Select Min/Max Port radio-button to specify the start
and end port or select the Source/Dest Port radio-button to specify the source and destination
ports.

o UDP—Applies a rule to the incoming and outgoing traffic from theUDP ports. If you have selected
theUDP service, specify a list of UDP ports. Select Min/Max Port radio-button to specify the
start and end port or select the Source/Dest Port radio-button to specify the source and
destination ports.

o Service—Applies a rule to the incoming and outgoing traffic from a set of predefined services and
protocols; for example, HTTPS and HTTP. Select the Service Alias from the drop-down list.

o Protocol—Applies a rule to the traffic that uses a specific routing protocol. Enter the protocols in
the Protocol field.

o Application—Applies rule to the applications. Enter the application names in theApplication
field.

o Application category—Applies rule to the application categories. Enter the Application
Categories in theApp category field.

o Web Category/Reputation—Applies rule to theweb category. Enter theweb categories in the
Web Category field and select theWeb reputation from the drop-down list.

n Action—Select one of the following options from the drop-down list:
o Deny—Denies traffic fromor to a specific network or network service.
o Permit—Allows traffic fromor to a network or network service.
o Log—Creates a log when a policy is applied based on the rules configured.
o Mirror—Mirrors session packets to datapath or remote destination.

n Blacklist—Automatically blacklists a client that is the source or destination of the traffic matching
this rule. This option is recommended for rules that prevent access to unauthorized clients.

n Disable scanning—Disables AP scanning when the rule is triggered.

4. Click Save.

5. Click Next to view a summary of the policies.

6. Click Finish.

Finish button is disabled if there are any errors in the configuration. Resolve the errors to
save your configurations.

Configuring Branch Gateways Using the Guided Setup
Aruba Branch Gateways operate at the branch to optimize and control WAN, LAN, and cloud security
services. The Branch Gateway provides essential features such as routing, firewall, security, website content
filtering, andWAN compression. With support formultipleWAN connection types, the Branch Gateway
routes traffic over themost efficient link that is based on availability, application, user-role, and link health.
It allows organizations to take advantage of high-speed, low-cost broadband links to supplement or replace
traditional WAN links such asMPLS.



Different Modes of Configuring Gateways and Gateway Groups | 42

You can configure a Branch Gateway group or Branch Gateway device using either theGuided Setup, Basic
mode, or Advancedmode. This section describes the procedure to configure Branch Gateways using the
Guided Setup.

Before You Begin
Ensure that you have completed the following procedures:

n Gateways are onboarded to Aruba Central.

n Gateways are assigned valid subscriptions in Aruba Central.

n Gateways are assigned to groups.

n Gateways are assigned the Branch Gateway group role.

Configuring a Branch Gateway Device in the Guided Setup
To configure a Branch Gateway device, complete the following steps:

1. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway.
The dashboard context for a group is displayed.

2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click a gateway underDevice Name.
The dashboard context for the gateway device is displayed.

4. UnderManage, Click Device.
The gateway configuration page is displayed.

If you are accessing the Branch Gateway configuration page for the first time, theGuided Setupwizard
opens automatically. Otherwise, click Guided Setup.
TheGuided Setupwizard displays the following tabs for device level configuration:

1. System—Allows you to configure the system IP address.

2. LAN—Allows you to configure LAN ports.

3. WAN—Allows you to modify WAN ports.

4. SDWAN & Routing—Allows you to configure SD-WAN routing profiles.

5. Redundancy—Allows you to configure LAN redundancy for high availability of the SD-Branch
devices.

6. Click Begin to start the guided setup process and complete the steps provided in the following
sections:

a. Configuring a System IP Address for a Branch Gateway.

b. Configuring a LAN Interface for a Branch Gateway .

c. Configuring aWAN Interface for a Branch Gateway.

d. Configuring Routing Profiles for a Branch Gateway.

e. Configuring LAN Redundancy for High Availability.
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Many procedures involve adding or configuring parameters in tables. Note that you have options to

edit and delete the existing configurations.

Configuring a System IP Address for a Branch Gateway
Each Branch Gateway requires a unique system IP address that is used by the gateway to communicatewith
network services such as VPN, RADIUS, Syslog, TACACS+ and SNMP. The system IP addresses for your
gateways can be assigned from the group using a pool or a per device or a bulk configuration upload.

To configure a system IP for a Branch Gateway device:

1. Click the System IP tab in theGuided Setupwizard.

2. Configure the following parameters:
n If you have configured the system IP address pool for VLAN 4087, which is the reserved system

VLAN and a Controller IP VLAN, then theVLAN Interface is a read-only field that displays VLAN
4087.

n If you have defined a system IP address pool during group configuration, complete the following
step:
o VLAN Interface—Select the VLAN interface from the drop-down list to assign an IP address to

the Branch Gateway.

n If you have not configured a system IP address pool during group configuration, complete the
following steps:
o IPv4 Address—Enter the IP address for the gateway.
o Netmask—Enter the subnet mask of the system IP address.

n Specify interface for this device—Select this option to assign IP address from a specific VLAN
interface to the Branch Gateway. When you select this option, ensure that you select the
VLAN interface for IP address assignment.

n Use IP address assigned by group—Select this option to assign an IP address from the address
pool configured for the Branch Gateway group.

3. Click Next.

4. Enter the host name in theHostname field.

5. Click Next.

6. Review the summary page and click Finish.

The Finish button is disabled if there are any errors in the configuration. Resolve the errors to
proceed to the next step.

7. Click Continue to configure a LAN interface.

Configuring a LAN Interface for a Branch Gateway
This section focuses on the LAN configuration of the Branch Gateways. By default, LAN interfaces have
LLDP enabled and a role-based security. However, this setting can be changed when you configure security
policies.

To configure VLANS on Branch Gateway group:
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1. In theVLAN page, select the IP DHCP server check box for the gateways to act as DHCP servers.

2. Click + in theVLANs table to add a new VLAN.

3. Enter aName for the VLAN

4. Enter theVLAN ID.

5. Select one of the following IP addressing mode from the drop-down list:
n Static—Select this option to use a static IP address. If you want to configure the LAN IP addresses at

the device level, leave the IPv4 address and netmask fields empty. You can also set the same static
IP/netmask for all the devices in the group.

n IPV4 Address—Enter a unique static IP address for each gateway in the group or a common
address for all gateways in the group.

n Netmask—Enter the subnet mask of the IP address.

Ensure that the VLAN used here is configured as a non-routable VLAN, as the VLAN will
overlap with the other gateways.

n Dynamic DHCP Pool—Select this option to dynamically assign IP address from aDHCP. To
configure an IP address range for dynamic assignment of DHCP IP addresses, configure the
following parameters:

6. To configure branch gateways as DHCP server, turn on theAct as DHCP server toggle switch and
configure the following parameters:
n Network—The network IP address.

n Netmask—The subnet mask of the network.

n Default Router—The IP address of the device used by clients if they want to communicatewith
devices outside of their subnet. By default, this is the Branch Gateway IP address for the particular
VLAN, or the VRRP virtual IP, if configured.

n Domain name—TheDNS domain name assigned to branch devices.

n DNS server type—Type of theDNS server. You can use either a public DNS server or add aDNS
server by selecting theUser DefinedDNS option.
o DNS Service Provider—If you use a Public DNS Service, select the name of theDNS service

provider from the list. For example, Google.
o DNS server IPv4 addresses—If you use aUser DefinedDNS server, enter the IP addresses

here. You can specify up to eight IP addresses separated by a comma.

7. Turn on the Enable DHCP relay toggle switch to relay the incoming DHCP requests to an external
DHCP server. Select this option when centralized DHCP servers are deployed to provide addressing
to branch devices or if device profiling is performed by services such as Aruba ClearPass.

a. Click + in the External DHCP Server table.

b. Add the IPV4 addresses.

8. Click Save.

9. Click Next.
The LAN Ports page is displayed.

10. To add a LAN port, click + in the LAN Ports/Ports Channel table.

11. Enter aName for the port.
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12. Select a port channel or a port from the Ports drop-down list.
n If you have selected Port Channel for the LAN port, configure the following parameters:

o Port channel protocol—Select a port channel protocol; for example, LACP (Link Aggregation
Control Protocol). If you have selected LACP, select the LACPmode as active or passive from the
LACP mode drop-down list.

o Port channel members—Select the port channelmembers.

13. Select one of the following VLAN modes:
n Access—Select this option to allow the LAN port to carry traffic only for the VLAN to which they are

assigned. All transmitted and received traffic on the port is untagged.
o Access VLAN—Select the VLAN ID assigned to the port or port channel.

n Trunk—Select this option to allow the LAN port to carry traffic formultiple VLANs. If you select the
Trunkmode, configure a list of allowed VLANs. The following options are available:

n Native VLAN—The untagged VLAN ID for the port or port channel.

n Allowed VLAN—The range of VLAN IDs assigned to the port or port channel including theNative
VLAN.

14. Click Next.

15. Review the summary page and click Finish.

The Finish button is disabled if there are any errors in the configuration. Resolve the errors to
proceed to the next step.

16. Click Continue to configure aWAN interface.

Configuring a WAN Interface for a Branch Gateway
This section focuses on theWAN configuration of the branch gateways.

To configure aWAN interface, complete the following steps:

1. In theWAN tab, turn on the Enable health checks toggle switch.

The WAN health check enables sending probes to measure availability and SLA of the uplinks.
When the health check feature is enabled, the probes are sent through the underlay at regular
intervals to verify if the Internet is reachable over the uplink interfaces configured on Gateways.

2. Configure the following health check parameters:
n Health check destination—You can configure aUser defined IP address or use the default

Aruba cloud instance to sendWAN health check probes.
o Health check IP address—If it is aUser defined destination, enter the IPv4 address or FQDN of

a host that is reachable through theWAN paths outside the VPN tunnel.

n Health check probe mode—Select one of the following probemodes:
o Ping—Sends ICMP probes to measure latency and packet loss.
o UDP—Sends UDP Probes through UDP port 4500 to measure latency, packet loss, and jitter.

3. Click Next.
The Load Balancing page is displayed.
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4. Select one of the followingmodes for uplink load balancing:
n Round robin—Select this option to sequentially distribute outgoing sessions betweenWAN links. It

is the simplest algorithm to configure and implement, but may result in uneven traffic distribution
over time.

n Session count—Select this option to balance traffic among the uplinks based on the current
number of active sessionsmanaged by each link, so that the load for each active uplink stays within
5% of the other active uplinks. For example, if there are two active uplinks with theWeight
parameter defined as 10 and 20, the active uplink with aweight of 20 will havemore sessions
assigned.

n Uplink utilization—Select this option to distribute traffic between activeWAN uplinks based on
the utilization % of each activeWAN uplink. Uplink utilization considers the link speed to calculate
the utilization and allows amaximumpercentage of bandwidth threshold to be defined. When the
bandwidth threshold exceeds the defined value, theWAN uplink will no longer be considered for
session allocation. When you configureWAN ports, it is important that you configure theWAN
uplink speed appropriately

5. Click Next.
TheWAN Details configuration page is displayed. This section defines uplink interfaces by
creatingWAN-facing VLANs, labelling them as uplink interfaces, and assigning them to the desired
uplink ports.

6. Turn on the Enable High Availability Deployment toggle switch for LAN redundancy.

7. Select the Peer gateway from the list.

8. Enter the Site ID to which the peer gateway belongs.

9. Click Next.

10. To add aWAN port, click + in theWAN Uplinks/Ports table.
TheAdd/Edit WAN Port pop-up is displayed.

11. Enter a name for theWAN port in theUplink field.

12. Select the type of WAN uplink to use from theWAN type drop-down list. For example, Internet or
MPLS.

13. Configure theWAN Speed. By default, theWAN uplink speed is set to 20 Mbps. You can configure a
custom value for uplink speed as per your requirements. The allowed range of values is 1–10000
Mbps.

14. To enable NAT for the outbound traffic on theWAN interface, select Source NAT.

15. To use the uplink in the standby mode, select theUse as backup check box. By default, all uplinks
operate as active uplinks.

16. Select an IP addressing method from the following options :
n Static—For static IP addressingmethod, enter the IP address and subnet mask.

n DHCP—When selected, the IP address from aDHCP pool is assigned for theWAN uplink.

n PPPOE—This is the Point to Point Protocol over Ethernet. When selected, you need to select an
authentication type to connect to the ISP.

n Turn on theGroup credentials toggle switch.
n Select an Authentication type. If you select Password Authentication Protocol (PAP), enter the

username and password for PPPoE authentication. If you select Challenge handshake
authentication protocol (CHAP), enter the user name and CHAP secret for authentication.
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17. To apply the default inbound security ACL forWAN ports, select the Secure with ACL check box.

18. Click Next.

19. Review the summary page and click Finish.

The Finish button is disabled if there are any errors in the configuration. Resolve the errors to
proceed to the next step.

20. Click Continue to configure routing profiles.

Configuring Routing Profiles for a Branch Gateway
To configure a routing profile on a Branch Gateway device:

1. In the SDWAN & Routing tab, configure a Static Routing profile.

2. To create a default route, click + in theDefault Routes table:
n Type—Select the default route type; Next Hop orVPNC.
n Next Hop/VPNC—Enter the IP address of theNext Hop or VPNC.

n Uplink—Select the uplink from the drop-down list.

n Cost—Enter the cost metric of the route.

3. Click Next to configure a static route profile.

4. To create a static route, click + in the Static Routes table and enter the following:
n Destination IP—Enter the destination IP address.

n Destination mask—Enter the subnet mask of the destination IP address.

n Type—Select the type of route.
o Nexthop—Select this option to configure a nexthop destination.
o Blackhole—Black holes refer to places in the network where incoming or outgoing traffic is

discarded (or dropped), without informing the source that the data did not reach its intended
recipient. When examining the topology of the network, the black holes themselves are invisible,
and can only be detected by monitoring the lost traffic.

n Next Hop—The IP address for the next hop.

n Cost—The cost metric for the route.

5. Click Next.

6. Review the summary page and click Finish.

7. Click Continue to configure LAN redundancy for high availability.

Configuring LAN Redundancy for High Availability
Before you proceed, ensure that you have enabled High Availability on theWAN page and configured peer
gateway for redundancy.

To configure LAN redundancy, complete the following steps:

1. In theRedundancy > VRRP page, configure a VRRP instance.

2. Click + in theVRRP Interfaces table and configure the following parameters:
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n VLAN ID—VLAN ID for which you want to set up the redundant gateway.

n IP Address on Local—The IP address of the VLAN on the local gateway.

n IP Address on Peer—The IP address of the VLAN on the peer gateway.

n Virtual IP—The virtual IP of the VLAN.

n Master —The designated active gateway of the redundant pair.

3. Review theWAN port sharing details for the peer Gateways.

4. Click Next. The VRRP Instance configuration page is displayed.

Configuring VPN Concentrator Group Using the Guided
Setup
ArubaGateways deployed at a data center can function as a headend Gateway or a VPN Concentrator. The
VPN Concentrators aggregate traffic from all branch offices. Branch Gateways (BGWs) establish secure
Internet Protocol security (IPsec) tunnels to one ormore headend gateways over the Internet or other
untrusted networks.

You can configure a VPN Concentrator group using theGuided Setup, Basicmode, or Advancedmode. This
section describes the procedure for configuring VPN Concentrators using theGuided Setup.

Before You Begin
Before you begin, ensure that you have completed the following procedures:

n Gateways are onboarded to Aruba Central.

n Many procedures involve adding or configuring parameters in tables. Note that you have options to edit

and delete the existing configurations.
n Gateways are assigned valid subscriptions in Aruba Central.

n Gateways are assigned to groups.

n Gateways are assigned the VPNC group role.

Ensure that the devices in the group are not running the guided setup at device level. If the device is
being configured using the Guided Setup, the group level setup will not be executed.

Configuring a VPNC Group in the Guided Setup
To configure a VPNC group using theGuided Setup, perform the following steps:

1. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway
that is configured as a VPN Concentrator.

The dashboard context for a group is displayed.

2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click theConfig icon.
The gateway group configuration page is displayed.

TheGuided Setupwizard displays the following tabs:
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n System—Allows you to configure systemparameters.

n LAN—Allows you to configure LAN interfaces.

n SDWAN & Routing—Allows you to configure the SDWAN overlay and routing profiles.

4. Click Begin to start the guided setup process and complete the steps provided in the following
sections:

a. Configuring SystemParameters for a VPNC Group.

b. Configuring a VLAN Interface for a VPNC Group.

c. Configuring VPN Routing Profiles for a VPNC Group (Static Routing).

Many procedures involve adding or configuring parameters in tables. Note that you have options to

edit and delete the existing configurations.

Configuring System Parameters for a VPNC Group
To configure systemparameters, complete the following steps:

1. In the System tab, navigate to theModel page.

2. Select a Branch Gateway model from theVPNC Model drop-down list.

3. Click Next.
The Time page is displayed.

Configure theNTP server for system clock synchronization. The system automatically updates
the time zone including the relevant daylight savings time (DST) across time zones. You can
optionally specify a time zonewhich is applied to all the gateways in the group. The default
time zone is set to GMT.

4. In the Public NTP Servers table, click + to add a Public NTP Provider:
n IPV4 Address/FQDN—Enter the IPV4 address or the FQDN of the public NTP provider. The

provider's NTP server is automatically added to the Branch Gateways in the group.

n Burst Mode—Select this option to expedite the system clock calibration.

n Timezone—Choose the time zone from the drop-down list. The list contains the list of Primary
time zones followed by other time zones.

5. Click Next.
TheDNS page is displayed.

6. Select one of the following options to configure DNS server:
n Specify DNS Servers—Select this option to configure a DNS server and define the following

parameters:
a. Enter aDomain name.

b. Click + to add a Public DNS server. You can select one ormoreDNS service providers from
the list or you can select User Defined from the Provider drop-down list.
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c. Enter the IPv4 address if you have selected User Defined from the Provider drop-down
list. If you select a DNS provider from the Provider drop-down list, the IPv4 Address is auto
populated

n Learn DNS server from ISP—Select this option if you want the gateway to learn theDNS server
dynamically from the ISP.

The DNS servers configured here are the ones that the gateway uses to resolve addresses. It
must be reachable through the underlay, as it is required by the device to communicate with
and the SD-WAN Orchestrator.

n Click Next.

Figure 6 Configuring DNS

TheManagement User page is displayed.
Amanagement user has administrative credentials to log in to the local management interface of the
device.

1. EnableAAA Authentication for an admin user, to centrally manage user authentication using
RADIUS or TACACS servers.

2. Click + to create an AAA server for authenticating devicemanagement user.
TheAdd AAA Server pop-up is displayed.
Configure the following parameters:

n Name—Nameof the authentication server.

n Server IP—IP address of the authentication server.

n AAA authentication—Authentication protocol to use; for example, TACACS orRADIUS.
n Key—Shared key for authenticating a device administrator.

n Retype key—Reenter the key to confirm.

3. Click Save.

4. To add a local user, click the + icon in the Local management users table.
TheAdd management user pop-up is displayed.
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Configure the following parameters:

n Name—Enter the username of themanagement user.

n Password—Enter the password for themanagement user.

n Retype Password—Enter the password for themanagement user.

n Role—Set the role of themanagement user. Select a user role from theRole drop-down list. The
following options are available:
o Super user role—Administrator user role.
o Guest provisioning role—Administrator role for provisioning guest users.
o Network operations role—Administrator role formanaging SD-WAN deployments.
o Read-only—Read-only user role.
o Local API management role—User role with access to manageGateways through the API

console.

5. Click Save.

6. Click Next to view the system configuration summary, and then click Finish.

Figure 7 Configuring Management User

7. Finish button is disabled if there are any errors in the configuration. Resolve the errors to proceed to
the next step.

8. Click Continue to configure VLANs and LAN Ports for VPN Concentrators.

Configuring a VLAN Interface for a VPNC Group
This section focuses on the LAN configuration of the VPNC group.

To configure VLANs on VPNC groups, complete the following steps:

1. In theVLAN tab, click + in theVLANs table to add a new VLAN.

2. Configure the following parameters:

n Enter aName for the VLAN.

n Enter theVLAN ID.
n Enter a description text for the VLAN
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n Enter a unique IPv4 address.
n Enter theNetmask.
n Click Save.

3. Click Next.

Formore information see, Configuring VLANS.

The LAN ports page is displayed.

1. To add LAN ports or a port channel, click + in the LAN Ports/port channel table.

2. Specify an uniqueName for the LAN port.

3. Select an unused Port from the list of available ports.

4. Select eitherAccess or Trunkfrom theVLAN mode drop-down list.
n Access—Select this option to allow the LAN port to carry traffic only for the VLAN to which they are

assigned. All transmitted and received traffic on the port is untagged. In Accessmode, the port or
port-channel is assigned a single LAN VLAN ID (Access VLAN).

n Trunk—Select this option to allow the LAN port to carry traffic formultiple VLANs. Traffic
transmitted and received on theNative VLAN will be untagged, while traffic transmitted and received
fromother VLANs in the Allowed VLANs list will be 802.1Q tagged. In Trunk mode, the port or port-
channel can be assigned to multiple LAN VLAN IDs. If you select the Trunkmode, configure a list of
allowed VLANs. The following options are available:
o Native VLAN (Optional)—This is the untagged VLAN ID for the port or port channel.
o Allowed VLAN (Optional)—This is the range of VLAN IDs assigned to the port or port channel.

This range includes the native VLAN.
o Management—Formanagement traffic.
o Guest—For guest user traffic.
o Employee—For employee user traffic
o IT—For IT administration traffic.

n If you have selected Port Channel for the LAN port, configure the following parameters:
o Port channel protocol—Select a port channel protocol; either: Static or LACP. The gateways

support Static and LACP (Link Aggregation Control Protocol) protocols. Select the protocol based
on the port channel configuration of the upstreamdevice.

n Static—Allowsmanual bundling of links. The link state of the port determines if the port is an active
member of the port-channel bundle.

n LACP—Link Aggregation Control Protocol allows devices to negotiate an automatic bundling of links
by sending LACP BPDUs to the peer. LACP provides failure detection and failover in the event that a
peer fails or becomes unreachable.
o LACP mode—Select Active or Passive mode from the LACP mode drop-down list. If LACP is

enabled, youmust specify if the ports on the gateway operate in Active or Passivemode. Active
enables LACP unconditionally; Passive enables LACP only when a LACP peer device is detected. For
the port-channel to become active, one sidemust be operating in an Activemode.

o Port channel members—Select the port channelmembers. Youmust add two ormore port
members of the same speed.

https://help.central.arubanetworks.com/2.5.0/documentation/online_help/content/gateways/cfg/interfaces/conf-vlans.htm


Aruba SD-WAN Solution | User Guide 53

5. Click Next to view the configuration summary, and then click Finish.

Finish button is disabled if there are any errors in the configuration. Resolve the errors to
proceed to the next step.

6. Click Continue to configure SDWAN and Routing profiles.

Configuring VPN Routing Profiles for a VPNC Group (Static Routing)
Enabling SD-WAN Overlay Orchestrator

Click the toggle switch to enableOverlay Orchestrator Peering.

Configuring VPN hubs and routing profiles

To configure VPN hubs and routing profiles, complete the following steps:

1. In the Static Routing tab, configure the static routing profile.

2. To create a default route, configure theNext hop IP address and define a cost metric.

3. To create a static route, configure the following parameters:
n Destination IP—Destination IP address

n Destination mask—Subnet mask of the destination IP address.

n Type—Set the route to eitherNexthop orBlackhole.
n Next Hop—The IP address for the next hop.

n Cost—The cost metric for the route. The lower the cost, the higher the priority assigned.

4. Click Next to configure routemaps for underlay and overlay routing.

Configuring Route Maps
In theRoute Maps tab, you can configureCommunity List Rules, Prefix Lists, and Route Maps.

Configuring Community List Rules

The Community List feature allows administrators to configure a set of community attributes to apply on
routes exchanged between ArubaGateways and their peers. The community attribute allows grouping
routes with similar properties and is generally used for tagging routes andmodifying BGP routing policies.

To create a community list, complete the following steps:

1. Click on theCommunity List Rules accordion.

2. Click the + icon in theCommunity List table.

3. Enter aName for the community list rule.

4. From theAction drop-down list select Permit orDeny, to match the community specifications.

5. Select aWell Known Community from the following options in the drop-down list.
n Internet—Advertises the prefix to all BGP neighbors.

n No-Export—Does not advertise the prefix to any eBGP neighbor. It advertises the prefix only to
iBGP neighbors.

n No-Advertise—Does not advertise the prefix to any peer, iBGP or eBGP neighbor.
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n Local-AS—Does not advertise the prefix outside of the local Autonomous System.

You can also enter a value for the following types of community strings and click + to add.

n AS:NN—TheBGP community string in the AS:NN format, where AS refers to the Autonomous
Systemnumber and NN refers to the network number. The valid range of values is 0-65535.

6. Set amatch from theCommunity Values.

7. Configure the community string in theAS:NN format, where AS refers to the Autonomous System
number and NN refers to theNetwork Number. The valid range of values is 0-65535.

Configuring a Prefix List

A prefix list allows routing systems to determinewhich routesmust be accepted when they peer with other
networks. Prefix lists contain one ormore ordered entries which are processed sequentially.

Prefix lists can be used as amatch criteria for applying routemap rules on network subnets. For example, if
you want to prevent a route for 10.0.0.0/24 frombeing redistributed, you can define a rule to match the
prefix and add it a asmatch criterion in the BGP redistribution routemap.

To create a prefix list, complete the following steps:

1. Click on the Prefix List accordion.

2. Click the + icon in the Prefix Rules table.

3. Enter aName for the prefix rule.

4. Enter a Sequence number.

5. Select an Action to be performed from the drop-down list, when the traffic matches the condition
defined in the prefix rule.

6. Enter the network Address to which you want to apply the prefix rule.

7. Enter theNetmask of the network.

8. If you want to define a prefix length parameter and use it as amatch criteria for applying rules, enter
a value greater than or equal to this value for theGE operator. The allowed range of values is 1–32.

9. If you want to define a prefix length parameter and use it as amatch criteria for applying rules, enter
a value lower than or equal to this value for the LE operator. The allowed range of values is 1–32.

Configuring Route Maps

Routemaps allow you to configure a filtering criteria by defining a set of rules ormatch statements with a
permit or deny condition. A routemap includes a seriesmatch statements to determine if a routematches
the criteria defined in the statement and then apply the permit or deny rule accordingly.

Important Points to Note

The following list includes some of the important points to consider when configuring a routemap:

n A routemap includes name, sequence number, permit or deny rule, thematch and set statements. The
match statements determine the route or the traffic to which the rulemust be applied, whereas the set
statements allow you configure attributes or adjust metrics for the route that matches the criteria
defined in thematch statement.

n The routemap rules are applied sequentially; that is, based on the sequence number defined for each
entry.

n The routemap can use a prefix list in thematch statement to apply the allow or deny rule. Formore
information on prefix lists, see Configuring a Prefix List.

https://help.central.arubanetworks.com/2.5.0/documentation/online_help/content/gateways/cfg/routing/bgp.htm
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n Routemaps can be attached to the BGP neighbor profiles for the inbound and outbound routes. You
can associate routemaps for the inbound and outbound traffic when configuring a BGP neighbor
profile. When the routemap policy is applied to the inbound or outbound BGP route, and if the traffic
matches the specified criteria, the attribute set for thematch condition is applied. If you do not have a
routemap attached to an iBGP neighbor profile, the iBGP neighbor can access all inbound and outbound
routes. Formore information on BGP neighbor profiles. see Adding BGP Neighbors.

To create a routingmap, complete the following steps:

1. Click on theRoute Maps accordion.

2. To add a routemap, click the + icon in theRoute Maps table. TheAdd/Edit Route Mapwindow
opens.
Configure these parameters as per your network requirements:

3. Enter aName for the routemap.

4. Enter a Sequence Number for the routemap. Sequence numbers allow routemaps to be executed
in an order. If you are configuringmultiplematch clauses or statements, ensure that you define a
sequence number to uniquely identify eachmatch statement.

5. Select an Action to be performed from the drop-down list, when the traffic matches the condition
defined.

6. Configure theMatch condition for the routes that have a destination network. Thematch
statements define a set of conditions for determining if the route redistributionmust be allowed or
denied. To add amatch statement, click the + icon in theMatch table. You can set match type to any
of the following:
n IP address—You can assign a prefix list to amatch statement. Thematch condition determines if

the route advertisements from the BGP neighbor with the prefixesmust be allowed or denied.

n Next-hop IP—You can assign a prefix list to amatch statement. Thematch condition determines if
the route advertisements from the BGP neighbor with the prefixesmust be allowed or denied.

n Well known community—Awell known community allows you to configure one of the following
options:
o Internet—Advertises subnets to all BGP neighbors.
o No-Export—Does not advertise prefix to any eBGP neighbor.
o No-Advertise—Does not advertise subnets to BGP neighbors.
o Local-as—Prevents sending packets outside the local autonomous system.

n Community AS:NN—the community string is in the AS:NN format, where AS refers to the
Autonomous Systemnumber and NN refers to the network number. The valid range of values is 0-
65535.

n Community Value—Allows you to specify a community value string. The valid range of values is 1–
4294967295.

n Community list—Allows you to select a community list configured on theGateway.

n Interface VLAN—Enter the interface VLANS separated by comma. You can enter up to 10 Interface
VLANs. The value you entermust be between 1 to 4095. To know how to configure VLANs, see
Configuring VLANs on ArubaGateways.

n OSPF route tag—You need to enter the tag names separated by comma. You can enter up to 10
tags. At least one of these tags has to match to allow route redistribution. The value you entermust
be between 0 to 4294967295.

7. Configure a Set of rules or attributes to apply to the BGP traffic that matches the conditions defined
in amatch statement.

https://help.central.arubanetworks.com/2.5.0/documentation/online_help/content/gateways/cfg/routing/bgp.htm
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To add a Set level attribute, click the + icon in the Set table and configure the following attributes as
per your requirement:

n as-path-prepend—Prepends AS numbers through which the packets have traversed. You can apply
the AS path prepending criteria to the BGP traffic to determine the best path.

n last-as—Prepends the last AS number to the AS path. The valid range of values is 1–10.

n Community value—TheBGP community Value string. The valid range of values is 1–4294967295.

n Community AS:NN formatch type, the community string is in the AS:NN format. The valid range
of values is 0-65535.

n Well known community—Awell known community. You can configure one of the following
options:
o Internet—Advertises subnets to all BGP neighbors.
o No-Export—Does not advertise prefix to any eBGP neighbor.
o No-Advertise—Does not advertise subnets to BGP neighbors.
o Local-AS—Prevents sending packets outside the local autonomous system.

n Local-as—Sets a local autonomous system string as an attribute in the routes.

n metric—Sets ametric value for determining the preferred path into an Autonomous System. You
can define ametric value between 0—4294967295. When ametric value in a routematches this
value, the route is advertised.

n origin—Sets the origin of the route. The following options are available:
o incomplete(EGP)—To specify that the route is originated from exterior routing protocol.
o igp—To specify that the route is originated from interior routing protocol.

n OSPF route-type—Sets the externalmetric (External Type-1 or External Type-2) attribute of the
route. To redistribute as routes as External type 1 which applies both external cost to the
destination and the cost to reach the boundary router in an Autonomous System. To redistribute
routes as External type-2 and apply only the external cost to the destination.

n OSPF route tag—Sets the tag attribute of the route. You need to enter the tag names separated by
comma. You can enter up to 10 tags. At least one of these tags has to match to allow route
redistribution. The value you entermust be between 0 to 4294967295.

Figure 8 Configuring Route Maps
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8. Click Next to proceed to Overlay Routing.

Configuring Overlay Routing
VPN Concentrators use theOverlay Agent Protocol (OAP) to automatically build the SD-WAN overlay
topology. TheOAP allows advertising local routes to the SD-WANOrchestrator in Aruba Central

Configuring Redistributing Rules

Redistribution rules allow you to enable advertising of routing information from the connected, static, OSPF,
and BGP interfaces into overlay routing. Routing information fromother sources is not automatically
redistributed into overlay routing, but need to be configured for each source protocol locally on each
Gateway.

To configure redistributing rules, complete the following steps:

1. Click Redistribution, to open theRedistribution Rules table.

2. To add a redistribution rule, click + in theRedistribution Rules table.

3. From the Source Protocol drop-down list, select a protocol to be redistributed into the overlay
routing. The following options are available:
n Static—To redistribute IP static routes.

n Connected—To redistribute routes received from the subnets that are directly connected to a
router’s interface at the hub site. If you have selected Connected, select theVLAN1 or Loopback
interfaces to which theGateway is connected.

n OSPF—To redistribute routes learnt from theOSPF neighbors. If you have selected OSPF, select the
OSPF path type from Filter column. The following filter options are available:
o Intra Area—To redistribute routes to same area fromwhich they originated.
o Inter Area—To redistribute routes to another area in theOSPF domain.
o External Type 1—To redistribute as routes as External type 1 which applies both external cost to

the destination and the cost to reach the boundary router in an Autonomous System.
o External Type 2—To redistribute routes as External type 2 and apply only the external cost to

the destination.

n BGP—To redistribute routes using BGP.

Configuring Data Center Aggregating Routes

For dynamic route summarization and faster calculation of best routing paths, you can configure a route
aggregation criteria. The route aggregation feature summarizesmultiple routes into a single route
advertisement, and thus helps in reducing the number of routing tables exchanged between BGP peers.

To aggregate data center routes, complete the following steps:

1. Click Data Center Aggregating Routes, to open theDC Aggregate Routes table.

2. To allow branch route aggregation, click Allow branch to branch check box.

3. Enter the following details in theDC Aggregate Routes table:
n IP Address—Enter a network IP address.

n Mask—Enter the subnet mask.
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4. Click Next to view a summary of configuration.

Figure 9 Configuring Overlay Routing

5. Click Finish to complete theGuided Setup.

The Finish button is disabled if there are any errors in the configuration. Resolve the errors to save
your configurations.

Configuring VPN Concentrators Using the Guided Setup
ArubaGateways deployed at a data center can function as a headend Gateway or a VPN Concentrator. The
VPN Concentrators aggregate traffic from all branch offices.

You can configure a VPN Concentrator device using theGuided Setup, Basicmode, or Advancedmode. This
section describes the procedure for configuring VPN Concentrators using theGuided Setup.

Before You Begin
Before you begin, ensure that you have completed the following procedures:

n Gateways are onboarded to Aruba Central.

n Gateways are assigned valid subscriptions in Aruba Central.

n Gateways are assigned to groups.

n Gateways are assigned the VPNC group role.

Ensure that the device is not part of a group that is running the guided setup. If the group is being
configured using the Guided Setup, the device level setup will not be executed.

Configuring a VPN Concentrator in the Guided Setup
To configure a VPN Concentrator using theGuided Setup, complete the following steps:
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1. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway
that is configured as a VPN Concentrator.

The dashboard context for a group is displayed.

2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click a gateway underDevice Name.
The dashboard context for the gateway device is displayed.

4. UnderManage, Click Device.
The gateway configuration page is displayed.

TheGuided Setupwizard displays the following tabs for device level configuration:

n System—Allows you to configure system IP address.

n LAN—Allows you to configure LAN ports.

n WAN—Allows you to modify WAN ports.

n SDWAN & Routing—Allows you to configure SD-WAN routing profiles.

5. Click Begin to start the guided setup process and complete the steps provided in the following
sections:

a. Configuring a System IP Address for a VPN Concentrator .

b. Configuring a LAN Interface for a VPN Concentrator.

c. Configuring aWAN Interface for a VPN Concentrator.

d. Configuring SDWAN and Routing Profiles for a VPN Concentrator.

Many procedures involve adding or configuring parameters in tables. Note that you have options to

edit and delete the existing configurations.

Configuring a System IP Address for a VPN Concentrator
Each VPN Concentrator requires a unique system IP Address that is used by the gateway to communicate
with network services such as VPN, RADIUS, Syslog, TACACS+, and SNMP. The system IP addresses for your
device can be assigned from the group using a pool or per device or bulk configuration upload.

To configure a System IP for a VPN Concentrator, complete the following steps:

1. Click the System IP tab in theGuided Setupwizard.

2. Configure theVLAN Interface:
n If a system IP address is configured usingAdvanced Mode on a VPNC, then that VLAN is populated

in the drop-down list.

n If system IP is not set, then enter the system IP in the textbox.

1. Click Next.

2. Enter theHostname.

3. Click Next.



Different Modes of Configuring Gateways and Gateway Groups | 60

4. Review the summary and click Finish.

Finish button is disabled if there are any errors in the configuration. Resolve the errors to
proceed to the next step.

5. Click Continue to configure a LAN interface.

Configuring a LAN Interface for a VPN Concentrator
To configure the LAN interface on a VPN Concentrator, complete the following steps:

1. In theVLANs tab, click + in theVLANs table to add a new VLAN.

2. Configure the following parameters:
n Name—Enter a name for the VLAN.

n VLAN ID—Enter the VLAN ID.

n Enter a description text for the VLAN.

n IPv4 Address—Enter an IP address.

n Netmask—Enter the subnet mask.

3. Click Save.

4. Click Next.
Formore information see, Configuring VLANS.

The LAN ports page is displayed.

5. To add a LAN port, click + in the LAN Ports/port channel table.

6. Enter aName for the port.

7. Select the Port from the list of available ports.

8. Select one of the followingmodes from theVLAN mode drop-down list:
n Access—Select this option to allow the LAN port to carry traffic only for the VLAN to which they are

assigned.

n Trunk—Select this option to allow the LAN port to carry traffic formultiple VLANs. If you select the
Trunkmode, configure a list of allowed VLANs. The following options are available:
o Native VLAN (optional)
o Allowed VLAN (optional)
o Management—Formanagement traffic.
o Guest—For guest user traffic.
o Employee—For employee user traffic
o IT—For IT administration traffic.
o Port channel protocol—Select a port channel protocol; select either Static or LACP from the

drop-down list.
o LACP mode—Select the Link Aggregation Control Protocolmode; select eitherActive or Passive

from the drop-down list.
o Port channel members—Select the port channelmembers.

9. Click Next.

https://help.central.arubanetworks.com/2.5.0/documentation/online_help/content/gateways/cfg/interfaces/conf-vlans.htm
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10. Review the summary page and click Finish.

Finish button is disabled if there are any errors in the configuration. Resolve the errors to
proceed to the next step.

11. Click Continue to configure aWAN interface.

Configuring a WAN Interface for a VPN Concentrator
This section defines uplink interfaces by creatingWAN-facing VLANs, labeling them as uplink interfaces, and
assigning them to the desired uplink ports.

To configure aWAN interface, complete the following steps:

1. To add aWAN port, click + in theUplinks table.
TheAdd/Edit WAN Uplink pane is displayed.

2. Enter a name for theWAN port in theUplink field.

3. Select the Interface VLAN ID from the drop-down list.

4. Select the type of WAN uplink to use from theWAN type drop-down list. For example, Internet or
MPLS.
The selection of Internet orMPLS determines the type of IP address used:

n Select Internet to use a Public IP address.
n Select MPLS to use a Private IP address.

5. Enter an IP address based on theWAN type selected.

6. Click Next.

7. Review the summary page and click Finish.

Finish button is disabled if there are any errors in the configuration. Resolve the errors to
proceed to the next step.

8. Click Continue to configure SDWAN routing profiles.

Configuring SDWAN and Routing Profiles for a VPN Concentrator
Enabling Overlay Orchestrator Peering

Click the toggle switch to enableOverlay Orchestrator Peering.
To configure VPN hubs and routing profiles, complete the following steps:

1. In the Static Routing tab, configure a static routing profile.

2. To createDefault Routes, configure theNext Hop IP address and define a Cost metric.

3. To create a static route, configure the following parameters:
n Destination IP—Destination IP address

n Destination Mask—Subnet mask of the destination IP address.

n Type—Set the route to eitherNexthop orBlackhole.
n Next Hop—The IP address for the next hop.

n Cost—The cost metric for the route.



Different Modes of Configuring Gateways and Gateway Groups | 62

4. Click Next to configure routemaps.

Figure 10 Enabling Overlay Orchestrator Peering

Configuring Route Maps
In theRoute Maps tab, you can configureCommunity Lists Rules, Prefix Lists, and Route Maps.

Configuring Community List Rules

The Community List feature allows administrators to configure a set of community attributes to apply on
routes exchanged between ArubaGateways and their peers. The community attribute allows grouping
routes with similar properties and is generally used for tagging routes andmodifying BGP routing policies.

To create a community list, complete the following steps:

1. Click on Community List Rules to display theCommunity List table.

2. Click the + icon in theCommunity List table.

3. Enter aName for the community list.

4. From theAction drop-down list select Permit orDeny, to match the community specifications

5. Select aWell Known Community from the following options in the drop-down list.
n Internet—Advertises the prefix to all BGP neighbors.

n No-Export—Does not advertise the prefix to any eBGP neighbor. It advertises the prefix only to
iBGP neighbors.

n No-Advertise—Does not advertise the prefix to any peer, iBGP or eBGP neighbor.

n Local-AS—Does not advertise the prefix outside of the local Autonomous System.

You can also enter a value for the following types of community strings and click + to add.

n AS:NN—TheBGP community string in the AS:NN format, where AS refers to the Autonomous
Systemnumber and NN refers to the network number. The valid range of values is 0-65535.

6. Set amatch from theCommunity Values.

7. Configure the community string in theAS:NN format. The valid range of values is 0-65535.

Configuring a Prefix List
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A prefix list allows routing systems to determinewhich routesmust be accepted when they peer with other
networks. Prefix lists contain one ormore ordered entries which are processed sequentially.

Prefix lists can be used as amatch criteria for applying routemap rules on network subnets. For example, if
you want to prevent a route for 10.0.0.0/24 frombeing redistributed, you can define a rule to match the
prefix and add it a asmatch criterion in the BGP redistribution routemap.

To create a prefix list, complete the following steps:

1. Click on Prefix List to display the Prefix Rules table.

2. Click the + icon in the Prefix Rules table.

3. Enter aName for the prefix rule.

4. Enter a Sequence number.

5. Select an Action to be performed from the drop-down list, when the traffic matches the condition
defined in the prefix rule.

6. Enter the network Address that the prefix rule applies to.

7. Enter theNetmask of the network.

8. If you want to define a prefix length parameter and use it as amatch criteria for applying rules, enter
a value greater than or equal to this value for theGE operator. The allowed range of values is 1–32.

9. If you want to define a prefix length parameter and use it as amatch criteria for applying rules, enter
a value lower than or equal to this value for the LE operator. The allowed range of values is 1–32.

Configuring Route Maps

Routemaps allow you to configure a filtering criteria by defining a set of rules ormatch statements with a
permit or deny condition. A routemap includes a seriesmatch statements to determine if a routematches
the criteria defined in the statement and then apply the permit or deny rule accordingly.

Important Points to Note

The following list includes some of the important points to consider when configuring a routemap:

n A routemap includes name, sequence number, permit or deny rule, thematch and set statements. The
match statements determine the route or the traffic to which the rulemust be applied, whereas the set
statements allow you configure attributes or adjust metrics for the route that matches the criteria defined
in thematch statement.

n The routemap rules are applied sequentially; that is, based on the sequence number defined for each
entry.

n The routemap can use a prefix list in thematch statement to apply the allow or deny rule. Formore
information on prefix lists, see Configuring a Prefix List.

n Routemaps can be attached to the BGP neighbor profiles for the inbound and outbound routes. You can
associate routemaps for the inbound and outbound traffic when configuring a BGP neighbor profile.
When the routemap policy is applied to the inbound or outbound BGP route, and if the traffic matches the
specified criteria, the attribute set for thematch condition is applied. If you do not have a routemap
attached to an iBGP neighbor profile, the iBGP neighbor can access all inbound and outbound routes. For
more information on BGP neighbor profiles. see Adding BGP Neighbors.

To create a routemap, complete the following steps:

1. Click on Route Maps to display theRoute Maps table.

2. To add a routemap, click the + icon in theRoute Maps table. TheAdd/Edit Route Map pane opens.

Configure these parameters as per your network requirements:

https://help.central.arubanetworks.com/2.5.0/documentation/online_help/content/gateways/cfg/routing/bgp.htm
https://help.central.arubanetworks.com/2.5.0/documentation/online_help/content/gateways/cfg/routing/bgp.htm
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1. Enter aName for the routemap.

2. Enter a Sequence number for the routemap. Sequence numbers allow routemaps to be executed
in an order. If you are configuringmultiplematch clauses or statements, ensure that you define a
sequence number to uniquely identify eachmatch statement.

3. Select an Action to be performed from the drop-down list, when the traffic matches the condition
defined.

4. Configure theMatch condition for the routes that have a destination network. Thematch
statements define a set of conditions for determining if the route redistributionmust be allowed or
denied. To add amatch statement, click the + icon in theMatch table. You can set match type to any
of the following:
n IP address—You can assign a prefix list to amatch statement. Thematch condition determines if

the route advertisements from the BGP neighbor with the prefixesmust be allowed or denied.

n Next-hop IP—You can assign a prefix list to amatch statement. Thematch condition determines if
the route advertisements from the BGP neighbor with the prefixesmust be allowed or denied.

n Well known community—Awell known community allows you to configure one of the following
options:
o Internet—Advertises subnets to all BGP neighbors.
o No-Export—Does not advertise prefix to any eBGP neighbor.
o No-Advertise—Does not advertise subnets to BGP neighbors.
o Local-as—Prevents sending packets outside the local autonomous system.

n Community AS:NN—the community string is in the AS:NN format, where AS refers to the
Autonomous Systemnumber and NN refers to the network number. The valid range of values is 0-
65535.

n Community value—Allows you to specify a community value string. The valid range of values is 1–
4294967295.

n Community list—Allows you to select a community list configured on theGateway.

n Interface VLAN—Enter the interface VLANS separated by comma. You can enter up to 10 Interface
VLANs. The value you entermust be between 1 to 4095. To know how to configure VLANs, see
Configuring VLANs on ArubaGateways.

n OSPF route tag—You need to enter the tag names separated by comma. You can enter up to 10
tags. At least one of these tags has to match to allow route redistribution. The value you entermust
be between 0 to 4294967295.

5. Configure a Set of rules or attributes to apply to the BGP traffic that matches the conditions defined
in amatch statement.
To add a Set level attribute, click the + icon in the Set table and configure the following attributes as
per your requirement:

n as-path-prepend—Prepends AS numbers through which the packets have traversed. You can apply
the AS path prepending criteria to the BGP traffic to determine the best path.

n last-as—Prepends the last AS number to the AS path. The valid range of values is 1–10.

n Community value—TheBGP community Value string. The valid range of values is 1–4294967295.

n Community AS:NN formatch type, the community string is in the AS:NN format. The valid range
of values is 0-65535.

n Well known community—Awell known community. You can configure one of the following
options:
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o Internet—Advertises subnets to all BGP neighbors.
o No-Export—Does not advertise prefix to any eBGP neighbor.
o No-Advertise—Does not advertise subnets to BGP neighbors.
o Local-AS—Prevents sending packets outside the local autonomous system.
o Community list—Allows you to select a community list configured on theGateway.

n Local-as—Sets a local autonomous system string as an attribute in the routes.

n metric—Sets ametric value for determining the preferred path into an Autonomous System. You
can define ametric value between 0—4294967295. When ametric value in a routematches this
value, the route is advertised.

n origin—Sets the origin of the route. The following options are available:
o incomplete(EGP)—To specify that the route is originated from exterior routing protocol.
o igp—To specify that the route is originated from internal routing protocol.

n OSPF route-type—Sets the externalmetric (External Type-1 or External Type-2) attribute of the
route.
o To redistribute as routes as External type 1 which applies both external cost to the destination

and the cost to reach the boundary router in an Autonomous System.
o To redistribute routes as External type-2 and apply only the external cost to the destination.

n OSPF route tag—Sets the tag attribute of the route. You need to enter the tag names separated by
comma. You can enter up to 10 tags. At least one of these tags has to match to allow route
redistribution. The value you entermust be between 0 to 4294967295.

6. Click Next to configureOSPF.

Figure 11 Configuring Route Maps

Configuring OSPF
TheOSPF configuration allows advertising branch networks into an OSPF area and also enables VPN
Concentrators to learn corporate routes. You can configure theGeneral, Interface and Redistribution
settings in this section.

n Click General and, click the Enable OSPF toggle switch to enableOSPF.

Configuring the Interface
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To configure an interface, complete the following steps:

1. Click on Interface to display theVLANs table.

2. To add an interface, click the + icon in theVLANs table.

3. Select a OSPF interfaceVLAN from the drop-down list.

4. Set theOSPF Area ID for the interface VLAN.

5. Set theCost for the interface VLAN.

6. Set theHello Interval timer to sendmessages to neighbors.

Configuring Redistribution Rules

To configure redistribution rules, complete the following steps:

1. Click Redistribution, to display theRedistribution rules table.

2. To add Redistribution rules, click the + icon in theRedistribution rules table.

3. From the Source Protocol drop-down list, select the type of routes to redistribute. The following
options are available:
n Static—To redistribute IP static routes.

n Connected—To redistribute routes received from the subnets that are directly connected to a
router’s interface at the hub site.

n SDWAN Overlay—To redistribute routes learnt from the SD-WAN overlay network through the
Overlay Agent Protocol.

4. Set the Filters for the list of VLANs to be redistributed into OSPF. This is applied only when the
source protocol is set to Connected.

5. Select theRoute Type based if the route is redistributed as External-Type 1 (E1) or External-Type
2 (E2). If you want to steer to the closest exit use E1, to steer the traffic to a specific exit use E2.
n E1 increases the cost, reflecting the in the internal OSPF domain path cost.

n E2 has a fixed cost as configured in the Cost field.

6. Allocate the initial Cost for the route.

7. Click Next to configure BGP.

Figure 12 Configuring OSPF
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Configuring BGP
To support interoperability with an existing network infrastructure, BGP a dynamic routing protocol enables
VPN concentrators to redistribute overlay routes learned fromBranch Gateways into BGP and advertise
those routes in the data center network.

Configuring General setting

1. Click General and click the Enable BGP toggle switch to enable BGP.

2. Select theDefault orignate check box to generate a default external route to OSPF.

3. Enter theAS number to determine if the BGP neighbor is in the same autonomous aystem (AS).

4. Enter theRouter ID. The router ID is the IPv4 address of Gateway used for identifying it as the
router in an autonomous system.

Configuring Neighbors

To configure neighbors, complete the following steps:

1. Click Neighbors to display theNeighbors table.

2. To add neighbors, click the + icon in theNeighbors table.

3. Enter the Peer Address (IP address) of the neighbor you want to establish communication with.

4. Select theMulti-Hop checkbox if you want theGateway to route packets to its remote BGP peer that
ismore than one hop away.

5. Set theUpdate Source for the Interface or IP address used for the BGP updates in amulti-hop
scenario.

6. Select theRoute Map In value from the drop-down list. This is a per-neighbor routing policy that is
applied to information received from the neighbor.

7. Select theRoute Map In value from the drop-down list. This is a per-neighbor routing policy that is
applied to information sent to the neighbor.

Advertising Networks to BGP

To advertise networks, complete the following steps:

1. Click Networks to Advertise to display theNetworks to Advertise table.

2. To add networks, click the + icon in theNetworks to Advertise table.

3. Enter the network IP Address that you want advertised.

4. Enter the subnet Mask for the advertised network.

Configuring Route Aggregation

To configure route aggregation, complete the following steps:

1. Click the + icon in theAggregate Routes table.

2. Under Aggregate Routes, configure the following parameters:
n Address—Enter a network IP address.

n Mask—Enter the subnet mask.

n Route Map—Select a routemap.

Configuring Redistribution Rules

To configure Redistribution Rules, complete the following steps:
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1. Click Redistribution to display theRedistribution Rules table.

2. To add rules, click the + icon in theRedistribution Rules table.

3. From the Source Protocol drop-down list, select the type of routes to redistribute. The following
options are available:
n Static—To redistribute the static routesmanually configured on Branch Gateways.

n OSPF—To redistribute the routes learnt from an OSPF neighbor.

n SD-WAN Overlay—To redistribute routes learnt from the SD-WAN overlay network through the
Overlay Agent Protocol.

n Connected—To redistribute routes received from the subnets that are directly connected to a
router’s interface at the hub site.

n IAP-VPN—To redistribute routes that were received frommicro-branch deployments with Instant
APs.

4. Optionally, you can select a routemap to associate to the routes.

5. Click Next to configureOverlay Routing.

Figure 13 Configuring BGP

Configure Overlay Routing
Redistribution rules allow you to enable advertising of routing information from the connected, static, OSPF,
and BGP interfaces into overlay routing. Routing information fromother sources is not automatically
redistributed into overlay routing, but need to be configured for each source protocol locally on each
Gateway.

Configuring Redistributing Rules

To redistribute routes as overlay routes, complete the following steps:

1. To add a redistribution rule, click + under theRedistribution rules table.

2. From the Source Protocol drop-down list, select the type of routes to redistribute. The following
options are available:
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n Static—To redistribute IP static routes.

n IKE Overlay—To redistribute branch routes advertised by the Branch Gateways after establishing
an IPsec tunnel with the VPN Concentrator at the hub site.

n Connected—To redistribute routes received from the subnets that are directly connected to a
router’s interface at the hub site. If you have selected Connected, select the VLAN interfaces to
which theGateway is connected.

n OSPF—To redistribute routes learnt from theOSPF neighbors. If you have selected OSPF, select the
OSPF path type from Filter column. The following options are available:
o Intra Area—To redistribute routes to same area fromwhich they originated.
o Inter Area—To redistribute routes to another area in theOSPF domain.
o External Type 1—To redistribute as routes as External type 1 which applies both external cost to

the destination and the cost to reach the boundary router in an Autonomous System.
o External Type 2—To redistribute routes as External type 2 and apply only the external cost to

the destination.

n IAP-VPN Overlay—Routes learnt frommicro-branch deployments with Instant APs.

n BGP—To redistribute routes using BGP.

3. Set a Filter for the selected protocol.

4. Associate an existing Route Mapwith the Source Protocols if required. The routemap association
is applicable only for available routes.

5. Click Next to view a summary of the configuration.

Figure 14 Configure Overlay Routing

Click Finish to complete this Guided Setup.

The Finish button is disabled if there are any errors in the configuration. Resolve the errors to save
your configurations.





Chapter 5
Deploying Aruba Virtual Gateways

Deploying Aruba Virtual Gateways
The Aruba SD-Branch solution supports deploying a hardware VPN Concentrator as headend gateway in the
customer's data center or a virtualized instance of a headend gateway in customer's public cloud
infrastructure. The virtualized instance of Aruba Gateway is referred to as Virtual Gateway.

Virtual Gateways allow customers to bring their public cloud infrastructure to the SD-WAN fabric and
facilitate connectivity between branches and the public cloud.

The inclusion of Virtual Gateways in the Aruba SD-WAN architecture offers the following benefits:

n Ability to directly connect a branch to cloud instances and thereby improving access to the instances hosted
on a public cloud infrastructure.

n Resilient connectivity from the cloud by utilizingmultiple transport links; for example, the link between an
Internet Gateway and Virtual Gateway.

n Centralized control and policy management across branch, data center and cloud end-points.

To enable Virtual Gateway support on your SD-Branch, please contact your Aruba Sales Specialist.

Features Supported by Virtual Gateway
With Virtual Gateway, users can extend their SD-WAN overlay services to the public cloud infrastructure.
Virtual Gateways function as VPN Concentrators in the SD-WAN architecture. Virtual Gateways can
terminate tunnels fromBranch Gateway, Instant APs (micro SD-Branches with Instant APs) and VIA clients.
Like the on-premises VPN Concentrators, Virtual Gateways support routing, security, and tunneling features.

Virtual Gateway Redundancy
Aruba supports deploying Virtual Gateways for high availability (HA). The Virtual Gateways can be deployed
in theHAmode and also can be deployed inmultiple availability zones.

Software Image for Virtual Gateways
The software image required for creating Virtual Gateway instances are available as an AMI. To obtain the
AMI for a Virtual Gateway, contact your Aruba Sales Specialist.

This section includes the following topics:

n Deploying Aruba Virtual Gateways in AWS

n Deploying Aruba Virtual Gateways in Microsoft Azure

n Deploying Aruba Virtual Gateways in VMware ESXi (UnmanagedMode)

n Provisioning Virtual Gateways to Groups

n Troubleshooting Deployment Issues

Deploying Aruba Virtual Gateways in AWS
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Virtual Gateways simplify branch network deployments for organizations intending to migrate their
infrastructure to cloud providers such as Amazon.

Aruba supports instantiating Virtual Gateways on AmazonWeb Services (AWS) Elastic Compute Cloud (EC2)
virtualized environment. Network administrators can deploy an AWS EC2 instancewith enhanced
networking option that uses single root I/O virtualization (SR-IOV)-enabled Ethernet Network Interface Card
(NIC).

The AWS EC2 instance is created fromOS images in AmazonMachine Image (AMI) format. The ArubaOS
VMC image is used for creating and registering the Virtual Gateway AMI. To obtain the AMI for Virtual
Gateway, contact your Aruba sales representative.

Aruba Central supports deploying andmanaging Virtual Gateways hosted on the Amazon AWS VPCs using
one of the followingmethods:

n Managedmode—In themanagedmode, Aruba Central allows administrators to deploy Virtual Gateways
using the orchestrator application in Aruba Central. The Virtual Gateway orchestrator in Aruba Central
imports VPCs from an AWS account, deploys, connects, and allows you to manage Virtual Gateways from
Aruba Central. For step-by-step instructions on deploying Virtual Gateways in themanagedmode, see
Deploying Aruba Virtual Gateways in AWS (ManagedMode).

n Unmanagedmode—In the unmanagedmode, Virtual Gatewaysmust bemanually deployed and launched
from the cloud provider console. Aruba Central allows you to generate user data for such deployments and
manage Virtual Gateways fromAruba Central. For step-by-step instructions on deploying Virtual Gateway
in unmanagedmode, see Deploying Aruba Virtual Gateways in AWS (UnmanagedMode) on page 86.

Virtual Gateway Sizing
The Aruba Virtual Gateway requires the use of a supported AWS instancewith aminimumof 500 Mbps of
throughput and can support up to 1600 IPSec tunnels. This table lists out the supported AWS instances for
each ArubaModel/SKU:

Aruba
Model/SKU
Name

Throughput Supported
AWS Instance vCPU

Flash
Memory
(GB)

Tunnels

VGW-500MB 500 Mbps c4.xlarge 4 15 1600

c4.2xlarge 8 30

c4.4xlarge 16 60

VGW-2GB 2 Gbps c4.2xlarge 8 30 4096

c4.4xlarge 16 60

VGW-4GB 4 Gbps c4.4xlarge 16 60 8192

If a higher number of tunnels are required, please contact your Aruba Sales Specialist.

Deployment Procedure
See the following topics for step-by-step instructions on how to deploy an Aruba Virtual Gateway in
AWS VPC:
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n Deploying Aruba Virtual Gateways in AWS (ManagedMode)

n Deploying Aruba Virtual Gateways in AWS (UnmanagedMode)

Additional References
For a detailed description of SD-WAN integration with AWS and Virtual Gateway deployment in AWS, see the
Aruba SD-WAN Integration with Public Cloud (AWS) Technical Note.

Deploying Aruba Virtual Gateways in AWS (Managed Mode)
Aruba Central supports deploying Virtual Gateways inmanaged and unmanagedmodes. Formanaged-
mode deployments, Aruba Central supports the orchestration service for automating Virtual Gateway
deployments. The orchestrator application in Aruba Central enables IT administrators bring up, configure,
andmonitor Virtual Gateways from the Aruba Central management interface.

The orchestrator application performs the following key functions:

n Instantiation of Virtual Gateways—The orchestrator service allows you to integrate an Aruba Central
account with a cloud provider account. This integration enables Aruba Central to automatically discover
VPCs acrossmultiple regions and their subnets, deploy, and connect Virtual Gateways fromAruba Central.

The orchestrator application also generates an 8-digit serial number for Virtual Gateway before
instantiation and creates elastic network interfacewith a static MAC address that ismapped to Gigabit
Ethernet0/0/0. It also creates an Elastic IP (static public IP) and attaches it to the network interface.

n Device Registration—The orchestrator app registers Virtual Gateways in the customer's inventory in
Activate database and whitelists the devices formanagement service fromAruba Central.

n Certificate Enrollment—The orchestrator app generates user data for Virtual Gateways, using which the
Virtual Gateways obtain EST certificate to connect to Aruba Central using aWebSocket.

Orchestration Workflow
The following figure illustrates the orchestration workflow for Virtual Gateways:

Figure 15 Orchestration Workflow

The following flowchart illustrates the steps required for instantiating Virtual Gateway using the
orchestrator app.

https://support.arubanetworks.com/Documentation/tabid/77/DMXModule/512/EntryId/34365/Default.aspx
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Setting up a Virtual Gateway Instance using the Orchestration Service

It is recommended that the resources used in these configurations are not reused or shared.

To instantiate Virtual Gateways using the orchestrator application, complete the following steps:

n Creating a VPC

n Configuring an Internet Gateway for the VPC

n Creating a Security Group

n Configuring a Key Pair

n Creating a Cloud Provider Account in Aruba Central

n Creating a Role ARN

n Deploying Virtual Gateways fromAruba Central

n Verifying the Aruba VGWdeployment on AWS

Creating a VPC
A VPC is a dedicated virtual data center in AWS. You can launch your AWS resources, such as AWS EC2
instances, into your VPC. The VPCs also provide granular cloud security by allowing you to provision a
logically isolated section of AWSwith your own IP addresses.

A single VPC supports a single Virtual Gateway deployment. Ensure that the VPC is not shared between
different accounts.

To create a VPC, complete the following steps:

1. Log in to AWS console.

2. Select the region in which you want to deploy the VPC.
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3. Go to the AWS VPC Dashboard and create a VPC. You can also create a VPC using theVPC Wizard.

4. Enter a name for the VPC.

5. Specify an IPv4 CIDR block.

6. Click Create.

Configuring an Internet Gateway for the VPC
To create an Internet Gateway, complete the following steps:

1. On the AWS VPC console, click Internet Gateway.

2. Click Create Internet Gateway and create an Internet Gateway.

3. To attach the Internet Gateway to the VPC, click Actions > Attach to VPC. The Internet Gateway
allows communication between the instances in your VPC and the Internet.

To terminate MPLS connections, you can also create Virtual Private Gateway and attach it to the VPC.

Creating a Security Group
A security group controls traffic for instances to which it is associated. Ensure that your network access
control and security group rules allow the relevant traffic to flow to and from your instance.

To create a security group, complete the following steps:

1. Go to the AWS EC2 Console.

2. Select the region in which the VPC is deployed.

3. In the AWSDashboard, select the EC2 tab and click on Security Groups underNETWORKING &
SECURITY.
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4. Enter a name for the group.

5. Select the VPC.

6. Add inbound and outbound rules. Ensure that the UDP 4500, TCP 443 and other ports required for
device communication over a network firewall are open.

7. Click Create.

Configuring a Key Pair
By default, the Linux instances do not have a password set. To secure your login information for your
instance, you can create a key pair. You can also use the key for logging in to the Virtual Gateway instance
using SSH.

To configure a key pair, complete the following steps:

1. In the AWSDashboard, select the EC2 tab and click on Key Pairs underNETWORKING & SECURITY.

2. Import an existing key pair or create a new one.

Creating a Cloud Provider Account in Aruba Central
To deploy Virtual Gateway instances in a customer's VPC, youmust create a cloud provider account in Aruba
Central andmap it to the IAM Role ARN of the customer's AWS account in which the VPC is deployed.
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1. Log in to Aruba Central.

2. In theNetwork Operations app, set the filter to Global.

3. Go to Manage > Network Services > Virtual Gateways, click theConfig icon. The configuration
page is displayed.

4. To add an account, click Accounts, and select AWS from the available options and click Add
Account.

5. In theAdd AWS Account pop-up window, enter an Account Name and your IAM Role ARN#.

6. Retain the details that are populated in theAccount ID and External ID fields.

7. Azure Marketplace Subscription Completed—Enable this option after subscribing to AWS
Marketplace Subscription in AWS console.

Aruba Virtual Gateway is available in the AWSMarketplace as a limited or private listing to host
images. Clicking on the listing deploys the hosted image using Virtual Gateway orchestration.

1. Click Submit. The account is added to list of accounts on theAccounts page.
2. Verify the status of the account. If the status column for the account is shown Access Verified,
proceed to deploy the Virtual Gateway instance.

Creating a Role ARN
Ensure that you have the IAM Role ARN of the customer's AWS account for which you want to deploy the
Virtual Gateway. If the IAM Role is not created, complete the following steps:

1. Log in the AWS account in which the VPC instancemust be deployed.

2. Click Services.

3. Select the IAM service.



Deploying Aruba Virtual Gateways | 78

4. To create a new role, click Roles > Create a New Role.

5. Enter a name for the role.

6. Click Next.

7. Select Another AWS Account Belonging to you or a 3rd party.

8. Enter yourAccount ID.

9. Select theRequire External ID checkbox.
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10. Enter the External ID. The External ID is created in Arubawhile creating the Cloud Provider Account
formore information, see the Adding AWS Account image in the Creating a Cloud Provider Account
section.

11. Click Next: Permissions.

12. Set the permission policy.
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13. Click Next: Tags.

14. Add a role name and description, in theReview screen and click Create role.

15. Note theRole ARN on theRole summary page.

Deploying Virtual Gateways from Aruba Central
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Before Deploying the Virtual Gateway, ensure that the VPC, Internet Gateway, Security Group, and Key
Pair are configured on the AWS.

To deploy a Virtual Gateway instance, complete the following steps:

1. Select theDeployment tab.

2. Select the account and the deployment region, and then click Import VPC. The orchestrator app
imports VPCs and displays the subnets allocated to the VPC.

Virtual Gateway deployment from Aruba Central triggers a series of events that may have
dependency on AWS. This may result in a delay in displaying the output. For example, a
deployment may take up to three or more minutes before the updated status is displayed on
the Deploy Virtual Gateway page.

3. Click Deploy Virtual Gateway. TheCreate Virtual Gateway pop-up window opens.

a. Virtual Gateway Subnet—Enter the subnet range for the VGW. The default subnet is
automatically set to the last available /24 subnet and theVirtual Gateway instance type.

b. Virtual Gateway Size—Enter the Aruba SKU details for the size of the VGW instance. For
more information see, Virtual Gateway Sizing in theDeploying Aruba Virtual Gateways in AWS
section.

c. AWS Instance TypeChoose the corresponding AWS instance size. Formore information see,
Virtual Gateway Sizing in theDeploying Aruba Virtual Gateways in AWS section.

d. Marketplace Image—Choose this option to select the ArubaOS image to be installed in Azure
Marketplace. When this option is enabled, Select Image is automatically updated with the
ArubaOS image to be installed in AWSMarketplace.

e. n Private Image—Choose this option to select a private ArubaOS image.

n Select Image—Displays the ArubaOS image to be installed.

f. Key-Name—Choose the Key-pair that will be associated with this VGW.

g. Security GroupChoose the Security Group that will manage this VGW.

h. Edge VPC—Choose this option to enable or disable Edge VPC. When Edge VPC is enabled, the
Virtual Gateways are deployed in an active-active high availability mode. All the Branch
Gateways are connected to both Virtual Gateways. The Virtual Gateways in-turn connect to
the VPCs through the AWS VPCwhich is responsible for interconnecting all the VPCs.

When Edge VPC is enabled, Connect/Disconnect Subnet option for VPC will be disabled.

i. Virtual Gateway High Availability—Select either to enable or disable High Availability for
the VGW.

j. Deploy Multi-Availability Zone—Select either to enable or disableMulti-Availability zone
deployment for the VGW.

When Edge-VPC is enabled, this configuration option is disabled by default.



Deploying Aruba Virtual Gateways | 82

Figure 16 Creating a virtual gateway

4. Click Deploy Virtual Gateway. After the deployment is completed, Virtual Gateway Deployed
message is displayed.

A summary of the deployment is also displayed on the Summary tab of theOrchestrated
Cloud Provider page. Hovering the cursor over any of the columns displays additional
information about the field.

Figure 17 Summary of deployed virtual gateways

TheDevice Inventory page displays the devices that are in the inventory.
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Figure 18 Viewing devices in Device Inventory

5. Assign the Virtual Gateway to a valid VPNC group. Adding the deployment to the group ensures that
the Virtual Gateway acquires the controllers IP address.

Figure 19 Assigning Virtual Gateway to a Group

6. To associate the subnet with the user route table on AWS, on theDeployment tab in Aruba Central,
click Connect/Disconnect Subnet.

Verifying the Aruba VGW deployment on AWS

The information that is available in this section is meant for debugging purposes only. Aruba does not
recommendedmaking any changes as that may disrupt the configuration.

To verify Aruba VGWdeployment on AWS, complete the following steps:
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1. In the AWS EC2 dashboard, click Instances section. After the Virtual Gateway is deployed
successfully fromAruba Central, AWS creates an instance.

2. Select the Instance.

3. Verify the Status Checks and ensure that the instance status is displayed as 2/2 checks. During
this process, theVGW Status in Central displays asDown.

4. Verify the status of Virtual Gateway deployment on theVirtual Gateway > Orchestrated Cloud
Provider > Summary page in Aruba Central Orchestrated Cloud Provider, displays the information
and status of each Virtual Gateway. Placing themouse cursor over each itemdisplays additional
information.

5. Go to the EC2 instance in the AWS console. Verify the Instance ID, Instance Type, along with
displaying the Elastic IPs, Private DNS, and Private IPs. A deployment can support up to two
Virtual Gateways. Each Virtual Gateway instance supports up to four interfaces. Each interfacemust
bemapped to a subnet.
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The following figure shows a samplemapping of the network interfaces:
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6. In theVirtual Private Cloud section of AWS, click Subnets to view the subnets.

7. In theVirtual Private Cloud section of AWS, click on Route Tables and verify the aruba-vgw-urt
user route table created as part of the orchestration. This route table enables the Virtual Gateway
instance to connect the connect the user subnet fromAruba Central to AWS.

After a successful deployment, the Virtual Gateway instances launch and connect to Aruba Central with the
latest AMI.

Deploying Aruba Virtual Gateways in AWS (Unmanaged Mode)
Aruba Central supports deploying Virtual Gateways in the unmanagedmode. In the unmanagedmode,
administrators deploy the Virtual Gateway instance using the AWS console. After deploying the Virtual
Gateway instance in AWS, administrators can generate user data fromAruba Central to allow Virtual
Gateway to connect to Aruba Central as amanaged device.

To deploy Virtual Gateways in the unmanagedmode in AWS, complete the following steps:

n Creating a VPC for Virtual Gateway Instance on AWS

n Creating a Security Group

n Creating a Network Interface

n Launching a Virtual Gateway Instance

n Generating User Data in Aruba Central

n Uploading theUser Data to the Virtual Gateway Instance in AWS Instance

n Verifying the Instantiation Status
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Creating a VPC for Virtual Gateway Instance on AWS
To set up a Virtual Gateway instance in AWS, log in to your AWS account and complete the following steps:

1. Log in to your AWS account.

2. Select a region for the VPC.

3. Click Launch VPC Wizard. TheVPC Wizard opens.

4. Enter a name for the VPC.

5. Configure subnets. The Virtual Gateway deployment requires two subnets; one each for
management and data traffic. The following figure illustrates the recommended subnet configuration
for Virtual Gateway deployments.

6. Click Create VPC.

7. Create an Internet Gateway and attach it to the VPC.

Creating a Security Group
Security groups allow you to control both incoming traffic and outgoing traffic from the Virtual Gateway
instance. For example, you can add a rule to a security group for connecting to your instance from your IP
address using SSH.

To create a security group, complete the following steps:

1. Select the region in which your VPC is created.

2. In the AWSDashboard, select the EC2 tab and click on Security Groups underNETWORKING &
SECURITY.

3. Enter a name for the group.
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4. Click Security Groups.

5. Specify a group name.

6. Select the VPC.

7. Add inbound and outbound rules. Ensure that the UDP port 4500 and other ports required for
device communication over a network firewall are open.

8. Click Create.

Creating a Network Interface
To create a network interface, complete the following steps:

1. Go to Amazon EC2 console and click Network Interfaces.

2. Click Create Network Interface.

3. Select the subnet.

4. Select the security group you just created.

5. Click Yes, Create.



Aruba SD-WAN Solution | User Guide 89

6. Associate an elastic IP address with your instance. By default, an instance in a nondefault VPC is not
assigned a public IP address. An elastic IP addressmust be allocated to your account, and then
associated with your instance. To allocate an elastic IP address:

a. Go to Amazon VPC console and click Elastic IPs.

b. Select Allocate New Address.

c. Click Close.

d. Select the elastic IP address from the list, and then click Actions > Associate Address.

e. Select the network interface.
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f. Click Associate.

Launching a Virtual Gateway Instance
To launch a Virtual Gateway instance, complete the following steps:

1. Open the AWS EC2 console.

2. Select the region in which you have deployed your VPC.

3. Click Launch Instance. When you launch an instance, youmust select an AMI. An AMI contains the
software image or information required to create a new instance. To obtain the AMI image for
instance, contact Aruba Customer Support.

4. On theChoose an Amazon Machine Image (AMI) page, select the AMI.

5. Click Choose Instance Type and select the hardware configuration and size of the instance to use.
Formore information see, Virtual Gateway Sizing in theDeploying Aruba Virtual Gateways in AWS
section.
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6. Click Configure Instance Details. Ensure that the subnets and network interfaces are configured.

7. Click Add Storage and add the storage details. Aruba recommends that you add at least 8GB
EBS storage.

8. Click Add Tags and add tags if required.

9. Click Configure Security Group and ensure that a security group is created and attached to the
VPC.

10. Click Review.

11. Review the configuration and click Launch. The systemprompts you to select an existing key pair or
create a new key pair. By default, the Linux instances do not have a password set. To secure your
login information for your instance, you can create a key pair.

12. Create new key pair if required.

13. Click Launch. The instance is launched and available for use.

Generating User Data in Aruba Central
For Aruba Central to manage a Virtual Gateway that is deployedmanually and directly in a customer's VPC,
generate device identity for the device in Aruba Central.

To generate device identity for the Virtual Gateway instance, complete the following steps:

1. In theNetwork Operations app, set the filter to Global.

2. Go to Manage > Network Services > Virtual Gateways, click theConfig icon. The configuration
page is displayed.

3. Click Unmanaged.

4. Select the Virtual Gateway model.

5. Click Create Device Identity.

6. Click Yes to confirm identity creation. Aruba Central displays the newly created VGWwith the
following fields:

a. Serial #—Displays the serial number of the Virtual Gateway.

b. MAC—Displays the sMAC address of the Virtual Gateway.

c. Model Number—Displays themodel number of the Virtual Gateway.

d. Device Identity—Displays the device identity of the Virtual Gateway.

e. Status—Displays the status as User Generated for the created device identity of the Virtual
Gateway.

7. Click the three vertical dots icon next to the Status to view theAccount Options.

8. Click Download txt. The user data includes the following information:

n Aruba Central URL

n Serial Number

n User name and password for the Virtual Gateway

Virtual Gateways use these credentials to connect to Activate and EST server for EST enrollment.

n MACAddress of Virtual Gateway

n Part Number of the Virtual Gateway instance

n Deployment mode
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n Network interfaces configured on a Virtual Gateway. For example, eth0, eth1, eth2 and eth3

n Activate URL

Uploading the User Data to the Virtual Gateway Instance in AWS Instance
To upload user data to the Virtual Gateway instance, complete the following steps:

1. Log in to the AWS EC2 console.

2. Select the Virtual Gateway instance for which you want to upload the user data.

3. Click Actions > Instance Settings > View/Change User Data.

4. Copy the user data downloaded fromAruba Central and paste it in theUser Data field.

5. Click Save.

6. To start the instance, click Actions > Instance State, and then click Start.

7. Wait for the instantiation to complete.

Verifying the Instantiation Status
To verify the instantiation status, and check the status of the Virtual Gateway instance in the Summary
dashboard, complete the following steps:

1. In theNetwork Operations app, set the filter to Global.

2. Go to Manage > Network Services > Virtual Gateways > Summary.

3. Check if the Virtual Gateway instance is displayed in the device inventory.

4. Check if Virtual Gateway instance is connected to Aruba Central.

Deploying Aruba Virtual Gateways in Microsoft Azure
Virtual Gateways simplify branch network deployments for organizations intending to migrate their
infrastructure to cloud providers such asMicrosoft Azure.

The SD-Branch integration with a private cloud infrastructure hosted in Microsoft Azure allows you to set up
a secure connection between the Aruba Branch Gateways and the Virtual Network (VNET) environments in
Microsoft Azure.

Aruba Branch Gateway supports standard IPsec tunnels, and establishes direct communication with the
Azure VPN Gateway.

Aruba Central supports deploying andmanaging Virtual Gateways hosted on theMicrosoft Azure VNETs
using one of the followingmethods:

n Managedmode—In themanagedmode, Aruba Central allows administrators to deploy Virtual Gateways
using the orchestrator application in Aruba Central. The Virtual Gateway orchestrator in Aruba Central
imports VNETs from aMicrosoft Azure account, deploys, connects, and allows you to manage Virtual
Gateways fromAruba Central. For step-by-step instructions on deploying Virtual Gateways in themanaged
mode, see Deploying Aruba Virtual Gateway in Microsoft Azure (ManagedMode).

n Unmanagedmode—In the unmanagedmode, Virtual Gatewaysmust bemanually deployed and launched
from the cloud provider console. Aruba Central allows you to generate user data for such deployments and
manage Virtual Gateways fromAruba Central. For step-by-step instructions on deploying Virtual Gateway
in unmanagedmode, see Deploying Aruba Virtual Gateway in Microsoft Azure (UnmanagedMode) on page
111.

Virtual Gateway Sizing
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The Aruba Virtual Gateway requires the use of a supported Azure instancewith aminimumof 500 Mbps of
throughput and can support up to 1600 IPSec tunnels. This table lists out the supported Azure instances for
each ArubaModel/SKU:

Aruba
Model/SKU
Name

Throughput
Supported
Azure
Instance

vCPU
Flash
Memory
(GB)

Tunnels

VGW-500MB 500 Mbps Standard_DS3_v2 4 15 1600

Standard_F8s_v2 8 30

Standard_F16s_
v2

16 60

VGW-2GB 2 Gbps Standard_F8s_v2 8 30 4096

Standard_F16s_
v2

16 60

VGW-4GB 4 Gbps Standard_F16s_
v2

16 60 8192

If a higher number of tunnels are required, please contact your Aruba Sales Specialist.

Deployment Procedure
See the following topics for step-by-step instructions on how to deploy an Aruba Virtual Gateway in
Microsoft Azure VNET:

n Deploying Aruba Virtual Gateway in Microsoft Azure (ManagedMode)

n Deploying Aruba Virtual Gateway in Microsoft Azure (UnmanagedMode)

Additional References
For a detailed description of SD-WAN integration with Microsoft Azure and Virtual Gateway deployment in
Microsoft Azure, see the Aruba SD-WAN Integration with Microsoft Azure Public Cloud Technical Note.

Deploying Aruba Virtual Gateway in Microsoft Azure (Managed
Mode)
Aruba Central supports deploying Virtual Gateways in Microsoft Azure using the orchestratedmode. For
orchestrated -mode deployments, Aruba Central supports the orchestration service for automating Virtual
Gateway deployments. The orchestrator application in Aruba Central enables IT administrators bring up,
configure, andmonitor Virtual Gateways from the Aruba Central management interface.

Setting up a Virtual Gateway Instance using the Orchestration Service
To instantiate Virtual Gateways using the orchestrator application, complete the following steps:

Deployment Procedure
Before deploying Aruba Virtual Gateway deployment in Azure VNET, ensure that you have the following
resources and account privileges:

https://support.hpe.com/hpesc/public/docDisplay?docId=a00099162en_us
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n A valid subscription and administrator credentials to access your Azure account.

n A valid subscription and administrator credentials to access your Azure account.

n A valid subscription and administrator credentials to access your Azure account.

You can configure an Aruba Virtual Gateway in Microsoft Azure using either the Azure Cloud Shell or
the Azure graphical user interface (UI). The configuration steps described in this document are based
on the UI workflows.

Currently, only the SKU# VGW-500MB is supported by Microsoft Azure.

To deploy a Virtual Gateway in Microsoft Azure, complete the following steps:

1. Registering a New Application in Azure

2. Creating a Client Secret

3. Adding the Application Permissions

4. Setting up Access control and Role Assignments

5. Viewing the Application IDs

6. Creating a Resource Group

7. Creating a Storage Account

8. Creating a VNET

9. Uploading the Aruba Virtual Gateway Software Image

10. Adding a Cloud Provider Account in Aruba Central

11. Deploying the Virtual Gateway

12. Verifying theDeployment Status

Additional References
Formore information about SD-WAN integration with Microsoft Azure and Virtual Gateway deployment in
Microsoft Azure, see the Aruba SD-WAN Integration with Microsoft Azure Public Cloud Technical Note.

Registering a New Application in Azure
Enterprise software-as-a-service (SaaS) providers develop commercial cloud services applications that can be
integrated with theMicrosoft identity platform to provide secure sign-in and authorization for their
services. To register a new application Azure, complete the following steps:

1. Log in to the Azure portal. On theHome screen, select App registration from the Azure services
listed.

2. In the App registrations page, click + New registration to initiate the registration process.

3. In theRegister an application page, enter these details:

n Name—Enter an account name for easy identification. This is amandatory field.

n Supported account types—Select the profile or entity that can access this application. By default
Accounts in this organizational directory only (Hewlett Packard Enterprise only - Single
tenant) is selected.

n Redirect URI (optional)—After successfully authenticating the user, a response is sent to this URI.
This information is optional and can be updated at a later time.

https://support.hpe.com/hpesc/public/docDisplay?docId=a00099162en_us
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Figure 20 Registering an app

4. Click Register to complete the registration. The new application page loads in a few seconds.

Creating a Client Secret
To ensure that the application communication is secure, complete the following steps and create a client
secret:

When the Client secret key expires, the orchestration page displays an access deniedmessage. To
create a new client secret key, complete the following steps.

1. On the left navigation pane, click Certificates & secrets to configure the client secret.

2. Click the + New client secret, to open the Add a client secret pane.

3. In the Add a client secret pane, enter a description of the secret and the duration of the secret validity
and click Add.

4. In theCertificate & secrets page, the new secret will be displayed along with theValue.
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Copy the Client secrets Value as this will be value will be hashed out after approximately tenminutes.

Figure 21 Setting up a Client secret

Adding the Application Permissions
To set the permissions for access and control of the application, complete the following steps:

1. To set the application permissions, on the left side navigation pane click API permissions.

2. In theAPI permissions pane, click +Add a permission to open theRequest API permission
pane.

3. In theRequest API permission pane, select Azure Service Management API from theMicrosoft
APIs tab.

4. Delegated permission is selected by default, select user_impersonation and click Add
permissions.

5. TheAzure Service Management api with user_impersonation permission is now added to the
list of permitted APIs.
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Figure 22 Adding the Application permissions

Setting up Access control and Role Assignments
Once the application is set up, a role needs to be assigned to the application. To assign a role to the
application, complete the following steps:

1. In the search box on the home screen search for Subscriptions, and select subscriptions from the
displayed service options.

2. In the Subscriptions page, select the subscription that you areworking with.

3. Select Access control (IAM) from the left side navigation to open the access control pane.

4. In the access control pane, select theRole assignments tab, and click the +Add and chooseAdd
role assignment.

5. In the Add role assignment set the following details:

n Role—Select the Role to be assigned to the app. In this configuration, set the role as a Contributor.
Changes to the roles and associated assignments can only bemade by an administrator.

n Assign access to—Assign the access level for the role.

n Select—Set the application, user, or device that inherits the above properties. If required, search
using the registered name or email address as keywords.

n Choose the user or application from the displayed options.

6. Click Save to save and exit.

Viewing the Application IDs
The application IDs are needed to start the onboarding process in Aruba Central. To view the application IDs,
complete the following steps:

1. In the search box on the home screen search for App registrations, select App registrations from
the displayed service options.

2. In theApp registrations page, select the application and the application details pane is displayed.
Note the following IDs to be used during the onboarding in Aruba Central:

n Application (client) ID
n Directory (tenant) ID
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Figure 23 Viewing the application ids

Creating a Resource Group
A resource group in Azure is a logical container that consists of resources required for deploying a virtual
machine (VM). Resource groups allow you to logically group related resources such as storage accounts,
virtual networks, and VMs. Resource groups also allow you to deploy andmanage all these resources as a
single entity.

Note the following important points about resource groups in Azure:

n A resource group can contain resources fromdifferent regions or locations.

n Access control for administrative actions can be scoped with a resource group.

n Resources can be added or removed from a group at any time.

n Resources can bemoved fromone group to another group.

n Each resource can only exist in one resource group.

n Resources can interact with other resources group containers.

To verify if your subscription has a resource group, click Home > Resource Groups.
If you do not have a resource group created in your Azure subscription, follow these steps to create a
resource group:

1. Log in to Azure portal using your Azure account credentials.

2. Click + Create a Resource to access Dashboard and then search for Resource Groups in the search
box to access theResource Groups configuration page.

3. Click Create.

4. In theBasics tab, enter the following information:

n Subscription—Select yourMicrosoft Azure subscription.

n Resource group name—Enter a name for the resource group.

n Region—Select the geographic location for the resource group.

5. Click Review+Create and then click Create.

Creating a Storage Account
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Storage account in Azure provides a unique namespace to store and access your Azure storage objects.
Every storage account must belong to an Azure resource group.

For Aruba Virtual Gateway deployments, you will need a storage account to store the software image and
also a separate storage account for Boot Diagnostics. The Boot Diagnostics option allows you to view logs
pertaining to VM boot issues. You can enable the Boot Diagnostics option when configuring a VM.

If you do not have a storage account created andmapped to the resource group that you want to use for
Aruba Virtual Gateway deployment, complete the following steps:

1. Log in to your Azure account.

2. Select Home > Storage Accounts.

3. In the Storage Accounts window, click Add.

4. Enter a unique name for your storage account.

The name must be between 3 and 24 characters in length, and can include numbers and lowercase
letters.

5. Choose a Subscription and Resource group that this account is linked to.

6. Enter the Storage Account Name, Location, Account kind, and Replication.

7. Click Review + create, validate the account before you proceed.

8. Enter theResource group name that will be associated with this storage account.

9. Click Create to complete the storage account creation procedure.

Figure 24
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Configuring Containers

Virtual machines create a partition for each operating systemdeployment. Each partition simulates a
machine using software. Containers offer near-instant deployment and are a great way of moving code, the
deployment time is shorter and they are easier to maintain.

1. In the Storage accounts window, select the account that was created, and click Containers.

2. Click on Containers to add a container.

3. In the new container window, enter aName for the container, and the Public Access level, click Ok
to proceed.

4. Click on the new container, in the container window, select the required .vhd file and click upload.

Figure 25 Selecting the container

Figure 26 Adding a new container
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Figure 27 Creating a new container

Creating a VNET
The Azure VNETs enable you to securely connect your Azure resources with each other. You can use VNETs
to provision andmanage VPNs in Azure and, optionally link the VNets with other VNETs in Azure, or with
your on-premises IT infrastructure to create hybrid or cross-premises solutions.

Deploying an Aruba Virtual Gateway in a customer VNET brings the SD-WAN fabric into the VNET and thus
enables connectivity to physical sites, such as branches and data centers.

Azure deletes your VNETs when a subscription is disabled. If the subscription is re-enabled, youmust
recreate the resources.
The orchestration app creates 8/27 subnets, ensure that that the VNET has a /24 block reserved for
the interconnect subnets.

If you do not have a VNET created in your Azure subscription, complete the following steps to bring up the
VNET in Azure:

1. On the Azure portal, go to Home > Networking > Virtual Networks. You can also search for virtual
network on theHomepage to access theVirtual Network configuration page.

2. On theVirtual Network page, ensure that the selected deployment model is set as Resource
Manager, and click Create. TheCreate virtual network page opens.

3. Configure the following parameters:
n Name—Enter a name for the virtual network.

n Address space—Enter the allocated address space details.

n Subscription—Select a subscription.

n Resource group—Select the resource group to which you want to attach the VNET.

n Location—Select a valid location.

n Subnet—Enter the following information:

n Name—Nameof the subnet.

n Address range—Enter the address range for the subnet.
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n DDoS Protection(Optional)—Select eitherBasic or Standard based on your subscription plan.

n Service endpoints(Optional)—Select eitherDisabled or Enabled based on your requirement. This
is set to Disabled by default.

n Firewall(Optional)—Select eitherDisabled or Enabled based on your requirement. This is set to
Disabled by default.

4. Click Create to complete the creation of the virtual network.

Uploading the Aruba Virtual Gateway Software Image
To use the Aruba Gateway software image as the source for an Azuremanaged virtual disk, youmust ensure
that the Aruba Virtual Gateway software image is uploaded to a blob container in your storage account.

Aruba supports Azure VNET deployments on Virtual Gateway appliances running ArubaOS SD-WAN 8.5.0.0-
2.0.0.0 or later software versions. To obtain access to a valid Virtual Harddrive (.vhd file) image for Virtual
Gateways, contact your Aruba Sales Specialist.

To upload the .vhd file, download and install theAzure Storage Explorer app. Formore information, see
Azure Storage Explorer.

Creating SSH keys

1. From the Azure portal, go to the Azure BASH Shell.

2. Create SSH key pair with the command ssh-keygen -t rsa -b 2048

3. Save the private key on your local machine to SSH into the Virtual Gateway

4. Save the public key and use it during the setup of the Virtual Gateway.

Formore information see, Create and use an SSH public-private key pair for Linux VMs in Azure.

Figure 28 Creating SSh Keys

Creating a Security group
A network security group (NSG) in Azure is theway to activate a rule or access control list (ACL), which will
allow or deny network traffic to your virtual machine instances in a virtual network. NSGs can be associated
with subnets or individual virtual machine instances within that subnet.

https://azure.microsoft.com/en-us/features/storage-explorer/
https://docs.microsoft.com/en-us/azure/virtual-machines/linux/mac-create-ssh-keys
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1. On the Azure portal, go to Home > Networking security groups, click + to start the creating theNSG.

2. In the Basics tab, enter the Subscription and Resource group that this NSG is linked to, also provide a
uniqueName and the Region for theNSG. Click Review + Create to proceed.

Figure 29 Creating Security group

3. On the Azure portal, go to Home > Networking security groups, click theNSG that was created.

4. Select Inbound security rules and click +Add. In the Basic tab, add UDP port 4500 in theDestination
port ranges to allow incoming IKE connection fromBranch Gateways.

5. Select Inbound security rules and click +Add. In the Advanced tab, add SSH port 110 as a Priority to
allow incoming SSH connections.

Figure 30 Security group summary

Enabling Aruba Virtual Gateway Subscription in Azure Marketplace
Aruba Virtual Gateway is available in the AzureMarketplace as a limited or private listing to host images. To
enable the Aruba Virtual Gateway subscription in AzureMarketplace, complete the following steps:
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1. Log in to the Azure portal.

2. In the search bar, typeMarketplace.

3. Marketplace is listed under Services.

4. Click Marketplace.

5. In the Search the Marketplace search bar, typeAruba Virtual Gateway, and click the Aruba
Virtual Gateway listing.

Figure 31 Searching Aruba Virtual Gateway Listing

6. UnderAruba Virtual Gateway (SD-WAN) (preview) page, click Create.

To add interfaces, click Start with a pre-set configuration, go to Azure portal, stop the VM, add
existing interfaces, and restart VM.
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Figure 32 Aruba Virtual Gateway (SD-WAN) (preview)

7. In Configure Programmatic Deployment page, under Choose the subscriptions, click Enable.
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Figure 33 Enabling Aruba Virtual Gateway Subscription

8. Click Save.

Adding a Cloud Provider Account in Aruba Central
To deploy Virtual Gateway instances in a customer's VNET, youmust create a cloud provider account in
Aruba Central andmap it to the customer's Azure account where the VNET is deployed.
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1. Log in to Aruba Central.

2. In theNetwork Operations app, use the filter to select All Devices.

3. UnderManage, click Network Services > Virtual Gateways to display the Summary page.

4. To add an account, click theConfig icon to open theAdd Cloud Provider Accounts page in the
Accounts tab.

5. To add an account, select Microsoft Azure from the dropdown options and click Add Account.
6. In theAdd Azure Account window, enter these details:

n Account Name—Enter an account name for easy identification.

n Tenant ID—Enter the Tenant ID from the Azure application.

n Subscription ID—Enter the subscription ID for your Azure account.

n Application ID—Enter the Azure Application ID. In the future, to edit this Azure account the
Application ID will be needed. The Application ID can remain the same.

n Secret Key—Enter the secret key for the Azure application. In the future, to edit this Azure account
the Secret Key will be needed. This Secret Key will be different from the one that is used currently.

n Azure Marketplace Subscription Completed—Enable this option after subscribing to Azure
Marketplace Subscription in Azure console.

Aruba Virtual Gateway is available in the AzureMarketplace as a limited or private listing to host
images. Clicking on the listing deploys the hosted image using Virtual Gateway orchestration.

The Tenant ID, Subscription ID, Application ID, and Secret Key are information that were saved
during the App creation process.

Figure 34 Adding an Azure account
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7. Click Submit. The account is added to list of accounts on theAccounts page.

8. Verify the status of the account. If the status column for the account is shown asAccess Verified,
proceed to deploy the Virtual Gateway instance.

To edit or delete an account, select the account, and click the setting icon in the Status column to
open the Account Options window.

Figure 35 Reviewing the cloud provider accounts

If the Azure account in Aruba Central displays an Access Denied error message, check the following
details:

nEnsure that the VNET is configured and available present in your Azure account.

nEnsure that the subnet configured for the VNET is larger than /24.

nEnsure that the Subscription ID, Tenant ID, App ID, and Client Secret are correct.

Deploying the Virtual Gateway
To deploy a Virtual Gateway, complete the following steps:

1. On theVirtual Gateways page, select theDeployment tab and chooseMicrosoft Azure from the

drop downmenu and click on Import VNETs to ensure that the information is refreshed and up
to date.

2. Select the region to host the virtual gateway, and click Deploy Virtual Gateway.

3. In theCreate Virtual Gateway page update the fields listed here:

n Virtual Gateway Subnet—Enter the gateway subnet

n Virtual Gateway Size—Enter the virtual gateway SKU (currently limited to VGW-500MB)

The Virtual Gateway Size also displays the total number of licenses and the number of available
licenses.

n Azure Instance Type—Enter the Azure instance type (currently limited to Standard_DS3_v2)

n Marketplace Image—Choose this option to select the ArubaOS image to be installed in Azure
Marketplace. When this option is enabled, Select Image is automatically updated with the ArubaOS image
to be installed in AzureMarketplace.

n Private Image—Choose this option to select a private ArubaOS image.
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n Select Image—Displays the ArubaOS image to be installed.

n SSH Public Key—Enter the SSH key. Formore information on creating the SSH key, see Create and use
SSH keys in Azure.

n Security Group (optional)—Enter the Security Group details

n Edge VNET—Choose this option to enable or disable Edge VNET. When Edge VNET is enabled, the Virtual
Gateways are deployed in an active-active high availability mode. All the Branch Gateways are connected to
both Virtual Gateways. The Virtual Gateways in-turn connect to the VNETs through the Azure vHub
Gateways, where the vHub Gateways are responsible for interconnecting all the VNETs.

When Edge VNET is enabled, Connect/Disconnect Subnet option for VPC will be disabled.

n Virtual Gateway High Availability—Choose if this virtual gateway supportsHigh Availability.
n Deploy Multi-Availability Zone—Select Yes if the virtual gateway will be available acrossmultiple

regions.

When Edge-VNET is enabled, this configuration option is disabled by default.

4. Click Deploy Virtual Gateway to initiate the virtual gateway deployment.

https://docs.microsoft.com/en-us/azure/virtual-machines/linux/mac-create-ssh-keys
https://docs.microsoft.com/en-us/azure/virtual-machines/linux/mac-create-ssh-keys
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Figure 36 Creating a virtual gateway

The Virtual Gateway deployment can take approximately 15 minutes to complete.

Figure 37 Deploying the virtual gateway
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After the deployment is completed, Virtual Gateway Deployedmessage is displayed. A summary of the
deployment is also displayed on the List view of theOrchestrated Cloud Provider page. Hovering the
cursor over any of the columns displays additional information about the field.

Figure 38 Summary of deployed virtual gateways

The Virtual Gateway deployment can take approximately 15 minutes to complete.

Licensing Confirmation
Ensure that the license is valid, formore information, see Assigning Subscriptions to Aruba Gateways.

Verifying the Deployment Status
To verify the Virtual Gateway deployment status, complete the following checks:

n Check if the Virtual Gateway is on-boarded to the device inventory in Aruba Central .

n Ensure that the Virtual Gateway is assigned to a device configuration group in Aruba Central.

n Verify if the Virtual Gateway is connected to Aruba Central.

n Configure a VPN tunnel between a Branch Gateway and the Virtual Gateway.

n In theNetwork Operations app, set the filter to Global and navigate to Manage > Network Services >
Virtual Gateways. A summary of the deployment is displayed in the List view of theOrchestrated
Cloud Provider pagewith the following columns:

n Cloud Provider—Displays the name of the cloud provider.

n Account—Displays the account name configured during the Virtual Gateway account creation.

n Region—Displays the region where the Virtual Gateway is deployed.

n VGW Serial—Displays the serial number of the Virtual Gateway.

n VGW Public IP—Displays the public IP address of the Virtual Gateway.

n High Availability—Displays the status of theHigh Availability mode for the deployed Virtual
Gateway.

n Orchestration—Displays the orchestration status for the deployed Virtual Gateway.

n VM Status—Displays the VM status of the Virtual Gateway.

n VGW Status—Displays the status of the Virtual Gateway.

TheDevice Inventory page displays the devices that are in the inventory. Click the to access the
Account Home > Device Inventory.
After a successful deployment, the Virtual Gateway instances launch and connects to Aruba Central with the
latest image.

Deploying Aruba Virtual Gateway in Microsoft Azure (Unmanaged
Mode)
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Aruba Virtual Gateways can now be deployed in Microsoft Azure to create a secure SD-WAN overlay
between physical sites and private virtual networks (VNETs) hosted in public cloud environments. Aruba
Branch Gateways will establish tunnels to the Virtual Gateways both though the Internet as well as through
the ExpressRoute communications between the customer’s private network and Azure. This effectively
results in bringing Azure VNETs into the SD-WAN fabric, ensuring that workloads hosted therewill be easily
accessible frombranches as well as data centers.

An Azure VNET is a representation of your own network in the cloud. It is a logical isolation of the
Azure cloud dedicated to your subscription. Each VNET you create has its own CIDR block, and can be
linked to other VNETs and on-premises networks as long as the CIDR blocks do not overlap. For more
information on VNETs, see Azure documentation.

The following figure illustrates the communication flow between ArubaGateways, SD branch network, and
data centers:

Figure 39 Aruba Virtual Gateway in Azure VNET

Deployment Procedure
Before deploying Aruba Virtual Gateway deployment in Azure VNET, ensure that you have the following
resources and account privileges:

n A valid subscription and administrator credentials to access your Azure account.

n A valid subscription and Aruba Central account credentials to deploy Virtual Gateways.

n Aruba Virtual Gateway VHD image.

https://docs.microsoft.com/en-us/azure/expressroute/expressroute-introduction
https://docs.microsoft.com/en-us/azure/virtual-network/virtual-networks-overview
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You can configure and set up an Aruba Virtual Gateway in Microsoft Azure using either the Azure
Cloud Shell or the Azure graphical user interface (UI). The configuration steps described in this
document are based on the UI workflows.

Aruba supports deploying Virtual Gateways in the unmanagedmode. In the unmanagedmode, the
administrators deploy the Virtual Gateway instance in the Azure portal and then onboard it into Aruba
Central as a managed device.

To deploy the Virtual Gateways in the Azure VNET, complete the following steps:

1. Creating a Resource Group

2. Creating a Storage Account

3. Creating a VNET

4. Creating a Network Security Group

5. Creating Security Rules

6. Configuring Subnets

7. Creating Network Interfaces

8. Uploading the Aruba Virtual Gateway Software Image

9. Creating Image and Data Disk

10. Setting up a Virtual Machine

11. Creating SSH Key Pairs

12. Generating User Data in Aruba Central

13. Verifying theDeployment Status

Creating a Resource Group
A resource group in Azure is a logical container that consists of resources required for deploying a virtual
machine (VM). Resource groups allow you to logically group related resources such as storage accounts,
virtual networks, VMs, and also deploy andmanage these resources as a single entity.

Note the following important points about resource groups in Azure:

n A resource group can contain resources fromdifferent regions or locations.

n Access control for administrative actions can be scoped with a resource group.

n Resources can be added or removed from a group at any time.

n Resources can bemoved fromone group to another group.

n Each resource can only exist in one resource group.

n Resources can interact with other resources group containers.

To verify if your subscription has a resource group, click Home > Resource Groups.
If you do not have a resource group created in your Azure subscription, complete the following steps to
create a resource group:

1. Log in to Azure portal using your Azure account credentials.

2. Click + Create a Resource to access Dashboard and then search for Resource Groups in the search
box to access theResource Groups configuration page.
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3. Click Create.

4. In theBasics tab, enter the following information:

n Subscription—Select yourMicrosoft Azure subscription.

n Resource group name—Enter a name for the resource group.

n Region—Select the geographic location for the resource group.

5. Click Review+Create and then click Create.

Figure 40 Creating a Resource Group

Creating a Storage Account
Storage account in Azure provides a unique namespace to store and access your Azure storage objects.
Every storage account must belong to an Azure resource group.

For Aruba Virtual Gateway deployments, you will need a storage account to store the software image and
also a separate storage account for Boot Diagnostics. The Boot Diagnostics option allows you to view logs
pertaining to VM boot issues. You can enable the Boot Diagnostics option when configuring a VM.

If you do not have a storage account created andmapped to the resource group that you want to use for
Aruba Virtual Gateway deployment, complete the following steps:

1. Log in to your Azure account.

2. Select Home > Storage > Storage Accounts.

3. On the Storage Accounts window, click Add.

4. Choose a subscription that you want to map to the storage account.
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5. Enter theResource group name that will be associated with this storage account.

6. Enter a unique name for your storage account.

The name must be between 3 and 24 characters in length, and can include numbers and lowercase
letters.

7. Select a location for your storage account.

8. Ensure that the values for remaining fields are defined as shown in the following table:

Field Value

Performance Standard

Account kind StorageV2 (general-purpose v2).

NOTE: A general-purpose v2 storage account provides access to all of the Azure Storage
services, such as blobs, files, queues, tables, and disks.

Replication Geo-redundant storage (GRS)

Access tier Hot

Table 9: Storage Account Configuration Parameters

9. Click Review + Create and then click Create.

Figure 41 Review + Create the Storage Account

Creating a VNET
The Azure VNETs enable you to securely connect your Azure resources with each other. You can use VNETs
to provision andmanage VPNs in Azure and, optionally, link the VNets with other VNETs in Azure, or with
your on-premises IT infrastructure to create hybrid or cross-premises solutions.
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Deploying an Aruba Virtual Gateway in a customer VNET brings the SD-WAN fabric into the VNET and thus
enables connectivity to physical sites, such as branches and data centers.

Your VNETs are automatically deleted by Azure when a subscription is disabled. If the subscription is
re-enabled, youmust re-create the associated resources.

If you do not have a VNET created in your Azure subscription, complete the following steps to bring up the
VNET in Azure:

1. On the Azure portal, go to Home > Networking > Virtual Networks. You can also search for virtual
network on theHomepage to access theVirtual Network configuration page.

2. On theVirtual Network page, ensure that the selected deployment model is set as Resource
Manager, and click Create. TheCreate virtual network page opens.

3. Configure the following parameters:
n Name—Enter a name for the virtual network.

n Address space—Enter the allocated address space details.

n Subscription—Select a subscription.

n Resource group—Select the resource group to which you want to attach the VNET.

n Location—Select a valid location.

n Subnet—Enter the following information:
o Name—Nameof the subnet.
o Address range—Enter the address range for the subnet.

n DDoS Protection(Optional)—Select eitherBasic or Standard based on your subscription plan.

n Service endpoints(Optional)—Select eitherDisabled or Enabled based on your requirement. This
is set to Disabled by default.

n Firewall(Optional)—Select eitherDisabled or Enabled based on your requirement. This is set to
Disabled by default.

4. Click Create to complete the creation of the virtual network.



Aruba SD-WAN Solution | User Guide 117

Figure 42 Creating a VNET

Creating a Network Security Group
Using a network security group you can filter network traffic to and fromAzure resources in an Azure VNET.
A network security group ismade up of security rules that allow or deny inbound traffic to, or outbound
network traffic from, several types of Azure resources.

The number of network security groups that you can create for a VNET may vary based your location
and your subscription plan. For more information, see Microsoft Azure documentation.

To create a network security group, complete the following steps:

1. Go to Home > Networking > Network Security Group. You can also use the search box on the
Home page to access theNetwork Security Group configuration page.

2. On theNetwork security group page, ensure that the selected deployment model is set as
Resource Manager, and then click Create. TheCreate network security group page opens.
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3. Configure the following parameters:

n Name—Enter a name for the network security group.

n Subscription—Select a subscription.

n Resource group—Select the resource group to which you want to map the network security
group.

n Location—Select your Azure location.

4. Click Create.

Figure 43 Creating a Network Security Group

Creating Security Rules
Security rules allow you to filter inbound and outbound network traffic that traverses through a VNET.
When a network security group is created, several default rules are created. Default security rules cannot be
deleted, but can be overridden with rules of a higher priority.
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For Aruba Virtual Gateway deployment, you will need to create security rules to allow inbound traffic
through UDP port 4500 for incoming IPsec tunnels. Similarly if you want to allow SSH traffic into the
VPN Concentrator, you can create a rule to open port 22 for incoming traffic

To configure inbound security rules for the network security group associated with your VNET, complete the
following steps:

1. Select the network security group that you just created for your VNET.

2. In the Settings list, select Inbound security rules and then click +Add. TheAdd inbound security
rule pane opens.

3. Add a security rule for UDP port 4500 as described in the following table:

Setting Rule Parameters for UDP 4500

Source Any

Source port ranges *

Destination Any

Destination port ranges 4500

Protocol UDP

Action Allow

Name Port_4500

Description 4500 incoming

Table 10: Security Rules

Figure 44 illustrates the procedure for creating an inbound security rule for theUDP port 4500:

Figure 44 Adding Inbound Security Rules

Figure 45 shows the inbound security rules created for the network security group for the Aruba Virtual
Gateway deployment:
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Figure 45 Inbound Security Rules

Configuring Subnets
An Azure VNET requires a specific subnet called the gateway subnet. Gateway subnet is required for
configuring a virtual network gateway. Gateway subnet allocates a set of IP addresses that the virtual
network gateway resources and services can use.

Apart from configuring the gateway subnet, youmust also configure separate interconnection subnets for
all network interfaces of Aruba Virtual Gateway. The interconnection subnets allow Aruba Virtual Gateway
to connect to all relevant resources in a VNET.

The following procedures describe the steps for creating subnets:

n Configuring a Gateway Subnet for a VNET

n Configuring Subnets for Virtual Gateway Network Interfaces

Configuring a Gateway Subnet for a VNET

1. Go to Home > Networking > Virtual Networks.

2. Select the VNET that you want to configure.

3. In the Settings list, select Subnets.

4. In the Subnets window, click +Gateway subnet.

5. By default, the gateway subnet name is set asGatewaySubnet.

6. Update theAddress range (CIDR block) values to match your requirements.

7. Click OK.

Ensure that the gateway subnet is not associated to a network security group to avoid malfunctioning
of the VPN gateway.
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Figure 46 Configuring Gateway Subnet

Configuring Subnets for Virtual Gateway Network Interfaces

To allow Aruba Virtual Gateway to connect to all relevant resources in your VNET, separate interconnection
subnets should be created for all its network interfaces:

n Management

n INET

n VPN

n LAN

The following figure illustrates the subnet requirements for Virtual Gateway network interfaces:
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Figure 47 Aruba Gateway Network Interfaces

Aruba recommends that you create interconnection subnets from a CIDR block of /28 or /27. This
ensures that there are sufficient IP address for future requirements.

To configure subnets for the Virtual Gateway network interfaces:

1. Go to Home > Networking > Virtual Networks.

2. Select the VNET that you want to configure.

3. In the Settings list, select Subnets.

4. In the Subnets window, click +Subnet.

5. Configure the following parameters:

n Name—Enter a name that is uniquewithin the VNET.

n Address range (CIDR block)—Enter an IP address range that is uniquewithin the VNET address
space. This rangemust not overlap with any other subnet range in the VNET.

n Network security group—Select an existing network security group fromwithin the same
subscription and location as the VNET.

n Route table—Select an existing route table from the same subscription and location as the VNET.

n Service endpoints-Services—From the Services list, select the services that you want enable for
the network interfaces connected to the subnet.

n Subnet delegation-Delegate subnet to a service—Subnet delegation allows explicit
permissions to the service to create service-specific resources in the subnet using a unique identifier
when deploying a service. To delegate for a service, select a service from the Services list.

6. Click OK.

7. Ensure that you have created subnets for each of following network interfaces:
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a. Management

b. INET

c. VPN

d. LAN

Figure 48 Configuring Subnets



Deploying Aruba Virtual Gateways | 124

Figure 49 Subnets added to a VNET

Creating Network Interfaces
A network interface enables an Azure VM to communicatewith the Internet, Azure, and other on-premises
resources. A VM can have one ormore network interfaces.

Azure portal does not support attaching multiple interfaces to a VM using the GUI. Instead, you can
create additional NICs in the GUI and attach then to the VM using the CLI during the VM creation
phase.

For Aruba Virtual Gateway deployment, Aruba recommends that you create a separate network interface
for each traffic type andmap these to subnets in the following order:

n NIC1—Management traffic

n NIC2—Internet traffic– Requires a Public IP for connectivity to Aruba Central

n NIC3—VPN traffic

n NIC4—LAN traffic

Aruba Virtual Gateways use DPDK internally and that includes bridging/switching functionality.
However due to generic restrictions of cloud networks (ProxyARP and no direct L2 connectivity), NIC0
is used internally for management connectivity; for example, SSH or WEBUI and any configuration is
optional. Ensure that NIC1 is used for all data traffic to and from the Aruba Virtual Gateway; for
example, IPSec, SSH, andWEBUI.

1. To create network interfaces follow these steps:

a. In the Azure portal, click Home > +Create a Resource .

b. On theHome page, enter network interface in the search box to access theNetwork Interface page.

c. Click Create.

d. In theCreate network interface window, configure the following parameters:
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n Name—Enter a name for the interface; for example, NIC1.

n Virtual network—Select the VNET to which you want to add the interface.

n Subnet—Select the subnet that you want assign to the interface.

n Private IP address assignment—Based on your configuration requirements, select either
Dynamic or Static addressing.

n Network security group—Select the network security group to which you want to attach this
interface.

n Subscription—Select the subscription.

n Resource Group—Select the resource group to which you want to map the interface.

n Location—Select the geographic location of your VNET.

e. Click Create.

f. Repeat these steps to create additional network interfaces, for NIC2, NIC3, and NIC4.

Figure 50 Creating Network Interfaces

2. To enable IP forwarding for NIC2, NIC3, and NIC4, follow these steps:

a. In the Azure portal, go to Home > Resource groups.

b. Select the resource group associated to your VNET.
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c. From the list of network interfaces, select theNIC.

d. Under Settings, select IP configurations.

e. Configure the following parameters:

IP forwarding settings
IP forwarding—Set to Enabled.

Figure 51 Enabling IP forwarding

3. To add Public IP to iNeT, follow these steps:

a. Under Settings, select IP configurations.

b. Set IP forwarding to Enabled.

c. Click Save.

d. Click the listed ipconfig1.

e. In the newwindow, set the Public IP address as Enabled.

f. Click Save.

Uploading the Aruba Virtual Gateway Software Image
To use the Aruba Gateway software image as the source for an Azuremanaged virtual disk, youmust ensure
that the Aruba Virtual Gateway software image is uploaded to a blob container in your storage account.

Aruba supports Azure VNET deployments on Virtual Gateway appliances running ArubaOS SD-WAN 8.4.0.0-
1.0.5.0 or later software versions. To obtain access to a valid VHD image for Virtual Gateways, contact your
Aruba Sales Specialist.

To upload the .vhd file, complete the following steps:

1. Download and install theAzure Storage Explorer app. Formore information, see Azure Storage
Explorer.

2. Open Azure Storage Explorer.

3. Log in with your Azure account credentials.

4. In the Storage Explorer window, navigate to your storage account, and select Blob Container.

5. Right-click and chooseCreate Blob Container and enter a name of the blob container. Ensure that
the container name is in lowercase.

6. Press Enter to create the container.

https://azure.microsoft.com/en-us/features/storage-explorer/
https://azure.microsoft.com/en-us/features/storage-explorer/
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7. Select Upload on the container ribbon. TheUpload Files pop-up window opens.

8. Browse to your local directory and select the image to upload.

9. Select Page Blob as the blob type and ensure that theUpload .vhd/vhdx file as page blobs
(recommended) check box is selected.

10. In theUpload to folder (optional) field, enter a folder name. If no folder is chosen, the files are
uploaded directly under the container.

11. Click Upload.

12. Navigate to the container under your storage account and verify if the .vhd image is uploaded as a
page blob.

Figure 52 Uploading a VHD Image



Deploying Aruba Virtual Gateways | 128

Figure 53 View blobs in a container

Creating Image and Data Disk
For Virtual Gateway deployment, an Image and data disk are required. Follow these steps to create the
Image and data disk:

1. To create a an Image with ArubaOS software follow these steps:

a. Log in to your Azure account.

b. In the Azure portal click + Create a resource.

c. In theHome>New page, search for Image in the search box.

d. Enter theName, Subscription, Resource group, and Location in the new Image page.

e. Select Linux as theOS disk type.

f. In the Storage blob field, click Browse, to navigate to the Storage accounts page.

g. In the Storage accounts page, select the container that has the .vhd file.

h. In the container page, select the VHD file and click Select to add the file to the image.
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Figure 54 Creating an image

Figure 55 Selecting the .vhd file
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Figure 56 Adding the .vhd file

OS disk—This is created from the image. Azure creates the disk during the VM deployment from the
Image. The disk size is set to 4 GB.

Data disk—The secondary disk is the data disk. The capacity for the secondary disk should be double
the size of the RAM.

2. To create a data disk follow these steps:

a. In the Azure portal, select Home > Managed Disks.

b. Select Create managed disk.

c. Select the subscription associated with your storage account.

d. Select the resource groupmapped to your storage account.

e. Enter the following details to create the disk:

1. Disk name—Create a uniquely identifiable name for the disk.

2. Region—Select the region for the disk.

3. Availability zone—Select the availability zone that this disk will be accessible from.

4. Source type—Select the source type asNone.

5. Size—Set the size of the disk.

f. Click Review + Create to review your storage account settings and create the account.

g. Click Create.
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Figure 57 Creating a secondary disk

Setting up a Virtual Machine
Currently, Azure portal does not support creating VMs through theGUI. Use Azure Cloud Shell to create
VMs.

To create a VM:

1. In the Azure portal, navigate to Home > Virtual networks and select the VM from themenu.

2. On the toolbar at the top of the page, click the Cloud Shell icon to launch Cloud Shell.

Figure 58 Cloud Shell icon

3. Log in with your credentials.

4. Create a VM using the az vm create command.

5. Ensure that you enter appropriate values for resource group, OS-type, boot diagnostics storage
account, network interfaces and the VM size.
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The recommendedminimum configuration is with four CPUs and 14 GB of RAM (DSv2-series -
Standard_DS3_v2). Ensure that you select Standard_DS3_v2 as the VM size.

The name of the storage account created earlier, is to be entered in the --boot-diagnostics-storage
command.

The --nics command is used to bind the network interfaces that were created earlier to the Virtual
Machine.

The following command text shows the example values for all associated parameters of a VM:

az vm create \

--resource-group aruba-vgw-rg \

--location eastus \

--name aruba-vgw \

--image aruba-vgw-image-xxxxx \

--attach-data-disks aruba-vgw-data-disk \

--boot-diagnostics-storage aruba-vgw-bootstorage \

--size Standard_DS3_v2 \

--nics aruba-vgw-nic1-mgmt aruba-vgw-nic2-inet aruba-vgw-nic3-vpn aruba-vgw-

nic4-lan \

--admin-username vgw-user --ssh-key-value @key.pub \

--custom-data userdata.txt

A sample of the user data file name is: VG2003084499-UserData.txt

If the VM is up and running, try to access it using the SSH console (Home > Virtual Machines > Serial
Console>. To access the VM console using SSH, use <username>@<external-IP-address>.

Figure 59 Console Access to the VM

Creating SSH Key Pairs
To create an SSH key pair, complete the following steps:
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1. In the Azure portal, navigate to Home > Virtual networks and select the VM from themenu.

2. On the toolbar at the top of the page, launch Cloud Shell by clicking on the icon.

3. In the bash shell, use ssh-keygen to create an SSH key pair.

For example: ssh-keygen -t rsa -b 2048

4. The ssh-keygen command generates both public and private keys with the default name of id_rsa
in the ~/.ssh directory. The command returns the full path to the public key. This table lists the
information required to complete the SSH key generation process:

Setting Value

Enter file in which to save

the key

The location where you want to save the key to. For example, aruba-
vgw-1sshkey.

Enter passphrase Enter a passphrase, or leave the field empty if there is no passphrase
required.

Enter same passphrase again Confirm the passphrase.

Table 11: SSH Key Generation Requirements

1. Note the path to the location of the public key

2. Use the cat command along with the path to the location of the public key to display the key.

For example: cat AOS_aruba-vgw-1sshkey.pub

3. Save the output of this command.

Generating User Data in Aruba Central
To allow Aruba Central to manage a Virtual Gateway that is deployedmanually and directly in a customer's
VNET, generate the device identity for the device in Aruba Central.

Ensure that you allow at least 30 seconds between the time the prompt appears and you enter the
user data.

To generate device identity for the Virtual Gateway instance in an Azure VNET, complete the following steps:

1. In theNetwork Operations app, set the filter to Global.

2. Go to Manage > Network Services > Virtual Gateways, click theConfig icon. The configuration
page is displayed.

3. Click Unmanaged Virtual Gateway.

4. In theUnmanaged Virtual Gateway page , select the Virtual Gateway model. Click Create Device
Identity.

5. Click Yes to confirm identity creation. Aruba Central displays the download link for downloading user
data.

6. Click Yes to confirm identity creation. Aruba Central displays the newly created VGWwith the
following fields:
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a. Serial #—Displays the serial number of the Virtual Gateway.

b. MAC—Displays the sMAC address of the Virtual Gateway.

c. Model Number—Displays themodel number of the Virtual Gateway.

d. Device Identity—Displays the device identity of the Virtual Gateway.

e. Status—Displays the status as User Generated for the created device identity of the Virtual
Gateway.

7. Click the three vertical dots icon next to the Status to view theAccount Options.

8. Click Download txt. The user data includes the following information:

n Aruba Central URL

n Serial Number

n User name and password for the Virtual Gateway. Virtual Gateways use these credentials to connect
to the Activate and EST servers for EST enrollment

n MACAddress of Virtual Gateway

n Part Number of the Virtual Gateway instance

n Deployment mode

n Network interfaces configured on a Virtual Gateway

n Activate URL

Figure 60 Sample User data

9. Ensure that you enter the Aruba Central-generated user data in the VM serial console during the
initial boot of VM instance. This step is required to add Virtual Gateways as amanaged device in
Aruba Central.

It is recommend that the user data be viewed in Wordpad or Notepad++ to retain the formatting.
The downloaded user data values must be converted to a single command, with each value separated
by a semicolon.

Here is a sample of the user data command:

Azure user-data: central_url:internal-device.central.arubanetworks.com; serial_

no:VG1901101037; username:"VG1901101037,02:1A:1E:33:1A:1B,MC-VA,VGW";

password:1901101800226565487619011018002265630190; mac_address:02:1A:1E:33:1A:1B;
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part_number:MC-VA; mode:VGW; interfaces:eth0, eth1, eth2, eth3; eth3:LAN; eth2:VPN;

eth1:INET; eth0:LAN;

Verifying the Deployment Status
To verify the Virtual Gateway deployment status, complete the following steps:

n Check if the Virtual Gateway is onboarded to the device inventory in Aruba Central .

n Ensure that the Virtual Gateway is assigned to a device configuration group in Aruba Central.

n Verify if the Virtual Gateway is connected to Aruba Central.

n Configure a VPN tunnel between a Branch Gateway and the Virtual Gateway.

n To check the Virtual Gateway operational status and the VPN tunnel status follow these steps:

a. In theNetwork Operations app, use the filter to select the gateway

b. In theNetwork Operations app, set the filter to a group that contains at least one Branch
Gateway.

c. The dashboard context for a group is displayed.

d. UnderManage, click Devices > Gateways.

e. A list of gateways is displayed in the List view.

f. Click a gateway underDevice Name.

g. The dashboard context for the gateway device is displayed.

h. Go to Manage > Overview.

Formore information, see theGateway monitoring help topic in Aruba Central Help Center.

Deploying Aruba Virtual Gateways in VMware ESXi
(Unmanaged Mode)
Aruba Central supports deploying Virtual Gateways in VMware ESXi using the unmanagedmode. In the
unmanagedmode, IT administrators bring up and configure the Virtual Gateway instances in VMware ESXi
using the vSphere client 5.5 or above versions, andmonitor the deployed Virtual Gateways fromAruba
Central.

Deployment Procedure
Before deploying Aruba Virtual Gateway in VMware ESXi, ensure that you have the following resources and
account privileges:

n Administrator credentials to access VMware ESXi.

n vSphere Client/vCenter 5.5 or above is installed on aWindowsmachine.

n Aruba Central account and valid subscription to deploy Virtual Gateways.

n Download theOVA from the Aruba Support Portal. Formore information, contact your Aruba Sales
Specialist.

To deploy a Virtual Gateways in VMware ESXi using the unmanagedmode, complete the following steps:
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1. Generate the device identity data for the Virtual Gateway instance in Aruba Central in the ISO format.

2. Download the Virtual Gateway OVA image from the Aruba Support Portal. For example, theOVA
image name format is— ArubaOS_VGW_8.6.0.4-2.2.0.0_76431.ova.

3. Create the VM using Virtual Gateway OVA and device identity data.

4. Connect the Virtual Gateway to Aruba Central by either using zero-touch provisioning or one-touch
provisioning.

5. Verify the deployment status.

Virtual Gateway Sizing
The Aruba Virtual Gateway requires the use of a supported VMware ESXi instancewith aminimumof 500
Mbps of throughput and can support up to 1600 IPsec tunnels. This table lists out the supported VMware
ESXi instances for each ArubaModel/SKU:

Aruba Model/SKU
Name Throughput vCPU

RAM
Memory
(GB)

Flash
Memory (GB) Tunnels

VGW-500MB 500 Mbps 4 7 15 1600

VGW-2GB 2 Gbps 8 15 30 4096

VGW-4GB 4 Gbps 16 30 60 8192

If a higher number of tunnels are required, contact your Aruba Sales Specialist.

Generating User Data in Aruba Central
For Aruba Central to manage a Virtual Gateway that is deployedmanually and directly in a customer's VPC,
generate device identity for the device in Aruba Central.

To generate device identity for the Virtual Gateway instance, complete the following steps:

1. In theNetwork Operations app, set the filter to Global.

2. Go to Manage > Network Services > Virtual Gateways, click theConfig icon. The configuration
page is displayed.

3. Click Unmanaged.

4. Select the Virtual Gateway model.

5. Click Create Device Identity.

6. Click Yes to confirm identity creation. Aruba Central displays the newly created VGWwith the
following fields:

a. Serial #—Displays the serial number of the Virtual Gateway.

b. MAC—Displays theMAC address of the Virtual Gateway.

c. Model Number—Displays themodel number of the Virtual Gateway.

d. Device Identity—Displays the device identity of the Virtual Gateway.
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e. Status—Displays the status as User Generated for the created device identity of the Virtual
Gateway.

7. Click the three vertical dots icon next to the Status to view theAccount Options.

8. Click Download ISO. The ISO format of the user data file is downloaded.

9. Ensure that you load the Aruba Central-generated ISO file in the vSphere Client during the initial boot
of VM instance. This step is required to add Virtual Gateways as an unmanaged device in Aruba
Central.

Creating and Configuring Virtual Gateway
To create and configure the Virtual Gateway using the Virtual Gateway OVA and device identity data,
complete the following steps:

1. Deploy theOVF template.

2. Pre-allocatememory and CPU utilization.

3. Upload ISO File in to the ESXi Sever Datastore.

4. Assign Network Connection.

5. Enable Security Profile Configuration.

6. Configure Serial Console for the VM.

Deploying the OVF Template
To deploy theOVF template, complete the following steps:

Log in to the vSphere Client.

It is recommended to use vSphere Client version 5.5 and above. For more information about the
procedure, see VMware vSphere Documentation Center.

Click File > Deploy OVF Template.

1. TheDeploy OVF Template Wizard is displayed.

2. It is recommended to copy theOVF template to the client machine before importing theOVF
template.

3. Click Browse and navigate to the location of theOVA file and click Next.

4. TheOVF Template Details option in the left pane is displayed.

5. Click Next. TheName and Location option in the left pane is displayed.

6. In theName field, enter a name for theOVF template and click Next. TheDisk Format option in the
left pane is displayed.

7. Select Thick Provision Lazy Zeroed option and click Next. TheNetwork Mapping option in the
left pane is displayed.

8. Select VM Network_Management from theNetwork Label drop-down list and click Next. The
Ready to Complete option in the left pane is displayed.

Network Mapping
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Review your preferences before clicking Finish.

Ensure that the Power on after deployment check box is disabled in the Ready to Complete
window.

9. Click Finish. TheOVF template is deployed.

10. Click OK.

11. Click Close.

Pre-allocating Memory and CPU Utilization
To pre-allocatememory and CPU utilization, complete the following steps:

1. Right-click the VM and select Edit Settings or click Edit virtual machine settings from the
Getting Started tab.

2. From theResources tab, select Memory and configure theMemory Size as per the Virtual Gateway
sizing table.

3. Click OK.
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Figure 61 Editing Memory Setting

4. From theResources tab, configure theCPUs as per the Virtual Gateway sizing table.

5. Click OK.

Figure 62 Editing CPUs Setting
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Uploading ISO File in to the ESXi Sever Datastore
To upload the ISO in to the ESXi sever Datastore, complete the following steps:

1. Right-click the VM and select Edit Settings or click Edit virtual machine settings from the
Getting Started tab.

2. From theResources tab, select CD/DVD drive.

Ensure that the Connected and Connected at power on options under Device Status are enabled.

3. UnderDevice Type, select the radio button against Datastore ISO File and click Browse.

4. Navigate to the location where the Aruba Central-generated ISO file is stored, select the ISO file, and
click OK.

It is recommended to copy the Aruba Central-generated ISO file to the client machine before importing
it.

Figure 63 Uploading ISO File

Assigning Network Connection
To assign network connection, complete the following steps:
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By default, the same network connection is assigned to all network adapters. This requires to be
avoided as it will result in a network loop.

1. Click Edit virtual machine settings.

Figure 64 Virtual Machine Settings

2. Select Network adapter2 and select the preferred network label from theNetwork label drop-
down list. Ensure that your network connection is not shared across all the network adapters as
shown in the following figure.

The VM should have network connectivity with the outside world through the Network adapter 2 to
connect with Aruba Central.
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Figure 65 Assigning A Network

3. Click OK.

Enabling Security Profile Configuration
To enable security profile configuration, complete the following steps:

This is an optional step and should be used only if serial console redirection is required. To enable security profile
configuration you need to Telnet over the network.

1. Click the ESXi host IP address.

2. Click theConfiguration tab.

3. In the Software section, click Security Profile.

4. In the Firewall section, click Properties.

5. Scroll down to VM serial port connected over network and ensure that the check box is selected.

6. Click OK.

Connecting Virtual Gateway to Aruba Central
To connect the Virtual Gateway to Aruba Central, use one of the following provisioningmethods:

n Zero touch provisioning

n One touch provisioning

Zero Touch Provisioning
The Virtual Gateway connects to Aruba Central using Zero touch provisioning when there is a DHCP server
in the network. Theworkflow is as follows:
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1. The Virtual Gateway receives an IP address from theDHCP, triggers the EST enrollment, and connects
to Aruba Central.

2. Verify the deployment status of the Virtual Gateway in Aruba Central. Formore information, see
Verifying theDeployment Status.

One Touch Provisioning
To connect the Virtual Gateway to Aruba Central using One touch provisioning, complete the following
steps:

Ensure that there is no DHCP server in the network.

1. Boot the Virtual Gateway VMwith the Aruba Central-generated ISO image. The VMware console
displays the VM as a Virtual Gateway during the initial boot.

2. Select vgw-static from the initial provisioning wizard and provide the static IP address in the initial
network configuration.

3. The Virtual Gateway triggers the EST enrollment and connects to Aruba Central.

4. Verify the deployment status of the Virtual Gateway in Aruba Central. Formore information, see
Verifying theDeployment Status.

Verifying the Deployment Status
To verify the Virtual Gateway deployment status, complete the following steps:

n Check if the Virtual Gateway is onboarded to the device inventory in Aruba Central .

n Ensure that the Virtual Gateway is assigned to a device configuration group in Aruba Central.

n Verify if the Virtual Gateway is connected to Aruba Central.

n Configure a VPN tunnel between a Branch Gateway and the Virtual Gateway.

n To check the Virtual Gateway operational status and the VPN tunnel status follow these steps:

a. In theNetwork Operations app, use the filter to select the gateway

b. In theNetwork Operations app, set the filter to a group that contains at least one Branch
Gateway.

c. The dashboard context for a group is displayed.

d. UnderManage, click Devices > Gateways.

e. A list of gateways is displayed in the List view.

f. Click a gateway underDevice Name.

g. The dashboard context for the gateway device is displayed.

h. Go to Manage > Overview.

Formore information, see theGateway monitoring help topic in Aruba Central Help Center.

Provisioning Virtual Gateways to Groups
Virtual Gateways are the virtualized instance of Headend Gateways.

Before provisioning the Virtual Gateways, ensure that you assign Virtual Gateways to a VPNC group. For
more information see Assigning a Group Role to an ArubaGateway Group.
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For information on configuring VPN Concentrators, see Configuring an SD-Branch Network Using the
Advanced Setup.

Troubleshooting Deployment Issues
If you have configured a key pair for the VPC, you can log in to Virtual Gateway console through SSH for
verifying the deployment status.

Ensure that you open port 22 before accessing the console.

To log in to the console:

1. Open an SSH client.

2. Log in to console using the key pair and public IP address of the instance.

ssh -i "<key pair name>.pem" ec2-admin@<public IPv4 address>

3. Execute the following commands to verify the deployment status:

show ip interface brief

show ip route

show configuration effective | begin 0/0/0

4. To verify the status of EST enrollment, use the following commands:

show est profile vgw_est_srv

5. To verify the Aruba Central URL:

show aruba-central details

High Availability Support for Aruba Virtual Gateways
TheHigh Availability (HA) solution for Aruba Virtual Gateways (Virtual Gateway) works in an Active-Passive
paired configuration. In this setup there can be only one active Virtual Gateway which can forward data in
and out of the Virtual Private Cloud's (VPC) connected subnets.

The Virtual Gateway Orchestrator app decides which of the virtual gateways becomes Active or Passive and
communicates this decision to all the pivotal components.

The decision of setting the Active or Passive virtual gateway is based on the following requirements:

n Virtual machine health of each of the virtual gateways in a given HA-pair.

n The health of the Virtual Gateways control connectivity to the Central Overlay Router Orchestration
component.

n The connectivity of each of the virtual gateways to all the Branch Gateways (BGW).

TheOrchestration app decides the status based on the state of each virtual gateway. The app runs a poll
every 20 seconds on each virtual gateway for these criteria:

n VM Health: The VM health status is obtained from the cloud app (AWS, Microsoft Azure, VMware ESXi) for
each of the gateways in all the VPCs or VNETs across each of the regions of a given cloud account.

n Control Health: The control health status is provided by theOverlay RouteOrchestratormodule.



Aruba SD-WAN Solution | User Guide 145

n Data and Tunnel Health: The data and tunnel health status is provided by theOverlay RouteOrchestrator
module.

Definition of connected and disconnected:

n A pair of end-points are declared connected, if there is at least one tunnel that both sides (Virtual Gateway
and Branch Gateway) have declared as being connected.

n A pair of end-points are declared disconnected, if all the configured tunnels have at least one side being
declared as disconnected.

After the Orchestration appmarks one of the virtual gateways as Active, there maybe some branches
that lose connectivity (to the cloud), if they don't have at least one live tunnel connection to the chosen
(Active) Virtual Gateway.

Figure 66 Overview of High Availability Virtual Gateway

Configuration using Overlay Route Orchestrator/Overlay Tunnel
Orchestrator Service-Configuration

1. Create a pair of HA virtual gateways in a VPC.

2. Assign this HA-Pair to an exclusive "Managed Group" (consisting of only these two Virtual Gateway
paired devices) marked with a VPN concentrator persona.

3. Configure the chosen hub-group:

a. Configure all the connected subnets that are to be part of the chosen (hub) group's DC-Aggregate-
Routes: Hub-Group > VPN > DC Aggregate Routes >Add subnets andmasks to be advertised.

b. Disable theAllow branch-to-branch:. Use this option to disable branch to branch communication
through the virtual gateway.

4. Configure individual Virtual Gateway devices:
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a. configure theWAN interfaces: Ge-0/0/0 (INET GW) and Ge-0/0/1 (VPN GW) - typically on the vlan-
4094 interface.

b. configure the VPC-CIDR reachability through GE-0/0/2 (eth3 interface subnet) AWS or cloud router's
IP.

n Example:

n Virtual Gateway-Instance-0: AWS-router-IP: A.B.C.97

n Virtual Gateway-Instance-1: AWS-router-IP: A.B.C.225

A.B.C.0/24 is the reserved subnet chosen during the Virtual Gateway-Deployment phase.

5. Configure a given Branch Group's connectivity through Service Config:

a. ConfigureOverlay Orchestration: Branch-Group >VPN > Orchestrationmode: Orchestrated.

b. Configure DC connectivity: Branch-Group >VPN >DC Preference >Add the Virtual Gateway-Hub-
Group, choosing both the Virtual Gateway paired devices.

6. Youmay add this Virtual Gateway pair to one ormore Branch Groups.

Configuration triggered message distribution and collection
channels
Adding the Virtual Gateway pair to the Branch Group(s) initiates the addition of these Virtual Gateway pairs
into one ormoreMulticast/Distribution Groups in theOverlay RouteOrchestratormodules. There is one
distribution group for each of the Branch Groups. This is a vital operation that binds the relationship
between the Virtual Gateway Orchestrator app and theOverlay RouteOrchestratormodules for each of the
given Virtual Gateway device.

TheOverlay RouteOrchestrator creates a per-device based, unique topic to which the Virtual Gateway
Orchestrator can publish its selection results. The decisionsmade are relayed to all the relevant devices in
the distribution (all the branch-devices of all the interested Branch Groups).

The Virtual Gateway Orchestrator app communicates to theOverlay RouteOrchestrator. Themessage could
be either of the following:

n a HA-Selection Updatemessage

n a Deletemessage

A HA-Selection Update message can further indicate whether a Virtual Gateway device has become
Active or Passive. Changes to the Service-Config or Branch-to-Hub association will initiate a change in
the Topic list and in the corresponding distribution channels.

Logical Flow Chart
The steps listed here, outline the logic used:

1. Virtual Gateway Orchestrator decides which Virtual Gateway with will be set as Active or Passive
either if there is a service disruption or at initialization.

2. The Virtual Gateway Orchestrator runs a poll periodically and decides who the new Active or Passive
Virtual Gateway is based on the criteria listed here:
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a. VM health

b. Control health

c. Tunnel and Datapath health

If there is a change in the Active or Passive Virtual Gateway, theOrchestrator app updates the database.

3. The Active or Passive status decision is broadcast to the distribution lists and branch-groups of the
Branch Gateways.

4. After the Branch Gateway receives the update, it either de-activates or re-activates the concerned
Virtual Gateway (tunnel) in its DC/VPC prefix next-hop calculations for the Branch Gateway.

5. Amessage is sent to the updated Virtual Gateways, ensuring the that they are aware of the change
regarding the updated Active or Passive status.

Active or Passive Selection Truth-Table (Version 1)
In the current version, there is no user interactive option available to select the preferred Virtual Gateway.
The Virtual Gateway app has support to set the preferred Virtual Gateway using RestAPI. If both the Virtual
Gateways are of equal operational quality, then the preferred Virtual Gateway is chosen to be the Active of
the paired-Virtual Gateways.

In this table an "X" indicates that the value is of no consequence.
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As noted in the Truth table version 1, if one or both the Virtual Gateway's Overlay RouteOrchestrator state
changes, which in-turn results in equal quality of Overlay RouteOrchestrator connectivity, there is no
change to the Active device allocation.
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CREDIT-BASED HA Switchover
In the current setup there is no dampening in the Virtual Gateway HA logic, and this leads to theHA
triggering based on differences between a pair of Virtual Gateways, resulting in any event, such as adding or
deleting Branches resulting inmomentarily altering the connectivity count and triggering an unwanted HA
mode change.

The introduction of a CREDIT-BASED HA switchover solution dampens the switchover that may be caused
by the changes of tunnel connectivity.

CREDIT-BASED Logic for Tunnel Connections

Instead of using Hold-Off-Time switchover to monitor status of tunnel connections of Virtual Gateways, a
CREDIT-BASED logic reduces the number of unnecessary switchovers using THRESHOLD and STABLE_TIME_
ELAPSED.

VM health status: Hold-Off-time
GRPC/Control status: Hold-Off-Time
Tunnel connections: CREDIT-BASED Logic

How does CREDIT-BASED Logic work

When a new pair of Virtual Gateways is deployed, a credit is assigned to this pair of Virtual Gateways. The
credit calculation is listed here:

n The Active Virtual Gateway getsMAX_CREDIT. The default value is 60.

n The Passive Virtual Gateway getsMIN_CREDIT. The default value is 0.

n Adding the credit of the Passive Virtual Gateway with the credit of the Active Virtual Gateway gives us the
MAX_CREDIT.

Virtual Gateway app will keep incrementing or decrementing credit on a pair of Virtual Gateways based on
these situations:

n When a Passive Virtual Gateway hasmore tunnel connections than the Active Virtual Gateway:

nn the credit of Passive Virtual Gateway is incremented by one
n the credit of Active Virtual Gateway is decremented by one

n When a Passive Virtual Gateway hasmore tunnel connections than the Active Virtual Gateway:

nn theMAX_CREDIT is reset to the Active Virtual Gateway
n theMIN_CREDIT is reset to the Passive Virtual Gateway

Important Constants:

Sample or Snapshot interval = 20 seconds

MAX_CREDIT = 60

MIN_CREDIT = 0

DOWN_THRESHOLD = 1 (Default)

UP_THRESHOLD = 10 (Default)

Calculation:

STABLE_TIME_ELAPSED = ((MAX_CREDIT / 2) + 1) * 20 Seconds

# For example: ((60/ 2) + 1) * 20 Seconds = 10 Minutes #

NO_CHANGE_TIME = STABLE_TIME_ELAPSED * 10

# For example: 10 Minutes * 10 = 100 Minutes #
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Credit Based Active and Passive selection

Listed here are a few practical examples of Credit Based Active and Passive Virtual Gateway selection:

The Active Virtual Gateway is the preferred choice:

n The Active Virtual Gateway hasmore data tunnels connections (Active getsMAX_CREDIT, Passive getsMIN_
CREDIT)

n The Passive Virtual Gateway hasmore data tunnels connections but the Active Virtual Gateway is preferred
based on:

n Both Active and Passive Virtual Gateways tunnel connections are growing (Active getsMAX_CREDIT,
Passive getsMIN_CREDIT)

n Passive Virtual Gateway tunnel connections is decreasing (Active getsMAX_CREDIT, Passive getsMIN_
CREDIT)

The Passive Virtual Gateway is the preferred choice:

n Passive Virtual Gateway hasmore data tunnels connections:

n Active Virtual Gateway data tunnels connection is stable or is decreasing. The Passive Virtual Gateway
data tunnel connections are stable or is growing (Passive Virtual Gateway: credit + 1, Active Virtual
Gateway: credit - 1)

n HA switchover takes placewhen credit of the Passive Virtual Gateway ismore than the credit of
the Active Virtual Gateway (Passive Virtual Gateway credit > Active Virtual Gateway credit)

n Immediate HA switchover (HOLD-OFF) initiated if:

1. The credit of the Active Virtual Gateway data tunnel connections=0 (the Active Virtual Gateway
tunnel status is DISCONNECTED)

2. The status of the Active Virtual Gateway is decreasing and all of the following criteria aremet:

a. Passive Virtual Gateway is stable or growing

b. No crossover between Active Virtual Gateway and Passive Virtual Gateway, and no HA
switchover was triggered for an extended time period that is defined by: >=STABLE_
TIME_ELAPSED)

c. The Passive Virtual Gateway data tunnels - The Active Virtual Gateway data tunnels >=
DOWN_THRESHOLD

3. Active Virtual Gateway is slowly growing and all of the following criteria aremet:

a. The Passive Virtual Gateway is stable for enough time. The stable time is that is defined
by: stable time >= STABLE_TIME_ELAPSED)

b. The Passive Virtual Gateway data tunnels - The Active Virtual Gateway data tunnels >=
UP_THRESHOLD

The Passive Virtual Gateway equal to The Active Virtual Gateway:

n Immediate HA switchover occurs if the following criteria aremet:

a. If they are both equal and no statuses changes (VM health, Control health, Tunnel
health, and credit) for extended period time that is defined by: Current time - last time
updated on both two Virtual Gateways >= NO_CHANGE_TIME
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b. Passive Virtual Gateway is the preferred Virtual Gateway

Monitoring Virtual Gateways
To view the Virtual Gateway dashboard, complete the following steps:

1. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway.
The dashboard context for a group is displayed.

2. UnderManage, click Devices > Gateways.

3. A list of gateways is displayed in the List view.

4. Click a gateway underDevice Name.

5. The dashboard context for the gateway device is displayed.

6. UnderManage, Click Overview.

Formore information, see Configuring an SD-Branch Network Using the Advanced Setup.



Chapter 6
Configuring an SD-Branch Network

Using the Advanced Setup

Configuring an SD-Branch Network Using the Advanced Setup
This section guides you through the steps required to set up your SD-WAN network using the Advanced
Setup.

Before you proceed with the configuration tasks, browse through the recommendations and best
practices described in the Aruba SD-Branch Fundamentals Guide and Aruba SD-Branch Security
Hardening Guide.

Configuration Checklist
Table 12 describes the configuration workflow for the SD Branch devices:

VPN Concentrators Branch Gateways

n Configure Address Pools
n Configure Hostname and IP address
n Configure VLAN Interfaces
n Assign VLANs to Switchports
n Whitelist Branch Gateways
n Configure Static Routes
n Configure OSPF

n Configure Address Pools
n Configure Hostname and IP address
n Configure VLAN Interfaces
n Configure Ports
n Assign VLANs to Switchports
n Configure WAN Uplinks
n Configure Hub and Spoke VPN
n Configure Site to Site VPN
n Configure Dynamic Path Steering Policies
n Configure Policies for PBR
n Configure Firewall Policies
n Configure User Roles
n Configure Authentication Profiles
n Install CA and Server Certificates

Table 12: SD Branch Configuration Checklist

n

n

Configuring Address Pools for Aruba Gateways
In a branch site, the SD Branch requires a pool of IP addresses to allow dynamic assignment of IP addresses
to itself and its client devices.

The SD Branch deployment requires the following types of address pools:

n Gateway Pool—A gateway pool is used to assign a range of IP addresses for a device group. IP addresses
are assigned to each SD-WAN Gateway that joins this device group.

n DHCP pools—ADHCP pool for a configuration group defines a set of IP addresses that can be assigned to
client devices associated to Branch Gateways.

n NAT Pools—ANAT pool is used to translate the source IP address when forwarding port traffic or allowing
traffic from the outside network to the designated hosts in the branch network.
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n Tunnel Pools—A tunnel pool defines a range of IP addresses that can be used by the Branch Gateway to
create a GRE tunnel to the headend gateway. When you add a Branch Gateway, an IP address is removed
from the tunnel pool on the hierarchy node and is leased to the added device. Addresses those are no
longer in use are automatically returned to the pool for reallocation.

Tunnel pools and gateway pools can be configured only at the group level as they are not applicable to
the device level configuration.

Configuring Gateway Pools for Aruba Gateways
A gateway pool refers to a pool of IP addresses configured for a device group. The system IP addresses for
the SD-WAN Gateways are assigned from the gateway pool when a device joins the group.

Gateway pools can be configured only at the group level and is not applicable for the device level
configuration.

Creating Gateway Pools for Aruba Gateways

1. To create a gateway pool for a device group, complete either of the following steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Click Interface > Pool Management.

4. Expand Gateway Pool.

5. To create a new gateway pool, click +.

6. In the Pool name field, enter a name for the new pool.

7. In the Start IP address field, enter the first IP address of the IP address range.

8. In the End IP address field, enter the last IP address of the IP address range.

9. Click Save Settings. The gateway poolmust be assigned to a VLAN to allow Aruba Centraldynamic
assignment of IP addresses from the pool.

Assigning a VLAN to a Gateway Pool
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1. To assign a VLAN to a gateway pool complete either of the following steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Click Interfaces > VLANs.

4. Select a VLAN from theVLANs table.

5. Select the VLAN ID from theVLAN IDs table. The VLAN details are displayed.

6. From the IP assignment drop-down list, select Gateway pool.

7. Select the required gateway pool from theVLAN Pool drop-down list.

8. Save the changes. To enable IP address assignment to SD-WAN Gateways from the gateway pool, see
Configuring System Information on ArubaGateways on page 159.

Configuring DHCP Address Pools on Aruba Gateways
ADHCP pool is a set of IP addresses that can be assigned to the client devices associated to the Branch
Gateway of a specific branch. When the Aruba Gateway acts as theDHCP server, DHCP pools allow dynamic
and automatic assignment of IP addresses for VLAN interfaces.

Creating a DHCP Pool
To create a DHCP address pool on a Branch Gateway, complete the following steps:

1. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway.
The dashboard context for a group is displayed.

2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click theConfig icon.
The gateway group configuration page is displayed.

4. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

5. Click Interface > DHCP.

6. Select the IP DHCP server checkbox to enable the Aruba Gateway to act as a DHCP server.
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7. To add a new pool, click + below the Pool Configuration table.

8. Configure the following parameters:

Parameter Description

IP version Enter the IP version of the pool.

Pool Name Enter the name of the new address pool.

Network
IP address
type

Network address type. Select Static to add a static IP address and netmask to the pool, or select
Dynamic to define a range of addresses that the DHCP server may assign to clients.

n If you select Static, youmust enter the IP address and IP mask of the network in the
Network IP address and Network IP mask fields. Youmust also specify the IP address of
the default router for the DHCP client in the Default routers field. The client should be on
the same subnet as the default router. You can specify up to eight IP addresses.
n If you select Dynamic, youmust enter the starting and ending IP addresses for the
address range, as well as the maximum number of hosts to be supported by the pool.

Network IP
address

Enter the network IP address.

Network
IP mask

Enter the subnet mask for the network IP.

Default
routers

Enter multiple routers separating each one with a space.

Domain
Name

Enter the domain name to which the client belongs.

DNS Servers Configure the DNS server IP address by selecting one of the following options:
n Specify Servers—Select this option and specify the IP addresses of the DNS servers in
the DNS servers IP addresses field. You can specify up to eight IP addresses. Multiple IP
addresses must be separated by a space.
n Import from DHCP/PPPoE—Select this option to import DNS server address obtained
through PPPoE or DHCP.
n Use gateway address—Select this option to use the Aruba Gateway as the DNS server.

DNS servers
IP addresses

Enter multiple DNS server IP addresses separating each one with a space.

Enable PXE Use this to enable network boot on Preboot Execution Environment (PXE) capable Gateway
clients.
Configure the following parameters for PXE boot support:

n Server Name—Enter a hostname or the IP address of the server from which the Gateway
clients can download the boot file. Ensure that the hostname or IP address configured for
the boot server can be resolved by the PXE-enabled clients through a DNS server.
n Next Server—Enter a hostname or IP address of the next server from which the Gateway
clients can download the boot file.
n Boot File—Specify the boot file that the Gateway clients can use for network boots.

Import
WINS server
from
DHCP/PPPoE

Enable this to import the NetBIOS name server address that is obtained through PPPoE or
DHCP.

Table 13: DHCP Pool Configuration Parameters
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Parameter Description

WINS Provide the IP address of a NetBIOS Windows Internet Naming Service (WINS) server if you are
not importing the WINS address from DHCP or PPPoE. You can specify up to eight IP addresses.
Multiple IP addresses must be separated by a space.

This field is not applicable if you enable the Import WINS server from DHCP/PPPoE option.

Lease time Specify the number of days, hours, or minutes for which the assigned IP address is valid for the
client.

Pool type Select any of the following options:
n public—To assign addresses from a public pool.
n private—To assign addresses from a private pool.
n ipupsell—To assign either private or public address from a designated DHCP pool.

Option Click + Option to add a client-specific option code and IP address or text string.

Table 13: DHCP Pool Configuration Parameters

Excluding IP Address Range
To exclude an IP address or a range of IP addresses from theDHCP pool, complete the following steps:

1. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

2. Click Interfaces > DHCP.

3. Click + from the IP Excluded Address Range table.

4. Specify the IP address range in the IPv4 excluded range field.

5. Save the changes.

Reserving IP addresses
By default, Gateways dynamically lease IP addresses from aDHCP pool to their connected clients. As IP
addresses are randomly assigned to clients, the client devicesmay not acquire the same IP address every
time they request for a network connection.

If your site has client devices, such as printers and scanners, for which you want to assign a static IP address,
you can use IP reservation to manually bind IP addresses from aDHCP pool to a client MAC address. With IP
reservation, Gateways can assign the same IP address to a client whenever it requests for a network
connection.

To reserve an IP address from theDHCP pool, complete the following steps:

1. In theNetwork Operations app, use the filter to select a Gateway group or a Gateway.

2. UnderManage, click Devices > Gateways.

3. Click the configuration icon to display theGateway configuration page.
4. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

5. Click Interfaces > DHCP.

6. Click + from the IP reservations table.

7. Specify theClient Name,MAC Address, and the IP Address that you want to reserve.



Configuring an SD-Branch Network Using the Advanced Setup | 157

The table allows five entries by default. Click + to add another row. You can configure up to 64 clients.

1. Click Save Settings.

To delete a client, select the client in the IP reservations table and click the delete icon.

Configuring NAT Pools
ANAT pool provides a set of IP addresses that can be used for translating network addresses for the
outgoing traffic from the branch network.

Creating a NAT Pool

1. To create a NAT pool, complete either of the following steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Click Interfaces > Pool Management.

4. Expand NAT Pools.

5. To add a new pool, click + below theNAT Pools table.

6. In the Pool name field, enter a name for the new pool.

7. In the Start IP address field, enter the first IP address of IP address range.

8. In the End IP address field, enter the last IP address of the IP address range.

9. In theDestination NAT IP address field, enter the IP address to configure the destination NAT.

10. Select theUsed by VPN if this NAT pool is used by the VPN.

11. Click Save Settings.

Creating a Static 1:1 NAT
To create a static 1:1 NAT on a Branch Gateway, complete the following steps:

1. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway.
The dashboard context for a group is displayed.

2. UnderManage, click Devices > Gateways.
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3. A list of gateways is displayed in the List view.

4. Click a gateway underDevice Name.
The dashboard context for the gateway device is displayed.

5. UnderManage, Click Device.

6. The gateway configuration page is displayed.

7. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

1. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

2. Click Interfaces > Pool Management.

3. Expand Static 1:1 NAT and click + below theNAT mapping table to edit the settings.

4. In the INTERNAL ADDRESS field, enter the internal IP address of the device.

5. In the EXTERNAL ADDRESS field, enter the IP address to bemapped to the device; this IP address is
exposed outside of the network.

6. Click Save Settings.

Based on your branch requirements, you can enable NAT on VLAN interfaces for the traffic that is routed
through the tunnel. Formore information on enabling NAT for egress traffic, see Configuring VLANs on
ArubaGateways on page 176.

Configuring Tunnel Pools for Aruba Gateways
A tunnel pool defines a range of IP addresses that can be used by the Branch Gateways in a group to create
a GRE tunnel to the headend gateway. When you add a Branch Gateway to the group, an IP address is
removed from the tunnel pool on that hierarchy node and is leased to that device. Addresses no longer in
use are automatically returned to the pool for reallocation.

Tunnel pools can be configured only at the group level and is not applicable for the device level
configuration.

To create a tunnel pool on a Branch Gateway group, complete the following steps:

1. To configure a gateway group or gateway device, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.
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2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Click Interfaces > Pool Management.

4. Expand Tunnel Pools.

5. To add a new pool, click + below theAdd New Tunnel Pool table.

6. Configure the following parameters and click Save Settings.

Parameter Description

Pool Name Enter the name of the new tunnel pool.

Start IP address Enter the IP address to define the start of the range of addresses.

End IP address Enter the IP address to define the end of the range of addresses.

Table 14: DHCP Pool Configuration Parameters

Uploading Bulk Configuration Template
Aruba Central allows you to configure VLANs, ports, DHCP Pools, PPPoE credentials or IP addresses for SD-
WAN Gateways in bulk.

To upload a template for bulk configuration, complete the following steps:

1. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway.
The dashboard context for a group is displayed.

2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click a gateway underDevice Name.
The dashboard context for the gateway device is displayed.

4. UnderManage, Click Device.
The gateway configuration page is displayed.

5. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

6. Click Interface > Bulk configuration upload.

7. Click Download device template. A CSV file with a list of Aruba Gateways is downloaded to your
local directory.

8. Update the CSV file with configuration parameters for VLANs, DHCP pools, and IP address
assignment.

9. Upload the template and click Save Settings. The configuration changes are applied to the Aruba
Gateways in the group.

Configuring System Information on Aruba Gateways
This section describes the procedures for configuring systemparameters for Aruba Gateways. Click on the
links listed here formore information:
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n Configuring or Renaming Gateway Hostname

n Configuring System IP Address

n Setting SystemClock and Time Zone

n Configuring Domain Name System

n Configuring Dynamic Domain Name System

n Configuring Redirect DNS Servers

n Setting Capacity Threshold

Configuring or Renaming Gateway Hostname
You can create a hostname in AdvancedMode and canmodify a hostname in Basic and Advancedmodes.

To assign ormodify a gateway hostname, complete the following steps:

1. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway.
The dashboard context for a group is displayed.

2. UnderManage, click Devices > Gateways.

3. A list of gateways is displayed in the List view.

4. Click a gateway underDevice Name.
The dashboard context for the gateway device is displayed.

5. UnderManage, Click Device.

6. The gateway configuration page is displayed.

7. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

1. Click Basic Info.

2. Enter a hostname.

If a gateway hostname already exists, you canmodify the string. For offline gateways, the
change is reflected in Aruba Central after the gateway comes online.

3. If required, configure admin credentials.

4. Click Save Settings

Configuring System IP Address
The system IP configuration is required on each Gateway provisioned in Aruba Central. Each Gateway uses
one VLAN interface as its system IP address for communicating with network services such as RADIUS,
syslog, TACACS+, and SNMP.

You can assign a system IP address to Gateways using one of the followingmethods:

n Gateway pools—You can assign a VLAN interface from aGateway pool and allow Aruba Central to
automatically allocate a host address to a dedicated VLAN interface from the range of addresses configured
for the device group.

n Dynamic DHCP Pools—If you have a dynamic pool of addresses configured for the Branch Gateway group,
Aruba Central can automatically allocate a subnet to the LAN VLAN interface on a Branch Gateway.
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n Bulk configuration templates—You can assign a system IP address by using the Bulk configuration upload
feature. The Bulk configuration upload feature allows you to upload Gateway configuration parameters to
Aruba Central using a CSV file.

n Manual assignment of VLAN interfaces—If you want to configure a system IP address per device, you can
manually configure a static IP address for the VLAN interface.

If the system IP address is not assigned to Gateways, Aruba Central will not push configuration to
Gateways, which may lead to configuration discrepancies.
A system reboot is required when you change the system IP address of a Gateway.

To configure system IP address for Aruba Gateways, complete the following steps:

1. In theNetwork Operations app, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Click System > General.

4. Expand System IP Address.

n To configure system IP address for Gateways at the group-level, complete the following checks:

n To dynamically assign system IP addresses using a Gateway pool, ensure that a gateway address
pool is configured and assigned to a VLAN interface. Aruba Central dynamically assigns system IP
addresses from the gateway address pool to the devices when they join the group. Formore
information on gateway pools, see Assigning a VLAN to a Gateway Pool on page 153.

n To dynamically assign system IP address from a dynamic DHCP pool, ensure that a dynamic
DHCP pool is configured and assigned to a VLAN interface.

n To assign a system IP address at the device level, ensure that a VLAN interface is configured on the
devicewith a static IP.

5. From IPv4 drop-down, select a VLAN interface

6. Click Save Settings.

A preprovisioned gateway configured using complete setup does not consider the system IP
configured here.
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Configuring a Loopback Interface
The loopback IP address is a logical IP interface used for terminating VPN and GRE tunnels, originating
requests to RADIUS servers, and accepting administrative communications. You can configure the loopback
address as a host address for Gateways The loopback address is not bound to any specific interface and is
operational at all times. To use this interface, ensure that the IP address is reachable through one of the
VLAN interfaces.

If your deployment requires OSPF configuration, Aruba recommends that you configure a loopback
interface per VPN Concentrator and set the same as the OSPF router ID. For more information, see
Example of a Prefix List on page 235.

To configure a loopback interface:

1. In theNetwork Operations app, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Click System > General.

4. Expand Loopback Interface.

5. Enter an IPv4 address.

6. Click Save Settings.

Configuring Location Access
You can configure access to the gateway location by enabling GPS. You can view theGPS coordinates in the
Gateway Monitoring dashboard.

To configure location access:

1. In theNetwork Operations app, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.
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b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Click System > General.

4. Expand Location.

5. TheGPS checkbox is selected by default.

6. Click Save Settings.

Setting System Clock and Time Zone
You can set the clock on a Branch Gateway manually or by configuring the Aruba Gateways to use an NTP
server to synchronize its system clock with a central time source. The system automatically updates the time
zone including the relevant daylight savings time (DST) across time zones. This is done to keep the time up-
to-date and precisewith daylight savings time adjustments effected automatically.

Configuring NTP Server

The Burst Mode is a configurable option and not the default behavior for the Branch Gateway, as this
option is considered recommended by some public NTP servers. If an NTP server is unresponsive, the
Burst Mode continues to send frequent queries until the server responds and time synchronization
starts.

To add an NTP server:

1. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway.
The dashboard context for a group is displayed.

2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click theConfig icon.
The gateway group configuration page is displayed.

4. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

1. Click System > General.

2. Click Clock.

3. Select Get time from NTP server and click the + icon.
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4. Select IPv4 or IPv6.

5. Enter the IPv4 or IPv6 address of theNTP server based on your selection in the previous step.

6. Select theBurst mode check box, if required. It is disabled by default.

7. Enter the authentication key to be used by NTP server in theAuthentication key text box. The
range of allowed values is 1–65534.

Enabling NTP Authentication
NTP authentication allows NTP clients to authenticate before synchronizing clocks. NTP authentication
works by using a symmetric key that is configured by the user. The secret key is shared both by the SD-WAN
Gateway and an external NTP server. NTP authentication is disabled by default.

1. EnableUse NTP authentication.

2. Under NTP Authentication, click +. TheAdd NTP Authentication section is displayed.

3. Enter the authentication key in theAuthentication key text box. The allowed range of numeric
values is 1–65534.

4. Enter value for theMD5 secret. The valid key valuemust be an ASCII string from 0 to 255 characters.

5. Select the Trusted key check box to specify that the authentication key is trusted. By default, the
check box is cleared.

6. Click Save Settings.

Setting Time Zone
To set a time zone, complete the following steps:

1. Click System > General.

2. Click Clock.

3. In the Timezone section, select the appropriate time zone from the drop-down list.

4. Click Save Settings.

Setting the Clock to Summer Time
If your time zone supports Daylight Saving Time (DST) or summer time, you can enable DST to adjust the
clocks. DST refers to the practice of advancing clocks, so that evenings havemore daylight andmornings
have less. Typically clocks are adjusted forward one hour near the start of spring and are adjusted backward
in autumn.

1. Click System > General.

2. Click Clock.

3. Under Summer Time, using the toggle switch activateAdjust clock in summer.

4. Configured the desired time settings and click Save Settings.

Configuring Domain Name System
Network devices on the Internet use an IP address to route your request to the site you are trying to reach.
Once you connect through aDNS server, it manages a database that maps domain names to IP addresses
and routes your query to the next appropriate server.

To enable Aruba Gateways to connect to a DNS serve, complete the following steps:
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1. In theNetwork Operations app, select one of the following options:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Click System > General.

4. Click Domain Name System.

5. Enter a domain name.

6. Enable DNS name resolution.

7. To add aDNS Server, click + in theDNS Servers table.

8. Enter the IP address of the DNS server in the IPv4 Address field.

9. Select the VLAN from theVLAN ID drop-down list. This list displays all uplink VLANs except LTE
uplink VLAN. VLAN 4095 is not displayed in the list.

10. Click Save Settings.

Configuring Redirect DNS Servers
ArubaGateways can redirect DNS queries to dedicated DNS servers configured for the corporate and public
domains. You can use this feature to optimize the load on the corporate DNS servers by splitting and
redirecting non-corporate traffic to a separate DNS server configured on the Branch Gateway.

Before enabling DNS traffic redirection, ensure that the Branch Gateway is configured as a DNS
server. To configure Branch Gateway as the DNS server, go to Interfaces > DHCP > IP Pool and set
Gateway address as the DNS server.

To enable Branch Gateways to redirect DNS queries, and to configure name servers for specific domains,
complete the following steps:

1. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway.
The dashboard context for a group is displayed.

2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.
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3. Click theConfig icon.
The gateway group configuration page is displayed.

4. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

1. Click System > General.

2. Click Domain Name System.

3. Enable DNS name resolution.

4. Enable theRedirect DNS option.

5. To add domains, click + in theDomains to Redirect table.

6. Enter the following information in theNew Redirect DNS Server pop-up window:

n Domain—Enter the domain name.

n IP Version—Select the IP version.

n IP address—Enter the IP address of the DNS server to be redirected for the specified domain name.

You can configure up to three IPv4 and three IPv6redirect DNS servers.

7. Click Save Settings.

Configuring Dynamic Domain Name System
Dynamic DNS, also known as DDNS, solves the problemof ever changing IP addresses by associating your
address with a consistent domain namewithout the need for a static IP.

The dynamic IP addresses assigned through aDHCP server frequently change, as the ISPsmanage their own
online systems. Thismakes it difficult to access the Branch Gateway if the DHCP issued address continues
to changewithout notice.

The dynamic DNS feature assigns a customdomain name to your home IP address that updates
automatically whenever your home IP changes. A device on your network periodically communicates your
IP to the dynamic DNS service. The domain name resolution changes as your IP changes. Thus, even if your
IP changes, you can still connect to your device to the network using the same hostname.

To configure Aruba Gateways to connect to a dynamic DNS server, complete the following steps:

1. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway.

2. The dashboard context for a group is displayed.

3. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

4. Click a gateway underDevice Name.
The dashboard context for the gateway device is displayed.

5. UnderManage, click Device.
The gateway configuration page is displayed.

6. Click System > General.

7. Click System > General.

8. Click Dynamic Domain Name System.

9. Specify the Server interval and Server IP values.

10. Select one of the following values forAuthentication type:
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n hmac-md5
n hmac-sha1
n hmac-sha256

11. Enter appropriate values in Authentication name and Authentication key for the specified
authentication type.

12. Add the required DHCP pools from the available list.

13. Save the changes.

Configuring Dynamic Domain Name System (HTTPS)
A dynamic DNS keeps theDomain Name System (DNS) records up-to-date automatically when an IP
address changes. The branch gateway receives the IP address from the specifiedWAN interface and
communicates to theDDNS service provider via an HTTPS connection to maintain the confidentiality of the
information over the internet.

To enable Aruba Gateways to connect to a dynamic DNS server over an HTTPS connection, complete the
following steps:

1. In theNetwork Operations app, select one of the following options:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Click System > General.

4. Expand Dynamic Domain Name System (HTTPS).

5. To create a Dynamic DNS Server, click + in theDDNS Servers table.

6. Select one of the following DDNS service providers from the Provider name drop-down list:

n DynDNS
n Noip
n ChangeIP

7. Enter the host name of the gateway in theHostname & domain ( FQDN ) field.

8. Enter the user name in theUsername field.

9. Enter the password and retype the password in the respective fields.



Aruba SD-WAN Solution | User Guide 168

10. Select the uplink VLAN from theWAN Interface VLAN drop-down list.

11. Click Save Settings.

Setting Capacity Threshold
You can set capacity thresholds for Gateways to trigger alerts when they exceed the set percentage of the
total capacity configured for its resources.

1. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway.
The dashboard context for a group is displayed.

2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click theConfig icon.
The gateway group configuration page is displayed.

4. From the group selection filter bar, select the Aruba Gateway that you want to configure.

5. Click System > General.

6. Click Capacity Threshold. Configure the threshold parameters listed in the following table as per
your requirement.

Category Description

Datapath
CPU

Sets an alert threshold for datapath CPU capacity. When the total datapath CPU capacity
exceeds the configured threshold percentage, an alert is triggered. The default threshold for this
parameter is 30%.

Controlpath
CPU

Sets an alert threshold for controlpath CPU capacity. When the total controlpath CPU capacity
exceeds the configured threshold percentage, an alert is triggered. The default threshold for this
parameter is 45%.

Controlpath
memory

Sets an alert threshold for controlpath memory consumption. When total memory capacity
exceeds the configured threshold percentage, an alert is triggered. The default threshold for this
parameter is 85%.

Total
tunnels

Sets an alert threshold for the tunnel capacity. When the total tunnel capacity of the device
exceeds the configured threshold percentage, an alert is triggered. The default threshold for this
parameter is 80%.

Total users Sets an alert threshold for the user capacity. When the total resource capacity of the device
exceeds the configured threshold percentage, an alert is triggered. The default threshold for this
parameter is 80%.

Table 15: Capacity Alert Thresholds

Configuring Device Administrator Credentials for Aruba Gateways
TheGateway administrator or amanagement user referred in this topic denotes a user who can access the
device user interface for troubleshooting purposes. We need to configure credentials for these
administrators to access the Aruba Gateway user interface for troubleshooting device specific issues. The
Aruba Central system administrators or other Aruba Central systemusers need not be themanagement
users of the Gateway device user interface or console.

See the sections below formore information:
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n Creating a NewUser with Certificate Authentication

n Configuring Servers forManagement User Authentication

n Configuring Servers forManagement User Authentication

The management user of Aruba Gateways have restricted to access and troubleshoot only the device
related issues through the device user interface. Any other tasks such as configuration, management,
or device upgrade for a Gateways can be performed only from the Aruba Central UI.

Configuring Management User Accounts for Aruba Gateways
To create amanagement user account, complete the following steps:

1. To configure a Branch Gateway group or Branch Gateway, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. Click System > Admin.

3. UnderManagement User, enable the Enable local authentication toggle switch.

4. Click + from theManagement User table.

5. Enter values forUsername and Password.

6. Select a role from the drop-down list.

7. Click Save Settings.

Creating a New User with Certificate Authentication

This section describes the steps to create a new user with certificate authentication:

1. To configure a Branch Gateway group or Branch Gateway, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.
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n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. Click System > Admin > Management User.

3. Click Show users with certificate authentication.

4. Click + in theManagement Users with Certificate Authentication table.

5. In theManagement Users with Certificate Authentication > New User section, complete the
following steps:

a. Select one of the following options from the Interface to connect drop box:

n WebUI—Select this option to enable only theWebUI authentication and configure
Username, Role, Trusted CA certificate name, and Client certificate serial
number.

n CLI through SSH—Select this option to enable only CLI through SSH and
configureUsername, Role, Client Certificate, and Revocation checkpoint.

n WebUI & CLI through SSH—Select this option to enable bothWebUI
authentication and CLI through SSH and configure all the required parameters.

The default username and password to login to the device using the CLI or
user interface are admin and admins respectively.

6. Click Save Settings.

Enabling Console Block

To enable console block:

1. To configure a Branch Gateway group or Branch Gateway, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.
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d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. Click System > Admin.

3. UnderManagement User, select Enable console block. Disabling this option locks down all
console ports such asmicro USB andmini USB on theGateways to enable high level security.

4. Click Save Settings.

Configuring Management User Authentication Options
TheGateway supports client certificate authentication for users accessing the user interface. (The default is
for username and password authentication.) You can use client certificate authentication only or client
certificate authentication with username and password (if certificate authentication fails, the user can log in
with a configured username and password).

1. In theNetwork Management app, use the filter bar to select a Gateway group or Gateway.

2. UnderManage, click Device(s) > Gateway(s).

3. Click the settings icon to display theGateway configuration page.
4. Click System > Admin > Admin Authentication Options and complete the following steps:

a. Select a default role.

b. Select Enable.

c. Select MSCHAPv2, if it is the desired authenticationmethod.

d. Select a server group.

e. Select Management telnet access to enablemanagement access through Telnet.

5. Click Save Settings.

Configuring WebUI Authentication

To configure theWebUI authentication formanagement users, complete the following steps:

1. To configure a Branch Gateway group or Branch Gateway complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.
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d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. Click System > Admin > Admin Authentication Options.

3. UnderWebUI Authentication, make the following changes:

a. Select Username/password if you do not want to use certificate authentication for
WebUI management.

b. Select Webui HTTPS port (443) access.

c. Select Client certificate to use certificate authentication forWebUI management.

d. Select the server certificate to be used for this service.

e. Enter a value for Idle session timeout inminutes or seconds.

f. Enter a value for re-authentication timeout inminutes or seconds.

4. Click Save Settings.

Configuring SSH Authentication for CLI Access

ArubaGateways support public key authentication of users who access the device using SSH. (The default is
for username and password authentication).

1. To configure a Branch Gateway group or Branch Gateway, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

Enabling Ciphers and MAC Algorithms

You can configure SSH to enable or disable the following ciphers andMAC algorithms based on your
preference:

n AES-CBC

n AES-CTR

n HMAC-SHA1

n MAC-SHA1-96
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By default, all the algorithms are enabled. However, the Gateway allows you to enable or disable a specific
cipher or theHMAC-SHA1-96 authentication algorithmusing theWebUI.

To enable or disable a cipher encryption, complete the following steps:

1. To configure a Branch Gateway group or Branch Gateway, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. Click System > Admin > Admin Authentication Options.

3. Under SSH (Secure Shell) Authentication Method, select AES-CBC,AES-CTR, orBoth as the
encryption option.

4. Click Save Settings.

To enable or disable HMAC-SHA1-96 authentication:

1. To configure a Branch Gateway group or Branch Gateway, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

Configuring Servers for Management User Authentication

You can use an external authentication server or the internal user database of Gateways to authenticate
management users.
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Formore information on configuring authentication servers and server groups, refer to the following topics:

n Configuring RADIUS Authentication Server on ArubaGateways on page 307

n Configuring Other External Authentication Servers on ArubaGateways on page 309

n Configuring Server Groups on page 315

Configuring Servers for Management User Authentication
You can use an external authentication server or the internal user database of Gateways to authenticate
management users.

Formore information on configuring authentication servers and server groups, refer to the following topics:

n Configuring RADIUS Authentication Server on ArubaGateways on page 307

n Configuring Other External Authentication Servers on ArubaGateways on page 309

n Configuring Server Groups on page 315

Configuring Switching Parameters
To avoid bridge loops between network nodes and to maintain a single active path between the network
nodes, youmay want to enable Spanning Tree for the VLANs.

To enable Spanning Tree and other switching parameters on Branch Gateways, complete the following
steps:

1. To configure a Branch Gateway group or a Branch Gateway, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Click System > Switching.

4. Expand Spanning Tree and configure the parameters described in the following table:
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Code Description

Spanning
Tree

Enable Spanning Tree.

Mode Select one of the following Spanning Tree modes:
n Rapid— RSTP takes advantage of point-to-point links and provides rapid convergence of the
Spanning Tree. RSTP is enabled by default on all Branch Gateway devices. RSTP provides rapid
convergence when interfaces are configured as either edge ports or point-to-point links.
n Rapid-PVST—Rapid-PVST provides load-balancing of VLANs across multiple ports, resulting
in optimal usage of network resources. Rapid-PVST also ensures interoperability with industry-
accepted Rapid-PVST protocols. Rapid-PVST is disabled by default.

Forward
Time

Specify the number of seconds that the port must spend in listening and learning states before
forwarding packets. The value must be within a range of 4–30.

Hello
Time

Specify a keep alive interval for BPDU within a range of 1-10.

Max Age Specify a waiting interval in seconds for the root bridge to receive a hello packet before changing
the STP topology. This allows the protocol to determine if a port is currently unusable for
forwarding. The value must be within a range of 6-40.

Priority Specify a value for priority to determine if a bridge must act as a root. The priority value must be
within a range of 0-65536, with 0 being the highest priority.

LACP Specify a value for Priority. When the LACP priority is configured, the LACP data units exchange
their corresponding system identifier or priority along with their port key or priority. This
information determines the LAG of a port. The LAG for a port is selected based on its keys. The port
is placed in that LAG only when its system ID or key and system ID or key of its partner matches the
other ports in the LAG (if the group has ports).
LACP is disabled by default.

Table 16: Switching Parameters

Configuring AMON Receivers for Aruba Gateways
You can configure Gateways to send ArubaMonitoring (AMON) feeds to the Aruba ALE server or Aruba
IntroSpect for data processing and analytics. When configured, Gateways constantly feed the receivers with
the real-time application data and firewall logs.

To configure the AMON receivers on Gateways, complete the following steps:

1. To configure a Branch Gateway group or Branch Gateway, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.
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c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. Click System > Aruba Monitoring (AMON).

3. Click + to add a new AMON destination.

4. Select one of the following AMON receivers from the Type drop-down.
n ALE—To send AMON feeds to the ALE server.

n IntroSpect—To send AMON feeds to a server on which the Aruba IntroSpect Analyzer application is
installed.

5. Enter the IP address of the AMON receiver.

6. Click Save Settings.

For AMON data logging, ensure that the Deep Packet Inspection and Firewall Visibility features
are enabled on Gateways.

Configuring VLANs on Aruba Gateways
As a layer 2 switch, the Branch Gateway requires an external router to route traffic between VLANs. The
Branch Gateway can also operate as a layer 3 switch that can route traffic between VLANs.

You can configure one ormore physical ports on the Branch Gateway to be amember of a VLAN.
Additionally, each wireless client association constitutes a connection to a virtual port on the Branch
Gateway, withmembership in a specified VLAN. You can place all authenticated wireless users into a single
VLAN or into different VLANs, depending on your network requirements. You can also configure an IP
address and netmask for a VLAN. The IP address is up when at least one physical port in the VLAN is up. The
VLAN IP address can be used as a gateway by external devices; packets that are not destined for the Branch
Gateway and directed to a VLAN IP address are forwarded according to the Branch Gateway’s IP routing
table.

For the SD-WAN deployment, each Branch Gateway requires VLAN interfaces forWAN uplinks and LANs.
Each VLANmust have a unique VLAN ID assigned to it. By default, the Branch Gateways are pre-configured
with the VLAN 4094.

See the following topics for instructions on configuring VLANs:

n Adding VLANs for Aruba Gateways

n Configuring VLANs forWAN Interfaces

n Configuring VLANs for LAN Interfaces

n Configuring Other Parameters for VLAN

Adding VLANs for Aruba Gateways
Complete the following tasks to add VLANs to the Aruba Gateway and configure the VLAN parameters:
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1. To configure Gateway group or Gateway, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Click Interface > VLANs.

4. Click + from theVLANs table to add a new VLAN interface.

5. In theNew VLAN window, specify the following parameters and save the changes:
n VLAN name
n VLAN ID/Range

Configuring VLANs for WAN Interfaces
To configure VLAN forWAN interfaces on a Branch Gateway or a VPN Concentrator, complete the following
steps:

1. To configure a gateway group or a gateway device, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.
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3. Click Interface> VLANs.

4. Select a VLAN from theVLANs table.

5. Select theWAN-facing VLAN ID from theVLAN IDs table.

6. Under the IPv4 tab configure the following parameters:

a. Select the Enable routing option.

b. Select one of the following options from the IP assignment drop-down list.
n Static

n DHCP
n PPPOE

a. Select theNAT outside check box to enable NAT only for the outbound traffic on public-facing
egress VLAN interfaces. When this feature is enabled on an uplink VLAN interface, the source
address is translated with the IP address of the VLAN interface to all the outbound traffic.
Ensure that theNAT pool is configured for sourceNAT IP allocation. Formore information see,
Configuring NAT Pools on page 157.

7. Save the changes.

Configuring VLANs for LAN Interfaces
To configure VLAN for LAN interfaces on a Branch Gateway, complete the following steps:

1. To configure a gateway group or a gateway device, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Click Interface> VLANs.

4. Select a VLAN from theVLANs table.

5. Select theWAN-facing VLAN ID from theVLAN IDs table.
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6. Under the IPv4 tab configure the following parameters:

a. Select the Enable routing option.

b. Select Static from the IP assignment drop-down list. If you configure the VLANs at the group level,
you can also chooseDynamic DHCP Pool. This option is not applicable for device level configuration.

c. EnableRelay to external option.

d. Add the IP address of the RADIUS server to which you want to relay theDHCP requests in the
DHCP helper table.

e. UnderOther option, ensure to apply a AAA profile to the VLAN from the AAA Profile drop-down list.
Alternately, you can assign a AAA profile to the VLAN interface from theApply Policies tab under
Gateway Management > Security. Formore information, see Assigning AAA profile to VLAN
Interfaces for Role Assignment on page 334.

7. Save the changes.

Configuring Other Parameters for VLAN
Complete the following tasks to configure the VLAN parameters:

1. To configure Gateway group or Gateway, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Click Interface > VLANs.

4. To configure the parameters for a VLAN ID, select the required VLAN from theVLANs table. The
VLAN IDs table is displayed.

5. From theVLAN IDs table, select a VLAN that you want to configure. The VLAN details are displayed
in the following tabs:

n IPv4
n Port Members
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6. To add ormodify the port members associated to a VLAN ID, complete the following tasks:

a. Select the Port Members tab.

b. Click Edit. TheAvailable/Selected Ports window is displayed.

c. Select the required ports from the list of available ports and click OK.

7. Select the IPv4 tab to configure the other VLAN parameters as described in Table 17 based on your
network requirements.

8. Save the changes.

Parameter Description

IP Assignment

Enable routing Enable this option to route traffic between the VLANs that are mapped to the IP subnetworks.

IP assignment Select one of the following IP assignment types for the Aruba Gateways to select the system
IP address:

n Static—Specify an IP address in the IPv4 address field. You can also optionally enable
the following DHCP settings:
lAct as DHCP server—Enables the device to act as a DHCP server with the specified
Network, Netmask, Pool name, Default router, DNS servers, and Netbios name
server configurations.
lRelay to external—Relays the DHCP requests for the interface to the external DHCP
servers configured in the DHCP helpers table. You need not configure this parameter if
the VLAN interface is in the same subnetwork as that of the DHCP server.

n DHCP—Specify the Client ID for the DHCP client.
n PPPoE—Configure the PPPoE server credentials in the Service name, User name,
Password, and Retype password fields. To configure CHAP secret, enable Configure
CHAP Secret and enter CHAP secret key. Based on the request from the PPPoE server,
either the PAP or the CHAP credentials are used for authentication. When you enable
CHAP authentication on VLAN  interface, the interface and its peer use the CHAP secret
key for mutual authentication.
n Dynamic DHCP Pool—Select a DHCP pool from the Dynamic DHCP pool drop-down
list. You can also optionally enable the Relay to external setting to relay the DHCP
requests for the interface to the external DHCP servers. You can add the DHCP server
IP addresses in the DHCP helpers table. You need not configure this parameter if the
VLAN interface is in the same subnetwork as that of the DHCP server.
n Gateway Pool—Select the required gateway pool from the VLAN pool drop-down list.

NOTE: Dynamic DHCP Pool and Gateway Pool options are applicable only for group level
configurations and not for device level configuration.

MTU Provide the MTU setting for the VLAN. The allowed range is 1280-1500. The default value is
1500.

Suppress ARP Select this option to prevent flooding of ARP broadcasts on all the untrusted interfaces. By
default, this is disabled.

NOTE: This option is not applicable if you selected DHCP or PPPoE as the IP assignment
option.

Table 17: VLAN IPv4 Tab Parameters
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Parameter Description

VLAN status Select this option to enable the operational state of the VLAN ID. By default, this is disabled.
Enabling this option keeps the state of the VLAN interface as up irrespective of the state of
the physical interface.

NAT inside Select this option to perform NAT with the desired IP address of the VLAN interface as the
source address.

NAT outside Select this option to enable NAT only for the outbound traffic on public-facing egress VLAN
interfaces. When this feature is enabled on an uplink VLAN interface, the source address is
translated with the IP address of the VLAN interface to all the outbound traffic. Ensure that
the NAT pool is configured for source NAT IP allocation. For more information see,
Configuring NAT Pools on page 157.

Admin state Select this option to enable the admin state of the VLAN interface.

Other Option

Description A text string to describe the VLAN interface.

Local-proxy
ARP

Select this option to activate the local proxy ARP feature on the interface.

Broadcast
multicast
optimisation

Select this option to enable controlled flooding of broadcast or multicast traffic without
compromising the client connectivity.

Bandwidth
contract

Select the bandwidth contract policy to be applied to the VLAN interface. The selected
contract policy limits both broadcast andmulticast traffic on the interface.

Enable OSPF Select this to enable OSPF protocol on the interface and configure the following
OSPF parameters:

n Area network (eg. 0.0.0.0)
n Authentication
n Password
n Retype password
n Cost [1-65535]
n Dead interval [1-65535]
n Hello interval [1-65535]
n Priority [0-255]
n Retransmit interval [1-65535]
n Transmit delay [1-65535]

AAA profile Select a AAA profile to be applied to the VLAN interface. Alternately, you can assign AAA
profiles to the VLAN interfaces from the Apply Policies tab under Gateway Management >
Security. For more information, see Assigning AAA profile to VLAN Interfaces for Role
Assignment on page 334.

ACL Select a routing policy to be applied to the VLAN interface. Alternately, you can assign
routing policies to the VLAN interfaces from the Apply Policies tab under Gateway
Management > Security. For more information, see Applying Route ACLs for VLAN
Interfaces on page 333.

Configuring SLB using NAT
Server Load Balancing (SLB) is a key feature in today's network deployments. It improves scalability of
servers with increasing session loads. Aruba uses NAT to offer Load Balancing feature, where session load
can be distributed across a pool of servers, instead of directing to a single server. NAT also enhances security
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by hiding the real IP address of the source and providesmore flexibility to move source across IP pools. You
can also configure health-check parameters to keep a tab on the performance.

Configuring Health-Check Profile
To configure a health-check profile, complete the following steps:

1. Configure health-check profile for a Branch Gateway or a Branch Gateway group:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Click Interface > SLB.

4. Click + in theHealth-check configuration table. TheCreate Health-check table is displayed.

5. Provide the following details in the Create Health-Check table:

a.  Enter a Profile name.

b. Frequency (secs)—Indicates how often the Branch Gateway checks to see if the server is up and
running. Default: 5 seconds.

c. Timeout (secs)—Indicates the number of seconds the Branch Gateway waits for a response to its
health check query beforemarking the health check as failed. Default: 2 seconds.

d. Retry count—Is the number of failed health checks after which themanaged devicemarks the server
as being down. Default: 2.

6. Click Save Settings to add the new health check profile.

Configuring an SLB Server Group
To configure a server group, perform the following task:

1. Configure SLB server group on a Branch Gateway or a Branch Gateway group:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.
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b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Click Interface > SLB.

4. Click + in the Server groups table. TheCreate Server Group table is displayed.

5. Provide the following details in theCreate Server Group table:

a. Enter aGroup name.

b. In theHealth-check profile drop-down list, select a health check profile.

6. Click Save Settings.

Configuring an SLB Server
To configure a server, perform the following task:

1. Configure SLB server for a Branch Gateway or a Branch Gateway group:

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Click Interface > SLB.

4. Click + in the Servers table. TheCreate Server table is displayed.

5. Provide the following details in theCreate Server table:

a. Enter a Server name.

b. Server group—Use the drop-down list to assign this server to a group from the existing configured
groups.

c. Server mode—Use the drop-down list to choose themode (bridge, nat, or route)as per your network
requirement.
n For bridge mode, enter the Trusted Port number (the port connected to the trusted side of the SLB

server) and theUntrusted Port number (the port connected to the untrusted side of the SLB server).

n Fornat mode, enter the Trusted IP Address (the trusted interface on the SLB server) and theNAT
Destination Port number (the port to which a packet is redirected to rather than the original
destination port in the packet). You can enableHealth-Check on the trusted IP address interface.

n For route mode, enter the Trusted IP Address (the IP address of the trusted interface on the SLB
server device) and theUntrusted IP Address (the IP address of the untrusted interface on the SLB
server device). You can enableHealth-Check on either or both of these interfaces.
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6. Click Save Settings.

Configuring Ports
Physical ports on the Branch Gateways are trusted and are usually connected to internal networks by
default. The untrusted ports connect to third-party APs, public areas, or other networks. When you define a
physical port as untrusted, the traffic passing through that port needs to go through a predefined ACL
policy.

Ports can also be classified as trusted or untrusted based on the VLAN interface associations. For example,
traffic on the port is trusted only if the VLAN interface associated to that port is trusted. When a port and its
associated VLANs are untrusted, any incoming and outgoing traffic must pass through a predefined ACL.
For example, you can configure an Ethernet port as an untrusted access port; assign VLANs and classify
them as untrusted; and designate a policy through which VLAN traffic on this port must pass. This
configuration is useful if your business provides wired user guest access and you want the guest user traffic
to pass through an ACL and connect to captive portal.

LAN ports are configured as untrusted so that users are authenticated using AAA profile. WAN ports
do not require users to authenticate and hence are configured as trusted ports.

You can set a range of VLANs as trusted or untrusted in trunk mode.

The following table lists the trusted or untrusted ports, VLAN configuration, and the impact on the network:

Port VLAN Traffic Status

Trusted Trusted Trusted

Untrusted Untrusted Untrusted

Untrusted Trusted Untrusted

Trusted Untrusted Untrusted

Table 18: Classifying Trusted and Untrusted Traffic

See the following topics to know how to configure ports:

n Adding Ports

n Configuring Ports for LAN Interfaces

n Configuring Ports forWAN Interfaces

n Configuring Other Parameters for Port

Adding Ports
Complete the following tasks to add ports to the Aruba Gateway and configure the port parameters:

1. To configure Gateway group or Gateway, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.
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b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Click Interfaces > Ports.

4. Click + from the Ports table to add a new port.

5. From theNew Port window, select the required ports to be added to the Ports table and save the
changes.

Configuring Ports for LAN Interfaces
To configure ports for LAN interfaces at the device or group level, complete the following steps:

1. To configure a gateway group or gateway device, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Click Interfaces > Ports.

4. Select the port from the Ports table.

5. Select the port type as LAN.

6. Clear the Trust check box to set the port to Untrusted.

7. To apply a policy to the LAN interface, select one of the following options from the Policy drop-down
list:
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n Inbound and Outbound—Select this option to apply a firewall policy of the incoming and outgoing
traffic.

n Per-Session—Select this option to apply a firewall policy for the session.

8. Select the port mode. You can set ports to either accessmode or trunk mode.

n Access—By default, ports are set to accessmode to carry traffic only for the VLAN to which they are
assigned. For Accessmode, select the VLAN and theVLAN trust checkbox. To apply a policy for the
VLAN traffic on access port, see Applying Policies for VLANs on Access Ports on page 332.

n Trunk— In trunk mode, a port can carry traffic formultiple VLANs. When the Trunkmode is
selected, specify whether the port must carry traffic for all VLANs configured for the branch or for
specific VLANs only. You can also configure the native VLAN for a port. To apply a policy for VLANs in
trunk mode, see Applying Policies for VLANs on Trunk Ports on page 333.

9. Save the changes.

Ensure to apply a AAA profile to the VLANs that are assigned to the port. For more information, see
Assigning AAA profile to VLAN Interfaces for Role Assignment on page 334.

Configuring Ports for WAN Interfaces
To configure port forWAN interfaces at the device or group level, complete the following steps:

1. To configure a gateway group or a gateway device, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Click Interfaces > Ports.

4. Select a port from the Ports table. The port details are displayed.

5. Select the port type asWAN.

6. Select the Trust check box.

7. To apply a policy to theWAN interface, select one of the following options from the Policy drop-
down list:
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n Inbound and Outbound—Select this option to apply a firewall policy for the incoming and
outgoing traffic.

n Per-Session—Select this option to apply a firewall policy for the session.

8.  Select the port mode. You can set ports to either accessmode or trunk mode.

n Access—By default, ports are set to accessmode to carry traffic only for the VLAN to which they are
assigned. For Accessmode, select the VLAN and theVLAN trust checkbox. To apply a policy for the
VLAN traffic on access port, see Applying Policies for VLANs on Access Ports on page 332.

n Trunk— In trunk mode, a port can carry traffic formultiple VLANs. When the Trunkmode is
selected, specify whether the port must carry traffic for all VLANs configured for the branch or for
specific VLANs only. You can also configure the native VLAN for a port. To apply a policy for VLANs in
trunk mode, see Applying Policies for VLANs on Trunk Ports on page 333.

9. Save the changes.

Configuring Other Parameters for Port
Complete the following tasks to configure the port parameters:

1. To configure a gateway group or gateway device, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Click Interfaces > Ports.

4. To configure the port parameters, select the required port from the Ports table. The port details are
displayed.

5. Configure the parameters described in Table 19 as per your network requirements.

6. Save the changes.

Parameter Description

Basic Options

Table 19: Port Parameters



Aruba SD-WAN Solution | User Guide 188

Parameter Description

Type Select the port type as WAN or LAN for WAN interface and LAN interface respectively.

Admin state Select this option to set the user state of the port interface as admin.

Speed Select one of the following values (Mbps) for speed operation of the port:
n 10
n 100
n 1000
n auto

Duplex Select one of the following values for duplex operation of the port:
n auto
n half
n full

PoE Enable this option to set the port interface as a PoE source.

Trust Enable this option to configure the port as a trusted interface.

Policy Select one of the following options from the drop-down list:
n Inbound and Outbound—Select this option to apply a firewall policy for the incoming
and outgoing traffic.
n Per-Session—Select this option to apply a firewall policy for the session.

Mode Select the port mode. You can set ports to either access mode or trunk mode.
n Access—By default, ports are set to access mode to carry traffic only for the VLAN to
which they are assigned. For Access mode, select the VLAN and the VLAN trust checkbox.
To apply a policy for the VLAN traffic on access port, see Applying Policies for VLANs on
Access Ports on page 332.
n Trunk— In trunk mode, a port can carry traffic for multiple VLANs. When the Trunk mode
is selected, specify whether the port must carry traffic for all VLANs configured for the
branch or for specific VLANs only. You can also configure the native VLAN and session
firewall policy on a port. To apply a policy for VLANs in trunk mode, see Applying Policies for
VLANs on Trunk Ports on page 333.

VLAN Select the VLAN interfaces that you want to associate to the port.

VLAN trust Enable this option to set the VLAN interface as trusted.

VLAN policy The firewall policy that is applied to the trusted VLAN which is associated to the port. You can
apply firewall policies only for trusted VLANs.
For more information on applying VLAN policies, see Applying Policies to Gateway Interfaces on
page 332.

Description Optional text string to describe the port interface.

Tunneled
node

Select this option to enable tunneled node capability for the port interface. By default, this is
disabled. The tunneled node connects to one or more client devices at the edge of the network
to establish a secure GRE tunnel.

Jumbo MTU Select this option to enable Jumbo frame MTU configured on the interface. This setting is
functional only if the Jumbo frame processing is enabled in the firewall policies.

Advanced Options
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Parameter Description

The following advanced options appear only if you click the Show advanced options link below the Ports
table.

Port
monitoring

Select this to enable the switch to send a copy of all network packets seen on one port to another
port.

Spanning
tree

Select this option to enable spanning tree protocol on the port. This is enabled by default.

Spanning
tree cost

Specify the spanning tree path cost of the port. The allowed range is 1-65535. The default value
is 2000.

Spanning
tree priority

Specify the spanning tree priority of the port. The allowed range is 0-255. The default value is
128.

Spanning
tree port
fast

Select this option to enable forwarding of traffic from the port. By default, this option is
disabled.

Spanning
tree point-
to-point

Select this option to enable the port as a point-to-point link. By default, this option is disabled.

Spanning
tree BPDU
guard

Enable BPDU guard to protect the port from receiving STP BPDUs. However, the port can
transmit STP BPDUs.

LLDP
transmission

Enable this option if you want the port to transmit LLDP packets and configure the following
LLDP transmissions parameters:

n Transmit interval—Specify the interval between LLDP TLV transmission in seconds. The
supported range is 1-3600 seconds and the default value is 30 seconds.
n Transmit hold—Enter a value from 1-100. This value is multiplied by the transmit interval
to determine the number of seconds to cache the learned LLDP information before it is
cleared. If the transmit-hold value is at the default value of 4, and the transmit interval is at
its default value of 30 seconds, then the learned LLDP information is cached for 4 x 30
seconds, or 120 seconds.
n Fast transmit interval—Set the LLDP fast transmission interval in seconds. The supported
range is 1-3600. The default value is 1.
n Fast transmit hold—Enter a value from 1-100. This value is multiplied by the fast transmit
interval to determine the number of seconds to cache the learned LLDP information before
it is cleared. If the fast transmit-hold value is at the default value of 4, and the fast transmit
interval is at its default value of 1 second, then the learned LLDP information is cached for 4
x 1 seconds, or 4 seconds.

LLDP
reception

Select this option to enable the port to receive LLDP packets.

LLPD-MED Select this option to enable LLDP-MED on the port.

Port security Set or limit the number of MAC addresses learnt on the port. The allowed range is 1-16384.

Configuring Uplinks
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Uplinks connect Branch Gateways to underlay networks. By default, both wired and cellular uplinks are set
as active links with load balancing enabled on Branch Gateways. Branch Gateways support a total of five
uplinks which include four wired uplinks and one cellular uplink.

Uplink Load Balancing
An uplink can be configured as an active uplink or as standby. The uplink load balancing feature supports
both active and standby uplinks, for example, traffic can be load balanced across two wired uplinks, while
the backup cellular uplink remains idle and is used when awired link fails. When a Branch Gateway has
multiple active uplinks, uplink load balancing canmodify the Internet Key Exchange (IKE) parameters for the
Branch Gateway to createmultiple IPsec tunnels, one on each uplink. Whenmultiple uplinks and IPsec
tunnels are up, the layer 3 traffic can be load-balanced across these uplinks using internal routing ACLs and
next hop lists.

WAN Bandwidth Optimization
Data compression reduces the size of data frames that are transmitted over a network link. This in turn
reduces the time required to transmit the frame across the network. IP payload compression is one of the
key features of theWAN bandwidth optimization solution, which consists of the following elements:

n IP Payload Compression

n Traffic Management and Quality of Service (QoS)

n Caching

WAN optimization through IP payload compression is not supported on 7205 Branch Gateway.

Branch Gateways can send traffic to destinations other than the corporate headquarters on the same link;
therefore payload compression is enabled on the IPsec tunnel between the Branch Gateway and VPN
Concentrator. Dynamic compression is used for the IP payload to achieve a high compression ratio.
However, compression is not applied to data, for example, an embedded image file that may already be in a
compressed format.

Configuring Uplink Interfaces on Branch Gateways
To configure uplink interfaces on Branch Gateways, complete the following steps:

1. To configure a Branch Gateway group or a Branch Gateway, complete one of the following steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.
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d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Go to WAN > Uplink. TheUplink configuration page opens.

4. To enable data compression, select theCompression check box.

5. Select any one of the following load balancingmodes:
n Round Robin—To equally distribute traffic among all active uplinks on a round robin basis. By

default, Branch Gateway uses the round robinmode for balancing load across uplinks.

n Session Count—To balance traffic among the uplinks based on the number of sessionsmanaged
by each link, so that the load for each active uplink stays within 5% of the other active uplinks. For
example, if there are two active uplinks with theWeight parameter defined as 10 and 20, the active
uplink with aweight of 20 will havemore sessions assigned.

n Uplink utilization—To distribute traffic between activeWAN uplinks based on the utilization % of
each activeWAN uplink. Uplink utilization considers the link speed to calculate the utilization and
allows amaximumpercentage of bandwidth threshold to be defined. When the bandwidth
threshold exceeds, theWAN uplink is no-longer considered for session allocation.

6. To calculate the available bandwidth for the uplinks, select theBandwidth Estimation check box.
The periodic computation of the actual available Internet bandwidth in both directions helps
administrators ensure better control of application performance at the branch even when the
bandwidth keeps changing over the internet. When the bandwidth estimation feature is enabled, the
available bandwidth ismeasured by synthesizing traffic and calculating an average for a specific time
duration. To view the average bandwidth estimated for your sites, see theWAN Health—Site
dashboard.

7. To add an uplink, click + in theUplink VLANs table and enter the following values to define an uplink
VLAN for an uplink interface on the Branch Gateway:
n Link Type—Select any one of the following types of uplink:

o MPLS—MPLS network
o INET—Internet
o LTE—4G cellular network
o Metro-Ethernet—Ethernet network in ametropolitan area

Configuring an MPLS, Metro-Ethernet, or an INET Uplink

To configure anMPLS, or aMetro-Ethernet, or an INET uplink, select the uplink type from the drop-down
list, and enter details for the parameters provided in the following table:
Table 20: MPLS, Metro-Ethernet, or an INET Uplink Configuration Parameters

Parameter Description

Link Name Specify the name of the uplink.

Interface VLAN ID Specify the VLAN ID that you want to assign to the uplink.

Operation state Use this checkbox to disable or re-enable the uplink. By default,
uplinks are enabled.

Use only as backup link By default, all uplinks operate as active uplinks. If you want to use
the uplink in the standby mode, select this checkbox.
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Parameter Description

Bandwidth Percentage Use this field to configure bandwidth percentage for uplink util-
ization. This field is available only for the Uplink utilization load
balancing mode.

Speed You can configure a custom value for uplink speed to optimize per-
formance. The allowed range of values is 1–10000 Mbps. If not set,
the WAN uplink speed defaults to auto-negotiated port speed for
INET, MPLS, and Metro-Ethernet. Based on the speed and band-
width threshold allowed for an uplink, Branch Gateways assign
session traffic.

Weight For Round Robin and Session Count load balancing modes, you
can define a value for Weight within a range of 1–100. By default,
this is set to 10. In an active-active uplink scenario, an uplink with
a higher weight is assigned more session traffic than an uplink
with a lower weight.

Configuring an LTE Uplink

To configure an LTE uplink, select LTE from the drop-down list, and enter details for the parameters
provided in the following table:
Table 21: LTE Uplink Configuration Parameters

Parameter Description

Link Name Specify the name of the uplink.

Connection type Specify one of the following connection types:
n Wired
n USB
n Internal

By default, USB is selected.

NOTE: For a 9004-LTE Branch Gateway, the default connection
type is Internal.

Interface VLAN ID The VLAN ID assignment is not configurable for 4G LTE USB and
Internal uplinks. By default, VLAN ID 4095 is assigned to the 4G
LTE USB and Internal uplinks.

Low frequency probe This is a global configuration for all LTE connections. Use this
check box to enable less-frequent health check probing on the
LTE uplink. LTE uplinks normally have lower bandwidth
compared to wired uplinks, therefore youmay want to enable
less frequent probing on the LTE uplinks. When Low frequency
probe is enabled, health check probes are sent every 15 seconds
with a burst size of 2 packets for all LTE uplink interfaces
configured on the Branch Gateway.

Use only as backup link By default, all uplinks operate as active uplinks. If you want to use
the uplink in the standby mode, select this checkbox.

Bandwidth Percentage Use this field to configure bandwidth percentage for uplink
utilization. This field is available only for the Uplink utilization
load balancing mode.
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Parameter Description

Speed You can configure a custom value for uplink speed to optimize
performance. The allowed range of values is 1–10000 Mbps. If
not set, the WAN uplink speed defaults to100 Mbps for LTE.
Based on the speed and bandwidth threshold allowed for an
uplink, Branch Gateways assign session traffic.

Weight For Round Robin and Session Count load balancing modes, you
can define a value for Weight within a range of 1–100. By
default, this is set to 10. In an active-active uplink scenario, an
uplink with a higher weight is assignedmore session traffic than
an uplink with a lower weight.

If you have selected Internal as the Connection Type, enter details for the following parameters:

Active SIM slot Select SIM 1 or SIM 2 as the active uplink.

Access point name (APN) Enter the name of the Access Point to which the uplink connects.

Public land mobile network (PLMN) A PLMN ID is a six digit ID which is a combination of Mobile
Country Code andMobile Network Code. Each service provider
has their own PLMN code. This field allows you to restrict
roaming. Select Auto or Manual for the PLMNmode. If you have
selected Manual, enter the PLMN ID in the text box. By default,
PLMN is on Auto mode.

Mode Select Auto, 4G LTE, or 3G as the network mode.

Data Usage Tracking Turn on the toggle switch to start tracking your data usage. If this
field is enabled, the options to configure data usage limit and the
Billing cycle are displayed.

Data usage alert limit Enter the data limit in megabytes (Range – 1 to 65535 MB) to be
used per month. Configure an alert in the Alerts & Events page
for the alert to be generated when the data usage crosses the
specified limit.

Monthly Billing start date Select the day of the month on which the billing cycle begins.

1. Click Save Settings.

Configuring Uplink Interfaces on VPN Concentrators

The SD-WAN Orchestrator requires uplink interfaces to be configured on both Branch Gateways and
VPN Concentrators for tunnel orchestration. For more information on configuration recommendations,
see Configuring Uplinks for Tunnel Orchestration on page 352.

To configure uplink interfaces on VPN Concentrators, complete the following steps:

1. To configure a Branch Gateway group or a Branch Gateway complete one of the following steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.
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b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Click WAN > Uplink.

4. To add an uplink VLAN, click + in theUplink VLANs table.

5. Configure the following parameters:
n Link Type—Select any one of the following uplink types:

o MPLS—For theMPLS traffic
o INET—For the Internet traffic

n Link Name—Enter a name for the uplink interface.
o ForMPLS uplinks—The link namemust match the link name configured for theMPLS uplink

interface on Branch Gateways.
o For INET uplinks—The link nameneed not be the same as theMPLS uplink name configured on

Branch Gateways.

n Interface VLAN ID—Enter the VLAN ID that you want to assign to the uplink interface.

n Private IP—If MPLS is selected as the uplink type, enter a private IP address.
By default, the IP address of the VLAN interface is used as the private IP address for both
MPLS and INET uplinks. Private IP address for INET uplinks cannot bemodified or overwritten.

n Public IP—This field is available only for INET uplinks. Ensure that you define a public IP address
that corresponds to the firewall NAT translation of the private IP address.

6. Click Save Settings.

Managing 9004-LTE Branch Gateway
Aruba Central supports the 9004-LTE Branch Gateway model that comeswith a default SD-WAN image. The
recommended software version for 9004-LTE Gateway is ArubaOS 8.5.0.0-2.1.0.0.

The 9004-LTE Gateway comeswith an inbuilt LTEmodem. This integratedmodemenhances performance in
comparison to a dongle that needs to be connected to a USB port. Thismodel provides amore efficient
radio network, latency reduction, and improvedmobility. The 9004-LTE Gateway has the capability of dual
SIM and single radio.

Configuring Uplink Interfaces on a 9004-LTE Branch Gateway
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1. To configure a Branch Gateway group or a Branch Gateway, complete one of the following steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Go to WAN > Uplink. TheUplink configuration page opens.

4. To add an uplink, click + in theUplink VLANs table and select LTE from the Link type drop-down
list.

For detailed information, see Configuring an LTE Uplink.

The following table contains the new fields that need to be configured for 9004-LTE Gateway along with the
existing fields:
Table 22: Configuring an LTE Uplink on a 9004-LTE Gateway

Parameter Description

Link Name Specify the name of the uplink.

Connection
type

Specify one of the following connection types:
n Wired
n USB
n Internal

NOTE: For a 9004-LTE Branch Gateway, the default connection type is Internal.

Interface
VLAN ID

The VLAN ID assignment is not configurable for 4G LTE USB and Internal uplinks. By default,
VLAN ID 4095 is assigned to the 4G LTE USB and Internal uplinks.

Low
frequency
probe

This is a global configuration for all LTE connections. Use this check box to enable less-frequent
health check probing on the LTE uplink. LTE uplinks normally have lower bandwidth compared to
wired uplinks, therefore youmay want to enable less frequent probing on the LTE uplinks. When
Low frequency probe is enabled, health check probes are sent every 15 seconds with a burst size
of 2 packets for all LTE uplink interfaces configured on the Branch Gateway.

Use only as
backup link

By default, all uplinks operate as active uplinks. If you want to use the uplink in the standby mode,
select this checkbox.
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Parameter Description

Bandwidth
Percentage

Use this field to configure bandwidth percentage for uplink utilization. This field is available only
for the Uplink utilization load balancing mode.

Speed You can configure a custom value for uplink speed to optimize performance. The allowed range
of values is 1–10000 Mbps. If not set, the WAN uplink speed defaults to 100 Mbps for LTE. Based
on the speed and bandwidth threshold allowed for an uplink, Branch Gateways assign session
traffic.

Weight For Round Robin and Session Count load balancing modes, you can define a value for Weight
within a range of 1–100. By default, this is set to 10. In an active-active uplink scenario, an uplink
with a higher weight is assignedmore session traffic than an uplink with a lower weight.

If you have selected Internal as the Connection Type, enter details for the following parameters:

Active SIM
slot

Select SIM 1 or SIM 2 as the active uplink.

Access
point name
(APN)

Enter the name of the Access Point to which the uplink connects.

Public land
mobile
network
(PLMN)

A PLMN ID is a six digit ID which is a combination of Mobile Country Code andMobile Network
Code. Each service provider has their own PLMN code. This field allows you to restrict roaming.
Select Auto or Manual for the PLMNmode. If you have selected Manual, enter the PLMN ID in
the text box. By default, PLMN is on Auto mode.

Mode Select Auto, 4G LTE, or 3G as the network mode.

Data Usage
Tracking

Turn on the toggle switch to start tracking your data usage. If this field is enabled, the options to
configure data usage limit and the Billing cycle are displayed.

Data usage
alert limit

Enter the data limit in megabytes (Range – 1 to 65535 MB) to be used per month. Configure an
alert in the Alerts & Events page for the alert to be generated when the data usage crosses the
specified limit.

Monthly
Billing start
date

Select the day of the month on which the billing cycle begins.

Viewing the 9004-LTE Gateway Details
To view 9004-LTE Gateway device details, complete the following steps:

1. In theNetwork Operations app, use the filter to select a 9004-LTE Branch Gateway.

2. UnderManage, go to Overview > Summary. TheGateway Details page is displayed.

New fields that pertain to 9004-LTE Gateway have been introduced in theWAN and Overview tabs.

WAN Tab
For a 9004-LTE Gateway, the faceplate displays the LTE uplink details. When you hover over Internal LTE,
you can view details about the active SIM, the name of the service provider, and the signal strength as
illustrated in the image:
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You can click on the active SIM to view the port details of cellular:

Formore information, see Gateway > WAN > Summary.

Overview Tab
The following attributes are added exclusively for 9004-LTE Gateway model:

n 4G/LTE Modem Type—Displays the LTE connection type as Internal if it is an internalmodem. Displays
the name of the vendor if it is an externalmodem.

n 4G/LTE Modem Status—Displays themodem connectivity status. A green check-mark icon indicates
that themodem is connected. A red circular icon indicates that themodem is disconnected. If the
modem type is Internal, this field also displays the name of the service

n provider and the signal strength along with themodem status. Hover over the information icon to
view details about the active SIM, the IMEI number, and the phone number. If themodem type is external,
this field displays only themodem connection status.

You can view the signal strength classification based on the RSSI value provided in the following table:
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Table 23: Signal Strength Classification

Signal Strength Value Representation

Good > –65 dBm All four bars are shaded green

Average > –80 dBm From the left, first 2 or 3 bars are shaded green

Poor < –80 dBm From the left, only one bar is shaded green

The following image displays the device information of a 9004-LTE Gateway:

Figure 67 Device Info - 9004-LTE Gateway

Formore information, see Gateway Details - Overview Tab.

Configuring WAN Health Check
TheWAN Health Check sends probes to measureWAN availability and latency on selected uplinks. Based on
probe response, Gateways continue to use the primary uplink, or fail over to a backup link.

As health check monitoring is critical for forwarding the Internet traffic, ensure that the health check feature
is enabled on all Branch Gateway groups. When the health check feature is enabled, the probes are sent
through the underlay at regular intervals to verify if the Internet is reachable over the uplink interfaces
configured on Gateways. Based on the probe response, the uplink interface ismarked as unavailable for the
underlay traffic.

When the health check is enabled on a Branch Gateway, it sends five UDP or ICMP probes to a host every 10
seconds. The tunnel health is determined based on the probes received at the host:

1. If a probe is lost, then five probes are sent every two seconds to the host.

2. If a probe is lost in the first two seconds, then the aggressivemode is enabled by default and 25
probes are sent every two seconds for the next 10 seconds.

3. If the probes do not reach the destination, then the tunnel is torn down hence achieving faster tunnel
age-out withminimumpacket loss.

When probes are not lost, The Branch Gateway goes back to send five probes every 10 seconds per uplink.

Enabling WAN Health Check Probes
To enableWAN health check and configure probe settings, complete the following steps:
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1. To configure a Branch Gateway group or a Branch Gateway complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, go to WAN > Health Checks.

3. Turn on the Enable health check toggle to allow the gateway to send UDP or ICMP probes to a
host and determine if the path is available to accommodate traffic, and configure the parameters
described in the following table:

Parameter Description

Health check
destinations

Remote host to which the Branch Gateways can send the health check probes.
As part of the SD-WAN solution, Aruba Central provides a globally redundant
path quality monitoring service for WAN health checks by default.

n User defined—select this option to use a user defined host that is
reachable through the WAN paths outside the VPN tunnel.
n Aruba cloud—select this option to use the responder
(pqm.arubanetworks.com) provided by Aruba Central

Health check
IP address

If a User defined health check destination is selected, provide the Health
check IP address with the IPV4 address or FDQN of the user defined host.

Health check probe
mode

Probe modes to use for connectivity checks.
The following probe modes are available:

n Ping—Sends ICMP probes to measure latency and packet loss.
n UDP—Sends UDP Probes through UDP port 4500 to measure latency,
packet loss and jitter.

Latency is calculated based on the Round-Trip Time (RTT) of ping responses.

Table 24: WANHealth Check Settings—Basic Mode

4. Click Advanced Mode to access the advanced configuration options.

5. Go to WAN > Health Check.
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6. Select theHealth Check check box and configure the parameters described in the following table:

Parameter Description

Remote Host
IP/FQDN

Remote host to which the Branch Gateways can send the health check probes.
As part of the SD-WAN solution, Aruba Central provides a globally redundant
path quality monitoring service for WAN health checks by default. Ensure that
you use the pqm.arubanetworks.com FQDN as the probe responder, so that
Aruba Central uses this host address to check the health of WAN uplinks
configured on Branch Gateways.
Branch Gateways with ArubaOS 8.4.0.0-1.0.6.0 or later software versions can
probe up to four IP addresses that are obtained after resolving the health
check FQDN. In the earlier releases, Branch Gateways could send probes to
only one IP address obtained after resolving the health check FQDN.

NOTE: The Branch Gateways running the ArubaOS 8.4.0.0-1.0.6.0 or later
software versions can install host routes to any DNS servers that are learned
or configured using the uplink interfaces. This enhancement ensures that the
DNS queries are routed through the appropriate uplink interfaces irrespective
of the default routes. However, Branch Gateways do not support installing host
routes on the MPLS uplink.

Probe Mode Probe modes to use for connectivity checks.
The following probe modes are available:

n Ping—Sends ICMP probes to measure latency and packet loss.
n UDP—Sends UDP Probes through UDP port 4500 to measure latency,
packet loss and jitter.

Latency is calculated based on the Round-Trip Time (RTT) of ping responses.

Probe Interval (sec) Probe interval for sending probes. The default probe interval is 10 seconds.
The allowed range of values is 2–3600 seconds.

Packet Burst Per
Probe

Number of probes to be sent during the probe interval. To change the default
value of 5 probes, enter a new value within a range of 1–16.

Probe Retries The number of times the Branch Gateway must attempt to resend a probe. You
can set any value withing a range of 1-255. The default value is 3.

Jitter Measurement For the UDP probe mode, you can enable this checkbox to measure jitters on
the uplink interface.

Table 25: WANHealth Check Settings—Advanced Mode

Monitoring WAN Health
If you have configured uplink interfaces and enabled health check, the dashboard on the Overview >
Gateways page displaysWAN availability, usage, and compression details.

Configuring WAN Interface Bandwidth Priorities
The SD-Branch devices support configuringWAN scheduler profiles to ensure that all traffic types are
allowed aminimumbandwidth. TheWAN scheduler profiles also allow you to define priorities per traffic
class to ensure that critical and delay-sensitive applications such as voice and video are assigned a higher
priority andmore bandwidth. EachWAN interface can have a scheduler profile that supports four queues
with different priority levels. When you use session ACLs to define traffic policies on the Branch Gateway,
you can use the scheduler profile to automatically associate different priority levels assigned by these
policies to a scheduler profile queue.
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For information on creating a traffic policy that assigns 802.1p priority levels to a specific application
or application type, see Creating a Firewall Policy for Network Services on page 292.

Creating a WAN Scheduler Profile
To enableWLAN interface bandwidth priorities usingWAN Scheduler, complete the following steps:

1. To configure a Branch Gateway group or a Branch Gateway complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Go to WAN > WAN Scheduler.

4. Click + below theWAN Scheduler Profiles table to define a new scheduler profile.

a. In the Profile name field, enter a profile name.

b. In the Priority fields, enter one ormore 802.1p priority levels (0–7) for each queue type. Each of the
seven priority levelsmust be supported by one of the four queues.

c. For each queue, click the Scheduler Discipline drop-down list and select one of the following discipline
types:
n Strict priority—The queue service is based exclusively on the priority of the queue, where the lower-

priority queues are not serviced until the higher-priority queue is clear. With this option, the highest-
level priority is guaranteed asmuch bandwidth as possible, but there can be phases where the second,
third, and fourth priority queuesmay receive little or no bandwidth.

n Deficit Round Robin (DRR) Weight: The queue is assigned a percentage of available bandwidth. If
you selected theDRR Weight option, youmust enter the percentage of bandwidth that should be
made available to the traffic in the selected queue.
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You can define both strict priority and DRR Weight discipline types for a single scheduler profile. If you
configure both strict priority and DRR weighted queues, the strict priority queues should be specified in
a sequential order, followed by the DRR weighted queues. For example, if you want to specify two strict
priority queues and two DRR weighted queues, configure queues 0 and 1 with the strict priority type,
and then configure queues 2 and 3 with a DRR priority type. Do not alternate between strict priority
and DRR weighted queues.

Table 26 displays sample Class of Service values for each queue of aWAN scheduler profile.

Queue Priority Scheduler Discipline

Queue 0 6 7 Strict Priority

Queue 1 4 5 Strict Priority

Queue 2 2 3 Strict Priority

Queue 3 0 1 Strict Priority

Table 26: Sample CoS Values for WAN Scheduler
profile

1. To assign the scheduler profile to a cellular or Gigabit Ethernet port interface, click + in the
Assignments area and configure the following parameters:

a. Select the Port option and from the Ports drop-down list, select an interface. In the Transmit Rate
field, enter themaximum transmit rate in Mbps for the selected interface.

b. Click theCellular option. In the Transmit Rate field, enter themaximum transmit rate in Mbps for the
selected interface. The allowed range of values is 1–500 Mbps.

2. Create a firewall session policy that assigns a priority level to an application or application group. For
details, see Creating a Firewall Policy for Network Services on page 292.

Configuring the SD-WAN Overlay Network
The Aruba SD-Branch solution supports the hub and spoke topology and uses IPsec tunnels between the
branch and the hub sites to build an SD-WAN overlay network. Hub sites are typically the corporate
headquarters or data centers that include one ormoreGateways operating as VPN Concentrators, while
branch sites or spokes include one ormore Branch Gateways. The overlay network securely transports
traffic forwarded between the hub and branch sites.

The SD-Branch deployment includes at least one hub site with one ormore VPN Concentrators that
terminate IPsec-based VPN tunnels initiated from the Branch Gateways. Based on the deployment size and
redundancy requirements, you can deploy one ormore VPN Concentrators at each hub site.

Overriding port-based tunnel client VLAN on the controller is supported only for untagged VLANs
configured on the port-based tunneling switch port. It is not supported when both untagged and tagged
VLANs are configured on the port-based tunneling switch port.

The following figure illustrates the hub and spoke topology with a single hub site:
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Figure 68 Hub and Spoke Topology: Single Hub Site

Large deploymentsmay include additional hub sites to provide redundancy in the event of a primary hub
site failure. Themost common deployment consists of a primary and secondary hub, each with two
redundant VPN Concentrators, as shown in the following figure:



Aruba SD-WAN Solution | User Guide 204

Figure 69 Hub and Spoke Topology: Dual Hub Sites

Configuration Recommendations
The Aruba SD-WAN overlay network based on the hub and spoke architecture requires the administrators to
configure Gateways using the Aruba Central management interface. Administrators can eithermanually set
up theGateways for establishing VPN tunnels or use the tunnel orchestrator service in Aruba Central to
enable Gateways to automatically establish VPN tunnels. When the VPN hub is set and the Branch
Gateways are configured as spokes, Aruba Gateways authenticate using the built-in TPM certificates and
automatically establish an overlay tunnel. Administrators can also upload custom certificates for
authentication.

Important Points to Note

n The overlay IPsec VPN tunnels are initiated by Branch Gateways and terminated on a VPN Concentrator in
a hub site using NAT traversal. For NAT traversal, the UDP 4500 port must be enabled.

n The VPN tunnels overMPLS basedWANs typically terminate on a VPN Concentrator using a VLAN interface
assigned a private IPv4 address.

n Internet-basedWAN services can either be directly terminated on a VPN Concentrator using a public IPv4 or
private IPv4 address assigned by the VLAN interface.

n Using the Aruba Central management interface, you can enable automatic whitelisting of Branch Gateways
ormanually add the list of hub sites on Branch Gateways.

Configuring Overlay Tunnels Automatically
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The Aruba SD-Branch Solution supports the SD-WAN overlay orchestration service that automates the
overlay tunnel and route configuration process. Formore information on SD-WANOverlay orchestration
service, see SD-WAN Overlay Tunnel and RouteOrchestration on page 351.

Manually Configuring Hub and Spoke VPN
To configure a hub and spoke topology for the SD-WAN overlay network, complete the following steps:

n Enabling AutomaticWhitelisting of Gateways on page 205

n Whitelisting GatewaysManually on page 207

n Advertising Branch Subnets to Hub Sites

Enabling Automatic Whitelisting of Gateways
In a hub and spoke VPN topology, where remote branches connect to the VPN Concentrator, newer
branches are added in a staggered way. Each time a Branch Gateway is added, the branch information
needs to be populated in the VPN Concentrator to whitelist the branch device. With large-scale
deployments, thismethod can be error prone and cumbersome. The automatic whitelisting feature
automates the process of allowing branch devices to connect to VPN Concentrators and thus eliminates the
need for configuring each device at the headend.

Using Aruba Central as a singlemanagement entity for Gateways, administrators can enable automatic
whitelisting and define a passphrase for secure transmission of VPN traffic. The automatic whitelisting
serves as a global configuration that enables all VPN Concentrators to terminate tunnels initiated by the
Branch Gateways provisioned in Aruba Central.

Automatic whitelisting configuration is required on both Branch Gateways and VPN Concentrator.
Ensure that you enable this feature on both Branch Gateway and VPN Concentrator groups.

Enabling Automatic Whitelisting of Branch Gateway on a VPN Concentrator
To whitelist a Branch Gateway automatically on a VPN Concentrator, complete the following steps:

1. In theNetwork Operations app, select a group in which VPN Concentrators are provisioned.
The dashboard context for a group is displayed.

2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click theConfig icon.
The gateway group configuration page is displayed.

4. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

5. Click VPN > SD-WAN Overlay.

6. Select theOverlay mode asManual.

7. Click Automatically Whitelist Branch Gateways.

8. Enter a passphrase for VPN peer authentication. Ensure that the same passphrase is configured on
the Branch Gateways.
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9. Select any of the following encryptionmethods from the Encryption drop-down list:
n Factory Cert—To use the built-in TPM certificate formutual authentication.\

n Custom Cert—To use custom certificates formutual authentication. If you want to use custom
certificates, ensure that the CA and Server certificates are uploaded to the certificate inventory on
Aruba Central. Formore information, see Certificates on page 24.

10. To apply a route ACL to the IPsec session, select an ACL from theRoute ACL drop-down.

11. To apply a session ACL, select an ACL from the Session ACL drop-down.

12. If you want to assign overlapping uplink IP addresses across the branches, enable theUplink IP
addresses overlap across branches feature and then enter the IP address range configured for
the branch pool.

13. Click Save Changes.

Enabling Automatic Whitelisting on Branch Gateways
To enable Branch Gateways to automatically connect to VPN Concentrators, complete the following steps::

1. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway.
The dashboard context for a group is displayed.

2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click a gateway underDevice Name.
The dashboard context for the gateway device is displayed.

4. UnderManage, Click Device.
The gateway configuration page is displayed.

5. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

6. Click VPN > SD-WAN Overlay.

7. Select theOverlay mode asManual.

8. Click Automatically Whitelist Branch Gateways.

9. Enter a passphrase for VPN peer authentication. Ensure that the same passphrase is configured on
the Branch Gateways.

10. Select any of the following encryptionmethods from the Encryption drop-down list:
n Factory Cert—To use the built-in TPM certificate formutual authentication.

n Custom Cert—To use custom certificates formutual authentication. If you want to use custom
certificates, ensure that the CA and Server certificates are uploaded to the certificate inventory on
Aruba Central. Formore information, see Certificates on page 24.

11. To apply a route ACL to the IPsec session, select an ACL from theRoute ACL drop-down.

12. To apply a session ACL, select an ACL from the Session ACL drop-down.

13. If you want to assign overlapping uplink IP addresses across the branches, enable theUplink IP
addresses overlap across branches feature and then enter the IP address range configured for
the branch pool.

14. Click Save Changes.

15. Select a group in which the Branch Gateway is provisioned.
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16. Click VPN > SD-WAN Overlay.

17. Click Connect automatically to VPNC.

18. Enter the VPN peer authentication passphrase. The passphrasemust be the same as the one
configured on the VPN Concentrator for automatic whitelisting.

19. If required, advertise branch VLANs to all hubs.

20. Click Save Settings.

Whitelisting Gateways Manually
Tomanually whitelist Gateways, administratorsmust manually add the VPN Concentrators as hubs in
Branch Gateways and add the Branch Gateways to the VPN Concentrator database.

Adding a VPN Endpoint on Branch Gateways
Tomanually add a VPN endpoint on Branch Gateways, complete the following steps:

1. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway.
The dashboard context for a group is displayed.

2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click a gateway underDevice Name.
The dashboard context for the gateway device is displayed.

4. UnderManage, Click Device.
The gateway configuration page is displayed.

5. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

6. Click VPN > SD-WAN Overlay.

7. Click VPN > SD-WAN Overlay.

8. Click + from theHubs table and add the following information:

n Primary VPNC—Enter theMAC address of the primary VPN Concentrator.

n Backup VPNC—If you have a backup VPN Concentrator deployed at your site, enter theMAC
address of the backup VPN Concentrator.

n IP Address—Enter the IP address of the VPN Concentrator.

n Source VLAN—If you havemore than one VPN Concentrator, enter the VLAN of WAN uplink
VLAN interface of the Branch Gateway on which the VPN tunnelmust initiate.

9. Select any of the following encryptionmethods from the Encryption drop-down list:
n Factory Cert—To use the built-in TPM certificate formutual authentication.

n Custom Cert—To use custom certificates formutual authentication. If you want to use custom
certificates, ensure that the CA and Server certificates are uploaded to the certificate inventory on
Aruba Central. Formore information, see Certificates on page 24.

10. If required, advertise branch VLANs to all hubs.

11. Click Save Settings.

Adding Branch Gateways on VPN Concentrators
Tomanually add Branch Gateways on VPN Concentrators, complete the following steps:
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1. In theNetwork Operations app, select a group in which the VPN Concentrators are provisioned.

2. UnderManage, click Devices > Gateways.

3. Click the settings icon. TheGateway dashboard is displayed.
4. Click VPN > SD-WAN Overlay.

5. Click + from theBranch Gateway Table to add theMAC address of the Branch Gateways:
n MAC ADDRESS—Enter theMAC address of the Branch Gateway.

n ENCRYPTION—Select any of the following encryptionmethods from the Encryption drop-down
list:
o Factory Cert—To use the built-in TPM certificate formutual authentication.
o Custom Cert—To use custom certificates formutual authentication. If you want to use custom

certificates, ensure that the CA and Server certificates are uploaded to the certificate inventory on
Aruba Central. Formore information, see Certificates on page 24.

6. Click Advanced and configure the following parameters as per your requirements:
n If you want to bring down the IPsec tunnel when the peer routes are lost on the LAN interface of the

VPN Concentrator, select the LAN health check checkbox.

n To apply a route ACL to the IPsec session, select an ACL from theRoute ACL drop-down.

n To apply a session ACL, select an ACL from the Session ACL drop-down.

n If you want to assign overlapping uplink IP addresses across the branches, enable theUplink IP
addresses overlap across branches and then enter the IP address range configured for the
branch pool.

7. Click Save Changes.

Advertising Branch Subnets to Hub Sites
Aruba recommends that you configure Branch Gateways to advertise branch networks to the hub sites in
which the VPN Concentrators are deployed. When this feature is enabled, Aruba devices use IKEv2
extensions to dynamically learn branch routes without the need for static routes configuration. The learned
IKEv2 routes are typically redistributed to neighboring routers through OSPF or BGP.

To advertise branch subnets, complete the following steps:

1. In theNetwork Operations app, select a group in which VPN Concentrators are provisioned.
The dashboard context for a group is displayed.

2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click theConfig icon.
The gateway group configuration page is displayed.

4. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

5. Click VPN > SD-WAN Overlay.

6. Ensure that theOverlay mode is set to Manual.
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7. Click + from theHubs table and add the following information:
n Primary VPNC—Enter theMAC address of the primary VPN Concentrator.

n Backup VPNC—If you have a backup VPN Concentrator deployed at your site, enter theMAC
address of the backup VPN Concentrator.

n Source VLAN—If you havemore than one VPN Concentrator, enter the VLAN of WAN uplink
VLAN interface of the Branch Gateway on which the VPN tunnelmust initiate.

8. Select any of the following encryptionmethods from the Encryption drop-down list:
n Factory Cert—To use the built-in TPM certificate formutual authentication.

n Custom Cert—To use custom certificates formutual authentication. If you want to use custom
certificates, ensure that the CA and Server certificates are uploaded to the certificate inventory on
Aruba Central. Formore information, see Certificates on page 24.

9. If required, advertise branch VLANs to all hubs.

10. Click Save Settings.

11. Click VPN > SD-WAN Overlay.

12. To advertise branch subnets to all hubs:

a. Turn on theAdvertise branch VLANs to all hubs toggle switch.

b. Select the VLANs to advertise. Ensure that you select only those VLANs that are required for device
communication through the overlay network. For example, management or user VLAN.

13. To advertise a set of VLANs to a specific VPN Concentrator on the hub site, enter a list of VLANs in the
VLANs Advertised to this Hub field in theHubs table.

14. To optimize the number of routes advertised to the VPN Concentrators on the hub site, turn on the
Summarize routes toggle switch.

15. Click Save Settings.

Monitoring VPN Tunnels
Tomonitor the VPN Tunnel status, complete the following steps:

1. In theNetwork Operations app, select the Gateway for which you want to monitor the tunnels.

2. UnderManage, click Overview > Tunnel.

Configuring the SD-WAN Hub Mesh Topology
The Aruba SD-Branch solution supports the hubmesh topology that uses overlay tunnels to connect a hub
site with one ormore hub sites and build an SD-WANmesh topology. A hub site is a headquarter or data
center that includes one ormoreGateways operating as VPN Concentrators (VPNCs).

When amesh topology is configured between two ormore hub groups, mesh links are formed between the
VPNCs of selected hub groups creating an overlay network that securely transports traffic between the
VPNCs of selected hub groups. Thesemesh links are displayed in themaps view of Overlay Tunnel
Orchestrator. Formore information, see Route and Tunnel pages.

The SD-Branch deployment includes at least one hub group with one ormore VPNCs that terminate IPsec-
based VPN tunnels initiated from the Branch Gateways. Based on the deployment size and redundancy
requirements, you can deploy one ormore VPNCs at each hub group.

The following figure illustrates the hubmesh topology between two hub groups:



Aruba SD-WAN Solution | User Guide 210

Figure 70 Hub Mesh Topology

Configuration Recommendations
The Aruba SD-WAN hubmesh topology requires you to configuremesh topologies using the Aruba Central
management interface.

For optimal routing using hubmesh topology, it is strongly recommended to enable theDynamic Data
Center Path Computation. Formore information, see Configuring Overlay Network Using SD-
WAN Orchestrator.

Important Points to Note

n You can configure up to eight hub groups in amesh topology.

n A hub group can be configured in onemesh topology only.

Configuring Hub Mesh Topology
To configure a hubmesh topology for the SD-WAN overlay network, complete the following steps:

1. In theNetwork Operations app, set the filter to Global.

2. UnderManage, click Network Services > SD-WAN Overlay.

3. Click theConfig icon.
The configuration page is displayed.

4. Click theMesh tab.
TheHub Mesh Topology configuration page is displayed.

5. To add amesh topology, expand Hub Mesh and click +.
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6. Provide a name to the new topology in theHub Mesh Topology table, and click OK.
Themesh label for the newly addedmesh topology is displayed in theHub Mesh Topology
table.

7. Select the newly addedmesh topology and click the edit icon.

8. Select the groups to be included in theHubmesh topology.
You can add aminimumof two and amaximumof eight groups.

9. Click Apply.

10. To delete amesh topology, select the respectivemesh label in theHub Mesh Topology table and
click delete icon.

11. To confirm deletion, click Yes.

Figure 71 Configuring Hub Mesh Topology

Configuring Site-to-Site VPN
A site-to-site VPN allows the branch sites to establish secure connections with one another over a public
network, for example, the internet. A site-to-site VPN allows users fromdifferent locations to access
network resources hosted within the corporate network.

Figure 72 illustrates the site-to-site VPN topology in which a tunnel connects Network A to Network B across
the internet.

Figure 72 Site-to-Site VPN Configuration Components

As shown in Figure 72, the following parametersmust be configured to set up a site-to-site VPN tunnel on a
Branch Gateway A:
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n The source network (Network A)

n The destination network (Network B)

n The VLAN on which Branch Gateway A’s interface to the layer 3 network is located (Interface A in Figure 72)

n The peer gateway, which is the IP address of Branch Gateway B’s interface to the layer 3 network (Interface
B in Figure 72).

For the site-to-site VPN, youmust configure VPN settings on Branch Gateways deployed at both the
local and remote sites.

Site-to-site VPNs allow sites in different locations to securely communicatewith one another over a layer 3
network such as the internet.

Aruba Gateways support the following IKE SA authenticationmethods for site-to-site VPNs:

n Pre-shared key—The same IKE shared secret must be configured on both the local and remote sites. The
MAC address of the VPN Concentrator should be added as the peerMAC address in the Branch Gateway to
establish the IKE/IPsec tunnel with the VPN Concentrator.

n Suite-B cryptographic algorithms—Branch Gateways support Suite-B cryptographic algorithmswhen the
Advanced Cryptography license is installed.

n Digital certificates—You can configure an RSA or ECDSA server certificate and a CA certificate for each site-
to-site VPN IPsecmap configuration. If you use certificate-based authentication, the peermust be
identified by its certificate subject name, distinguished name (for deployments using IKEv2), or peer’s IP
address (for IKEv1).

Configuring IPsec Map for Site-to-Site VPNs
To configure IPsecmap parameters for a site-to-site VPN, complete the following steps:

1. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway.
The dashboard context for a group is displayed.

2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click a gateway underDevice Name.
The dashboard context for the gateway device is displayed.

4. UnderManage, Click Device.
The gateway configuration page is displayed.

5. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

6. Click VPN > Site to Site.

7. In the IPsec Maps section, click + to open theNew Ipsec Map section.

8. Configure the required parameters as described in Table 27.

9. Save the changes.
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Parameter Description

Name Enter a name for the VPN connection.

Enabled Select the check box.

Priority Enter a priority level for the IPsec map. Negotiation requests for security
associations try to match the highest-priority map first. If that map does not
match, the negotiation request continues down the list to the next highest-
priority map until a match is found.

Source network type Select one of the following options to identify the source, the local
VPN network connected to the Branch Gateway:

n IP Address—The source is identified by an IP address.
lSource network —If you selected IP Address, you must enter the IP
address of the source network.
lSource subnet mask—Enter the netmask for the source network.

n VLAN—The source is identified by a VLAN ID.
lVLAN—If you selected the VLAN ID for the source network type, you
must specify the VLAN ID from the drop-down list.

n Any—The source can be any network.

Destination network type Select one of the following options to identify the destination, the remote
network to which the local network communicates:

n IP Address—The destination is identified by an IP address.
lDestination network —If you selected IP Address, you must enter
the IP address of the destination network.
lDestination subnet mask—Enter the netmask for the destination
network.

n Any—The destination can be any network.

IKE version Select v1 to configure the VPN for IKEv1, or v2 for IKEv2. For more
information on configuring an IKE policy, see Configuring IKE Policies

IKE policy (Optional) Click the Policies drop-down list and select a predefined or
custom IKE policy to apply to the IPsec map.

Transforms Add one or more transform sets to be used by the IPsec map. Click + and
select an existing transform set or create a new one. Then click Apply to
add that transform set to the IPsec map.
If you selected Add new transform enter the follwoing details:

n Name—Enter a name for the transform.
n Encryption—Select the encryption level from the drop-down list.
n Hash—Select the hash key fromthe drop down list.

Remote peer addressing Select one of the following options: 
n Static—For site-to-site VPNs with peers that have static IP address.
n Dynamic—For site-to-site VPNs with dynamically addressed peers.

Peer gateway type The peer gateway type can be one of the following values:
n IP address—If you selected this option, then specify an IP address in
the Peer gateway IPv4 field.
n FQDN—If you selected this option then specify a value in the
Destination gateway FQDN field.

Destination gateway This field is applicable only if you selected Dynamic in the Remote peer
addressing field. Select one of the following options:

Table 27: IPsec Map Parameters
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Parameter Description

n Initiator—Select this if the dynamically addressed switch is the
initiator of IKE Aggressive-mode for site-to-site VPNs
n Responder— Select this option if the dynamically addressed switch is
the responder for IKE Aggressive-mode.

Source FQDN Enter an FQDN for the Branch Gateway if the Branch Gateway is defined as
a dynamically addressed responder,

n All Peers Select this option to make the Branch Gateway a responder
for all VPN peers.
n Per Peer Id Select this option to make the Branch Gateway a
responder for one specific initiator. Specify the FQDN id of the specific
initiator to which the Branch Gateway acts a responder

VLAN Select the VLAN containing the interface of the Branch Gateway that
connects to the layer 3 network. This determines the source IP address used
to initiate IKE. If you selected 0 or None, the default is the VLAN of the
Branch Gateway’s IP address .

NOTE: This field is not applicable if you have enabled Load balance.

Authentication method Select one of the following authentication options:
n PSK—Select this option for PSK authentication:
lRepresentation type—Select either Text-based or Hex-based.
lIKE shared secret—Enter a shared secret value. This authentication
type is generally required in IPsec maps for a VPN with dynamically
addressed peers, but can also be used for a static site-to-site VPN.
lRetype shared secret—Retype the shared secret value.

n Custom Certificate—Select this option for certificate authentication:
lServer certificate—For certificate authentication, select the server
certificates previously imported into the Branch Gateway
lCA certificate— Select the CA certificates previously imported into the
Branch Gateway.
lPeer certificate subject name—Enter the peer certificate subject
name.

Table 27: IPsec Map Parameters

Click Show Advanced Options to view the parameters listed in the following table:

Parameter Description

SA lifetime (seconds) The specified value (in seconds) defines the lifetime of the IPsec security asso-
ciation. The default value is 7200 seconds. The allowed range is 300–86,400
seconds.

SA lifetime (kb) The specified value (in kilobytes) defines the lifetime of the IPsec security
association. The allowed range is 1000–1,000,000,000 kilobytes.

Trusted tunnel Select the Trusted tunnel check box if the traffic between the networks is
trusted. If you do not select this, then the traffic between the networks is
untrusted.

Table 28: IPsec Map Parameters
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Parameter Description

Enforce NATT Select the check box to enforce UDP 4500 for IKE and IPsec. This option is
disabled by default.

Pre-connect Select the Pre-connect check box to establish the VPN connection, even if
there is no traffic being sent from the local network. If you do not select this,
the VPN connection is established only when traffic is sent from the local
network to the remote network.

IP compression This option appears only if you selected v2 as IKE version. IKEv2 site-to-site
VPNs between VPN Concentrators and Branch Gateways support traffic
compression between those devices. Set IP compression to Enabled to
enable compression for traffic in the site-to-site tunnel.
Enabling this feature reduces the size of data frames transmitted over a
site-to-site VPN between 7200 Series or 7000 Series controllers using IKEv2
authentication. IP compression can reduce the time required to transmit the
frame across the network. When this hardware-based compression feature
is enabled, the quality of unencrypted traffic (such as Lync or Voice traffic) is
not compromised by increased latency or decreased throughput. IP
compression is disabled by default.

This feature is only supported in an IPv4 network using IKEv2. This feature
cannot be enabled on a 7205controller or on a site-to-site VPN that is
established using IKEv1.

Factory certificate
authentication

Select the check box to enable the Factory certificate authentication.

NOTE: This option is applicable only if you selected v2 as IKE version.

Inbound Route ACL Select the inbound route ACL from the drop-down list.

NOTE: This option is applicable only if you selected v2 as IKE version.

PFS If you enable PFS mode, new session keys are not derived from previously
used session keys. Therefore, if a key is compromised, that compromised
key does not affect any previous session keys. PFS mode is disabled by
default. To enable this feature, click the PFS drop-down list and select one of
the following PFS modes:

n group1—768-bit Diffie–Hellman prime modulus group
n group2—1024-bit Diffie–Hellman prime modulus group
n group 14—2048-bit Diffie–Hellman prime modulus group
n group19—256-bit random Diffie–Hellman ECP modulus group
n group20—384-bit random Diffie–Hellman ECP modulus group

Force tunnel mode Select the check box to enforce tunnel mode. This option is disabled by
default.

Table 28: IPsec Map Parameters

Enabling Dead Peer Detection
DPD is enabled by default on the Branch Gateway for site-to-site VPNs. DPD, as described in RFC 3706, uses
IPsec traffic patterns to minimize the number of IKEmessages required to determine the liveliness of an IKE
peer.

Configuring Dead Peer Detection Parameters
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To enable Dead Peer Detection, complete the following steps:

1. In theNetwork Operations app, use the filter to select a group with branch gateways.

2. Go to Manage > Devices > Gateways, click the configuration icon. The gateway
configuration page is displayed.

3. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

4. Click VPN > DPD.

5. Click DPD toggle swithc to enable or disable the feature.

6. Enter the idle timeout, retry timeout, retry attempts, and Tunnel MTU in the respective fields.

7. Save the changes.

Configuring Site-to-Site VPN with GRE Tunnel
Site-to-site tunnel with GRE can be used to setup connections between Branch Gateways and their
Enterprise headend. In site-to-site tunnel configuration, the VPN traffic is encapsulated using before
entering the IPsec tunnels. Site-to-site tunnel configuration is required when VPN Concentrator at the data
center is a non-Aruba device.

To set up a site-to-site VPN with GRE tunnel, complete the following tasks:

1. Configure a site-to-site VPN—Formore information, see Configuring Site-to-Site VPN.

2. Configure GRE tunnel—Formore information, see Configuring Layer 2 GRE Tunnels and Configuring
Layer 3 GRE Tunnels.

3. Route the IPsec traffic into theGRE tunnel—Formore information, see Directing Traffic into theGRE
Tunnel.

Configuring GRE Tunnels
The headend gateway supports GRE tunnels between Branch Gateways and other network devices that
support GRE tunnels.

To configuring a site-to-site VPN with GRE Tunnel, complete the following tasks:

n Configuring Layer 2 GRE Tunnels

n Configuring Layer 3 GRE Tunnels

n Configuring Tunnel Keepalives

n GRE Tunnel Groups

n Directing Traffic into theGRE Tunnel

Configuring Layer 2 GRE Tunnels
The headend gateway supports GRE tunnels between Branch Gateways and other network devices that
support GRE tunnels.

Layer 2 GRE Tunnels
Layer 2 GRE tunnels allow you to have the same VLAN inmultiple locations (separated by a layer 3 network)
and be connected. The forwardingmethod for a layer 2 GRE tunnel is bridging.

However, the drawback of using layer 2 GRE tunnels is that all broadcasts are flooded through the tunnel,
adding traffic load to the network and the Branch Gateway.
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Configuring a Layer 2 GRE Tunnel
To configure a layer 2 GRE tunnel for a source Branch Gateway and destination Branch Gateway, complete
the following steps:

1. To configure a Branch Gateway group or a Branch Gateway for which you want to configure a layer 2
GRE tunnel, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. In the Interface tab, click + from theGRE Tunnel table to add aGRE tunnel. TheAdd GRE Tunnel
section is displayed.

4. Select the IP version as IPv4.

5. Specify a tunnel ID in the Tunnel ID field.

6. Select theMode as L2.

7. Specify the layer 2 protocol to be used on the tunnel in the Protocol field.

8. In theVlans field, specify the VLAN IDs of all the interfaces fromwhich the traffic to be encapsulated
originate.

9. To enableOpenFlow on the tunnel, select the Enable check box .

10. To make the tunnel interface as trusted, select the Trusted check box.

11. Specify theMTU size for the tunnel interface in theMTU field.

12. Select one of the following options as the local endpoint of the tunnel from the Tunnel Source
drop-down list based on your requirements:

n loopback—Select this option to set the loopback IP as your tunnel source.

n ipaddr—Select this option if you have a specific IP address as the tunnel source and specify the
IP address in the IP address field.

n system-ip—Select this option if your tunnel source is the IP address of the SD-WAN Gateway being
configured.

n vlan—Select this option if your tunnel source is a specific VLAN interface and specify the VLAN ID in
theVLAN field.

13. Specify the destination IP address of the tunnel in the Tunnel destination field.
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14. To enable tunnel keepalives, select Enable keepalive and configure the following Keepalive options:

a. Specify a value forHeartbeat interval (secs).
The default value is 10 seconds.

b. Specify a value for Heartbeat retries.
The default value is 3 retries.

Formore information on tunnel keepalive feature, see Configuring Layer 2 GRE Tunnels on
page 216

15. Save the changes

Configuring Layer 3 GRE Tunnels
The headend gateway supports GRE tunnels between Branch Gateways and other network devices that
support GRE tunnels.

Layer 3 GRE Tunnels
The benefit of layer 3 GRE tunnels is that broadcasts are not flooded through the tunnel, so there is less
wasted bandwidth and less load on the Branch Gateway. The forwardingmethod for a layer 3 GRE tunnel is
routing.

IPv6 encapsulated in IPv4 and IPv4 encapsulated in IPv6 are not supported. The only layer 3 GRE
modes supported are IPv4 encapsulated in IPv4 and IPv6 encapsulated in IPv6.

Configuring a Layer 3 GRE Tunnel
To configure a layer 3 GRE tunnel for a source Branch Gateway and destination Branch Gateway, complete
the following steps:

1. To configure a Branch Gateway group or Branch Gateway for which you want to configure a layer 3
GRE tunnel, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.
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3. In the Interface tab, click + from theGRE Tunnel table to add aGRE tunnel. TheAdd GRE Tunnel
section is displayed.

4. Select the IP version as IPv4.

5. Specify a tunnel ID in the Tunnel ID field.

6. Select theMode as L3.

7. Select the IPv4 address type as one of the following options based on your requirements:
n Dynamic—Select this option if you are configuring the tunnel ID for a device group. Then , select

the required tunnel pool from theDynamic IP address pool drop-down list. Formore information
on creating a tunnel pool, see Configuring Tunnel Pools for Aruba Gateways on page 158.

n Static—Select this option if you are configuring the tunnel ID for a specific Branch Gateway. Then,
enter the tunnel IP and the IP mask in the IP address and IP mask fields, respectively.

8. To enableOpenFlow on the tunnel, select the Enable check box .

9. To make the tunnel interface as trusted, select the Trusted check box.

10. Specify theMTU size for the tunnel interface in theMTU field.

11. Select one of the following options as the local end point of the tunnel from the Tunnel Source
drop-down list based on your requirements:
n loopback—Select this option to set the loopback IP as your tunnel source.

n ipaddr—Select this option if you have a specific IP address as the tunnel source and specify the
IP address in the IP address field.

n system-ip—Select this option if your tunnel source is the IP address of the SD-WAN Gateway being
configured.

n vlan—Select this option if your tunnel source is a specific VLAN interface and specify the VLAN ID in
theVLAN field.

12. Specify the destination IP address of the tunnel in the Tunnel destination field.

13. Select a route ACL name from theRoute ACL name drop-down list to attach a route ACL to the
inbound traffic on the L3 GRE tunnel interface.

14. To enable tunnel keepalives, select Enable keepalive and configure the following Keepalive options:

a. (Optional)To interoperatewith Cisco network devices, select theCisco compatible check box.

b. Specify a value forHeartbeat interval (secs).
The default value is 10 seconds.

c. Specify a value for Heartbeat retries.
The default value is 3 retries.

Formore information on tunnel keepalive feature, see Configuring Layer 3 GRE Tunnels on
page 218

15. To enableOSPF on the tunnel, select Enable OSPF and configure the following options:
n Area network (eg. 0.0.0.0)—Enter the IP address of theOSPF area.

n Authentication—If you want to authenticate OSPF neighbors for secure exchange of routing
information, turn on theAuthentication toggle switch. By default, theMD5 authentication
method is used. Enter theMessage Digest key and password.

n Cost—Enter a value for cost. By default, the cost value is set to 1.
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n Dead Interval—Enter a dead time interval to enable devices to determine if a participating router is
dead. If the hello packets are not received by a neighboring router for a given duration, the router is
declared as dead after the dead time interval is elapsed. The default dead time interval is 40 seconds.

n Hello Interval—Specify the interval for exchanging hello packets with the neighboring devices. The
default value is 10 seconds.

n Priority—Specify a number to indicate a priority level for the routes transmitted from the tunnel
interface. The default value is 1.

n Retransmit Interval—Specify a time interval for retransmitting LSAs. The default value is 5
seconds.

n Transmit Delay—Specify a delay interval for retransmitting LSAs. The default value is 1.

16. Click Save Settings.

If a VLAN interface has IPv6 addresses configured, one of them is used as the tunnel source IPv6
address. If the selected IPv6 address is deleted from the VLAN interface, then the tunnel source
IP address is reconfigured with the next available IPv6 address.

Configuring Tunnel Keepalives
The headend gateway determines the status of a GRE tunnel by sending periodic keepalive frames on the
layer 2 or layer 3 GRE tunnel. When you enable tunnel keepalives and the keepalives fail repeatedly, the
tunnel is considered down.

If you configure a firewall policy rule to redirect traffic to the tunnel, traffic is not forwarded to the tunnel
until it is up. When the tunnel comes up or goes down, an SNMP trap and loggingmessage is generated. The
remote endpoint of the tunnel does not need to support the keepalivemechanism.

The headend gateway sends keepalive frames at 60-second intervals by default and retries keepalives up to
three times before the tunnel is considered down. You can change the default values of the intervals:

n For the interval, specify a value between 1 and 86400 seconds.
n For the retries, specify a value between 0 and 1024.
n To interoperatewith Cisco network devices, select theCisco compatible check box. This option is

applicable only for layer 3 GRE tunnels.

To configure keepalives (Heartbeats), complete the following steps:

1. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway.
The dashboard context for a group is displayed.

2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click a gateway underDevice Name.
The dashboard context for the gateway device is displayed.

4. UnderManage, Click Device.
The gateway configuration page is displayed.

5. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.
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6. To enable tunnel keepalives, select Enable keepalive and configure the following Keepalive options.

a. (Optional) To interoperatewith Cisco network devices, select theCisco compatible check box. This
option is not applicable for layer 2 GRE tunnels.

b. Specify a value forHeartbeat interval (secs).
The default value is 10 seconds.

7. Specify a value for Heartbeat retries.
The default value is 3 retries.

8. Click Save Settings.

GRE Tunnel Groups
Branch Gateways support redundancy of GRE tunnels for both layer 2 and layer 3 GRE tunnels. This feature
enables automatic redirection of the user traffic to a standby tunnel when the primary tunnel goes down.

A tunnel group is identified by a name or number. You can addmultiple tunnels to a tunnel group. The
order of the tunnels defined in the tunnel-group configuration specifies their standby precedence. The first
member of the tunnel-group is the primary tunnel.

A GRE tunnel group combines two tunnels created on a Branch Gateway, where one tunnel is active and the
other tunnel is the standby. Traffic forwarding can occur on the active tunnel, and the standby tunnel can
become active once the active tunnel is down. When the first tunnel fails, the second tunnel carries the
traffic. The third tunnel in the tunnel-group takes over if the second tunnel also fails. In themeantime, if the
first tunnel comes up, it becomes themost eligible standby tunnel.

You can also enable or disable preemption as part of the tunnel-group configuration. Preemption is enabled
by default. This preemptive-failover option automatically redirects the traffic whenever it detects an
active tunnel with a higher precedence in the tunnel group. When preemption is disabled, the traffic gets
redirected to a higher precedence tunnel only when the tunnel carrying the traffic fails.

When creating a tunnel group, remember the following points:

n When a tunnel is added to the tunnel group, the tunnel is used for data traffic only if it is the active tunnel
in the group.

n Standby tunnels do not carry any data traffic. However, all tunnels in the group continue to send and
receive keepalive packets.

n Only one type of tunnel can be placed into a tunnel group—either layer 2 or layer 3. That is, you cannot
have a tunnel group consisting of both layer 2 and layer 3 tunnels.

n The default value of tunnel group type is layer 3.

n All tunnels in a layer 2 tunnel groupmust be tunneling the same VLAN.

n A layer 2 tunnel can only be part of one tunnel group.

n The Branch Gateway layer 2 tunnel-group is not interoperable with other vendors. Youmust set up layer 2
tunnel groups between Aruba devices only.

Configuring Tunnel Groups
To configure a layer 2 or layer 3 GRE tunnel group, complete the following steps:
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1. To configure a Branch Gateway group or a Branch Gateway complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. In the Interface tab, click + in the Tunnel Group table.

4. Specify a name for the tunnel group in the Tunnel Group Name field.

5. In the Tunnel Group Members text box, click + to add one ormore tunnel IDs.

6. Select the IDs and click OK.

7. To enable preemption, select the Enable Preemptive-Failover Mode check box. This option is
enabled by default.

8. In theMode section, identify the tunnel group type as a layer 2 or layer 3 group.

9. Click Save Settings.

Directing Traffic into the GRE Tunnel
You can direct traffic into a GRE tunnel by configuring a Static route, which directs traffic to the IP address of
the tunnel, or a firewall policy (session-based ACL), that redirects traffic to the specified tunnel ID.

Configuring Static Routes
You can configure a static route that specifies the IP address of a tunnel as the next hop for traffic for a
specific destination. See Configuring Static IP Routes on page 229 for detailed information on how to
configure a static route.

While redirecting traffic into a layer 3 GRE tunnel via a static route, be sure to use the tunnel IP address
of the source Branch Gateway as the next hop, instead of providing the tunnel IP address of the
destination Branch Gateway.

Configuring a Firewall Policy Rule
You can configure a firewall policy rule to redirect selected traffic into a GRE tunnel.

Traffic redirected by a firewall policy rule is not forwarded to a tunnel that is down (see, Configuring Tunnel
Keepalives on page 220, formore information on howGRE tunnel status is determined).
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To configure a firewall policy for directing traffic into a GRE tunnel using session based ACLs, see Creating a
Firewall Policy for Network Services on page 292.

1. Click Submit.

2. Click Pending Changes.

3. In the Pending Changes window, select the check box and click Deploy changes

Configuring IKE Policies
Branch Gateways support both IKEv1 and IKEv2 protocols to establish IPsec tunnels. Though both IKEv1
and IKEv2 support the same suite-B cryptographic algorithms, IKEv2 is a simpler, faster, andmore reliable
protocol than IKEv1.

This section covers the following topics:

n Configuring IKEv1 Policies and DynamicMaps

n Configuring IKEv2 Policies and DynamicMaps

Configuring IKEv1 Policies and Dynamic Maps
SD-WAN allows you to add or edit an existing IKEv1 policy or an IKEv1 dynamicmap that can be used for an
IPsec connection. Dynamicmaps enable IPsec SA negotiations fromdynamically addressed IPsec peers. You
can also define the authenticationmethod and server addresses on the Branch Gateway.

The IKE policy selections, along with any preshared key, must be reflected in the VPN client
configuration. When using a third-party VPN client, set the VPN configuration on clients to match the
choices made above.

Use the following procedure to configure the authenticationmethod, IKEv1 policies and dynamic IPsec
maps on the Branch Gateway:

1. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway.
The dashboard context for a group is displayed.

2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click theConfig icon.
The gateway group configuration page is displayed.

4. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

5. Click VPN >IKEv1.

6. To configure the authenticationmethod, enable the required option:

a. To enable L2TP, select L2TP.

b. To enable XAuth, select XAuth.

7. Select an authenticationmethod for IKEv1 clients. Currently, supportedmethods include:
n PAP
n EAP
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n CHAP
n MSCHAP
n MSCHAPv2

8. In the IKEv1 Policies table, click an existing policy to edit it, or click + to open theAdd IKEv1 Policy
section. Configure the required parameters as described in Table 29.

Parameter Description

Priority Specify the priority number for this policy. Set the value to 1 for the
configuration to take priority over the default setting.

Enable policy Select the check box to enable the IKEv1 policy when it is saved.

Encryption select one of the following encryption types:
n DES
n 3DES
n AES128
n AES192
n AES256

Hash algorithm select one of the following hash types:
n MD5
n SHA
n SHA1-96
n SHA2-256-128
n SHA2-384-192

Authentication Select one of the following authentication types for the IKE rule:
n Pre-Share
n RSA (for clients using certificates)
n ECDSA-256 (for clients using certificates)
n ECDSA-384 (for clients using certificates)

Diffie-Hellman group Diffie-Hellman is a key agreement algorithm that allows two parties to
agree upon a shared secret, and is used within IKE to securely
establish session keys. To set the Diffie–Hellman Group for the
ISAKMP policy, select one of the following options:

n Group 1: 768-bit Diffie–Hellman prime modulus group
n Group 2: 1024-bit Diffie–Hellman prime modulus group
n Group 14: 2048-bit Diffie–Hellman prime modulus group
n Group 19: 256-bit random Diffie–Hellman ECP modulus group
n Group 20: 384-bit random Diffie–Hellman ECP modulus group

Lifetime Set the lifetime of the IKE security association in seconds. The
supported range is 300-86400 seconds. The default value is 7200
seconds.

Table 29: IKEv1 Policy Parameters

9. In IKEv1 IPSec Dynamic Maps, click an existing dynamicmap to edit it or click + to open theAdd
IKEv1 Dynamic Map section. Configure the required parameters as described in Table 30
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Parameter Description

Priority Set the priority level for the IPsec map. Negotiation requests for
security associations try to match the highest-priority map first. If that
map does not match, the negotiation request continues down the list to
the next highest-priority map until a match is found.

Name Enter a name for the dynamic map.

Dynamic map Select the check box to enable the dynamic map. This is enabled by
default.

PFS group (Optional) Configure PFS settings for the dynamic peer by assigning a
Diffie-Hellman prime modulus group. PFS group provides an additional
level of security by ensuring that the IPsec SA key was not derived from
any other key, and therefore, cannot be compromised if another key is
broken. Select one of the following groups:

n Group 1: 768-bit Diffie–Hellman prime modulus group
n Group 2: 1024-bit Diffie–Hellman prime modulus group
n Group 14: 2048-bit Diffie–Hellman prime modulus group
n Group 19: 256-bit random Diffie–Hellman ECP modulus group
n Group 20: 384-bit random Diffie–Hellman ECP modulus group

Transforms Click + to open the New Transform section.
1. To add an existing transform, select Add existing transform
2. Select a transform from the list.
3. Click Save Settings.
4. To add a new transform, select Add new transform.
5. From the Encryption drop-down list, select one of the following
encryption types:
lDES
l3DES
lAES128
lAES192
lAES256

6. From the Hash algorithm drop-down list, select one of the
following hash types:
lMD5
lSHA
lSHA1-96
lSHA2-256-128
lSHA2-384-192

7. Click Save Settings.

Lifetime(seconds) Set the lifetime of the security association for the dynamic peer in
seconds. The supported range is 300-86400 seconds. The default value
is 7200 seconds.

Lifetime(kilobytes) Set the lifetime of the security association for the dynamic peer in
kilobytes

Table 30: IKEv1 Dynamic IPsec Map Parameters

10. Save the changes.

Configuring IKEv2 Policies and Dynamic Maps
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To configure the EAP passthrough, IKEv2 policies, and dynamic IPsecmaps on the Branch Gateway,
complete the following steps:

1. To configure a Branch Gateway group:
n In theNetwork Operations app, use the filter to select Groups.

n UnderManage, click Devices > Gateways, click the settings icon. The gateway
configuration page is displayed.

2. Click VPN >IKEv2.

3. In EAP passthrough, select the EAP passthrough for IKEv2 clients. The currently supportedmethods
include:
n EAP-TLS

n EAP-PEAP

n EAP-MSCHAPv2

4. In the IKEv2 Policies table, click an existing policy to edit it, or click + to open theAdd IKEv2 Policy
section. Configure the required parameters as described in Table 31.

Parameter Description

Priority Specify the priority number for this policy. Set the value to 1 for the
configuration to take priority over the default setting.

Enable policy Select the check box to enable the IKEv1 policy when it is saved.

Encryption Select one of the following encryption types:
n DES
n 3DES
n AES128
n AES192
n AES256

Hash algorithm Select one of the following hash types:
n MD5
n SHA
n SHA1-96
n SHA2-256-128
n SHA2-384-192

Authentication Select one of the following authentication types for the IKE rule:
n Pre-Share (for IKEv1 clients using pre-shared keys)
n RSA (for clients using certificates)
n ECDSA-256 (for clients using certificates)
n ECDSA-384 (for clients using certificates)

Diffie-Hellman group Diffie-Hellman is a key agreement algorithm that allows two parties to
agree upon a shared secret, and is used within IKE to securely
establish session keys. To set the Diffie–Hellman Group for the
ISAKMP policy, select one of the following options:

n Group 1: 768-bit Diffie–Hellman prime modulus group

Table 31: IKEv2 Policy Parameters
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Parameter Description

n Group 2: 1024-bit Diffie–Hellman prime modulus group
n Group 14: 2048-bit Diffie–Hellman prime modulus group
n Group 19: 256-bit random Diffie–Hellman ECP modulus group
n Group 20: 384-bit random Diffie–Hellman ECP modulus group

PRF This algorithm is an HMAC function used to hash certain values
during the key exchange. Set this to one of the following values based
on the value selected for Hash algorithm:

n PRF-HMAC-MD5
n PRF-HMAC-SHA1
n PRF-HMAC-SHA256
n PRF-HMAC-SHA384

Lifetime Set the lifetime of the IKE security association in seconds. The
supported range is 300-86400 seconds. The default value is 7200
seconds.

Table 31: IKEv2 Policy Parameters

5. In IKEv2 IPSec Dynamic Maps, click an existing dynamicmap to edit it or click + to open theAdd
IKEv2 Dynamic Map section. Configure the required parameters as described in Table 32.

Parameter Description

Priority Set the priority level for the IPsec map. Negotiation requests for
security associations try to match the highest-priority map first. If that
map does not match, the negotiation request continues down the list to
the next highest-priority map until a match is found.

Name Enter a name for the dynamic map.

Dynamic map Select the check box to enable the dynamic map. This is enabled by
default.

PFS group (Optional) Configure PFS settings for the dynamic peer by assigning a
Diffie-Hellman prime modulus group. PFS group provides an additional
level of security by ensuring that the IPsec SA key was not derived from
any other key, and therefore, cannot be compromised if another key is
broken. Select one of the following groups:

n Group 1: 768-bit Diffie–Hellman prime modulus group
n Group 2: 1024-bit Diffie–Hellman prime modulus group
n Group 14: 2048-bit Diffie–Hellman prime modulus group
n Group 19: 256-bit random Diffie–Hellman ECP modulus group
n Group 20: 384-bit random Diffie–Hellman ECP modulus group

Transforms Click + to open the New Transform section.
1. To add an existing transform, select Add existing transform
2. Select a transform from the list and save the changes.
3. To add a new transform, select Add new transform.
4. From the Encryption drop-down list, select one of the following
encryption types:
lDES

Table 32: IKEv2 Dynamic IPsec Map Parameters
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Parameter Description

l3DES
lAES128
lAES192
lAES256

5. From the Hash algorithm drop-down list, select one of the
following hash types:
lMD5
lSHA
lSHA1-96
lSHA2-256-128
lSHA2-384-192

6. Click Save Settings.

Lifetime(seconds) Set the lifetime of the security association for the dynamic peer in
seconds. The supported range is 300-86400 seconds. The default value
is 7200 seconds.

Lifetime(kilobytes) Set the lifetime of the security association for the dynamic peer in
kilobytes

Table 32: IKEv2 Dynamic IPsec Map Parameters

6. Save the changes

Routing
Aruba’s SD-Branch solution leveragesWAN services that interconnect hub and spoke sites to establish VPN
tunnels, which encapsulate and forward corporate traffic. EachWAN service is referred to as the underlay
network, while the VPN tunnels form the overlay network.

The Branch Gateway and VPN Concentrator in an SD-Branch network must have IPv4 routes to determine
how each devicemust reach Aruba Central and its VPN peers over any intermediate public or private IPv4
networks (underlay routes). Routes are also required to determinewhich internal networksmust be reached
by the Aruba Gateways through the overlay VPN tunnels (overlay routes).

Dynamic Routing
To enable interoperability with other systems in the network and provide flexible routing options, the Aruba
SD-Branch solution supports the following dynamic routing protocols:

n BGP—The BGP routing protocol allows exchanging routing information between the peers within or
between autonomous systems to determine the optimal paths for traffic flows. Network administrators
can configure Aruba Gateways to advertise routes to an upstream router in theMPLS provider network.
Formore information, see Example of a BGP Prefix List on page 247.

n OSPF—OSPF is a link state routing protocol that routes traffic information by sending Link-State
Advertisements (LSAs) to all other routers within a specific area. Depending on the deployment
architecture, network administrators can either implement static routes or leverage dynamic routing
through OSPF. Small deployments with single VPN Concentrator hub site can implement static routes, while
larger deployments withmultiple VPN Concentrator hub sites can be configured to useOSPF. Formore
information, see Example of a Prefix List on page 235.

Underlay Routing
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For establishing VPN tunnels, the VLAN interfaces on the Branch Gateways and VPN Concentratorsmust be
reachable over eachWAN service. To provide IP reachability through eachWAN service, a combination of
default gateways and static routes are required.

Based on the type of WAN service, you can configure different types of routes:

n Internet WAN Services—Requires default gateways to be defined on both Branch Gateways and
VPN Concentrators. The default routes aremanually configured on VPN Concentrators and dynamically
learned by Branch Gateways from the ISP through DHCP or PPPoE.

n MPLS/PrivateWAN Services—Requires static default routes on Branch Gateways and static routes on VPN
concentrators. These routesmust bemanually configured Branch Gateways and VPN Concentrators. A
default gateway is required on each Branch Gateway forMPLS networks. The default gateway must be
defined with a cost of 15 or higher.

For deployments withmultiple Internet WAN services, Branch Gateways load-balance or steer sessions out
of the respective Internet WAN uplinks based on the configured DPS and PBR policies. VPN Concentrators
typically implement a single default route and leverage the stateful packet inspection firewall to tag each
VPN tunnel to the correct VLAN interface.

Overlay Routing
To simplify overlay routing and provide scalability, the Aruba Gateways support a combination of dynamic
and static route configuration:

n Branch Gateways can be configured with static routes to determine that the destination networks are
reachable through the VPN tunnels. One static route is defined per VPN Concentrator peer for eachWAN
uplink.

n Branch Gateways can be configured to advertise internal LAN networks to each L2 active VPN
Concentrator peer using Aruba IKEv2 extensions. Each advertised LAN is installed as an IKEv2 route on
each L2 active VPN Concentrator (one route per activeWAN uplink).

n The VPN Concentrators participate in OSPF and BGP, and learn corporate routes fromneighboring routers
and redistribute IKEv2 overlay routes to the neighboring OSPF or BGP peers.

After the overlay routing has been configured between Branch Gateways and VPN Concentrators, firewalls
in the data center and corporate network will need to know how to reach branch networks that are behind
VPN Concentrators.

Routes Configuration on Aruba Gateways
See the following topics for information on how to configure routes:

n Configuring Static IP Routes on page 229

n Configuring Static Default Gateways on page 231

n Configuring Default Gateways for Dynamic Routing on page 231

n Example of a Prefix List on page 235

n Example of a BGP Prefix List

n Routes Advertisement Using RIPv2

n Advertising Overlay Routes

Configuring Static IP Routes
For overlay routing using static IP routes, ensure that you define static routes for each branch network and
data center as follows:
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n Define static routes for each branch network on the router in the data center.

n Define static routes for each branch network on the VPN Concentrator for each remote network, peer, and
link.

n Define static routes for each data center or a hub site for each Branch Gateway.

Static routing is not recommended for multiple VPN Concentrator hub deployments as additional
mechanisms such as IP SLA need to be implemented on routers to provide dynamic failover between
primary and secondary hub sites.

Creating a Static IP Route
To configure a static IP route, complete the following steps:

1. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway.
The dashboard context for a group is displayed.

2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click a gateway underDevice Name.
The dashboard context for the gateway device is displayed.

4. UnderManage, Click Device.
The gateway configuration page is displayed.

5. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

6. Click Routing > IP Routes.

7. Under IP Routes, click + to add a static route to a destination network or host.

8. Enter the IP address and netmask for theDestination IP address and Destination network
mask, respectively.

9. Configure a forwarding setting:

n Using Forwarding Router Address—Enter the next hop IP address in dotted decimal format
(A.B.C.D). You can also enter the distancemetric (cost) for this route. The cost prioritizes routing to
the destination. The lower the cost, the higher the priority.

n Using IPsec Tunnel to VPNC—Select the VPN Concentrator and the uplink to use. Select this
option for a Hub and Spoke VPN. Formore information, see Configuring the SD-WANOverlay
Network on page 202.

n Using Site-to-Site IPsec—Enter the IPsecmap name to use in a static IPsec routemap. Select this
option for a site-to-site VPN. Formore information, see Configuring Site-to-Site VPN on page 211.

n Using Null Interface—Select this option to designate a null interface.

10. Specify a value for theCost.

11. Enter a value forDistance. TheDistance parameter is used for prioritizing routes distributed by
various routing protocols. By default, the administrative distance for static routes is set to 1; that is,
static routes are prioritized over the routes distributed by dynamic routing protocols such as OSPF or
BGP. If a static route has the same administrative distance as a dynamic route, the static routes take
precedence. The allowed range of values is 1–255.

12. Click Save Settings.
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Configuring Static Default Gateways
Static default gateways are required for all deployments implementing Internet basedWAN services. The
default gateway is statically defined on VPN Concentrators and dynamically derived on the Branch
Gateways from the Internet Service Provider (ISP) through DHCP or PPPoE. A static default gateway is also
required on Branch Gateways connecting to anMPLSWAN or privateWAN services.

Aruba recommends that you configure static default gateways at the device level, because default gateways
are typically unique to each Branch Gateway. However, if the devices in a deployment share a common
gateway, you can configure default gateways at the group level.

To configure default gateways for routing, complete the following steps:

1. In theNetwork Operations app, set the filter to a group that contains the VPN Concentrator.

2. The dashboard context for a group is displayed.

3. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

4. Click a gateway underDevice Name.
The dashboard context for the gateway device is displayed.

5. UnderManage, Click Device.
The gateway configuration page is displayed.

6. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

7. Click Routing > IP Routes.

8. Under Static Default Gateway, click + to add a new default gateway.

9. Select Ipv4 from the IP version drop-down list.

10. To use a default gateway IP, select theDefault Gateway IP option and enter the default gateway IP
address.

11. To use an IPsecmap, select the IPsec Map option and select the IPsecmap.

12. In theUplink field, click the edit icon to open theAvailable/Selected Uplinks window to add or
remove available uplinks.

13. Enter a value for Cost.

14. Click Save Settings.

Configuring Default Gateways for Dynamic Routing
The default gateway is statically defined on VPN Concentrators and dynamically derived on the Branch
Gateways from the ISP through DHCP or PPPoE.

The default gateways that are dynamically derived through DHCP, Cellular link, or PPPoE are installed in the
route table with a default cost of 10. If a deployment includes Branch Gateways withmultiple internet
basedWAN services that implement both dynamic and static addressing, Aruba recommends that you
define static default gateways at a cost equal to the dynamically learned default gateways, so that both
default gateways can be installed in the routing table on Branch Gateways.

To configure dynamic default gateways on Branch Gateways:

1. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway.
The dashboard context for a group is displayed.
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2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click a gateway underDevice Name.
The dashboard context for the gateway device is displayed.

4. UnderManage, Click Device.
The gateway configuration page is displayed.

5. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

6. Click Routing > IP Routes.

7. Expand Dynamic Default Gateway.

8. To configure the server type fromwhich Branch Gateways can learn the default gateways, select
DHCP, PPPoE, or Cellular.

9. Specify the cost for each server type you selected. The Branch Gateway first tries to obtain a gateway
IP address using the option with the least cost. If the Branch Gateway is unable to obtain a gateway
IP address, it tries to obtain a gateway IP address using the option with the next lowest path cost.

10. Click Save Settings.

Routes Advertisement Using OSPF
Open Shortest Path First (OSPF) is a routing protocol used for distributing routing information to the
neighboring layer-3 devices. TheOSPF configuration allows advertising branch networks into an OSPF area
and also enables VPN Concentrators to learn corporate routes. OSPF simplifies routing, allows dynamic
exchange of branch and corporate routes between VPN Concentrators, and also provides the ability to
support failover to an available VPN hub site. Therefore, Aruba recommends that you useOSPF for routing
in large SD-Branch deployments withmultiple VPN hub sites.

OSPF Areas
OSPF operates within a single Autonomous System. An autonomous system consists of a network, or a
group of networks with a common administrative entity and routing policies. In OSPF deployments, a single
Autonomous System can be divided into smaller groups called areas. An OSPF area typically includes a set of
networks and hosts grouped together under a common subnet. Distributing routes using OSPF areas
reduces the number of link-state advertisements (LSA) and the size of the link state database that each
routermust maintain.

Aruba Gateways support advertising routes in the following OSPF areas:

n Normal Area—Allows advertising all routes to all the routers within the area.

n Stub Area—Allows routers to advertise only the default route.

n Not-So-Stubby Area (NSSA)—Allows external routes from the routing devices that belong to more than one
OSPF area; for example, Area Border Router (ABR).

Most deployments connect VPN Concentrators to normal OSPF areas either behind routers or firewalls in
the data center.

Best Practices for OSPF Configuration
Consider the following recommendations before configuring and enabling OSPF on VPN Concentrators:
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n You can use the loopback interface, any VLAN interface, or the Gateway Pool address as the system IP
address of the VPN Concentrator, and also use it as theOSPF router ID. Formore information on
configuring system IP address and loopback address, see Configuring System Information on Aruba
Gateways and Configuring System Information on ArubaGateways respectively.

n Ensure that the VPN Concentrator is not elected as a designated router in an OSPF area.

n If using IKEv2 overlay routes for redistribution, configure VPN Concentrator to redistribute IKEv2 overlay
routes at a specific cost. Ensure that the VPN Concentrators at the primary hub site are configured to
redistribute IKEv2 overlay routes at a lower cost than the VPN Concentrators at the secondary hub site.

Workflow for Configuring OSPF Routing on VPN Concentrators
Complete the following steps to configureOSPF on a VPN Concentrator:

n Enabling OSPF Configuration

n Configuring Route Redistribution Criteria

n Example of a Prefix List

n Configuring Administrative Distance on page 240

Enabling OSPF Configuration

To enableOSPF configuration on a VPN Concentrator, complete the following steps:

1. In theNetwork Operations app, set the filter to a group that contains the Branch Gateway that is
configured as a VPN Concentrator and on which you want to enableOSPF routing.

The dashboard context for a group is displayed.

2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click a gateway underDevice Name.
The dashboard context for the gateway device is displayed.

4. UnderManage, Click Device.
The gateway configuration page is displayed.

5. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

6. Click Routing > OSPF.The OSPF page opens.

7. Under General, turn on the Enable OSPF toggle switch.

8. To enable distribution of default information, select theDefault Information checkbox.

9. For Area ID, enter the configured router ID. Ensure that the router ID is the same as the IPv4 address
assigned to the loopback interface on the VPN Concentrator.

10. UnderArea, click + to add an OSPF area.

11. Enter the network address of theOSPF area.

12. Select any of following area types:

n Normal—To enable advertising of routes to all the routers in a backbone or regular areawithin an
Autonomous System.

n Stub—To advertise only the default routes. Stub areas do not propagate external routes and
replace external routes with the default routes. For Stub area, you can configure the default cost
and also disable or enable the link state advertisement.
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n NSSA—To allow external routes from the routing devices that belong to more than oneOSPF area;
for example, ABRs. For NSSA area, you can configure the default cost and enable distribution of the
default information. If required, you can also disable redistribution and link state summarization.

13. Click Save Settings.

Configuring a Prefix List

A prefix list allows routing systems to determinewhich routesmust be accepted when they peer with other
networks. A prefix list includes IP prefixes with amatch criteria that allows or denies route redistribution.
Prefix lists contain one ormore ordered entries which are processed sequentially.

Prefix lists can be used as amatch criteria for applying routemap rules on network subnets. For example, if
you want to prevent a route for 10.0.0.0/24 frombeing redistributed, you can define a rule to match the
prefix and add it a asmatch criterion in theOSPF redistribution routemap. Formore information, see
Configuring RouteMaps on page 235.

To create a prefix list, complete the following steps:

1. Configure an OSPF prefix list on a Branch Gateway or a Branch Gateway group.

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Click Routing > OSPF.

4. Click the + icon in the Prefix Rules table.

5. Enter a name for the prefix rule.

6. Enter a sequence number.

7. Define the action to performwhen the traffic matches the condition defined in the prefix rule.

8. Enter a network address to which you want to apply the prefix rule.

9. Enter the subnet mask of the network.

10. If you want to define a prefix length parameter and use it as amatch criteria for applying rules, enter
an appropriate value for the optional LE and GE operators. The allowed range of values is 1–32.

If the LE parameter is configured, the prefix rules are applied only if the subnets are equal to or
smaller than the value specified for LE. Similarly, if theGE parameter is configured, the prefix rules
are applied only if the subnets are equal to or greater than the value specified for GE. If either LE



Configuring an SD-Branch Network Using the Advanced Setup | 235

orGE parameter is not configured, the prefix rule is applied only to those subnets that match the
exact address or subnet mask configured in the rule.

11. Click Save Settings.

Example of a Prefix List

The following figure shows the prefix list configured for a VPN Concentrator in Aruba Central:

Figure 73 OSPF Prefix List

In the above example, the following prefix entries are processed sequentially based on the sequence
number configured for each entry.

n Thep1 prefix list entry permits advertising the exact prefix 91.0.0.0/8 by allowing 91.0.0.0 with the subnet
mask of 255.0.0.0.

n Thep4 prefix list entry prevents the exact prefix 16.1.1.0/24 frombeing advertised by denying 16.1.1.0
with the subnet mask of 255.255.255.0.

n Thep2 prefix list entry permits advertising the exact prefix 17.1.1.0/24 and all other prefixes within the
length of 32 bits. The LE parameter in the prefix list definesmaximumprefix length for rule application.

n Thep3 prefix list prevents all prefixes within 20.1.0.0/8 that are at least 16 bits in length frombeing
advertised. TheGE parameter in the prefix list defines theminimumprefix length for rule application.

Configuring Route Maps

Routemaps allow you to configure a filtering criteria by defining a set of rules ormatch statements with a
permit or deny condition. A routemap includes a series of match statements to determine if a route
matches the criteria defined in the statement and then applies the permit or deny rule accordingly. You can
also configure an additional set of parameters to adjust the attributes andmetrics for routes that match the
criteria defined in thematch statement.

The following list includes some of the important points to consider when configuring a routemap:

n A routemap includes name, sequence number, permit or deny rule, thematch and set statements.
Thematch statements determine the route or the traffic to which the rulemust be applied,
whereas the set statements allow you configure attributes or adjust metrics for the route that
matches the criteria defined in thematch statement.

n The routemap rules are applied sequentially; that is, based on the sequence number defined for
each entry.

n The routemap can use a prefix list in thematch statement to apply the allow or deny rule. For
more information on prefix lists, see Configuring a Prefix List on page 234.

To create a routingmap, complete the following steps:
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1. In theNetwork Operations app, set the filter to a group that contains the Branch Gateway that is
configured as a VPN Concentrator and on which you want to create a routemap.

The dashboard context for a group is displayed.

2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click a gateway underDevice Name.
The dashboard context for the gateway device is displayed.

4. UnderManage, Click Device.
The gateway configuration page is displayed.

5. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

6. Click Routing > OSPF.

7. To add a routemap, click the + icon in theRoute Maps table. TheCreate New Route Map panel is
displayed.

8. Configure the following parameters as per your network requirements:

Parameter Description

Name Enter a name for the route map.

Sequence
Number

Enter a sequence number for the route map. Sequence numbers allow route maps to be
processed in an order. If you are configuring multiple match clauses or statements, ensure that
you define a sequence number to uniquely identify eachmatch statement.

Action Configure an allow or deny rule for the match condition.

Match Configure the match condition for the routes that have a destination network. The match
statements define a set of conditions for determining if the route redistributionmust be allowed
or denied.
To add a match statement, click the + icon in the Match table. You can set match type to any of
the options listes here:

n IP address—If you have selected the IP address for match type, you can assign a prefix
list to a match statement. The match condition determines if the route advertisements from
the OSPF neighbor with the prefixes must be allowed or denied.
n Next-hop IP address—If you have selected the Next-hop IP address for match type,
you can assign a prefix list to a match statement. The match condition determines if the
route advertisements from the OSPF neighbor with the prefixes must be allowed or denied.
n Community—Community is applicable only for BGP routes.
n Interface VLAN—If you have selected Interface VLAN for match type, enter the
interface VLANS separated by comma. You can enter up to 10 Interface VLANs. The value
you enter must be between 1 to 4095. To know how to configure VLANs, see Configuring
VLANs on Aruba Gateways.
n OSPF route tag—If you have selected OSPF route tag for match type, a match tag
condition is added. You need to enter the tag names separated by comma. You can enter up
to 10 tags. At least one of these tags has to match to allow route redistribution. The value
you enter must be between 0 to 4294967295.

Set Configure a set of rules or attributes to apply to the OSPF traffic that matches the conditions
defined in a match statement.
To add a set attribute, click the + icon in the Set table and configure the following attributes as
per your requirement:

Table 33: Route Map Configuration Parameters
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Parameter Description

n as-path-prepend—Prepends AS numbers through which the packets have traversed.
You can apply the AS path prepending criteria to determine the best path.
lAS number— Enter any valid Autonomous System (AS) number between 1 to 65535.

n last-as—Prepends the last AS number to the AS path. The valid range of values is 1–10.
n Community is applicable only for BGP routes.
n ip next-hop—Sets a next-hop IPv4 address as an attribute in the routes.
n local-preference—Sets a preference value to the routes for determining the best AS
path. When the neighboring device receives multiple routes to the same destination
network, the route with the highest local preference value takes precedence. The valid
range of values for local preference is 0–4294967295.
n metric—Sets a metric value for determining the preferred path into an Autonomous
System. You can define a metric value between 0—4294967295. When a metric value in a
route matches this value, the route is advertised.
n origin—Sets the origin of the route. The following options are available:
lincomplete(EGP)—To specify that the route is originated from exterior routing protocol.
ligp—To specify that the route is originated from interior routing protocol.

n OSPF route tag—Sets the tag attribute of the route.
n OSPF route-type—Sets the external metric (E1 or E2) attribute of the route.

1. Click Save Settings.

Example of an OSPF Route Map

The following figure shows the routemaps configured for OSPF routes in Aruba Central:

Figure 74 OSPF Route Maps

Configuring Route Redistribution Criteria

To configure rules for redistributing routes to OSPF areas, complete the following steps:

1. In theNetwork Operations app, set the filter to a group that contains the Branch Gateway that is
configured as a VPN Concentrator and on which you want to configure a route distribution criteria.

The dashboard context for a group is displayed.

2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click a gateway underDevice Name.
The dashboard context for the gateway device is displayed.

4. UnderManage, Click Device.
The gateway configuration page is displayed.

5. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.
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6. Click Routing > OSPF.

7. Click Redistribution.

8. To add a redistribution rule, click + under theRedistribution Rules table and configure the
following parameters:

a. From the Source Protocol drop-down, select a source type:

n Static—To redistribute IP static routes.

n IKE Overlay—To redistribute branch routes advertised by the Branch Gateways after
establishing an IPsec tunnel with the VPN Concentrator at the hub site. By default, the VPN
Concentrators redistribute the IKEv2 overlay routes learnt fromBranch Gateways irrespective of
the route summarization status. Optionally, you can enable route summarization for IKE overlay
routes on the VPN Concentrators to avoid LSA flooding within an OSPF area.

n IAP-VPN—To redistribute routes that were received frommicro-branch deployments with
Instant APs.

n Connected—To redistribute routes received from the subnets that are directly connected to a
router’s interface at the hub site.

n SD-WAN Overlay—To redistribute routes learnt from the SD-WAN overlay network through the
Overlay Agent Protocol.

b. From theRoute Type drop-down, select an OSPF route type. Aruba Gateways support propagating
OSPF routes as External Type 1 (E1) and External Type 2 (E2) routes.

n E1—The External Type 1 applies both external cost to the destination and the cost to reach the
boundary router in an Autonomous System.

n E2—The External Type 2 type applies only the external cost to the destination.

c. Enter an appropriate value for Cost.

d. Optionally, you can select aRoute Map to associate to the routes.

e. Click Save Settings.

9. To summarize overlay routes before advertising, click the + icon in Overlay route summary table
and configure the following information:

a. Source Protocol—Select the source protocol of the overlay routes that you want to summarize.

b. Network—Enter the network IP address. For IKE overlay routes, ensure that the configured IP address
range includes all networks assigned to LAN VLAN interfaces of Branch Gateways.

c. Netmask—Enter the subnet mask.

d. Cost—Specify the cost.

e. Click Save Settings.

10. To exclude a subnet:

a. Click the + icon in the Excluded Subnet table.

b. Add the subnet and netmask.

c. Click Save Settings.
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Enabling OSPF Configuration on VLAN Interfaces

To enableOSPF configuration for a VLAN interface, complete the following steps:

1. Configure a VLAN interface on a Branch Gateway or a Branch Gateway group.

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Click Routing > OSPF. Then, click Interface Settings.

4. Click the + icon in the VLAN table.

5. Select the VLAN ID.

6. Enter the IP address of theOSPF area.

7. If you want to authenticate OSPF neighbors for secure exchange of routing information, turn on the
Authentication toggle switch. By default, MD5 authenticationmethod is used.

8. Enter theMessage Digest key and password.

9. Configure the following parameters as per your deployment requirements:

n Cost—Cost for theOSPF routes. By default, the cost value is set to 1.

n Dead Interval—Dead time interval to enable devices to determine if a participating router is dead.
If the hello packets are not received by a neighboring router for a given duration, the router is
declared as dead after the dead time interval is elapsed. The default dead time interval is 40
seconds.

n Hello Interval—Timer for exchanging hello packets on the VLAN interface. The default value is 10
seconds.

n Priority—Number indicating a priority level for routes transmitted from the interface. The default
value is 1.

n Retransmit Interval—Timer for retransmitting LSAs. The default value is 5 seconds.

n Transmit Delay—Delay interval for retransmission of LSAs. The default value is 1.

10. Click Save Settings.

Enabling OSPF on the Layer-3 GRE Tunnel Interface

Aruba SD-Branch supports site-to-site VPN tunnel configuration for interoperability with third-party
VPN Concentrators at the data center. For site-to-site tunnel configuration, you can enableOSPF on the
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Layer-3 GRE tunnel interface, so that theOSPF packets exchanged between the branch devices and the
VPN Concentrator are encapsulated using GRE before entering the IPsec tunnels.

To enableOSPF on the Layer-3 GRE tunnel interface, complete the following steps:

1. To configure a layer 3 GRE tunnel on a Branch Gateway group or a Branch Gateway, complete either
one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. Go to Interface > GRE Tunnel. Select a GRE tunnel. If there are no GRE tunnels configured, add a
newGRE tunnel.

3. Click + from theGRE Tunnel table to add aGRE tunnel. TheAdd GRE Tunnel section is displayed.

4. Ensure that the tunnelmode is set to L3.

5. Turn on the Enable OSPF toggle switch and configure the following parameters:

n Area network (eg. 0.0.0.0)—Enter the IP address of theOSPF area.

n Authentication—If you want to authenticate OSPF neighbors for secure exchange of routing
information, turn on theAuthentication toggle switch. By default, theMD5 authentication
method is used. Enter theMessage Digest key and password.

n Cost—Enter a value for cost. By default, the cost value is set to 1.

n Dead Interval—Enter a dead time interval to enable devices to determine if a participating router is
dead. If the hello packets are not received by a neighboring router for a given duration, the router is
declared as dead after the dead time interval is elapsed. The default dead time interval is 40 seconds.

n Hello Interval—Specify the interval for exchanging hello packets with the neighboring devices. The
default value is 10 seconds.

n Priority—Specify a number to indicate a priority level for the routes transmitted from the tunnel
interface. The default value is 1.

n Retransmit Interval—Specify a time interval for retransmitting LSAs. The default value is 5
seconds.

n Transmit Delay—Specify a delay interval for retransmitting LSAs. The default value is 1.

6. Click Save Settings.

Configuring Administrative Distance
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Administrative distance is one of themain criterion to determine a preferred routewhen there aremultiple
paths to the same destination. The routewith the a lower administrative distance takes precedence for
route redistribution.

To configure administrative distance for OSPF routes, complete the following steps:

1. Configure administrative distance for OSPF on a Branch Gateway or a Branch Gateway group.

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. UnderManage, click Device > Routing > OSPF.

4. Click Advanced.

5. Enter a value for distancewithin a range of 1–255. By default, the distance is set to 130.

6. Click Save Settings.

Viewing OSPF Configuration Status
To verify theOSPF configuration and route details, complete the following steps:

1. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway.
The dashboard context for a group is displayed.

2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click a gateway underDevice Name.
The dashboard context for the gateway device is displayed.

4. UnderManage, click Overview. TheGateway Details page is displayed.

5. Click Routing > OSPF. TheOSPF Summary page is displayed. TheOSPF summary page displays the
total number of OSPF areas configured on the device,

6. VLAN interfaces on which OSPF is enabled, OSPF neighbors, and active and retransmitted LSAs.

OSPF Areas
To view details of theOSPF areas, select Areas in theOSPF Details panel.
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Figure 75 OSPF Areas view

OSPF Neighbors
To view a list of OSPF neighbors, click Neighbors in theOSPF Details panel.

Figure 76 OSPF Details view

To viewmore information about theOSPF neighbor, click the neighbor entry in the table.

Figure 77 OSPF neighbor details view

OSPF Interfaces
To view the list of VLAN interfaces on which theOSPF configuration is enabled, click Interfaces in the
OSPF Details panel.
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OSPF Link State Database
To view the Link State Databasewith LSAs transmitted by theGateway, click Link State Database in
theOSPF Details panel.

Monitoring OSPF Routes
To view the route table, complete the following steps:

1. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway
that is configured as a VPN Concentrator.

The dashboard context for a group is displayed.

2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click a gateway underDevice Name.
The dashboard context for the gateway device is displayed.

4. UnderManage, click Overview. TheGateway Details page is displayed.

5. In theGateway monitoring dashboard, click Routing > Route Table. A list of routes advertised by
theGateway is displayed.

6. Sort the route table by theOSPF protocol to view theOSPF routes.

Figure 78 Routes Summary

Troubleshooting OSPF Configuration Issues
To troubleshoot OSPF configuration issues, complete the following steps:
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1. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway.
The dashboard context for a group is displayed.

2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click a gateway underDevice Name.
The dashboard context for the gateway device is displayed.

4. UnderAnalyze, click Tools. The Tools page for troubleshooting devices is displayed.

5. Click Commands.

6. From Category, select Networking.

7. From the command list, select theOSPF commands that you want to use. For example, show ip ospf
neighbor and show ip ospf database.

8. Click Run.

9. Verify the command output and resolve configuration errors if any.

10. Go to theGateway Details page. Verify the configuration status andmonitor OSPF routes. If the
issue persists, contact Aruba Technical Support.

Advertising Routes Using BGP
To support interoperability with an existing network infrastructure, Aruba SD-Branch solution supports the
BGP dynamic routing protocol to enable VPN Concentrators to redistribute overlay routes learned from
Branch Gateways into BGP and advertise those routes in the data center network.

BGP is a dynamic routing protocol used for exchanging routing information within and between
Autonomous Systems (AS). In a typical deployment, routers are configured to function as BGP peers or
neighbors, and exchange routing information after establishing a TCP connection. If BGP is used for routing
between two ASs, it is referred to as eBGP. Similarly, when BGP is used within an AS, it is referred to as iBGP.

When BGP support is enabled, Aruba Gateways function as BGP peers and advertise routes to their iBGP
and eBGP neighbors.

TheMultipath feature allows you to load balance the traffic acrossmultiple available links. When there are
multiple paths with the sameBGP path-selection attributes such as the origin code, MED, IGPmetric, AS
path and so on, they are considered formutipath nexthops.

This feature is currently available only for links within the same AS, that is between iBGP peers.
BGP support on Gateways is a limited availability feature. Contact your Aruba Sales Specialist to
enable BGP support for your SD-WAN deployments.

The SD-WANOrchestrator carries BGP attributes such as theOrigin, AS-Path, Community, Extended
Community, and Large Community. RouteMaps can be used to set filters and attributes for Overlay BGP
Redistributed routes.

The following are the guidelines for configuring BGP for Gateways:

n class="Bullet_1">If BGP routing is required between two different AS, ensure that you configure the
neighboring router in theMPLS network and the router at the data center as eBGP peers of Aruba
Gateways.
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n The loopback interface can be used as the system IP of the VPN Concentrator and also as the BGP router
ID. Ensure that you configure loopback interface on each VPN Concentrator. Formore information, see
Configuring System Information on ArubaGateways.

n Theminimum software version required for BGP configuration on ArubaGateways is ArubaOS 8.4.0.0-
1.0.5.0.

n There are various parameters to set a route preference. The following list provides a few of the preference
criteria for choosing the optimal route:

n Routewith the lowest administrative distance (routes with the lowest external distance and internal
distance to the boundary router)

n Routewith the highest value defined for the local preference attribute

n Routewith the lowest metric value (BGPMultiple Exit Discriminator (MED))

n Routes received from eBGP neighbors

Configuring BGP Routing on Aruba Gateways
The following steps are required on theGateway devices for BGP routing:

n Enabling BGP on page 245

n Configuring RouteMaps on page 248

n Configuring a Prefix List on page 246

n Adding BGP Neighbors on page 251

n Advertising Networks to BGP on page 253

n Configuring Redistribution Rules for BGP Routes on page 254

n Configuring BGP Timers on page 255

Enabling BGP

To enable BGP support on a Branch Gateway or a Branch Gateway group, complete the following steps:

1. In theNetwork Operations app, select one of the following options:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Click  Routing > BGP.
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4. If you want to enable BGP support on all devices provisioned in Aruba Central, click Enable BGP, and
enter theAutonomous System number.

5. Enter theRouter ID. The router ID is the IPv4 address of Gateway used for identifying it as the
router in an AS.

6. Click Save Settings.

Configuring a Prefix List

A prefix list allows routing systems to determinewhich routesmust be accepted when they peer with other
networks. It includes IP prefixes with amatch criteria that allows or denies route redistribution. It contains
one ormore ordered entries which are processed sequentially.

Prefix lists can be used as amatch criteria for applying routemap rules on network subnets. For example, if
you want to prevent a route for 10.0.0.0/24 frombeing redistributed, you can define a rule to match the
prefix and add it a asmatch criterion in the BGP redistribution routemap. Formore information, see
Configuring RouteMaps on page 248.

To create a prefix list:

1. In theNetwork Operations app, select one of the following options:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Click  Routing > BGP.

4. Click the + icon in the Prefix Rules table.

5. Enter a name for the prefix rule.

6. Enter a sequence number.

7. Define the action to performwhen the traffic matches the condition defined in the prefix rule.

8. Enter a network address to which you want to apply the prefix rule.

9. Enter the subnet mask of the network.

10. If you want to define a prefix length parameter and use it as amatch criteria for applying rules, enter
an appropriate value for the optional LE and GE operators. The allowed range of values is 1–32.

If the LE parameter is configured, the prefix rules are applied only if the subnets are equal to or
smaller than the value specified for LE. Similarly, if theGE parameter is configured, the prefix rules
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are applied only if the subnets are equal to or greater than the value specified for GE. If either the
LE orGE parameter is not configured, the prefix rule is applied only to those subnets that match
the exact address or subnet mask configured in the rule.

11. Click Save Settings.

Example of a BGP Prefix List

The following figure shows the prefix list configured for a VPN Concentrator in Aruba Central:

Figure 79 BGP Prefix List

In the above example, the following prefix entries are processed sequentially based on the sequence
number configured for each entry.

n Thep1 prefix list entry permits advertising the exact prefix 91.0.0.0/8 by allowing 91.0.0.0 with the subnet
mask of 255.0.0.0.

n Thep4 prefix list entry prevents the exact prefix 16.1.1.0/24 frombeing advertised by denying 16.1.1.0
with the subnet mask of 255.255.255.0.

n Thep2 prefix list entry permits advertising the exact prefix 17.1.1.0/24 and all other prefixes within the
length of 32 bits. The LE parameter in the prefix list definesmaximumprefix length for rule application.

n Thep3 prefix list prevents all prefixes within 20.1.0.0/8 that are at least 16 bits in length frombeing
advertised. TheGE parameter in the prefix list defines theminimumprefix length for rule application.

Configuring an IP Community List

The IP community list feature allows administrators to configure a set of community attributes to apply on
the BGP routes exchanged between ArubaGateways and their BGP peers. The community attribute allows
grouping routes with similar properties and is generally used for tagging routes andmodifying BGP routing
policies. The IP community list allows you to configure a community or an extended community, or groups
of both used for filtering ormodifying community values. You can attach a community to a routemap,
which can in turn be associated to a BGP neighbor profile.

To create a community list:

1. In theNetwork Operations app, select one of the following options:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.
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n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in Basic Mode, click Advanced Mode to access the advanced configuration options.

3. Click  Routing > BGP.

4. Click + in theCommunity-list rules table.

5. Enter a name for the community list.

6. Set a permit or allow rule as per your requirement.

7. If required, select a community value. The following attributes are available:

n Internet—Advertises the prefix to all BGP neighbors.

n No-Export—Does not advertise the prefix to any eBGP neighbor. It advertises the prefix only to
iBGP neighbors.

n No-Advertise—Does not advertise the prefix to any peer, iBGP or eBGP neighbor.

n Local-AS—Does not advertise the prefix outside of the local AS.

You can also enter a value for the following types of community strings and click + to add.

n as:nn—TheBGP community string in the AS:NN format, where AS refers to the Autonomous
Systemnumber and NN refers to the network number. The valid range of values is 0-65535.

n community-val—TheBGP community value string. The valid range of values is 1–4294967295.

You can specify one ormore community values. If the community list hasmore than one value,
the routemapmatches only those routes that have all the values defined in the list.

8. Click Save Settings.

The following figure shows the community list configuration options available on ArubaGateways:

Figure 80 BGP Community List

After you create the community list, associate it to a routemap. Formore information, see Configuring
RouteMaps on page 248.

Configuring Route Maps

Routemaps allow you to configure a filtering criteria by defining a set of rules ormatch statements with a
permit or deny condition. It includes a series of match statements to determine if a routematches the
criteria defined in the statement and then apply the permit or deny rule accordingly. You can also configure
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an additional set of parameters to adjust the attributes andmetrics for routes that match the criteria
defined in thematch statement.

The following list includes some of the important points to consider when configuring a routemap:

n A routemap includes name, sequence number, permit or deny rule, thematch and set statements. The
match statements determine the route or the traffic to which the rulemust be applied, whereas the set
statements allow you configure attributes or adjust metrics for the route that matches the criteria defined
in thematch statement.

n The routemap rules are applied sequentially; that is, based on the sequence number defined for each
entry.

n The routemap can use a prefix list in thematch statement to apply the allow or deny rule. Formore
information on prefix lists, see Configuring a Prefix List on page 246.

n Routemaps can be attached to the BGP neighbor profiles for the inbound and outbound routes. You can
associate routemaps for the inbound and outbound traffic when configuring a BGP neighbor profile.
When the routemap policy is applied to the inbound or outbound BGP route, and if the traffic matches the
specified criteria, the attribute set for thematch condition is applied. If you do not have a routemap
attached to an iBGP neighbor profile, the iBGP neighbor can access all inbound and outbound routes. For
more information on BGP neighbor profiles. see Adding BGP Neighbors on page 251.

Creating a Route Map

To create a routingmap:

1. In theNetwork Operations app, select one of the following options:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Click  Routing > BGP.

4. To add a routemap, click the + icon in theRoute Maps table. TheCreate New Route Map panel
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opens.

5. Configure the following parameters as per your network requirements:

Parameter Description

Name Enter a name for the route map.

Sequence
Number

Enter a sequence number for the route map. Sequence numbers allow route maps to be
executed in an order. If you are configuring multiple match clauses or statements,
ensure that you define a sequence number to uniquely identify eachmatch statement.

Action Configure an allow or deny rule for the match condition.

Match Configure the match condition for the routes that have a destination network. The match
statements define a set of conditions for determining if the route redistributionmust be
allowed or denied.
To add a match statement, click the + icon in the Match table. You can set match type to
IP address, next-hop IP address, an Interface VLAN, an OSPF route tag or a BGP
community string.
If you have selected the IP address or Next-hop IP address for match type, you can
assign a prefix list to a match statement. The match condition determines if the route
advertisements from the BGP neighbor with the prefixes must be allowed or denied.
If you have selected Community for match type, use one of the following options to
define the community string.

n as:nn—The BGP community string in the AS:NN format. The valid range of values
is 0-65535.
n community-val—The BGP community Value string. The valid range of values is 1–
4294967295. Allows you to specify a community value.
n well-known community—A well-known BGP community. Allows you to configure
one of the following options:
lInternet—Advertises subnets to all BGP neighbors.
lNo-Export—Does not advertise prefix to any eBGP neighbor.
lNo-Advertise—Does not advertise subnets to BGP neighbors.
lLocal-AS—Prevents sending packets outside the local AS.

n Community list—Allows you to select a community list configured on the
Gateway.

If you have selected Interface VLAN for match type, enter the interface VLANS
separated by comma. You can enter up to 10 Interface VLANs. The value you enter must
be between 1 to 4095. To know how to configure VLANs, see Configuring VLANs on
Aruba Gateways.
If you have selected OSPF route tag for match type, a match tag condition is added. You
need to enter the tag names separated by comma. You can enter up to 10 tags. At least
one of these tags has to match to allow route redistribution. The value you enter must be
between 0 to 4294967295.

Set Configure a set of rules or attributes to apply to the BGP traffic that matches the
conditions defined in a match statement.
To add a set attribute, click the + icon in the Set table and configure the following
attributes as per your requirement:

n as-path-prepend—Prepends AS numbers through which the packets have
traversed. You can apply the AS path prepending criteria to the BGP traffic to
determine the best path.
lAS number— Enter any valid AS number between 1 to 65535.

n last-as—Prepends the last AS number to the AS path. The valid range of values is
1–10.
n community—Sets a BGP community string as an attribute in the routes. BGP
community strings add additional information to the prefixes advertised to BGP

Table 34: Route Map Configuration Parameters
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Parameter Description

neighbors. You can set one of the following types of community string:
las:nn—The BGP community string in the AS:NN format. The valid range of values
is 0-65535.
lcommunity-val—The BGP community Value string. The valid range of values is 1–
4294967295.
lwell-known community—A well-known BGP community. You can configure one
of the following options:

lInternet—Advertises subnets to all BGP neighbors.
lNo-Export—Does not advertise prefix to any eBGP neighbor.
lNo-Advertise—Does not advertise subnets to BGP neighbors.
lLocal-AS—Prevents sending packets outside the local AS.

lCommunity list—Allows you to select a community list configured on the
Gateway.

n ip next-hop—Sets a next-hop IPv4 address as an attribute in the routes.
n local-preference—Sets a preference value to the routes for determining the best
AS path. When the iBGP neighbor receives multiple routes to the same destination
network, the route with the highest local preference value takes precedence. The
valid range of values for local preference is 0–4294967295. Local preference
configuration is recommended only for iBGP neighbors.
n metric—Sets a metric value for determining the preferred path into an AS. You
can define a metric value between 0—4294967295. When a metric value in a route
matches this value, the route is advertised. Metric configuration is recommended
only for eBGP peers.
n origin—Sets the origin of the route. The following options are available:
lIGP—To specify that the route is originated from interior routing protocol.
lIncomplete(EGP)—To specify that the route is originated from exterior routing
protocol.

n OSPF route tag—Sets the tag attribute of the route.
n OSPF route-type—Sets the external metric (E1 or E2) attribute of the route.

6. Click Save Settings.

Configuration Example

The following figure shows the routemaps configured for BGP routes in Aruba Central:

Figure 81 BGP Route Maps

Adding BGP Neighbors

To add a BGP neighbor profile for the Branch Gateway or a Group, complete the following steps:
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1. In theNetwork Operations app, select one of the following options:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Click  Routing > BGP.

4. Click the + icon in theNeighbors table.

5. In theCreate New Neighbor panel, configure the following parameters:

n Neighbor IP Address—Enter the IPv4 address of the peer router.

n Local Address—Select a VLAN. Ensure that the selected VLAN has a valid IP address assigned.

n Remote-AS—Enter the number of the AS to which the peer router belongs.

n Multi-hop—Select this checkbox if you want the gateway to route packets to its remote BGP peer
that ismore than one hop away.

n Route Map In and Route Map Out—If you have created routemaps for filtering inbound and
outbound BGP routes, select a routemap. Ensure that the same routemaps are not used for
inbound and outbound BGP routes.

n Allow AS in—If you are configuring an eBGP peer, select this checkbox to allow seamless exchange
of routing information between two branches that have the sameAS number.

For example, in some deployments, two branch routers at different locations that are
configured as eBGP peersmay share the sameAS number. When the branch routes are
exchanged between these routers, the packetsmay get dropped by default, as they share the
sameAS number. When the allow AS in option is enabled, eBGP peers can exchange the
routing information.

n Next hop self—Select this check box to enable an iBGP peer to use an external eBGP peer as the
next hop when routing packets to an external source. The BGP routemessages include the next-hop
information so that a router can forward packets to a particular destination. Thenext hop self
configuration is required when an iBGP peer of a router has an eBGP peer.

For example, Router1 is an iBGP peer for Router2, which in turn is an eBGP peer for another
router (Router3) in a remote AS. When the Router2 advertises a route learned fromRouter3
to Router1 through iBGP, it will use the original next hop address. As Router1 is an iBGP peer,
it will not have the route for the next hop. When thenext hop self feature is enabled on
Router2, it will set next hop address to the one (usually, the loopback address of the
Router3) that the Router1 (iBGP peer) can reach.



Configuring an SD-Branch Network Using the Advanced Setup | 253

n Passphrase and Retype Passphrase—If you want to enableMD5 authentication in BGP neighbor
profiles, assign a passphrase. Ensure that the passphrase length is within the 1–16 range. When BGP
MD5 authentication is enabled, any TCP segment belonging to BGP that is exchanged between the
peers is verified and accepted only if the authentication is successful. For authentication to be
successful, peer devicesmust have the same password in their respective BGP profiles. If
authentication fails, the BGP peers cannot exchange or advertise routes to each other.

n Max-prefix limit—You can configure a prefix limit to take action on the BGP prefixes when the
number of prefixes exceeds the configured value. The default value is zero. When the number of
prefixes exceeds the limit, you can configure the action to be taken asDrop orWarning. The
default action isNone. If you select Drop, the BGP prefixes from the neighbor are dropped; if you
select Warning, a warningmessage is displayed in themonitoring dashboard while the gateway
continues to receive prefixes. When the number of prefixes exceeds the route limit, an alert is
generated and displayed in the gateway monitoring dashboard irrespective of the action configured.
The alert is cleared when the number of prefixes falls below the configured limit.

n Click Save Settings.

Advertising Networks to BGP

To advertise a network to BGP, youmust configure a network statement with the network address and
subnet mask details. To configure a network statement:

1. In theNetwork Operations app, select one of the following options:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Click  Routing > BGP.

4. To add a network, click + in theAdvertise Network table.

5. Enter the network IP address and subnet mask.

6. Click Save Settings.

Aggregating Routes

For dynamic route summarization and faster calculation of best routing paths, you can configure a route
aggregation criteria. The route aggregation feature summarizesmultiple routes into a single route
advertisement, and thus helps in reducing the number of routing tables exchanged between BGP peers.

To configure a route aggregation criteria on the Branch Gateway or a Group, complete the following steps:
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1. In theNetwork Operations app, select one of the following options:|

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Click  Routing > BGP.

4. Then, click Advertise Networks.

5. UnderAggregate Routes, configure the following parameters:

n Address—Enter a network IP address.

n Mask—Enter the subnet mask.

n Route Map—Select a routemap. This routemap can be used only to set attributes of the aggregate
route. Formore information on routemaps, see Configuring RouteMaps.

6. Click Save Settings.

Configuring Redistribution Rules for BGP Routes

To configure redistribution rules for the Branch Gateway or a Group, complete the following steps:

1. In theNetwork Operations app, select one of the following options:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.
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2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Click  Routing > BGP. Then, click Redistribute.

4. To add a network, click the + icon in theRedistribution Rules table.

5. From the Source Protocol drop-down, select the type of routes to redistribute:

n Static—To redistribute the static routesmanually configured on Branch Gateways.

n OSPF—To redistribute the routes learnt from an OSPF neighbor.

n IKE Overlay—To redistribute branch routes advertised by Branch Gateways after establishing an
IPsec tunnel with the VPN Concentrator at the site. By default, the VPN Concentrators redistribute
the IKEv2 overlay routes learnt fromBranch Gateways irrespective of the route summarization
status.

n IAP-VPN—To redistribute routes that were received frommicro-branch deployments with Instant
AP

n Connected—To redistribute routes received from the subnets that are directly connected to a
router’s interface at the hub site.s.

n SD-WAN Overlay—To redistribute routes learnt from the SD-WAN overlay network through the
Overlay Agent Protocol.

6. Optionally, you can select a routemap to associate to the routes.

7. Click Save Settings.

Configuring BGP Timers

To configure BGP timers on Gateways, complete the following steps:

1. In theNetwork Operations app, select one of the following options:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Click  Routing > BGP. Then, click Advanced.

4. Define the time interval in seconds for the following BGP timers:

n Keepalive Timer—Allows you to set an interval for keeping a BGP session functional. The keepalive
timer enables BGP peers to exchange keepalivemessages at the specified interval in order to
determine if a link is available. The allowed range of values is between 0 to 65535. By default, the
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keepalive interval is set to 30 seconds.

n Hold Timer—Allows you to configure a duration for which Gateways can wait for a keepalive
message from its BGP peers. When Gateways do not receive a keepalivemessagewithin the
specified hold time, they stop advertising routes to the peer device and reset the routing session.
The allowed range of values is between 0 to 65535. By default, the hold time is set to 90 seconds.

Configuring Multipath Selection

Enablingmultipath allows you to load balance the traffic acrossmultiple available links. When there are
multiple paths with the sameBGP path-selection attributes such as the origin code, MED, IGPmetric, AS
path and so on, they are considered formutipath nexthops.

To configureMultipath Selection on Gateways, complete the following steps:

1. In theNetwork Operations app, select one of the following options:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Click  Routing > BGP> Advanced.

4. Select Enable multipath. Multipath is disabled by default.

This feature is currently available only for links within the same AS, that is between iBGP peers.

Configuring Graceful Restart

Graceful restart allows a devicewith a pending restart to inform the neighbors of the restart condition.
While undergoing a graceful restart, the device neighbors continue to forward packets without disrupting
network performance.

To configure Graceful Restart on Gateways, complete the following steps:

1. In theNetwork Operations app, select one of the following options:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.
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b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Click  Routing > BGP. Then, click Advanced.

4. Select Enable graceful restart. Enabling graceful restart on the gateway device allows it to
communicate the status to its neighboring devices . Graceful restart is disabled by default.

5. Set theGraceful restart timer. You can set the timer between 1 and 4095 seconds. By default, it is
set to 120 seconds. The BGP routes are active during the graceful restart period.

Configuring Administrative Distance

Administrative distance is one of themain criteria to determine a preferred routewhen there aremultiple
paths to the same destination. The routewith the lower administrative distance takes precedence for route
redistribution.

To configure administrative distance, complete the following steps:

1. Configure Graceful Restart either on a Branch Gateway or a Group.

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Click  Routing > BGP. Then, click Advanced.

4. Define a route preference value for External distance (eBGP) and Internal distance (iBGP)
routing within a range of 1–255.
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By default, the external distance is set to 110 and internal distance is set to 160 on Aruba
Gateways.

5. Click Save Settings.

Configuring BGP over an IPsec Tunnel

To enable BGP routing over an IPsec tunnel:

1. Configure a site-to-site tunnel between the devices that you want to configure as BGP peers.

2. Ensure that an IPsec tunnel is established between the devices.

3. Configure a BGP neighbor profile for eBGP peer on both devices and ensure that theMultihop
option is enabled in the BGP neighbor profile.

4. Configure a static IP route on Gateway to allow it to reach the neighbor devicewith next-hop using
the IPSecmap.

5. Ensure that similar steps are configured on both eBGP peers.

6. Verify that the BGP peers are exchanging routes over the tunnel interface.

Verifying the BGP Configuration
To verify the BGP configuration andmonitor BGP routes:

1. In theNetwork Operations app, set the filter to Global or a group containing at least one Branch
Gateway.

2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click a gateway underDevice Name.
The dashboard context for the specific gateway is displayed.

4. UnderManage, click Overview > Routing > BGP.
The BGPmonitoring dashboard is displayed.

BGP Summary

TheBGP summary section displays the total number of neighbors, routes that were learned, router ID, and
AS number details.

BGP Neighbors

To view a list of BGP neighbors, click Neighbors in theBGP Details panel.
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Figure 82 BGP Summary

To viewmore information about the BGP neighbor, click the neighbor entry in the table.

Figure 83 BGP neighbor information

BGP Routes

To view a list of routes advertised through BGP, click Routes in theBGP Details panel.

Figure 84 List of routes advertised

To view the details of a route, click the route entry in the table.
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Figure 85 Route details

Viewing Route Table with BGP Routes
To view the route table:

1. In theNetwork Operations app, set the filter to Global or a group containing at least one Branch
Gateway.

2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click a gateway underDevice Name.
The dashboard context for the specific gateway is displayed.

4. UnderManage, click Overview > Routing > Route Table. A complete list of routes advertised by
theGateway is displayed.

5. Sort route the table by the BGP protocol to view the BGP routes.

Figure 86 BGP routes

Formore information on themonitoring section, see Gateway > Overview > Routing.

Troubleshooting BGP Configuration Issues
To troubleshoot BGP configuration issues:
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1. In theNetwork Operations app, set the filter to Global or a group containing at least one Branch
Gateway.

2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click a gateway underDevice Name.
The dashboard context for the specific gateway is displayed.

4. UnderAnalyze, click Tools.

5. Click Commands.

6. From Category, select Network.

7. From the command list, select the BGP commands that you want to use. For example, show ip bgp
or show ip bgp neighbors.

8. Click Run.

9. Verify the command output and resolve configuration errors if any.

10. Go to Gateway Details page, verify the configuration status, andmonitor BGP routes. If the issue
persists, contact Aruba Technical Support.

Routes Advertisement Using RIPv2
Routing Information Protocol (RIPv2) is a distance vector Interior Gateway Protocol (IGP) that uses the hop
count metric for advertising subnets to the network. To support interoperability with an existing network
infrastructure, Aruba Gateways support advertising routes learned from the SD-WAN overlay network into
the data center network.

When RIPv2 support is enabled, Aruba Gateways function as peer devices and advertise routes to their RIP
neighbors.

The following is a list of best practices for configuring RIPv2 on ArubaGateways:

n The loopback interface can be used as the system IP of theGateway and also as the RIP router ID. Ensure
that you configure loopback interface on each Gateway. Formore information, see Configuring System
Information on ArubaGateways.

n Theminimum software version required for RIP configuration on ArubaGateways is ArubaOS 8.5.0.0-
2.0.0.0.

n There are various parameters to set a route preference. The following list provides a few of the preferred
criteria for choosing the optimal route:

Workflow for Configuring RIPv2 Routing on Gateways
TheRIPv2 tab in theGateway routing configuration page allows you to enable RIPv2 support on Gateways.
The following steps are required on theGateway devices for RIPv2 routing:

n Enabling RIPv2 on page 261

n Configuring RIPv2 on a VLAN Interface on page 262

n Configuring RIP Timers for All VLAN Interfaces on Gateways on page 263

n Configuring Infinity Value for RIP Routing on page 264

Enabling RIPv2

By default, RIP is disabled on Gateways. Youmust enable RIPv2 on the gateway for sending RIP
information.
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To enable RIPv2 support on Gateways, complete the following steps:

1. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway.
The dashboard context for a group is displayed.

2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click a gateway underDevice Name.
The dashboard context for the gateway device is displayed.

4. UnderManage, Click Device.
The gateway configuration page is displayed.

5. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

6. Click Routing > RIP.

7. To enable RIPv2, click General and turn on the Enable RIPv2 toggle switch.

8. Click Save Settings.

Configuring RIPv2 on a VLAN Interface

You can configure RIPv2 on a VLAN interface in theNetwork Operations app by either selecting an individual
Gateway or a group containing at least oneGateway.

To configure RIPv2 on a VLAN interface, complete the following steps:

1. To configure RIP v2 on a gateway or a gateway group, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Click Routing > RIP.

4. Expand Interface Settings. TheCreate New Interface page is displayed.

5. Click + in the VLAN table.

6. Select theVlan ID
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7. Enter a value forMetric. You can define ametric valuewithin the range of 1–255.
RIP uses hop count asmetric. The hop count refers to the number of routers that a packet can
traverse before reaching its destination. For example, if you set themetric value to 2, two hop
counts are used asmetric for distributing RIP routes from the VLAN interface.

A directly connected network has ametric of 1. By default, themetric value for RIP-enabled VLAN
interfaces is set to 1.

8. Select Passive to enable passivemode and to prevent the VLAN interface from transmitting packets.
When passivemode is enabled, the IP address of the VLAN interface is not advertised as an
external route. By default, passivemode is disabled.

9. Select Split-horizon to prevent the interface from advertising routes learned from the same
interface. When Split-horizon is enabled on a VLAN interface, the Gateway does not send the
RIP routes that were learned from the same interface and thus avoids routing loops.

10. Select Poison-reverse to instruct the VLAN interface to advertise learned routes on the same
interface. When Poison-reverse is enabled, ametric value of 16 is used for RIP routes.

11. Select one of the following options forAuthentication if you want to authenticate RIP neighbors
for secure exchange of routes, .

n Message-Digest—Configuresmessage digest key as a passphrase for authentication.

n Plain-Text—Configures a plain-text password for authentication.

12. Configure timers for routing RIP updates on the VLAN interface:

n Update timer—Determines how often RIP updates are sent over the VLAN interface. By default,
the update timer is set to 30 seconds. The accepted range of values is 1–31536000.

n Flush timer—Determines how long a route ismaintained in the RIP database after it is declared
invalid. Once the flush timer expires, the route is removed from the RIP database. By default, the
flush timer is set to 120 seconds. The accepted range of values is 1–31536000.

n Invalid timer—Determines the duration for declaring a RIP update as invalid. If a valid route
update is not received for a route for the specified duration, the route is declared invalid but is
maintained in the RIP database. By default, the invalid timer is set to 180 seconds. The accepted
range of values is 1–31536000.

13. Click Save Settings.

Configuring RIP Timers for All VLAN Interfaces on Gateways

To configure RIP timers on all VLAN interfaces on Gateways, complete the following steps:

1. To configure RIP v2 on a gateway device or a gateway group, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.



Aruba SD-WAN Solution | User Guide 264

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Click Routing >RIP, and then click Advanced.

4. Define the time interval in seconds for the following RIP timers:

n Update timer—Determines how often RIP updates are sent over the VLAN interfaces configured
on Gateways. By default, the update timer is set to 30 seconds. The accepted range of values is 1–
31536000.

n Flush timer—Determines how long a route ismaintained in the RIP database after it has been
declared invalid. Once the flush timer expires, the route is removed from the RIP database. By
default, the flush timer is set to 120 seconds. The accepted range of values is 1–31536000.

n Invalid timer—Determines the duration for declaring a RIP update as invalid. If the route is not for
the specified duration, the route is declared invalid but ismaintained in the RIP database. By default,
the invalid timer is set to 180 seconds. The accepted range of values is 1–31536000.

Configuring Administrative Distance

Administrative distance is one of themain criteria to determine a preferred routewhen there aremultiple
paths to the same destination learned fromdifferent routing protocols. The routewith the lower
administrative distance takes precedence for route redistribution.

To configure administrative distance, complete the following steps:

1. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway.
The dashboard context for a group is displayed.

2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click a gateway underDevice Name.
The dashboard context for the gateway device is displayed.

4. UnderManage, Click Device.
The gateway configuration page is displayed.

5. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

6. Click Routing > RIP, and then click Advanced.

7. Define a value forDistance. By default, the administrative distance value is set to 150.

8. Click Save Settings.

Configuring Infinity Value for RIP Routing

The infinity parameter defines themaximumnumber of next hops allowed for the RIP network. A RIP
network is usually no wider than 15 hops, and therefore, the infinity value is set to 16 by default.

To change the infinity value, complete the following steps:
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1. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway.
The dashboard context for a group is displayed.

2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click a gateway underDevice Name.
The dashboard context for the gateway device is displayed.

4. UnderManage, Click Device.
The gateway configuration page is displayed.

5. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

6. Click Routing > RIP, and then click Advanced.

7. Select a value for Infinity.

8. Click Save Settings.

Verifying RIP Configuration and Monitoring Routes
To verify RIP configuration andmonitor RIP routes, complete the following steps:

1. In theNetwork Operations app, set the filter to the group that contains the gateway on which RIP
routing is enabled.

The dashboard context for a group is displayed.

2. UnderManage > Devices, click theGateways tab.
A list of gateways is displayed in List view.

3. Click a gateway underDevice Name.
The dashboard context for the specific gateway is displayed.

4. UnderManage, click Overview > Routing > RIP.
TheRIP Summary page is displayed.

TheRIPsummary page displays the RIP version, interfaces on which RIP routing is enabled, the
total number of neighbors, routes, and infinity value.

TheRIP Details panel displays detailed information for RIP interfaces, neighbors, and routes.

Formore information, see Gateway > Overview > Routing.

Troubleshooting RIP Configuration Issues
To troubleshoot RIP configuration issues, complete the following steps:

1. In theNetwork Operations app, set the filter to Global to view the dashboard for all devices.

2. UnderAnalyze, click Tools.
The Tools page for troubleshooting devices is displayed.

3. Click Commands.

4. Set the device type to Gateway and select the gateway device you want to troubleshoot.

5. From theCategories drop-down list, select Network.
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6. From the command list, select the RIP commands that you want to use. For example, Show IP RIP,
Show IP RIP Interfaces or Show IP RIP neighbors.

7. Click Run.

8. Verify the command output and resolve configuration errors if any.

9. Go to theGateway monitoring dashboard, verify the configuration status, andmonitor RIP routes. If
the issue persists, contact Aruba Technical Support.

Configuring Policies for PBR
Formost SD-WAN deployments, Branch Gateways forward traffic through the overlay network or to the
Internet using destination-based routing. Each Branch Gateway includes static routes for the corporate
subnets that point to their respective VPN overlay tunnels as well as default gateways for eachWAN uplink.

However, for some deployments, youmay need to forward traffic from a subset of devices through a
specific VPN overlay tunnel or to a specific Internet WAN uplink. Alternatively, youmay require all traffic
(corporate and Internet) to be forwarded through the overlay VPN tunnels or force all traffic to be
forwarded locally using Policy Based Routing (PBR). A typical use case for PBR would be to force all traffic to
a specific VPN Concentrator or a tunnel endpoint.

PBR allows your network administrators to create policies formaking routing decisions. You can create a
PBR rule that can forward traffic as normal, or route traffic over a VPN tunnel specified by an IPsecmap. The
PBR rules can also route traffic to a next hop router on a next hop list, or redirect it over an L3 GRE tunnel or
tunnel group. PBR rules allow administrators to make use of all available uplinks.

PBR Policies for WAN Networks
In the SD Branch solution, the administrators can create PBR policies to configure preferred VPN traffic
routing paths for different types of traffic based on their source and destination IPs and ports.

To use PBR policies or rules onWAN networks, youmust configure the following features and parameters
on ArubaGateways:

n PBR next hop—The PBR next hop can be physical links such as the Ethernet or 3G/4G uplinks. The
administrators can also use logical links like site-to-site VPN tunnel.

n Route ACL—The administrators can define traffic match conditions and the next hop for the traffic in the
ACL.

n Attach Points—To apply the PBR rules, the administrators associate the ACL rules to a user role or VLAN.

After the next hop list is configured and attached to route ACL, the active IP address for the next hop is
selected based on the reachability and priority.

When the user traffic hits the route ACL, the following actions are applied:

n If PBR is disabled on the user-role or VLAN, traffic is directly sent to the routing block where the regular
routing takes place.

n If the PBR is enabled, the traffic is evaluated against the route ACL and the appropriate PBR next hop is
selected for routing.

n If traffic does not match any rule in route ACL, it is passed to the routingmodule for regular forwarding.

If Dynamic Path Steering selects an uplink that is not provided by PBR, the PBR forwarding path takes
precedence.

Configuring Policies for PBR
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To configure a policy for PBR on Branch Gateways, complete the following steps:

1. To configure a gateway group or a gateway device, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Click Routing > Policy-Based Routing.

4. Click + below the Policies table to create a new routing policy.

5. Enter name for the policy and save the changes.

6. Select the policy from the Policies table.

7. Click + to add ACL rules. Formore information on ACL rule configuration, see Configuring Access
Rules on page 293.

8. Save the changes.

9. Assign the policy to a user role or VLAN. Formore information, see Assigning PBR Policies to User
Role or VLAN on page 267.

Assigning PBR Policies to User Role or VLAN
To assign a PBR policy to a user role or a VLAN, complete the following steps:

1. To assign a policy to a user role, see Configuring User Roles for Clients on page 302.

2. To assign a policy to a VLAN, complete the following steps:

a. To configure a gateway group or a gateway device, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.
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n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

3. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

4. Click Interfaces > VLANs tab.

5. Select a VLAN from theVLANs table.

6. Select the VLAN ID to which you want to assign a routing policy from theVLAN IDs table.

7. Under the IPv4 tab, expand Other option.

8. Select a routing policy from the ACL drop-down list.

9. Save the changes.

Configuring Next Hop Lists for PBR
You can configure SD-WAN Gateway to use policy-based routing and forward packets to a next hop device.
With the next hop list, the administrators can ensure that when the next hop device becomes unreachable,
the packetsmatching the policy can still reach their destination.

To define a next hop list, complete the following steps:

1. To configure a gateway group or a gateway device, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Click Routing > NextHop Configuration.
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4. Click + to add a new next hop list and configure the following parameters:

5.

Parameter Description

NextHop-
list name

Name of the new next hop list.

NextHop
IP/DHCP

IP address of the next hop device or the VLAN ID of the VLAN used by the next hop device.
If the VLAN gets an IP address using DHCP and the default gateway is determined by the
VLAN interface, the gateway IP is used as the next hop IP address.
When you click + to define a next hop IP or DHCP value, a pop-up list with a field that
requires you to select either the IP or DHCP option is displayed.

n If you selected IP, enter the IP address and priority of the next hop device in the IP
and Priority fields, respectively.
n If you selected DHCP, enter the VLAN ID and priority of the next hop device in the
VLAN ID and Priority fields, respectively.

Priorities of next hops define which next hop should get a higher priority to carry the
session traffic. A higher number indicates a higher priority (1 – 255). If two next hops
have the same priority, they will be load-balanced.

IPsec name
map

A next hop list may require policy-based redirection of traffic to different VPN tunnels.
To add an IPsec name map, complete the following steps:

1. Click + from the IPsec name map table. The Add New IPsec Map pop-up is
displayed.
2. Select one of the following options from the Forward settings drop-down list
based on your requirement:
lUsing Site-to-Site IPSec—Select this option for a site-to-site VPN or Zscaler tunnel
and select the required IPsec map from the Using site-to-site IPSec drop-down list.
If uplink VLAN is configured for the selected IPsec map, then you can select the
required uplink from the Uplink field.

NOTE: The Uplink field does not appear for IPsec maps that are not configured with
uplink VLAN.

lUsing IPsec Tunnel to VPNC—Select this option for a Hub and Spoke VPN and
select the required MAC address and the uplink of the VPN Concentrator from the
Using IPSec tunnel to VPNC and Uplink options lists respectively. You can also
select None if you want to use Auto-VPN. For more information, see Configuring the
SD-WAN Overlay Network on page 202.

3. Enter the priority value for the forward setting in the Priority field.

NOTE: Use the same priority for different paths from the same SD-WAN Gateway but
different priorities for different Zscaler data centers.

4. Click OK.

Preemptive-
failover

If Preemptive-failover is disabled and the highest-priority device on the next hop list is
disabled, the new primary next hop device functions as the primary device even when the
original device comes back online.

NOTE: Ensure that Preemptive failover is enabled for Zscaler tunnels.

Figure 87 Next Hop Settings

6. Click Save Settings.

Configuring Policies for Dynamic Path Steering
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For a transport-independent SD-WAN fabric, the SD Branch devices form IPsec tunnels over all WAN circuits.
For your branch setup to work across asymmetric links, a path selection criteria is required to enable Branch
Gateways to dynamically choose an upstreampath in real-time. To enable Branch Gateways to dynamically
steer traffic to an upstreampath, you can createWAN policies with specific performance criteria for
different types of traffic, so that the best local uplink or optimal path (MPLS or the internet) is used for a
given traffic flow.

The dynamic path selection feature allows you to steer and route traffic in real-time and load-balance traffic
across available uplinks. For example, you can create policies that would route themost critical traffic, such
as voice traffic, through theMPLS network, while the rest of the traffic is load-balanced. You could also set
policies to route the voice traffic over uplinks with the least amount of packet loss, while the other types of
traffic can be routed to uplinks with the lowest latency.

For optimal use of uplink resources, you can configure path steering policies with specific match criteria to
choose an uplink. The uplink choice is driven by the parameters in the threshold profile, which include
latency, jitter, packet loss, and bandwidth utilizationmetrics.

How Dynamic Path Selection Works
A dynamic path steering policy serves as a global policy that determines paths for the outgoing corporate
and Internet traffic. The policy consists of the following configurable components:

n Rules—The policy includes a sequential list of rules for traffic steering.

n Service Level Agreements (SLAs) and Threshold Settings—Each of these rules can be configured
with specific threshold settings that are based on SLAs.

n WAN path preferences—The policy also allows you to set a path preference and enable load balancing of
sessions amongmultiple paths.

The status bar remains gray color when there is no data to display.

Example

The following example illustrates the path selection workflow:

1. A client device tries to connect to the network.

2. The authentication server authenticates the client, assigns the employee role, and then directs the
client to the SD-WAN Gateway.

3. The firewall classifies the session as Skype.

4. The routing for an employee using Skype states that the next-hop is a VPN Concentrator and that the
paths available areMPLS, INET1, and LTE

5. As Skype is classified asUCC, the policy categorizes it as voice traffic. The policy is configured to use
MPLS as the preferred path with an SLA criterion.

6. If the thresholdmetrics forMPLSmeet the SLA for the voice policy, the session goes through the
tunnel that is established using theMPLS uplink

7. If at any point in time themeasured SLA forMPLS drops, the SD-WAN Gateway steers traffic to
another active tunnel.

If none of the uplink groupmembers are compliant with the policies configured, the SD-WAN Gateway
chooses the best among the available uplinks.

Configuring a Dynamic Path Steering Policy
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TheDynamic Path Steering policy configuration procedure includes the following tasks

Ensure that you configure health check probe destinations and uplinks before configuring the dynamic
path steering policies.

1. Creating a Dynamic Path Steering Policy on page 271

2. Configuring Traffic Specification Rules on page 271

3. Configuring SLA Parameters on page 273

4. ConfiguringWAN Path on page 273

Creating a Dynamic Path Steering Policy
To create a dynamic path steering policy, complete the following steps:

1. To configure a Branch Gateway group or Branch Gateway for which you want to create a dynamic
path steering policy, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Click WAN > Dynamic Path Steering

4. To create a new policy, click +.

5. Enter the name of the policy.

6. Configure Traffic Specification Rules.

7. Click Save Settings.

8. Click Next.

9. Select SLA for the new policy. You can select an existing SLA or create a new one.

10. Select theWAN path for the new policy.

11. Click Finish.

Configuring Traffic Specification Rules
To add traffic specification rules, complete the following steps:
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1. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway.
The dashboard context for a group is displayed.

2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click a gateway underDevice Name.
The dashboard context for the gateway device is displayed.

4. UnderManage, Click Device.
The gateway configuration page is displayed.

5. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

6. Go to WAN > Dynamic Path Steering.

7. From the list of policies, select the policy to edit.

8. Click the edit icon in Traffic Specification Rules.

9. To add a new rule, click +, and then configure the following parameters:
n Source—You can set the source to any of the following options:

o Any—For the traffic coming from any of the source.
o User—For the traffic originating from a specific user.
o Host—For the traffic that has a specific host. If you select this option, you have to provide the IP

address of theHost.
o Network—For the traffic that has a specific source IP from a subnet of IP addresses. If you select

this option, you have to enter the IP address and the subnet mask of the source network.
o Alias—For the traffic originating from an alias of a host or network. If you select this option, you

have to select the Source alias from the drop-down list.
o User Role—For the traffic originating from a specific user role. If you select this option, you have

to select an existing user role from the list or create a new role to steer traffic only fromusers with
that role.

n Destination—You can set the destination to any of the following options:
o Any—For the traffic coming from any of the source.
o Host—For the traffic that has a specific host. If you select this option, you have to provide the IP

address of theHost.
o Network—For the traffic that has a specific source IP from a subnet of IP addresses. If you select

this option, you have to enter the IP address and the subnet mask of the destination network.
o Alias—For the traffic originating from an alias of a host or network. If you select this option, you

have to select theDestination alias from the drop-down list.

n Application/Port—You can select any of the following options:
o Application—To set rules for a specific application, for example, Facebook.
o Application Category—To set traffic rules for application category, for example, social

networking.
o Web Categories/Reputations—To set rules for web categories, for example, travel.
o UDP—To set rules for the traffic passing through theUDP ports.
o TCP—To set rules for the traffic passing through the TCP ports.
o Service—To set rules for any specific network service.
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10. Click Save Settings

11. Click Next to configure SLA parameters.

For example, if you set the source asUser Role such as employee, and the destination is restricted to a
specified network, based on other configurations such as preferred uplinks and SLAs set, the Dynamic Path
Steering feature steers traffic dynamically through themost viable path.

Configuring SLA Parameters
To set SLA parameters for the traffic type configured for the policy, complete the following steps:

1. In the policy definition, configure the following SLA categories and parameters:
n Name—Nameof the service. The default services areBestForInternet, BestForVoice, and

HighlyAvailable. Click Create new SLA to add a new service.

n Latency—Tomeasure the round-trip ping time. You can set a threshold value inmilliseconds.

n Jitter—Tomeasure if the packets are delivered in a proper order. You can set a threshold value in
milliseconds to observe jitters in packet transmission.

n Loss—Tomeasure packet loss. You can set a specific percentage of packet loss allowed for the
traffic type.

n Utilization—Tomeasure the percentage of bandwidth utilization. You can set a specific percentage
of bandwidth utilization as ametric to prioritize and load-balance the traffic

2. Click Next to configureWAN path.

3. Set probe options for SLAs if required. To set the probe options select an SLA and click Show Probe
Options:

a. Set the probe interval in seconds. During this interval, a number of probes are sent to determine the
SLA thresholds.

b. ForBursts per Probe, specify the number of probes to be sent during the probe interval.

Configuring WAN Path
To configure aWAN path for traffic types defined in the policy, complete the following steps:

1. Click the edit icon in WAN Path Selection.

2. In the policy definition, set the following parameters forWAN path selection:

3. Click Finish.

Routing Traffic After Path Selection
After path selection, the next hop is determined by the IP forwarding table. When a path is selected, the IP
forwarding table determines the next hop. Based on the routes configured on the Branch Gateway, the
next hop can be an IPsecmap or the router IP address.

n If the next hop is an IPsecmap, the session is forwarded to the IPsecmap that is configured in the
forwarding table associated with the selected path.

n If the next hop is a router IP address, the session is forwarded to the default gateway that is associated
with the selected path.

SaaS Application Traffic Management with SaaS Express
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Asmore businesses are adopting the SD-WAN fabric to take advantage of inexpensive broadband Internet
services and also adopting Software-as-a-Service (SaaS) applications such as Office365, Box, Slack, and
Zendesk , the SD-WAN business solutionsmust ensure that the users at a branch site can seamlessly and
securely connect to their applications in the cloud.

Aruba SD-WAN solution introduces the SaaS Express feature on Branch Gateways to enable discovery of the
SaaS application servers, monitor application performance, and steer traffic to the best available servers,
and thus provide an improved user experience.

The SaaS Express feature offers the following benefits:

n Real-time probemeasurement criteria to determine the optimal exit for routing user traffic.

n Centralized policy administration, enforcement, andmonitoring.

n Ability to choose the best network path to connect users to SaaS applications for better user experience.

n Improved service reliability withmultiple network paths and dynamic traffic-steering.

n Visibility into SaaS application performance and SaaS server availability metrics.

Criteria for SaaS Express Optimal Path
SaaS Express determines the optimal path for SaaS application traffic based on the following criteria:

n SaaS application profile parameters

n Path quality monitoringmetrics derived fromHTTP probes

n FQDN resolution over best available uplinks

n Path selection and traffic steering

SaaS Application Profile Parameters
By default, Aruba Branch Gateways support a set of applications and application categories in their Deep
Packet Inspection (DPI) library. The built-in application list includes a set of SaaS applications; for example,
Adobe, DropBox, Amazon, Google, Saleforce, Slack, Webex, and so on.

If a SaaS application is not available in the list, administrators can configure it on Branch Gateways using the
Aruba Central management interface. Formore information, see Configuring an SD-Branch Network.

Each SaaS application profile includes the following elements:

n Application name—Nameof the SaaS application.

n FQDN—A list of domain URLs bound to the SaaS application.

n Exit profile—Traffic steering policy for determining an optimal path exit.

n SLA—Threshold profile formeasuring path quality and performance.

n Health Check ProbeURI—URI to use for HTTP probes to determine the best available path.

HTTP Probes
ArubaGateways send HTTP requests to each SaaS application over every available path. Based on the
response, Gateways calculate the average packet loss and latency for each path, based on which path
quality and performance are determined. When a user requests for access to a SaaS application, Gateways
send an HTTP probe over each available circuit and determines the best performing ISP circuit. Gateways
then steer the application traffic to the best available path.

DNS Resolution
When a client requests for SaaS application access, the Aruba Gateway router tries to resolve the FQDN of
the SaaS application into IP addresses. Based on the type of SaaS application, the location of DNS caching

https://help.central.arubanetworks.com/latest/documentation/online_help/content/gateways/cfg/conf_gateways.htm
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servers for a given ISP, and geographical location of the device that initiates theDNS request, Gateways
determine the best available uplink for a given SaaS application on each ISP circuit.

For DNS resolution, DPI must be enabled on Branch Gateways.

Traffic Steering and Path Selection
Network administrators can use aWAN policy with a path steering criteria based on key performance
indicators such as jitter, latency, and packet loss to attach the policy to each SaaS application profile. By
default, the ArubaOS software includes aBestforSaaS SLA profile, which can be used for SaaS application
profiles. Administrators can also use a custom SaaS policy for steering SaaS application traffic.

Supported Deployment Scenarios
The SaaS Express feature on Branch Gateway supports Direct Cloud Access from a Branch with Dual ISP
Circuits.

In this scenario, when a client requests access to a SaaS application, Branch Gateways resolve the FQDN of
the SaaS application and send HTTP probes on all ISP circuits to collect performancemeasurements; for
example, latency or loss. Based on theHTTP response and SLA threshold profile configured for the SaaS
application, Branch Gateways determine the optimal path and route the designated SaaS application traffic
from a branch site using the best available ISP circuit.

The following figure illustrates SaaS traffic steering from a branch site with dual ISP circuits:

Figure 88 Branch Sites with Dual ISP Circuits
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To know how to configure SaaS Express, see Configuring SaaS Express .

Configuring SaaS Express
To route SaaS application traffic to the best available path, perform the following configuration steps on
Branch Gateways.

1. Configuring an SLA Profile on page 276

2. Configuring an Exit Profile on page 277

3. Configuring a Predefined SaaS Application Profile

4. Configuring an Exit Profile

5. Configuring a Custom SaaS Application Profile

Prerequisites
Before you begin, perform the following checks:

n ArubaGateways are upgraded to ArubaOS 8.4.0.0-1.0.6.0 or a later software version. Formore
information, see Updating Software Images on ArubaGateways

n Ensure that you assign sites to the gateways before enabling SaaS Express. If you assign the site after
enabling SaaS Express, you can view the site in themonitoring dashboard only after two hours.

n Ensure that DPI is enabled. To enable DPI follow the steps listed here:
1. In theNetwork Operations app, set the filter to a group that contains at least one Branch

Gateway.

The dashboard context for a group is displayed.

2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click a gateway underDevice Name.
The dashboard context for the gateway device is displayed.

4. UnderManage > Device, click Security > Applications.
The gateway configuration page is displayed.

5. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

6. Expand Application Visibility and click Deep Packet Inspection (apprf).

7. EnableDeep Packet Inspection.

For application performance monitoring, youmust enable the TCP Sequence numbers in the packets
by selecting the Enforce TCP sequence numbers check box on the Gateway Management >
Security > Auth Servers> Firewall page.

n Uplink interfaces are configured and thewired uplink is functional. Formore information, see Configuring
Uplinks

n TheApp Performance Monitoring and DHCP Performance Monitoring options are enabled on Branch
Gateways. These advancedmonitoring options are available underNetwork Operations > Select a
Gateway > Manage > Device > Security > Firewall.

Configuring an SLA Profile
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An SLA profile defines a threshold value for path performance indicators such as latency, jitter, packet loss,
and uplink utilization. To determine if the pathmeets the performance criteria, Branch Gateways use the
loss, latency, and jitter information polled from theHTTP probes. Branch Gateways determine the optimal
path that meets the criteria defined in the SLA profile for the SaaS application.

To set SLA parameters for a SaaS application profile, complete the following steps:

1. In theNetwork Operations app, set the filter to a group that contains at least one Branch
Gateway.

The dashboard context for a group is displayed.

2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click theConfig icon.
The gateway group configuration page is displayed.

4. Click WAN > SAAS Express.

5. Click SLAs. By default, the Branch Gateway includes theBestForSaas exit profile.

6. To add a new SLA profile, click + in the SLAs table.

7. Configure the following performance indicators:

n Name—Nameof the service. By default, BestForSaaS is selected.
n Loss %—Tomeasure packet loss. You can set a specific percentage of packet loss allowed for the

traffic type.

n Latency (MS)—Tomeasure the round-trip ping time. You can set a threshold value inmilliseconds.

n Jitter (MS)—Tomeasure if the packets are delivered in a proper order. You can set a threshold value
inmilliseconds to observe jitters in packet transmission.

n Utilization%—Tomeasure the percentage of bandwidth utilization. You can set a specific
percentage of bandwidth utilization as ametric to prioritize and load-balance the traffic.

8. Click Save Settings.

Configuring an Exit Profile
To configure an exit profile, complete the following steps:

1. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway.
The dashboard context for a group is displayed.

2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click theConfig icon.
The gateway group configuration page is displayed.

4. Click WAN > SAAS Express.

5. Click Exit Profile. By default Branch Gateways include theBestForSaas exit profile.

6. To add a new exit profile, click + in the Exit Profile table.

7. Select an uplink path from the available list of uplinks:
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n Primary Path—Aprimary uplink path for steering traffic. You can select multiple uplink IDs in a
sequential order. Whenmultiple primary paths are configured, the traffic is load-balanced across all
primary paths that meet the configured SLA.

n Secondary Path—Asecondary uplink path for steering traffic. To configure a secondary path, select
the uplink type or ID. When a session is steered to a secondary path, it stays on the link until the end,
irrespective of the status of the primary path. When a primary path becomes active andmeets the
configured SLA, the new sessions are steered back to the primary path.

n Tertiary Path—The third uplink path as a last attempt to steer traffic (when both primary and
secondary paths are down) . When a session is steered to a tertiary path, it stays on the link until the
end. When a primary path becomes active andmeets the configured SLA, the new sessions are
steered back to the primary path.

8. Click Save Settings.

Configuring a Predefined SaaS Application Profile
You can create a profile for a SaaS application that is available in theDPI library of Branch Gateways. By
default, Aruba Branch Gateways support a set of applications and application categories available in their
DPI library. The built-in application and application category lists include a set of SaaS applications; for
example Adobe, DropBox, Amazon, Google, Saleforce, Slack, Webex, and so on. A default application profile
is configured for the SaaS applications that are already available on the Branch Gateways.

To create a predefined SaaS application profile, complete the following steps:

1. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway.
The dashboard context for a group is displayed.

2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click theConfig icon.
The gateway group configuration page is displayed.

4. Click WAN > SAAS Express.

5. Click SAAS Application.

6. In the SAAS application with optimized routing table, click + to add a new application profile.

Administrators can also create a custom list of SaaS applications and add it to s' app library. For
more information, see Creating Custom Application and Application Categories.

7. In theCreate new application table, configure the following parameters:

n Application—Select the application from the drop-down list.

n Exit Profile—Select an exit profile. The exit profile allows you to define an exit criteria for SaaS
application traffic based on the best available path. The exit profile defines a primary link for all SaaS
application traffic, and secondary and tertiary uplinks as fallback options if the primary path does
not meet the SLA configured for the SaaS application. By default, theBestforSaaS exit profile is
available on Branch Gateways. You can also configure a custom exit profile and associate it to the
SaaS application profile.

n SLA—Select an SLA profile.

n FQDN—Add the FQDN of the SaaS application site.
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n Healthcheck Probe URI—Enter the health check probeURI. Branch Gateways use the healthcheck
probeURI to gather a set of servers for the SaaS application.

The following figure illustrates the predefined SaaS application profile creation workflow:

Figure 89 Predefined SaaS Application Creation Workflow

8. Click Save Settings.

Configuring DNS Servers for Path Exit
When a client at a branch site initiates a DNS query to a SaaS application, the Branch Gateway intercepts the
DNS query, acts as a proxy, and forwards the query to theDNS server. You can also configure the Branch
Gateway as theDNS server for SaaS application FQDN resolution by defining theDNS server for that uplink
in the Exits table.
To configure DNS server details:

1. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway.
The dashboard context for a group is displayed.

2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click theConfig icon.
The gateway group configuration page is displayed.

4. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

1. Click WAN > SAAS Express > Exits

2. To add a new exit profile, click + in the Exits table.

3. Select an uplink.

4. Select one of the following options:

n IP address
n ISP DNS

If you selected IP address, enter theDNS server IP address.

5. Click Save Settings.

Configuring a Custom SaaS Application Profile
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You can create a profile for a custom SaaS application as per your requirement even if it is not available in
theDPI library of Branch Gateways.

To create a custom SaaS application profile, complete the following steps:

1. In theNetwork Operations app, set the filter to Global.
The dashboard context for all devices is displayed.

2. UnderManage, click Applications > SaaS Express.
Themap view of the SaaS Express dashboard is displayed.

3. Click theConfig icon.
The SaaS Express configuration page is displayed.

4. In the SAAS applications table, click + to add a new application profile.

5. In theNew SaaS Application window, configure the following parameters:

n Application—Enter the name of the application that you want to configure.

n FQDN—Add the FQDN of the SaaS application site.

n Healthcheck Probe URI—Enter the health check probeURI. Branch Gateways use the healthcheck
probeURI to gather a set of servers for the SaaS application.

6. Click Save.

The following figure illustrates the custom SaaS application profile creation workflow:

Figure 90 Custom SaaS Application Creation Workflow

To know how tomonitor your SaaS applications, seeMonitoring SaaS Express .

Configuring Aruba Gateways for Application Visibility and
Control
The application visibility and control feature on ArubaGateways enables administrators to monitor, analyze,
and control application usage and bandwidth consumption in their networks. To provide in-depth visibility
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and insightful reporting of the applications in use, Aruba Gateways support deep packet inspection of
applications accessed by the client devices in the SD-WAN network.

Based on application usage, network administrators can configure ACLs to control application access,
prioritizemission-critical applications, and improve quality of experience by fine tuning bandwidth allocation
per application or application category.

Aruba Gateways support the following types of application visibility and control features:

n Firewall Visibility—Allows Gateways to log all firewall sessions.

n Deep Packet Inspection (AppRF)—Allows Gateways to perform a deep packet of inspection of the
application traffic. Formore information, see Using Deep Packet Inspection.

n Website Content Classification (WebCC)—Allows administrators to filter URLs based on website
categories and security reputation score. When you enableWebCC, you can configure enable filtering
websites based on IP reputation and geolocation. Formore information, see Filtering URLs Based on
Website Content and Reputation.

Using Deep Packet Inspection
ArubaGateways support Deep Packet Inspection (DPI) of applications and application categories used by
the connected clients.

TheDPI feature enables Gateways to perform the following functions:

n Traffic Inspection and reporting—When DPI is enabled, Gateways perform deep packet inspection of
application traffic and report it in theGateway monitoring dashboard. The app library on Gateways
includes a list of default applications and application categories on which you can enable deep packet
inspection. You can also create a list of custom applications and application categories for DPI.

n Application control—Based on application usage and bandwidth consumptionmetrics, administrators can
configure ACLs per application or application category and throttle bandwidth formission-critical
applications for traffic prioritization and QoS.

Figure 91 Enabling Deep Packet Inspection in the Gateway Dashboard

Creating Custom Application and Application Categories

You can add up to 64 custom applications to Aruba Gateway's DPI library. For each custom application, you
configure up to 16 ACL rules.

To create a custom application:
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1. To configure a Branch Gateway group or a Branch Gateway complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. Switch to Advanced Mode.

3. Click Security > Applications > Custom Application.

4. To add a new application, click +.

5. Enter aName for the custom application.

6. Enter an Application ID between 1 and 64. The application ID is used to identify the application in
the application category during DPI.

7. Select a Category from the drop-down list. The application category list displays the default
application categories available in theDPI library. To add a new application category. click +. You can
create up to 32 application categories.

8. (Optional) Click + in the Server name table and configure theDNS server name and the FQDN URI.

9. (Optional) Click + in theReferer name table and configure a referrer URL. A referrer is URL data
from an HTTP header field that is used for identifying theweb link to direct users to aweb page.

10. (Optional) Click + in the CommonName table and configure a Common Name; that is, the SSL
certificate CommonName identifies the hostname associated with the certificate. The Common
Name is typically includes host and domain name. The CommonNamemust match website address
of the application.

11. Click Save Settings.

Enabling DPI under Application Visibility

To enable DPI, complete the following steps:

1. To configure a Gateway group or Gateway complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.
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n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. Click Security > Applications.

3. Click Application Visibility.

4. Select theDeep Packet Inspection check box.

Configuring Proxy Server on Branch Gateway for DPI

If your network has clients that access web applications through a proxy server, youmust configure the
proxy server details on Branch Gateways to enable DPI for client traffic and application usage.

To configure proxy server details on Branch Gateway for DPI, complete the following steps:

1. To configure a Branch Gateway group or Branch Gateway complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. Switch to Advanced Mode.

3. Click Security > Applications.

4. Click Application Visibility.

5. Enable theApplication visibility with proxy server.

6. Enter theHTTP and HTTPS port of the proxy server.

7. Click Save Settings.

Monitoring Application Usage

Tomonitor application usage for Gateway clients:
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1. To monitor application usage for a Gateway group or Gateway complete either one of these steps:

n To view application usage for a Gateway group:

2. In theNetwork Operations app, set the filter to a group containing at least one Branch Gateway.

3. UnderManage, click Applications > Visibility.

n To view application usage for a gateway:

4. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway.
The dashboard context for a group is displayed.

5. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

6. Click a gateway underDevice Name.
The dashboard context for the gateway device is displayed.

7. UnderManage, click Applications > Visibility.

Formore information on application graphs and usagemetrics, see Gateway > Applications > Visibility on
page 503.

Configuring Security Policies for Application Access Control
Formore information, see Configuring ACLs for Deep Packet Inspection.

Configuring Bandwidth Contracts Per Applications

To configure bandwidth contract, complete the following steps:

1. To configure a Branch Gateway group or Branch Gateway device, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. Switch to Advanced Mode.

3. Click Security > Applications.

4. Expand Per-Application Limits.

5. To add an application or application category to a bandwidth contract, click + in the table TheAdd
Application Limit section is displayed.
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6. Select the application bandwidth type from the Type drop-down list.

7. Select the name of the bandwidth contract from theName drop-down list.

8. Enter values in Kbits orMbits in theUpstream and Downstream fields.

9. Click Save Settings.

Filtering URLs Based on Website Content and Reputation
ArubaGateways enhance branch security by providing real-timeweb content and reputation filtering. The
Website Content Classification feature on Branch Gateways allows you to classify website content based on
reputation and takemeasures to block malicious sites.

Aruba Gateways useWebroot BrightCloud Security Services to fetch information on website content
classification, and geolocation of IPs. The IP reputation database contains known IP addresses associated
with variousmalicious activities or threats such as botnet, DOS, and spam sources. The geolocation IP
database contains the geographical location of the IP address fromwhere the traffic is received or to which
the traffic is sent. This allows the Branch Gateways to provide geolocation and reputation filtering as part of
the security suite.

When a new session is received, the source and destination IP are fetched and both these IP addresses
looked up on the BrightCloud server to retrieve information about the reputation and geolocation of these
IPs. If the table lookup succeeds, then the session ismarked as classified and subjected to IP classification
based firewall policies. If the table lookup fails, IP classification query message is sent to the control plane to
have the classification for these IPs downloaded fromWebroot's Brightcloud service.

Enabling Web Content Classification

To enableWebCC, complete the following steps:

1. To configure a gateway group or gateway device, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. Click Security > Applications.

3. Click Application Visibility.

4. For enabling traffic analysis forWebCC, select theWeb content classification (WebCC) check box.

5. Click Save Settings.

Configuring Security Policies for Filtering Websites and IP Addresses
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Formore information, see Configuring ACLs forWeb Content Classification.

Dropping Unclassified Web Content

To drop the packets that do not match any web content category or reputation levels in the Branch
Gateway's internal web content cache, complete the following task:

1. To configure a gateway group or gateway device, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. Click Security > Applications.

3. Click Application Visibility.

4. For website URL filtering, turn on theWeb Content Classification (WebCC) toggle switch.

5. Select theDrop packets during webcc miss check box.

6. Click Save Settings.

Configuring Redirect URLs for Blocked Sessions

To configure a URL to redirect the users when they access blocked sessions, complete the following tasks:

1. To configure a Gateway group or Gateway complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.
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2. Click Security > Applications.

3. Click Application Visibility.

4. For website URL filtering, select theWeb Content Classification (WebCC) check box.

5. Specify a URL to which the users should be redirected when they access blocked session in theURL
to redirect blocked session field.

6. Click Save Settings.

Configuring IP Reputation and Filtering

IP reputation policies can be applied to Branch Gateways to prevent traffic fromor to malicious websites.

Before configuring this feature, ensure that you configure the WebCC or Web reputation policies. For
more information, see Configuring ACLs for Web Content Classification on page 296.

To enable IP reputation and filtering, complete the following tasks:

1. To configure a gateway group or gateway device, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. Click Security > Applications.

3. Click Application Visibility.

4. For website URL filtering, turn on theWeb Content Classification (WebCC) toggle switch.

5. Enable IP classification and reputation.

6. To deny incoming traffic frommalicious IP addresses, select theDeny inbound connections from
malicious IP address.

7. To deny outgoing traffic to malicious IP addresses, select theDeny outbound connections to
malicious IP address.

8. To whitelist any trusted IP address or a range of IP addresses that may bemisclassified asmalicious
IP addresses, complete the following tasks:

a. Click + from the IP ADDRESS table under theWhitelisted IP addresses field.

b. Enter the IP address to bewhitelisted in the IP address field. If you want to whitelist a range of
IP addresses, enter the starting IP address of the range in this field.
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c. Enter the ending IP address of the range to bewhitelisted in the End IP address field.

d. Specify any description of the IP address or the IP address range in theDescription field.

The IP addresses included in this table are considered trusted IP addresses even if they are
classified as malicious IP address by the IP reputation database.

e. Click Save Settings.

Configure Geolocation-Based Filtering

TheGeolocation filtering policies allow you to filter traffic based on the geographic location of the source or
destination IP addresses. You can configure these policies to permit or deny outgoing or incoming traffic
from specific countries.

To enable geolocation-based filtering, complete the following tasks:

1. To configure a gateway group or gateway device, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. Click Security > Applications.

3. Click Application Visibility.

4. For website URL filtering, turn on theWeb Content Classification (WebCC) toggle switch.

5. EnableGeo location.

6. Click + in theGeoLocation table to add a new geolocation rule.

7. In theNew GeoLocation Rule section, configure the following parameters:

n Action—Select the action as Permit orDeny.
n Direction—Select the direction as To or From.

n Country—Select the required country for which you want to apply this rule.

n Log—Select the check box to enable logging for this rule.

8. Click Save Settings.

Monitoring Application Traffic
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For website traffic visibility:

1. To configure a gateway group or gateway device, complete either one of these steps:

n To view aGateway group:

class="Bullet_2_in_Steps">In theNetwork Operations app, use the filter to select Groups.
n UnderManage, click Applications > Visibility.

n To view a gateway:

n In theNetwork Operations app, use the filter to select the gateway.

Formore information on application graphs and usagemetrics, see Gateway > Applications > Visibility on
page 503.

Enforcing a Common Security Policy for Wired and
Wireless Users
The Aruba SD Branch solution supports dynamic segmentation of the branch network based on device
profiles. The solution also supports diverting client traffic from selected devices to Branch Gateways.

If your SD Branch has Aruba Switches deployed and provisioned to function along with the Branch
Gateways, your network administrators can configure common set of security policies for wired and
wireless clients on the ClearPass server and use Branch Gateway as policy enforcement points to inspect
every communication in the branch.

The Tunneled Node feature on Aruba switches allowswired traffic entering a switch port to be routed to
Branch Gateway through theGRE tunnel. An Aruba switch can also initiate a GRE tunnel with the Branch
Gateway from itsmanagement IP address associated to an underlay VLAN that is different from the user
VLANs.

To allow policy enforcement for thewired traffic, the port-based tunnelsmust be configured and the IP
address of the Branch Gateway must be set as a primary tunneled node on the switches. Formore
information on the configuration procedure, see theHPE ArubaOS-Switch Management and Configuration
Guide.

Configuring Firewall Policies and ACLs
To secure your branch, youmust configure a policy with a set of ACLs and apply these policies to user roles
or user-facing VLAN interfaces.

For an SD Branch setup, the general recommendation is to set theWAN-facing ports as trusted and LAN-
facing ports as untrusted. AlthoughWAN-facing ports are trusted, Aruba recommends that you apply a
restrictive firewall policy to theWAN interfaces.

As LAN-facing ports are untrusted, it is very important to secure your branch by applying a AAA profile to
the VLANs configured for the LAN interfaces. When a AAA policy is applied, SD-WAN Gateways assign the
user roles based on the role preferences configured in a AAA profile.

Firewall Policies for SD Branch
The SD Branch solution supports identity-based controls to enforce application-layer security, prioritization,
traffic forwarding, and network performance policies for theWAN network. You can configure firewall
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policies on Branch Gateways to define user access to network, set priority queue for Quality of Service
(QoS), and assign bandwidth contracts.

A firewall policy identifies specific characteristics about a data packet and performs one of the following
actions:

n Firewall-type action such as permitting or denying the packets.

n Administrative action such as logging the packets.

n QoS action such as setting 802.1p bits or placing the packet in a priority queue.

Types of ACLs
Aruba Central allows you to configure the following types of ACLs on Branch Gateways.

n Standard ACLs—Permit or deny any traffic based on the source IP address of the packet. Standard ACLs
can be either named or numbered, with valid numbers in the range of 1–99 and 1300–1399. Standard
ACLs use a bit-wisemask to specify the portion of the source IP address to bematched.

n Extended ACLs—Permit or deny any traffic based on source or destination IP address, source or
destination port number, or IP protocol. Extended ACLs can be named or numbered, with valid numbers in
the range 100–199 and 2000–2699.

n MAC ACLs—Filter the traffic on a specific sourceMAC address or range of MAC addresses. MAC ACLs can
be either named or numbered, with valid numbers in the range of 700–799 and 1200–1299.

n Ethertype ACLs—Filter the traffic based on the Ethertype field in the frame header. Ethertype ACLs can be
either named or numbered, with valid numbers in the range of 200–299.These ACLs can be used to permit
IPs while blocking other non-IP protocols, such as IPX or AppleTalk.

n Session ACLs—Restrict all services from specific hosts and subnets. Rules with this ACL are applied to all
traffic on the Branch Gateway regardless of the ingress port or VLAN.

n Route ACLs—Forward all packets to a device defined by an IPsecmap, a next hop list, a tunnel or a tunnel
group.

Configuring Aliases for Firewall Policies
Aliases allow you to name your network ports, protocols, and services in a simple yet understandable way.
When configuringmultiple ACLs, you can use a common alias instead of providing details of the network
ports, protocols, and services each time.

Creating a Network Alias
A network alias defines a TCP, UDP, or IP protocol and a list or range of ports supported by that service. You
can use a network alias when specifying a network service formultiple session ACLs.

1. To configure a Branch Gateway group or a Branch Gateway, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.
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n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. Click Security > Aliases.

3. Click + to create a network alias.

4. Enter a name and description for this alias.

5. Select the Invert checkbox.

6. Click Save Settings.

7. UnderDestination click + to add a new user rule.

8. Select Network from theRule type drop-down list.

9. Enter a IPv4 address and Network mask.

10. Click Save Settings.

Creating a Service Alias
To create a service alias:

1. To configure a Branch Gateway group or a Branch Gateway, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. Click Security > Aliases.
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3. Click + to create a service alias.

a. Enter a value in the Service name field.

b. In the Protocol drop-down list, select either TCP orUDP, or select protocol and enter the IP protocol
number and Application level gateway (alg) of the protocol for which you want to create an alias.

c. In the Port type drop-down list, specify whether you want to define the port by a contiguous range of
ports, or by a list of non-contiguous port numbers.

n If you selected range, enter the starting and ending port numbers in the Starting port and End
port fields, respectively.

n If you selected list, enter a comma-separated list of port numbers in the Port list field.

d. To limit the service alias to a specific application, select one of the following service types from the
Application Level Gateway (alg) drop-down list:

n ftp: Service is FTP

n tftp: Service is TFTP

n dns: Service is DNS

n dhcp: Service is DHCP

n sip: Service is SIP

n sips: Service is Secure SIP

n svp: Service is SVP

n sccp: Service is SCCP

n rtsp: Service is RTSP

n vocera: Service is VOCERA

n noe: Service is Alcatel NOE

n h323: Service is H323

n jabber: Service is Jabber

n facetime: Service is Facetime

4. Click Save Settings.

Creating a Firewall Policy for Network Services
To create a firewall policy, complete the following procedure:

1. To configure a Branch Gateway group or a Branch Gateway, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.
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c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. Click Security > Policies.

3. Click + to create a new policy.

4. Select a policy type from the Policy type drop-down list. You can select Session, Ethertype,MAC,
Route, Extended, or Standard.

5. Enter the policy name in the Policy name field.

6. Click Save Settings.

Configuring Access Rules
To configure access rule, complete the following procedure:

1. From the list of policies, select the policy that you created and click + in the Policy <policy name>
table.

2. Select theAccess Control option in theRule Type field and click OK.

3. To add a rule to restrict packet flow or permit access to network or services, configure the following
parameters:

Parameter Description

IP version Specifies the IP version that the policy applies to. Select IPv4.

Source
(required)

Source of the traffic, which can be one of the following:
n Any—Acts as a wildcard and applies to any source address.
n User—Refers to the traffic from the wireless client.
n Host—Refers to the traffic from a specific host. When this option is selected, specify the IP
address of the host.
n Network—Refers to the traffic that has a source IP from a subnet of IP addresses. When
this option is selected, specify the IP address and network mask of the subnet.
n Alias—Refers to using an alias for a host or network.
n Local IP—Refers to the local IP address.
n User Role—Refers to the user role to be assigned.

Destination
(required)

Destination of the traffic.

Service/app
(required)

Type of traffic, which can be one of the following:
n Any—This option specifies that this rule applies to any type of traffic.
n TCP—Using this option, you configure a range of TCP ports to match for the rule to be
applied.
n UDP—Using this option, you configure a range of UDP ports to match for the rule to be
applied.
n Service—Using this option, you use one of the pre-defined services (common protocols
such as HTTPS and HTTP) as the protocol to match for the rule to be applied.
n Protocol—This option specifies the routing protocol.

Action
(required)

The action that you want the Branch Gateway to perform on a packet that matches the specified
criteria.

Table 35: Firewall Policy Rule Parameters
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Parameter Description

n Deny—Denies traffic not matching this rule.
n Reject—Drops the packet and sends an ICMP notification to the traffic source.
n Permit—Permits the traffic matching this rule.
n Redirect—This option redirects the traffic to a GRE tunnel. This option is used primarily to
redirect all guest traffic to a GRE tunnel and then to a DMZ router or switch.
n Destination NAT—Redirects traffic to the configured IP address and destination port. An
example of this option is to redirect all HTTP packets to the captive portal port on the Branch
Gateway as used in the predefined policy called captive portal. This action functions in tunnel
or decrypt-tunnel forwarding mode. User should configure the NAT pool in the Branch
Gateway.
n Source and Destination NAT—This option performs both source and destination NAT on
packets matching the rule. This action forwards packets from the source network to the
destination network and re-marks them with destination IP of the target network. This action
functions in tunnel or decrypt-tunnel forwarding mode. User should configure the NAT pool in
the Branch Gateway.
n Source NAT—Performs NAT on packets matching the rule. When this option is selected,
you need to select a NAT pool. . This action functions in tunnel or decrypt-tunnel forwarding
mode.
n Route Source NAT—Routes traffic based on source address.
n Route Destination NAT—Routes traffic based on destination address.

DSCP
(optional)

Option to re-tag the traffic with the specified DSCP tag in the IP header of the packet that
matches this rule when it leaves the Branch Gateway.

Time Range You can allow or deny access during specific time range. You can either create an absolute time
range with a single fixed start and end date and time; or a periodic (recurring) time range that
starts and ends at a specified time on a weekday, weekend, or selected day.

802.1p
Priority
(optional)

When this parameter is enabled, the value of 802.1p priority bits are marked in the frame of a
packet matching this rule when it leaves the Branch Gateway. 0 represents the lowest priority
(background traffic) and 7 represents the highest priority (network control).

Log
(optional)

Logs a match to this rule. This is recommended when a rule indicates a security breach, such as
a data packet on a policy that is meant only to be used for voice calls.

Mirror
(optional)

Mirrors session packets to datapath or remote destination.

Blacklist
(optional)

Automatically blacklists a client that is the source or destination of the traffic matching this rule.
This option is recommended for rules that indicate a security breach where the blacklisting
option can be used to prevent access to clients that are attempting to breach the security.

Disable
scanning
(optional)

Disable AP scanning other channels.

Table 35: Firewall Policy Rule Parameters

Configuring ACLs for Deep Packet Inspection
Branch Gateways support AppRF, Aruba's custom-built layer 7 firewall capability. It consists of an onboard
Deep Packet Inspection (DPI) service that allows creating firewall policies based on the types of application
and application categories.

You can configure ACLs to restrict user access to an application or application category. You can also define
traffic-shaping policies such as bandwidth control and QoS per application for client roles. For example, you
can block bandwidth-monopolizing applications on a guest role within an enterprise.
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Creating ACLs for Application Access Control
To create ACL rules for Deep Packet Inspection on Branch Gateways, complete the following procedure:

1. To configure a Branch Gateway group or a Branch Gateway, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. Click Security > Policies.

3. Click + to create a new policy.

4. Enter the policy name in the Policy name field.

5. From the list of policies, select the policy you just created and click +.

6. Select one of the following options from the Service/app drop-down list.

n Application—To allow or deny access to a specific application.

n Application Category—To allow or deny access to a specific application category.

7. Specify an action.

8. Click Save Settings.

Configuration Example

This example shows aDPI rule along with a layer 3 or layer 4 rule with forwarding action in the sameACL.
Both ACL policies can be applied to a single user role.

n Rule 1
o source: any
o destination: any
o service or application: application facebook
o action: permit
o DSCP value: 45

n Rule 2
o source: any
o destination: any
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o service or application: application YouTube
o action: deny

n Rule 3
o source: any
o destination: any
o service or application: application category peer-to-peer
o action: deny

n Rule 4
o source: any
o destination: any
o service or application: TCP 23
o action: permit

n Rule 5
o source: network 40.1.0.0/16
o destination: any
o service or application: TCP 80
o action: permit
o DSCP: 60

n Rule 6

n Rule 2

n Rule 3

Configuring ACLs for Web Content Classification
TheWebCC feature in Branch Gateways allows your network administrators to analyze thewebsite usage by
clients. Branch Gateways classify the usage pattern based on web categories and website reputation scores;
it allows your network administrators to take appropriatemeasures to prevent maliciousmalware, spyware,
or adware by blocking dangerous websites.

To configure an ACL rule for website content classification, complete the following steps:

1. To configure a Branch Gateway group or a Branch Gateway, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.
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d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. Click Security > Policies.

3. Click + to create a new policy. Select a policy type from the Policy type drop-down list.

4. Enter the policy name in the Policy name field.

5. From the list of policies, select the policy you just created and click +.

6. In theRules of this Role only section, perform the steps:

7. Select Web Category/Reputation from the Service/app drop-down list:

a. From theWeb reputation drop-down list, select one of the following reputation scores based on your
requirement:

n high-risk—These are high risk sites. There is a high probability that the user will be exposed to
malicious links or payloads.

n low-risk—These are benign sites andmay not expose the user to security risks. There is a low
probability that the user will be exposed to malicious links or payloads.

n moderate-risk—These are generally benign sites, but may pose a security risk. There is some
probability that the user will be exposed to malicious links or payloads.

n suspicious—These are suspicious sites. There is a higher than average probability that the user
will be exposed to malicious links or payloads.

n trustworthy—These arewell known sites with strong security practices andmay not expose the
user to security risks. There is a very low probability that the user will be exposed to malicious
links or payloads

b. From theAction drop-down list, select Deny to not allow user to access this web category; else, select
Permit to allow user to access theweb category.

c. ForDSCP, enter a value.

d. From the Time range drop-down list, select a suitable time range during which you want the policy to
be active or valid. Alternatively, you can also create a new time range by clicking the + icon.

e. From the 802.1p priority drop-down list, select a priority from 1-7.

f. ForOptions, select Log, Mirror, and Blacklist, or any other option that is applicable.

8. Click Save Settings.

Configuring Global Firewall Parameters
The ArubaGateways support stateful firewall for stateful inspection of packets. Stateful firewalls provide an
additional layer of security by tracking the state of network connections and using the state information
fromprevious communications to monitor and control new communication attempts. To protect your
network from external attacks and unauthorized communication attempts, you can configurematch
conditions and packet filtering criteria for the Aruba Gateways.

To configure global firewall parameters for protection against external attacks:

1. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway.
The dashboard context for a group is displayed.
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2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click a gateway underDevice Name.
The dashboard context for the gateway device is displayed.

4. UnderManage, Click Device.
The gateway configuration page is displayed.

5. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

6. Click Security > Firewall.

7. Configure the parameters described in Table 36 as per your network requirements.

8. Click Save Settings.

Parameter Description

Monitor ping
attack

Number of ICMP pings per 30 seconds, which if exceeded, can indicate a DoS attack. A valid
range is 1-16384 pings per 30 seconds. Recommended value is 120.

Monitor TCP
SYN attack
rate

Number of TCP SYN messages per 30 seconds, which if exceeded, can indicate a DoS attack.
A valid range is 1-16384 pings per 30 seconds. Recommended value is 960.

Monitor IP
sessions
attack

Number of TCP or UDP connection requests per 30 second, which if exceeded, can indicate a
DoS attack. A valid range is 1-16384 requests per 30 seconds. Recommended value is 960.

Monitor/police
non-
gratuitous
ARP attacks

Enable monitoring and policing non-gratuitous ARP attacks and configure the following
parameters:

n Monitor/police non-gratuitous ARP attack rate—Specify the number of ARP packets
(other than Gratuitous ARP packets) per 30 seconds, which if exceeded, can indicate a DoS
attack. A valid range is 1-16384 packets per 30 seconds. Recommended value is 960.
n Monitor/police non-gratuitous ARP attack action—Select an action to be taken upon
detection of ARP attacks. The options are Blacklist and Drop.

Monitor/Police
Gratuitous
ARP Attack
rate (per 30
seconds)

Number of gratuitous ARP packets per 30 seconds, which if exceeded, can indicate DoS
attack. A valid range is 1-16384 packets per 30 seconds. Recommended value is 50.

Monitor/police
gratuitous
ARP attack
action

The action to be taken upon detection of ARP attacks. The options are Blacklist and Drop. The
default value is Drop.

Monitor/police
CP attack rate

Rate limit for control plane traffic policing. The recommended value is 3000 frames per 30
seconds.

Deny inter
user bridging

Prevents the forwarding of layer 2 traffic between wired or wireless users. You can configure
user role policies that prevent layer 3 traffic between users or networks but this does not
block layer 2 traffic. This option can be used to prevent traffic from being forwarded.

Table 36: Firewall Parameters
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Parameter Description

Deny inter
user traffic

Denies traffic between untrusted users by not allowing layer 2 and layer 3 traffic.

Deny source
routing

Permits firewall to reject and log packets with the specified IP options loose source routing,
strict source routing, and record route.

Deny all IP
fragments

Drops all IP fragments.

NOTE: Do not enable this option unless instructed to do so by an Aruba Support
representative.

Enforce TCP
handshake
before
allowing data

Prevents data from passing between two clients until the three-way TCP handshake has been
performed. This optionmust be disabled when you have mobile clients on the network as
enabling this optionmay affect mobility.

Prohibit IP
spoofing

Enables detection of IP spoofing (where an intruder sends messages using the IP address of a
trusted client). When this option is enabled, source and destination IP andMAC addresses are
checked for each ARP request or response. Traffic from a secondMAC address using a
specific IP address is denied, and the entry is not added to the user table. Possible IP spoofing
attacks are logged and an SNMP trap is sent. This is enabled by default.

Prohibit RST
replay attack

Closes a TCP connection in both directions if a TCP RST is received from either direction, this
option is disabled by default.

NOTE: Do not enable this option unless instructed to do so by an Aruba Support
representative.

Log all
received ICMP
errors

Enables logging of received ICMP errors.

NOTE: Do not enable this option unless instructed to do so by an Aruba Support
representative.

Allow tri-
session with
DNAT

Allows a three-way session when performing destination NAT. This optionmust be enabled
when the Branch Gateway is not the default gateway for wireless clients. This option is
typically used for captive portal configuration.

AMSDU
configuration

Enables handling AMSDU traffic from clients.

Session idle
timeout

Set the time, in seconds, that a non-TCP session can be idle before it is removed from the
session table. Specify a value in the range of 16-300 seconds.

NOTE: Do not enable this option unless instructed to do so by an Aruba Support
representative.

Disable FTP
server

Disables the FTP server. Enabling this option prevents FTP transfers.

NOTE: Do not enable this option unless instructed to do so by an Aruba Support
representative.

GRE call ID
processing

Creates a unique state for each PPTP tunnel.

Table 36: Firewall Parameters
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Parameter Description

NOTE: Do not enable this option unless instructed to do so by an Aruba Support
representative.

Optimize
duplicate
address
detection
frames

Enables optimization of duplicate address detection frames with respect to IPv4 gratuitous
ARPs.

Stall detection Enable this to detect if there is any hardware issue with the forwarding engine and to take
necessary mitigating steps.

NOTE: Do not enable this option unless instructed to do so by an Aruba Support
representative.

Immediate
freeback

Enables immediate freeback of hardware buffers from datapath to the interface.

NOTE: Do not enable this option unless instructed to do so by an Aruba Support
representative.

Stateful ICMP
processing

Enables stateful ICMP processing for all kinds of ICMP traffic. This option is used to selectively
control different kinds of ICMP traffic through ACLs.

Mcast RED Enables the multicast random early detection algorithm parameters.

Per-packet
logging

Enables logging of every packet if logging is enabled for the corresponding session rule. By
default, one event is logged per session. If you enable this option, each packet in the session is
logged.

Prohibit ARP
spoofing

Detects and prohibits ARP spoofing. When this option is enabled, possible address resolution
protocol (arp) spoofing attacks are logged and an SNMP trap is sent.

Prevent DHCP
exhaustion

Enables verification DHCP client hardware address against the packet source MAC address.
This command checks the frame's source-MAC against the DHCPv4 client hardware address
and drops the packet if it does not match. Enabling this feature prevents a client from
submitting multiple DHCP requests with different hardware addresses, thereby preventing
DHCP pool depletion.

Only allow
local subnets
in user table

Adds only IP addresses, which belong to a local subnet, to the user table.

Session-
tunnel FIB

Enable session-tunnel-based forwarding.
Enable this parameter only during maintenance window or off-peak production hours.

Multicast
automatic
shaping

Enables multicast optimization and provides excellent streaming quality regardless of the
amount of VLANs or IP IGMP groups that are used.

Enforce bw
contracts for
broadcast
traffic

Applies bandwidth contracts to local subnet broadcast traffic.

Table 36: Firewall Parameters
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Parameter Description

Enforce TCP
sequence
numbers

Enforces the TCP sequence numbers for all packets.

Public-access
mode

Enables public access mode for all packets.

Rate limit CP
untrusted
ucast traffic
(pps)

Indicates the rate limit value of untrusted unicast traffic. The range is 1-65535 packets pps.

Rate limit CP
untrusted
mcast traffic
(pps)

Indicates the rate limit value of untrustedmulticast traffic. The range is 1-65535 pps.

Rate limit CP
trusted ucast
traffic (pps)

Indicates the rate limit value of trusted unicast traffic. The range is 1-98304 pps.

Rate limit CP
trusted mcast
traffic (pps)

Specifies the trustedmulticast traffic rate limit. The range is 1-65535 pps.

Rate limit CP
route traffic
(pps)

Indicates the rate limit value of route traffic that needs ARP requests. The range is 1-65535
pps.

Rate limit CP
session mirror
traffic (pps)

Indicates the rate limit value of sessionmirrored traffic forwarded to the Aruba Gateway
device. The range is 1-65535 pps.

Rate limit CP
VRRP traffic
(pps)

Indicates the rate limit value of VRRP traffic that hits the control plane. The range is 1-65535
pps.

Rate limit CP
ARP traffic
(pps)

Indicates the rate limit value of ARP traffic that hits the control plane. The range is 1-65535
pps.

Rate limit CP
l2
protocol/other
traffic (pps

Indicates the rate limit value of other L2 traffic that hits the control plane. The range is 1-
65535 pps.

Rate limit CP
auth process
traffic (pps)

Indicates the rate limit value of the traffic that is forwarded to the authentication process. The
range is 1-65535 pps.

Rate limit CP
IKE traffic
(pps)

Indicates the rate limit value of IKE traffic that hits the control plane. The range is 1-65535 pps.

Table 36: Firewall Parameters
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Parameter Description

Jumbo frames
processing

Enables Jumbo frames processing for data frames that are larger than 1500 bytes. You can
specify a value in the Jumbo MTU[1789-9216] bytes field. The The range is 1789-9216 bytes.
The default value is 9216 bytes.

Mark
management
frames

Enables marking of management frames.

Trust client
QoS

Uses the DSCP set by client to prioritize the RTP traffic.

Table 36: Firewall Parameters

Advanced Monitoring Parameters

Parameter Description

App Performance Monitoring Enables application performance monitoring.

DHCP Performance Monitoring Enables DHCP and DNS server performance monitoring.

Table 37: Advanced Monitoring

Configuring User Roles for Clients
A client device in an Aruba user-centric network is associated with a user role that determines the access
privileges, bandwidth contract assignments, and frequency of client authentication.

A client device is assigned a user role by several methods. The following list shows the role assignment
preferences for a branch network:

1. Initial user role—The initial user role or VLAN for unauthenticated clients is configured in the AAA
profile.

2. User-derived role—The user role can be derived fromuser attributes when a client connects to an AP.
You can configure access rules to assign a user role to the clients that match a specific criteria. For
example, you can configure a rule to assign the roleVoIP-Phone to any client that has aMAC address
that starts with bytes xx:yy:zz. The user-derived roles are applied before client authentication.

3. Default user role—The user role can be the default user role configured for an authentication
method, such as 802.1X or VPN. For each authenticationmethod, you can configure a default role
for the clients that successfully authenticate based on the specified authenticationmethod.

4. Server-derived role—The user role can be derived from attributes returned by the authentication
server and certain client attributes. If the client authenticates through an authentication server, the
user role for the client can be based on one ormore attributes returned by the server during
authentication, or on client attributes such as SSID (even if the attribute is not returned by the
server). Server-derived roles are applied after client authentication.

5. VSA-Derived Role—Many NAS vendors, including Aruba, use vendor-specific attributes to provide
features that are not supported in standard RADIUS attributes. The Aruba VSAs allow deriving user
roles and VLAN for the clients that authenticate to the RADIUS server. A role derived from a VSA takes
precedence over other types of user roles.

Refer to the following topics to know how to configure User Roles for clients:
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n Creating a Role

n Assigning a Policy to a Role

n Assigning User Roles in AAA Profiles

n Configuring a Default Role Based on AuthenticationMethods

Creating a Role
To create a user role:

1. To configure a Branch Gateway group or a Branch Gateway, complete either one of these steps:

2. Click Security > Roles.

3. Click + from theRoles table to create a new role.

4. Enter a name for the new role and click Save Settings.

5. To add access rules, click + underRULES of this Role only and configure access rules.

6. Click Save Settings.

Assigning a Policy to a Role
To add a policy to a role:

1. Select the role name from theRoles table.

2. Click + under the Policies tab.

3. Select theAdd an existing policy option.

4. Select a policy type from the Policy type drop-down list. Select the policy type as Route to apply
PBR policies.

5. Select a policy from the Policy name drop-down list.

6. Click Save Settings.

7. (Optional) If the user role containsmore than one firewall policy, use the up and down arrows to
assign priorities to each policy. The higher the position of the policy on the list, the higher its priority.

Assigning User Roles in AAA Profiles
AAA profiles define user roles for unauthenticated clients (initial role) as well as the default user role forMAC
and 802.1X authentication.

To assign user roles in a AAA profile:

1. To configure a Branch Gateway group or a Branch Gateway, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.
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c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. Click Security > AAA Profiles.

3. Click + to create a new role.

4. Select a profile underAAA Profiles.

5. Select the default profile or a user-defined AAA profile.

6. Select the desired user role for unauthenticated users, from the Initial Role drop-down list.

7. Select the desired user role for users who have completed 802.1X authentication, from the 802.1X
Authentication Default Role drop-down list.

8. Select the desired user role for clients who have completedMAC authentication, from theMAC
Authentication Default Role drop-down list.

9. Click Save Settings.

Configuring a Default Role Based on Authentication Methods
You can configure a default role for the clients that authenticate using the specified authentication that
method. To configure a default role for an authenticationmethod:

1. To configure a Branch Gateway group or the Branch Gateway for which you want to configure a
default role for a specific authenticationmethod, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. Click Security > AAA Profiles.

3. Click + to create a new role.

4. To configure the default user role forMAC or 802.1X authentication, select theAAA Profiles tab.

5. Select an AAA profile underAAA Profiles and select the desired user role forMAC Authentication
Default Role or 802.1X Authentication Default Role.

6. To configure the default user role for other authenticationmethods, select the L2 Authentication
or L3 Authentication tab.
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a. Select the authentication type (Stateful 802.1X for L2 Authentication, Captive Portal or VPN
Authentication for L3 Authentication).

b. Select the profile.

c. Enter the user role forDefault Role.

7. Click Save Settings.

Configuring Bandwidth Contracts
Aruba Central allows you to configure application specific bandwidth contracts forWLAN andWAN clients.
By default, bandwidth contracts for applications are applied on a per-role basis.

You can also configure an exclude list to exclude applications or application categories on which a generic
user or role bandwidth-contract is not applied. Use the exclude list option to prioritizemission-critical
applications over other user traffic. An enterprisemay havewell known applications such asMicrosoft
Exchange, SAP, Oracle, accounting and finance applications, and other enterprise resource planning or
customer relationshipmanagement applications.

Instead of enumerating bandwidth limits for each application individually on a per-user or per-role basis,
you can configure a single bandwidth contract to limit all non-mission-critical applications. You can then
exclude all mission-critical applications by placing them in an exclude list. This way, mission-critical
applications will not be rate-limited.

Assigning Bandwidth Contracts to User Roles
To configure bandwidth contract, complete the following procedure:

1. To configure a Branch Gateway group or a Branch Gateway, complete either one of these steps:

2. Click Security > Roles.

3. Select a role name from theRoles table and select theBandwidth tab.

4. To add an application or application category to a bandwidth contract, click + under Per-Application
Limits for This Role.

a. Select the application bandwidth type from the Type drop-down list.

b. Select the name of the bandwidth contract from theName drop-down list.

c. Enter values in Kbits orMbits in theUpstream and Downstream fields.

d. Click Submit.

5. To add an exception, click + under Per-Application Limit Exceptions for This Role.

a. Enter the name of the application or application category.

6. Click Save Settings.

Configuring Global Bandwidth Contracts for Applications
To configure bandwidth contract, complete the following steps:
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1. To configure a Branch Gateway group or a Branch Gateway, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. Click Security > Applications.

3. Expand Per-Application Limits.

4. To add an application or application category to a bandwidth contract, click + underGlobal Per-
Application Limits . TheAdd Application Limit section is displayed.

5. Select the application bandwidth type from the Type drop-down list.

6. Select the name of the bandwidth contract from theName drop-down list.

7. Enter values in Kbits orMbits in theUpstream and Downstream fields.

8. Click Save Settings.

Ensure that Deep Packet Inspection is enabled.

1. In the IP protocol number(1-255)orIP protocol field, enter the number for a protocol or select the
protocol from the drop-down list used by session traffic

2. In the Starting ports field, enter a starting port. This is the first port, in the port range, on which
permitted or denied session traffic is running. Port range: 1–65535.

3. In the End port field, enter an ending port. This is the last port, in the port range, on which permitted
or denied session traffic is running. Port range: 1–65535.

4. (Optional) Select the name of the bandwidth contract to which the session traffic should be applied,
from theWhite list bandwidth contract drop-down list.

5. Click Save Settings. The ACL displays on thewhite list section.

Configuring Authentication Profiles
The Aruba SD Branch solution supportsmultiple types of authenticationmethods. Based on your network
goals, security requirements, user types, and the types of client devices, you can configure a AAA profile with
a specific authenticationmethod that is suitable for your Layer 2 and Layer 3 security infrastructure.

For example, you can choose to configure an authentication profile with 802.1X orMAC authentication, and
configure an authentication server or server group to allow role assignment to client devices.
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See the following topics formore information how to set up authentication sources and profiles.

n Configuring RADIUS Authentication Server on ArubaGateways on page 307

n Configuring Other External Authentication Servers on ArubaGateways on page 309

n Configuring Authentication Survivability on a Branch Gateway on page 314

n Configuring Server Groups on page 315

n Creating a AAA Profile on page 315

Configuring RADIUS Authentication Server on Aruba Gateways
To add a RADIUS authentication server, complete the following procedure:

1. To configure a Branch Gateway group or Branch Gateway, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. Click Security > Auth Servers.
3. Click + underAll Servers.
4. Enter a name for the new server.

5. Enter the IP address for the new server.

6. To configure a RADIUS server, select RADIUS as the server type.
7. In theAll Servers table, select the name of the new RADIUS server and configure parameters
described in Table 38.

Code Description

Name Name of the RADIUS server.

IP address /
hostname

IP address or FQDN of the authentication server. The maximum supported FQDN length is 63
characters. Default: N/A

Secure
radius

Enable this option to secure communication between the RADIUS server and the Branch
Gateway. Specify values for the following parameters:

n Secure auth port—The destination port for RADIUS over TLS. By default, the value is set
to 2083.

Table 38: RADIUS Server Configuration Parameters
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Code Description

n Radsec trusted CA name—The CA certificate that is uploaded as a Trusted CA if the
Radsec server uses a certificate signed by a CA.
n Radsec server cert name—The server certificate that is uploaded.
n Radsec client cert—The client certificate sent to the Radsec server.

Auth port Authentication port of this server. The default value is 1812.

Acct port Accounting port of this server. The default value is 1813.

Shared key Shared secret between the Branch Gateway and the authentication server. The maximum
length is 128 characters.

Retype key Retype shared secret key.

Timeout Maximum time, in seconds, that the Branch Gateway waits before timing out the request and
resending it. The default value is 5 seconds.

Retransmits Maximum number of retries sent to the server by the Branch Gateway before the server is
marked as down. The default value is 3.

NAS ID NAS identifier to use in RADIUS packets.

NAS IP The NAS IP address to be sent in RADIUS packets from that server.

Use MD5 Use MD5 hash of cleartext password.

Enable Enable the use of IPv4 address for the server.

Lowercase
MAC
addresses

SendMAC address with lowercase in the authentication and accounting requests to this server.

Use IP
address for
calling
station ID

Enables using the IP address as the calling station ID.

MAC address
delimiter

SendMAC address with the following delimiters in the authentication and accounting requests
of this server:

n colon: SendMAC address as XX:XX:XX:XX:XX:XX
n dash: SendMAC address as XX-XX-XX-XX-XX-XX
n none: SendMAC address as XXXXXXXXXXXX
n oui-nic: SendMAC address as XXXXXX-XXXXXX

Service-type
of FRAMED-
USER

Send the service-type as FRAMED-USER instead of LOGIN-USER. For more information, see
RADIUS Service-Type Attribute on page 176.

CPPM
credentials

If you are using ClearPass Policy Manager as the RADIUS server, provide user credentials for
ClearPass Policy Manager server.

CALLED STATION ID

Station ID
type

Select any of the following options to configure called station ID:

n MAC Address — Uses theMAC address as the called station ID.

Table 38: RADIUS Server Configuration Parameters
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Code Description

n AP group — Uses the host name of the Instant AP as the called station ID.

n AP MAC address —Uses theMAC address of the Instant AP as the called station ID.

n AP name —Uses the host name of the Instant AP as the called station ID.

n IP address —Uses the IP address of the Instant AP as the called station ID.

n VLAN ID —Uses the VLAN ID of as the called station ID.

Station ID
delimiter

Select a character such as Colon or Dash as the delimiter for the string.

Include SSID Select the checkbox to append the SSID name to the called station ID.

Table 38: RADIUS Server Configuration Parameters

8. Click Save Settings.

Configuring an RFC 3576 Server
You can configure a RADIUS server to send user disconnect, CoA, and session timeout messages as
described in RFC 3576, “Dynamic Authorization Extensions to RemoteDial In User Service (RADIUS).”

To configure an RFC 3576 server, complete the following procedure:

1. To configure a Branch Gateway group or Branch Gateway, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. Click Security> Auth Servers.
3. Click + underAll Servers.
4. Select RFC 3576 from the Type drop-down list.

5. Enter the IP address for the new server.

6. Enter the server authentication key into theKey and Retype key fields.

7. Click Save Settings.

Configuring Other External Authentication Servers on Aruba
Gateways
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This section describes how to configure external authentication servers:

Configuring an LDAP Server
To configure an LDAP server, complete the following steps:

1. To configure a Branch Gateway group or Branch Gateway, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. Click Security > Auth Servers.

3. UnderAll Servers, click the + icon to add a new server.

4. Set the Type to Ldap and click Submit.

5. From theAll Servers list, select the server to edit properties.

6. Configure the parameters described in the following table:

Parameter Description

Host IP address of the LDAP server.

Admin-dn Distinguished name for the admin user who has read or search privileges across all
the entries in the LDAP database (the user does need write privileges, but can search
the database, and read attributes of other users in the database).

Admin-passwd Password for the admin user.

Re-type
admin-passwd

Retype the password for the admin user for confirmation.

Allow clear-
text

Allows clear text (unencrypted) communication with the LDAP server.
Default: disabled

Auth port Port number used for authentication.
Default: 389

Base-dn Distinguished Name of the node that contains the entire user database.

Table 39: LDAP Server Configuration Parameters
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Parameter Description

Filter A string search for users in the LDAP database. The default filter string is:
(objectclass=*).

Key attribute A string search for an LDAP server. For Active Directory, the value is
sAMAccountName.
Default: sAMAccountName

Timeout Timeout period of an LDAP request, in seconds.
Default: 20 seconds

Enable Option to enable or disable the server.
Default: enabled

Preferred
connection
type

Preferred type of connection between a Branch Gateway and the LDAP server. The
default order of connection type is:

1. ldap-s
2. start-tls
3. clear-text

The Branch Gateway first attempts to contact the LDAP server using the preferred
connection type, and only attempts to use a lower-priority connection type if the first
attempt is not successful.

NOTE: If you selected clear-text as the preferred connection type, youmust also
enable the allow-cleartext option.

Maximum
number of
non-admin
connections

Configure the maximum number of non-admin connections to the server.
Default: 4

Chase referrals Chase referrals anonymously.

Table 39: LDAP Server Configuration Parameters

7. Select the Enable check box to activate the authentication server.

8. Click Submit.

Configuring a TACACS+ Server
To configure a TACACS+ server, complete the following steps:

1. To configure a Branch Gateway group or Branch Gateway, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.
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c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. Click Security > Auth Servers.

3. UnderAll Servers, click the + icon to add a new server.

4. Set the Type to Tacacs.

5. Enter the serverName and its IP address.

6. Click Submit.

7. From theAll Servers list, select the server to configure server parameters.

8. Configure the parameters described in the following table:

Parameter Description

Host IP address of the server.

Key Shared secret to authenticate communication between the TACACS+ client and server.

Retype key Retype the shared secret for confirmation.

TCP port TCP port used by server.

Retransmits Maximum number of times a request is retried.
Default: 3

Timeout Timeout period for TACACS+ requests (in seconds).
Default: 20 seconds

Mode Option to enables or disable the server.
Default: enabled

Session
authorization

Option to enable or disable session authorization. Session authorization turns on the
optional authorization session for admin users.
Default: disabled

Table 40: TACACS+ Server Configuration Parameters

Configuring a Windows Server
To configure aWindows server, complete the following steps:

1. To configure a Branch Gateway group or Branch Gateway, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.
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n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. Click Security > Auth Servers.

3. UnderAll Servers, click the + icon to add a new server.

4. Set the Type to Windows.

5. Enter the serverName and its IP address fields, respectively.

6. Click Submit.

7. From theAll Servers list, select the server to configure server parameters.

8. Configure the parameters described in the following table:

Parameter Description

Host IP address of the server.

Mode Option to enable or disable the server.
Default: enabled

Windows Domain Name of the Windows Domain assigned to the server.

Table 41: Windows Server Configuration Parameters

Configuring XML API Server
To configure an XML API server, complete the following steps:

1. To configure a Branch Gateway group or Branch Gateway, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.
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2. Click Security > Auth Servers.

3. UnderAll Servers, click the + icon to add a new server.Set the Type to XML.

4. Enter the server IP address.

5. Enter the server authentication key in theKey and Retype key fields.

6. Click Submit.

Configuring Authentication Survivability on a Branch Gateway
Authentication survivability is required for all sites where authentication transactions traverse aWAN. It's
primary function is to prevent remote link failures between aGateway device and an authentication server
that is either in the cloud or a data center. However, if the connectivity between theGateway and the
authentication server is lost for a limited amount of time, this feature ensures that the known users can
securely join the network even if the authentication server is unavailable.

To configure authentication survivability on a Branch Gateway, complete the following procedure:

1. To configure a Branch Gateway group or Branch Gateway, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. Click Security > Auth Servers.

3. Click theAuthentication Survivability drop-down and slide the toggle switch next to Enable
authentication survivability.

4. Select a valuewithin the range of 1 to 7 days from the Local cache lifetime drop-down to set the
duration after which the authenticated credentials in the cache expires. When the cache expires, the
clients are required to authenticate again.

5. From theCA Certificate drop-down, select the client's CA certificate to be configured as Trusted CA
cert on theGateway device. You can addmultiple CA certificates in this field.

6. From theCA Certificate drop-down, select the client's CA certificate to be configured as Trusted CA
cert on theGateway device. You can addmultiple CA certificates in this field.

7. From theAuthentication server certificate drop-down, select a server certificate used by the local
survival server to terminate EAP-TLS for 802.1X authentication.

8. Click Save Settings.
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Authentication Survivability is supported in deployments where the SD-WAN gateway is used as an
authenticator.
Authentication Survivability is not supported in deployments where the SD-WAN gateway is used for
stateful 802.1x authentication

Configuring Server Groups
You can create server groups to distinguish authentication servers and for the ease of use. For example, you
can configure a server group based on the following criteria:

n User authentication—Servers that authenticate client devices.

n Management authentication—Servers that authenticatemanagement users such as the Branch Gateway
admin.

n Accounting—Servers that support accounting.

Accounting is supported only with RADIUS and TACACS servers.

To add a server group:

1. To configure a Branch Gateway group or Branch Gateway, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. Click Security > Auth Servers.

3. Under Server, click the + icon to add a new server.

4. Enter theName of the server group.

5. Click Submit.

6. From the Server Groups list, select a server group and assign the servers.

7. Click Save Settings.

Creating a AAA Profile
To configure a AAA profile:
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1. To configure a Branch Gateway group or Branch Gateway, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Click Security > Role Assignment (AAA Profiles).

4. Select AAA underAAA Profiles.

5. Click + underAAA Profile: New Profile to define AAA profile settings.

6. Enter a name for the profile in the Profile name field, then configure the AAA profile parameters
described in Table 42.

Parameter Description

Initial role Assigns role for the unauthenticated users. The default role for unauthenticated
users is logon.

MAC
authentication
default role

Assigns role after the client device completes MAC authentication. The default role
for MAC authentication is the guest user role.

802.1X
authentication
default role

Assigns role after the client device completes 802.1X authentication.

Download role
from CPPM

Allows Aruba Gateways to download roles from Clear Pass Policy Manager.

Set username
from dhcp
option 12

Assigns a user name from DHCP option 12.

l2
authentication
fail through

WhenMAC authentication fails and if 802.1X authenticationmethod is configured,
client devices are assigned roles after they complete 802.1x authentication.

Table 42: AAA Profile Parameters
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Parameter Description

Multiple server
accounting

Enables SD-WAN Gateways to send accounting messages to all the servers
configured in the server group in a sequential order.

User idle
timeout

Configures a session time out value for inactive user sessions. A value of 0, deletes
the user immediately after disassociation from the wireless network. Valid range is
30-15300 in multiples of 30 seconds. Specifying a value overrides the global settings
configured in the AAA timers.

RADIUS roaming
accounting

Creates an accounting session for each client. The records in the session contain the
same set of RADIUS attributes as compared to the timer-based RADIUS Interim-
Update Accounting record, except the statistics attributes.

RADIUS interim
accounting

Enables Branch Gateway to send Interim-Update messages with current user
statistics to the server at regular intervals. This option is disabled by default, allowing
the Branch Gateway to send only start and stopmessages to the RADIUS accounting
server.

RADIUS acct-
session-id in
access-request

An accounting ID for the start and stop record of the session. This option is disabled
by default.

User derivation
rules

Specifies a profile from which the user role or VLAN is derived.

Reauthenticate
wired user on
VLAN change

Enable this feature to keep users authenticated when they roam from the wired side
of the network. This feature is disabled by default.

Device type
classification

Allows SD-WAN Gateways to parse user-agent strings and attempt to identify the
type of device connecting to the AP.

Enforce DHCP Allows clients to obtain IP from DHCP before associating to an AP. Enable this option
when you create a user rule that assigns a specific role or VLAN based upon the
client device’s type.

PAN firewalls
Integration

Requires IP mapping at Palo Alto Networks firewalls.

Apply ageout
mechanism on
bridge mode
wireless clients

Enable this feature for the bridge entry to not age out as long as the wireless client is
associated with the AP. The bridge entry is deleted only when the wireless client is
deleted. This feature is disabled by default.

7. Click Save Settings.

8. Assign AAA policy to VLAN interfaces.

Configuring Authentication Timers
To set an authentication timer, complete the following steps:

1. To configure a Branch Gateway group or Branch Gateway, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.
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b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. Click Security > Advanced.

3. Click Authentication Timers.

4. Configure the timers as described in Table 43:

Timer Description

User idle
timeout

Maximum period after which a client is considered idle if there is no wireless traffic
from the client. The timeout period is reset if there is wireless traffic. If there is no
wireless traffic in the timeout period, the client is aged out. Once the timeout period
has expired, the user is removed. If the keyword seconds is not specified, the value
defaults to minutes at the command line.
Range: 1–255 minutes (30–15300 seconds)
Default: 5 minutes (300 seconds)

Authentication
server dead
time (min)

Maximum number of minutes after which the Branch Gateway considers an
unresponsive authentication server to be out of service.
This timer is only applicable if there are two or more authentication servers
configured on a Branch Gateway. If there is only one authentication server configured,
the server is never considered out of service, and all requests are sent to the server.
If one or more backup servers are configured and a server is unresponsive, it is
marked as out of service for the dead time; subsequent requests are sent to the next
server on the priority list for the duration of the dead time. If the server is responsive
after the dead time has elapsed, it can take over servicing requests from a lower-
priority server; if the server continues to be unresponsive, it is marked as DOWN for
the dead time.
Range: 0–50 minutes
Default: 10 minutes

Logon user
lifetime (min)

Maximum time, in minutes, for which all unauthenticated clients are allowed to remain
logged on.
Range: 0–255 minutes
Default: 5 minutes

User interim
stats
frequency

Sets the timeout value (in minutes or seconds) for user statistics and reporting.
Range: 300–600 seconds, or 5–10 minutes
Default: 600 seconds

Table 43: Authentication Timers Parameters

5. Click Save Settings.

L3 Authentication
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The following sections describe the different L3 authenticationmethods:

n Captive Portal Authentication on page 319

n VIA Authentication on page 322

n VPN Authentication on page 330

Captive Portal Authentication
Captive portal is one of themethods of authentication supported by ArubaOS. A captive portal presents a
web pagewhich requires user action before network access is granted. The required action can be simply
viewing and agreeing to an Acceptable Usage Policy, or entering a user ID and password whichmust be
validated against a database of authorized users.

You can also configure captive portal to allow clients to download the Aruba VPN dialer forMicrosoft VPN
clients if the VPN is to be terminated on the VPN Concentrator.

You can configure captive portal for guest users, where no authentication is required, or for registered users
whomust be authenticated against an external server or the internal database of the Branch Gateway.

While you can use captive portal to authenticate users, it does not provide for encryption of user data
and should not be used in networks where data security is required. Captive portal is most often used
for guest access, access to open systems (such as public hot spots), or as a way to connect to a VPN.

Captive portal can be used for guest and registered users at the same time. The default captive portal web
page provided with ArubaOS displays login prompts for both registered users and guests. You can also load
up to 16 different customized login pages into the Branch Gateway. The login page displayed is based on
the SSID to which the client associates.

Policy Enforcement Firewall Next Generation License

You can use captive portal with or without the PEFNG license installed in the VPN Concentrator. The PEFNG
license provides identity-based security to wired and wireless clients through user roles and firewall rules.
Youmust purchase and install the PEFNG license on the VPN Concentrator to use identity-based security
features.

There are differences in how captive portal functions work and how you configure captive portal, depending
on whether the license is installed. Other parts of this chapter describe how to configure captive portal in
the base operating system (without the PEFNG license) and with the license installed.

Server Certificate

The Branch Gateway is designed to provide secure services through the use of digital certificates. The server
certificate is installed on the Branch Gateway through the VPN Concentrator. A server certificate installed in
the Branch Gateway verifies the authenticity of the Branch Gateways for captive portal.

The Branch Gateway ships with a demonstration self-signed certificate. Until you install a customer-specific
server certificate in the Branch Gateway, this demonstration self-signed certificate is used by default for all
secure HTTP connections such as captive portal. This self-signed certificate is included primarily for the
purposes of feature demonstration and convenience and is not intended for long-term use in production
networks. Users in a production environment are urged to obtain and install a certificate issued for their site
or domain by awell-known CA. You can generate a CSR on the Branch Gateway to submit to a CA.

The Branch Gateway can accept wild card server certificates (CN begins with an asterisk). If a wildcard
certificate is uploaded (for example, CN=*.domain.com), the asterisk in CN is replaced with 'captiveportal-
login' in order to derive the Captive Portal logon pageURL (captiveportal-login.domain.com).
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Once you have imported a server certificate from the VPN Concentrator to Branch Gateway, you can select
the certificate to be used with captive portal.

The following sections present the procedure for configuring the captive portal authentication profile, the
AAA profile, and the virtual AP profile using theWebUI or the CLI. Configuring the VLAN and authentication
servers and server groups are described elsewhere in this document.

To configure captive profile authentication parameters:

1. To configure a Branch Gateway group or Branch Gateway, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. Click Security > L3 Authentication.

3. Select Captive Portal Authentication profile.

a. Click + to create a new Captive Portal Authentication Profile, enter the name of the profile.

b. You can enable user login and guest login, and configure other captive portal profile parameters as
described in Table 44.

c. Click Save Settings.

Parameter Description

Default Role Role assigned to the Captive Portal user upon login. When both user and guest logon are
enabled, the default role applies to the user logon; users logging in using the guest interface
are assigned the guest role.
Default: guest

Default Guest
Role

Role assigned to guest.
Default: guest

Redirect Pause Time, in seconds, that the system remains in the initial welcome page before redirecting the
user to the final web URL. If set to 0, the welcome page displays until the user clicks on the
indicated link.
Default: 10 seconds

User Login Enables Captive Portal with authentication of user credentials.

Table 44: Captive Portal Authentication Profile Parameters
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Parameter Description

Default: Enabled

Guest Login Enables Captive Portal logon without authentication.
Default: Disabled

Logout popout
window

Enables a pop-up window with the Logout link for the user to logout after logon. If this is
disabled, the user remains logged in until the user timeout period has elapsed or the station
reloads.
Default: Enabled

Use HTTP for
authentication

Use HTTP protocol on redirection to the Captive Portal page. If you use this option, modify the
captive portal policy to allow HTTP traffic.
Default: disabled (HTTPS is used)

Logon wait
minimum wait

Minimum time, in seconds, the user will have to wait for the logon page to pop up if the CPU
load is high. This works in conjunction with the Logon wait CPU utilization threshold
parameter.
Default: 5 seconds

Logon wait
maximum
wait

Configure parameters for the logon wait interval
Default: 10 seconds

Logon wait
CPU
utilization
threshold

CPU utilization percentage above which the Logon wait interval is applied when presenting
the user with the logon page.
Default: 60%

Max
Authentication
failures

Maximum number of authentication failures before the user is blacklisted.
Default: 0

Show FQDN Allows the user to see and select the FQDN on the login page. The FQDNs shown are
specified when configuring individual servers for the server group used with captive portal
authentication.
Default: Disabled

Authentication
Protocol

Select the PAP, CHAP or MS-CHAPv2 authentication protocol.

NOTE: Do not use the CHAP = option unless instructed to do so by an Aruba representative.

Login Page URL of the page that appears for the user logon. This can be set to any URL.
Default: /cgi-bin/login?cmd=authenticate or /cgi-bin/login?cmd=login

Welcome Page URL of the page that appears after logon and before redirection to the web URL. This can be
set to any URL.
Default: /auth/welcome.html

Show
Welcome Page

Displays the configured welcome page before the user is redirected to their original URL. If
this option is disabled, users are redirected to the web URL immediately after they log in.
Default: Enabled

Proxy server
configuration

Configure captive portal to work with proxy Web servers. Enter the address and port details of
the proxy server.
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Parameter Description

Add gateway
IP in
redirection
URL

Sends the IP address of the Branch Gateway in the redirection URL when external captive
portal servers are used. An external captive portal server can determine the Branch Gateway
from which a request originated by parsing the ‘switchip’ variable in the URL.
Default: Disabled

Add user vlan
in the
redirection
URL

Sends the user VLAN ID in the redirection URL when external captive portal servers are used.

Add a gateway
interface in
the redirection
URL

Sends the interface IP address of the Branch Gateway in the redirection URL when external
captive portal servers are used. An external captive portal server can determine the Branch
Gateway from which a request originated by parsing the ‘switchip’ variable in the URL.

Allow only one
active user
session

Allows only one active user session at a time.
Default: Disabled

White List To add a netdestination to the captive portal whitelist, enter the destination host or subnet,
then click Add. The netdestination will be added to the whitelist. To remove a netdestination
from the whitelist, select it in the whitelist field, then click Delete.
If you have not yet defined a netdestination, use the CLI command netdestination to define a
destination host or subnet before you add it to the whitelist.
This parameter requires a PEFNG license.

Black List To add a netdestination to the captive portal blacklist, enter the destination host or subnet,
then click Add. The netdestination will be added to the blacklist. To remove a netdestination
from the blacklist, select it in the blacklist field, then click Delete.
If you have not yet defined a netdestination, use the CLI command netdestination to define a
destination host or subnet before you add it to the blacklist.

Show
Acceptable
Use Policy
Page

Show the acceptable use policy page before the logon page.
Default: Disabled

User idle
timeout

The user idle timeout value for this profile. Specify the idle timeout value for the client in
seconds. Valid range is 30-15300 in multiples of 30 seconds. Enabling this option overrides
the global settings configured in the AAA timers. If this is disabled, the global settings are
used.

Redirect URL URL to which an authenticated user will be directed. This parameter must be an absolute URL
that begins with either http:// or https://.

URL Hash Key If a redirection URL is defined, enter a URL Hash Key to hash the redirect URL using the
specified key.
This parameter enhances security for the ClearPass Guest login URL so that ClearPass Policy
Manager can trust and ensure that the client MAC address in the redirect URL has not been
tampered with by anyone. Default: Disabled.

VIA Authentication
For detailed information on the Aruba VIAsolution, see Configuring Support for Aruba VIA Service on page
434

Configuring VIA Authentication Profile
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The VIA authentication profile defines the authentication server group used and the default role assigned to
the authenticated users. Multiple authentication profiles can be created. Whenmultiple authentication
profiles are available, the VIA client prompts the user to select an authentication profile.

The VIA authentication profile is a critical part of VIA configuration and it is used for these purposes:

n To determine the authentication server for the XAUTH authentication phase of IKEv1 and EAP
authentications of IKEv2.

n To determine the authentication server for the VIAweb authentication. The VIA authentication profile is an
integral part of the VIAweb authentication, which determines the authentication sever used for VIA
bootstrap process and for authenticating users on the VIA installer download page of the
VPN Concentrator. Formore information on VIAweb authentication see Configuring VIAWeb
Authentication.

To configure a VIA authentication profile, complete the following steps:

1. To configure a Branch Gateway group or a Branch Gateway, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Click Security > L3 Authentication.

4. Select VIA Authentication.

5. Click + to create a new VIA authentication profile or select an existing profile. You can also use the
predefined defaultVIA authentication profile.

6. After selecting the required profile, select the role that you defined for the VIA users in theDefault
role field. Formore information on configuring the other parameters for this profile, see Table 45.

7. Select the required server group for authentication from the appropriate server group option under
the selected profile. The server group options areRADIUS Accounting Server Group, RFC 3576
Server, and Server Group. Optionally you can configure the following options for the selected
server group:

n Fail through—Enables the fail through option for the server group.

n Load balance—Enables load balancing among the servers for authentication requests.

8. Save the changes.
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Parameter Description

Default Role Select the role that you want to be assigned as the default role for the client
when authenticating using this profile. By default, the default-via-role is
assigned.

Max Authentication failures Maximum number of authentication failures allowed for the client. Allowed
range is 1-10 and the default value is 0.

Description Description of the authentication profile.

Check certificate common
name against AAA server

Select this option to check for certificate common name against the AAA
server. Default: enabled.

Client-certificate based
authentication for VIA
Profile download

Select this option to enable client-certificate based authentication for VIA
Profile download. By default, this is disabled.

Authentication protocol Select the authentication protocol to be used. The default value is PAP.

Download Role from CPPM Select this option to download the default role from ClearPass Policy
Manager, if the default role is not defined.

Table 45: VIA Authentication Profile Parameters

Configuring VIA Connection Profile

The VIA connection profile is a collection of all the configurations required by a VIA client. The VIA
connection profile contains all the details required for the VIA client to establish a secure IPsec connection to
the VPN Concentrator. A VIA connection profile also defines other optional parameters. Such optional
parameters can be client auto-login, split-tunnel settings, and Content Security Services (CSS) settings. You
can configuremultiple VIA connection profiles.

A VIA connection profile is always associated to a user role, and all users that belong to that role use the
configured settings. When a user authenticates successfully to a server in an authentication profile, the VIA
client downloads the VIA connection profile that is attached to the role assigned to that user.

Table 46 summarizes the various parameters of a VIA connection profile .

To configure a VIA connection profile, complete the following steps:

1. In theNetwork Management app, use the filter to select a VPN Concentrator group or VPN
Concentrator.

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.
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d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. Click Security > L3 Authentication.

3. Select VIA Connection.

4. Click + to create a new VIA connection profile or select an existing profile. You can also use the
predefined defaultVIA connection profile.

5. After selecting the required profile, configure the various VIA connection profile parameters as
described in Table 46

6. Save the changes.

Parameter Description

VIA servers This parameter has the following fields:
n Addr—Add the public IP or DNS hostname of the VPN Concentrator. This is the host
name or IP address that the users enter as the remote server information on the VIA
client.
n Internal IP—Add the IP address of any of the internal VLAN interfaces of the
VPN Concentrator. This IP address should not be reachable from the public Internet.
The VIA client uses this IP address to determine whether or not the user is connected
to a trusted network.
n Description—Add a human-readable description of the VIA server.

NOTE: More than one VIA server can be added to the list.

Client auto-login Enabling client auto-login makes the VIA client detect untrusted network and connect
automatically. If you disable auto-login, VIA stays idle after it comes up and the user has
to manually click Connect to establish a VPN connection even though an untrusted
network is detected.
Default: enabled

VIA authentication
profiles to
provision

This VIA authentication profile is used to determine the authentication server used for the
IKE authentication process. If more than one VIA authentication profile is added to this
list, the users can choose the VIA authentication profile to be used during IKE
authentication. If no VIA authentication profile is defined, the users are authenticated
against the server group that is specified by the default VIA authentication profile
(predefined).

Allow client to
auto-upgrade

This parameter allows the VIA client to automatically upgrade if a newer version of VIA is
available on the VPN Concentrator. By default this is enabled.

VIA tunneled
networks

When split-tunneling is enabled, the VIA client tunnels traffic to the VPN Concentrator for
all the network destinations (IP address and netmask) listed in this parameter. All other
network destinations are bridged appropriately on the client.
If split-tunnel is disabled, all the traffic is tunneled to the VPN Concentrator irrespective of
the destination.

Enable split
tunneling

When enabled, all traffic to the VIA tunneled networks goes through the VPN
Concentrator and the rest is bridged directly on the client.
If split-tunnel is disabled, all the traffic is tunneled to the VPN Concentrator irrespective of
the destination.

Allow client-side
logging

This parameter determines whether client side logging is allowed or not. If enabled, VIA
client collects logs that can be sent to the support email address for troubleshooting.
Default: Enabled

Table 46: VIA Connection Profile Parameters
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Parameter Description

VIA IKEv2 Policy This IKE policy is used for IKEv2 connections by the VIA client. Remember that IKEv2 using
PSK is not supported for VIA. For more information on configuring IKE policies, see
Configuring IKE Policies.

VIA IKE Policy This IKE policy is used for IKEv1 connections by the VIA client. This policy determines
whether IKEv1 phase 1 authentication uses PSK or certificates. For more information on
configuring IKE policies, see Configuring IKE Policies.

Use windows
credentials

This parameter determines whether the Windows credentials are used automatically to
login to VIA. If enabled, the single sign-on feature can be utilized by remote users to
connect to internal resources.
Default: Enabled

Enable IKEv2 This parameter enables or disables IKEv2.

Use suite b
cryptography

This parameter enables or disables Suite B cryptographic methods.

IKEv2
authentication
method

This parameter indicates the IKEv2 client authenticationmethod. It can be one of these
settings:
l user-cert
l EAP-TLS
l EAP-MSCHAPv2
Remember that EAP termination on the VPN Concentrator is not supported.

VIA IPSec v2
crypto map

This IPsec map is used by IKEv2 VIA client to connect to the VPN Concentrator.

VIA IPSec crypto
map

This IPsec map is used by IKEv1 VIA client to connect to the VPN Concentrator.

Allow user to save
passwords

This parameter determines whether the users can save the passwords entered in VIA or
not. If this is enabled, the user credentials that were able to successfully establish a VIA
connection are saved securely until VIA is uninstalled or until IKE authentication fails with
stored credentials. If this option is disabled, VIA prompts for credentials every time it
establishes a connection.
If secure tokens such as the RSA tokens are used for authentication, disable this option to
prompt the user for a password/token for each connection attempt.
By default, this is enabled.

Enable supplicant This parameter enables the supplicant mode.

Enable FIPS
module

This parameter enables the VIA FIPS module.

Auto-launch
supplicant

This parameter automatically connects to the configured WLAN network.

Lockdown all
settings

This parameter locks all the configuration options available on the end-user VIA client. If
this option is enabled, a VIA user can only connect, disconnect or send logs.
Diagnostics such as traceroute and ping can still be used, but no settings can be
changed.

NOTE: This option is available in VIA 2.1 and later versions.
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Parameter Description

Domain suffix in
VIA authentication

This parameter enables domain suffix in VIA authentication.

Enable Controllers
load balance

This parameter enables load balancing of VIA clients by randomly choosing a VPN
Concentrator from the list of available VIA VPN Concentrators that can be used for
connection. This feature does not take the existing load of the VPN Concentrator into
account.

NOTE: This option is available in VIA 2.1 and later versions.

Enable domain
pre-connect

This parameter enables pre-connection to the domain. By default, this is enabled.

VIA banner
message
reappearance
timeout(minutes)

This parameter configures the timeout value in minutes for reappearance of VIA login
banner message. The default value is 60 minutes.

VIA client network
mask

This network mask is set on the client after the VPN connection is established.
The default value is 255.255.255.255.

Validate server
certificate

If enabled, the VIA client validates the server certificate presented by the VPN
Concentrator during the IPsec process. Remember that to validate the server certificate,
the CA that signed the VPN Concentrator certificate should be a trusted CA in the client
certificate store. By default, this is enabled.

VIA client DNS
suffix list

This is the DNS suffix that is set on the client after the VPN connection is established.

OCSP cert
verification
enabled

This parameter enables OCSP certificate verification.

In EAP/IKE, action
taken when OCSP
cert verification
result is unknown

This parameter accepts the certificate when OCSP certificate verification result is
unknown for EAP/IKEs.

VIA domain name
profile

This parameter allows you to add VIA domain name profiles.

Destination traffic
to be blocked

This parameter allows you to configure the IP address and netmask of the destination
traffic for blocking.

Block-destination-
traffic-selector
(on/off)

This parameter enables or disables the blocking of destination traffic.

VIA max session
timeout

This parameter defines the maximum time, in minutes, allowed before the VIA session is
disconnected.
Default: 1440 min

VIA logon script This parameter specifies the name of the logon script that must be executed after VIA
establishes a secure connection. The logon script must reside on the client computer.
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Parameter Description

VIA logoff script This parameter specifies the name of the logoff script that must be executed after VIA
tears down a secure connection. The logoff script must reside on the client computer.

VIA support e-mail
address

This is the support email address to which VIA users send client logs using the VIA client.
For information on sending VIA logs using the VIA client, see Chapter 8: Establishing VIA
connection.

Maximum
reconnection
attempts

This parameter defines the maximum reconnection attempts by the VIA client. If the
reconnection attempt is exceeded, the VIA client becomes idle. However, if the
connection attempt fails due to an IKE authentication failure error, then the user is
prompted to reenter username and password.
Default: 3

VIA external
download URL

The VIA installer can be hosted on an external server other than the VPN Concentrator
for download by the VIA client during VIA upgrades and by the end users. If the VIA
installer is hosted on an external server, this parameter should be configured to redirect
the VIA clients to the external URL for the upgrade process. If this parameter is not
configured, the VIA clients automatically go to https:// <VPN Concentrator IP address or
FQDN >/via for upgrades.

Allow user to
disconnect VIA

This feature determines whether the users can disconnect VIA or not. Remember that a
user with administrative rights to a laptop can always uninstall VIA or disable the service
running on the laptop. For users with restricted access to the laptops, disabling this
feature ensures that users cannot disconnect VIA. By default, his is enabled.

Content security
gateway URL

When split-tunnel mode is enabled, traffic to external websites is inspected by the CSS.

Comma separated
list of HTTP ports
to be inspected
(apart fromdefault
port 80)

Traffic to the specified list of ports is verified by the CSS provider.

Certificate criteria Certificate criteria expressed in key-value pairs where keys can be certificate attributes,
or certificate OIDs. Multiple key-value pairs can be combined with semi-colon.

Enable content
security services

This parameter enables the CSS. The CSS requires the CSS licenses.

Keep VIA window
minimized

When this feature is enabled, the VIA client is minimized to the system tray during the
connection phase. This feature is applicable only for VIA clients installed onMicrosoft
Windows laptops.
Default: disabled

Block traffic until
VPN tunnel is up

This parameter allows blocking of traffic until VPN tunnel is up.

Block traffic rules This parameter configures the VIA whitelist traffic rules. Specify the IP address, netmask
and description for the traffic rules.

User idle timeout User idle timeout value. Allowed range is 30-15300 seconds in multiples of 30 seconds.

VIA client mtu
value

MTU value for the VIA client. Allowed range is 576-5120 bytes. The default value is 1452
bytes.

Attaching the VIA Connection Profile to User Role
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VIA connection profile that the VIA client has to download should be attached to the user role to be
assigned to the user. When a user goes through the authentication phase it is placed on a role which has a
certain connection profile associated. Suppose, the users authenticating to the VIA authentication profile
are assigned thedefault-via-role. To assign a specific connection profile to these users, attach the
connection profile to thedefault-via-role.
To attach the VIA connection profile to a user role, complete the following steps:

1. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway.
The dashboard context for a group is displayed.

2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click theConfig icon.
The gateway group configuration page is displayed.

4. Click Security > Roles.

5. Select the role to which you want to associate a VIA connection profile and select theMore tab.

6. Expand VPN and select the required VIA connection profile from theVIA connection profile drop-
down list.

7. Save the changes.

Configuring VIA Web Authentication

The VIAweb authentication is a list of VIA authentication profiles. Theweb authentication list allows the
users to login to the VIA download page <https://<VPN Concentrator IP address>/via> to download the VIA
client. To successfully login to the VIA download page, the usersmust authenticate successfully against the
VIA authentication profile in the list. If more than one VIA authentication profile is configured in theweb
authentication list, the users can view the list and select one authentication profile before authenticating to
the VIA installer download page.

Theweb authentication list is also used during the initial user authentication process that determines the
VIA user role. The Branch Gateway has a default web authentication list to whichmultiple VIA
authentication profiles can be added. Additional VIA web authentication lists cannot be created.

To configure the VIAweb authentication list, add one ormore VIA authentication profiles to the default web
authentication list and order them according to the priority. Configuringmore than one VIA authentication
profile in the VIAweb authentication list allows the users to use the backup authentication server when the
primary server becomes unavailable temporarily.

To configure the VIAweb authentication profile, complete the following steps:

1. To configure a Branch Gateway group or Branch Gateway complete either one of these steps:

n For a Branch Gateway group, in theNetwork Operations app, use the filter to select Groups.
n For a Branch Gateway in theNetwork Operations app, use the filter to select the gateway.

2. UnderManage, click Devices > Gateways.

3. Click the configuration icon. The gateway configuration page is displayed.
4. Select VIA Web Authentication > default.



Aruba SD-WAN Solution | User Guide 330

5. Click + to add a VIA authentication profile in theVIA authentication profiles table.

6. Save the changes.

VPN Authentication
Wireless networks can use VPN connections to further securewireless data from attackers. A VPN
concentrator is used to terminate all VPN connections fromboth wired and wireless clients.

VPN Authentication Profiles

VPN authentication profiles identify an authentication server, the server group to which the authentication
server belongs to, and a user-role for authenticated VPN clients. There are three predefined VPN
authentication profiles: default, default-cap, default-hp-switch, default-iap, and default-rap. These
different profiles allow you to use different authentication servers, user roles, and IP pools for VPN, remote
AP, switches, Instant AP, and campus AP clients.

Parameter Description default *rap *cap *hp-
switch *iap

Default Role The role that is
assigned to the
authenticated
users.

default-vpn-
role

default-vpn-
role

sys-ap-
role
0

default-
vpn-role

default-
vpn-role

Maximum
allowed
authentication
failures

The number of
contiguous
authentication
failures before
the station is
blacklisted.

0 (feature is
disabled)

0 (feature is
disabled)

0 (feature
is
disabled)

0
(feature
is
disabled)

0
(feature
is
disabled)

Check certificate
common name
against AAA
server

When enabled,
this feature
verifies that the
certificate's
common name
exists in the
server.

disabled enabled enabled enabled enabled

Export VPN IP
address as a
route

When enabled,
this feature
causes any VPN
client address to
be exported to
OSPF using IPC.

NOTE: The
Framed-IP-
Address attribute
is assigned the IP
address as long
as the any server
returns the

enabled enabled enabled enabled enabled

Table 47: Predefined Authentication Profile settings
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Parameter Description default *rap *cap *hp-
switch *iap

attribute. The
Framed-IP-
Address value
always has a
higher priority
than the local
address pool.

User idle
timeout

The user idle
timeout value for
this profile.
Specify the idle
timeout value for
the client in
seconds. Valid
range is 0-15300
in multiples of 30
seconds.
Enabling this
option overrides
the global
settings
configured in the
AAA timers. If this
is disabled, the
global settings
are used.

disabled N/A N/A disabled disabled

PAN firewalls
Integration

Requires
IP mapping at
Palo Alto
Networks
firewalls.

disabled disabled disabled disabled disabled

Tomodify the default VPN authentication profile via theWebUI:

1. In theMobility Master node hierarchy, navigate to theConfiguration > System > Profiles page.

2. In theAll Profiles list, expand Wireless LAN > VPN Authentication and select thedefault VPN
authentication profile.

3. From theDefault Role drop-down list, select the default user role for authenticated VPN users.

4. (Optional) Set Max Authentication failures to an integer value. The default value is 0, which
disables this feature.

5. (Optional) If you use client certificates for user authentication, select theCheck certificate
common name against AAA server check box to verify that the certificate's common name exists
in the server. This parameter is enabled by default in thedefault-cap and default-rap VPN profiles,
and is disabled by default on all other VPN profiles.

6. (Optional) Enabling PAN Firewall Integration requires IP mapping at Palo Alto Networks firewalls.

7. Click Submit.

8. Click Pending Changes.

9. In the Pending Changes window, select the check box and click Deploy Changes.
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10. In theAll Profiles list, select the Server Group entry below theWireless LAN >
VPN Authentication > Default profile.

11. From the Server Group drop-down list, select the server group to be used for VPN authentication.

12. Click Submit.

13. Click Pending Changes.

14. In the Pending Changes window, select the check box and click Deploy Changes.

Applying Policies to Gateway Interfaces
After configuring the firewall policies, ACLs, and AAA profiles, you need to apply the appropriate policies on
theWAN and LAN interfaces of the Aruba Gateways.

For trusted (WAN) interfaces, apply the firewall policies directly. For untrusted (LAN) interfaces, assign
AAA profiles (role assignment policies) to the VLANs.

This section includes the following topics that describe how to apply policies on appropriate ports and VLAN
interfaces of the Aruba Gateways:

n Applying Policies for VLANs on Access Ports on page 332

n Applying Policies for VLANs on Trunk Ports on page 333

n Applying Route ACLs for VLAN Interfaces on page 333

n Assigning AAA profile to VLAN Interfaces for Role Assignment on page 334

Applying Policies for VLANs on Access Ports
Complete the following procedure to apply a firewall policy for a trusted VLAN on access port:

1. To configure a Branch Gateway group or a Branch Gateway, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. Click Security > Apply Policies.

3. To apply a firewall policy, select an access port from Interface table.
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4. Under the POLICY column, select the policy to be applied from the drop-down list.

You can apply firewall policies only for trusted VLAN interfaces.

5. Save the changes.

Applying Policies for VLANs on Trunk Ports
Complete the following procedure to apply firewall policies for trusted VLANs on trunk port:

1. To configure a Branch Gateway group or a Branch Gateway, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. Click Security > Apply Policies.

3. Click Edit Policies from the POLICY column of Interface table for the trunk port on which you
want to apply a firewall policy. The Interface > <port-number> table appears which lists all the
VLANs configured for the selected trunk port.

4. Select any trusted VLAN from the Interface <port-number> table for which you want to apply a
firewall policy.

You can apply firewall policies only for trusted VLAN interfaces.

5. Under the POLICY column, select the policy to be applied from the drop-down list.

6. Save the changes.

7. Repeat step 6 to step 8 to apply policies formultiple VLANs.

Applying Route ACLs for VLAN Interfaces
Complete the following procedure to apply Route ACLs for the configured VLAN interfaces:

1. To configure a Branch Gateway group or a Branch Gateway, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.
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b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. Click Security > Apply Policies.

3. From theVLANs table, select the VLAN for which you want to apply a route ACL.

4. Under theROUTE ACL column, select the ACL to be applied from the drop-down list.

5. Save the changes.

Assigning AAA profile to VLAN Interfaces for Role Assignment
Complete the following procedure to apply a AAA profile on a VLAN interface for role assignment:

1. To configure a Branch Gateway group or a Branch Gateway, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. Click Security > Apply Policies.

3. From theVLANs table, select the VLAN for which you want to apply a AAA profile.

4. Under theROLE ASSIGNMENT column, select the AAA profile to be applied to the VLAN interface
from the drop-down list.

5. Save the changes.

SD Branch Redundancy
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Administrators can set up a redundancy scheme in SD branches and data centers to provide a highly
available and an always-on network. The data center, VPN Concentrator, and Branch Gateway failover
redundancy features allow network administrators to significantly reduce the downtime and client traffic
disruptions.

Data Center Redundancy
The SD-WAN solution supports active-standby or active-active VPN Concentrator configuration at the data
center. Any of the Aruba 7200 Series controllers can be configured to function as a VPN Concentrator at the
data center or headquarters to aggregate data traffic frombranches.

Administrators can configure primary and redundant VPN Concentrators in active-activemode to allow
someBranch Gateways to terminate on one VPN Concentrator and the remaining on the second VPN
Concentrator.

For example, if you have data centers on the East andWest Coasts, half of the branch sites could connect to
the data center on theWest Coast as primary and that on the East Coast as backup. The remaining sites
could connect to the East Coast data center as primary and that on theWest Coast as backup. This
architecture reduces downtime during VPN Concentrator failures as only half of the sites need to switch to
the backup VPN Concentrator.

VRRP Redundancy
The Virtual Router Redundancy Protocol (VRRP) is used to create various redundancy solutions, such as
pairs of Aruba Gateways acting in active-backupmode or in primary-standby mode by using a virtual IP
address. When the primary device becomes unavailable, a backup SD-WAN Gateway comes up as the
primary devicewith the virtual IP address. All network elements (APs and other devices) are configured to
access the virtual IP address, thereby providing a transparent redundant solution to your network.

VRRP eliminates a single point of failure by providing amechanism to elect a VRRPmaster device. If VRRP
preemption is disabled and all Aruba Gateways share the same priority, the first device that comes up is
elected as the VRRPmaster. However, if VRRP preemption is enabled and all devices share the same priority,
the devicewith the highest IP address becomes the VRRPmaster.

To avoid routing loops during overlay negotiation with the hubs, Branch Gateways automatically
suppress route advertisements for subnets that do not have the VRRP state as Master.

To know how to configure redundant gateways for high availability, see Configuring Redundant Gateways
for High Availability.

Configuring Redundant Gateways for High Availability
To configure a Gateway pair for high availability, complete the following steps:

n Configuring Peer Aruba Gateways and Transport VLAN forWAN Redundancy

n Configuring DHCP State Synchronization

n Configuring VRRP for LAN Redundancy

Configuring Peer Aruba Gateways and Transport VLAN for WAN Redundancy
Aruba SD-Branch solution allows to establish a virtual link between redundant Aruba Gateways to share the
WAN interfaces. This virtual link is a GRE tunnel that is automatically established between Branch Gateways
when peer Aruba Gateways and transport VLAN are configured.

Aruba provides Layer 3 redundancy between a peer Branch Gateway and a default Branch Gateway to
which the clients in that site are connected. These two Branch Gateways have a dynamic or a static routing
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set up to get reachability information. Routing information is redistributed over the SD-WAN overlay to
communicate to the VPN concentrators that these subnets are not directly attached. The Site ID
determines that the Branch Gateways are installed at the same site. This allows path computation to take
place, set the auto-cost andmaintain the symmetry of traffic flows through the overlay. When redistributing
routes on a VPN Concentrator or Branch Gateway to upstream routing devices, path selection can be
influenced by the options available through the respective protocol. For example, interface cost when using
OSPF in the branch site. The following image illustrates this feature:

Figure 92 Layer 3 Redundancy for high availability

When the virtual link is established, Branch Gateways share uplink interfaces with their peers. Peer Aruba
Gateways use uplink interfaces from the other Aruba Gateways only if WAN ports are configured with
different uplink VLANs.

Note the following guidelines for configuring Peer Aruba Gateways and Transport VLAN for
WAN Redundancy:

n It is recommended not to configure the same SD-WAN Gateway as theMaster for some VLANs and as
Backup for some other VLANs.

n Peer Aruba Gateways use uplink interfaces from the other Aruba Gateways only if WAN ports are
configured with different uplink VLANs.

To set up the communication between the peer Aruba Gateways, complete the following steps:

1. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway.
The dashboard context for a group is displayed.
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2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click a gateway underDevice Name.
The dashboard context for the gateway device is displayed.

4. UnderManage, Click Device.
The gateway configuration page is displayed.

5. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

6. Click High Availability. TheRedundancy configuration page is displayed.

7. In theWAN Redundancy section, enter the Site ID to which the gateways belong.

8. Enter the peer SD-WAN Gateway IP address in the Peer gateway IP address field to enable Branch
Gateway redundancy with uplink sharing.

9. Select the VLAN ID from theVLAN ID connecting to peer gateway field to configure the
transport VLAN for communication between the redundant Aruba Gateways.

10. Save the changes.

11. Repeat steps 1-6 on the configured peer SD-WAN Gateway to enable uplink load sharing.

Configuring DHCP State Synchronization
State synchronization is achieved through a combination of DHCP failover profile, pool scope, and NTP
server. The pool scope under theDHCP database is similar for both peers. Users have no control over the
failover profile and they are automatically added to theDHCP databasewhen a virtual Branch Gateway link
is successfully established between the Branch Gateway peers.

To configure DHCP state synchronization, configure a corporate NTP server at the group level. Formore
information, see Configuring System Information on ArubaGateways on page 159.

Ensure that you create the same DHCP scope on both Aruba Gateways. Exclude VLAN interface
IP addresses from the pool address range. To view the pool address range, execute the 'show ip dhcp
database' command and ensure that the range is same across peers.
Normal functioning of a DHCP server is dependent on NTP clock synchronization and network (virtual
link) connectivity between Branch Gateway peers in a high availability (HA) setup. Ensure that both the
peers are connected and functioning.

TheDHCP high availability and failovermechanism for two Branch Gateway peers work differently as
explained in the following states:

n Peer down state—This state occurs during boot up where one peer comes up first and gets provisioned
while the second peer takes time to comeup. In this scenario, the first peer invokes peer down timer for 60
seconds and waits for the second peer to come up. If connectivity to second peer is not established in 60
seconds, then the first peer acts in standalonemode claiming the full DHCP lease range keeping a reduced
lease time of fiveminutes. This approach avoids any boot time setbacks and limits IP address conflicts to
fiveminutes when peers have connectivity issues with network or each other. Once the second peer is
commissioned and connectivity to the first peer is established, the peers start operating in High Availability
modewith configured lease times. 

n Connectivity down state—This state occurs when two peers successfully establish a connection with
each other and share a DHCP pool lease range but lose connectivity due to a hardware failure or network
issues.
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For example, consider a scenario where Peer A and Peer B successfully establish connection with each other
and share a DHCP pool of 10 leases. Peer-A owns five leases and Peer B owns the remaining five. Peer-A
hands out four leases to its clients and Peer-B hands out four leases to its clients. A hardware failure causes
Peer B to go down and they lose connectivity with each other. As Peer A is aware of the total two free leases
both of themowned before Peer B went down, Peer A renews the eight leases (four owned and leased by
each peer) until it re-establishes connection with Peer B. Peer-A hands out the ninth lease (one free lease left
that it owned at the time of connectivity loss) to its new client. During the time of their connectivity down
state, neither Peer A nor Peer B will hand out the 10th lease (one free lease left for Peer-B) . TheDHCP high
availability and failovermechanism takes extreme precautions to stop any silo operation, conflict, or
duplicate IP address grant.  Once the connectivity is restored, Peer B will be able to hand out the tenth lease
to its client.

Configuring VRRP for LAN Redundancy
Before you begin configuring VRRP redundancy, obtain the following network information:

n VLAN ID for the two ArubaGateways on the same layer 2 network.

n Virtual IP address to be used for the VRRP instance.

To configure VRRP redundancy, complete the following steps:

1. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway.
The dashboard context for a group is displayed.

2. UnderManage, click Devices > Gateways
A list of gateways is displayed in the List view.

3. Click a gateway underDevice Name.
The dashboard context for the gateway device is displayed.

4. UnderManage, Click Device.
The gateway configuration page is displayed.

5. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

6. Click High Availability. TheRedundancy configuration page opens.

7. Click + to add a new virtual router in theVirtual Router Table. TheNew Virtual Router section is
displayed.

8. Select the IP version from the IP Version drop-down list.

9. Select the VLAN on which you want to configure VRRP from theVLAN drop-down list.

10. Set Admin State to UP.

11. Specify the priority value in the Priority field. For a backup SD-WAN Gateway, use the default priority
value of 100. For the primary SD-WAN Gateway, use a priority value higher than the default value,
such as 110.

12. Configure the other VRRP parameters as described in Table 48.

13. Save the changes.

14. Repeat steps 1-10 to configure VRRP on the other device in the primary and backup redundant pair.

Ensure to reload the device whenever youmodify the Master VRRP configuration under Master
Redundancy to avoid any configuration errors.
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Parameter Description

ID The ID uniquely identifies a VRRP instance. For ease of administration, specify
VLAN ID as the ID.

Description Description of the VRRP instance.

IP version The IP version. Select IPv4.

Authentication
Password

Password to authenticate VRRP peers in their advertisements.

Retype authentication
password

Reconfirm the password, if configured.

IP address This is the virtual IP address that is owned by the elected VRRP master. Ensure that
the same IP address and VRRP ID is configured on eachmember of the redundant
pair.

Priority Priority level of the VRRP instance for the device. This value is used in the election
mechanism for the master. When configuring VRRP on a standby device, use the
default priority value of 100. For a master device, use a higher priority value such as
110.

Advertisement interval
(secs)

This is the interval, in seconds, between successive VRRP advertisements sent by
the current master. The default interval time is recommended.
Default: 1 second

Hold time (secs) This is the hold time, in seconds. The default interval time is recommended.
Default: 45 seconds

Enable router Pre-
emption

Enables a device to take over the role of master if it detects a lower priority device
that is currently acting as master.

Pre-emption delay
(secs)

Specifying a value enables the delay timer. The timer is triggered when the VRRP
state moves out of backup or init state to become a master. This is applicable only if
you enable router pre-emption.
When the timer is triggered, it forces VRRP to wait for a specified period of time, so
that all the applications are ready before coming up. This prevents the APs from
connecting to the SD-WAN Gateway before the SD-WAN Gateway can accept the
connection. In the meantime, if there is an advertisement from another VRRP, the
VRRP stops the timer and does not transition to master.

Admin state Administrative state of the VRRP instance. To start the VRRP instance, change the
admin state to UP.

VLAN VLAN on which the VRRP protocol runs.

Tracking master up-
time

Perform VRRP priority tracking based on how long the device has been the master.
This feature is designed to ensure that a master is allowed to take andmaintain
control of the VRRP if it has been up for a certain amount of time in minutes (0-
1440). This prevents a common issue where a device that is periodically going up
and down assumes the role of primary master. Configuring this parameter is
optional.

Table 48: VRRP Configuration Parameters
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Parameter Description

Tracking master up-
time priority

The additional priority given to the master after it has been up for the time interval
defined by the Tracking Master Up-time parameter. Configuring this parameter is
optional.

Tracking VRRP master
state ID

Perform tracking based on the UP or DOWN state of another VRRP master by
specifying the VRRP ID of the master to be tracked. Configuring this parameter is
optional.

Tracking VRRP master
state priority

The priority taken away from a VRRP master if it is in a DOWN state. The priority
levels are returned to their previous state when the VRRP master comes back up.
Configuring this parameter is optional.

Tracking VLAN Perform VRRP priority tracking based on the UP or DOWN state of a VLAN. Click +
below the Tracking VLAN table and specify the following values:
VLAN Id: ID of the VLAN to be tracked.
Subtract: Priority level to be subtracted from the device's VRRP priority if the tracked
VLAN goes down.
Configuring this parameter is optional.

Tracking interface (Optional) Perform VRRP priority tracking based on the UP or DOWN state of a
specific interface. Click + below the Tracking Interface table and specify the
following values:
Interface: Interface Port to be tracked.
Subtract: Priority level to be subtracted from the device's VRRP priority if the tracked
interface goes down.
Configuring this parameter is optional.

Table 48: VRRP Configuration Parameters

Configuring Aruba Gateways for Certificate-Based
Authentication
Certificates provide a secureway of authenticating devices and eliminate the need for less secure password-
based authentication. In certificate-based authentication, digital certificates are used to identify a user or
device before granting access to a network or application.

Digital certificates use PKI that requires a private-public key pair. A digital certificate is associated with a
private key, known only to the certificate owner, and a public key. A certificate encrypted with a private key
is decrypted with its public key. For example, party A encrypts its certificate with its private key and sends it
to party B. Party B decrypts the certificate with the public key of party A.

Server certificates and the digital certificates issued by a CA validate the identities of servers and clients. For
example, when a client connects to a server for the first time, or the first time since its previous certificate
has expired or been revoked, the server requests that the client transmit its authentication certificate and
verifies it. Clients can also request and verify the authentication certificate of the server.

Branch devices use digital certificates for authenticating a client's access to user-centric network services
such as VPN, the device UI or CLI. Branch Gateways include a server certificate by default for captive portal
server authentication. However, Aruba recommends that you replace the default certificate with a custom
certificate issued for your site or domain by a trusted CA. Certificates can be stored locally on the devices
and used for validating device or user identity during authentication.

Adding Certificates to Certificate Store in Aruba Central
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TheGlobal Settings > Certificates page in the Aruba Central UI allows you to add certificates to the
Central's certificate store. If the certificates are added in the Aruba Central's certificate store, you can import
ormap the certificates required for SD-WAN configuration.

Formore information on adding certificates to Aruba Central, see Certificates on page 24.

Installing Certificates
To enable branch devices to use certificate-based authentication, youmust install the certificates loaded in
the Aruba Central's certificate store on branch devices.

Installing Certificates for Server Authentication
To install certificates for web server, captive portal, or VIA server authentication, complete the following
steps:

1. To configure a Branch Gateway group or Branch Gateway complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. Click System > Certificates.

3. Click Server Certificates.

4. Under Captive portal certificate, select a certificate for captive portal server authentication.

5. Under Configure SSL/TLS protocol, select a security protocol. By default, all TLS protocols are
selected.

6. UnderVIA server certificate, select a certificate for VIA server authentication.

7. Click System > Admin.

8. Click Admin Authentication Options.

9. UnderWebUI Authentication > Server certificate, select a certificate for server authentication.

10. Click Save Settings.

Installing Certificates for VPN Clients
To install a certificate for VPN client authentication, complete the following steps:
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1. To configure a Branch Gateway group or Branch Gateway, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. Click System > Certificates > Certificates for VPN Clients.

n To add a CA certificate, click + in theCA Certificate Assigned for VPN Clients table.
n To add certificate group, click + in theCertificate Groups for VPN Clients table.

TheAdd New Certificate table is displayed at the bottomof the page.

1. Select the certificate to add from a list of certificates uploaded in the Aruba Central's certificate store.

2. Click Save Settings.

Configuring Revocation Checkpoint
The Certificate Revocation feature enables the Aruba Gateways to perform real-time certificate revocation
checks using OCSP server, or traditional certificate validation using the CRL client.

OCSP (RFC 2560) is a standard protocol that consists of an OCSP client and an OCSP responder. This
protocol determines revocation status of a given digital public-key certificate without downloading the
entire CRL.

CRL is the traditionalmethod of checking certificate validity. A CRL provides a list of certificate serial
numbers that have been revoked or are no longer valid. CRLs let the verifier check the revocation status of
the presented certificate while verifying it. CRLs are limited to 512 entries.

When configured as an OCSP responder, the Aruba Gateways provide revocation status information to
applications that use CRLs.

Ensure that the required OCSP signer and responder certificates are available in the Aruba Central
certificate store.

Configuring Revocation Checkpoint Using OCSP
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1. To configure a Branch Gateway group or Branch Gateway, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. Click System > Certificates > Revocation Checkpoint.

3. In theRevocation Checkpoint table, click + to add the record for which you want to configure the
revocation checkpoint. TheAdd Revocation Checkpoint section is displayed.

4. From theName drop-down list, select the CA cert for which you want to configure the revocation
check point.

5. Select ocsp from theRevocation method 1 drop-down list as the primary check method.

6. Specify theOCSP server URL in theOCSP URL field.

7. Optionally, select a backup check method (crl ) from theRevocation method 2 drop-down list.

a. Select the Enable OCSP responder check box to configure the SD-WAN Gateway as an OCSP
responder for the selected CA certificate.

b. Select the required OCSP signer certificate from theOCSP signer cert drop-down list.

c. Select the required OCSP responder certificate from theOCSP responder cert drop-down list.

8. Optionally, you can configure one of the following actions to be taken when the configured server is
unreachable:

n Fail-Over—Fails over to the revocationmethod 2, if configured.

n Allow Cert—Allows the certificate.

n Revoke Cert—Revokes the certificate.

9. Save the changes.

Configuring Revocation Checkpoint Using CRL
To configure the SD-WAN Gateway as an OCSP responder for providing revocation status information using
CRL, complete the following steps:

1. To configure a Branch Gateway group or Branch Gateway, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.
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b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. Click System > Certificates > Revocation Checkpoint.

3. Optionally, if you want to globally enable theOCSP responder service on the SD-WAN Gateway,
complete the following steps:

a. Click the Enable OCSP responder option to enable theOCSP responder service on the Aruba
Gateways.

Enable OCSP responder is a global option that enables or disables theOCSP responder service
on the Aruba Gateways. By default, it is disabled.

b. Select theOCSP signer certificate to be used to sign OCSP responses for this revocation checkpoint from
theOCSP certificates drop-down list.

4. In theRevocation Checkpoint table, click + to add the record for which you want to configure the
revocation checkpoint. TheAdd Revocation Checkpoint section is displayed.

5. From theName drop-down list, select the CA cert for which you want to configure the revocation
check point.

6. Select crl from theRevocation method 1 drop-down list as the primary check method.

7. Select the CRL that you want to use for this revocation checkpoint from theCRL location drop-down
list. The CRLs listed are files that have already been imported onto the Aruba Gateways.

8. Optionally, select a backup check method as follows:

a. Select ocsp from theRevocation method 2 drop-down list.

b. Specify theOCSP server URL in theOCSP URL field.

9. If you want to override the global OSCP responder settings and configure specific settings for the
selected CA certificate, complete the following tasks:

a. Select the Enable OCSP responder check box to configure the SD-WAN Gateway as an OCSP
responder for the selected CA certificate.

b. Select the required OCSP signer certificate from theOCSP signer cert drop-down list.

c. Select the required OCSP responder certificate from theOCSP responder cert drop-down list.

10. Optionally, you can configure one of the following actions to be taken when the configured server is
unreachable:
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n Fail-Over—Fails over to the revocationmethod 2, if configured.

n Allow Cert—Allows the certificate.

n Revoke Cert—Revokes the certificate.

11. Save the changes.

Configuring Aruba Gateways for SNMP-Based Reporting
The ArubaGateways support versions 1, 2c, and 3 of SNMP for reporting purposes. For SNMP-based data
collection andmanagement, configure the following SNMP parameters:

Field Description

Host Name Host name of the Gateway.

System Contact Name of the person who acts as the System Contact or administrator
for the Gateway.

System Location String to describe the location of the Gateway.

If you are using SNMPv3 to obtain values from the Gateway, you can configure the following
parameters:

User name A string representing the name of the user.

Authentication
protocol

An indication of whether messages sent on behalf of this user can be
authenticated, and if so, the type of authentication protocol used. This
can take one of the two values:

n MD5: HMAC-MD5-96 Digest Authentication Protocol
n SHA: HMAC-SHA-96 Digest Authentication Protocol

Authentication
protocol

If messages sent on behalf of this user can be authenticated, the
(private) authentication key for use with the authentication protocol.
This is a string password for MD5 or SHA depending on the choice
above.

Privacy protocol An indication of whether messages sent on behalf of this user can be
protected from disclosure, and if so, the type of privacy protocol which
is used.

Privacy protocol
password

If messages sent on behalf of this user can be encrypted or decrypted
with DES, the (private) privacy key for use with the privacy protocol.

Enable Trap
Generation

Enables generation of SNMP traps to configured SNMP trap receivers.
Refer to the list of traps in the “SNMP traps” section below for a list of
traps that are generated by the Branch Gateway.

Table 49: SNMP Parameters

Community String for SNMPv1 and SNMPv2
Community strings are used to authenticate requests for SNMP versions before version 3. This is needed
only when using SNMP v2c and is not needed if using version 3.

SNMP Trap Receivers



Aruba SD-WAN Solution | User Guide 346

This table contains information on a trap receiver. This host needs to be running a trap receiver to receive
and interpret the traps sent by the Branch Gateway. Configure the following for each host or trap receiver:

n IP address: This is the IP address of the new trap receiver.

n SNMP version: The SNMP version can be 1, 2c, or 3.

n Security string: Choose from the community strings that was created for SNMPv1 and SNMPv2.

n Type: Trap or Inform (SNMPv2c or SNMPv3 only)

n Engine ID: (SNMPv3 only)

n UDP port: This is the port on which the trap receiver is listening for traps. The default is the UDP port
number 162. This is optional, and will use the default port number if not modified by the user.

Viewing Gateway Configuration Status
Aruba Central provides an audit dashboard to review configuration changes for the devices provisioned in
UI and template groups. TheConfiguration Audit menu option is available for all types of devices
provisioned in Aruba Central.

To access theGateway Config Audit page:

1. In theNetwork Operations app, use the filter to select a gateway. Summary of the selected
gateway is displayed.

2. UnderManage, click Device. The selected gateway's configuration page is displayed.

3. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

4. Click Config Audit tab.

Managing Configuration Overrides
Aruba Central supports two levels of configuration hierarchy:

n Group level—When you configure a set of parameters at the group level, all other gateways provisioned in
that group inherit the configuration updates.

n Device level—In certain cases, your deployment topology may require you to modify the system
configuration of a specific device provisioned in a group. In such cases, you canmodify the parameters at
the device level. The final configuration for such devices will include the configuration applied at the group
level and the overrides applied at the device level.

If a configuration parameter ismodified both at the group and device levels, the configuration applied at
the device level takes precedence.

Aruba recommends that you configuremost of the provisioning parameters at the group-level unless a
device-specific override is required. For SD-Branch deployments, Aruba recommends that you configure
the following features and parameters at the device-level:

n Gateway hostname

n Loopback Interface addresses

n OSPF and BGP router IDs

n Local DHCP pools

n Gateway peer configuration

n Manual override of firewall aliases
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n Uplink configuration inherited from Zero Touch Provisioning

n Bulk configuration imported from a CSV file

Configuration Overrides
When a configuration parameter ismodified both at the group and device levels, Aruba Central marks this
configuration difference as an override. For such parameters, Aruba Central displays a green bullet icon. On
clicking this icon, you can view the details of the override and also remove the override if required.

Important Points to Note
Note the following points:

n Configuration overrides are applicable to only those parameters which can bemodified at both group and
device levels.

n Aruba Central does not display the configuration override indicator (green bullet icon) for the following UI
fields:
o All password fields in theUI—For example, SNMPv3 user credentials (System > SNMP).
o Configuration parameters that are already configured at the group level, but are not available for device-

level edits—For example, the IP address UI field in the System > Logging > Syslog Servers > Add
New Syslog Server page.

o Configuration parameters that must be applied only at device-level— For example, hostname (System >
General > Basic Info), SNMP hostname (System > SNMP > Hostname), System contact and System
location (System > SNMP), and other such configruation parameters. The device-specific parameters are
configured only at the device level. Hence, the override option is not applicable to these fields.

Limitations
Due to feature limitations in this release, Aruba Central does not display the configuration override bullet
icon for the following UI elements:

n Parameters withmultiple UI elements in a row. For example, theAuth Protocols field in theVPN > IKEV1
page.

n Cascading UI elements that are displayed after selecting another UI element, such as a toggle switch or
check box.

For example:
o TheAdvertise VLANs to all hubs toggle switch that appears when Overlay mode isManual in the

VPN > SD-WAN Overlay page.
o TheDPD toggle switch and its associated parameters on theVPN > DPD page.

n Somedrop-down lists with options for selecting an IP address or VLAN interface; For example, the IPv4
Address drop-down under System IP Address in the System > General page.

n Parameters in the tables displayed on the Security > Auth Servers and System > Admin > Admin
Authentication Servers pages.

Configuring Aruba Gateways for Syslog Message Collection
This section outlines the steps required to configure logging on an SD-WAN Gateway.

For each category or subcategory of message, you can set the logging level or severity level of themessages
to be logged.

The following table summarizes these categories:
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Code Description

network Network messages

all All network messages

packet-dump Protocol packet dumpmessages

mobility Mobility messages

dhcp DHCPmessages

system Systemmessages

all All systemmessages

configuration Configurationmessages

messages Messages

snmp SNMPmessages

webserver web server messages

security security messages

all all security messages

aaa AAA messages

firewall firewall messages

packet-trace packet trace messages

mobility mobility messages

vpn VPN messages

dot1x 802.1X messages

ike IKE messages

webserver web server messages

wireless wireless messages

all all wireless messages

captive-portal captive portal user messages

vpn VPN messages

dot1x 802.1x messages

radius RADIUS user messages

Table 50: Software Modules
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For each category or subcategory, you can configure a logging level. The following table describes the
logging levels in order of severity, frommost to least severe.

Code Description

emergency captive portal user messages

alert VPN messages

critical 802.1x messages

errors RADIUS user messages

warning warning messages

notice Significant events of a non-critical and normal nature.

informational Messages of general interest to system users.

debug Messages containing information useful for debugging.

Table 51: Logging Levels

The default logging level for all categories isWarning. You can also configure IP address of a syslog server to
which the Branch Gateway can direct these logs.

Configuring Logging Levels

1. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway.
The dashboard context for a group is displayed.

2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click a gateway underDevice Name.
The dashboard context for the gateway device is displayed.

4. UnderManage, Click Device.
The gateway configuration page is displayed.

5. Click System > Logging.

6. Click + in the Syslog Servers section to add a logging server.

7. Add the logging server to the list of logging servers. Update the followings fields:
n IP address
n Category
n Logging facility
n Logging level
n Format: Select the logging format from the Format drop-down list. The ArcSight CEF is a log

management standard that uses a standardized logging format so that data can easily be collected
and aggregated for analysis by an enterprisemanagement system.
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Ensure that the syslog server is enabled and configured on this host.

8. Click Save Settings.

To select the types of messages you want to log, select Logging Levels.

1. Select the category or subcategory to be logged.

2. To select the severity level for the category or subcategory, select the level from the Logging Level
drop-down list.

3. Click Save Settings.



Chapter 7
SD-WAN Overlay Tunnel and Route

Orchestration

SD-WAN Overlay Tunnel and Route Orchestration
To simplify branch deployments, the Aruba SD-Branch solution provides support to the SD-
WAN Orchestrator service for automatically setting up IPsec tunnels between the Branch Gateways and
VPN Concentrators (VPNCs) provisioned in an Aruba Central account.

The SD-WAN Orchestrator supports the following functions:

n Tunnel Orchestration—The SD-WANOrchestrator automates tunnel configuration between the branch and
hub sites. The service can be enabled globally or for individual groups in Aruba Central.

n RouteOrchestration—The SD-WAN Orchestrator automates the route advertisement and redistribution
process by routing information learnt from each connected branch in a dynamic way.

n Overlay Tunnel and RouteMonitoring—The SD-WAN Orchestrator service also includes a dashboard that
displays detailed information about the orchestrated tunnels and routes.

Formore information on SD-WAN Orchestrator, see the following topics:

n Configuring Overlay Network Using SD-WAN Orchestrator on page 351

n Advertising Overlay Routes on page 355

n Monitoring SD-WANOverlay Tunnels and Routes on page 362

Configuring Overlay Network Using SD-WAN Orchestrator
The Aruba SD-Branch solution supports overlay networks based on the hub and spoke VPN model. For large
deployments, administrators can now use the SD-WANOrchestrator for automatic configuration of IPsec
tunnels between Branch Gateways and VPN Concentrators. The SD-WANOrchestrator supports IPsec
tunnel configuration between ArubaGateways provisioned in an Aruba Central account.

The SD-WAN Orchestrator can be enabled either globally or on individual device groups. When enabled, the
SD-WAN Orchestrator automatically builds an overlay network based on the data center preference you
configure for the device groups in qAruba Central.

Prerequisites
Before you begin, ensure that your deployment topology meets the following prerequisites:

n ArubaGateways are onboarded to and aremanaged fromAruba Central.

n ArubaGateways are provisioned in Branch Gateway and VPNC groups in Aruba Central.

n Access to FQDNsmust be allowed for device communication when SD-WANOrchestrator service is enabled
for a Aruba Central account.

n ArubaGateways are upgraded to ArubaOS 8.4.0.0-1.0.5.1 or later software version.

n The overlay IPsec VPN tunnels are initiated by Branch Gateways and terminated on a VPN Concentrator in a
hub site using NAT traversal, therefore ensure that UDP 4500 port is enabled.

Configuration Steps
The following configuration steps are required for tunnel and route orchestration on ArubaGateways:
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n Configuring Uplinks for Tunnel Orchestration

n Configuring Data Center Preference

n Enabling SD-WAN Orchestrator

n Aggregating Routes fromVPN Concentrators in theData Center

n Redistributing Overlay Routes

Configuring Uplinks for Tunnel Orchestration
For tunnel orchestration, uplink configuration is required on both Branch Gateways and
VPN Concentrators. The SD-WAN Orchestrator requires an appropriate pair of uplinks to:

n Bring up IPsec tunnels between Branch Gateways and VPN Concentrators

n Determinewhich uplink interface of a VPN Concentrator should be used for terminating IPsec tunnels

For tunnel orchestration, the following configuration is required on the uplink interfaces:

n ForMPLS uplinks:
o Link Name—The link name configured on theMPLS uplink interface of a VPN Concentratormust match

the link name of theMPLS uplink interface on Branch Gateways.
o Private IP address—By default, the IP address of the VLAN interface is used as the private IP address for

uplink interfaces on the VPN Concentrators. The private IP address can bemodified.

n For INET uplinks:
o Link Name—Link namematching is not mandatory. However, the SD-WANOrchestrator will try to find

the INET link with the same name; for example, if the INET uplink is named as att_inet, the SD-WAN
Orchestrator tries to establish tunnels to att_inet. Even if there is nomatching INET link, the SD-WAN
Orchestrator can establish IPsec tunnels between Branch Gateways and VPN Concentrators.

o Public IP address—Youmust configure a public IP address that corresponds to the firewall NAT
translation of the private IP address for the uplink interfaces on VPN concentrators.

o Private IP address—By default, the IP address of the VLAN interface is used as the private IP address for
INET uplink interfaces on the VPN concentrators. Private IP address for INET uplinks cannot bemodified
or overwritten.

Formore information on how to configure uplinks on Gateways, see Configuring Uplinks on page 189.

Configuring Data Center Preference
If you havemultiple data centers, you can configure a preferred data center for the Branch Gateway for
IPsec tunnel configuration and route distribution.

To configure data center preference, complete the following steps:

1. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway.
The dashboard context for a group is displayed.

2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click theConfig icon.
The gateway group configuration page is displayed.

4. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options

5. Click VPN > SD-WAN Overlay.
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6. Select Orchestrated for theOverlay mode fromdrop down options.

7. Click DC Preference.

8. To add the hub details, click + and select the hub group and VPN Concentrator. If the hub site has
multiple VPN Concentrators, you can configure a primary and secondary VPN concentrator for the
Branch Gateways.

9. Click Save Settings.

Data Center preference also determines the cost of the specific routes. A different cost based on the
order of configuration is assigned to the redistributed routes. This means that Data Center 1 with a
primary VPNC automatically gets a lower cost assigned than the secondary VPN Concentrator. This
cost is applied to the subnets being redistributed into overlay (and subsequently into Data Center
through OSPF or BGP) as well as the opposite direction (the Data Center subnets being redistributed
through the VPN Concentrator and advertised to the branch

Enabling SD-WAN Orchestrator
To configure tunnels and routes using the SD-WAN Orchestrator, complete the following steps:

1. In theNetwork Operations app, set the filter to Global.

2. UnderManage, click Network Services > SD-WAN Overlay.

3. Click theConfig icon to display the SDWAN Overlay configuration dashboard.

4. To enable the SD-WAN Orchestrator globally on ArubaGateway devices provisioned in Aruba Central,
click Global Settings and configure the following parameters:

a. In theGlobal branch aggregate table, click + and enter the IP summary range allocated to branch
offices. The IP summary rangewill be advertised with corresponding hubs as next hops to all the
branches. Aruba recommends that you define a summary IP range to reduce the routing table size of
the Branch Gateways.

b. Ensure that the following timers are configured:

n Graceful Restart timer—Sets the timer for keeping the tunnel and route state on the devicewhen
it loses connectivity to cloud.

n Tunnel rekey timer—Sets a timer for Branch Gateway and VPN Concentrators to exchange keys
for IPsec tunnel. Formore information, see Cloud Survivability.

By default, the SD-WAN Orchestrator service is enabled. When you shut down the service, tunnel and
routing service is disabled and the SD-WAN overlay network is impacted. Aruba recommends that you
use this option in case of emergency or when guided by the Aruba SD-WAN support team.

EnableDynamic data center path computation to allow theOverlay RouteOrchestrator to use the best
path computation using various route attributes, while selecting the next hops for the data center routes.

By default, the Overlay Route Orchestrator uses the configured Date Center preference for the next
hop selection while announcing data center routes to the branches.
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1. To enable SD-WAN Orchestrator for the groups deployed in your account:

a. Click Group Orchestration.

b. Select the groups for which you want to enable this service.

c. Click Enable.

Aggregating Routes from VPN Concentrators in the Data Center
To aggregate route prefixes for all VPN Concentrators routes in a data center, complete the following steps:

1. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway.
The dashboard context for a group is displayed.

2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click theConfig icon.
The gateway group configuration page is displayed.

4. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

5. Click VPN > SD-WAN Overlay.

6. Select Orchestrated for theOverlay mode.

7. Click DC Aggregate Routes.

8. Enter a summary IP range for the prefixes in the data center. This summary will be advertised with
corresponding hubs as the next hops to all the branches. Aruba recommends that you configure a
summary IP range to reduce the routing table size of the Branch Gateways

9. If you want to allow branch to branch traffic through the VPN Concentrator hub, select theAllow
branch-to-branch check box. Enabling this option will make the VPN Concentrator hub a transit site
and allow branch-to-branch traffic.

10. Click Save Changes.

Redistributing Overlay Routes
For information on redistributing overlay routes, see Advertising Overlay Routes on page 355.

Additional Documents
Aruba SD-WANOrchestrator

Cloud Survivability
Configured tunnels have a definite expiry time, the common default expiry time is 24 hours. During
rekeying, if the cloud connection fails, the tunnel keys expire. The expiration of authentication keys causes
the tunnels to go offline, resulting in network traffic disruption.

Cloud Survivability mitigates the loss of a tunnel or the IPSec traffic between Aruba devices. These devices
have IPsec tunnels which are orchestrated by SD-WAN Tunnel Orchestration and have a finite key expiry
time. If the cloud connection fails for any reason, the devices remain connected through either LAN orWAN
connections. This feature is available fromArubaOS 8.5.0.0-2.1.0.0 onward.

https://support.hpe.com/hpesc/public/docDisplay?docId=a00089978en_us
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Devices can also re-establish IPSec tunnels between thembased on tunnel configurations which are received
from SD-WAN Tunnel Orchestration using legacy IKE/IPSec tunnel establishment. When cloud connectivity
failure is detected during the rekeying process, the tunnels seamlessly switch over to legacy IPSec tunnels.

Cloud Survivability is triggered when:

n Devices on both sides of the tunnel have no connectivity to theOverlay Tunnel Orchestration.

n Overlay Tunnel Orchestration pushes new keys to the Branch Gateway or VPN Concentrator (VPNC), but
the Branch Gateway or VPNC did not receive the new keys.

n Overlay Tunnel Orchestration does not push a new key to the Branch Gateway or VPNC.

n The Branch Gateway or VPNC is unable to bring up the tunnel using theOverlay Tunnel Orchestration keys
received.

A maximum of 6000 tunnels per VPNC is supported. The number of supported tunnels also depends on
the gateway model.

Whilemonitoring the tunnels, when the tunnelsmove to a survivability mode the tunnel type is categorized
asOrch-Srv. The tunnel status is displayed in the Tunnelsmonitoring page. Formore information, see the
Gateway > WAN > Tunnels.

Formore information about orchestrated configuration of IPsec tunnels, see Configuring Overlay Network
Using SD-WAN Orchestrator.

Advertising Overlay Routes
To simplify routing and allow SD-Branch deployments to build scalable and secure VPNs on demand, the
Aruba SD-Branch solution supports the SD-WANOrchestrator for centralized orchestration of tunnels and
routes. The SD-WANOrchestrator automates the route configuration process and distributes routing
information learnt from each connected branch in a dynamic way as per the routing segmentation
requirements.

Branch Gateways and VPN Concentrators in an SD-WAN topology, use theOverlay Agent Protocol (OAP) to
automatically build the SD-WAN overlay topology. TheOAP allows advertising local routes to the SD-
WAN Orchestrator in Aruba Central.

The route orchestration service learns the following attributes in the routes advertised by the peer devices:

n IP address of the device fromwhich the routes were received.

n IP address of the LAN side router fromwhich the routes originated.

n TheWAN service over which the routes are distributed.

n The site fromwhere the route originated.

n Number of preferred data centers.

n Source protocol fromwhich the routes originate.

n Metric and cost assigned to the routes.

Configuring Route Maps
Routemaps allow you to configure a filtering criteria by defining a set of rules ormatch statements with a
permit or deny condition. A routemap includes a seriesmatch statements to determine if a routematches
the criteria defined in the statement and then apply the permit or deny rule accordingly. You can also
configure an additional set of parameters to adjust the attributes andmetrics for routes that match the
criteria defined in thematch statement.
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Important Points to Note

The following list includes some of the important points to consider when configuring a routemap:

n A routemap includes name, sequence number, permit or deny rule, thematch and set statements. The
match statements determine the route or the traffic to which the rulemust be applied, whereas the set
statements allow you configure attributes or adjust metrics for the route that matches the criteria defined
in thematch statement.

n The routemap rules are applied sequentially; that is, based on the sequence number defined for each
entry.

n The routemap can use a prefix list in thematch statement to apply the allow or deny rule. Formore
information on prefix lists, see Configuring a Prefix List on page 358.

Creating a Route Map

To create a routemap:

1. To configure a gateway group or gateway device, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Go to Routing > Overlay Routing.

4. To add a routemap, click the + icon in theRoute Maps table. TheCreate New Route Map panel
opens.

5. Configure the following parameters as per your network requirements:

Parameter Description

Name Enter a name for the route map.

Sequence
Number

Enter a sequence number for the route map. Sequence numbers allow route maps to be
executed in an order. If you are configuring multiple match clauses or statements, ensure that
you define a sequence number to uniquely identify eachmatch statement.

Action Configure a permit or deny rule for the match condition.

Table 52: Route Map Configuration Parameters
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Parameter Description

Match Configure the match condition for the routes that have a destination network. The match
statements define a set of conditions for determining if the route redistributionmust be
allowed or denied.
To add a match statement, click the + icon in the Match table. You can set match Type to any of
the options listed here:

n IP address
n Next-hop IP address
n Community
n Interface VLAN
n OSPF route tag

If you have selected the IP address or Next-hop IP address for match type, you can assign a
prefix list to a match statement.
If you have selected Community for match type, use one of the following options to define the
community string.

n as:nn—The community string in the AS:NN format, where AS refers to the Autonomous
System number and NN refers to the network number. The valid range of values is 0-65535.
n community-val—The Community Value string allows you to specify a community value.
The valid range of values is 1–4294967295.
n well-known community—A well-known community. Allows you to configure one of the
following options:
lInternet—Advertises subnets to all neighboring devices.
lNo-Export—Does not advertise prefix to any neighboring device.
lNo-Advertise—Does not advertise subnets to neighboring devices.
lLocal-AS—Prevents sending packets outside the local autonomous system.

n community list—Allows you to select a community list configured on the Gateway.
If you have selected Interface VLAN for match type, enter the interface VLANS separated by
comma. You can enter up to 10 Interface VLANs. The value you enter must be between 1 to
4095. To know how to configure VLANs, see Configuring VLANs on Aruba Gateways.
If you have selected OSPF route tag for match type, a match tag condition is added. You need
to enter the tag names separated by comma. You can enter up to 10 tags. At least one of these
tags has to match to allow route redistribution. The value you enter must be between 0 to
4294967295.

Set Configure a set of rules or attributes to apply to the overlay route that matches the conditions
defined in a match statement.
To add a set attribute, click the + icon in the Set table and configure the following attributes as
per your requirement:

n as-path-prepend—Prepends AS numbers through which the packets have traversed.
You can apply the AS path prepending criteria to determine the best path.
lAS number— Enter any valid AS number between 1–65535.

n last-as—Prepends the last AS number to the AS path. The valid range of values is 1–10.
n community—Sets a community string as an attribute in the routes. Community strings
add additional information to the prefixes advertised to neighboring devices. You can set
one of the following types of community string:
las:nn—The community string in the AS:NN format, where AS refers to the Autonomous
System number and NN refers to the network number. The valid range of values is 0-
65535.
lcommunity-val—The community Value string. The valid range of values is 1–
4294967295.
lwell-known community—A well-known community. You can configure one of the
following options:

lInternet—Advertises subnets to all neighbors.
lNo-Export—Does not advertise prefix to any neighbor.
lNo-Advertise—Does not advertise subnets to neighbors.
lLocal-AS—Prevents sending packets outside the local autonomous system.

lCommunity list—Allows you to select a community list configured on the Gateway.
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Parameter Description

n ip next-hop—Sets a next-hop IPv4 address as an attribute in the routes.
n local-preference—Sets a preference value to the routes for determining the best AS
path. When the neighboring device receives multiple routes to the same destination
network, the route with the highest local preference value takes precedence. The valid
range of values for local preference is 0–4294967295.
n metric—Sets a metric value for determining the preferred path into an Autonomous
System. You can define a metric value between 0–4294967295. When a metric value in a
route matches this value, the route is advertised.
n origin—Sets the origin of the route. The following options are available:
lincomplete (EGP)—To specify that the route is originated from exterior routing protocol.
ligp—To specify that the route is originated from interior routing protocol.

n OSPF route tag—Sets the OSPF route tag information. You can set a value between 0–
4294967295.
n OSPf route-type—Sets the external OSPF route type. Configure one of the following
options:
lExternal Type-1—To redistribute routes as External type 1 which applies both external
cost to the destination and the cost to reach the boundary router in an Autonomous System.
lExternal Type-2—To redistribute routes as External type 2 and apply only the external
cost to the destination.

Configuring a Prefix List
A prefix list allows routing systems to determinewhich routesmust be accepted when they peer with other
networks. A prefix list includes IP prefixes with amatch criteria that allows or denies route redistribution.
Prefix lists contain one ormore ordered entries which are processed sequentially.

Prefix lists can be used as amatch criteria for applying routemap rules on network subnets. For example, if
you want to prevent a route for 10.0.0.0/24 frombeing redistributed, you can define a rule to match the
prefix and add it as amatch criterion in theOverlay redistribution routemap. Formore information, see
Configuring RouteMaps on page 355.

To create a prefix list:

1. To configure a gateway group or a gateway device, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Go to Routing > Overlay Routing page, click Prefix List.
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4. Click the + icon in the Prefix Rules table.

5. Enter a name for the prefix rule.

6. Enter a sequence number.

7. Select the action to performwhen the traffic matches the condition defined in the prefix rule.

8. Enter a network address to which you want to apply the prefix rule.

9. Enter the subnet mask of the network.

10. If you want to define a prefix length parameter and use it as amatch criteria for applying rules, enter
an appropriate value for the optional LE and GE operators. The allowed range of values is 1–32.

If the LE parameter is configured, the prefix rules are applied only if the subnets are equal to or
smaller than the value specified for LE. Similarly, if theGE parameter is configured, the prefix rules
are applied only if the subnets are equal to or greater than the value specified for GE. If either LE
orGE parameter is not configured, the prefix rule is applied only to those subnets that match the
exact address or subnet mask configured in the rule.

Redistributing Overlay Routes
Redistribution rules allow you to enable advertising of routing information from the connected, static, OSPF,
and BGP interfaces into overlay routing. Routing information fromother sources is not automatically
redistributed into overlay routing, but need to be configured for each source protocol locally on each
Gateway.

To redistribute routes as overlay routes:

1. To configure a gateway group or a gateway device, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Go to Routing > Overlay Routing.

4. Click Redistribution Routes.

5. To add a redistribution rule, click + under theRedistribution Rules table.

6. From the Source Protocol drop-down list, select a source type. The following options are available:
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n Static—To redistribute IP static routes.

n IKE Overlay—To redistribute branch routes advertised by the Branch Gateways after establishing
an IPsec tunnel with the VPN Concentrator at the hub site.

n Connected—To redistribute routes received from the subnets that are directly connected to a
router’s interface at the hub site. If you have selected Connected, select the VLAN interfaces to
which theGateway is connected.

n OSPF—To redistribute routes learnt from theOSPF neighbors. If you have selected OSPF, select the
OSPF path type in the Filter column. The following options are available:
o Intra Area—To redistribute routes to same area fromwhich they originated.
o Inter Area—To redistribute routes to another area in theOSPF domain.
o External Type–1—To redistribute as routes as External type 1 which applies both external cost to

the destination and the cost to reach the boundary router in an Autonomous System.
o External Type–2—To redistribute routes as External type 2 and apply only the external cost to

the destination.

n IAP-VPN Overlay—Routes learnt frommicro-branch deployments with Instant APs.

n BGP—To redistribute routes using BGP.

7. Set a Filter for the selected protocol.

8. Associate an existing Route Mapwith the Source Protocols if required. The routemap association
is applicable only for available routes.

9. For connected routes, you can enable theAuto Aggregate option to summarize routes.

Configuring Administrative Distance
Administrative distance is one of themain criteria to determine a preferred routewhen there aremultiple
paths to the same destination. The routewith the lower administrative distance takes precedence for route
redistribution.

To configure administrative distance:

1. To configure a gateway group or a gateway device, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.
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3. On the Routing > Overlay Routing page, click Advanced.

4. Define a route preference value for the following parameters:
n SDWAN overlay distance—Enter a valuewithin the range of 1–255. Default value is 90.

n IKE overlay distance—Enter a valuewithin the range of 1–255. Default value is 70.

n IAP-VPN overlay distance—Enter a valuewithin the range of 1–255. Default value is 60.

Viewing Overlay Routes in the Route Table
To view aGateway group or Gateway route table complete either one of these steps:

1. In theNetwork Operations app, set the filter to Global or a group containing at least one Branch
Gateway.

2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click a gateway underDevice Name.
The dashboard context for the specific gateway is displayed.

4. UnderManage, click Overview > Routing > Route Table.
A complete list of routes advertised by theGateway is displayed.

5. From the Protocol drop-down list, select Overlay to view theOverlay routes.

Troubleshooting Overlay Configuration Issues

1. To troubleshoot Overlay configuration issues in a gateway group or a gateway device, complete either
one of these steps:

n To troubleshoot a Gateway group:

n In theNetwork Operations app, set the filter to aGroup containing at least one Branch
Gateway.

The dashboard context for a group is displayed.

n To troubleshoot a gateway:

2. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway.
The dashboard context for a group is displayed.
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a. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

i. Click a gateway underDevice Name.

The dashboard context for the gateway device is displayed.

3. UnderAnalyze, click Tools. The Tools page for troubleshooting devices opens.

4. Ensure theDevice Type is set to Gateway and theGateway device you want to troubleshoot is listed
underAvailable Devices.

5. From Categories, select Network.

6. Select the commands that you want to use from theCommands list and add to the Selected
Commands.

7. Click Run.

8. Verify the command output and resolve configuration errors if any.

9. Go to monitoring dashboard, verify the configuration status, andmonitor the routes.

10. If the issue persists, contact Aruba Technical Support.

Monitoring SD-WAN Overlay Tunnels and Routes
The Aruba SD-WAN solution provides support to configure SD-WANOverlay network manually and
automatically. To view information about the tunnels and routes configured for individual Branch Gateway,
go to the Tunnels and Routing tab in the gateway monitoring dashboard. Formore information, see
Gateway > WAN > Tunnels and Gateway > Overview > Routing.

Aruba Central provides a separate dashboard to monitor the status of tunnels and routes.

See the following sections formore information:

n Overlay RouteOrchestrator in Map View

n Overlay RouteOrchestrator in Grid View

n Overlay Tunnel Orchestrator in Map View

n Overlay Tunnel Orchestrator in Grid View

Overlay Route Orchestrator in Map View
TheMap view is a pictorial representation of the geographical locations of SD-Branch deployment sites.
When a branch group is selected, themap view displays its data centers and the number of VPN
Concentrators (VPNCs) in each data center. If the selected branch group has hub-mesh topology, the tunnel
network between data centers is also displayed. For information about how to create amesh topology, see
Configuring the SD-WAN HubMesh Topology.

The following topics are discussed in this section:

n Navigating to theMap View

n Overlay RouteOrchestrator Summary

n Overlay RouteOrchestrator Topology

Navigating to the Map View
To view the orchestration topology details in amap or grid:
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1. In theNetwork Operations app, set the filter to Global.
The global dashboard is displayed.

2. UnderManage, click Network Services > SD-WAN Overlay.
The SD-WANOverlay page is displayed in the List view. This is the default view. The page consists
of two tabs:

n Route—Consists of theOverlay Route Orchestrator Summary pane and theOverlay Route
Orchestrator Topology pane.

n Tunnel—Consists of theOverlay Tunnel Orchestrator Summary pane and theOverlay
Tunnel Orchestrator Topology pane.

3. In theOverlay Route Orchestrator Topology section, perform the following steps:

n Click Map to view the orchestration details on a geographical plot.

n Click Grid to view the orchestration details in a grid table.

The Route tab consists of the following sections:

n Overlay RouteOrchestrator Summary

n Overlay RouteOrchestrator Topology

Overlay Route Orchestrator Summary
TheOverlay Route Orchestrator Summary section displays the following information:

n Peers—Number of Branch Gateways configured as peers for exchanging route information. The number
corresponding to Up indicates the gateways that are up and running and the number corresponding to
Down indicates the gateways that are down. Click the number to view gateway details in the contextual
summary table.

The following columns are displayed:
o MAC Address—Displays theMAC address of the gateway.
o Mode—Displays the orchestratedmode.
o Name—Displays the name of the gateway.
o IP Address—Displays the IP address of the gateway.
o Serial—Displays the serial number of the gateway.
o Role—Displays the role adopted by the gateway.
o Device Type—Displays the type of the device.
o Group Name—Displays the name of the group to which the device belongs.

n Branch Groups—The total number of device groups on which the SD-WANOrchestrator is enabled.

n Routes Learned—The total number of routes received frompeer devices.

n Routes Advertised—The total number of routes advertised.

n VPNC Groups—The total number of VPNC groups present in the orchestration.

Figure 93 Overlay Route Orchestrator Summary
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Overlay Route Orchestrator Topology
You can view theOverlay Route Orchestrator Topology details as follows:

n Map View—Apictorial representation of the geographical location of SD-Branch deployment sites.

n Grid View—The topology information for each branch group in a tabular format.

Map View

TheMap view consists of the following sections:

n Branch Group Filter

n Map View

n Contextual summary table

Figure 94 Overlay Route Orchestrator in Map View

Number UI Element Description

1 Branch Group Filter Displays the list of branch groups present in the network.

2 Map View Displays data centers as pins andmesh links as bars (lines).
Selecting a branch group depicts the location of the deployment
site and details of the data center preference configured for the
branch devices. The map also indicates if the VPN Concentrator
(VPNC) is set as the primary VPNC for the Branch Gateways in the
group.
Search Options:

n The icon allows you to search a particular branch group.

Table 53: User Interface Elements
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Number UI Element Description

n The and icons allow you to sort the branch group
names in ascending or descending order.

3 Contextual summary table Displays information corresponding to the selected item (branch
group or data center or tunnel). For example, if you have selected
a branch group, the map displays the geographical location of the
data centers and the summary table displays the Peer, Site, State,
Last State Change, Routes Learned, and Routes Advertised
information.

By default, themap view displays all the data centers of the SD-WAN overlay connected through amesh
link. Youmust select a branch group to view details specific to it.

Map View Elements

The following features aid in reading theOverlay RouteOrchestration Topology in themap view.

Figure 95 Viewing Options

Number UI Element Description

1 Branch Group filter To view the branch group topology in the map, select a branch

group from the Branch Group filter. The data centers ( —pin)
appear on the map. If the branch group is configured with hub-

mesh topology, you can see mesh links ( —bar) between
the data centers.

2 Zoom buttons n Click + to zoom in.
n Click - to zoom out.

3 Home icon Click the Home icon to reset the map view.

4 Data Center pin Hover over the data center to view the data center name and its
VPNCs.

Table 54: Map View Elements
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Number UI Element Description

5 Tunnel lines This feature is specific to hub-mesh topology branch groups.
When you select a branch group with mesh topology, there are
tunnels formed between the data centers. The tunnels are
indicated by lines between the data centers.

Tunnel Details
Hover over the tunnel link to view the number of active
tunnels between the data centers.

NOTE: Ensure to click the mesh link (bar) only when you see the
hand pointer icon.

Source and Destination
Details

To view the source and destination site details of a tunnel, click
the tunnel link. A pop-up window appears displaying the list of
tunnels between the data centers and its corresponding
information.
The columns present in the pop-up window are:

n Name—Name of the tunnel.
n From and To—The From and To site, hosts and links that
connect the tunnel.
n Tunnel State—Current status of the tunnel.
n Next Rekey—Time stamp for the next rekey.

NOTE:

n Expand the drop-down to view details about the devices in
the source and the destination such as the link type, their
MAC and IP addresses and so on.

n Click the Ellipses icon to display more columns in the
table. See the Tunnel Details Pop-Up topic for more
information.

6 Tunnel/Data Center Status The status of the tunnel and data center is indicated by colors.
n Green—Indicates active tunnels or data centers.
n Red—Indicates inactive tunnels or data centers.
n Yellow— Indicates one or more tunnels that are down.

Tunnel Details Pop-Up

In themap view for theOverlay Route Orchestrator Topology, click the tunnel link to display the tunnel
details pop-up window.

Figure 96 Pop-up—Tunnel Details

Contextual Summary Table
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To view the overlay route for each group and the devices in a group, click the branch group in theMap or
Grid view. The route details for Branch Gateways deployed in the selected branch group is displayed
towards the bottomof the page. The details displayed in the summary table are contextual to the selected
item in theMap orGrid. If you select the branch group, the values in the columns correspond to the branch
group. Similarly, if you select the data center or tunnel, the respective values are displayed.

Figure 97 Overlay Route Orchestrator Device Details

By default, theControl Connections option is selected and the following details are displayed for each
Branch Gateway in a group:

n Total—The total number of connections established.

n Last Refreshed—Indicates when the last refresh was completed.

n Peer—The list of Peer Branch Gateway devices that exchanged routes.

n Site—The physical location of the SD-Branch site.

n State—The state of the connection which could beUp,Down, orUnknown.
n Last State Change—The time stamp of the last state change.

n Routes Advertised—The number of advertised routes. Click the number to view the details of the routes
advertised by the device
o The Routes Advertised table displays the following:
o Routes Advertised—Displays the route name.
o Timestamp—Displays the time.
o Nexthop—Displays information about the next hop.
o Origin Protocol—Displays the protocol taken by the route at origin.
o Cost—Displays cost associated with the route.
o Segment Name—Displays the segment associated for the route.

Figure 98 Details of the Routes Advertised
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n Routes Learned—The number of routes that are learned fromother peer devices. Click the number to
view the details of the routes learned from the device.

The Routes Learned table displays the following:
o Routes Learned—Displays the route name.
o Timestamp—Displays the time.
o Origin Protocol—Displays the protocol taken by the route at origin.
o Originator ID/Nexthop—Displays the originator ID or nexthop information.
o Metric—Displays themetric value of the route.
o Segment Name—Displays the segment associated for the route.

Figure 99 Details of the Routes Learned

n System MAC—TheMAC address of Branch Gateway.

n Branch Group—The group to which the device is assigned.

n Duration—The uptime or downtime of the Branch Gateway.

n Last Reset Reason—The reason that triggered the last reboot.

Expand the device to view the peer device details and the link to Event Logs:

n Events—The link to the table that lists the events recorded. Click the number of events to open the Event
Logs table.

Figure 100 Overlay Route Orchestrator Event Logs

n Date/Time—The timestamp of the event.

n Severity —Specifies whether the event is aWarning, an Alert, or aNotice based on the severity of the
event.
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n Type—Specifies the type of event
o Config
o Route
o Device

n Sub Type—Specifies the Sub Type of the event. It could be one of the following.
o Connection
o Tunnel
o Route
o Config
o Customer

n Description—Abrief description of the event.

If you select Routes in the drop-down, the following details are displayed:
n Route—The subnet fromwhich route is advertised.

n Site —The data center or the hub site that redistributed routes.

n Advertising Peer—The peer device that advertised the route.

n Origin Protocol—The routing protocol that redistributed the route.

n Metric—The cost associated with the route

n Segment Name—Displays the segment associated for the route.

Figure 101 Overlay Route Orchestrator Route Details

Overlay Route Orchestrator in Grid View
TheGrid view provides the topology information for each branch group and VPNC group in a tabular
format.

The following topics are discussed in this section:

n Navigating to theGrid View

n Overlay RouteOrchestrator Summary

n Overlay RouteOrchestrator Topology

Navigating to the Grid View
To view the orchestration topology details in amap or grid:
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1. In theNetwork Operations app, set the filter to Global.
The global dashboard is displayed.

2. UnderManage, click Network Services > SD-WAN Overlay.
The SD-WANOverlay page is displayed in the List view. This is the default view. The page consists
of two tabs:

n Route—Consists of theOverlay Route Orchestrator Summary pane and theOverlay Route
Orchestrator Topology pane.

n Tunnel—Consists of theOverlay Tunnel Orchestrator Summary pane and theOverlay
Tunnel Orchestrator Topology pane.

3. In theOverlay Route Orchestrator Topology section, perform the following steps:

n Click Map to view the orchestration details on a geographical plot.

n Click Grid to view the orchestration details in a grid table.

The Route tab consists of the following sections:

n Overlay RouteOrchestrator Summary

n Overlay RouteOrchestrator Topology

Overlay Route Orchestrator Summary
TheOverlay Route Orchestrator Summary section displays the following information:

n Peers—Number of Branch Gateways configured as peers for exchanging route information. The number
corresponding to Up indicates the gateways that are up and running and the number corresponding to
Down indicates the gateways that are down. Click the number to view gateway details in the contextual
summary table.

The following columns are displayed:
o MAC Address—Displays theMAC address of the gateway.
o Mode—Displays the orchestratedmode.
o Name—Displays the name of the gateway.
o IP Address—Displays the IP address of the gateway.
o Serial—Displays the serial number of the gateway.
o Role—Displays the role adopted by the gateway.
o Device Type—Displays the type of the device.
o Group Name—Displays the name of the group to which the device belongs.

n Branch Groups—The total number of device groups on which the SD-WANOrchestrator is enabled.

n Routes Learned—The total number of routes received frompeer devices.

n Routes Advertised—The total number of routes advertised.

n VPNC Groups—The total number of VPNC groups present in the orchestration.

Figure 102 Overlay Route Orchestrator Summary
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Overlay Route Orchestrator Topology
You can view theOverlay Route Orchestrator Topology details as follows:

n Map View—Apictorial representation of the geographical location of SD-Branch deployment sites.

n Grid View—The topology information for each branch group in a tabular format.

Grid View

TheGrid view consists of the following sections:

n Branch Groups

n VPNCGroups

Branch Groups

TheBranch Groups tab consists of the hub and spoke overlay topology details:

n Branch Group—The name of the device group in which the Aruba Gateways are provisioned.

n DC Preference—The data center preference order configured for the branch devices.

n Site—The physical location of the SD-Branch site.

n Preferred VPNC—The VPNC deployed in the preferred hub site.

n Latitude—The latitude of the SD-Branch topology.

n Longitude—The longitude of the SD-Branch topology.

VPNC Groups

TheVPNC Groups tab consists of the data center name and themesh topology to which it belongs.

n Name—The data center name.

n Hub Mesh—Themesh topology to which the data center is associated.

Figure 103 Overlay Route Orchestrator in Grid View

Contextual Summary Table

To view the overlay route for each group and the devices in a group, click the branch group in theMap or
Grid view. The route details for Branch Gateways deployed in the selected branch group is displayed
towards the bottomof the page. The details displayed in the summary table are contextual to the selected
item in theMap orGrid. If you select the branch group, the values in the columns correspond to the branch
group. Similarly, if you select the data center or tunnel, the respective values are displayed.
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Figure 104 Overlay Route Orchestrator Device Details

By default, theControl Connections option is selected and the following details are displayed for each
Branch Gateway in a group:

n Total—The total number of connections established.

n Last Refreshed—Indicates when the last refresh was completed.

n Peer—The list of Peer Branch Gateway devices that exchanged routes.

n Site—The physical location of the SD-Branch site.

n State—The state of the connection which could beUp,Down, orUnknown.
n Last State Change—The time stamp of the last state change.

n Routes Advertised—The number of advertised routes. Click the number to view the details of the routes
advertised by the device
o The Routes Advertised table displays the following:
o Routes Advertised—Displays the route name.
o Timestamp—Displays the time.
o Nexthop—Displays information about the next hop.
o Origin Protocol—Displays the protocol taken by the route at origin.
o Cost—Displays cost associated with the route.
o Segment Name—Displays the segment associated for the route.

Figure 105 Details of the Routes Advertised

n Routes Learned—The number of routes that are learned fromother peer devices. Click the number to
view the details of the routes learned from the device.

The Routes Learned table displays the following:
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o Routes Learned—Displays the route name.
o Timestamp—Displays the time.
o Origin Protocol—Displays the protocol taken by the route at origin.
o Originator ID/Nexthop—Displays the originator ID or nexthop information.
o Metric—Displays themetric value of the route.
o Segment Name—Displays the segment associated for the route.

Figure 106 Details of the Routes Learned

n System MAC—TheMAC address of Branch Gateway.

n Branch Group—The group to which the device is assigned.

n Duration—The uptime or downtime of the Branch Gateway.

n Last Reset Reason—The reason that triggered the last reboot.

Expand the device to view the peer device details and the link to Event Logs:

n Events—The link to the table that lists the events recorded. Click the number of events to open the Event
Logs table.

Figure 107 Overlay Route Orchestrator Event Logs

n Date/Time—The timestamp of the event.

n Severity —Specifies whether the event is aWarning, an Alert, or aNotice based on the severity of the
event.

n Type—Specifies the type of event
o Config
o Route
o Device
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n Sub Type—Specifies the Sub Type of the event. It could be one of the following.
o Connection
o Tunnel
o Route
o Config
o Customer

n Description—Abrief description of the event.

If you select Routes in the drop-down, the following details are displayed:
n Route—The subnet fromwhich route is advertised.

n Site —The data center or the hub site that redistributed routes.

n Advertising Peer—The peer device that advertised the route.

n Origin Protocol—The routing protocol that redistributed the route.

n Metric—The cost associated with the route

n Segment Name—Displays the segment associated for the route.

Figure 108 Overlay Route Orchestrator Route Details

Overlay Tunnel Orchestrator in Map View
TheMap view is a pictorial representation of the geographical locations of SD-Branch deployment sites.
When a branch group is selected, themap view displays its data centers and the number of VPN
Concentrators (VPNCs) in each data center. If the branch group has amesh topology, the tunnel network
between data centers is also displayed. For information about how to create amesh topology, see
Configuring the SD-WAN HubMesh Topology.

The following topics are discussed in this section:

n Navigating to theMap View

n Overlay Tunnel Orchestrator Summary

n Overlay Tunnel Orchestrator Topology

Navigating to the Map View
To view the orchestration topology details in amap or grid:

1. In theNetwork Operations app, set the filter to Global.
The global dashboard is displayed.
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2. UnderManage, click Network Services > SD-WAN Overlay.
The SD-WANOverlay page is displayed in the List view. This is the default view. The page consists
of two tabs:

n Route—Consists of theOverlay Route Orchestrator Summary pane and theOverlay Route
Orchestrator Topology pane.

n Tunnel—Consists of theOverlay Tunnel Orchestrator Summary pane and theOverlay
Tunnel Orchestrator Topology pane.

3. In theOverlay Route Orchestrator Topology section, perform the following steps:

n Click Map to view the orchestration details on a geographical plot.

n Click Grid to view the orchestration details in a grid table.

The Tunnel tab includes the following sections:

n Overlay Tunnel Orchestrator Summary

n Overlay Tunnel Orchestrator Topology

Overlay Tunnel Orchestrator Summary
TheOverlay Tunnel Orchestrator Summary displays the following information:

n Peers—The number of Branch Gateways configured as peers for exchanging route information. The
number corresponding to Up indicates the gateways that are up and running and the number
corresponding to Down indicates the gateways that are down. Click the number to view details in the
contextual summary table.

The following columns are displayed:

l MAC Address—Displays theMAC address of the gateway.

l Mode—Displays the orchestratedmode.

l Name—Displays the name of the gateway.

l IP Address—Displays the IP address of the gateway.

l Serial—Displays the serial number of the gateway.

l Role—Displays the role adopted by the gateway.

l Device Type—Displays the type of the device.

l Group Name—Displays the name of the group to which the device belongs.

n Branch Groups—The total number of device groups on which SD-WANOrchestrator is enabled.

n Tunnels—The total number of tunnels orchestrated.

n VPNC Groups—The total number of VPNC groups present in the orchestration.

Figure 109 Overlay Tunnel Orchestration Summary

Overlay Tunnel Orchestrator Topology
You can view theOverlay Tunnel Orchestrator Topology details as follows:
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n Map View—Apictorial representation of the geographical location of SD-Branch deployment sites.

n Grid View—The topology information for each branch group in a tabular format.

Map View

TheMap view consists of the following sections:

n Branch Group filter

n Map View

n Contextual summary table

Figure 110 Overlay Tunnel Orchestrator in Map View

Number UI Element Description

1 Branch Group filter Displays the list of branch groups present in the network.

2 Map View Displays data centers as pins andmesh links as bars (lines).
Selecting a branch group depicts the location of the deployment
site and details of the data center preference configured for the
branch devices. The map also indicates if the VPN Concentrator
(VPNC) is set as the primary VPNC for the Branch Gateways in the
group.
Search Options:

n The icon allows you to search a particular branch group.

n The and icons allow you to sort the branch group
names in ascending or descending order.

Table 55: User Interface Elements
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Number UI Element Description

3 Contextual summary table Displays information corresponding to the selected item (branch
group or data center or tunnel). For example, if you have selected
a branch group, the map displays the geographical location of the
data centers and the summary table displays the Peer, Site, State,
Last State Change, Routes Learned, and Routes Advertised
information.

By default, themap view displays all the data centers of the SD-WAN overlay connected via amesh link. You
must select a branch group to view details specific to the selected branch group.

Map View Elements

The following features aid in reading theOverlay Tunnel Orchestration Topology inmap view.

Figure 111 Viewing Options

Number UI Element Description

1 Branch Group filter To view the branch group topology in the map, select a branch

group from the Branch Group filter. The data centers ( —pin)
appear on the map. If the branch group is configured with hub-

mesh topology, you can see mesh links ( —bar) between
the data centers.

2 Zoom buttons n Click + to zoom in.
n Click - to zoom out.

3 Home icon Click the Home icon to reset the map view.

4 Data Center pin Hover over the data center to view the data center name and its
VPNCs.

Table 56: Map View Elements
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Number UI Element Description

5 Tunnel lines This feature is specific to hub-mesh topology branch groups.
When you select a branch group with mesh topology, there are
tunnels formed between the data centers. The tunnels are
indicated by lines between the data centers.

Tunnel Details
Hover over the tunnel link to view the number of active
tunnels between the data centers.

NOTE: Ensure to click the mesh link (bar) only when you see the
hand pointer icon.

Source and Destination
Details

To view the source and destination site details of a tunnel, click
the tunnel link. A pop-up window appears displaying the list of
tunnels between the data centers and its corresponding
information.
The columns present in the pop-up window are:

n Name—Name of the tunnel.
n From and To—The From and To site, hosts and links that
connect the tunnel.
n Tunnel State—Current status of the tunnel.
n Next Rekey—Time stamp for the next rekey.

NOTE:

n Expand the drop-down to view details about the devices in
the source and the destination such as the link type, their
MAC and IP addresses and so on.

n Click the Ellipses icon to display more columns in the
table. See the Tunnel Details Pop-Up topic for more
information.

6 Tunnel/Data Center Status The status of the tunnel and data center is indicated by colors.
n Green—Indicates active tunnels or data centers.
n Red—Indicates inactive tunnels or data centers.
n Yellow— Indicates one or more tunnels that are down.

Tunnel Details Pop-Up

In themap view for theOverlay Tunnel Orchestrator Topology, click the tunnel link to display the
tunnel details pop-up window.

Figure 112 Pop-up—Tunnel Details

Contextual Summary Table
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To view tunnel information for each group and the devices in a group, click the branch group in theMap or
Grid view. The tunnel details for Branch Gateways deployed in selected branch group is displayed. The
details displayed in the summary table are contextual to the selected item in theMap orGrid. If you select
the branch group, the values in the columns correspond to the branch group. Similarly, if you select the data
center or tunnel, the respective values are displayed.

Figure 113 Overlay Tunnel Orchestrator—Tunnel Details

n By default, theControl Connections option is selected and the following details are displayed for each
Branch Gateway in a group:

n Total—The total number of connections established.

n Last Refreshed—Indicates when the last refresh was completed.

n Peer—The list of peer devices with which the tunnel is established.

n Site—The physical location of the hub site with which the tunnel is established.

n Type—The type of the site. Indicates if the tunnel request is triggered from the hub or branch site.

n Tunnel State—The current status of the tunne

n Last Status Change—The time stamp of the last status change.

n Tunnels—Displays the number of tunnels orchestrated, number of live tunnels and the number of active
tunnels.

n Uptime—The uptime of the tunnel.

n Last Reset Reason—The reason that triggered the last reboot.

n Uplink—Displays the uplink type and the VLAN tag associated with the tunnel.

Expand the device to view the peer device details and the link to Events Log:

n Events—The link to the table that lists the events recorded. Click Events to open the Event Logs table

Figure 114 Overlay Tunnel Orchestrator Event logs
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n Date/Time—The timestamp of the event.

n Severity—Specifies whether the event is Invalid, or aWarning, or an Alert or aNotice based on the
severity of the event.

n Type—Specifies the type of event.
o Config—Aconfiguration event.
o Tunnel—Tunnel related events.
o Device—Adevice related event such as a gateway going down.

n Sub Type—Specifies the sub type of the event.
o Create—New tunnel configuration is created.
o Update—Tunnel configuration is updated.
o Delete—Tunnel configuration is deleted.
o Up—Device is operationally UP.
o Down—Device is operationally down.
o IKE—Tunnel operational event sent by the device.
o Resync—Adevice tries to resync.

n Description—Abrief description of the event.

If you select Tunnels in the drop-down, list of tunnels with the following details is displayed:
n Name—Nameof the tunnel.

n From and To—The From and To site, hosts and links that connect the tunnel.

n Tunnel State—Current status of the tunnel.

n Next Rekey—Time stamp for the next rekey.

Expand the drop-down to view details about the devices in the source and the destination such as the link
type, theirMAC and IP addresses and so on.

Figure 115 Overlay Tunnel Orchestrator—Tunnels

Overlay Tunnel Orchestrator in Grid View
TheGrid view provides the topology information for each branch group and VPNC group in a tabular
format.

The following topics are discussed in this section:

n Navigating to theGrid View

n Overlay Tunnel Orchestrator Summary

n Overlay Tunnel Orchestrator Topology
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Navigating to the Grid View
To view the orchestration topology details in amap or grid:

1. In theNetwork Operations app, set the filter to Global.
The global dashboard is displayed.

2. UnderManage, click Network Services > SD-WAN Overlay.
The SD-WANOverlay page is displayed in the List view. This is the default view. The page consists
of two tabs:

n Route—Consists of theOverlay Route Orchestrator Summary pane and theOverlay Route
Orchestrator Topology pane.

n Tunnel—Consists of theOverlay Tunnel Orchestrator Summary pane and theOverlay
Tunnel Orchestrator Topology pane.

3. In theOverlay Route Orchestrator Topology section, perform the following steps:

n Click Map to view the orchestration details on a geographical plot.

n Click Grid to view the orchestration details in a grid table.

The Tunnel tab consists of the following sections:

n Overlay Tunnel Orchestrator Summary

n Overlay Tunnel Orchestrator Topology

Overlay Tunnel Orchestrator Summary
TheOverlay Tunnel Orchestrator Summary displays the following information:

n Peers—The number of Branch Gateways configured as peers for exchanging route information. The
number corresponding to Up indicates the gateways that are up and running and the number
corresponding to Down indicates the gateways that are down. Click the number to view details in the
contextual summary table.

The following columns are displayed:

l MAC Address—Displays theMAC address of the gateway.

l Mode—Displays the orchestratedmode.

l Name—Displays the name of the gateway.

l IP Address—Displays the IP address of the gateway.

l Serial—Displays the serial number of the gateway.

l Role—Displays the role adopted by the gateway.

l Device Type—Displays the type of the device.

l Group Name—Displays the name of the group to which the device belongs.

n Branch Groups—The total number of device groups on which SD-WANOrchestrator is enabled.

n Tunnels—The total number of tunnels orchestrated.

n VPNC Groups—The total number of VPNC groups present in the orchestration.
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Figure 116 Overlay Tunnel Orchestration Summary

Overlay Tunnel Orchestrator Topology
You can view theOverlay Tunnel Orchestrator Topology details as follows:

n Map View—Apictorial representation of the geographical location of SD-Branch deployment sites.

n Grid View—The topology information for each branch group in a tabular format.

Grid View

TheGrid view displays the following tabs:

n Branch Groups

n VPNCGroups

Branch Groups

TheBranch Groups tab consists of the hub and spoke overlay topology details:

n Branch Group—The name of the device group in which the Aruba Gateways are provisioned.

n DC Preference—The data center preference order configured for the branch devices.

n Site—The physical location of the SD-Branch site.

n Preferred VPNC—The VPNC deployed in the preferred hub site.

n Latitude—The latitude of the SD-Branch topology.

n Longitude—The longitude of the SD-Branch topology.

VPNC Groups

TheVPNC Groups tab consists of the data center name and themesh topology to which it belongs.

n Name—The data center name.

n Hub Mesh—Themesh topology to which the data center is associated.

Figure 117 Overlay Tunnel Orchestrator in Grid View
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Contextual Summary Table

To view tunnel information for each group and the devices in a group, click the branch group in theMap or
Grid view. The tunnel details for Branch Gateways deployed in selected branch group is displayed. The
details displayed in the summary table are contextual to the selected item in theMap orGrid. If you select
the branch group, the values in the columns correspond to the branch group. Similarly, if you select the data
center or tunnel, the respective values are displayed.

Figure 118 Overlay Tunnel Orchestrator—Tunnel Details

n By default, theControl Connections option is selected and the following details are displayed for each
Branch Gateway in a group:

n Total—The total number of connections established.

n Last Refreshed—Indicates when the last refresh was completed.

n Peer—The list of peer devices with which the tunnel is established.

n Site—The physical location of the hub site with which the tunnel is established.

n Type—The type of the site. Indicates if the tunnel request is triggered from the hub or branch site.

n Tunnel State—The current status of the tunne

n Last Status Change—The time stamp of the last status change.

n Tunnels—Displays the number of tunnels orchestrated, number of live tunnels and the number of active
tunnels.

n Uptime—The uptime of the tunnel.

n Last Reset Reason—The reason that triggered the last reboot.

n Uplink—Displays the uplink type and the VLAN tag associated with the tunnel.

Expand the device to view the peer device details and the link to Events Log:

n Events—The link to the table that lists the events recorded. Click Events to open the Event Logs table

Figure 119 Overlay Tunnel Orchestrator Event logs
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n Date/Time—The timestamp of the event.

n Severity—Specifies whether the event is Invalid, or aWarning, or an Alert or aNotice based on the
severity of the event.

n Type—Specifies the type of event.
o Config—Aconfiguration event.
o Tunnel—Tunnel related events.
o Device—Adevice related event such as a gateway going down.

n Sub Type—Specifies the sub type of the event.
o Create—New tunnel configuration is created.
o Update—Tunnel configuration is updated.
o Delete—Tunnel configuration is deleted.
o Up—Device is operationally UP.
o Down—Device is operationally down.
o IKE—Tunnel operational event sent by the device.
o Resync—Adevice tries to resync.

n Description—Abrief description of the event.

If you select Tunnels in the drop-down, list of tunnels with the following details is displayed:
n Name—Nameof the tunnel.

n From and To—The From and To site, hosts and links that connect the tunnel.

n Tunnel State—Current status of the tunnel.

n Next Rekey—Time stamp for the next rekey.

Expand the drop-down to view details about the devices in the source and the destination such as the link
type, theirMAC and IP addresses and so on.

Figure 120 Overlay Tunnel Orchestrator—Tunnels
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Aruba SD-Branch Integration with Zscaler Cloud Security Service
To secure traffic and enforce policies, businesses often useMPLS links or encrypted VPN links to tunnel
traffic between the branch and data center. However, backhauling branch traffic to the data center before it
reaches an endpoint can result in latency and increased bandwidth consumption.

For faster delivery and efficient use of bandwidth, you can break your branch traffic locally and redirect the
traffic directly to the Internet. However, if you want to allow branch devices to directly connect to the
Internet, youmust ensure that your branch network is secured from threats. Themost common approach
to secure the branch Internet traffic is to enable branch devices to route all Internet traffic through a cloud
security platform, such as the Zscaler cloud security service.

The Zscaler Cloud Security Platform provides fast and secure connections between users and applications,
regardless of device, location, or network. Branch Gateways in the SD Branch can inter-operatewith Zscaler
cloud network to provide a secure branch network connectivity with threat detection capabilities.

The integration between the Aruba Branch Gateways and Zscaler Internet Access (ZIA) allows you to set up a
secure connection between the branch networks and one or several cloud-hosted enforcement points called
Zscaler Enforcement Nodes (ZENs).

The following figure illustrates the SD-Branch integration with the Zscaler cloud network:

Figure 121 Zscaler and SD-Branch Integration

Branch Gateways connect to ZENs through IPsec tunnel with null encryption. This provides the ability to
traverseNAT boundaries and leverage IKEv2 for authentication, while at the same time limiting the
overhead.
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After the tunnels are established between the Branch Gateways and ZEN nodes, Zscaler uses reverse-
pinning technology to ensure that the traffic is sent back through the same tunnel fromwhich the traffic
originated.

Integrating SD-Branch with ZIA
The SD-Branch and Zscaler integration requires configuration at both Zscaler admin interface and Aruba
Central.

Ensure that you complete these prerequisite steps, before configuring Branch Gateways for ZIA integration:

1. Locate the FQDN of the ZIA instance to be used. Formore information, see the Locating the
Hostnames and IP Addresses of Your ZENs at ZIA Help portal.

2. Verify that the Branch Gateways can resolve the FQDN of the selected nodes.

3. Access the ZIA admin portal and set up the customer information, VPN credentials, and location (site
information).

4. Set up the API key to use for the Zscaler REST APIs.

Setting up Tunnels to ZIA
The Aruba SD-Branch supports the following types of configurationmethods for setting up IPsec tunnels to
ZIA:

n Orchestrated Tunnel Establishment—In thismethod, ZENs are automatically discovered and assigned
for tunnel establishment. This configuration can be applied globally or at the group level. Aruba
recommends that you use the global configuration or large SD-Branch deployments.

n Manual Tunnel Establishment—In thismethod, youmust manually configure ZEN nodes on each
Branch Gateway group.

Orchestrated Tunnel Establishment

The orchestrated tunnel establishment or automatic tunnel service is a limited availability feature. To
avail this feature, contact your Aruba Sales specialist.

In thismethod, SD-WANOrchestrator automates large distributed deployments to integrate Aruba SD-
Branch and ZIA.

To enable SD-WANOrchestrator to automate large distributed deployments, perform the following steps:

1. Configure ZIA for API Access in Zscaler admin portal.

2. Configure Aruba SD-WAN for Orchestrated Tunnels in Aruba Central.

Configuring ZIA for API access
In the automated workflow, it is not required to configure locations or VPN credentials in the Zscaler admin
portal. Instead, SD-WANOrchestrator uses the partner access to communicate through the API.

To add a partner API key for Aruba SD-Branch, complete the following steps:

1. Log in to the Zscaler admin portal.

2. Click Administration > Partner Integrations > SD-WAN in the Partner Integrations page in the ZIA
portal.
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3. Click Add Partner Key and create a Partner API Key.

4. Create a Partner Administrator Role with a name, access control, and SD-WAN API partner pccess
to provide credentials for the API access. This is done fromAdministration > Role Management.

5. Create a partner account for the SD-WANOrchestrator with the following details. This can be done
fromAdministration > AdministratorManagement.

a. Login ID—Login ID of the ZIA admin account.

b. Email—Email address of the ZIA admin account.

c. Name—Username of the ZIA admin account.

d. Partner Role—Nameof the Partner Administrator Role.

e. Password—Passwordof the ZIA admin account.

Configuring Aruba SD-WAN for Orchestrated Tunnels

The automatic tunnel service is a limited availability feature. To avail this feature, contact your Aruba
Sales specialist.

To automatically set up IPsec tunnels between the Branch Gateways in Aruba Central and ZIA:

1. 1. To enable automatic configuration of IPSec Tunnels globally on all Branch Gateways, click
Global Settings and configure the following parameters:

a. Select theAutomatic option.

b. Configure the following parameters:
n Base URI—BaseURI of the Zscaler API. This is the Zscaler cloud name that was provisioned for your

organization. For example: admin.zscalerbeta.net
n Username—Username of the ZIA admin account. This is the username created by the user to access

the ZIA credentials.

n Password—Password of the admin account. This is the password created by the user to access the ZIA
credentials.

n API Key—API key for accessing the ZENs.

The base URI and API key information are available in the ZScaler Admin Portal.

a. Click Save Settings.

2. To enable automatic IPSec tunnel establishment with ZIA on specific device groups:

a. Click Group Orchestration

b. Select the device groups.

c. Click Enable.

When automatic tunnel configuration is enabled, the tunnel orchestration service performs the following
functions:
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n Obtains the public IP address of all Gateways that are currently connected to Aruba Central.

n Based on the public IP address of the Branch Gateways, discovers two ZENs closer for each Branch
Gateway.

n Generates and publishes an IKE crypto map on the Branch Gateways.

n Registers Branch Gateways in the Zscaler cloud network using the ZIA admin credentials configured in
Aruba Central. When the devices are registered, the tunnel configuration is distributed to the ZENs in the
Zscaler cloud.

Manual Tunnel Establishment
In themanual workflow, the integration with ZIA requirs configurations on the Zscaler admin portal and
Aruba Central.

Prerequisites
Locate the FQDN of the ZIA instance to be used. Formore information, see the Locating the Hostnames and
IP Addresses of Your ZENs at ZIA Help portal.

Configuring ZIA
Configure the ZIA service to terminate VPN tunnels fromAruba Branch Gateway. These VPN tunnels are the
IPSec tunnels using IKEv2 credentials to uniquely identify each Branch Gateway. Each Branch Gateway
would therefore have to be assigned with a Location and the corresponding VPN credentials in the Zscaler
admin portal.

To create the Location and credentials in Zscaler admin portal:

1. Navigate to Administration > Resources > Location Management.

2. ChooseAdd Location and enter the general information about the location.

3. Select the previously created VPN credentials or create a new set of credentials by clicking the + sign.

4. Optionally, enable other features for this location.

Configuring Aruba Branch Gateways to manually establish tunnels to ZIA
Perform the following tasks on the Branch Gateway to enable Zscaler integration:

1. To configure a Gateway group or Gateway complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.
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d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Click VPN > Cloud Security.

4. In the IPsec Maps section, click + to open theNew IPsecmap section.

5. Ensure that Zscaler is set as the cloud security provider.

6. Enter an administrative name for the tunnel.

7. Enter a priority number for the IPsecmap within a range of 1 to 10,000. A priority value of 1 indicates
the highest priority. Ensure that the same priority is set for all active and backup tunnels.

8. Configure a transform set. Transform sets allow you to define a combination of security protocols
and algorithms that you can apply to the IPsec traffic flow. To add a transform set:

a. Click + in the Transforms section.

b. Enter a name for the transform.

c. Specify the encryptionmethods to use in the transformation set.

The Zscaler cloud provider does not support DES encryption in IKEv2 phase 2 parameters. For
more information, see https://help.zscaler.com/zia/about-ipsec-vpns.

d. Click Save Settings.

9. Enter the FQDN of the Zscaler Enforcement Node (ZEN) asDestination gateway FQDN.

Ensure that the destination gateway FQDN value contains the string, zscaler in it.

10. Enter the FQDN of the VPN source in Source FQDN.

11. Select the VLAN ID to which you want to apply the IPsecmap. For Branch Gateways, select uplink
VLAN. You can select multiple VLANs to enable load balancing betweenmultiple uplinks.

12. Enter IKE pre-shared secret key that you configured on the ZIA portal.

13. Click Save Settings.

14. Repeat the steps to create a backup tunnel.

15. Specify the source FQDN in the Source FQDN field.

16. Configure the following parameters to the specified values:

Configuring Zscaler Nexthop List
Configure Zscaler nexthop list with Zscaler active and standby IPsec tunnels on different uplinks. Formore
information on configuring a nexthop list, see Configuring Next Hop Lists for PBR on page 268.

Adding Nexthop List to PBR Policy
Add the nexthop list to a PBR policy and ensure that the policy is applied to a user role or VLAN. Formore
information on adding a nexthop list to a global PBR policy, see Configuring Policies for PBR on page 266.

Verifying Tunnel Status
To verify the status of the tunnels:
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1. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway.
The dashboard context for a group is displayed.

2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click a gateway underDevice Name.
The dashboard context for the gateway device is displayed.

4. UnderManage, click Overview. TheGateway Details page is displayed.

5. Click the Tunnels tab to view the Zscaler tunnel details.

Formore information, see Gateway > WAN > Tunnels.

You can also view the tunnel status and uplink health in theMonitoring & Reports > Topology page.

Additional References
Formore information on Zscaler and Aruba SD-Branch integration with ZIA:

n Visit https://www.zscaler.com/

n Refer to the Aruba SD-Branch and Zscaler Internet Access Integration Guide

Configuring Prisma Access
To enable integration between the Aruba SD-Branch and Prisma Access, complete the following steps:

n Configuring Prisma Access for Aruba SD-Branch Integration

n Configuring Branch Gateways for Prisma Access Integration

Configuring Prisma Access for Aruba SD-Branch Integration
To configure branch locations, IPsec tunnels, and crypto policies, complete the following steps in the Prisma
Access portal:

1. Ensure that you deploy the Panorama VM in your data center.

2. To access the Prisma Access dashboard, install the cloud service plug-in on Panorama.

3. Log in to Prisma Access dashboard and complete the following tasks:

a. Create IPsec tunnels.

b. Configure crypto profiles.

c. Create a branch network in Panorama.

d. Use route summary to advertise the branch local subnets to Prisma Access.

From the Prisma Accesss dashboard, you can get the IP address of the required cloud service
region. This IP address is configured as the peer gateway IP address of the Gateway on .

Formore information on planning the cloud service infrastructure and service connection, see Prisma
Access documentation.

https://www.zscaler.com/
https://support.arubanetworks.com/Documentation/tabid/77/DMXModule/512/EntryId/34365/Default.aspx
https://docs.paloaltonetworks.com/globalprotect/gpcs.html
https://docs.paloaltonetworks.com/globalprotect/gpcs.html
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Configuring Branch Gateways for Prisma Access Integration
Before configuring the Branch Gateways, ensure that the devices can reach the IP address of the
selected cloud region on Prisma Access.

Complete the following steps on the Branch Gateway:

1. Configuring IPsecMaps on page 391

2. Configuring Prisma Access Next-hop List on page 393

3. Adding Next-hop List to a Routing Policy on page 394

4. Applying Policies to Roles or VLANs

5. Verifying Tunnel Status

Configuring IPsec Maps
To configure an IPsecmap for Prisma Access, complete the following tasks:

1. To configure a Branch Gateway group or Branch Gatewaycomplete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. Click VPN > Cloud Security.

3. In the IPsec Maps section, click + to open theNew IPsec map section.

4. Select Palo Alto Networks - Prisma as the cloud security provider from the drop-down list.

5. Enter a name for the IPsecmap. The allowed character limit is 128.

6. Enter a priority number for the IPsecmap within a range of 1 to 10,000. A priority value of 1 indicates
the highest priority.

7. Configure a transform set. Transform sets allow you to define a combination of security protocols
and algorithms that you can apply to the IPsec traffic flow.

To add a transform set:
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a. Click + under Transforms.

b. Specify the encryptionmethods to use in the transformation set.

c. Click Save Settings.

8. Enter the IP address of the cloud region elected from the Prisma Access dashboard in the Tunnel
destination IP field.

9. Select one of the following options in theRepresentation type drop-down list:

n Text-Based
n Hex-Based

10. Enter IKE pre-shared secret key that you configured on the Prisma Access dashboard in the
IKE shared secret and Retype shared secret fields.

11. Select one of the following options for Tunnel source as per your configuration requirements.

n VLAN—Select a VLAN from theVLAN drop-down list. Select the VLAN to use for bringing up tunnels
to Prisma Access (in the case of Branch Gateway) or the source VLAN in the case of VPN
Concentrators.

n Uplink VLAN—If required, configure a primary and secondary uplink VLAN for the primary and
secondary source FQDNs. If multiple uplinks are configured, ensure different priorities are assigned
for each uplink when you add a next-hop list.

12. Specify the FQDN of the tunnel source in the Source FQDN field. The source FQDNmust match the
FQDN configured on the Prisma Access. If you want to configure both primary and secondary source
FQDNs, ensure that a primary and secondary uplink VLANs are defined.

13. Click Save Settings.

The following figure shows an example of cloud security profile configured for Prisma Access:
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Figure 122 IPsec Map for Prisma Access

Configuring Prisma Access Next-hop List
Configure a Prisma Access next-hop list with active and standby IPsec tunnels on different uplinks.

When configuring a next-hop list:

n Assign a higher priority for the tunnel that points to the primary node.

n Enable Preemptive failover.
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Figure 123 Next-hop list Configuration

Formore information on configuring a next-hop list, see Configuring Next Hop Lists for PBR on page 268.

Adding Next-hop List to a Routing Policy
After you configure the next-hop list with the tunnels towards Prisma Access, add the next-hop list to a
routing policy.

Formore information on creating a routing policy, see Configuring Policies for PBR on page 266.

Applying Policies to Roles or VLANs
After creating a routing policy, ensure that you apply this policy to a user role or VLAN. Formore
information, see Applying Policies to Gateway Interfaces on page 332.

Verifying Tunnel Status
To verify the tunnel status:

1. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway.
The dashboard context for a group is displayed.
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2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click a gateway underDevice Name.
The dashboard context for the gateway device is displayed.

4. UnderManage, click Overview.

5. Click Tunnels.

Formore information, see Gateway > WAN > Tunnels.

You can also view the tunnel status and uplink health in the Topology page.
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Aruba SD-Branch Integration with Zscaler through Cloud Connect Service
The SD-Branch integration with Zscaler through Cloud Connect service allows you to set up a secure
connection between the Aruba Branch Gateways and one or several cloud-hosted enforcement points called
Zscaler Internet Access (ZIA) Public Service Edges.

The Cloud Connect service uses SD-WANOrchestrator as the transport medium to send configurations to
Branch Gateways. Branch Gateways connect to ZIA Public Service Edges through the automatically
orchestrated IPsec tunnels—Orch-IKE tunnels, which use the Internet Key Exchange (IKE) protocol to set up a
security association (SA) in the IPsec protocol suite with Zscaler. This provides the ability to traverseNAT
boundaries and leverage IKEv2 for authentication, while at the same time limiting the overhead. After the
tunnels are established between the Branch Gateways and ZIA Public Service Edges, Zscaler uses reverse-
pinning technology to ensure that the traffic is sent back through the same tunnel fromwhich the traffic
originated.

When using framework to orchestrate Cloud Security connections, it is preferable to establish a
maximum of 50 connections within a span of one hour. If any tunnel is deleted, Cloud Connect has the
auto healing mechanism to re-establish that tunnel through orchestration.

The Cloud Connect service continuously looks for new ZIA Public Service Edges. If there are new ZIA Public
Service Edges available, it pushes themaps of these ZIA Public Service Edges to the Branch Gateways and
ensures that they are always connected to a Public Service Edge at any give time.

The integration of SD-Branch and ZIA is supported with following scenarios:

n Single Branch Gateway to ZIA—If multiple uplinks are used, the Branch Gateway establishes one tunnel per
uplink for the primary and secondary nodes.

n Dual Gateway to ZIA—If branch High Availability (HA) is used, the gateways establish tunnels to ZIA through
virtual and physical uplinks.

n Headend Gateway (VPNC or Virtual Gateway) to ZIA—VPNCs establish tunnels to two ZIA nodes. In this
case, only one tunnel per ZIA node is established, as the VPNC does not support the load-balancing logic.

Formore information about the supported scenarios, see Aruba SD-Branch and Zscaler Internet Access
Integration Tech Note

The following figure illustrates the SD-Branch integration with the Zscaler cloud network:
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Figure 124 Cloud Connect and SD-Branch Integration with Zscaler through Cloud Connect

To integrate SD-Branch with Zscaler through Cloud Connect service, complete the following steps:

1. Configure ZIA for API access in Zscaler Admin Portal.

2. Onboard Cloud provider accounts into Aruba Central through Cloud Connect service.

3. Orchestrate tunnel to the nearest ZIA Public Service Edge through Cloud Connect service.

4. Configure Zscaler nexthop list.

5. Add nexthop list to PBR policy.

6. Verify tunnel status.

Additional References
Formore information on Zscaler and Aruba SD-Branch integration with ZIA:

n Visit https://www.zscaler.com/

n Refer to the Aruba SD-Branch and Zscaler Internet Access Integration Guide

Configuring ZIA for API Access in Zscaler Admin Portal
In the automated workflow, it is not required to configure locations or VPN credentials in the Zscaler admin
portal. Instead, SD-WANOrchestrator uses the partner access to communicate through the API.

To add a partner API key for Aruba SD-Branch, complete the following steps:

1. Log in to the Zscaler admin portal.

2. Click Administration > Partner Integrations > SD-WAN in the Partner Integrations page in the ZIA
portal.

3. Click Add Partner Key and create a Partner API Key.

https://www.zscaler.com/
https://asp.arubanetworks.com/downloads/documents/RmlsZTo2MjhlNWY2Yy1jZWE3LTExZTktOGFlZC1iN2M2ZjQxZDI4ODc%3D
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4. Create a Partner Administrator Role with a name, access control, and SD-WAN API partner access
to provide credentials for the API access. This is done fromAdministration > Role Management.

5. Create a partner account for the SD-WANOrchestrator with the following details. This can be done
fromAdministration > AdministratorManagement > Partner Administration.

a. Login ID—Login ID of the ZIA API user account.

b. Email—Email address of the ZIA API user account.

c. Name—Username of the ZIA API user account.

d. Partner Role—Nameof the Partner Administrator Role.

e. Password—Password of the ZIA API user account.

Onboarding a Cloud Provider Account in Aruba Central

Before onboarding a cloud provider account through Cloud Connect service, ensure that any existing
account created through the Cloud Security (Legacy) service is deleted.

To onboard a Zscaler account, complete the following steps:

1. Log in to Aruba Central.

2. In theNetwork Operations app, set the filter to Global.

3. Go to Manage > Network Services > Cloud Connect, click the settings icon. The configuration
page is displayed.

4. To add an account, click Settings. UnderAccounts, select Zscaler from the available options and
click Add Account.

5. In theAdd Zscaler Account pop-up window, enter the following details:

a. Account Name—Account name of the ZIA admin account. This is the account name created by the
user to access the ZIA admin account.

The Account name is limited to a maximum of 32 alphanumeric characters.

b. Base URI—BaseURI of the Zscaler API. This is the Zscaler

c. cloud name that was provisioned for your organization.

d. API Key—Integration API key to access ZEN.

e. Username—Username of the ZIA admin account. This is the username created by the user to access
the ZIA credentials for Partner admin API access.

f. Password—Password of the admin account. This is the password created by the user to access the ZIA
credentials.
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Figure 125 Adding a Zscaler Account

6. Click Submit.

Orchestrating Tunnels to the Nearest ZIA Public Service
Edge
Connect a Group to Cloud Hub using the Cloud Connect service to automatically orchestrate an Orch-IKE
tunnel to the nearest ZIA Public Service Edge.

To connect a Group to Cloud Hub, complete the following steps:

1. In theNetwork Operations app, set the filter to Global.

2. Go to Manage > Network Services > Cloud Connect, click the settings icon.
The configuration page is displayed.

3. Click Deployment tab.

4. Select a Group from the available options under Filter groups.

5. Enable the checkbox under Connection column. Select other groups and enable theConnection
checkbox to connect multiple Groups to Cloud Hub.

6. Click Preview.
The page displays all the Groups selected for connecting to Cloud Hub.

7. Click Submit.

TheDeployment Status displays one of the following statuses:

a. Not started—Groups arewaiting to get connected to Cloud Hub.

b. Completed—Groups successfully connected to Cloud Hub.
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c. Partially completed—Cloud connect service is in the process of connecting all the devices belonging
to a group from the cloud endpoint.

d. Failed—If a group ormultiple groups fail to connect to Cloud Hub, the failed groups are retried for
connecting to Cloud Hub every threeminutes.

Youmay notice a delay up to five minutes to see the actual deployment status.

Figure 126 Connecting a Group to Cloud Hub

A summary of the deployment is displayed in the List view of theOrchestrated Cloud Provider pagewith
the following columns

n Group—Displays the name of the group connected to the Cloud Hub.

n Account—Displays the account name of the ZIA admin account.

n Base URI—Displays the BaseURI of the Zscaler API.

n Username—Displays the username of the ZIA admin account.

n Deployment Status—Displays the deployment status of the group.

Figure 127 Group connections summary

Configuring Zscaler Nexthop List
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Configure Zscaler nexthop list with Zscaler active and standby IPsec tunnels on different uplinks. Formore
information on configuring a nexthop list, see Configuring Next Hop Lists for PBR on page 268.

Adding Nexthop List to PBR Policy
Add the nexthop list to a PBR policy and ensure that the policy is applied to a user role or VLAN. Formore
information on adding a nexthop list to a global PBR policy, see Configuring Policies for PBR on page 266.

Verifying Tunnel Status
To verify the status of the tunnels, complete the following steps:

1. In theNetwork Operations app, set the filter to one of the options underGroups. Ensure that the
filter selection contains at least one gateway.

2. UnderManage > Devices, click theGateways tab.
A list of gateways is displayed in List view.

3. Click a gateway underDevice Name.
The dashboard context for the specific gateway is displayed.

4. UnderManage, click WAN > Tunnels.
The Tunnels summary and Tunnels table displays the information about all the tunnels
associated with the gateway. Formore information, see Gateway > WAN > Tunnels.

5. Click theMode drop-down in the Tunnels table.

6. Select Orch-IKE to view the Zscaler tunnels. Formore information, see Gateway > WAN > Tunnels.
You can also view the tunnel status and uplink health in theMonitoring & Reports > Topology
page.
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Aruba SD-Branch Integration with Prisma Access
A common network architecture today is to tunnel traffic between an organization’s HQ and branches over
eitherMPLS or dedicated encrypted VPN links. Asmore services aremoving to a cloud-based architecture,
breaking out traffic locally from the branches allows faster delivery and efficient use of bandwidth as
opposed to tunneling traffic back to an aggregation point before routing it to its final destination. However,
allowing branch devices to directly connect to the Internet may introduce security issues.

The integration between the Aruba Branch Gateways and Prisma Access secures connection between the
branch networks and one or several cloud-hosted enforcement points. Prisma Access is a cloud-based
infrastructure that provides security to branch networks by allowing organizations to set up regional cloud-
based firewalls. The Aruba Branch Gateways can be configured to bring up secure tunnels to the Prisma
Access firewall and redirect selected traffic flows through Prisma Access to provide advanced threat
protection in an efficient and scalable way.

The integration between ClearPass and Prisma Access also enables sharing the user context with the firewall
and facilitates the creation of role-centric security policies.

The combined solution can offer the following benefits:

n Unified security management for campus and branch networks.

n Context-aware security policies driven by ClearPass.

n Intelligent routing of traffic based on user-role and application.

Deployment Scenarios
The SD-Branch and Prisma Access integration supports the following deployment scenarios.

Branch Gateways to Prisma Access
Aruba Branch Gateways can establish tunnels to one or several Prisma Access nodes (in different regions, as
shown in the following figure) to secure user traffic going to public cloud services or to the Internet, thus
providing high availability. The solution allows for active-active cloud firewalls.

Aruba SD-WAN Solution | User Guide 403



Deployment Scenarios | 404

Figure 128 Branch Gateways to Prisma Access

Regional Hub to Prisma Access
In certain deployments, the branch traffic is aggregated at a local hub and then routed to the Internet or to
other corporate resources. In such scenarios, Aruba VPN Concentrators can set up tunnels to the nearest
Prisma Access firewall to allow branch traffic go through the distributed security service as shown in the
following figure:
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Figure 129 Regional Hub to Prisma Access

Supported IKE and IPSec Cryptographic Profiles
The tunnel configuration recommended for this integration are described in the following table:

Parameters Phase 1 Phase 2

Confidentiality AES-256 AES-256

Integrity SHA256 SHA1

Authentication Username/password N/A

Key Exchange Method Diffie-Hellman Diffie-Hellman

Diffie-Hellman Group 14 14

NAT-Transversal Enabled N/A

Dead Peer Detection Enabled

Perfect Forward Secrecy N/A Yes

VPN Type N/A Policy-based VPN

Table 57: Tunnel Encryption



Deployment Scenarios | 406

To know how to enable integration between the Aruba SD-Branch and Prisma Access, see Configuring
Prisma Access.
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Aruba SD-Branch Integration with Check Point
Withmore servicesmoving to a cloud-based architecture, one of themost common requirements is to allow
SD-branches to route traffic to its intended destination using the Internet. Direct access frombranch to the
Internet allows faster delivery and efficient use of bandwidth as opposed to tunneling traffic to an
aggregation point before routing it to its final destination. However, allowing branch devices to directly
connect to the Internet may introduce security issues.

To enhance branch security and provide advanced threat protection, Aruba supports SD-Branch integration
with third-party cloud network security services such as Check Point. Check Point Network Security as a
Service is a cloud security platform that provides Check Point threat prevention and access control for
branch offices. With the Check Point integration, network administrators can connect Aruba Gateway device
to Network Security as a Service to leverage Check Point’s best-in-class network security services and deploy
a secure SD-WAN network.

The SD-Branch integration with Check Point offers the following benefits:

n Unified security management for campus and branch networks

n Context-aware security policies driven by ClearPass

n Intelligent routing of traffic based on user role and application

n Security event logging andmonitoring

Supported IKE and IPsec Cryptographic Profiles
The Aruba Branch Gateway and Check Point support several options for setting up VPN tunnels. Aruba and
Check Point recommend using IKEv2 for cloud security.

The following encryption settings are recommended for tunnel configuration.

Parameters Phase 1 Phase 2

Confidentiality AES-256 AES-256

Integrity SHA1 SHA1

Authentication Username/password N/A

Key Exchange Method Diffie-Hellman Diffie-Hellman

Diffie-Hellman Group Group 2 -

Table 58: Tunnel Encryption

Configuration Steps
The SD-Branch integration with Check Point requires configuration the Check Point portal and Aruba
Gateways.

Before you begin, perform the following checks:
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n The ArubaGateways are connected to andmanaged fromAruba Central.

n You have access to the Check Point web portal and administrative credentials to set up tunnels with Aruba
Gateways.

To enable Aruba SD-Branch integration with Check Point, complete the following configuration steps:

n Configuring Check Point for SD-Branch Integration on page 408

n Configuring Aruba Gateways for Integration with Check Point on page 410

Configuring Check Point for SD-Branch Integration
To configure Check Point for SD-Branch integration:

1. Log in to the Check Point Portal.

2. Access Network Security As A Service app.

3. Create a site. TheCreate New Site wizard opens.

4. Enter site details.

5. Select the tunnel type as IPsec - Pre-Shared Key and define the external IP address and shared
secret key.

6. Set the IP address of the branch site as external IP address and configure subnets for internal
networks within a branch site.

7. Confirm site creation.

8. From theNetwork Security As A Service dashboard, select the site you just created and click View
Instructions.

9. Note the tunnel destination FQDN.

The following figures illustrate the site creation procedure in Check Point portal.

Figure 130 Site Creation
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Figure 131 Tunnel Configuration

Figure 132 Subnet Configuration
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Figure 133 View Instructions

Configuring Aruba Gateways for Integration with Check
Point
To enable Aruba Gateways to connect to Check Point, complete the following configuration steps:

n class="Bullet_1"MadCap:conditions="Conditions.Print_only"> Configuring IPsec Tunnels to Check Point on
page 410

n Adding theNext-hop List to a Routing Policy on page 413

n Applying Policies to a Role or VLAN on page 413

Configuring IPsec Tunnels to Check Point
To configure an IPsec tunnel to Check Point:

1. To configure a Branch Gateway group or a Branch Gateway, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.
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n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. Click VPN > Cloud Security.

3. In the IPSec Maps section, click + to open theNew IPSec map section.

4. Select Check Point - CloudGaurd Connect as the cloud security provider from the drop-down list.

5. Enter a name for the IPsecmap. The allowed character limit is 128.

6. Enter a priority number for the IPsecmap within a range of 1 to 9998. A priority value of 1 indicates
the highest priority.

7. Configure thedefault-aes transform. Transform sets allow you to define a combination of security
protocols and encryption settings that you can apply to the IPsec traffic flow.

To add a transform set:

a. Click + under Transforms.

b. From the available transforms set, select default-aes. Thedefault-aes transformuses AES 256
encryption with SHA1 Hash.

c. Click Save Settings.

8. Select one of the following options in Tunnel source based on your requirement. Select the Uplink
VLAN to use for bringing up tunnels to Check Point (in the case of Branch Gateway) or the source
VLAN in the case of VPN Concentrators.

n VLAN—Select a VLAN from theVLAN drop-down list.

n Uplink VLAN—Select an uplink VLAN from theUplink VLAN drop-down list.

Ensure that you assign different priorities for different uplinks in the next-hop list
configuration.

9. In the Tunnel destination field, specify the FQDN address of the branch site configured in Check
Point to which the tunnel will be established.

10. Select one of the following options in theRepresentation type drop-down list:

n Text-Based
n Hex-Based

11. In the IKE shared secret, field, enter the IKE pre-shared secret key that you configured on the Check
Point portal and retype the secret key to confirm.

The following figure shows the sample configuration values:
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Figure 134 Checkpoint Configuration

1. Click Save Settings.

2. Repeat steps 1 through 13 to add a secondary IPsec tunnel.

Configuring a Next-hop List
After configuring the tunnels, you can create a next-hop list to group the tunnels inside a routing policy.

Note the following points for next-hop list configuration:

n If you want to use both (primary and secondary) IPsec tunnels in the Active-Activemode, assign the same
priority for the tunnels.

n If you want to use the tunnels in the Active-Standby mode, assign a higher priority for the tunnel that
points to the primary node and enable Preemptive failover.
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Figure 135 Next-hop Configuration

Formore information, see Configuring Next Hop Lists for PBR on page 268.

Adding the Next-hop List to a Routing Policy
After creating the next-hop list, youmust add the next-hop list to a routing policy.

In the example shown in the following figure, the policy is sending all the traffic to private subnets through
the regular path and the rest of the traffic through the Check Point nodes.

Figure 136 Routing Policy for Check Point

Formore information on adding a next-hop list to a global routing policy, see Configuring Policies for PBR on
page 266.

Applying Policies to a Role or VLAN
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After you configure a routing policy, apply it to a role or VLAN.

The following figures illustrate the procedure for configuring a Check Point role and applying routing policies
to a role and VLAN:

Figure 137 Apply Check Point Routing Policy to a Role

Figure 138 Apply Routing Policy to VLAN
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Formore information, see Applying Policies to Gateway Interfaces on page 332.

Verifying Tunnel Status
To verify the tunnel status:

1. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway.
The dashboard context for a group is displayed.

2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click a gateway underDevice Name.
The dashboard context for the gateway device is displayed.

4. UnderManage, click Overview.

5. Click Tunnels

Formore information, see Gateway > WAN > Tunnels.

You can also view the tunnel status and uplink health in theMonitoring & Reports > Topology page.
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Aruba SD-Branch Integration with Symantec WSS
Withmore servicesmoving to a cloud-based architecture, one of themost common requirements is to allow
SD-branches to route traffic to its intended destination using the Internet. Direct access frombranch to the
Internet allows faster delivery and efficient use of bandwidth as opposed to tunneling traffic to an
aggregation point before routing it to its final destination. However, allowing branch devices to directly
connect to the Internet may introduce security issues.

To enhance branch security and provide advanced threat protection, Aruba supports SD-Branch integration
with third-party cloud security and firewall services such as SymantecWeb Security Service (WSS).

Integration Overview
The integration between the Aruba Branch Gateway and SymantecWSS allows network administrators to
set up a secure connection between an SD-Branch and one or several cloud-hosted enforcement points.
Branch Gateways can establish secure tunnels to theWSS firewall and redirect selected traffic flows through
WSS and leverage advanced threat protection, such SSL decryption, malware inspection, web isolation and
enforce Data Loss Prevention (DLP), in an efficient and scalable way.

The following figure illustrates SD-Branch integration with SymantecWeb Security Service:

Figure 139 Figure 2 - SD-Branch integration with Symantec Web Security Service

The SD-Branch integration with SymantecWSS offers the following benefits:
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n Unified security management for campus and branch networks

n Context-aware security policies driven by ClearPass

n Intelligent routing of traffic based on user role and application

The integration also allows SD-Branch users to leverage the benefits of the advanced threat protection:

URL Filtering and categorization

Malware analysis

Anti-virus

Web isolation

Cloud Access Security Broker (CASB)

Data Loss Prevention

Role-Based and Application-Based Routing
Aruba Branch Gateway function as stateful firewalls with support for web content, reputation and
geolocation filtering. Thismeans that it can selectively determinewhich traffic needs to be routed through
WSS.

For example, security policies for guest users generally require content and reputation filtering, and other
devices like printers or network camerasmay not need to reach out to the Internet. At the same time, traffic
to trusted cloud services like streaming providersmay not require the additional security of an advanced
threat protection engine.

Figure 140 Figure 3 - Role-Based and Application-Based routing

The following parameters can be taken into consideration when determining which traffic types are to be
sent throughWSS:

n VLAN/User Role—PBR policies can be applied to roles or VLANs

n Application/Application Category

n Stateful policies with protocol, source/destination address, source/destination port, and DSCP
parameters
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n FQDN—ArubaOS supports creating netservices based on FQDN, which can be used to build PBR
policies

Branch Gateway to WSS
The Aruba SD-BranchWSS integration allows branches to securely connect to variousWSS datacenter
locations and sending HTTP and HTTPS traffic of users to Symantec for further inspection.

Branch Gateways an establish tunnels to one or several WSS datacenter locations to secure user traffic
going to public cloud services or to the Internet.

The solution allows for active-active cloud firewalls as shown in the following figure:

Figure 141 Figure 4 - Active-Active Firewall Regions

For a complete list of available DC locations and their IP addresses, see https://support.symantec.com/en_
US/article.TECH242979.html.

Supported IKE and IPSec Cryptographic Profiles
The Aruba Branch Gateway andWSS support several options for setting up VPN tunnels.

The tunnel configuration recommended for this integration are described in the following table:

Parameters Phase 1 Phase 2

Confidentiality AES-256 AES-256

Integrity SHA256 SHA1

Authentication Username/password N/A

Key Exchange Method Diffie-Hellman Diffie-Hellman

Diffie-Hellman Group 14 14

NAT-Transversal Enabled N/A

Dead Peer Detection Enabled

Table 59: Tunnel Encryption

https://support.symantec.com/en_US/article.TECH242979.html
https://support.symantec.com/en_US/article.TECH242979.html
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Parameters Phase 1 Phase 2

Perfect Forward Secrecy N/A Yes

VPN Type N/A Policy-based VPN

To know how to enable Aruba SD-Branch integration withWSS, see Configuring SymantecWSS.

Configuring Symantec WSS
To enable Aruba SD-Branch integration withWSS, the following steps are required:

n ConfiguringWeb Security Service for SD-Branch Integration on page 419

n Configuring Aruba Gateways for Integration withWSS on page 421

Configuring Web Security Service for SD-Branch Integration
TheWeb Security Service ismanaged and configured through theUI or APIs. The configuration steps
described in this section follow theUI-based workflows.

Before you begin, ensure that you are a registered user of theWeb Security Service portal with
administrative privileges.

TheWeb Security Service configuration includes the following steps:

n Creating IPSec and IKE Crypto Profiles on page 419

n Configuring IPsec Tunnels to WSS on page 421

n Adding Branch Sites to WSS Datacenters on page 419

n Configuring an Authentication Policy (Optional) on page 420

Creating IPSec and IKE Crypto Profiles
SymantecWeb Security Service supports the crypto profile that Aruba uses by default. Formore
information, see https://portal.threatpulse.com/docs/am/reference/ref-ike-proposals.htm.

Adding Branch Sites to WSS Datacenters
To allow Aruba branches to connect to WSS, youmust add branch locations inWSS.

To add a branch site to WSS:

1. Log in to theWSS portal.

2. Go to Service > Network > Locations. The Locations page opens and displays a list of sites that
are already configured and the VPN connection status indicators for these sites.

3. To add branch location, click + Add Location.

4. In the FQDN IKEv2 Firewall section, enter the FQDN address of the branch location and the pre-
shared key.

https://portal.threatpulse.com/docs/am/reference/ref-ike-proposals.htm
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Figure 142 Figure 6: Adding a Branch location to a WSS Datacenter

1. Click Save.

Configuring an Authentication Policy (Optional)
When traffic from the branch is sent over to WSS, traffic can be inspected transparently, or SAML
authentication can be used to leverageDLP and CASB services. If an authentication policy is configured, WSS
identifies the user and device. Administrators can also use a software client on the device to authenticate a
user.

If the users have installed Symantec root CA certificate and Branch Gateways forward HTTP and HTTPS
traffic, SSL interception will be effective upon adding a branch location inWSS. However, you can configure
custom authentication profile to enable role-based policies in WSS. For example, administrators can perform
web isolation for all HRmanagement and Finance employees and only performweb category filtering for
IOT devices. Authentication can be performed by a software client, the Symantec Endpoint Client with or
without SAML authentication.

For SAML authentication, the traffic through TCP port 8443 must be routed throughWSS as well,
besides TCP 80 and TCP 443 ports.

To configure an authentication policy:

1. In theWSS portal, go to Service > Authentication > Authentication Policy > Location Policy >
Firewall/VPN Authentication.

2. Configure an authentication profile.

The following figure shows an example for the authenticationmethod configuration.
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Figure 143 Authentication Policy

2. Click Save Rule.

Configuring Aruba Gateways for Integration with WSS
To enable Aruba Gateways to connect to WSS, the following configuration is required:

n Configuring IPsec Tunnels to WSS on page 421

n Configuring a Next-hop List on page 423

n Adding theNexthop List to PBR Policy on page 424

n Applying Policies to a Role or VLAN on page 425

Configuring IPsec Tunnels to WSS
To configure an IPsec tunnel to WSS:

1. To configure a Branch Gateway group or Branch Gateway complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. Click VPN > Cloud Security.

3. In the IPSec Maps section, click + to open theNew IPSec map section.
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4. Select Symantec WSS as the cloud security provider from the drop-down list.

5. Enter a name for the IPsecmap. The allowed character limit is 128.

6. Enter a priority number for the IPsecmap within a range of 1 to 10,000. A priority value of 1 indicates
the highest priority.

7. Configure a transform set. Transform sets allow you to define a combination of security protocols
and algorithms that you can apply to the IPsec traffic flow.

To add a transform set:

a. Click + under Transforms.

b. From the available transforms set, select default-aes. Thedefault-aes transformuses AES 256
encryption with SHA1 Hash.

c. Click Save Settings.

8. Select one of the following options in Tunnel source based on your requirement. Select the Uplink
VLAN to use for bringing up tunnels to WSS (in the case of Branch Gateway) or the source VLAN in the
case of VPN Concentrators.

n VLAN—Select a VLAN from theVLAN drop-down list.

n Uplink VLAN—Select an uplink VLAN from theUplink VLAN drop-down list.

Ensure that you assign different priorities for different uplinks in the next-hop list
configuration.

9. Enter the FQDN of the tunnel source in the Source FQDN field. The source FQDNmust match the
FQDN configured on theWSS portal.

The source FQDN is unique for each branch location.

10. In the Tunnel destination IP field, specify the IP address of the branch location configured in
WSS to which the tunnel will be established.

11. Select one of the following options in theRepresentation type drop-down list:

n Text-Based
n Hex-Based

12. In the IKE shared secret, field, enter the IKE pre-shared secret key that you configured on the
WSS portal and retype the secret key to confirm.

The following figure shows the sample configuration values:
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Figure 144 Symantec WSS Configuration

13. Click Save Settings.

Configuring a Next-hop List
After configuring the tunnels, you can create a next-hop list to group the tunnels inside routing policies. For
more information, see Configuring Next Hop Lists for PBR on page 268.

When creating a next-hop list:

n Ensure that different priorities are assigned for the tunnels.

n Ensure that Preemptive failover is enabled.
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Adding the Nexthop List to PBR Policy
After creating the next-hop list, youmust add the next-hop list to a routing policy. Formore information on
adding a next-hop list to a global routing policy, see Configuring Policies for PBR on page 266.

In the example shown in the following figures, the routing policy sends all traffic to private subnets (an alias
representing 10.0.0.0/8 and 172.16.0.0/12) through the regular path, and all theweb traffic to theWSS
nodes, and the remaining traffic through the regular ISP lines.

Figure 145 Creating a Symantec WSS Alias for Web Ports



Integration Overview | 425

Figure 146 Routing Policies

Applying Policies to a Role or VLAN
After you configure a routing policy, apply it to a role or VLAN. Formore information, see Applying Policies
to Gateway Interfaces.

Verifying Tunnel Status

1. To view the tunnel status on a gateway:

n In theNetwork Operations app, use the filter to select the gateway.
n UnderManage, click Overview.

2. Click Tunnels.

Formore information, see Gateway > WAN > Tunnels.



Chapter 13
Micro Branch Redundancy Architectures

Micro Branch Redundancy Architectures
This section describes the high availability (HA) and redundancy features of aMicro Branch. HA is a critical
feature in a network to minimize downtime and provide continuous access to systems and applications.
Aruba SD-Branch solution provides different types of redundancy in aMicro Branch, based on the size and
requirement. In a typical Micro Branch setup, Instant APs (IAP) are deployed at the branch site and VPN
Concentrators are deployed at the corporate site or data center.

Aruba Micro Branch solution also supports VPNCs deployed in Public Cloud environments such as AWS
andMicrosoft Azure.

The following image illustrates aMicro Branch with one IAP at the branch and two data centers (primary and
backup). In thisMicro Branch, the IAP is the Branch Gateway for the entire branch network including both
wired and wireless clients. Based on the policies configured, overlay traffic (corporate traffic) is routed
through the IPsec tunnels to ensure security while underlay traffic is routed through theWAN uplinks.

Figure 147 Basic Micro Branch Topology

Supported Topologies
The following sections explain the different types of topologies that are supported by Aruba to provide high
availability in aMicro Branch.

n Micro Branch with VPNC and WAN Redundancy (L2 Redundancy)

In this type of Micro Branch network, two VPNCs are deployed in a single data center. This is a Layer 2 (L2)
redundancy. Both the VPNCs run Virtual Router Redundancy Protocol (VRRP) to dynamically fail over to the
standby VPNC if the active VPNC fails. It is important to note that the standby VPNC does not terminate any
VPN tunnels or advertise branch routes through OSPFv2 or BGP4 until it transitions to an active state.

Aruba SD-WAN Solution | User Guide 426



Micro Branch Redundancy Architectures | 427

At the branch site, twoWAN uplinks are available. However, only one active IPsec tunnel is established and
this tunnel terminates on the VRRP virtual IP. Asmost VPNCs are deployed behind an Internet edge firewall,
a port-forwarding rule is configured to permit UDP4500 traffic from an outside public IP address to the
VRRP virtual IP.

On the IAP, you can either have two ethernet uplinks, or one ethernet and oneUSB uplink for a 3G/4G
connection. You can set priority to choose the active uplink. When the current active uplink goes down, the
IAP looks into the priority list andmakes the next uplink in the list as the active uplink.

The following image is a sample topology of aMicro Branch network with VPNC andWAN redundancy:

Figure 148 Micro Branch with VPNC and WAN Redundancy

n Micro Branch with Data Center and WAN redundancy (L3 Redundancy)

To understand this topology, let us consider a setup that includes two hubs to provideHigh Availability. One
of these is a primary hub and the other one is a secondary hub. This deployment model is often referred to
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as Layer 3 redundancy sinceOSPFv2 or BGP4 route costs in the corporate network are used to determine
which hub site is actively forwarding traffic to the branch sites. The hub that advertises the branch routes at
the lowest cost is the preferred path.

In this setup, redundancy is provided by configuring the IAP at theMicro Branch to establish two IPsec
tunnels, one to each of the hubs. The active tunnel is terminated on the primary hub and the backup tunnel
is terminated on the back-up hub. When the active tunnel goes down, the back-up tunnel establishes a
connection with the secondary hub.

Each hub is therefore assigned a primary or secondary role. The designated VPNCs in each hub advertise the
branch routes into OSPFv2 or BGP4 at different route costs. The VPNCs in the primary hub advertise the
branch routes at a lower route cost than the VPNCs in the secondary hub. The VPNCs in the primary hub
forward hub-to-spoke, spoke-to-hub and spoke-to-spoke traffic during normal operation. If the primary
hub fails or becomes unreachable, the VPN tunnels are already established to the secondary hub site.

During a failover, theOSPF/BGP routers will re-converge so that the routes are reachable via the secondary
hub with a typical re-convergence occurring in under 1 minute (depending on the IGP configuration).

In this model, it is important to note that while the IAPs establish active VPN tunnels to both hubs, only one hub is
actively forwarding traffic for the IAPs at any given time. The ability to simultaneously forward traffic to both hubs
at the same time is not supported with the IAP VPN solution.

The following image is a sample topology of aMicro Branch network with DC andWAN redundancy:

Figure 149 Micro Branch with data center and WAN redundancy

n A fully redundant Micro Branch

In this type of aMicro Branch setup, you can havemultiple APs, connected to a switch to provide
redundancy. One of these APs acts as the conductor and the rest aremembers. If the conductor fails,
anothermember is chosen as the conductor. An active and a back-upWAN uplink connection is established
from the APs. Both of these uplinks can be ethernet or one of them can be aUSB uplink to support 3G/4G
connections.

The following image is a sample topology of aMicro Branch network with full redundancy:
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Figure 150 Micro Branch with full redundancy

Configuring a Micro Branch with Instant APs
For small branch deployments, Aruba offers an Instant AP-based SD-WAN solution. In amicro branch
deployment, you do not require a Branch Gateway. If you have an Instant AP cluster deployed, the Instant
AP acting as a Virtual Controller or amaster AP can establish secure VPN connections with
VPN Concentrators.

Instant APs that are managed by AirWave or Aruba Central can only establish Instant AP-VPN tunnels
to a cloud-managed VPN Concentrator.

To get started with yourMicro Branch deployment, complete the following tasks:

Before you begin, ensure that you have provisioned and configured the VPNCs in Aruba Central. If not, see
Provisioning Aruba Gateways in Aruba Central.

1. Tunnel Authentication—Validate that the VPNC group is using the default setup to authenticate
IAP-VPN tunnels. For verification, the settings can be found underVPNC Group > Devices >
Gateways > Security > L3 Authentication > VPN Authentication > default-iap > Server
Group.

2. Dynamic IP Assignment—When connecting to the VPNC, APs behave like dynamic VPN clients.
Thismeans that they are assigned a pool of Inner IP addresses, which can be configured in VPNC
Group > Devices > Gateways > VPN > General VPN.
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3. Route Redistribution—The ArubaMicro-Branch architecture can work in layer 2 (L2) mode, where
VLANs are L2 extended from the APs to the VPNC, or in layer 3 (L3) mode, where branch subnets are
advertised upstream as part of the tunnel negotiation. When working in L3 mode, branch subnets
should be redistributed into a dynamic routing protocol such as OSPF and BGP.

The following topics describe the various configurations that need to be done on Instant APs and VPN
Concentrators for deploying aMicro Branch solution:

n Configuring VPN Concentrators forMicro Branch Solution

n Configuring Instant APs forMicro Branch Solution

Formore information on how to configure IAP-VPN address pools, and enableOSPF and BGP routing
protocols, see Aruba IAP-VPN Solution Guide for Teleworkers and Home Offices.

Configuring Instant APs for Micro Branch Solution
For a single data center without redundancy, perform the following configuration tasks on the Instant AP:

1. Configure a single VPN using an IPsec tunnel. Formore information, see the Configuring IPsec Tunnel
section underManaging WLANNetworks in Aruba Central Help Center.

2. Configure a routing profile for split-tunneling of client traffic. Formore information, see the
Configuring Routing Profiles section underManaging WLANNetworks in Aruba Central Help Center.

3. Configure the Enterprise domains for split-tunneling of DNS traffic from clients. Formore
information, see the Configuring Enterprise Domains section underManaging WLANNetworks in
Aruba Central Help Center.

4. Configure DHCP scope in Distributed, L3 and Centralized, L2 modes. Formore information, see the
Configuring DHCP Scopes section underManaging WLANNetworks in Aruba Central Help Center.

Configuring VPN Concentrators for Micro Branch Solution
For a successful Instant AP VPN termination on the SD-WAN Gateway, perform the following configuration
tasks on the SD-WAN Gateway:

n Configuring Instant AP VPN Pool for Aruba Gateways on page 430

n Authentication Servers on page 431

n Redistributing Branch Subnets on page 432

Configuring Instant AP VPN Pool for Aruba Gateways
The VPN local pool is used to assign an IP Address to the Instant AP after successful Extended
Authentication (XAuth) VPN.

To configure the Instant AP VPN Pool, complete the following steps:

1. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway.
The dashboard context for a group is displayed.

2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click theConfig icon.
The gateway group configuration page is displayed.

4. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

https://www.arubanetworks.com/assets/so/SG_IAP-VPN.pdf
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5. Click VPN > General VPN.

6. Click + from theAddress Pools table to open theAdd New Address Pool section.

7. Enter the following information in theAdd New Address Pool section to create a new address pool:

n Pool name—Nameof the pool

n Start address(ipv4)—The starting IPv4 address of the pool.

n End address(ipv4)—The ending IPv4 address of the pool

8. Configure the following additional VPN parameters based on your requirements:

n Source-nat—Enable this option if the IP addresses of VPN clientsmust be translated to access the
network and select a NAT pool to be used for address translation from theNAT pool drop-down list
.

n VIA SSL fallback—Enable this option to allow VIA SSL fallback.

n IAP-VPN backward compatible—Enable this option to allow the Instant APs and Branch Gateways
that run on AOS versions earlier than 8.4.x.x to use port 8089 for VPN VLAN subnet registrations.

n Primary DNS server—Specify the IP address of the Primary DNS Server to be pushed to the
VPN client.

n Secondary DNS server—Specify the IP address of the Secondary DNS Server to be pushed to the
VPN client.

n Primary WINS server—Specify the IP address of the Primary WINS Server to be pushed to the
VPN client.

n Secondary WINS server—Specify the IP address of the Secondary WINS Server to be pushed to
the VPN client.

9. Save the changes.

Authentication Servers
Instant APs identify themselves using the internal TPM certificate, which has theMAC address as the CN.
TheMicro Branch solution can use the internal server or an external RADIUS server with the database of all
the Instant APs, so that the VPN Concentrators accept the incoming connection from the Instant APs.

If you are using the internal server, see Configuring an Internal Server.

If you are using an external RADIUS server, see Configuring andMapping External RADIUS Server.

Configuring an Internal Server

When you use the internal server for authenticating the Instant AP, the VPN Concentrator validates if the
Instant AP is in the same user account with valid subscription assigned and automatically whitelists it.

To enable internal server authentication, complete the following steps:

1. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway.
The dashboard context for a group is displayed.

2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click theConfig icon.
The gateway group configuration page is displayed.

4. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.
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5. Click Security > L3 Authentication.

6. Select thedefault-iap profile underVPN Authentication.

7. In thedefault-iap profile, select internal from Server Group.

8. Save the changes.

Configuring and Mapping External RADIUS Server

To use an external RADIUS server for authentication, youmust configure the server on the VPN
Concentrator. To configure an external RADIUS server for authentication, see Configuring RADIUS
Authentication Server on ArubaGateways on page 307

Aruba recommends to use the ClearPass Policy Manager as it can download the list of Instant APs
owned by the customer from the Activate server to automate the whitelisting process. For information
on configuring the ClearPass Policy Manager, see ClearPass Policy Manager User Guide.

Map the configured RADIUS server to the Instant AP VPN server group using the following steps:

1. In theNetwork Operations app, use the filter to select a Group in which VPN Concentrators are
provisioned.

2. UnderManage, click Devices > Gateways and then click theConfig icon to display theGateway
configuration dashboard.

3. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

4. Click Security > L3 Authentication.

5. Select thedefault-iap profile underVPN Authentication.

6. In thedefault-iap profile, select the configured RADIUS server fromRADIUS Accounting Server
Group.

7. Save the changes.

Redistributing Branch Subnets
TheMicro Branch solution provides support to learn branch subnets using the dynamic routing protocol. To
redistribute the branch networks in L3 mode, complete the following steps:

1. In theNetwork Operations app, use the filter to select a Group in which VPN Concentrators are
provisioned.

2. UnderManage, click Devices > Gateways and then click theConfig icon to display theGateway
configuration dashboard.

3. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

4. Click Routing > OSPF.

5. EnableOSPF for routing and configure the area to be used. Formore information on configuring
OSPF area and other parameters, see Example of a Prefix List on page 235.

6. EnableRedistribute overlay routes, and then specify a cost for the overlay routes. The cost set
here applies only to the routes that are learnt from the ArubaGateways.

7. Save the changes.

8. Click Interfaces > VLANs and select the uplink VLAN interface from theVLAN IDs table.

9. From the IPv4 tab, select Enable OSPF underOther Options and configure theOSPF area to be
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used.

10. Save the changes.



Chapter 14
Configuring Support for Aruba VIA

Service

Configuring Support for Aruba VIA Service
Aruba VIA refers to Aruba Virtual Intranet Access solution for establishing a virtual private network
connection. VIA has two primary purposes:

n to provide secure corporate access to employee laptops and smart-phones from anywhere

n to provide ease-of-use for the end users and network administrators

The ease-of-use is what differentiates VIA fromother VPN solutions. VIA offers a zero-touch end-user
experience and removes the complexity that is associated with configuring VPN clients on end-user devices.
VIA not only provides ease-of-use for end users but also simplifies configuration andmanagement for the IT
team.

The VIA client that is available forMicrosoft Windows computers (Windows XP, Vista, andWindows 7), Apple
Mac OS X, and Apple iOS devices is a hybrid Internet Protocol Security (IPsec)/ Secure Sockets Layer (SSL)
VPN client. If the user is connected to an untrusted network, the VIA client scans network connections and
automatically establishes a secure connection back to the corporate network. Some additional features
include Content Security Services (CSS), single-logon, SSL fallback when IPsec is blocked, and the ability to
configureWireless Local Area Network (WLAN) settings using the supplicant provided by the operating
system.

Configuring VIA
1. Configure the foll parameters in the connection profile:

1. To configure an Aruba VIA solution, complete the following tasks :

n Configuring VPN IP Pool

n Defining IKEv1 Shared Secret

n Configuring VIA User Role

n Creating VIA Server Group for Authenticating VIA Users

n Configuring VIA Authentication Parameters

n Loading and Applying VIA Certificates

n Configuring and Attaching VIA Connection Profile

n Uploading VIA Installer to VPN Concentrator

Configuring VPN IP Pool
The first step to configure VIA is to create a VPN IP Pool on the VPN Concentrator. To configure the
VPN IP Pool, complete the following steps:

1. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway
configured as a VPNC.

The dashboard context for a group is displayed.
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2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click theConfig icon.
The configuration page for the VPNC group is displayed. You can configure VPN IP pool either in
Basic Mode or in Advanced Mode.

4. If you are in theBasic Mode, complete the following steps:

a. Click theVPN tab.

b. Click + in theAddress Pools table to add address pools. These address pools are used as Inner IPs for
remotely connected IAPs and VIA client.

c. Enter the following information to add a new address pool:

n Pool name—The name of the pool.

n Start address—The starting IPv4 address of the pool.

n End address—The ending IPv4 address of the pool. The end IP addressmust be greater than or
equal to the start IP address

d. Select the address pool from the IAP-VPN pool drop-down list (Optional). This is the address pool that
is used as the Inner IP of APs working in IAP-VPNmode, and is automatically mapped to the default
VPN role.
n You can view the address pools created in theBasic Mode page in Advanced Mode in the following

tabs:Under VPN > General VPN.

n Under Security > Roles, select default-vpn-role. Click More and expand VPN. The Address Pool is
listed in the L2tp pool drop-down list.

5. Click Advanced Mode to access the advanced configuration options.

a. Click VPN > General VPN.

b. Click + from theAddress Pools table to open theAdd New Address Pool section.

c. Enter the following information in theAdd New Address Pool section to create a new address pool:

n Pool name—The name of the pool.

n Start address(ipv4)—The starting IPv4 address of the pool.

n End address(ipv4)—The ending IPv4 address of the pool. The end IP addressmust be greater
than or equal to the start IP address.

d. Configure the following additional VPN parameters based on your requirements:

n Source-NAT—Enable this option if the IP addresses of VPN clientsmust be translated to access
the network and select a NAT pool to be used for address translation from theNAT pool drop-
down list .

n VIA SSL fallback—Enable this option to allow VIA SSL fallback.

n Primary DNS server—Specify the IP address of the Primary DNS Server to be pushed to the
VPN client.

n Secondary DNS server—Specify the IP address of the Secondary DNS Server to be pushed to
the VPN client.



Aruba SD-WAN Solution | User Guide 436

n Primary WINS server—Specify the IP address of the Primary WINS Server to be pushed to the
VPN client.

n Secondary WINS server—Specify the IP address of the Secondary WINS Server to be pushed to
the VPN client.

6. Save the changes.

Ensure that the configured IP addresses are reachable.

Defining IKEv1 Shared Secret
If you are configuring a VPN to support IKEv1 and clients using pre-shared keys, you can configure a global
IKE key or IKE key for each subnet. Make sure that this key matches the key on the VPN client.

1. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway.
The dashboard context for a group is displayed.

2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click a gateway underDevice Name.
The dashboard context for the gateway device is displayed.

4. UnderManage, Click Device.
The gateway configuration page is displayed.

5. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

6. Click VPN >Shared Secrets.

7. In the IKE Shared Secrets for VPN Clients table, click + to open theCreate IKE Group section.

8. Enter the Subnet and Subnet mask. To make the IKE key global, enter 0.0.0.0 for both values.

9. Select theRepresentation type from the drop-down list.

10. Enter a value for Shared key and repeat it in theRetype shared key field.

Configuring VIA User Role
The VIA user role is assigned to the users who successfully authenticate through their VIA client. The user
role defines the access rights of the users that connect using VIA. Aruba recommends that network
administrators configure customuser roles that depict the network access policy of their respective
organizations. You can also use the predefined default-via-role and edit it according to your requirements.

Formore information on creating user roles, see Configuring User Roles for Clients on page 302.

Creating VIA Server Group for Authenticating VIA Users
A server group is a collection of servers that are used for authentication. By default, the first server on the
list is used for authentication unless it is unavailable. A server group can have different types of
authentication servers. For example, you can create a server group that uses an LDAP server as a backup for
a RADIUS server.
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To configure a custom server group for authenticating VIA users, see Configuring Server Groups on page
315.

Configuring VIA Authentication Parameters

Configuring VIA Authentication Profile
The VIA authentication profile defines the authentication server group used and the default role assigned to
the authenticated users. Multiple authentication profiles can be created. Whenmultiple authentication
profiles are available, the VIA client prompts the user to select an authentication profile.

The VIA authentication profile is a critical part of VIA configuration and it is used for these purposes:

n To determine the authentication server for the XAUTH authentication phase of IKEv1 and EAP
authentications of IKEv2.

n To determine the authentication server for the VIAweb authentication. The VIA authentication profile is an
integral part of the VIAweb authentication, which determines the authentication sever used for VIA
bootstrap process and for authenticating users on the VIA installer download page of the
VPN Concentrator. Formore information on VIAweb authentication see Configuring VIAWeb
Authentication.

To configure a VIA authentication profile, complete the following steps:

1. To configure a Branch Gateway group or a Branch Gateway, complete either one of these steps:

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Click Security > L3 Authentication.

4. Select VIA Authentication.

5. Click + to create a new VIA authentication profile or select an existing profile. You can also use the
predefined defaultVIA authentication profile.

6. After selecting the required profile, select the role that you defined for the VIA users in theDefault
role field. Formore information on configuring the other parameters for this profile, see Table 60.

7. Select the required server group for authentication from the appropriate server group option under
the selected profile. The server group options areRADIUS Accounting Server Group, RFC 3576
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Server, and Server Group. Optionally you can configure the following options for the selected
server group:

n Fail through—Enables the fail through option for the server group.

n Load balance—Enables load balancing among the servers for authentication requests.

8. Save the changes.

Parameter Description

Default Role Select the role that you want to be assigned as the default role for the client
when authenticating using this profile. By default, the default-via-role is
assigned.

Max Authentication failures Maximum number of authentication failures allowed for the client. Allowed
range is 1-10 and the default value is 0.

Description Description of the authentication profile.

Check certificate common
name against AAA server

Select this option to check for certificate common name against the AAA
server. Default: enabled.

Client-certificate based
authentication for VIA
Profile download

Select this option to enable client-certificate based authentication for VIA
Profile download. By default, this is disabled.

Authentication protocol Select the authentication protocol to be used. The default value is PAP.

Download Role from CPPM Select this option to download the default role from ClearPass Policy
Manager, if the default role is not defined.

Table 60: VIA Authentication Profile Parameters

Configuring VIA Web Authentication
The VIAweb authentication is a list of VIA authentication profiles. Theweb authentication list allows the
users to login to the VIA download page <https://<VPN Concentrator IP address>/via> to download the VIA
client. To successfully login to the VIA download page, the usersmust authenticate successfully against the
VIA authentication profile in the list. If more than one VIA authentication profile is configured in theweb
authentication list, the users can view the list and select one authentication profile before authenticating to
the VIA installer download page.

Theweb authentication list is also used during the initial user authentication process that determines the
VIA user role. The Branch Gateway has a default web authentication list to whichmultiple VIA authentication
profiles can be added. Additional VIA web authentication lists cannot be created.

To configure the VIAweb authentication list, add one ormore VIA authentication profiles to the default web
authentication list and order them according to the priority. Configuringmore than one VIA authentication
profile in the VIAweb authentication list allows the users to use the backup authentication server when the
primary server becomes unavailable temporarily.

To configure the VIAweb authentication profile, complete the following steps:

1. To configure a Branch Gateway group or Branch Gateway complete either one of these steps:

n For a Branch Gateway group, in theNetwork Operations app, use the filter to select Groups.
n For a Branch Gateway in theNetwork Operations app, use the filter to select the gateway.

2. UnderManage, click Devices > Gateways.
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3. Click the configuration icon. The gateway configuration page is displayed.
4. Select VIA Web Authentication > default.

5. Click + to add a VIA authentication profile in theVIA authentication profiles table.

6. Save the changes.

Loading and Applying VIA Certificates
VIA configuration requires server certificates for both HTTPS as well as VPN. It also requires CA certificates if
certificate-based authentication is used on the client devices.

To load and apply VIA certificates, complete the following tasks:

1. Load the required VIA certificates to the certificates store in Aruba Central. Formore information on
loading certificates using Aruba Central, see Aruba Central Help Center.

2. Configure the VPN Concentrator to use the required VIA certificate. Formore information on
configuring certificates for a device, see Configuring Aruba Gateways for Certificate-Based
Authentication on page 340.

Configuring and Attaching VIA Connection Profile

Configuring VIA Connection Profile
The VIA connection profile is a collection of all the configurations required by a VIA client. The VIA
connection profile contains all the details required for the VIA client to establish a secure IPsec connection to
the VPN Concentrator. A VIA connection profile also defines other optional parameters. Such optional
parameters can be client auto-login, split-tunnel settings, and Content Security Services (CSS) settings. You
can configuremultiple VIA connection profiles.

A VIA connection profile is always associated to a user role, and all users that belong to that role use the
configured settings. When a user authenticates successfully to a server in an authentication profile, the VIA
client downloads the VIA connection profile that is attached to the role assigned to that user.

Table 61 summarizes the various parameters of a VIA connection profile .

To configure a VIA connection profile, complete the following steps:

1. In theNetwork Management app, use the filter to select a VPN Concentrator group or VPN
Concentrator.

n To configure a Branch Gateway group, complete the following steps:
a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard.

n To configure a Branch Gateway, complete the following steps:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.
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c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway device configuration page is displayed.

2. Click Security > L3 Authentication.

3. Select VIA Connection.

4. Click + to create a new VIA connection profile or select an existing profile. You can also use the
predefined defaultVIA connection profile.

5. After selecting the required profile, configure the various VIA connection profile parameters as
described in Table 61

6. Save the changes.

Parameter Description

VIA servers This parameter has the following fields:
n Addr—Add the public IP or DNS hostname of the VPN Concentrator. This is the host
name or IP address that the users enter as the remote server information on the VIA
client.
n Internal IP—Add the IP address of any of the internal VLAN interfaces of the
VPN Concentrator. This IP address should not be reachable from the public Internet.
The VIA client uses this IP address to determine whether or not the user is connected
to a trusted network.
n Description—Add a human-readable description of the VIA server.

NOTE: More than one VIA server can be added to the list.

Client auto-login Enabling client auto-login makes the VIA client detect untrusted network and connect
automatically. If you disable auto-login, VIA stays idle after it comes up and the user has
to manually click Connect to establish a VPN connection even though an untrusted
network is detected.
Default: enabled

VIA authentication
profiles to
provision

This VIA authentication profile is used to determine the authentication server used for the
IKE authentication process. If more than one VIA authentication profile is added to this list,
the users can choose the VIA authentication profile to be used during IKE authentication.
If no VIA authentication profile is defined, the users are authenticated against the server
group that is specified by the default VIA authentication profile (predefined).

Allow client to
auto-upgrade

This parameter allows the VIA client to automatically upgrade if a newer version of VIA is
available on the VPN Concentrator. By default this is enabled.

VIA tunneled
networks

When split-tunneling is enabled, the VIA client tunnels traffic to the VPN Concentrator for
all the network destinations (IP address and netmask) listed in this parameter. All other
network destinations are bridged appropriately on the client.
If split-tunnel is disabled, all the traffic is tunneled to the VPN Concentrator irrespective of
the destination.

Enable split
tunneling

When enabled, all traffic to the VIA tunneled networks goes through the VPN
Concentrator and the rest is bridged directly on the client.
If split-tunnel is disabled, all the traffic is tunneled to the VPN Concentrator irrespective of
the destination.

Table 61: VIA Connection Profile Parameters
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Parameter Description

Allow client-side
logging

This parameter determines whether client side logging is allowed or not. If enabled, VIA
client collects logs that can be sent to the support email address for troubleshooting.
Default: Enabled

VIA IKEv2 Policy This IKE policy is used for IKEv2 connections by the VIA client. Remember that IKEv2 using
PSK is not supported for VIA. For more information on configuring IKE policies, see
Configuring IKE Policies.

VIA IKE Policy This IKE policy is used for IKEv1 connections by the VIA client. This policy determines
whether IKEv1 phase 1 authentication uses PSK or certificates. For more information on
configuring IKE policies, see Configuring IKE Policies.

Use windows
credentials

This parameter determines whether the Windows credentials are used automatically to
login to VIA. If enabled, the single sign-on feature can be utilized by remote users to
connect to internal resources.
Default: Enabled

Enable IKEv2 This parameter enables or disables IKEv2.

Use suite b
cryptography

This parameter enables or disables Suite B cryptographic methods.

IKEv2
authentication
method

This parameter indicates the IKEv2 client authenticationmethod. It can be one of these
settings:
l user-cert
l EAP-TLS
l EAP-MSCHAPv2
Remember that EAP termination on the VPN Concentrator is not supported.

VIA IPSec v2
crypto map

This IPsec map is used by IKEv2 VIA client to connect to the VPN Concentrator.

VIA IPSec crypto
map

This IPsec map is used by IKEv1 VIA client to connect to the VPN Concentrator.

Allow user to save
passwords

This parameter determines whether the users can save the passwords entered in VIA or
not. If this is enabled, the user credentials that were able to successfully establish a VIA
connection are saved securely until VIA is uninstalled or until IKE authentication fails with
stored credentials. If this option is disabled, VIA prompts for credentials every time it
establishes a connection.
If secure tokens such as the RSA tokens are used for authentication, disable this option to
prompt the user for a password/token for each connection attempt.
By default, this is enabled.

Enable supplicant This parameter enables the supplicant mode.

Enable FIPS
module

This parameter enables the VIA FIPS module.

Auto-launch
supplicant

This parameter automatically connects to the configured WLAN network.

Lockdown all
settings

This parameter locks all the configuration options available on the end-user VIA client. If
this option is enabled, a VIA user can only connect, disconnect or send logs.
Diagnostics such as traceroute and ping can still be used, but no settings can be changed.

NOTE: This option is available in VIA 2.1 and later versions.
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Parameter Description

Domain suffix in
VIA authentication

This parameter enables domain suffix in VIA authentication.

Enable Controllers
load balance

This parameter enables load balancing of VIA clients by randomly choosing a VPN
Concentrator from the list of available VIA VPN Concentrators that can be used for
connection. This feature does not take the existing load of the VPN Concentrator into
account.

NOTE: This option is available in VIA 2.1 and later versions.

Enable domain
pre-connect

This parameter enables pre-connection to the domain. By default, this is enabled.

VIA banner
message
reappearance
timeout(minutes)

This parameter configures the timeout value in minutes for reappearance of VIA login
banner message. The default value is 60 minutes.

VIA client network
mask

This network mask is set on the client after the VPN connection is established.
The default value is 255.255.255.255.

Validate server
certificate

If enabled, the VIA client validates the server certificate presented by the VPN
Concentrator during the IPsec process. Remember that to validate the server certificate,
the CA that signed the VPN Concentrator certificate should be a trusted CA in the client
certificate store. By default, this is enabled.

VIA client DNS
suffix list

This is the DNS suffix that is set on the client after the VPN connection is established.

OCSP cert
verification
enabled

This parameter enables OCSP certificate verification.

In EAP/IKE, action
taken when OCSP
cert verification
result is unknown

This parameter accepts the certificate when OCSP certificate verification result is
unknown for EAP/IKEs.

VIA domain name
profile

This parameter allows you to add VIA domain name profiles.

Destination traffic
to be blocked

This parameter allows you to configure the IP address and netmask of the destination
traffic for blocking.

Block-destination-
traffic-selector
(on/off)

This parameter enables or disables the blocking of destination traffic.

VIA max session
timeout

This parameter defines the maximum time, in minutes, allowed before the VIA session is
disconnected.
Default: 1440 min

VIA logon script This parameter specifies the name of the logon script that must be executed after VIA
establishes a secure connection. The logon script must reside on the client computer.
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Parameter Description

VIA logoff script This parameter specifies the name of the logoff script that must be executed after VIA
tears down a secure connection. The logoff script must reside on the client computer.

VIA support e-mail
address

This is the support email address to which VIA users send client logs using the VIA client.
For information on sending VIA logs using the VIA client, see Chapter 8: Establishing VIA
connection.

Maximum
reconnection
attempts

This parameter defines the maximum reconnection attempts by the VIA client. If the
reconnection attempt is exceeded, the VIA client becomes idle. However, if the
connection attempt fails due to an IKE authentication failure error, then the user is
prompted to reenter username and password.
Default: 3

VIA external
download URL

The VIA installer can be hosted on an external server other than the VPN Concentrator for
download by the VIA client during VIA upgrades and by the end users. If the VIA installer is
hosted on an external server, this parameter should be configured to redirect the VIA
clients to the external URL for the upgrade process. If this parameter is not configured,
the VIA clients automatically go to https:// <VPN Concentrator IP address or FQDN >/via
for upgrades.

Allow user to
disconnect VIA

This feature determines whether the users can disconnect VIA or not. Remember that a
user with administrative rights to a laptop can always uninstall VIA or disable the service
running on the laptop. For users with restricted access to the laptops, disabling this
feature ensures that users cannot disconnect VIA. By default, his is enabled.

Content security
gateway URL

When split-tunnel mode is enabled, traffic to external websites is inspected by the CSS.

Comma separated
list of HTTP ports
to be inspected
(apart fromdefault
port 80)

Traffic to the specified list of ports is verified by the CSS provider.

Certificate criteria Certificate criteria expressed in key-value pairs where keys can be certificate attributes,
or certificate OIDs. Multiple key-value pairs can be combined with semi-colon.

Enable content
security services

This parameter enables the CSS. The CSS requires the CSS licenses.

Keep VIA window
minimized

When this feature is enabled, the VIA client is minimized to the system tray during the
connection phase. This feature is applicable only for VIA clients installed onMicrosoft
Windows laptops.
Default: disabled

Block traffic until
VPN tunnel is up

This parameter allows blocking of traffic until VPN tunnel is up.

Block traffic rules This parameter configures the VIA whitelist traffic rules. Specify the IP address, netmask
and description for the traffic rules.

User idle timeout User idle timeout value. Allowed range is 30-15300 seconds in multiples of 30 seconds.

VIA client mtu
value

MTU value for the VIA client. Allowed range is 576-5120 bytes. The default value is 1452
bytes.

Attaching the VIA Connection Profile to User Role
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VIA connection profile that the VIA client has to download should be attached to the user role to be assigned
to the user. When a user goes through the authentication phase it is placed on a role which has a certain
connection profile associated. Suppose, the users authenticating to the VIA authentication profile are
assigned thedefault-via-role. To assign a specific connection profile to these users, attach the connection
profile to thedefault-via-role.
To attach the VIA connection profile to a user role, complete the following steps:

1. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway.
The dashboard context for a group is displayed.

2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click theConfig icon.
The gateway group configuration page is displayed.

4. Click Security > Roles.

5. Select the role to which you want to associate a VIA connection profile and select theMore tab.

6. Expand VPN and select the required VIA connection profile from theVIA connection profile drop-
down list.

7. Save the changes.

Uploading VIA Installer to VPN Concentrator

VIA installers for Apple iOS andMac OS X devices are available in the Apple App store. VIA installers
for other devices with Windows 32-bit and 64-bit operating systems are available at the Aruba support
site.

For end users and VIA client to access the VIA installers during upgrades, the VIA installers require to be
uploaded on the VPN Concentrator (VPNC) or an external hosting server.

If the VIA installer is hosted on an external hosting server, configure the gateway configuration parameter
VIA external download URL under Security > L3 Authentication > VIA Connection to redirect the VIA
clients to the external URL for the upgrade process. Formore information, see Configuring and Attaching
VIA Connection Profile.

If the VPNC is used to host the VIA images, it automatically detects the operating systemof the device that is
connecting to the VIA download page. It also learns the parameters of theweb browser used to connect to
the VIA download page to determine the operating system.

After the users login to the VIA download page, the VPN Concentrator presents the appropriate VIA installer
image. After the initial installation, the VIA clients are capable of automatically upgrading their image
(depending on VIA connection profile setting). If the network administrator uploads a new version of VIA
installer to the VPNC or to an external server (indicated by the VIA external download URL parameter of the
VIA connection profile), the VIA clients automatically upgrade their image.

To upload the installer packages, complete the following steps:
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1. Log into the local WebUI of the VPNC.

2. Navigate to Configuration > Services > VPN > VIA .

3. To upload a VIA installer package, expand VIA, click +, and upload the VIA installer package.

Figure 151 Upload VIA installer package into VPNC



Chapter 15
Provisioning Gateways Using

Configuration Templates

Provisioning Gateways Using Configuration Templates
If your deployment has a large number of Aruba Gateways and requires bulk configuration, you can use the
configuration template feature in Aruba Central to quickly provision Gateways. The configuration template
feature is available for theGateway devices provisioned in template groups in Aruba Central.

The template groups in Aruba Central allow network administrators to create a common configuration
output by using a combination of CLI commands and variables, and apply this configuration to the other
Gateway devices provisioned in that group.

Important Points to Note
Before you begin the provisioning procedure, note the following important points and recommendations:

n Aruba recommends that the administrators who are provisioning Gateways using templates familiarize
themselves with theGateway CLI commands. A prior understanding of the Gateway CLI commands helps in
determining the service impact and avoiding errors that may occur due to incorrect configuration.

n Before assigning devices to groups, identify the devices that have a common set of CLI commands and
configuration requirements.

n The configuration requirements for a Branch Gateway and VPN Concentrator are different, so Aruba
recommends that you create separate template groups for Branch Gateways and VPN Concentrators.

n If you are provisioning Gateways with factory-default configuration, you can build a template based on the
current configuration of the first device that joins a template group.

n If you want to create a template based on the current configuration of an existing Gateway device, access
the CLI console of the device and copy the configuration. Use this configuration as the template text when
building a new template. You can enhance this template formulti-device use by adding variable definitions.

n While Aruba Central allows you to move a Gateway device from aUI group to a template group, youmust
ensure that the current configuration running on the device is backed up and is included in the
configuration template created for that template group. However, Aruba recommends that you exercise
caution whenmoving a device from aUI group to a template group as incorrect configurationmay lead to
service disruption.

Configuring Gateways Using a Template
To provision Gateways in a template group, complete the following steps:

n Creating a Template Group

n Creating a Configuration Template for Gateways

n Customizing a Template Using Variable Definitions

n Sample Template and Variables Files

n Verifying Configuration Status

n Backing up and Restoring Templates

Creating a Template Group
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To create a template group, complete the following steps:

1. In theNetwork Operations app, set the filter to Global.

2. Go to Maintain > Organization > Groups. TheGroups page is displayed.

3. Click (+) New Group. TheCreate a New Group pop-up window opens.

4. Enter a name for the group

5. Select the IAP and Gateway check box to create a template group for Gateways.

Figure 152 Template Group Creation

6. Click Add Group.

Assigning a Gateway to a Template Group
To assign a Gateway to a group, complete the following steps:

1. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway.
The dashboard context for a group is displayed.

2. Go to Maintain > Organization > Groups. TheGroups page is displayed.

3. From theDevices > Gateways table, select the Gateway that you want to assign to a template
group.

4. Drag and drop the device to the template group that you just created.

Creating a Configuration Template for Gateways
AGateway configuration template includes a set of common configuration commands that you can apply
to multiple Gateway devices provisioned in a group.
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Before you Begin
Before generating a configuration template:

n Familiarize with the CLI commands available on the device.

n Identify the commands that you want to use at the group level and the overrides required at the device
level.

n Ensure that the Gateways are assigned to a template group.

Best Practices and Recommendations
Note the following recommendations when adding configuration text to a template:

n Verify the CLI syntax on theGateway device before adding it to the template text.

n Ensure that the command text indentationmatches the indentation in the running configuration.

n As the command text and definitions are case-sensitive, ensure that there are no errors or discrepancies in
the CLI definitions.

Configuration Steps
To create a template for theGateways provisioned in a template group:

1. In theNetwork Operations app, set the filter to a group or Branch Gateway. Ensure that you select
a group or Branch Gateway for which template-based configurationmode is enabled.
n To select a Branch Gateway group in the filter:

a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard

n To select a Branch Gateway in the filter:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.
The gateway configuration page is displayed.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Click Templates. The Templates page opens.

4. Click + to add a new template. TheAdd Template page opens.

5. Add the template name.

6. Select a Gateway hardwaremodel and the Aruba SD-WAN software version for which you want to
apply the template.

7. To apply the template to all models and software versions of Gateways, select All.
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8. Add the template text.

Figure 153 Creating a Configuration Template

9. Click Save. After you apply the configuration template, Gateways reboot and reconnect to Aruba
Central with the new configuration.

Customizing a Template Using Variable Definitions
Variables in Aruba Central refer to the data set in the configuration template that can vary per device.

Aruba Central supports composing the variables in JSON and CSV formats. To add variable definitions, you
can download a sample variable file fromAruba Central, add the definitions, and then upload it to Aruba
Central.

To view a list of variables in a template, select the template row and click the edit or delete icon respectively.

Downloading a Sample Variables File
To download a sample variables file, complete the following steps:

1. In theNetwork Operations app, set the filter to a group or Branch Gateway. Ensure that you select
a group or Branch Gateway for which template-based configurationmode is enabled.

n To select a Branch Gateway group in the filter:

a. Set the filter to a group containing at least one Branch Gateway.

The dashboard context for a group is displayed.

b. Click Gateways.

c. Click theConfig icon to view the Branch Gateway group configuration dashboard
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n To select a Branch Gateway in the filter:
a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. UnderManage, click Device.

2. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

3. Click Variables

4. Select a file format. The supported file formats are JSON and CSV.

5. Click Download Sample Variables File.

Modifying a Variables File
Note the following conditions whenmodifying variable definitions:

n The _sys_serial and _sys_lan_mac aremandatory variables for specifying the serial number andMAC
address of each device.

n The < or <= or > or >= operators should have only numeric integer value on the right side. The variables
used in these 4 operations are compared as integer after flooring. For example, if any float value is set as
%if dpi_value > 2.8%, it is converted as%if dpi_value > 2 for comparison

n The variable names should not includewhite space, and the& and % special characters. The variable names
must match regular expression [a-zA-Z0-9_]. If a variable defintion includes%, add a space before and after
the% instance.

n The first character of the variable namemust be an alphabet. Numeric values are not supported.

n If quotes are required, they must be included as part of the variable value.

n If you are using a CSV file formodifying variable definitions, themodified columnmust be set to Y to allow
Aruba Central to parse themodified definition.

Uploading a Variables File
To upload a variables file, complete the following steps:

1. In theNetwork Operations app, use the filter to select a group or Branch Gateway. Ensure that you
select a group for which template-based configurationmode is enabled.
n To select a Branch Gateway group in the filter:

a. Set the filter to a group containing at least one Branch Gateway.

2. Click Gateways.
The dashboard context for a group is displayed.

a. Click theConfig icon to view the Branch Gateway group configuration dashboard.
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3. To select a Branch Gateway in the filter:

a. Set the filter to Global or a group containing at least one Branch Gateway.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway underDevice Name.
The dashboard context for the gateway is displayed.

d. Click a gateway underDevice Name.

e. UnderManage, click Device.

4. If you are in theBasic Mode, click Advanced Mode to access the advanced configuration options.

5. Click Upload Variables File and select the variables file to upload.

6. To verify if the variables are added in the template, go to Gateway Management > Templates.

7. Click the edit icon in the template. Verify the list of variables displayed in the Edit Template screen.

Sample Template and Variables Files

Template Text
The following example shows the contents of a Gateway configuration template:

vlan 4094

!

interface gigabitethernet 0/0/0

switchport access vlan 4094

trusted

trusted vlan 1-4094

!

interface gigabitethernet 0/0/1

!

interface gigabitethernet 0/0/2

!

interface gigabitethernet 0/0/3

!

interface gigabitethernet 0/0/4

!

interface gigabitethernet 0/0/5

!

interface gigabitethernet 0/0/6

!

interface gigabitethernet 0/0/7

!

interface gigabitethernet 0/0/8

!

interface gigabitethernet 0/0/9

!

interface gigabitethernet 0/0/10

!

interface gigabitethernet 0/0/11

!

interface gigabitethernet 0/0/12

!
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interface gigabitethernet 0/0/13

!

interface gigabitethernet 0/0/14

!

interface gigabitethernet 0/0/15

!

interface gigabitethernet 0/0/16

switchport access vlan %_vlan_id3_%

!

interface gigabitethernet 0/0/17

switchport access vlan %_vlan_id1_%

!

interface vlan 4094

ip address dhcp-client

!

firewall

dpi

cp-bandwidth-contract trusted-ucast 65535

cp-bandwidth-contract trusted-mcast 3906

cp-bandwidth-contract untrusted-ucast 9765

cp-bandwidth-contract untrusted-mcast 3906

cp-bandwidth-contract route 976

cp-bandwidth-contract sessmirr 976

cp-bandwidth-contract vrrp 512

cp-bandwidth-contract auth 976

cp-bandwidth-contract arp-traffic 3906

cp-bandwidth-contract l2-other 1953

!

mgmt-user admin root itsabug

interface vlan 4094

ip address dhcp-client

!

hostname %_hostname_%

vlan %_vlan_id_%

interface vlan %_vlan_id_%

ip address %_ip_addr_% %_net_mask_%

!

controller-ip vlan %_vlan_id_%

!

wlan virtual-ap %_vap1_%

aaa-profile %_prof_name7_%

vlan %_vlan_id3_%

!

aaa server-group %_svr_grp1_%

auth-server %_svr1_%

!

aaa server-group %_svr_grp2_%

auth-server %_svr1_%

!

aaa server-group %_svr_grp3_%

auth-server %_svr1_%

!

aaa server-group %_svr_grp4_%

auth-server %_svr1_%

!

aaa server-group %_svr_grp5_%

auth-server %_svr1_%

!

aaa server-group %_svr_grp6_%

auth-server %_svr1_%
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!

crypto-local pki ServerCert new_svr1_ocsp new_svr1_ocsp

crypto-local pki ServerCert SERVER-CERT SERVER-CERT

crypto-local pki TrustedCA pata_ca pata_ca

crypto-local pki rcp pata_ca

aaa authentication dot1x %_pdot1x_%

server-cert %_svr_cert_%

ca-cert %_ca_cert_%

!

aaa authentication-server radius %_svr1_%

!

vlan %_vlan_id1_%

wired aaa-profile %_prof_name7_%

!

aaa profile %_prof_name7_%

initial-role %_role1_%

dot1x-default-role %_role1_%

dot1x-server-group %_svr_grp1_%

!

aaa profile %_prof_name5_%

initial-role %_role1_%

dot1x-default-role %_role1_%

!

vlan %_vlan_id2_%

wired aaa-profile %_prof_name5_%

!

user-role %_role1_%

!

vlan %_vlan_id3_%

!

interface vlan %_vlan_id2_%

ip address %_ip_vlan2_% %_net_mask_%

!

ip access-list session %_acl1_%

!

aaa server-group %_svr_grp1_%

auth-server %_svr1_%

!

aaa authentication-server radius %_svr1_%

!

vlan 3434

!

netdestination peds-devices

%if local_network_ip%

range %local_network_ip%.91 %local_network_ip%.100

range %local_network_ip%.101 %local_network_ip%.110

%endif%

!

aaa profile %_prof_name8_%

%if role_group%

%role_group%

%endif%

!

aaa authentication captive-portal %_cap1_%

redirect-url "https://abc%xyz"

!

user

user

Sample Variables File
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The following example shows the contents of a sample variables file in the JSON format:

"CG0011297": {

"_sys_lan_mac": "00:0B:86:dd:67:80",

"_sys_serial": "CG0011297",

"_hostname_": "Aruba7010_DD_67_80",

"_vlan_id_" : "700",

"_ip_addr_" : "1.70.70.10",

"_net_mask_" : "255.255.255.0",

"_vlan_id1_" : "225",

"_vlan_id2_" : "226",

"_vlan_id3_" : "227",

"_prof_name5_" : "prof5",

"_prof_name6_" : "prof6",

"_prof_name7_" : "prof7",

"_prof_name9_" : "prof9",

"_role1_" : "role1",

"_ip_vlan2_" : "1.27.26.10",

"_vap1_" : "vap1",

"_svr_grp1_" : "svr_grp1",

"_svr_grp2_" : "svr_grp2",

"_svr_grp3_" : "svr_grp3",

"_svr_grp4_" : "svr_grp4",

"_svr_grp5_" : "svr_grp5",

"_svr_grp6_" : "svr_grp6",

"_svr1_" : "svr1",

"_svr_cert_" :"new_svr1_ocsp",

"_ca_cert_" : "pata_ca",

"_pdot1x_" : "pdot1x",

"_server_ocsp3_" : "server_ocsp3",

"_acl1_" : "acl1",

"local_network_ip" : "34.34.54",

"_prof_name8_" : "prof8",

"role_group" : "initial-role role1\n dot1x-default-role role1",

"_cap1_" : "cap1",

"_url_" : "https://abc/%xyz",

"_role2_" : "\"test%role2\""

},

"CG0007810": {

"_sys_lan_mac": "00:0B:86:dB:B0:C0",

"_sys_serial": "CG0007810",

"_hostname_": "Aruba7010_DB_B0_C0",

"_vlan_id_" : "166",

"_ip_addr_" : "166.10.10.10",

"_net_mask_" : "255.255.255.0",

"_vlan_id1_" : "225",

"_vlan_id2_" : "226",

"_vlan_id3_" : "227",

"_prof_name5_" : "prof5",

"_prof_name6_" : "prof6",

"_prof_name7_" : "prof7",

"_prof_name9_" : "prof9",

"_role1_" : "role1",

"_ip_vlan2_" : "1.27.26.11",

"_vap1_" : "vap1",

"_svr_grp1_" : "svr_grp1",

"_svr_grp2_" : "svr_grp2",

"_svr_grp3_" : "svr_grp3",

"_svr_grp4_" : "svr_grp4",

"_svr_grp5_" : "svr_grp5",

"_svr_grp6_" : "svr_grp6",
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"_svr1_" : "svr1",

"_svr_cert_" :"new_svr1_ocsp",

"_ca_cert_" : "pata_ca",

"_pdot1x_" : "pdot1x",

"_server_ocsp3_" : "server_ocsp3",

"_acl1_" : "acl1",

"local_network_ip" : "34.34.54",

"_prof_name8_" : "prof8",

"role_group" : "initial-role role1\n dot1x-default-role role1",

"_cap1_" : "cap1",

"_url_" : "https://abc/%xyz",

"_role2_" : "\"test%role2\""

}

Verifying Configuration Status
n To verify that Gateways are assigned to the template group and the configuration is pushed fromAruba

Central, go to Analyze > Audit Trail.
n To view the configuration sync errors and overrides, use theConfiguration Audit for Gateways. Formore

information, see Viewing Gateway Configuration Status on page 346.

Backing up and Restoring Templates
Aruba Central supports backing up and restoring configuration templates. TheConfiguration Audit page
for Gateways allows you to back up the configuration templates and variables and restore thesewhen
required. Formore information, see Backing Up and Restoring Configuration Templates in Aruba Central
Help Center.



Chapter 16
Monitoring SD-Branch

Monitoring SD-Branch
After you set up the data center, branch sites, and configure devices deployed in the SD-Branch, the
monitoring dashboards allow you to view the branch health andmonitor theWAN uplink and gateway
performance. This application also provides a dashboard for analyzing application usage by the clients
connected in theWAN network. You can also view the branch topology, configure alerts, and create reports.

Formore information on details, see the following topics:

n Gateway > Overview > Summary—View details of the gateways deployed in theWAN network.

n WANHealth—Global—View detailed information of the network health status and usage for the sites
configured in your setup.

n WANHealth—Site—View details of a specific site.

n Monitoring Sites in the Topology Tab—View a graphical representation of the network layout.

n Gateway Alerts—Configure and view gateway alerts.

n Reports—Create and view gateway reports.

Monitoring Gateway
You canmonitor gateways in Aruba Central from all the available dashboards includingGlobal,Groups,
Sites, Labels, and Gateways.
For a snapshot of all the gateways configured at the global, group or site level, in either list or summary view,
see the following topics:

n Monitoring Gateway in the List View

n Monitoring Gateways in the Summary View

Monitoring Gateways in List View
The List view for gateways is available from theGlobal,Group, Site, and Label dashboards. In all applicable
dashboards, the List view is underManage > Devices > Gateways.
To view the list of gateways, complete the following steps:

1. In theNetwork Operations app, set the filter to one of the options underGroups, Labels, or Sites.
For all devices, set the filter to Global.

Ensure that the selected option has at least one gateway configured.

The dashboard context for the selected filter is displayed.

2. UnderManage click Devices > Gateways.
A list of gateways is displayed in the List view.

List View
The list view displays the following tabs:
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n Gateways—Displays the total number of gateways configured.

n Online—Displays a list of gateways that are online and connected to Aruba Central.

n Offline—Displays a list of Gateways that are currently down.

List View > Gateways

TheGateways table displays the following details forGateways,Online and Offline tabs:

n Device Name—Displays the gateway name.

n Model—Displays themodel of the gateway.

n Firmware Version—Displays the firmware version of the gateway.

n Uptime—Displays the time period for which the gateway has been functioning.

n IP Address—Displays the IP address of the gateway.

n Site—Displays the site information.

n MAC—Displays theMAC address of the gateway.

n Group—Displays the gateway group name.

n Labels—Displays the labels assigned to the gateway.

n Serial—Displays the gateway serial number.

Apart from the above fields, you can see the following fields if IDPS is enabled:

n Inspection Engine—The Aruba IDPS engine version number.

n Ruleset—The ruleset version currently running on the device.

n Last Successful Ruleset Update—The timestamp of the last successful ruleset update.

n Ruleset Update Status—The ruleset update status could be one of the following:
o Failed
o Success
o Initialized

Click the download icon to download the gateways details as a .csv file. Foremore information, see
Downloading Gateway Details.

Click the ellipsis icon to perform the following additional operations:

n Select the columns that you want to display in the table.

n Adjust the columnwidth of the table to fit the page evenly.

n Reset the table view to the default columns.

Monitoring Gateways in Summary View
The Summary view for gateways is available from theGlobal,Groups, Sites, and Labels dashboards. In all
applicable dashboards, the Summary view is underManage > Devices > Gateways. Displays a graphical
representation of the gateway operations.

To view the summary of gateways, complete the following steps:

1. In theNetwork Operations app, set the filter to one of the options underGroups, Labels, or
Sites. For all devices, set the filter to Global.

Ensure that the selected option has at least one gateway configured.

The dashboard context for the selected filter is displayed.
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2. UnderManage, click Devices>Gateways.
A list of gateways is displayed in the List view.

3. Click the Summary icon.
A graphical representation of the gateway operations is displayed.

You can change the time range by clicking the time range filter and selecting one of the available options:
3 hours, 1 day, 1 week, 1 month, and 3 months.

If you have just set up a gateway, youmay not see relevant data immediately.

Summary View
The Summary view displays a graphical representation for the following:

n Usage—Displays the overall usagemetrics for the gateways provisioned in your Aruba Central account.
Displays the incoming and outgoing traffic for the gateways with time plotted on the x-axis. You can hover
over the chart to see the incoming and outgoing traffic for a particular time frame.

n WAN Compression—Displays the data packet compression statistics for theWAN network. You can view
the compressed, uncompressed, and saved bandwidth. By default, traffic between the Branch Gateway
and VPN Concentrator is subject to compression. You can hover over the chart to see the compressed and
uncompressed statistics for a particular time frame.

n WAN Tag Provider Distribution—Displays the number of online and offline uplinks perWAN provider.

n WAN Transport Health—Displays theMean Opinion Score (MOS) score trends for each uplink for the
selected time range. The uplink health trend is plotted using health indicators such as Good, Fair, and Poor.
You can hover over the chart to see the uplink scores for a particular time frame. Click an uplink name to
show or hideMOS score trends for that uplink.

n WAN Type Provider Distribution—Displays the number of online and offline uplinks perWAN circuit
type.

n Model Distribution—Displays the total percentage of gateways distributed per hardware platform. You
can hover over a donut slice to display the percentage for a specific hardwaremodel. Click a hardware
platform number to show or hide the distribution percentage for that platform.

n Firmware Distribution—Displays the total percentage of gateways distributed by software versions. Click
a firmware number to show or hide the distribution percentage for that firmware.

Gateway > Overview > Summary
The Summary tab underManage > Overview in the gateway dashboard displays the following three
sections:

n Device Info

n WAN Summary

n Health Status

Viewing the Overview > Summary Tab
To navigate to the Summary tab in the gateway dashboard, complete the following steps:

1. In theNetwork Operations app, set the filter to one of the options underGroups, Labels, or
Sites. Ensure that the filter selection contains at least one gateway. For all devices, set the filter to
Global.
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The dashboard context for the selected filter is displayed.

2. UnderManage > Devices, click theGateways tab.
A list of gateways is displayed in List view.

3. Click a gateway underDevice Name.
The dashboard context for the specific gateway is displayed.

4. UnderManage, click Overview > Summary .
To exit the gateway dashboard, click the back arrow on the filter.

You can change the time range for the Summary tab by clicking the time range filter and selecting
one of the available options: 3 hours, 1 day, 1 week, 1 month, and 3 months.

Device Info
TheDevice Info section displays the following details.

Figure 154 Device Info

n Name—The name of the gateway.

n Serial Number—The serial number of the gateway.

n Model—The hardwaremodel of the gateway.

n MAC Address—TheMAC address of the gateway.

n System IP address—The IP address of the gateway.

n Public IP address—The public IP address of the gateway.

n Firmware Version—The firmware version running on the gateway. If a new version of the firmware is
available, this information is also displayed. Clicking on the new firmware version redirects you to the
Maintain > Firmware > Gateways page in the gateway dashboard, where you can select the gateway to
upgrade it.

n POE (DRAW/MAX)—The amount of power that the devices connected to the Branch Gateway consume
and themaximumPoE power capacity. For example, if the value displayed is 6/120, the devices draw 6
watts and themaximumPoE power allocated is 120 watts.

n Redundancy Peer—Displays the redundant gateway if it is configured. Click the link to view the
redundant gateway details.

n Group Name—The name of the group, if the gateway is configured as part of a group. Click the group
name to go to theOverview > Summary page for that group.

n Site—The name of the site, if the gateway is configured as part of a site. Hover over the i icon to display the
complete address of the site. Click the site name to go to theOverview > Site Health page for that site.

n Labels—The name of the label, if the gateway is configured as part of a single ormultiple labels.
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n 4G/LTE Modem Status—Displays themodem connectivity status. The status shows only 'Connected'
when themodem type is not internal.

n 4G/LTE Modem Type—Displays the LTE connection type.

n Config Sync Status—The status of the configuration sync. Hover over the i icon to display the last
successful configuration sync time.

n NTP Server—The name of theNTP server configured and its synchronization status.

n Last Reboot Reason—The reason for the last reboot.

n Internal Modem Status (Only for Gateway model: 9004-LTE)—Displays the name of the service

provider and the signal strength. Hover over the information icon to view details about the active SIM,
the IMEI number and the phone number. You can view the signal strength classification based on RSSI value,
in the following table:

WAN Summary
TheWAN Summary section displays information of WAN Availability, VPN Availability, Usage, Throughput
and Compression.

Figure 155 WAN Summary

n WAN Availability—Provides a graphical representation of the WAN uplink availability for the Branch
Gateway. The graph displays eachWAN uplink availability for the selected time range. Availability is
determined by the default gateway andmonitored IP reachability. You can hover over the chart to see the
WAN availability statistics for a particular time frame.
o Red—Down
o Yellow—(>50) Partial availability
o Green—No Issues
o Gray—Unknown
o Dotted lines—Invalid

n VPN Availability—Provides a graphical representation of the VPNC reachability for the Branch Gateway.
Availability is determined by the probe settings configured using theHealth Check option.
o Red—Down
o Yellow—>50 percent availability
o Green—No Issues
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o Gray—Unknown
o Dotted lines—Invalid

n Usage—Displays the aggregate sent and received traffic usage by theWAN interface for the Branch
Gateway. Displays the incoming and outgoing traffic for the gateways with time plotted on the x-axis. You
can hover over the chart to see the incoming and outgoing traffic for a particular time frame. Select one of
the following options from the drop-down list:
o All
o Internet
o VPN

Click the following icons to see the chart in logarithmic scale or linear scale.

n Logarithmic Scale—Click this icon to view chart in logarithmic scale.

n Linear Scale—Click this icon to view chart in linear scale.

Click Received or Sent at the bottomof the chart to view or hide the usage chart for received or sent data.

n Throughput—Provides a graphical representation of the aggregatedWAN interfaces throughput. The
graph displays the transmit and receive performance in bps for aWAN interface. Displays the incoming and
outgoing traffic for the gateways with time plotted on the x-axis. You can hover over the chart to see the
received and sent throughput for a particular time frame.

Click the following icons to see the chart in logarithmic scale or linear scale.

n Logarithmic Scale—Click this icon to view chart in logarithmic scale.

n Linear Scale—Click this icon to view chart in linear scale.

Click Received or Sent at the bottomof the chart to view or hide the usage chart for received or sent data.

n Compression—Displays the aggregateWAN compression details across all uplinks. The average bandwidth
savings is displayed as a percentage. The compressed and uncompressed bandwidth is displayed as vertical
grouped bar graphs. You can hover over the chart to see the bandwidth savings statistics for a particular
time frame.
o Gray—Optimized
o Red—NonOptimized

Health Status
TheHealth Status section displays the health of the gateway in terms of CPU, Memory and device
connectivity to Central.

The health status is plotted using health indicators such as Good, Fair, Poor and Offline. You can hover over
the chart to see the health status for a particular time frame.
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Figure 156 Health Status

The default view of gateways table shows only a few columns. To view the hidden columns, click the
settings icon at the right side of the table. To reset the columns, click Reset Columns.

Actions
TheActions drop-down list contains the following options (the Clear IPSec SA, and Clear ISAKMP SA options
are available for tunnels only):

n Reboot Gateway—Reboots the gateway. See Rebooting a Gateway

n Open Remote Console—Opens the remote console for a CLI session through SSH. The default user ID is
admin, but you can edit and customize the user ID. This customuser ID must bemapped to the device. See
Opening a Remote Console

n Clear IPSec SA—Clears the IPSec Security Associations (SA). See Clearing IPSec SA

n Clear ISAKMP SA—Clears the ISAKMP SA. See Clearing ISAKMP SA

Go Live
TheGo Live link redirects to theManage > WAN > Summary tab in the gateway dashboard. See theGo
Live section in theGateway > WAN > Summary page.

1. UnderManage, click Devices > Gateways.

2. Click a gateway underDevice Name.

3. UnderManage, click Overview. By default, the Summary tab is displayed.

n WAN—Displays the total number of WAN interfaces that are currently operational or down. On clicking a
port, the dashboard displaysWAN interface details.

n LAN—Displays the total number of LAN interfaces that are currently operational or down. On clicking a
port, the dashboard displays LAN and VLAN interface details.

n Tunnels—Displays the total number of VPN tunnels that are currently active or down. On clicking a port
tunnel, the dashboard displays VPN tunnel details.

n IDPS—Displays details pertaining to the IDPS traffic inspection engine health and the number of packets
dropped. The IDPS tab is displayed for 9004 gateways with a valid IDPS subscription.

n Routing—Displays details pertaining to the routing protocols such as BGP, OSPF, RIPv2 and Overlay.

n Path Steering—Displays the total number of path steering policies that are compliant with the
performance criteria (SLAs) defined for each type of traffic.

n Sessions—Displays detailed information about the running sessions.
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n AI Insights—Displays a report of network events that could possibly affect the quality of the overall
network performance.

n Alerts—Displays the total number of open alerts that are yet to be acknowledged.

Gateways > Overview > IDPS
The IDPS tab underManage > Overview in the gateway dashboard displays the following sections:

n Traffic Inspection Engine Status

n Traffic Inspection Engine CPU Usage

n Traffic Inspection EngineMemory Usage

n Dropped Packets

After you on-board the gateways and configure IDPS, you can view the IDPS traffic engine health and the
number of packets dropped.

Viewing the Overview > IDPS Tab
To navigate to the IDPS tab in the gateway dashboard, complete the following steps:

1. In theNetwork Operations app, set the filter to one of the options underGroups, Labels, or Sites
that has IDPS supported gateways. For all devices, set the filter to Global. The dashboard context for
the selected filter is displayed.
The dashboard context for the selected filter is displayed.

2. UnderManage > Devices, click theGateways tab.
A list of gateways is displayed in List view.

3. Click a gateway underDevice Name.
The dashboard context for the specific gateway is displayed.

4. UnderManage, click Overview > IDPS .

To exit the gateway dashboard, click the back arrow on the filter.

You can change the time range for the IDPS tab by clicking the time range filter and selecting one of the
available options: 3 hours, 1 day, 1 week, 1 month, and 3 months.

To set the charts to show data for specific duration, use the options in the time range filter. By default,

the data is displayed for a duration of 3 hours. To view the graphs for different durations, click the
time filter icon and select a time range of your choice. You can view data for 3 hours, 1 day, 1 week, 1
month, or 3 months.
The IDPS tab is displayed for 9004 gateways with a valid IDPS subscription.

Traffic Inspection Engine Status
The Traffic Inspection Engine Status chart displays the status of the traffic inspection engine for the
selected period in a timeline chart. Hover over the graph to view the status of the traffic inspection engine
at a particular time. The legends represent different status of the traffic inspection engine.

The Traffic Inspection Engine Status chart is available for a period of 3 hours, 1 day, 1 week, or 1
month.
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Figure 157 Traffic Inspection Engine Status

Traffic Inspection Engine CPU Usage
The Traffic Inspection Engine CPU Usage chart displays the CPU usage percentage of the traffic
inspection engine for the selected period in a line chart. Hover over the graph to view the CPU usage
percentage at a particular time.

Figure 158 Traffic Inspection Engine CPU Usage

Traffic Inspection Engine Memory Usage
The Traffic Inspection Engine Memory Usage chart displays the percentage of memory usage by the
traffic inspection engine for the selected period in a line chart. Hover over the graph to view thememory
usage percentage at a particular time.

Figure 159 Traffic Inspection Engine Memory Usage

Dropped Packets
TheDropped Packets chart displays the number of packets dropped for the selected period in a vertical
bar chart. Hover over the graph to view the packets dropped at a particular time.

Figure 160 Dropped Packets

Actions
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TheActions drop-down list contains the following options (the Clear IPSec SA, and Clear ISAKMP SA options
are available for tunnels only):

n Reboot Gateway—Reboots the gateway. See Rebooting a Gateway

n Open Remote Console—Opens the remote console for a CLI session through SSH. The default user ID is
admin, but you can edit and customize the user ID. This customuser ID must bemapped to the device. See
Opening a Remote Console

n Clear IPSec SA—Clears the IPSec Security Associations (SA). See Clearing IPSec SA

n Clear ISAKMP SA—Clears the ISAKMP SA. See Clearing ISAKMP SA

Go Live
TheGo Live link redirects to theManage > WAN > Summary tab in the gateway dashboard. See theGo
Live section in theGateway > WAN > Summary page.

Gateway > Overview > Routing
TheRouting tab underManage > Overview in the gateway dashboard displays the following sections:

n Gateway > Overview > Routing > Route Table

n BGP Details > Neighbors

n Gateway > Overview > Routing > OSPF

n Gateway > Overview > Routing > Overlay

n Gateway > Overview > Routing > RIP

Viewing the Overview > Routing Tab
To navigate to theRouting tab in the gateway dashboard, complete the following steps:

1. In theNetwork Operations app, set the filter to one of the options underGroups, Labels, or
Sites. Ensure that the filter selection contains at least one gateway. For all devices, set the filter to
Global.

The dashboard context for the selected filter is displayed.

2. UnderManage > Devices, click theGateways tab.
A list of gateways is displayed in List view.

3. Click a gateway underDevice Name.
The dashboard context for the specific gateway is displayed.

4. UnderManage, click Overview > Routing .
To exit the gateway dashboard, click the back arrow on the filter.

You can change the time range for theRouting tab by clicking the time range filter and selecting
one of the available options: 3 hours, 1 day, 1 week, 1 month, and 3 months.

Gateway > Overview > Routing > Route Table
TheRoute Table tab underManage > Overview > Routing in the gateway dashboard displays the
following sections:

n Routes Summary

n Routes

Viewing the Overview > Routing > Routes Table Tab
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To navigate to theRoutes Table tab in the gateway dashboard, complete the following steps:

1. In theNetwork Operations app, set the filter to one of the options underGroups, Labels, or
Sites. Ensure that the filter selection contains at least one gateway. For all devices, set the filter to
Global.

The dashboard context for the selected filter is displayed.

2. UnderManage > Devices, click theGateways tab.
A list of gateways is displayed in List view.

3. Click a gateway underDevice Name.
The dashboard context for the specific gateway is displayed.

4. UnderManage, click Overview > Routing > Routes Table.
To exit the gateway dashboard, click the back arrow on the filter.

You can change the time range for theRoutes Table tab by clicking the time range filter and
selecting one of the available options: 3 hours, 1 day, 1 week, 1 month, and 3 months.

Routes Summary

n Capacity—Number of routes currently configured. Also displays themaximumnumber of allowed routes.

n Default—Number of default routes.

n Static—Number of static routes.

n Dynamic—Number of dynamic routes.

n Overlay—Number of overlay connections.

Figure 161 Routes Summary

Routes

n Last Refreshed—Indicates the time, in hr:mm:ss format, when the routes were last refreshed.

n Prefix—Controller prefix for the route.

n Length—Prefix length.

n Address—Destination IP address of the route.

n Route—The route IP address and subnet.

n Nexthop—The IP address of the next hop.

n Protocol—Routing protocol. Possible values are Unknown, Connected, Static, IKE, Overlay, BGP, OSPF,
BOC, RAPNG, RIP, VPN, Application and Default

n Type—The type of connection.

n Metric—Distance for static routes. For a given route destination, there can bemultiple next hops. A route
metric enables the gateway to prefer one route over another or load-balancewhen themetric is the same.

n Flags—Route flags that indicate the flags for the selected routes.
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Figure 162 Routes details

Click the settings icon to reset or set the default columns that are displayed.

Click the filter icon on each column header row to type in an applicable value, and then display the
corresponding row. For Protocol column you can select a value from the drop-down list.
Click the icon on on each column header row to arrange the data in ascending or descending order.
Click the refresh icon on the Routes table to refresh the table data.

Actions

TheActions drop-down list contains the following options (the Clear IPSec SA, and Clear ISAKMP SA options
are available for tunnels only):

n Reboot Gateway—Reboots the gateway. See Rebooting a Gateway

n Open Remote Console—Opens the remote console for a CLI session through SSH. The default user ID is
admin, but you can edit and customize the user ID. This customuser ID must bemapped to the device. See
Opening a Remote Console

n Clear IPSec SA—Clears the IPSec Security Associations (SA). See Clearing IPSec SA

n Clear ISAKMP SA—Clears the ISAKMP SA. See Clearing ISAKMP SA

Go Live

TheGo Live link redirects to theManage > WAN > Summary tab in the gateway dashboard. See theGo
Live section in theGateway > WAN > Summary page.

Gateway > Overview > Routing > BGP
TheBGP tab underManage > Overview > Routing in the gateway dashboard displays the following
sections:

n BGP Summary

n BGP Details

n BGP Details > Neighbors

n BGP Details > Routes

Viewing the Overview > Routing > BGP Tab

To navigate to theBGP tab in the gateway dashboard, complete the following steps:

1. In theNetwork Operations app, set the filter to one of the options underGroups, Labels, or Sites.
Ensure that the filter selection contains at least one gateway. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.

2. UnderManage > Devices, click theGateways tab.
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A list of gateways is displayed in List view.
3. Click a gateway underDevice Name.
The dashboard context for the specific gateway is displayed.

4. UnderManage, click Overview > Routing > BGP.
To exit the gateway dashboard, click the back arrow on the filter.

You can change the time range for theBGP tab by clicking the time range filter and selecting one of the
available options: 3 hours, 1 day, 1 week, 1 month, and 3 months.

BGP Summary

TheBGP Summary section displays the following information:

l Router ID—Displays the Router ID.

l AS Number—Displays the private Autonomous System (AS) number.

l Neighbors—Displays the number of neighboring connections.

l Routes Learned—Displays the number of routes that have been learned.

Figure 163 BGP—Summary

BGP Details

TheBGP Details section displays the information categorized by Neighbors and Routes.

BGP Details > Neighbors

l Total Neighbors—Displays the total number of neighbors.

l Last Refreshed—Indicates when the last refresh was completed.

l Neighbor—Displays the available neighbors.

l ASN—Displays the private Autonomous System (AS) number.

l State—Displays the current state.

l Type—Neighbor type.

l Last State Change—Displays the last state change.

l Down Count—Displays the number of neighbors that are down.

l Up Count—Displays the number of neighbors that are up.

l Hold Time—Displays the time spent on hold.

l Keep Alive Interval—Displays the time set for the Keep Alive Interval.

l Router ID—Displays the Router ID.

l Neighbor Version—Displays the firmware version of the connected neighbors.

l IP Precedence Value—Displays the IP precedence.

l Datagrams (Max = 1400Bytes)—Displays existing datagrams.

l Route Refresh—Displays the latest route refresh.

l Graceful Restart Capability—Displays whether graceful restart is supported.

l BGP Addtl-Paths Computation—Displays the additional paths computation.
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l Recv Paths—Displays the receive path information.

l Send Paths—Displays the send path information. Clicking the number of routes opens theRoutes
Advertised table which displays the routes advertised to that neighbor.

l Sent—Displays the number of routes sent.

l Received—Displays the number of routes received. Clicking the number of routes opens theRoutes
Learned table. This table displays a small red circle if the number of routes received has exceeded the
route limit and the corresponding action being taken on the routes (Drop orWarning) as configured
in the BGP configuration page.

l Recv Path Limit—Displays the Route Limit per neighbor configured in the BGP configuration page.

l Recv Path Action—Displays the action specified in the BGP configuration pagewhen the number of
routes exceeds the route limit.

l Source Address—Displays the source information.

l Nexthop—Displays information about the next hop.

l Link Address—Displays the link address.

l CFfg Hold Time—Displays theminimumacceptable hold time.

l CFfg Keep Alive Time—Displays the configuration keep alive time.

l IS Route Reflector—Displays the net hop path.

l IS Router Server—Displays the IS Router Server details.

l BGP Advertise-Best_External—Displays the backup external route.

l Up Time—Displays the time that the connection has been up.

Figure 164 BGP—Neighbors Details

Clear Neighbor Sessions
l TheClear button allows you to clear BGP neighbor sessions.
l Clear a neighbor session: To clear a specific neighbor session, use theClear button available for

that particular neighbor row.

l Clear all neighbor sessions: To clear all neighbor sessions, use theClear button available on the
table header.
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Figure 165 BGP—Clear Neighbors

BGP Details > Routes

l Total Routes—Displays the total number of routes.

l Last Refreshed—Indicates when the last refresh was completed.

l Network—Connected network.

l Neighbor—Displays the available neighbors.

l Nexthop—Displays information about the next hop.

l Metric—Distance for static routes. For a given route destination, there can bemultiple next hops. A
routemetric enables the gateway to prefer one route over another or load-balancewhen themetric is
the same.

l Local Pref—Displays the outbound external path.

l AS Path—Displays the private Autonomous Systempath.

l State—Displays the connection state of the connection.

l Route Source—Displays the specific route the packet should take.

l Origin—Displays the origin attribute value.

l Advertised to Upd-Grp—Displays the Advertised Update-Group status.

l Router ID—Displays the router ID.

Figure 166 BGP—Routes Details
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Actions

TheActions drop-down list contains the following options (the Clear IPSec SA, and Clear ISAKMP SA options
are available for tunnels only):

n Reboot Gateway—Reboots the gateway. See Rebooting a Gateway

n Open Remote Console—Opens the remote console for a CLI session through SSH. The default user ID is
admin, but you can edit and customize the user ID. This customuser ID must bemapped to the device. See
Opening a Remote Console

n Clear IPSec SA—Clears the IPSec Security Associations (SA). See Clearing IPSec SA

n Clear ISAKMP SA—Clears the ISAKMP SA. See Clearing ISAKMP SA

Gateway > Overview > Routing > OSPF
TheOSPF tab underManage > Overview > Routing in the gateway dashboard displays the following
sections:

n OSPF Summary

n OSPF Details

Viewing the Overview > Routing > OSPF Tab

To navigate to theOSPF tab in the gateway dashboard, complete the following steps:

1. In theNetwork Operations app, set the filter to one of the options underGroups, Labels, or
Sites. Ensure that the filter selection contains at least one gateway. For all devices, set the filter to
Global.

The dashboard context for the selected filter is displayed.

2. UnderManage > Devices, click theGateways tab.
A list of gateways is displayed in List view.

3. Click a gateway underDevice Name.
The dashboard context for the specific gateway is displayed.

4. UnderManage, click Overview > Routing > OSPF.
To exit the gateway dashboard, click the back arrow on the filter.

You can change the time range for theOSPF tab by clicking the time range filter and selecting one
of the available options: 3 hours, 1 day, 1 week, 1 month, and 3 months.

OSPF Summary

n Status—Status is either Enabled or Disabled.

n Router ID—The routers identification details.

n Areas—Area type as specified in theOSPF parameters.

n Interfaces—Displays the current interface.

n Neighbors—Displays the number of neighbors available.

n Active LSA—Displays the Active Link-State Advertisements.

n Retransmit LSA—Displays the Retransmitted Link-State Advertisements.
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Figure 167 OSPF—Summary

OSPF Details

Displays the information categorized by Neighbors, Interfaces,Areas, and Link State Databases.

n Neighbors
o Total Neighbors—The total number of neighbors.
o Last Refreshed—Indicates when the last refresh was completed.
o Neighbor—Details of the neighbors.
o Address—IP address of the neighbor.
o Interface—Displays the current interface for the neighbor.
o Priority—Displays the priority of each neighbor.
o State—Displays the state of the connection.
o Area—Displays the area of the neighbor.
o Options—Available neighbor options.
o Dead Timer—Displays the required time to wait before the neighbor connection is dead.
o Retransmit Timer—Displays the time between OSPF and LSA retransmissions.

Figure 168 OSPF—Neighbor details

n Interfaces
o Total Interfaces—The total number of interfaces.
o Last Refreshed—Indicates when the last refresh was completed.
o Name—Nameof the interface.
o Area—Displays the logical collection of devices that share the same area.
o Address—IP address of the interface.
o Mask—IP mask of the interface.
o State—Displays the state of the connection.
o Type—Displays the type of connection.
o Cost—Displays the cost associated with theOSPF traffic on the tunnel interface.
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o Neighbor Count —Displays the number of neighbors.
o ID—Displays the interface ID.
o Address—Displays the IP address of the interface.
o Priority—Displays the priority of the interface to determine the default router.
o Hello Timer—Displays the time interval between the hello packets to be sent on the interface.
o Dead Timer—Displays the time interval after which a router is declared dead if hello packets are not

received.
o Retransmit Timer —Displays the retransmit interval time for link state advertisements.
o Authentication—Displays the status of this option that is used for enabling OSPF authenticationmode

forMD5.

Click on an interface listed in the table to view the following details:
o Type—Displays the type of connection.
o Area—Displays the logical collection of devices that share the same area.
o Address—IP address of the interface.
o Mask—IP mask of the interface.
o Cost—Displays the cost associated with theOSPF traffic on the tunnel interface.
o State—Displays the state of the connection.
o Priority—Displays the priority of the interface to determine the default router.
o Neighbor Count—Displays the number of neighbors.
o Dead Timer—Displays the time interval after which a router is declared dead if hello packets are not

received.
o Hello Timer—Displays the time interval between the hello packets to be sent on the interface.
o Retransmit Timer—Displays the retransmit interval time for link state advertisements.
o Authentication—Displays the status of this option that is used for enabling OSPF authenticationmode

forMD5.

Figure 169 OSPF— Interfaces details

n Areas

Click the Settings icon to reset or set the default columns that are displayed.

o Total Areas—The total number of areas.
o Last Refreshed—Indicates when the last refresh was completed.
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o Area—Displays the logical collection of devices that share the same area.
o Type—Displays the type of connection.
o Interface count—Displays the interface count.
o SPF Count—Displays the Shortest Path First count.
o Enable Summary—Displays if summary collection is enabled.

Figure 170 OSPF— Areas details

n Link State Databases

Click the Settings icon to reset or set the default columns that are displayed.

o Total Link State Database—The total number of Link State Databases.
o Last Refreshed—Indicates when the last refresh was completed.
o Link ID—Displays the router ID of the originating router.
o Advertising Router—Displays the routes that is advertising the link-state.
o Area—Displays the logical collection of devices that share the same area.
o LSA Type—Displays the aggregation type.
o Age—Displays the age of theOSPF LSA.
o State—Displays the state of the connection.
o Seq No.—Displays the 32-bit OSPF Sequence number.
o Checksum—Displays the 16-bit checksum for theOSPF packet.

Figure 171 OSPF—Link State Databases details

n LSA types—There are various LSA types available and they are listed here:
o Router—The Router page displays the following details:

l Flags

l Link ID

l Link Data
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l Link Type

l Metric
o Network—TheNetwork page displays the following details:

l Mask

l Attached router
o Network Summary—TheNetwork Summary page displays the following details:

l Address

l Mask

l Metric
o ASBR Summary—The ASBR Summary page displays the following details:

l ASBR

l Metric
o External—The External page displays the following details:

l Mask

l Metric

l Type

l Route Tag

l Forwarding Address

Actions

TheActions drop-down list contains the following options (the Clear IPSec SA, and Clear ISAKMP SA options
are available for tunnels only):

n Reboot Gateway—Reboots the gateway. See Rebooting a Gateway

n Open Remote Console—Opens the remote console for a CLI session through SSH. The default user ID is
admin, but you can edit and customize the user ID. This customuser ID must bemapped to the device. See
Opening a Remote Console

n Clear IPSec SA—Clears the IPSec Security Associations (SA). See Clearing IPSec SA

n Clear ISAKMP SA—Clears the ISAKMP SA. See Clearing ISAKMP SA

Go Live

TheGo Live link redirects to theManage > WAN > Summary tab in the gateway dashboard. See theGo
Live section in theGateway > WAN > Summary page.

Gateway > Overview > Routing > Overlay
TheOverlay tab underManage > Overview > Routing in the gateway dashboard displays the following
sections:

n Overlay Summary

n Overlay Details

Viewing the Overview > Routing > Overlay Tab

To navigate to theOverlay tab in the gateway dashboard, complete the following steps:

1. In theNetwork Operations app, set the filter to one of the options underGroups, Labels, or Sites.
Ensure that the filter selection contains at least one gateway. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.
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2. UnderManage > Devices, click theGateways tab.
A list of gateways is displayed in List view.
3. Click a gateway underDevice Name.
The dashboard context for the specific gateway is displayed.

4. UnderManage, click Overview > Routing > Overlay.
To exit the gateway dashboard, click the back arrow on the filter.

You can change the time range for theOverlay tab by clicking the time range filter and selecting one of
the available options: 3 hours, 1 day, 1 week, 1 month, and 3 months.

Click the Settings icon to reset or set the default columns that are displayed.

Click the filter icon on each column header row to filter the displayed information

Overlay Summary

l Status—Status is either Enabled or Disabled.

l Site—Displays the site location.

l Control Connections—Displays the number of active control connections.

l Interfaces—Displays the number of active interfaces.

l Routes Advertised—Displays the number of routes that are advertised.

l Routes Learned—Displays the number of routes that are learned.

Figure 172 Overlay—Summary

Overlay Details

n Displays the information categorized by Control Connections, Interfaces, Routes Advertised, and
Routes Learned.

n Control Connections

Click the Settings icon to reset or set the default columns that are displayed.

Click the filter icon on each column header row to filter the displayed information

l Total Control Connections—Displays the total number of control connections.

l Last Refreshed—Indicates when the last refresh was completed.
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l Control Plane Peers—Displays the Control Plane Peers.

l State—Displays the state of the connection.

l Last State Change—Indicates the Last State Change.

l Down Count—Displays theDown Count.

l Routes Advertised—Displays the advertised routes.

l Routes Learned—Displays the number of routes that are learned.

Figure 173 Overlay Details —Control Connections

n Interfaces

Click the Settings icon to reset or set the default columns that are displayed.

Click the filter icon on each column header row to filter the displayed information

l Total Interfaces—Displays the total number of interfaces.

l Last Refreshed—Indicates when the last refresh was completed.

l Interfaces—Displays the number of active interfaces.

l State—Displays the state of the interface.

l Tunnel Destination—Displays the destination address.

l Uptime—Amount of time the tunnel has been active since it was last reset.

l Routes Learned—Displays the number of routes that are learned.

Figure 174 Overlay Details —Interfaces

n Routes Advertised

Click the Settings icon to reset or set the default columns that are displayed.

Click the filter icon on each column header row to filter the displayed information.

l Route—Displays the route name.

l Nexthop—Displays information about the next hop.

l Interface—Displays the number of active interfaces.

l Flags—Lists the number of active flags.

l Origin—Origin of the route.

l Cost—Cost associated with the route.
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Figure 175 Overlay Details—Routes Advertised

n Routes Learned
l Total Routes Learned—Displays the total number of routes that are learned.

l Last Refreshed—Indicates when the last refresh was completed.

l Route—The route IP address aand subnet.

l Age (Last Updated)—Last updated date.

l Origin—Orging of the connection, for example, Connected or Overlay.

l Flags—Lists the number of active flags.

l Nexthop—Displays information about the next hop.

l Interface—Displays the number of active interfaces.

Figure 176 Overlay Details—Routes Learned

Actions

TheActions drop-down list contains the following options (the Clear IPSec SA, and Clear ISAKMP SA options
are available for tunnels only):

n Reboot Gateway—Reboots the gateway. See Rebooting a Gateway

n Open Remote Console—Opens the remote console for a CLI session through SSH. The default user ID is
admin, but you can edit and customize the user ID. This customuser ID must bemapped to the device. See
Opening a Remote Console

n Clear IPSec SA—Clears the IPSec Security Associations (SA). See Clearing IPSec SA

n Clear ISAKMP SA—Clears the ISAKMP SA. See Clearing ISAKMP SA

Go Live

TheGo Live link redirects to theManage > WAN > Summary tab in the gateway dashboard. See theGo
Live section in theGateway > WAN > Summary page.

Gateway > Overview > Routing > RIP
TheRIP tab underManage > Overview > Routing in the gateway dashboard displays the following
sections:
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n RIP Summary

n RIP Details

Viewing the Overview > Routing > RIP Tab

To navigate to theRIP tab in the gateway dashboard, complete the following steps:

1. In theNetwork Operations app, set the filter to one of the options underGroups, Labels, or
Sites. Ensure that the filter selection contains at least one gateway. For all devices, set the filter to
Global.

The dashboard context for the selected filter is displayed.

1. UnderManage > Devices, click theGateways tab.
A list of gateways is displayed in List view.

2. Click a gateway underDevice Name.
The dashboard context for the specific gateway is displayed.

3. UnderManage, click Overview > Routing > RIP.
To exit the gateway dashboard, click the back arrow on the filter.

You can change the time range for theRIP tab by clicking the time range filter and selecting one of
the available options: 3 hours, 1 day, 1 week, 1 month, and 3 months.

RIP Summary

TheRIP Summary section displays the following information:

n Enabled—Implies that RIPv2 is enabled on the gateway device.

n Version—Displays the RIP version, RIPv1 or RIPv2. Currently, Arubasupports only RIPv2.

n Interfaces—Displays the number of interfaces that participates in the routing process.

n Neighbors—Displays the number of neighboring connections.

n Routes—Displays the number of routes advertised.

n ECMP—Displays the number of ECMPs available.

n Infinity—The hop count (16) assigned to unreachable devices (typically, any route that requiresmore than
15 hops).

n Timers—RIP uses timers to regulate its performance:
o Update timer displays the interval between periodic routing updates. By default this is set to 30

seconds.
o Invalid timer displays the time in seconds after which the route ismarked invalid but is still available in

the table. By default this is set to 180 seconds.
o Flush timer displays the time duration after which the route is flushed out or removed from the table.

By default this is set to 120 seconds.

Figure 177 RIP—Summary

RIP Details
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Displays the information categorized by Interfaces,Neighbors, and Routes.

n Interfaces
o Name—Displays the name of the interface.
o Address—Displays the IP Address of the interface.
o Cost—Displays the cost associated.
o State—Displays the state of the connection (Up pr Down).
o Neighbors—Displays the number of neighbors.
o Authentication—Displays the status of this option that is used for enabling RIP authenticationmode

forMD5.
o Next Update—Time in seconds for the next update

Click on an interface listed in the table to view the following details:
o RIP Interface—Displays the name of the interface.
o Address—Displays the IP Address of the interface.
o Mask—Displays the subnet mask.
o State—Displays the state of the connection (Up or Down).
o Port—Displays the port number of the interface.
o Version—Displays the RIP protocol version.
o Mode—Displays the interface configurationmode.
o Metric—Displays the number of hop counts.
o Passive—Indicates whether the interface is operating in passivemode.
o Split Horizon—Indicates whether Split Horizon is implemented.
o Poison Reverse—Indicates whether Poison Reverse is implemented.
o Authentication—Displays the status of this option that is used for enabling RIP authenticationmode

forMD5.
o Update Timer—Displays the interval between periodic routing updates, by default this is set to 30

seconds.
o Invalid Timer—Displays the time in seconds after which the route ismarked invalid but is still available

in the table.
o Flush Timer—Displays the time duration after which the route is flushed out or removed from the

table.
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Figure 178 RIP—Interfaces Details

n Neighbors
o Address—Displays the IP address of the neighbor.
o Interface—Displays the name of the interface.
o Metric—Displays the number of hop counts.
o Routes—Displays the number of routes learned. Click the number for details of the routes learned.
o Last Seen—Displays the last seen time duration in nD nH nM nS format.

Figure 179 RIP—Neighbors Details

n Routes
o Route—Displays the route.
o Next Hop—Displays information about the next hop.
o Metric—Displays the number of hop counts.
o Tag—Displays the tag number associated with the route attribute that is set.
o Expires—Displays the time in nD nH nM nS format after which the route expires.
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Figure 180 RIP—Routes Details

Actions

TheActions drop-down list contains the following options (the Clear IPSec SA, and Clear ISAKMP SA options
are available for tunnels only):

n Reboot Gateway—Reboots the gateway. See Rebooting a Gateway

n Open Remote Console—Opens the remote console for a CLI session through SSH. The default user ID is
admin, but you can edit and customize the user ID. This customuser ID must bemapped to the device. See
Opening a Remote Console

n Clear IPSec SA—Clears the IPSec Security Associations (SA). See Clearing IPSec SA

n Clear ISAKMP SA—Clears the ISAKMP SA. See Clearing ISAKMP SA

Go Live

TheGo Live link redirects to theManage > WAN > Summary tab in the gateway dashboard. See theGo
Live section in theGateway > WAN > Summary page.

Gateway Details - Overview Tab
After you onboard and configure the gateways, you can view the branch health, monitor theWAN uplink,
and view gateway performance from theGateways page.
To view theGateway Overview page, complete the following steps:

1. In theNetwork Operations app, use the filter to select a Branch Gateway

2. UnderManage, click Overview > Summary. TheGateway Details page is displayed. .

TheOverview dashboard provides gateway device details, WAN availability and performance information,
and the list of top applications. TheOverview tab displays the following details:

Device Info

Displays the gateway device details.
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Figure 181 Device Info

Device Info section displays the following details:

n Name—The name of the gateway.

n Serial Number—The serial number of the gateway.

n Model—The hardwaremodel of the gateway.

n MAC Address—TheMAC address of the gateway.

n System IP address—The IP address of the gateway.

n Firmware Version—The firmware version running on the gateway.

n Group Name—The name of the group to which the gateway belongs.

n Labels—The labels attached to the gateway.

n Site—The site name of the gateway location.

n POE (DRAW/MAX)—The amount of power that the devices connected to the Branch Gateway consume
and themaximumPoE power capacity. For example, if the value displayed is 6/120, the devices draw 6
watts and themaximumPoE power allocated is 120 watts.

n Redundancy Peer—Displays the redundant gateway. Click the link to view the redundant gateway details.
See the Setting up Redundant Gateways for High Availability section in the Aruba Central Help Center.

n 4G/LTE Modem Type—Displays the LTE connection type.

n 4G/LTE Modem Status—Displays themodem connectivity status. A green check-mark icon indicates
that the connection is successful. This field also displays the name of the service provider and the signal

strength. Hover over the information icon to view details about the active SIM, the IMEI number, and
the phone number. You can view the signal strength classification based on the RSSI value provided in the
following table:

SIGNAL STRENGTH VALUE REPRESENTATION

Good > –65 dBm All four bars are shaded green

Average > –80 dBm From the left, first 2 or 3 bars are shaded
green

Poor <–80 dBm From the left, only one bar is shaded green

n NTP Server—The name of theNTP server configured.

n Config Sync Status—The status of the configuration sync.

n Last Reboot Reason—The reason for the last reboot.
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n Internal Modem Status (Only for Gateway model: 9004-LTE)—Displays the name of the service provider

and the signal strength. Hover over the information icon to view details about the active SIM, the IMEI
number and the phone number. You can view the signal strength classification based on RSSI value, in the
following table:

WAN Summary

Displays overview information about WAN and VPN.

WAN Availability

Provides a graphical representation of the Branch Gateway'sWAN uplink availability. The graph displays
eachWAN uplink availability for the selected time range. Availability is determined by default gateway,
monitored IP, and data VPN Concentrator reachability.

VPN Availability

Provides a graphical representation of the Branch Gateway's tunnel availability. Availability is determined by
the probe settings configured using theHealth Check option.

Usage

Displays the Branch Gateway's aggregate inbound and outbound traffic usage by WAN interface. Select one
of the following options from the drop-down list:

n All
n Internet
n VPN

Throughput

Provides a graphical representation of the selectedWAN interface's throughput. The graph displays the
WAN interface's transmit and receive performance in Kbps. The graph also displays information that is sent
and received.

Compression

Displays the aggregateWAN compression details across all uplinks. The average bandwidth savings is
displayed as a percentage. The compressed and uncompressed bandwidth is displayed as vertical grouped
bar graphs. Formore information about the process to enable data compression, see the Configuring Uplink
Interfaces section in the Aruba Central Help Center.
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Health Status

Displays the health of the gateway in terms of CPU andmemory usage.

Figure 182 Health Status

Gateway > Overview > AI Insights
In the gateway dashboard, theAI Insights tab displays information on gateway performance issues such as
tunnel up, tunnel down, airtime utilization, andmemory utilization.

Viewing Gateways > AI Insights
To navigate to theAI Insights tab in the gateway dashboard, complete the following steps:

1. In theNetwork Operations app, set the filter to one of the options underGroup, Label, or Site.
For all devices, set the filter to Global. Ensure that the filter selected contains at least one active
gateway.

The dashboard context for the selected filter is displayed.

2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click a gateway listed underDevice Name.
The dashboard context for the gateway is displayed.

4. In the gateway dashboard context, click theAI Insights tab.
The Insights page is displayed.
To exit the gateway dashboard, click the back arrow on the filter.

You can change the time range for theAI Insights tab by clicking the time range filter and
selecting one of the available options: 3 hours, 1 day, 1 week, 1 month, and 3 months.

AI Insights are displayed for the time range selected. Select the time range from the Time Range
Filter ( ) to filter reports.

AI Insights Categories
AI Insights are categorized in high, medium, and low priorities depending on the number of occurrences.

n Red—High priority

n Orange—Mediumpriority

n Yellow—Low priority
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AI Insights listed in the dashboard are sorted fromhigh priority to low priority. TheAI Insights dashboard
displays a report of network events that could possibly affect the quality of the overall network
performance. Each insight report provides specific details on the occurrences of these events for ease in
debugging.

Gateway > WAN > Summary
The Summary tab underManage > WAN page in the gateway dashboard displays the following sections:

n Port Status

n WAN Interfaces

n Go Live

You can view andmonitor yourWAN interfaces, the tunnels configured, and the path steering data for all
the DPS policies configured.

Viewing the WAN > Summary Tab
To navigate to theWAN > Summary tab in the gateway dashboard, complete the following steps:

1. In theNetwork Operations app, set the filter to one of the options underGroups, Labels, or
Sites. Ensure that the filter selection contains at least one gateway. For all devices, set the filter to
Global.

The dashboard context for the selected filter is displayed.

2. UnderManage > Devices, click theGateways tab.
A list of gateways is displayed in List view.

3. Click a gateway underDevice Name.
The dashboard context for the specific gateway is displayed.

4. UnderManage, click WAN > Summary.
To exit the gateway dashboard, click the back arrow on the filter.

You can change the time range for the Summary tab by clicking the time range filter and selecting
one of the available options: 3 hours, 1 day, 1 week, 1 month, and 3 months.

Port Status

n Displays theWAN port status. Click aWAN port formore details.

Figure 183 Port Status

For a 9004-LTE Branch Gateway, the Port Status displays the LTE uplink details and when you hover over
Internal LTE, you can view details about the active SIM, the name of the service provider, and the signal
strength.
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Figure 184 Port Status of a 9004-LTE Gateway

You can click on the active SIM to view the port details of cellular.

Figure 185 Port Details

WAN Interfaces

n Lists theWAN interfaces and provides the total number of WAN interfaces. Displays the summary of WAN
uplinks. The following details are displayed for the port:

Click the Settings icon to reset or set the default columns that are displayed.
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o Total WAN Interfaces—Total number of WAN interfaces available.
o Name—Nameof theWAN interface.
o Port—Port number along with the associated VLAN ID.
o WAN Status—WAN reachability status.
o VPN Status—VPNC reachability status.
o Usage—WAN interface usage (Sent and Received).
o Throughput—WAN interface transmit and receive performance in Kbps.
o Loss—Loss percentage.
o Latency—The latency inmilliseconds.

In theWAN Interfaces table, click a port number to display the Packets and Errors details.

Figure 186 WAN Interfaces Packets and Errors

n The following graphs are displayed under the Packets tab:
o Unicast—The number of unicast packets per second.
o Multicast—The number of multicast packets per second.
o Broadcast—The number of broadcast packets per second.

n The following graphs are displayed under the Errors tab:
o CRC Errors—The number of cyclic redundancy errors logged.
o Error Frames—The number of error frames logged.
o Collisions—The number of collisions encountered.

n Additional Parameters—In theWAN Interfaces table, hover on theWAN interface name to view the
additional parameter for theWAN interface.
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Figure 187 Additional Parameters

The following additional parameters are displayed for theWAN interface:
o Uptime—Uptime of the uplink (DD-HH-MM).
o Default Gateway—Default gateway.
o Speed/Duplex—Port speed.
o Type—Service provider uplink type (Physical / Virtual).
o Private IP—Private IP address.
o WAN Backup—Backup of WAN interface (Enabled or Disabled).

n WAN Availability—Provides an overall graphical representation of the selected interface'sWAN
availability based on reachability. The graph shows the selectedWAN port's ability to reach its default
gateway and health check IP.

n VPN Availability—Provides an overall graphical representation of the selected interface's VPN availability
based on reachability.

n Usage—Displays the inbound and outbound traffic usage.

n WAN Compression—Displays theWAN compression details. The average bandwidth savings is displayed
as a percentage.

n Usage—Provides a snapshot of theWAN usage and is available forAll Traffic, Internet, and VPN specific
information. The graphs also display information that is sent and received and total usage.

n Throughput—Provides a graphical representation of the selectedWAN interface's throughput. The graph
displays theWAN interface's transmit and receive performance in bps.

n Performance—The Performance section displays theMOS score of interface and the following graphs
based on the probe that is selected. For a health check probe, only Latency and Packet Loss graphs are
displayed.
o Latency—The latency inmilliseconds.
o Packet Loss—Displays the packet loss in percentage.
o Jitter—Displays the jitter in milliseconds.
o MOS Score—Displays theMOS score.

n WAN Compression—Provides bandwidth savings of WAN compression uplink, along with optimized and
non optimized packets and the average bandwidth saved in percentage.
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Figure 188 WAN Interfaces Availability

LiveMonitoring for Device State is enabled for Status Header Tile, Port Status and WAN Interfaces.

Figure 189 WAN_Live Monitoring

Actions
TheActions drop-down list contains the following options (the Clear IPSec SA, and Clear ISAKMP SA options
are available for tunnels only):

n Reboot Gateway—Reboots the gateway. See Rebooting a Gateway

n Open Remote Console—Opens the remote console for a CLI session through SSH. The default user ID is
admin, but you can edit and customize the user ID. This customuser ID must bemapped to the device. See
Opening a Remote Console

n Clear IPSec SA—Clears the IPSec Security Associations (SA). See Clearing IPSec SA

n Clear ISAKMP SA—Clears the ISAKMP SA. See Clearing ISAKMP SA

Go Live
TheGo Live option allows you to view theWAN interface data in real-time. The details about individual
WAN interfaces are updated every fiveminutes in the normalWAN page view, whereas the details displayed
in Livemode are updated every five seconds. This feature allows you to compare the statistics of twoWAN
interfaces. By default, the first two are displayed. You can select the uplinks for which you want to view the
data. This feature is especially useful to troubleshoot issues.
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TheDownstream graph displays data on download speed and theUpstream graph provides data on
upload speed. The X-axis in the graph indicates the time and the Y-axis indicates the throughput in Bytes per
second (bps).

The Live session is active for 15 minutes and automatically returns to normal view at the end of 15 minutes.
A timer displays the number of minutes since the live session started.

To view the live statistics of theWAN interfaces, click theGO LIVE button. To go back to normal view, click
the STOP LIVE button.

Figure 190 GO LIVE page

Gateway > WAN > Tunnels
The Tunnels tab underManage > WAN page in the gateway dashboard displays the following sections:

n Tunnels Summary

n Tunnels

n Tunnel Info

The Tunnels tab displays the status and health details for Branch Gateway tunnels and IAP-VPN tunnel.

Viewing the WAN > Tunnels Tab
To navigate to the Tunnels tab in the gateway dashboard, complete the following steps:

1. In theNetwork Operations app, set the filter to one of the options underGroups, Labels, or
Sites. Ensure that the filter selection contains at least one gateway. For all devices, set the filter to
Global.

The dashboard context for the selected filter is displayed.

2. UnderManage > Devices, click theGateways tab.
A list of gateways is displayed in List view.

3. Click a gateway underDevice Name.
The dashboard context for the specific gateway is displayed.

4. UnderManage, click WAN > Tunnels.
To exit the gateway dashboard, click the back arrow on the filter.
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You can change the time range for the Tunnels tab by clicking the time range filter and selecting
one of the available options: 3 hours, 1 day, 1 week, 1 month, and 3 months.

Tunnels Summary
The following details are displayed in the Tunnels Summary table:

n Total—Total number of VPN tunnels.

n Up—Number of VPN tunnels in UP state.

n Down—Number of VPN tunnels in DOWN state.

n Peers—Total number of VPN peers.

n Orchestrated—Total number of VPN tunnels running in orchestratedmode.

Figure 191 Tunnels Summary

Tunnels
The following details are displayed in the Tunnels table:

n Name—Tunnel name.

n Status—Status of the tunnel (Up or Down).

n Mode—Displays the type of tunnel. The tunnel configurations displayed are:
o Orch—Identifies tunnels that have been orchestrated.
o Orch-Srv—Identifies the orchestrated tunnels that are in survivability state.
o Orch-IKE—Orchestrated tunnels which use the Internet Key Exchange (IKE) protocol to set up a security

association (SA) in the IPsec protocol suite with 3rd party devices such as Zscaler.
o IKE—Identifies tunnels createdmanually using the IKE protocol.

n Source—Source IP address of the tunnel.

n Destination—Destination IP address of the tunnel.

n Loss—Percentage of packet loss.

n Latency—The latency inmicroseconds.

n Last Change Reason—Reason for the last status change of the tunnel.

n Availability—Availability graph of the tunnel. Displays the percentage of time the tunnel was in UP state.

The default view of gateways table shows only a few columns. To view the hidden columns, click the
settings icon at the right side of the table. To reset the columns, click Reset to default.
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Figure 192 Tunnels Details

Tunnel Info

n Expand a tunnel name to view the following details:
o Uptime—Amount of time the tunnel has been active since it was last reset.
o Link—Tunnel link.
o WAN IP—WAN IP address.
o Uplink Port—Uplink port details.
o Last Change Reason—Reason for the last status change of the tunnel.
o Peer IP—Peer IP address.
o VLAN—VLAN ID.
o Source MAC—SourceMAC address.
o Next Rekey—Next Rekey time.
o Auth—Authenticationmethods such as SHA1, DES, and 3DES.
o In SPI—Inbound Security Parameter Index (SPI).
o Out SPI—Outbound Security Parameter Index (SPI).
o Encryption—Encryption.

n Availability—Availability information of the tunnel.
o Tunnel Status—Provides an overall graphical representation of the selected tunnel's availability based

on VPNC reachability.
o Usage—Displays the tunnel's traffic usage.
o Throughput—Displays the inbound and outbound traffic rates for the selected tunnel. The graph

displays the tunnel's performance in Kbps. The graph also displays information that is sent and received.
o Performance—The Performance section displays the details based on the interface that is selected.

Livemonitoring is enabled for sections that display the status, such as:

n The Tunnels Summary
n Status of the Tunnels Details

Actions
TheActions drop-down list contains the following options (the Clear IPSec SA, and Clear ISAKMP SA options
are available for tunnels only):
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n Reboot Gateway—Reboots the gateway. See Rebooting a Gateway

n Open Remote Console—Opens the remote console for a CLI session through SSH. The default user ID is
admin, but you can edit and customize the user ID. This customuser ID must bemapped to the device. See
Opening a Remote Console

n Clear IPSec SA—Clears the IPSec Security Associations (SA). See Clearing IPSec SA

n Clear ISAKMP SA—Clears the ISAKMP SA. See Clearing ISAKMP SA

Go Live
TheGo Live link redirects to theManage > WAN > Summary tab in the gateway dashboard. See theGo
Live section in theGateway > WAN > Summary page.

n Utilization—Displays the utilization in percentage terms. The average, minimum, andmaximumpacket
utilization is displayed.

n SLA Policy Compliance—Displays the following details:

Gateway > WAN > Path Steering
In the Path Steering tab, you can view traffic path steering details for the Dynamic Path Steering policies
configured on the Branch Gateway. This tab also displays the number of policies that are compliant along
with the total number of policies configured on the Branch Gateway.

From the list of Dynamic Path Steering polices, select the policy for which you want to view the path steering
details.

The Pathsteering tab underManage > WAN page in the gateway dashboard displays the following
sections:

n Path Steering Summary

n Path Steering Details

Viewing the WAN > Path Steering Tab
To navigate to the Path Steering tab in the gateway dashboard, complete the following steps:

1. In theNetwork Operations app, set the filter to one of the options underGroups, Labels, or
Sites. Ensure that the filter selection contains at least one gateway. For all devices, set the filter to
Global.

The dashboard context for the selected filter is displayed.

2. UnderManage > Devices, click theGateways tab.
A list of gateways is displayed in List view.

3. Click a gateway underDevice Name.
The dashboard context for the specific gateway is displayed.

4. UnderManage, click WAN > Path Steering.
To exit the gateway dashboard, click the back arrow on the filter.

You can change the time range for the Path Steering tab by clicking the time range filter and
selecting one of the available options: 3 hours, 1 day, 1 week, 1 month, and 3 months.

Path Steering Summary
Displays the following information.
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n State—Displays whether the path steering feature is enabled.

n Policy Compliance—Displays the compliance status of all the configured policies.

Figure 193 Path Steering Summary

Path Steering Details
Displays the following information.

n Status—Provides a graphical representation of the configured uplink statuses. The following details are
displayed:
o Overall status
o The status of each of the uplinks configured for theDynamic Path Steering policy on that gateway

Hover over the status bar to view the compliance status details of all the configured uplinks. You can
view the compliance status of the uplinks and the probe IPs. If the probe IPs are non-compliant, it
displays the reason for non-compliance such as latency, jitter, or packet loss. The following list contains
the various colors and the corresponding compliance status:

o Green—An uplink is Compliant when all of the associated probe IPsmeet the set SLAs and threshold
settings.

o Orange—An uplink is Partially Compliant when you havemultiple probe IPs and not all of them are
compliant.

o Red—An uplink isNon-Compliant when all of the probe IPs are non-compliant.
o Yellow—This is theHold Periodwhen an uplink changes it's status fromNon-compliant to Compliant

(usually the first 3 minutes of the transition phase).
o Grey—Uplink status isUnknown when theDynamic Path Steering feature does not send any

compliance information to the cloud.

n Sessions—Provides a graphical representation of the total number of sessions. The following details are
displayed:
o Overview
o The sessions count on each of the uplinks configured for theDynamic Path Steering policy on that

gateway



Aruba SD-WAN Solution | User Guide 496

Figure 194 Path Steering Details—Compliance Summary

n Event Logs—When an uplink becomes non-compliant, an event is recorded. When the same uplink
becomes compliant adhering to the set SLAs, another event is recorded. The Event Logs table provides
information about all such events. It displays the timestamp and a detailed event statement that contains
the policy name, the uplink name, the probe IP, and the reason for non-compliance, if it is a non-compliance
event.

Figure 195 Event Logs

Livemonitoring is enabled for sections that display status, such as:

n Thepath Steering Summary
n Real time state of the Event Logs
n Path Steering Summary—Path steering summary of the primary, secondary, and standby uplinks. The

following details are displayed for each uplink:

n Path Steering Details—Displays the following path steering details:

n Traffic Path—Displays traffic path steering status for each link associated with theWAN policy. The
following details are also displayed:

n Status—Provides a graphical representation of the status of uplinks. The following details are displayed:

n MPLS (Primary)
n Comcast (Secondary)
n LTE (Standby)
n Traffic Steer—Displays the following graphs:

n Traffic Classification—Displays charts showing client traffic trends to application, application categories,
website categories, and websites of a specific security reputation score. The Traffic Classification section
also shows application with the highest security threat score. To view the traffic classification based on
application, application category, and website category, youmust enableDeep Packet Inspection on the
Branch Gateways.

Actions
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TheActions drop-down list contains the following options (the Clear IPSec SA, and Clear ISAKMP SA options
are available for tunnels only):

n Reboot Gateway—Reboots the gateway. See Rebooting a Gateway

n Open Remote Console—Opens the remote console for a CLI session through SSH. The default user ID is
admin, but you can edit and customize the user ID. This customuser ID must bemapped to the device. See
Opening a Remote Console

n Clear IPSec SA—Clears the IPSec Security Associations (SA). See Clearing IPSec SA

n Clear ISAKMP SA—Clears the ISAKMP SA. See Clearing ISAKMP SA

Go Live
TheGo Live link redirects to theManage > WAN > Summary tab in the gateway dashboard. See theGo
Live section in theGateway > WAN > Summary page.

Gateway > LAN > Summary
The Summary tab underManage > LAN page in the gateway dashboard displays the following sections:

Port Status

LAN Interfaces Summary

VLAN Interfaces Summary

Viewing the LAN > Summary Tab
To navigate to theWAN > Summary tab in the gateway dashboard, complete the following steps:

1. In theNetwork Operations app, set the filter to one of the options underGroups, Labels, or
Sites. Ensure that the filter selection contains at least one gateway. For all devices, set the filter to
Global.

The dashboard context for the selected filter is displayed.

2. UnderManage > Devices, click theGateways tab.
A list of gateways is displayed in List view.

3. Click a gateway underDevice Name.
The dashboard context for the specific gateway is displayed.

4. UnderManage, click LAN > Summary.
To exit the gateway dashboard, click the back arrow on the filter.

You can change the time range for the Summary tab by clicking the time range filter and selecting
one of the available options: 3 hours, 1 day, 1 week, 1 month, and 3 months.

Port Status

n Provides a graphical representation of the Branch Gateway's LAN link availability. Also provides a quick
view of the LAN port status. Click a LAN port to view the Port Details pop-up screen.
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Figure 196 LAN port status

LAN Interfaces Summary

n The table displays the summary of LAN interfaces and total number of LAN interfaces. The following details
are displayed for the port:
o Port—Port number. Click on the Port to open the Port Details pop-up screen.
o Admin State—Administrative state of the LAN interface. Values are Enabled orDisabled.
o Operational State—Operational state of the LAN interface. Values areUp orDown.
o Port Speed—Port speed.
o VLANs—Range of VLANs.
o MTU—MTU value.

Figure 197 LAN Interfaces Summary

Port Details pop-up Screen
Click on a Port in the Port Status or LAN Interfaces Summary screen to display the Port Details pop-up
screen.

n The following graphs are displayed under the Port Details > Packets tab:
o Unicast—The number of unicast packets per second.
o Multicast—The number of multicast packets per second.
o Broadcast—The number of broadcast packets per second.

Hover over any point of time on the x-axis to get data about packets for that instant of time.
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Figure 198 Port Details—Packets

n The following graphs are displayed under the Port Details > Errors tab:
o CRC Errors—The number of cyclic redundancy errors logged.
o Error Frames—The number of error frames logged.
o Collisions—The number of collisions encountered.

Hover over any point of time on the x-axis to get data about packets for that instant of time.
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Figure 199 Port Details—Errors

VLAN Interfaces Summary

n The table displays the summary of VLAN interfaces and total number of VLAN interfaces. The following
details are displayed:
o VLAN ID—VLAN ID number.
o IP Address—IP address.
o Admin State—Administrative state of the VLAN interface.
o Oper. State—Operational state of the VLAN interface.
o Addressing Mode—Type of addressingmode.
o Description—Description of the VLAN.
o Status—Status of the VLAN interface.

Figure 200 VLAN Interfaces Summary

Livemonitoring is available for the following:
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n Port Status
n Operational state of the LAN interface in LAN Interfaces Summary table.

Actions
TheActions drop-down list contains the following options (the Clear IPSec SA, and Clear ISAKMP SA options
are available for tunnels only):

n Reboot Gateway—Reboots the gateway. See Rebooting a Gateway

n Open Remote Console—Opens the remote console for a CLI session through SSH. The default user ID is
admin, but you can edit and customize the user ID. This customuser ID must bemapped to the device. See
Opening a Remote Console

n Clear IPSec SA—Clears the IPSec Security Associations (SA). See Clearing IPSec SA

n Clear ISAKMP SA—Clears the ISAKMP SA. See Clearing ISAKMP SA

Go Live
TheGo Live link redirects to theManage > WAN > Summary tab in the gateway dashboard. See theGo
Live section in theGateway > WAN > Summary page.

Gateway > LAN > DHCP
TheDHCP tab underManage > LAN page in the gateway dashboard displays the following sections:

n Gateway > LAN > DHCP

n Active Leases

Viewing the LAN > DHCP Tab
To navigate to theWAN > DHCP tab in the gateway dashboard, complete the following steps:

1. In theNetwork Operations app, set the filter to one of the options underGroups, Labels, or
Sites. Ensure that the filter selection contains at least one gateway. For all devices, set the filter to
Global.

The dashboard context for the selected filter is displayed.

2. UnderManage > Devices, click theGateways tab.
A list of gateways is displayed in List view.

3. Click a gateway underDevice Name.
The dashboard context for the specific gateway is displayed.

4. UnderManage, click LAN > DHCP.
To exit the gateway dashboard, click the back arrow on the filter.

You can change the time range for theDHCP tab by clicking the time range filter and selecting one
of the available options: 3 hours, 1 day, 1 week, 1 month, and 3 months.

DHCP Pools

n The table displays the summary of DHCP pools and total number of DHCP pools. The following details are
displayed:
o VLAN ID—VLAN ID number.
o Pool Name—Nameof theDHCP pools.
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o Subnet—IP address of the client subnet.
o Pool size—Size of the pool.
o Lease time—Lease time of the pool.
o Free—Number of addresses available.

Figure 201 DHCP Pools

Active Leases

n The table displays the summary of active leases total number of active leases. The following details are
displayed:
o Pool Name—Nameof theDHCP pools.
o Private IP—IP address of the client subnet. The IP address with asterisk symbol (*) indicates it is a

reserved IP address.
o MAC Address—MAC address of the client. Clicking on the address takes you to the Client page.
o Client Name—Client name.
o Client Type—Client type.
o Start Date—Start date and time of the lease.
o End Date—End date and time of the lease.
o Remaining—Remaining time for the lease to expire.

Figure 202 Active Leases

Livemonitoring is available for the following:

n Port Status
n Operational state of the LAN interface in LAN Interfaces Summary table.

Actions
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TheActions drop-down list contains the following options (the Clear IPSec SA, and Clear ISAKMP SA options
are available for tunnels only):

n Reboot Gateway—Reboots the gateway. See Rebooting a Gateway

n Open Remote Console—Opens the remote console for a CLI session through SSH. The default user ID is
admin, but you can edit and customize the user ID. This customuser ID must bemapped to the device. See
Opening a Remote Console

n Clear IPSec SA—Clears the IPSec Security Associations (SA). See Clearing IPSec SA

n Clear ISAKMP SA—Clears the ISAKMP SA. See Clearing ISAKMP SA

Go Live
TheGo Live link redirects to theManage > WAN > Summary tab in the gateway dashboard. See theGo
Live section in theGateway > WAN > Summary page.

Gateway > Applications > Visibility
TheVisibility tab underManage > Applications in the gateway dashboard displays the following tabs:

n Gateway > Applications > Visibility

n Gateway > Applications > Visibility

TheVisibility dashboard displays charts showing client traffic trends with respect to application, application
categories, website categories, and websites of a specific security reputation score. To view the traffic
classification based on application, application category, and website category, youmust enable
Application Visibility service on Branch Gateways.

To view the application usagemetrics for gateways, complete the following steps:

1. In theNetwork Operations app, set the filter to one of the options underGroups, Labels, or
Sites. Ensure that the filter selection contains at least one Branch Gateway. For all devices, set the
filter to Global.

The dashboard context for the selected filter is displayed.

2. UnderManage > Devices, click theGateways tab.
A list of gateways is displayed in the List view.

3. Click a gateway underDevice Name.
The dashboard context for the specific gateway is displayed.

4. UnderManage, click Applications > Visibility .
The Visibility dashboard is displayed with two second-level tabs,Applications and Websites.
You can change the time range for theVisibility tab by clicking the time range filter and selecting
one of the available options: 3 hours, 1 day, 1 week, 1 month, and 3 months.

Click the List and the Summary icons on the Application and Websites sections to toggle between
the dashboard views.

Applications Tab in List View
TheVisibility > Applications tab in List view displays the following:
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n Application—Displays the top N applications based on total bandwidth usage. Apart from the top N, the
rest of the applications are grouped under theUnclassified category. Click the + sign next to the service
name to expand an application in List view. A graph is displayed with date and time on the x-axis and usage
on the y-axis. The graph displays the amount of data sent and received by the application over a period of
time. To get the data sent and data received information for a specific day, hover over a point on the x-axis.

n Category—Displays the top N web categories based on total bandwidth usage. Apart from the top N, the
rest of theweb categories are grouped under theUnclassified category.

n Usage—Displays the bandwidth usage of each application.

n Sent—Displays the amount of data sent by the application.

n Received—Displays the amount of data received by the application.

Figure 203 Visibility > Applications in List View

Applications Tab in Summary View

n TheVisibility > Applications tab in Summary view displays the following:

n Applications—Displays the graph top 5 applications based on total bandwidth usage. The graph displays
date on the x-axis and usage on the y-axis. To get the total data usage information for a specific day, hover
over a bar on the x-axis.

n Categories—Displays the top 5 web categories based on total bandwidth usage. The graph displays date
on the x-axis and usage on the y-axis. To get the total data usage information for a specific day, hover over
a bar on the x-axis

Figure 204 Visibility > Applications in Summary View

Websites Tab in List View
TheVisibility > Websites tab in List view displays the following:
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n Reputation and Usage—Displays the reputation and usage percentage.

n Category and Usage—Displays theWebCC category and the usage percentage.

Figure 205 Visibility > Websites in List View

Websites Tab in Summary View
TheVisibility > Websites tab in Summary view displays the following:

n Reputations—Displays the top 5 reputations based on total bandwidth usage. The graph displays date on
the x-axis and usage on the y-axis. To get the total data usage information for a specific day, hover over a
bar on the x-axis.

n Web Categories—Displays the top 5 WebCC categories based on total bandwidth usage. The graph
displays date on the x-axis and usage on the y-axis. To get the total data usage information for a specific
day, hover over a bar on the x-axis.

Figure 206 Visibility > Websites in Summary View

Downloading Gateway Details
You can download the gateway details as a .csv file.

To download the gateway details, complete the following steps:

1. In theNetwork Operations app, set the filter to one of the options underGroups, Labels, or
Sites. For all devices, set the filter to Global.

The dashboard context for the selected filter is displayed.

2. UnderManage click Devices > Gateways.
A list of gateways is displayed in the List view under the second-levelGateways tab.
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3. In theGateways table, click the download icon to download the gateways details as a .csv file.
A .csv file is downloaded.

Related links:

Deleting a Gateway

Rebooting a Gateway

Deleting a Gateway
You can only delete a gateway when the device is offline. To delete an offline gateway, complete the
following steps:

1. In theNetwork Operations app, set the filter to one of the options underGroups, Labels, or
Sites. Ensure that the filter selection contains at least one gateway. For all devices, set the filter to
Global.

The dashboard context for the selected filter is displayed.

2. UnderManage > Devices, click theGateways tab.
A list of gateways is displayed in List view under the second-levelGateways tab.

3. Click Offline to display a table with the list of offline gateways.

4. From theGateways table, select the gateway(s) that you want to delete. To select a gateway, click on
any column except Device Name.

Clicking on a device name in the Device Name column opens the gateway dashboard.

5. Click theDelete button at the bottomof the page to delete all the selected gateways. To delete a
particular gateway, click theDelete button available at the end of the row for that gateway.

6. Confirm deletion.

The offline gateway is deleted. However, the device still can be found in Aruba Central database, as the
device entry remains in theDevice Inventory page.

Rebooting a Gateway
You can reboot a gateway using the Aruba Central UI.
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TheReboot Gateway option is available under theActions drop-down formany gateway pages. The
following procedure explains how to reboot a gateway in theManage > Overview > Summary page for a
gateway.

The Reboot Gateway option is only available for online gateways.

To reboot a gateway, complete the following steps:

1. In theNetwork Operations app, set the filter to one of the options underGroups, Labels, or
Sites. Ensure that the filter selection contains at least one gateway. For all devices, set the filter to
Global.

The dashboard context for the selected filter is displayed.

2. UnderManage > Devices, click theGateways tab.
A list of gateways is displayed in the List view under the second-levelGateways tab.

3. Click the second-levelOnline tab to display a table with the list of online gateways.

4. In theGateways table, click the gateway to reboot.

5. You can delete the gateway inmultiple ways. Perform one of the following steps:
n In theActions drop-down list, click Reboot Gateway.
n Click theReboot button available at the end of the row for that gateway.

n Click theReboot button at the bottomof the page.

AReboot dialog box is displayed.

6. Click Yes to reboot the gateway.
All clients connected to this gateway are disconnected and gateway reboots.

TheGateway Details page takes less than aminute to update the interface status after the gateway is
rebooted and reconnected to Aruba Central

Opening a Remote Console
In the Aruba Central UI, you can open the remote console for a CLI session through SSH for a gateway.
Ensure that you allow SSH over port 443.

To open the remote console for a gateway, complete the following steps:

1. In theNetwork Operations app, set the filter to one of the options underGroups, Labels, or
Sites. Ensure that the filter selection contains at least one gateway. For all devices, set the filter to
Global.

The dashboard context for the selected filter is displayed.

2. UnderManage > Devices, click theGateways tab.
A list of gateways is displayed in the List view under the second-levelGateways tab.

3. Click the second-levelOnline tab to display a table with the list of online gateways.

4. In theGateways table, click the gateway for which you want to open the remote console.
TheOverview > Summary page corresponding to the gateway is displayed.

5. In theActions drop-down list, click Open Remote Console.
A CLI session dialog box is displayed. The default user ID isAdmin, but you can edit and
customize the user ID. This customuser ID must bemapped to the device.
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Clearing IPSec SA
In the Aruba Central UI, you can clear the IPSec Security Association (SA) for a gateway. TheClear IPSec SA
option is available under theActions drop-down formany gateway pages. The following procedure explains
how to clear IPSec SA in theManage > Overview > Summary page for a gateway.

The Clear IPSec SA option is only available for online gateways.

To clear IPSec SA for a gateway, complete the following steps:

1. In theNetwork Operations app, set the filter to one of the options underGroups, Labels, or
Sites. Ensure that the filter selection contains at least one gateway. For all devices, set the filter to
Global.

The dashboard context for the selected filter is displayed.

2. UnderManage > Devices, click theGateways tab.
A list of gateways is displayed in the List view under the second-levelGateways tab.

3. Click the second-levelOnline tab to display a table with the list of online gateways.

4. In theGateways table, click the gateway for which you want to clear the IPSec SA option.
TheOverview > Summary page corresponding to the gateway is displayed.

5. In theActions drop-down list, click Clear IPSec SA.

Clearing ISAKMP SA
In the Aruba Central UI, you can clear the ISAKMP Security Association (SA) for a gateway. TheClear
ISAKMP SA option is available under theActions drop-down formany gateway pages. The following
procedure explains how to clear ISAKMP SA in theManage > Overview > Summary page for a gateway.

The Clear IPSec SA option is only available for online gateways.

1. In theNetwork Operations app, set the filter to one of the options underGroups, Labels, or
Sites. Ensure that the filter selection contains at least one gateway. For all devices, set the filter to
Global.

The dashboard context for the selected filter is displayed.

2. UnderManage > Devices, click theGateways tab.
A list of gateways is displayed in the List view under the second-levelGateways tab.

3. Click the second-levelOnline tab to display a table with the list of online gateways.

4. In theGateways table, click the gateway for which you want to clear the ISAKMP SA option.
TheOverview > Summary page corresponding to the gateway is displayed.

5. In theActions drop-down list, click Clear ISAKMP SA.
The clear command is sent successfully. A successmessage is displayed.

WAN Health—Global
TheWAN Health tab provides detailed information of the network health status and usage for the sites in
which Branch Gateways and VPN Concentrators are configured in your setup.
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To navigate to this page:

1. In theNetwork Operations app, set the filter to Global.

2. UnderManage, click Overview > WAN Health.

3. Click the List icon to navigate to the list view of sites.

Page Views
TheWAN Health page offers the following views:

n Summary—This view provides a pictorial view of the network across various sites. The sites are color
coded; red indicates potential issues and green indicates that there are no issues. To change the zoom level,
click the zoom icons. You can click the different site on themap to view details.

n List—Primarily provides numerical representation of the data. The Site Type and Connectivity Status
columns provide textual values. You can select the site from the Site Name column to view details about
that site health.

This page uses the following indicators to present information on status of the network health:

n Grey bullet
icon—Indicates no issues.
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n Red bullet
icon—Indicates potential issues.

WAN Health

Header Totals Description

Site Name Displays the total
number of sites.

Name of the site. Use the column filter bar to search for a particular site.
Click the site name to open the Site Health page. For more information,
see the Site Health section in the Aruba Central Help Center.

Site Type Displays the total
number of sites
for each site type.

Displays whether the device is deployed as a hub or spoke.
n To filter gateways provisioned as a hub, click Hub.
n To filter gateways provisioned as a spoke, click Spoke.
n To filter gateways deployed as cloud instances, click Cloud. Only
hubs can be deployed as cloud instances, so if a hub is deployed as a
cloud instance, the site type is Cloud.

Device
Status

Displays the total
number of
devices in Up and
Down state.

Displays the total count of devices in the UP and DOWN states.
n To filter devices in UP sate, click Up.
n To filter devices in DOWN sate, click Down.

Table 62: Gateways Network Health Page
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Header Totals Description

Connectivity Displays the total
number of links
and the average
bandwidth
consumed.

Displays the following information:
n Status—Displays the overall connectivity status. One of the following
statuses is displayed:
lUp
lPartial
lDown

Hover over the column to view the circuit status, tunnel status, overlay
status, and underlay status separately.

n Bandwidth—Displays bandwidth details.
lConfigured—Displays the bandwidth that is configured on the
Branch Gateway.
lEstimated—Displays the estimated bandwidth availability for the
uplinks. The Bandwidth Estimation feature must be enabled to display
this data.
lConsumed—Displays the bandwidth consumed by the clients. The
consumed bandwidth is split into transmitted and received, and
displayed at site level.

Performance Displays the
average value for
site availability
and policy
compliance.

Displays the following metrics:
n Site Availability—Displays the site availability. The range is from 0
to 100 percent. To filter site availability, click the column filter bar and
enter values in the Min and Max text boxes. Hover your mouse over
the column to view site availability on a per provider basis.
n Policy Compliance—Displays the policy compliance. The range is
from 0 to 100 percent. To filter policy compliance, click the column filter
bar and enter values in the Min and Max text boxes. Hover your mouse
over the column to view policy compliance on a per policy basis.

Table 62: Gateways Network Health Page

For information about a particular site, seeWAN Health—Site.

WAN Health—Site
TheWAN Health page displays details for thewired, wireless, and gateway devices deployed on the site.

To launch theWAN dashboard, complete the following procedure:

1. In theNetwork Operations app, set the filter to a site.

2. UnderManage, click Overview > WAN to launch theWAN dashboard.

3. Click the site on themap, or the site from the Site Name column in the List view, to view details of
that site.

TheWAN Health dashboard displays the following information:

Content Description

Name Name of the site.

Location Location of the site.

Summary The following details are available:

Table 63: WAN Health—Site
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Content Description

n Name—Name of the site.
n Location—Location of the site.
n APs—Number of APs deployed on the site.
n Switches—Number of switches deployed on the site.
n Gateways—Number of gateways deployed on the site.

Site Availability graph Site availability metrics per provider represented in a chart. The graph displays
detailed metrics for the number of sites in the down status, percentage of site
availability, and the number of unknown sites.

Policy Compliance graph Policy compliance metrics for the site. The path steering data is used to
calculate this metric.
A site can have multiple gateways andmultiple path steering policies configured
on a gateway.
For example, consider a site that has five gateways. For a given policy, if three
out of the five are compliant, one is partially compliant, and one is non-
compliant, the Policy Compliance graph is displayed in green suggesting that
the path steering policies for the site are compliant.
If there are multiple policies, the precedence rule comes into effect in the
following order: Compliant > Partially compliant > Non-compliant > Unknown.
That is, even if one of the policies in the site is compliant, the graph is displayed
in green indicating compliance. For more information, see Gateway > WAN >
Path Steering.

Bandwidth graph Bandwidth utilization of the selected site. From the drop-down list, select one of
the following:

n All Traffic
n Internet vs. VPN

Bandwidth graph Bandwidth utilization of the selected uplink. From the drop-down list, select the
uplink.

Transport Health graph Displays the transport health of the site based on active monitoring probes. Site
transport health is an average of MOS score across all probes.

NOTE: If you hover over any graph, a pop-up window opens and displays the data specific to that graph. Click on
the graph to lock the time range. After you lock the selection, the same time range is selected across all the
graphs in the Site Health page.

NOTE: If you click on any graph, a see devices button in enabled below all the graphs. Click see details to view
the list of devices. From the Add Metric drop-down list, select one or more of the following: Site Availability,
Bandwidth or Internet vs. VPN.

Table 63: WAN Health—Site

Monitoring Sites in the Topology Tab
In Aruba Central, the Topology tab in the site dashboard provides a graphical representation of the site
including the network layout, details of the devices deployed, and the health of theWAN uplinks and
tunnels.

The minimum required ArubaOS version for topology is ArubaOS version 8.1.0.0-1.0.1.1.

This section includes the following topics:
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n Before You Begin

n Grouping VPNCs

n Viewing the Topology Tab
o Parts of the Topology Tab User Interface
o Pop-Up Details
o Details Pane

Before You Begin
The pre-requisites for Branch Gateways are:

n The topology map filters devices based on sites. To view the topology map, ensure that you have assigned
the devices to sites.

n To view the topology map, ensure that LLDP is enabled. On switches, LLDP is enabled by default. On
Branch Gateways, if the port type is LAN, LLDP is enabled by default.

The pre-requisite for Aruba CX switches is:

n To view Aruba CX switches in the topology map, youmust create a template configuration for the switch
with the password in plaintext.

Grouping VPNCs
If the tunnels in the overlay are orchestrated, the VPNCs are grouped according to their hub groups. You
can also see the group preference ordermarked as primary, secondary, or tertiary.

If the tunnels are configuredmanually, the VPNCs are grouped according to their sites. If the VPNCs are not
associated with any site, they are grouped based on their hub groups. Formanual tunnels, the Data Center
group preference is not displayed.

If you have a combination of gateways in a single site, with one gateway configured as amanual tunnel and
the other gateway configured as an orchestrated tunnel, both the tunnels are treated asmanual and the
VPNCs are grouped based on their sites. If there are no associated sites, they are grouped according to their
hub groups.

Various combinations of configuration for VPNCs in a single site is not recommended.

Viewing the Topology Tab
To view the topology tab, complete the following steps:

1. In theNetwork Operations app, set the filter to one of the options under Site for which you want
to view the topology map.

The dashboard context for the site is displayed.

2. UnderManage, click Overview > Topology.
The Topology tab for the selected site is displayed.

3. In the topology map, hover over a device or a link to view the pop-up details. Formore information,
see Pop-Up Details.

4. In the device or the link pop-up, click the Show Details link to view the correspondingDetails pane.
Formore information, see Details Pane .
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Parts of the Topology Tab User Interface
In the topology tab, the icons provides the following functionality:

Figure 207 Parts of the Topology Tab

Callout
Number Description

1 Set the toggle icon to show or hide the labels.

2 Click the icon to filter the type of devices to be shown on the map. The following options are
available:

n Access Points—Allows you to show or hide the access points from the topology map.
n Security Cloud—Allows you to show or hide the Zscaler and Palo Alto Prisma Access™
Cloud Service from the topology map.
n Switch—Allows you to show or hide the switches from the topology map.
n VPNC—Allows you to show or hide the VPNCs and virtual gateways from the topology map.
n Show Devices Without Link—Allows you to show or hide the devices without link from
the topology map.

3 Click the icon to view the topology map in a left to right orientation. The default orientation of the
topology map is left to right orientation.

4 Click the icon to view the topology map in a top to down orientation.

5 The search bar allows you to locate a device in the topology map. The search bar field supports
exact and partial text search.

6 Click the icon to reset the topology map to the default view.

7 Click the icons to change the zoom level of the topology map. Alternatively, you can drag the
slider to set the zoom level of the topology map.

8 Click the icon to view the topology map in full-screen view. In the full-screen view, the pop-up
details feature is disabled in the topology map.

Table 64: Icon Details
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When the number of downstream devices connected to a device is less than or equal to 10, the
devices are visible in the topology map. When the number of downstream devices connected to a
device is more than 10, click the device icon to view the devices in the topology map. A bubble icon on
the device represents the number of connected downstream devices.

Pop-Up Details
When you hover over a device or link, a pop-up displays the following details:

Figure 208 Pop-Up Details

Type Description

Access Point Displays the following details:
n Name—Hostname of the access point.
n Type—Type of the device.
n Model—Hardware model of the access point.
n Health Reason—The health status of the access point. This parameter is only
available when the access point is offline.
n Show Details—Click the link to view the Details pane.

Branch Gateway Displays the following details:
n Name—Hostname of the Branch Gateway.
n Type—Type of device deployment.
n Model—Hardware model of the device.
n Children—Number of devices connected to the Branch Gateway categorized based
on the health and status of the devices. The Children field displays the following
details:
lHealth—Count of devices connected to the Branch Gateway based on the health of
the device. The red, yellow, and green dots indicate the health of the devices.
lStatus—Count of devices connected to the Branch Gateway based on the current
status of the devices. The green (up) and red (down) arrows indicate the status of the
devices.

n Show Details—Click the link to view the Details pane.

VPNC Displays the following details:
n Name—Hostname of the VPNC.
n Type—Type of device deployment.
n Model—Hardware model of the device.
n Show Details—Click the link to view the Details pane.

Switch Displays the following details:
n Name—Hostname of the switch.

Table 65: Pop-Up Details
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Type Description

n Type—Type of the device.
n Model—Hardware model of the switch.
n Children—Number of devices connected to the switch categorized based on the
health and status of the devices. The Children field displays the following details:
lHealth—Count of devices connected to the switch based on the health of the device.
The red, yellow, and green dots indicate the health of the devices.
lStatus—Count of devices connected to the switch based on the current status of the
devices. The green (up) and red (down) arrows indicate the status of the devices.

n Show Details—Click the link to view the Details pane.

Switch Stack Displays the following details:
n Name—Hostname of the switch stack.
n Type—Type of the device.
n Model—Hardware model of the switch.
n Children—Number of devices connected to the switch categorized based on the
health and status of the devices. The Children field displays the following details:
lHealth—Count of devices connected to the switch based on the health of the device.
The red, yellow, and green dots indicate the health of the devices.
lStatus—Count of devices connected to the switch based on the current status of the
devices. The green (up) and red (down) arrows indicate the status of the devices.

n Show Details—Click the link to view the Details pane.

Aruba CX VSX
Switch

Displays the following details:
n Name—Name of the Aruba CX switch that is configured with VSX. The name is
displayed in the VSX_<Device Name> format. For example, VSX_8320-switch-
primary.
n Type—Type of the device.
n Model—Hardware model of the Aruba CX switch.
n VSX Role—Role of the Aruba CX switch in the VSX configuration. Supported values
are Primary and Secondary.
n Children—Number of devices connected to the switch categorized based on the
health and status of the devices. The Children field displays the following details:
lHealth—Count of devices connected to the switch based on the health of the device.
The red, yellow, and green dots indicate the health of the devices.
lStatus—Count of devices connected to the switch based on the current status of the
devices. The green (up) and red (down) arrows indicate the status of the devices.

n Show Details—Click the link to view the Details pane.

Tunnel Displays the alias map name of the tunnel configured on the Branch Gateway.
In the topology map, the tunnels are shown as dotted lines. The red and green color of the
tunnel link indicates the health of the tunnel link.
Click the tunnel link to view the Details pane.

NOTE: In case of High Availability, the redundant gateway tunnel details are also displayed
in the Details tab under Virtual Tunnels when you select the tunnel.

Uplink Displays the following information about uplinks configured on the Branch Gateway:
n <Name of the Branch Gateway>—Displays the name of the Branch Gateway.
n Uplink—Type of the uplink.
n VLAN—VLAN ID of the uplink.
n Health Reason—Displays the health status and reason of the down uplink. This
parameter is only available when the uplink is down.

The red and green color of the uplink indicates the health of the uplink.
Click the uplink to view the Details pane.

NOTE: In case of High Availability, the redundant gateway tunnel details are also displayed
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Type Description

in the Details tab under Virtual Tunnels when you select the uplink.

Edge Displays the following information about the edge link:
n <Interface of the device>—Interface number of the device.
n <Name of the device>—Displays the name of the device.
n Health Reason—Displays the health status and reason of the down edge link. This
parameter is only available when the edge link is down.

The red and green color of the edge link indicates the health of the edge.
Click the edge link to view the Details pane.

ISL edge in Aruba
CX VSX toplogy
map

Displays the following information about the link:
n ISL—Number of inter-switch link (ISL) present between the Aruba CX switches
configured with VSX.
n Other Links—Number of other links present between the Aruba CX switches
configured with VSX.

Active tunnels are green in color and inactive tunnels are red in color. If there are multiple tunnels
connecting to a VPNCs, and even if one of those tunnels is down, the tunnel mapping is displayed in
red dotted lines.

Details Pane
In the topology map, theDetails task pane provides a summary of the devices, uplinks, and tunnel details.
The red and green indicators show the current status and health of theWAN uplinks and tunnels.

In the topology map, select a device and then click the Show Details link in the pop-up window to view the
Details pane. To view theDetails pane for a tunnel, uplink, or edge, click the link.

Figure 209 Details Pane

TheDetails task pane displays the following information:

Type Description

Access
Point

Displays the following details:
n Name—Hostname of the access point. Click the access point name to view the Access

Table 66: Contents of the Details Pane
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Type Description

Point Details page.
n IP—IP address of the access point.
n MAC—MAC address of the access point.
n Type—Type of the device.
n Serial—Serial number of the access point.
n Model—Hardware model of the access point.
n Status—Operational status of the access point.
n Health—Operational health of the access point.

Branch
Gateway

Displays the following details:
n Name—Hostname of the Branch Gateway. Click the Branch Gateway name to view the
Gateway Details page.
n IP—IP address of the Branch Gateway.
n MAC—MAC address of the device.
n Type—Type of device deployment.
n Serial—Serial number of the Branch Gateway.
n Model—Hardware model of the device.
n Status—Operational status of the device.
n Health—Operational health of the device.

VPNC Displays the following details:
n Name—Hostname of the VPNC. Click the VPNC name to view the Gateway Details page.
n IP—IP address of the VPNC.
n MAC—MAC address of the device.
n Type—Type of device deployment.
n Serial—Serial number of the VPNC.
n Model—Hardware model of the device.
n Status—Operational status of the device.
n Health—Operational health of the device.

Switch Displays the following details:
n Name—Hostname of the switch. Click the switch name to view the Switch Details page.
n IP—IP address of the switch.
n MAC—MAC address of the switch.
n Type—Type of the device.
n Serial—Serial number of the switch.
n Model—Hardware model of the switch.
n Status—Operational status of the switch.
n Health—Operational health of the switch.

Switch
Stack

Displays the following details:
n Name—Hostname of the switch. Click the switch name to view the Switch Details page.
n IP—IP address of the switch.
n MAC—MAC address of the switch.
n Type—Type of the device.
n Serial—Serial number of the switch.
n Stack Role—Role of the switch in the stack.
n Model—Hardware model of the switch.
n Status—Operational status of the switch stack.
n Health—Operational health of the switch stack.
n Stack Members—Provides the Name, Role, and State details of the stack member. Click
the stack member name to view the Switch Details page.

Aruba CX
VSX

Displays the following details:
n Name—Hostname of the Aruba CX switch with VSX configured. Click the switch name to
view the Switch Details page.
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Type Description

n IP—IP address of the switch.
n MAC—MAC address of the switch.
n Type—Type of the device.
n Serial—Serial number of the switch.
n Model—Hardware model of the switch.
n Status—Operational status of the switch.
n Health—Operational health of the switch.

VSX section displays the following details:
n ISL State—State of the ISL connection with the peer Aruba CX switch. Following are the
supported values:
lWAITING_FOR_PEER—Waiting for connectivity to the peer.
lPEER_ESTABLISHED—Steady state. VSX LAGs are up when the device is in this state.
lSPLIT_SYSTEM_PRIMARY—Lost ISL connectivity to the peer and the device is operating as
primary.
lSPLIT_SYSTEM_SECONDARY—Lost ISL connectivity to the peer and the device is operating
as secondary.
lSYNC_PRIMARY—ISL connectivity to the peer restored and the device is syncing states to the
peer.
lSYNC_SECONDARY—ISL connectivity to the peer restored and he device is learning states
from the peer. VSX LAGs are down when the device is in this state.
lSYNC_SECONDARY_LINKUP_DELAY—Device has learned its states from the peer and
monitoring for hardware is to be programmed. VSX LAGs are down when the device is in this
state.

n ISL Port—ISL port number of the selected Aruba CX switch. If the ISL is a LAG, then this field
displays the LAG name.
n ISL Mgmt State—Management state of the ISL. Following are the supported values:
lOPERATIONAL—ISL management is operational.
lINTER_SWITCH_LINK_MGMT_INIT—ISL management is in initialization state.
lCONFLICTING_OR_MISSING_DEVICE_ROLES—Either the role is missing on one of the
VSX peers or the same role is configured on both VSX peers.
lSW_IMAGE_VERSION_MISMATCH_ERROR—Software version on the primary device
does not match with the software version on the secondary device.
lINTER_SWITCH_LINK_DOWN—ISL is down.
lINTERNAL_ERROR—ISL management has internal errors.

n Config Sync Enabled—Configuration synchronization between the VSX switches are
enabled or disabled.
n Config Sync Status—Status of the configuration synchronization between the VSX switches.
Following are the supported values:
lIN-SYNC—Configuration synchronization is operational and the VSX switches are in sync.
lDISABLED—Configuration synchronization is disabled.
lSW_IMAGE_VERSION_MISMATCH_ERROR—Software image version on the primary
device does not match with the software image version on the secondary device.
lCONFLICTING_OR_MISSING_DEVICE_ROLES—Either the role is missing on one of the
VSX peers or the same role is configured on both VSX peers.
lPEER_DB_CONNECTION_ERROR—Error in connecting to peer database. It involves errors
due to ISL or ISL management.
lCONFIGURATION_SYNC_CONFLICT—Configuration synchronization is operational, but
has conflicts synchronizing the configuration. Conflicts can occur if the configuration on the
primary device is marked for sync, but the same configuration on the secondary device is not
marked for sync.
lCONFIGURATION_SYNC_MISSING_REFERENCE—Configuration synchronization is
operational, but has missing references in synchronizing the configuration.

n Role—Role of the Aruba CX switch in the VSX configuration. Supported values are Primary
and Secondary.
n Peer IP—IPv4 address of the peer switch.
n Peer Serial—Serial number of the peer switch.
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Type Description

n Peer MAC—MAC address of the peer switch.
n Peer Name—Hostname of the peer switch.
n Last Seen—Date on which the peer switch was last synced.

Tunnel Displays the following information about tunnels configured on the Branch Gateway:
n Map Name—Name of the tunnel interface.
n Peer MAC—MAC address of the peer device with which the tunnel was established.
n Local MAC—MAC address of the Branch Gateway.
n Source IP—Source IP address from where the traffic originates.
n Destination IP—IP address to which the traffic is sent.
n Established Time—Timestamp showing when the tunnel was established.
n VLAN—VLAN ID of the tunnel.
n Source Serial—Source Serial of the tunnel.
n A green bullet icon indicates that the tunnel is up and a red bullet icon indicates that the
tunnel is down.

Uplink Displays the following information about uplinks configured on the Branch Gateway:
n Uplink Type—Type of the uplink.
n VLAN—VLAN ID of the uplink.
n Link Status—Uplink status.
n Description—Description of the uplink.
n WAN Status—WAN status.
n IP Address—IP address of the WAN interface.
n Public IP Address—Public IP address.
n Device MAC—MAC address of the device.
n Serial—Serial number of the device.
n Port Number—Port number of the device.
n Tunnels—Displays a list of tunnels mapped to the uplink. Click the drop-down on each
tunnel to view the tunnel details.
n A green bullet icon indicates that the tunnel is up and a red bullet icon indicates that the
tunnel is down.

Edge Displays the following information about the link:
n Interface numbers—Interface numbers of the device.
n Interface—Interface number of the individual device.
n Serial—Serial number of the individual device.
n Device Name—The name of the individual device.
n Port Number—The port number of the individual device.

NOTE: In case of Branch Office Controller (BOC) to Switch link, if a peer Branch Gateway link is
configured for redundancy, link details are displayed for the peer Branch Gateway to switch link as
well.

ISL edge in
Aruba CX
VSX
toplogy
map

Displays the following information about the ISL edge:
n Inter-Switch Link Status—Status of the ISL connection with the peer.
n <LAG-name> - ISL section displays details about all the interfaces that are part of the LAG.
The section also displays the details of the devices connected to these interfaces. It displays
the following details:
lSerial—Serial number of the individual device.
lDevice Name—Name of the individual device.
lPort Number—Port number of the individual device.

n Other—This section displays details about the other links present between the VSX
configured Aruba CX switches. It displays the following details:
lSerial—Serial number of the individual device.
lDevice Name—Name of the individual device.
lPort Number—Port number of the individual device.
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For an animation of the site topology map, click
https://help.central.arubanetworks.com/latest/documentation/online_
help/content/resources/images/gifs/topology.gif.

Monitoring SaaS Express
The SaaS Express monitoring dashboard displays charts with QoE scores for all of the SaaS applications
that you have configured. You can view the dashboard fromGlobal, Group, Site, and Gateway contexts. The
Branch Gateway measures the packet loss, latency, and jitter, and sends the data to Aruba Central. The
insights gained from themonitoring dashboard helps you to identify the applications that do not perform
well and correlate performancewith the geographical region, the ISP, and so on to troubleshoot issues.

To view the performance of the SaaS applications, youmust have configured the required SaaS applications
in the Branch Gateway. Formore information, see Configuring SaaS Express .

You can select one of the following time ranges for which you want to view the data from the Time Range
filter:

n 3 Hours
n 1 Day
n 1 Week
n 1 Month
n 3 Months

Global Dashboard
To view the SaaS Expressmonitoring dashboard in theGlobal view, complete the following steps:

1. In theNetwork Operations app, set the filter to Global.

2. UnderManage, click Applications > SaaS Express.
By default, themap view of the Saas Express dashboard is displayed.

Map View
Themap displays all the sites with branch gateways in which SaaS Express is configured. The sites in
which theQoE scores of all the SaaS applications are good are displayed in green. Even if one of them is
fair or poor, the site is displayed in red.

You can click the site to view the details of all applications. The following GIF illustrates the options
available in themap view of themonitoring dashboard:
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Figure 210 Map View - SaaS Express Monitoring Dashboard

List View
The list view displays theApplication Health table in which you can view theQoE scores of all the sites
for all the applications. You can sort the list fromGood to Poor and vice versa. You can set filters to
Good, Fair, or Poor for each application to display only those sites based on theQoE scores and you can
also search with the site name in theName column. TheQoE scores are classified as follows:

Table 67: QoE Scores and Statuses

Application Status Colour QoE score

Good Green > 7

Fair Orange < 7 to ≥ 4

Poor Red ≤ 4

You can click on a site to navigate to the dashboard that displays Site level information. The following GIF
illustrates the options available in the list view of themonitoring dashboard:

Figure 211 List VIew - SaaS Express Monitoring Dashboard

Site Dashboard
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The details displayed in the Site view providesmore granular insights on the performance of your SaaS
applications.

To view the SaaS Expressmonitoring dashboard in the Site context, complete the following steps:

1. In theNetwork Operations app, set the filter to one of the options under Sites.

2. UnderManage, click Applications > SaaS Express.
The Saas Express monitoring dashboard for that site is displayed.

SaaS Express Summary
The SaaS Express Summary section displays the following information:

n Total Apps—The total number of active applications.

n Categories Per Exit—The total number of WAN interfaces for each application category.

n Avg QoE—An average of all the three scores: Loss, Latency, and Jitter.

n Avg Loss—The average percentage of packet loss during transmission.

n Avg Latency—The average time taken to transmit data packets to the destination inmilliseconds.

n Avg Jitter—The average time delay or jitter in transmitting data packets over the network inmilliseconds.

SaaS Express Details
The table in this section displays the following information for each of the active SaaS application category:

n Category—The name of the SaaS application category.

n Current Exit
o WAN Interfaces—The uplink through which the SaaS application traffic traversed.
o Gateways—TheBranch Gateway through which the SaaS application traffic traversed.

n QoE (#/10)—The average score (out of 10) based on the loss, latency and jitter values.

n Loss—The percentage of packet loss during data transmission.

n Latency—The time taken to transmit data packets to the destination inmilliseconds.

n Jitter—The time delay or jitter in transmitting data packets over the network inmilliseconds.

Click + in theCategory column to expand and view the graphical representation of the application
performance in terms of QoE, Loss, Latency, and Jitter. Hover over the graph to view the values at a
particular time of the day or the day of theweek and so on, depending on the time range selected. The
table also displays themaximum,minimum, and average scores for each of these parameters for the
selected time range.

The following GIF illustrates the options available in the SaaS Expressmonitoring dashboard on the Site
context:
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Figure 212 Site View - SaaS Express Monitoring Dashboard

Gateway Alerts
Aruba Central allows network administrators and users with admin permissions to configure alerts.

Following are the SD-WAN and Gateway appliance-related alerts that you can configure:

n SLA DPS Compliance Violations—Generates an alert when theWAN policy does not meet the
compliance criteria.

n New Gateway Connected—Generates an alert when a newBranch Gateway is connected.

n Gateway Disconnected—Generates an alert when a Branch Gateway is disconnected. When a gateway
disconnects because of license expiry, the alert description shows 'Reason: Device unlicensed'.

n Gateway CPU Utilization—Generates an alert when the Branch Gateway CPU utilization exceeds the
threshold value. You can add additional rule(s) for this alert.

n Gateway Memory Utilization—Generates an alert when the Branch Gateway memory utilization
exceeds the threshold value. You can add additional rule(s) for this alert.

n OSPF Session Error—Generates an alert when an OSPF session fails.

n BGP Session Error—Generates an alert when a BGP session fails.

n Gateway Base License Capacity Limit Exceeded—Generates an alert when aGateway with
Foundation-Base Capacity subscription exceed the client capacity threshold.

n Routing Table Limit—Generates an alert when the routing table size exceeds the 90% of the capacity.
This alert is auto-acknowledged when the Routing table size goes below 85% of the capacity.

n BGP Neighbor Route Limit—Generates an alert when the number of routes received from a BGP
neighbor exceeds the configured limit. This alert is auto-acknowledged when the number of routes from
the BGP neighbor goes below the configured limit.

n Overlay Route Orchestrator Connection—Generates an alert when the control connection between
the Branch Gateway and theOverlay RouteOrchestration (ORO) is down. This alert is auto-acknowledged
when the control connection is re-established.

n Gateway Cellular Data Usage—Generates an alert when the cellular data usage exceeds the threshold
value. Youmust set theData Usage alert limit and Billing start date in theUplink configuration page
for this alert to generate.

Note: This alert configuration is only applicable for 9004-LTE gateways that have an integrated LTEmodem.

n WAN Health-Check Failure—Generates an alert whenWAN health check fails.
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n WAN VPN-Peer Unreachable—Generates an alert when theWAN VPN peer is unreachable.

n WAN Uplink Status Change—Generates an alert when theWAN uplink status changes.

n WAN Uplink Autonegotiation State Change—Generates an alert when theWAN uplink automatic
negotiation status changes.

n WAN Uplink Input Errors—Generates an alert when the percentage of WAN uplink input errors exceed
the threshold value. In the Interface field, enter the interface name. You can add additional rule(s) for this
alert.

n WAN Uplink Output Errors—Generates an alert when the percentageWAN uplink output errors exceed
the threshold value. In the Interface field, enter the interface name. You can add additional rule(s) for this
alert.

n WAN Uplink PHY Errors—Generates an alert when the percentageWAN uplink PHY errors exceed the
threshold value. In the Interface field, enter the interface name. You can add additional rule(s) for this
alert.

n DHCP Pool Consumption Alert—Generates an alert when the percentageDHCP pool consumption
exceeds the threshold value. In the Subnet field, enter the subnet address to filter the alert based on
subnet.

n IPSec Establishment Failure—Generates an alert when the IPsec tunnel fails to establish.

n IPSec SA Down—Generates an alert when the IPsec SA is down.

n All IPSec SAs Down—Generates an alert when all the IPsec SAs are down.

n CFG-SET Advertisement Failure—Generates an alert when the CFG-SET advertisement fails.

n Uplink Flapping—Generates an alert when the uplink state changes frequently. In the Interface field,
enter the interface name. You can add additional rule(s) for this alert.

n Tunnel Flapping—Generates an alert when the tunnel state changes frequently. In the Interface field,
enter the interface name. You can add additional rule(s) for this alert.

n Uplink Speed Flapping—Generates an alert when the uplink speed changes. In the Interface field, enter
the interface name. You can add additional rule(s) for this alert.

n EST Enrollment Failure—Generates an alert when the Virtual Gateway fails to enroll with the EST server.

n VGW VM Down—Generates an alert when an Aruba Virtual Gateway deployed as a Virtual Machine is
down.

n Gateway Firmware Upgrade Failed—Generates an alert when there is a firmware upgrade failure.

n Gateway IDS/IPS Engine Error State—Generates an alert when theGateway’s IDS/IPS Engine state is
either crashed or stopped. A severity of Critical indicates that the engine has crashed and Major indicates
that the engine has stopped.

n Gateway IDS IPS Engine CPU Utilization—Generates an alert when the CPU utilization by IDS/IPS
engine exceeds the threshold value and duration. You can add additional rule(s) for this alert.

n Gateway IDS IPS Engine Memory Utilization—Generates an alert when thememory utilization exceeds
the threshold value and duration. You can add additional rule(s) for this alert.

n Gateway IDS IPS Engine Packer Dropped Detected—Generates an alert every timewhen the number
of packets dropped exceeds the configured threshold value.

Currently, Aruba IDPS is supported only on 9004, 9012, and 9004-LTE Branch Gateways that have
Security license entitled to them.
Alerts that fall under WAN/ Tunnels/ DPS/ Routing/ Firewall are not applicable to Aruba Unified
Network Architecture deployments.

You can configure the following alerts for gateways running ArubaOS 8.0.x:
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n Gateway Emergency Mode—Generates an alert when a gateway enters the emergency mode, where
all the uplinks are down and the backup uplink is activated.

n VPN Peer Failover—Generates an alert when all the tunnels from the gateway to the primary VPN
controller go down including via backup uplink and establishes a tunnel with the secondary VPN
controller.

You can configure and enable these alerts for gateways running other ArubaOS versions also.
However, these alerts will not be generated for gateways on versions other than ArubaOS 8.0.x.

Reports
The Aruba Central dashboard enables you to create various types of reports. You can create recurrent
reports or configure the reports to run on demand. To create a report, youmust have read/write privileges
or Admin rights.

TheReports page has the following sections:

n Create—Creates a report that can run instantly, on scheduled time, or recurrent reports.

n Manage—Edits or deletes the scheduled reports.

n Browse—Lists all the archived reports.

This section includes the following topics:

n Report Categories

n Creating a Report

n Editing a Report

n Viewing a Report

n Downloading a Report

n Deleting a Report

Report Categories
Aruba Central allows you to create various types of reports based on your network requirements. The
report types supported by Aruba Central are:

n Clients
n Infrastructure
n Security Compliance
n Applications

The following table lists the different types of reports under each report category:

Section Description

Client
Inventory

Displays the client details summarized by all aggregation fields. The report includes the following
details:

Table 68: Clients Reports
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Section Description

n Client count by SSID
n Client count by role
n Client count by connectionmode
n client count by connection type
n Client count by OS
n Client count by vendors

Client
Session

Displays the details of client sessions for the SSIDs provisioned on Instant APs. The report includes
the following details:

n Clients
n Sessions
n Traffic
n Session Data by OS / Connection Mode / SSID / Role / MAC Vendor
n Clients by OS / Connection Mode / SSID / Role / MAC Vendor
n Time Spent by OS / Connection Mode / SSID / Role / MAC Vendor
n Data Usage by OS / Connection Mode / SSID / Role / MAC Vendor
n Client Device OS / Connection Mode / SSID / Role / MAC Vendor
n Top 10 clients by usage filtered based on SSID

Client
Usage

Displays the client usage and count details. The report includes the following details:
n Client Usage
n Top 10 clients by usage filtered based on SSID
n Client Count
n Top 10 applications by usage
n Top 10 web categories by usage
n Top 10 app categories
n Web reputation

Guest Displays the guests, and guest session details for all the SSIDs for a specific time period.

NOTE: Guest report does not support location based filtering for any selected device group or site
label to ensure end user privacy protection.

Summary Displays wireless and wired clients, and wireless and wired usage for one year. The report includes
the following details:

n Total data usage
n Trends
lClients per day
lAverage clients per day
lUsage over time

n Top N Widgets—Top 5, Top 10, Top 25, or Top 50
lTop clients by usage
lTop OS by usage

NOTE: Summary report is supported from Aruba Central 2.5.2 onwards and the data is available
only after an upgrade to version 2.5.2 or later. Data prior to the 2.5.2 upgrade is not available in the
report.

Table 68: Clients Reports
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Section Description

Capacity
Planning

Displays the throughput and client density information for devices provisioned in Aruba
Central. The report includes the following details:

n Subscription Utilization: Total Subscription, Used subscriptions, and Available
subscriptions
n Top 25 APs by usage
n Top 25 switches by usage
n Top 25 APs by peak client
n Top-25 APs by average client

Configuration
& Audit

Displays the configuration and audit logs for all the device management, configurations,
and user management events triggered in Aruba Central. The report includes the following
details:

n Configuration Audit Status
n Aruba Switches Configuration Audit Status
n Virtual Controllers Configuration Audit Status

Infra Inventory Displays the inventory and subscription information for the devices that are online during a
specific duration. The report includes the following details:

n Subscription Utilization: Total Subscription, Used subscriptions, and Available
subscriptions
n Subscription Keys
n Number of APs
n Number of Switches
n Number of Gateways
n Firmware Version Summary (IAP)
n Firmware Version Summary (Switch)
n Firmware Version Summary (Gateway)
n Devices by Site
n Model and Firmware version (IAP)
n Model and Firmware version (Switch)
n Model and Firmware version (Gateway)
n AP interfaces summary

Network Displays the following parameters:
n Top 20 Sites By Availability
n Bottom 20 Sites By Availability
n Top 20 Sites By WLAN Usage
n Bottom 20 Sites By WLAN Usage
n Number of APs
n AP Model
n Top Ten Clients By Usage filtered based on SSID
n Device Types (Current)
n Top Ten APs By Usage
n Total Usage By SSID
n Wireless Clients by SSID
n Peak and Average Wireless Data Usage
n Number of Switches
n Switch Model
n Top Ten Switches by Usage
n Top Ten Ports by Usage
n Wired Peak and Average Uplink Stats
n Number of Gateways
n Gateway Model

Table 69: Infrastructure Reports
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Section Description

New Infra
Inventory

Displays the inventory and subscription information to the devices that are newly added in
Aruba Central. The report includes the following details:

n Subscription Utilization: Total Subscription, Used subscriptions, and Available
subscriptions
n Subscription Keys
n APs Added by Model
n APs Added by Group
n Switches Added by Model
n Switches Added by Group
n Total APs
n Total Switches

Resource
Utilization

Displays the details of infrastructure devices that exceeded the configured thresholds on a
daily, weekly, andmonthly basis. The report includes the following details:

n Resource Utilization Threshold
n CPU/Memory Compliance
n Sites with Non-Compliant Devices
n Non-Compliance by Device Type
n Non-Compliant Access Points
n Non-Compliant Switches

RF Health Displays the following RF usage statistics for the AP radios.
n Problem Radios (5 GHz / 2.4 GHz)
n Most Noise (5 GHz / 2.4 GHz)
n Most Errors (5 GHz / 2.4 GHz)
n Most Utilized by Channel Usage (5 GHz / 2.4 GHz)
n Least Utilized by Channel Usage (5 GHz / 2.4 GHz)
n Most Channel Changes (5 GHz / 2.4 GHz)
n Most Transmission Power Changes (5 GHz / 2.4 GHz)
n Radio with Least Goodput (5 GHz / 2.4 GHz)

NOTE: For APs that support 5 GHz dual band in synchronization with Aruba Instant 8.3.0.0,
the Device column in the RF Health Report shows the radio number of the operating
radio along with the model number of the device.

Switch Capacity
Planning

Displays the following details about the switch ports usage:
n Total Used/Unused Switch Ports
n Switch Port Summary
n Switch POE Usage Summary

NOTE: The data for this report is generated only after you upgrade to Aruba Central
version 2.5.2. You can view or generate the report for 1, 7, 30, and 90 days after upgrading
to Aruba Central version 2.5.2.

WAN Availability Displays WAN overlay and underlay availability information.
The Underlay report contains the following details:

n Branch Gateway
lSite
lSerial Number
lHost name
lMAC

n Uplink
lName
lType

Table 69: Infrastructure Reports
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Section Description

lVLAN
n %Uptime
n Uptime
n Downtime

The Overlay report contains the following details:
n Branch Gateway
lSite
lSerial Number
lHost name
lMAC

n Uplink
lVLAN

n Tunnel
lName
lSIP
lDIP

n %Uptime
n Uptime
n Downtime

WAN Inventory Displays a list of Branch Gateways onboarded. The report is segregated by ArubaOS
software version and contains the following information:

n Software Version
n Site Name
n Serial Number
n Host name
n MAC
n IP Address
n Model
n Status
n Street Address

WAN Compliance Displays the worst performing or best performing links according to the SLA compliance
violations. The report contains the following details:

n Policy Name
n Branch Gateway
lSite
lSerial Number
lHost Name
lMAC

n Uplink
lName
lType

n Value
lCompliance

WAN Transport
Health

Displays the top N links with probed values. The report contains the following details:
n Report Name
n Report Type
n Date Run
n Periodicity
n Title
n Probe Destination IP
n Branch Gateway

Table 69: Infrastructure Reports
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Section Description

lSite
lSerial Number
lHost name
lMAC

n Uplink
lName
lUplink

n Value
lEither Loss (%

WAN Utilization Displays WAN bandwidth utilization information for Underlay, Overlay, and Uplinks. The
report contains the following details:

n Branch Gateway
lSite
lSerial Number
lHost name
lMAC

n Uplink
lName
lType
lVLAN

n Usage
lAverage Bandwidth (Mbps)
lSLA Bandwidth (Mbps)
l%Utilization

WAN Web
Content
Classification

Displays the details of Reputation, Categories, and Destination Countries. The report can
categorize information by:

n Transport Type— Internet or VPN.
n Top N Count—Top N count of events, the number should be be between 1-250.
n Classify On—Classify the report on geo location, web category, or web
reputation.
n Report type— Choose either a complete summary report or blocked urls report.
n Report Period—Choose the time period for the report from:
lLast day
lLast seven days
lLast 30 days
lCustom Range

n Recurrence—Set the recurrence for the report generation.
The reports contain the following Device Details:

n Site—Location of the Gateway or VPNC.
n Serial #—Serial number of the device.
n Hostname—The hostname.
n MAC—Device MAC address.

The report also contains the top 5 Web Reputation, Web Category, Destination, and total
usage details. If required, a user can generate a report for web traffic going over a VPN.

Table 69: Infrastructure Reports

Section Description

PCI Compliance Displays the PCI Compliance result for the generated report. The report displays the
following details:

n Netmask

Table 70: Security Compliance Reports
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Section Description

n Compliance result as Fail or Pass with the number of violations
n PCI report version 3.2 for Instant AP

RAPIDS Displays the details of all rogue or interfering devices in Aruba Central.

Security
Compliance

Displays the security compliance results. The report includes the following details:
n Rogue APs
n Total Rogue APs Detected
n Wireless Intrusions
n Total Wireless Intrusions

Table 70: Security Compliance Reports

Section Description

AppRF Displays application usage report for a specific device group. The report displays the following
widgets:

n Top 10 applications accessed by the clients
n Top 10 web categories accessed by the clients
n Top 10 applications for device types
n Others

Table 71: Applications Reports

Creating a Report
You can generate reports for devices associated with a group, multi-group, label, or site level. You can also
set a periodicity for running the reports.

Although your page view is set to a specific group, site, or label, you can create reports for a different
group, site, or label. However, if your page view is set to an Instant AP cluster or Switch, you can
schedule report generation only for that Instant AP cluster or Switch.

To create a report:

1. In theNetwork Operations app, set the filter to one of the options underGroups, Labels, or
Sites. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.

2. UnderAnalyse, click Reports. The reports overview page is displayed.

3. Click Create. TheReports page is displayed.

4. Select one of the categories from the page display and click on the type of report you wish to create.

5. Under Context, select one of the following options:

a. Groups

b. Sites

c. Labels

6. To generate reports for the devices attached to a group, select Groups and then select a device
group.
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7. To generate reports for devices attached to a label, click Labels and then select a label.

8. To generate reports for devices deployed on a specific site, click Sites and select a site.

For Client Session report, the Show Detailed Report option is available only for a selected
site. Selecting this option restricts the Report Period to Last Day and Custom Range only.
Selecting custom range enables you to select a one day time range from the particular day till
the last seven days only.

9. To set a role based or SSID based filter for a Client Inventory report or a Client Session report,
select all groups, multiple groups, or a single group. The Filter By window is displayed. Set the filter
to Roles or SSIDs, and select the required role or SSID filter.

10. To set the threshold values for aResource Utilization report, select the AP, Switch, and Gateway
thresholds under the Thresholdwindow.

11. Click Next.

12. UnderReport Period, select one of the following options:

a. Last day

b. Last 7 days

c. Last 30 days

d. Custom Range

13. Click Next.

14. Select one of the recurrent options:

a. One time (now)

b. One time (Later)

c. Every day

d. Every week

e. Every month

15. UnderReport Information, add a report title, and an optional email address to receive the report as
email.

16. Select PDF and/or CSV, to specify the format of the report to receive the email.

17. Click Generate. The report gets generated is displayed under theGenerated Reports tab. The
report gets emailed as an attachment to the email address provided. If not, you can download the
PDF and/or CSV from theGenerated Reports table.

18. If you selected One Time as the option in step 12, the report will display underArchived Reports.
If the report is scheduled for a later time, the details will display under Scheduled Reports.

Editing a Report
To edit a report:

1. In theNetwork Operations app, set the filter to one of the options underGroups, Labels, or
Sites. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.
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2. UnderAnalyze, click Reports. The reports overview page is displayed.

3. Click Manage.

4. Under Scheduled Reports, select a report and then click the edit icon. TheCreate Report page is
displayed.

5. Click Next. TheContext page is displayed.

6. Under Context, select one of the following options:

a. Groups

b. Sites

c. Labels

7. To generate reports for the devices attached to a group, select Groups and then select a device
group.

8. To generate reports for devices attached to a label, click Labels and then select a label.

9. To generate reports for devices deployed on a specific site, click Sites and select a site.

10. Click Next.

11. UnderReport Period, select one of the following options:

a. Last day

b. Last 7 days

c. Last 30 days

d. Custom Range

12. Click Next.

13. Select one of the recurrent options:

a. One time (now)

b. One time (Later)

c. Every day

d. Every week

e. Every month

14. Select theRun Time for generating the report at a specific time.

15. UnderReport Information, add a report title, and an optional email address to receive the report as
email.

16. Select PDF and/or CSV, to specify the format of the report to receive the email.

17. Click Generate. The report gets generated is displayed under theGenerated Reports tab. The
report gets emailed as an attachment to the email address provided. If not, you can download the
PDF and/or CSV from theGenerated Reports table.

18. If you selected One Time as the option in step 12, the report will display underArchived Reports.
If the report is scheduled for a later time, the details will display under Scheduled Reports.

Viewing a Report
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To view a report:

1. In theNetwork Operations app, set the filter to one of the options underGroups, Labels, or
Sites. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.

2. UnderAnalyze, click Reports. The reports overview page is displayed.

3. Click Browse. TheReport table is displayed. Existing reports are listed underGenerated Reports
page.

4. UnderGenerated Reports, click the report name. The report details are displayed.

Downloading a Report
To download a report:

1. In theNetwork Operations app, set the filter to one of the options underGroups, Labels, or
Sites. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.

2. UnderAnalyze, click Reports. The reports overview page is displayed.

3. Click Browse. TheReport table is displayed. Existing reports are listed underGenerated Reports
page.

4. UnderGenerated Reports, hover the cursor over the report name. The PDF, CSV, Email, and Delete
icons are displayed.

5. Click PDF or CSV to download the report. The report gets downloaded to the local system.

6. Optionally, click the email icon to generate an email attachment of the report.

You can also download the report from the report details page. Click PDF, CSV, or email icon to select the
format.

Deleting a Report
To delete a report, perform the following steps:

1. In theNetwork Operations app, set the filter to one of the options underGroups, Labels, or
Sites. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.

2. UnderAnalyze, click Reports. The reports overview page is displayed.

3. Click Browse. TheReport table is displayed. Existing reports are listed underGenerated Reports
page.

4. UnderGenerated Reports, hover the cursor over the report name. The PDF, CSV, Email, and Delete
icons are displayed.

5. Click the delete icon. The selected report gets deleted.

Deleting Multiple Reports
To deletemultiple reports, perform the following steps:

1. In theNetwork Operations app, set the filter to one of the options underGroups, Labels, or
Sites. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.
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2. UnderAnalyze, click Reports. The reports overview page is displayed.

3. Click Browse. TheReport table is displayed. Existing reports are listed underGenerated Reports
page.

4. UnderGenerated Reports, select multiple reports by clicking each row. A pop-up displays the
number of selected rows.

5. Click the delete icon within the pop-up. TheDelete Report window appears.

6. Click Yes to delete the selected reports. The selected reports get deleted.



Chapter 17
Maintenance

Maintenance
TheMaintenance application allows you to upgrade firmware and troubleshoot devices. See the following
topics formore information:

n Updating Software Images on ArubaGateways on page 545

n Troubleshooting Devices on page 537

Troubleshooting Devices
The Troubleshooting menu in theMaintenance module allows your network administrators to run
troubleshooting or diagnostics commands on the devicesmanaged fromAruba Central. When a
troubleshooting operation is initiated, Aruba Central establishes a session with the devices, retrieves the
output of the commands, and displays the output in theUI.

Aruba Central supports running troubleshooting operations on one or several devices. You can select up to
10 devices for a troubleshooting operation. If the user access is restricted to certain groups within a
network, Aruba Central allows running troubleshooting commands only for the devices provisioned in the
allowed groups.

Formore information on troubleshooting, see Troubleshooting Devices in the Aruba Central Help Center.

Enabling Gateway Logs
Logs aims to help users diagnose and debug issues detected in an Aruba Central-managed network. The
Logs tab on the Tools page of a gateway dashboard provides the user with an option to enableOn-
Demand data collection. TheOn-Demand data collection enables you to download TAR logs and crash
logs related to gateways.

To enable logs collection for a gateway on the Aruba Central-managed network, complete the following
procedure::

1. In theNetwork Operations app, set the filter to one of the options underGroups, Labels, or Sites.
Ensure that the selected option contains at least one gateway. For all devices, set the filter to Global.
The dashboard context for the selected filter is displayed.

n To select a device in the filter:
a. Set the filter to Global.

b. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

c. Click a gateway listed underDevice Name for which you want to perform diagnostic test.

The dashboard context for the gateway is displayed.

2. UnderManage > Devices, click theGateways tab.
A list of gateways is displayed in the List view.
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3. Click a gateway listed underDevice Name.
The dashboard context for the gateway is displayed.

4. UnderAnalyze > Tools, click the Logs tab.

5. In the Logs tab, turn on the Enable On-Demand data collection toggle to download TAR logs and
crash logs.

6. To upload TAR log or crash log, click + in the Log Files table. TheUpload Log File panel opens.

7. Configure the following parameters as per your requirements:

Parameter Description

File type Select one of the log file types listed here:
n TAR log
n Crash log

Tar log The following options are displayed when the File Type is configured as TAR log. You
can select one of the options listed here:

n Upload existing file—Allows you to upload an existing TAR log file.
n Generate & upload new file now—Allows you to generate and upload a new
TAR log file now.
n Generate & upload new file at a scheduled time—Allows you to generate and
upload a new TAR log file at a later date and time.

Crash Log The following options are displayed when the File Type is configured as Crash log. You
can select one of the options listed here:

n Upload existing file—Allows you to upload an existing Crash log file.
n Prepare & upload new file now—Allows you to prepare and upload a new Crash
log file now.
n Prepare now & upload new file at a scheduled time—Allows you to prepare a
Crash log file now and upload it at a later date and time.

Scheduled
Time

If you chose to upload a TAR or Crash log file at a later date and time, configure the
parameters listed here:

n Select Zone—Allows you to configure the time zone.
n Select Date—Allows you to select a date within the range of a week.
n Hours—Allows you to configure hour ranging from 0 to 23.
n Minutes—Allows you to configure minutes ranging from 0 to 59.

Table 72: Upload Log File Configuration Parameters

8. Click Save.

9. The Log Files table displays the information in the table below:

Parameter Description

File type Displays the name of the generated log file.

Type Displays the type of the generated log file:
n TAR file
n Crash file

Status Displays the status of the generated log file.
Scheduled—Displays this status when an existing log file is scheduled for upload.

Table 73: Log Files Parameters
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Parameter Description

In progress—Displays this status when a new log file is generated and it is scheduled for
upload now or for a later date.

Collection
Time

Displays the time when the log file was created.

Size Displays the size of the log file.

User Displays the User ID of the user who generated the log file.

10. To download a log, select the respective log listed in the Log Files table and click the download icon.

11. To delete a log, select the respective log listed in the Log Files table and click the delete icon.

Gateway Diagnostic Tests
Aruba Central provides troubleshooting utilities to test SD-WAN overlay network connections. Users
experiencing device connectivity issues at the branch site at a specific location, can select the device and
specify an IP address to test the network connectivity. SD-WAN diagnostic tests allow users to view the
routing path and forwarding rules that are used to forward or drop packets in an SD-WAN orchestrated
network.

Diagnostic tests identify the routing or forwarding issues in the overlay network path, if any. Following are
two types of diagnostic tests:

n Control plane test

n Data plane test

SD-WAN diagnostic tests do not trace underlay routing network paths.

The minimum firmware version required for performing SD-WAN diagnostic tests is ArubaOS 8.5.0.0-
2.1.0.0.

This section includes the following topics:

n Control Plane on page 539

n Data Plane on page 541

n Node-Specific ErrorMessages on page 543

n Asymmetric Routing on page 543

n Routing Loop on page 544

n Error Notifications on page 544

Control Plane
The control plane builds andmaintains the network topology andmakes decisions on the traffic flow in a
SD-WAN network. Control plane tracing is based on the active routing table entries.

In theControl plane test, the diagnostic framework traces all the nodes and the forward route details in
the orchestrated path from the selected gateway to the destination IP. It also traces all the nodes and the
forward route detail in the reverse path, from the last gateway in the overlay path to the source IP. The last
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gateway in the path tracing output is the gateway in which the packet gets routed through the underlay
routes, but not through the tunnels.

To perform a Control plane test, complete the following steps:

1. In theNetwork Operations app, set the filter to one of the options underGroups, Labels, or
Sites. Ensure that the filter selection contains at least one gateway. For all devices, set the filter to
Global.The dashboard context for the selected filter is displayed.

2. UnderAnalyze > Tools, click Network Check.

3. From theDevice Type drop-down list, select Gateway.

4. From the Test drop-down list, select Diagnostics.

5. From theDiagnostic Type drop-down list, select Control plane.

6. From the Sources drop-down list, select the source.

7. In the Source IP Address field, enter the IP address for which you want to perform the test.

8. In theDestination IP Address field, enter the IP address for which you want to perform the test.

9. Click Run.

The output is displayed in theDevice Output section.

Figure 213 Control Plane—Device Output

Control Plane—Node Details
When you click on a node, a pop-up displays information that allows the user to analyze the data at every
node in the forward and reverse path.

Gateway and VPNC—Node Details

When you click a Gateway node or a VPNC node in a forward or reverse path, the pop-up displays the
following information:

n Forwarded through—Displays the name of the network path.

n Protocol—Displays the type of protocol.

n Cost—Displays themetric value of the path cost.
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Figure 214 Gateway and VPNC—Node Details

Aruba Central Platform—Node Details

When you click an Aruba Central Platform node in a forward or reverse path, the pop-up displays the
following information:

n Originator—Displays the name of the devices which originated the particular route prefix in the overlay
topology. It is the destination IP for the forward path and the source IP for the reverse path.

n Next hop by cost—Displays the list of next hops in an order of increasing value of cost

Figure 215 Aruba Central Platform—Node Details

Data Plane
The data plane is responsible for forwarding the packets based on the decisions from the control plane in a
SD-WAN network. Data plane tracing is based on the current datapath session table entries. Data path
sessions are created when traffic flows through the gateways. When data traffic flow stops, data path
sessions are cleared after the age-out interval of the session. The test output is valid when you execute the
test within the age-out interval of the data path session and there are data path session entries in the
gateway matching your input for the diagnostics test.

For most effective data plane test results, live traffic flowmust be available matching your input for the
diagnostics test.

In theData plane test, the diagnostic framework traces all the nodes and the datapath session status for
the selected flow in the overlay path from the selected gateway to the destination IP or port. It also traces all
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the nodes and the datapath session status for the reverse traffic from the last gateway in the overlay path
to the source IP. The last gateway in the data plane tracing output is the gateway in which the packet gets
routed through the underlay routes or gets dropped because of the configured firewall rules, but not
through the tunnels.

To perform aData plane test, complete the following steps:

1. In theNetwork Operations app, set the filter to one of the options underGroups, Labels, or
Sites. Ensure that the filter selection contains at least one gateway. For all devices, set the filter to
Global. The dashboard context for the selected filter is displayed.

2. UnderAnalyze > Tools, click Network Check.

3. From theDevice Type drop-down list, select Gateway.

4. From the Test drop-down list, select Diagnostics.

5. From theDiagnostic Type drop-down list, select Data plane.

6. From the Protocol drop-down list, select the protocol. The protocols supported are ICMP, IGMP,
IPv4_ENCAP, TCP,UDP, IPv6_ENCAP, RSVP,GRE, IPSEC_ESP, IPSEC_AH, and L2TP.

7. From the Sources drop-down list, select the source.

8. In the Source IP Address field, enter the IP address for which you want to perform the test.

9. In the Port field, enter the port number.

10. In theDestination IP Address field, enter the IP address for which you want to perform the test.

11. In the Port field, enter the port number.

12. Click Run.

The output is displayed in theDevice Output section.

In the Data plane test, the Port fields are optional. When you select the ICMP protocol, the Port fields
are disabled.

Figure 216 Data Plane—Device Output

Data Plane—Node Details
When you click on a node, a pop-up displays information that allows the user to analyze the data at every
node in the forward and reverse path.

Gateway and VPNC—Node Details
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When you click a Gateway node or a VPNC node in a forward or reverse path, the pop-up displays the
following information:

n Forwarded through—Displays the name of the network path.

n Protocol—Displays the type of protocol.

n Cost—Displays themetric value of the path cost.

n Uplink—Displays the name of the uplink.

n Access control list—Displays the firewall ACL/ACE rules applied for the session.

n Dynamic path selection—Displays the SD-WAN DPS policy applied for the session.

n Policy-based routing—Displays the PBR policy applied for the session.

n Error description—Displays the errormessage associated with a specific error.

Figure 217 Gateway and VPNC—Node Details

Node-Specific Error Messages
In the diagnostic tests, when an error occurs, the Error description parameter appears in the pop-up of

that specific node. The icon for that specific node changes to an error icon.
The following are few errormessages:

n Session not found—Errormessage states that the device does not have any session entry for the
specified parameters, such as source IP, destination IP, protocol, source port, or destination port, and the
packet flow did not reach the device.

n ACL denied—Errormessage states that the session has hit a firewall ACL/ACE deny rule and the packets
are dropped by the device.

n Reverse packet not seen—Errormessage states that the device has forwarded the packets to the next
hop in the forward direction but is yet to receive any packets from that next hop device.

n Connection test stopped here due to incompatible device firmware—Errormessage states that the
device firmware is incompatible to run the diagnostic tests.

Asymmetric Routing
Asymmetric routing occurs when the forward traffic traverses from a source to a destination in one path but
the reverse traffic follows a different path from the destination to source. For example, forward traffic from
Branch B1 traverses via VPNC A and the reverse traffic traverses via VPNC A to reach Branch B1.
Asymmetric path is when the reverse traffic traverses via VPNC B to reach Branch B1.

The diagnostic tests detect asymmetric routing in a control plane path and data plane path.
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Figure 218 Asymmetric Routing

Routing Loop
Routing Loop is a network failure in which the traffic is continuously routed back and forth between two
hops rather than reaching the destination host.

The diagnostic tests detect routing loop issues in a control plane path and data plane path.

Error Notifications
The following are a few error notifications:

n Diagnostics test has timed out—Errormessage states that the diagnostic test is not completed within
the expected delay of 60 seconds. The reason for the time out can be one of the following:

n The back-end is still querying a gateway.

n The device fails to answer for a reason.

n Occurs even after partial path data is collected and displayed.

n Diagnostics test request cannot be fulfilled—Errormessage states that the diagnostic test request is
not fulfilled. The reason for the failure of the request can be because invalid parameters are entered in the
diagnostic test request or while querying for the diagnostic test result.

n Diagnostics test is unavailable—Errormessage states that the test cannot be completed and indicates
that the back-end or the source gateway is down.

n Diagnostics test has failed—Default errormessage to indicate errors other thanmentioned above.
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Figure 219 Error Message

Updating Software Images on Aruba Gateways
Aruba Central supports various versions of SD-WAN software images on the Aruba Gateways provisioned in
your account. Using the Aruba Central management interface, you can also update software images on
Gateways. The Firmware page in the Aruba Central also shows the recommended software versions for
each device.

Feature Availability Across Multiple Software Versions
Aruba Central supports provisioning Gateways running different versions of SD-WAN software images.
Although some features introduced in later software versions can be configured at the group level, the
devices running lower software versions do not inherit these configuration changes.

To alert users about the feature availability, Aruba Central shows per-field caution indicators when you try to
configure a feature on a device that is running an older software version. The caution text also displays the
minimum software version that supports the feature. If a software version of a device does not support any
particular feature or function, Aruba Central does not allow you to enable, disable ormodify values for that
feature on the device. After selecting the group from the filter, navigate to Devices and click theConfig
icon to open the Branch Gateway group configuration page. In theAdvanced mode, go to VPN > DPD to
view the feature availability indicator for a group that includes a devicewith a lower software version.

If a software version of a device does not support any particular feature or function, Aruba Central does not
allow you to enable, disable ormodify values for that feature on the device.

Upgrading Software
Aruba recommends that you upgrade your devices periodically to the recommended software version.
Aruba Central also allows you to schedule a compliance check and thus ensure that compatibility between
devices provisioned in a group.

For information on how to upgrade software images on ArubaGateways, see theManaging Software
Upgrades topic in Aruba Central Help Center.

Configuring Aruba Gateways for Syslog Message Collection
This section outlines the steps required to configure logging on an SD-WAN Gateway.
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For each category or subcategory of message, you can set the logging level or severity level of themessages
to be logged.

The following table summarizes these categories:

Code Description

network Network messages

all All network messages

packet-dump Protocol packet dumpmessages

mobility Mobility messages

dhcp DHCPmessages

system Systemmessages

all All systemmessages

configuration Configurationmessages

messages Messages

snmp SNMPmessages

webserver web server messages

security security messages

all all security messages

aaa AAA messages

firewall firewall messages

packet-trace packet trace messages

mobility mobility messages

vpn VPN messages

dot1x 802.1X messages

ike IKE messages

webserver web server messages

wireless wireless messages

all all wireless messages

captive-portal captive portal user messages

vpn VPN messages

Table 74: Software Modules
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Code Description

dot1x 802.1x messages

radius RADIUS user messages

For each category or subcategory, you can configure a logging level. The following table describes the
logging levels in order of severity, frommost to least severe.

Code Description

emergency captive portal user messages

alert VPN messages

critical 802.1x messages

errors RADIUS user messages

warning warning messages

notice Significant events of a non-critical and normal nature.

informational Messages of general interest to system users.

debug Messages containing information useful for debugging.

Table 75: Logging Levels

The default logging level for all categories isWarning. You can also configure IP address of a syslog server to
which the Branch Gateway can direct these logs.

Configuring Logging Levels

1. In theNetwork Operations app, set the filter to a group that contains at least one Branch Gateway.
The dashboard context for a group is displayed.

2. UnderManage, click Devices > Gateways.
A list of gateways is displayed in the List view.

3. Click a gateway underDevice Name.
The dashboard context for the gateway device is displayed.

4. UnderManage, Click Device.
The gateway configuration page is displayed.

5. Click System > Logging.

6. Click + in the Syslog Servers section to add a logging server.

7. Add the logging server to the list of logging servers. Update the followings fields:
n IP address
n Category
n Logging facility
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n Logging level
n Format: Select the logging format from the Format drop-down list. The ArcSight CEF is a log

management standard that uses a standardized logging format so that data can easily be collected
and aggregated for analysis by an enterprisemanagement system.

Ensure that the syslog server is enabled and configured on this host.

8. Click Save Settings.

To select the types of messages you want to log, select Logging Levels.

1. Select the category or subcategory to be logged.

2. To select the severity level for the category or subcategory, select the level from the Logging Level
drop-down list.

3. Click Save Settings.



Chapter 18
APIs

APIs
Aruba Central supports an Application Programming Interface (APIs) to allow the administrator users to
create andmanage APIs. It supports the following types of APIs:

n A polling-based API—The Representational State Transfer (REST)-based APIs support HTTP GET operations
by providing a specific URL for each query. The output for these operations are returned in the JSON
format.

n Push or Event APIs—The Push API gives web applications the ability to receivemessages pushed to them
from a server.

The API Gateway feature in Aruba Central offers the following benefits:

n Provides an API management gateway to create, publish, mange the life cycle of APIs

n Provides a gateway that can run on public and private cloud as containers

n Displays the API usage pattern

n Provides a developer portal to develop applications using the APIs

Formore information on API Gateway, supported APIs, and theOAuth token generation procedure, see API
Gateway in Aruba Central Help Center.
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