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Pioneers in Electricity
he phenomenon that Thales had observed and recorded in antiquity aroused the interest of many 

scientists through the ages. They made various practical experiments in their efforts to identify the  

elusive force that Thales had likened to a "soul" and which we now know to have been static electricity.  

Of all forms of energy, electricity is the most baffling and difficult to describe. An electric current cannot 

be seen. In fact it does not exist outside the wires and other conductors that carry it. A live wire carrying 

a current looks exactly the same and weighs exactly the same as it does when it is not carrying a current.   

An electric current is simply a movement or flow of electrons. 

The following sections describe some pioneers in the advancement of our knowledge of electricity.

The Early Scientists

Benjamin Franklin

Benjamin Franklin, the American statesman and scientist born in Boston in 1706, investigated the nature 

of thunder and lightning by flying a child’s kite during a thunderstorm. He had attached a metal spike to 

the kite, and at the other end of the string to which the kite was tied he secured a key. As the rain soaked  

into the  string, electricity flowed freely down the string and Franklin was able to draw large sparks from 

the key. Of course this could have been very dangerous, but he had foreseen it and supported the  

FrameMaker documents easily convert to 

Hypertext Markup Language (HTML) 

for delivery on the World Wide Web or 

your company’s intranet. You can convert 

single documents or books, split docu-

ments into multiple Web pages, and 

include image maps and links to other 

Web sites. FrameMaker creates an HTML 

stylesheet along with the HTML docu-

ment so that much of your text format-

ting is preserved when viewed with a Web 

browser that supports stylesheets.



LESSON 15342
Web Publishing

In this lesson, you’ll save a FrameMaker document as Hypertext Markup Language 

(HTML) and view the resulting file in a Web browser. Then you’ll refine your document 

by adding links and dividing the original document into a series of Web pages. You’ll learn 

how to do the following:

• Save a document as HTML

• Refine the automatic mapping of FrameMaker formats to HTML elements

• Add links to other Web pages

• Create an image map

• Split a long document into multiple Web pages

• Add navigation buttons to a series of Web pages

Note: The more advanced exercises require at least a little knowledge of HTML. If you don’t 

have any familiarity with HTML, you can skip those sections.

For best results, you should view your HTML files in a Web browser that supports HTML 

stylesheets (.css files). Netscape Navigator 4.0 (or later) and Microsoft Internet 

Explorer 3.0 (or later) both support stylesheets.

About WebWorks Standard Edition
In addition to using the Save As command to export FrameMaker documents to SGML 

and HTML formats, FrameMaker includes Quadralay WebWorks Publisher Standard 

Edition, which provides robust features for creating HTML, Dynamic HTML, and XML 

output. You can use WebWorks Standard Edition to do the following:

• Map FrameMaker elements (such as paragraph tags, character tags, and graphics) to 

online styles.

• Convert text, graphics, and tables to HTML, Dynamic HTML—HTML with cascading 

style sheets (CSS)—and XML.

• Determine how a FrameMaker document is divided into one or more HTML files.

• Convert any images to online formats.

• Specify how navigation bars appear at the top and bottom of a page.

• Create an HTML FrameSet.
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You can install WebWorks Standard from the separate CD included in your FrameMaker 

product package. For more information on setting up and using WebWorks Standard, see 

the WebWorks Publisher Standard Edition User Guide.

Viewing the finished document
A copy of the final FrameMaker document, called Finished.fm, with all the refinements 

you’ll be working on in this lesson is in the Lesson15 folder. 

1 In the Lesson15 folder, open Finished.fm. 

2 Take a few moments to explore it. Notice the following:

• The basic layout of this document is two columns, except for the first few paragraphs 

and the table at the end.

• On the first page, the graphic at the top of the page, the drop cap at the start of the first 

body paragraph, and the graphic describing the three main sections of the chapter are 

each in anchored frames. 

• The document has three levels of headings. If you click in the title, Pioneers in Electricity, 

you’ll see in the status bar that the paragraph tag is Heading1. The heading Section 1: The 

Early Scientists is tagged Heading2. The Heading2 format includes an autonumber 

(Section 1:). The run-in heading (Benjamin Franklin) is the third level of heading in the 

document, format Heading3.

1

Pioneers in Electricity
he phenomenon that Thales had observed and recorded in antiquity aroused the interest of many sci-
entists through the ages. They made various practical experiments in their efforts to identify the elu-
sive force that Thales had likened to a “soul” and which we now know to have been static electricity.

Of all forms of energy, electricity is the most baf ing and dif cult to describe. An electric current cannot be 
seen. In fact it does not exist outside the wires and other conductors that carry it. A live wire carrying a current 
looks exactly the same and weighs exactly the same as it does when it is not carrying a current. An electric 
current is simply a movement or  ow of electrons.

The following sections describe some pioneers in the advancement of our knowledge of electricity.

Section 1:  The Early Scientists
Benjamin Franklin Benjamin Franklin, the 
American statesman and scientist born in Boston in 
1706, investigated the nature of thunder and light-
ning by  ying a child’s kite during a thunderstorm. He 

had attached a metal spike to the kite, and at the 
other end of the string to which the kite was tied he 
secured a key. As the rain soaked into the string, 
electricity  owed freely down the string and Franklin 
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• On page 3, at the end of the section about Thomas Alva Edison, you’ll see a cross-

reference to another section of the document: see “The Achievements of Nicola Tesla” on 

page 4.

• On page 6, you’ll see both numbered and bulleted lists.

• Also on page 6, you’ll find a table with ruling and shading.

3 Close Finished.fm.

Now that you’re familiar with how the document will look, you’re ready to start.

Saving as HTML
When you save a document as HTML for the first time, FrameMaker automatically maps 

FrameMaker formats to HTML elements and then converts the document. As you’ll see 

later, you can adjust the automatic mappings if they don’t meet your needs.

1 In the Lesson15 folder, open Web.fm. 

2 Choose File > Save As, enter the filename Web1.fm, and click Save.

Now you’re ready to convert to HTML, a process that can be as simple as saving the file.

3 Choose File > Save As.

4 Enter the filename Web1.html, making sure to include the file extension .html.

Edison’s one-time employee Nicola Tesla went on to 
rival his employer and in many respects to outshine 
him. For more information on this remarkable—albeit 
obscure—inventor, see “The Achievements of Nicola 
Tesla” on page 4.
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5 Choose HTML from the pop-up menu.

6 Click Save. 

That’s it. You’ve converted the document to an HTML file. In the few moments after you 

clicked Save, FrameMaker set up mappings for formats to HTML elements, used those 

mappings to create a new HTML file, converted graphics in anchored frames to GIF 

format, and created an HTML stylesheet (more on stylesheets in a moment).

7 Minimize or hide FrameMaker (but don’t exit).

8 In your operating system, navigate to the Lesson15 folder. You will see the following 

files that FrameMaker created (in Windows, you may need to show file extensions to 

differentiate these files):

• Web1.html, which is the new HTML file containing the original FrameMaker text

• Web1-1.gif and Web1-2.gif, which are graphics files
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• Web1.css, which contains HTML formatting information (the HTML stylesheet)

Viewing the results in a Web browser
Before you open the HTML file in your Web browser, you’ll rename the Web1.css file. This 

way you’ll see how your Web browser displays the HTML file without the effect of a 

stylesheet.

As you view the converted HTML file, remember that many factors affect how the Web 

page looks. Different Web browsers format text differently. Also, you may have 

customized the default settings of your browser.

Keep the FrameMaker document handy as you look at the HTML file so you can compare 

the conversion.

1 In your operating system, rename the file Web1.css to xWeb1.css. Changing its name 

prevents it from being used when you view the HTML file in your browser.
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2 Open the file Web1.html in your Web browser. 

3 Notice the following:

• The entire Web page is one column even though the original document was two 

columns in FrameMaker. (HTML doesn’t support multiple text columns, but a 

workaround exists. You could have created the FrameMaker document by entering your 

text in tables. FrameMaker converts tables without ruling lines to HTML tables with 

invisible borders, thereby simulating multiple columns of text.)

• The top banner graphic, and the drop cap at the start of the first body paragraph 

converted with the text. These graphics were originally TIF images. FrameMaker 

converted them to GIF. (The Web doesn’t support TIF.) Later you’ll see how to convert 

graphics to other graphic formats that the Web supports.

• The section heading The Early Scientists no longer has its autonumber (Section 1:).

• The third-level heading Benjamin Franklin is no longer a run-in head. 

• At the end of the second paragraph about Thomas Edison, the cross-reference 

converted to a link and the page number is gone.

• Near the end of the Web page, the numbered questions and the bulleted list converted 

to HTML numbered and bulleted lists. 

• The table lost its shading and its rotated cells because HTML table formatting is more 

limited than FrameMaker’s.

Pioneers in Electricity
he phenomenon that Thales had observed and recorded in antiquity aroused the interest of many 

scientists through the ages. They made various practical experiments in their efforts to identify the  

elusive force that Thales had likened to a "soul" and which we now know to have been static electricity.  

Of all forms of energy, electricity is the most baffling and difficult to describe. An electric current cannot 

be seen. In fact it does not exist outside the wires and other conductors that carry it. A live wire carrying 

a current looks exactly the same and weighs exactly the same as it does when it is not carrying a current.   

An electric current is simply a movement or flow of electrons. 

The following sections describe some pioneers in the advancement of our knowledge of electricity.

The Early Scientists

Benjamin Franklin

Benjamin Franklin, the American statesman and scientist born in Boston in 1706, investigated the nature 

of thunder and lightning by flying a child’s kite during a thunderstorm. He had attached a metal spike to 

the kite, and at the other end of the string to which the kite was tied he secured a key. As the rain soaked  

into the  string, electricity flowed freely down the string and Franklin was able to draw large sparks from 

the key. Of course this could have been very dangerous, but he had foreseen it and supported the  
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4 Rename xWeb1.css back to Web1.css, and then click Reload (or Refresh) in your Web 

browser window.

As the page reloads, you will see the difference a stylesheet makes. (But if you’re using a 

browser that doesn’t support stylesheets, such as Navigator 3.0, there will be no 

difference.) The text size, weight, and color now more closely match the original 

document. The difference will be most obvious in the heading paragraphs. 

Without a stylesheet (left), and with a stylesheet (right)

5 Close your Web browser or minimize its window.

Refining the mappings
When you save a document as HTML or open the HTML Setup dialog box for the first 

time, FrameMaker automatically maps paragraph and character formats to standard 

HTML elements and cross-reference formats to special conversion macros.

You can change these automatic mappings in the HTML Setup dialog box.

Pioneers in Electricity
he phenomenon that Thales had observed and recorded in antiquity aroused the interest of many 

scientists through the ages. They made various practical experiments in their efforts to identify the  

elusive force that Thales had likened to a "soul" and which we now know to have been static electricity.  

Of all forms of energy, electricity is the most baffling and difficult to describe. An electric current cannot 

be seen. In fact it does not exist outside the wires and other conductors that carry it. A live wire carrying 

a current looks exactly the same and weighs exactly the same as it does when it is not carrying a current.   

An electric current is simply a movement or flow of electrons. 

The following sections describe some pioneers in the advancement of our knowledge of electricity.

The Early Scientists

Benjamin Franklin

Benjamin Franklin, the American statesman and scientist born in Boston in 1706, investigated the nature 

of thunder and lightning by flying a child’s kite during a thunderstorm. He had attached a metal spike to 

the kite, and at the other end of the string to which the kite was tied he secured a key. As the rain soaked  

into the  string, electricity flowed freely down the string and Franklin was able to draw large sparks from 

the key. Of course this could have been very dangerous, but he had foreseen it and supported the  

Pioneers in Electricity

he phenomenon that Thales had observed and recorded in antiquity aroused the interest of many scientists through   

likened to a "soul" and which we now know to have been static electricity.

Of all forms of energy, electricity is the most baffling and difficult to describe. An electric current cannot be seen. In fact 

it does not exist outside the wires and other conductors that carry it. A live wire carrying a current looks exactly the same 

 

and weighs exactly the same as it does when it is not carrying a current. An electric current is simply a movement or flow 

of electrons.  

The following sections describe some pioneers in the advancement of our knowledge of electricity.

The Early Scientists

Benjamin Franklin

the ages. They made various practical experiments in their efforts to identify the elusive force that Thales had 
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Looking at and changing paragraph mappings

The easiest way to inspect or change mappings is to use the HTML Setup dialog box.

1 In FrameMaker, go to the first page of Web1.fm, click in the first body paragraph, and 

then choose File > Utilities > HTML Setup. 

This dialog box contains the following three pop-up menus:

• The Map pop-up menu determines the type of mappings. It is initially set to Paragraph 

Formats. If you wanted to remap a Character format, you’d choose Character Formats 

from that pop-up.

• The From pop-up menu lists the formats that are in the document’s catalog. 

• The To pop-up menu lists the HTML elements that can be mapped to paragraphs.

The mapping for the current paragraph is displayed in the HTML Setup dialog box: The 

paragraph format 1stParagraph is mapped to the Paragraph HTML element. You can view 

the mappings for other paragraphs simply by clicking in them. 

2 Click in the paragraph under the heading Benjamin Franklin. You’ll see that this 

paragraph, tagged Body, is also mapped to the Paragraph HTML element. (On the 

Macintosh, you may have to resize the document window so that both the window and 

the dialog box are showing.)

Benjamin Franklin Benjamin Franklin, the 
American statesman and scientist born in Boston in 
1706, investigated the nature of thunder and light-
ning by  ying a child’s kite during a thunderstorm. He 



LESSON 15350
Web Publishing

This mapping is what you normally want, so you won’t change it.

You can also see what the mappings are that FrameMaker set up by choosing a format 

from the From pop-up menu. You’ll do this next.

3 Choose Heading1 in the From pop-up menu. Notice that Heading1 maps to 

Heading (Auto Level). This mapping means that FrameMaker will determine which of the 

six HTML heading elements is most appropriate. If you wanted to map a paragraph 

format to a specific HTML heading element, you would have to edit the special tables in 

the document’s reference pages. You’ll examine the reference pages later.

Again, this mapping is what you want in most cases, so you won’t change it. There is, 

however, a format whose mapping in this document could be improved. The decorative 

divider dots used between the sections about the individual scientists in the original 

FrameMaker document are less effective in the HTML document. Next, you’ll remap 

them so that they won’t appear in the HTML document. 

The divider dots in the FrameMaker document 

The divider dots in the converted HTML document 

4 Choose Paragraph Divider in the From pop-up menu. This format is currently mapped 

to the HTML Paragraph format.

Otto von Guericke Otto von Guericke (1602–
1686) a Mayor of Magdeburg in Germany, was an 
amateur scientist who had constructed all manner of 
gadgets. One of them was a machine consisting of 
two glass discs revolving in opposite directions 
which produced high voltage charges through fric-
tion. 

•  •  •

Alessandro Volta A signi cant breakthrough 
occurred when Alessandro Volta (1745–1827) in It-

Otto von Guericke

Otto von Guericke (1602-1686) a Mayor of Magdeburg in Germany, was an amateur scientist who 

had constructed all manner of gadgets. One of them was a machine consisting of two glass discs 

revolving in opposite directions which produced high voltage charges through friction. 

Alessandro Volta

A significant breakthrough occurred when Alessandro Volta (1745-1827) in Italy constructed a 

simple electric cell (in 1799) which produced a flow of electrons by chemical means. Two plates, 

•  •  •
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5 Choose Throw Away from the To pop-up menu and then click Change.

The next time you save as HTML, any text formatted as Paragraph Divider will be omitted 

in the conversion.

Looking at cross-reference mappings

Cross-reference formats don’t map directly to HTML elements. FrameMaker uses a 

conversion macro to change cross-references to HTML.

1 Choose Cross-Reference Formats from the Map pop-up menu.

2 Click the From pop-up menu to display its contents. The From pop-up menu lists the 

document’s cross-reference formats.

3 Click the To pop-up menu to display its contents. The To pop-up menu lists the 

currently defined cross-reference conversion macros. (Later you’ll see where to add new 

macros in the HTML reference pages.)
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The See Also macro is the default mapping for all cross-references in a document, and you 

won’t need to change it in this document. However, if you wanted to keep the original 

format of a cross-reference, you would choose Original Cross-Reference Format from the 

To pop-up menu. If you wanted to delete the cross-reference from the HTML file, you’d 

choose Throw Away from the To pop-up menu.

Specifying a graphic format
FrameMaker automatically copies and converts graphics in anchored frames to a specified 

Web image format. If the graphic was imported by copy, FrameMaker creates a GIF (or 

JPEG, or PNG) version of the graphic and places it in the folder in which you save the 

HTML file. If the graphic was imported by reference, FrameMaker creates a new file if the 

original format is not the Web format that you specified. 

You’ll see how to set the image format for conversion.

1 In the HTML Setup dialog box, click Options. GIF is selected.

2 Click JPEG, click OK, then close the HTML Setup dialog box. The next time you save 

this document as HTML, the graphics will convert to JPEG format instead of GIF.

3 Save Web1.fm.

Adding hypertext links
You’ve seen that cross-references in the original FrameMaker document automatically 

convert to HTML links, but you may also want to include other types of links in your Web 

pages. First you’ll add a link to another Web site, and then you’ll make an image map.

Adding a link to another Web site

A uniform resource locator (URL) defines the location of a Web page on the Internet. 

You’ll insert a special marker into the document that will become a link to a URL when 

you save as HTML.
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1 In the last paragraph of the document, below the table, select the text Adobe Systems, 

Inc. 

2 Press Control+8, press l (lowercase L), and then press Return to apply the Link 

character format to the selected text. (Actually, any character format would work, but the 

Link format has already been defined for you.) The text becomes underlined and purple.

3 Click between the words Adobe and Systems, and then choose Special > Hypertext.

4 Choose Message Client from the Command pop-up menu and enter 

URL http://www.adobe.com in the text box after message.

5 Click New Hypertext Marker, then close the Hypertext dialog box.

The next time you save as HTML, FrameMaker converts this marker to a link to 

www.adobe.com. The active area of the link will be defined by the character format you 

applied (the Link format).

Prepared for Adobe Systems, Inc.

Thomas Edison 

Michael Faraday

Adobe Systems, Inc.

Thomas Edison 

Michael Faraday

Prepared for 
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Creating an image map

An image map on a Web page is a graphic in which different areas of the image are defined 

as links to other locations. You’ll import a graphic into the FrameMaker document and 

set it up so that it converts to an image map when you save as HTML.

1 Go to the first page of the document and click at the end of the third body paragraph 

(the sentence ending with our knowledge of electricity). 

2 Choose File > Import > File, navigate to the art folder within the Lesson15 folder, and 

click Imagemap.tif. 

3 Be sure that Import by Reference is selected and click Import.

4 In the Imported Graphic Scaling dialog box, click 72 dpi and click Set.

5 Click the Tools button ( ) on the right side of the document window to open the Tools 

palette. 

6 Use the text frame tool ( ) to draw a text frame over each of the three panels of the 

graphic, as shown, clicking Set in the Create New Text Frame dialog box that appears after 

each drag. (If you can’t easily make the frame the right size, choose Graphics > Snap to 

turn the snap grid off.) The placement of each text frame will determine a “hot spot” 

(a clickable rectangular area) of the image map. When you’re finished, close the Tools 

palette.

Now you’ll add hypertext markers to the text frames. The markers can be links to other 

locations in your document, to other documents that you’ll be converting as part of a 

book, or to a URL, such as the link you added in the previous section.

looks exactly the same and weighs exactly the same as it does when it is not carrying a current. An electric 
current is simply a movement or  ow of electrons.¶

The following sections describe some pioneers in the advancement of our knowledge of electricity.¶

Section 1:  The Early Scientists¶

The following sections describe some pioneers in the advancement of our knowledge of electricity.¶
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You’ll create links to three headings in the current document. You need destination 

hypertext markers (called newlink markers) in the three heading paragraphs. These will 

convert into HTML anchors. You’ll add a newlink marker next.

7 Click in the heading Section 1: The Early Scientists, and then choose Special > 

Hypertext.

8 Choose Specify Named Destination from the Command pop-up menu, click in the text 

box, and enter scientists after newlink. Then, click New Hypertext Marker. This adds the 

newlink marker you’ll need when you create a link in the image map.

The other newlink markers in the other two section headings are already in place, so you 

won’t have to insert those. Now you’ll insert the hypertext markers in the image map that 

will jump to the locations of these newlink markers. 

9 Click in the left text frame that you drew over Early Scientists. In the Hypertext dialog 

box, choose Jump to Named Destination from the Command pop-up menu.

The following sections describe some pioneers in the advancement of our knowledge of electricity.¶

Section 1:  The Early Scientists ¶
Benjamin Franklin Benjamin Franklin, the 
American statesman and scientist born in Boston in 

had attached a metal spike to the kite, and at the 
other end of the string to which the kite was tied he 
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10 Click in the text box after gotolink and enter scientists. Then, click New Hypertext 

Marker. (If you need to redraw the document display, press Control+l.)

11 Click in the middle text frame that you drew over 19th Century Advancements. 

12 In the Hypertext dialog box, choose Jump to Named Destination from the Command 

pop-up menu, click in the text box after gotolink, and enter 19century. Then, click New 

Hypertext Marker.

13 Click in the right text frame that you drew over Achievements of Nicola Tesla. 

14 In the Hypertext dialog box, choose Jump to Named Destination from the Command 

pop-up menu, click in the text box after gotolink, and enter tesla (making sure to use the 

correct spelling). Then, click New Hypertext Marker.

15 Close the Hypertext dialog box.

The next time you save as HTML, the new graphic will function as an image map in the 

HTML document, with each area of the graphic being a link to each of the three sections.

Splitting the document into multiple Web pages
Accessing documents on the World Wide Web is more efficient when the documents are 

small. For this reason, you’ll often want to have FrameMaker split your document into 

several Web pages. Later you’ll add links and buttons that readers can use to return to the 

main page and move between pages in the series.
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To divide the document, you’ll specify a heading format that will signify the start of a new 

Web page. Every paragraph tagged with the format you choose will appear as an H1 

HTML element at the top of a Web page. Subheads in the document will be promoted and 

retain their relative head level to the new H1. On the main (first) Web page, you’ll see the 

document’s introductory paragraphs, followed by HTML links to the new files that 

FrameMaker automatically split off. The result looks and works like a table of contents.

FrameMaker names the new files by adding -1, -2, and so on, to the original filename.

1 Choose File > Utilities > HTML Setup.

2 In the HTML Setup dialog box, choose Paragraph Formats from the Map pop-up 

menu and choose Heading2 in the From pop-up menu.

3 Select Start New, Linked Web Page, and click Change.

4 Close the HTML Setup dialog box, then save the document.

Later, you’ll save the document as HTML and see the results.

Seeing the results in HTML
You’re now ready to save the Web1.fm document as HTML again to see the results of the 

work you’ve done so far. 

1 Choose File > Save As and navigate to the Lesson15 folder.
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2 Enter the filename Web1.html—make sure to include the file extension .html—and 

choose HTML from the pop-up menu. 

3 Click Save, then click OK (Replace on the Macintosh) to overwrite the existing 

Web1.html file.

4 Minimize or hide the FrameMaker window.

5 In your operating system, open the Lesson15 folder. You’ll see the following files that 

FrameMaker has created:

• The main HTML document, Web1.html

• The subdocuments that are linked to the main HTML document, Web1-1.html, 

Web1-2.html, Web1-3.html, and Web1-4.html

• The HTML stylesheet, Web1.css

• The converted graphics files, Web-1.jpg, Web1-2.jpg, and Web1-3.jpg
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6 Open Web1.html in your Web browser.

This is the main document. It contains the image map graphic and under it, hypertext 

links to the four subdocuments. Now is a good time to test the several types of links you 

entered.

7 Explore the linked files, noticing the following:

• The image map you created (see page 354) now works. You can click it to jump to the 

specified section. (Click the Back button in your browser to return to the main page.)

• The single FrameMaker document has been automatically split up into linked HTML 

subdocuments, just as you specified (see the previous section) at each Heading2. You can 

click the links to jump to the specified sections. (Click the Back button in your browser to 

return to the main page.)

Pioneers in Electricity

he phenomenon that Thales had observed and recorded in antiquity aroused the interest of many 

scientists through the ages. They made various practical experiments in their efforts to identify the 

elusive force that Thales had likened to a "soul" and which we now know to have been static electricity.

Of all forms of energy, electricity is the most baffling and difficult to describe. An electric current cannot be seen. 

In fact it does not exist outside the wires and other conductors that carry it. A live wire carrying a current looks 

exactly the same and weighs exactly the same as it does when it is not carrying a current. An electric current is  

simply a movement or flow of electrons.

The following sections describe some pioneers in the advancement of our knowledge of electricity.

The Early Scientists

19th Century Advancements

The Achievements of Nicola Tesla

Review Questions
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• The divider dots that you remapped to Throw Away (see page 351) no longer appear in 

the HTML subdocuments.

• Graphic files in the HTML document are now in JPEG format instead of GIF, as you 

specified (see page 352).

• Clicking the URL link you created (see page 353) at the bottom of the last subdocument 

opens the main page of the Adobe Web site (www.adobe.com) in your browser. 

Advanced topics
The following sections deal with advanced topics that require some familiarity with 

HTML code and concepts. You don’t need to go through these exercises unless you want 

to work with HTML macros or learn more about how FrameMaker stores and keeps track 

of mappings. 

If you decide to skip these advanced topics, you’re finished with this lesson. To review 

what you’ve learned, see “Review questions” on page 368.

Examining the reference pages

FrameMaker stores information about format mapping on reference pages. All the 

settings that you make in the HTML Setup dialog box are reflected on these pages—plus 

many more options.

This is also where you set up conversion macros for cross-references or embed Java 

applets.

1 Minimize or hide your browser window and return to the FrameMaker window.

2 If the HTML Setup dialog box is still open, close it.

3 Choose View > Reference Pages.
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4 Go to the third reference page, called HTML. (You’ll see the page name in the status 

bar.) This reference page contains several tables and spans several pages. 

HTML Mapping Table§
FrameMaker Source Item§ HTML Item§        Include 

Auto#§
Comments§

Element§ New Web 
Page?§

P:1stParagraph§ P§ N§         
P:Body§ P§ N§         
P:Bullet§ LI¶

Parent = UL¶

Depth = 1§

N§

N§
N§
N§
N§
N§
N§
N§
N§
N§
N§
N§

§

§
§
§
§
§
§
§
§
§
§
§

N§
N§
N§

§
§
§

N§ §

N§ §

N§ §

N§
N§

§
N§ §

P:CellBody§ P§ N§
P:CellBodyRotate§ H*§ N§
P:CellHeading§ P§ N§
P:credit§ P§ N§
P:Heading1§ H*§ N§
P:Heading2§ H*§ Y§
P:Heading3§ H*§ N§
P:Mapping Table Cell§ P§ N§
P:Mapping Table Title§ P§ N§
P:MessageBody§ P§ N§
P:Numbered§ LI¶

Parent = OL¶

Depth = 0§

N§

P:Numbered-2ndlevel§ LI¶

Parent = OL¶

Depth = 0§

N§

P:Numbered1§ LI¶

Parent = OL¶

Depth = 0§

N§

P:Paragraph Divide§ THROW AWAY§ N§
P:Quote§ P§ N§
P:TableTitle§ LI¶

Parent = OL¶

Depth = 0§

N§

C:Emphasis§ EM§ N§
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5 Scroll through the tables in the reference pages and note the following:

• The first table on the page is called the HTML Mapping Table. It sets up the mappings 

of FrameMaker formats to HTML elements. The left column lists all the formats in the 

FrameMaker document. In the first body row you see P:1stParagraph. The P: indicates 

that the item is a paragraph format. (C: indicates a character format and X: indicates a 

cross-reference format.) 1stParagraph is the paragraph tag. The second column indicates 

the HTML element that this paragraph format maps to. 

• The third column indicates (with Yes or No) whether FrameMaker starts a new Web 

page. Look at this setting for P:Heading2. You see a Y because this is the heading you 

changed earlier in the HTML Setup dialog box.

• The Include Auto# column indicates (with Yes or No) whether to include a FrameMaker 

autonumber in the paragraph. FrameMaker automatically converts paragraphs that start 

with a number or a bullet to HTML ordered and unordered lists—so normally, you won’t 

want the FrameMaker autonumber also included. 

HTML Mapping Table§
FrameMaker Source Item§ HTML Item§        Include 

Auto#§
Comments§

Element§ New Web 
Page?§

P:1stParagraph§ P§ N§         
P:Body§ P§ N§         
P:Bullet§ LI¶

Parent = UL¶

Depth = 1§

N§ §

N§
N§

§
N§ §

C:Emphasis§ EM§ N§ N§
N§
N§
N§

§
§
§
§

C:Link§ EM§ N§
X:Heading & Page§ See Also§ N§
X:Page§ See Also§ N§

N§
N§
N§
N§

§
§
§
§

P:Heading1§ H*§ N§
P:Heading2§ H*§ Y§
P:Heading3§ H*§ N§
P:Mapping Table Cell§ P§ N§
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6 Scroll to the System Macros table. This table contains predefined macros you can use 

to add items to the start and end of your Web pages. You’ll edit this table in a minute.

7 Scroll to the last reference page, the Headings reference page. The only table here is the 

Headings table. This is where the settings for the autolevel headings are stored. 

Now that you’ve had a brief tour of the mappings on the HTML and Headings reference 

pages you’ll edit a table. 

Including return links to the main page

When you divide a document into several Web pages, FrameMaker automatically creates 

a linked “table of contents” so that your readers can navigate to the other pages in the 

series. But to return to the main contents page, a reader must click the Back button in the 

browser window. You can provide a more elegant way to get back to the main document 

by having FrameMaker insert a hypertext return link at the end of each subdocument.

To provide the return links, you need to edit the System Macros table on the HTML 

reference page.

Headings Table§
Heading Level§ Paragraph Format§ Comments§
1§ Heading1§
2§ Heading2§
3§

§

§

§

§

Heading3§
4§ CellBodyRotate§
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1 Scroll to the System Macros table on the HTML reference page.

2 In the Replace With column of the EndOfSubDoc row, enter the following HTML code 

to add a link to the subpages, but not to the main page or the last page in the series:

<P><A HREF="<$parentdoc>"> Return to main page </A></P>

Note: Don’t be concerned about how this HTML code wraps or hyphenates in the table cell. 

FrameMaker will read the code as if it were one unbroken line.

Here is an analysis of the parts of this code:

<P> ... </P> <A> ... </A> HREF="<$parentdoc>"  Return to main page

Start and end of 
the paragraph 
element

Start and end of 
the linking 
(anchor) ele-
ment

The hypertext reference for the link: in 
this case, the FrameMaker building 
block for the parent document (the doc-
ument from which this document was 
split) 

The text that will be the 
link (it will be clickable)

HTML Mapping Table§
FrameMaker Source Item§ HTML Item§                              Include 

Auto#§
Comments§

§
§
§
§
§
§
§
§

§
§
§
§
§
§
§
§

§
§
§
§
§
§
§

§
§

§

§

§

§

N§
N§
N§
N§
N§
N§
N§

Elemen§ New Web 
Page?§

P:TableTitle§ LI¶

Parent = OL¶

Depth = 0§

N§        N§ §

C:Emphasis§ EM§ N§
C:Link§ EM§ N§
X:Heading & Page§ See Also§ N§
X:Page§ See Also§ N§
X:See Heading & Page§ See Also§ N§
X:Table All§ See Also§ N§
X:Table Number & Pag§ See Also§ N§

HTML Options Table§
Contro§l Value§ Comments§
Image Format§ 0001IMAGJPEGMACP0001JPEG§
Copy Files Imported by Reference§ N§

System Macros§
Macro Name§ Replace With§     Head§     Comments§
StartOfDoc§     <TITLE> <$defaulttitle></TITLE>§
EndOfDoc§
StartOfSubDoc§     <TITLE> <$defaulttitle></TITLE>§
EndOfSubDoc§
StartOfFirstSubDoc§     <TITLE> <$defaulttitle></TITLE>§
EndOfFirstSubDoc§
StartOfLastSubDoc§     <TITLE> <$defaulttitle></TITLE>§
EndOfLastSubDoc§

Cross-Reference Macros
Macro Name§ Replace With§ Comments§
See Also§ <$paratext>§ §

General Macros§
Macro Name§ Replace With§ Head§ Comments§
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3 Copy the HTML code you just entered and paste it in the Replace With column of the 

EndOf LastSubDoc row. This takes care of the return link for the last page.

Adding navigation buttons to individual pages

You’ve added a way to return to the main page, but it would also be nice to be able to move 

to the next and previous subdocument without having to go back to the main page first. 

You’ll add links to do that next, and you’ll enhance the links with graphics that will work 

as buttons.

The button graphics are in the Lesson15 art folder. You’ll reference these graphics and add 

the code to make them active.

Once again you’ll edit the System Macros table on the HTML reference page. 

§
§
§

§
§
§

§
§
§
§

§
§
§

§

§

§

§

System Macros§
Macro Name§ Replace With§     Head§     Com
StartOfDoc§     <TITLE> <$defaulttitle></TITLE>§
EndOfDoc§
StartOfSubDoc§     <TITLE> <$defaulttitle></TITLE>§
EndOfSubDoc§

StartOfFirstSubDoc§     <TITLE> <$defaulttitle></TITLE>§
EndOfFirstSubDoc§
StartOfLastSubDoc§     <TITLE> <$defaulttitle></TITLE>§
EndOfLastSubDoc§

page </A></P>§
<P><A HREF="<$parentdoc>">Return to main 

page </A></P>§
<P><A HREF="<$parentdoc>">Return to main 

storage battery. When he touched the tips of the rods together a very bright white light was

produced. As he drew the rods apart, the arc light persisted until the tips had burnt away to

the critical gap which extinguished the light. As a researcher and lecturer at the Royal

Institution Davy worked closely with Michael Faraday (see  ) who first

joined the institution as his manservant and later became his secretary.       

Michael Faraday

Return to main page
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1 In the System Macros table on the HTML reference page, click between </A> and </P> 

in the Replace With column of the EndOfSubDoc row.

2 Enter the following text:

<A HREF="<$prevsubdoc>"><IMG SRC="Art/back.gif " Border=0></A>
<A HREF="<$nextsubdoc>"><IMG SRC="Art/forward.gif " Border=0></A>

Note: Type the HTML exactly as you see it here. FrameMaker cannot check the HTML code 

for errors. The links won’t work if you make a typing error.

The buttons will appear in every Web page after the first—except for the last page. On the 

last page you’ll want to add only a back button; you’ll do that next.

3 In the Replace With column of the EndOf LastSubDoc row, enter the following text 

between </A> and </P>:

<A HREF="<$prevsubdoc>"><IMG SRC="art/back.gif " Border=0></A>

§
§
§

§
§
§

§
§
§
§

§
§
§

§

§

§

§

System Macros§
Macro Name§ Replace With§     Head§     Com
StartOfDoc§     <TITLE> <$defaulttitle></TITLE>§
EndOfDoc§
StartOfSubDoc§     <TITLE> <$defaulttitle></TITLE>§
EndOfSubDoc§

StartOfFirstSubDoc§     <TITLE> <$defaulttitle></TITLE>§
EndOfFirstSubDoc§
StartOfLastSubDoc§     <TITLE> <$defaulttitle></TITLE>§
EndOfLastSubDoc§

page </A> </P>§
<P><A HREF="<$parentdoc>">Return to main 

page </A></P>§
<P><A HREF="<$parentdoc>">Return to main 



367ADOBE FRAMEMAKER 6.0
Classroom in a Book

The completed table looks like this:

4 Choose View > Body Pages, and choose File >Save.

Viewing the navigation links in a Web browser

You’ve made all your adjustments and now you’re ready to save your document as HTML 

one last time.

1 Choose File > Save As and navigate to the Lesson15 folder.

2 Enter the filename Web1.html—make sure to include the file extension .html—and 

choose HTML from the pop-up menu. 

3 Click Save, then click OK (Replace on the Macintosh) to overwrite the existing 

Web1.html file.

4 Open Web1.html in your Web browser to test the new navigation links.

§
§
§

§
§
§

§

§

§
§
§
§

§
§
§
§

§

§

System Macros§
Macro Name§ Replace With§     Head§     Com
StartOfDoc§     <TITLE> <$defaulttitle></TITLE>§
EndOfDoc§
StartOfSubDoc§     <TITLE> <$defaulttitle></TITLE>§
EndOfSubDoc§

StartOfFirstSubDoc§     <TITLE> <$defaulttitle></TITLE>§
EndOfFirstSubDoc§
StartOfLastSubDoc§     <TITLE> <$defaulttitle></TITLE>§
EndOfLastSubDoc§

<P><A HREF="<$parentdoc>">Return to main 
page </A><A HREF="<$prevsubdoc>"><IMG 
SRC="art/back.gif" Border=0></A> <A 
HREF="<$nextsubdoc>"><IMG SRC="art/for-
ward.gif" Border=0></A></P>

<P><A HREF="<$parentdoc>">Return to main 
page </A><A HREF="<$prevsubdoc>"><IMG 
SRC="art/back.gif" Border=0></A></P>
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5 Click Early Scientists in the image map, scroll to the end of the Early Scientists page, and 

click Return to Main Page.

6 Now click the hypertext links on the main page, then use the back and forward buttons 

to move among the subdocuments.

7 When you’re finished testing the links, close the browser, then return to FrameMaker 

and save and close Web1.fm.

Moving on
You’ve completed this lesson. For in-depth information about converting FrameMaker 

documents to HTML, see Chapter 19, “HTML, XML, and PDF Conversion,” in the Adobe 

FrameMaker User Guide.

Review questions
For answers to these questions, see page 382.

1 How do you make FrameMaker automatically set up mappings to HTML elements?

2 What is the purpose of an HTML stylesheet? What are some of its limitations?

3 How can you change the default mappings that FrameMaker sets up?

4 What is an image map and how does it work?

5 Why would you want to split up a document into separate HTML files?

6 What kinds of advanced formatting can you do by editing the tables on the reference 

pages?

storage battery. When he touched the tips of the rods together a very bright white light was

produced. As he drew the rods apart, the arc light persisted until the tips had burnt away to

the critical gap which extinguished the light. As a researcher and lecturer at the Royal

Institution Davy worked closely with Michael Faraday (see  ) who first

joined the institution as his manservant and later became his secretary.       

Michael Faraday

Return to main page
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